Стандартные меню

T.C. Hollingsworth

Перевод на русский язык: Ольга Миронова
Рецензирование: Александр Яворский

Следующие меню имеются у многих приложений KDE. При этом у большинства приложений пунктов меню больше, чем описано здесь, в то время как у отдельных приложений некоторые из описанных пунктов отсутствуют.

Строка меню

Строка меню программы просмотра изображений Gwenview.

В некоторых приложениях, таких как диспетчер файлов Dolphin, строка меню по умолчанию не отображается. Её можно вызвать нажатием комбинации клавиш Ctrl+M. Тем же самым образом строку меню можно скрыть в тех приложениях, где такая функция поддерживается.

Меню «Файл»

Меню Файл позволяет выполнять действия с открытым в данный момент файлом и даёт доступ к стандартным задачам в приложениях.

Стандартные пункты меню:

Файл → Создать (Ctrl+N)

Создаёт новый файл.

Файл → Новое окно

Открывает новое окно.

Файл → Открыть... (Ctrl+O)

Открывает существующий файл.

Файл → Сохранить (Ctrl+S)

Сохраняет файл. Если файл уже существует, его содержимое будет заменено на новое.

Файл → Сохранить как...

Сохраняет файл под новым именем.

Файл → Сохранить все

Сохраняет все открытые файлы.

Файл → Обновить (F5)

Заново считывает текущий файл с диска.

Файл → Обновить все

Обновляет все открытые файлы.

Файл → Печать... (Ctrl+P)

Печатает файл. Для создания файла PDF необходимо выбрать вариант Печать в файл (PDF), а для печати только каких-то конкретных страниц в новый файл PDF следует задать диапазон печати.

Файл → Закрыть (Ctrl+W)

Закрывает текущий файл.

Файл → Закрыть все

Закрывает все открытые файлы.

Файл → Выход (Ctrl+Q)

Закрывает программу.

Меню «Правка»

Меню Правка позволяет редактировать текущий файл.

Правка → Отменить действие (Ctrl+Z)

Отменяет последнее выполненное действие.

Правка → Повторить (Ctrl+Shift+Z)

Повторяет последнее отменённое действие.

Правка → Вырезать (Ctrl+X)

Удаляет выбранный фрагмент файла, при наличии такового, и помещает его копию в буфер обмена.

Правка → Копировать (Ctrl+C)

Помещает копию выбранного фрагмента файла, при наличии такового, в буфер обмена.

Правка → Вставить (Ctrl+V)

Копирует первый фрагмент, при наличии такового, из буфера обмена в текущее местоположение в файле.

Правка → Выделить все (Ctrl+A)

Выделяет всё содержимое открытого в данный момент файла.

Правка → Найти... (Ctrl+F)

Позволяет производить поиск по тексту текущего файла.

Правка → Заменить... (Ctrl+R)

Позволяет производить поиск по тексту текущего файла и заменять его другим текстом.

Правка → Продолжить поиск (F3)

Переход к следующему совпадению в последней операции поиска.

Правка → Найти предыдущее (Shift+F3)

Переход к предыдущему совпадению в последней операции поиска.

Меню «Вид»

Меню Вид позволяет изменять представление текущего файла и/или работающего приложения.

Разные приложения имеют разные пункты меню.

Меню «Сервис»

Меню Сервис позволяет совершать определённые действия с текущим файлом.

Сервис → Автоматическая проверка орфографии (Ctrl+Shift+O)

Проверка орфографии текста по мере его набора. Более подробная информация приведена в разделе «Автоматическая проверка орфографии».

Сервис → Проверка орфографии...

Запускает программу проверки орфографии, предназначенную помогать пользователю замечать и исправлять орфографические ошибки. Более подробная информация приведена в разделе «Проверка орфографии».

Сервис → Проверка орфографии от курсора...

Запускает программу проверки орфографии, но проверяет только фрагмент документа, начинающийся от текущего положения курсора до конца документа. Более подробная информация приведена в разделе «Проверка орфографии».

Сервис → Проверка орфографии в выделенном фрагменте...

Запускает программу проверки орфографии, но проверяет только выделенный фрагмент текста. Более подробная информация приведена в разделе «Проверка орфографии».

Сервис → Выбрать словарь...

Позволяет выбрать словарь, используемый для проверки орфографии. Более подробная информация приведена в разделе «Настройка Sonnet».

Меню «Настройка»

Меню Настройка позволяет изменять параметры приложения в соответствии с предпочтениями пользователя.

Данное меню обычно имеет следующие пункты:

Настройка → Показать меню (Ctrl+M)

Включает и выключает показ строки меню. Для отображения скрытой строки меню следует нажать комбинацию клавиш Ctrl+M. Если строка меню скрыта, контекстное меню, открываемое по щелчку правой кнопкой мыши по любому месту области просмотра, имеет дополнительный пункт Показать меню.

Настройка → Показать строку состояния

Включает и выключает показ строки состояния. В некоторых приложениях KDE строка состояния располагается в нижней части окна и используется для отображения полезной информации.

Настройка → Видимые панели инструментов

Позволяет скрывать и отображать различные панели инструментов, поддерживаемые приложением.

Настройка → Показать строку состояния

При установленном флажке в нижней части приложения отображается небольшая строка, в которой содержится информация об этом приложении. Если флажок снят, то строка состояния скрыта.

Настройка → Комбинации клавиш...

Позволяет включать, отключать и изменять комбинации клавиш. Более подробная информация приведена в разделе «Использование и настройка комбинаций клавиш».

Настройка → Панели инструментов...

Позволяет изменять содержимое, вид, текст и значки панелей инструментов. Более подробная информация приведена в разделе «Настройка панелей инструментов».

Настройка → Настроить уведомления...

Этот пункт показывает стандартный диалог настройки уведомлений KDE, в котором можно настроить параметры уведомлений, используемых в приложении (звуковые сигналы, видимые сообщения и т.д.).

Более подробную информацию о настройке уведомлений можно получить в документации к модулю «Уведомления» программы Параметры системы.

Настройка → Настроить приложение...

Открывает диалоговое окно настройки текущего приложения.

Меню «Справка»

Меню Справка предоставляет доступ к руководству пользователя приложения и другой справочной информации.

Справка → Руководство пользователя приложения (F1)

Вызывает центр справки KDE, открывая его на странице руководства пользователя текущего приложения.

Справка → Что это? (Shift+F1)

Курсор мыши меняется на сочетание стрелки и вопросительного знака. Щелчок по элементам интерфейса приложения откроет окно справки с описанием функций этого элемента (если для этого элемента существует такое описание).

Справка → Совет дня

Данная команда открывает диалоговое окно Совет дня. Можно пролистать все советы, используя кнопки диалога, и настроить показ советов при запуске.

Примечание: функция вывода советов имеется не в каждом приложении.

Справка → Сообщить об ошибке…

Открывает диалог «Отправить отчёт об ошибке», в котором можно сообщить об ошибке в программе или оставить пожелания.

Справка → Сделать пожертвование

Открывает веб-страницу Donations, где можно оказать финансовую поддержку KDE и его проектам.

Справка → Сменить язык интерфейса приложения…

Открывает диалог, в котором можно менять Основной язык и Резервный язык для приложения.

Справка → О программе приложение

Показывает информацию о версии приложения и его авторе.

Справка → О KDE

Показывает информацию о версии платформы разработки KDE, а также другие базовые сведения.

Благодарности

Отдельное спасибо анонимному участнику «Google Code-In 2011» за большой вклад в написание данной документации.