Das Menü Datei

DateiÖffnen... (Strg+O)

Ein Ordner wird geöffnet, und alle Dateien, welche den gewählten Dateinamenfilter erfüllen, werden im Dateilistenfeld angezeigt. Die gewählte Datei wird selektiert.

DateiZuletzt geöffnete Dateien

Ein kürzlich geöffneter Ordner wird geöffnet.

DateiOrdner öffnen ... (Strg+D)

Ein Ordner wird geöffnet, und alle Dateien, welche den gewählten Dateinamenfilter erfüllen, werden im Dateilistenfeld angezeigt.

DateiNeu laden (F5)

Ordner neu einlesen. Veränderte Dateien müssen vorher gespeichert werden. Ausgeklappte Unterordner werden eingeklappt.

DateiSpeichern (Strg+S)

Speichert alle veränderten Dateien im Ordner. Die veränderten Dateien sind durch ein Diskettensymbol gekennzeichnet. Wenn Dateinamen verändert wurden, so werden die entsprechenden Dateien umbenannt.

DateiZuletzt gespeicherte Fassung

Macht die Änderungen an einer oder mehreren Dateien rückgängig. Wenn keine Dateien im Dateilistenfeld selektiert sind, so werden die Änderungen an allen Dateien rückgängig gemacht, ansonsten nur an den ausgewählten Dateien.

DateiImportieren...

Der Import Dialog wird verwendet, um Daten direkt von einem freedb.org Server, von einem MusicBrainz Server, von Discogs, Amazon oder anderen Quellen mit Albumtitellisten zu importieren.

Zum Importieren von einem freedb.org-Server wird Von Server: gnudb.org gewählt. Der zu suchende Interpret und der Name des Albums können in den zwei oberen Feldern eingegeben werden, und die gefundenen Alben werden nach Klick auf Suchen dargestellt, sobald sie von www.gnudb.org empfangen werden. Die Stückdaten eines Albums werden nach Auswahl geladen, der verwendete freedb.org-Server kann gewählt werden, ebenso der CGI Pfad. Die importierten Daten werden in der Vorschau des Import-Dialogfensters dargestellt. Wenn man mit den Daten in der Vorschau zufrieden ist, können sie mit OK importiert werden.

Zum Importieren vom Discogs Server wird Discogs gewählt. Wie bei gnudb.org können auch hier Interpret und Album eingegeben werden und es wird ebenfalls eine Liste mit Alben zur Auswahl gestellt. Ein Token kann eingegeben werden, um das RESTful Discogs API zu verwenden statt der Web-Schnittstelle, welche oft geändert wird und dann funktioniert der Import-Parser nicht mehr. Dazu muss man sich bei Discogs registrieren und dann dort ein Token generieren (Settings/Developers, Generate new token). Man sollte nicht vergessen, das Token mit Einstellungen speichern zu sichern, damit es auch für künftige Anfragen verwendet wird. Wenn Standard-Tags markiert ist, werden grundlegende Informationen importiert, so z.B. Interpret, Album und Titel. Wenn Zusätzliche Tags markiert ist, werden mehr verfügbare Informationen importiert, z.B. Musiker, Arrangierer oder der Herausgeber. Wenn Cover-Bilder markiert ist, werden Cover-Bilder heruntergeladen, falls vorhanden.

Zum Importieren von Amazon wird Amazon gewählt. Wie bei Von gnudb.org können auch hier Interpret und Album eingegeben werden und es wird ebenfalls eine Liste mit Alben zur Auswahl gestellt. Wenn Zusätzliche Tags markiert ist, werden mehr verfügbare Informationen importiert, z.B. Musiker, Arrangierer oder der Herausgeber. Wenn Cover-Bilder markiert ist, werden Cover-Bilder heruntergeladen, falls vorhanden.

In der gleichen Art kann mit Von MusicBrainz Album auch in der Album-Datenbank von MusicBrainz gesucht werden. Die Bedienung ist wie bei gnudb.org beschrieben.

Zum Importieren von einem MusicBrainz Server dient der Dialog, der nach Klicken auf Von MusicBrainz Fingerprint erscheint. Wie bei freedb kann auch hier der Server ausgewählt werden. Unten ist eine Tabelle, welche die importierten Stückdaten darstellt. Die rechte Spalte zeigt dabei den Zustand der MusicBrainz-Abfrage, welche gleich mit dem Öffnen des Dialogs mit "Suche läuft" beginnt. Es folgen dann ein Abfrage des Fingerprints und, falls diese kein Ergebnis liefert, eine Suche anhand der in der Datei vorhandenen Tags. Für eine erfolgreiche MusicBrainz-Suche kann es daher hilfreich sein, vorhandene Informationen (z.B. Interpret und Album) vorangehend in den Tags zu speichern. Wenn ein Resultat gefunden wurde, so endet die Suche im Zustand "Erkannt", andernfalls wurde nichts gefunden oder gleich mehrere mögliche Resultate, von denen der Benutzer eines auswählen kann. OK und Anwenden übernehmen die importierten Daten, Abbrechen schließt den Dialog. Das Schließen des Dialogs kann eine Weile dauern, da noch die ganze MusicBrainz-Maschinerie runtergefahren werden muss.

Zum Importieren von Albumdaten in Textform öffnet man einen Unterdialog mit Von Datei/Zwischenablage. Dort stehen mehrere vorkonfigurierte Formate zur Verfügung. Die ersten zwei, "CSV unquoted" und "CSV quoted", dienen dazu, Daten welche über die Export Funktion exportiert wurden, wieder zu importieren. Diese Daten können natürlich von einer Tabellenkalkulation bearbeitet werden. CSV-Daten aus einer Tabellenkalkulation müssen mit Tabulator als Trennzeichen geschrieben werden und sollten sich über "CSV quoted" einlesen lassen. Dieses ist flexibler als "CSV unquoted", dafür dürfen die enthaltenen Felder keine Anführungszeichen enthalten. Falls nur von Kid3 exportiert und wieder importiert wird, so sollte dies problemlos mit "CSV unquoted" möglich sein. Im Kontextmenü der Dateiliste hat es darüber hinaus die Funktionen "Export CSV" und "Import CSV", welche Skripts benutzen, um CSV-Daten vollständiger und flexibler auszutauschen.

Das nächste Format, "freedb HTML text", kann benutzt werden, um Informationen aus einer HTML-Seite von freedb.org zu kopieren. Dazu sucht man sich in freedb das Album, und wenn die gewünschte Information im Browser angezeigt wird, kann sie selektiert und in die Zwischenablage kopiert werden. Nach einem Klick auf Von Zwischenablage werden die importierten Daten in der Tabelle angezeigt und können mit OK übernommen werden. Das Ziel (Tag 1, Tag 2 oder Tag 1 und Tag 2) kann mit einem Auswahlfeld festgelegt werden. Die Titel in der Dateiliste sollten in der korrekten Reihenfolge angezeigt sein um die richtigen Tags zu kriegen. Dies ist kein Problem, wenn sie nummeriert sind.

Das nächste vorkonfigurierte Format, "freedb HTML source", kann dann benutzt werden, wenn die Import-Daten als HTML-Dokument vorliegen. Solch eine Datei kann im Datei Dialog, welcher nach Klick auf Von Datei erscheint, ausgewählt werden. Natürlich können die Daten auch in einem Editor kopiert und dann über die Zwischenablage übernommen werden. Dieses Format kann für Offline Import nützlich sein, obschon die HTML-Datei auch von einem Browser angezeigt und im ersten Format über die Zwischenablage importiert werden kann.

Weitere vorkonfigurierte Formate, z.B. "Track Title Time" stehen zur Verfügung. Mit Klick auf Hinzufügen kann ein leeres benutzerdefiniertes Format erzeugt und vom Benutzer gesetzt werden. Die zwei Zeilen unterhalb des Formatnamens können hierzu mit regulären Ausdrücken gefüllt werden. Der erste Ausdruck wird einmal angewendet, um albumspezifische Daten wie Interpret, Album, Jahr und Genre zu extrahieren. Die zweite Zeile wird vom Dokumentanfang bis zum Schluss für jeden Titel probiert, um Titeldaten zu kriegen, also Nummer und Titel. In den regulären Ausdrücken können alle von Qt unterstützten Funktionen eingesetzt werden; also das meiste von dem, was Perl bietet. Klammerkonstrukte "(..)" werden benützt, um Felddaten zu extrahieren und werden von einem Kid3-spezifischen Feldcode eingeleitet. Die Codes sind dieselben wie beim Dateinamenformat, auch hier sind nebst den unten aufgelisteten Codes beliebige Framenamen möglich:

  • %s %{title} Titel (Song)

  • %a %{artist} Interpret (Artist)

  • %l %{album} Album

  • %c %{comment} Kommentar (Comment)

  • %y %{year} Jahr (Year)

  • %t %{track} Nummer (Stück)

  • %g %{genre} Genre

  • %d %{duration} Länge (Dauer)

Beispiel: Ein regulärer Ausdruck für die zweite Zeile, um Titel aus einer .m3u Stückliste zu holen, könnte "%{track}(\d+)\s+%{title}(\S[^\r\n]*)\.mp3[\r\n]" sein. Alle Formate können geändert werden, indem der Name und die regulären Ausdrücke editiert werden und Einstellungen speichern gedrückt wird. Gespeichert werden sie in der Datei kid3rc im Konfigurationsordner. Diese Datei kann auch direkt verändert werden, um mehr Importformate zu haben, oder man kann sie löschen, um wieder zu den Standardeinstellungen zu kommen. Formate können mit Entfernen gelöscht werden.

Genauigkeit zeigt eine Abschätzung, wie gut die importierten Daten zu den Stücken passen. Dazu werden die Längen oder die Dateinamen verglichen um den Grad an Übereinstimmung in Prozent zu errechnen. Cover-Bild zeigt die URL des Cover-Bildes, welches heruntergeladen wird.

Um zu prüfen, ob die importierten Stücke den vorhandenen Dateien entsprechen, können die Längen verglichen werden. Diese Option kann mit dem Markierungsfeld Teste maximal erlaubten Zeitunterschied eingeschaltet werden und der maximal erlaubten Zeitunterschied kann in Sekunden eingestellt werden. Wird eine Überschreitung dieser Toleranzschwelle festgestellt, so wird die entsprechende Länge in der Vorschau rot dargestellt.

Falls nun die vorhandenen Dateien in einer anderen Reihenfolge als die importierten Stücke vorliegen, so sollte die Zuordnung korrigiert werden. Diese Arbeit wird durch die Zuordnen mit Knöpfe Länge, Nummer und Titel erleichtert, welche die Stücke dem jeweiligen Feld entsprechend zuordnen. Sollte die Zuordnung noch manuell korrigiert werden müssen, so kann ein Track nach Drücken der Steuerungs-Taste (Strg/Strg) mit der linken Maustaste gefasst und dann an die gewünschte Stelle gezogen werden.

Wenn der Import Dialog geöffnet wird, enthält die Tabelle die aktuell vorhandenen Werte der Tags. Der Tag Typ (Tag 1, Tag 2, Tag 1 und Tag 2) kann über das Ziel Auswahlfeld selektiert werden. Der Knopf rechts von diesem Auswahlfeld dient dazu, die Tabelle auf die in den Tags gespeicherten Werte zurückzusetzen. Über die Markierungsfelder in der ersten Tabellenspalte können die Stücke gewählt werden, deren Tags importiert werden sollen. Dies kann z.B. dann nützlich sein, wenn ein Ordner alle Stücke eines Doppelalbums enthält, aber bloß die Stücke der zweiten CD importiert werden sollen.

Um die Dateien, welche importiert werden, zu identifizieren, können die Dateinamen oder die vollständigen Pfade in der Tabelle dargestellt werden. Diese Einstellung ist über das Kontextmenü, welches bei Rechtsklick auf die Kopfzeile erscheint, möglich. Die Werte in der Import-Tabelle lassen sich editieren. Die momentan in den Tags vorhandenen Werte lassen sich mit dem Rückgängig-Knopf rechts vom Ziel-Listenfeld wiederherstellen. Dies ist auch dann nützlich, wenn man das Ziel verändert hat und die dort vorhandenen Werte in der Tabelle sehen möchte.

Wie in fast allen Dialogen dient der Einstellungen speichern Knopf dazu, die dialogspezifischen Optionen und die Fenstergröße persistent zu speichern.

Von Tags führt zu einem Unterdialog, mit welchem sich Tag Frames mit dem Inhalt aus anderen Tag Frames füllen lassen. Dies kann dazu benutzt werden, um einfach Informationen zwischen Tags zu kopieren oder einen Teil des Inhaltes eines Tag Frames zu extrahieren und in einem anderen Tag Frame einzufügen.

Wie beim Import von Datei/Zwischenablage stehen frei konfigurierbare Formate zur Verfügung, um verschiedene Operationen durchzuführen. Vorkonfigurierte Formate erlauben es beispielsweise, den Wert des Interpreten zum Album Interpreten, Komponisten oder Leiter zu kopieren, bei Titeln, welche die Stücknummer enthalten, diese zu extrahieren und im Stücknummer-Frame zu speichern. Ebenso lässt sich ein Untertitel aus dem Titel extrahieren.

Das Erstellen eines eigenen Importformates wird im folgenden anhand eines Beispieles erklärt. Die Information im Untertitel soll auch im Kommentar gesetzt werden. Dazu wird ein neues Format mit Hinzufügen erstellt und ein neuer Name gesetzt, in diesem Beispiel also "Subtitle to Comment". Nun gibt man unter Quelle "%{subtitle}" und unter Extraktion "%{comment}(.*)" ein und klickt Einstellungen speichern.

Der Ausdruck in Quelle kann aus Format Codes für beliebige Tag Frames bestehen, wobei natürlich auch mehrere Codes verwendet werden können, um den Inhalt verschiedener Frames zu kombinieren. Für jedes Stück wird aus den Tags und dem Quelle Format ein Text erzeugt, und auf diesen wird dann der reguläre Ausdruck aus Ermittlung angewendet, um neue Tag Werte zu setzen. Dieser reguläre Ausdruck enthält Klammerkonstrukte "(..)", um Felddaten zu extrahieren, und die Klammer-Konstrukte werden vom Format Code des Tag Frames eingeleitet. Es funktioniert also gleich wie bei den Formaten zum Import von Datei/Zwischenablage .

Import von Tags... ist auch direkt im Menü Datei verfügbar. Der Unterschied zwischen diesen zwei Funktionen ist, dass der Unterdialog des Import-Dialogs auf allen Dateien des aktuellen Ordners arbeitet, während die Menü-Funktion auf die selektierten Dateien angewendet wird (welche in verschiedenen Ordnern liegen können). Die Menü-Funktion verfügt über einen zusätzlichen Format Code "%{__return}" um den extrahierten Wert zurückzugeben, was im CLI und bei der QML-Schnittstelle nützlich sein kann.

DateiImportieren von gnudb.org...

Importieren von einem freedb.org Server mit Album-Suche auf gnudb.org. Dieser Menüpunkt öffnet denselben Import Dialog wie Importieren..., öffnet jedoch direkt auch den gnudb.org Dialog.

DateiImportieren von Discogs...

Importieren vom Discogs Server. Dieser Menüpunkt öffnet denselben Import Dialog wie Importieren..., öffnet jedoch direkt auch den Discogs Dialog.

DateiImportieren von Amazon...

Importieren von Amazon. Dieser Menüpunkt öffnet denselben Import Dialog wie Importieren..., öffnet jedoch direkt auch den Amazon Dialog.

DateiImportieren von MusicBrainz Album...

Importieren von der MusicBrainz Album Datenbank. Dieser Menüpunkt öffnet denselben Import Dialog wie Importieren..., öffnet jedoch direkt auch den Von MusicBrainz Album Dialog.

DateiImportieren von MusicBrainz Fingerprint...

Importieren von einem MusicBrainz Server. Dieser Menüpunkt öffnet denselben Import Dialog wie Importieren..., öffnet jedoch direkt auch den Von MusicBrainz Fingerprint Dialog.

DateiImportieren von Tags...

Wie Import von Tags, jedoch wird der Import auf die selektierten Dateien angewendet.

DateiAutomatisch importieren...

Automatisch importieren lassen sich Informationen für mehrere Alben von verschiedenen Web-Diensten. Wenn Ordner in der Dateiliste selektiert sind, so werden Metadaten für die Stücke der gewählten Ordner importiert. Wenn kein Ordner ausgewählt ist, so werden Informationen für alle Ordner innerhalb der Dateiliste importiert.

Der Tag Typ (Tag 1, Tag 2, Tag 1 und Tag 2) kann über das Ziel Auswahlfeld selektiert werden.

Profile bestimmen, von welchen Servern die Album-Informationen geholt werden. Einige Profile sind bereits vordefiniert (All, MusicBrainz, Discogs, Cover Art), eigene Profile können mit dem Hinzufügen Knopf rechts von der Profil Auswahlliste erstellt werden.

Die Tabelle darunter zeigt die Server, welche benutzt werden, wenn mit dem ausgewählten Profil importiert wird. Der Import-Prozess für ein Album wird beendet, wenn alle geforderten Informationen gefunden wurden, daher ist die Reihenfolge der Server in der Tabelle wichtig. Sie kann mit den Nach oben und Nach unten Knöpfen verändert werden. Mit Bearbeiten kann ein bestehender Eintrag verändert werden. Die Server Auswahl stellt dieselben Server zur Verfügung wie die Import-Funktionen. Standard Tags, Zusätzliche Tags und Cover-Bilder bestimmen die Informationen, welche vom Server geholt werden sollen. Die Genauigkeit schließlich bestimmt die minimale Übereinstimmung, welche erreicht werden muss, damit die importierten Daten akzeptiert werden. Ist sie ungenügend, so wird ein Import mit dem nächsten Server versucht. Dieser Dialog mit den Server-Eigenschaften wird auch angezeigt wenn Hinzufügen gewählt wird, um einen neuen Eintrag zu erstellen. Bestehende Zeilen können mit Entfernen gelöscht werden.

Um einen automatischen Import mit dem ausgewählten Profil zu beginnen wird Starten gedrückt. Details über den laufenden Prozess werden im Dialog oben angezeigt. Abbrechen führt zu einer vorzeitigen Beendigung des Imports.

DateiNach Cover-Bildern suchen...

Der Dialog Nach Cover-Bildern suchen hilft bei der Suche nach Album Cover-Bildern. Interpret/Album werden wenn möglich aus den Tags übernommen. Quelle stellt eine Vielzahl von Webseiten mit Cover-Bildern zur Verfügung. Unter dem Namen ist die URL mit Interpret und Album als Parametern angegeben. Für URL-codierte Werte können dabei %u{artist} und %u{album} angegeben werden oder auch andere Werte aus den Tags, wie in Kid3 einrichten bei Benutzerbefehle beschrieben. Nach "Custom Source" können auch eigene Quellen hinzugefügt werden. Dazu wird "Custom Source" durch den Namen der Quelle ersetzt, dann Return gedrückt, die URL eingegeben und mit Einstellungen speichern gesichert. Das resultierende Browser-Kommando wird oben im Dialog dargestellt und nach Drücken des Browser-Knopfes ausgeführt. Der Browser, welcher in den Einstellungen konfiguriert werden kann, wird mit der gewählten Quelle gestartet. Das gewünschte Cover-Bild kann dann aus dem Browser in das Kid3 Fenster gezogen werden und wird im Bild-Feld von Tag 2 der selektierten Dateien gesetzt.

Da nicht alle Browser Drag'n'Drop von Bildern unterstützen und häufig die Bilder auf Webseiten mit einer URL unterlegt sind, erhält Kid3 in solchen Fällen bloß die entsprechende URL und nicht das Bild. Wenn die URL auf ein Bild zeigt, wird dieses heruntergeladen. Falls die URL jedoch auf sonst eine Webseite hinweist, so muss von dieser auf das gewünschte Cover-Bild geschlossen werden. Dies ist die Aufgabe der Tabelle URL-Ersetzung. Die linke Spalte Vergleich enthält einen regulären Ausdruck, welcher mit der URL verglichen wird. Wenn eine Übereinstimmung festgestellt wird, so werden die erhaltenen Klammer-Werte im Muster der Spalte URL des Bildes ersetzt (\1 usw.). Der ersetzte reguläre Ausdrucks enthält dann die URL des Bildes. Auf diese Weise können auch Bilder von Amazon, Google Images, usw. per Drag'n'Drop importiert werden. Natürlich können auch hier eigene Ersetzungen erfasst werden.

DateiExportieren...

Der Export Dialog wird verwendet, um die Daten aus den Tags in einer Datei oder der Zwischenablage zu speichern. Das oberste Editierfeld stellt einen einfachen Editor zur Verfügung, welcher eine Vorschau der zu exportierenden Daten bietet. Falls die Export-Daten Tabulatorzeichen enthalten, wird der Export in einer Tabelle dargestellt. Die Daten werden aus den Tags der Dateien im aktuellen Ordner generiert, und zwar gemäß dem unten eingestellten Format.

Diese Formateinstellung ist gleich aufgebaut wie im Import Dialog: Im obersten Feld ist der Titel (z.B. "CSV unquoted"), dann folgt der Header - dieser wird nur am Anfang der Datei generiert. Nun folgt das Stück-Format, es wird für jedes Stück angewendet. Schließlich gibt es noch einen Trailer, welcher die Datei noch abschließt.

Die Formatfelder enthalten keine regulären Ausdrücke wie im Import Dialog, sondern bloß Ausgabeformate, bei denen spezielle %-Ausdrücke durch Werte aus den Tags ersetzt werden. Das ganze verhält sich also gleich wie beim Dateinamenformat, es werden auch dieselben Codes verwendet, plus ein paar zusätzliche. Nicht nur die unten aufgelisteten Codes sind möglich, es können die Namen aller Tag Frames verwendet werden.

  • %s %{title} Titel (Song)

  • %a %{artist} Interpret (Artist)

  • %l %{album} Album

  • %c %{comment} Kommentar (Comment)

  • %y %{year} Jahr (Year)

  • %t %{track} Nummer (Stück, z.B. 01)

  • %t %{track.n} Nummer mit Feldlänge n (z.B. 001 für %{track.3})

  • %T %{tracknumber} Nummer (Stück, ohne führende Null, z.B. 1)

  • %g %{genre} Genre

  • %f %{file} Dateiname (File name)

  • %p %{filepath} Pfadname

  • %{modificationdate} Änderungsdatum

  • %{creationdate} Erstellungsdatum

  • %u %{url} URL

  • %{dirname} Ordnername

  • %d %{duration} Dauer in Minuten:Sekunden

  • %D %{seconds} Dauer in Sekunden

  • %n %{tracks} Anzahl Stücke im Album

  • %e %{extension} Dateiendung

  • %O %{tag1} Das Format von Tag 1 (ID3v1.1 oder leer falls nicht vorhanden)

  • %o %{tag2} Das Format von Tag 2 (ID3v2.3.0, ID3v2.4.0, ID3v2.2.0, ID3v2.2.1, Vorbis, APE, MP4, ASF oder leer falls nicht vorhanden)

  • %b %{bitrate} Bitrate in kbit/s

  • %v %{vbr} VBR oder leer (nur für ID3v2.3 mit id3lib)

  • %r %{samplerate} Samplerate in Hz

  • %m %{mode} Kanalmodus (Stereo oder Joint Stereo)

  • %h %{channels} Anzahl Kanäle (1 oder 2)

  • %k %{codec} Codec (z.B. MPEG 1 Layer 3, MP4, Ogg Vorbis, FLAC, MPC, APE, ASF, AIFF, WAV)

Mit diesen Formatcodes sind bereits einige Formate vordefiniert. "CSV unquoted" trennt die einzelnen Felder durch Tabulatoren. Daten in diesem Format können einfach wieder über das gleichnamige Importformat in Kid3 importiert werden. "CSV quoted" setzt die Felder zusätzlich noch in Anführungszeichen, was den Import in Tabellenkalkulationen erleichtert. Dafür sollten in den Feldern keine Anführungszeichen vorkommen. "Extended M3U" und "Extended PLS" erzeugen Stücklisten mit Zusatzinformationen und absoluten Pfadnamen. "HTML" dient dazu, eine HTML-Seite mit verlinkten Stücken zu erstellen. "Kover XML" generiert eine XML-Datei, welche vom Cover-Druck-Programm Kover gelesen werden kann. "Technical Details" liefert Informationen über Bitrate, Samplerate, Kanäle, usw. "Custom Format" schließlich ist frei für ein eigenes Format. Natürlich können auch die anderen Formate beliebig angepasst werden, oder es können noch mehr Formate in der Datei kid3rc im Konfigurationsordner hinzugefügt werden.

Die Quelle der Daten (Tag 1 oder Tag 2) kann mit einem Auswahlfeld festgelegt werden. Ein Klick auf In Datei bzw. In Zwischenablage speichert die Daten in einer Datei oder der Zwischenablage. OK und Abbrechen beenden den Dialog, wobei OK die aktuellen Einstellungen übernimmt.

DateiStückliste erstellen...

Erzeugt eine Stückliste. Das Format und der Inhalt der Stückliste können mit verschiedenen Optionen bestimmt werden.

Wie Ordnername generiert den Dateinamen der Wiedergabeliste aus dem Namen des Ordners. Es kann aber auch ein Format mit Werten aus den Tags benutzt werden, z.B. "%{artist} - %{album}", um die Namen von Interpret und Album im Dateinamen zu haben. Es können dieselben Format Codes wie bei Exportieren verwendet werden. Erstelle neue leere Stückliste erzeugt eine leere Stückliste mit dem angegebenen Namen. Die Dateierweiterung richtet sich nach dem Format der Stückliste.

Wo die Wiedergabeliste erstellt wird, kann bestimmt werden mit der Auswahlliste Erstelle in

Aktueller Ordner

Die Stückliste wird im aktuellen Ordner erstellt und enthält nur Dateien aus diesem Ordner. Der aktuelle Ordner ist der Ordner, in welchem sich die aktuelle Datei befindet. Wenn mehrere Dateien ausgewählt sind, ist wahrscheinlich die zuletzt ausgewählte Datei die aktuelle Datei.

Jedem Ordner

In jedem Ordner, welcher gelistete Dateien enthält, wird eine eigene Stückliste erstellt, welche die Dateien aus dem jeweiligen Ordner enthält.

Basisordner

Nur eine einzige Stückliste wird im Basisordner (d.h. dem Ordner der Dateiliste) erstellt, und sie enthält die gelisteten Dateien aus dem Basisordner und allen Unterordnern.

Das Format der Wiedergabeliste kann M3U, PLS oder XSPF sein.

Nur ausgewählte Dateien einfügen führt dazu, dass nur ausgewählte Dateien in der Stückliste erscheinen. Wenn ein Ordner ausgewählt ist, so gelten all seine Dateien ebenfalls als selektiert. Wenn diese Option nicht aktiviert ist, gelangen alle Audio-Dateien in die Stückliste.

Sortiere nach Dateiname ordnet die Dateien wie üblich nach dem Dateinamen in der Wiedergabeliste an. Mit Sortiere nach Tag-Feld ist es möglich, eine Format-Zeichenfolge mit Tag-Werten für die Sortierung zu verwenden. "%{track.3}" kann beispielsweise benutzt werden, um nach der Stücknummer zu sortieren (".3" wird verwendet, um 3 Stellen mit führenden Nullen zu kriegen, und somit korrekt nach der Nummer zu sortieren). Es ist auch möglich, mehrere Codes zu verwenden, z.B. "%{genre}%{year}", um nach einer Zeichenfolge aus Genre und Jahr zu sortieren.

Die Einträge in der Stückliste sind relative oder absolute Pfadangaben, je nachdem ob Benutze relativen Pfad für Dateien in der Wiedergabeliste oder Benutze vollen Pfad für Dateien in der Wiedergabeliste gesetzt ist.

Nur Liste der Dateien schreiben führt dazu, dass die Stückliste nur die Pfade zu den Dateien enthält. Wünscht man zusätzliche Informationen, so steht Schreibe Informationen mit einer Format-Zeichenfolge zur Verfügung, und es wird eine erweiterte Stückliste generiert.

DateiBeenden (Strg+Q)

Beendet die Anwendung.