Окно редактора KMail

Меню «Письмо»

Меню «Письмо»

Меню «Письмо»

 

Письмо → Новое окно редактора (Ctrl+N)

Открывает новое окно редактора, позволяя создать письмо.

Письмо → Отправить письмо (Ctrl+Return)

Сразу же отправляет письмо. Если для отправки используется сервер SMTP, и он недоступен, письмо окажется в папке «Исходящие», и появится сообщение об ошибке. После устранения проблем можно отправить письмо из этой папки с помощью пункта меню Файл → Отправить из очереди (в окне чтения).

Письмо → Отправить через >

Позволяет указать, какой сервер исходящей почты следует использовать для отправки письма.

Письмо → Отправить позже

Запускает диалог для отправки письма в запланированное время. Более подробная информация содержится в документации агента «Отправить позже».

Письмо → Отправить позже через >

Позволяет указать, какой сервер исходящей почты следует использовать для отправки отложенного письма.

Письмо → Сохранить как файл

Сохраняет письмо как файл. Поддерживаются следующие форматы: текст с форматированием (.html), простой текст (.txt) и формат Open Document (.odt).

Письмо → Сохранить как черновик (Ctrl+S)

Сохраняет письмо в папке Черновики, позволяя закончить его позже.

Письмо → Сохранить как шаблон

Позволяет сохранить письмо как шаблон. Более подробная информация содержится в разделе «Создание писем из шаблонов».

Письмо → Вставить текстовый файл…

Вставляет текстовый файл в текст письма начиная с позиции курсора.

Письмо → Последние вставленные файлы >

Позволяет выбрать файл из списка недавно вставленных текстовых файлов и вставить его в текущее письмо. Чтобы очистить список, выберите пункт Очистить список.

Письмо → Предварительный просмотр

Открывает окно предварительного просмотра и показывает письмо, отформатированное для печати.

Письмо → Печать… (Ctrl+P)

Форматирует и печатает созданное письмо.

Письмо → Опубликовать текст письма… >

Позволяет сохранить копию письма в другом месте. Доступно четыре варианта: Nextcloud (свободное приложение для обмена файлами), Pastebin (свободно доступный веб-сайт), Bluetooth и электронная почта (открывает ещё одно окно редактора и прикладывает текущее письмо к новому в качестве вложения). Этот пункт доступен, только если включён модуль Публикация текста.

Письмо → Закрыть (Ctrl+W)

Закрывает окно редактора.

 

Меню «Правка»

Меню «Правка»

Меню «Правка»

 

Если описание какого-либо пункта меню отсутствует в этом руководстве, обратитесь к разделу «Меню „Правка“» Основ KDE. Описанные в этом руководстве пункты меню имеются только в KMail.

Правка → Вставить как цитату (Ctrl+Shift+O)

Вставляет текст из буфера обмена в формате цитаты (то есть в начале каждой строки вставляет символ «>» и пробел).

Правка → Вставить как вложение

Вставляет в виде вложения файл, который был скопирован в буфер обмена (например, при использовании диспетчера файлов Dolphin).

Правка → Вставить без форматирования (Ctrl+Shift+V)

Вставляет данные из буфера обмена в качестве простого текста без форматирования HTML.

Правка → Убрать пробелы

Этот параметр предположительно должен заменять несколько смежных символов новой строки или пробелов одиночными разрывами строк или пробелами, но он, по-видимому, не работает.

Правка → Добавить символы цитирования

Добавляет перед каждой строкой выделенного текста символы цитирования (по умолчанию это > и пробел). Если не было ничего выделено, символы добавляются перед каждой строкой письма.

Правка → Удалить символы цитирования

Удаляет крайние левые символы цитирования из выделенного текста.

Правка → Вставить адрес эл. почты…

Показывает список всех имён адресной книги, затем вставляет выбранный адрес электронной почты в положение курсора (после выбора нужного элемента и нажатия кнопки ОК). Эта функция доступна только если модуль Вставка адреса электронной почты включён.

Правка → Вставить неразрывный пробел (Ctrl+Пробел)

Вставляет неразрывный пробел в положение курсора. Эта функция доступна только если модуль Вставка неразрывных пробелов включён.

Правка → Вставить специальный символ…

Позволяет вставить специальный символ в положении курсора. Доступно большое количество символов в формате Unicode. Эта функция доступна только если включён модуль Вставка специальных символов.

Этот пункт меню был перемещён в меню Вставка в версии 5.17. Если после подключения модуля этот пункт меню не появляется при перезапуске KMail, проверьте меню Вставка.

Правка → Сменить регистр текста >

Позволяет изменить регистр выделенного текста. Доступны четыре варианта: Все прописные (все буквы становятся прописными), Все строчные (все буквы становятся строчными), Как в обычном тексте (заглавными буквами пишется первая буква выделенного элемента, а остальные — в нижнем регистре) и Инвертировать регистр побуквенно (преобразует буквы в верхнем регистре в нижний и наоборот). Эта функция доступна только если включён модуль Смена регистра. Соответствующий пункт меню будет выделен серым цветом и неактивен, пока не будет выбран текст для преобразования.

Правка → Масштаб… >

Позволяет увеличивать или уменьшать масштаб создаваемого письма. Это та же функция, что и пункт меню Вид → Масштаб > в окне просмотра письма. Эта функция доступна только если включён модуль Масштабирование текста.

Правка → Переменные >

Позволяет вставлять содержимое именованного поля в положение курсора. Можно выбрать одно из следующих полей: Кому >, Отправитель >, Копия >, Вложение >, Дата/Время > и Прочее > (с которым связан только один пункт вложенного меню — «Тема»). Есть одна примечательная особенность: дата и время, показываемые во вложенном меню, фиксируются на момент открытия окна редактора писем, но фактически вставленное значение основывается на системных часах.

 

Меню «Вид»

Меню «Вид»

Меню «Вид»

 

Это меню позволяет переключать показ полей заголовка и нескольких других элементов в окне редактора писем. Выбранные пункты будут отмечены в меню.

Доступны следующие варианты:

  • Все поля. Показывает все шесть представленных ниже полей.

  • Профиль. Если настроено несколько профилей, появится раскрывающийся список для выбора.

  • Словарь, используемый для проверки орфографии. Если установлено несколько словарей, появится раскрывающийся список для выбора.

  • Папка отправленной почты. Кнопка   , появляющаяся справа, открывает диалог выбора папки.

  • Метод отправки. Если настроено несколько учётных записей отправки, появится раскрывающийся список.

  • Отправитель. Содержимое может различаться в зависимости от используемого профиля.

  • Тема. Воспользуйтесь этим полем, чтобы кратко описать содержимое письма.

Раскрывающийся список Кому всегда расположен в верхней части окна редактора. В этом списке доступны следующие категории адресов: Копия, Скрытая копия и Обратный адрес. Более подробная информация о заголовках письма содержится в разделе «Заголовки редактора».

 

Вид → Моноширинный шрифт

Позволяет использовать моноширинный шрифт для показа текущего редактируемого письма. Используемый шрифт настраивается в разделе Внешний вид диалога настройки KMail.

Вид → Фразы

Показывает в правой части окна редактора столбец, позволяющий использовать и создавать фразы. Более подробная информация содержится в разделе «Фразы».

 

Меню «Параметры»

Меню «Параметры»

Меню «Параметры»

 

Это меню позволяет переключать различные параметры текущего письма. Выбранные пункты будут отмечены в меню.

Параметры → Срочное письмо

Устанавливает для письма приоритет «Срочно», добавляя две строки в заголовок: «X-PRIORITY: 2 (High)» и «Priority: urgent». Почтовый клиент получателя должен поддерживать такие заголовки, иначе они не дадут никакого эффекта. KMail не поддерживает приоритеты для входящих писем (несмотря на то, что их возможно отметить как «Важные»).

Параметры → Запросить уведомление об обработке

При выборе этого пункта KMail вставит в письмо строку заголовка Disposition-Notification-To:, которая запрашивает уведомление по электронной почте после того, как получатель загрузит и прочитает письмо. Эту функцию должен поддерживать и использовать почтовый клиент получателя, в противном случае она не будет работать.

Справочные сведения и несколько способов настроить уведомления о прочтении, которые сам KMail отправляет в ответ на полученную строку Disposition-Notification-To:, приведены в разделе Уведомления об обработке писем .

Параметры → Запросить подтверждение получения

При выборе этого пункта KMail вставит в письмо строку заголовка «Return-Receipt-To:», которая запрашивает уведомление по электронной почте после того, как письмо будет загружено почтовым сервером и доставлено получателю. Эта функция должна поддерживаться используемым сервером исходящей электронной почты, в противном случае она не будет работать.

Параметры → Подписать письмо

Подписывает письмо цифровой подписью с помощью OpenPGP или сертификата X.509. Более подробная информация об этой функции представлена в главе про OpenPGP.

Параметры → Зашифровать письмо

Шифрует письмо с помощью OpenPGP или сертификата X.509. Более подробная информация о шифровании содержится в главе про OpenPGP.

Параметры → Формат шифрования/подписи >

Позволяет выбрать формат шифрования или подписи писем. Более подробная информация содержится в разделе «Форматы шифрования писем».

Параметры → Редактирование с форматированием

Включает возможность редактирования текста с форматированием (то есть HTML).

Параметры → Кодировка >

Устанавливает кодировку текущего письма. Выбранная кодировка будет указана в заголовке отправляемого письма. Почти всегда можно использовать вариант Автоматически: KMail сообщит, если появится необходимость указать другую кодировку вручную.

Параметры → Перенос строк

Включает и выключает автоматический перенос строк. Его лучше отключить при вставке длинных строк, которые нельзя переносить (например, URL).

Параметры → Автоматическая проверка орфографии

Переключает автоматическую проверку орфографии.

Параметры → Создать напоминание об ответе…

Запускает диалог, позволяющий добавить в календарь задачу. Эта функция выделена серым цветом и неактивна, если модуль «Агент напоминания об ответе» отключён.

 

Меню «Вложение»

Меню «Вложение»

Меню «Вложение»

 

Это меню позволяет настроить параметры вложений.

Вложение → Добавить подпись

Добавляет в конец письма указанную пользователем подпись («нижний колонтитул»). Подробная информация о настройке подписи представлена в разделе «Настройка подписи профиля».

Вложение → Вставить подпись в начало

Добавляет подпись («заголовок») в начало письма.

Вложение → Вставить подпись в текущей позиции

Вставляет подпись в текущей позиции курсора.

Вложение → Вставить открытый ключ…

Открывает диалог Вложение открытого ключа OpenPGP. Более подробная информация содержится в разделе «Настройка профиля — Криптография — Ключ подписи OpenPGP».

Вложение → Вставить мой открытый ключ

Прикладывает к письму открытый ключ GnuPG или сертификат X.509 (то есть открытый ключ, присвоенный используемому профилю).

 

Вложение → Вложить > → Вложить файл…

Позволяет приложить к текущему письму один или несколько файлов. Вложения по умолчанию зашифрованы, если зашифровано письмо. Более подробная информация содержится в разделе «Форматы шифрования писем».

Вложение → Вложить > → Вложить папку…

Создаёт ZIP-архив, содержащий выбранную папку, и прикладывает его к текущему письму.

Вложение → Вложить > → Вложить мою электронную визитку

Позволяет приложить к текущему письму свою электронную визитку.

Вложение → Вложить > → Вложить электронные визитки…

Открывает диалог KAddressBook, который позволяет выбрать электронные визитки одного или нескольких (Ctrl и левая кнопка мыши) людей и приложить их к письму.

Вложение → Вложить > → Вложить текст из буфера обмена…

Если самый верхний элемент, хранящийся в буфере обмена, содержит не менее двух байт, откроется диалог ввода имени файла. KMail создаст вложение, содержащее текст из буфера обмена, и присвоит вложению указанное пользователем имя.

 

Вложение → Удалить вложение

Удаляет вложение, выбранное в области вложений под основной частью окна редактора.

Примечание

Этот и следующие два пункта меню будут выделены серым цветом и неактивны, пока не выбрано вложение.

Вложение → Сохранить вложение как…

Сохраняет выбранное вложение в файл.

Вложение → Свойства вложения

Показывает свойства выбранного вложения. Эта функция также позволяет подписать или зашифровать вложение и изменить некоторые свойства (имя, описание, тип MIME и так далее).

 

Меню «Сервис»

Меню «Сервис»

Меню «Сервис»

 

Если описание какого-либо пункта меню отсутствует в этом руководстве, обратитесь к разделу «Меню „Сервис“» Основ KDE. Описанные в этом руководстве пункты меню имеются только в KMail.

Сервис → Выбрать получателей…

Открывает диалог Выбор получателей, в котором можно выбрать получателей из всех адресных книг.

Сервис → Адресная книга

Открывает KAddressBook.

Сервис → Сохранить список распространения…

Открывает диалог, позволяющий сохранять группы контактов как один объект, имеющий собственное имя. Очень полезная функция, если приходится часто рассылать одно и то же письмо одним и тем же людям, например всем членам клуба.

Сервис → Автоматически исправить текст >

Выполняет автоматическую коррекцию. Предлагается два варианта: сканировать и автоматически исправлять выделенный текст или применить автокоррекцию для всего письма. Этот пункт меню появляется, только если загружен модуль Автокоррекция, и работает, только если функция автокоррекции включена на странице настройки редактора писем.

Сервис → Машинный перевод (Ctrl+Alt+T)

Открывает окно переводчика.

Сервис → Проверка грамматики (Language Tool)

Открывает окно проверки грамматики и проверяет письмо, подсвечивая найденные ошибки. Эта функция не обновляет проверенный текст по мере ввода, поэтому следует сначала написать письмо, а затем запустить проверку грамматики. Этот инструмент доступен только если включён модуль Проверка грамматики. Как и переводчик, проверка грамматики передаёт текст письма на сервер в Интернете (по умолчанию: https://languagetool.org/api/v2).

 

Меню «Настройка»

Меню «Настройка»

Меню «Настройка»

 

Если описание какого-либо пункта меню отсутствует в этом руководстве, обратитесь к разделу «Меню „Настройка“» Основ KDE. Описанные в этом руководстве пункты меню имеются только в KMail.

Настройка → Видимые панели инструментов >

Позволяет настроить показ панелей инструментов. Можно выбрать любое сочетание из следующих трёх вариантов: Основная панель инструментов (Отправить, В очередь, Текст с форматированием и так далее), панель инструментов для работы с HTML (Стиль, Шрифт / Размер и так далее) и «Направление текста» (если используется письменность с направлением справа налево). Обратите внимание, что панель HTML легко включается и отключается кнопкой Текст с форматированием на основной панели инструментов.

Настройка → Программа проверки орфографии…

Позволяет настроить проверку орфографии KDE Sonnet.

 

Меню «Справка»

Меню «Справка»

Меню «Справка»

 

Точно такое же, как «Меню „Справка“» из Основ KDE.