Окно редактора

Окно редактора

Окно редактора писем в режиме создания письма в формате HTML.

 

Окно редактора писем используется для написания новых писем, составления ответов и пересылки писем. Открыть это окно можно несколькими способами. Ниже описаны различные варианты создания писем.

Составление писем

Создать письмо…

Чтобы вызвать окно редактора писем, воспользуйтесь одним из следующих четырёх вариантов:

  • Файл → Создать → Создать письмо…

  • Письмо → Создать письмо…

  • Кнопкой Создать на главной панели инструментов.

  • Комбинацией клавиш Ctrl+N.

Чтобы написать письмо, заполните соответствующие поля в окне редактора. Чтобы выбрать, какие заголовки следует показывать, воспользуйтесь меню Вид. Сделанный выбор сохранится по умолчанию для новых окон редактора. Доступны следующие элементы:

  • Раскрывающийся список Профиль позволяет выбрать профиль для использования.

  • Раскрывающийся список Словарь позволяет выбрать словарь, используемый для проверки орфографии.

  • Папка отправленных позволяет указать, где будет сохранена локальная копия этого письма при его отправке.

  • Метод отправки позволяет выбирать сервер исходящей почты.

  • Стандартные поля «Отправитель:», «Кому:» и «Тема:» (поле «Адрес для ответа:» появится, только если был указан альтернативный Адрес для ответа на вкладке Дополнительно в диалоге Настройка → Настроить KMail… → Учётные записи → Профили).

  • Функция Моноширинный шрифт включает или выключает использование моноширинных шрифтов.

  • Пункт Фразы показывает окно фраз, в котором можно сохранять часто используемые фрагменты текста.

Существует множество средств, облегчающих выбор получателей. Кнопки Выбрать…, расположенные рядом с полями Кому:, Копия: и Скрытая копия: вызывают адресную книгу для выбора из неё адресов.

При начале ввода адреса в полях Кому:/Копия:/Скрытая копия: появляется список совпадающих адресов из списка недавно использованных и из адресной книги. Чтобы отключить автоматическое дополнение адресов, щёлкните по текстовому полю правой кнопкой мыши и в открывшемся контекстном меню выберите другое Автодополнение текста >. Это контекстное меню также позволяет настроить порядок, в котором появляются варианты для автодополнения (пункт Настроить автодополнение…).

При добавлении нескольких адресатов в какое-либо текстовое поле для разделения адресов используйте запятую. Возможно, потребуется указать полные адреса (то есть user@example.com) даже для локальных пользователей — это зависит от параметров системы.

Завершив написание письма, нажмите кнопку Отправить для немедленной отправки письма или кнопку В очередь для помещения письма в папку «Исходящие». Если письмо ещё не готово к отправке, выберите пункт меню Письмо → Сохранить как черновик для сохранения письма в качестве черновика. Чтобы напечатать письмо, воспользуйтесь пунктом меню Письмо → Предварительный просмотр для просмотра письма и пунктом меню Письмо → Печать… для непосредственной печати.

Письмо → Отправить позже позволяет отложить отправление писем на определённую дату и время. Более подробная информация содержится в разделе «Агент „Отправить позже“».

 

Файл → Создать → Новое письмо на основе шаблона → Мой шаблон

Создание нового письма из шаблона полезно, когда было создано удачное письмо, которое можно использовать в качестве шаблона для новых писем. Выберите Письмо → Сохранить как шаблон; это поместит новый шаблон в папку Шаблоны. Шаблоны возможно в любое время менять (для этого их следует выбрать в папке). Чтобы открыть шаблон в окне редактора, дважды щёлкните левой кнопкой мыши по названию шаблона (либо нажмите клавишу T). Можно также выбрать шаблон через меню Файл, как показано выше.

 

Подписывание и шифрование писем

Чтобы отправить зашифрованное письмо или письмо с цифровой подписью, нажмите на панели инструментов кнопку Подписать и/или Зашифровать. Чтобы выбрать формат шифрования письма, воспользуйтесь раскрывающимся списком Параметры → Формат шифрования/подписи > (меню Параметры также позволяет подписать или зашифровать письмо). Можно выбрать один из следующих пяти форматов:

Любой

KMail будет использовать формат, понимаемый всеми получателями письма. Предпочитаемый формат для каждого из них можно указать в KAddressBook.

Встроенный OpenPGP (устаревший)

Этот формат устарел, но он поддерживается для обратной совместимости. При использовании этого формата будет подписан или зашифрован только текст письма без вложений. Письма в формате HTML в этом формате подписывать нельзя. Этот формат следует использовать только при особой необходимости, например, при отправке писем тем людям, которые пользуются почтовыми клиентами, не поддерживающими более современные форматы.

OpenPGP/MIME

Этот формат — преемник устаревшего встраиваемого формата OpenPGP. При использовании этого формата подписываются и/или шифруются текст письма и все вложения (по крайней мере, по умолчанию). При использовании шифрования OpenPGP рекомендуется выбирать этот формат.

S/MIME

Этот формат — это альтернатива OpenPGP/MIME. При использовании этого формата подписываются и/или шифруются текст и все вложения письма (по крайней мере, по умолчанию). Этот формат используется чаще всего большими компаниями. Он основывается на сертификате x.509, а не на ключе PGP / GPG.

Непрозрачный S/MIME

Этот формат — это вариант формата S/MIME. Поскольку он объединяет письмо, вложения и цифровую подпись в один объект MIME, он требует больших ресурсов процессора и должен использоваться только при необходимости.

 

Создание писем в формате HTML

Обратите внимание, что письма в формате HTML многих раздражают, поэтому рекомендуется использовать такой формат разумно. В частности, не следует отправлять письма в формате HTML получателям в списках рассылки, если только письма в таком формате не разрешены в явном виде.

Для создания писем в формате HTML необходимо сначала включить инструменты разметки. Чтобы сделать это, включите функцию Редактирование с форматированием в меню Параметры или нажмите значок Текст с форматированием на панели инструментов KMail. Появится дополнительная панель инструментов с некоторыми инструментами форматирования. С помощью панели инструментов HTML можно выбрать стандартный текст или маркированные/нумерованные списки (используйте раскрывающийся список Нет на левом краю панели инструментов для управления стилем маркированных/нумерованных списков). Можно также настраивать тип шрифта, размер, стиль (полужирный, курсив, подчёркнутый или зачёркнутый) и цвет текста и фона. Можно указать выравнивание текста (по левому краю, по центру, по правому краю, по ширине) и вставить метки привязки (ссылки), горизонтальные линии, изображения, таблицы и произвольный HTML-код (хотя поддержка некоторых более продвинутых HTML-тегов всё ещё неполная).

 

Добавление вложений

Можно приложить к письму файлы, используя любой из перечисленных ниже методов:

  • Воспользуйтесь вложенным меню Вложение → Вложить > и появившимся диалогом, чтобы выбрать файл;

  • Нажмите кнопку Вложить и выберите файл, который следует вложить.

  • Перетащите файл с рабочего стола или из другой папки в окно редактора;

  • Перетащите письмо из списка писем KMail в окно редактора — это письмо будет вложено;

  • Выберите одну из дополнительных пунктов в меню Вложение или

  • Выберите Письмо → Вставить текстовый файл… или Письмо → Последние вставленные файлы >.

Вложенный файл появляется на панели вложений в нижней части окна редактора. Контекстное меню вложения (вызывается щелчком правой кнопкой мыши) позволяет выполнить с ним действия Просмотреть, Открыть, Редактировать, Обновить, Сохранить как… или Удалить (содержимое меню немного зависит от типа файла). Для каждого вложенного файла можно включать и выключать несколько параметров (Сжать/Зашифровать/Подписать/Предложить автоматический показ).

Используйте пункт меню Свойства в контекстном меню для открытия диалога Свойства вложения. Первое поле содержит MIME-тип вложения. Как и поле Имя, оно автоматически будет заполнено соответствующим значением. Иногда тип MIME может определяться неверно, в таком случае можно ввести любой тип MIME или выбрать его вручную из списка. Также можно выбрать способ кодирования вложения (обычно всё отлично работает с настройкой по умолчанию). Чтобы предложить получателю автоматический показ вложения в теле письма, установите флажок Предложить автоматический показ. Сработает ли это, зависит от почтового клиента получателя и его настроек.

Также можно приложить к письму открытые ключи с помощью соответствующих пунктов в меню Вложение. Ключи GnuPG и сертификаты x.509 (обычно) обрабатываются как вложения.

Проверка орфографии письма

KMail может автоматически проверять правописание и подчёркивать неизвестные слова красным. Если таких слов слишком много, KMail выключит проверку. Чтобы выбрать язык для проверки правописания, воспользуйтесь меню Вид → Словарь. Чтобы отключить автоматическую проверку правописания, воспользуйтесь меню Параметры.

Если требуется написать письмо на разных языках, включите раскрывающийся список Словарь: в меню Вид → Словарь. Этот раскрывающийся список позволяет сменить язык для проверки орфографии по щелчку мыши.

Чтобы проверить орфографию письма с помощью соответствующего диалога, воспользуйтесь пунктом меню Сервис → Проверка орфографии…. Для проверки орфографии KMail использует программу Sonnet — оболочку KDE для программ проверки орфографии Aspell, Hspell, Enchant и HUNSPELL. Обратите внимание, что, возможно, сначала потребуется настроить параметры проверки орфографии с помощью пункта меню Настройка → Программа проверки орфографии….

Настройка инструмента вставки фраз

При написании писем в окне редактора можно вставлять часто используемые фрагменты текста в виде фраз. Чтобы настроить возможность вставки фраз, воспользуйтесь пунктом меню Вид → Фразы. Появится новая панель на правой стороне редактора.

Чтобы добавить новые фразы на панель, щёлкните по панели правой кнопкой мыши и в открывшемся контекстном меню выберите вариант Добавить фразу…. Откроется диалог редактора фраз, позволяющий ввести текст и название фразы, а также назначить для неё Комбинацию клавиш. Фразы можно объединять в группы. Чтобы добавить, изменить или удалить фразы из сохранённого набора, воспользуйтесь контекстным меню, вызываемым щелчком правой кнопкой мыши по фразе.

Инструмент Фразы позволяет при каждой вставке фразы подставлять изменяемый текст в заранее заданные места. Для этого инструмент Фразы предлагает собственный механизм переменных. Переменные можно вставлять прямо в текст фразы, заключая их имена в разделители ( $ ). Например: $variablename$, $invoicenumber$, $weekno$.

Разделитель переменных можно заменить на другой символ, изменив строку snippetDelimiter в разделе [SnippetPart] конфигурационного файла, который находится по адресу ~./config/kmailsnippetrc.

snippetDelimiter=$

Использование встроенного переводчика

Редактор писем KMail 2 имеет встроенный переводчик, который вызывается с помощью пункта меню Сервис → Машинный перевод. В нижней части окна редактора появится новая панель.

Чтобы перевести фрагмент текста, сначала введите текст в поле с надписью Перетащите сюда текст, который нужно перевести.. В раскрывающемся списке С языка: выберите язык, с которого требуется произвести перевод, а в раскрывающемся списке На язык: — язык, на который следует перевести, затем нажмите кнопку Перевести. После перевода с помощью Google Translate, бесплатного онлайн-сервиса, переведённый текст появится в соседнем поле. Если требуется перевести в обратном направлении, нажмите кнопку Наоборот. Чтобы очистить весь текст, нажмите кнопку Очистить.