Глава 9. Справочник

Меню

При запуске KOrganizer появляется его главное окно. В нём есть несколько элементов: строка меню, панель инструментов, календарь месяца, главная панель с текущим «представлением» событий и список задач.

Меню предоставляет доступ ко всем основным операциям, которые могут быть выполнены над календарём, включая сохранение, загрузку, добавление и удаление событий, задач и записей дневника, печать и другие операции.

Обратите внимание, что при использовании KOrganizer в качестве компонента календаря Kontact меню будет отличаться от меню в самостоятельном приложении.

Файл

Меню Файл обеспечивает доступ к функциям, влияющим на весь календарь.

Файл → Открыть… (Ctrl+O)

Открывает файловый диалог, который позволяет выбрать файл формата vCalendar или iCalendar для загрузки. Если в текущем календаре выполнены изменения, их будет предложено сохранить перед открытием нового календаря.

Дополнительные сведения доступны в разделе «Импорт, экспорт и управление календарями».

Файл → Печать… (Ctrl+P)

Чтобы распечатать текущий календарь, выберите в меню пункт Печать или нажмите значок Печать. Можно указать диапазон дат, которые необходимо распечатать (вручную или с помощью виджета календаря), и шаблон печати (печать дня, недели, месяца, задач или записей дневника).

Файл → Предварительный просмотр

Если выбрать в меню пункт Предварительный просмотр или нажать значок Предварительный просмотр, текущий календарь будет выведен на экран, а не отправлен на печать. Используйте эту возможность для проверки корректности распечатки перед выполнением печати.

Можно указать диапазон дат, которые необходимо распечатать (вручную или с помощью виджета календаря), и шаблон печати (печать дня, недели, месяца или задач).

Файл → Импорт → Импорт календаря…

Выберите этот пункт меню, если имеются другие файлы в формате iCalendar или vCalendar и требуется объединить их содержимое с существующим календарём, добавить их в качестве нового источника или открыть их в новом окне. Эта возможность полезна, например, когда по почте получен содержащий несколько записей файл vCalendar.

Дополнительные сведения доступны в разделе «Импорт календарей».

Файл → Экспорт → Экспорт в iCalendar…

При выборе этого действия все активные события, задачи и записи дневника (независимо от того, с каким источником они связаны) будут экспортированы в новый файл iCalendar.

Дополнительные сведения доступны в разделе «Экспорт календарей».

Файл → Архивировать старые события…

Время от времени необходимо удалять старые события.

Дополнительные сведения доступны в разделе «Управление календарями».

Файл → Удалить выполненные задачи

При выборе этого действия из активного календаря будут удалены все выполненные задачи.

Дополнительные сведения доступны в разделе «Управление календарями».

Файл → Выход (Ctrl+Q)

При выборе пункта меню Выход или нажатии значка Выход будет выполнен выход из текущего окна календаря с запросом на сохранение, если в календаре имеются несохранённые изменения.

Это не приведёт к закрытию других открытых окон календарей. Закрытие каждого окна календаря выполняется по отдельности.

Правка

С помощью меню Правка можно изменять и искать события и задачи.

Пункты меню Вырезать, Копировать и Вставить работают так же, как и в других приложениях KDE. Пункт Найти… позволяет выполнять поиск событий и задач в текущем календаре.

Правка → Отменить действие (Ctrl+Z)

Отменить последнее действие — иными словами, вернуть календарь в то состояние, в котором он находился непосредственно перед выполнением последнего действия.

Правка → Повторить действие (Ctrl+Shift+Z)

Повторить последнее действие — иными словами, вернуть календарь в то состояние, в котором он находился непосредственно перед отменой последнего действия.

Правка → Вырезать (Ctrl+X)

Вырезать текущее выбранное событие в буфер обмена, удалив его из календаря.

Правка → Копировать (Ctrl+C)

Скопировать текущий выбранный элемент в буфер обмена, оставив его в календаре.

Правка → Вставить (Ctrl+V)

При выборе пункта Вставить содержимое буфера обмена будет вставлено в календарь. Буфер обмена должен содержать корректные данные формата vCalendar или iCalendar, предоставленные предыдущими операциями копирования/вырезания или выделением вне KOrganizer. Если содержимое буфера обмена не удаётся распознать, будет показано соответствующее предупреждение.

Подсказка

Тем не менее для копирования текста из любого приложения в окно редактирования события KOrganizer и наоборот можно использовать комбинации клавиш Ctrl+C и Ctrl+V.

Правка → Удалить

Удалить текущий выбранный элемент, убрав его из календаря.

Правка → Найти… (Ctrl+F)

Выбор пункта Найти… в меню Правка или щелчок по значку Поиск позволяет выполнить поиск событий, задач или записей дневника по их названиям, описаниям и/или меткам.

Дополнительные сведения доступны в разделе «Поиск».

Вид

Для показа событий, задач и записей дневника существует несколько «представлений». KOrganizer сохраняет между сеансами сведения о том, какое представление было активным, и при следующем запуске показывает его же.

В целом, каждое представление позволяет просматривать записи дневника, задачи и события в рамках определённого периода времени или стиля показа. Щёлкните по элементу, чтобы выполнить над ним действие. Если щёлкнуть по элементу правой кнопкой мыши, появится контекстное меню с такими вариантами действий, как Изменить…, Удалить и так далее. Аналогичные операции можно выполнить и с помощью меню Действия.

Вид → Расписание

Переключиться в представление расписания.

Дополнительные сведения доступны в разделе «Режим просмотра «Расписание»».

Вид → Месяц

Переключиться в представление месяца.

Дополнительные сведения доступны в разделе «Режим просмотра «Месяц»».

Вид → Шкала времени

Переключиться в представление шкалы времени.

Дополнительные сведения доступны в разделе «Режим просмотра «Шкала времени»».

Вид → Задачи

Переключиться в представление списка задач.

Дополнительные сведения доступны в разделе «Задачи».

Вид → События

Переключиться в представление списка событий.

Дополнительные сведения доступны в разделе «Режим просмотра «События»».

Вид → Что дальше

Переключиться в представление «Что дальше».

В этом режиме показаны предстоящие события и задачи. Все события и задачи показываются в отдельных строках.

Дополнительные сведения доступны в разделе «Режим просмотра «Что дальше»».

Вид → Дневник

Переключиться в представление дневника.

Дополнительные сведения доступны в разделе «Режим просмотра «Дневник»».

Вид → Обновить

Обновить или перезагрузить текущее представление.

Вид → Масштаб

Это подменю позволяет настроить текущее представление на показ большего или меньшего количества данных.

Представление расписания (то есть представление одного или нескольких дней или недели) можно масштабировать для показа большего или меньшего количества дней (Масштаб → Увеличить по ширине и Масштаб → Уменьшить по ширине) или большего или меньшего количества часов в дне (Масштаб → Увеличить по высоте и Масштаб → Уменьшить по высоте).

Вид → Применить фильтр

Это подменю предоставляет доступ к фильтрам, уже созданным в диалоге Редактирование фильтров календаря. Выберите фильтр, который будет использован для представления KOrganizer. Если фильтр не требуется, выберите Показать все.

Переход

Дополнительные сведения о просмотре представлений KOrganizer доступны в разделе «Режимы просмотра KOrganizer».

Переход → Назад

Перейти к предыдущему дню, неделе или месяцу, в зависимости от текущего представления.

Переход → Вперёд

Перейти к следующему дню, неделе или месяцу, в зависимости от текущего представления.

Переход → Сегодня

Перейти к периоду времени, который включает текущую дату.

Переход → День

Переключиться в представление дня.

Дополнительные сведения доступны в разделе «Режим просмотра «Расписание»».

Переход → Следующие x дней

Переключиться в представление следующих x дней (x задаётся в основных параметрах KOrganizer).

Дополнительные сведения доступны в разделе «Режим просмотра «Расписание»».

Переход → Рабочая неделя

Переключиться в представление рабочей недели.

Аналогично представлению недели, но содержит только рабочие дни.

Дополнительные сведения доступны в разделе «Режим просмотра «Расписание»».

Переход → Неделя

Переключиться в представление недели.

Представление недели очень похоже на представление дня. События семи дней показываются рядом друг с другом. Все функции, доступные в представлении дня, также работают и в представлении недели.

Дополнительные сведения доступны в разделе «Режим просмотра «Расписание»».

Действия

Действия → Создать событие…

Чтобы создать новое событие, выберите пункт меню Создать событие….

Подробное описание окна события доступно в разделе «Создание событий».

Действия → Создать задачу…

Чтобы создать новую задачу, выберите пункт меню Создать задачу…. При необходимости для задачи можно указать дату завершения.

Подробное описание окна задач доступно в разделе «Создание задач».

Действия → Создать подзадачу…

Пункт меню Создать подзадачу… позволяет начать создание новой подзадачи. Текущая выбранная задача используется в качестве родительской. При необходимости для задачи можно указать дату завершения.

Подробное описание окна задач доступно в разделе «Создание задач».

Действия → Создать запись в дневнике…

Пункт меню Создать запись в дневнике… позволяет начать создание новой записи дневника.

Переход → Выбрать дату

Открывает диалог выбора даты для быстрого перехода к нужному дню.

Действия → Просмотреть

Пункт меню Просмотреть позволяет открыть диалоговое окно со сведениями о текущей выбранной записи дневника, событии или задаче.

Действия → Изменить…

Пункт меню Изменить… позволяет изменить текущую выбранную запись дневника, событие или задачу.

Действия → Удалить (Del)

Пункт меню Удалить позволяет удалить текущую выбранную запись дневника, событие или задачу.

Действия → Сделать подзадачу самостоятельной

Пункт меню Сделать подзадачу самостоятельной позволяет отделить текущую выбранную подзадачу от родительской задачи и сделать её независимым элементом списка задач.

Расписание

Расписание → Опубликовать сведения…

Направить выбранное событие, задачу или запись дневника по электронной почте в формате iCalendar.

Дополнительные сведения доступны в разделе «Публикация событий, задач и записей дневника».

Расписание → Отправить приглашение участникам

Направить сведения о выбранной задаче или событии участникам и (если требуется) запросить ответ.

Дополнительные сведения доступны в разделе «Отправка приглашений и обработка ответов».

Расписание → Отправить обновление статуса

Если произошли изменения в состоянии участия («принято», «принято предварительно» и так далее), с помощью этого пункта о них можно сообщить организатору события.

Дополнительные сведения доступны в разделе «Ответ на приглашение».

Расписание → Отправить участникам уведомление об отмене

Если требуется отменить событие или задачу, выделите этот элемент и выберите этот пункт меню, чтобы сообщить участникам об отмене.

Дополнительные сведения доступны в разделе «Отмена события или задачи».

Расписание → Запросить обновление

Запросить последнюю версию сведений о выбранном событии или задаче у организатора.

Дополнительные сведения доступны в разделе «Запрос новейшей версии события или задачи».

Расписание → Запросить изменение

Направить альтернативное предложение организатору выбранного события или задачи.

Дополнительные сведения доступны в разделе «Отправка встречного предложения».

Расписание → Отправить сведения о занятом времени по почте…

Направить сведения о занятом времени по одному или нескольким адресам электронной почты.

Дополнительные сведения доступны в разделе «Информация о занятости».

Расписание → Опубликовать информацию о занятом времени

Отправить сведения о занятом времени на сервер совместной работы, чтобы их могли получить другие пользователи.

Дополнительные сведения доступны в разделе «Информация о занятости».

Настройка и справка

Помимо стандартных меню KDE, описание которых приведено в главе Меню раздела справки «Основы KDE», в KOrganizer имеются следующие специфичные для этого приложения пункты меню «Настройка» и «Справка»:

Настройка → Боковая панель

Чтобы показать или скрыть компоненты боковой панели KOrganizer, следует установить или снять соответствующие флажки пунктов этого подменю. Обратите внимание, что боковая панель видна только в том случае, если под текущее представление не выделено всё пространство.

Настройка → Настроить дату и время…

Этот пункт меню позволяет настроить формат даты и времени. Обратите внимание, что этот параметр общий для всех приложений рабочего стола.

Настройка → Фильтры…

Этот пункт меню позволяет открыть диалоговое окно Редактирование фильтров календаря, с помощью которого можно создавать, удалять и изменять фильтры для управления показом элементов в KOrganizer.

Настройка → Метки событий…

Этот пункт меню позволяет открыть диалоговое окно Метки событий, с помощью которого можно создавать, удалять и изменять метки элементов календаря. Метки используются для организации событий и задач по группам.