Глава 4. Обзор интерфейса

Содержание

Команды меню

Команды меню

Игра → Начать игру (Ctrl+N)

Начинает новую игру.

Игра → Загрузить… (Ctrl+O)

Загрузить сохранённую игру.

Игра → Начать заново (F5)

Перезапустить текущую игру.

Игра → Новая игра по номеру…

Начинает игру с заданным номером расклада.

Диалог «Новая игра по номеру»

Игра → Сохранить (Ctrl+S)

Сохраняет текущую игру.

Игра → Пауза (P)

Приостанавливает или возобновляет игру. Во время приостановки все плитки скрываются.

Игра → Показать лучшие результаты (Ctrl+H)

Показывает таблицу рекордов.

Показать рекорды

Если ваш рекорд вошёл в десятку лучших, то вам будет предложено ввести своё имя.

Игра → Редактор раскладки

Открывает редактор раскладки.

Редактор раскладки

Порядок редактирования раскладки:

  1. Панель инструментов редактора раскладки позволяет создать новую раскладку или загрузить и изменить существующую.

  2. Сохраните раскладку в папке пользователя $XDG_DATA_HOME/kmahjongg/layouts

  3. Создайте файл имя_вашей_раскладки.desktop в той же папке.

  4. Поместите в этот файл следующие строки с помощью любого текстового редактора:

    [KMahjonggLayout]
    Name=имя_вашей_раскладки
    Description=описание_вашей_раскладки
    VersionFormat=1
    Author=ваше_имя
    AuthorEmail=ваш_адрес_электронной_почты
    FileName=имя_вашей_раскладки.layout
    
  5. Чтобы использовать новую раскладку, перезапустите KMahjongg.

Игра → Выход (Ctrl+Q)

Осуществляет выход из KMahjongg.

Ход → Отменить (Ctrl+Z)

Отменить ваш предыдущий ход.

Ход → Повторить (Ctrl+Shift+Z)

Повторить ранее отменённый ход.

Ход → Подсказка (H)

Дать подсказку миганием парных плиток.

Ход → Демонстрация (D)

Включить демонстрационный режим.

Ход → Перемешать

Перетасовать плитки на игровой доске.

Вид → Повернуть по часовой стрелке (G)

Повернуть угол обзора по часовой стрелке.

Вид → Повернуть против часовой стрелки (F)

Повернуть угол обзора против часовой стрелки.

Кроме того KMahjongg имеет стандартные для KDE меню Настройка и Справка, для получения дополнительных сведений о них обратитесь к разделам Меню «Настройка» и Меню «Справка» документации «Основы KDE».