Capitolo 3. Guida ai comandi

La finestra principale di Cantor

Cantor ha le voci di menu comuni di KDE; per maggiori informazioni, consulta il capitolo Menu dei «Fondamentali di KDE».

Segue la lista delle voci di menu aggiuntive o speciali in Cantor. Nota che alcuni menu sono mostrati solo per i motore che li implementano.

Il menu File

File → Nuovo (Ctrl+N)

Crea un nuovo foglio di lavoro con il motore predefinito.

File → Nuovo → Motore

Crea un nuovo foglio di lavoro con il motore scelto.

File → Apri... (Ctrl+O)

Apre con la finestra dei file un nuovo foglio di lavoro supportato.

File → Apri recenti

Scegli un foglio di lavoro da un elenco di file usati di recente.

File → Scarica fogli di lavoro d'esempio

Apre la finestra per scaricare esempi inviati da altri utenti di Cantor usando GetHotNewStuff.

File → Apri esempio

Apre la finestra per caricare un esempio. Gli esempi devono essere prima scaricati usando File → Scarica fogli di lavoro d'esempio.

File → Salva come testo semplice

Permette di salvare il foglio di lavoro corrente come documento di testo semplice.

File → Esporta come LaTeX

Permette di salvare il foglio di lavoro corrente come documento LATEX.

File → Pubblica foglio di lavoro

Apre la finestra per pubblicare il tuo foglio di lavoro corrente e renderlo disponibile ad altri utenti di Cantor per mezzo di GetHotNewStuff.

File → Avvia script

Permette di caricare ed eseguire script con il motore corrente.

Il menu Visualizza

Visualizza → Pannelli

Ti permette di visualizzare o di nascondere alcune schede nella barra laterale. Le scelte sono:

Navigatore dei file

Mostra o nasconde la scheda Navigatore dei file nella barra laterale.

Aiuto

Mostra o nasconde la scheda Aiuto nella barra laterale.

Gestore variabili

Mostra o nasconde la scheda Gestore variabili nella barra laterale.

Visualizza → Ingrandisci (Ctrl++)

Ingrandisce il foglio di lavoro corrente del 10%.

Visualizza → Riduci (Ctrl+-)

Riduce il foglio di lavoro corrente 10%.

Visualizza → Mostra editor degli script

Apre la finestra per la modifica degli script per il motore corrente.

Il menu Foglio di lavoro

Foglio di lavoro → Vàluta foglio di lavoro (Ctrl+E)

Avvia la valutazione dell'intero foglio di lavoro.

Foglio di lavoro → Vàluta voce (Shift+Invio)

Avvia la valutazione della voce corrente.

Foglio di lavoro → Inserisci voce di comando (Ctrl+Invio)

Inserisce una nuova voce di comando sotto la posizione corrente del cursore.

Foglio di lavoro → Inserisci voce di testo

Inserisce una nuova voce di testo sotto la posizione corrente del cursore.

Foglio di lavoro → Inserisci voce di Markdown

Inserisce una nuova voce di Markdown sotto la posizione corrente del cursore.

Worksheet → Inserisci voce di LaTeX

Inserisce una nuova voce di LATEX sotto la posizione corrente del cursore.

Foglio di lavoro → Inserisci immagine

Inserisce un'immagine sotto la posizione corrente del cursore.

Foglio di lavoro → Inserisci interruzione di pagina

Inserisce un'interruzione di pagina sotto la posizione corrente del cursore.

Foglio di lavoro → Collassa tutti i risultati

Collassa tutti i risultati della voce di comando.

Foglio di lavoro → Espandi tutti i risultati

Espandi tutti i risultati della voce di comando.

Foglio di lavoro → Rimuovi tutti i risultati

Rimuovi tutti i risultati della voce di comando.

Foglio di lavoro → Rimuovi la voce corrente (Shift+Canc)

Rimuove la voce corrente dal foglio di lavoro.

Il menu Algebra lineare

Algebra lineare → Crea matrice

Apre la finestra di creazione delle matrici.

Algebra lineare → Calcola autovalori

Apre la finestra dell'assistente all'inserimento del nome della matrice per calcolare i suoi autovalori e la dimensione della molteplicità nell'ordine corrispondente.

Algebra lineare → Calcola autovettori

Apre la finestra dell'assistente all'inserimento del nome della matrice per calcolare i suoi autovalori e la dimensione della molteplicità degli autovalori e degli autovettori nell'ordine corrispondente.

Algebra lineare → Inverti matrice

Apre la finestra di dialogo di inserimento del nome della matrice per trovare l'inversa di una matrice.

Il menu Calcola

Calcola → Calcola differenziale

Apre la finestra dei parametri del differenziale.

Calcola → Integra

Apre la la finestra dei parametri dell'integrata.

Calcola → Risolvi equazioni

Apre la finestra di dialogo di inserimento parametri per risolvere equazioni lineari e non lineari.

Il menu Pacchetto

Pacchetto → Importa pacchetto

Apre la finestra di importazione dei pacchetti.

Il menu Grafico

Grafico → Grafico

Apre la finestra dei parametri del grafico.

Grafico → Grafico 2D

Apre la finestra dei parametri del grafico.

Grafico → Grafico 3D

Apre la finestra dei parametri del grafico.

I menu Impostazioni e Aiuto

Cantor ha le voci di menu Impostazioni e Aiuto comuni di KDE; per maggiori informazioni, consulta le sezioni sul menu Impostazioni e sul menu Aiuto dei «Fondamentali di KDE».