Chapter 4. The Menu Entries

The File Menu

File → New (Ctrl+N)

This starts a new document in a new and independent editor window.

File → New Window

Create another window containing the current document. All changes to the document in one window are reflected in the other window and vice versa.

File → Open... (Ctrl+O)

Displays a standard KDE Open File dialog. Use the file view to select the file you want to open, and click on Open to open it.

File → Open Recent

This is a shortcut to open recently saved documents. Clicking on this item opens a list to the side of the menu with several of the most recently saved files. Clicking on a specific file will open it in KatePart - if the file still resides at the same location.

File → Save (Ctrl+S)

This saves the current document. If there has already been a save of the document then this will overwrite the previously saved file without asking for the user's consent. If it is the first save of a new document the save as dialog (described below) will be invoked.

File → Save As... (Ctrl+Shift+S)

This allows a document to be saved with a new file name. This is done by means of the file dialog box described above in the Open section of this help file.

File → Save As with Encoding

Save a document with a new file name in a different encoding.

File → Save Copy As

Save a copy of the document with a new file name and continue editing the original document.

File → Reload (F5)

Reloads the active file from disk. This command is useful if another program or process has changed the file while you have it open in KatePart.

File → Print... (Ctrl+P)

Opens a simple print dialog allowing the user to specify what, where, and how to print.

File → Export as HTML

Save the currently open document as an HTML file, which will be formatted using the current syntax highlighting and color scheme settings.

File → Close (Ctrl+W)

Close the active file with this command. If you have made unsaved changes, you will be prompted to save the file before KatePart closes it.

File → Quit (Ctrl+Q)

This will close the editor window, if you have more than one instance of KatePart running, through the New or New Window menu items, those instances will not be closed.