Меню «Сервис»

Сервис → Тип документа

Позволяет выбрать тип файла для текущего документа. Переопределяет глобальный тип файла, указанный с помощью пункта меню Настройка → Настроить редактор… на вкладке «Режимы и типы файлов», но только для текущего документа.

Сервис → Подсветка

Позволяет выбрать нестандартную схему подсветки для текущего документа. Переопределяет глобальный режим подсветки, указанный с помощью пункта меню Настройка → Настроить редактор…, но только для текущего документа.

Сервис → Расстановка отступов

Позволяет выбрать режим отступов для текущего документа. Переопределяет глобальный режим отступов, указанный с помощью пункта меню Настройка → Настроить редактор…, но только для текущего документа.

Сервис → Кодировка

Позволяет выбрать для текущего документа кодировку, отличную от указанной с помощью пункта меню Настройка → Настроить редактор… на вкладке Открытие и сохранение.

Сервис → Добавлять отметку о порядке байтов (BOM)

Позволяет явным образом добавить маркер последовательности байтов в документах, закодированных в формате Юникод. Маркер последовательности байтов — это символ из стандарта Юникод, используемый для обозначения порядка байтов в текстовом файле или потоке. Дополнительные сведения: Маркер последовательности байтов.

Сервис → Конец строки

Позволяет выбрать режим конца строки для текущего документа. Переопределяет глобальный режим конца строки, заданный с помощью пункта меню Настройка → Настроить редактор…, но только для текущего документа.

Сервис → Сценарии

Это вложенное меню содержит список сценариев. Можно также написать собственные сценарии. Это позволяет расширить функциональность KatePart инструментами, определёнными пользователем.

Сервис → Сценарии → Навигация
Сервис → Сценарии → Навигация → Перейти к предыдущему такому же отступу (Alt+Shift+Стрелка вверх)

Перемещает курсор к первой строке над текущей, которая имеет тот же уровень отступа, что и текущая.

Сервис → Сценарии → Навигация → Перейти к следующему такому же отступу (Alt+Shift+Стрелка вниз)

Перемещает курсор к первой строке под текущей, которая имеет тот же уровень отступа, что и текущая.

Сервис → Сценарии → Редактирование
Сервис → Сценарии → Редактирование → Отсортировать выделенный текст

Упорядочивает выделенный текст или весь документ по возрастанию.

Сервис → Сценарии → Редактирование → Переместить строки ниже (Ctrl+Shift+Стрелка вниз)

Переместить выделенные строки ниже.

Сервис → Сценарии → Редактирование → Переместить строки выше (Ctrl+Shift+Стрелка вверх)

Переместить выделенные строки выше.

Сервис → Сценарии → Редактирование → Продублировать выделенные строки ниже (Ctrl+Alt+Стрелка вниз)

Дублирует выделенные строки ниже.

Сервис → Сценарии → Редактирование → Продублировать выделенные строки выше (Ctrl+Alt+Стрелка вверх)

Дублирует выделенные строки выше.

Сервис → Сценарии → Редактирование → Закодировать выделенный текст в формат URI

Кодирует выделенный текст таким образом, чтобы его было можно использовать как часть строки запроса URL-адреса. Выделенный текст заменяется закодированным.

Сервис → Сценарии → Редактирование → Декодировать выделенный текст в формате URI

Если выделена часть строки запроса URL-адреса, она будет декодирована. Выделенный фрагмент заменяется исходным необработанным текстом.

Сервис → Сценарии → Emmet
Сервис → Сценарии → Emmet → Развернуть сокращение

Преобразует выделенный текст в пару открывающих и закрывающих тегов HTML или XML. Например, если выделено div, этот элемент будет заменён на <div></div>.

Сервис → Сценарии → Emmet → Обернуть в тег

Оборачивает выделенный текст в тег, указанный в командной строке.

Сервис → Сценарии → Emmet → Переместить курсор к соответствующему тегу

Если курсор находится внутри открывающего тега HTML/XML, он будет перемещён к закрывающему тегу. Если же курсор находится внутри закрывающего тега, он будет перемещён к открывающему тегу.

Сервис → Сценарии → Emmet → Выделить содержимое тега HTML/XML, перемещаясь внутрь

Если курсор находится внутри пары тегов HTML/XML, выделение будет охватывать содержимое этих тегов HTML/XML без самих тегов.

Сервис → Сценарии → Emmet → Выделить содержимое тега HTML/XML, перемещаясь наружу

Если курсор находится внутри пары тегов HTML/XML, выделение будет охватывать содержимое этих тегов HTML/XML вместе с самими тегами.

Сервис → Сценарии → Emmet → Закомментировать или раскомментировать

Если выделенный текст не является комментарием, он будет обозначен как комментарий HTML/XML (например, <!-- выделенный текст -->). Если выделенный текст является комментарием, то соответствующие теги будут удалены.

Сервис → Сценарии → Emmet → Удалить тег под курсором

Если курсор находится внутри тега HTML/XML, этот тег будет удалён целиком.

Сервис → Сценарии → Emmet → Уменьшить число на 1

Если выделенный текст является числом, из него будет вычтена единица. Например, если выделено 5, результатом будет 4.

Сервис → Сценарии → Emmet → Уменьшить число на 10

Если выделенный текст является числом, из него будет вычтено 10. Например, если выделено 15, результатом будет 5.

Сервис → Сценарии → Emmet → Уменьшить число на 0,1

Если выделенный текст является числом, из него будет вычтено 0,1. Например, если выделено 4,5, результатом будет 4,4.

Сервис → Сценарии → Emmet → Увеличить число на 1

Если выделенный текст является числом, к нему будет прибавлена единица. Например, если выделено 5, результатом будет 6.

Сервис → Сценарии → Emmet → Увеличить число на 10

Если выделенный текст является числом, к нему будет прибавлено 10. Например, если выделено 5, результатом будет 15.

Сервис → Сценарии → Emmet → Увеличить число на 0,1

Если выделенный текст является числом, к нему будет прибавлено 0,1. Например, если выделено 4,5, результатом будет 4,6.

Сервис → Командная строка (F7)

Показывает командную строку KatePart в нижней части окна. Чтобы получить справочную информацию, введите help, а чтобы получить список команд — help list. Дополнительные сведения о командной строке доступны в разделе Командная строка компонента редактирования.

Сервис → Дополнить код (Ctrl+Пробел)

Вручную вызывает функцию дополнения кода (обычно это выполняется с помощью соответствующей комбинации клавиш).

Сервис → Автодополнение слов

При выборе пункта Использовать нижестоящее слово (Ctrl+9) или Использовать вышестоящее слово (Ctrl+8) для дополнения введённой на данный момент части слова будет выполняться поиск похожих слов в направлении вниз или вверх от текущей позиции курсора. При выборе пункта Автодополнение как в командной оболочке появится окно с совпадающими записями.

Сервис → Орфография → Автоматическая проверка орфографии (Ctrl+Shift+O)

Если параметр Автоматическая проверка орфографии включён, неправильно написанное слово будет подчёркнуто сразу же.

Сервис → Орфография → Проверка орфографии…

Запускает средство проверки орфографии, которая позволяет пользователю найти и исправить орфографические ошибки. При выборе этого пункта меню будет запущена проверка и открыт диалог управления её ходом. В этом диалоге присутствуют следующие параметры:

Неизвестное слово:

Слово, в котором, возможно, содержится ошибка. На самом деле ошибки может и не быть, просто такого слова нет в словаре (с содержимым которого модуль сравнивает каждое проверяемое слово) модуля.

Заменить на:

Если в словаре есть слова, похожие на ошибочное, здесь будет показано первое из совпадений. Можно принять исправление, ввести свой вариант или выбрать из списка другой вариант.

Язык:

Если установлено несколько словарей, здесь можно выбрать, какой из них следует использовать.

В правой части диалога расположены 6 кнопок управления проверкой орфографии:

Добавить в словарь

Добавить неизвестное слово в словарь модуля. Это значит, что при следующих запусках проверки слово будет считаться правильным.

Похожие слова

Список возможных замен слова с ошибкой. Если щёлкнуть по одному из вариантов, он появится в поле Заменить на.

Заменить

Подтвердить замену неизвестного слова текстом из поля Заменить на.

Заменить все

Не только заменить текущее неизвестное слово на слово в поле Заменить на, но и автоматически выполнить аналогичную замену для всех остальных вхождений этого неизвестного слова.

Игнорировать

Продолжить поиск ошибок, не меняя неизвестное слово.

Игнорировать везде

Пропустить текущее неизвестное слово и поступать аналогичным образом со всеми такими же словами в документе.

Примечание

Применяется только для текущего сеанса проверки орфографии. При следующем запуске снова будет предложено заменить это слово.

Ещё три кнопки расположены по горизонтали, в нижней части диалога проверки орфографии:

Справка

Открывает справочную систему KDE на странице справки к этому диалогу.

Готово

Завершает процесс проверки орфографии (сохраняя все исправления).

Отмена

Прерывает проверку орфографии (не сохраняя исправления).

Сервис → Орфография → Проверка орфографии от курсора…

Запускает средство проверки орфографии, но начинает проверку с позиции курсора (а не с начала документа).

Сервис → Орфография → Проверка орфографии в выделенном фрагменте…

Проверяет орфографию в выделенном фрагменте текста.

Сервис → Орфография → Выбрать словарь…

Показывает в нижней части окна редактора поле с раскрывающимся списком всех доступных словарей для проверки орфографии. Это поле позволяет легко переключаться между орфографическими словарями, например, для автоматической проверки орфографии в тексте на разных языках.