Common Menus

T.C. Hollingsworth

Many KDE applications contain these menus. However, most applications will have more menu entries than those listed here, and others may be missing some of the entries listed here.

A menubar

The menubar in Gwenview.

Some applications, like Dolphin, do not show a menubar by default. You can show it by pressing Ctrl+M. You can also use this to hide the menubar in applications that support doing so.

The File Menu

The File menu allows you to perform operations on the currently open file and access common tasks in applications.

Common menu items include:

File → New (Ctrl+N)

Creates a new file.

File → New Window

Opens a new window.

File → Open... (Ctrl+O)

Opens an already existing file.

File → Save (Ctrl+S)

Saves the file. If the file already exists it will be overwritten.

File → Save As...

Saves the file with a new filename.

File → Save All

Saves all open files.

File → Reload (F5)

Reloads the current file.

File → Reload All

Reloads all open files.

File → Print... (Ctrl+P)

Prints the file. Use Print to File (PDF) to generate a PDF file or select a range of pages to print only these pages to a new PDF file

File → Close (Ctrl+W)

Closes the current file.

File → Close All

Closes all open files.

File → Quit (Ctrl+Q)

Exits the program.

The Edit Menu

The Edit menu allows you to modify the currently open file.

Edit → Undo (Ctrl+Z)

Undo the last action you performed in the file.

Edit → Redo (Ctrl+Shift+Z)

Redo the last action you performed in the file.

Edit → Cut (Ctrl+X)

Removes the currently selected portion of the file, if any, and places a copy of it in the clipboard buffer.

Edit → Copy (Ctrl+C)

Places a copy of the currently selected portion of the file, if any, in the clipboard buffer.

Edit → Paste (Ctrl+V)

Copies the first item in the clipboard buffer to the current location in the file, if any.

Edit → Select All (Ctrl+A)

Selects the entire contents of the currently open file.

Edit → Find... (Ctrl+F)

Allows you to search for text in the currently open file.

Edit → Replace... (Ctrl+R)

Allows you to search for text in the currently open file and replace it with something else.

Edit → Find Next (F3)

Go to the next match of the last Find operation.

Edit → Find Previous (Shift+F3)

Go to the previous match of the last Find operation.

The View Menu

The View menu allows you to change the layout of the currently open file and/or the running application.

This menu has different options depending on the application you are using.

The Tools Menu

The Tools menu allows you to perform certain actions on the currently open file.

Tools → Automatic Spell Checking (Ctrl+Shift+O)

Check for spelling errors as you type. For more information, see the section called “Automatic Spell Checking”.

Tools → Spelling...

This initiates the spellchecking program - a program designed to help the user catch and correct any spelling errors. For more information, see the section called “Check Spelling”.

Tools → Spelling (from cursor)...

This initiates the spellchecking program, but only checks the portion of the document from the current location of the cursor to the end. For more information, see the section called “Check Spelling”.

Tools → Spellcheck Selection...

This initiates the spellchecking program, but only checks the currently selected text in the document. For more information, see the section called “Check Spelling”.

Tools → Change Dictionary...

This allows you to change the dictionary used to check spellings. For more information, see the section called “Configuring Sonnet”.

The Settings Menu

The Settings allows you to customize the application.

This menu typically contains the following items:

Settings → Show Menubar (Ctrl+M)

Toggle the Menubar display on and off. Once hidden it can be made visible using the shortcut Ctrl+M again. If the menubar is hidden, the context menu opened with a right mouse button click anywhere in the view area has an extra entry Show Menubar.

Settings → Show Statusbar

Toggles the display of the statusbar on and off. Some KDE applications use statusbar at the bottom of their screen to display useful information.

Settings → Toolbars Shown

Allows you to show and hide the various toolbars supported by the application.

Settings → Show Statusbar

When checked, this displays a small bar at the bottom of the application containing information about the status. When unchecked the status bar is hidden.

Settings → Configure Shortcuts...

Allows you to enable, disable, and modify keyboard shortcuts. For more information, see the section called “Using and Customizing Shortcuts”.

Settings → Configure Toolbars...

Allows you to customize the contents, layout, text, and icons of toolbars. For more information, see the section called “Customizing Toolbars”.

Settings → Configure Notifications...

This item displays a standard KDE notifications configuration dialog, where you can change the notifications (sounds, visible messages, etc.) used by the application.

For more information how to configure notifications please read the documentation for the System Settings module Manage Notifications.

Settings → Configure Application...

Opens the configuration panel for the currently running application.

The Help Menu

The Help menu gives you access to the application's documentation and other useful resources.

Help → Application Handbook (F1)

Invokes the KDE Help system starting at the running application's handbook.

Help → What's This? (Shift+F1)

Changes the mouse cursor to a combination arrow and question mark. Clicking on items within the application; will open a help window (if one exists for the particular item) explaining the item's function.

Help → Tip of the Day

This command opens the Tip of the Day dialog. You can page through all the tips by using the buttons on the dialog and select to show the tips at startup.

Note: Not all applications provide these tips.

Help → Report Bug...

Opens the Bug report dialog where you can report a bug or request a “wishlist” feature.

Help → Donate

Opens the Donations page where you can support KDE and its projects.

Help → Switch Application Language...

Opens a dialog where you can edit the Primary language and Fallback language for this application.

Help → About Application

This will display version and author information for the running application.

Help → About KDE

This displays the KDE Development Platform version and other basic information.

Thanks and Acknowledgments

Special thanks to an anonymous Google Code-In 2011 participant for writing much of this documentation.