Меню «Выделение»

Выделение → Выделить все (Ctrl+A)

Выделяет весь текст в документе. Полезно, если требуется скопировать в другое приложение весь файл.

Выделение → Снять выделение (Ctrl+Shift+A)

Снимает выделение с текста (если есть).

Выделение → Блочное выделение (Ctrl+Shift+B)

Переключает режим выделения. Когда установлен режим Блок (он обозначается текстом «[Блок]» в строке состояния), можно выполнять вертикальное выделение, например, выделить столбцы с пятого по десятый в строках 9–15.

Выделение → Закомментировать (Ctrl+D)

Добавляет знак комментария, отделённый от начала текста в строке пробелом.

Выделение → Раскомментировать (Ctrl+Shift+D)

Удаляет знак комментария и пробел, которым этот знак отделялся от начала текста в строке.

Выделение → Объединить строки (Ctrl+J)

Объединяет выделенные строки (или текущую строку с расположенной ниже) в одну, разделяя их пробелом. Пробелы в начале и конце строк удаляются.

Выделение → Прописные буквы (Ctrl+Alt+U)

Делает первую букву каждого слова выделенного текста (или текущего слова) прописной.

Выделение → Перевести в ВЕРХНИЙ РЕГИСТР (Ctrl+U)

Переводит выделенный текст (или букву под курсором) в верхний регистр.

Выделение → Перевести в нижний регистр (Ctrl+Shift+U)

Переводит выделенный текст (или букву под курсором) в нижний регистр.

Выделение → Привести отступы в порядок

Исправляет отступы в выделенном фрагменте текста или в строке, на которой находится курсор. Благодаря этому действию выделенный текст будет соответствовать выбранному режиму расстановки отступов.

Выделение → Форматированный отступ

Заново выравнивает текущую строку или строки в выделенном фрагменте согласно правилам отступа для документа.

Выделение → Выровнять по…

Эта команда выравнивает строки в выделенном блоке или всём документе по позиции, которая указана регулярным выражением (его будет предложено ввести).

Если указать пустой шаблон, выравнивание по умолчанию будет выполняться по первому непустому символу.

Если в шаблоне есть блок захвата, для захваченного совпадения будет добавлен отступ.

Примеры:

При использовании «-» будут вставлены пробелы перед первым «-» в каждой строке, чтобы выровнять все дефисы по одной позиции.

При использовании «alignon :\\s+(.)» будут вставлены пробелы перед первым непустым символом, стоящим после двоеточия, чтобы выровнять все такие символы по одной позиции.

Выделение → Выполнить перенос строк

Включает статический перенос строк в документе. Символ новой строки будет вставлен автоматически, когда текущая строка достигнет длины, указанной параметром Переносить слова на новую строку после на вкладке «Редактирование» (Настройка → Настроить редактор…).

Выделение → Добавить точку вставки над курсором (Ctrl+Alt+Стрелка вверх)

Добавляет ещё одну точку вставки над текущим курсором. Она располагается в строке выше на той же самой позиции, что и текущий курсор.

Выделение → Добавить точку вставки под курсором (Ctrl+Alt+Стрелка вниз)

Добавляет ещё одну точку вставки под текущим курсором. Она располагается в строке ниже на той же самой позиции, что и текущий курсор.

Выделение → Добавить курсоры в конце строк (Alt+Shift+I)

Добавляет курсор ко всем текущим выделенным строкам.

Выделение → Найти и выделить следующее вхождение (Alt+J)

Находит следующее вхождение текущего слова под курсором, выделяет его и добавляет курсор.

Выделение → Найти и выделить все вхождения (Ctrl+Alt+Shift+J)

Находит все вхождения текущего слова под курсором, выделяет их и добавляет курсор для каждого из них.