Capítulo 6. Referência de Comandos

A janela principal do kdesvn

O Menu Ficheiro

Ficheiro → Abrir (Ctrl+O)

Abre uma cópia de trabalho local ou um repositório previamente extraído

Ficheiro → URL's abertos recentemente

Este é um atalho para abrir os repositórios abertos recentemente. Se carregar neste item, irá abrir uma lista do lado do menu com diversas cópias locais ou repositórios abertos recentemente. Se carregar num item específico, abri-lo-á no kdesvn

Ficheiro → Novo (Ctrl+N)

Abre uma janela com uma nova instância do kdesvn

Ficheiro → Administração do Subversion

Itens de menu com tarefas administrativas para os repositórios de Subversion, como por exemplo:

Criar e abrir um novo repositório
Guardar os dados do repositório num ficheiro
Replicar um repositório
Carregar um ficheiro de dados para um repositório

Para mais informações, veja o resultado do comando svnadmin --help

Ficheiro → Fechar (Ctrl+W)

Fecha o repositório ou cópia local aberto de momento

Ficheiro → Sair (Ctrl+Q)

Sai do kdesvn

O Menu Favorito

Veja a ajuda do Konqueror.

O Menu Subversion

Acções gerais do Subversion

Subversion → Geral → Histórico do item (Ctrl+L)

Mostra o registo histórico completo do item seleccionado de momento. Tenha cuidado, esta lista poderá ficar realmente grande!

Subversion → General → Histórico do item sem cópias... (Ctrl+Shift+L)

Mostra o registo histórico do item seleccionado sem as cópias adjacentes.

Subversion → Geral → Detalhes (Ctrl+I)

Mostra informações detalhadas sobre os itens seleccionados

Subversion → Geral → Anotação

Cria uma lista anotada de todas as modificações efectuadas. Isto poderá levar algum tempo!

Subversion → Geral → Anotação do intervalo

Mostra as anotações de um dado conjunto de versões de um ficheiro.

Subversion → Geral → Mostrar a última versão

Mostra o conteúdo da última versão desse item. (poderá ser diferente da versão da cópia local se estiver a trabalhar sobre uma!)

Subversion → Geral → Mover (F2)

Move ou muda o nome de um item dentro de uma cópia local ou de um repositório

Subversion → Geral → Copiar (Ctrl+C)

Copia o item dentro de uma cópia local ou de um repositório

Subversion → Geral → Apagar os ficheiros/pastas seleccionados (Del)

Apaga os elementos seleccionados. Se estiver a trabalhar dentro de uma cópia local, deverá confirmar as suas remoções posteriormente.

Subversion → Geral → Nova pasta

Cria uma nova pasta.

Subversion → Geral → Importar as pastas para o actual

Selecciona as pastas que deseja importar para a pasta seleccionada de momento

Subversion → Geral → Extrair um repositório

Cria uma nova cópia local de um repositório

Subversion → Geral → Exportar um repositório

Exporta um repositório para o sistema de ficheiros, isto é cria uma árvore de versões limpa e sem qualquer informação do Subversion.

Subversion → Geral → Bloquear os itens actuais

Marca os itens actuais como bloqueados. Leia o manual do Subversion antes de usar esta opção!

Subversion → Geral → Desbloquear os itens actuais

Remove as marcações de bloqueio dos itens actuais. Leia o manual do Subversion antes de usar esta opção!

Cópia local

Subversion → Cópia local → Actualizar para o HEAD

Actualiza a cópia local para a última versão do repositório

Subversion → Cópia local → Actualizar para a versão...

Actualiza a cópia local para uma dada versão do repositório

Subversion → Cópia local → Enviar (Ctrl+#)

Envia as modificações na cópia local dos itens seleccionados para o repositório.

Subversion → Cópia local → Diferenças das modificações locais (Ctrl+D)

Mostra as alterações locais como resultado das diferenças (sem acesso à rede). Esta é a diferença apenas ao último estado para o qual foi actualizada a cópia local, e não face à versão no repositório.

Subversion → Cópia local → Diferenças para o HEAD (Ctrl+H)

Mostra as diferenças da cópia local actual para a última versão no repositório.

Subversion → Cópia local → Propriedades (Ctrl+P)

Ver/editar as propriedades atribuídas ao item actual.

Subversion → Cópia local → Adicionar os ficheiros/pastas seleccionados (Insert)

Adiciona os ficheiros e/ou pastas seleccionados ao controlo de versões.

Subversion → Cópia local → Reverter as alterações actuais

Anula as últimas alterações efectuadas sobre a cópia local e actualiza para o último estado de actualização.

Subversion → Cópia local → Marcar como resolvido

Marca os itens em conflito como resolvidos e remove os ficheiros associados aos conflitos.

Subversion → Cópia local → Reunir duas versões

Reune duas versões dos itens na cópia local.

Subversion → Cópia local → Ignorar/Aceitar o item actual

Edita a propriedade da pasta-mãe em relação ao item seleccionado de momento, de modo a que este item passe a ser ignorado pelo controlo de versões; caso contrário, remove-o da lista de itens a ignorar.

Subversion → Cópia local → Limpar

Limpa a cópia local de quaisquer ficheiros de envio bloqueados, se existirem

Subversion → Cópia local → Mudar de repositório

Muda o nó de topo da cópia local actual.

Repositório

Subversion → Repositório → Extrair a localização do repositório actual

Cria uma cópia local a partir do item seleccionado de momento, se for uma pasta.

Subversion → Repositório → Exportar a localização do repositório actual

Cria uma cópia limpa no sistema de ficheiros local do item seleccionado de momento, se for uma pasta.

Acções do 'Ver'

Subversion → Ver → Actualizar a janela (F5)

Actualiza o estado actual de todos os itens apresentados. Isto irá apresentar todos os itens com o estado actual.

Subversion → Ver → Expandir/Fechar a Árvore de Ficheiros

Expande ou recolhe a árvore de repositórios.

Subversion → 'Cache' do Registo → Parar a actualização da 'cache' do histórico

O registo histórico fica em 'cache' e é usado para mostrar a árvore de versões de um repositório. Dependendo da ligação à Internet, do tamanho do repositório de Subversion e do tamanho do histórico, isto poderá levar muito tempo. Como tal, poderá parar de actualizar a 'cache' com esta acção.

Subversion → Geral → Adicionar identidades do SSH ao ssh-agent

Grava a sua senha da chave de SSH para a sua sessão actual, para que não seja mais necessário introduzir a sua senha.

O Menu Base de Dados

Base de Dados → Mostrar o conteúdo da base de dados

Apresenta uma visão geral sobre o conteúdo da base de dados da 'cache' para os repositórios conhecidos e permite apagar a 'cache' ou o repositório e aceder às definições do mesmo.

Base de Dados → Configuração do repositório actual

Mostra uma janela para adaptar a configuração da 'cache', dos registos e das estatísticas.

Os Menus de Configuração e Ajuda

À parte dos menus de Configuração e Ajuda comuns do KDE, descritos nas secções dos menus de Configuração e Ajuda dos Fundamentos do KDE, o kdesvn tem este item de menu adicional:

Configuração → Configuração rápida
Carregar o último URL aberto no arranque

Volta a carregar o último URL aberto, caso não tenha sido indicado nenhum na linha de comandos.

Os registos seguem as mudanças dos nós

Mostrar os ficheiros ignorados

Mostrar os itens marcados no Subversion para serem ignorados ou não.

Mostrar os ficheiros desconhecidos

Mostrar os ficheiros por adicionar ao repositório do Subversion.

Esconder os ficheiros inalterados

Use esta acção para mostrar apenas os ficheiros alterados, dando uma visão geral clara e concisa.

Modo ligado

Se trabalhar desligado da rede, a 'cache' do registo histórico não será actualizada, pelo que o histórico em 'cache' poderá ser diferente do real.