Capitolo 3. Guida ai comandi

Panoramica

Questo capitolo fornisce spiegazioni dettagliate di tutti i comandi disponibili in KDE Partition Manager. È pensato per essere una guida di riferimento per accompagnare le informazioni contenute in Capitolo 2, Uso di KDE Partition Manager.

Il menu File

FileEsci (Ctrl+Q)

Termina l'esecuzione di KDE Partition Manager senza applicare alcuna delle operazioni pendenti. In caso di operazioni non ancora applicate, comunque, l'applicazione ti chiederà una conferma della scelta di uscire dal programma.

Il menu Modifica

ModificaAnnulla (Ctrl+Z)

Annulla l'ultima operazione che è stata aggiunta alla lista delle operazioni.

Questo comando è abilitato solo quando la lista delle operazioni non è vuota.

ModificaPulisci

Svuota la lista delle operazioni senza applicare nessuna di esse.

Questo comando è abilitato solo quando la lista delle operazioni non è vuota.

ModificaApplica

Applica la lista delle operazioni. Questo comando applicherà tutte le operazioni elencate nella lista, così che tutte le modifiche siano apportate permanentemente ai tuoi dischi. Al termine dell'esecuzione delle operazioni la lista sarà svuotata e non ci sarà modo per annullare nessuna delle modifiche.

Questo comando è abilitato solo quando la lista delle operazioni non è vuota.

Il menu Dispositivo

DispositivoSeleziona il dispositivo corrente

Ti consente di selezionare un dispositivo da un sottomenu con tutti i dispositivi disponibili del sistema.

DispositivoAggiorna i dispositivi (F5)

Aggiorna i dispositivi: questo comando forza KDE Partition Manager ad eseguire una nuova scansione e lettura dei dispositivi collegati al tuo computer. Questo potrebbe essere ad esempio utile nel caso tu abbia collegato un disco rigido USB dopo l'avvio di KDE Partition Manager.

DispositivoNuova tabella delle partizioni (Ctrl+Shift+N)

Crea una nuova tabella delle partizioni: questo comando crea sul dispositivo attualmente selezionato una nuova tabella GPT o MSDOS delle partizioni vuota. Tutte le partizioni sul dispositivo e tutti i dati in esse presenti saranno eliminati, quindi è bene usare questo comando con molta attenzione.

Questo comando è abilitato solo se è selezionato un dispositivo e non è attualmente montata nessuna partizione presente in esso.

DispositivoEsporta la tabella delle partizioni

Ti consente di esportare un elenco di partizioni nel dispositivo selezionato in un file.

DispositivoImporta la tabella delle partizioni

Ti consente di importa la tabella delle partizioni da un file esportato in precedenza.

Tutte le partizioni sul dispositivo e tutti i dati in esse presenti saranno eliminati, quindi è bene usare questo comando con molta attenzione.

Questo comando è abilitato solo se è selezionato un dispositivo e non è attualmente montata nessuna partizione presente in esso. L'importazione in dispositivi come i gruppi di volumi LVM non è attualmente supportata.

DispositivoStato SMART

Mostra un rapporto di SMART. SMART è un sistema di monitoraggio incluso nei dischi fissi e in quelli a stato solido che rileva e segnala utilizzando vari indicatori di affidabilità dell'unità, con l'intento di consentire la prevenzione di guasti hardware.

DispositivoProprietà

Mostra informazioni sui dispositivi attualmente selezionati. In questa finestra è possibile trovare la capacità, le dimensioni dei settori, il tipo di tabella delle partizioni, così come il numero utilizzato e massimo di partizioni primarie.

Il menu Partizione

PartizioneNuova (Ctrl+N)

Crea una nuova partizione: apre la finestra per la creazione di una nuova partizione, nella quale potrai impostare tipo, dimensione, posizione e file system della partizione che desideri creare.

Tieni presente che la tabella delle partizioni di un dispositivo può imporre restrizioni alla creazione di partizioni. La tabelle delle partizioni MS-DOS, ad esempio, ammettono solo quattro partizioni primarie.

Questo comando è abilitato solo se viene selezionata un'area del dispositivo non ancora allocata.

PartizioneRidimensiona/Sposta (Ctrl+R)

Ridimensiona o sposta una partizione: apre la finestra per il ridimensionamento o lo spostamento di una partizione esistente. A seconda del file system della partizione e degli strumenti esterni installati sul tuo computer, potrebbero non essere disponibili nella finestra tutte e tre le possibili azioni legate al ridimensionamento: lo spostamento della partizione, la sua riduzione («restringimento») o il suo ampliamento («allargamento»). Vedi StrumentiFile system supportati .

Questo comando è abilitato solo se è selezionata una partizione che non è attualmente montata ed il cui file system può essere ristretto, allargato o spostato. Per una partizione estesa, esso è abilitato solo se non è montata nessuna delle partizioni logiche presenti al suo interno.

PartizioneElimina (Canc)

Elimina una partizione: questo comando elimina la partizione attualmente selezionata.

Questo comando è abilitato solo se è selezionata una partizione attualmente non montata. Nel caso di una partizione estesa, esso è abilitato solo se essa non contiene alcuna partizione logica.

Attenzione: possibile perdita di dati

Eliminare una partizione significa che tutti i dati sulla partizione vengono distrutti.

PartizioneDistruggi (Ctrl+Canc)

Distrugge una partizione: questo comando distrugge la partizione attualmente selezionata.

Questo comando è abilitato solo se è selezionata una partizione attualmente non montata. Nel caso di una partizione estesa, esso è abilitato solo se essa non contiene alcuna partizione logica.

Attenzione: perdita di dati

Distruggere una partizione significa che tutti i dati sulla partizione saranno distrutti.

PartizioneCopia (Ctrl+C)

Copia una partizione: questo comando copia la partizione selezionata negli appunti di KDE Partition Manager.

Questo comando è abilitato solo se è selezionata una partizione attualmente non montata ed il cui file system può essere copiato. Le partizioni estese non possono essere copiate.

PartizioneIncolla (Ctrl+V)

Incolla una partizione: questo comando incolla la partizione dagli appunti di KDE Partition Manager nella partizione o nell'area non allocata attualmente selezionata.

Quando l'operazione avvenga verso un'area non allocata, verrà mostrata una finestra che ti consente di spostare o di ingrandire la copia inserita. Nel caso in cui sia sovrascritta una partizione esistente, invece, questa finestra non comparirà.

Questo comando è abilitato solo se negli appunti è attualmente presente una partizione e viene selezionata una destinazione valida (una partizione oppure un'area non allocata). La destinazione deve anche essere abbastanza capiente per contenere la partizione originaria, e non può essere montata. Non puoi copiare una partizione su se stessa.

Attenzione: possibile perdita di dati

Incollare una partizione su un'altra già esistente vuol dire che tutti i dati nella partizione esistente vengono distrutti e sostituiti con i dati presenti nella partizione incollata.

PartizioneModifica punto di montaggio

Apre una finestra per modificare il punto di montaggio e le opzioni relative.

Questo comando è abilitato solo se una partizione è smontata.

PartizioneMonta/smonta

Monta o smonta una partizione: questo comando monta oppure smonta la partizione selezionata, a seconda del suo stato attuale.

Questo comando è abilitato solo se è selezionata una partizione che possa essere montata o smontata. Se il sistema operativo non conosce un punto di montaggio per la partizione, non ti sarà possibile montarla in KDE Partition Manager.

PartizioneVerifica

Verifica una partizione: questo comando esegue una verifica della partizione selezionata e del suo file system alla ricerca di errori, e tenta di correggere i problemi eventualmente rilevati. Durante il processo, inoltre, il file system della partizione viene ridimensionato in modo da riempire completamente la partizione.

Questo comando è abilitato solo se è selezionata una partizione che possa essere verificata e che non sia attualmente montata.

PartizioneCopia di sicurezza

Esegue una copia di sicurezza della partizione: questo comando salva in un file una copia di sicurezza del file system presente nella partizione selezionata. Dopo l'attivazione del comando ti verrà chiesto dove salvare il file contenente l'immagine.

Il file immagine creato è una copia settore per settore del file system presente nella partizione. Non è compresso e non contiene meta informazioni o intestazioni aggiuntive: se il sistema operativo supporta l'operazione, è quindi possibile montarlo direttamente, utilizzando un loop device, al di fuori di KDE Partition Manager, se il sistema operativo lo supporta

Questo comando è abilitato solo se è selezionata una partizione del cui file system possa essere creata una copia di sicurezza. La partizione, inoltre, non deve essere montata.

PartizioneRipristina

Ripristina una partizione: questo comando esegue il ripristino di un file system da un file immagine ad una partizione. Dopo aver attivato il comando, ti verrà chiesto il nome del file immagine da ripristinare. La partizione destinazione in cui deve avvenire il ripristino deve essere sufficientemente grande per il file immagine.

Il comando è abilitato solo se è selezionata un'area non allocata oppure una partizione che non è attualmente montata.

Attenzione: possibile perdita di dati

Effettuare il ripristino di una partizione su di una già esistente comporta che tutti i dati nella partizione esistente siano distrutti e sostituiti con i dati contenuti nel file immagine che viene ripristinato.

PartizioneProprietà

Mostra le proprietà di una partizione: questo comando visualizza una finestra contenente informazioni sulla partizione o sullo spazio non allocato attualmente selezionati.

Ciò che viene visualizzato e ciò che può essere modificato in questa finestra dipende dal tipo di partizione, dal tipo di file system su di essa e dal fatto che la partizione sia montata oppure no.

Non tutti i file system, ad esempio, supportano la definizione di un'etichetta. Di solito, inoltre, non è possibile modificare alcuna proprietà se la partizione è montata.

Questa è una lista di tutte le proprietà delle partizioni e dei file system che generalmente possono essere modificate per mezzo della finestra:

  • Impostare o modificare un'etichetta di file system

  • Modificare il file system della partizione.

    Attenzione: possibile perdita di dati

    Modificare il file system di una partizione comporta sempre la distruzione di tutti i dati in essa presenti.

  • Ricreare il file system sulla partizione

    Attenzione: possibile perdita di dati

    Rigenerare il file system su una partizione comporta sempre la distruzione di tutti i dati presenti in essa. La rigenerazione del file system dovrebbe essere usata solo come estrema risorsa, nel caso in cui il file system su una partizione non possa essere riparato in alcun modo.

  • Modificare i parametri di una partizione

    A seconda del tipo di tabella delle partizioni utilizzato, sarà disponibile una serie di parametri per ciascuna partizione nella tabella delle partizioni. Nella maggior parte dei casi la modifica dei parametri non è necessaria, e dovrebbe essere considerata una funzionalità avanzata.

Il comando è abilitato solo se sono selezionate un'area non allocata oppure una partizione.

Il menu Strumenti

StrumentiNuovo gruppo di volumi (Ctrl+Shift+L)

Crea un nuovo dispositivo logico come gruppo di volumi LVM.

StrumentiFile system supportati

Visualizza la finestra dei file system supportati. La finestra mostra nel dettaglio quali operazioni possono essere eseguite per i singoli file system supportati.

Ecco un esempio di come potrebbe apparire la finestra con la maggior parte degli strumenti esterni installata:

Finestra dei file system supportati, con la maggior parte degli strumenti esterni installata

I segni di spunta blu significano «supportato», le croci rosse «non supportato». Alcune combinazioni non sono mai supportate (ad esempio, verificare un file system linuxswap) perché esse sono intrinsecamente impossibili. Altre non possono essere supportate perché gli strumenti esterni sono privi della relativa funzionalità.

Se hai installato nuovi strumenti mentre KDE Partition Manager è in esecuzione, fai clic su Nuova analisi del supporto per forzare una nuova verifica degli strumenti di supporto dei file system installati.

I menu Impostazioni e Aiuto

KDE Partition Manager ha gli elementi comuni dei menu di KDE Impostazioni e Aiuto; descritti nei fondamentali di KDE con un sottomenu aggiuntivo Pannelli mostrati, dove è possibile alternare la visualizzazione di Dispositivi, Operazioni in attesa, Informazioni e i pannelli Risultato del registro.