Chapitre 3. Référence des commandes

Vue d'ensemble

Ce chapitre fournit des explications détaillées de toutes les commandes disponibles dans le gestionnaire de partitions de KDE. Il est prévu pour servir de référence en complément des informations données dans le Chapitre 2, Utilisation du gestionnaire de partitions de KDE.

Le menu Fichier

FichierQuitter (Ctrl+Q)

Quitte le gestionnaire de partitions de KDE sans appliquer aucune opération en attente. L'application vous demandera cependant de confirmer votre choix de quitter s'il existe des opérations en attente.

Le menu Édition

ÉditionAnnuler (Ctrl+Z)

Annule la dernière opération qui a été ajoutée à la pile des opérations.

Cette commande est activée uniquement si la liste des opérations n'est pas vide.

ÉditionEffacer

Efface la liste des opérations sans appliquer aucune d'entre elles.

Cette commande est activée uniquement si la liste des opérations n'est pas vide.

ÉditionAppliquer

Applique la liste des opérations. Cette commande appliquera toutes les opérations de la liste pour que tous les changements soient écrits de façon permanente sur vos disques. Après que les opérations ont été appliquées, la liste est effacée et il n'existe plus aucun moyen d'annuler une quelconque opération.

Cette commande est activée uniquement si la liste des opérations n'est pas vide.

Le menu Périphérique

PériphériqueSélectionner le périphérique courant

Vous permet de sélectionner un périphérique dans un sous-menu contenant tous les périphériques disponibles du système.

PériphériqueRafraîchir la liste des périphériques (F5)

Rafraîchit la liste des périphériques : cette commande force le gestionnaire de partitions de KDE à analyser et lire à nouveau la liste des périphériques présents sur votre ordinateur. Elle peut s'avérer utile par exemple si vous avez connecté à chaud un disque dur USB externe après avoir démarré le gestionnaire de partitions de KDE.

PériphériqueNouvelle table de partitions (Ctrl+Maj+N)

Crée une nouvelle table de partitions : cette commande crée une nouvelle table vide de partitions « GPT » ou « MSDOS » sur le périphérique actuellement sélectionné. Ceci supprimera toutes les partitions sur le périphérique ainsi que toutes les données qui s'y trouvent. Ainsi, vous aurez tout intérêt à être prudent avec cette commande.

Cette commande est activée uniquement si un périphérique est sélectionné et qu'il n'existe aucune partition actuellement montée sur celui-ci.

PériphériqueExporter la table de partitions

Vous permet d'exporter dans un fichier une liste de toutes les partitions du périphérique sélectionné.

PériphériqueImport la table des partitions

Vous permet d'importer une table de partition à partir d'un fichier précédemment exporté.

Ceci supprimera toutes les partitions sur le périphérique ainsi que toutes les données qui s'y trouvent. Ainsi, vous aurez tout intérêt à être prudent avec cette commande.

Cette commande n'est activée que si un périphérique est sélectionné et qu'aucune partition sur ce périphérique n'est actuellement montée. L'importation dans des périphériques logiques tels que les groupes de volumes « LVM » n'est actuellement pas prise en charge.

PériphériqueÉtat SMART

Affiche un rapport SMART. SMART est un système de surveillance intégré dans les disques durs et les lecteurs à semi-conducteurs, détectant et établissant des rapports sur divers indicateurs de fiabilité du lecteur, dans le but de permettre l'anticipation des défaillances matérielles.

PériphériquePropriétés

Affiche des informations sur les périphériques actuellement sélectionnés. Dans cette boite de dialogue, vous pouvez trouver la capacité, les tailles des secteurs, le type de table de partitions ainsi que le nombre utilisé et maximal de partitions primaires.

Le menu Partitions

PartitionNouvelle (Ctrl+N)

Crée une nouvelle partition : ouvre la boite de dialogue permettant de créer une nouvelle partition où vous pourrez définir le type, la taille, la position et le système de fichiers de la partition à créer.

Veuillez noter que la table de partitions présente sur un périphérique peut imposer des restrictions concernant le nombre de partitions qu'il est possible de créer. Les tables de partitions MS-DOS, par exemple, n'autorisent que quatre partitions primaires.

Cette commande est activée uniquement si une zone non allouée sur un périphérique est sélectionnée.

PartitionRedimensionner/Déplacer (Ctrl+R)

Redimensionne ou déplace une partition : ouvre la boite de dialogue permettant de redimensionner ou déplacer une partition existante. Selon le système de fichiers de la partition et les outils externes installés sur votre ordinateur, il se peut que les trois actions possibles liées au redimensionnement -- c'est-à-dire déplacer la partition, la rendre plus petite (la « réduire ») ou la rendre plus grande (l'« agrandir ») -- ne soient pas disponibles dans cette boite de dialogue.Veuillez consultez la section OutilsPrise en charge des systèmes de fichiers .

Cette commande est activée uniquement si une partition est sélectionnée, qui n'est pas actuellement montée et dont le système de fichiers peut être réduit, agrandi ou déplacé. Pour une partition étendue, elle n'est activée que si aucune des partitions logiques contenues dans la partition étendue n'est montée.

PartitionsSupprimer (Del)

Supprime une partition : cette commande supprime la partition actuellement sélectionnée.

Cette commande est activée uniquement si une partition est sélectionnée, qui n'est pas actuellement montée. Pour une partition étendue, elle n'est activée que si aucune des partitions logiques contenues dans la partition étendue n'est montée.

Avertissement : perte de données possible

Supprimer une partition signifie que toutes les données présentes sur la partition sont détruites.

PartitionsFormater (Ctrl+Del)

Formate une partition : cette commande formate la partition actuellement sélectionnée.

Cette commande est activée uniquement si une partition est sélectionnée, qui n'est pas actuellement montée. Pour une partition étendue, elle n'est activée que si aucune des partitions logiques contenues dans la partition étendue n'est montée.

Avertissement : perte possible de données

La réduction de taille d'une partition implique que toutes les données présentes sur la partition seront détruites.

PartitionCopier (Ctrl+C)

Copie une partition : cette commande copie la partition actuellement sélectionnée dans le presse-papiers du gestionnaire de partitions de KDE.

Cette commande est activée uniquement si une partition est sélectionnée, qui n'est pas actuellement montée et dont le système de fichiers peut être copié. Il n'est pas possible de copier des partitions étendues.

PartitionColler (Ctrl+V)

Colle une partition : cette commande colle la partition depuis le presse-papiers du gestionnaire de partitions de KDE vers la partition actuellement sélectionnée ou une zone non allouée.

Lorsqu'on colle une partition dans une zone non allouée, une boite de dialogue apparait, permettant de déplacer ou d'agrandir la copie insérée. Cette boite de dialogue ne s'affiche pas lors de l'écrasement d'une partition existante.

Cette commande est activée uniquement si une partition se trouve actuellement dans le presse-papiers et qu'une cible valable (soit une partition, soit une zone non allouée) est sélectionnée. La cible doit de plus être assez grande pour contenir la source et il ne faut pas qu'elle soit montée. Il est impossible de copier une partition sur elle-même.

Avertissement : perte de données possible

Coller une partition sur une partition existante signifie que toutes les données présentes sur la partition existante sont détruites et remplacées par les données provenant de la partition collée.

PartitionModifier le point de montage

Ouvre une boite de dialogue pour modifier le point de montage et les options de montage.

Cette commande n'est activée que si la partition est libérée.

PartitionMonter / Libérer

Monte ou libère une partition : cette commande monte ou libère la partition sélectionnée, en fonction de son état courant.

Cette commande est activée uniquement si une partition est sélectionnée, qui peut être montée ou libérée. Si le système d'exploitation ne connaît pas de point de montage pour la partition en question, il est impossible de la monter depuis le gestionnaire de partitions de KDE.

PartitionVérifier

Vérifie une partition : cette commande vérifie s'il existe des erreurs sur la partition sélectionnée ainsi que son système de fichiers, et essaie de résoudre tout problème qu'elle rencontre. Pendant ce processus, le système de fichiers présent sur la partition sera également redimensionné de façon à remplir entièrement la partition.

Cette commande est activée uniquement si une partition est sélectionnée, qui peut être vérifiée et n'est pas actuellement montée.

PartitionSauvegarder

Enregistre une partition : cette commande enregistre dans un fichier le système de fichiers présent sur la partition sélectionnée. Une boite de dialogue vous demandera où enregistrer le ficher image après activation de cette commande.

Le fichier « image » créé est une copie secteur par secteur du système de fichiers installé sur la partition. Il 'est pas comprimé et ne comporte aucune métadonnée supplémentaire et aucune en-tête ajoutée. Ainsi, il peut être directement monter à l'aide d'un périphérique « loop », en dehors de gestionnaire de partitions de KDE, si le système d'exploitation prend en charge cette fonction.

Cette commande est activée uniquement si une partition est sélectionnée et qu'on peut enregistrer le système de fichiers installé dessus. Il faut aussi que la partition ne soit pas montée.

PartitionRestaurer

Restaure une partition : cette commande restaure un système de fichiers à partir d'un fichier image vers une partition. Une boite de dialogue vous demandera le nom du fichier image à restaurer après activation de cette commande. La cible dans laquelle sera effectuée la restauration doit être assez grande pour le fichier image.

Cette commande est activée uniquement soit si une zone non allouée soit une partition, qui n'est pas actuellement montée, est sélectionnée.

Avertissement : perte de données possible

Restaurer une partition sur une partition existante signifie que toutes les données contenues dans la partition existante sont détruites et remplacées par les données provenant du fichier image restauré.

PartitionPropriétés

Affiche les propriétés d'une partition : cette commande affiche une boite de dialogue comportant des informations sur la partition actuellement sélectionnée ou l'espace non alloué.

La nature de ce qui est affiché et de ce qu'on peut modifier dans cette boite de dialogue dépend du type de partition, du type du système de fichiers présent sur cette partition et si la partition est actuellement montée ou non.

Tous les systèmes de fichiers, par exemple, ne prennent pas en charge la mise en place d'une étiquette. Il n'est en outre généralement pas possible de modifier quelque propriété que ce soit si la partition est montée.

Voici une liste de toutes les propriétés des partitions et des systèmes de fichiers qu'on peut en général modifier dans cette boite de dialogue :

  • Définir ou modifier l'étiquette d'un système de fichiers

  • Changer le système de fichiers de la partition

    Avertissement : perte de données possible

    Changer le système de fichiers d'une partition signifie toujours que toutes les données présentes sur la partition sont détruites.

  • Recréer le système de fichiers sur la partition

    Avertissement : perte de données possible

    Recréer un système de fichiers sur une partition signifie toujours que toutes les données contenues sur la partition sont détruites. Il ne faudra utiliser la re-création d'un système de fichiers qu'en dernier recours s'il n'est plus possible de réparer le système de fichiers sur une partition.

  • Changer les drapeaux d'une partition

    Selon le type de la table de partitions utilisée, il existe plusieurs drapeaux disponibles pour chaque partition sur la table des partitions. Dans la majorité des cas, modifier les drapeaux n'est pas nécessaire et devra être considéré comme une fonctionnalité avancée.

Cette commande est activée uniquement si soit une zone non allouée, soit une partition, est sélectionnée.

Les menus Outils

OutilsNouveau groupe de volumes (Ctrl+Maj+L)

Créer un nouveau périphérique logique tel que le groupe de volumes LVM.

OutilsPrise en charge des systèmes de fichiers

Affiche la boite de dialogue de prise en charge des systèmes de fichiers Cette boite de dialogue affiche en détail les opérations pouvant être effectuées pour tels ou tels systèmes de fichiers.

Voici un exemple de ce à quoi la boite de dialogue pourrait ressembler avec la plupart des outils externes installés :

La boite de dialogue de prise en charge des systèmes de fichiers avec la plupart des outils externes installés

Les coches en bleu signifient « pris en charge », les croix en rouge « non pris en charge ». Certaines combinaisons ne sont jamais prises en charge, par exemple la vérification d'un système de fichiers « linuxswap », car elles sont par nature impossibles. D'autres sont impossibles à prendre en charge car les outils externes ne disposent pas de la fonctionnalité.

Si vous avez installé de nouveaux outils pendant que le gestionnaire de partitions de KDE fonctionne, cliquez sur Analyser à nouveau la prise en charge pour forcer un nouveau contrôle des outils de prise en charge des systèmes de fichiers installés.

Le menu de configuration et d'aide

gestionnaire de partitions de KDE possède les menus communs de KDE Configuration et Aide, décrits dans les fondamentaux de KDE, ainsi qu'un sous-menu supplémentaire Panneaux affichés, où vous pouvez activer et désactiver l'affichage des panneaux Périphériques, Opérations en attente, Informations et Affichage de journaux.