Mode affichage

Le mode « Affichage » permet l'affichage des images en taille réelle. La même barre latérale que celle disponible en mode « Navigation » est affichée à gauche. En bas, se trouve la barre de vignettes, vous permettant de vous déplacer dans les images du dossier actuel. La barre de vignettes peut être développée par un clic sur le bouton Afficher les vignettes. Un nouveau clic la repliera. Pour modifier la taille des vignettes, veuillez déplacer le séparateur avec le bouton gauche de la souris.

Le mode affichage permet d'afficher plusieurs images côte à côte simultanément. Vous pouvez sélectionner plusieurs images en mode navigation avant de basculer en mode affichage. Vous pouvez également cliquer sur le bouton + (qui apparait lorsque le pointeur de la souris passe au-dessus d'une image) dans la barre des vignettes pour ajouter un panneau affichant cette image. Un - apparait alors, vous permettant d'enlever ce panneau.

Lorsque plusieurs images sont affichées, une petite barre d'outils apparait en dessous de chaque image, vous permettant de supprimer l'image, ou d'enlever son panneau. Vous pouvez zoomer chaque image de manière indépendante, ou les synchroniser, en cochant Synchroniser à gauche du curseur de zoom, ou en appuyant sur Ctrl+Y. Vous pouvez passer d'une image à l'autre en cliquant sur son panneau, ou en utilisant le clavier. Pour passer à l'image à droite, appuyez sur Tab. Pour passer à l'image de gauche, appuyez sur Maj+Tab.

Le curseur en bas à droite contrôle le zoom de l'image. Le bouton Ajuster, Remplir et le bouton 100 % se trouvent près du curseur de zoom et correspondent à trois niveaux de zoom prédéfinis. Le bouton Ajuster réalise un zoom de l'image actuelle pour l'ajuster aux dimensions de la fenêtre. Le bouton Remplir réalise un zoom de l'image actuelle pour remplir la fenêtre en largeur ou en hauteur. Le bouton 100 % réalise un zoom de l'image actuelle à la taille réelle en pixels. Le raccourci F permet de basculer entre les modes Ajuster et 100%. Un appui sur les touches Maj+F basculera le mode Remplir respectivement entre hauteur et largeur.

Lorsqu'une image est en mode zoomer pour ajuster, vous pouvez vous déplacer vers l'image suivante ou précédente en utilisant les touches fléchées. Lorsque vous zoomez, les flèches sont utilisées pour se déplacer dans l'image. C'est un comportement très similaire à celui des téléphones ou appareils photos.

Lorsqu'une image est agrandie, un affichage en vue aérienne apparait et vous permet de faire défiler l'image en utilisant la souris et les touches de flèches. L'affichage en vue aérienne se masque automatiquement après un court délai et ne s'affiche que lors d'un zoom ou d'un défilement. L'affichage en vue aérienne peut être désactivée à partir d'un clic droit pour afficher le menu contextuel ou à partir de Affichage → Affichage en vue aérienne lors d'un zoom avant

Vous pouvez définir que si se produit lorsque vous allez vers l'image B après avoir zoomé sur une zone de l'image A en utilisant les options dans le groupe Mode de zoom de la page Vue par image dans la fenêtre de configuration de Gwenview. Cette fenêtre peut être appelée en utilisant le menu Configuration → Configurer Gwenview....

  • Si réglé sur Ajuster automatiquement chaque image, l'image B est dézoomée pour s'ajuster à l'écran.

  • Si réglé sur Conserver le zoom et la position, toutes les images partagent le même zoom et la même position : l'image B est réglée sur le même zoom que l'image A (et s'il y a des modifications, l'image A sera alors affichée en tenant compte du nouveau zoom et de la nouvelle position).

  • Si réglé sur Zoom et position par image, toutes les images se souviendront de leur propres zoom et position : l'image B est initialement réglée sur le même zoom que l'image B, mais se souviendra alors de son propre zoom et de sa propre position (s'ils sont changés, l'image A ne sera pas affichée avec le nouveau zoom et la nouvelle position).

Astuce

Vous pouvez démarrer directement dans le mode affichage en démarrant Gwenview depuis un menu contextuel comme Ouvrir avec dans un autre programme, ou en le lançant depuis la ligne de commande avec une image comme argument.

Les opérations sur les images suivantes ne sont disponibles qu'on mode affichage :

  • Édition → Rogner (Maj+C) : cette opération vous permet d'éliminer des parties de l'image dont vous ne voulez pas.

    Vous pouvez accéder à la configuration avancée du rognage en cochant Configuration avancée dans le panneau qui apparait en bas. Utilisez les champs correspondants pour régler finement l'opération de rognage.

    Il est également possible d'ajuster la zone de rognage en glissant les poignées carrées grises sur les bords de l'image. Vous pouvez déplacer la zone à rogner en cliquant, puis en maintenant le bouton gauche de la souris enfoncé, et en déplaçant le pointeur de la souris.

    Appuyez sur le bouton Rogner pour voir le résultat lorsque vous êtes prêt(e). Utilisez le panneau qui apparait en haut pour enregistrer le résultat ou annuler / refaire l'opération.

  • Édition → Anti-yeux rouges : cette opération réduit l'effet « Yeux rouges » couramment rencontré dans les photos prises avec un flash.