Capitolo 2. Guida ai comandi

La barra dei menu

La barra dei menu è in cima alla finestra di Konsole. Se la barra è nascosta, Mostra barra dei menu è raggiungibile facendo clic destro nella finestra (fintanto che in quella finestra non c'è un'applicazione che occupa tutto lo schermo, come vi, minicom, eccetera). La scorciatoia predefinita viene elencata a seguito di ogni elemento del menu.

In alternativa, è possibile utilizzare la scorciatoia Ctrl+Shift+M per mostrare o nascondere la barra dei menu.

Il menu File

FileNuova finestra (Ctrl+Shift+N)

Apre una nuova finestra di Konsole a parte con il profilo predefinito.

FileNuova scheda (Ctrl+Shift+T)

Apre una nuova scheda con il profilo predefinito.

Nota

Konsole fornisce un profilo predefinito. Ogni nuovo profilo aggiunto dall'utente sarà elencato nel sottomenu. Non ci sarà alcun sottomenu se c'è da mostrare solo il profilo predefinito.

FileClona scheda

Prova a clonare la scheda attuale in un'altra.

FileSave output come... (Ctrl+Shift+S)

Salva lo scorrimento attuale come file di testo o HTML.

FileStampa schermo (Ctrl+Shift+P)

Stampa lo schermo attuale. Come impostazione predefinita, l'output viene adattato alle dimensioni della carta su cui si stampa con testo in nero e senza sfondo. Nella finestra di stampa queste opzioni sono modificabili nella scheda Opzioni di output.

FileApri gestore dei file

Apre il gestore dei file di KDE nella cartella attuale. Come impostazione predefinita, è Dolphin.

FileChiudi scheda (Ctrl+Shift+W)

Chiude la scheda attuale.

FileChiudi finestra (Ctrl+Shift+Q)

Esce da Konsole.

Nota

Konsole mostrerà una finestra di conferma se c'è più di una scheda aperta. Questa finestra può essere disabilitata facendo clic sulla casella Non chiedermelo più.

Se si desidera ricevere nuovamente la finestra di conferma, eliminare la voce

[Notification Messages]
CloseAllTabs=true

in $XDG_CONFIG_HOME/konsolerc.

Il menu Modifica

ModificaCopia (Ctrl+Shift+C)

Copia il testo selezionato agli appunti.

ModificaIncolla (Ctrl+Shift+V)

Incolla il testo dagli appunti alla posizione del cursore.

ModificaSeleziona tutto

Seleziona tutto il testo nella finestra attuale.

ModificaCopia input aTutte le schede nella finestra attuale

Invia simultaneamente l'input della sessione attuale a tutte le sessioni nella finestra attuale.

ModificaCopia input aSeleziona schede (Ctrl+Shift+.)

Invia simultaneamente l'input della sessione attuale alle sessioni scelte dall'utente.

ModificaCopia input aNessuna (Ctrl+Shift+/)

Ferma l'invio dell'input dalla sessione attuale nelle altre

ModificaInvia segnale

Manda il segnale specificato al processo shell, o altro processo, che è stato lanciato quando è stata avviata la nuova sessione.

I segnali attualmente disponibili sono:

STOPper fermare il processo
CONTcontinua se fermato
HUPhangup rilevato sul terminale di controllo, o morte del processo controllante
INTinterruzione da tastiera
TERMsegnale di terminazione
KILLsegnale di uccisione
USR1segnale utente 1
USR2segnale utente 2

Riferisciti alle pagine di manuale del tuo sistema per ulteriori dettagli dando il comando man 7 signal.

ModificaRinomina scheda (Ctrl+Alt+S)

Apre una finestra che permette di cambiare il nome della scheda attuale (maggiori informazioni).

ModificaInvia con ZModem (Ctrl+Alt+U)

Apre una finestra per selezionare un file da inviare se il software richiesto è installato.

ModificaTrova (Ctrl+Shift+F)

Apre una barra di ricerca in fondo alla finestra di Konsole.

Permette ricerche con distinzione di maiuscole, in avanti o all'indietro, e con espressioni regolari.

ModificaTrova successivo (F3)

Sposta alla successiva istanza di ricerca. Se la barra di ricerca ha il focus, è possibile utilizzare anche la scorciatoia Invio.

ModificaTrova precedente (Shift+F3)

Sposta alla precedente istanza di ricerca. Se la barra di ricerca ha il focus, è possibile utilizzare anche la scorciatoia Shift+Invio.

Il menu Visualizza

VisualizzaDividi vistaDividi vista destra/sinistra (Ctrl+()

Divide tutte le schede in viste a destra e a sinistra.

Tutto l'output su una vista viene duplicato sull'altra.

VisualizzaDividi vistaDividi vista alto/basso (Ctrl+))

Divide tutte le schede in viste il alto e in basso.

Tutto l'output su una vista viene duplicato sull'altra.

VisualizzaDividi vistaChiudi attiva (Ctrl+Shift+X)

Chiude la vista attuale.

VisualizzaDividi vistaChiudi altre (Ctrl+Shift+O)

Chiude tutte le viste diverse dall'attuale.

VisualizzaDividi vistaEspandi vista (Ctrl+Shift+])

Allarga la vista attuale.

VisualizzaDividi vistaRestringi vista (Ctrl+Shift+[)

Rimpicciolisce la vista attuale.

VisualizzaStacca la scheda attuale (Ctrl+Shift+L)

Apre la scheda attuale in una finestra a parte.

L'uscita dalla finestra precedente di Konsole non avrà effetto sulla nuova finestra creata.

VisualizzaStacca la vista attuale (Ctrl+Shift+H)

Apre la vista divisa attuale in una finestra separata

VisualizzaControlla se c'è silenzio (Ctrl+Shift+I)

Commuta la rilevazione di mancanza di attività nella scheda attuale.

Come impostazione predefinita, dopo 10 secondi di inattività, appare un'icona informativa nella linguetta della sessione. Il tipo di avvisi può essere cambiato con ImpostazioniConfigura le notificheSilenzio rilevato in una sessione sorvegliata.

VisualizzaControlla se c'è attività (Ctrl+Shift+A)

Commuta la rilevazione di attività nella scheda attuale.

A seguito di qualsiasi attività, appare un'icona informativa nella linguetta della sessione. Il tipo di avvisi può essere cambiato con ImpostazioniConfigura le notificheAttività rilevata in una sessione sorvegliata.

VisualizzaSola lettura

Commuta la sessione in sola lettura: non è accettato alcun inserimento, il trascinamento e rilascio è disabilitato.

VisualizzaIngrandisci carattere (Ctrl++)

Aumenta la dimensione dei caratteri del testo.

VisualizzaRipristina la dimensione dei caratteri (Ctrl+0)

Ripristinare la dimensione dei caratteri del testo ai valori predefiniti del profilo.

VisualizzaRimpicciolisci carattere (Ctrl+-)

Riduce la dimensione dei caratteri del testo

VisualizzaImposta codifica

Imposta la codifica dei caratteri.

VisualizzaPulisci scorrimento

Rimuove il testo dallo scorrimento.

VisualizzaPulisci scorrimento e azzera (Ctrl+Shift+K)

Rimuove il testo nella scheda attuale e nello scorrimento, e azzera il terminale.

Il menu Segnalibri

SegnalibriAggiungi segnalibro (Ctrl+Shift+B)

Aggiunge l'indirizzo attuale.

SegnalibriAggiungi le schede come cartella

Aggiunge tutte le schede a una cartella di segnalibri.

Verrà chiesto il nome della cartella di segnalibri.

SegnalibriNuova cartella di segnalibri

Aggiunge una nuova cartella all'elenco dei segnalibri.

Verrà chiesto il nome della cartella di segnalibri.

SegnalibriModifica segnalibri

Apre l'editor dei segnalibri.

Nota

Il programma keditbookmarks deve essere installato affinché questa voce di menu appaia.

Puoi usare l'editor dei segnalibri per aggiungere manualmente URL. Attualmente Konsole accetta le seguenti:

  • ssh://utente@host:porta

  • telnet://utente@host:porta

Il menu Impostazioni

ImpostazioniModifica il profilo attuale

Apre una finestra per configurare il profilo attuale.

ImpostazioniCambia profilo

Cambia il profilo attuale a uno elencato

ImpostazioniGestisci profili

Apre un editor per gestire i profili.

ImpostazioniMostra la barra dei menu (Ctrl+Shift+M)

Commuta la visibilità della barra dei menu.

ImpostazioniModalità a schermo intero (F11)

Commuta la visualizzazione di Konsole su tutto lo schermo.

ImpostazioniConfigura le scorciatoie

Apre l'editor delle scorciatoie da tastiera. Altre informazioni sulla configurazione delle scorciatoie sono disponibili nei Fondamenti di KDE.

In aggiunta, Konsole ha alcune scorciatoie speciali alle quali non corrispondono voci di menu:

ScorciatoiaDescrizione
Shift+DestraScheda successiva
Shift+SinistraScheda precedente
Ctrl+Shift+SinistraSpostare una scheda a sinistra
Ctrl+Shift+DestraSpostare una scheda a destra
Ctrl+Shift+InsIncolla selezione
Shift+TabContenitore di viste successivo
ImpostazioniConfigura le notifiche

Apre l'editor delle notifiche.

ImpostazioniConfigura Konsole

Apre l'editor delle impostazioni di Konsole.

Questa finestra contiene opzioni che influenzano l'aspetto e il comportamento della Barra delle schede e opzioni generali della finestra di Konsole.

Il menu Aiuto

Konsole ha alcuni dei normali elementi del menu di KDE Aiuto; per maggiori informazioni leggere le sezioni sul menu Aiuto dei Fondamentali di KDE.