The KMail Handbook

Daniel Naber
David Rugge
Laurent Montel
Scarlett Clark
Contents

1 Introduction ................................................................. 9
  1.1 Some KMail Features .................................................. 9
  1.1.1 Getting Help ....................................................... 10

2 Getting Started ........................................................... 11
  2.1 Account Wizard ....................................................... 11
  2.2 Manual Configuration Quickstart .................................... 12
    2.2.1 Setting your Identity ........................................... 13
    2.2.2 Setting up your Account ....................................... 13
      2.2.2.1 Sending Messages .......................................... 13
      2.2.2.2 Options relevant to Kolab server ....................... 13
    2.2.3 Receiving Messages ............................................ 13
      2.2.3.1 Options only relevant to IMAP .......................... 14
      2.2.3.2 Options only relevant to POP3 ......................... 14
      2.2.3.3 Options for both IMAP and POP3 ....................... 14
  2.3 Testing your Setup .................................................. 15

3 Using KMail .............................................................. 16
  3.1 The Main Window .................................................... 16
  3.2 Keyboard Shortcuts ................................................ 18
  3.3 The Composer Window .............................................. 19
    3.3.1 Composing a Message ........................................ 19
    3.3.2 Signing and Encrypting Messages ............................ 20
    3.3.3 Creating HTML Messages .................................... 21
    3.3.4 Adding Attachments ......................................... 21
    3.3.5 Checking the Spelling of your Message ................... 22
    3.3.6 Setting Up the Text Snippets Tool ......................... 22
    3.3.7 Using the Built-in Translator ............................... 22
  3.4 Message Folders ................................................... 23
    3.4.1 Creating and Using Folders ................................ 24
    3.4.2 Folder Properties ............................................ 25
3.4.2.1 General ................................................. 25
3.4.2.2 View .................................................. 26
3.4.2.3 Retrieval .............................................. 26
3.4.2.4 Templates .......................................... 26
3.4.2.5 Expiry .................................................. 26
3.4.2.6 Access Control tab (IMAP only) ..................... 26
3.4.2.7 Mailing List ......................................... 28
3.4.2.8 Shortcut ............................................... 29
3.4.2.9 Maintenance ......................................... 29
3.5 Message Filters ............................................ 29
  3.5.1 Fast Filter Creation .................................. 29
  3.5.2 The Filter Dialog ..................................... 29
  3.5.3 Search Patterns ...................................... 31
  3.5.4 Filter Action .......................................... 32
  3.5.5 Filter Examples ...................................... 34
  3.5.6 Filter Optimization .................................. 35
  3.5.7 Filter Log .............................................. 36
3.6 Backing up KMail ........................................ 36
  3.6.1 Archiving ............................................. 36
  3.6.2 Exporting ............................................. 38
3.7 Restore and Import in KMail ............................ 38
  3.7.1 Restoring backed up email and settings ............. 38
  3.7.2 Importing options in KMail ......................... 38
3.8 Using Multiple Accounts ............................... 38
3.9 Signing and Encrypting Messages with GnuPG ........ 39
  3.9.1 Preconditions ....................................... 39
  3.9.2 GnuPG-Related Settings in KMail ................... 39
  3.9.3 Sign your Messages .................................. 40
  3.9.4 Encrypt your Messages ................................ 40
  3.9.5 Send your Public Key ................................ 41
  3.9.6 You received an encrypted Message ................. 41
  3.9.7 Receiving a Public Key ................................ 41
3.10 The Anti-Spam Wizard .................................. 41
  3.10.1 Basics ............................................... 41
  3.10.2 Advanced ............................................ 42
  3.10.3 Some More Details for Experts ..................... 43
3.11 The Anti-Virus Wizard .................................. 43
  3.11.1 Basics ............................................... 43
  3.11.2 Advanced ............................................ 43
  3.11.3 Details ............................................... 44
4 Configure KMail
4.1 General Information .................................................. 45
4.2 Identities Page .......................................................... 46
  4.2.1 The New Identity Dialog ........................................... 46
  4.2.2 General .............................................................. 47
  4.2.3 Cryptography ....................................................... 48
  4.2.4 Advanced ........................................................... 49
  4.2.5 Templates ........................................................ 51
  4.2.6 Signature .......................................................... 51
  4.2.7 Picture ............................................................. 52
4.3 Accounts Page .......................................................... 53
  4.3.1 Sending ............................................................ 53
  4.3.2 Receiving .......................................................... 54
4.4 Appearance Page ....................................................... 54
  4.4.1 Fonts ............................................................... 54
  4.4.2 Colors ............................................................. 54
  4.4.3 Layout ............................................................. 55
  4.4.4 Message List ...................................................... 55
  4.4.5 Message Window .................................................. 58
  4.4.6 System Tray ....................................................... 59
4.5 Composer Page .......................................................... 59
  4.5.1 General ............................................................ 59
  4.5.2 Standard Templates .............................................. 60
  4.5.3 Custom Templates ............................................... 60
  4.5.4 Subject ........................................................... 60
  4.5.5 Charset ........................................................... 60
  4.5.6 Headers ........................................................... 60
  4.5.7 Attachments ....................................................... 61
  4.5.8 Autocorrection .................................................... 61
  4.5.9 Auto Resize Image ............................................... 61
  4.5.10 External Editor ................................................... 62
4.6 Security Page ............................................................ 63
  4.6.1 Reading ........................................................... 63
  4.6.2 Composing ........................................................ 65
  4.6.3 Miscellaneous ..................................................... 66
  4.6.4 S/MIME Validation .............................................. 67
4.7 Misc Page ............................................................... 68
  4.7.1 Folders ............................................................. 68
  4.7.2 Invitations ........................................................ 69
4.8 Options without a user interface representation ...................... 70
## Command and Menu Reference

### 5.1 The KMail Reader Window
- **File Menu** .......................................................... 73
- **Edit Menu** .......................................................... 75
- **View Menu** .......................................................... 75
- **Go Menu** ............................................................ 77
- **Folder Menu** ......................................................... 77
- **Message Menu** ...................................................... 79
- **Tools Menu** .......................................................... 82
- **Settings Menu** ....................................................... 83
- **Help Menu** ........................................................... 84

### 5.2 The KMail Composer Window
- **Message Menu** ...................................................... 84
- **Edit Menu** .......................................................... 85
- **View Menu** .......................................................... 86
- **Options Menu** ....................................................... 86
- **Attach Menu** ........................................................ 87
- **Tools Menu** .......................................................... 88
- **Settings Menu** ....................................................... 88
- **Help Menu** ........................................................... 88

## Frequently Asked Questions (FAQ)

### 7.1 KMail doesn’t send mail ................................... 98
### 7.2 Clean start after a failed migration ...................... 98
### 7.3 Local Folders is added over and over .................. 100
### 7.4 You get the error Unable to fetch item from backend when entering IMAP folder 101
### 7.5 Your mails are not being sent, without error messages 101

## Credits and License

### 8.1 Development Team ............................................ 102
### 8.2 Credits .......................................................... 104
### 8.3 Documentation ................................................ 104
The KMail Handbook

List of Tables

3.2 ACL Rights Summary .................................................. 28
Abstract

KMak is KDE’s powerful and user friendly email client.
Chapter 1

Introduction

Daniel Naber
Scarlett Clark
2013-12-12
KDE 4.12

The KMail Team welcomes you to KMail, a user-friendly email client by KDE. Our goal is to make KMail a program that is beautiful and intuitive without sacrificing power.

If you have never set up an email client on a UNIX® system before, we suggest that you read through the Getting Started section first.

1.1 Some KMail Features

Some links to the great features available in KMail
The KMail Handbook

- You do not have to use your mouse to use KMail. Everything can be done by using Keyboard Shortcuts.
- Although KMail can be considered reliable you should keep backups of your messages, i.e. use one of the export/archive options listed in Backup Options to backup your settings and email to a safe place.
- KMail is capable of importing email in several formats from your previous email applications using options in Restore and Import in KMail.
- Organize your folders with ease using KMail’s extensive Folders options. Some of the features include handling per folder: mailing lists, acl (IMAP only), and archiving.
- Compliment your folder setup with highly configurable filters.
- By default KMail will detect common email scams. You can also fight SPAM and viruses with built-in wizards to work with external programs to scan email as it comes in. See Anti Spam Wizard and Anti-Virus-Wizard for details.
- Easily manage per-account settings using multiple identities.

We hope you will enjoy KMail!

1.1.1 Getting Help

**NOTE**
If you experience any problems migrating to KMail 2 please read the chapter Troubleshooting.

KMail’s homepage can be found at https://userbase.kde.org/KMail. There you will find useful links, e.g. to the user and developer mailing lists. Please report bugs in KMail using Help → Report Bug....
Chapter 2

Getting Started

This is a short introduction to KMail and its usage so you can start working with it right away. For more in-depth information see the Using KMail section.

2.1 Account Wizard

The first time you run KMail you will be greeted with the Account Wizard.
The wizard will take you through the process of creating your email accounts. Your screens will vary depending on how much the wizard can determine on its own. Below is an outline of the screens you may encounter while using this wizard.

- **Provide personal data** is the first screen of the wizard. It will prompt you for your basic account information: Full name, E-mail address, and Password. By default, the Find provider settings on the Internet option is checked, the wizard will attempt to retrieve the necessary information from the server. Uncheck this option if you are an expert user and you need to set up advanced configuration. Click the Next button once finished.

  **NOTE**
  If you use GMail 2-step verification you will need to generate an application-specific password within gmail security settings and enter that password in the password text box.

- If you want to secure your communication with GnuPG you can generate a new key and publish the key on a public key server or import an existing key. When sending mails KMail then automatically looks for encryption keys of your recipients and secures the mail when keys for each recipient can be found. It also signs your mails cryptographically so that it can be verified that your messages have not been tampered with.

- The Select Account Type screen will be next if the wizard cannot determine your account type. Select your account type from the list (if you do not know, you will need to contact your email provider). If your account type is not listed, click the Check for more on Internet button. Once your account type has been selected, click the Next button, and you will be presented with the Personal Settings screen.

  The Provide personal data screen will show again with the server details it found if the wizard was successful at determining the account type. Click the Finish set up the account, complete the wizard and close the window.

- The Personal Settings screen will show if you had to enter your account type. Verify that your information is correct on this page. Select Download all messages for offline use if you want your messages available when you do not have an Internet connection (IMAP only). Click the Next button once finished.

- Your account will then be set up, and you can click the Finish button to complete the wizard and close the window.

For manually creating accounts please continue reading the rest of this document.

### 2.2 Manual Configuration Quickstart


To begin sending and receiving messages you will only have to change some settings in the Identities and Accounts pages.
2.2.1 Setting your Identity

The settings in the Identities page are fairly straightforward. Select your default identity and click Modify. Fill in the Your name field with your full name (e.g. John Doe) and the Organization field (optional) with the appropriate information.

Next, fill in the Email address field with your email address (e.g. john@example.net).

If you are using PGP or GnuPG you can set your OpenPGP keys and/or S/MIME certificates in the Cryptography tab.

Optionally, go to the Signature tab and enter your signature. This is a short text that will be automatically appended to all your messages. It has nothing to do with digital signatures.

2.2.2 Setting up your Account

The Accounts page contains the settings that tell KMail how to send and receive your email messages. Many of these settings can vary greatly depending on the setup of your system and on the kind of network that your mail server is located in. If you do not know what setting to choose or what to put in a field, consult your Internet Service Provider (ISP) or system administrator.

2.2.2.1 Sending Messages

The Sending tab provides a list of ways to send messages. The first item in the list is the default way to send messages. Using the Add... button you can fill in the Name field with a descriptive name (e.g. My Mail Account). Click the Create and Configure and fill the Outgoing mail server field with the name and domain of your mail server (e.g. smtp.provider.com). You will probably not need to change the Port setting (the default is 25).

The way of sending messages configured here will be used for your default identity and for all other identities that do not have their own way of sending messages. You can use different ways of sending messages for different identities by selecting the Outgoing Account check box in the Advanced tab of the Identities page.

A description of the other options can be found in the Configuration chapter.

2.2.2.2 Options relevant to Kolab server

When configuring an SMTP account with a Kolab server Host, you need to check the Server requires authentication option and to fill in your Kolab user’s email address and password in the Login and Password fields. Then select the Security tab and click on the Check What the Server Supports for automated setup of your Security configuration. The default should be TLS/PLAIN. The Kolab server supports SSL/PLAIN as well. These settings may of course be configured manually.

2.2.3 Receiving Messages

By default the Local Folders (inbox, outgoing, sentmail, trash, drafts and templates) with data from a local Maildir folder are predefined on this tab. Using the drop down box you can select the Retrieval Options for these folders.

To set up an account so you can receive mail, press the Add... button in the Receiving tab. You will then be prompted for the type of your email account. Most users should select POP3 E-Mail Server or IMAP E-Mail Server. If you want to use a local mailbox file, please see the FAQ about file locking.
You will then be presented with the account settings window. First, fill in the **Account name** field to name your account. You can choose any name you like. **Username**, **Password**, and **Incoming mail server** should be filled in with the appropriate information from your ISP or system administrator. You should not need to change the **Port** setting (the default for POP3 is **110**, the default for IMAP is **143**).

### 2.2.3.1 Options only relevant to IMAP

If you check **Automatically compact folders** KMail removes the messages you deleted from the server as soon as you leave a folder. Otherwise the messages are only marked as deleted and it is up to you to compact the folders manually by using the menu item **File → Compact All Folders**.

If you check **Show hidden folders**, folders whose name starts with a dot are also displayed.

### 2.2.3.2 Options only relevant to POP3

Select **Leave fetched messages on the server** if you want to leave your messages on the server after you downloaded them.

Select **Include in Manual Mail Check** if you want to check this account whenever you use **File → Check Mail**. If you unselect this option you can still check for new messages on this account with **File → Check Mail In**.

Select **Enable interval mail checking** if you want KMail to check for new messages automatically. The interval can be specified below under **Check mail interval**.

**inbox** is the default folder for incoming messages. If you want to change that for some reason, you can do so with **Destination folder**. But what you probably want is a **filter**, which has nothing to do with this option.

With **Pre-command** you can specify any program that KMail will execute just before fetching mail. Please specify the full path (do not use ‘~’) and note that KMail will not continue until the program returns.

In the **POP Settings** group you can select **Use pipelining for faster mail download** if this is supported by your server. You should carefully test this to make sure it works safely.

### 2.2.3.3 Options for both IMAP and POP3

KMail supports encryption via **SSL/TLS** and **STARTTLS** (**SSL/TLS** should be preferred if it is available).

For POP3 KMail supports:

- Clear text,
- PLAIN,
- LOGIN,
- CRAM-MD5 (recommended if **DIGEST-MD5** is not available),
- DIGEST-MD5 (recommended),
- NTLM,
- GSSAPINTLM and
- APOP authentication.
DIGEST-MD5, CRAM-MD5 and APOP are secure on their own, the other options are only secure when used together with SSL or TLS. You should only use Clear text if your server does not support any of the other authentication methods. Additionally, for IMAP Anonymous is supported, but APOP is not. Use the Check what the server supports button on the Security tab to automatically select the most secure settings supported by your server.

You are now ready to send and receive mail. For IMAP, just open your folders in the folder tree in KMail’s main window. KMail then connects to your server and displays the messages it finds. For POP3 use File → Check Mail.

2.3 Testing your Setup

First, you should send yourself a message to test your configuration. To send a message, either hit Ctrl+N, select the New Message icon or select the Message → New Message... menu item. The composer window will appear. Fill in the To field with your email address and type something in the Subject field. Send the message by selecting Message → Send Mail.

To check your email, select File → Check Mail. In the lower right corner of the main window, a progress bar will indicate how many messages are being downloaded. If you receive the message you just sent, then congratulations! If, however, you receive any error messages while testing your setup, make sure that your network connection is working and recheck your settings at Settings → Configure KMail....
Chapter 3

Using KMail

Daniel Naber
Scarlett Clark
2013-12-14
(KDE 4.12)

3.1 The Main Window

The main window is the window that appears when KMail is started. It is by default divided into three panes:

Folder list (on the left)
This pane contains the list of your message folders (other email programs may call them mailboxes). To select a folder, simply click on it. The messages contained in the folder will now appear in the Headers pane. The folder list can be displayed in both a short view, which takes up only a small portion of the left side of the screen, and a long view, which takes up the entire left side of the screen but is able to show more mailboxes. You can toggle between these two views under Appearance/Layout in the Settings → Configure KMail... dialog. The top section of the folder pane contains quick links to your favorite folders. Add folders here through the right mouse button context menu Add to Favorite Folders. Please see the Folders Section for detailed information about how to use folders.

Message list (in the upper right by default)

This pane lists header information (message Status Flags, Sender, Subject, Date, and other optional columns like Size, Attachment Flag, Important Flag, etc.) for the messages in the currently selected folder. Clicking on a header will select that message and display it in the Message pane; you can also select more than one message by holding down the Ctrl key when clicking on messages. Change the view of your message list by selecting View → Message List → Theme. You have several options here.

- **Classic** A simple, backward compatible, single row with clickable sort columns.
- **Smart** A smart multi-line, multi-item with status icons, no sort columns.
- **Smart with clickable status** A smart multi-line, multi-item, status icons and clickable sort icons.
- **Configure...** Allows you to customize your own Message List Theme e.g. add or remove columns from the clickable sort bar.

If you have chosen a theme with a clickable status, you may sort the messages by clicking on the column that you wish to sort; if you click on the same column more than once, sort order will toggle between ascending/descending and some alternative sorting criteria will become available (like sorting by Status when you click on the header of the Subject column). Clicking the right mouse button on the list header shows a pop up menu, which allows you to show or hide several columns in the list. You can customize the columns visible on the sort bar, see Configure Appearance Message List for details.
The KMail Handbook

Message preview pane (in the lower right by default)
This pane displays the currently selected message. Below you will find options to adjust the reader window to your preference.

The top of the reader window contains various header options. Go to View → Headers and try them out until you find one you like! Details for the various headers are as follows:

- **Enterprise Headers** A minimal header with title, From, and To, with a graphical design.
- **Fancy Headers** Minimal header with a spam status notification.
- **Brief Headers** Title, and in parentheses you will find From and the date.
- **Standard Headers** Title, From, and To.
- **Long Headers** Title, Date, From, and To.
- **All Headers** List everything you ever wanted to know about the email, including every server it went through, virus/spam scanners it went through, etc.
- **Custom Headers** See Message Window configuration Headers: to set up custom headers that can be selected here.
- **Example** An example header from the Download New Themes....
- **Example Fancy** An example fancy header from the Download New Themes....
- **Download New Themes...** Allows you to download custom themes created by other KMail users.

If you prefer to view your email in HTML format instead of plain text (Default) click on the bar located on the left hand side of the pane. The text on the bar will inform you which view you are in. If this bar is missing you can enable it in the Settings → Configure KMail... dialog, from there you want the Message Window tab, and select Show HTML status bar.

If you would like to change how your attachments appear in your messages, go to View → Attachments. Your options are as follows:

- **As Icons**, all attachments appear as icons at the bottom of the message.
- **Smart** will show attachments as icons, unless the message suggests that they should be displayed inline. You can suggest that certain attachments should be shown inline in your own messages when you select Suggest automatic display in the attachment’s properties dialog.
- **Inline** shows the contents of the attachments at the bottom of the message. Attachments that cannot be displayed, e.g. compressed files, will still be shown as an icon.
- **Hide** will not show attachments.

For complex messages you can show the structure of the message by selecting View → Show Message Structure, this will show in the message structure viewer below the preview pane.

You can scroll through the message page-by-page using the Page Up and Page Down keys, or line-by-line using the Up arrow and Down arrow keys; you can also use keyboard shortcuts to skip through your messages without having to use the mouse.

### 3.2 Keyboard Shortcuts

The following keyboard shortcuts are supported in the main window:

<table>
<thead>
<tr>
<th>Keyboard Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space</td>
<td>Scroll down in the current message or go to the next unread message if you are already at the bottom.</td>
</tr>
</tbody>
</table>
### 3.3 The Composer Window

The composer window is used to write new, reply, and forward messages; it can be invoked in several ways. Here you will find the various options to composing messages.

#### 3.3.1 Composing a Message

**New Message...**

The New Message composer window can be invoked the following ways:

- **File → New → New Message...**
- **Message → New Message...**
- The **New** icon on the main toolbar.
To write your message, fill in the appropriate fields in the composer window. Use the View menu to select which header fields are displayed. Some field options offer a Sticky checkbox, that if checked, your selection will remain as the default when you open a new composer window. The following list describes the various headers.

- The **Identity** drop down box allows you to select an identity to use.
- The **Dictionary** drop down box allows you to choose your dictionary of choice for use with spellchecking.
- The **Sent-Mail folder** allows you to change the location to save sent emails.
- The **Mail transport** allows you to select the outgoing mail server you would like to use.
- Your traditional From:, Reply To:, To:, and Subject: fields.
- The **Use Fixed Font** allows you to toggle fixed fonts on and off.
- The **Snippets** allows you to show the snippets window to store and use often used parts of text.
- The **Translator** allows you to translate your text within the composer window.

There are a variety of shortcuts to help you with writing your messages. The Select... buttons next to the To:, CC:, and BCC: fields will call up the address book so that you can select addresses from there. When you start typing an address in the To:/CC:/BCC: fields, a popup will appear that offers matching addresses that have been used recently and matching addresses from your address book; if you do not like the automatic popup you can disable it by clicking with the right mouse button on the field and choosing a different completion mode.

Whenever you want to add more than one recipient in one of the fields, use a comma to separate each address from the next one. You may need to specify fully qualified addresses (i.e. `user@example.com`) even for local users, depending on your system configuration.

When you are finished with your message, you click the Send icon (the envelope) to send the message now, or click the Queue icon to put the message in the outbox. If your message is not finished yet, select Message → Save as Draft to save for later editing. If you would like to print your message, select Message → Print Preview to preview the message, and Message → Print to print it.

**Message → Send Later** allows you to schedule your emails to send at a specific date and time. Please see Send Later Agent for details.

**File → New → Message From Template → My Super Template**

Compose a new Message from Template is useful if you have created a masterpiece message that you would like to save as a template for use in future new messages. Select Message → Save as Template and this will place your new template in the templates: folder. You can revise the template at anytime by selecting it in this folder. The saved template will now be listed under this menu to use for new messages. Please see Compose New Message for further details on composing a message.

### 3.3.2 Signing and Encrypting Messages

If you want to send an encrypted or digitally signed message, select the Sign Message or Encrypt Message icons in the toolbar. Moreover you can select the format that should be used to sign and/or encrypt the message. Depending on the installed encryption programs you can choose between:

**Any**

KMail will use a format which is understood by all recipients of the message. The preferred format of the recipients can be specified in the KDE Address Book.
**Inline OpenPGP (deprecated)**

This format is outdated. If you use this format then only the message text will be signed and/or encrypted. Attachments will neither be signed nor encrypted. HTML messages cannot be signed with this format. You should only use this format if necessary, i.e. if you send messages to users of email clients that cannot handle the more advanced formats.

**OpenPGP/MIME**

This format is the successor of the inline OpenPGP format. If you use this format then the message text and all attachments will be signed and/or encrypted (at least by default). This is the recommended format if you use OpenPGP.

**S/MIME**

This format is an alternative format to OpenPGP/MIME. If you use this format then the message text and all attachments will be signed and/or encrypted (at least by default). This format is mostly used by corporations.

**S/MIME opaque**

This format is a variant of the S/MIME format. It should only be used if necessary.

### 3.3.3 Creating HTML Messages

Note that HTML messages are often regarded as an annoyance; therefore, you should avoid sending HTML messages if possible. Particularly, you should never send HTML messages to a mailing list unless HTML messages are explicitly allowed.

In order to be able to create HTML messages you first have to enable the markup tools. To do this enable **Rich text editing** in the **Options** menu. A toolbar with several tools to format the message will appear. Via the drop down box you can select between standard text and six different types of lists (three bulleted lists with different symbols and three numbered lists with different numbering). Moreover, you can select the font family, the font size, the font style (bold, italic, underlined) and the text color. Last but not least, you can select the alignment of the text (left aligned, centered, right aligned).

Creating tables and embedding images is currently not possible.

### 3.3.4 Adding Attachments

You can attach files to your message by using one of the methods below:

- Click the **Attach File** (paper clip) icon and select the file you wish to attach;
- Drag a file from the desktop or another folder into the composer window;
- Drag a message from KMail’s message list into the composer window -- that message will then be attached;
- Select one of the options in the **Attach** menu.
- Select **Message → Insert Recent text file**.

Once a file is attached to your message, it appears in the attachments pane at the bottom of the composer window. You can use the right mouse button on each attachment to **Open, View, Save As...** or **Remove** the attachment.

Use the **Properties** item to open the **Message Part Properties** dialog. The first field contains the attachment’s MIME type. Just like the **Name** field, it should be automatically filled with an appropriate value. Sometimes the MIME type value may be wrong. You can then type in any MIME type or choose from the list of common MIME types. You can also select an encoding
method for your file from the list of encoding options (normally, the default value works fine).

Check the **Suggest automatic display** option if you want to suggest to the recipient the automatic (inline) display of this attachment. Whether this works or not depends on the recipient’s email client and on his settings.

You can also attach public keys to the message by using the appropriate options in the Attach menu. GnuPG key attachments are handled like file attachments.

### 3.3.5 Checking the Spelling of your Message

KMail will automatically check the spelling of your message (in HTML mode this currently does not work) and display unknown words using red color. If there are too many unknown words KMail will disable its checking. To select the language used for checking, select **View → Dictionary**. You can disable automatic spellchecking in the **Options** menu.

If you need to write mails in different languages, enable the **Dictionary** drop down box with **View → Dictionary** from the menu. Using this drop down box allows you to change the spellchecker’s language with one mouse click.

To check the spelling of your message using a dialog, select **Tools → Spelling...** KMail uses Sonnet to check spelling, which is the KDE frontend to the ispell or aspell spelling checker. Note that you may first need to configure the spellchecker using **Settings → Spellchecker...**

### 3.3.6 Setting Up the Text Snippets Tool

When editing in the composer window you can store often used parts of text as snippets. To configure the capabilities of the mail snippets part select **View → Snippets** from the menubar. A new panel will appear on the right side of the composer.

To add a new snippet to Snippet Panel, right click on panel, click on **Add Snippet** in the context menu. A snippet editor dialog will appear, in which new text can be added and the snippet can be given a name. Also a **Shortcut** can be associated with the snippet. Snippets can be grouped together as well by creating groups and adding snippets to a particular group. If you want to view the stored text in a tooltip window keep the mouse cursor over the title of that snippet.

The **Snippets** tool allows for a variable text in predefined places any time you insert a snippet into a file. To accomplish this **Snippets** provides its own variables mechanism. You can insert variables in the snippet text itself by using separators ( $ ) that enclose the variable names. For example: $variablename$, $invoicenumber$, $weekno$.

The variable separator can be changed to another character by changing **snippetDelimiter** in the [SnippetPart] section in the Text Snippet configuration file, which can be found at $KDEHOME-/share/config/kmailsnippetrc$.

```text
snippetDelimiter =$
```

### 3.3.7 Using the Built-in Translator

KMail 2 composer provides a built-in translator that can be accessed by selecting **View → Translator** from the menubar. A new panel will appear at the bottom of the composer.

To translate a section of text, first select the text you would like translated to the box with the **Drag text that you want to translate**. Select the language it currently is, in the From: drop down box. Select the language you would like to translate to in the To: drop down box, and click the Translate button. Your translated text will appear in the next box. If you need to translate in the other direction you can just click the Invert button. To clear all text, click the Clear button.
3.4 Message Folders

Message Folders are used to organize your email messages. When you first start KMail the ‘Local Folders’ containing inbox, outbox, sent-mail, trash, drafts and templates folders are created. These folders each have special functions:

**inbox:**
Where KMail by default puts your new messages when you ask it to check your mail.

**outbox:**
Where messages are put while they are waiting to be delivered. Note that you should not drag and drop messages here to send them, use the Send icon in the composer window instead.

**sent-mail:**
By default copies of all messages that you have sent are put into this folder.

**trash:**
By default all messages that you have moved to trash are moved into this folder.

**drafts:**
Contains messages you started to edit but then saved to this folder through Message → Save as Draft.

**templates:**
This folder holds your templates created via Message → Save as Template in the composer window. Please see New Composer Templates for details.
3.4.1 Creating and Using Folders

Organize your emails, e.g. by mailing lists, bill receipts etc., by creating new folders. To create a new folder, select Folder → Add Folder... or Add Folder... from the right mouse button context menu. A dialog will pop up, enter the name of the new folder in the text box. You can fully customize each folder e.g. views, replies, etc. in the properties for a folder by selecting the folder you wish to modify in the folders pane and select Folder Properties from the right mouse button context menu. See Properties of Folder for details.

To move messages from one folder into another, select the message(s) you want to move and press the M key or select Message → Move Messages To. A list of folders will appear; select the folder from the list that you want to move the messages to. Messages can also be moved by dragging them from the Message list to a folder in the Folder list.

If you have folders that are frequently accessed, you can add them to your favorite folders pane in the upper left corner. Add them through the right mouse button context menu Add to Favorite Folders.

You can create a virtual folder with search parameters by going to either Edit → Find Messages..., Tools → Find Messages..., or Keyboard shortcut S. Enter your search parameters into the dialog. Name your search at the bottom Search folder name: textbox, e.g. emails with the word Blog. Click the Search button. Now select the Open Search Folder. Your results folder will be at the bottom of the Folder pane.

Creating filters to automatically move messages to specified folders is a great way to organize messages by mailing list, sender, subject etc. Please see Filters for details.

In the case that you receive emails from a trusted source, e.g. a Blog you signed up for, that is formatted in HTML and you would like to enable HTML view for just those emails. You can achieve this by doing the following: Create a new folder, set up a filter to place those emails in the new folder, select the folder and select Folder → Message Default Format → Prefer HTML to Plain Text.

Some common folder actions are:

Folder → Move All Messages to Trash
Moves all your messages in the selected folder to the trash folder.

Folder → Archive Folder
Create an archive of the folder. See Archive Folder for details.

Folder → Delete Folder
Remove a folder with all its messages and sub-folders.

Folder → Remove Duplicate Messages
This will search the currently selected folder for duplicates and delete them.
3.4.2 Folder Properties

Folder Properties Example

The Properties of Folder dialog lets you rename and specify all of its properties. Note that most properties are only available for your own folders and not for default folders like inbox etc. Default folders also cannot be renamed.

3.4.2.1 General

If you need to rename a folder change the entry in the Name: field.

Act on new/unread mail in this folder is enabled by default on new folders, it allows notifications about new mail that arrives in the folder. Uncheck this option on folders like SPAM and trash that you do not desire notifications.

When replying to messages in this folder, check Keep replies in this folder if you want the replies to be stored in this folder rather than into the default configured sent-mail folder.

Check Hide this folder in the folder selection dialog if you do not want this folder to be shown in folder selection dialogs, such as the Jump to Folder and Move Message to dialogs.

By default new folders use the default identity. Uncheck Use default identity and select a new one from the Sender identity drop down menu. See Identities configuration for information on Identities. Replies to messages that were sent directly to you will still default to the message’s ‘To’ address if an according identity is found.

If you have groupware, you can change the contents e.g. calendar, notes, etc. of the folder in the Folder contents: drop down box.

If you share the folder with other users, you can Share unread state with all users which will show the same unread state for all users.

For example, a ticket system that all emails must be read and multiple users are responsible for reading unread tickets.
3.4.2.2 View

The **Use custom icons** option lets you choose icons that are different from the default ones in the folder list.

With **Show column** drop down you can set the visible columns in the header pane to Default, Sender, or Receiver. This is useful if you use a folder to save your own sent messages.

In the **Message List** section you can select and configure an **Aggregation** and **Theme** for this folder different from the default configured in KMails settings. For more details see the **Message List** tab in the **Appearance** page.

3.4.2.3 Retrieval

If you have an account that does not receive much mail and you don’t want KMail to query the server as often, you can uncheck **Use options from parent folder or account** to set a higher interval in **Automatically synchronize after**: spin box.

In **Retrieval Options** you can change **Always retrieve full messages** option to **Retrieve message bodies on demand** if you have a slow connection. You can set how long the message will remain locally in the following spin box.

3.4.2.4 Templates

On this tab you can define folder-specific templates for your custom folders. For more details see the **Standard Templates** tab in the **Composer** page.

3.4.2.5 Expiry

You can set automatic cleanup or deletion of emails in this tab. Check the box if you would like to automatically expire read or unread messages respectively. Set the amount of days in the spinbox.

If you do not want to permanently delete the messages you can assign a folder to move them to in **Move expired messages to**: textbox or folder selection dialog. Once you have reviewed the messages and want to permanently delete them, you can go to the folder expiry options of the folder you chose to move them to and set the option **Delete expired messages permanently**, then click the **Save Settings and Expire Now**.

**Warning**

Messages that are deleted during expiration of old messages cannot be restored, so be careful with this setting.

3.4.2.6 Access Control tab (IMAP only)

Here you can manage the access control lists (ACLs) of IMAP folders.

**Note**

The IMAP server must have user level ACL configured and enabled for this tab to be visible.

The currently active ACL is shown in the list. It consists of pairs of **User Ids** and the **Permissions** granted to users identified by that **User Id**. **1** ACLs are settable per-folder.

---

Notes:

1. Note that a single **User Id** might refer to more than one user. Depending on the IMAP server and its configuration, there may be **User Ids** that correspond to groups of users, anonymous users, or any user. Consult the manual of your specific IMAP server implementation for more information.
NOTE
As with everything else when using disconnected IMAP, you need to sync with the server for the changes to be transferred to the server.

IMAP ACLs define a lot of fine-grained permissions that you can grant or deny other users. For the sake of clarity, KMail will present them as the following five categories that you can choose from (see Table 3.2 for the details if you already know IMAP ACLs).

**None**
Grants the users identified by **User Id** no rights at all. This is also the default for users not explicitly (or implicitly, as a group) listed in the ACL. These users will not see this folder in the list of IMAP folders presented to them by their mail clients.

**Read**
Grants the users identified by **User Id** reading rights for this folder. This also includes the ability for their mail clients to mark mails as read and store this information on the server.

These users will see this folder in the list of IMAP folders presented to them by their mail clients.

Use this to create a shared folder that others can read, but not modify.

If you were the editor of a company’s news letter, you could create a folder for the purpose of distributing the news letter, grant everyone reading rights, and save the letter to this folder instead of sending it out by email to a catch-all address.

**Append**
(also known as **Post**)
Grants the users identified by **User Id** reading (see above) and posting rights for this folder.

Use this to create a shared folder that others can read and post messages to, but cannot otherwise modify.

If you wanted to create a company-wide discussion forum, instead of using a web-based form or a separate company-private usenet server, you could create a bunch of folders (one per topic), and grant everyone reading and posting rights. Instead of posting to an NNTP server or writing their messages into a web form, people would just write emails and store them in the folder suitting the topic of the message.

**Write**
Grants the users identified by **User Id** reading, posting (see above), and writing rights for this folder.

The right to write to a folder includes deleting of messages, creating subfolders, and storing other attributes than read/unread on the server (e.g. answered).

Use this to create a shared folder that everyone has (almost, see **All**) the same rights for.

In the **Append** example, you could assign write rights to a group of people acting as moderators, which would then be able to remove off-topic posts, and create sub-topic-folders for high-traffic folders.

**All**
Grants the users identified by **User Id** reading, posting, writing (see above), as well as administration rights, i.e. the right to modify the ACL of this folder.

This is the default set of rights for the owner of a folder.

Table 3.2 summarizes the IMAP ACL rights associated with each permission level.

---

2 Every user has their own list of read mail, so none of your unread mails will suddenly be marked as read just because someone else has already read them.
3.4.2.7 Mailing List

If you are going to use the folder for a mailing list open the Mailinglist Folder Properties dialog with Folder → Mailing List Management from the menu. Then you should check Folder holds a mailing list to associate this folder with the mailing list. Next you should click on Detect Automatically. KMail will then try to guess some information about the mailing list from the currently selected message. If KMail could not determine some addresses then you can add the missing information manually. To do this first select the Address type for which you want to add an address. You can choose between:

**Post to List**
This address is used for sending messages to the mailing list. This is usually an email address.

**Subscribe to List**
This address is used for subscribing to the mailing list. This can be an email address or the address of a web page.

**Unsubscribe From List**
This address is used for unsubscribing from the mailing list. This can be an email address or the address of a web page.

**List Archives**
This is the address of the archive of the mailing list. This is usually the address of a web page.

**List Help**
This address is used for requesting help for this mailing list. This is usually an email address.

After selecting the appropriate Address type you enter the email address or the address of the web page and then click on Add. With Remove you can remove addresses.

If all addresses have been added then you can execute an action, e.g. go to the list archives, by selecting the appropriate Address type and then clicking on Invoke Handler. If there is an email address and an address of a web page for the desired action then you will have to select the Preferred handler prior to clicking on Invoke Handler. Select KMail if you want to send a message to the email address and select Browser if you want to go to the web page.

Alternatively to invoking the handler for Post to List you can send a new message to the mailing list via Message → New Message to Mailing-List...

### Table 3.2: ACL Rights Summary

<table>
<thead>
<tr>
<th>ACL right</th>
<th>None</th>
<th>Read</th>
<th>Append</th>
<th>Write</th>
<th>All</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lookup</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Read</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Store Seen</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Insert</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Post</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Write Flags</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Create</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Delete</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Administer</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The KMail Handbook
3.4.2.8 Shortcut
You can define a keyboard shortcut to access the folder.

3.4.2.9 Maintenance
This tab shows an overview about the folder type and its size, the number of read and unread messages in the folder and allows you to enable text indexing.

3.5 Message Filters

After using KMail for a while, you may find that you have trouble sorting out the new messages in your inbox when they arrive. Filters allow you to automatically perform certain actions on incoming messages and to manually perform actions on selected messages in a folder.

Filters consist of: filter criteria, whose rules are used as criteria to determine whether this filter should be applied to a given message; and a list of filter actions, which describe what is to be done with, or to, the message if the search pattern matches. Read more about filter criteria and filter actions in the following subsections.

NOTE
Filters are considered one after the other, starting with the first filter in the list. The first one whose pattern matches the given message gets executed; you can request that the remaining filters also be applied, but the default is to stop processing at the first matching filter.

Usually, filters are used on incoming messages, but they can also be applied to sent messages or to an arbitrary message or group of messages. To selectively filter messages, select the messages you want to filter in the message list and either type Ctrl+J or select Message → Apply Filter: this will apply all filters that have been marked for manual filtering in the filter dialog to those messages.

3.5.1 Fast Filter Creation

There are two methods for creating a filter; the quick method is to use Message → Create Filter and select a criteria from the submenu: this will call the filter dialog and present you with a new filter which has the first rule of the search pattern and the first action (as Move into Folder) preset. In most cases, all you have to do is select the folder where the message should be moved to; but you can, of course, edit the filter as you like.

When creating a filter on mailing list messages this method will try really hard to find a criterion that uniquely identifies messages from that list; If it succeeds, the guessed name of the list is presented in the Message → Create Filter → Filter on Mailing-List... menu entry.

The second method is to manually construct a filter from scratch by calling the filter dialog through Settings → Configure Filters.... The filter dialog is described in detail in the following subsection.

3.5.2 The Filter Dialog

This dialog allows you to manage and edit your list of filters.

You can reach it either via Message → Create Filter or Settings → Configure Filters....

The dialog is divided into three main sections on the General and Advanced tab:
Available Filters

This group contains the list of filters and some action buttons to modify the filters, namely: to create new filters; to move them up or down the list; to delete them; or to rename them. If you select a filter from the list, its properties are shown in the right-hand half of the dialog.

Filter Criteria

In this group you can edit the pattern that messages must match for the filter to be applied to them. You can select here whether all of the defined rules must match or whether it suffices that any one of them matches. See Search Patterns below for a detailed description of each search rule type.

You can click on More to get an additional (initially empty) rule if you want to define more-complex patterns and on Fewer to remove the last rule. Clear clears the pattern, i.e. it removes all but two rules from screen and resets those two. Invalid or empty rules are not evaluated.

Filter Actions

In this group you can edit the list of actions that are applied to all messages that match the defined filter criteria. See Filter Actions below for a detailed description of each action type.

You can click on More to get a new, empty action (if you want to define more than one action) and on Fewer to remove the last action. Clear clears the list, i.e. it removes all but one action and resets that one. Invalid or empty actions are not executed.

Advanced Options

In this group you can define a few advanced options for filters that allow you to refine your filtering.

Using the first row of check boxes, you can toggle when the filter is applied: the Apply this filter to incoming messages option means that the filter is applied to messages when you receive them (i.e. on Check Mail). The filter can be applied to all messages, to all but online IMAP accounts and to a selection of incoming folders.

The Apply this filter to sent messages option means that the filter is applied to messages when you send them and the Apply this filter on manual filtering option controls whether to apply this filter when filtering is specifically selected (i.e. via Message → Apply Filters.)

If Apply this filter to sent messages is checked the filter will be triggered after the message is sent and it will only affect the local copy of the message. If the recipient’s copy also needs to be modified, please use Apply this filter before sending messages.

The If this filter matches, stop processing here check box controls whether or not the filters after the current filter will be applied, if the current filter matches.

If the Add this filter to the Apply Filter menu check box is selected, this filter will be inserted in the Message → Apply Filter submenu. You can then apply this filter to a message. Another way of applying filters is to use Message → Apply Filters menu option, which applies all the filters - one after another until they are all used or one of the filters that matches has the If the filters matches, stop processing here.

NOTE

Filters are automatically named unless you explicitly rename them using the Rename... button. The dialog assumes that it should continue auto-naming the filter as long as the filter name starts with '<'.

NOTE

If you apply filter changes, via OK or Apply, only valid filters are actually copied to the internal filter manager. Similarly, empty rules and actions are removed from the pattern and action list respectively, before the filter is saved.
3.5.3 Search Patterns

The most common use of filters is to filter on the sender of messages; this can be done by choosing From. A good bet for a mailing list would be <recipients>, but there are other criteria a filter can search for (note that all patterns are interpreted case-insensitively):

<message>
Searches the whole message (i.e. headers, body and attachments, if any);

<body>
Searches the body of the message (i.e. the whole message except the headers);

<any header>
Searches the headers of the message;

<recipients>
Searches the ‘To’ and ‘CC’ header fields of the message;

<size in bytes>
Sets upper or lower bounds on the message size;

<age in days>
Sets upper or lower bounds on the message age;

<status>
Sets restrictions on the status of the message;

Any other name
Searches the header field that is given by that name.

The list of possible rules depends on what you selected in the first drop down box. The available rules are:

<table>
<thead>
<tr>
<th>Rule</th>
<th>Available for</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>contains/does not contain</td>
<td>all textual search items</td>
<td>Matches if the searched item contains (or does not contain) the given text.</td>
</tr>
<tr>
<td>equals/does not equal</td>
<td>most textual search items</td>
<td>Matches if the searched item is equal to (or not equal to) the given text.</td>
</tr>
<tr>
<td>matches regular expr./does not match reg. expr.</td>
<td>all textual search items</td>
<td>Matches if a part of the searched item matches the given regular expression (or does not match it). If the regular expression editor is installed then you can edit the regular expression by clicking on the Edit... button.</td>
</tr>
<tr>
<td>has an attachment/has no attachment</td>
<td>&lt;message&gt;</td>
<td>Matches if the message has an attachment (or does not have an attachment).</td>
</tr>
<tr>
<td>is in address book/is not in address book</td>
<td>most textual search items</td>
<td>Matches if the searched item contains an address that is in your address book (or if the searched items contains only unknown addresses). Of course, this rule only makes sense for address fields like From or &lt;recipients&gt;</td>
</tr>
<tr>
<td>is in category/is not in category</td>
<td>most textual search items</td>
<td>Matches if the searched item contains an address that is in the specified category in your address book (or if the searched item contains no address that is in the specified category). Again, this rule only makes sense for address fields.</td>
</tr>
<tr>
<td>is equal to/is not equal to</td>
<td>numerical search items</td>
<td>Matches if the value of the search item is equal to (or not equal to) the specified value.</td>
</tr>
<tr>
<td>is less than</td>
<td>numerical search items</td>
<td>Matches if the value of the search item is less than the specified value.</td>
</tr>
<tr>
<td>is greater than</td>
<td>numerical search items</td>
<td>Matches if the value of the search item is greater than the specified value.</td>
</tr>
<tr>
<td>is less than or equal to</td>
<td>numerical search items</td>
<td>Matches if the value of the search item is less than or equal to the specified value.</td>
</tr>
<tr>
<td>is greater than or equal to</td>
<td>numerical search items</td>
<td>Matches if the value of the search item is greater than or equal to the specified value.</td>
</tr>
<tr>
<td>is/is not</td>
<td>&lt;status&gt;</td>
<td>Matches if the message has (or does not have) the specified status.</td>
</tr>
</tbody>
</table>

### 3.5.4 Filter Action

The most common use of filters is to sort incoming messages to certain folders; this can be done by choosing Move into Folder. Here is a list of all possible actions:

**Move Into Folder**

This will file the message into another folder, removing it from its current folder if necessary; you cannot, currently use IMAP folders as a target.

**Copy Into Folder**

This will copy the message to another folder.
NOTE
You currently cannot use IMAP folders as a target.

Set Identity To
This will set the identity that will be used if you reply to this message.

Mark As
This allows you to mark the message as read or important (flagged), but also as forwarded, replied, etc.

Send Fake MDN
This will send a faked message disposition notification (i.e. a read receipt) to the sender of the message.

Set Transport To
This will set the method of transport (e.g. SMTP) that will be used if you reply to the message.

Set Reply-To To
This will modify the Reply-To field of this message. This can be useful for mailing lists that automatically set a Reply-To which you do not like.

Forward To
This will forward the message inline (i.e. as if you selected Message → Forward → Inline...) to another email address. You can select the template to be used when forwarding with this filter with the drop down list.

Redirect To
This will redirect the message as-is to another email address.

Confirm Delivery
Will try to return a message to the sender that indicates successful delivery of their message, if the sender requested that.

This action allows you to select who will get delivery receipts from you. Though you can globally enable the sending of delivery confirmations in the Configure KMail... dialog (Security page) we recommended not to send them to everyone, since this makes tracking of spam messages, for example, very easy for the sender.

Execute Command
This will execute a program, but will not modify the message. Specify the full path to the program you want to execute; KMail will then block until the program returns. If you do not want KMail to block then append ‘&’ to the command. You can feed the program with the parts of the mail: %0, %1, etc. stand for files representing the message parts; for common messages %0 is the text, %1 the first attachment and so on. Additionally, the whole message is fed into the program’s stdin; and every occurrence of %{foo} is replaced by the content of the foo header. If you need to identify the message via its storage location in the Akonadi store, you can use the %itemid or %itemurl placeholders to achieve that.

WARNING
This currently only works if the message has at least one attachment. No, not even %0 will work in the general case!
You can enter arbitrarily-complex shell commands here, since KMail uses a sub shell to execute the command line; therefore, even this command will work (within its limits): `uudecode -o $(mktemp kmail-uudecoded.XXXXXX) && echo $'\a'

Pipe Through

This will feed the message to a program: if the program returns output, the entire message (including the headers) will be replaced with this output; if the program does not return output or exits with a return code other than 0 (indicating an error occurred), the message will not change. Specify the full path to the program. The same substitutions (%n, %\{foo\} as with `execute command` are performed on the command line.

**WARNING**

Be cautious with this action, as it will easily mess up your messages if the filter program returns garbage or extra lines.

Remove Header

Will remove all header fields with the given name from the message. This is useful mainly for removing bogus ‘Reply-To:’ headers.

Add Header

If no such field is already present this will add a new header field with the given name and value to the message; if there already is a header field with that name, it is overwritten with the given value; if there are already multiple headers with the given name (e.g. ‘Received:’ headers), an arbitrary one of them is overwritten and the others are left unchanged — this is a known limitation. You may want to combine this filter with the remove header filter above to make sure that there are no other headers with that name in the message.

Rewrite Header

Will scan the given header field, modify its contents and write it back. The search string is always interpreted as a case-sensitive regular expression. The replacement string is inserted literally except for occurrences of \n, $n and $\{nn\}, where n is a positive (single-digit, except for the third form) number or 0. These constructs are interpreted as back references to substrings captured with parentheses in the search string.

Analogous restrictions as in the add header action apply here, too.

Play Sound

Will play the specified sound.

### 3.5.5 Filter Examples

As of yet KMail does not highlight or mark mails that have an extra `Priority:` header. If I want to flag all ‘urgent’ messages as being important, I can use a filter:

1. Open up the Settings → Configure Filters... dialog and click the New icon below the Available Filters list.
2. In the Filter Criteria area, select Anywhere in Headers and contains from the drop down boxes and type `Priority:` in the text field. Select the same criteria in the next line and type urgent in the text field of the second drop down box.

   So your filter will match all messages containing a ‘Priority: urgent’ header field.
3. Skip down to the Filter Actions area. Select Mark As from the first drop down box. A new drop down box containing a list of marker flags is shown to the right. Select Important from the drop down box.
4. Since you want this filter to *not* prevent other filters message rules from being applied, carefully *uncheck* the *If this filter matches, stop processing here* option.

5. Click on **OK**, and you are done.

   Just keep in mind to move the ‘Priority: urgent’ entry to the top of the *Available Filters* list, each time, when you have added another filter, so your non-stopping filter will always be applied first.

If I am subscribed to the (general) KDE List, I could create a folder for the list (I will call it **KDE-General**) and use a filter to automatically transfer new messages from my inbox to my **KDE-General** folder if they are from the KDE List. Here is how to create this filter:

1. Try if **Message → Create filter → Filter on Mailing-List...** can identify the mailing list (the name of the list should then appear in the menu item); in this case, this works and I am presented a filter that has ‘List-Id *contains* <kde.kde.org>’ preset. You select the desired destination folder from the folder pull-down menu in the **Filter Action** group and that is it.

   If that does not work, think of a unique way of identifying the messages you want to filter. The (almost) unique property of my KDE List messages is that they always contain ‘kde@kde.org’ in the **To:** or **CC:** field. It is only almost unique, because this fails for cross-posted messages.

2. Select **Settings → Configure Filters...**.

3. Press the **New** button to create an empty filter. It will appear as `<unknown>`.

4. In the **Filter Criteria** area, select **All Recipients** from the first drop down box, **contains** from the second drop down box, and type **kde@kde.org** in the text field.

5. Skip down to the **Filter Actions** section. Select **Move Into Folder** from the first drop down box. Click on the folder icon and a window containing a list of folders will appear. Select the folder that you want the filtered messages to be transferred to. For this example, you would select **KDE-General**.

You may find that you need to use more powerful criteria to properly filter your messages; for example, you may only want to filter the KDE List messages that are written by your friend **Fred Johnson <fj@anywhere.com>**. This is where the rest of the matching criteria section comes into play:

1. Open up the **Configure Filters...** window and select the filter you just created.

2. Since you want to filter all messages that have **kde@kde.org** in the **To:** or **CC:** field *and* that are from Fred, check the **Match all of the following** radio button.

3. Now, go to the second search rule and select the following from the pull-down menus: **From, contains**. Now, type **fj@anywhere.com** in the text field.

You now have a filter that transfers all KDE List messages that are from **fj@anywhere.com**.

### 3.5.6 Filter Optimization

It is important to know that, for example, the order of the filters has an impact on the speed of the filter process. Here are some ideas which can help you to improve the filtering:
Stop filter processing as early as possible:

If you know that a filter finally processes a certain class of messages, please make sure to check the option **If this filter matches, stop processing here** for the filter. This will avoid the evaluation of the filter rules of all subsequent filters. (See the advanced options in the Filter Dialog).

An example is filtering messages from mailing lists via List-Id header into separate folders. Having found out that a message came from list A means that you can avoid checking the next filter for messages from list B.

Consider the costs of the evaluation of filter rules:

The time required to evaluate a filter rule depends on the way the rule is constructed. In particular, scanning for a substring using the `contains` operation is faster than a pattern matching using the `matches regular expr` operation.

Another dependency is on the amount of data which is used for the evaluation of a filter rule. If the rule is based on a message header, its evaluation should normally be much faster than the evaluation of a rule based on the complete message.

You should try to keep the filter rules as simple as possible.

Check the order of your filters:

All the different filter actions have a different complexity. The most expensive filter actions are **Pipe Through** and **Execute Command**, because both need external programs to be run. Placing filters containing these filter actions behind other filters that can reduce the number of times these complex actions are required is useful, if the filter logic does allow this.

An example is filtering messages from a mailing list and detecting spam messages. For the spam detection you will usually use an external tool via a **Pipe Through** action. Filtering the messages for the mailing list is done via the List-Id header. If you do not want to check the messages from the mailing list for spam too, it is better to use the filter for the mailing list messages before the filter for the spam detection. This way you avoid the expensive and slow spam check for all messages which were identified as mailing list messages.

3.5.7 Filter Log

If you want to verify that your filters work as intended, you can open a viewer for the filter log via **Tools → Filter Log Viewer**.

In the viewer, there you can configure the logging of the filter processing. You can control the detail level of the log, clear the log or save the log into a file. The log can provide valuable information if you need to debug your filtering process.

3.6 Backing up KMail

This section describes various backup solutions within KMail.

3.6.1 Archiving

**Folder → Archive Folder**

This feature is also available through the context menu launched with a right mouse button, then select **Archive Folder**. This will open a dialog that allows you to create a single archive of the currently selected folder.

The **Folder** shows the currently selected folder, if you wish to change the folder to be archived click the folder icon. The **Format** drop down menu allows you to choose a format.
(choices are: zip, tar, tar.bz2, and tar.gz). If you would like to change the default name or location, click the folder at the end of Archive File.

Check the Delete folder and subfolders after completion if you would like everything you archived deleted. By default all subfolders will be archived, uncheck Archive all subfolders if you only want to archive the parent folder.

Settings → Configure Automatic Archiving...

This is a powerful tool that can be used to assist in backing up your email. Please see Automatic Archiving for details.

Settings → Configure Folder Archive Agent...

This feature allows you to archive single emails to a specified folder.

Folder Archive can be enabled on a per account basis to allow you to archive individual emails through the right click menu.

Folder Archive is used to archive single emails to a specified folder. For instance, you need to archive all of those pesky bill receipts in one place. Folder Archive can easily accommodate those needs. Start by using Settings → Configure Folder Archive Agent... in KMail’s reader window to open a dialog to set up the folder archive agent.

This dialog will have a tab for each of your configured accounts including Local Folders and you will need to configure all accounts that you wish to use this feature with. The first option allows you to enable/disable the folder archive agent. It is disabled by default, to enable check the Enable checkbox. You can set the location of your Archive folder by clicking the folder icon next to Folder and selecting the folder you wish to use. For example, you could create a folder called ‘bill receipts’ by clicking the New Subfolder... and typing bill receipts in the dialog. You may choose a folder location anywhere, e.g... a folder in your ‘Local Folders’ or on your IMAP server.

You have several choices on how the emails will be archived:

Unique folder
Uses the selected folder sorted by date.

Folder by months
Creates new folders inside the selected folder by months.
The KMail Handbook

Folder by years
Creates new folders inside the selected folder by years.

Now when you receive a bill receipt, right mouse button the email and select Archive from
the menu. The email will be archived into your configured archive folder for easy viewing
later on.

3.6.2 Exporting

Tools → Export KMail Data...
This feature exports settings and local mail to a compressed file. Please see pimsettingexporter for details.

3.7 Restore and Import in KMail

This section describes restoring backups and importing in KMail

3.7.1 Restoring backed up email and settings

Tools → Export KMail Data...
If you used PIM Setting Exporter to backup local email and or settings, please use it again
to import back into KMail. See PIM Setting Exporter for details.

3.7.2 Importing options in KMail

KMail has an import wizard to make the transition from another email application extremely
easy.

Tools → Import Wizard...
This starts the import wizard and try to automatically detect data from another email ap-
plication. In case the mail data you want to import is not found, use the manual import
below.

File → Import Messages...
Start the import wizard and let you select your mail data manually for importing.

Please read the Import Wizard documentation for details.

3.8 Using Multiple Accounts

Multiple accounts are used to check for messages from more than one email address and/or mail
server. Select Settings → Configure KMail... and click on the Accounts page to add or change
your account settings. See the Getting started section for more information on the settings in the
Accounts page.

To check for messages from a particular account, use the File → Check Mail In submenu to select
the account to check for mail. You can also press the mouse button on the Check Mail icon for
some time to get a list of accounts.
3.9 Signing and Encrypting Messages with GnuPG

This is a short introduction on how to setup KMail’s GnuPG (GNU Privacy Guard) support; it gives some hints on the use of GnuPG too. It is written for people who are beginners in this area; if you are familiar with the use of GnuPG, you can skip most of the steps.

Please also check out the FAQ item about GnuPG.

WARNING
Attachments will not be signed/encrypted if you are using inline OpenPGP: to sign/encrypt attachments, you have to install GnuPG and some necessary libraries; then, you can decide for each attachment whether it should be signed/encrypted or not.

WARNING
KMail has to rely on GnuPG’s output; this output is often different between different versions of GnuPG, so it is important that you test if encryption really works with your setup before you start using it seriously. KMail might not warn you if something fails -- enable Show signed/encrypted text after composing.

To setup and use GnuPG support in KMail it is necessary to have GnuPG installed and set up properly; of course, we cannot give you a full introduction of GnuPG here. We will only mention the steps you have to do to get GnuPG going. For details you should have a look at the The GNU Privacy Handbook.

It is certainly a good idea to study this documentation as well as an introduction into public key cryptography: there you can learn a lot about the basic concepts, which will help you to understand what is going on; also, many security related issues you should know about are discussed there.

Now, let us start.

3.9.1 Preconditions

KMail expects that your GnuPG binary is called gpg. If this is not the case for you, just make a symlink.

If you have not done so, you have to generate a key pair (secret and public key) for your identity. Either do that using KGpg or Kleopatra or do this at the command line: gpg --gen-key; KMail has no internal support for gpg’s key generation at this time. The identity (normally your name followed by your email address within brackets, such as John Doe <john@example.com>) and your passphrase are important for the co-operation between KMail and GnuPG.

3.9.2 GnuPG-Related Settings in KMail

Select the Composing tab on the Security settings page; there you will find the following options:

When encrypting emails, always also encrypt to the certificate of my own identity
If this option is off and you want to send an encrypted message to somebody, then you cannot read this message any longer after you have composed and encrypted it. Turn this option on to keep sent encrypted messages readable for you too.
Store sent messages encrypted

When this box is checked, sent messages are stored encrypted like they were sent. This is not recommended, as you will not be able to read the messages any longer if a necessary certificate expires.

Always show the encryption keys for approval

This will always open a dialog that lets you choose the keys used for each recipient when you are sending an encrypted message; if this option is off, KMail will show this dialog only when it cannot find a key for a recipient or when there are conflicting or unset encryption preferences.

Automatically encrypt messages whenever possible

If this option is on, KMail will automatically encrypt messages with the built-in OpenPGP support or the PGP/MIME-Plugin provided that, for every recipient, a trusted PGP key is found in your keyring and you did not tell KMail not to encrypt messages sent to certain recipients. If in doubt, KMail will ask whether the message should be encrypted or not.

Now that you have setup the encryption tool you have to tell KMail which OpenPGP key you want to use for signing and for encrypting messages; to do this go to the Identities configuration and set the key that should be used on the Cryptography tab of the identity configuration.

Now you are able to sign outgoing messages; to let people send you encrypted messages and to let them verify your signature you must send them your public key or upload your public key to a public GnuPG key server so that they can fetch your key from there. To send encrypted messages to other people or to verify their signed messages you will need their public keys; you can store your public key(s) on a public GnuPG key server.

3.9.3 Sign your Messages

You can compose your message as usual in the composer window of KMail. Before you send the message, check the Sign icon on the toolbar of the composer window; then, you can send the message. The identity you are using to write the current message needs to be connected to an OpenPGP Key in the Identity section of the Configure dialog. To sign the message, KMail needs to know your GnuPG passphrase: if you did not select Keep passphrase in memory in the Security section, KMail will ask you for it; otherwise, if you have already given the phrase to KMail, it will sign the message without any further prompt.

3.9.4 Encrypt your Messages

To send an encrypted message to somebody whose public key you have, you simply create the message in the composer window. Before you send the message, check the Encrypt button in the toolbar of the composer window; note that you might not have to check the button if Automatically encrypt messages whenever possible is selected in KMail’s configuration (see above). Then send the message.

If you checked the Encrypt button and KMail cannot find a matching key for a recipient, it will display a list containing all available keys in the Encryption Key Selection dialog; if KMail finds more than one trusted key for a recipient, it will display a list containing all matching keys for this recipient. In both cases you can select the key(s) which should be used for encrypting this message for the recipient in question. Using the Remember choice checkbox you can save your selection for future messages.

If you are using a key for the first time, there are conflicting Encryption Preferences, or if Always show the encryption keys for approval is selected in the Security section of KMail’s configuration dialog, the Encryption Key Approval dialog will appear; here, you can select different keys for the recipients and can set the Encryption Preference for each recipient. The default option,
Encrypt whenever encryption is possible, will automatically encrypt your message if there is a trusted key for each recipient.

As mentioned above, you will not be able to read your own encrypted sent messages if you do not check When encrypting emails, always also encrypt to the certificate of my own identity in the settings’ Security page.

3.9.5 Send your Public Key

Prepare a message to the person to whom you want to send your public key; then, choose, in the composer window’s menu, Attach → Attach My Public Key: this will attach the public key you defined for the current identity to the message. Now you can send the message.

Remember that it is not safe at all if you sign the message to make sure that the receiver will get the correct key: there can be a man-in-the-middle attack, as somebody can change the key and sign the message with that other key. That is why the recipient should verify the attached key by checking the key’s fingerprint against the one he received in a secure way from you; have a look at the GnuPG documentation for further details.

3.9.6 You received an encrypted Message

All you have to do is to select the message in KMail. You will be prompted for your passphrase; then, KMail will try to decrypt the message and show you the plain text if the message had been encrypted with your public key: if not, then you will not be able to read it. KMail stores the messages encrypted, so nobody can read these messages without knowing your passphrase.

3.9.7 Receiving a Public Key

You can receive a public key as an attachment or via http, ftp or a floppy. Before you can use this key to encrypt a message to the owner of the key, you should verify the key (check its fingerprint or look for trusted signatures); then, you can add this key to your public keyring by typing gpg --import filename at the command line. If the key is not certified with a trusted signature you cannot use it to encrypt messages unless you have signed the key with your key.

3.10 The Anti-Spam Wizard

3.10.1 Basics

KMail does not have a built-in spam detection solution: the developers believe using external, but specialized, tools is the better approach. KMail uses these tools through its flexible filter architecture. The Anti-Spam Wizard helps you with the initial filter setup.

What can the wizard do to help you?

It will give you some choices about how you want the spam filtering to be set up. Afterwards it will automatically create the appropriate filter rules.

What are the limitations of the wizard?

It can only initially set up the filters for you; and it will provide a standard setup. Manual modifications in existing filters are not considered. Instead, these filters are overwritten by the wizard.
You can activate the wizard via **Tools → Anti-Spam Wizard**....

The wizard scans for known anti-spam tools on your computer. It is also possible to use the results of spam checks made by your service provider by evaluating header information which has been added to the messages. You can let the wizard prepare KMail to use one or more of these in parallel. However, note that anti-spam tool operations are usually time consuming. KMail can appear to be frozen during the scan of messages for spam; you may encounter problems with the responsiveness of KMail. Please consider deleting the filter rules created by the wizard if the filtering becomes too slow for you. Here are some recommendations regarding the supported tools:

**Bogofilter**

Bogofilter is a bayesian filter, that means its spam detection relies on an initial training phase. On the other hand, it’s a pretty fast tool. That’s why it is recommended to be used by people who primarily want to have fast spam detection, and who won’t worry about the initial training before the detection rate increases significantly.

**SpamAssassin**

SpamAssassin is a pretty complex tool to use against spam. Although its behavior depends heavily on its configuration, it can detect spam quite well without any training. However, scanning a message takes a little longer compared to pure bayesian filters. Let’s say it’s not the tool of choice for people without some background information about SpamAssassin’s capabilities.

**Annoyance-Filter**

Perhaps not so often used until distributions pick it up. It’s clearly a tool for specialists.

**GMX Spam Filter**

If you get your mail via the GMX freemail provider, your messages are already scanned for spam. The result of that process is documented in a special header field of each message. It’s possible to use the content of this header field to sort out spam. There is no slowdown in the filtering if only this tool is used, as the messages have already been processed.

### 3.10.2 Advanced

Here are the details of how the wizard works: KMail can use several external tools to detect spam messages; it will try to automatically find out which tools are installed on your system and will show you these in a list. The list is ordered by the average speed of the filtering process of the tools. You can mark the tools which you want to be used by KMail to detect spam. Of course, you can close the wizard, install a new tool, and restart the wizard again.

If you have marked at least one tool, KMail is able to provide filters which allow the classification of the messages as spam or not spam. It will also provide actions to let you manually classify messages. These actions will be available via the menu and toolbar icons. If any of the tools you selected support Bayesian filtering (i.e. a method to detect spam based on statistical analysis of the messages) then these messages are not only marked but additionally transferred to the tools to enable them to learn thereby improving their detection rate.

On the second page, you will be able to select some additional actions to be performed in KMail with regard to spam messages: if you want messages detected as spam to be moved into a certain folder, select the appropriate folder and mark the **Move known spam to:** option; if messages detected as spam should additionally be marked as read, then mark the **Mark detected spam messages as read** option.

Selecting at least one of the available tools will allow the wizard to finish the filter setup. The wizard will not take any modifications in existing filters, formerly created by it, into consideration but will either append new filters or replace existing filters. In any case you may want to inspect the result of this process in the **Filter Dialog**. The wizard will also create toolbar buttons for
marking messages as spam or as ham; keep in mind that classifying messages as spam will also move those messages to the folder you had specified for spam messages, if you have selected the appropriate option.

3.10.3 Some More Details for Experts

The wizard uses information stored in a special configuration file named `kmail.antispamrc` (stored in the global or local KDE config directory). It will first check the global config file and then the local config file: if the local config file contains entries with higher (newer) version numbers per-tool the configuration data from the local file for that tool is used; that way, both administrators and users can update the wizard configuration.

The local detection of spam messages is achieved by creating `pipe through` actions per-tool within a special filter. Another filter contains rules to check for detected spam messages and actions to mark them and (optionally, depending on the choice in the wizard) to move them into a folder. Both filters are configured to be applied on incoming messages and on manual filtering.

Two filters are needed for the classification of ham and spam. They contain actions to mark the messages appropriately. As mentioned above, the filter for classification as spam can have another supplementary action to move the messages into a predefined folder. If the selected tools support Bayesian filtering, the wizard will create additional filter actions to pass the messages to the tools (via `execute command` actions) in the appropriate learning mode.

If you want to fine-tune the filtering process, you might be interested in the chapter about Filter Optimization.

3.11 The Anti-Virus Wizard

3.11.1 Basics

KMail does not have a built-in virus detection solution: the developers believe using external, but specialized, tools is the better approach. KMail uses these tools through its flexible filter architecture. The Anti-Virus Wizard helps you with the initial filter setup.

What can the wizard do to help you?

It will give you some choices about how you want virus filtering to be set up. Afterwards it will automatically create the appropriate filter rules.

What are the limitations of the wizard?

It can only initially set up the filters for you; and it will provide a standard setup. Modifying existing filters is not yet possible.

You can activate the wizard via `Tools → Anti-Virus Wizard`.

3.11.2 Advanced

The Anti-Virus Wizard basically works exactly as the Anti-Spam Wizard does. Here are the details of how the wizard works: KMail can use several external tools to detect messages containing viruses; it will try to automatically find out which of these tools are installed on your system and will show you the result of the search. You can mark the tools which you want to be used by KMail to detect viruses. Of course, you can close the wizard, install a new tool, and restart the wizard again.

If you have chosen at least one tool you will be able to select actions to be done in KMail to messages containing viruses: to let KMail detect messages containing viruses you definitely should
mark the **Check messages using the anti-virus tools** option; if you want messages detected as virus-infected to be moved into a certain folder, select the appropriate folder and mark the **Move detected viral messages to the selected folder** option; if messages detected as virus-infected should additionally be marked as read, then mark the **Additionally, mark detected viral messages as read** option.

Selecting at least one of these options will allow the wizard to finish the filter setup. The wizard will not take any existing filter rules into consideration but will append new rules. In any case you may want to inspect the result of this process in the Filter Dialog.

### 3.11.3 Details

The wizard uses information stored in a special configuration file named `kmail.antivirusrc` (stored in the global or local KDE config directory). It will first check the global config file and then the local config file: if the local config file contains entries with higher (newer) version numbers per-tool the configuration data from the local file for that tool is used; that way, both administrators and users can update the wizard configuration.

The detection of messages containing viruses is achieved by creating **pipe through** actions per-tool within a special filter. Another filter contains rules to check for detected viral messages and actions to mark them and (optionally, depending on the choice in the wizard) to move them into a folder. Both filters are configured to be applied on incoming messages and on manual filtering.
Chapter 4

Configure KMail

Daniel Naber
David Rugge
Marc Mutz
Michel Boyer de la Giroday
Laurent Montel
Scarlett Clark
2013-12-18
(KDE 4.12)

4.1 General Information

Configure KMail Dialog

KMail’s configuration window enables you to configure KMail in many ways. You can reach it via Settings → Configure KMail...
The KMail Handbook

The dialog has several buttons:

**Help**
This will open this manual at the appropriate page.

**Defaults**
This will reset the configuration options on the current page back to the default values.

**Reset**
This resets all changes you have made since you last saved the settings.

**OK**
This saves the settings and closes the configuration dialog.

**Apply**
This saves the settings without closing the configuration dialog.

**Cancel**
This closes the configuration dialog without saving the changes you have made.

The configuration pages are divided into six pages, each of them represented by one of the icons in the list on the left hand side of the dialog. The pages will be described in detail below.

4.2 **Identities Page**

You can find a quick introduction to the Identities page in the Getting Started section.

This page allows you to create one or more Identities, i.e. combinations of name, email address and other settings. For example, you can create one identity for business communication and one for personal communication. If you have more than one email address, you can create one identity per address. You will then be able to select an identity on a per-message basis.

The page consists of a list of identities and buttons to manage them. The identities list will always show at least one identity, which is then the Default identity.

To add a new identity to the identity list, click on the Add... button.

4.2.1 **The New Identity Dialog**

![New Identity Dialog](image)
You have to enter the name of the new identity into the **New Identity** edit field. This will be the name shown in the identity list.

You can choose how the new identity should be initialized by checking one of the three radio buttons in the middle of the dialog:

**With empty fields**
- All fields of the new identity are cleared or preset with standard values.

**Use System Settings values**
- Uses the values from *Account Details → Password & User Account* in the System Settings category *Common Appearance and Behavior*.

**Duplicate existing identity**
- Copies all fields from an existing identity. You can choose which identity to copy from by selecting the corresponding entry in the *Existing identities* drop down box.

### 4.2.2 General

The *General* tab allows you to specify some basic settings for the currently selected identity.

**Your name**
- Enter your full name here (sometimes also called *display name*). Although this field is not strictly mandatory, it is recommended to enter the correct value here.

**Organization**
- Enter your organization here. This field is optional.

**Email address**
- Enter your email address here, i.e. something like *joe@example.com*.

**Example 4.1 Email address**

So if your address is *Joe User <joe@example.com>*, you should enter *Joe User* into the *Your name* field and *joe@example.com* into the *Email address* field.
Email aliases

This field contains alias addresses that should also be considered as belonging to this identity (as opposed to representing a different identity).

Example 4.2 Email aliases

Primary address: first.last@example.org
Aliases: first@example.org and last@example.org

4.2.3 Cryptography

Identity Cryptography

The Cryptography tab allows you to specify OpenPGP and S/MIME keys associated with this identity, as well as choosing the preferred (cryptographic) message format to use.

OpenPGP signing key

Here you can select the key to be used when OpenPGP-signing messages written with this identity in effect.

For brevity, only the short key id of selected keys is shown. Hovering with the mouse over the key list will show more information in a tooltip.

To clear the label press the Clear button. To change the selected key, press the Change... button. A dialog listing all configured secret OpenPGP keys will be shown allowing you to select the one to use. If you do not have key configured yet, click the Start Certificate Manager to open Kleopatra. See Kleopatra for information on using Kleopatra to create and manage openpgp keys and certificates. Listed below is a brief description of the chosen key/certificate uses.

OpenPGP encryption key

Here you can select the key to OpenPGP-encrypt messages to when this identity and encrypting emails, always also encrypt to the certificate of my own identity are in effect. This key is also used for the Attach → Attach My Public Key function of the Composer.
S/MIME signing certificate

Here you can select the certificate to be used when S/MIME-signing messages written with this identity in effect.

S/MIME encryption certificate

Here you can select the certificate to S/MIME-encrypt messages when this identity and When encrypting emails, always also encrypt to the certificate of my own identity are in effect.

Preferred format

Here you can choose which cryptographic message format to use by default with this identity. You can either select any of the four formats supported by KMail or leave the option at the recommended default setting of Any, which will choose a suitable format based on the recipients of the message, or might even go so far as to create two copies of the message, one S/MIME signed and/or encrypted, the other OpenPGP signed and/or encrypted.

4.2.4 Advanced

The Advanced tab allows you to specify some rarely used or otherwise specialized settings for the currently selected identity.

Reply-To address

Enter the address to which replies to your messages should be sent. Only fill out this field if it is different from your normal address (specified using the Name and Email Address on the General tab), since replies default to the sender’s address anyway.

This field is only useful if you want replies to your mail to go somewhere else than your regular email address, e.g. if you are using this identity to send messages from an email address that cannot receive messages.

NOTE
Note that some mailing lists overwrite this header field with their post address to make sure that replies go to the list instead of individuals. So the usefulness of this field is very limited and it should only be used in rare cases.
BCC addresses
Optionally enter addresses separated by a comma to which blind copies of your messages should be sent to. When you compose a message with this identity, the BCC field is filled with these addresses. If you want to send a BCC regardless of this setting, you should look at the Headers tab of the Composer page.

Dictionary
Select the default dictionary for current identity.

Sent-mail folder
Select the folder into which messages should be filed after sending when using this identity. IMAP users should consider changing this to an IMAP folder, so their sent-mail is stored on a server instead of being stored in a local folder. This way they can access these messages from a different location.

Tip
You can exercise more fine-grained control over where to file sent messages by creating a corresponding message filter that is applied to outgoing messages.

Drafts folder
Select the folder into which drafts should be filed when using this identity. IMAP users should consider changing this to an IMAP folder, so their drafts are stored on a server instead of being stored in a local folder. This way they can easily continue to work on their drafts at a different location.

Templates folder
Select the folder into which templates should be filed when using this identity. Please see Compose from templates for more information on templates.

Outgoing Account
Select or enter an alternative SMTP server to be used when sending messages using this identity.

Note
You need to configure outgoing mail servers first, before you can choose them from the list. You can do this on the Sending tab of the Accounts page.
4.2.5 Templates

Identity Templates

Here you can create and manage templates to use when composing new messages, replies or forwarded messages.

The message templates support substitution commands, either simply type them or select them from the Insert Command menu. Templates specified here are identity-specific. They override global templates, but can be overridden by per-folder templates if they are specified.

4.2.6 Signature

Identity Signature
This tab allows you to specify a signature (sometimes called ‘footer’ or ‘disclaimer’) to be appended to each message sent using this identity.

**NOTE**
This type of signature has nothing to do with the (digital) signatures for which you can select the keys to use on the Cryptography tab. It is just bad wording to call this a signature, but since the term is already used everywhere else, we keep this notation. Just keep in mind that these signatures and digital signatures are two completely different things.

Check the Enable signature option if you want to be able to append the signature when using this identity. To automatically append it to every new message you also have to select Automatically insert signature in the Composer configuration page.

KMail can obtain the signature text from various sources. The default is Input Field Below. Just enter what you would like your signature to be into the textbox.

The traditional way on Unix is to read the text from a file called .signature in your home folder. This file can be shared between several programs, so you get the same signature in each mail program you use. Select File from the Obtain Signature text from drop down menu. If you want to edit the file, click the Edit File button.

KMail can also read the signature text from the output of a command. Thus, you can use programs such as fortune to create a new signature text for every message. Everything the program prints onto stdout is caught and used as the signature text. To read the text from the output of a command you select Output of Command. Enter the command (preferably with full path) in the Specify command edit field.

**NOTE**
On the Internet, signatures are by convention separated from the body of the message by a line containing only the three character ‘-- ’ (dash, dash, space). KMail will automatically prepend the signature text with this line if it is not already present in the signature text.

If you do not wish the separator to be prepended automatically by KMail, simply add it to the signature text yourself.

### 4.2.7 Picture

KMail can send a small (48x48 pixels), low-quality, monochrome picture with every message. For example, this could be a picture of you or a glyph. It is shown in the recipient’s mail client (if supported).
KMail can send a small (48x48 pixels), low-quality, monochrome picture with every message. For example, this could be a picture of you or a glyph. It is shown in the recipient’s mail client (if supported).

**Send picture with every message**

Check this box if you want KMail to add a so-called X-Face header to messages written with this identity. An X-Face is a small (48x48 pixels) black and white image that some mail clients are able to display.

**External Source**

- **Select File...**
  
  Use this to select an image file to create the picture from. The image should be of high contrast and nearly quadratic shape. A light background helps improve the result.

- **Set From Address Book**
  
  You can use a scaled-down version of the picture you have set in your address book entry.

**Input Field Below**

Use this field to enter an arbitrary X-Face string. Examples are available at [https://ace.home.xs4all.nl/X-Faces/](https://ace.home.xs4all.nl/X-Faces/)

### 4.3 Accounts Page

You can find a quick introduction to the Accounts page in the Setting up your Account section. This page allows you to create one or more (incoming and outgoing) accounts, i.e. combinations of mail servers, login information and other settings. Typically, you will create one outgoing (used for sending messages) and one incoming (used to retrieve messages) account. You can create as many accounts as you want, though, and assign each one to different identities or decide on a per-message basis.

#### 4.3.1 Sending

The Sending tab allows you to define new outgoing mail servers and set some common options. For basic information, see Setting up your Account: Sending.

When you click **Add...** or **Modify...** the Create Outgoing Account or Configure account dialogs will open respectively. For sending via sendmail® or similar programs you can specify a name and the location of the sendmail® program. For SMTP you can specify Name, Outgoing mail server, and Port of the server. Server requires authentication will enable the Login and Password fields. If you are not sure about the security settings you can make KMail test for the best settings by using Auto Detect on the Advanced tab.

Confirm before send will pop up a confirmation box every time you send a message.

Send messages in outbox folder lets you specify when queued messages, i.e. messages in the outbox folder pending to be sent, should be sent. You can choose between:

- **Never**,
- **Automatically**,
- **Queued messages will only be sent if you select File → Send queued messages.**
On Manual Mail Checks
Queued messages will be sent after you have manually checked for new mail, e.g. with File → Check Mail. Of course, you can also manually send the queued messages with File → Send queued messages.

On All Mail Checks
Queued messages will be sent after all checks for new mail, i.e. after automatic mail checks as well as after manual mail checks. Of course, you can also manually send the queued messages with File → Send queued messages.

Default send method lets you define what happens when a message is sent. If Send now is selected, the message is sent to the mail server immediately, while if Send later is selected, the message is queued in the outbox to be sent later with the File → Send Queued Messages command or automatically when you check your mail, depending on the setting of Send messages in outbox folder above.

4.3.2 Receiving
For basic information, see Setting up your Account: Receiving.

Using the Retrieval Options popup menu for each resource, lets you specify whether KMail should check for new mail immediately after it has been started. You can also select Include in Manual Mail Check and Switch offline on KMail Shutdown.

With New Mail Notification you can set how KMail will notify you if new messages have arrived: Beep will play a short beep sound; if Detailed new mail notification is enabled then KMail will show the number of new messages for each folder provided you have chosen to be notified with a dialog. More advanced notification options, like showing a dialog or running a certain command, are available via the Other Actions button.

4.4 Appearance Page

4.4.1 Fonts
This section allows you to change the type, size and character set of the display fonts. Message Body sets the font for the reader pane, Composer sets the font for the body of your messages written in KMail Composer.

4.4.2 Colors
This section allows you to change the color of the text by double clicking on an item in the listbox. Recycle colors on deep quoting will restart the quote coloring at the first level after the third level of quoting has been reached. Note that the Quoted text colors only work in the message reader, not in the composer. If you want folders which are close to their quota (space allotment, usually used on IMAP servers) to be displayed in a different color, you can specify a percentage value as a threshold for this. The color to be used can be configured along with the other custom colors.
4.4.3 Layout

This tab lets you configure the layout of the main window.

In the Folder List section you can choose between the Long folder list (default) using the full height of the window and the Short folder list with the message preview pane using the entire bottom part of the window.

If you want to have your favorite folders and a quick search field for folders at the top left of the main window select the next two options.

The Show Favorite Folders View section allows you to change how your favorites folder displays your favorite folder. As Icons uses a lot of space, so if you have several favorite folders you might try As List. If you do not have any favorite folders you can disable the view altogether by selecting Never.

On by default, Folder Tooltips display additional information like the total number of messages, unread messages and storage size when hovering a folder with the mouse pointer. Select Never to disable this feature.

You can choose where in relation to the message list you want the Message Preview Pane or disable it all together.

4.4.4 Message List

In the General section you can alter the appearance of the Message List pane.

Choose to Display tooltips for messages and group headers. Check Hide tab bar when only one tab is open to have more space for the messages in the list.

The next options are the settings for Default Aggregation and Default Theme which can be overridden using the Folder Properties dialog for each folder individually.

Using the Configure button opens a window to customize the default aggregation or theme to your needs and allows you to add your own.
Default aggregation

Senders/Receivers, Flat
This view groups the messages by senders or receivers (depending on the folder type). Messages are not threaded.

Activity by Date, Flat
This view uses day-by-day groups. Messages are not threaded. So for example, in ‘Today’ you will simply find all the messages arrived today.

Activity by Date, Threaded
This view uses day-by-day groups. Messages are threaded. So for example, in ‘Today’ you will find all the messages arrived today and all the threads.

Current Activity, Flat
This view uses smart date range groups. Messages are not threaded. So for example, in ‘Today’ you will simply find all the messages arrived today.

Current Activity, Threaded
This view uses smart date range groups. Messages are threaded. So for example, in ‘Today’ you will find all the messages arrived today and all the threads that have been active today.

Thread Starters
This view groups the messages in threads and then groups the threads by the starting user.

Flat Date View
This is a plain and old list of messages sorted by date: no groups and no threading.

Standard Mailing List
This is a plain and old mailing list view: no groups and heavy threading.

Customize...

Customize Message Aggregation Modes
To create a custom aggregation theme, click the Configure... button. Select an existing aggregation similar to what you want to change it to and click the Clone Aggregation, if none are similar click the New Aggregation button. The General tab allows you to change the Name: and Description: The Groups & Threading tab allows you to configure several elements to customize your aggregation.
• **Grouping:** Allows you to select from dates, sender/receiver or none. With the smart options KMail will group related emails together.

• **Group expand policy:** Allows you to set whether KMail will automatically expand grouped emails.

• **Threading:** Allows you to change if KMail will include references and subject in determining perfect threading. You can also turn off threading all together.

• **Thread leader:** Allows you to change the leader of the thread between most recent message or topmost.

• **Thread expand policy:** Allows you to change how KMail determines whether a thread should be expanded or no expanding at all.

The **Advanced** allows you to change the **Fill view strategy:** You would choose Favor speed if you have a slow connection. Interactivity will show all of your current conversations first. And Batch mode will not sort the view at all.

**Default Theme**

**Classic**
A simple, backward compatible, single row theme

**Smart**
A smart multi-line and multi-item theme

**Smart with Clickable Status**
A smart multi-line and multi-item theme with a clickable status column

**Configure...**

![](image)

**Customize Message List Theme**
To create a custom message list theme, click the **Configure...** button. Select an existing theme similar to what you want to change it to and click the **Clone Theme**, if none are similar click the **New Theme** button. The **General** tab allows you to change the **Name:** and **Description:**.

The **Appearance** tab allows you to configure visible columns and status items. To add a column, right click the column bar and select **Add Column**. Name the column and select what the column will represent from the **Header click sorts messages:**.
The KMail Handbook

drop down list. By default **Visible by default** is checked, uncheck it if you only want the column to be available on the right mouse button add or remove menu for the clickable sort bar. Then drag the appropriate label from the **Content Items** to the column view box under the column bar, e.g. if you chose to add a size column you would drag the Size label to underneath the Size column. Continue to do this until you have all the columns you desire. You can change the font and color of column items through the view area right mouse button menu. Move, delete and resize columns through the right mouse button menu of the column bar.

The **Advanced** tab allows you to change whether to show headers. You can also change the size of status icons.

In the **Date Display** section you can choose between several date formats. The **Localized Format** is the one you can specify under **Country/Region & Language** in the System Settings. **Smart format** will show today, yesterday etc. The **Custom format** you can get a description of the possible values by clicking on **Custom format information** option.

### 4.4.5 Message Window

If the **Close message window after replying or forwarding** option is activated, KMail will close the message window after replying to or forwarding the message that is displayed in the window. This only applies to the separate message window, not to the embedded message preview pane.

By default, **Enable access key** is enabled. Access keys allow you to use the keyboard keys for functions which would perhaps normally be done with the mouse, such as following links. For more information on access keys please see **Access keys**.

**Show HTML status bar** activates a bar at the left side of the reader pane that tells you if a message is HTML or not. This is important because HTML messages might imitate the look of a signed and encrypted message, so you should be aware of the fact that you are reading an HTML message. The HTML status bar itself cannot be influenced by the HTML code of the message.

Enable **Replace smileys by emoticons** if you want smileys like :-)) appearing in the message text to be replaced by emoticons (small pictures) such as 😛.

Enable **Reduce font size for quoted text** to show quoted text with a smaller font.

Enable **Show expand/collapse quote marks** to show different levels of quoted text. Disable to hide the levels of quoted text.

**Fallback character encoding**: Some emails, especially those generated automatically, do not specify the character encoding which needs to be used to properly display them. In such cases a fallback character encoding will be used, which you can configure here. Set it to the character encoding most commonly used in your part of the world. As a default the encoding configured for the whole system is used.

**Override character encoding**: Changing this from its default **Auto** will force the use of the specified encoding for all emails, regardless of what they specify themselves.

**Minimum font size**: This option allows you to set the smallest size a font will show as. This can be helpful if you have a hard time reading really small fonts.

To customize which headers you would like to view in the message window (e.g. subject, from, to, cc, bcc, date), click the **Configure Custom Headers** button next to **Headers**: Add your selection in the dialog that pops up. If you are using fancy headers, you can enable **Show spam status in fancy headers** here. Please note that if your email provider does not provide Spamassassin services to check your email for spam, you will need to install it on your computer. e.g. through a package manager (Yast on SuSE®, Ubuntu™ Software Center on Ubuntu™ etc.). For more information see: **Anti-Spam Wizard** to set up spamassassin with KMail.
4.4.6 System Tray

If you enable the system tray icon then a small KMail icon with the number of unread messages will be shown in the system tray. You can enable KMail’s system tray icon with Enable system tray icon, and with System Tray Mode you can specify whether the tray icon should always be shown or only if you have unread messages.

If the icon is visible then you can hide KMail’s main window by clicking on the icon or by clicking on the window close button. By clicking on the icon you can make KMail’s main window visible again. If you click on the icon with the right mousebutton then you get a menu with a few useful commands. You can check for new mail, create a new message or quit KMail. Additionally, there is the entry New Messages In which lists all folders containing unread messages. If you choose one of those folders then this folder will be selected in KMail’s main window.

4.5 Composer Page

4.5.1 General

Automatically insert signature
If checked, your signature as defined in the identity page is automatically included at the end of all messages you create (i.e. new messages, replies, etc.).

Use smart quoting
If checked, KMail will break long lines but will try to keep the correct quoting (e.g. the ‘> ’ will always be at the start of the line).

Only quote selected text when replying
If checked, KMail will quote only the selected text in the message window, instead of the complete message, when replying. With this, it is possible to quickly generate replies that quote only the relevant paragraph to which you are actually replying, and omits the other paragraphs that are not relevant to the context.

Remove the signature when replying
If checked, KMail will remove the signature from the quoted text when replying to a message. This is useful since it reduces the amount of quoted text, which makes it easier to read the reply.

Automatically request message disposition notifications
If checked, Options → Request Disposition Notification will default to on. Check this option only if you know what you are doing. MDNs are considered a nuisance (or are simply ignored) by a lot of people. It is better to decide to request them on a message-by-message basis.

Word wrap at column
Lets you turn word wrapping on and off in the composer window and lets you set the column at which words will be wrapped (you probably should not need to change the default value, which is 78).

Autosave interval
A backup copy of the text in the composer window can be created regularly. This option lets you specify the interval used to create the backup. You can disable autosaving by setting it to the value 0.
4.5.2 Standard Templates

Here you can add, edit, and delete custom message templates to use when you compose a reply or forwarding message.

Message templates support substitution commands, by simply typing them or selecting them from the Insert Command menu.

These are global (default) templates. They can be overridden by per-identity templates or per-folder templates if they are specified.

4.5.3 Custom Templates

Here you can add, edit, and delete custom message templates to use when you compose a reply or forwarding message. Create the custom template by typing the name into the input box and press the + button. You can bind a keyboard combination to the template for faster operations.

Message templates support substitution commands, by simply typing them or selecting them from the Insert Command menu.

There are four types of custom templates: used to Reply, Reply to All, Forward, and Universal which can be used for all kinds of operations. You cannot bind a keyboard shortcut to Universal templates.

4.5.4 Subject

This section contains a list of prefixes for ‘Reply’ and ‘Forward’. If you receive messages that use prefixes different to the standard ones, you can add them here so KMail will recognize them. This way KMail can ignore them for sorting messages and when setting the subject of a reply or a forwarded messages, and optionally replace them with ‘Re:’ or ‘Fwd:’ respectively.

4.5.5 Charset

Here you can manage the default charsets used for your own messages. Every message you send will be checked if it is written in one of the listed charsets, starting at the top of the list. If it is, this charset will be used. If it is not, a dialog will show up and tell you that you manually have to choose a charset using Options → Set Encoding.

If you select Keep original charset when replying or forwarding (if possible), the original message’s charset will be kept, unless there are now characters that cannot be represented using that charset.

4.5.6 Headers

Check the Use custom message-id suffix checkbox if you want KMail to generate Message-Id’s with a custom suffix. Enter the desired suffix in the Custom message-id suffix field. Please make sure that the suffix that you specify is world-wide unique. The best thing is to use the name of a domain which you are the owner of. If you do not check Use custom Message-Id suffix then KMail will automatically generate the complete Message-Id. If you do not know what this is all about do not check this option.

The Define custom mime header fields list sets the headers that KMail will use for its outgoing messages. You can both invent new fields and overwrite existing ones. This feature is only useful for advanced users.
4.5.7 Attachments

If you have to send attachments with filenames containing non-English characters to users of Microsoft® Outlook or Microsoft® Outlook Express then you might want to check the Outlook-compatible attachment naming option. KMail will then encode the attachment names in a non-standard way that is understood by Microsoft® Outlook.

Note that KMail will create non-standard compliant messages, and consequently it is possible that your messages will not be understood by standard-compliant mail clients. So, unless you have no other choice, you should not enable this option.

Check the Enable detection of missing attachments checkbox if you want KMail to warn you whenever you are about to send a message without attachments although the message text contains certain words which indicate that you wanted to include an attachment. The list of key words can be modified.

4.5.8 Autocorrection

To enable the feature, check the Enable autocorrection option. In the drop down box choose the language you would like to use. You can import settings from LibreOffice or another KMail installation by selecting the appropriate choice from the Import drop down box. If you need to save your settings for another installation or application, select the Export button.

AUTOCORRECT OPTIONS

Simple Autocorrection
This allows you to configure KMail to autocorrect various simple corrections. Check the box next to the autocorrect feature you would like to enable.

Custom Quotes
You can replace double or single quotes with typographical quotes by checking the appropriate box. You can also add non breaking space before specific punctuation marks in French text by selecting the option.

Advanced Autocorrection
You can enter custom automatic word replacement by checking this option. To enter a custom string to replace automatically enter the word to be replaced in the Find box, and the replacement word in the Replace box and click the Add button. To remove a custom word replacement string, highlight the string and click Remove.

Exceptions
This allows you to set exceptions where you would like KMail to ignore your autocorrect selections for end of sentence and two uppercase letters. Enter the exception and click Add button. To remove the exception, highlight the string and click Remove button.

Once you have made all of your autocorrect selections click the Apply button.

4.5.9 Auto Resize Image

In some circumstances you may need to have KMail automatically resize image attachments on outgoing emails, e.g. Mail server limits. To do so, select Automatically resize images. There are several options that come with this feature.
The KMail Handbook

General

Some general options for auto image resizing are as follows: If you need your images to keep the ratio of length and width intact e.g. Photographs, select Keep ratio. The default behavior is for KMail to prompt and ask if you want to resize before resizing, if you want it to resize without asking, unselect Ask before resizing. KMail will save the file in JPG, if you would rather have them save in PNG format, select it from the Write to format drop down box.

Image

Say you have a relative that can only receive image files of a certain size due to their email providers limits, you can use the Reduce image to maximum dimension: option to select a size to reduce the image to and enter their email into the filters on the Recipients tab. The recipients tab is discussed in further detail at the end of this section. If you need a custom size, choose the last option Custom from the width and height drop down boxes, and enter the number in the text box. You can also enlarge images by selecting Enlarge image to minimum dimension. The last option allows you to skip images of a certain filesize (this will verify image size by width x height only).

Filename

Source filter

If you would like the resizing to be done based on the name of the file, you would select the appropriate filter here. e.g. You need to send your boss multiple images daily, and your boss requires them to be the same size. You could name all of your work images work1, work2 etc. then select Include all files whose names contains one of the patterns and enter work into the Pattern: text box. You can also exclude files in the same way by selecting Exclude all files whose names contains one of the patterns. The default behavior is no filtering.

Image Format

Select Resize all images with one of these formats to set a specific format to resize the image to.

• When this option is enabled you must select the Select Format... button and select a format from the dialog.

Resize filename

Select Rename resized images with the following pattern if you would like your resized images to be renamed with a specific pattern. Enter the pattern into the text box. You can use:

%t set current time
%d set current date
%n original filename
%e original extension
%x new extension

Recipients

This tab is where you would specify recipients that need to have resized images. e.g. grandma@myfamily.net; boss@mywork.com. You need to decide if you need multiple or only one, and enter the email(s) into the text box using the ‘;’ as a separator when you have multiple. You can also specify if you do not want certain recipient(s) images to be resized. The default is no filtering.

4.5.10 External Editor

Use external editor instead of composer
This selection allows you to use a different editor. Please note that the composer window will still open, and the external editor will open on top of the composer window. When you are done, save the text and exit the editor. The text will now appear in the composer window, where you can send it. Note that your editor may not return immediately, you have to use e.g. `gvim -f %f` for gvim.

4.6 Security Page

4.6.1 Reading

On this tab you can configure security-relevant options for reading messages.

Prefer HTML to plain text

By default KMail will show HTML messages in plain text. If you prefer to view messages with HTML formatting and layout automatically, select this option. However, we recommend leaving this option off, as security problems with HTML might show up.

You can still easily view messages in HTML format per email by clicking the plain message/html message toggle bar on the left hand side of the message window. Please see Message Window to enable this feature.

Allow messages to load external references from the Internet

If checked, KMail can load external images, stylesheets etc. from the Internet when you look at an HTML message. We strongly recommend to leave this option off (although it has no effect if you only view plain text messages).

By adding external references to their messages, people sending spam can detect when you have looked at their message, your location, and alot of other information that gets logged on web servers. Note that this option has no effect on Java™, JavaScript and Plugins as these are not supported in KMail at all, which is a good thing, as most viruses propagate through these.

Informs if message reading is a suspected email scam

With the popularity of email, unfortunately comes the popularity of email scams. Email scams can include emails made to appear as though they come from legitimate companies, but they really link to malicious web sites requesting your personal information. This can lead to identity theft and worse. By default KMail analyzes messages for common scams, and will inform you if the email is a suspected scam. It is highly advised to keep this feature enabled. If you wish to disable this great feature, uncheck Informs if message reading is a suspected email scam.

If you have legitimate emails being flagged, e.g. from trusted friends, you can add their email to the Whitelist: by clicking the Add... and enter the email into the dialog that pops up. Please note that at this time, only individual emails are supported.

Encrypted messages

By default, KMail will automatically attempt to decrypt encrypted messages when you view them. If you prefer to do it manually, unselect this option.

Certificate & Key Bundle Attachments

If you would like to have KMail to Automatically import keys and certificate from incoming messages for decryption, select this option.

Message Disposition Notifications

MDNs are a generalization of what is commonly called a ‘read receipt’. The message author requests a disposition notification to be sent and the receiver’s mail program generates a
reply from which the author can learn what happened to his message. Common disposition
types include ‘displayed’ (i.e. read), ‘deleted’ and ‘dispatched’ (e.g. forwarded).
The following options (listed as **Send policy**) are available to control *when* KMail sends
MDNs:

**Ignore (recommended)**
Ignores any request for disposition notifications. No MDN will ever be sent automat-
ically.

**Ask**
Answers requests only after asking the user for permission. This way, you can send
MDNs for selected messages while denying or ignoring them for others.

**Deny**
Always sends a ‘denied’ notification. This is only *slightly* better than always sending
MDNs. The author will still know that the messages has been acted upon, he just
cannot tell whether it was deleted or read etc.

**Always send**
Always sends the requested disposition notification. That means that the author of
the message gets to know when the message was acted upon and, in addition, what
happened to it (displayed, deleted, etc.). This option is strongly discouraged, but
since it makes sense where privacy is not a concern, e.g. in customer relationship
management, it has been made available.

If you are unsure, experiment a while with **Ask** and if you find KMails questions annoying,
switch to **Ignore**.

The following options (listed as **Quote original message**) are available to control *how much*
of the original message KMail sends back in MDNs.

**Nothing**
No parts of the message other than the mandatory message-id and the original recip-
ient is included in the MDN reply. This preserves enough information for the sender
to find the message in his sent messages for which this MDN was generated.

**Full message**
Attaches the complete message to the disposition notification. Usually, this is overkill.
It does not add any valuable information that cannot be deduced from the message
headers alone, but people sometimes insist on this, since it is much easier for humans
to correlate the content of the message than just the headers to what they sent earlier.

**Only headers**
Attaches only the headers to the disposition notification. This is usually enough to
enable both humans (by subject) and computers (by message-id) to easily correlate
MDN and original message.

If unsure, leave the option at the default.

**Do not send MDNs in response to encrypted messages**
This option suppresses the sending of MDNs if the message is encrypted (partially or in
whole). This thwarts attempts to use KMail’s MDN feature as an *oracle* to deduce whether
you were able to decrypt the message or not.

Strictly speaking, this option is not needed, since KMail sends MDNs regardless of whether
the message could be successfully decrypted or not (the disposition notification request
resides in the unencrypted part of the message), but it gives the security-conscious user
the choice to either send them always if requested (option unchecked), or never (option
checked).

If unsure, leave the option checked.
Automatically import keys and certificates

If checked, KMail automatically imports any attachments containing OpenPGP keys into your local keyring, and any attachments containing S/MIME keys into your local key box.

**NOTE**
Verifying S/MIME signatures always involves importing the contained certificates. This option thus does not affect this. It is also unrelated to GPG's auto-key-retrieve feature, where GPG will try to import unknown keys from a key server.

### 4.6.2 Composing

On this tab you can configure security-relevant options for composing messages.

**Automatically sign messages**

If checked, the Options → Sign Message option in the composer will default to on. However, you can still switch it on and off on a per-message basis.

**When encrypting emails, always also encrypt to the certificate of my own identity**

If checked, any message that is encrypted to the recipients will additionally be encrypted to yourself.

**WARNING**
If you uncheck this option, you may not be able to decrypt the messages written by yourself and encrypted to other people anymore.

**Store sent messages encrypted**¹

If checked, messages are stored in your sent-mail folder just as you sent them (i.e. if they were encrypted, they are also stored that way).

If unchecked, messages will always be stored unencrypted in your sent-mail folder, even if they are sent encrypted.

**Always show the encryption keys for approval**

If checked, every time you encrypt a message, a dialog will appear that presents you with the encryption keys that will be used for each recipient. You can then review the choice of keys, change them, and approve or cancel the encryption operation. We recommend to keep this option checked, since it makes the encryption process more transparent.

**Automatically encrypt messages whenever possible**

Also called ‘opportunistic encryption’. If checked, KMail will try to match recipients to (OpenPGP or S/MIME) keys even when you did not specifically request encryption. If usable keys are found for all recipients, KMail will ask whether or not you want to encrypt the message.

It is highly recommended to turn this on, as it makes encrypting messages really easy to use.

---

¹ This option enables a mode of using mail encryption that is sometimes (misleadingly) called ‘transport-only’ encryption. In this mode of operation, the message encryption is stripped off as soon as the message has reached its destination. The encryption lasts only while the message is on its way.

KMail supports this mode half-heartedly, since such functionality should better placed at the mail server (MTA) than at the mail client (MUA) level. Thus, future versions of KMail may drop support for this option.
Never sign/encrypt when saving as draft

If checked, KMail will not attempt to sign and/or encrypt messages that are merely saved to the drafts folder. This is more convenient, and does not result in a gross loss of security, provided the drafts folder is safe. IMAP users might want this option turned off, if their drafts folder is on the server.

4.6.3 Miscellaneous

On this tab you can switch security-relevant warnings on and off.

Warn when trying to send unsigned messages

If checked, KMail will show a warning if for whatever reason a message would be sent without being digitally signed.

Warn when trying to send unencrypted messages

If checked, KMail will show a warning if for whatever reason a message would be sent without being encrypted.

**NOTE**

While it is common to sign all outgoing messages, encrypting them is not. So unless your company has a policy of never sending any unencrypted messages, it might be a good idea to keep this option switched off and rely on opportunistic encryption to alert you if you could send encrypted messages, but did not request it.

Warn if receiver's email address is not in certificate

If checked, KMail will emit a warning if an S/MIME certificate or OpenPGP key will be used for a recipient whose email address is not listed in the email addresses stored in the certificate.

Situations in which this warning will trigger include when configuring your per-identity OpenPGP keys or S/MIME certificates, when encrypting, and when verifying signatures, if the signature was made with a certificate that does not include the email address of the sender.

Warn if certificates/keys expire soon

If checked, KMail will warn when an S/MIME certificate or OpenPGP key is used which will expire soon.

The period in which to warn before key/certificate expiration can then be configured separately for signing and encryption keys, as well as (in the case of S/MIME), for end-user certificates, intermediate CA certificates and root certificates.

Re-Enable All “Don’t Ask Again” Warnings

Apart from the main warnings described above, there are more warning and information messages, which contain an option to not show them again. If you would like to re-enable them after choosing not to show them again, you can achieve this by pressing this button.²

² This will re-enable *all* such warnings for KMail. It does not make much sense to allow more fine-grained selection of which warnings to show since you can just check the option to suppress them again when they next show up.
4.6.4 S/MIME Validation

This tab contains selected entries from GpgSM’s. Please refer to the GpgSM manual for a description of these options.

Validate certificates using CRLs
If checked, S/MIME certificates are validated using Certificate Revocation Lists (CRLs).

Validate certificates online (OCSP)
If this option is selected, S/MIME certificates are validated using the Online Certificates Status Protocol (OCSP).
Fill in the URL of the OCSP responder in the field reserved at this effect.

OCSP responder URL
Enter the address of the server for online validation of certificates. The URL is usually starting with https://.

OCSP responder signature
Select or change and enter the S/MIME key to use.

Ignore service URL of certificates
Check this option to skip online validation using the OCSP. This Option requires dirnmgr >= 0.9.0.

Do not check certificate policies
By default, GnuPG uses the file ~/.gnupg/policies.txt to check if a certificate policy is allowed. If this option is selected, policies are not checked.

Never consult a CRLs
If this option is checked, Certificate Revocation Lists are never used to validate S/MIME certificates.

Fetch missing issuer certificates
Check this option if you want the missing issuer certificates to be fetched when necessary. This applies to both validation methods, CRLs and OCSP.

Do not perform any HTTP requests
Entirely disables the use of HTTP for S/MIME.

Ignore HTTP CRL Distribution Point of certificates
When looking for the location of a CRL, the ‘to-be-tested’ certificate usually contains what are known as CRL Distribution Point (DP) entries, which are URLs describing the way to access the URL. The first found DP entry is used. With this option all entries using the HTTP scheme are ignored when looking for a suitable DP.

Use system HTTP proxy
If this option is selected, the value of the HTTP proxy shown on the right (which comes from the environment variable http_proxy) will be used for any HTTP request.

Use this proxy for HTTP requests
Enter here the location of your HTTP Proxy, which will be used for all HTTP requests relating to S/MIME The syntax is ‘host:port’, for instance myproxy.nowhere.com:3128.

Do not perform any LDAP requests
Entirely disables the use of LDAP for S/MIME.
Ignore LDAP CRL Distribution Point of certificates
When looking for the location of a CRL, the ‘to-be-tested’ certificate usually contains what are known as CRL Distribution Point (DP) entries, which are URLs describing the way to access the URL. The first found DP entry is used. With this option all entries using the LDAP scheme are ignored when looking for a suitable DP.

Primary host for LDAP requests
Entering a LDAP server here will make all LDAP requests go to that server first. More precisely, this setting overrides any specified host and port part in a LDAP URL and will also be used if host and port have been omitted from the URL. Other LDAP servers will be used only if the connection to the proxy failed. The syntax is HOST or HOST:PORT. If PORT is omitted, ‘port 389’ (standard LDAP port) is used.

4.7 Misc Page

4.7.1 Folders

Ask for confirmation before moving all messages to trash
Enable this option if you want to be asked for confirmation whenever you use Folder → Move All to Trash.

Exclude important messages from expiry
Enable this option if important messages should never be deleted during message expiration, i.e. during automatic deletion of old messages.

When trying to find unread messages
This option controls what happens if you press one of the shortcuts to go to the next or previous unread message (e.g. Space). If you ask KMail to go to the next unread message although there is no unread message below the currently selected message then the following happens:

• If Do not Loop is selected then nothing will happen.
• If Loop in Current Folder is selected then KMail will search from the beginning of the current folder for an unread message. If none is found then nothing happens.
• If Loop in All Folders is selected then KMail will first search in the current folder for another unread message. If none is found then KMail will search the next folder containing unread messages.

Correspondingly, if you ask KMail to go to the previous unread message.

When entering a folder
This option controls what happens if you open a folder.

• If Jump to First Unread Message is selected then KMail will select the first message it finds that is marked as unread.
• If Jump to Last Selected Message is selected then KMail will select the message that was selected when the folder was open the last time.
• If Jump to Newest Message is selected then KMail will select the newest message by date.
• If Jump to Oldest Message is selected then KMail will select the oldest message by date.

Mark selected message as read after...
When you select a new or unread message, KMail will change the message’s status to read after the number of seconds entered here. If you disable this option, messages will keep their new or unread status.
Ask for action after dragging messages to another folder
When you drag a message to a different folder, a small popup will ask you if you want to move or copy the message. If you disable this option, the message will be moved immediately, without a popup.

Open this folder on startup
Here you can set the folder that should be selected by default if you start KMail. If you use only IMAP folders then you might want to set this to your IMAP inbox folder. If you do that, you can collapse the local folders in the folder list, and then they will stay collapsed when KMail starts.

Empty the local trash folder on program exit
The trash folder is cleared of messages when you quit KMail if this option is selected.

4.7.2 Invitations

Mangle From:/To: headers in replies to invitations
Enable this option to make Microsoft® Outlook understand your answers to invitations replies.

Send invitations in the mail body
Invitations are usually sent as attachments to a mail. When this option is enabled, invitation are sent in the text of the mail, which is necessary to send invitations and replies to Microsoft® Outlook.

Exchange compatible invitations naming
Microsoft® Outlook, when used in combination with a Microsoft® Exchange server, has a problem understanding standards-compliant groupware e-mail. Enable this option to send groupware invitations in a way that Microsoft® Exchange understands. The invitation will be sent as an attachment with name ical.ics.

Outlook compatible invitation reply comments
When the user provides comments when responding to invitations, send the comment in a way that Microsoft® Outlook understands. If this option is not enabled, the response comments will not be seen in Outlook.

Show invitation update differences in the Outlook style
When viewing updated invitations, this option enables the differences between the previous and current invitations to be displayed in a way very much like Microsoft® Outlook. This is the default. The user can turn this option off if they want to see the invitation update differences shown in the ‘classic’ KMail style.

Automatic invitation sending
When this is checked, you will not see the mail composer window. Instead, all invitation mails are sent automatically. If you want to see the mail before sending it, you can uncheck this option. However, be aware that the text in the composer window is in iCalendar syntax, and you should not try modifying it by hand.

Delete invitation emails after the reply to them has been sent
When this is checked, received invitation emails that have been replied to will be moved to the Trash folder, once the reply has been successfully sent.
4.8 Options without a user interface representation

Apart from the options presented in the configuration dialog, some options can only be set directly in the KMail configuration file or through KIOSK (e.g. Input into Konsole). These so called ‘hidden’ configuration options cannot be changed via the normal KMail Settings dialog; they must be made by modifying the configuration file using a text editor or the kwriteconfig program. The configuration file is to be written in the format of [Section Name] and the following lines are the variables and their settings. If you are manually editing the configuration file you will need to add the [Section Name] before adding variables. The kwriteconfig will add the section for you as long as you use the --group switch.

The KMail configuration file is called kmail2rc and can be found in your home directory. The location can vary according to your operating system or distribution, but can always be found by running the command kde4-config --path config --locate kmail2rc. For the remainder of this section, assume that the configuration file is located in /path/to/kmail2rc.

WARNING
Whenever changing these options, make sure to quit KMail first before editing the configuration file. Only restart KMail after you have made and saved the changes to the configuration file.

SendMDNsWithEmptySender

Send Message Disposition Notifications with an empty sender string. Some servers might be configured to reject such messages, so if you are experiencing problems sending MDNs, make sure this option is set to false. To enable this feature, add to the ‘[MDN]’ section:

- Configuration file:
  SendMDNsWithEmptySender=true

- kwriteconfig
  % kwriteconfig --file /path/to/kmail2rc --group MDN --key SendMDNsWithEmptySender true

NOTE
The default setting of ‘false’ strictly speaking violates Internet standards, but is set that way for practical reasons, to avoid servers rejecting MDNs that KMail generates because they think they are SPAM.

CloseDespiteSystemTray

This option allows you to configure the application to close fully, even if there is a system tray icon configured, which would normally keep the application running. To enable the feature, add to the ‘[General]’ section:

- Configuration file:
  CloseDespiteSystemTray=true

- kwriteconfig
  % kwriteconfig --file /path/to/kmail2rc --group General --key CloseDespiteSystemTray true
The KMail Handbook

disregardUmask
In versions prior to 1.9, KMail saved all attachments to disk with permissions set to 600 —only readable or writable by the owner of the file. In response to user feedback, this was made configurable in KMail version 1.9, with the defaults changed to honour the umask set on the user account while saving files to disk. To enable this feature, add to the ‘[General]’ section:

  • Configuration file:

    disregardUmask=true

  • kwriteconfig

    % kwriteconfig --file /path/to/kmail2rc --group General --key disregardUmask true

CheckOutOfOfficeOnStartup
With this option enabled, KMail will check on every startup if there is an active out-of-office configured and show a warning if this is the case. To disable the feature, add to the ‘[OutOfOffice]’ section:

  • Configuration file:

    CheckOutOfOfficeOnStartup=false

  • kwriteconfig

    % kwriteconfig --file /path/to/kmail2rc --group OutOfOffice --key CheckOutOfOfficeOnStartup false

AllowOutOfOfficeSettings
In case you don’t want users to be able to upload their own out-of-office scripts to the server you can add to the ‘[OutOfOffice]’ section:

  • Configuration file:

    AllowOutOfOfficeSettings=false

  • kwriteconfig

    % kwriteconfig --file /path/to/kmail2rc --group OutOfOffice --key AllowOutOfOfficeSettings false

AllowOutOfOfficeUploadButNoSettings
If you want to allow your users to upload their own out-of-office scripts but you do not want them to be able to change the domain to react to and the react-to-spam setting, you can add to the ‘[OutOfOffice]’ section:

  • Configuration file:

    AllowOutOfOfficeUploadButNoSettings=true

  • kwriteconfig

    % kwriteconfig --file /path/to/kmail2rc --group OutOfOffice --key AllowOutOfOfficeUploadButNoSettings true

OutOfOfficeDomain
When editing vacation (out-of-office) scripts, the user can specify a domain to limit the sending of such replies to. Applying defaults to the out-of-office configuration dialog via the corresponding button will restore this domain, in case the user has changed it. To preload this setting with a default value, add to the ‘[OutOfOffice]’ section:

  • Configuration file:

    AllowOutOfOfficeDomain=domain
OutOfOfficeDomain = myMailDomain.test

• kwriteconfig
  % kwriteconfig --file /path/to/kmail2rc --group OutOfOffice --key OutOfOfficeDomain myMailDomain.test

OutOfBoundsReactToSpam
By default, out-of-office replies are not sent to messages marked as SPAM. To override this behavior, add to the [OutOfOffice] section:

• Configuration file:
  OutOfOfficeReactToSpam = true
  % kwriteconfig --file /path/to/kmail2rc --group OutOfOffice --key OutOfOfficeReactToSpam true

ShowUserAgent
Starting in version 1.9, KMail can show the User-Agent or X-Mailer value from the message header when using Fancy Headers (see View → Headers menu). To enable this feature, add to the [Reader] section:

• Configuration file:
  ShowUserAgent = true
  % kwriteconfig --file /path/to/kmail2rc --group Reader --key ShowUserAgent true
Chapter 5

Command and Menu Reference

Each KMail specific menu item is discussed below. When there is a keyboard shortcut that performs a menu item function, the default shortcut is listed with the menu item.

5.1 The KMail Reader Window

5.1.1 File Menu

File → New
Here you can create several new items as follows:

File → New → New Message...
Compose a new message.

File → New → Message from Template
Creates a new message from a selected template. Please see Compose From Templates for additional information on creating templates.
If you do not have any templates saved, you will see Message → Message from Template → (no templates).

File → New → Add Folder...
Create a new folder.

File → New → New AddressBook Contact...
Brings up the New Contact dialog.

File → Open... (Ctrl+O)
Open email messages or mailboxes.

File → Open Recent
Opens recently used messages. Only messages that have been saved and then opened will show up on this list.
The KMail Handbook

File → Save As... (Ctrl+S)
Saves the currently displayed message to a .mbox. This includes all the headers and attachments.
If you would like to save it to a different format e.g. .txt, deselect **Automatically select filename extension (.mbox)**, and be sure to change the file extension while naming the file.

File → Import Messages...
Starts up KMailCVT. This application lets you import messages from several email clients into KMail.

File → Print Preview...
Display a dialog which shows how your email will be printed.

**NOTE**
This will only be enabled if a printer has been configured and is online available for use.

File → Print... (Ctrl+P)
Display a dialog that lets you print the currently displayed message.

File → Expire All Folders
Delete old messages from all folders. Deletion will occur according to the rules in each folder’s Properties dialog (the default is not to delete old messages at all).

File → Empty All Trash Folders
Use this to empty all trash folders, i.e. the local trash folder and all trash folders that you might have on IMAP servers.

File → Work Offline
Sets KMail to offline mode. This turns off all network jobs. This is useful when working with messages without a network connection. This selection will become File → Work Online, which needs to be selected to go back online (required to send and receive).

File → Check Mail (Ctrl+L)
Checks for new messages in all your accounts.

File → Check Mail In
Check for new messages from a particular account, these accounts will be listed in the submenu.

File → Update Folder (F5)
Checks whether new mail arrived in the currently selected folder.

**NOTE**
This is only available for IMAP folders.

File → Update This Folder and All Its Subfolders (Ctrl+F5)
Checks whether new mail arrived in the currently selected folder and all of its subfolders.
You can also select multiple folders and the menu item will turn into File → Update These Folders and All Their Subfolders

**NOTE**
This is only available for IMAP folders.
File → Send Queued Messages
Sends the messages that are in your outbox. Messages can end up in your outbox by selecting Queue in the composer menu, composing a message in offline mode, and sending while you have no Internet connection.

File → Send Queued Messages Via
Sends the messages that are in your outbox via a specific outgoing account. This allows you to choose which server to send your queued messages from. They must be configured in Configure KMail dialog, under the Accounts+Sending tab to show up here.

File → Quit (Ctrl+Q)
Exits KMail.

5.1.2 Edit Menu
If the menu item you are looking for is missing, please see Edit Menu of the KDE Fundamentals. The items listed here are KMail specific.

Edit → Move to Trash (Del)
Moves the selected messages to the trash folder. If the selected messages are already in the trash folder, they will be permanently deleted.

Edit → Move Thread to Trash (Ctrl+Del)
Moves the selected thread to the trash folder, e.g. a conversation in a mailing list.

Edit → Find Messages... (S)
Opens up a search window that lets you search for messages with certain characteristics, e.g. a certain subject. Please see Filter Criteria for details on search options.
Your search results will display in the text area, at which point you can open the Open Search Folder or highlight the desired message and select Open Message.

Edit → Find in Message... (Ctrl+F)
Searches the current message text for a string entered into the Find: textbox.

Edit → Select All Messages (Ctrl+A)
Selects all messages in the current folder.

Edit → Select All Text (Ctrl+T)
Selects the text of the currently displayed message.

5.1.3 View Menu

View → Message List
This menu has the following options to change the view of your message list.

Sorting
Contains options to customize your sort order as follows:
• Message Sort Order has several options, most are self explanatory. The following options may not be immediately obvious, therefore deserve an explanation.
  – By Smart Sender/Receiver will display the sender when you are reading in your outbox folder/template folder, and display the receiver when you are in your inbox/inbox subfolders.
The KMail Handbook

– **By Action Item Status** and **By Important Status** need to be set before they can be sorted. Please see Mark Messages for more information on marking your messages.

• **Message Sort Direction** and **Group Sort Direction** allow you to change the direction of your messages/groups sort respectively.

• **Folder always Uses this Sort Order** allows you to keep your sort settings per folder.

**Aggregation**

Allows you to set your aggregation view.

**Configure...** Allows you to configure aggregation, please see Configure Appearance Message List for more information on aggregation.

**Theme**

Allows you to select a theme.

**Configure...** Allows you to configure themes, please see Configure Appearance Message List for more information on themes.

**Create New Tab (Ctrl+Shift+O)**

Creates a new tab, then select the folder you would like to display in the tab.

**Close Tab (Ctrl+Shift+W)**

Closes the currently selected tab.

**View → Headers**

Select your headers view. Please see Header Options for details on headers.

**View → Attachments**

Changes the way attachments appear in the Message Preview Pane (independent of the MIME Tree). Please see Attachment Options for details on attachments.

**View → Expand Thread / Group (.)**

This will display the thread of the current message, i.e. all messages that are replies to the current message.

**View → Collapse Thread / Group (,)**

This will hide the thread of the current message, i.e. it will hide all messages that are replies to the current message.

**View → Expand All Threads (Ctrl+.)**

Expands all threads in the current folder.

**View → Collapse All Threads (Ctrl+,)**

Collapses all threads in the current folder.

**View → View Source (V)**

Shows the message and its complete headers in plain text format in a new window. This can be useful to find out the origin of a mail.

---

**NOTE**

You should know that it is easy to fake the From: header of a mail, but one can still find out which mail servers have been used to send the message by looking at the Received: lines in the header.

**View → Show Message Structure**

Display the structure viewer, which is part of the main window that lets you access all parts of a message.
The KMail Handbook

**View → Use Fixed Font (X)**

Uses a fixed width (Monospace) font to display the messages in the current folder. The font to be used can be configured in the Fonts tab on the Appearance page of the KMail configuration dialog.

**View → Set Encoding**

Lets you choose the character encoding to be used in the Message Pane. The default, Auto, should work in almost all cases.

**View → Zoom**

Allows to zoom message in the Message Pane.

### 5.1.4 Go Menu

**Go → Jump to Folder... (J)**

Show a dialog box with a list of all your folders. Click on the folder you wish to view and it will display it in the message view pane.

**Go → Next Message (N)**

Selects the next message in the message list. The keyboard shortcut Right Arrow also performs this action.

**Go → Next Unread Message (+)**

Selects the next unread message in the message list. If there are not any unread messages below the currently selected message, then the behavior depends on the value of the When trying to find unread messages option.

**Go → Previous Message (P)**

Selects the previous message in the message list.

**Go → Previous Unread Message (-)**

Selects the previous unread message in the message list. If there is not an unread message above the currently selected message, then the behavior depends on the value of the When trying to find unread messages option.

**Go → Next Unread Folder (Alt++)**

Jumps to the next folder with unread messages.

**Go → Previous Unread Folder (Alt+-)**

Jumps to the previous folder with unread messages.

**Go → Next Unread Text (Space)**

Scrolls down if you are not yet at the bottom of a message, otherwise jumps to the next unread message.

### 5.1.5 Folder Menu

**Folder → Add Folder...**

Opens the Folder Properties dialog that lets you create a new folder.

**Folder → Mark All Messages as Read**

Sets the status of all new and unread messages in the current folder to read.
Folder → Update Folder (F5)
Checks whether new mail arrived in the currently selected folder.

<table>
<thead>
<tr>
<th>NOTE</th>
</tr>
</thead>
<tbody>
<tr>
<td>This is only available for IMAP folders.</td>
</tr>
</tbody>
</table>

Folder → Update Folder and All Its Subfolders (Ctrl+F5)
Checks whether new mail arrived in the currently selected folder and all of its subfolders.

<table>
<thead>
<tr>
<th>NOTE</th>
</tr>
</thead>
<tbody>
<tr>
<td>This is only available for IMAP folders.</td>
</tr>
</tbody>
</table>

Folder → Move All to Trash
Moves all of the messages in the selected folder into the trash folder.

<table>
<thead>
<tr>
<th>NOTE</th>
</tr>
</thead>
<tbody>
<tr>
<td>This is only available if the currently selected folder is not a trash folder. If the currently selected folder is a trash folder, you will see Empty Trash. Please see next section for details.</td>
</tr>
</tbody>
</table>

Folder → Empty Trash
Permanently deletes all messages.

<table>
<thead>
<tr>
<th>NOTE</th>
</tr>
</thead>
<tbody>
<tr>
<td>This is only available if the currently selected folder is a trash folder.</td>
</tr>
</tbody>
</table>

Folder → Archive Folder...
Brings up a dialog to allow you to create an archive of the currently selected folder. Please see Folder Archive for details.

Folder → Delete Folder
Removes the selected folder and all its contents, including subfolders.

<table>
<thead>
<tr>
<th>WARNING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Please note that there is no way to access the contents of a folder after it has been removed.</td>
</tr>
</tbody>
</table>

Folder → Remove Duplicate Messages (Ctrl+*)
Searches the folder for duplicate messages and deletes them.

Folder → Apply All Filters On Folder
Applies all configured filters on the currently selected folder. Please see Filter dialog for more information on filters.

Folder → Prefer HTML to Plain Text
If enabled then HTML messages in this folder will be shown using HTML rendering.

<table>
<thead>
<tr>
<th>WARNING</th>
</tr>
</thead>
<tbody>
<tr>
<td>For security reasons, we recommend to only activate this for folders which only contain trusted messages.</td>
</tr>
</tbody>
</table>
Folder → Load External References
If you have HTML messages enabled (see above), then you have the option to enable this to have images and resources linked from the web will load automatically.

**WARNING**
For security reasons, we recommend to only activate this for folders which only contain trusted messages.

Folder → Mailing List Management...
This opens up the mailing list management dialog. Please see Mailing List dialog for more information on mailing lists.

Folder → Assign Shortcut...
This allows you to assign a keyboard shortcut to the currently selected folder.

### 5.1.6 Message Menu

**Message → New Message... (Ctrl+N)**
Opens the composer window so you can write a new message.

**Message → New Message to Mailing-List... (Ctrl+Shift+N)**
Opens the composer window so you can write a new mail. If the current folder holds a mailing list and has a posting address defined, this address will be the default To: address.

**Message → Reply... (R)**
Opens up the composer window, inserts the quoted text of the currently selected message and presets the To: field either with the mailing-list address (if you reply to a mailing-list message) or with the preferred reply address of the sender. If you want to control which address the To: field is preset with then you should use Reply Special. Your identity will automatically be set to the identity this message was originally sent to.

**Message → Reply to All... (A)**
Opens up the composer window, inserts the quoted text of the currently selected message and presets the To: field with the addresses of all other recipients of the currently selected message excluding your own address. Your identity will automatically be set to the identity this message was originally sent to.

**Message → Reply Special → Reply to Author... (Shift+A)**
Opens the composer window, inserts the quoted text of the currently selected message and presets the To: field with the preferred reply address of the sender. Your identity will automatically be set to the identity this message was originally sent to.

**Message → Reply Special → Reply to Mailing-List... (L)**
Opens up the composer window, inserts the quoted text of the currently selected message and presets the To: field with the mailing-list address. If you did not specify a mailing-list address for the currently selected folder and KMail cannot determine the posting address from the currently selected message then the To: field will be empty. Your identity will automatically be set to the identity this message was originally sent to.

**Message → Reply Special → Reply Without Quote... (Shift+R)**
Works just like Reply... except that the text of the currently selected message is not quoted.
The KMail Handbook

Message → Reply Special → Reply With Custom Template
Works just like Reply... with the option to select a custom template that has been configured in Custom Templates.

Message → Reply Special → Reply to All With Custom Template
Works just like Reply to All... with the option to select a custom template that has been configured in Custom Templates.

Message → Forward → As Attachment (Shift+F)
Forwards the message to a new recipient. The message and its attachments will become an attachment of the new message. The original message headers will be included in the forwarded message as well.

Message → Forward → Inline (F)
The message’s text and some important header fields will be copied to the body of the new message with text marking the forwarded part. Attachments will be forwarded as attachments of the new message.

Message → Forward → Redirect (E)
This works like forward, except that the message stays the same (even the From: field). The user who redirected the message is added in special header fields (Redirect-From, Redirect-Date, Redirect-To, etc.).

Message → Forward → With Custom Template
Works just like forward with the option to select a custom template that has been configured in the composer custom templates tab in Custom Templates.

Message → Send Again...
Opens a composer window with the currently selected message so it can be sent again.

NOTE
This is only available for messages which you have sent or, more precisely, for messages which have the sent status.

Message → Edit Message (T)
Edits the selected message if it is editable.

NOTE
Only messages in the outbox and drafts folder can be edited.

Message → Mailing List
Offers several options for mailing list messages.

NOTE
The current working folder must be configured as a mailing list for this to be available. Please see Folder Properties Mailing List for information on setting up mailing lists.

The following options are available to mailing list folders:

- **Post New Message(email)** will presets the To: with the address configured in Post to List.
- **Request Help(email)** will presets the To: with the address configured in Post to List and help word in the Subject: field.
• **Subscribe to List(web)** will open your default web browser to the subscribe website of the configured mailing list.

• **Subscribe to List(email)** will presets the **To:** with the mailing list subscription address and **subscribe** word in the **Subject:** field.

• **Unsubscribe from List(web)** will open your default web browser to the unsubscribe website of the configured mailing list.

• **Unsubscribe from List(email)** will presets the **To:** with the mailing list subscription address and **unsubscribe** word in the **Subject:** field.

**Message → Copy Message To**

Copies the selected messages to a specified folder, you can choose from recent folders, local folders, or a specific account folder.

**Message → Move Message To**

The same as copy message to, except you permanently move the selected messages to a specified folder.

**Message → Mark Message**

Allows you to change the status of the selected message to one of the following states:

<table>
<thead>
<tr>
<th>Status</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mark Message as Read (Ctrl+R)</td>
<td>![Symbol]</td>
</tr>
<tr>
<td>Mark Message as Unread (Ctrl+U)</td>
<td>![Symbol]</td>
</tr>
<tr>
<td>Mark Message as Important</td>
<td>![Symbol]</td>
</tr>
<tr>
<td>Remove Important Mark</td>
<td>![Symbol]</td>
</tr>
<tr>
<td>Mark Message as Action Item</td>
<td>![Symbol]</td>
</tr>
<tr>
<td>Remove Action Item Mark</td>
<td>![Symbol]</td>
</tr>
</tbody>
</table>

**Message → Mark Thread**

Allows you to change the status of all messages in a thread as follows:

<table>
<thead>
<tr>
<th>Status</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mark Thread as Read</td>
<td>![Symbol]</td>
</tr>
<tr>
<td>Mark Thread as Unread</td>
<td>![Symbol]</td>
</tr>
<tr>
<td>Mark Thread as Important</td>
<td>![Symbol]</td>
</tr>
<tr>
<td>Remove Important Thread Mark</td>
<td>![Symbol]</td>
</tr>
<tr>
<td>Mark Thread as Action Item</td>
<td>![Symbol]</td>
</tr>
<tr>
<td>Remove Action Item Thread Mark</td>
<td>![Symbol]</td>
</tr>
</tbody>
</table>
The KMail Handbook

<table>
<thead>
<tr>
<th>Watch Thread</th>
<th>Ignore Thread</th>
</tr>
</thead>
</table>

**Message → Create Filter**

Opens up the Filter dialog with a new filter added. This new filter is based on fields of the current mail, depending on which sub menu item you select from:

- Filter on Subject...
- Filter on From...
- Filter on To...
- Filter on Mailing-List...(currently selected mail must be a mailing list for this to be available)

**Message → Apply Filter**

Allows you to Apply all Filters. If you have spam filtering set up through Anti-Spam Wizard the options Classify as Spam and Classify as NOT Spam will be available for spam filtering.

**Message → Create To-do/Reminder**

Brings up the Kontact To-do/Reminder dialog with options to add the selected email as a link, inline, or inline without attachments.

**Message → Add Note...**

Brings up the Kontact Note dialog to add a note to the selected email.

5.1.7 Tools Menu

**Tools → Find Messages... (S)**

Opens up a search window that lets you search for messages with certain characteristics, e.g. a certain subject. Please see Filter Criteria for details on search options.

Your search results will display in the text area, at which point you can open the Open Search Folder or highlight the desired message and select Open Message.

**Tools → Certificate Manager...**

Starts Kleopatra, the KDE certificate manager.

**Tools → GnuPG Log Viewer**

Starts KWatchGnuPG, a tool to present the debug output of the GnuPG application. If signing, encryption, or verification mysteriously stop working, you might find out why by looking at this log.

**Tools → Edit “Out of Office” Replies...**

Launch the Configure “Out of Office” Replies dialog, which allows you to set-up vacation notifications.

**NOTE**

Out of Office reply functionality relies on server-side filtering. To be able to use it you need to configure the Filtering tab (see option relevant to kolab server) of your IMAP account set-up.
Tools → Debug Sieve...
Launch the Sieve Diagnostics dialog. This is useful to debug sieve if you are having problems with it.

**NOTE**
You must have sieve support on your email server.

Tools → Filter Log Viewer...
Opens up the viewer window for the filter log; there you find some options to control the logging of the filtering process. In the log you will find valuable information about what filter rules were used, what was the result of the evaluation of those rules, and which filter actions were applied to a message.

Tools → Import Wizard...
Brings up the Import Wizard dialog which assists in easily importing settings and email. Please see Import Wizard for details.

Tools → Export KMail Data...
Brings up the PIM Setting Exporter dialog which assists in easily exporting your settings and email. Please see pimsettingexporter for details.

Tools → Account Wizard...
Brings up the Account Wizard dialog which assists in easily setting up accounts. Please see Account Wizard for details.

Tools → Anti-Spam Wizard...
Brings up the Anti-Spam Wizard which can help you to set up spam filtering. Please see Anti-Spam Wizard for details.

Tools → Anti-Virus Wizard...
Brings up the Anti-Virus Wizard which can help you to set up scanning messages for viruses. Please see Anti-Virus Wizard for details.

5.1.8 Settings Menu

If the menu item you are looking for is missing, please see Settings Menu of the KDE Fundamentals. The items listed here are KMail specific.

Settings → Show Quick Search bar (Ctrl+H)
Allows you to enable the Quick Search bar, which allows you to quickly search for messages matching a search text, is visible.

Settings → Configure Filters...
Opens the Message Filters window.

Settings → Manage Sieve Scripts...
If your mail server supports sieve (server side filtering), you would configure your scripts here.

Settings → Configure Automatic Archiving...
Brings up the dialog to set up automatic archiving. Please see Automatic Archiving for details.
Settings → Configure Send Later Agent...
Brings up a dialog that allows you to modify and remove emails that have been sent using
the send later feature. Please see Send Later Agent for details.

Settings → Configure Folder Archive Agent...
Brings up a dialog that allows you to configure accounts to use the folder archive agent
feature with. Please see Folder Archive Agent for details.

Settings → Configure Notifications...
Opens a dialog that lets you configure what happens when new mail arrives, e.g. play a
sound, display a popup, etc.

5.1.9 Help Menu

Help Menu of the KDE Fundamentals.

5.2 The KMail Composer Window

5.2.1 Message Menu

Message → New Composer (Ctrl+N)
Opens up a new composer window.

Message → New Main Window
Creates a new main window.

Message → New AddressBook Contact
Brings up the Kontact New Contact Dialog to add a new contact your addressbook.

Message → Send Mail (Ctrl+Return)
Sends the message immediately. If you use SMTP to send your messages and the SMTP
server is not reachable, the message will be put into the outbox and you will get an error
message. After the connection issues are resolved, you can send the messages in the outbox
using File → Send Queued Messages.

Message → Send Mail Via
Allows you to select which outgoing mail server you wish to use to send the message.

Message → Send Later
Brings up the send later dialog. Please see Send Later for details.

Message → Send Later Via
Allows you to choose which outgoing account to send your send later configured message.

Message → Save as File
Saves the message as a text document.

Message → Save as Draft (Ctrl+S)
Save the message in the drafts folder so you can later edit and send it.
Message → Save as Template
Allows you to save your message as a template. Please see Compose from templates for details on templates.

Message → Insert Text File...
Inserts a text file into the message text, starting at the cursor position.

Message → Insert Recent Text File...
Allows you to choose from a list of recently inserted text files to insert into your message. Select Clear List to clear the list.

Message → Print... (Ctrl+P)
Prints the current text.

Message → Close (Ctrl+W)
Closes this composer window.

5.2.2 Edit Menu
If the menu item you are looking for is missing, please see Edit Menu of the KDE Fundamentals. The items listed here are KMail specific.

Edit → Paste as Quotation (Ctrl+Shift+O)
Pastes the text from the clipboard marked as quotation.

Edit → Paste as Attachment
Pastes the text from the clipboard as an attachment.

Edit → Paste Without Formatting (Ctrl+Shift+V)
Pastes the text from the clipboard exactly as is, with no formatting.

Edit → Clean Spaces
This replaces multiple line breaks or spaces with single line breaks or spaces. It works on the current selection or the complete message text if there is no selection.

Edit → Add Quote Characters
Prepends the selected text with quotation marks.

Edit → Remove Quote Characters
Removes the left-most quotation marks from the selected text.

Edit → Uppercase
Convert the selected text to uppercase.

Edit → Lowercase
Convert the selected text to lowercase.

Edit → Insert Special Characters
It allows you to insert special character in composer.
5.2.3 View Menu

This menu lets you toggle the display of the header fields and other options in the composer window. Currently visible items will have a checkmark shown next to their name in the menu.

Options available are:

- All Fields
- Identity
- Dictionary
- Sent-Mail folder
- Mail Transport
- From
- Reply To
- Subject

Please see Composer Headers for details on these options.

View → Use Fixed Font

Uses a fixed width (monospaced) font to display the currently edited message. The font to be used can be configured in the Appearance section of KMail’s configuration dialog.

View → Snippets

Displays a column on the right side of the composer window that allows you to use and create snippets. Please see Snippets for more information.

View → Translator

Displays the translator tool at the bottom of the composer window. Please see Using the Translator for more information.

5.2.4 Options Menu

This menu lets you toggle various options for the current message. Currently used options will have a checkmark shown next to their name in the menu.

Options → Urgent

Sets the priority of the message to Urgent. The receiver’s email client has to support this or it will have no effect. KMail itself does not support priorities for incoming messages.

Options → Request Disposition Notification

If you choose this option, you request a confirmation email once your message is downloaded and read by its recipient. This has to be supported and enabled by the receiver’s email client in order to work.

See Message Disposition Notifications for background information and ways to customize the read receipts that KMail itself sends.

Options → Sign Message

Digitally sign the message using OpenPGP. You can learn more about this in the chapter on OpenPGP.
The KMail Handbook

Options → Encrypt Message
Encrypt the message using OpenPGP. You can learn more about this in the chapter on OpenPGP.

Options → Cryptographic Message Format
Choose the cryptographic message format to use to digitally sign and/or encrypt the message in. Please see Cryptographic Message Formats for more information.

Options → Rich Text Editing
Enables Rich Text/HTML editing.

Options → Encoding
Set the charset encoding of this message. The chosen encoding will appear in the header of the outgoing mail. You can use Auto for almost all cases, KMail will tell you if you need to select a different encoding manually.

Options → Wordwrap
Toggles the automatic wordwrap. It may be useful to turn it off if you want to paste long lines that should not wrap.

Options → Automatic Spellchecking
Toggles automatic spellchecking.

5.2.5 Attach Menu
This menu lets you select attachment options.

Attach → Append Signature
Appends your signature (‘footer’) to the end of the message. Please see Configure Identity Signature for details on configuring your signature.

Attach → Prepend Signature
Prepends your signature (‘header’) to the beginning of the message. Please see Configure Identity Signature for details on configuring your signature.

Attach → Append Signature At Cursor Position
Appends your signature to the current location of your cursor to the message. Please see Configure Identity Signature for details on configuring your signature.

Attach → Attach Public Key...
Opens the Attach Public OpenPGP Key dialog. Please see Configure Identity Cryptography OpenPGP Signing for details.

Attach → Attach My Public Key
Attaches your GnuPG public key to your message.

Attach → Attach → Attach File...
Attaches one or more files to the current message. By default attachments are not encrypted, please see Cryptographic Message Formats for information on encryption and attachments.

Attach → Attach → Attach Own vCard
Attaches your vCard to the current message.

Attach → Remove Attachment
Removes the attachment that is selected in the attachment part of the composer.
Attach → Save Attachment As...
   Saves the attachment that is selected in the attachment window to a file.

Attach → Attachment Properties
   Displays the properties of the attachment that is selected in the attachment window. It also
   allows you to sign/encrypt the attachment. Please see Configure Security Composing to
   set up encryption.

5.2.6 Tools Menu

If the menu item you are looking for is missing, please see Tools Menu of the KDE Fundamentals.
The items listed here are KMail specific.

Tools → Select Recipients...
   Opens up the Select Recipient dialog with your personal contacts to select from.

Tools → Addressbook...
   Opens up KAddressBook.

Tools → Save Distribution List...
   Opens a dialog that allows you to save groups of contacts.

5.2.7 Settings Menu

If the menu item you are looking for is missing, please see Settings Menu of the KDE Fundamentals.
The items listed here are KMail specific.

Settings → Spellchecker...
   Allows you to configure Sonnet, KDE’s spellchecker.

5.2.8 Help Menu

Help Menu of the KDE Fundamentals.
Chapter 6

Frequently Asked Questions (FAQ)

Daniel Naber
David Rugge
2013-12-20
KDE 4.12

1. How to set Firefox as your default browser?
   You want to click on a link in KMail and have it opened in Firefox. At the moment, another
   browser is used. You want to change this.

   This solution will affect all of KDE, not just KMail. Start System Settings → Default Applications → Web Browser → Open http and https URLs in the following browser → firefox.

   If you are an administrator and want to set this setting automatically for your users, it is
   • in your user directory in $(kde4-config --localprefix)/share/config/kdeglobals
     add the line BrowserApplication[\$e]=!firefox under category [General]

   You can also use the script in Tutorials/Modify_KDE_Software_Defaults

2. How to control your Roaming profile’s connection?
   You set up a Roaming profile to access your home server while you are on the road, but it
   keeps trying to connect even when you are at home. Auto-connection is disabled in the
   setup screens.

   Settings → Configure KMail → Accounts → Receiving (tab) → (select the account to ex-
   clude) → Retrieval Options, uncheck Include in Manual Mail Check. This will exclude
   the profile when you hit the download icon, but the profile will still be available from the
   drop-down list, making it easy to get your mail while away from home.

3. How to store sent mails in a special folder?
   Symptom: You want to store mails in a special folder. Maybe you are using an IMAP server
   and want to store your mails on the server, not in the client.

   Solution: In KMail, choose Settings → Configure KMail → Identities → (Choose an iden-
   tity) → Modify → Advanced → Sent-mail folder

4. How to store trash mails in a special folder?
   Symptom: You want to store mails in a special folder. Maybe you are using an IMAP server
   and want Trashed mails to be stored on the server, not in the client.

   In the settings dialog select an IMAP account on the Accounts page. Click on Modify and
   change the trash folder location on the Advanced tab.
5. **How to store encrypted mails as unencrypted?**

*Symptom:* You exchange encrypted mail with a friend, but would like to store it unencrypted, once you have opened the message.

*Solution:* To store emails that have been decrypted once in unencrypted format henceforth, add this to your `kmail2rc` configuration file, in the [Reader] section:

```
store-displayed-messages-unencrypted=true
```

This may only work with S/MIME but implementation for OpenPGP is being worked on.

6. **How to filter spam on an IMAP server?**

*Symptom:* You intend moving on to reading your mail from an IMAP server, and wonder how filtering and spam handling will occur?

*Solution:* The machine that already has your mail can become your IMAP server. You will need to configure a server application. **Dovecot** is one such, and the guidance on the project web pages make it easy to set up. That still leaves you with the problem of filtering, as it makes sense to do it on the server (when you point KMail at the server you will see the folders that you have created on the server). Again there are options, but one of the best known is **procmail**. Again there is plenty of information on the Internet on how to set this up. You give it a set of ‘recipes’ - here’s an example:

```
:0
* (^To|^CC|^List-ID): .*kde-linux
${MAILDIR}.INBOX.KDE-Lists.kde-users/
```

If you have `maildir` folders, each recipe must end with a ‘/’. If your folders are `mbox`, just omit the ‘/’.

If you have been using **bogofilter** with KMail you will already have a **wordlist**. This can be used at server level, too, so you will not have to start training from scratch. The trick is to set this before the **procmail** recipes:

```
:0fw
| bogofilter -e -p
0e
{ EXITCODE=75 HOST }
0:
* ^X-Bogosity: Spam, tests=bogofilter
${MAILDIR}.INBOX.a-Spam/
0e
{ EXITCODE=75 HOST }
0:
* ^X-Bogosity: Unsure, tests=bogofilter
${MAILDIR}.INBOX.a-Unsure/
0e
{ EXITCODE=75 HOST }
```

Note that it is going to use a mailbox for spam and one for unsure - I add a ‘a-’ to the name to ensure that they are easily seen, at the top of the list.

Finally, to improve performance, run the following command occasionally on saved spam and unsure:

```
/usr/share/bogofilter/contrib/trainbogo.sh -c -H /home/user/Maildir /.INBO.X.bogotrain_spam/cur/
```

(don’t forget to check the path.)
This is not a complete guide to setting up a server, but notes on how to set up the server to work as you expect in KMail.

7. How to get more screen space in KMail?

Symptom: You are using KMail on a netbook, and find that the new Aggregation display leaves you little screen space.

Solution: If you want to change the look so that a mail uses a single row instead of two rows, go to View → Message List → Theme and change the theme to Classic. If you want to disable grouping by date, change the aggregation using View → Message List → Aggregation to Standard Mailing List. Now your KMail will look exactly like it did in earlier versions.

In Settings → Configure KMail → Appearance → Fonts you can select Use custom fonts and change the setting for each component in the list. This is when you discover that your folder list and the message bodies do use the fonts you want, but the message list still has too large a font.

You can make the font changes by right-clicking on the Message List headers, and selecting Theme → Configure → Appearance tab. Each one of those column headers needs to be clicked on, and your new custom font set. At the end of this, the message list will display in the same font as the rest of your layout.

8. How to unconfigure KMail folder tool tips?

Symptom: You are using KMail on a netbook, and find that the tooltips over folders hide too many folder names.

Solution: Right-clicking on the header of the Folder List and unselect Display Tooltips.

9. How to unconfigure KMail message list tool tips?

In KMail, Settings → Configure KMail → Appearance → Message List uncheck General → Display tooltips for messages and group headers.

10. How to remove alternate line colourings?

In System Settings → Application Appearance → Colors → Colors, for each color set except Common Colors (which doesn’t have it), change the Alternate Background to be the same as the Normal Background.

Mandriva and Mageia doesn’t use the name System Settings. As in KControl, the KDE 3 control centre, they name it ‘Configure your Desktop’ to distinguish it from ‘Configure your Computer’, a.k.a. the Mandriva/Mageia Control Center (MCC). Other than this name change, the method is as described above.

11. How to transfer mail and settings to another computer (or another user account on the same machine)?

Use Tools → Export KMail Data... to export and import settings and data. Please see PIM Setting Exporter for details.

12. Why am I not able to copy mails to a USB stick?

Symptom: You are setting up a new computer and want to transfer all your mail. You decide to copy everything to a USB stick. The job starts, then you start to get failure message, Unable to copy ............ Invalid argument.

Solution: Your usb stick is (V)FAT formatted, and thus can’t handle maildir folder names (nor can it handle permissions, which can cause many other problems). You have two choices. Either format your USB stick as ext2 (in which case you should be aware it can’t be read on Windows® OSes without installing additional software there) or create a tar file of all your mail, copy that to the stick and extract it to your new host.
13. Why are my filters not applied to incoming messages of IMAP accounts?
Normal IMAP mode does not support filtering, but the new disconnected IMAP account type does. You could try to use server-side filtering (ask your admin for how to install filters on the server and in which format), since IMAP is all about managing your email on the server. Unfortunately, although there exists a mail filter language (Sieve, defined in RFC3028), there is no standardized access protocol for installing or editing server-side Sieve scripts. If such a protocol becomes available in the future, KMail will most probably include support for it.

14. What should I know if I want to use PGP/GnuPG with KMail?
KMail provides a simple and easy-to-use interface for the basic functions of these programs; still you should understand how these programs work and what might make their use insecure. Some important issues:

- You really should test if encryption works before you use it. KMail partly relies on PGP/GnuPG’s error strings, which often change between different versions.
- KMail will not encrypt messages with an untrusted (unsigned) public key: if you want to encrypt to such a key you should check the identity of the key owner and only then sign the key with your secret key; if you do not want to or cannot check the identity of the key owner but nevertheless want to encrypt the message then please sign the key locally with gpg --lsign keyID.
- Trusting a foreign public key without checking it is not a good idea.
- KMail cannot encrypt and sign attachments if you are using the built-in OpenPGP support. For encrypted and signed attachments you need to have crypto plugins installed and configured.
- Starting with GnuPG 1.0.7 you have to set your own key to ultimate ownertrust: it is no longer implicitly done for you.

15. Where does KMail save my settings and my mail?
Most KMail settings are stored in $(kde4-config --localprefix)/share/config/kmail2rc and the Akonadi-controlled entries are stored in the following folders and files:

- ~/.local/share/
- ~/.config/akonadi/
- $(kde4-config --localprefix)/share/config/nepomukserverrc
- $(kde4-config --localprefix)/share/apps/nepomuk/ (KAddressBook stores contact groups in Nepomuk.)

Note that some of the files are hidden: remember to also copy those if you want to backup or archive your mails.

16. Why did KMail regenerate the index of a folder?
KMail regenerates the index of a folder whenever the index appears to be out of date, i.e. whenever the contents of a folder are newer than the index. KMail regenerates the index in this case in order to prevent the loss or corruption of messages. Unfortunately, currently-deleted messages might reappear and message flags (like important, etc.) might be lost when the index is regenerated.

An outdated index can have several causes; the two most important causes are:

- Some other program modified the contents of the folder: if you want to use KMail together with procmail then please read this FAQ. If you want to use KMail together with another email client then please read this FAQ.
- If your mail folder is on a volume which is mounted via NFS and if the clock of the NFS server is ahead of the clock of your computer then the NFS server sometimes reports a wrong file date for the index file. In this case KMail assumes that the index is outdated although in reality it is not. To fix this problem you (or your system administrator) have to make sure that the clock of the NFS server and the clock of your computer are always in sync. One way to achieve this is the use of the ntp daemon.
17. **Why does KMail not start up?**

   **Symptom:** You want to start KMail from a minimal desktop environment like fvwm2. It does not start.
   
   **Reason:** You are missing the dbus functionality.
   
   **Solution:** Start KMail using dbus-launch like this:
   ```
   dbus-launch kmail
   ```

18. **Can I use KMail together with a different email client, e.g. mutt?**

   If you’re using the mbox format for your folders it is not possible to use a different email client while KMail is running. With mutt there may also be problems even if both programs are not running at the same time. We recommend to use the maildir format in this case, this should solve all problems.

19. **How can I convert my mailboxes from mbox to maildir?**

   There is no automatic way to do that. You will have to create a new folder in maildir format and copy the messages from the mbox folder into this new folder. Remember to adapt any filter rules connected with the old folder before you delete it.

20. **How can I remove attachments from messages without removing the message itself?**

   Open the context menu with a right mouse button click on an attachment and select Delete Attachment

21. **How can I make KMail check for new messages at startup?**

   If KMail should always check for new messages at startup then enable Check mail on startup on the Accounts configuration page. Otherwise start KMail with `kmail --check`.

22. **Where can I get a list of changes between the versions of KMail?**

   The welcome screen lists all important changes for your version. It is displayed when you select Help → KMail Introduction.

23. **I’m one of those people whose mails consist of 100 quoted lines and one line written by myself. For some reason this annoys other people. Can KMail help me and make everyone’s life better?**

   Sure. Just select a short relevant part of the original mail with the mouse before you reply. Only this part will then be quoted in your reply.

24. **For some messages the value in the Date field is unknown or it is not correct.**

   Probably the ‘Date:’ header of these messages is broken and KMail cannot interpret it. That is not a bug in KMail but in the software that sent the mail.

25. **My signature has two dashes above it. What’s up?**

   Separating the signature from the message body with two dashes and a space on a single line is common usage. These symbols permit mail clients who recognize them to trim the signatures from a reply. If your signature does not already have this separator, KMail will automatically add it.

26. **Are there any known bugs in KMail?**

   A list of submitted bugs can be obtained by the query from the Bugzilla page. Note that not all these bugs are valid. All in all we think that KMail is a very robust piece of software.

**WARNING**

However, you should not run KMail while another email client is already accessing the files in the mail directory; if you try to do so, you might lose messages. Note that you should make backups of your messages anyway.
27. **KMail does not display HTML mail properly.**

References to external content like images, are disabled by default, as they can be used to track whether and when you read a message. Loading external references can be activated in the **Security** tab in KMail’s configuration dialog; also Plugins (like Adobe® Flash), Java™ and JavaScript will not be displayed in KMail for security reasons and there is no way to activate them.

28. **Can I use two different versions of KMail at the same time? Can I go back from a current version of KMail to an older one?**

You can only run one instance of KMail at a time. We also recommend to stick to a certain version and not switch back and forth between different versions. Downgrading to an older version will probably cause problems, e.g. because the index file formats might have changed. Upgrading should never be a problem.

29. **Does KMail support uuencoded files?**

Uuencoded attachments are not supported. Save your mail with an uuencoded attachment and use **uudecode** to decode the attachment.

30. **KMail crashed while I was writing a mail; is that mail lost now?**

KMail tries to save your mail to \$(kde4-config --localprefix)/share/apps/kmail/autosave in case of a crash. The next time you start KMail the mail composer should appear with your mail again; If it does not, try to open the files in \$(kde4-config --localprefix)/share/apps/kmail/autosave with an editor. If there are no files in this folder then the crash was so bad that KMail could not save your mail.

31. **When I try to set a folder to be mailing list-aware, it does not do anything when receiving an email from the list.**

Associating a folder with a mailing list has nothing to do with filtering the mailing list messages — you have to add a new filter rule manually; however, once you associated a folder with a mailing list you can use **Message → Reply to Mailing-List...** or **Message → New Message to Mailing-List...** and the mailing list address will be set in the **To:** field.

32. **My SMTP server requires authentication; does KMail support this?**

The **Authentication** can be set in the **Advanced** tab of the SMTP configuration dialog.

33. **Can I use KMail and procmail?**

Yes, but it is important to do it the right way or you might lose mail. In order to use procmail and KMail you need to set up KMail so that it will fetch new mail from the spoolfiles in which procmail drops your mail. Do **not** set up procmail to deliver mail in a KMail folder, this cannot work.

For each procmail spoolfile you then need to create an account from which KMail will fetch new mail; you also need to make sure you specify the right lockfile name for this account. When setting up an account, KMail will do some minimal parsing on your .procmail file, and will try to list every spoolfile it has found, and also the lockfiles next to the **procmail lockfile** item. procmail lets the user specify lockfiles in three different ways, so there is no way to establish a correspondence between the spoolfiles and lockfiles; so it’s really up to you to make sure you specify the right lockfile for each spoolfile.

34. **Spellchecking does not recognize non-English characters.**

Before you can use spellchecking the first time, you have to configure it. You can do so in the composer window’s menu under **Settings → Spellchecker...**. You can set the dictionary there.

35. **How do I use my Eudora/Netscape®/Outlook/... mail folders in KMail?**

See the section **Importing in KMail.**
The KMail Handbook

36. Can I use encryption with my normal (non-SSL) POP3 account?
If your POP3 server runs an ssh daemon, you can use ssh to tunnel your POP3 connection using the following command:

```
ssh -L 11000:127.0.0.1:110 user@host
```

Modify your KMail configuration to fetch the mail via POP3 from localhost and ssh will tunnel the connection for you.

**NOTE**
If non-encrypted messages have already been sent via Internet, the only advantage of using ssh is that your password will be sent encrypted to the POP3 server.

37. Does KMail lock the folders it uses?
KMail does not lock the files in ~/.local/share.
To avoid the risk of losing mail if using a local account it is necessary to ensure that KMail uses the same type of locking as your mail delivery agent.
There are five different locking options you can use:

- **Procmail lockfile**
- **Mutt dotlock**
- **Mutt dotlock privileged**
- **FCNTL (default)**
- **none (use with care)**

**Procmail lockfile** will use a small utility that comes with procmail called lockfile. You can use this if your mail folder is in a folder where you have write permission. This will not work on your /var/spool/mail/user file in most cases. It will create .lock files on your account when KMail is checking for new mail. Please note that this will only work if procmail is installed on your system.

**Mutt dotlock** and **Mutt dotlock privileged** will both use a small utility that comes with mutt called mutt_dotlock. **Mutt dotlock** can be used in the same way as the **Procmail lockfile** option, with the same limitation with regards to the /var/spool/mail/ folders. However, the **Mutt dotlock privileged** option can create lock files in the /var/spool/mail folder. mutt_dotlock is a setgid program and this option will run it in setgid mode. Please note that these options will only work if mutt is installed on your system.

**FCNTL** will use the fcntl() system call.

**WARNING**
Usage of FCNTL locking might cause system lockups when the mail spool file is on an NFS mounted device.

If you do not want to use any locking, the **none** option is what you want. However, there are risks of losing mail when no locking is used.

38. How do I leave messages on the POP3 server?
If you want to leave all messages on the server: open up the Settings → Configure KMail... window. Click on the Accounts page. Select your account from the account list and click the Modify... button. This dialog contains the Leave fetched messages on the server setting which you must enable.

39. How do I automatically insert a text footer within my messages?
The text footer is also called a signature (not to be confused with a cryptographic signature). Select Settings → Configure KMail... Look in the Identity page for the Signature tab and add your signature there. Then go to the General tab on the Composer page and enable Automatically insert signature.
40. *How do I set up sendmail® to work with KMail if I have a dial-up connection?*

First you should check if your distribution can do this for you. It probably has already been set up during installation.

If that is not the case, you may want to have a look at the [Mail Queue HOWTO](https://help.kde.org/).

41. *I’ve seen demonstrations of remote control behavior with KMail. Is there any documentation on the available interfaces?*

You can get a list of functions by using this command in a shell: `qdbus org.kde.kmail /KMail`. Then you can control KMail like this: `qdbus org.kde.kmail /KMail org.kde.kmail.kmail.folderList`. You can use qdbusviewer to browse available methods in a graphical interface.

42. *When I reply to a message, only a part of the message is quoted. How come?*

This can happen when the message contains two dashes and a space on a single line. This is seen as the start of the signature. The remaining part of the message will not be quoted, because when you reply to a message KMail strips the signature.

43. *I am only using IMAP, can I get rid of those Local Folders in the folder list or at least keep them collapsed all the time?*

No, you cannot get rid of them. The local folders function as a fallback when the IMAP server is unreachable. Although you only use IMAP, KMail uses the outbox for sending the messages. If we hide all local folders you will not be able to fix messages in the outbox which cannot be send for some reason. But it is possible to keep the local folders collapsed. What you have to do is go to Settings → Configure KMail... and go to the section Misc, there you can setup the folder on startup. If you change that to a folder on the IMAP account, the Local Folders will stay collapsed when KMail starts.

44. *How to watch the threads?*

If you want to follow a thread, right click and choose Mark Thread → Watch Thread.

From this point on all messages on the thread that starts in this message will be marked as Watched.

45. *How to watch your own threads?*

This is useful in case you are registered to a mailing list such as kdepim-users@kde.org and want to filter out the threads you participate in.

- Create a filter to mark all your incoming messages to a mailing list as Watched
  - To create a filter go to: Settings → Configure Filters
  - select Match all of the following
  - Add the conditions:
    - From → Contains → yourmail@maildomain
    - List-Id → Contains listID
  - Under Filter Actions choose Mark As → Watched.
- In the Advanced tab
  - Uncheck if this filter matches, stop processing here, so that other filters such as sorting the incoming messages from the mailing list to sub-folders would execute.
  - Place that filter before other filters that may stop the filtering process, or simply put it first. (changing the filters order is done using the two arrows up and down, under the Available filters list)
- Create a search on mailing list messages
  - Go to the folder where your mailing list messages are stored (e.g. Local Folders/KDE-PIM-USERS) and hit S key or in the menu Edit → Find Messages.

1 replace yourmail@maildomain with your outgoing mail address
2 replace listID with a specific mailing list id e.g. (<kdepim-users.kde.org>) or just a '.' to include outgoing mail to all mailing lists with '.' in their id (basically all).
– Select **Match all of the following**
– Add the condition: **Message Status → is → Watched**
– Give the search an informative name (**Search folder name**) like `KDE-PIM-USER-Watched`
– Make the search. After it is done you can close the search window.
Now whenever you start a thread or participate in one, it is **Watched**.

46. **How to use E-Mail Translation?**

To translate text in the composer window read the section **Using the Built-in Translator**

In the message preview pane highlight the text you would like to translate and select **Translate (Ctrl+Alt+T)** from the right mouse button context menu.

---

3 Pay attention to the **Include sub-folders**.
Chapter 7

KMail Troubleshooting

This chapter was converted from the KDE UserBase KMail/FAQs Hints and Tips page.
2012-07-28
KDE SC 4.9

7.1 KMail doesn’t send mail

Some users find that mail does not go out, and it appears that SMTP is missing, even though the Settings page looks correct. It has been reported that this is cured by opening akonadiconsole and adding Mail Dispatcher Agent.

If the computer was suddenly turned off in suspend mode (e.g. by a power cut) sometimes e-mails simply stay in the outbox without being sent, but no error message is generated either. This may be due to the fact that the Mail Dispatcher Agent is set to ‘offline’ in the configuration file during suspend and is not changed back due to the crash. Edit the following file:

`~/.config/akonadi/agent_config_akonadi_maildispatcher_agent`

and change

```
[Agent]
Online=false
```

to

```
[Agent]
Online=true
```

7.2 Clean start after a failed migration

In case migration from KMail 1 to KMail 2 fails or you have weird problems after it, you can try to do a clean import of your data, instead of migrating the existing settings. Be warned, this needs more manual setup, so do only if you are confident of setting up your KMail accounts again; it can generate a large amount of network traffic for IMAP resources.

1. Stop Akonadi and related applications
   quit KMail/Kontact/KOrganizer, and issue this command:
akonadictl stop
Make sure no Akonadi or MySQL process is running:

```
ps ux | grep mysql
ps ux | grep akonadi
```
They should not show anything else but the grep process itself.

2. Remove old Akonadi database and config
   Delete the following folders
   • ~/.local/share/akonadi
   • ~/.config/akonadi
   Delete also the files starting with akonadi from ~/.kde4/share/config

3. Restart Akonadi server
   akonadictl start

4. Add back the accounts
   Now it is time to add your account back. You can use KMail (Kontact) for it, or you can use
   the akonadiconsole tool.
   In KMail: Settings → Configure KMail → Accounts and use Add.
   If you use IMAP, add a new IMAP E-Mail server. If you want disconnected mode (so you
   can read the mails offline), enable it on the Advanced tab. Be sure to check that you are
   subscribed to all your important folders.
   You might already see a Local folder resource. This points to a local maildir folder. You can
   either modify this to point to your existing maildir folders or you can add a new resource
   for local mails.
   When adding a maildir resource you can choose between KMail Mail Folder or Maildir.
   Unless you have a mixed folder containing both maildir folders and mbox files, you should
   choose Maildir. For independent mbox files, like the one in the /var/spool/mail, you can
   set up a new MBox folder.
   Add the POP3 accounts as well. If you have multiple Local Folders set up, on the Advanced
   tab, choose the destination folder where the newly downloaded mails are put.
   For all accounts, configure the mail check interval. For Local folders disable interval check-
   ing and also disable Include in manual mail check in the Retrieval options.
   Add the sending (SMTP) accounts.

5. Fix your filters, identities and favorite folders
   If you have client side filtering (common with POP3 mails), go to Settings → Configure Fil-
   ters and fix the destination folder for the filters, they most probably are wrong. Otherwise
   mails will end up in folders you don’t expect.
   Spam filter (at least in version 4.7.3 and earlier) does not work as expected in that the rule
   that the wizard creates does not send spam to the folder you have defined.
   The workaround for this is to change the ‘spam’ and ‘spam unsure’ (if the spam filter
   you use supports that) from looking at Status-fields in the header X-Status-Classification: ‘SPAM or unsure’. Look
   at the filters the wizard creates and copy the ‘contains’ part. Example for Spambayes: ‘X-
   Spambayes-Classification: spam’ and ‘X-Spambayes-Classification: unsure’.
   You also need to verify the identity settings and set the sent-mail, drafts and templates fold-
   ers to point to the right folders. To do that go to Settings → Configure KMail → Identities,
   modify the identity, go to the Advanced tab and modify the above mentioned folder set-
   tings.
   Check also that your Favorite Folders are the ones you have chosen before.
6. Initiate a mail check

Start a mail check for your accounts. It is suggested doing it per account.

First check for IMAP, if you have it.

Next check (import) your local mails. One solution is to do a full check in one go File → Check Mail In and select the local account; the other is to click one by one on the folders, that should initiate the check for that folder (alternatively right click on the folder name and select Update Folder).

The initial import might be slow and could use a lot of memory, especially if you have folders with a large amount of mail. In that case per-folder check is preferred. If the check (complete or for one folder) is finished and the memory usage is still high, you could restart the Akonadi server — as seen above — or just the maildir agent, if you use akonadiconsole. Do not worry, this high memory usage is only for initial import.

Initiate a check mail for POP3 resources.

Hopefully after these steps, you will have a much nicer KMail experience.

7.3 Local Folders is added over and over

In some cases you might end up with a maildir account pointing to a certain place (like $HOME/MAIL), but you still see a Local Folders folder in the folder list with Inbox/Outbox/Trash/Drafts/etc. subfolders and KMail keeps putting mails there, especially sent mails.

The problem is that certain folders are marked as special folders (system folders) and if you don’t have them, KMail cannot operate correctly. That is the reason why it keeps re-creating that folder.

At this time there is no easy way to change this in the UI for all types of special folders. Here is what you can do:

1. The Sent-Mail, Drafts and Templates folder is configurable for each identity. Go to Settings → Configure KMail → Identities, select your identity, click on Modify, go to the Advanced tab and set the folders to point to the right place.

2. The default Inbox is configurable for each POP3 account. Go to Settings → Configure KMail → Account, select your POP3 account, click on Modify go to the Advanced tab and set the Destination folder.

3. For IMAP accounts you can configure the Trash folder. Do as above. The setting name is Trash folder.

4. The most problematic part is the Outbox. First, locate specialmailcollectionsrc in your KDE configuration directory ($HOME/.kde4/share/config or similar). It contains something like this:

   [SpecialCollections] DefaultResourceId=akonadi_maildir_resource_0

Now start akonadiconsole, on the Agents tab locate your local account for your Outbox folder, click on it and note the identifier that appears in the lower part (akonadi_maildir_resource_XXX or similar). Put this identifier in the above shown specialmailcollectionsrc, by replacing the existing one.

After that restart akonadi (you can do from the akonadiconsole, Server → Restart Server or from command line with:

   akonadictl restart

Now remove the Local Folders that you don’t want to use anymore.

If it keeps reappearing and the Mail Dispatcher Agent still crashes, you need to do one more thing in akonadiconsole. Go to the Browser tab, find the outbox you want to use, right click on
it, select Folder Properties, Attributes tab, enter SpecialCollectionAttribute then click Add, double click on the Value near the SpecialCollectionAttribute and enter outbox. Add also another attribute, the attribute name has to be ENTITYDISPLAY and the value ("outbox" "mail-folder-outbox" "") (just copy paste from here). Restart akonadi and now you should be able to remove completely the unneeded local folder account.

7.4 You get the error Unable to fetch item from backend when entering IMAP folder

There are a number of possible reasons for this and it is something the KMail team hopes to tackle in time. Meanwhile, there are some workarounds:

Workaround 1

- edit ~/.local/share/akonadi/mysql.conf
- Under the [mysql] section, add: `binlog_format=row`

If this does not work, try workaround 2 (below).

Workaround 2

This one is mostly a matter of restarting so KMail can fetch those pesky items... Some possible steps:

Use Alt-F2 or Konsole to type: `kquitapp kmail`, then wait a minute, then akonadictl `stop`, wait a minute, type akonadictl `start`, wait a minute, type kmail. This stops KMail (closing all windows), stops the KMail backend, starts the KMail backend, starts KMail. Having a working internet connection increases the chances of success. Sometimes, you can also just do kquitapp kmail, wait a minute, and start KMail again. Often, a few restarts seem to be needed. It is unclear what is the reason for this, but on bad network connections it is more likely to happen.

See also the below item for how akonadiconsole can be helpful.

7.5 Your mails are not being sent, without error messages

If KMail does not send mail without saying anything, the ‘agent’ responsible for dispatching the messages can be stuck. Of course, you need to ensure you have proper network connectivity for mail to be sent!

To remedy this, it might help to abort the current action and restart it. First, quit KMail by using KRunner (Alt-F2) or Konsole and typing: `kquitapp kmail`. Note that a normal Alt-F4 or File → Quit does not do the trick! Wait a minute, then start KMail again. Now start akonadiconsole using KRunner (Alt-F2) or Konsole. Go to the Mail Dispatcher Agent, do a right-click and abort the current action. You will most likely get some error messages popping up. Go back to KMail and choose File → Send Queued Messages. Now it might work. If not, instead of aborting the current action, try toggling the offline/online status of the Mail Dispatcher Agent or restarting things as mentioned in workaround 2 of the problem above this one.

NOTE

akonadiconsole can be quite helpful for a number of situations as it shows all the ‘agents’, the separate components of the KMail backend. You can stop and start them, put them in offline mode, abort ongoing actions etc. It can be very helpful when things get stuck.
Chapter 8

Credits and License

Daniel Naber
David Rugge
2013-04-24
KDE 4.11
KMail: Copyright the KMail developers, 1997-2013
This program is licensed under the terms of the GNU General Public License.
This documentation is licensed under the terms of the GNU Free Documentation License.

8.1 Development Team

• Laurent Montel (montel at kde org): Maintainer
• Ingo Klöcker (kloecker at kde org): Former maintainer
• Don Sanders (sanders at kde org): Adopter and co-maintainer
• Stefan Taferner (taferner at kde org): Original author
• Michael Häckel (haeckel at kde org): Former maintainer
• Till Adam (till at adam-lilienthal de): Core developer
• Carsten Burghardt (burghardt at kde org): Core developer
• Marc Mutz (mutz at kde org): Core developer
• Daniel Naber (daniel naber at t-online de): Documentation
• Zack Rusin (zack at kde org): Core developer
• Toyohiro Asukai (toyohiro at ksmplus com)
• Waldo Bastian (bastian at kde org)
• Ryan Breen (ryan at ryanbreen com): system tray notification
• Steven Brown (swbrown at ucsd edu)
• Matthias Kalle Dalheimer (kalle at kde org)
• Cristi Dumitrescu (cristid at chip ro)
• David Faure (faure at kde org)
• Philippe Fremy (pfremy at chez com)
• Kurt Granroth (granroth at kde org)
• Andreas Gungl (a gungl at gmx de): PGP 6 support and further enhancements of the encryption support
• Steffen Hansen (hansen at kde org)
• Igor Janssen (rm at linux ru net)
• Matt Johnston (matt at caifex org)
• Christer Kaivo-oja (whizkid at telia com)
• Lars Knoll (knoll at kde org): Original encryption support, PGP 2 and PGP 5 support
• J. Nick Koston (bdraco at darkorb net): GnuPG support
• Stephan Kulow (coolo at kde org)
• Guillaume Laurent (glaurent at telegraph-road org)
• Sam Magnuson (sam at trolltech com)
• Matt Newell (newellm at proaxis com)
• Denis Perchine (dyp at perchine com)
• Samuel Penn (sam at bifrost demon co uk)
• Carsten Pfeiffer (pfeiffer at kde org)
• Sven Radej (radej at kde org)
• Mark Roberts (mark at taurine demon co uk)
• Wolfgang Rohdewald (wrohdewald at dplanet ch)
• Espen Sand (espen at kde org)
• Aaron J. Seigo (aseigo at olympusproject org)
• George Staikos (staikos at kde org)
• Jason Stephenson (panda at mis net)
• Jacek Stolarczyk (jacek at mer chemia polsl gliwice pl)
• Roberto S. Teixeira (maragato at kde org)
• Bo Thorsen (bo at sonofthor dk)
• Ronen Tzur (rtzur at shani net)
• Mario Weilguni (mweilguni at sime com)
• Wynn Wilkes (wynnw at calderasystems com)
• Robert D. Williams (rwilliams at kde org)
• Markus Wübben (markus wuebben at kde org)
• Karl-Heinz Zimmer (khz at kde org)
8.2 Credits

- Heiko Hund (heiko at ist eigentlich net): POP filters
- Bernhard Reiter (bernhard at intevation de): Ägypten and Kroupware project management
- Jan Simonson (jan at simonson pp se): beta testing of PGP 6 support
- Patrick S. Vogt (patrick vogt at unibas ch): timestamp for 'Transmission completed’ status messages
- Jan-Oliver Wagner (jan at intevation de): Ägypten and Kroupware project management
- Wolfgang Westphal (wolfgang westphal at gmx de): multiple encryption keys per address
- Thorsten Zachmann (t zachmann at zagge de): POP filters

8.3 Documentation

Update for KMail 4.11 by Laurent Montel montel@kde.org and Scarlett Clark scarlett@scarle.ttglyclark.com

Update for KMail 1.7 by Ingo Klöcker kloecker@kde.de and Marc Mutz mutz@kde.org, Anti-Spam Wizard chapter by Andreas Gungl a.gungl@gmx.de, section about filter log by Andreas Gungl a.gungl@gmx.de and Brad Hards bradh@frogmouth.net, additional changes by Daniel Naber daniel.naber@t-online.de.

Update for KMail 1.2 to 1.5 by Daniel Naber daniel.naber@t-online.de, OpenPGP chapter by Andreas Gungl a.gungl@gmx.de and Ingo Klöcker kloecker@kde.de, message filter chapter by Marc Mutz mutz@kde.org, download filter chapter by Thorsten Zachmann T.Zachmann@zagge.de. Other parts have been contributed by various KMail developers.

KMail 1.0 documentation by David Rugge davidrugge@mediaone.net. Original documentation by Markus Wuebben markus.wuebben@kde.org, Robert Williams rwilliams@kde.org (Editor).

Thanks to Michael Elkins me@cs.hmc.edu for his excellent description of the different UNIX® mail formats in the Mutt documentation.

Thanks to the following people for providing directions on using other email client mailboxes with KMail:

- Nik Gaffney nik@f0.am (Mailsmith)
- David McMillen mcmillen@math.bu.edu and Mendel Mobach mendel@mobach.nl (Netscape® mail)
- Ed Shapard shapard@bigfoot.com (Pegasus Mail)
- Ray Muir rjmuir@ibm.net (Forte Agent)