The KXStitch Handbook

Stephen P. Allewell
## Contents

1 Introduction ................................................................. 6

2 Features ........................................................................ 7

3 The User Interface ............................................................ 9
   3.1 The KXStitch Main Window ........................................... 9
   3.2 Editor Window ............................................................ 10
      3.2.1 Context Menu ...................................................... 10
   3.3 Preview Window ......................................................... 10
   3.4 Palette Window .......................................................... 10
      3.4.1 Context Menu ...................................................... 11

4 Command Reference .......................................................... 12
   4.1 KXStitch Menus .......................................................... 12
      4.1.1 The File Menu ..................................................... 12
      4.1.2 The Edit Menu ..................................................... 13
         4.1.2.1 Cut, Copy and Paste ...................................... 14
      4.1.3 The View Menu .................................................... 14
      4.1.4 The Stitches Menu ............................................... 15
      4.1.5 The Tools Menu ................................................... 15
      4.1.6 The Palette Menu .................................................. 16
      4.1.7 The Library Menu ................................................. 17
      4.1.8 The Pattern Menu ............................................... 17
      4.1.9 The Settings Menu ................................................. 17
      4.1.10 The Help Menu .................................................. 18

5 Creating patterns .............................................................. 19
   5.1 Starting KXStitch ....................................................... 19
   5.2 Importing Images ...................................................... 19
   5.3 Background Images .................................................... 19
   5.4 Pattern Libraries ....................................................... 20

6 Printing patterns .............................................................. 21
7 Dialogs

7.1 The Palette Manager Dialog .................................................. 22
  7.1.1 Symbol Selector .......................................................... 23
7.2 The New Color Dialog .......................................................... 24
7.3 The Floss Calibration Dialog .................................................. 25
7.4 The Configuration Dialog ..................................................... 26
7.5 The Import Image Dialog ...................................................... 26
7.6 The File Properties Dialog .................................................... 27
7.7 The Pattern Library Dialog ................................................... 28
7.8 The Text Dialog ................................................................. 30
7.9 Extend Pattern Dialog ......................................................... 30
7.10 The Printer Dialog .............................................................. 31
  7.10.1 Pattern Element ............................................................ 32
    7.10.1.1 Map Element ......................................................... 33
  7.10.2 Text Element .............................................................. 33
    7.10.2.1 Text Variables ....................................................... 34
  7.10.3 Key Element ............................................................... 34
  7.10.4 Resize Element ............................................................ 35

8 Credits and License ................................................................. 37

A Installation ............................................................................. 38
  A.1 How to obtain KXStitch ....................................................... 38
  A.2 Requirements ................................................................. 38
  A.3 Compilation and Installation ................................................ 38
Abstract

KXStitch is an application designed to allow people to create cross stitch patterns and print them. These patterns can be either created from scratch on a user defined size of grid, or an image can be imported from various graphic files.
Chapter 1

Introduction

KXStitch is a program that lets you create cross stitch patterns and charts. Patterns can be created from scratch on a user defined size of grid, which can be enlarged or reduced in size as your pattern progresses. Alternatively you can import images from many graphics formats. When importing images you can restrict the conversion to full stitches or optionally use fractional stitches. You may also use images as backgrounds resizing them to fit in a selected area. These imported images can then be modified using the supplied tools to produce your final design.

There are many tools to aid designing your pattern, from open and filled rectangles and ellipses, filled polygons and lines and backstitching. Additionally cut, copy and paste can be used to duplicate selected areas. Selected areas can also be rotated 90, 180 and 270 degrees anti clockwise, or mirrored horizontally or vertically.

There is also a pattern library that can be used to store small and not so small portions of patterns that can then be reused in other patterns. The patterns in these libraries are stored in a hierarchical list that makes it easy to sort and navigate them to find the ones you want. These pattern libraries can also be used as alphabets by assigning a character to each one. By using the Alphabet tool, each key press is searched for in the current library and if present, the associated library pattern will be inserted in the pattern.

Please report any bugs or feature requests to the KDE Bugtracking System or the KXStitch mailing list
Chapter 2

Features

The current feature list and other planned features is shown here.

• Creation of new patterns
  – User defined size
  – Selection of material color
  – Insertion of a background images for tracing
  – Importing of various image formats
  – Importing options allow
    * Limiting the number of colors
    * Limiting colors to a specific palette
    * Scaling to a finished size
    * Support for transparency in images
    * Allow the use of fractional stitches

• Editing of existing patterns, Editing tools will include
  – Open and filled rectangles
  – Open and filled ellipses
  – Filled polygons
  – Painting
  – Lines
  – Erasing stitches, knots and backstitches
  – Color selection from existing stitches
  – Swapping two colors
  – Replace one color with another
  – Text with user defined fonts and sizes
  – Cut, copy and paste of rectangular areas.
  – Unlimited undo and redo
  – Mirroring, horizontally and vertically.
  – Rotation, 90, 180 and 270 degrees anti clockwise.
  – Resizing of the canvas
    * Extend canvas left, top, right, bottom
    * Cropping canvas to pattern
    * Cropping canvas to selection
The KXStitch Handbook

- Inserting rows and columns
- Center the pattern on the canvas
  - Conversion between floss schemes
- Use of standard floss pallets, DMC, Anchor, etc.
- Create customized floss pallets
- Create new colors for any floss pallet
- Save / Load current palette
- Use of standard stitches
- Pattern library manager
  - Create new library patterns
  - Insert library patterns into a design
  - Drag and drop from the library to the pattern
  - Drag and drop from one library to another
  - Assign key press to patterns for use with the Alphabet tool
- Free use of backstitching
- Printing of completed patterns and floss keys
  - Pattern image
  - Instructions
  - Floss key and stitch summary
  - Pattern chart with page map
  - Text boxes
- Mapping of symbols to flosses
- Specify the number of threads for stitches and backstitches
- Calibration of floss colors

Requests for new features can be made to the KDE Bugtracking System
Chapter 3

The User Interface

3.1 The KXStitch Main Window

The KXStitch main window consists of an editor window shown on the right in the image above with three dock windows. The dock windows provide a preview of the pattern, the palette of flosses and a history list. If an image is imported, an additional dock window showing a preview of the original image for reference will be shown. Each of these dock windows can be moved around to various edges of the main window, detached from the view or turned off and back on.

The sections are divided by splitters, which can be moved to change the amount of space allocated to any of the sections.

The layout of other elements, menu bar, toolbars and the status bar, is similar to other KDE applications you run.

The status bar at the bottom of the window shows various status messages.
3.2 Editor Window

The main editing window shows a grid pattern and scales top and left. The scales can be formatted in stitches, centimeters or inches. The editor is a scrolling, zoomable view of your pattern and allows you to use the various editing tools to modify your design.

Generally the left mouse button is used to activate any of the tools on the pattern. Details of each of the tools and their use is shown in the command reference section.

The grid shows heavier lines dividing the cells into groups. The number of cells per group is configurable, the default is 10, as are the colors for the lines. This is useful if you are creating patterns on a dark colored canvas that requires lighter colored lines for contrast.

A menu option allows you to add background images to the editor window, to use as a template for adding stitches. For more details see the section on Creating Patterns.

3.2.1 Context Menu

Using your right mouse button on the editor will activate a context menu allowing you to change the format of the scales and the visual appearance of the stitches. It also allows you to toggle on or off the background images, the stitches, backstitches, the grid and the scales.

3.3 Preview Window

The Preview window shows a scrolling overview of the current design at a smaller scale than the Editor window. The Preview shows a black rectangle representing the current view within the Editor window.

By clicking the left mouse button within the preview window, the Editor window will be centered on that point. Additionally by pressing down the left mouse button and dragging a rectangle around an area, the Editor window will be zoomed to encompass that area.

3.4 Palette Window

The Palette window shows the floss colors currently in this patterns palette as colored blocks, and optionally with the symbols that are associated with each color. Moving the mouse pointer over a color block will pop up a tool tip showing the color number and name for that color. Clicking on a color selects that color for the next painting or drawing function.
3.4.1 Context Menu

Using your right mouse button on the Palette view will activate a context menu allowing you to perform several functions on the palette. See the command reference for more details on their use.
Chapter 4

Command Reference

4.1 KXStitch Menus

4.1.1 The File Menu

New (Ctrl+N)
   Creates a new pattern, using the default values set in the pattern properties dialog.

Open (Ctrl+O)
   Opens an existing pattern

Open Recent
   Open a recently used pattern

Save (Ctrl+S)
   Saves the pattern

Save As (Ctrl+Shift+S)
   Saves the pattern under a new name

Revert
   Revert the pattern to the last saved state

Print (Ctrl+P)
   Print the pattern

Print Setup
   Set up the printing layout

Import Image
   Import an image file converting it to stitches

File Properties
   Display / Edit the document properties

Add Background Image
   Insert an image as a background for tracing.
The KXStitch Handbook

Remove Background Image
Select a background image to remove. The sub menu for this is populated from the background images previously inserted.

Close (Ctrl+W)
Close the pattern

Quit (Ctrl+Q)
Quits KXStitch

4.1.2 The Edit Menu

Undo (Ctrl+Z)
Undo the last change. The list of changes are shown in the History window.

Redo (Ctrl+Shift+Z)
Redo the last change undone. The list of changes are shown in the History window.

Cut (Ctrl+X)
Cut the selected area to the clipboard

Copy (Ctrl+C)
Copy the selected area to the clipboard

Paste (Ctrl+V)
Paste the selected area

Selection Masks → Stitch Mask
Limit selections to the currently selected stitch type

Selection Masks → Color Mask
Limit selections to the currently selected color

Selection Masks → Exclude Backstitches
Exclude backstitches from the selection

Selection Masks → Exclude Knots
Exclude Knots from the selection

Mirror / Rotate makes copies
If set, the mirror and rotate functions will make a copy of the selection, otherwise the selected area is moved

Mirror Selection → Horizontally
Mirror the selected area horizontally, i.e. flipped from left to right

Mirror Selection → Vertically
Mirrors the selected area vertically, i.e. flipped from top to bottom

Rotate Selection → 90 degrees
Rotate the selected area anti clockwise 90 degrees

Rotate Selection → 180 degrees
Rotate the selected area anti clockwise 180 degrees

Rotate Selection → 270 degrees
Rotate the selected area anti clockwise 270 degrees
4.1.2.1 Cut, Copy and Paste

Cutting and copying areas of the pattern can make use of stitch and color masks and the exclusion of backstitches and knots to limit the selection. The paste operation in KXStitch allows you to press and hold the left mouse button down roughly in the position that the paste data is to go which will provide an image of the paste data to allow accurate positioning before releasing the mouse button to finalize the position. This technique is also used for the mirroring and rotate functions. The cursor keys can also be used to move the pasted pattern around and the Enter key used to fix the position.

4.1.3 The View Menu

Actual Size
   Zoom the view so that the screen size approximates the physical size

Fit To Page
   Zoom the view so that the whole pattern fits within the visible area

Fit To Page Width
   Zoom the view so that the patterns width fits within the visible area

Fit To Page Height
   Zoom the view so that the patterns height fits within the visible area

Zoom In (Ctrl++)
   Zoom in on the editor view

Zoom Out (Ctrl+-)
   Zoom out on the editor view

Preview
   Show or hide the preview window

Palette
   Show or hide the palette window

History
   Show or hide the history window

Imported Image
   Show or hide the imported image preview window

Show Background Image
   Show or hide a background image. The list is generated dynamically based on the inserted background images

Fit Background Image to Selection
   Fit the selected background image to the current selection area
4.1.4 The Stitches Menu

Quarter Stitch
Quarter Stitch, the position is determined by the quadrant of the cell selected

Half Stitch
Half Stitch, the direction is determined by the quadrant of the cell selected

3 Quarter Stitch
Three Quarter Stitch, the orientation is determined by the quadrant of the cell selected

Full Stitch
Full Stitch

Small Half Stitch
A small half stitch, the position is determined by the quadrant of the cell selected

Small Full Stitch
A small full stitch, the position is determined by the quadrant of the cell selected

French Knot
French Knot Stitch

4.1.5 The Tools Menu

Paint
Paint stitches onto the canvas - Press down the left mouse button and drag around the window. Stitches will be added to each cell passed over. Release the mouse button to stop painting.

Draw
Draw a line of stitches onto the canvas - Press down the left mouse button at the start of the line, drag to the required end point of the line and release the mouse button. Stitches will be added to each cell that the line passes through.

Erase
Erase stitches - Press down the left mouse button and drag over the stitches to be deleted. All stitches within the cells passed over will be removed. Release the mouse button to stop erasing. To erase backstitches hold down the Ctrl key and left click in the start or end point of the backstitch, if there is more than one backstitch at the digitized point this method will erase the first one found. To delete a specific backstitch, click and drag from one end to the other. To erase french knots hold down the Shift key and left click on the knot to delete it.

Draw Rectangle
Draw a rectangle - Press down the left mouse button at one corner of the rectangle and drag to the opposite corner. Release the mouse button and an unfilled rectangle of stitches will be added to the canvas.

Fill Rectangle
Draw a filled rectangle - Press down the left mouse button at one corner of the rectangle and drag to the opposite corner. Release the mouse button and a filled rectangle of stitches will be added to the canvas.

Draw Ellipse
Draw an ellipse - Press down the left mouse button at one corner of the ellipse and drag to the opposite corner. Release the mouse button and an unfilled ellipse of stitches will be added to the canvas.
Fill Ellipse

Draw a filled ellipse - Press down the left mouse button at one corner of the ellipse and drag to the opposite corner. Release the mouse button and a filled ellipse of stitches will be added to the canvas.

Fill Polygon

Draw a filled polygon - Click on each cell marking the vertexes of the polygon, click and drag to create more complex curves. Each of the vertexes are marked by a circle with a black line joining them. To close the polygon click on the starting cell again. You can use the **Backspace** key to remove the last point, or the **Esc** key to remove all vertexes and cancel the operation.

Text

Insert text in stitches. This invokes the text dialog. Select the font required and the size, enter the text and click **OK**. Press the left mouse button roughly where you would like the text, move the mouse to position the text accurately and then release the mouse button. This is the same as the paste function.

Alphabet

Insert patterns from the currently selected library that match the keys pressed. This allows the creation of pattern alphabets that can have a key assignment. After selecting this tool and clicking a position on the pattern for the insertion point, each key pressed will be searched for in the current library for a matching pattern. If found this will be inserted at the position on the pattern and the insertion position then advanced by the width of the inserted character pattern. The pattern space will be extended right to allow further characters to be entered. Pressing **Enter** will start a new line under the position of the original insertion point, the pattern space will be extended downwards to accommodate the new line if insufficient space is available. **Backspace** will delete the last character entered and the **Space** key will advance the insertion point by either the width of a space character in the library or a predetermined amount if no space character exists. The text will wrap onto the next line if the edge of the pattern is reached and the end of a word is detected.

Select

Select a rectangular region - Press down the left mouse button at one corner of the rectangle, drag to the opposite corner and release the button. A selection rectangle is shown to indicate the area.

Color picker

Allows the selection of a color from the existing stitches. Hovering over stitches will show a tool tip indicating the color under the cursor. Clicking with the left mouse button will select it.

Backstitch

Add backstitching to the canvas - Press down the left mouse button at the start of the backstitch, it will snap to the closest of 9 points in the cell, drag to the end point of the backstitch and release the mouse button, again this will snap to the nearest of 9 points in the cell.

4.1.6 The Palette Menu

Palette Manager

Add and remove colors to the current palette. Assign symbols and the number of strands for the stitching and backstitching.

Show Symbols

Show the symbols associated with each color
Clear Unused
Removes the unused colors from the palette.

Swap Colors
The next color selected will be swapped with the currently selected color. If you select the eye dropper tool, you can choose the color to be swapped with directly from the pattern.

Replace Colors
The next color selected will replace the currently selected color. As with swap colors, you can use the eye dropper tool to select the color from the pattern.

4.1.7 The Library Menu

Library Manager
Open the pattern library manager which is a non modal dialog allowing the creation and use of libraries of patterns or alphabets. Drag and drop is available to allow the dragging and dropping of patterns from the library to the pattern. Automatic conversion of flosses to suit the current pattern and scaling of the image to the current pattern scale for accurate positioning.

4.1.8 The Pattern Menu

Extend Pattern
Extend the pattern top, left, right and bottom

Center Pattern
Center the pattern in the canvas

Crop Canvas To Pattern
Crop the canvas to the extents of the pattern

Crop Canvas To Selection
Crop the canvas to the extents of the current selection

Insert Rows
Insert a number of rows represented by a selection area

Insert Columns
Insert a number of columns represented by a selection area

4.1.9 The Settings Menu

Apart from the common KDE Settings menu entries described in the Settings Menu chapter of the KDE Fundamentals KXStitch has these application specific menu entries:

Format Scales As
Change the scale display format to Stitches, CM or Inches.

Render Stitches As
Change the way stitches are displayed.
Render Backstitches As
   Change the way backstitches are displayed.

Render Knots As
   Change the way knots are displayed.

Color Highlight
   Enable or disable color highlight mode

Show Stitches
   Show or hide the stitches

Show Backstitches
   Show or hide the backstitches

Show French Knots
   Show or hide the french knots

Show Grid
   Show or hide the grid

Show Background Images
   Show or hide all the background images

Configure KXStitch
   Open KXStitch configuration dialog.

4.1.10 The Help Menu

Additionally KXStitch has the common KDE Help menu items, for more information read the section about the Help Menu of the KDE Fundamentals.
Chapter 5

Creating patterns

5.1 Starting KXStitch

When starting KXStitch you will be presented with a blank canvas of the default size. This is also the case when selecting File → New. The default sizes can be set in the pattern properties dialog by enabling the set as default checkbox.

If the default size is not suitable for your planned pattern, you can use the File → File Properties dialog to change it. Adjust the values as required and after clicking on OK, the pattern will be resized to suit.

Before creating a pattern you will need to add some flosses to the palette using the Palette → Palette Manager. This will enable the tools in the Tools menu and toolbar. See the Palette Manager Dialog for further information.

5.2 Importing Images

KXStitch allows you to import an image. A dialog will be displayed that previews the image based on the default import options.

The initial size of the pattern will be based on the default pattern size.

Options for importing allow you to change the floss scheme used and to limit the number of colors. You can also change the scaling to reduce or enlarge the final pattern.

Checking the Use fractionals checkbox will enable the use of fractional stitches to give more detail for any given pattern size.

Checking the Ignore color checkbox will allow the selection of a color within the image which will then be considered as the transparent color and ignored during the import.

After the image has been imported, an additional dock window will be available giving a preview of the original image without any color transitions.

5.3 Background Images

You can insert an image as a background to the editor window. This is useful if importing the image is not desirable or gives poor results.

The image is normally scaled to cover the entire pattern grid. This may not be suitable, therefore you can use the select tool to select an area that you want to cover and then select the View → Fit
**Background Image to Selection.** This will rescale the image to fit within the selected area. You can continue doing this until you are happy with the result, even after you have started adding stitches.

There is no limit to the number of background images that can be added. Although practical limits of the menus will determine how many can be added. The background images are stored within the document, so they will be available when the pattern is reloaded.

### 5.4 Pattern Libraries

The pattern library manager can be used to store patterns for insertion into the working pattern. They can be categorized into a hierarchy of categories and subcategories with multiple root nodes in the library list. The Alphabet tool makes use of these libraries to provide an alphabet of insertable characters that can be assigned an associated key.

The library manager is a non-modal dialog and can be left open whilst working on your pattern. You can select different libraries as needed and then drag and drop library patterns onto the working pattern.

Adding new category headings can be done with a right mouse button on either an existing entry, to create a sub category, or on a blank space on the library list, to create a new root entry, and selecting the **New Category** option. Enter the name of the category and click **OK**.

Creating a new library pattern is done by selecting an area of your working pattern, copying and pasting to one of the existing categories.

Each library pattern has properties, accessed by its context menu. These properties include size, floss scheme, baseline value and associated key. The baseline value is used by the Alphabet tool to adjust the height of a character above, negative values, or below the insertion point. The associated key is again used by the Alphabet tool to match with the key pressed on the keyboard.
Chapter 6

Printing patterns

Once you have completed your design, you will no doubt want to print it. KXStitch allows you to customize the printing, from what is printed to how big the final print is.

This version of KXStitch allows a fully customized printing layout. The new printer configuration allows pages to be added, inserted or removed. The paper size and orientation can be selected and each page can contain text elements, pattern elements or key elements.

For further details see the printer dialog
Chapter 7

Dialogs

7.1 The Palette Manager Dialog

The palette manager allows you to add, remove or swap flosses from your current palette and the selected scheme. You can remove all non used flosses from your current palette and you are able to add new flosses to the scheme. Additionally you can bring up the floss calibration dialog from here.

You can allocate the number of strands of cotton used for each floss, for both stitching and back-stitching. This information will be used in calculating the amount of floss required in the final design.

The dialog includes a Pick Color button which allows selection of a color from anywhere on screen. This could be from a background image for example to allow easy selection of matching colors. The cursor will change to a cross with a color swatch indicating the color of the pixel under the cross. After clicking on a pixel, a floss that closely matches the selected color will be selected in the flosses list.
7.1.1 Symbol Selector

For each of the flosses you can allocate a symbol. The symbol selector dialog shows all the available symbols. Used symbols are shown grayed out and a tooltip will show 'Used' when the symbol is hovered over. For the palette, the symbol library used can also be changed by selecting one from the drop down list. All the flosses will then be allocated a symbol from the new library.
The dialog shows the name of the scheme that the new color will be added to. The color requires a name and a description, which can be anything you want, although color name will usually be defined by the floss manufacturer.

Clicking on the Color button will show a standard KDE color selection dialog. The initial color can be selected and then the parameters can be adjusted to give the correct color.

Once added this new color will be available to be included in your patterns palette via the Palette Manager dialog. It may also be adjusted by using the Floss Calibration dialog.
7.3 The Floss Calibration Dialog

This dialog has two parts.

On the left, a pick list of the schemes that are currently available along with a list of colors that are in that scheme. The color description will be appended with (Calibrated) if the color has been modified by the current invocation of this dialog.

On the right, is the name and description of the currently selected color, this will be appended with (Modified) if the color has been modified, a preview of the color, and the current RGB values for the color.

Also shown is a Reset Color button. This will reset the currently selected color to the value it had when the dialog was first invoked.

Pressing the OK button will commit all of the changed colors.

Pressing the Cancel button will restore all the changed colors back to their original values.
7.4 The Configuration Dialog

This dialog lets you configure a number of elements of KXStitch. Most of the options are self explanatory. The check boxes enable or disable various functions or elements. The pick lists allow selection of the required format of those elements. You can return to the default set of parameters using the **Defaults** button.

7.5 The Import Image Dialog

![Image of the Import Image Dialog]

This dialog lets you configure a number of elements of KXStitch. Most of the options are self explanatory. The check boxes enable or disable various functions or elements. The pick lists allow selection of the required format of those elements. You can return to the default set of parameters using the **Defaults** button.
On the left of the dialog there is a preview of the imported image, based on the parameters on the right.

The floss scheme for the finished pattern can be selected, by default this is the same as the **New Pattern Properties** dialog defaults. The maximum colors to be used for the pattern can be enabled and changed as required, by default the imported pattern will have as many colors as are defined in the original image that are converted to floss colors. Checking the **Ignore Color** box allows you to click the dropper tool to select a color in the image that will be ignored on import. This is useful to remove backgrounds that you don’t need converting to stitches. The ignored color will be displayed as a checker board pattern in the preview.

The cloth count value defaults to the **New Pattern Properties** dialog and the scale is set such that the final size is as close to the **New Pattern Properties** pattern size as possible. These values can be changed as required.

The **Crop image** checkbox enables cropping of the preview image. Click and drag across the preview image to select the area required. Guide lines are shown before selecting the starting point to allow more accurate placement. Once an area is selected the preview will be rerendered to show the cropped area. Further cropping can be done if required. Clicking on the reset button, or turning off cropping will revert the preview to the original image.

The **Use fractionals** checkbox will enable the use of fractional stitches in the imported pattern. This effectively doubles the import resolution without affecting the overall size of the pattern.

Clicking **OK** will convert the image into a pattern.

### 7.6 The File Properties Dialog

The pattern size can be defined in units of stitches, centimeters or inches. The width and height values will updated automatically to the equivalent size in the new unit type if the units type is changed.

The cloth count is defined in units per centimeter or inches and is dependent on the units of size. i.e. if CM is selected for the units then cloth count will be in units per centimeter, similarly for
inches. If the Units is changed to Stitches then the cloth count units will remain as the last CM or inches value.

The Title, Author, Copyright and Fabric fields are free text, so you can enter anything you like here. The fabric color can be set by pressing the color button and selecting the required color. This will then be shown in the editor and preview windows.

The floss scheme has a pick list for all the available floss schemes, including any that you have defined yourself.

The Instructions tab can be used to enter any specific instructions for sewing the pattern.

### 7.7 The Pattern Library Dialog

The Pattern Library Manager has a hierarchical tree view (more of a forest really) of categories on the left with an icon view of the selected category of patterns on the right. This dialog is non-modal and can be left open whilst working on the pattern.

The simplest way to use the library patterns is to drag and drop them onto the pattern space. Alternatively using the right mouse button on a library pattern will show a context menu with an option to copy it, this can then be pasted into the pattern as many times as required.

Additional items on the context menu are:

- **Delete**: Delete a library item, for which a confirmation dialog is shown.
- **Properties**: Show the properties dialog for the item.
The properties dialog for each item displays its size and the floss scheme used, the baseline value and the associated keyboard character. The baseline is used to position the character pattern vertically relative to the cursor position when using the Alphabet tool. Positive values move it down, negative values move it up. The associated character is only required for use with the Alphabet tool. After clicking in the associated character text box, the next key press, including modifiers (Shift, Ctrl, etc.) is used as the key.

Create new libraries by clicking the right mouse button on either an existing category, to create a sub category, or on a blank area of the library list, for a new top level category, and select the New Category option, enter the name and click OK.

Creating a new library pattern by selecting an area in the pattern editor, select copy, then use the right mouse button on an existing category and select paste. If necessary you can use the properties option to add an associated key if you want to use it as a character library.

Library patterns can be dragged and dropped to other libraries in the list to allow you to rearrange them to your needs. Note that there is no checks to ensure that the key codes assigned to library patterns is unique and you should modify any that duplicate an existing one.
7.8 The Text Dialog

The text dialog allows you to select a font and size, then enter the text. Clicking OK closes the dialog and returns you to the KXStitch window. Positioning the text is the same as pasting any other element. Press the left mouse button on the canvas roughly where you want the text, this will show a preview of the text, position the text exactly where you want it, then release the left mouse button.

7.9 Extend Pattern Dialog

This is used to extend the pattern in various directions by a number of cells. Enter the number of cells in the spin boxes and press OK to extend the pattern.
7.10 The Printer Dialog

The dialog has a page list on the left showing a thumbnail for each of the pages. The right panel contains the layout editor where the elements can be placed. Each element is customizable using the context menu and can be positioned and sized to suit your requirements.

Select a printer configuration template. Currently a similar one to KDE3 is included.

Append a page - This will append a page at the end of the list.
The KXStitch Handbook

- Insert a page - This will insert a page before the one currently selected in the list.
- Delete a page - This will delete the page currently selected in the list.
- Select an element - Used to select elements for editing or resizing.
- Insert a text element - Used to insert a text element onto the current page.
- Insert a pattern element - Used to insert a pattern element onto the current page.
- Insert an image element - Used to insert an image element onto the current page.
- Insert a key element - Used to insert a floss key element onto the current page.

When adding elements, select the required element icon, then select the area of the page that the element is to occupy by clicking and dragging with the left mouse button from one corner to another. The properties of the element can be viewed and changed using the context menu accessed by the right mouse button.

The elements can be resized by selecting them using the select tool, this will provide a sizing rectangle around the element. The corners can be dragged around to adjust the size or the whole element can be moved by clicking and dragging using the left mouse button.

The page has an associated properties dialog which allows setting the page margin and the grid size and visibility. The page margin provides a guide for the placement of objects but does not prevent elements from being positioned outside the defined margin.

### 7.10.1 Pattern Element

The pattern element will show the arrangement of stitches on the grid. The properties dialog can be used to configure how the stitches will be displayed. This allows the element to display as a picture of the pattern or as the working pattern showing the symbols.
The KXStitch Handbook

The pattern element defaults to showing the whole pattern when it is created. Using the properties dialog a selection of the required area can be made in the preview window by clicking and dragging a selection area.

7.10.1.1 Map Element

The map element is used when the pattern spans multiple sheets. It shows the area of the whole pattern that this element represents. It can be enabled in the pattern element properties.

7.10.2 Text Element

A text element can be used to add text notes to the pattern or to show titles or comments. The text is configurable with fonts, color and transparency. In addition a border can be displayed.
Text elements can also utilize variables which will be converted to properties from the pattern.

### 7.10.2.1 Text Variables

- \$\{title\}
- \$\{author\}
- \$\{copyright\}
- \$\{fabric\}
- \$\{instructions\}
- \$\{horizontalClothCount\}
- \$\{verticalClothCount\}
- \$\{width.stitches\}
- \$\{height.stitches\}
- \$\{width.inches\}
- \$\{height.inches\}
- \$\{width.cm\}
- \$\{height.cm\}
- \$\{scheme\}
- \$\{page\}

### 7.10.3 Key Element

The key element shows the flosses used. The properties dialog allows the selection of the fields that can be displayed. The First element and No. elements can be used for large keys that may span multiple pages and allows some symbols to be on one page and others to be on another page.
DMC Flosses

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Name</th>
<th>Strands</th>
<th>Description</th>
<th>Stitches</th>
<th>Length (m)</th>
<th>Skeins (8m)</th>
</tr>
</thead>
<tbody>
<tr>
<td>▲</td>
<td>317</td>
<td>2 / 2</td>
<td>Pewter Gray</td>
<td>43</td>
<td>0.66</td>
<td>1 (0.01)</td>
</tr>
<tr>
<td>▼</td>
<td>318</td>
<td>2 / 2</td>
<td>Steel Gray Lt</td>
<td>333</td>
<td>5.1</td>
<td>1 (0.11)</td>
</tr>
<tr>
<td>▲</td>
<td>414</td>
<td>2 / 2</td>
<td>Steel Gray Dk</td>
<td>21</td>
<td>0.32</td>
<td>1 (0.01)</td>
</tr>
<tr>
<td>▲</td>
<td>415</td>
<td>2 / 2</td>
<td>Pearl Gray</td>
<td>18</td>
<td>0.28</td>
<td>1 (0.01)</td>
</tr>
<tr>
<td>▲</td>
<td>433</td>
<td>2 / 2</td>
<td>Brown Med</td>
<td>2423</td>
<td>37.15</td>
<td>1 (0.77)</td>
</tr>
<tr>
<td>▲</td>
<td>434</td>
<td>2 / 2</td>
<td>Brown Light</td>
<td>6</td>
<td>0.09</td>
<td>1 (0)</td>
</tr>
<tr>
<td>▲</td>
<td>762</td>
<td>2 / 2</td>
<td>Pearl Gray Vv Lt</td>
<td>22</td>
<td>0.34</td>
<td>1 (0.01)</td>
</tr>
<tr>
<td>●</td>
<td>780</td>
<td>2 / 2</td>
<td>Topaz Ultra Vv Dk</td>
<td>4</td>
<td>0.06</td>
<td>1 (0)</td>
</tr>
<tr>
<td>●</td>
<td>782</td>
<td>2 / 2</td>
<td>Topaz Dark</td>
<td>53</td>
<td>0.81</td>
<td>1 (0.02)</td>
</tr>
<tr>
<td>●</td>
<td>783</td>
<td>2 / 2</td>
<td>Topaz Medium</td>
<td>2</td>
<td>0.03</td>
<td>1 (0)</td>
</tr>
<tr>
<td>▼</td>
<td>927</td>
<td>2 / 2</td>
<td>Gray Green Light</td>
<td>22</td>
<td>0.34</td>
<td>1 (0.01)</td>
</tr>
</tbody>
</table>

7.10.4 Resize Element

All elements can be resized by selecting them with the [ ] which will show the resize boundary. The whole element can be moved by clicking and dragging inside the element. To resize, hover over the corner resize handles, click and drag to the required size.
Chapter 8

Credits and License

KXStitch
Program copyright 2002-2015 Stephen P. Allewell steve.allewell@gmail.com
Contributors:

• Pierre Brua kxstitchdev@paralline.com: Bug fixes, application icons
• Eric Pareja xenos@upm.edu.ph: Man page
• Adam Gundy adam@starsilk.net: Bug fixes, improvements

Documentation copyright 2015 Stephen P. Allewell steve.allewell@gmail.com
This documentation is licensed under the terms of the GNU Free Documentation License.
This program is licensed under the terms of the GNU General Public License.
Appendix A

Installation

A.1 How to obtain KXStitch

The KXStitch source can be found at http://download.kde.org/stable/kxstitch/. The KXStitch homepage can be found at http://userbase.kde.org/KXStitch.

A.2 Requirements

KXStitch has been written with Qt™ 5.x and KDE Frameworks 5.

For the image import functions the ImageMagick libraries are required, this includes the development headers ImageMagick and Magick++, these are available with your distribution or from http://www.imagemagick.org/.

A.3 Compilation and Installation

Compilation of KXStitch requires cmake and suitable build tools, make, gcc, etc. A build script has been provided which should perform the necessary compilation operations and install KXStitch for which you may be required to enter the root password.

bash$ ./build.sh