# Contents

1 Introduction ............................................. 6

2 Using KuickShow ........................................ 7
   2.1 More KuickShow features .............................. 7

3 The KuickShow Configuration Dialog ...................... 9
   3.1 General Options ...................................... 9
   3.2 The Modifications Tab ................................. 10
   3.3 The Slideshow Tab .................................... 11
   3.4 The Shortcuts Tabs ................................... 11

4 Menu Reference ......................................... 12
   4.1 The File Menu ......................................... 12
   4.2 The Edit Menu ......................................... 12
   4.3 The View Menu ........................................ 13
   4.4 The Settings and Help Menu ........................... 13

5 Command Reference ...................................... 14
   5.1 The Image Window .................................... 14
   5.2 The Browser Window ................................. 15

6 Credits and License ...................................... 17
The KuickShow Handbook

List of Tables

5.1 Image Window Keyboard Shortcuts ........................................ 15
5.2 Image Window Mouse Usage ............................................ 15
5.3 Browser Window Keybindings ............................................ 15
5.4 Browser Window Mouse Usage ............................................ 16
Abstract

KuickShow is a comfortable image browser/viewer.
Chapter 1

Introduction

KuickShow is a comfortable image browser/viewer. It displays a filebrowser where you can select images which are then shown.

The following image formats are supported:

- jpg
- gif
- tiff
- png
- bmp
- psd
- xpm
- ppm
- pgm
- pbm
- pnm
- eim
- xcf

Images can be displayed either in their own window, as large as the image, or fullscreen.
Chapter 2

Using KuickShow

Using KuickShow is very simple. The file browser lists files, which you can select with a left mouse button click or the Return key.

2.1 More KuickShow features

The options dialog makes available more possibilities:

- Images can be automatically shrunk to fit onto the screen, if they are larger.
- You can configure whether images should show up in their own window, or always use the same window.
- You can set the delay time for a slide show.
- You can tell the browser which file types to show.
• You can tweak the speed/quality ratio

If you are looking for a certain file, just enter the first few characters of its filename in the browser. A small edit window will pop up in the bottom right corner. When a matching file is found, it is highlighted. You can leave the edit window by pressing **Return** or **Esc**.
Chapter 3

The KuickShow Configuration Dialog

The **KuickShow Configuration** dialog contains 5 tabs. Three of them, **General**, **Modifications** and **Slideshow** configure the operation of KuickShow, and the other two, **Viewer Shortcuts** and **Browser Shortcuts** allow you to personalize the shortcuts for the respective windows.

### 3.1 General Options

The **General** contains the options to configure and tune KuickShow.

**Fullscreen mode**
- If this is selected, images open in full screen mode. If the image is not large enough to fill the screen, the rest of the screen is filled with the background color selected below. The default is off.

**Preload next image**
- If this is selected, KuickShow will load the next image in the folder, while you are looking at the current one. This reduces the delay when you select the next image, and is especially useful for slide shows.

**Remember last folder**
- If this is selected, KuickShow saves the name of the last folder on exit. On next start KuickShow will open this folder in the browser window.

**Background color:**
- Click on the colored bar to select a background color. This is used to fill the screen in fullscreen mode, or the window, if you have resized it larger than the image.

**Show only files with extension:**
- You can configure KuickShow to only show you some of the file types it is capable of.

**Quality/Speed**

**Fast rendering**
- Render things fast.
Dither in HiColor (15/16bit) modes
Dither in LowColor (<=8bit) modes
Use own color palette
Fast palette remapping
Maximum cache size (MB):

3.2 The Modifications Tab

Check Apply default image modifications to open an image with these modifications in KuickShow.

SCALING

Shrink image to screen size, if larger
   If this is selected, large images are displayed in maximized window. The default is on.
Shrink image to screen size, if smaller, up to factor:
   If this is selected, KuickShow increases the magnification of small images up to the selected factor.

GEOMETRY

Flip vertically
   Flips the image vertically.
Flip horizontally
   Flips the image horizontally.
Rotate image
   Rotates the image to 0, 90, 180 or 270 degrees.

ADJUSTMENTS

Brightness:
   Lightens/darkens the image.
Contrast:
   Adds/Removes contrast.
Gamma:
   More/less gamma.

A Preview of the Original and Modified image is displayed below this options.
3.3 The Slideshow Tab

Switch to full-screen
Indicates if KuickShow should switch to full-screen mode when starting the slideshow.

Start with current image
Indicates if the slideshow should start with the first image in the folder or with the image which is selected.

Delay between slides:
The length of time between image changes during the slideshow. You can use the slider, type a new value into the field, or use the small arrows to increase or decrease the value. The default is 3 seconds.

Iterations (0 = infinite):
The amount of iterations. If set to 0 it will loop until you abort the slideshow. You can use the slider, type a new value into the field, or use the small arrows to increase or decrease the value. The default is 1.

3.4 The Shortcuts Tabs

Change the shortcuts for the different modes of KuickShow in the Viewer Shortcuts and the Browser Shortcuts tabs.
For more information read the section about Shortcuts of the KDE Fundamentals.
Chapter 4

Menu Reference

4.1 The File Menu

File → Open (Ctrl+O)
Opens a new image in KuickShow.

File → Show Image
Displays the selected image in a new image window.

File → Show Image in Active Window
Displays the selected image in the active image window.

File → Show Image in Fullscreen Mode
Displays the selected image in fullscreen mode.

File → Start Slideshow (F2)
Starts a slideshow of the images in the folder.

File → Print Image... (Ctrl+P)
Prints the image.

File → Quit (Ctrl+Q)
Quits KuickShow. If you have several images windows open, all of them are closed.

4.2 The Edit Menu

Edit → New Folder... (F10)
Create a new folder.

Edit → Move to Trash (Del)
Moves the current file to the trash. You will be asked to confirm the action.

Edit → Properties (Alt+Return)
Displays the properties of the current image file.
4.3 The View Menu

View → Short View (F6)
If this option is selected, only the names of the files and folders will be shown.
Compare this to detailed view.

View → Detailed View (F7)
If this option is selected, the names, sizes, dates, permissions, file owners and group ownerships are shown.
Compare this to short view.

View → Tree View
View → Detailed Tree View

4.4 The Settings and Help Menu

Settings → Configure KuickShow...
Opens a dialog for changing some options as described in the section chapter 3

KuickShow has the common KDE Help menu items, for more information read the section Help Menu of the KDE Fundamentals.
## 5.1 The Image Window

All the shortcuts are configurable from the Configuration Dialog.

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Down</td>
<td>Load the next image</td>
</tr>
<tr>
<td>Page Up</td>
<td>Load the previous image</td>
</tr>
<tr>
<td>Home</td>
<td>Loads the first image</td>
</tr>
<tr>
<td>End</td>
<td>Loads the last image</td>
</tr>
<tr>
<td>+</td>
<td>Zooms into the image</td>
</tr>
<tr>
<td>-</td>
<td>Zooms out of the image</td>
</tr>
<tr>
<td>*</td>
<td>Flips the image horizontally</td>
</tr>
<tr>
<td>/</td>
<td>Flips the image vertically</td>
</tr>
<tr>
<td>7</td>
<td>Rotates 270 clockwise (which is also 90 counter-clockwise)</td>
</tr>
<tr>
<td>8</td>
<td>Rotates 90 clockwise</td>
</tr>
<tr>
<td>9</td>
<td>Rotates 180 clockwise</td>
</tr>
<tr>
<td>Arrow keys</td>
<td>Move the image (or rather, you, the viewer,) if it is larger than the screen</td>
</tr>
<tr>
<td>Return</td>
<td>Toggles between fullscreen and window mode</td>
</tr>
<tr>
<td>Space</td>
<td>Toggles the display of the browser</td>
</tr>
<tr>
<td>Esc</td>
<td>Closes the image window. This will close KuickShow entirely, if you don't have a browser window open.</td>
</tr>
<tr>
<td>B/Shift+B</td>
<td>Lightens/darkens the image</td>
</tr>
<tr>
<td>C/Shift+C</td>
<td>Adds/Removes contrast</td>
</tr>
<tr>
<td>G/Shift+G</td>
<td>More/less gamma</td>
</tr>
<tr>
<td>O</td>
<td>Shows the image in original size. This is only useful when you have enabled automatic scaling.</td>
</tr>
<tr>
<td>Enter</td>
<td>Redisplays the image with the default settings and size.</td>
</tr>
<tr>
<td>Ctrl+S</td>
<td>Opens the Save As dialog</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the current image. You will be asked to confirm the request.</td>
</tr>
</tbody>
</table>
The KuickShow Handbook

### Table 5.1: Image Window Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Action</th>
<th>Keybinding</th>
</tr>
</thead>
<tbody>
<tr>
<td>Deletes the current image without asking for confirmation</td>
<td>Shift+Delete</td>
</tr>
<tr>
<td>Displays the properties of the image</td>
<td>Alt+Return</td>
</tr>
<tr>
<td>Opens the online help (this file)</td>
<td>F1</td>
</tr>
<tr>
<td>Quits KuickShow</td>
<td>Ctrl+W</td>
</tr>
</tbody>
</table>

### Table 5.2: Image Window Mouse Usage

<table>
<thead>
<tr>
<th>Action</th>
<th>Mouse button</th>
</tr>
</thead>
<tbody>
<tr>
<td>Opens the context menu, with several options</td>
<td>Right click</td>
</tr>
<tr>
<td>Moves the image, if it doesn’t fit in the window.</td>
<td>Left drag</td>
</tr>
<tr>
<td>Marks a rectangle you can zoom into.</td>
<td>Shift+Left drag</td>
</tr>
<tr>
<td>Closes the current image</td>
<td>Left double click</td>
</tr>
</tbody>
</table>

### Table 5.3: Browser Window Keybindings

<table>
<thead>
<tr>
<th>Action</th>
<th>Keybinding</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enters a folder, or opens an image window, depending on the item</td>
<td>Return</td>
</tr>
<tr>
<td>selected.</td>
<td>Page Down</td>
</tr>
<tr>
<td>Advances one page in the list of files</td>
<td>Page Up</td>
</tr>
<tr>
<td>Moves back up a page in the list of files</td>
<td>Home</td>
</tr>
<tr>
<td>Selects the first file or folder</td>
<td>End</td>
</tr>
<tr>
<td>Selects the last file or folder</td>
<td>Space</td>
</tr>
<tr>
<td>Toggles showing the browser, if an image window is open</td>
<td>any alpha-numeric character</td>
</tr>
<tr>
<td>Opens the edit field used for ‘completion’. Enter the first characters of a filename to search for, and if found, the file will be selected.</td>
<td>Delete</td>
</tr>
<tr>
<td>Deletes the current file. You will be asked to confirm the action.</td>
<td>Shift+Delete</td>
</tr>
<tr>
<td>Deletes the current file without asking for confirmation.</td>
<td>F1</td>
</tr>
<tr>
<td>Quits KuickShow</td>
<td>Ctrl+Q</td>
</tr>
</tbody>
</table>

### Table 5.2: Image Window Mouse Usage

<table>
<thead>
<tr>
<th>Action</th>
<th>Mouse button</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter a folder, or select an image window.</td>
<td>Left click</td>
</tr>
<tr>
<td>Opens a context menu, with several options.</td>
<td>Right click</td>
</tr>
</tbody>
</table>

5.2 The Browser Window

<table>
<thead>
<tr>
<th>Action</th>
<th>Keybinding</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enters a folder, or opens an image window, depending on the item</td>
<td>Return</td>
</tr>
<tr>
<td>selected.</td>
<td>Page Down</td>
</tr>
<tr>
<td>Advances one page in the list of files</td>
<td>Page Up</td>
</tr>
<tr>
<td>Moves back up a page in the list of files</td>
<td>Home</td>
</tr>
<tr>
<td>Selects the first file or folder</td>
<td>End</td>
</tr>
<tr>
<td>Selects the last file or folder</td>
<td>Space</td>
</tr>
<tr>
<td>Toggles showing the browser, if an image window is open</td>
<td>any alpha-numeric character</td>
</tr>
<tr>
<td>Opens the edit field used for ‘completion’. Enter the first characters of a filename to search for, and if found, the file will be selected.</td>
<td>Delete</td>
</tr>
<tr>
<td>Deletes the current file. You will be asked to confirm the action.</td>
<td>Shift+Delete</td>
</tr>
<tr>
<td>Deletes the current file without asking for confirmation.</td>
<td>F1</td>
</tr>
<tr>
<td>Quits KuickShow</td>
<td>Ctrl+Q</td>
</tr>
<tr>
<td>Double click</td>
<td>Loads the selected image or enters the selected folder</td>
</tr>
<tr>
<td>--------------</td>
<td>-------------------------------------------------------</td>
</tr>
</tbody>
</table>

Table 5.4: Browser Window Mouse Usage
Chapter 6

Credits and License

KuickShow
Program copyright 1998-2009 Carsten Pfeiffer pfeiffer@kde.org
Documentation copyright 2001 Carsten Pfeiffer pfeiffer@kde.org
Converted to DocBook XML and extended by Lauri Watts lauri@kde.org
This documentation is licensed under the terms of the GNU Free Documentation License.
This program is licensed under the terms of the GNU General Public License.