The Kompare Handbook

Sean Wheller
Contents

1 Introduction ................................................. 6

2 Using Kompare ............................................. 8
  2.1 Getting Started .......................................... 8
    2.1.1 Starting Kompare ................................... 8
    2.1.2 The Main Interface ................................ 8
      2.1.2.1 Menus ........................................ 9
      2.1.2.2 Toolbar ...................................... 9
      2.1.2.3 Source and Destination Folders ............... 9
      2.1.2.4 Source and Destination Files ................ 9
      2.1.2.5 Source and Destination Line Changes ......... 9
      2.1.2.6 Source and Destination View ................. 9
      2.1.2.7 Text View ................................... 9
      2.1.2.8 Statusbar ................................... 9
    2.1.3 Viewing Differences ............................... 10
      2.1.3.1 Managing Screen Real-Estate ................. 10
      2.1.3.2 Switching Source and Destination Views .... 10
      2.1.3.3 Displaying Difference Statistics ............ 10
      2.1.3.4 Navigating the Difference View .............. 11
        2.1.3.4.1 Selecting a Difference .................. 11
        2.1.3.4.2 Traversing Differences .................. 11
        2.1.3.4.3 Switching Between Files ................. 12
    2.1.4 Merging Differences ............................... 12
      2.1.4.1 Applying a Difference ....................... 12
      2.1.4.2 Unapplying a Difference ..................... 12
      2.1.4.3 Applying All Differences .................... 12
      2.1.4.4 Unapplying All Differences ................. 12
      2.1.4.5 Saving Changes ............................. 12
    2.1.5 Working with Diff Files ......................... 13
      2.1.5.1 Creating a Diff ............................ 13
      2.1.5.2 Displaying a Diff .......................... 13
      2.1.5.3 Applying Differences in a Diff File ........ 13
      2.1.5.4 Blending a URL with a Diff ................ 13

2.2 Viewing Differences ................................... 10
  2.2.1 Managing Screen Real-Estate ....................... 10
  2.2.2 Switching Source and Destination Views .......... 10
  2.2.3 Displaying Difference Statistics ................. 10
  2.2.4 Navigating the Difference View ................... 11
    2.2.4.1 Selecting a Difference ....................... 11
    2.2.4.2 Traversing Differences ....................... 11
    2.2.4.3 Switching Between Files ..................... 12
  2.2.5 Merging Differences ............................... 12
    2.2.5.1 Applying a Difference ....................... 12
    2.2.5.2 Unapplying a Difference ..................... 12
    2.2.5.3 Applying All Differences .................... 12
    2.2.5.4 Unapplying All Differences ................. 12
    2.2.5.5 Saving Changes ............................. 12
  2.2.6 Working with Diff Files ........................... 13
    2.2.6.1 Creating a Diff ............................ 13
    2.2.6.2 Displaying a Diff .......................... 13
    2.2.6.3 Applying Differences in a Diff File ........ 13
    2.2.6.4 Blending a URL with a Diff ................ 13

2.3 Merging Differences ................................... 12
  2.3.1 Applying a Difference ............................ 12
  2.3.2 Unapplying a Difference .......................... 12
  2.3.3 Applying All Differences ........................ 12
  2.3.4 Unapplying All Differences ....................... 12
  2.3.5 Saving Changes ................................. 12

2.4 Working with Diff Files .............................. 13
  2.4.1 Creating a Diff ................................. 13
  2.4.2 Displaying a Diff ............................... 13
  2.4.3 Applying Differences in a Diff File ............. 13
  2.4.4 Blending a URL with a Diff ..................... 13
# The Kompare Handbook

## 3 Configuring Preferences

3.1 View Settings .................................................. 14  
   3.1.1 Appearance .................................................. 14  
   3.1.2 Fonts .......................................................... 16  
3.2 Diff Settings ..................................................... 16  
   3.2.1 Diff ............................................................. 17  
   3.2.2 Format .......................................................... 17  
   3.2.3 Options ........................................................ 18  
   3.2.4 Exclude ......................................................... 19

## 4 Command Reference

4.1 Menu Items ...................................................... 21  
   4.1.1 The File Menu ............................................... 21  
   4.1.2 The Difference Menu ........................................ 22  
   4.1.3 The Settings and Help Menu ................................. 22  
4.2 Commandline Options .......................................... 22

## 5 Credits and License
Abstract

Kompare is a GUI front-end program that enables differences between source files to be viewed and merged. Kompare can be used to compare differences on files or the contents of folders. Kompare supports a variety of diff formats and provide many options to customize the information level displayed.
Chapter 1

Introduction

When two or more people are working on a file and passing it back and forth between one another, it becomes difficult to see what changes have been made to a new version or copy of the file. Opening the new copy and the original, side-by-side in the application used to create it is one solution but, laborious, time consuming, and prone to error. This is where a program to show differences, diffs for short, is useful.

As would be expected, an appropriate name for such a program would be ‘diff’. As it happens, the program diff is installed on most Linux®-based systems and is used for exactly this purpose. Developers often use diff, as a command line tool, to show differences between versions of a source code file. However, the use of diff is not limited to showing differences in code source files, it can be used on many text-based file types.

Using diff from the command line can be confusing, learning the diff command syntax and deciphering the output can bewilder most people. This is where Kompare comes into play. Providing a graphical front-end to the diff program, the interface displays source and destination files side-by-side with all differences automatically highlighted. From this starting point, changes in one file can be sequentially applied to the other file on a selective and controlled basis. Not all changes need to be applied and if you do apply a change it can always be ‘unapplied’. When all required changes have been applied they can be saved and will display as normal in the original application used to create the file.

In addition to displaying differences between a source and destination file, Kompare can be used to create and view a special file called a ‘diff’. This file captures the differences between the two sources into a single file that can be used to view and apply changes to any other copy of the file. For example, if two people are editing a document. The first person wants to make changes and send just the changes made to the second person. Normally, the first person would send a complete copy of the modified document to the second person, who would then have to compare the modified document side-by-side with unmodified version. The process for this is much like what we have described in the previous paragraphs. With Kompare the first person would first make a local copy of the file to be modified, then make changes and compare the original and modified copy. Now using Kompare a diff file can be created that captures only the changes made. This can be sent to the second person in place of a whole file containing the changes.

Using Kompare the second person can view the diff file, compare it to the local copy of the document and apply the changes made by the first person. So the process can go on for many versions of the document, each person making changes, creating diffs, distributing them and applying them. This process is commonly called ‘patching’, a term taken from the program named ‘patch’ which is another command line tool specifically designed for the purpose of applying diff files.

It sometimes happens that people edit a file at the same time. In this situation it is likely that people will make changes in the document at exactly the same line. This creates a problem because, without applied caution, people could be overwriting each others work as they apply the diff files they receive. Fortunately the developers of the diff and patch programs took this
into consideration and so these tools will not allow such changes to be applied without manual intervention. When this state is reached, it is known as a ‘conflict’. Kompare will display conflicts so that you can manually resolve them, deciding which changes should be applied to which file.

Kompare is also a great program for comparison of file changes on a folder level. When used to compare folders Kompare recursively examines subfolders and their file contents for differences. In this use case, each file where differences are found are automatically opened and listed by Kompare where easy navigation between the various files is possible.
Chapter 2

Using Kompare

2.1 Getting Started

This section provides instructions for starting Kompare and provides a quick tour to the Kompare main interface.

2.1.1 Starting Kompare

A shortcut for starting Kompare can be found in the application menu in the Development group Development → Kompare.

When Kompare starts the first thing it does is display a dialog from which to select the files you wish to compare. Special settings for the properties of the diff and the appearance thereof can also be selected. In the file form select a source and destination source to compare. This can be any two files, folders or a URL and a file. Once the source and destination are selected click the Compare button.

Once Kompare has discovered the differences it will display the main interface. When comparing two files or a URL and a file the process takes just a few seconds. However, when comparing folders with many subfolders and files, this process can take awhile.

For explanation of the options available from diff and appearance forms see chapter 3.

2.1.2 The Main Interface

This section provides a quick tour of the main interface which is comprised of the following areas:

- Menus
- Toolbar
- Source and Destination Folders
- Source and Destination Files
- Source and Destination Line Changes
- Source and Destination Text View
- Statusbar
2.1.2.1 Menus

Kompare provides a menu driven interface. Explanation to the menu items and their options is provided in chapter 4.

2.1.2.2 Toolbar

The Kompare toolbar provides shortcuts to the most frequently used diff and merge operations. The toolbar orientation, text positioning, icon size properties and which shortcut icons are displayed can be customized from the toolbar context menu accessed when right-clicking the toolbar with the mouse. The toolbar context menu also enables the toolbar to be hidden. If the toolbar is hidden and you wish to unhide it, select Settings \rightarrow Show Toolbar.

2.1.2.3 Source and Destination Folders

The source folder and destination folder panes display the folders in which compared files reside. When many subfolders are included in the comparison, then selecting a folder will display the first document in that folder where a difference was found between the source and destination.

2.1.2.4 Source and Destination Files

The source and destination file pane displays files where a difference was found for the currently selected source or destination folder. When a folder has multiple documents containing differences, all documents with a difference are listed. The selected document is displayed.

2.1.2.5 Source and Destination Line Changes

The source and destination line changes pane summarizes the differences found between the current source and destination documents. Selecting a record within the pane highlights and selects the difference. This is a useful way to navigate and inspect long documents with many differences.

2.1.2.6 Source and Destination View

The source and destination view is the main workspace of Kompare. The contents and highlighted differences of the currently selected source and destination file are displayed here with line numbers.

2.1.2.7 Text View

The Text View is not displayed by default. It can be opened by selecting Settings \rightarrow Show Text View.

2.1.2.8 Statusbar

The status bar provides a summary of the current source and destination file or folder under comparison. The status bar also reports the number of changes found in the current document and counts the differences that have been applied. Furthermore, the status bar shows the overall number of documents containing differences and the current document number selected from this set. For example, a comparison run over two folders may return 1890 files with differences. The currently selected document is number 18 of 1890.
2.2 Viewing Differences

2.2.1 Managing Screen Real-Estate

Kompare displays the source and destination file under using equal percentage of the main interface view work area. This view area provides some features that help optimize use of screen real-estate while viewing differences, including:

Dual Scrollbars
The most obvious feature is that scrollbars are provided both on the right and bottom edges of the view area. Using the scrollbars it is possible to move rapidly through the comparison.

Share Grip Handle
The vertical space between the source and destination view not only makes it possible to clearly see the start and end of lines in each of the panes, but is also a grip handle that allows adjustment of percentage occupied between the source and destination views that comprise the view pane. To change pane size for one of the views, hover the mouse pointer over the grip handle then hold down the mouse button and drag left or right. Naturally, increasing the area of one pane will decrease the area available to the opposite pane within the view panel area.

A second horizontal handle is available between the navigation panel and the source and destination view.

Docking
The navigation panel can be undocked from the main interface by clicking the icon located top right of the panel. This opens it in a window of its own, allowing you to move it across the screen. You can even hide the navigation panel by clicking the icon. To display a hidden navigation bar again, click with the right mouse button into the menubar and select Navigation from the context menu.

Statusbar Toggle
The status bar of the view panel can be toggled on and off by selecting Settings → Show Statusbar.

2.2.2 Switching Source and Destination Views

Sometimes it can be useful to consider what the file to which differences where to be applied as the source. For example, when comparing two modified versions of a file and discovering that the one file has many more modifications that the other. The file with more changed would be better as the source, since then fewer differences would need to be applied.

In this case select File → Swap Source with Destination. This will switch the files displayed in all Kompare panels.

2.2.3 Displaying Difference Statistics

For a quick overview of the differences, select File → Show Statistics. This will display the Diff Statistics dialog. The following information is provided:

Old file:
The file name of what is usually the source file or file that is unmodified.
New file:
The file name of what is usually the destination file or file that is modified and to which differences will be applied.

Format:
The diff format used to display the difference (see Section 3.2.2).

Number of hunks:
The number of hunks found in the difference.
A hunk is a ‘chunk’ of lines that have been marked as different between source and destination and may include context lines depending on the diff format Lines of Context value (see Section 3.2.2).

Number of differences
The actual number of differences found, not hunks. A hunk can contain one or more differences when the line change range and the context lines of any two or more changes overlap.

2.2.4 Navigating the Difference View
Kompare enables rapid navigation of differences on a file level and of multiple difference files when comparing folder trees.

2.2.4.1 Selecting a Difference
A difference can be selected using by:

- clicking a line in the Source and Destination Line Changes pane (top right of the main window).
- clicking the highlighted difference in the View pane.
- traversing the listed differences in a comparison (see Section 2.2.4.2).

When a difference is selected it is considered to be ‘in focus’ and is displayed in a brighter color that non-selected differences.

2.2.4.2 Traversing Differences
When a comparison finds many differences one of the best ways to approach reviewing them is to traverse the differences in a logical order, usually from top to bottom.

By default Kompare selects the first difference found in a comparison. By selecting Difference → Next Difference (Ctrl+Down) the difference following the current selection is brought into focus. To select the difference before the current difference select Difference → Previous Difference (Ctrl+Up).

In this way it is possible to traverse differences in an orderly manner, applying and unapply differences upon review.
2.2.4.3 Switching Between Files

When a comparison is performed on folder level, many files may be found with differences. A complete list of the files compared with difference found is provided in the ‘Source and Destination Folders’, and ‘Source and Destination Files’ panes. However, Kompare displays differences between source and destination one comparison at time.

To switch between documents in this scenario the following options are available:

- Select the ‘Source and Destination Folders’ pane to display file differences found in the ‘Source and Destination Files’ pane, then select a file.
- Select Difference → Previous File (Ctrl+PgUp) or Difference → Next File (Ctrl+PgDown) to display the previous or next difference file found in the ‘Source and Destination Files’ pane.

2.3 Merging Differences

Kompare makes the task of applying and unapplying differences as simple as point and click. Multiple apply and unapply operations can be performed on a difference as all operations are performed in memory and not written to the files on disk until the save operation is performed.

2.3.1 Applying a Difference

To apply a difference, click the highlighted difference region, then select Difference → Apply Difference (Space).

2.3.2 Unapplying a Difference

To unapply a difference, click the highlighted difference region previously applied, then select Difference → Unapply Difference (Backspace).

2.3.3 Applying All Differences

After reviewing differences between files and finding all acceptable it is possible apply them all with a single operation by selecting Difference → Apply All (Ctrl+A).

2.3.4 Unapplying All Differences

To revert all differences that have been applied previously select Difference → Unapply All (Ctrl+U).

2.3.5 Saving Changes

Once differences have been applied they can be saved by selecting File → Save or File → Save All.

Applied differences are saved to both the source and destination file.
2.4 Working with Diff Files

Diff files contain only the changes made between files, or a set of files within a folder system, and may or may not contain a number of context lines before and after line changes. The sum of a line change and its context lines is known a hunk. A diff file therefore may contain multiple hunks from one or more files. When the context lines of two or more hunks overlap, they are considered a single hunk. Diff files can be used to:

- Apply the changes contained in the hunks to an original file.
- Apply the changes contained in the hunks to a file or set of original files within a folder system.
- Modified before being applied to an original file or set of original files within a folder system.

2.4.1 Creating a Diff

To create a diff file a comparison must be displayed in Kompare. Assuming this is the case, then select File → Save Diff... This will display the Diff Options dialog (see Section 3.2 for more information on diff formats and options). After configuring these options, click the Save button and save the diff to a file with the extension .diff.

2.4.2 Displaying a Diff

It is possible to display the contents of a diff file within Kompare by opening the diff file from File → Open Diff....

When viewing a diff file the hunks between the source and destination file are shown, remember that only the hunks are shown, no unmodified lines will be shown. In some cases a diff file is created with 0 lines of context. In this case only the changed lines will be displayed.

When a diff file contains hunks from multiple files Kompare displays the hunks from each file one at a time and you can switch between files as though they were real files even though this information is only provided by the diff file contents.

2.4.3 Applying Differences in a Diff File

When viewing differences in a diff file it is possible to apply difference as you would when comparing source and destination files (see Section 2.3).

2.4.4 Blending a URL with a Diff

In cases where a diff file is provided it is possible to compare the hunks in the diff against a file or folder. To do this select File → Blend URL with Diff.... Then input the File/Folder and Diff Output paths.

When viewing differences between a source file and a diff file it is possible to apply difference as you would when comparing source and destination files (see Section 2.3).
Chapter 3

Configuring Preferences

Kompare enables users to set appearance preferences for difference formatting in the main interface and set behavioral properties of the diff program. The Preferences dialog can be accessed by selecting Settings → Configure Kompare....

To configure preferences for appearance select the View menu item (see Section 3.1).
To configure preferences for diff program properties select the Diff menu item (see Section 3.2).

3.1 View Settings

The View page in the Preferences dialog displays the Appearance and Fonts tabbed forms.

3.1.1 Appearance

The Appearance form provides controls to manage the Colors used to denote difference in the main interface, behavior of the Mouse Wheel when jogging up and down and how Tabs to Spaces conversion is managed.
The Kompare Handbook

COLOR GROUP

Removed color
Lines that have been removed, do not exist, between source and destination.

Changed color
Lines that have been changed, modified, between source and destination.

Added color
Lines that have been added between source and destination.

Applied color
Any of the above states where the difference has been applied between source and destination.

MOUSE WHEEL

Number of lines
The number of lines to jog the differences when turning the mouse wheel forward or backward.

TABLES TO SPACES

Number of spaces to convert a tab character to
Convert each tab character to n space characters.
3.1.2 Fonts

Select the font family and size to display when displaying differences.

3.2 Diff Settings

The Diff page in the Preferences dialog displays the Diff, Format, Options and Exclude tabbed forms. These forms can be used to configure the behavioral properties of the Diff program.
3.2.1 Diff

The command used to run the diff program (default diff).

3.2.2 Format

Adjust options for the **Output Format** and number of **Lines of Context**.

**OUTPUT FORMAT**
The Kompare Handbook

Context
The context output format adds several lines of context around the lines that differ.

Normal
The normal output format displays differing lines without any surrounding lines of context.

Unified
The unified output format is a variation on the context format. It is considered better than context because the output is more compact than that of context as it omits redundant context lines.

Lines of Context

Number of context lines
When performing a diff with context or unified output format use this parameter to control the number of context lines included.

3.2.3 Options

The Options tab form allows configuration of the options supported by the diff program.

General

Treat new files as empty
With this option enabled diff will treat a file that only exists in one of the directories as empty in the other directory. This means that the file is compared with an empty file and because of this will appear as one big insertion or deletion.

Look for smaller changes
Forces diff to display changes in case, punctuation, space, etc. when checked.
Optimize for large files
Switches diff to process files with high-speed when checked.

Ignore changes in case
Lower and Uppercase character changes are omitted when this option is checked.

Ignore regexp
Ignore lines matching a regular expression.

Whitespace

Expand tabs to spaces in output
When checked diff outputs will converts tab characters to the number of spaces defined in the Preferences dialog View menu Tabs to Spaces option.

Ignore added or removed empty lines
lines of zero length that differ between source and destination are ignored when this option is checked.

Ignore changes in the amount of whitespace
White space before, after and between lines may change depending on different editors. When this option is checked such changes are ignored.

Ignore all whitespace
when checked white space differences are completely ignored.

Ignore changes due to tab expansion
when checked white space resulting from tab characters is ignored.

3.2.4 Exclude

The Exclude form enables use of the filter options provided by the diff program.
**FILE PATTERN TO EXCLUDE**

**File Pattern to Exclude**
Exclude files based on wild card filtering

**FILE WITH FILENAMES TO EXCLUDE**

**File with Filenames to Exclude**
Define the filter based on the content of an externally managed file.
Chapter 4

Command Reference

4.1 Menu Items

4.1.1 The File Menu

File → Open Diff... (Ctrl+O)
Displays the Open dialog.

File → Compare Files... (Ctrl+C)
Displays the Compare Files or Folders dialog.

File → Blend URL with Diff... (Ctrl+B)
Displays the Blend File/Folder with diff Output dialog.

File → Save (Ctrl+S)
Writes applied differences to current source and or destination file.

File → Save All
Writes applied differences to all source and or destination files.

File → Save Diff...
Displays the Diff Options dialog to define diff format and options.

File → Refresh Diff (F5)
Updates the difference of the original paths. Useful if you have applied some changes, saved them and want to see what is left.

File → Swap Source with Destination
Changes source and destination.

File → Show Statistics
Displays the Display Statistics dialog.

File → Quit (Ctrl+Q)
Exits Kompare.
4.1.2 The Difference Menu

**Difference → Unapply All (Ctrl+U)**
Unapply all differences previously applied between source and destination.

**Difference → Unapply Difference (Backspace)**
Revert a selected difference previously applied.

**Difference → Apply Difference (Space)**
Apply a selected difference.

**Difference → Apply All (Ctrl+A)**
Apply all differences between source and destination.

**Difference → Previous File (Ctrl+PgUp)**
Make the previous difference, in the list of differences, the current file in the view pane.

**Difference → Next File (Ctrl+PgDown)**
Make the next difference, in the list of differences, the current file in the view pane.

**Difference → Previous Difference (Ctrl+Up)**
Select the difference above the currently selected difference.

**Difference → Next Difference (Ctrl+Down)**
Select the difference below the currently selected difference.

4.1.3 The Settings and Help Menu

Kompare has the common KDE **Settings** and **Help** menu items, for more information read the sections about the **Settings Menu** and **Help Menu** of the KDE Fundamentals.

4.2 Commandline Options

**-c**
This will compare URL1 with URL2.

**kompare -o**
This will open URL1 and expect it to be diff output. URL1 can also be a `-' and then it will read from standard input. Can be used for instance for `cvs diff | kompare -o -`. Kompare will do a check to see if it can find the original file(s) and then blend the original file(s) into the diffoutput and show that in the viewer. `--` disables the check.

**kompare -b**
This will blend URL2 into URL1, URL2 is expected to be diff output and URL1 the file or folder that the diffoutput needs to be blended into.

**kompare -n**
Disables the check for automatically finding the original file(s) when using `-' as URL with the `-o` option.

**kompare -e encoding**
Use this to specify the encoding when calling it from the command line. It will default to the local encoding if not specified.
Chapter 5

Credits and License

Kompare
Program copyright 2001-2004, John Firebaugh jfirebaugh@kde.org and Otto Bruggeman otto.bruggeman@home.nl
Documentation Copyright (c) 2007 Sean Wheller sean@inwords.co.za
This documentation is licensed under the terms of the GNU Free Documentation License.
This program is licensed under the terms of the GNU General Public License.