KDE Fundamentals
# Contents

1 Introduction .......................................................... 7

2 Installing KDE Plasma Desktop and KDE Applications ............... 8
   2.1 Installing Packages .................................................. 8
       2.1.1 Linux® ............................................................ 8
       2.1.2 Microsoft® Windows® ........................................ 8
       2.1.3 Mac®OS ........................................................ 9
       2.1.4 BSD™ .......................................................... 9
       2.1.5 Mobile Devices ................................................ 9
       2.1.6 Live Media ..................................................... 9
       2.1.7 Building from Source Code .................................. 9

3 Finding Your Way Around ............................................. 10
   3.1 A Visual Dictionary .................................................. 10
       3.1.1 The Big Picture ............................................... 10
           3.1.1.1 Windows ............................................... 10
           3.1.1.2 Elements of Graphical User Interface (GUI) .......... 12
       3.1.2 The Widgets ................................................... 14
   3.2 Common Menus ...................................................... 19
       3.2.1 The File Menu ............................................... 20
       3.2.2 The Edit Menu ............................................... 20
       3.2.3 The View Menu ............................................... 21
       3.2.4 The Tools Menu .............................................. 21
       3.2.5 The Settings Menu ........................................... 22
       3.2.6 The Help Menu ............................................... 22
       3.2.7 Thanks and Acknowledgments ................................ 23
   3.3 Common Keyboard Shortcuts ....................................... 23
       3.3.1 Working with Windows ....................................... 23
           3.3.1.1 Starting and Stopping Applications .................. 23
           3.3.1.2 Moving Around ......................................... 24
           3.3.1.3 Panning and Zooming .................................. 24
       3.3.2 Working with Activities and Virtual Desktops ............. 25
KDE Fundamentals

3.3.3 Working with the Desktop ........................................................................... 25
3.3.4 Getting Help .................................................................................................. 25
3.3.5 Working with Documents .............................................................................. 25
3.3.6 Working with Files .......................................................................................... 26
3.3.7 Changing Volume and Brightness ................................................................. 26
3.3.8 Leaving Your Computer ............................................................................... 26
3.3.9 Modifying Shortcuts ....................................................................................... 27

4 Common Tasks .................................................................................................... 28
4.1 Navigating Documents ...................................................................................... 28
  4.1.1 Scrolling ......................................................................................................... 28
  4.1.2 Zooming ......................................................................................................... 29
4.2 Opening and Saving Files .................................................................................... 29
  4.2.1 Introduction ..................................................................................................... 29
  4.2.2 The File Selection Window ........................................................................... 29
  4.2.3 Thanks and Acknowledgments ...................................................................... 33
4.3 Check Spelling .................................................................................................... 34
  4.3.1 Check Spelling ................................................................................................ 34
  4.3.2 Automatic Spell Checking ............................................................................ 34
  4.3.3 Configuring Sonnet ....................................................................................... 35
  4.3.4 Thanks and Acknowledgments ...................................................................... 35
4.4 Find and Replace ................................................................................................ 35
  4.4.1 The Find Function ....................................................................................... 35
  4.4.2 The Replace Function ................................................................................... 37
  4.4.3 Thanks and Acknowledgments ...................................................................... 38
4.5 Choosing Fonts ................................................................................................... 38
4.6 Choosing Colors ................................................................................................ 39
  4.6.1 Using Basic Colors ....................................................................................... 39
  4.6.2 Mixing Colors ................................................................................................ 40
    4.6.2.1 Using the Grid .......................................................................................... 40
    4.6.2.2 Using the Screen Colors .......................................................................... 40
    4.6.2.3 Hue/Saturation/Value .............................................................................. 40
    4.6.2.4 Red/Green/Blue ...................................................................................... 40
    4.6.2.5 HTML Hexadecimal Code ..................................................................... 40
  4.6.3 Custom Colors ............................................................................................... 40
5 Customizing KDE software

5.1 Customizing Toolbars

5.1.1 Modifying Toolbar Items

5.1.1.1 Adding an Item

5.1.1.2 Removing an Item

5.1.1.3 Changing the Position of Items

5.1.1.4 Adding a Separator

5.1.1.5 Restoring Defaults

5.1.1.6 Changing Text and Icons

5.1.2 Customizing Toolbar Appearance

5.1.2.1 Text Position

5.1.2.2 Icon Size

5.1.2.3 Moving Toolbars

5.1.2.4 Show/Hide Toolbars

5.1.3 Thanks and Acknowledgments

5.2 Using and Customizing Shortcuts

5.2.1 Introduction

5.2.2 Changing a Shortcut

5.2.3 Resetting Shortcuts

5.2.4 Removing a Shortcut

5.2.5 Working with Schemes

5.2.6 Printing Shortcuts

5.2.7 Thanks and Acknowledgments

6 Credits and License
Abstract

This guide provides an introduction to the Plasma workspace and applications and describes many common tasks that can be performed.
Chapter 1

Introduction

Welcome to KDE!
This guide will introduce you to the many features of the Plasma workspace and applications and describe many common tasks you can perform.
For more information on KDE, visit the KDE website.
Chapter 2

Installing KDE Plasma Desktop and KDE Applications

You can install KDE applications, including KDE Plasma Desktop, on a variety of different platforms, ranging from smartphones and tablets to computers running Microsoft® Windows®, Mac®, OS, UNIX®, BSD™ or Linux®. Binary packages are available for many different platforms and distributions, or advanced users may build the source code.

2.1 Installing Packages

Hundreds of developers worldwide have done a lot of work to make it easy to install KDE onto a variety of different devices and platforms.

2.1.1 Linux®

Nearly every Linux® distribution provides binary packages for individual applications and the KDE Plasma Desktop as a whole.

To install an individual application, look for its name in your distribution’s package collection. To install one of the KDE Plasma Workspaces, like KDE Plasma Desktop, look for a metapackage or package group, typically plasma-desktop.

NOTE

Some applications may be installed together with other applications in a combined package named after the KDE package they are provided in. For instance, Konqueror might be found in the kde-base apps package.

If you have trouble locating KDE packages for your distribution, please contact their support resources. Many distributions also have a team dedicated to packaging applications by KDE that can provide assistance specific to them.

2.1.2 Microsoft® Windows®

The KDE on Windows Initiative provides binary packages of KDE applications for Microsoft® Windows®. They also provide a special installer application that permits you to install individual applications or groups and all necessary dependencies easily.
For more information on the initiative and to download the installer, visit the KDE on Windows Initiative.

2.1.3 Mac® OS

Individual KDE applications can be installed through several different ‘ports’ systems available for Mac® OS. Several different KDE applications also provide their own binary builds for Mac® OS.
For more information, visit KDE on Mac OSX.

2.1.4 BSD™

Most BSD™ distributions allows you to install KDE applications and the KDE Plasma Desktop through their ‘ports’ system.
For more information on installing ports, see your BSD™ distribution’s documentation.

2.1.5 Mobile Devices

Plasma Mobile is an exciting initiative to bring a new KDE experience to mobile devices like smartphones or tablets. Binary releases are provided for several different devices.
For more information, visit Plasma Mobile.

2.1.6 Live Media

Several Linux® and BSD™ distributions offer live media. This permits you to try out the KDE Plasma Desktop without installing anything to your system. All you have to do insert a CD or connect a USB drive and boot from it. If you like what you see, most offer an option to install it to your hard drive.

There is a list of distributions that offer the KDE workspace and applications on live media on the KDE website.

2.1.7 Building from Source Code

For detailed information on how to compile and install KDE Plasma Desktop and applications see Build from source.
Since KDE software uses cmake you should have no trouble compiling it. Should you run into problems please report them to the KDE mailing lists.
The recommended tool to build Frameworks, KDE Plasma Desktop and all the other applications is kdesrc-build
Chapter 3

Finding Your Way Around

3.1 A Visual Dictionary

The KDE Plasma Workspaces feature many different graphical user interface elements, commonly known as ‘widgets’. This guide will introduce you to their names and functions.

3.1.1 The Big Picture

3.1.1.1 Windows

This is the window of the KWrite, a text editor. Click on part of the window to learn more about it.

1. The **Window Menu**
2. The **Titlebar**
KDE Fundamentals

3. Buttons to *minimize, maximize, or close* the window
4. The **Menubar**
5. The **Toolbar**
6. A very large **Text Area** that acts as this program’s **Central Widget**
7. A vertical **Scrollbar** (there is also a horizontal scrollbar below the text box)
8. The **Statusbar**

This is the another window, that of the Dolphin file manager. Click on part of the window to learn more about it.

1. A **panel** that contains a list of Places on the computer system
2. A **Breadcrumb** of the path of the displayed folder
3. A folder **Icon**
4. A file **Icon**
5. A highlighted **Icon**
6. A **Context Menu** listing actions that can be performed on a file
7. A **Slider** that changes the size of the **Icons** displayed
8. More **Panels**
3.1.2  Elements of Graphical User Interface (GUI)

This screenshot, from the System Settings Formats panel, shows some GUI elements. Click on part of the window to learn more about it.

1. An **Icon List** (the second item is selected)
2. An open **Drop Down Box**
3. An item in the **Drop Down Box** that has been selected
4. Some more **Buttons**
This screenshot, from the System Settings Custom Shortcuts panel, shows some more GUI elements.

1. A **Tree View**
2. A **Check Box** that has been selected
3. A pair of **Spin Boxes**
4. A **Menu Button**

This screenshot, from the System Settings Default Applications panel, shows even more GUI elements. Click on part of the window to learn more about it.

1. A **List Box**
2. A pair of **Radio Buttons**
3. A **Text Box**
Finally, this screenshot, from the System Settings Colors panel, shows five Tabs

### 3.1.2 The Widgets

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Screenshot</th>
</tr>
</thead>
<tbody>
<tr>
<td>Central Widget</td>
<td>The main area of the running application. This might be the document you are editing in a word processor or the board of a game like Chess.</td>
<td>The KDE Community is an international technology team dedicated to creating a free and user-friendly computing experience, offering an advanced graphical desktop, a wide variety of applications for communication, work, education and entertainment and a platform to easily build new applications upon. We have a strong focus on finding innovative solutions to old and new problems, creating a vibrant atmosphere open for experimentation.</td>
</tr>
<tr>
<td>Button</td>
<td>These can be clicked with the left mouse button to perform an action.</td>
<td><img src="image" alt="OK" /></td>
</tr>
<tr>
<td>Breadcrumb</td>
<td>Shows the path in a hierarchical system, such as a filesystem. Click on any part of the path to go up in the tree to that location. Click on the arrow to the right of part of the path to go to another child element of that path.</td>
<td><img src="image" alt="Path" /></td>
</tr>
<tr>
<td><strong>Check Box</strong></td>
<td>These can be clicked to select and unselect items. They are typically used in a list of several selections. Selected items typically display a check mark, whereas unselected items will have an empty box.</td>
<td></td>
</tr>
<tr>
<td><strong>Color Selector</strong></td>
<td>This allows a color to be selected for various purposes, such as changing the color of text. For more information, see Section 4.6</td>
<td></td>
</tr>
<tr>
<td><strong>Combo Box</strong></td>
<td>A combination of a Drop Down Box and a Text Box. You can select an option from the list, or type in the text box. Some combo boxes may automatically complete entries for you, or open the list with a list of choices that match what you have typed.</td>
<td></td>
</tr>
<tr>
<td><strong>Context Menu</strong></td>
<td>Many user interface elements in the Plasma Workspace and in Applications contain a context menu, which can be opened by clicking on something with the right mouse button. This menu contains options and actions that usually affect the user interface element that was right-clicked.</td>
<td></td>
</tr>
<tr>
<td><strong>Dialog Box</strong></td>
<td>A small window that appears above a larger application window. It may contain a message, warning, or configuration panel, among others.</td>
<td></td>
</tr>
<tr>
<td><strong>Drop Down Box</strong></td>
<td>This provides a list of items, from which you may select one.</td>
<td></td>
</tr>
<tr>
<td>Icon</td>
<td>A graphical representation of something, such as a file or action. They typically, but not always, also contain a text description, either beneath or to the right of the icon.</td>
<td></td>
</tr>
<tr>
<td>------</td>
<td>------------------------------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>Icon List</td>
<td>This provides a list of items represented by an Icon and a description. It is typically used in the left panel of configuration panels to allow selection from various types of configuration categories.</td>
<td></td>
</tr>
<tr>
<td>List Box</td>
<td>This is a list of items that typically allows multiple items to be selected. To select a group of contiguous items, press the Shift key and click the first and last items. To select multiple items that are not contiguous, press the Ctrl key and select the desired items.</td>
<td></td>
</tr>
<tr>
<td>Menu</td>
<td>A list of selections, that usually perform an action, set an option, or opens a window. These can be opened from menubars or menu buttons.</td>
<td></td>
</tr>
<tr>
<td>KDE Fundamentals</td>
<td></td>
<td></td>
</tr>
<tr>
<td>------------------</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Menubar</strong></td>
<td>These are located at the top of nearly every window and provide access to all the functions of the running application. For more information, see Section 3.2.</td>
<td></td>
</tr>
<tr>
<td><strong>Menu Button</strong></td>
<td>A special type of button that opens a menu.</td>
<td></td>
</tr>
<tr>
<td><strong>Panel or Sidebar or Tool View</strong></td>
<td>These are located on the sides or bottom of the central widget and allow you to perform many different tasks in an application. A text editor might provide a list of open documents in one, while a word processor might allow you to select a clip art image.</td>
<td></td>
</tr>
<tr>
<td><strong>Progress Bar</strong></td>
<td>A small bar that indicates that a long-running operation is being performed. The bar may indicate how much of the operation has completed, or it may simply bounce back and forth to indicate that the operation is in progress.</td>
<td></td>
</tr>
<tr>
<td><strong>Radio Button</strong></td>
<td>These are used in a list of options, and only permit one of the options in the list to be selected.</td>
<td></td>
</tr>
<tr>
<td><strong>Scrollbar</strong></td>
<td>Allows you to navigate a document.</td>
<td></td>
</tr>
</tbody>
</table>
## KDE Fundamentals

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Slider</strong></td>
<td>Allows a numeric value to be selected by moving a small bar either horizontally or vertically across a line.</td>
</tr>
<tr>
<td><strong>Spin Box</strong></td>
<td>This permits a numerical value to be selected, either by using the up and down arrows to the right of the box to raise or lower the value, respectively, or by typing the value into the text box.</td>
</tr>
<tr>
<td><strong>Status Bar</strong></td>
<td>These are located at the bottom of many applications and display information about what the application is currently doing. For instance, a web browser might indicate the progress of loading a web page, while a word processor might display the current word count.</td>
</tr>
<tr>
<td><strong>Tab</strong></td>
<td>These appear at the top of an area of a window, and permit that area of the window to be changed to a variety of different selections.</td>
</tr>
<tr>
<td><strong>Text Area</strong></td>
<td>Allows a large amount of text to be typed in, typically multiple lines or paragraphs. Unlike a Text Box, pressing Enter will usually result in a line break.</td>
</tr>
<tr>
<td><strong>Text Box</strong></td>
<td>A single-line text entry that allows a small amount of text to be typed in. Typically, pressing Enter will perform the same action as clicking the OK button.</td>
</tr>
<tr>
<td><strong>Titlebar</strong></td>
<td>This is located at the top of every window. It contains the name of the application and usually information about what the application is doing, like the title of the web page being viewed in a web browser or the filename of a document open in a word processor.</td>
</tr>
<tr>
<td>KDE Fundamentals</td>
<td></td>
</tr>
<tr>
<td>------------------</td>
<td></td>
</tr>
<tr>
<td><strong>Toolbar</strong></td>
<td></td>
</tr>
<tr>
<td>These are located near the top of many applications, typically directly underneath the <strong>menu bar</strong>. They provide access to many common functions of the running application, like <em>Save</em> or <em>Print</em>.</td>
<td></td>
</tr>
<tr>
<td><strong>Tree View</strong></td>
<td></td>
</tr>
<tr>
<td>A Tree View allows you to select from a hierarchical list of options. A section, or category, of the Tree View may be unexpanded, in which case no options will appear beneath it and the arrow to the left of the title will be pointing right, toward the title. It may also be expanded, in which case several options will be listed below it, and the arrow to the left of the title will be pointing down, toward the options. To expand a portion of the tree view, click the arrow to the left of the title of the section you wish to expand, double-click on the title, or select the title using your keyboard’s arrow keys and press the <strong>Enter</strong> or + key. To minimize a portion of the tree view, you may also click the arrow, double-click on the title, or press the <strong>Enter</strong> or - key.</td>
<td></td>
</tr>
</tbody>
</table>

### 3.2 Common Menus

Many KDE applications contain these menus. However, most applications will have more menu entries than those listed here, and others may be missing some of the entries listed here.

*The menubar in Gwenview.*
Some applications, like Dolphin, do not show a menubar by default. You can show it by pressing \texttt{Ctrl-M}. You can also use this to hide the menubar in applications that support doing so.

### 3.2.1 The File Menu

The \texttt{File} menu allows you to perform operations on the currently open file and access common tasks in applications.

Common menu items include:

- **File → New (Ctrl+N)**
  - Creates a new file.

- **File → New Window**
  - Opens a new window.

- **File → Open... (Ctrl+O)**
  - Opens an already existing file.

- **File → Save (Ctrl+S)**
  - Saves the file. If the file already exists it will be overwritten.

- **File → Save As...**
  - Saves the file with a new filename.

- **File → Save All**
  - Saves all open files.

- **File → Reload (F5)**
  - Reloads the current file.

- **File → Reload All**
  - Reloads all open files.

- **File → Print... (Ctrl+P)**
  - Prints the file. Use \texttt{Print to File (PDF)} to generate a PDF file or select a range of pages to print only these pages to a new PDF file.

- **File → Close (Ctrl+W)**
  - Closes the current file.

- **File → Close All**
  - Closes all open files.

- **File → Quit (Ctrl+Q)**
  - Exits the program.

### 3.2.2 The Edit Menu

The \texttt{Edit} menu allows you to modify the currently open file.

- **Edit → Undo (Ctrl+Z)**
  - Undo the last action you performed in the file.

- **Edit → Redo (Ctrl+Shift+Z)**
  - Redo the last action you performed in the file.
Edit → Cut (Ctrl+X)
Removes the currently selected portion of the file, if any, and places a copy of it in the clipboard buffer.

Edit → Copy (Ctrl+C)
Places a copy of the currently selected portion of the file, if any, in the clipboard buffer.

Edit → Paste (Ctrl+V)
Copies the first item in the clipboard buffer to the current location in the file, if any.

Edit → Select All (Ctrl+A)
Selects the entire contents of the currently open file.

Edit → Find... (Ctrl+F)
Allows you to search for text in the currently open file.

Edit → Replace... (Ctrl+R)
Allows you to search for text in the currently open file and replace it with something else.

Edit → Find Next (F3)
Go to the next match of the last Find operation.

Edit → Find Previous (Shift+F3)
Go to the previous match of the last Find operation.

3.2.3 The View Menu

The View menu allows you to change the layout of the currently open file and/or the running application.

This menu has different options depending on the application you are using.

3.2.4 The Tools Menu

The Tools menu allows you to perform certain actions on the currently open file.

Tools → Automatic Spell Checking (Ctrl+Shift+O)
Check for spelling errors as you type. For more information, see Section 4.3.2.

Tools → Spelling...
This initiates the spellchecking program - a program designed to help the user catch and correct any spelling errors. For more information, see Section 4.3.1.

Tools → Spelling (from cursor)...
This initiates the spellchecking program, but only checks the portion of the document from the current location of the cursor to the end. For more information, see Section 4.3.1.

Tools → Spellcheck Selection...
This initiates the spellchecking program, but only checks the currently selected text in the document. For more information, see Section 4.3.1.

Tools → Change Dictionary...
This allows you to change the dictionary used to check spellings. For more information, see Section 4.3.3.
3.2.5 The Settings Menu

The Settings allows you to customize the application. This menu typically contains the following items:

**Settings → Show Menubar (Ctrl+M)**

Toggle the Menubar display on and off. Once hidden it can be made visible using the shortcut Ctrl+M again. If the menubar is hidden, the context menu opened with a right mouse button click anywhere in the view area has an extra entry Show Menubar.

**Settings → Show Statusbar**

Toggles the display of the statusbar on and off. Some KDE applications use statusbar at the bottom of their screen to display useful information.

**Settings → Toolbars Shown**

Allows you to show and hide the various toolbars supported by the application.

**Settings → Show Statusbar**

When checked, this displays a small bar at the bottom of the application containing information about the status. When unchecked the status bar is hidden.

**Settings → Configure Shortcuts...**

Allows you to enable, disable, and modify keyboard shortcuts. For more information, see Section 5.2.

**Settings → Configure Toolbars...**

Allows you to customize the contents, layout, text, and icons of toolbars. For more information, see Section 5.1.

**Settings → Configure Notifications...**

This item displays a standard KDE notifications configuration dialog, where you can change the notifications (sounds, visible messages, etc.) used by the application.

For more information how to configure notifications please read the documentation for the System Settings module Manage Notifications.

**Settings → Configure Application...**

Opens the configuration panel for the currently running application.

3.2.6 The Help Menu

The Help menu gives you access to the application’s documentation and other useful resources.

**Help → Application Handbook (F1)**

Invokes the KDE Help system starting at the running application’s handbook.

**Help → What’s This? (Shift+F1)**

Changes the mouse cursor to a combination arrow and question mark. Clicking on items within the application; will open a help window (if one exists for the particular item) explaining the item’s function.

**Help → Tip of the Day**

This command opens the Tip of the Day dialog. You can page through all the tips by using the buttons on the dialog and select to show the tips at startup.

Note: Not all applications provide these tips.
Help → Report Bug...
Opens the Bug report dialog where you can report a bug or request a ‘wishlist’ feature.

Help → Donate
Opens the Donations page where you can support KDE and its projects.

Help → Switch Application Language...
Opens a dialog where you can edit the Primary language and Fallback language for this application.

Help → About Application
This will display version and author information for the running application.

Help → About KDE
This displays the KDE Development Platform version and other basic information.

3.2.7 Thanks and Acknowledgments
Special thanks to an anonymous Google Code-In 2011 participant for writing much of this documentation.

3.3 Common Keyboard Shortcuts
The KDE Plasma Workspaces provide keyboard shortcuts that allow you to perform many tasks without touching your mouse. If you use your keyboard frequently, using these can save you lots of time.
This list contains the most common shortcuts supported by the workspace itself and many applications available within. Every application also provides its own shortcuts, so be sure to check their manuals for a comprehensive listing.

**NOTE**
The Meta key described below is a generic name for the custom key found on many different keyboards. On keyboards designed for Microsoft® Windows®, this key is usually called the Windows key, and will have a picture of the Windows® logo. On keyboards designed for Mac® computers, this key is known as the Command key and will have a picture of the Apple® logo and/or the ⌘ symbol. On keyboards designed for UNIX® systems, this key is really known as the Meta key and is typically labeled with a diamond: ◆.

3.3.1 Working with Windows
These shortcuts allow you to perform all kinds of operations with windows, whether it be opening, closing, moving, or switching between them.

3.3.1.1 Starting and Stopping Applications
These shortcuts make it easy to start and stop programs.
3.3.1.2 Moving Around

These shortcuts allow you to navigate between windows, activities, and desktops efficiently.

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+F10</td>
<td>Present Windows</td>
</tr>
<tr>
<td>Ctrl+F9</td>
<td>Present Windows on current desktop</td>
</tr>
<tr>
<td>Ctrl+F7</td>
<td>Present Windows of current application only</td>
</tr>
<tr>
<td>Ctrl+F12</td>
<td>Show Desktop</td>
</tr>
<tr>
<td>Ctrl+Alt+A</td>
<td>Activate Window Demanding Attention</td>
</tr>
<tr>
<td>Alt+Tab</td>
<td>Walk through windows</td>
</tr>
<tr>
<td>Alt+Shift+Tab</td>
<td>Walk through windows (Reverse)</td>
</tr>
<tr>
<td>Alt+F3</td>
<td>Open the Window Operations menu</td>
</tr>
<tr>
<td>Meta+Alt+Up</td>
<td>Switch to Window Above</td>
</tr>
<tr>
<td>Meta+Alt+Down</td>
<td>Switch to Window Below</td>
</tr>
<tr>
<td>Meta+Alt+Left</td>
<td>Switch to Window to the Left</td>
</tr>
<tr>
<td>Meta+Alt+Right</td>
<td>Switch to Window to the Right</td>
</tr>
</tbody>
</table>

3.3.1.3 Panning and Zooming

Need to get a closer look? The KDE Plasma Workspaces allow you to zoom in and out and move your entire desktop around, so you can zoom in even when the application you are using doesn’t support it.

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Meta+=</td>
<td>Zoom In</td>
</tr>
<tr>
<td>Meta+-</td>
<td>Zoom Out</td>
</tr>
<tr>
<td>Meta+0</td>
<td>Zoom Normal</td>
</tr>
<tr>
<td>Meta+Up</td>
<td>Pan Up</td>
</tr>
<tr>
<td>Meta+Down</td>
<td>Pan Down</td>
</tr>
<tr>
<td>Meta+Left</td>
<td>Pan left</td>
</tr>
<tr>
<td>Meta+Right</td>
<td>Pan Right</td>
</tr>
</tbody>
</table>
3.3.2 Working with Activities and Virtual Desktops

These shortcuts allow you to switch between and manage Activities and virtual desktops.

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Meta+Q / Alt+D,Alt+A</td>
<td>Manage Activities</td>
</tr>
<tr>
<td>Meta+Tab</td>
<td>Next Activity</td>
</tr>
<tr>
<td>Meta+Shift+Tab</td>
<td>Previous Activity</td>
</tr>
<tr>
<td>Ctrl+F1</td>
<td>Switch to Desktop 1</td>
</tr>
<tr>
<td>Ctrl+F2</td>
<td>Switch to Desktop 2</td>
</tr>
<tr>
<td>Ctrl+F3</td>
<td>Switch to Desktop 3</td>
</tr>
<tr>
<td>Ctrl+F4</td>
<td>Switch to Desktop 4</td>
</tr>
</tbody>
</table>

3.3.3 Working with the Desktop

These shortcuts allow you to work with the KDE Plasma Desktop and panels.

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AltD A</td>
<td>Add Widgets</td>
</tr>
<tr>
<td>AltD R</td>
<td>Remove this Widget</td>
</tr>
<tr>
<td>AltD L</td>
<td>Lock/Unlock Widgets</td>
</tr>
<tr>
<td>AltD S</td>
<td>Widget Settings</td>
</tr>
<tr>
<td>Ctrl+F12</td>
<td>Show Desktop</td>
</tr>
<tr>
<td>AltD T</td>
<td>Run the Associated Application</td>
</tr>
<tr>
<td>Alt+D,Alt+S</td>
<td>Desktop Settings</td>
</tr>
</tbody>
</table>

3.3.4 Getting Help

Need some help? The manual for the current application is only a keypress away, and some programs even have additional help that explains the element in focus.

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Help</td>
</tr>
<tr>
<td>Shift+F1</td>
<td>What’s This?</td>
</tr>
</tbody>
</table>

3.3.5 Working with Documents

Whether it’s a text document, spreadsheet, or web site, these shortcuts make performing many kinds of tasks with them easy.

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>F5</td>
<td>Refresh</td>
</tr>
<tr>
<td>Ctrl+A</td>
<td>Select All</td>
</tr>
</tbody>
</table>
3.3.6 Working with Files

Whether you are in an Open/Save dialog or the Dolphin file manager, these shortcuts save you time when performing operations on files. Note that some of the concepts used with files are the same as with documents, so several of the shortcuts are identical to their counterparts listed above.

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Z</td>
<td>Undo</td>
</tr>
<tr>
<td>Ctrl+Shift+Z</td>
<td>Redo</td>
</tr>
<tr>
<td>Ctrl+X</td>
<td>Cut</td>
</tr>
<tr>
<td>Ctrl+C</td>
<td>Copy</td>
</tr>
<tr>
<td>Ctrl+V</td>
<td>Paste</td>
</tr>
<tr>
<td>Ctrl+N</td>
<td>New</td>
</tr>
<tr>
<td>Ctrl+P</td>
<td>Print</td>
</tr>
<tr>
<td>Ctrl+S</td>
<td>Save</td>
</tr>
<tr>
<td>Ctrl+F</td>
<td>Find</td>
</tr>
<tr>
<td>Ctrl+W</td>
<td>Close Document/Tab</td>
</tr>
<tr>
<td>Ctrl+A</td>
<td>Select All</td>
</tr>
<tr>
<td>Ctrl+Shift+A</td>
<td>Invert Selection</td>
</tr>
<tr>
<td>Alt+Left</td>
<td>Back</td>
</tr>
<tr>
<td>Alt+Right</td>
<td>Forward</td>
</tr>
<tr>
<td>Alt+Up</td>
<td>Up (to folder that contains this one)</td>
</tr>
<tr>
<td>Alt+Home</td>
<td>Home Folder</td>
</tr>
<tr>
<td>Delete</td>
<td>Move to Trash</td>
</tr>
<tr>
<td>Shift+Delete</td>
<td>Delete Permanently</td>
</tr>
</tbody>
</table>

3.3.7 Changing Volume and Brightness

In addition to the standard keys, many computer keyboards and laptops nowadays have special keys or buttons to change the speaker volume, as well as the brightness of your monitor if applicable. If present, you can use these keys in the KDE Plasma Workspaces to perform those tasks.

If you do not have such keys, see Section 3.3.9 for information on how to assign keys for these tasks.

3.3.8 Leaving Your Computer

All done? Use these shortcuts and put your computer away!
KDE Fundamentals

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Alt+L</td>
<td>Lock Screen</td>
</tr>
<tr>
<td>Ctrl+Alt+Del</td>
<td>Leave</td>
</tr>
</tbody>
</table>

3.3.9 Modifying Shortcuts

The shortcuts described in Working With Windows, Leaving Your Computer, Changing Volume and Brightness and Working with Activities and Virtual Desktops are called global shortcuts, since they work regardless of which window you have open on your screen. These can be modified in the Global Shortcuts panel of System Settings, where they are separated by KDE component.

The shortcuts described Working with the Desktop are immutable and cannot be modified.

The shortcuts described in Working with Documents and Getting Help are set by individual programs. Most KDE programs allow you to use the common shortcut editing dialog to modify these. The shortcuts described in Working With Files can be edited in the same manner when used inside a file manager like Dolphin or Konqueror, but cannot be modified in the case of Open/Save dialogs, etc.
Chapter 4

Common Tasks

4.1 Navigating Documents

4.1.1 Scrolling

You’re probably familiar with the scrollbar that appears on the right side (and sometimes the bottom) of documents, allowing you to move within documents. However, there are several other ways you can navigate documents, some of which are faster and easier.

Several mice have a wheel in the middle. You can move it up and down to scroll within a document. If you press the Shift key while using the mouse wheel, the document will scroll faster.

If you’re using a portable computer like a laptop, you might also be able to scroll using the touchpad. Some computers allow you to scroll vertically by moving your finger up and down the rightmost side of the touchpad, and allow you to scroll horizontally by moving your finger across the bottommost side of the touchpad. Others let you scroll using two fingers: move both fingers up and down anywhere on the touchpad to scroll vertically, and move them left and right to scroll horizontally. Since this functionality emulates the mouse wheel functionality described above, you can also press the Shift key while you do this to scroll faster.

If you use the KDE Plasma Workspaces, you can control mouse wheel behavior in the Mouse module in System Settings, and you can control touchpad scrolling behavior in the Touchpad module in System Settings. Otherwise, look in the configuration area of your operating system or desktop environment.

Additionally, the scrollbar has several options in its context menu. You can access these by right-clicking anywhere on the scrollbar. The following options are available:

Scroll here
  Scroll directly to the location represented by where you right-clicked on the scrollbar. This is the equivalent of simply clicking on that location on the scrollbar.

Top (Ctrl+Home)
  Go to the beginning of the document.

Bottom (Ctrl+End)
  Go to the end of the document.

Page up (PgUp)
  Navigate to the previous page in a document that represents a printed document, or one screen up in other types of documents.
Page down (PgDn)
Navigate to the next page in a document that represents a printed document, or one screen down in other types of documents.

Scroll up
Scroll up one unit (usually a line) in the document. This is the equivalent of clicking the up arrow at the top of the scrollbar.

Scroll down
Scroll down one unit (usually a line) in the document. This is the equivalent of clicking the down arrow at the bottom of the scrollbar.

4.1.2 Zooming
Many applications permit you to zoom. This makes the text or image you are viewing larger or smaller. You can generally find the zoom function in the View menu, and sometimes in the status bar of the application.

You can also zoom using the keyboard by pressing Ctrl++ to zoom in, or Ctrl+- to zoom out. If you can scroll with the mouse wheel or touchpad as described in Section 4.1.1, you can also zoom by pressing Ctrl and scrolling that way.

4.2 Opening and Saving Files

4.2.1 Introduction
Many KDE applications work with files. Most applications have a File menu with options that allow you to open and save files. For more information on that, see Section 3.2.1. However, there are lots of different operations that require selecting a file. Regardless of the method, all KDE applications generally use the same file selection window.

Opening a file in Konqueror.

4.2.2 The File Selection Window

The Toolbar
This contains standard navigation tool buttons:
KDE Fundamentals

Back
Causes the folder view to change to the previously displayed folder in its history. This button is disabled, if there is no previous item.

Forward
Causes the folder view to change to the next folder in its history. This button is disabled, if there is no next folder.

Parent Folder
This will cause the folder view to change to the immediate parent of the currently displayed folder, if possible.

Reload (F5)
Reloads the folder view, displaying any changes that have been made since it was first loaded or last reloaded.

Show Preview
Displays a preview of each file inside the folder view.

Zoom Slider
This allows you to change the size of the icon or preview shown in the folder view.

Options

Options → Sorting

Options → Sorting → By Name
Sort files listed in the folder view alphabetically by name.

Options → Sorting → By Size
Sort files listed in the folder view in order of their file size.

Options → Sorting → By Date
Sort files listed in the folder view by the date they were last modified.

Options → Sorting → By Type
Sort files listed in the folder view alphabetically by their file type.

Options → Sorting → Descending
When unchecked (the default), files in the folder view will be sorted in ascending order. (For instance, files sorted alphabetically will be sorted from A to Z, while files sorted numerically will be sorted from smallest to largest.) When checked, files in the folder will be sorted in descending order (in reverse).

Options → Sorting → Folders First
When enabled (the default), folders will appear before regular files.

Options → View

Options → View → Short View
Displays only the filenames.

Options → View → Detailed View
Displays Name, Date and Size of the files.

Options → View → Tree View
Like Short View, but folders can be expanded to view their contents.

Options → View → Detailed Tree View
This also allows folders to be expanded, but displays the additional columns available in Detailed View.

Options → Show Hidden Files (Alt+.)
Displays files or folders normally hidden by your operating system. The alternate shortcut for this action is F8.

Options → Show Places Navigation Panel (F9)
Displays the places panel which provides quick access to bookmarked locations and disks or other media.

Options → Show Bookmarks
Displays an additional icon on the toolbar that provides access to ‘bookmarks’, a list of saved locations.
Options → Show Aside Preview
Displays a preview of the currently highlighted file to the right of the folder view.

Bookmarks
Opens a submenu to edit or add bookmarks and to add a new bookmark folder.

Location Bar
The location bar, which can be found on top of the folder view, displays the path to the current folder. The location bar has two modes:

Bread Crumb Mode
In the ‘bread crumb’ mode, which is the default, each folder name in the path to the current folder is a button which can be clicked to quickly open that folder. Moreover, clicking the ‘>’ sign to the right of a folder opens a menu which permits to quickly open a subfolder of that folder.

Location bar in bread crumb mode.

Editable Mode
When in bread crumb mode, clicking in the gray area to the right of the path with the left mouse button switches the location bar to the ‘editable’ mode, in which the path can be edited using the keyboard. To switch back to bread crumb mode, click the check mark at the right of the location bar with the left mouse button.

Location bar in editable mode.

The context menu of the location bar offers action to switch between the modes and to copy and paste the path using the clipboard. Check the last option in this context menu to display either the full path starting with the root folder of the file system or to display the path starting with the current places entry.
KDE Fundamentals

The Places List
This provides the standard KDE list of Places, shared with Dolphin and other file management tools.

The Folder View
The largest part of the file selection window is the area that lists all items in the current directory. To select a file, you can double-click on it, or choose one and hit Open or Save.
You can also select multiple files at once. To select specific files, or to unselect specific files that are already selected, press and hold Ctrl, click on each file, then release Ctrl. To select a contiguous group of files, click the first file, press and hold Shift, click on the last file in the group, and release Shift.
The Folder View supports a limited set of file operations, which can be accessed by right-clicking on a file to access its context menu, or using keyboard shortcuts. The following items are available in the context menu:

Create New...
Create a new file or folder.

Move to Trash... (Del)
Move the currently selected item to the trash.

Sorting
This submenu can also be accessed from the toolbar, and is described in Options → Sorting.

View
This submenu can also be accessed from the toolbar, and is described in Options → View.

Open File Manager
Opens the current folder in your default file manager application.

Properties (Alt+Enter)
Open the Properties window that allows you to view and modify various types of metadata related to the currently selected file.

The Preview Pane
If enabled, this displays a preview of the currently highlighted file.
The Name Entry

When a file is selected, a name will appear in this text box. You may also manually enter a file name or path in this text box.

The Filter Entry

When opening a file, the Filter entry allows you to enter a filter for the files displayed in the folder view. The filter uses standard globs; patterns must be separated by white space. For instance, you can enter `*.cpp *.h *.moc` to display several different common Qt™ programming files.

To display all files, enter a single asterisk (`*`).

The filter entry saves the last 10 filters entered between sessions. To use one, press the arrow button on the right of the entry and select the desired filter string. You can disable the filter by pressing the Clear text button to the left of the autocompletion arrow button.

When saving a file, the Filter entry will instead display a drop down box that allows you to select from all the file types the application supports. Select one to save a file in that format.

Automatically select filename extension

When saving a file, this check box will appear. When selected (the default), the application will automatically append the default file extension for the selected file type to the end of the file name, if it does not already appear in the Name entry. The file extension that will be used is listed in parenthesis at the end of the check box label.

![Saving a file in Konqueror.](image)

The Open or Save Button

Depending on the action being performed, an Open or Save button will be displayed. Clicking on this button will close the file selection window and perform the requested action.

The Cancel Button

Clicking Cancel will close the file dialog without performing any action.

4.2.3 Thanks and Acknowledgments

Special thanks to Google Code-In 2011 participant Alexey Subach for writing parts of this section.
4.3 Check Spelling

Sonnet is the spelling checker used by KDE applications such as Kate, KMail, and KWord. It is a GUI frontend to various free spell checkers.

To use Sonnet you need to install a spell checker like GNU Aspell, Enchant, Hspell, ISpell or Hunspell and additionally the corresponding dictionaries for the languages that you wish to use.

4.3.1 Check Spelling

Correcting a misspelling.

To check spelling, go to Tools → Spelling....

If a word is possibly misspelled in your document, it is displayed in the top line in the dialog. Sonnet tries to appropriate word(s) for replacement. The best guess is displayed to the right of Replace with. To accept this replacement, click on Replace.

Sonnet also allows you to select a word from the list of suggestions and replace the misspelled word with that selected word. With the help of the Suggest button, you can add more suggestions from the dictionary to the suggestions list.

Click on Ignore to keep your original spelling,

Click on Finished to stop spellchecking and keep the changes made.

Click on Cancel to stop spellchecking and cancel the changes already made.

Click on Replace All to automatically replace the misspelled word(s) with the chosen replacement word, if they appear again in your document later.

Click on Ignore All to ignore the spelling at that point and all the future occurrences of the word misspelled.

Click on Add to Dictionary to add the misspelled word to your personal dictionary.

The Personal Dictionary is a distinct dictionary from the system dictionary and the additions made by you will not be seen by others.

The drop down box Language at the bottom of this dialog allows you to switch to another dictionary temporarily.

4.3.2 Automatic Spell Checking

In many applications, you can automatically check spelling as you type. To enable this feature, select Tools → Automatic Spell Checking.

Potentially misspelled words will be underlined in red. To select a suggestion, right click on the word, select the Spelling submenu, and select the suggestion. You may also instruct Sonnet to ignore this spelling for this document by selecting Ignore Word, or you may select Add to Dictionary to save it in your personal dictionary.
4.3.3 Configuring Sonnet

To change your dictionary, go to Tools → Change Dictionary... A small window will appear at the bottom of the current document that will allow you to change your dictionary.

For more information on configuring Sonnet, see the Spell Checker System Settings module documentation.

4.3.4 Thanks and Acknowledgments

Special thanks to Google Code-In 2011 Participant Salma Sultana for writing much of this section.

4.4 Find and Replace

The Find function of many KDE applications lets you find specific text in a document, while the Replace function allows you to replace text that is found with different text you provide.

You can find both these functions in the Edit menu of many KDE applications. For more information on this menu, see Section 3.2.2.

4.4.1 The Find Function

The Find function searches for text in a document and selects it.

To use Find in many applications, go to Edit → Find... or press Ctrl+F. Then, in the Text to find: text box, enter the text that you want to find.

If Regular expression is checked you will be able to search using regular expressions. Click on Edit to select from and enter commonly used regular expression characters, like White Space or

Searching for income in Calligra Sheets.
Start of Line. If Kate is installed, you can find more information on writing regular expressions in its documentation.

You can limit the found results by configuring these options:

Case sensitive
Capital and lowercase characters are considered different. For example, if you search for ‘This’, results that contain ‘this’ will not be returned.

Whole words only
By default, when the application searches for text, it will return results even in the middle of other text. For instance, if you search for ‘is’ it will stop on every word that contains that, like ‘this’ or ‘history’. If you check this option, the application will only return results when the search text is a word by itself, that is, surrounded by whitespace.

From cursor
The search will start from the location of the cursor and stop at the end of the text.

Find backwards
By default, the application searches for the text starting at the beginning of the document, and move through it to the end. If you check this option, it will instead start at the end and work its way to the beginning.

Selected text
Select this option to search only in the text that is currently selected, not the entire document. It is disabled when no text is selected.

Many applications show a search bar instead of the Find window. See KatePart documentation for additional information on the search bar.

Searching for software in Kate’s search bar.
The Find function only selects the first match that it finds. You can continue searching by selecting Edit → Find Next or by pressing F3.
4.4.2 The Replace Function

The Replace function searches for text in a document and replaces it with other text. You can find it in many applications at **Edit → Replace...** or by pressing **Ctrl+R**.

Replacing *income* with *expense* in Calligra Sheets

The window of the Replace function is separated into 3 sections:

**Find**
Here you may enter the text you wish to search for. See Section 4.4.1 for more information on the options provided here.

**Replace**
Here you may enter the text you wish to replace the found text with.
You can reuse the found text in the replacement text by selecting the **Use placeholders** checkbox. Placeholders, sometimes known as backreferences, are a special character sequence that will be replaced with all or part of the found text. For instance, '\0' represents the entire found string.

You may insert placeholders into the text box by clicking the **Insert Placeholder** button, then selecting an option from the menu like **Complete Match**. For example, if you are searching for 'message', and you want to replace it with **messages** insert the **Complete Match** placeholder and add an ‘s’. The replace field will then contain ‘\0s’.

If Kate is installed, you can learn more about placeholders in the **Regular Expressions appendix of its documentation**.

**Options**
This contains all the same options that the **Find** function does, with one addition:
If the **Prompt on replace** option is checked a window will appear on every found word, allowing you to confirm whether you would like to replace the found text.
KDE Fundamentals

Many Applications show a search and replace bar instead of the Replace window. See KatePart documentation for additional information on the search and replace bar.

Replacing `kmail` with `kate` in Kate’s search and replace bar

4.4.3 Thanks and Acknowledgments

Thanks to an anonymous Google Code-In 2011 participant for writing much of this section.

4.5 Choosing Fonts

The font selector appears in many different KDE applications. It lets you select the font face, font style, and font size of the text that appears in your application.

Selecting a font in System Settings.

Font

This is the leftmost selection box, and lets you choose the font face from a list of fonts on your system.

Font style

This is the center selection box, and lets you choose the font style from the following choices:
KDE Fundamentals

- **Italic** - this displays text in a cursive, or slanted fashion, and is commonly used for citations or to emphasize text.
- **Regular** - the default. Text is displayed without any special appearance.
- **Bold Italic** - a combination of both **Bold** and **Italic**
- **Bold** - this displays text in a darker, thicker fashion, and is commonly used for titles of documents or to emphasize text.

**Size**

This is the rightmost selection box, and lets you select the size of your text. Font size is measured in points, a standard unit of measure in typography. For more information on this, see the [Point (typography) article on Wikipedia](https://en.wikipedia.org/wiki/Point_(typography)).

**Preview**

The bottom of the font selector displays a preview of text using the font settings that are currently selected. You may change this text if you wish.

### 4.6 Choosing Colors

The color chooser appears in many KDE applications, whenever you need to select a color. It lets you pick from a **Basic colors** consisting of many predefined colors or mix your own when you want a specific color.

![Select Color in System Settings](image)

Selecting a color in **System Settings**.

#### 4.6.1 Using Basic Colors

The basic colors group is a set of predefined colors. You can find it on the top side of the color chooser window.

To select a color from the basic colors, simply click on it. The color will be displayed at the right of the palette, along with its HTML hexadecimal code.
4.6.2 Mixing Colors

The color chooser also lets you mix your own colors. There are several ways to do this:

4.6.2.1 Using the Grid

The right side of the color chooser contains a large box, and a thinner box immediately to its right. You can use the left box to select the Hue and Saturation of the desired color based on the visual guide provided in the box. The right bar adjusts the Value. Adjust these to select the desired color, which is displayed in the middle of the window.

For more information on Hue, Saturation, and Value, see Section 4.6.2.3

4.6.2.2 Using the Screen Colors

The eyedropper tool allows you to select a color from your screen. To use it, select the Pick Screen Color button below the basic colors, and then click anywhere on your screen to select that color.

4.6.2.3 Hue/Saturation/Value

The lower-right corner of the screen allows you to manually enter the coordinates of the desired color in the Hue/Saturation/Value (HSV) color space. For more information on this, see the HSL and HSV article on Wikipedia.

These values are also updated when selecting a color by other methods, so they always accurately represent the currently selected color.

4.6.2.4 Red/Green/Blue

The lower-right corner of the screen also allows you to manually enter the coordinates of the desired color in the Red/Green/Blue (RGB) color model. For more information on this, see the RGB color model article on Wikipedia.

These values are also updated when selecting a color by other methods, so they always accurately represent the currently selected color.

4.6.2.5 HTML Hexadecimal Code

You may enter the HTML hexadecimal code representing the color in the lower-right corner of the screen. For more information on this, see the Web colors article on Wikipedia.

This value is also updated when selecting a color by other methods, so it always accurately represents the currently selected color.

4.6.3 Custom Colors

After selecting a color, you may add it to the Custom Colors group so you can use it later. To do so, click the Add to Custom Colors button.
Chapter 5

Customizing KDE software

5.1 Customizing Toolbars

5.1.1 Modifying Toolbar Items

To customize an application’s toolbars, go to Settings → Configure Toolbars... or right-click on a toolbar and select Configure Toolbars....

On the left side of the toolbar configuration panel, the available items that you can put in your toolbar are shown. On the right, the ones that already appear on the toolbar are shown. At the top, you can select the toolbar you wish to modify or view.

Above each side of the panel there is a Filter text box you can use to easily find items in the list.
5.1.1.1 Adding an Item

You can add an item to your toolbar by selecting it from the left side and clicking on the right arrow button.

5.1.1.2 Removing an Item

You can remove an item by selecting it and clicking the left arrow button.

5.1.1.3 Changing the Position of Items

You can change the position of the items by moving them lower or higher in the list. To move items lower, press the down arrow button, while to move items higher press the up arrow button. You can also change items’ position by dragging and dropping them.

On horizontal toolbars, the item that’s on top will be the one on the left. On vertical toolbars, items are arranged as they appear in the toolbar.

5.1.1.4 Adding a Separator

You can add separator lines between items by adding a --- separator --- item to the toolbar.

5.1.1.5 Restoring Defaults

You can restore your toolbar to the way it was when you installed the application by pressing the Defaults button at the bottom of the window and then confirming your decision.
5.1.1.6 Changing Text and Icons

You can change the icon and text of individual toolbar items by selecting an item and clicking either the Change Icon... or Change Text... button.

5.1.2 Customizing Toolbar Appearance

You can change the appearance of toolbars by right-clicking on a toolbar to access it’s context menu.

5.1.2.1 Text Position

You can change the appearance of text on toolbars in the Text Position submenu of a toolbar’s context menu.

You can choose from:

- Icons - only the icon for each toolbar item will appear.
- Text - only the text label for each toolbar item will appear.
- Text Alongside Icons - the text label will appear to the right of each toolbar item’s icon
- Text Under Icons - the text label will appear underneath each toolbar item’s icon

You can also show or hide text for individual toolbar items by right-clicking on an item and checking or unchecking the item under Show Text.

5.1.2.2 Icon Size

You can change the size of toolbar items’ icons by selecting Icon Size from the toolbar’s context menu.

You can choose from the following options: (each lists the icon size in pixels)

- Small (16x16)
- Medium (22x22) [the default value]
- Large (32x32)
- Huge (48x48)

5.1.2.3 Moving Toolbars

In order to move toolbars, you must ‘unlock’ them. To do so, uncheck Lock Toolbar Positions from a toolbar’s context menu. To restore the lock, simply recheck this menu item.

You can change a toolbar’s position from the Orientation submenu of its context menu.

You can choose from:

- Top [the default in many applications]
- Left
- Right
- Bottom

You can also move a toolbar by clicking and holding onto the dotted line at the left of horizontal toolbars or the top of vertical toolbars and dragging it to your desired location.
5.1.2.4 Show/Hide Toolbars

If your application has only one toolbar, you can hide a toolbar by deselecting Show Toolbar from either the toolbar’s context menu or the Settings menu. To restore the toolbar, select Show Toolbar from the Settings menu. Note that toolbars must be ‘unlocked’ to hide them from their context menu; see Section 5.1.2.3 for more information.

If your application has more than one toolbar, a submenu called Toolbars Shown will appear in the context menu and Settings menu instead of the above menu entry. From that menu you may select individual toolbars to hide and show.

5.1.3 Thanks and Acknowledgments

Thanks to an anonymous Google Code-In 2011 participant for writing much of this section.

5.2 Using and Customizing Shortcuts

5.2.1 Introduction

Many KDE applications allow you to configure keyboard shortcuts. To open the standard keyboard shortcuts configuration panel, go to Settings → Configure Shortcuts...

In the Configure Shortcuts window, you will see a list of all the shortcuts available in the current application. You can use the search box at the top to search for the shortcut you want.

Searching for shortcuts with file in Dolphin.

5.2.2 Changing a Shortcut

To change a shortcut, first click on the name of a shortcut you want to change. You will see a radio group where you can choose whether to set the shortcut to its default value, or select a new shortcut for the selected action. To set a new shortcut, choose Custom and click on the button next to it. Then just type the shortcut you would like to use, and your changes will be saved.
5.2.3 Resetting Shortcuts

There is a button at the bottom of the window, called Defaults. Clicking on this button will reset all your custom shortcuts to their default values.

You can also reset an individual shortcut to its default value by selecting it, and choosing the Default radio button.

5.2.4 Removing a Shortcut

To remove a shortcut, select it from the list, then click the remove icon (a black arrow with a cross) to the right of the button that allows you to select a shortcut.

5.2.5 Working with Schemes

Schemes are keyboard shortcuts configuration profiles, so you can create several profiles with different shortcuts and switch between these profiles easily.
KDE Fundamentals

To see a menu allowing you to edit schemes, click on the **Manage Schemes** button at the bottom of the form. The following options will appear:

**Current Scheme**
Allows you to switch between your schemes.

**New...**  
Creates a new scheme. This opens a window that lets you select a name for your new scheme.

**Delete**  
Deletes the current scheme.

**More Actions**  
Opens the following menu:

- **Save Shortcuts to scheme**  
  Save the current shortcuts to the current scheme.

- **Export Scheme...**  
  Exports the current scheme to a file.

- **Import Scheme...**  
  Imports a scheme from a file.

### 5.2.6 Printing Shortcuts

You can print out a list of shortcuts for easy reference by clicking the **Print** button at the bottom of the window.

### 5.2.7 Thanks and Acknowledgments

Special thanks to Google Code-In 2011 participant Alexey Subach for writing much of this section.
Chapter 6

Credits and License

The original idea for this guide was proposed by Chusslove Illich and brought to fruition with input from Burkhard Lück, Yuri Chornoivan, and T.C. Hollingsworth

Much of it was written by participants of Google Code-In 2011. Thanks to Google for sponsoring their excellent work!

This documentation is licensed under the terms of the GNU Free Documentation License.
This program is licensed under the terms of the GNU General Public License.