Chapter 3. Command Reference

The main Cantor window

Cantor has the common KDE menu items, for more information read the Menu chapter of the KDE Fundamentals.

Below is the list of the additional or special menu items in Cantor. Please note that some menus are only shown for backends that have corresponding implementation.

The File Menu

FileNew (Ctrl+N)

Creates a new worksheet with the default backend.

FileNewBackend

Creates a new worksheet with the chosen backend.

FileDownload Example Worksheets

Opens the dialog to download examples uploaded by other Cantor users with GetHotNewStuff.

FileOpen Example

Opens the dialog to choose an example to load. The examples should be downloaded with FileDownload Example Worksheets beforehand.

FileSave Plain Text

Allows saving the current worksheet as a plain text document.

FileExport to LaTeX

Allows saving the current worksheet as a LATEX document.

FilePublish Worksheet

Opens the dialog to publish your current worksheet and make it available to other Cantor users through GetHotNewStuff.

FileRun Script

Allows to load and run the batch scripts for the current backend.

The View Menu

ViewZoom In (Ctrl++)

Zoom in the current worksheet by 10%.

ViewZoom Out (Ctrl+-)

Zoom out the current worksheet by 10%.

ViewShow Script Editor

Opens the batch script editor window for the current backend.

ViewPanelsHelp

Toggles the visibility of the Help tab in the sidebar.

ViewPanelsVariable Manager

Toggles the visibility of the Variable Manager tab in the sidebar.

The Worksheet Menu

WorksheetEvaluate Worksheet

Triggers the evaluation of the whole worksheet.

WorksheetEvaluate Entry (Shift+Return)

Triggers the current entry evaluation.

WorksheetInsert Command Entry (Ctrl+Return)

Inserts a new command entry below the current cursor position.

WorksheetInsert Text Entry

Inserts a new text entry below the current cursor position.

WorksheetInsert Latex Entry

Inserts a latex entry below the current cursor position..

WorksheetInsert Page Break

Inserts the page break below the current cursor position.

WorksheetRemove current Entry (Shift+Del)

Removes current entry from the worksheet.

The Linear Algebra Menu

Linear AlgebraCreate Matrix

Opens the matrix creation assistant dialog.

Linear AlgebraCompute Eigenvalues

Opens the matrix name input assistant dialog to compute its eigenvalues and dimensions of the multiplicities of the eigenvalues in the corresponding order.

Linear AlgebraCompute Eigenvectors

Opens the matrix name input assistant dialog to compute its eigenvalues, dimensions of the multiplicities of the eigenvalues and eigenvectors in the corresponding order.

Linear AlgebraInvert Matrix

Opens the matrix name input assistant dialog to find the inverse of the matrix.

The Calculate Menu

CalculateDifferentiate

Opens the differentiation parameters dialog.

CalculateIntegrate

Opens the integration parameters dialog.

CalculateSolve equations

Opens the parameters input dialog to solve linear and non-linear equations.

The Package Menu

PackageImport Package

Opens the package import dialog.

The Plot Menu

PlotPlot

Opens the plot parameters dialog.

PlotPlot 2D

Opens the plot parameters dialog.

PlotPlot 3D

Opens the plot parameters dialog.

The Settings and Help Menu

Cantor has the common KDE Settings and Help menu items, for more information read the sections about the Settings Menu and Help Menu of the KDE Fundamentals.