The JuK Handbook

Lauri Watts
Michael Pyne
Scott Wheeler
# Contents

1 Introduction 5

2 Using JuK 6
   2.1 The Song List ................................................................. 7
   2.2 JuK Playlists ................................................................. 8
   2.3 The JuK Tag Editor ......................................................... 10
      2.3.1 Editing the Tags in a Single File ............................... 10
      2.3.2 Editing the Tags in Multiple Files ............................... 11
   2.4 The Rename File dialog ................................................. 12
   2.5 The Tag Guesser Configuration dialog ............................... 13
   2.6 The Advanced Search dialog ........................................... 14

3 The JuK Toolbar 15
   3.1 The Main Toolbar ......................................................... 15
   3.2 The Search bar ............................................................ 16

4 Menu and Command Reference 17
   4.1 Menus ................................................................. 17
      4.1.1 File Menu .......................................................... 17
      4.1.2 Edit Menu .......................................................... 18
      4.1.3 View Menu .......................................................... 19
      4.1.4 Player Menu ........................................................ 19
      4.1.5 Tagger Menu ....................................................... 20
      4.1.6 Settings Menu ...................................................... 20
   4.2 Keybinding Reference .................................................. 21

5 Credits and License 22
Abstract

JuK is a jukebox, tagger and music collection manager.
Chapter 1

Introduction

JuK is, well, a jukebox. As is typical with many jukebox applications, JuK allows you to edit the ‘tags’ of your audio files, and manage your collection and playlists.
JuK Handbook

Chapter 2

Using JuK

JuK maintains a list of all files that it knows about. This is called the Collection List. The collection list is specific to JuK and is not shared with other applications.

Independent of the Collection List, are playlists. You can have as many playlists as you want. You can use JuK created playlists with other media players (such as Amarok or xmms) and you can manage playlists created in those applications from within JuK.

You can add files to the Collection List individually, using File → Open ... and selecting them from a standard KDE file dialog. You can add entire folders using File → Manage Folders.... Folders added this way will be rescanned every time you start JuK. You can even define folders inside these folders that will be excluded from scan. You can force the folders to be rescanned by right-clicking on the Collection List icon, and selecting Reload.

Adding a song to a playlist will automatically add its file to the Collection List, but adding a file to the Collection List won’t automatically add the song to any playlists.

You can quickly create a playlist from your entire Collection List, by right mouse button clicking on the Collection List icon, and choosing Duplicate. The resulting playlist is a normal playlist, and editing it will not affect the Collection List.
You can add playlist files created outside JuK individually by selecting them with File → Open ...
Any playlist files found in folders you add with File → Manage Folders... will also be added automatically.

You can create a new empty playlist, a search playlist or a playlist from a folder by choosing File → New or the New icon on the toolbar. You will be prompted for a name, and then an icon for that playlist will appear in the playlist pane. You can now drag and drop files from the Collection List, or from other playlists, to your playlist. Use the Save icon or File → Save to save the playlist at any time.

2.1 The Song List

When you are viewing the Collection List, the main pane contains all the files that JuK knows about. When you are viewing a playlist, only the songs that are in that playlist are shown. In either case, the appearance and behavior of the list is the same.

Each song takes one row in the display. There is a column for each metadata field that JuK tracks. These columns correspond to the fields available to edit in the tag editor.

You can reorder the list at any time by left mouse button clicking on the column header. This will first sort the files in ascending order based on the contents of that column. If you left mouse button click again on the same header, the files will be re-sorted in descending order.

The columns are initially sized wide enough to show the longest entry available. You can resize the columns by placing your mouse cursor on the divider between two columns. When the cursor changes from a pointer, left mouse button click and drag in the direction you want to resize the columns.

You can reorder the columns by left mouse button clicking on a header and dragging the header to the left or right. You cannot drag past the edge of the window when doing this however, so you may need to scroll a little to the left or right, and repeat dragging the header, until you have placed it in your preferred position.

You can hide or unhide columns by right mouse button clicking on a column header, and clicking on the name of the column to change.

left mouse button double clicking on a file will play it with the built-in player. If another song was already playing, it will stop, and the new song will play.

right mouse button clicking on a file offers you several options:

Add to Play Queue

This will start playing the file as soon as the current song is over. If no song is playing, the file will be played when you next hit the Play button. If you have already chosen the Add to Play Queue option on a different file, then this file will override that selection.

Cut, Copy, Paste ...

Remove from Playlist

If you are viewing the Collection List, choosing this action will remove the file from the list, and will also remove all corresponding entries for this song from all playlists. You should note that if this file is in a folder that JuK scans on startup, it will be readded to the Collection List the next time you start up JuK but it won’t be automatically added to any playlists.

If you are viewing a playlist, Remove from Playlist will simply remove the song from the playlist.
The JuK Handbook

Edit Column Title
Will allow you to edit the currently highlighted song, in the column you clicked in. For example, if you do not have the tag editor visible, and you are busy creating a playlist, but you notice a mis-spelling in an artist name, you can edit it directly with this menu item. Changes made in this manner are always saved immediately as soon as you click elsewhere and are finished editing.
This menu item will be disabled if JuK detects that the track you have selected is read-only.

Refresh
This will reload the tag information of the selected files, in case the files have been changed while JuK was running.

Delete
This will remove the file from the Collection List, remove all entries for the song in all playlists, and delete the file from your disk. You cannot undo this, although you will be asked to confirm your choice. Use this with caution.

Guess Tag Information
This will make JuK try to guess information such as the Artist and Title of a song. JuK employs different methods of guessing:

From File Name
JuK will try to guess the tags of the song based on its filename. For example, a song name such as Roxette - You’ve Got the Look.mp3 would guess Roxette for the artist and You’ve Got the Look as the title. You can adjust the way JuK guesses for tags by selecting Settings → Tag Guesser..., which will open the Tag Guesser dialog. JuK will not replace tags that it did not guess from the file name.

From Internet
JuK will try to guess the tags of the song by using the MusicBrainz program. You must have MusicBrainz installed for this command to work.

Rename File
This will rename the selected files to conform to a given format. You must choose the way you want the files renamed first by selecting Settings → File Renamer... The resulting name of each file is based on its metadata tags. For example, the Ogg Vorbis song ‘The Theme (Metroid)’ by Stemağı could result in /usr/share/music/Stemağı/The Theme (Metroid).ogg.

Create Playlist From Selected Items
This allows you to quickly create a playlist from songs in your Collection List. This function will prompt you for a name for the new playlist, and will then insert all of the songs that are selected into the new playlist.

Add Selected Items to Audio or Data CD
This allows you to quickly create a K3b CD-burning project from your selected songs. JuK will ask you if you would like an Audio CD project or a Data CD project, unless K3b already has a project open.
If K3b is not already running, JuK will start it up for you. After that, JuK will add your selected files to the current K3b project. You can then save the project in K3b for burning later, or burn the CD right away.

2.2 JuK Playlists

A playlist is simply a collection of songs grouped by some category. For example, you may have a playlist of songs that you listen to while coding, while trying to sleep, or even when you need a laugh. JuK supports several different types of playlists.
Normal playlists

This is the most common kind of playlist. It is a playlist composed of files, just like the Collection List.

The history playlist

If you enable this playlist (by enabling View → Show History, this playlist will record every song that JuK plays. The playlist will have an extra column, Time, which records the exact time and date the song played. The playlist doesn’t start tracking the history until it is enabled, however.

Search playlists

This is a playlist which is based off of a search. You can create a playlist like this by clicking File → New → Search Playlist, or by clicking on the Search Playlist button on the toolbar.

After creating this playlist, it will keep track of which songs in the Collection List match your criteria, and automatically update itself accordingly whenever the Collection List changes.

Playlists are organized in the Playlist pane, which is the vertical bar at the left. In this pane is an icon for every playlist you have. There are different view mode for this pane, which can be selected from the View → View Modes menu.

Default View mode

This is the default view mode. In this mode, all the playlists are shown as large icons, one above the other in the view mode.

Compact View mode

This mode is similar to the Normal View mode, with the exception that the playlists are represented with horizontal bars with small icons instead of with square boxes.

Tree View mode

This mode is the most powerful. This mode is just like the Compact view mode, except that the Collection List is now the root of a tree of virtual playlists. The Collection List has three children nodes, Artist, Album, and Genre. Each of these node has children representing all of the entries from that specific category. For example, if your Collection List contains music from 4 different artists, you would have 4 entries under the artist node.

One nifty feature of the tree view mode is something called drag-and-drop retagging. Simply select some files in the track list, and drag them onto one of the artist, album, or genre nodes under Collection List. The songs will automatically be retagged to match the item you dropped the tracks on. For example, if you drag a group of tracks onto a Genre called “Rock”, all of the tracks will be retagged will a Genre tag of Rock.
2.3 The JuK Tag Editor

For many file formats, it is practical to use the filename to describe the contents of the file: 'Report for the board - June 2003.doc' for example, may be all the information you need in order to find that file again. Trying to capture all the useful information about a particular song however, could lead to filenames like this: 'Type O Negative - The Glorious Liberation Of The Peoples Technocratic Republic Of Vinnland By The Combined Forces Of The United Territories Of Europa.mp3' or 'Various Artists_15_The Smithsonian Collection of Classic Jazz Volume II_Jimmie Lunceford & His Orchestra - Organ Grinder’s Swing.mp3'. These are neither very practical to use, nor do they contain all of the useful information that you might have collected about the song. Adding the album, and track number, for example, to the first would make it even longer and more unmanageable, while still not telling you at a glance the year it was released, or what style of music it is, if you’re not familiar with the artist.

The solution then, is to store this kind of metadata inside the files themselves. Mp3 and ogg files can also contain small snippets of text which you can use to describe the content of the file. There are several formats, but JuK hides the details of the differences between them, and provides a standard way to edit a standard subset of well known tags for all your audio files.

JuK’s full featured tag editor allows you to edit the tags in both mp3 and ogg files. You can edit single files or multiple files, and you can select a mix of mp3 and ogg files to edit. The only requirement is that you have write access to the files themselves; you cannot edit the tags of a file that is mounted from a CD-ROM for example.

2.3.1 Editing the Tags in a Single File

To edit the tag in a single file, select it in either the collection list or any entries it has in any playlist. If the tag editor is not visible, enable it by choosing View → Show Tag Editor. The tag editor displays in the bottom of the list view.

Simply type into any of the editable fields to change the information. When you are done, left mouse button click back in the list, and you will be prompted to save your changes.

You may find that the tag editor remains disabled when you’ve clicked on a file. This happens when JuK has detected that the track is read-only.

TAG EDITOR FIELDS

**Artist Name:**

The name of the Artist(s) who released the song.

**Track Name:**

The name of the song.

**Album Name:**

The name of the album the song was released on.

**Genre:**

The ‘Style’ of the music. JuK provides a list corresponding roughly to the informal id3 standard, but you are free to type your own entries in this list.

**File Name:**

The file name of the actual file on disk. You can edit this directly, and when you save, the file will be renamed.

**Track:**

The position of the track on the original recording.

**Year:**

The year the song was released.
Length:
   This is not editable, it is simply shown for information.

Bitrate:
   This is not editable, it is simply shown for information.

Comment:
   You can add your own free text comment here, with additional notes etc.

You can explicitly and immediately save your changes at any time using the **Tagger → Save** menu entry or by pressing **Ctrl+T**.

### 2.3.2 Editing the Tags in Multiple Files

You can select multiple files in the list view, and edit one or more fields in the tags for all files at once.

Use **Shift** and the left mouse button to select a contiguous list of files, and **Ctrl** and left mouse button to select individual non-contiguous files.

If the tag editor is not visible, you can enable it by choosing **View → Show Tag Editor**. The tag editor displays in the bottom of the list view.

The tag editor behaves slightly differently when you have selected multiple files.

Each field in the tag editor will now show an **Enable** check box next to it. Any field that has exactly the same contents for all the files you selected, displays that content, and is enabled for editing, with the **Enable** check box checked.

Any field that does not have matching contents in all selected files is not initially editable, and does not display any contents at all.

To change the content of any field, check the **Enable** check box if it is not already checked, and edit the field as you normally would.

When you are done, left mouse button click back in the list view and you will be prompted to save your changes. The prompt dialog will show you a list of the affected files, so you have a chance to check that you are indeed altering the files you intended to.

You can explicitly and immediately save your changes at any time using the **Tagger → Save** menu entry or by pressing **Ctrl+T**.
The JuK Handbook

2.4 The Rename File dialog

The File Renamer Configuration dialog box is used to configure the Rename File action, which renames a song’s based on the information contained within its metadata tags.

The whole Rename File feature is used to get consistent file names for your music collection (including moving the files if necessary). For example you may have some songs which appear on disk as `01 - Title.mp3` if you got them from Amazon, while songs from OCRemix might be `Ailsean- Mega_Man_3_Mega_Fire_(OC_Remix).mp3` or something along those lines.

Using the file renamer allows JuK to rename those songs to something ‘sane’ on-disk, such as `Ailsean - Mega Fire.mp3` and `The Strokes - Reptilia.mp3`. You can even include paths throughout to automatically sort the music (e.g. by year or album), like `$HOME/Music/2003/The Strokes - Reptilia.mp3`.

Doing this is as simple as activating the ‘Rename File’ action, either from the Tagger menu, or right-clicking on the files. The default is the Ctrl-R shortcut. But before this is done you should setup how the files are to be renamed.

That is done from the above mentioned dialog that can be opened with Settings → File Renamer... menu item. You can define a destination path, by using a base music folder and then adding pieces to there. These path pieces would be based on the music metadata such as song title, artist, etc., and are added using the Add Category selector.

Each “path piece” has a check box between it allowing a folder separator to be added.

The options for each piece, which simply control what happens if the appropriate metadata is empty, and allow a prefix/suffix when the entry is substituted in, can help you to make the renaming procedure more effective.
The Tag Guesser Configuration dialog is used to configure the Guess from File Name action.

In the dialog you will see a list on the left of different filename scheme patterns. JuK includes an extensive set of defaults patterns to match most common filenaming styles. If you’d like to add a new scheme, click on the Add button, and type in your scheme and click on OK.

Here you can see the currently configured file name schemes which the tag editor uses to extract tag information from a file name. Each string may contain one of the following placeholders:

- %t: Title
- %A: Album
- %a: Artist
- %T: Track
- %c: Comment

For example, the file name scheme ‘[%T] %a - %t’ would match ‘[01] Deep Purple - Smoke on the water’ but not ‘(Deep Purple) Smoke on the water’. For that second name, you would use the scheme ‘(%a) %t’.

JuK will try the schemes you have listed one at a time, starting at the top of the list. The first scheme which results in a match will be the scheme used to guess the song’s tags. Some songs may match more than one scheme. You can make sure that the correct scheme matches first by selecting the scheme in the list box and then using the arrow buttons to move it to the top of the list.

You can also edit or remove a scheme from the list. Just select the scheme in the list, and use the Modify button to change the scheme, or the Remove button to remove the scheme from the list.
2.6 The Advanced Search dialog

The Advanced Search dialog is used to create Search Playlists. It allows you to make a fine-grained search among the different tags of your song collection.

At the top of the dialog, you can type in the name of your search playlist. Then, you can define your search criteria in the Search Criteria group.

The top of the Search Criteria group has two radio buttons, Match any of the following and Match all of the following. If you select Match any of the following, then a match by any of the conditions you define will include the song in the playlist. Otherwise, every condition you define must match in order to include the song in the playlist.

Below the radio buttons are the condition definitions. You can add more conditions by using the More button, and remove conditions by using the Fewer button. Any conditions you leave blank are ignored, so you do not have to use Fewer to eliminate empty conditions.

Every condition definition has three parts: The tag chooser list on the left, the matching style list on the right, and the search text in the middle. The tag chooser lets JuK know what tag you want to search for the text in. If you choose the special tag /hungarumlaut.ts1/All Visible/ /hungarumlaut.ts1/, then any tag that you can see in the Collection List listing is fair game to match the search text. If you choose the special tag "<All Visible>", then any tag that you can see in the Collection List listing is fair game to match the search text.

The match style list lets JuK know which search method to use. The search methods you can use are as follows:

**Normal Matching**
This is the default matching style. It searches for the given text anywhere in the chosen tag, ignoring case differences. For example a search for mode in the Artist tag would match Depeche Mode.

**Case Sensitive**
This search is just like Normal Matching, except that the search must match the exact case of the text.

**Pattern Matching**
This is the most powerful search method. The search text you type in will define a regular expression used to search within the tag. Regular expressions are beyond the scope of this documentation, but the application KRegExpEditor can help you form a regular expression. JuK uses the Qt™ regular expression style.

Simply choose the conditions you want to include in your search, and click OK to create your search playlist!
Chapter 3

The JuK Toolbar

3.1 The Main Toolbar

From left to right in the screenshot above, the icons on the default toolbar are:

New
Create a new playlist. If you hold down the button, a menu will pop up allowing you to select the different kinds of playlists to create.

Empty Playlist...
This prompts you for a playlist name, and then inserts it into the Playlist view. The playlist starts out completely empty.

Playlist From Folder...
This prompts you for a folder to open, and then creates a playlist containing the music within the folder and any sub-folders. The name of the created playlist is the same as the name of the selected folder.

Search Playlist...
This brings up the Advanced Search Dialog, allowing you to create a ‘virtual playlist’. Any songs in your Collection List that match the search criteria that you specify in the Advanced Search Dialog will be added to the new playlist. As your Collection List changes, the new playlist will as well. For example, if you create a playlist of all of your Depeche Mode songs, and then add another Depeche Mode song to your Collection List, it will show up in the Depeche Mode playlist with no special action required on your part.

Open
Add a file to the collection list (if it’s active) or to the currently selected playlist. Adding a file to a playlist will add it to the collection list automatically, but not vice versa.

Save
Save the currently selected playlist. To save a tag you have edited, either select another item, or press Ctrl+T instead.

Cut
If a playlist or song is selected, cut (remove) it from the list. If the tag editor is active, this works like cut in any editor, removing the selected text, but keeping a copy on the clipboard.
Copy
If the tag editor is active, this works like copy in any editor, placing a copy of the selected
text on the clipboard.
If you use copy on a song in the collection list, the url is placed on the clipboard, so you
can paste it. For example, you could paste the url into a text editor, Konqueror, or another
playlist.

Paste
If you previously either cut or copied a url from the collection list, you can paste the url back
into a new playlist. You could also paste a url you have copied from Konqueror or any other
application. If you are operating in the tag editor, paste will paste any text currently on the
clipboard into the selected field.

Show Search Bar
Show or hide the search bar.

Show Tag Editor
Show or hide the tag editor.

Play controls
These work like any standard media player you may have come across. The controls are
Play, Pause, Stop, Previous and Next.
There is also a tracking bar, showing how far along (relatively) in the current song you are.
You can drag this slider with the mouse in order to skip forwards or backwards within a
track.
Finally there is a volume slider. As you may expect, this raises and lowers the volume.
‘Loud’ is on the right, and ‘Quiet’ is on the left.

3.2 The Search bar

The search bar allows you to quickly search for a song in the collection list or a playlist.
Simply typing text into the search bar will reduce the visible list of songs to those which contain
that text in any visible column. Pressing Enter will start playing the top match in the playlist
view.
Searching begins instantly when text is entered into the search field. Searching is incremental,
that is, as you type each character into the text field, the search is narrowed further. This is useful
to find a song where you only remember part of a name, for instance.
Chapter 4

Menu and Command Reference

4.1 Menus

4.1.1 File Menu

File → New → Empty Playlist... (Ctrl+N)
Create a new playlist

File → New → Search Playlist... (Ctrl+F)
Create a new search playlist.

File → New → Playlist From Folder... (Ctrl+D)
Create a new playlist, containing all music files in a folder and any sub-folders. Any music within playlists files that JuK recognizes will also be added.

File → Open... (Ctrl+O)
Select a file (or files) to add to the collection list. If you select a playlist file, every file in the playlist will be added.

File → Manage Folders...
This menu item opens the same window that is shown on a first JuK start
Select a folder (or folders) to add to the collection list. These folders will also be rescanned whenever JuK is started or File → Reload is chosen.
You can also select folders that should not be automatically searched (which would override the list of folders to scan on startup). This way you can avoid having to completely change up your music layout on-disk just to keep JuK from automatically grabbing songs you do not want or need managed from within JuK.
NOTE
If you want to remove files that are already in the collection list, you can enable the **File Name (full path)** column in a playlist and then use the search bar to find the offending path name, select and remove the files that are shown.

File → Rename...
Rename a playlist.

File → Duplicate...
Create a duplicate of the selected playlist, and prompt for a new name.

File → Reload
Reloads the tag information on every file in the selected playlist.

File → Remove
Remove the selected playlist.

File → Save (Ctrl+S)
Save the selected playlist.

File → Save As...
Save the selected playlist, with a different name.

### 4.1.2 Edit Menu

Edit → Clear
Removes the selected songs from the playlist.
4.1.3 View Menu

**View → Show Search Bar**
This is a toggle action that sets whether or not the Search Bar is shown.

**View → Show Tag Editor**
This is a toggle action that sets whether or not the Tag Editor is shown.

**View → Show History**
This is a toggle action that sets whether or not the History Playlist is shown.

**View → View Modes → Default**
Switches to Default View mode.

**View → View Modes → Compact**
Switches to Compact View mode.

**View → View Modes → Tree**
Switches to Tree View mode.

4.1.4 Player Menu

**Player → Random Play**
This is a toggle option which controls the Random Play setting. If Random Play is enabled, then JuK will randomly select a random song from the current playlist when the currently playing song is over.

**Player → Loop Playlist**
This is a toggle option which controls the Loop Playlist setting. If Loop Playlist is enabled, then JuK will start playing from the beginning when it has finished playing every song in the current playlist.

**Player → Play**
This command starts playing the currently selected song, or resumes playback of the song if it was paused.

**Player → Pause**
This command pauses the currently playing song. Use the Play command to restart playback.

**Player → Stop**
This command stops the playback of the currently playing song. You cannot resume playback from its current position after that.

**Player → Next**
This command skips to the next song to play in the playlist.

**Player → Previous**
This command plays the song that was playing before the currently playing song.
4.1.5 Tagger Menu

Tagger → Save (Ctrl+T)
This command saves any changes to the tags that you are editing. Normally, changes are not saved until you deselect the file you are editing.

Tagger → Delete
This command deletes the currently selected files from the Collection List and any playlists containing it, and then deletes the selected file from the disk.

Tagger → Refresh
This command allows you to refresh playlist tags after changing them.

Tagger → Guess Tag Information → From Filename (Ctrl+G)
This command tries to guess the tags of the selected files by scanning the filename. You can configure the patterns used for guessing by selecting Settings → Tag Guesser..., which opens the Tag Guesser Configuration dialog.

Tagger → Guess Tag Information → From Internet (Ctrl+I)
This command tries to guess the tags of the selected files by using the TunePimp library provided with MusicBrainz.

Tagger → Rename File (Ctrl+R)
This command allows you to rename a file or a group of files for the selected songs in the playlist. Before the real rename happens JuK will show a preview dialog where you can confirm or cancel the action. The files will be renamed according to the parameters defined using Rename File dialog.

4.1.6 Settings Menu

Settings → Toolbars Shown → Main / Play Toolbar
These commands show or hide the Main Toolbar and the Play Toolbar.

Settings → Dock in System Tray
This is a toggle option. If enabled, JuK will display an icon in your system tray. You can use the system tray icon to tell if JuK is playing, and control playback.

Settings → Stay in System Tray on Close
This is a toggle option. If enabled, JuK will remain running if you close the main window. The Dock in System Tray option must also be enabled. To quit JuK, use the File → Quit command from the main window, or the Quit command from the system tray's context menu.

If JuK is started up when it is set to dock in the system tray on startup a simple notification will be shown (as otherwise the user may wonder why JuK window did not open up). It is possible to remove this additional notification by going to Common Appearance and Behavior → Application and System Notifications in System Settings to manage JuK music player application notifications. Just uncheck Show a message in a popup item for JuK running in dock mode. More information on KDE notification settings can be found here.

Settings → Popup Track Announcement
This is a toggle option. If enabled, JuK will display an indicator whenever a song starts playing, with information on the artist and title, and with buttons allowing you to quickly switch to a different song. The Dock in System Tray option must also be enabled.
The JuK Handbook

Settings → Tag Guesser...
This command brings up the Tag Guesser Configuration dialog box, where you can alter the patterns used to guess tag information from filenames.

Settings → File Renamer...
This command brings up the File Renamer Configuration dialog box, where you can alter the way JuK renames files for you.

Additionally JuK has the common KDE Settings and Help menu items, for more information read the sections about the Settings Menu and Help Menu of the KDE Fundamentals.

4.2 Keybinding Reference

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+A</td>
<td>Select all</td>
</tr>
<tr>
<td>Ctrl+C</td>
<td>Copy</td>
</tr>
<tr>
<td>Ctrl+R</td>
<td>Rename file</td>
</tr>
<tr>
<td>Ctrl+I</td>
<td>Guess tags from the Internet.</td>
</tr>
<tr>
<td>Ctrl+G</td>
<td>Guess tags from the filename.</td>
</tr>
<tr>
<td>Ctrl+F</td>
<td>New search playlist.</td>
</tr>
<tr>
<td>Ctrl+N</td>
<td>New empty Playlist</td>
</tr>
<tr>
<td>Ctrl+D</td>
<td>New playlist from folder.</td>
</tr>
<tr>
<td>Ctrl+T</td>
<td>Save changes to edited tags.</td>
</tr>
</tbody>
</table>
Chapter 5

Credits and License

JuK Copyright (c) 2002-2013 Scott Wheeler, Michael Pyne, and others.
JuK is developed and maintained by Scott Wheeler wheeler@kde.org and Michael Pyne michael.pyne@kdemail.net.

Many thanks to the following people who have contributed to JuK:

- Daniel Molkentin molkentin@kde.org for system tray docking, ‘inline’ tag editing, bug fixes, evangelism, moral support.
- Tim Jansen tim@tjansen.de for the GStreamer port
- Stefan Asserhäll stefan.asserhall@telia.com for global shortcut support.
- Stephen Douglas stephen_douglas@yahoo.com for track announcement popups.
- Frerich Raabe raabe@kde.org for automagical track data guessing, and bugfixes.
- Zack Rusin zack@kde.org for more automagical things, including MusicBrainz support.
- Adam Treat manyoso@yahoo.com for co-conspiring in MusicBrainz wizardry.
- Matthias Kretz kretz@kde.org for being the friendly neighborhood aRts guru.
- Maks Orlovich maksim@kde.org for making JuK friendlier to people with terabytes of music.
- Antonio Larrosa Jimenez larrosa@kde.org for the DCOP interface.
- Allan Sandfield Jensen kde@carewolf.com for the FLAC and MPC support.
- Nathan Toone nathan@toonetown.com for the Album cover manager.
- Pascal Klein 4pascal@tpg.com.au for the splash screen.
- Laurent Montel montel@kde.org for the porting to KDE 4 when no one else around.
- Georg Grabler georg@grabler.net for the KDE Platform porting efforts.
- Martin Sandmark martin.sandmark@kde.org for the Last.fm scrobbling support, lyrics, prepping for KDE Frameworks.
- Eike Hein hein@kde.org for the MPRIS2 interface implementation.

Documentation Copyright (c) 2003, Lauri Watts, and copyright (c) 2004-2013 Michael Pyne.
This documentation is licensed under the terms of the GNU Free Documentation License.
This program is licensed under the terms of the GNU General Public License.