Gwenview User Manual

Aurélien Gâteau
Christopher Martin
Henry de Valence
## Contents

1 Introduction .......................................................... 5  
1.1 What is Gwenview .................................................. 5

2 The Interface ............................................................ 6  
2.1 Start Page .......................................................... 6  
2.2 Image Operations .................................................. 6  
2.3 Browse Mode ........................................................ 7  
2.4 View Mode .......................................................... 8  
2.5 Full Screen Modes .................................................. 9  
2.5.1 Browse Mode Full Screen ........................................ 10  
2.5.2 View Mode Full Screen .......................................... 10  
2.6 Sidebar ............................................................... 11

3 Gwenview Importer ..................................................... 13  
3.1 Introduction ........................................................ 13  
3.1.1 Importing Images ............................................... 14  
3.1.2 Automatic Renaming .......................................... 14

4 Tips ................................................................. 15  
4.1 Using the mouse .................................................... 15  
4.1.1 Panning with the mouse ....................................... 15  
4.1.2 Zooming with the mouse ..................................... 15  
4.1.3 Browsing with the mouse .................................... 15
4.2 Key bindings ........................................................ 15

5 Configuring Gwenview ................................................. 17  
5.1 Configuration overview ........................................... 17  
5.2 General .............................................................. 17  
5.3 Image View ........................................................ 18  
5.4 Advanced .......................................................... 19  
5.5 Hidden Configuration Options ...................................... 19

6 Credits and Copyright .................................................. 20
Abstract

Gwenview is an image and video viewer.
Chapter 1

Introduction

1.1 What is Gwenview

Gwenview is a fast and easy to use image and video viewer.

Gwenview features two main modes: Browse and View. Both modes can be used in a normal application window and Full Screen. Browse Mode lets you navigate through your computer showing thumbnails of your images, View Mode lets you view images one at a time, and Full Screen lets you make quick slideshows. There is also a start screen that displays a list of recently opened folders and URLs as well as your places and tags.

Image loading is handled by the Qt™ library, so Gwenview supports all image formats your Qt™ installation supports. Gwenview correctly displays images with an alpha channel (transparency) as well as animations.

Gwenview supports the displaying and editing of EXIF comments in JPEG images. Lossless JPEG transforms such as rotations and mirroring are also supported.

Gwenview can read embedded color profiles from PNG and JPEG files. It can use the image color profile together with the display color profile to output correct colors on the screen.
Chapter 2

The Interface

2.1 Start Page

The start page lists recently opened folders and URLs on the left side, and your places and tags on the right side.

2.2 Image Operations

Gwenview has a few features which are available in both Browse, View, and Full Screen view. Gwenview has the capability to do basic alteration of your images.

- **Rotate**: A rotate operation will rotate the image either to the left or to the right, depending on whether you do Edit → Rotate Right (Ctrl+R) or Edit → Rotate Left (Ctrl+Shift+R).
- **Edit → Mirror**: This operation will reflect the image along the vertical axis, as if you were seeing it in a mirror.
• **Edit → Flip**: This operation will reflect the image upside-down (a reflection along the horizontal axis)
• **Edit → Resize (Shift+R)**: This operation will allow you to shrink or expand the image. Note that if you increase the size of an image, it may appear blurry and/or pixelated.

These actions are also available on the **Operations** tab of the sidebar.

If you have edited one or more images a bar with additional actions is displayed at the top of the image. You can undo or redo your changes, go to the previous or next modified image and there are three options to save the changed images.

<table>
<thead>
<tr>
<th>Current image modified</th>
<th>_undo</th>
<th>redo</th>
<th>Previous modified image</th>
<th>Next modified image</th>
<th>Save</th>
<th>Save As</th>
<th>Save All</th>
</tr>
</thead>
</table>

**Tip**
If you have installed the KIPI Plugins, a **Plugins** menu will be available that will allow you to perform many additional operations on your images.

### 2.3 Browse Mode

When in Browse Mode, you can easily navigate through your files and folders. The preview window shows thumbnails of the images in the current folder, as well as subfolders.

Moving the mouse over an image shows buttons to select or rotate the image as well as a button to enter Fullscreen Mode. Modified images are indicated by an icon down right, click it to save the changed image. Clicking on an image takes you into View Mode. You may select multiple images and switch to View Mode to view them side-by-side.

The slider at the bottom right allows you to change the size of the images. You can also filter the images by filename, date, tag or rating using the box on the lower left. The toolbar appears in both Browse mode as well as View mode and contains the most commonly used actions.
• **Start Page**: Open the start page.
• **Browse**: Switches to Browse Mode.
• **View**: Switches to View Mode.
• **Previous**: Clicking this icon will go to the previous image in the folder.
• **Next**: Clicking this button will go to the next image in the folder.
• **Show Editing Tools**: Clicking this button toggles the Operations sidebar tab.
• **Share**: Clicking this button opens an export menu to share your images through social media and image collection web services. This functionality depends on the list of installed KIPI plugins.
• **Full Screen**: Switches to Full Screen Mode.

## 2.4 View Mode

View Mode displays full-size images. The same sidebar available in Browse Mode is displayed on the left. At the bottom, there is the Thumbnail Bar, which allows you to scroll through the images in the current folder. The Thumbnail Bar can be unfolded by clicking on the **Thumbnail Bar** button. Clicking again will fold it. To change the size of the thumbnails move the splitter with the left mouse button.

View Mode supports viewing multiple images side-by-side. You may select multiple images in Browse Mode before switching to View Mode, or you may click the + button that appears when hovering over images in the Thumbnail Bar to add a pane displaying that image. A - will then appear that will permit you to remove its pane.

When multiple images are displayed, a small toolbar appears below each image that permits you to delete the image or remove its pane. You may perform zoom operations independently for each image, or synchronize them. Toggle this by checking the **Synchronize** to the left of the zoom slider or by pressing Ctrl+Y. You can switch images by clicking on their pane, or using your keyboard. To switch to the image on the right, press Tab. To switch to the image on the left, press Shift+Tab.
The slider at the bottom right controls the zoom of the image. The **Fit**, **Fill** and **100%** buttons are next to the zoom slider and are three preset zoom levels. The **Fit** button zooms the current image to fit the size of the window, the **Fill** button zooms the image to fill the window by fitting width or height and the **100%** button zooms the image to the actual pixel size. The shortcut **F** toggles between **Fit** mode and **100%**, pressing **Shift+F** will toggle **Fill** respectively.

When an image is in zoom-to-fit mode, you can go to the previous and next image with the arrow keys. When you zoom in, arrow keys are used to scroll the image. This is very similar to the behavior provided by phones or digital cameras.

When an image is zoomed in, a bird’s eye view appears and lets you scroll the image using the mouse and the arrow keys. The bird’s eye view automatically hides itself after a short delay, showing back only while zooming or scrolling. The bird’s eye view can be disabled from the right click context menu or from **View → Show Bird’s Eye View When Zoomed In**

You can define what happens when going to image B after having zoomed in on an area of image A using the options in the **Zoom mode** group on the **Image View** page of the Gwenview configuration window which can be reached using the **Settings → Configure Gwenview**.

- **If set to Auto-fit each image**, image B is zoomed out to fit the screen.
- **If set to Keep same zoom and position**, all images share the same zoom and position: image B is set to the same zoom parameters as image A (and if these are changed, image A will then be displayed with the updated zoom and position).
- **If set to Per image zoom and position**, all images remember their own zoom and position: image B is initially set to the same zoom parameters as image A, but will then remember its own zoom and position (if these are changed, image A will not be displayed with the updated zoom and position).

**Tip**

You can start directly in View mode by starting Gwenview from a context menu like **Open With** in another program or by launching it from the command line with an image as an argument.

The following additional image operations are available only in View Mode:

- **Edit → Crop (Shift+C)**: This operation lets you discard parts of the image you don’t want.
  
  You can access the advanced cropping parameters by ticking **Advanced settings** check box on the bottom popup pane. Use the corresponding fields to tune up the cropping operation.
  
  It is also possible to adjust the cropped area by dragging the gray square handles on the borders of the image. You can move the cropped area by clicking and holding the left mouse button and drag it with the mouse pointer.
  
  Press the **Crop** button to see the results when you are ready. Use the upper popup pane to save the results or undo/redo the operation.

- **Edit → Reduce Red Eye**: This operation reduces the “red eye” effect commonly found in photographs taken with a flash camera.

### 2.5 Full Screen Modes

Access Full Screen by pressing the **Full Screen** button on the toolbar, or by **View → Full Screen Mode (Ctrl+Shift+F)**.

To leave this mode press the **Esc** key.
2.5.1 Browse Mode Full Screen

In Browse Mode you can switch to fullscreen also by clicking on the button that appears when you move the mouse over the thumbnails.

Going fullscreen while browsing gives you a more immersive experience while you go through your pictures. It is quite nice on your regular computer, but makes even more sense when you connect your laptop to the big TV in the living room to show pictures to your guests.

2.5.2 View Mode Full Screen

The full screen View Mode shows a slideshow of your images. Access Full Screen Mode by clicking on the button that appears when you move the mouse over the thumbnails in Browse Mode, by pressing the Full Screen button on the taskbar.
The top bar will hide itself automatically; to show it simply move the mouse to the top of the screen. If the mouse cursor is over the top bar, it will not autohide. Most of the buttons on the bar are the same as the ones on the toolbar in Browse or View Modes, except for the Exit Full Screen Mode button which returns you to the Gwenview window, the Pause/Resume Slideshow button, and the Configure Full Screen Mode button which shows a small settings dialog that allows you to easily and quickly configure the slideshow. The slideshow controls there are:

- The **Interval** slider controls how long Gwenview will show an image before it move to the next one.
- If the **Loop** check box is checked, when the end of the slideshow is reached, it will continue from the beginning instead of stopping.
- If the **Random** check box is checked, instead of progressing through the folder alphabetically, images will be shown in random order.
- **Select Image Information to Display** allows you to define what metadata is displayed under the buttons on the toolbar.
- If the **Show thumbnails** check box is checked, thumbnails for all images in the current folder will be displayed to the right of the toolbar.
- The **Height** slider changes the size of the thumbnails displayed.

If enabled, an area that shows you the other images in the current folder will be shown on the top bar. Clicking on one will display it.

### 2.6 Sidebar

The sidebar on the left is available in the Browse and View modes, but does not appear by default in Browse Mode. Its appearance can be toggled using View → Sidebar (F4) or using the ← / → button at the left side of the statusbar. When clicked it collapses or expands the sidebar. The sidebar contains several tabs:
Gwenview User Manual

Folders
Displays a list of all folders on your system permitting you to switch between them. In Browse Mode thumbnails from the folder will be displayed, while in View Mode the first image in the folder will appear, from which you can browse through the folder using the Previous and Next buttons or shortcuts. Clicking on a folder multiple times toggles between View Mode and Browse Mode.

Information
Displays Meta Information like the filename and size. The More... link permits you to view all available metadata and select which data appear in the sidebar.

Operations
This permits you to perform the previously described global image operations as well as those specific to View Mode. It also permits common file operations like copying, renaming, deleting, and creating new folders.
Chapter 3

Gwenview Importer

3.1 Introduction

The Gwenview Importer allows you to import images from a digital camera or removable media. To launch it, select Download Photos with Gwenview in the KDE Device Notifier after connecting a supported device.

When you plug in a device the Gwenview importer recursively lists all images and videos. This is not always what you expect, e.g., plugging a smartphone you do not want to list all media of the device; but only the pictures you took, which are usually in a special subfolder.

It is possible to select the root folder to list, and Gwenview Importer will remember the last root folder for each device. This way, next time you plug a device in, only the relevant pictures and videos should be listed.
3.1.1 Importing Images

If you wish, you may select the images you want to import under **Select the documents to import** by pressing the + button that appears when hovering over an image. You may also select the folder that images are imported to in the text box at the bottom of the window. When you are done, click the **Import Selected** button to import only the images you have selected, or click **Import All** to import all images found on the device.

3.1.2 Automatic Renaming

Gwenview Importer can rename your files according to a specified pattern. To configure this, select the **Settings** in the lower left corner. You may turn this feature on or off using the check box at the top. The **Rename Format** supports several special parameters, which will be replaced by metadata such as the date the image was created or its filename. They are listed below the text box. You may either click on the parameter name to enter it into the text box or type one manually.
Chapter 4

Tips

4.1 Using the mouse

4.1.1 Panning with the mouse

- Holding down the left mouse button on an image allows you to scroll the image.
- The mouse wheel will scroll the image up and down.

4.1.2 Zooming with the mouse

- Clicking the middle mouse button will toggle the Fit zoom button. Hold down the Shift key and middle-click to toggle the Fill zoom button.
- Hold down the Ctrl key, then either use the mouse wheel to zoom in and out or left click to zoom in and right click to zoom out.
- The mouse wheel, used while holding down the Alt key, will scroll the image horizontally.

4.1.3 Browsing with the mouse

- When in Browse mode, clicking an image switches into View mode and shows that image.
- When in Browse mode, scrolling the mouse wheel will scroll up or down the thumbnail view area.
- If the Mouse wheel behavior option in Settings → Configure Gwenview is set to Browse, scrolling the mouse wheel while in View Mode will move you through the images in the folder.

4.2 Key bindings

Gwenview comes with a range of keyboard shortcuts, all of which can be viewed and remapped by selecting Settings → Configure Shortcuts. Note that in the Files and Folders windows, all the normal Plasma shortcuts are functional, unless otherwise remapped.

A few of the most useful default bindings are:

- Space: Displays the next image in the directory.
• **Backspace**: Displays the previous image in the directory.
• **Alt+Up**: Moves to the parent folder of the current folder.
• **Ctrl+Shift+F**: Switches into Full Screen Mode.
• **Esc**: Switches back to Browse Mode.
• **Ctrl+M**: Show or hide the menubar.
• **Ctrl+B**: Show or hide the Thumbnail bar.
• **F4**: Show or hide the Sidebar.
• **F6**: Make the Location bar editable so that you can directly type in a file path. You can return to the standard Location Bar by pressing the arrow at the right.
• **Ctrl+R**: Rotate the current image to the right.
• **Ctrl+Shift+R**: Rotate the current image to the left.
• **Shift+R**: Resize the current image.
• **Shift+C**: Crop the current image.
• **Ctrl+Y**: When multiple images are displayed in View Mode, this synchronizes their views.
• **Ctrl+S**: Save any changes made to the image.
• **Del**: Move the current image to the trash.
• **Shift+Del**: Permanently delete the image from the disk. Note that this operation is irreversible and cannot be undone.
• **Ctrl+P**: Print the current image.
• **Ctrl+O**: Open an image using the standard file selection dialog.
• **F**: Pressing this shortcut toggles zoom-to-fit on and off.
• **P**: Viewing a video this shortcut toggles playback on and off.
• **Ctrl+T**: Edit tags.
• **F2**: Rename an image inline.
• **Del**: Move an image to the trash.
• **Shift+Del**: Delete an image.
• **F7**: Copy an image.
• **F8**: Move an image.
• **F9**: Link an image.
Chapter 5

Configuring Gwenview

5.1 Configuration overview

You can configure Gwenview by choosing Settings → Configure Gwenview.... The configuration dialog is split into three sections. This chapter describes the available options in detail.

• General
• Image View
• Advanced

5.2 General

Videos

Check the Show videos checkbox to allow Gwenview to show videos among the images. Uncheck the Automatically play checkbox to disable autoplaying videos. This prevents video from automatically starting when browsing.

Notify after reaching the last image

Select the Never item to allow Gwenview looping through the list of images without additional notifications.
Select the Only during slideshows item if notifications about reaching the list end should be shown only in the slideshow mode.
Select the Always item if you want to receive the notifications unconditionally.

Background color

Move the slider to change the color of the gray background in Browse and View mode from black (the leftmost position) to white (the rightmost position).

Fullscreen background

• Black — Set the background color in fullscreen mode to black.
• Dark gray texture — Set the background in fullscreen mode to a dark gray texture.
Lossy image save quality

Save/compression quality setting for lossy image formats like JPEG, WEBP, AVIF, HEIF, and HEIC, which can be temporarily overridden in the Save As dialog when saving a file in a lossy image format. When saving an existing lossy image with a new name or after performing a non-lossy edit (e.g. rotation, which only changes the EXIF rotation tag), the appearance of the file is not changed because no actual image manipulation is done.

Thumbnail actions

Whether the thumbnail action buttons should be shown as overlays above image thumbnails.

- **All buttons** — Show all buttons
- **Show selection button only** — Show select/unselect button only
- **None** — Do not show any thumbnail button

5.3 Image View

Show transparency with

Choose how the background of transparent raster or SVG images is rendered.

- **Surrounding background** — Use background color from the General page.
- **Checkerboard background** — Use the traditional checkerboard background.
- **Solid color background** — Use a color that can be chosen using the color selector.

Mouse wheel behavior

Select how scrolling over an image in View mode behaves.

- **Scroll** — When zoomed in, pan the image vertically. Otherwise, nothing will happen.
- **Browse** — Switch to the next or the previous image.
- **Zoom** — Use mouse wheel to zoom in/out the current image.

Zoom mode

Allows choosing how zooming in View mode works.

- **Autofit each image** — Automatically resize images to the view pane.
- **Keep same zoom and position** — Use the same zoom level for all images.
- **Per image zoom and position** — Use individual zoom levels for each image.
- **Enlarge smaller images** — check this item to make Gwenview enlarge smaller images in View mode.

Animations

Allows choosing how fading between images is done in View mode.

- **OpenGL** — Use hardware accelerated animations.
- **Software** — Do not use hardware accelerated animations. Select this option if OpenGL does not work satisfactorily, but you still want to fade between images.
- **None** — Do not use animations when switching between images.

Thumbnail Bar

Allows configuring the thumbnail bar.

- **Orientation**
  - **Horizontal** — Show a horizontal thumbnail strip below the image.
  - **Vertical** — Show a vertical thumbnail strip to the right of the image.
- **Row count** — Use the spin box to change the number of rows on the thumbnail bar
5.4 Advanced

Thumbnails
Enable the **Low resource usage mode** option if you do not have a lot of disk space. This will avoid storing thumbnails on disk and will prefer embedded thumbnails of lower quality that are faster to load, if available.

Be careful: This will delete the folder named `thumbnails` in your `.cache` folder, removing all thumbnails previously generated by Gwenview and other applications.

History
Check the **Remember folders and URLs** to make Gwenview remember visited folders and URLs and show them on the **Recent Folders** pane.

Rendering intent
Allows choosing the **rendering intent** for showing images.

- **Perceptual** — scale all colors equally to fit them within the active color profile’s color gamut
- **Relative Colorimetric** — squash colors that don’t fit within the active color profile’s color gamut, leaving other colors untouched

Color profile
Allows choosing if you want to additionally apply the system-wide **color profile** to the color profile from the image file.

If the **Apply only the profile embedded in the image file** item is checked Gwenview assumes that the system-wide color correction already applies monitor profile.

5.5 Hidden Configuration Options

Some notes on hidden Gwenview options can be found on [this page](#).

**IMPORTANT**
The options described on the above-mentioned page may help you tune Gwenview for specific needs, but please keep in mind there is no warranty they will continue working from one version to another.
Chapter 6

Credits and Copyright

Gwenview is currently maintained by Aurélien Gâteau
This document was written by Christopher Martin
This document was updated for KDE 4 by Henry de Valence
This documentation is licensed under the terms of the GNU Free Documentation License.
This program is licensed under the terms of the GNU General Public License.