Chapter 3. Using Skrooge (beginner)

The main menu

Skrooge follows the standard KDE menu scheme. So it has many menu entries that are common for all KDE applications. More information on these menu entries can be found this help section.

Below, you can find descriptions for Skrooge-specific menu entries.

The File Menu

You can find in this menu all functions relative to the Skrooge document

  • Change password...: To change the password. Let the field empty to remove the password

  • Print...: To print the open pages

  • Print preview: To display the preview before printing

  • Import: To import data.

    • Import standard bookmarks: To import the standard bookmarks. They are created at the creation of a new document

    • Import categories: To import a set of predefined categories. This option depends of your country

    • Import: To import operation from files

    • Import with backend: To import operation with a backend

    • Import currency values...: To import currency values from files. Of course, the csv file must have the three columns (unit, date and amount).

    • Import rules...: To import Search and process rules to associate a category to a payee. Of course, the csv file must have the two columns (payee and category).

  • Export...: To export operations into a file

The Edit Menu

You can find in this menu all functions that can be used to modify selected objects

  • Undo: Cancel the previous modification done

  • Redo: Reapply the previous modification canceled

  • Revert document: Cancel the previous modifications done up to the last save

  • Delete: Delete the selected objects (operations, accounts, categories, ...)

  • Add property: Add a property regularly used on the selected objects

  • Select all: Select all lines of the table of the current page

  • Fast edit:: Facilitation the creation of new operations by filling fields automatically based on previous operations created

  • Find...: Open the Search and process page with a predefined filter corresponding to the selected objects

  • Switch highlight: Switch the highlight state of objects

  • Switch close: Switch the close state of objects

  • Reconcile...: Open the Operations page in reconciliation mode

  • Point: Point the selected operations

  • Group operations: Group the selected operations

  • Ungroup operations: Ungroup the selected operations

  • Duplicate: Duplicate the selected operation to create a new one from a previous one

  • Create template: Create a template from a selected operation

  • Apply template: Apply a template on selected operations

  • Merge sub operations: Merge selected operations in one split operation

  • Schedule: Schedule the selected operation

  • Validate imported operations: Validate all selected imported operations

  • Merge imported operations: Merge one imported operation with another operation entered manually. If amounts are different then a confirmation is requested

  • Split shares: Split selected shares

The View Menu

You can find in this menu all functions relative to pages

  • Enable editor: Activate the editor on the current page

  • New tab: Open a new tab

  • Reopen last closed page: Recover the last closed page

  • Close: Close the current page

  • Close All: Close all pages except pinned ones

  • Close All Other: Close all pages except the current one and the pinned ones

  • Pin this page: Set the current page pinned. This will avoid replacement by another one or closure

  • Reset page state: Reset the status of the current page

  • Save page state: Save the status of the current page

  • Overwrite bookmark state: Save the status of the current bookmarked page. The bookmark is updated with the new state

The Go Menu

You can find in this menu all functions relative to pages

  • Home: Close all pages and reopen all bookmarks autostarted like when the document is opened

  • Previous: Change the content of the current page with the content of the previous one. Like in a web browser

  • Next: Change the content of the current page with the content of the next one. Like in a web browser

  • Open highlights...: Open highlighted operations

  • Open last modified...: Open operations modified by the last action done

  • Open potential duplicates...: Open operations potentially duplicated

  • Open sub operations...: Open sub operations of the selected operation. Similar to a double click

  • Open report...: Open a report based on the selection. This is really useful. For example: if you select 2 accounts and launch this action then the report page will be opened but only for operations of those accounts

  • Open imported operations not yet validated...: nothing to add

  • Open operations without category...: Open all operations not having a category

  • Open transfers without category...: Open all transfers not having a category

  • Open operations without payee...: Open all operations not having a payee

  • Open transfers without payee...: Open all transfers not having a payee

  • Open operations without mode...: Open all operations not having a mode

  • Open operations with dates not aligned...: Open all single operations not having the date aligned with its sub operation

  • Open operations with comments not aligned...: Open all single operations not having the comment aligned with its sub operation

  • Open operations in groups with only one operation...: Open all single operations alone in a group

  • Open very old operations: nothing to add

The Tools Menu

  • Find and group transfers: Create potential transfers

  • Clean bank's import: Clean operations after imports

  • Anonymize: Anonymize your document to help debugging of Skrooge

  • Align comment of suboperations: Correct single operations having comments not aligned

  • Align date of suboperations: Correct single operations having dates not aligned

  • Remove groups with only one operation: Correct alone in a group

  • Delete unused payees: nothing to add

  • Delete unused categories: nothing to add

  • Delete unused units: nothing to add

  • Validate operations that do not require further action: Validate imported operations

  • Process budget rules: Recompute the budgets based on defined rules