The digiKam Handbook
The digiKam Handbook

2.2.3.2 How to Use IPTC Viewer ................................. 59
2.2.3.4 XMP Tags .................................................. 59
  2.2.3.4.1 What is XMP ........................................ 59
  2.2.3.4.2 How to Use XMP Viewer ......................... 59
2.2.4 Colors ....................................................... 59
  2.2.4.1 Histogram Viewer ...................................... 60
  2.2.4.2 How To Use an Histogram ......................... 61
2.2.5 Maps ......................................................... 63
2.2.6 Captions ..................................................... 64
  2.2.6.1 Introduction ........................................... 64
  2.2.6.2 Comment View ........................................ 65
  2.2.6.3 Date & Time .......................................... 65
  2.2.6.4 Rating ................................................. 66
  2.2.6.5 Tag Tree ................................................ 66
  2.2.6.6 Information View .................................... 66
2.2.7 Versions view .............................................. 66
2.2.8 Filters ....................................................... 68
2.2.9 Tools view .................................................. 69
  2.2.9.1 Sidebar Tools of the Image Editor .................. 69
2.3 The digiKam Light Table ...................................... 69
2.4 The digiKam Batch Queue Manager ......................... 70
  2.4.1 The Batch Queue Manager Window ..................... 70
  2.4.2 Batch RAW Workflow ................................... 70
    2.4.2.1 Introduction to Raw Converter .................... 70
    2.4.2.2 Using Raw Converter .............................. 71
2.5 The digiKam Tag Manager .................................. 71
  2.5.1 The Tag Manager Toolbar ............................... 72
  2.5.2 The Tag Manager Window ............................... 72
2.6 Digital Asset Management (DAM) with digiKam .......... 73
  2.6.1 Introduction to DAM .................................... 73
  2.6.2 Build a System to Organize and Find Your Photographs 74
    2.6.2.1 A case for doing DAM with digiKam .............. 74
    2.6.2.2 Build the archive: Folder organization, physical layout as information 74
    2.6.2.3 Automatic metadata generation .................... 75
    2.6.2.4 Rating/Ranking .................................... 76
    2.6.2.5 Tagging, Keyword assignment .................... 77
    2.6.2.6 Captions/Comments ................................ 78
    2.6.2.7 Geolocation (geo-tagging) ....................... 79
  2.6.3 Protect Your Authorship and Copyright ............... 80
    2.6.3.1 Digital Watermarking (DW) ....................... 81
2.6.4 Protect Your Images from Data Corruption and Loss

2.6.4.1 What are then the main factors of digital data loss? 81

2.6.4.2 Physical deterioration

2.6.4.2.1 CD, DVD, Blue Ray, optical drives 82

2.6.4.2.2 Hard disks (hard drives, HDD) 83

2.6.4.2.3 Power surges 83

2.6.4.2.4 How surges happen 83

2.6.4.2.5 Surge protectors 84

2.6.4.2.6 Uninterruptible power supply (UPS) 84

2.6.4.2.7 Solid state drives: USB sticks, memory cards, flash disks 84

2.6.4.2.8 Magnetic media 85

2.6.4.3 Saveguarding against logical errors

2.6.4.3.1 Web storage services 85

2.6.4.3.2 Transmission Errors 85

2.6.4.3.3 ‘Oracle’ or ‘Rising Sun’ at the file system horizon? 86

2.6.4.4 Human errors

2.6.4.4.1 Theft and accidents 87

2.6.4.4.2 Malware 87

2.6.4.4.3 Panic is a factor in data loss 87

2.6.4.5 Common myths dispelled 87

2.6.4.6 Make your budget: Data size, required storage volume estimation 88

2.6.4.7 Back it up, backup, backup, recover!

2.6.4.7.1 Disaster prevention 88

2.6.4.7.2 Some backup technicalities explained for laymen 88

2.6.4.7.3 Best practice: The IT-layman’s backup cookbook 89

2.6.4.7.4 A useful rsync recipe to backups 89

2.6.4.8 Preserve your images through the changes of technology and owners

2.6.4.8.1 How to keep up with technology? 90

2.6.4.8.2 Scalability 90

2.6.4.8.3 Use open, non-proprietary standards as file formats 90

2.6.4.9 Best practice: Data protection 92

2.6.5 A Typical DAM Workflow 93

2.7 Face tagging with digiKam 94

2.8 Using a Digital Camera With digiKam 95

2.8.1 Introduction to the Import Interface 95

2.8.2 Basic Import Interface Operations 95

2.8.2.1 Getting information about the photographs 96

2.8.2.2 Geolocation Tab 96

2.8.2.3 Downloading photographs to your computer 96
2.8.2.4 Uploading Photographs to your camera .................................. 97
2.8.2.5 Deleting photographs from the camera .................................... 97
2.8.3 Advanced Import Interface Operations ...................................... 98
  2.8.3.1 File Renaming Options ...................................................... 98
  2.8.3.2 Auto-Creation of Albums .................................................. 100
  2.8.3.3 On the Fly Operations ...................................................... 101
  2.8.3.4 DNG Convert Options ...................................................... 102
  2.8.3.5 Scripting ................................................................. 102
2.8.3.5 Scripting ................................................................. 102
2.9 digiKam Configuration .............................................................. 102
  2.9.1 Introduction ................................................................. 102
  2.9.2 Database Settings ............................................................ 103
    2.9.2.1 The Sqlite Database .................................................. 103
    2.9.2.2 The MySQL Database ............................................... 104
      2.9.2.2.1 MySQL Versus SQLite ......................................... 104
      2.9.2.2.2 The MySQL Internal Server ................................ 105
      2.9.2.2.3 The MySQL Remote Server ................................ 105
    2.9.2.3 Database Migration .................................................. 107
    2.9.2.4 Database Backup Recommendation .................................. 107
    2.9.2.5 Database Statistics .................................................. 108
  2.9.3 Collections Settings ......................................................... 108
  2.9.4 Views Settings ............................................................... 109
    2.9.4.1 Icon Settings ........................................................ 109
    2.9.4.2 Tree View Settings .................................................. 110
    2.9.4.3 Preview Settings ..................................................... 111
    2.9.4.4 Full-Screen Settings ................................................ 112
    2.9.4.5 Mime Types Settings ............................................... 112
    2.9.4.6 Album Categories Settings ......................................... 113
  2.9.5 Tooltip Settings ............................................................. 113
  2.9.6 Metadata Settings ........................................................... 114
    2.9.6.1 Introduction .......................................................... 114
    2.9.6.2 Behavior Settings ................................................... 114
    2.9.6.3 Sidecars Settings .................................................... 115
    2.9.6.4 Rotation Settings .................................................... 116
      2.9.6.4.1 Rotate Actions .................................................. 116
    2.9.6.5 Views Settings ........................................................ 117
    2.9.6.6 Advanced Settings .................................................. 117
  2.9.7 Templates Settings ........................................................... 117
  2.9.8 Image Editor Settings ....................................................... 121
    2.9.8.1 Editor Window Settings ............................................. 121
    2.9.8.2 Save Image Options .................................................. 122
The digiKam Handbook

2.9.8.3 Image Versioning Settings ........................................ 122
2.9.8.4 RAW Decoding Settings ....................................... 123
2.9.8.5 RAW Default Settings ......................................... 124
2.9.9 Color Management Settings ...................................... 126
2.9.10 Light Table Settings ............................................. 128
2.9.11 Slide-Show Settings .............................................. 129
2.9.12 Image Quality Settings .......................................... 129
2.9.13 Camera Settings ..................................................... 130
2.9.14 Miscellaneous Settings ........................................... 134
  2.9.14.1 General Settings ............................................. 134
  2.9.14.2 Application Behavior Settings ................................ 134
2.9.15 The Theme Setup .................................................. 135
2.9.16 Configure Shortcuts .............................................. 135
  2.9.16.1 Rating assignment ........................................... 135
  2.9.16.2 Pick label assignment ....................................... 135
  2.9.16.3 Color label assignment ...................................... 135
  2.9.16.4 Zooming ....................................................... 136
  2.9.16.5 General shortcuts ........................................... 136

3 The Image Editor .......................................................... 137
  3.1 Introduction to Image Editor ....................................... 137
    3.1.1 The Image Editor Window .................................... 137
    3.1.2 Restoring Your Original Photograph .......................... 138
    3.1.3 Undoing/Redoing Actions ..................................... 138
    3.1.4 Moving Between Photographs .................................. 139
    3.1.5 Changing the View ............................................ 139
    3.1.6 Printing Images ................................................ 139
  3.2 Photographic Editing - Workflow .................................. 139
    3.2.1 Image Editing/Workflow Tools ................................ 139
      3.2.1.1 A Standard Workflow Proposal ........................ 139
      3.2.1.2 Introduction to common editing tools features .... 140
      3.2.1.3 The digiKam tool set ................................ 141
    3.2.2 Processing RAW image files, RAW workflow .................. 142
    3.2.3 Color editing tools ......................................... 142
      3.2.3.1 Encoding Depth ........................................ 142
      3.2.3.2 Color Management ...................................... 143
      3.2.3.3 Introduction ........................................... 143
      3.2.3.4 Black and White Conversion Filters .................... 145
        3.2.3.4.1 The Legacy Black and White Films Emulation .... 145
        3.2.3.4.2 Simulate Infrared Film ........................... 149
3.2.3.5 Correcting Colors ......................................................... 150
3.2.3.6 Introduction ................................................................. 152
   3.2.3.6.1 Using Adjust Curves .............................................. 153
   3.2.3.6.2 The Adjust Curves in action .................................. 154
3.2.3.7 Introduction ................................................................. 155
   3.2.3.7.1 Using the Adjust Levels tool .................................. 156
   3.2.3.7.2 The Adjust Levels tool in action ............................ 157
3.2.3.8 Correcting Exposure ...................................................... 158
3.2.3.9 Introduction ................................................................. 159
   3.2.3.9.1 Using the Channel Mixer ....................................... 159
   3.2.3.9.2 The channel mixer in action .................................. 160
3.2.3.10 Introduction ............................................................... 160
   3.2.3.10.1 Using the Whitebalance Tool ................................. 161
3.2.3.11 Color Negative Tool ................................................... 163
3.2.4 Image Enhancement .......................................................... 163
3.2.4.1 Introduction ................................................................. 163
   3.2.4.1.1 Using the lens distortion tool ................................ 163
   3.2.4.1.2 The lens distortion tool in action ............................ 165
3.2.4.2 Introduction ................................................................. 165
   3.2.4.2.1 Create the Black Frames ....................................... 166
   3.2.4.2.2 Using the hotpixel tool ....................................... 166
   3.2.4.2.3 The hotpixels tool in action .................................. 167
3.2.4.3 Improve Photos exposure with Local Contrast Tool ................ 167
3.2.4.4 Introduction ................................................................. 168
   3.2.4.4.1 Using the Noisereduction Tool ................................. 169
   3.2.4.4.2 Noisereduction in action ..................................... 170
3.2.4.5 Softening a Photograph .................................................. 171
3.2.4.6 Introduction ................................................................. 172
   3.2.4.6.1 Using the Restoration tool ..................................... 172
   3.2.4.6.2 The Restoration tool in action ............................... 174
3.2.4.7 Introduction ................................................................. 175
   3.2.4.7.1 Using the vignetting correction tool ......................... 176
   3.2.4.7.2 The vignetting correction tool in action ................... 177
3.2.4.8 Introduction ................................................................. 178
   3.2.4.8.1 Using the Inpainting tool ..................................... 179
   3.2.4.8.2 The Inpainting tool in action ............................... 180
3.2.4.9 Remove Red Eyes in a Photograph ................................... 181
3.2.4.10 Introduction ............................................................... 182
   3.2.4.10.1 Adjusting Sharpness .......................................... 182
   3.2.4.10.2 Unblurring a Photograph .................................... 182
   3.2.4.10.3 Reducing Graininess In a Photograph ....................... 183
The digiKam Handbook

3.2.4.10.4 Softening a Photograph ......................... 183
3.2.4.10.5 The Unsharp Masking Filter .................. 183
3.2.4.10.6 The Unsharp Mask in action .................. 184
3.2.4.10.7 Refocus a Photograph ......................... 185
3.2.4.10.8 Using the Refocus Tool ....................... 186
3.2.4.10.9 Refocus comparison with other techniques .... 187
3.2.4.11 Lens Auto Correction Tool ...................... 189

3.2.5 Image transformation tools ............................ 189
3.2.5.1 Cropping a Photograph ............................ 189
  3.2.5.1.1 Manual Crop .................................. 189
  3.2.5.1.2 Auto Crop ................................... 190
  3.2.5.1.3 Proportional Crop ............................. 190
  3.2.5.1.4 Composition Guide ............................ 192
3.2.5.2 Introduction ........................................ 196
  3.2.5.2.1 Free Rotation Tool ............................ 196
  3.2.5.2.2 Free Rotation action .......................... 197
3.2.5.3 Introduction ........................................ 197
  3.2.5.3.1 Using the Perspective Adjustment ............. 198
  3.2.5.3.2 The Perspective Adjustment in action ........ 198
3.2.5.4 Introduction ........................................ 199
  3.2.5.4.1 Resizing a Photograph ......................... 199
  3.2.5.4.2 Increasing image size (Restoration) .......... 200
  3.2.5.4.3 The blow-up tool in action .................... 201
3.2.5.5 The Liquid Rescale Tool .......................... 201
3.2.5.6 Rotating or Flipping a Photograph ................ 201
3.2.5.7 Introduction ........................................ 202
  3.2.5.7.1 Using the Sheartool ........................... 202
  3.2.5.7.2 The Sheartool in action ....................... 202
3.2.6 Adding decorative elements ............................ 203
3.2.6.1 Introduction ........................................ 203
  3.2.6.1.1 Using the Texture Tool ....................... 204
  3.2.6.1.2 The Texture tool in action .................... 204
3.2.6.2 Introduction ........................................ 205
  3.2.6.2.1 Using the Add-border tool ..................... 205
  3.2.6.2.2 The Add-border tool in action ................. 206
3.2.6.3 Introduction ........................................ 206
  3.2.6.3.1 Using the Insert Text tool ..................... 206
  3.2.6.3.2 The Insert Text tool in action ................. 206
3.2.7 Special Effects (Filters) ............................. 207
3.2.7.1 Introduction ........................................ 207
  3.2.7.1.1 Using the Blurfx ............................... 207
3.2.7.1.2 The Blurfx in action ........................................... 210
3.2.7.2 Introduction ....................................................... 211
  3.2.7.2.1 Using the Charcoal filter ................................. 211
  3.2.7.2.2 The Charcoal filter in action .......................... 211
3.2.7.3 Introduction ....................................................... 212
  3.2.7.3.1 The Solarization Effect .................................. 212
  3.2.7.3.2 The Vivid Effect (Velvia filter) ....................... 213
  3.2.7.3.3 The Neon Effect ........................................... 214
  3.2.7.3.4 The Edge Effect ........................................... 214
  3.2.7.3.5 The Lut3D Effect .......................................... 214
3.2.7.4 Introduction ....................................................... 214
  3.2.7.4.1 Using the filter ............................................ 214
  3.2.7.4.2 The Distortion filter in action ......................... 219
3.2.7.5 Introduction ....................................................... 219
  3.2.7.5.1 Using the Emboss filter ................................. 219
  3.2.7.5.2 The Emboss filter in action .......................... 219
3.2.7.6 Introduction ....................................................... 220
  3.2.7.6.1 Using the Filmgrain filter ............................. 220
  3.2.7.6.2 The filter in action ...................................... 220
3.2.7.7 Introduction ....................................................... 221
  3.2.7.7.1 Using the Oil Paint filter .............................. 221
  3.2.7.7.2 The Oil Paint filter in action ......................... 221
3.2.7.8 Introduction ....................................................... 222
  3.2.7.8.1 Using the Raindrops filter ............................. 222
  3.2.7.8.2 The Raindrops filter in action ......................... 223
3.3 RAW File Treatment and Color Management .......................... 223
  3.3.1 Introduction ....................................................... 223
    3.3.1.1 Which buttons do I push? ................................. 224
    3.3.1.2 Is there anyone who doesn’t need to worry about color management? .......................... 224
  3.3.2 More definitions about Color Management ....................... 224
  3.3.3 The Color Space Connections .................................... 226
    3.3.3.1 Where to find camera profiles .......................... 227
    3.3.3.2 Soft Proofing .............................................. 232
    3.3.3.3 Rendering intention ...................................... 232
    3.3.3.4 Links ..................................................... 232
  3.3.4 The Working Space ................................................ 232
    3.3.4.1 So I told digiKam where to find my monitor profile and I have a camera profile that I applied to the image file produced by my raw processing software. What’s the next step in color management? .......................... 232
    3.3.4.2 Why cannot I just edit my images in the color space described by the camera profile? .......................... 233
    3.3.4.3 Which working space should I choose? .......................... 233
3.3.4.4 What gamma should my working space have? ....................... 233
3.3.4.5 How many discrete tonal steps are there in a digital image? .... 234
3.3.4.6 Should I use a large-gamut or a small-gamut working space? .... 234
3.3.5 The sRGB color space .................................................. 235
3.3.5.1 What is so special about the sRGB color space? ................. 235
3.3.5.2 How small is sRGB? .................................................. 236
3.3.6 Calibrating and Profiling Your Monitor RGB ......................... 237
3.3.6.1 If I choose to work exclusively in the sRGB color space, do I need
to calibrate my monitor? ................................................. 237
3.3.6.2 What are the consequences of working with an uncalibrated mon-
titor? ................................................................................ 237
3.3.6.3 The meaning of “black point” and “brightness” seems pretty clear,
but what does “gamma” mean? .......................................... 238
3.3.6.4 What’s the difference between calibrating a monitor and profiling
a monitor? ........................................................................ 238
3.3.6.5 Can I calibrate my monitor without a spectrophotometer? .... 239
3.3.6.6 Assuming I’ve decided to work exclusively in the sRGB color
space, what “digiKam buttons” should I push after I calibrate my
monitor? ............................................................................ 239
3.3.6.7 Where are all the icc profiles are located on my computer? .... 240
3.3.6.8 Does the lighting and wall/ceiling/drape/furniture colors near
my monitor matter? ......................................................... 240
3.3.7 The Camera Profile and Raw File Development ....................... 240
3.3.7.1 What’s the next step in color management? ......................... 240
3.3.7.2 Why doesn’t the image produced by raw converters like dcraw
or ufraw look like the embedded preview displayed by digikam? 240
3.3.7.3 The embedded jpeg preview looks so much nicer than dcraw’s
output. What is the value in scene-referred tonality? ................ 241
3.3.7.4 I can see the value in starting my image-editing with a scene-
referred rendition instead of the eye-popping rendition that I see
in the embedded jpeg. But I’m telling you, the images produced
by digiKam/libraw look really really bad! Why? ....................... 241
3.3.7.5 Where do I find good information on digital noise? ............... 242
3.3.7.6 Why are the Canon and Nikon colors better than the colors pro-
duced by Libraw? .......................................................... 242
3.3.7.7 Why is a camera profile specific to a given make and model of
camera? ........................................................................... 242
3.3.7.8 What does “analog-to-digital conversion” mean? ................. 243
3.3.7.9 Why is a camera profile specific to the raw processing program
used to develop the raw file? ............................................. 243
3.3.7.10 Where do I find a generic profile for my camera? ............... 243
3.3.7.11 How do I get a camera profile specific to my camera, lighting
conditions, and raw workflow? ......................................... 244
3.3.7.12 How do I apply a camera profile to the 16-bit image file produced
by my open source raw processing software? ....................... 244
The digiKam Handbook

3.3.8 The Profiles Point to Real Colors in the Real World ........................................ 245
  3.3.8.1 Camera, scanner, working space, monitor, printer - what do all these color profiles really do? .................................................. 245
  3.3.8.2 How can a color profile point to a real color in the real world? .................. 245
3.3.9 Printer Profiles with Rendering Intents and Soft-Proofing .............................. 246
  3.3.9.1 Where do I get a printer profile? ....................................................... 246
  3.3.9.2 What about rendering intents? .......................................................... 246
  3.3.9.3 What rendering intent should I use for displaying images on my monitor? ................................................................. 247
  3.3.9.4 What is soft-proofing? ....................................................................... 247
  3.3.9.5 What rendering intent should I use when I soft-proof? ......................... 247
  3.3.9.6 And what about black point compensation? ........................................ 247
  3.3.9.7 Can all of the rendering intents be used when converting from one color space to another? ..................................................... 247
  3.3.9.8 Why does the perceptual rendering intent get recommended so often as the "photographic" rendering intent? .................. 248

4 Acquire Images Tool ............................................................................................................ 249
  4.1 Scanner Selection ........................................................................................................... 249
  4.2 Main Dialog .................................................................................................................. 250
  4.3 Scanning ........................................................................................................................ 251
  4.4 Scanning Multiple Selections ..................................................................................... 253
  4.5 Help and Close .............................................................................................................. 253

5 Geolocation .......................................................................................................................... 254
  5.1 Geolocation Editor ....................................................................................................... 255
    5.1.1 The map .............................................................................................................. 256
    5.1.2 Edit Coordinates ............................................................................................... 257
    5.1.3 The Correlator .................................................................................................... 257
    5.1.4 Undo/Redo ......................................................................................................... 259
    5.1.5 Reverse Geocoding ......................................................................................... 260
    5.1.6 Search ............................................................................................................... 262

6 Presentation Tool .................................................................................................................. 264
  6.1 The Settings Dialog ...................................................................................................... 264
  6.2 Presentation Tool in Action ....................................................................................... 265

7 Metadata Editor .................................................................................................................... 267

8 Panorama Tool ..................................................................................................................... 269

9 HTML Gallery ..................................................................................................................... 270
  9.1 Album Selection Dialog ............................................................................................ 270

10 Expoblending Tool .............................................................................................................. 275
11 Calendar Tool

12 Maintenance Tool
12.1 Introduction
12.2 The Maintenance Features
12.2.1 The Common Options
12.2.2 The Scan for New Items Tool
12.2.3 The Rebuild Thumbnails Tool
12.2.4 The Rebuild Fingerprint Tool
12.2.5 The Find Duplicates Tool
12.2.6 The Face Management Tool
12.2.7 The Image Quality Sorter Tool
12.2.8 The Metadata Synchronizer Tool

13 DLNA Mediaserver Tool
13.1 Starting The Server
13.2 The Configuration Panel
13.3 Important Notes

14 Print Wizard

15 Send Images Tool
15.1 Using the Module
15.1.1 Image Selection
15.1.2 Mail Settings
15.1.3 Email Images in Action

16 Flickr Export Tool
16.1 Tool initialization on first access
16.2 Regular Tool Usage

17 Piwigo Export Tool

18 KML Export Tool

19 Google Services Export Tool

20 Flash Export tool

21 DropBox Tool

22 FaceBook Tool

23 ImageShack Tool

24 ImgUr Tool
## List of Figures

<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.1</td>
<td>The Presentation Dialog</td>
<td>265</td>
</tr>
<tr>
<td>6.2</td>
<td>The Presentation Tool in Action</td>
<td>266</td>
</tr>
<tr>
<td>9.1</td>
<td>The Album Selection Dialog in digiKam</td>
<td>271</td>
</tr>
<tr>
<td>9.2</td>
<td>The Theme Selection Dialog</td>
<td>271</td>
</tr>
<tr>
<td>9.3</td>
<td>Parameters for Classic Theme</td>
<td>272</td>
</tr>
<tr>
<td>9.4</td>
<td>The Image Settings and Thumbnails Dialog</td>
<td>273</td>
</tr>
<tr>
<td>9.5</td>
<td>The Output Dialog</td>
<td>274</td>
</tr>
<tr>
<td>15.1</td>
<td>The Email Images Dialog</td>
<td>284</td>
</tr>
<tr>
<td>15.2</td>
<td>The E-mail Images Tool in Action</td>
<td>285</td>
</tr>
<tr>
<td>16.1</td>
<td>The First Sign Up Dialog Preview</td>
<td>286</td>
</tr>
<tr>
<td>16.2</td>
<td>The Successful Signup Flickr page</td>
<td>287</td>
</tr>
<tr>
<td>16.3</td>
<td>Current Permissions Dialog preview</td>
<td>287</td>
</tr>
<tr>
<td>16.4</td>
<td>The Main Uploading Dialog Preview</td>
<td>288</td>
</tr>
<tr>
<td>16.5</td>
<td>The Uploading Progress Dialog Preview</td>
<td>289</td>
</tr>
</tbody>
</table>
digiKam is a Photo Management Application with support for Digital Cameras.
Chapter 1

Introduction

1.1 Background

1.1.1 About digiKam

digiKam is an advanced digital photo management application for Linux, MacOS and Windows desktop. It provides a simple interface which makes importing and organizing digital photographs a "snap". digiKam enables you to manage large numbers of digital photographs in Albums and to organize these photographs for easy retrieval using tags (keywords), captions, collections, dates, geolocation and searches. It has many features for viewing, organizing, processing and sharing your images. Thus, digiKam is a formidable Digital Asset Management (DAM) software including powerful image editing functions.

An easy-to-use Camera interface is provided that will connect to your digital camera and download photographs directly into digiKam Albums. More than 1000 digital cameras are supported by the gphoto2 library. Of course, any media or card reader supported by your operating system will interface with digiKam.

digiKam incorporates a fast Image Editor with many image editing tools. You can use the Image Editor to view your photographs, comment and rate them, correct, enhance and alter them. The images post processing can be easily done by a set of tools though the Batch Queue Manager, or by many import and export tools dedicated to work with remote web services.
While digiKam remains easy to use, it provides professional level features by the dozens. It is fully 16 bit enabled including all available tools, supports RAW format conversion through libraw, DNG export and ICC color management work flow.

1.1.2 Reporting Bugs

digiKam is an Open Source project. This means that it relies on its users to play their part by, at least, reporting problems and suggesting possible improvements.

digiKam makes it as easy as possible for you to report bugs or suggest improvements. Wherever you are in the application the Help menu will include a Report Bugs option. This will display a message box with a highlighted link. Click on the link and your web browser will open the page for the reporting system. All the information required will already be filled in, just follow the instructions for completing your report.

1.1.3 Support

digiKam is a community supported project, which means that users and developers support one another. If you become a regular user of digiKam you are encouraged to join the digiKam Users Mailing List. You can start off by asking questions to other digiKam users and hopefully soon you will be answering the support questions of others.

digiKam Users Mailing List joining instructions.

You can also visit the digiKam Home Page for news of new releases and other digiKam related information.

1.1.4 Getting Involved

There are many ways that you can get involved with the continued development of digiKam. You do not need to be a software developer. You can help with documentation, translation and user interface design or just contribute really good ideas to the wish-list. You can also get involved by testing early development code as it is being developed and providing feedback to the
developers. Of course, if you are a software developer then you can help to make digiKam the best digital photograph application there is.

The best way to start getting involved with digiKam is to join the Developers Mailing List. digiKam Developer Mailing List joining instructions.

1.2 Getting Started

1.2.1

1.2.1.1 The First Run Dialog

When you start digiKam for the very first time, it will ask you where you store your photographs. You can choose any local, remote or removable folder. Just type in the path name of a folder or click on the Browse... icon to select a folder from the dialog.

Later on you can add as many locations as you like - digiKam will add them to the album library. Settings → Configure digiKam → Collections
Then you have to specify a local folder that resides on your computer, in which the database will be stored. This path will be the same for all image folders. For details about the database type selection have a look at The digiKam Database. If you have a local installation and a collection of less than 30,000 photographs you may well keep the default setting (SQLite).

Next, you will have to choose the way you would like to open RAW files: either with automatic adjustments or with the digiKam RAW import tool to adjust corrections manually.

If you don’t know what a RAW file is, or if your camera doesn’t support RAW files, you should keep the default setting and skip this step.
Metadata information storage may be important if you plan to work with another photo management program and you should choose Add information to files. But if you don’t want to alter your pictures, keep the default setting: Do nothing.

Then choose how digiKam will load images in preview mode and light table. Reduced version will load faster but at the cost of quality.
Now decide how digiKam will open images with a click of the right mouse button. Previews will load faster but you won’t be able to make any corrections.

Tooltips are a fast and easy way to display important information about a photograph; they popup as the mouse hovers over a thumbnail. Select “Use tooltips” if you want to display them.
Click on Finish. DigiKam will now start to scan for photographs...

Nothing really to select here. You can cancel or start the scan with Finish. None of the photographs will be altered. During folders parsing you can see a progress bar in the lower right corner like this:
As digiKam uses your folders on your hard disk directly, other applications like file managers can remove any albums outside a digiKam session. In this case digiKam will ask you at the next session whether all albums that have been removed from the digiKam photographs root path shall be deleted from albums database. If you want to move folders around and don’t want to do that in digiKam, we suggest you do that while digiKam is running, so the database will be kept in sync and you do not lose any metadata.

When you use an existing folder of photographs as the Album Library folder, you will notice that the Albums in the Album list do not have photographs as their icons. You can change that by dragging any photograph in the Album onto the folder icon in the left sidebar and use this as the Album icon. See the Album section for details of how to change the Album icon.

digiKam uses a dedicated database to store thumbnails with an optimized wavelets compression algorithm (PGF). There is no way of hiding non-standard thumbnail folders from the ‘Albums’ list. If you want to keep them you could create an Album Category that just contains all the thumbnail Folders and then view your Albums in View → Sort Albums → By Category order. See the Album section for more about Album Categories.

Once you have configured the Album Library Folder you can set up digiKam to work with your digital camera and then learn how to use Albums and Tags to arrange your photograph Albums.

1.3 Supported Image Formats

1.3.1 Introduction

digiKam relies on a number of libraries and support packages to load and save image formats. Which image formats are available will depend on the availability of these libraries on your system and, in some cases, on the way that those libraries have been compiled. On most distributions you will find that a wide range of image formats are viewable within digiKam.

This dependence on other libraries means that it is not possible to give a definitive list of all of the formats that will be available on your system. At the very least JPEG, PNG, and TIFF should be available.

digiKam only displays files that are in formats that it understands. It does this by looking at the file extension on the files and checking this against a predefined list. If the file extension is in the list digiKam will show the file in the Image View, provided the appropriate library is installed. You can change the list of file extensions that digiKam will accept; see the Configuration section for more details.

Almost all digital cameras store photographs in one of two formats: JPEG or TIFF. Many cameras enable you to select which of these formats to use. A full description of these formats can be found at the Wikipedia. digiKam supports both of these formats.
1.3.2 Still Image Compression

Image compression is the application of data compression schemes on digital images. It is done through reducing redundancy of the image data in order to be able to store or transmit data in an efficient form.

Image compression can be lossy or lossless. Lossless compression methods are always preferred for their high preservation value for archival purposes before applying transformations like cropping, resizing, color corrections, etc. This is because lossy compression methods, especially when used at low bit rates, introduce compression artifacts. Lossy methods are suitable for natural images such as photos in applications where minor (sometimes imperceptible) loss of fidelity is acceptable to achieve a substantial reduction in file size. Lossy compression is good for image publishing on the Internet.

1.3.3 JPEG

JPEG is a compressed format that trades some of the image quality to keep file sizes small. In fact, most cameras save their images in this format unless you specify otherwise. A JPEG image is stored using lossy compression, and you can vary the amount of compression. This allows you to choose between lower compression and higher image quality or greater compression and poorer quality. The only reason to choose higher compression is because it creates smaller files so you can store more images, and it's easier to send them by e-mail or post them on the Web. Most cameras give you two or three choices equivalent to good, better, best, although the names vary.

JPEG 2000 is supported as well. It provides for the same compression ratio with better (smoother) results compared to JPEG. The 2000 version has the option of being lossless if so specified in the settings.

1.3.4 TIFF

TIFF has been widely accepted and widely supported as an image format. Commonly, TIFF may be stored by the camera in uncompressed form or using a lossless compression algorithm (Deflate). It maintains higher image quality but at the expense of much larger file sizes. Some cameras let you save your images in this format, and it is a popular format because of its lossless compression algorithm. The problem is that the format has been altered by so many people that there are now 50 or more flavors and not all are recognizable by programs.

1.3.5 PNG

PNG is an image format that was developed as a replacement for a number of older, in the 1990’s widely used, image file formats. It is a lossless format like TIFF but it is much more compact and saves disk space. Although your camera is unlikely to support PNG, some people like to convert their photographs to PNG as soon as they get them on their computer. Unlike JPEG, PNG images do not lose quality every time you re-encode them after modification. digiKam fully supports PNG images and the Batch Queue Manager can convert a batch of images from any supported format to PNG (and other formats) in one step.

PNG is an extensible file format for the lossless, portable, well-compressed storage of raster images. PNG provides a patent-free replacement for GIF and can also replace many common uses of TIFF. PNG is designed to work well in on-line viewing applications, such as the World Wide Web, so it is fully streamable with a progressive display option. Also, PNG can store gamma and chromaticity data for improved color matching on heterogeneous platforms. PNG supports 8 and 16 bits / colors / pixels depth. It’s the perfect file format to archive your photographs. For more information about the PNG format see the PNG homepage.
1.3.6 PGF

“Progressive Graphics File” is another not so known but open file image format. Wavelet-based, it allows lossless and lossy data compression. PGF compares well with JPEG 2000 but it was developed for speed (compression/decompression) rather than to be the best at compression ratio. At the same file size a PGF file looks significantly better than a JPEG one, while remaining very good at progressive display too. Thus it should be well-suited to the web but at the moment few browsers can display it. For more information about the PGF format see the libPGF homepage.

1.3.7 RAW

Some, typically more expensive, cameras allow you to store images in RAW format. RAW format is not really an image standard at all. It is different for every make of camera. RAW format images contain all the data that is taken directly from the camera’s image sensor before the software in the camera applies things like white balance, sharpening etc. Storing photographs in a camera’s RAW format allows you to alter settings, such as white balance, after the photograph has been taken. Most professional photographers use RAW format, because it offers them maximum flexibility. The downside is that RAW image files can be very large indeed.

If you want to learn more about RAW image format visit the very helpful guides Wikipedia, The Luminous Landscape, and Cambridge in Colour. You can convert RAW format images into JPEG, PNG, or TIFF in digiKam using the Image Editor.

digiKam supports RAW image loading only, relying on the Libraw library which is included in digiKam core and supports over 800 RAW file formats. All supported cameras are listed at the bottom of Dave Coffin’s web page. The table below shows a short list of camera RAW files supported by digiKam:

<table>
<thead>
<tr>
<th>RAW File Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CRW, CR2</td>
<td>Canon digital camera RAW file formats</td>
</tr>
<tr>
<td>NEF</td>
<td>Nikon digital camera RAW file format</td>
</tr>
<tr>
<td>ORF</td>
<td>Olympus digital camera RAW file format</td>
</tr>
<tr>
<td>RAF</td>
<td>Fuji digital camera RAW file format</td>
</tr>
<tr>
<td>RWL</td>
<td>Leica camera RAW file format</td>
</tr>
<tr>
<td>PEF, PTX</td>
<td>Pentax digital camera RAW file format</td>
</tr>
<tr>
<td>X3F</td>
<td>Sigma digital camera RAW file format</td>
</tr>
<tr>
<td>DCR, KDC, DC2, K25</td>
<td>Kodak digital camera RAW file format</td>
</tr>
<tr>
<td>SRF, ARW, MRW, MDC</td>
<td>Sony/Minolta digital camera RAW file format</td>
</tr>
<tr>
<td>RAW</td>
<td>Panasonic, Casio, Leica digital camera RAW file format</td>
</tr>
<tr>
<td>DNG (CS1, HDR)</td>
<td>Adobe RAW file format (Digital Negative)</td>
</tr>
<tr>
<td>BAY</td>
<td>Casio RAW (Bayer)</td>
</tr>
<tr>
<td>ERF</td>
<td>Epson digital camera RAW file format</td>
</tr>
<tr>
<td>FFF</td>
<td>Imacon/Hasselblad RAW format</td>
</tr>
<tr>
<td>MOS</td>
<td>CREO Photo RAW</td>
</tr>
<tr>
<td>PXN</td>
<td>Fotoman RAW</td>
</tr>
<tr>
<td>RDC</td>
<td>Ricoh RAW format</td>
</tr>
</tbody>
</table>
1.4 Supported Movie Formats

1.4.1 Introduction

Many digital cameras support taking of short movie clips. These clips are usually stored in AVI, MOV, or MP4 format. digiKam understands metadata from these formats and will generate thumbnails for the movie files.

However, digiKam is not a movie editing application and it does not have any built-in movie editing capabilities. If you double click on a movie file digiKam you can preview video or choose a dedicated viewing / editing application through your desktop settings.

1.4.2 Video Formats

digiKam relies on QtAV Multimedia framework to handle video files. In background, QtAV use the powerful FFmpeg video toolkit, which include all codecs that digiKam needs to play video files.

FFmpeg codec is available under Linux® desktop, MacOS, and Windows. You don’t need to install extra video codecs on your computer.

1.4.3 Video Features

With digiKam, you will be able to read video metadata, such as movie length, video frames per second, video size, and encoding options, in order to populate the database at scanning and to perform searches on your collection about video properties. You will be able to play video in embedded preview mode, and in a slideshow. This includes previewing video from your camera device before downloading (only with USB Mass Storage connection mode).

1.5 Supported Digital Still Cameras

**NOTE**

RAW file support: if you are using RAW shooting mode with your camera, digiKam is probably well able to deal with it. RAW support depends on the libraw library. To find out if your particular camera is supported, bring up the list of supported RAW cameras from the Help → Supported RAW Cameras menu.

How to setup and work with RAW files is described in RAW Decoding Settings and RAW Workflow.

An easy-to-use camera interface is provided that will connect to your digital camera and download photographs directly into digiKam Albums. More than 1000 digital cameras are supported by the gphoto2 library. Of course, any media or card reader supported by your operating system will interface with digiKam.

Current digital cameras are characterized by the use of Compact Flash Memory cards and USB or FireWire (IEEE-1394 or i-link) for data transmission. The actual transfers to a host computer are commonly carried out using the USB Mass Storage device class (so that the camera appears as a disk drive) or using the Picture Transfer Protocol (PTP) and its derivatives. Older cameras may use the Serial Port (RS-232) connection.
The digiKam Handbook

<table>
<thead>
<tr>
<th>Preview Example</th>
<th>Connector Type</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="FireWire connector" /></td>
<td>FireWire (IEEE-1394 or i-link) connector from a professional digital still camera</td>
</tr>
<tr>
<td><img src="image2.png" alt="Universal Serial Bus connector" /></td>
<td>Universal Serial Bus (USB) connector from a consumer digital still camera</td>
</tr>
<tr>
<td><img src="image3.png" alt="Serial Port connector" /></td>
<td>Serial Port (RS-232) connector from an old digital still camera</td>
</tr>
</tbody>
</table>

**Transfers using gPhoto2: PTP and RS-232 Serial Port**

digiKam employs the gPhoto2 program to communicate with digital still cameras. gPhoto2 is a free, redistributable set of digital camera software applications which supports a growing number of over 800 cameras. gPhoto2 has support for the Picture Transfer Protocol, which is a widely supported protocol developed by the International Imaging Industry Association to allow the transfer of images from digital cameras to computers and other peripheral devices without the need of additional device drivers.

Many old digital still cameras used Serial Port to communicate with host computers. Because photographs are big files and serial port transfers are slow, this connection is now obsolete. digiKam supports these cameras and performs image transfers using the gPhoto2 program. You can find a complete list of supported digital cameras at this [url](url).

**NOTE**

libgphoto2 needs to be built with libexif to retrieve thumbnails to digiKam properly. EXIF support is required for thumbnail retrieval on some libgphoto2 camera drivers. If EXIF support is not set with libgphoto2, you might not see thumbnails or the thumbnail extraction may be very slow.
Transfers using Mass Storage device

For the devices that are not directly supported by gPhoto2, there is support for the Mass Storage protocol, which is well supported under GNU/Linux®. This includes many digital cameras and Memory Card Readers. Mass Storage interfaces are:

- **USB Mass Storage**: a computer interface using communication protocols defined by the USB Implementers Forum that run on the Universal Serial Bus. This standard provides an interface to a variety of storage devices, including digital cameras.

- **FireWire Mass Storage**: a computer interface using communication protocols developed primarily by Apple Computer in the 1990s. FireWire offers high-speed communications and isochronous real-time data services. Like USB Mass Storage, this standard provides an interface to a variety of storage devices, including digital still cameras. Almost all recent digital cameras support USB version 1 and eventually will support USB version 2; a very few support FireWire.

To use a generic Mass Storage device with digiKam, select **Import → Camera → Add Camera Manually**, add your device and set the correct mount point path.

For details see the chapter **Configure digiKam...**, into Section “Camera”.

1.6 The digiKam Database

1.6.1 Introduction

Everyone knows about a database; it is used to store data. As all other photographs management programs, digiKam too uses the database for some obvious reasons like avoiding data duplication, reducing data redundancy, a quick search engine, and greater data integrity. Moreover, the cost of data entry, storage and retrieval are drastically reduced. Additionally, any user can access the data using query language.

Talking in particular about digiKam, the Albums, Album Roots, Tags, Thumbnails, Face Recognition Data, Image Metadata, File Paths, Settings etc. are all stored in different database files.

The digiKam actually manages more than one database. For convenience, it is broadly categorized in three:

1. Core database for all collection properties, i.e. it hosts all albums, images and searches data.

2. Thumbnails database for compressed thumbnails i.e. to host image thumbs using wavelets compression images (PGF format).

3. Face database for storing face recognition metadata i.e. to host face histograms for faces recognition.

1.6.2 Technical Background and Configuration

The whole details of database settings are mostly given in the setup section about digiKam databases.
Chapter 2

Using digiKam

2.1 The Main digiKam Window

2.1.1 Introduction to the Main Window

2.1.1.1 Areas and Bars

digiKam’s main window has two areas in the center showing your photographs. One is the Icon Area, showing thumbnails of the content of the selected album or of a search result, and the other one the Preview, showing the selected image. Together let’s call them the Image Area. In the top left corner of the Preview we have a few buttons for moving back and forth through the content of the album, for rotating the image, for showing or adding face tags and to switch to full screen mode. By clicking on the preview you can make it disappear and by clicking on the picture area of a thumbnail open it again.
The digiKam Handbook

The Image Area in the center is surrounded by the menu bar and the Main Toolbar at the top, the Status Bar at the bottom and the Left and Right Sidebar. The Left Sidebar lets you switch between nine 'Views': Albums (shown here), Tags, Labels, Dates, Timeline, Search, Fuzzy (Search), Map and People (Tags). The Right Sidebar can be used to show all information about your images and partly also to edit them. You can use all these views to organize and find your photographs. If you click on one of the buttons on the sidebars there will fold out another area, offering possibilities to select, to make inputs, e.g. for searches, to edit data and to show information.

Don’t worry if your main window looks quite different at the moment. You will soon learn how to switch the different areas on and off and at some point you might get a look very similar to the above screenshot.

Drag & Drop of images works about everywhere: d&d an image into another branch of the album tree, across the horizontal album separation line, or to another application window. The only restriction is that you cannot d&d into tag, date or searches.

2.1.1.2 The Status Bar

The status bar at the bottom shows in all eight views:
- the file name when selecting a single file
- selection information when several items are selected
- Quick filters:
  - Information how many filters are active
  - a trash bin button to reset all active filters
  - a funnel button to open the filter settings panel
- a progress bar for batch processes, e.g. assigning tags
- a thumbnail and preview size slider with buttons for “Fit to Window” and “Zoom to 100%”
- a size selection pop up list in % for the preview

2.1.1.3 Main Toolbar

The window top shows the Menu Bar and the Main Toolbar below.

1. Open Image Editor with the selected image
2. Open Light Table (L)
3. Open Batch Queue Manager (B)
4. Import (drop down menu showing all connected cameras and mass storage devices)
5. Switch to thumbnail view
6. Toggle preview of selected image
7. Switch to map view to display images with geolocation data
8. Switch to configurable table view
9. Slideshow drop down menu
10. Toggle Full Screen (Ctrl-Shift-F)
11. Link to digikam.org, also an indicator for ongoing processes

You can customize the Toolbar by choosing Settings → Configure Toolbars... or click with the right mouse button on it and choose Configure Toolbars... from the context menu.
2.1.2 Image Area

2.1.2.1 General Information

In all eight views the Image Area shows the result of your selection or search on the Left Sidebar in the Icon Area. Each image is displayed as a thumbnail. You can alter the size of the thumbnails using the magnifier slider close to the right end of the status bar.

The first time you select an Album you may have to wait briefly while the thumbnails are generated.

Information about each photograph is displayed below each thumbnail. You can control what information is displayed from the Settings → Configure digiKam... dialog. Select the Album View page and look for the Icon-View Options section.

The thumbnails have Tool Tips which will pop up if you allow the mouse to dwell over a thumbnail for a moment. The Tool Tip shows the most important properties of the photograph including any tags that you have applied.

The content of the Tool Tips can be configured in the Tool Tip section of Settings → Configure digiKam...

As an alternative you can display the photographs in a table by hitting the Table button on the Main Toolbar or by selecting View → Table menu from the menu bar. This allows to see a lot of photographs at the same time (Tip: leave away the thumbnail column) in a way you can customize the usual way by clicking with the right mouse button on the headline bar and choosing the information you want to see. Clicking with the left mouse button on a line in the table will open the preview of that photograph.

You can access most of the functions that digiKam can perform on a photograph by clicking with the right mouse button over the thumbnail or line in the table (context menu) or by selecting from the Item menu in the menu bar.
2.1.2.2 Viewing an image

There are several possibilities to view an image. You can either click on it, select View → Preview Image (F3) from the menu bar or select Preview Image from the context menu. The Preview Area will open and the Icon Area will be reduced to one line. For viewing it larger, click the sidebars away (by just clicking on the active button on them). An even larger view you can achieve by clicking the ‘Show Fullscreen’ icon either on the thumbnail or on the preview. While viewing images you can take action from the context menu at any time (not in fullscreen mode). To close the preview, just click again or press Esc or F3 or click the Table or Thumbnails button.

You can also view your images in a slideshow using the ‘Slideshow’ drop down menu from the Main Toolbar. You have the choice to start a slideshow with a selection of photographs, the whole content of the folder (or search result) or even including all subfolders.

2.1.2.3 Editing a Photograph

You can open the Image Editor on a photograph either clicking the Image Editor button on the Main Toolbar or by selecting Item → Open... (F4) from the menu bar or clicking with the right mouse button and selecting Open... from the context menu. See the digiKam Image Editor section for instructions on how to edit your photographs. The Image Editor offers a wide range of tools to enhance, decorate and/or modify your photographs.

2.1.2.4 Viewing or Editing a Photograph With Another Application

Sometimes digiKam may not provide all of the capabilities you need. You can open a photograph in another application by clicking with the right mouse button on it and selecting from the Open With... sub-menu (At the moment this function is available only under Linux®). The list of applications that appear in this menu is controlled by the standard desktop file associations for the image format type of this photograph. Consult the desktop manual for instructions on changing these file associations if the application that you need is not listed.
Note that there can be a problem with meta-data embedded in photographs when they are edited by other image manipulation applications. Some applications do not retain the photograph’s meta-data when you save a modified image. This means that if you modify a photograph using one of these programs you will lose information such as orientation, aperture etc. that are stored in the EXIF and IPTC tags.

### 2.1.2.5 Lossless Image Rotation

<table>
<thead>
<tr>
<th>NOTE</th>
</tr>
</thead>
<tbody>
<tr>
<td>There is a difference between rotating a photograph in one of the Views of digiKam or in the Image Editor. The Image Editor uses a different method of rotating an image, you may not notice any difference but the Image Editor method can cause some loss of quality in the photograph when saving the picture as JPEG. The rotation methods described here preserve the original quality of the photograph also in JPEG - Files.</td>
</tr>
</tbody>
</table>

DigiKam provides two ways to get your photographs the right way up. The simplest method is to click one of the rotate icons on the thumbnail or the preview or to click with the right mouse button for the context menu and select Rotate and then pick the direction of rotation needed.

The second method is to select Item → Auto Rotate/Flip Using EXIF Information from the menu bar. Most digital cameras have an orientation sensor. This sensor can detect how you hold the camera while taking an image. It stores this orientation information inside the image. This meta data is stored in an embedded meta-data section called EXIF. The cameras could rotate the image themselves right away, but they have limited processing power, so they leave this job to an application like digiKam. If the camera is storing the orientation, then digiKam can use it to automatically rotate your photographs so that they are the correct way up when you display them. DigiKam will rotate the image on disk according to this orientation information.

The photograph is rotated without loss of quality and the orientation information is set to normal, so that other EXIF-aware applications will handle it correctly. The Import Tool can perform this operation automatically when it uploads the photographs from your camera which will ensure that your photographs are always the right way up. The rotate operation will do nothing if your camera does not include this information in the photos.

### 2.1.2.6 Renaming a Photograph

You can change the filename for a photograph by clicking with the right mouse button over a thumbnail and selecting Rename (F2). Remember to keep the file extension (.jpg, .tif, etc.).

You can also batch rename photographs. One method is to use the Batch Queue Manager (B). Another one is to select multiple photographs and then press F2. A dialog will open showing the list of selected photographs with their current name and the new name. These two are identical at first until you place the cursor in the input field, type in something and/or select a modifier from the buttons below. Make use of the tooltips!

### 2.1.2.7 Deleting a Photograph

When you delete a photograph from digiKam with Item → Move to Trash (Del) it will be moved from its folder on the hard disk to the internal Trash Can. Deleting works from anywhere in any digiKam window.
2.1.2.8 Grouping Photographs

Grouping items is a very useful way to organize Photographs and/or videos that are related to each other and to adjust the way they are displayed in the image area. This function is available through the context menu on a selection of items (more than one item selected).

You can put the whole selection into one group using Group Selected Here or you can create more than one group determined by time (seconds will be ignored) or by file name. Note that the latter will put items with the same name but different file types into one group. Use case see further below!

The next group in the menu is to control whether only the reference icon of the group (the first of the group according to the sorting order at the moment of grouping) is displayed or all of them. These two functions can also be accessed by the little grouping indicator (folder symbol) on the reference icon (see upper left icon on the screenshot). While the mouse pointer is hovering over it there will pop up an information ‘n grouped items. Group is closed/open.’ where n indicates the number of items in the group which are invisible if the group is closed. Clicking on the indicator toggles between open and closed. In the Table mode of the Image Area groups are indicated the way we know from many other lists and tables: with a little triangle in front of the reference item. Clicking on this triangle will fold out/in the grouped items.

The last group in the Group context menu allows to remove individual items from the group or to disband the whole group. The content of the menu will change depending on whether you use it on a selection of still un-grouped items, on a group or on single items of a group.

What can you do with a group? In terms of functions of digiKam you can perform a lot of operations like copy, delete, move, rotate on the whole group by selecting only the reference icon provided the group is closed. The same way you can load the whole group into tools like Light Table or the Batch Queue Manager, even into the Image Editor where you can navigate through the group members with the page keys on your keyboard. You can assign tags and labels (see further below in this chapter) and also write descriptions (see Captions). Give it a try!

In terms of use cases you can for instance group videos together with the jpg - images related to them which most cameras provide or RAW images with their JPG counterpart. This is made easy by Group Selected By Filename. In the screenshot above exposure bracketed images are being grouped. One could do the same for archiving purposes with images used for a panorama. If you have very specific requirements for documenting of editing steps the Versions function of
digiKam cannot meet you may find a solution using grouping. I can think of more use cases for grouping but I don’t want to overload this section of the handbook here. Maybe a last hint for your own ideas: grouping is not restricted to items out of the same album. The whole group (open or closed) will only be visible in the album of the reference item. The other members of the group will be visible in their own albums only if the group is open. Can be confusing, use with care!

**NOTE**
Everything described in this Grouping section has nothing to do with Group Images in the View menu. That function doesn’t form permanent groups of items, it only organizes the way icons are displayed in the Image Area.

### 2.1.3 Albums View

By clicking the ‘Albums’ button on the left side bar you toggle the ‘Albums’ tree which provides an organized view of your photograph albums. The top item ‘Albums’ just shows the ‘welcome to digiKam’ screen in the view area. The next level of the ‘Albums’ tree shows your different Collections (marked by the icon) or at least one if you haven’t added one or more yet in the Settings → Configure digiKam... Collections section. Each Collection represents a folder branch on your hard disk, on removable media or on network shares and the next levels in the tree show the structure of those folders, here called ‘Albums’. The albums can be sorted by their folder layout on the hard disk, by the Category that has been set in the Album Properties or by the Date of that Albums (this date can also be changed in the Properties of each Album). You can invert the sort order (ascending/descending) by clicking on the title bar of the album tree.

You can switch between these sort orders using Sort Albums from the View menu.

#### 2.1.3.1 Creating a New Album

There are a number of ways to create a new Album. You can create a new Album when you upload new photographs from the Camera using Import → Cameras. You can also create a new
empty Album with **Album → New...** (Ctrl-N) in the ‘Albums’ view. As an additional option, you can create a new Album by importing an existing folder of photographs from your computer; just select **Import → Add Folders...** from the menu bar and select the folder that you want to import. An Album will be created with the same name as the hard disk folder. You can use drag and drop to import a folder. Drag a folder icon, for example from a Dolphin window. Then drop it on the album list on the left. A menu will appear that gives you the option to move or copy the folder into digiKam.

### 2.1.3.2 Deleting an Album

When you delete an Album from digiKam it will be moved into the internal Trash Can. As an option you could change this behavior, so that delete really will remove the Album and all of the photographs in it. This can be changed by selecting **Settings → Configure digiKam...** and selecting the Miscellaneous page. At the top of this page are the settings that control what happens when a photograph is deleted. To delete an Album, click with the right mouse button over the Album in the ‘Albums’ tree and select Delete Album from the context menu.

### 2.1.3.3 Adding a Photograph to an Album

Most of the time you will create new Albums and populate them with photographs directly from your camera using the Camera Tool. However, sometimes you may want to add a photograph that you already have on your computer to an existing Album. To add a photograph to an Album select **Import → Add Images...** (Ctrl-Alt-I) from the menu bar. Select a source folder from the dialog and click OK. An import window will open. Select the photographs that you want to add and choose **Download Selected** from the ‘Download’ drop down menu. A dialog will open where you can choose the destination album. The photographs will be copied into the Album. **Download New** (Ctrl-N) from the same menu will copy only those images which are not in the destination folder yet.

Additionally, you can use drag and drop to import photographs. Drag the photographs icons, for example from a Dolphin window. Then drop it on the image list on the right hand side.

If you have a scanner configured, you can also scan a photograph straight into an Album. Select **Import → Import from Scanner...**.

### 2.1.3.4 Moving or Copying Photographs Between Albums

Simply drag the photograph and drop it on the destination Album to move or copy it from one Album to another. A menu will appear that gives you the option to **Move** or **Copy** the photograph. You can move or copy multiple photographs the same way, just select all the photographs that you want to move and drag them on to the destination Album.

### 2.1.3.5 Managing Albums

Album Properties can help you remember which kind of photographs are in an Album and can also help you to organize the ‘Albums’ tree. To access the Album Properties, click with the right mouse button on an Album and select **Properties** (Alt-Enter) from the context menu.
The digiKam Handbook

The Album Properties dialog allows you to set:

- **The Album Title**: Name of the Album, identical with the name of the folder on your hard disk. If you edit it here, the folder will also be renamed.

- **The Album Category**: this is a way of grouping your Albums together by a common label. The Category you set will be used to order your albums when you select **By Category** from the drop down box in the tool bar or using **View → Sort Albums → By Category**. If you want to add and delete Category labels, choose from the menu **Settings → Configure digiKam…** and here the Album Category section.

- **The Caption for the Album**: Usually a short description of the content, but of course you are free to abuse it in any conceivable way. But beware: this will be shown in the banner at the top of the main Image Window ;-)

- **The Album Date**: this will be used when you order your Albums by date using **View → Sort Albums → By Date**.

- **Oldest, Average, Newest buttons**: these will set the **Date** to the oldest, average or latest date of the images in that album. It will first try to calculate the average date of the images in the album based on the EXIF-headers. If that fails it will fall back to the modification date of the files in that folder.

2.1.3.6 Setting the Album Icon

digiKam displays the usual folder icon in the ‘Albums’ list. You can choose one of your photographs instead. This may help you to remember what kind of photographs are contained in an Album.

To select a photograph as the Album icon, click with the right mouse button on the photograph that you want to use as the Album icon and select **Set as Album Thumbnail** from the context menu. Additionally you can use drag and drop to set the Album icon. Drag the photographs icon from the thumbnail area and drop it on the currently selected Album in the Album list.
NOTE
An Album can only be in one Album Collection and Album Collections cannot be nested. digiKam also supports tagging individual photographs. Album Categories are different from photograph tagging because the Album Category applies to all the photographs in an Album rather than to individual photographs. You can use both Album Category and tagging to organize your photographs.

2.1.4 Tags View

(Hierarchical) tagging provides a flexible and powerful way to organize and catalog your images. Tags (also called ‘keywords’ in other applications) are labels that can be applied to individual images or whole groups. Once a tag has been set to an image the image can be found again by selecting the tag or doing a search.

Tags can be arranged in a hierarchical tree. This allows you to organize your tags in a logical manner. You can collapse parts of the tree in the ‘Tags’ list so that you can easily find the tags that you are looking for.

When a tag is selected in the Left Sidebar, all of the images that are marked with that tag are displayed in the View Area.

But before assigning and using tags you first have to define them. If you import photographs with tags assigned digiKam will build an appropriate tag tree during import. Other than that you have to define tags by yourself. An easy access to that is the context menu shown in the screenshot above.

2.1.4.1 Managing Tags

You can add new tags by clicking with the right mouse button on either the ‘Tags’ label or an existing tag and selecting New Tag.... A dialog will open where you can type in the tag name (or even a whole hierarchy branch), assign an icon and/or a shortcut to the tag. If you add a new tag by clicking with the right mouse button on an existing tag, your new tag will be created as a sub-tag.
You can delete a tag by clicking with the right mouse button on the tag you want to delete and selecting **Delete Tag**. When you delete a tag, the photographs themselves are not deleted. Simply the tag is removed from those photographs.

You can move the position of a tag within the tree by dragging it to the position that you want and dropping it there. A menu will appear that gives you the option to **Move** the tag. This works from the left and right sidebar. A tag can only be in one place in the tree at a time.

You can set the Tag Properties by clicking with the right mouse button on a tag and selecting **Properties...**. The Tag Properties allow you to change the name of the tag, the icon used in the Tags tree and the shortcut.

To select a photograph as the tag icon, click with the right mouse button on the photograph that you want to use as the tag icon and select **Set as Tag Thumbnail** from the context menu. Additionally you can use drag and drop to set the tag icon. Drag the images icon and drop it on the currently selected tag in the tag list.

A tool for more elaborate work on big tag trees is the Tags Manager which you can access by clicking the **Open Tag Manager** button at the top of the Tags tree.

In the Digital Asset Management (DAM) chapter of this handbook you can find some useful considerations about how to build your Tags tree.

It is not always easy to build a logical hierarchy from general and generic categories. You might run into a problem like this:

```
Animal
  - Domestic Animal
    - Cat
    - Cattle
    - Dog
  - Wild Animal
    - Bird
    - Cat
      - Cheetah
      - Lion
      - Tiger
  - Zoo Animal
    - Bird
    - Cat
      - Cheetah
      - Leopard
```

In this tag tree the keyword ‘Cat’ appears three times. This will not cause a problem within digiKam but there are quite a few views where the user cannot know which of the three is applied to an image because he might not be able to see the whole hierarchy of the tag. A help could be to tag the image in a case like this also with the parent tag or even the whole hierarchy but it becomes quite unwieldy, e.g. in the image icon if you have the tags displayed there. The second ‘Cat’ can be avoided by calling it ‘Wild Cat’ but calling the third one ‘Zoo Cat’ is a bit out of the roof, I think. And still: there are also two ‘Cheetah’!

Solution: You replace the ‘Zoo Animal’ branch by a single tag ‘Zoo’ which you use in addition to the tag you choose from the two remaining branches. You could even put it on the top level of your hierarchy if you have photographs taken in a zoo but not showing animals.

### 2.1.4.2 Tagging Photographs

Before you can get the most out of digiKam’s tagging capabilities, you must first tag your photographs. There are a few methods for that task. Once you have identified the photographs that
you want to tag you can either drag and drop them onto the tag in the Tags tree or, by clicking with the right mouse button on the selected photographs in the Image Window, you can use the Assign Tag menu to select the tags you wish to set.

Drag and Drop: works with both sidebars provided they are showing tags of course. With the Right Sidebar it works the obvious way: you drag the tag and drop it onto the photograph or selection of photographs you want to tag. With the Left Sidebar you have to drag the photographs to the tags. You want to know why? Just try it the other way and you will see :-) 

Shortcuts: as mentioned earlier in this chapter you can assign keyboard shortcuts in the Tag Properties. With these you can assign or un-assign a tag to the selected photograph(s).

Context menu: by clicking with the right mouse button on the selected photographs and choosing Assign Tag you will see the next menu step offering the ten most recently used tags, Add New Tag..., described at the beginning of the previous article, and More Tags... which leads to what is described in the next paragraph. The context menu method is obviously very useful if you use only a limited number of tags out of your whole tree for a while.

Example 2.1 Tagging Image with context menu

You can remove a tag from a photograph by clicking with the right mouse button on the photograph and using the Remove Tag menu. This menu will only show those tags that have been set on this photograph.

The Right Sidebar: this is what I would call my standard method for assigning tags. Click Captions/Tags on the Right Sidebar and then the Tags tab and you will see the whole tags tree. Simply check/un-check the boxes of the tags you want to assign/un-assign and then click Apply. If you change focus without that you will be asked whether you want to apply the changes unless you disabled that confirmation either by checking ‘Always apply changes without confirmation’ or by checking ‘Do not confirm when applying changes in the right sidebar’ in the Miscellaneous section of Settings → Configure digiKam.... More details about the other buttons and fields in the Tags tab see in digiKam sidebar.

You can label a photograph with as many tags as you like. The photograph will appear when you select any of the tags that are set against it. This way you can set a tag for each person in a photograph, as well as the place the photograph was taken, the event it was taken at, etc.
Once you have tagged a photograph, the tag name will appear under the thumbnail in the Image Area.

**Tip**

Tags are stored in a database for fast access, and, the applied tags are written into IPTC data fields of the image (at least for JPEG). So you can use your tags with other programs or, in case of loss of that data in the database, the tags will be re-imported when the image is noticed by digiKam.

### 2.1.5 Labels View

The Labels View allows you to select photographs by the Rating, Pick and Color labels you assigned to them previously either by using the context menu of a thumbnail or the Description tab of the Captions/Tags section on the Right Sidebar.

You may select more than one label by Ctrl+left click. The selected labels are connected by boolean AND, e.g. selecting Four Star and Yellow will display only photographs that have both labels assigned. You can perform even more sophisticated searches by using the Filters section of The Right Sidebar.
2.1.6 Dates View

The Dates View organizes your photographs based on their dates. digiKam uses either the EXIF date or, if no EXIF date is available, the last modification time of the file.

When you select a month from the list, all images from that month are displayed in the Image Area. You can select days or weeks in the date sheet at the bottom of the Left Sidebar to show only the images from the selected dates.

2.1.7 Timeline View

The Timeline View shows a timescale-adjustable histogram of the numbers of images per time unit which is selectable by a drop down field. To the right of that you can choose between a linear or logarithmic histogram. A selection frame moves over the histogram. To display the photographs out of a certain time frame just click on the corresponding bar. You are not restricted to one bar. With Shift+left click or Ctrl+left click you can add more bars to the first one.
In the field right below you can enter a title and save your selection. It will then appear in the ‘Searches’ list field below. But the best is still to come: the Timeline View offers a search for a search! If you have a lot more searches saved than my ridiculous four in the screenshot the adaptive search field at the bottom may help to find a certain search.

2.1.8 Search View

We talked about quite a few views already and their searching capabilities, which are all kind of specialized. The Search View now offers a more versatile and general way of searching. There are two different approaches.
2.1.8.1 The Quick Search

Quick Search is the adaptive search box at the top of the search dialog (Left Sidebar) and provides you with a simple means to search the digiKam database with a single query. You can enter any arguments in the Search: text field and it will be used to determine the results. For instance, you can enter the string 'birthday' to search the complete database for occurrences of the word 'birthday' in all metadata text fields, or '05.png' to search for a specific image file name '05.png' (no escaping as in regexpressions needed).

Search Properties:

- searches are case insensitive
- blank separated search terms are boolean AND combinations
- special characters are literal and not interpreted ( . * ? / etc.)
- include all elements of the database: names, rating, keywords, tags, albums, collections, dates (and more in the future)

You can save your searches as a live folder that always filters for what you entered as search criteria. Just type a name for the search into the Save Current Search field and click the save button to the right of it. When saved, the filter will appear in the Searches list. By clicking the title bar of this list you can invert the sorting order. Once you select one of your saved searches, the search result will be presented in the Image Area immediately and the Save Current Search field will convert into a Edit Stored Search field where you can edit your search criteria. The name of the saved search will be used to label the search result in the Image Area.

If you want to delete or rename a saved search from the list, click with the right mouse button on it and select from the context menu.

2.1.8.2 The Advanced Search Tool

Advanced Search tool provides an extended search form which can be used to search in specific fields of the digiKam database in a more sophisticated way. Click the Advanced Search... button and it will come up like this:
The field labeled ‘Find pictures that have associated all these words:’ is just a duplicate of the Quick Search field.

Click on one of the blue categories and there will fold out an area with all the fields you can search for in that very category. Depending on the kind of data each field contains different input fields for your search, sometimes more than one type for the same field. Simplest are selection buttons, e.g. for colors. Then you have plain fields of the ‘The field content contains’ type, drop down lists and checkboxes. Many fields have two input fields allowing you to define a range, e.g. ‘Find pictures with a width between’. And often you find a link type thing called ‘Any’ which opens a drop down field with checkboxes for the possible contents of that field.

**Example 2.2 Advanced Search Criteria**

![Advanced Search Criteria](image)

Thanks to the labeling of the search fields they are pretty much self explaining. What we have to talk about is how they work together if you fill in or select more than one. On the right side of the header (blue area at the top) you find a little link ‘Options’. If you click on that one the header will change and you see four options:

- ‘Meet All of the following conditions’ means that your different search parameters will be connected by boolean AND for the search. Example: if you selected Album name ‘Holidays’ and color ‘red’ the search will find all pictures labeled with ‘red’ out of the Album ‘Holidays’.

- ‘Meet Any of the following conditions’ means that your different search parameters will be connected by boolean OR for the search. Example: if you selected Album name ‘Holidays’ and color ‘red’ the search will find the content of the Album ‘Holidays’ and all pictures labeled with ‘red’ out of your whole collection.

- ‘None of these conditions are met’ means that your different search parameters will be connected by boolean NAND for the search. Again our example: if you selected Album name ‘Holidays’ and color ‘red’ the search will find all pictures of your collection except those labeled with ‘red’ and except those out of the Album ‘Holidays’.

- ‘At least one of these conditions is not met’ means that your different search parameters will be connected by boolean NOR for the search. One more example: if you selected Album name ‘Holidays’ and color ‘red’ the search will find all pictures of your collection except those labeled with ‘red’ out of the Album ‘Holidays’.

47
Complicated? No, good! Because the real stuff is yet to come. Have a look at the footer of the Advanced Search Tool. Here you find **+ Add Search Group**. If you hit this button another list with the same categories of search fields will open below the first one (scroll down in case you don’t see it right away) separated by a blue header showing the same options we were just talking about. On top of them you see an underlined OR meaning that this list is connected to the first one by boolean OR. You can change that to AND by clicking on it.

To explain how it works let’s make another example based on one of those we had already. I want to use the second one. That means: in the first group you checked ‘Meet Any of the following conditions’ and you selected Album name ‘Holidays’ and color ‘red’. As we said already this will produce all pictures labeled with ‘red’ out of your whole collection and the content of the Album ‘Holidays’. Now let’s assume for some reason you want to exclude all rejected files and all files with a rating lower than three stars. So you open a second group, click on the underlined OR in the header in order to change it to AND, select ‘None of these conditions are met’, fold out the ‘Picture Properties’, check under ‘Labels’ the red flag (rejected) and select under ‘Rating’ no star (five white stars) in the first field and two stars in the second field. Note that there is a difference between ‘no star’ and ‘No Rating assigned’! If you want to exclude the pictures without any rating as well you got to open another Search Group, click on the underlined OR in the header in order to change it to AND, select ‘None of these conditions are met’ and select ‘No Rating assigned’ in the ‘Picture Properties’ category.

Which brings us to the fact that you can open as many additional Search Groups as you need to formulate your query. But since the purpose of this handbook is not to open a competition in creating the most sophisticated queries I leave it to you to figure out how far you have to go or can go in this respect and rather finish this section with a few hints about the other buttons in the Advanced Search Tool. Beside the **+ Add Search Group** button you see **Reset**. This removes all additional Search Groups and clears all the fields in the remaining one. It’s a good policy to use this button before starting to create a new search, in particular when you leave the Advanced Search Tool with the intention to use the Quick Search for your next query, because otherwise the search criteria remain active even if you don’t see them and screw up your new search. **Try** carries out the search but leaves the Advanced Search Tool window open, **OK** does the same but closes the window. ‘Remove Group’ in the header of the additional Search Groups doesn’t need an explanation, I think.

### 2.1.9 Fuzzy View

digiKam characterizes every image by a lengthy number using a special technique (Haar algorithm) that makes it possible to compare images by comparing this calculated signature. The less numerical difference there is between any two image signatures, the more they resemble each other. This technique has three implementations in digiKam:

- **Duplicates**: before you can have digiKam finding duplicates the signatures (or fingerprints) have to be calculated. You can start that process with the button **Update fingerprints** which initiates a total rebuild of the image signatures (may take hours if you have a large collection, an estimate is 2 hours for 10'000 images). Once the fingerprints are calculated you can use **Find duplicates**, but it will take a long time too as it has to compare every image with any other image. So the way to go in both cases is to confine your search to certain albums and/or tags. With the Similarity range you can narrow down or enlarge the search result. Note that by lowering the upper threshold a little bit below 100 % you can keep things like exact copies, images from series shots, etc. out of the search result if you want.
Example 2.3 Find duplicates while restricting to an album

An overview of the result will be given in the Left Sidebar. The first column shows the reference images of each single result. The Items column tells you how many images belong to each result including the reference image. The last column shows the average similarity which gives you an idea about how similar the images of every result might be. The reference image with its 100 % is not included in the average. Note that the results can be sorted by clicking on one of the column headers.

Individual similarity values for each item can be obtained in the table view of the Image Area (Table button on the Main Toolbar). Click with the right mouse button over one of the column headers and select Similarity from Item properties to display the similarity column. By clicking on the header of this column then the results will be sorted by similarity grouped by reference images. Clicking repeatedly on the header will toggle between ascending and descending order.

- Image (Similar items): This is a drag&drop zone where you can drop any image to find a similar one. Drag an image from anywhere, even from outside digiKam (file manager, other programs), over the fuzzy search icon in the left sidebar, it will open and you drop it there or use Find Similar... from the context menu of a thumbnail in any other view. You can narrow down or enlarge the resulting selection with the similarity range here as well. In the field below you can enter a name for the search and save it. In the searches list below you find your saved searches. Clicking on the title bar of that list toggles the sorting order between ascending and descending. At the bottom you find an adaptive search field which can help you to find a particular search.
Example 2.4 Fuzzy search for similar image

- Sketch: free hand color sketching: draw a quick sketch and digiKam will find corresponding images. You will find the same means to save your search as in the **Image** tab.

Example 2.5 Fuzzy search by sketch
2.1.10 Map View

The whole digiKam geolocation suite - if you want to call it that way ;-) - consists of four parts:

1. The Map mode of the Image Area which displays images with GPS data on a map depending on the selection on the Left Sidebar, e.g. the images in the album you selected in the Album View, the images with a certain tag assigned (selected in the Tag View), with a certain label and so on.

2. This view which is the search tool for finding images by their GPS data.

3. The Geolocation Editor which is accessible via Item → Edit Geolocation... (Ctrl+Shift+G) and allows to set and to edit GPS data.

4. The Map tab on the Right Sidebar which shows the location of the image on a map and is purely informative.

All four are based on the Marble widget.

For navigating on the map refer to Marble handbook, Chapter 2. The meaning of ‘GPS’ and functions and buttons that apply to all three geolocation parts are described in the Geolocation Editor chapter of this handbook. This applies to the context menu on the map and the first line of buttons under the map except the last three. The designations I use here for the buttons is the content of the respective tooltip.

Usually you will begin searching for images by defining a region on the map. From the ‘Search by area:’ buttons click the left one, the Select-images-by-drawing-a-rectangle button, then click with the left mouse button over one corner on the map, draw open a rectangle and click with the left mouse button over another corner. All images falling within the coordinates of that rectangle will be shown in the Image Area (provided your images have been geo-coded of course).

The next button to the right is the Create-a-region-selection-from-a-thumbnail button which creates a small region around the position of a marker or thumbnail if you click on it. If there are other images hidden behind it because they have the same position or one very close to the image you click on they will be shown in the Image Area.
The last button in this row is the Remove-the-current-region-selection button. Well, do I still have to explain that after all? O.k., I should mention that it, of course, only removes the selection, not your precious pics :-)  

Now let’s have a look on the three buttons at the right end of the row right under the map. They control which images you see in the Image Area out of your defined region. Let’s begin with the one at the very end of the row, the Select-images button. If you activate it, it will toggle the selection of a photograph (or a group of photographs if they are hidden behind each other) once you click on it on the map. This can be helpful to fine tune your selection before carrying out operations from the Right Sidebar or the menus.  

The Filter-images button (the one with the funnel on it) will, other than the Select-images button who leaves all images from your defined region visible in the Image Area, switch off all other images and show only the one you clicked on. This is particular useful if the map is just showing markers or if the thumbnails are too small to clearly identify images.  

The Remove-the-current-filter button is self explaining but I want to mention here that these three last buttons won’t affect your defined search region which means that once you click the button with the white cross in a red circle all images in that region should be displayed again in the Image Area.  

The Show Non-Geolocated Items button displays all images without GPS data in the Image Area. If this applies to many images from your collections it might be a good idea to use the Filters tab of the Right Sidebar and/or the sorting and grouping functions in the View menu additionally.  

In the box below you can enter a name for your geo filter. It will be added to the list view below for future reference once you click the save button to the right of it, it acts as a live geo folder. The search field at the bottom searches in the Searches list above.  

2.1.11 People View  
As long as you are not just taking pictures from machines or stars or something like that, Face Management might be an interesting feature for you (even with a machine there might be a human being operating it). In digiKam it consists of two tasks: Face Detection and Face Recognition.  

2.1.11.1 Face Detection  
The first step is to have digiKam finding all those pics that show faces not even knowing yet who’s face it is. To prepare that process you click Scan collection for faces which will open the Scanning faces dialog. Right under the header you have a drop down menu where you can choose between  

- Skip images already scanned  
- Scan again and merge results  
- Clear unconfirmed results and rescanning  

The first one you would choose if you didn’t scan yet or if you did with a satisfying result but added new photographs since then or if you already improved a search result, e.g. by removing face tags which obviously don’t show a face. The second you would choose if you want the images already scanned to be included in the next scan. The third is more interesting in the context of Face Recognition since ‘unconfirmed results’ means face tags that don’t have a name assigned to them yet.  

For the task we are talking about you check Detect faces, of course. Since face detection is a time-consuming task you better don’t hit Scan right away, rather Options. An additional area will fold out organized with three tabs. In Albums you can confine the scan to certain albums or tags. In Parameters you can try to find a balance between speed and accuracy that suits your
needs. Under **Advanced** you will find two checkboxes. The first is explained by the text above it. The second is for face recognition, see next article.

Once you have chosen your options carefully you click **Scan** and after a while, depending on the scope of your selection, the result will be presented in the Image Area. In the Tags list of the Left Sidebar you will see the People branch of your tag tree. You will see the whole scan result only if the topmost tag 'People' is selected. In the tree you will see a new virtual tag called ‘Unknown’ which will show all those images where faces are recognized but not yet connected to a person. If you just scanned for the first time you will find the whole result also here.

**Example 2.6 Face Detection result**

Note that the thumbnails presented here are not showing the whole image. They show the area of the image where the scan algorithm put down a **Face Tag**. You can see that if you click on the thumbnail. In the preview that opens you will see the whole image with all the face tags on them.

If you don’t see them, click the button in the upper left corner of the preview. If there is more than one face tag on the image it will also be represented by more than one thumbnail. In the screenshot above this is the case with the two topmost thumbnails.
This screenshot image have been chosen because it shows one important issue: the algorithm will find inevitably details in an image that resemble a face but are actually something else. That’s what the Remove button is for. It will remove the face tag from the photograph and if it is the only face tag (left) the photograph will disappear from the scan result.

If it really is a face the field labeled “Who is this?” comes into play. Here you can either type in the name of an existing People tag out of your tag tree or use the drop down function to show your tag tree and select a tag. With Confirm you can save that to the database. If it was the only face tag (left) the image will disappear from the ‘Unknown’ selection and you will find it once you select either the ‘People’ tag or one of the tags you assigned to one of the face tags in that image.

In the context menu of the preview there are two more items related to face tags: Add a Face Tag and Clear all faces on this image.

2.1.11.2 Face Recognition

Assigning People tags to face tags is an important prerequisite to Face Recognition. Very obviously digiKam can only recognize faces if it has something to compare with. So it’s up to you to show it the ropes, which means in this case to tell digiKam: This is Lara, this is Juan, this is Peter and so forth. For that you would, after performing a Face Detection as described in the previous article, typically select the ‘unknown’ tag on the Left Sidebar, click on a thumbnail and click, if necessary, on the (Show Face Tags) button. Now you should see the face tags of that photograph. Those which have a people (or other) tag already assigned will simply show the name of that tag. The others, showing ‘unknown’ faces, will show a field and two buttons as in the screenshot of the previous article. In the field labeled “Who is this?” you can either type in the name of an existing People tag out of your tag tree or use the drop down function to show your tag tree and select a tag. With Confirm you can save that to the database.

NOTE

If you use the context menu item Assign Tag instead of the procedure described above that will not assign a face tag. It will assign an ordinary tag and it will assign it to the whole image.
If a face tag is confirmed and thus showing only the name of the tag but not the buttons to remove, edit or confirm it, but you need this buttons because e.g. it’s wrong and you want to edit or remove it, just double-click on the name and the buttons will re-appear.

Once you have a tag assigned to a few photographs you can have digiKam looking if it can find more photographs showing the same face. To prepare that process you click Scan collection for faces but this time you select Recognize faces.

**NOTE**
To be able to recognize a new face automatically, a minimum of 4 similar faces tagged in different images need to be previously trained using manual face management workflow.

Face Recognition is faster than Face Detection but it still makes sense to click Options and confine the scan to certain albums or tags in the Albums tab, e.g. to the “Unknown” tag. In the Parameters tab we can play with the balance between speed and accuracy. Under Advanced you will find two checkboxes. The first is explained by the text above it.

In case of unsatisfying results it might be helpful to use Clear and rebuild all training data. One reason can be that there are too many face tags assigned to a person which shows this person in a way that doesn’t really help the search algorithm, e.g. with sunglasses, blurred, unusual colors, carnival make up, dark shaded areas in the face, baby/kid/adult photographs mixed... Another reason to use that option can be false face recognition due to a wrong accuracy setting in the Parameters tab.

To start the Face Recognition you click Scan. The process will tag every recognized face with the appropriate People tag out of your tag tree and the corresponding thumbnail will disappear from the “Unknown” tag selection.

## 2.2 The digiKam Right Sidebar

### 2.2.1 Introduction to the Right Sidebar

The digiKam main window has a sidebar at the right border providing important information and actions of the selected images. This same sidebar is also available in the digiKam Image Editor (except the Filters tab). It can be displayed by respectively clicking on one of the eight tabs:

- **Properties**: File and image properties, key shooting parameters.
- **Metadata**: EXIF, Makernotes, IPTC and XMP data.
- **Colors**: Histograms and embedded ICC profiles.
- **Maps**: Marble widget shows GPS location.
- **Captions**: Comments, Date & Time setting, Labels, Rating, Tags, selected metadata.
- **Versions**: Image history.
- **Filters**: Filters to apply to main window selection.
- **Tools**: An optional contextual view dedicated to group by categories all main tools available.

Clicking successively onto the same tab will make the sidebar pop up or fold back into the border.
2.2.2 Properties

The properties sidebar shows the essential information about the selected image which are largely self-explanatory. It is grouped into the following sections:

- File Properties: these are file system related information
- Image Properties: shows the image and format properties like dimension, compression, color-depth, etc.
- Photograph Properties: shows a summary of the most important parameters when taking the photograph. These data are taken from the EXIF or XMP data fields if available.
- digiKam Properties: optional view to show a summary of the most important values set in digiKam database.

![Properties Sidebar](image)

2.2.3 Metadata

Metadata are data about the images or files, like technical data of camera setting during shooting, author info, copyrights, keywords, captions, and coordinates of location.

The metadata sidebar is composed of four sub tabs EXIF, Makernote, IPTC and XMP data. On the left, two buttons let you choose between full and simplified data display. In the middle you will find a disk icon to save the metadata to the disk. Next to it are a printer and copy icon - they do just that: print or copy the respective tab metadata to the clipboard.

A really nice feature is the live search box on the lower end of the metadata tabs. As you type in a keyword, the metadata on top of it will be successively filtered until you narrow down and what you are looking for. It is a quick way of accessing specific information.

Metadata, as shown in these four tabs, can be modified and enhanced in a number of ways elsewhere:

- with the camera interface
2.2.3.1 EXIF Tags

2.2.3.1.1 What is EXIF

EXIF stands for Exchangeable image file format. It was designed specifically for digital cameras. It allows a large amount of information about the photograph to be stored. This information describes the camera which took the image along with the settings (including date and time) in use when the image was taken. An in-line thumbnail can be included.

EXIF format contains a set of marker sections named Image File Directories (IFD). The sections likely to be found in a normal EXIF file are as follows:

- **Image Information**: contains general information about the image.
- **Embedded Thumbnail**: contains information about the embedded thumbnail image.
- **Photograph Information**: contains extended information about the photograph.
- **Interoperability**: contains information to support interoperability between different EXIF implementations.

2.2.3.1.2 How to Use EXIF Viewer

You can review embedded EXIF information for the selected image from the first sidebar tab. The EXIF Viewer is purely informational: nothing you do with it will cause any change to the EXIF sections. If there are more entries than space available, just scroll down with the mouse wheel.

You can use two different levels to display EXIF marker sections:
• **Simple**: display only more important EXIF marker for photograph.
• **Full**: display all EXIF markers.

Some vendors add additional EXIF sections, such as Canon, Fujifilm, Nikon, Minolta, and Sigma. These sections contain vendor and model specific notes. These will be displayed on the **Maker-note** tab.

### 2.2.3.2 Makernote Tags

#### 2.2.3.2.1 What is Makernote

The EXIF standard defines a Makernote tag, which allows camera manufacturers to place any custom format metadata in the file. This is used increasingly by camera manufacturers to store a myriad of camera settings not listed in the EXIF standard, such as shooting modes, post-processing settings, serial number, focusing modes, etc. but this tag format is proprietary and manufacturer specific.

#### 2.2.3.2.2 How to Use Makernote Viewer

You can review embedded Makernote information for the selected image in this sidebar tab. The Makernote Viewer is purely informational: nothing you do with it will cause any change to the Makernote sections.

### 2.2.3.3 IPTC Tags

#### 2.2.3.3.1 What is IPTC

The **International Press Telecommunications Council**, is a consortium of the world’s major news agencies and news industry vendors. It develops and maintains technical standards for improved news exchange that are used by virtually every major news organization in the world.
The IPTC was established in 1965 by a group of news organizations to safeguard the telecommunications interests of the world’s press. Since the late 1970s IPTC’s activities have primarily focused on developing and publishing industry standards for the interchange of news data.

In particular, the IPTC defined a set of metadata attributes that can be applied to images. These were defined originally in 1979, and revised significantly in 1991 to be the “Information Interchange Model” (IIM), but the concept really advanced in 1994 when Adobe defined a specification for actually embedding the metadata into digital image files - known as “IPTC headers”.

2.2.3.2 How to Use IPTC Viewer

You can review embedded IPTC information for the selected image in this sidebar tab. The IPTC Viewer is purely informational: nothing you do with it will cause any change to the IPTC sections.

2.2.3.4 XMP Tags

2.2.3.4.1 What is XMP

TODO

2.2.3.4.2 How to Use XMP Viewer

TODO

2.2.4 Colors

The colors sidebar has two sub tabs Color and ICC Profile. Here are more details about Color Management
2.2.4.1 Histogram Viewer

The histogram for an image shows the amount of each color that is present and their different amplitudes within the image. If your photograph has a color cast you might be able to see what is wrong by looking at the histogram.

The Histogram Viewer shows the statistical distribution of color values in the current image. It is purely informational: nothing you do with it will cause any change to the image. If you want to perform a histogram based color correction, use for example Color Balance, Levels Adjust or Curves Adjust in the Image Editor.

An image can be decomposed into **Red**, **Green** and **Blue** color channels. **Alpha** channel is a Layer in the image that supports transparency (like PNG or GIF images). Each channel supports a range of intensity levels from 0 to 255 (integer valued). Thus, a black pixel is encoded by 0 on all color channels; a white pixel by 255 on all color channels. A transparent pixel is encoded by 0 on the alpha channel; an opaque pixel by 255.

The Histogram Viewer allows you to view each channel separately:

- **Luminosity**: shows the distribution of brightness values.
- **Red**, **Green**, **Blue**: show the distribution of intensity levels for the Red, Green, or Blue channels respectively.
- **Alpha**: shows the distribution of opacity levels. If the layer is completely opaque or completely transparent, the histogram will consist of a single bar on the left or right edge.
- **Colors**: shows the **Red**, **Green**, and **Blue** histograms superposed, so that you can see all of the color distribution information in a single view.

With the **Scale** option you can determine whether the histogram will be displayed using a linear or logarithmic Y axis. For images taken with a digital camera, the **Linear** mode is usually the most useful. However, for images that contain substantial areas of constant color a **Linear** histogram will often be dominated by a single bar. In this case a **Logarithmic** histogram will be more useful.

You can restrict the analysis of the **Statistics** field shown at the bottom of the dialog to a limited range of values if you wish. You can set the range in one of two ways:
The digiKam Handbook

- Click and drag the pointer across the histogram display area, from the lowest level to the highest level of the range you want.
- Use the spin button entries below the histogram area. Left entry is bottom of range and right entry is top of range.

The statistics shown at the bottom of the Histogram Viewer describe the distribution of channel values, restricted to the selected range. These are:

- The number of pixels in the image.
- The number whose values fall within the selected range.
- The mean.
- The standard deviation.
- The median of the selected histogram portion.
- The percentage whose values fall within the selected range.
- The color depth of the image.
- Alpha channel in the image.
- The source of the histogram, either Full Image or Image Region if you have selected an area of the image in the Editor.

### 2.2.4.2 How To Use an Histogram

Histograms are a graphical means to assess the accuracy of an image shown on the screen. The graph represents the 3 regions of the photograph brightness:

- (1) : the shadows-tone on the left.
- (2) : the middle-tone in the middle.
- (3) : the highlights-tone on the right.

---

**Example 2.7 An Image Histogram in All Colors Mode**

![An Image Histogram in All Colors Mode](image)

---

61
The distribution of the graph, where the spikes and bulges are clustered, indicates whether the image is too dark, too bright, or well-balanced.

With an under exposed photograph, the histogram will have a distribution of brightness that tends to be mostly on the left of the graph.

**Example 2.8 An Under Exposed Photograph**

With an over exposed photograph, the histogram will have the bulge showing the brightness distributed mostly towards the right of the graph.

**Example 2.9 An Over Exposed Photograph**

With a correctly exposed photograph, the histogram will have a distribution of brightness that will be most prominent near the center part of the graph.
Important: not all photographs have to exhibit this bulge in the center part of their histogram. Much depends on the subject of the photograph. In some cases, it might be appropriate for the histogram to show a peak at one end or the other, or both.

The histogram is a reliable way of deciding whether or not a photograph is correctly exposed. Should the histogram show an over or under exposure, an Exposure Correction Tool should be used to fix the photograph.

2.2.5 Maps

There are four tools regarding geolocation in digiKam and two in Showfoto:

1. The Map mode of the Image Area which displays images with GPS data on a map depending on the selection on the Left Sidebar, e.g. the images in the album you selected in the Album View, the images with a certain tag assigned (selected in the Tag View), with a certain label and so on. This is only available in digiKam.

2. The Map View on the Left Sidebar of digiKam which is the search tool for finding images by their GPS data. This is also only available in digiKam.

3. The Geolocation Editor which is accessible via Item → Edit Geolocation... (Ctrl+Shift+G) (File → Edit Geolocation... in Showfoto) and allows to set and to edit GPS data.

4. The Map tab on the Right Sidebar we are talking about here which shows the location of the image on a map and is purely informative.

All four are based on the Marble widget.

This tab shows a map of orientation where you will find a marker or a thumbnail to indicate the GPS location of the selected image. The GPS coordinates and the time information are displayed below the widget. You can zoom in and out with the mouse wheel by either scrolling it or hold and drag it. Pan by holding down the left mouse button.
For navigating on the map refer to Marble handbook, Chapter 2. The meaning of ‘GPS’ and functions and buttons that apply to all three geolocation parts are described in the Geolocation Editor chapter of this handbook. This applies to the context menu on the map and the line of buttons under the map except the last one.

For information about the different map services you can use the drop-down field under the line of buttons. Choose a service here and then click the See-more-information-on-the-Internet button to the right.

The displayed positioning data are actually stored in the image’s EXIF tags. That allows the location to be read by any other application that can understand EXIF GPS data.

2.2.6 Captions

2.2.6.1 Introduction

This sidebar tab serves to apply and edit image attributes like captions, rating, date and tags. The attributes are stored in the associated database, in the IPTC and EXIF data fields and become part of the image. All attributes are accessible in one sidebar view as shown in the screenshot below. During image reading the order of priority is a) database b) IPTC and c) EXIF. So if there is a discrepancy between any of the three, this priority will take effect and a synchronization will take place. This sidebar has a first-previous-next-last arrow navigator field on top if shown in the main application.
2.2.6.2 Comment View

The caption view can be used to type or paste in a caption of unlimited size (see note below). The text is UTF-8 compatible, meaning that all special characters are allowed. The captions are copied to EXIF and IPTC fields to be used by other applications.

**CAUTION**

IPTC data only supports ASCII characters and is limited to 2000 characters (old American norm). All texts will be truncated after 2000 chars, and special characters will be malformed. If you intend to use the IPTC caption field in other applications you should be compliant with these restrictions.

After commenting, either choose the Apply button or go straight to the next image, the captions will be saved.

Next to the Apply button there is the More button. From it you can either choose to read metadata from the selected file to the database, or the other way around, to write metadata to the files (the latter take place anyway if you chose a metadata setting so that all metadata is always saved to the images).

2.2.6.3 Date & Time

In the Date & Time section, which reflects the time of taking the photograph, you can change all values. From the date combo-box a calendar opens, and the time setting spin-box can also be written by directly typing the time. The dating is copied to the EXIF ‘Date and Time’ field. If you need to change a number of images for their creating time & date, there is a more comfortable method available in Batch Queue Manager. This latter option can be found under Image → Adjust time & date.... Select the images to be changed in the main view and call the tool.
2.2.6.4 Rating

The Rating section displays a 0...5 star rating scheme that can be used in searches and sort orders. It can be applied by a single mouse click to the 5 stars in the sidebar or with a keyboard short-cut Ctrl-0...5. The rating from the sidebar is always applied to one image at a time. To rate a number of images, select them and pop-up the context menu (click with the right mouse button) to apply a common rating.

The rating is then transcribed into the IPTC ‘urgency’ data field. The transcoding follows the scheme in this table:

<table>
<thead>
<tr>
<th>digiKam Rating</th>
<th>IPTC Urgency</th>
</tr>
</thead>
<tbody>
<tr>
<td>-</td>
<td>8</td>
</tr>
<tr>
<td>*</td>
<td>7</td>
</tr>
<tr>
<td>*</td>
<td>6</td>
</tr>
<tr>
<td>**</td>
<td>5</td>
</tr>
<tr>
<td>***</td>
<td>4</td>
</tr>
<tr>
<td>****</td>
<td>3</td>
</tr>
<tr>
<td>*****</td>
<td>2</td>
</tr>
<tr>
<td>******</td>
<td>1</td>
</tr>
</tbody>
</table>

2.2.6.5 Tag Tree

The tag view shows an adaptive filter tag search box, the tag tree and a combo-box containing the tags previously applied in this digiKam session.

The tag tree will be adapted dynamically as a function of the search word as you type into the box. So it is easy to quickly reduce the number of possibilities when searching for a tag. Of course, this feature is only useful if you have many tags.

The combo-box at the bottom is another ergonomic feature for easy tagging of an image series. As you apply different tags they will be memorized in this box for quick access.

Otherwise tags are simply applied by checking the respective boxes in the tree. All tags of an image are transcribed into the IPTC ‘keyword’ data field.

**NOTE**

In case you have selected a number of images in the main view and you check a tag in the tag tree, this one is only applied to the highlighted image, and not to the whole selection. If you want to tag selections, refer to the Filters section.

2.2.6.6 Information View

TODO

2.2.7 Versions view

The Versions tab shows the history and the saved versions of a photograph. With the three buttons in the top right corner you can choose between a simple list of the saved versions, a tree view and a combined list that shows the versions together with the actions performed with the selected photograph.
The tree view shows the parent and child versions of the selected image. Here the second and the fifth version derive directly from the original image, the third and forth version are children of the second version.

The combined list shows the versions together with the actions/filters applied to them. Here the second version was created by resizing the original, applying the unsharp mask, correcting the white balance and finally adding a frame with the border tool. The child versions are grouped in Derived Versions and Related Versions. Related Versions arise if you modify the original and save the changes with **Save As New Version**.

To learn how to control what is stored as a separate version and which versions are displayed in the Image Area see **Image Versioning Settings**.


2.2.8 Filters

The Filters tab is used to limit the set of images displayed in the Image Area. Normally one uses the Left Sidebar with its different views to confine the images displayed for example to the content of an album or to images with a certain label assigned to them. The Filters tab on the Right Sidebar offers a number of filters and if one of these are filled in, selected or checked only the cross-section of these two selections will be displayed in the Image Area.

To give an example, suppose you have a tag called ‘public’ which tags all images except your private ones. Then you can check this ‘public’ tag in the Right Sidebar to hide the private images (all those not having ‘public’ tag). Whatever view mode you chose from the Left Sidebar, only ‘public’ images will be displayed. Another typical example is the selection of a subset of tags in a hierarchical tree. Suppose you want to display ‘red’ and ‘green’ from a tag tree containing 7 different colors as sub-tags. Simply click on the ‘color’ tag of the main view and check ‘red’ and ‘green’ from the Right Sidebar.

You can also use a combination of the filters but here we have to look a little bit closer: The main filters and also the different types of labels in the Labels Filter (color, pick, rating) are connected with boolean AND which means that all selected filters have to fit for the images to be displayed. If you select ‘JPG’ in the MIME type filter and ‘red’ in the labels filter only those photographs from the selection on the Left Sidebar will be displayed that have JPG format AND are labeled ‘red’.

On the other hand the tags in the tag filter and the individual labels within one type of labels are connected with boolean OR as you might have noticed already in the public/private example above. That means if you check more than one tag in the Tags Filter all images with at least one of these tags applied will show up (as long as they are not ruled out by one of the other filters).

Another use of this tab of the Right Sidebar is drag-and-drop tagging. Let’s say you chose with the help of the Left Sidebar a number of images to tag them and they are now displayed in the Image Area. If the tag already exists, simply drag it from the Right Sidebar onto one of the icons. A dialog will pop-up and ask if this tag should be applied to this item only, to all items or, if there is more than one icon selected (highlighted), to the selected items.

In the above example the main window shows the images from a calendar date, the tag filter is set to ‘Oldtimer’, which reduces the set to 3 images. In the Text Filter I typed ‘Funeral’ which leaves only one picture of the only funeral car oldtimer in my collections. Then a tag is dragged...
from the Tag Filter over the icon and dropped. A pop-up dialog asks if the tag shall be applied to
this item only or to all (displayed) items.

Note that the Text Filter has a little drop-down menu to select which image information should
be included in the search and the rating group in the Labels Filter has one to choose whether you
want a certain rating or a range.

2.2.9 Tools view

The tools view from right sidebar hosts the list of actions available to process actions on selection.
The list is an icon-view sorted by categories of tools. This view give a quick preview of all actions
from main menu. For example, with the Image Editor, you can adjust the size of the current
image with the relevant crop tool.

2.2.9.1 Sidebar Tools of the Image Editor

2.3 The digiKam Light Table

digiKam features a light table in a separate window to easily compare images. It works with all
supported image formats including RAW files.

Select one or several images in any view from the main window, call Place onto Light Table
(Ctrl-L) from the context menu. The selection will be added to the light table, and its separate
window will open. When you are back to the digiKam main window you can quickly access the
light table with Tools → Light Table (L).

From the thumbbar drag & drop images to the left and right comparison pane below. A little
arrow will indicate which copy is shown in which pane. If you choose Synchronize from the
toolbar, any zoom and panning in one window will be synchronously executed in the other pane,
so that you can compare the same areas of two images.
Another mode is better suited for quickly culling from a series of images. If you choose **By Pair** from the toolbar, the first two images will be automatically inserted into the comparison panes. Click on any thumbnail to make it the left side preview, the adjacent thumbnail to the right will be inserted into the right pane. That make it easy to sift through a series of similar images.

Of course, the usual delete actions work from the light table directly as well as **File → Edit...** (F4)

All image information from the main window right sidebar is available for each of the two previews in the light table. This makes it easy to link visual differences to exposure data for example.

In the lower right corner of each pane there you find a built-in panning action (crossed arrows). Click on it and keep the left mouse button pressed to pan across the image (in synchronous mode both images will show the same viewing point).

Zooming works the same as in other views: use indifferently the zoom slider below the panes or **Ctrl-scroll wheel** to zoom in and out, with both images when in synchronous mode.

---

**Example 2.12** The Light Table in Action

---

### 2.4 The digiKam Batch Queue Manager

#### 2.4.1 The Batch Queue Manager Window

TODO

#### 2.4.2 Batch RAW Workflow

##### 2.4.2.1 Introduction to Raw Converter

With the Batch Queue Manager, you can import/convert your images stored in **RAW format** to a target formats as (JPEG, TIFF, or PNG).
There are some considerations before you convert, and even before you shoot in raw format. RAW image file formats keep the original information of the exposure supposedly without loss (when compressed, they use reversible, lossless compressions algorithms). Many photographers prefer to take their picture in RAW mode because the camera’s built-in conversion program is often of lesser quality than what you can achieve with digital image processing. The whitebalance of the digital camera is registered but not applied to the image. Some CMOS CCD’s create four types of color filter data: RGBG, Red, Green, Blue and another Green mask for contrast enhancement. This tool can take this into account.

The conversion is actually based on libraw. Don’t expect to produce the same images as software provided by the camera vendor but sometimes libraw gives better results.

### 2.4.2.2 Using Raw Converter

Select the RAW files to convert and load them to a dedicate batch queue. In Batch Queue Manager settings view, you can adjust the available check and value boxes to optimize the RAW conversion process. The first checkbox indicates to use the camera settings for white balance. The essential parameters like brightness, and red/blue amplifier may be adjusted. If the result is not quite optimal, don’t worry, it is always possible to fine-tune the image later on.

A **Interpolate RGB as four colors** conversion can be selected to use contrast information. (If your camera works in RGB mode, the RGBG setting has no effect).

You must choose one output formats to save the conversion result by placing the target file format conversion tool. The file name will stay the same by default, only the extension changes. **JPEG** uses the lossy algorithm and produces the smallest output file size. In opposite the tagged image format (**TIFF**) preserves all information of your image while using lossless LZW compression.

#### Tip

If you intend to work a lot on your images or if it is likely that you have to reuse it later on, don’t use **JPEG** format because it allows a limited number of operations before it deteriorates visibly. **TIFF** and **PNG** are better suited to keep the original data.

#### Note

If you choose **JPEG**, or **TIFF**, or **PNG** as the **Save Format** then the metadata included in RAW file will be included in the target files as Exif information.

When you have finished to setup the queue, click the **Process** button to start the conversion. If you want abort image conversion, press the **Abort** button.

### 2.5 The digiKam Tag Manager

There are certain possibilities to manage tags from the context menu on tags in the digiKam sidebars like **New Tag...** or **Delete Tag**. The Tag Manager offers a more comfortable and comprehensive way to organize your tags. For general information about tags, why and how to use them see **Tags View** in the Main digiKam Window chapter.
2.5.1 The Tag Manager Toolbar

The toolbar at the top offers

- an adaptive search field to find certain tags in a big tree
- a button to add a tag as a sub-tag to the current (last clicked) tag
- a button to delete a tag or a selection of tags
- the drop down menu Organize which contains
  - Edit Tag Title
  - Reset Tag Icon to the standard tag icon
  - Create Tag from Address Book
  - Invert Selection, useful if you want to select most but not all of your tags
  - Expand Tag Tree expands all of the nodes of the tag tree
  - Expand Selected Nodes
  - Remove Tag from Images un-assigns selected tag(s) from all images
  - Delete Unassigned Tags, useful to clean up your tag tree
- and the drop down menu Sync Export which contains
  - Write Tags from Database to Image
  - Read Tags from Image (and write them to the database)
  - Wipe all Tags from Database only

2.5.2 The Tag Manager Window

The Tag Manager window consists of two parts, the Quick Access List to the left and the Tag Tree (or parts of it) to the right. On the right sidebar you fold out additionally the properties dialog for the selected tag.

The Quick Access List allows you to display only a certain node (and its sub-nodes) in the tag tree window. Select a tag in the tag tree and click Add to List. The tag will appear in the Quick Access List. If you select it there the tag tree will show only that node which you can still expand to see the sub-nodes. Note that the tag tree will also show only a limited number of tags while using the search field. It will show only those tags that contain the string in the search field.

The Tag Properties dialog allows you to change the name of the tag, the icon used in the Tag tree and the shortcut.
2.6 Digital Asset Management (DAM) with digiKam

2.6.1 Introduction to DAM

...in the end, photographs need a lot of care. I hope it’s you who said this.

Can you find your digital photographs when you need them? Or do you spend more time sifting through your hard drive and file cabinets than you would like? Do you have a systematic approach for assigning and tracking content data on your photos? If you make a living as a photographer, do your images bear your copyright and contact information, or do they circulate in the marketplace unprotected? Do you want your future grandchildren to admire your photographs you have taken yesterday? How do you ensure backup and the correctness of your data? How to prepare to change your computer, your hard disk, the software, the operating system and still manage to find your pictures or movies?

What is digital asset management - apart from a buzz word? Digital Asset Management (DAM) refers to every part of the process that follows the taking of the picture, all the way through the final output and permanent storage. Anyone who shoots, scans or stores digital photographs is practicing some form of DAM, but most of us are not doing so in a systematic or efficient way.

We present a tool, a plan and practical advice on how to file, find, protect and re-use photographs, focusing on best practices for digital photographers using digiKam. We cover downloading, renaming, culling, converting, grouping, backing-up, rating, tagging, archiving, optimizing, maintaining and exporting image files.

A generic definition:

“Digital Asset Management ingests, indexes, categorizes, secures, searches, transforms, assembles and exports content that has monetary or cultural value.”

And since we’re at it another important one:

Metadata is defined as data about data. Metadata is definitional data that provides information about or documentation of other data managed within an application or environment.

In our context here it stands for all information about a photograph.

digiKam with its libraries and tools is a unique and comprehensive tool to cover most of DAM tasks, and it does it fast and transparently. Based on open standards on all fronts it will not confine you to a platform or application, rather it puts you into a fast track to manage and find your photographs and to move on if you so please to any other platform, application, system without losing any of your work be it as an occasional user, enthusiast or professional.

The one thing that differentiates the archiving capabilities of film vs digital is that with digital you can make as many new originals as you want. With film you only have one original. All copies will have a slightly lower quality, and both originals and copies are more or less slowly aging and disappearing. The only way to keep it “forever fresh” is to make a digital copy of it. And that is also the only way to protect it from all hazards.

Even if digital media today may last shorter than film it is just up to you to make new copies every year, 5, 10 years or whenever necessary, and to always keep at least 2-3 copies of the files, preferably in different physical locations. You never had that opportunity with film. It could always be damaged in a fire, floods or similar - or even be stolen. The good and bad news then is this: if you lose digital images/data it is only your own laxity.
2.6.2 Build a System to Organize and Find Your Photographs

Themes: hierarchy, tags, rating, captions, geolocation, date, albums, filenames, versioning, exporting

I dare-say if you have more than 1000 photographs on your computer in no-DAM fashion it takes you too long to find any particular image. And if you don’t know how many images are in your files you’re surely not using digiKam. The dual approach to store metadata in a database and in the image files guarantees ultra fast searching and secure archiving freely accessible to other applications, platforms and formats.

But as much as there is no such thing as a free lunch, there is no free cataloging or DAM - those who spend the initial time of building a systematic method of their own will be better off as time passes and the number of photographs multiplies. The ROI (return on investment) of DAM has been estimated in different studies to be better than 10. Keep in mind to be concise, plan for the future (30-50y), do it once. The upcoming semantic web will totally integrate into and add value to a DAM environment.

2.6.2.1 A case for doing DAM with digiKam

digiKam provides a number of methods to classify photographs: filenames, albums, collections, date + time, tags, rating, GPS position and captions. As if this was not enough, you can search many standard metadata items like camera model, lens, coordinates, image size and many more. Metadata categories as listed here are in fact different ‘views’ of your photo library. Combining these views is the very powerful method to narrow down the search for a file and to find it quickly. Imagine having 800 photos of your loved one. Searching for ‘Mary’, having more than ‘***’ rating, shot in ‘France’ will surely leave you with very few candidates. In terms of selection criteria for a DAM system, digiKam fares very well in terms of completeness, versatility, speed, scalability, accuracy and openness.

The key thing to remember is that you don’t know how you or somebody else will try to find an image 2 years ahead of our time. You will remember past events in a different context, it’s a fact of life. So if you can narrow down your search by remembering place or time or camera or theme or rating or owner you stand an infinitely better chance to find it quickly than by just one of those criteria or none. At the beginning, at the time of taking a photograph, all metadata is in your head (except for the EXIF data). If you do not transcribe some of it into your DAM system, it will be lost eventually as much as every event fades into oblivion over time.

One distinction has to be interjected here between private and public metadata. One could say that all file-embedded attributes are potentially public since the images may be exported, sold, and copied to other places and people. On the other hand all non-embedded metadata in the database can be considered private as they stay in the database and go nowhere else. By adjusting digiKam’s settings accordingly you can control what kind of data remains private and what will be embedded and eventually become public.

2.6.2.2 Build the archive: Folder organization, physical layout as information

The first thing to do and to know before you put anything onto your system is to build an information structure (as opposed to data structure). Your image files have to be somehow organized within the computer, you have to decide if others should have access to your photographs (sharing), if you put them on a dedicated drive, on a network drive etc. Keep in mind that you have to migrate one day onto some bigger volume.

The organization should be simple, unified and scalable, and it should be independent of the storage medium on which you host them. Do not make the folders too small, several thousand images in one folder is not too much to ask for, but keep them small enough so that they can fit into a backup medium like a DVD or a Blue Ray. Remember that the archive will grow all the time! The concrete type of structure depends on your use case of course: Let’s take a simple yet
frequent example: you are a casual photographer taking pictures of your private life, your family, holidays and so on. It could be efficient to create a structure based on years plus some holiday and export containers. It could look like this:

<table>
<thead>
<tr>
<th>Year</th>
<th>Subfolders</th>
</tr>
</thead>
<tbody>
<tr>
<td>2006</td>
<td></td>
</tr>
<tr>
<td>2007</td>
<td></td>
</tr>
<tr>
<td>2008</td>
<td></td>
</tr>
<tr>
<td>Holidays</td>
<td></td>
</tr>
<tr>
<td></td>
<td>A</td>
</tr>
<tr>
<td></td>
<td>B</td>
</tr>
<tr>
<td></td>
<td>C</td>
</tr>
<tr>
<td>Export</td>
<td></td>
</tr>
<tr>
<td>Fun stuff</td>
<td></td>
</tr>
</tbody>
</table>

Maybe you’ll be happy with this structure. Holiday pictures can be quickly found by its location (unless you go to the same place every year), the rest will be organized by date. If you shoot enough pictures you want to create sub folders below the years as months e.g. 2008-01, 2008-02 etc. ‘Export’ would be a container for images to print or to put onto a website.

The more professional photographer will have very different needs as there will be versions of photographs, archives, workflows, a constant influx of images of diverging themes, and a large quantity of everything. Within 10 year you’ll have 95% archives and 5% work space files and you don’t want to organize your structure around content!

The consideration are these:

- What kind of files go together? Segregation of file type makes batch processing easier. Keep new and old files separate.
- How can you make that structure scalable?
- Segregation of original and working files makes it easier to allocate the backup strategy and migration. You will always know if you look for an original or a derivative.

2.6.2.3 Automatic metadata generation

How to go about all this metadata business? Firstly, there are already a lot of automatically generated metadata: EXIF data and Makernotes. If you have configured digiKam with your identity section all imported images will be imprinted with this data set which includes copyrights, all automatic. If you have a GPS track recorded in parallel to your taking the photographs, you can geolocate those images in a single action using the Geolocation tool. Even if you brought back 1000 images from a shooting session, so far you’ll not have spent more than 10 minutes to do all that. And by now you have all camera settings of every shot, lens data like zoom, focus, aperture etc., date and time, shooting location, copyrights, authorship, program used, and more. Not bad, isn’t it? But we could have done more during the importing, we could have changed the file names to include the date, or place or theme, we could have changed the format to a lossless 16 bit per channel format, we could have automatically separated JPEG and RAW files into their folders. I actually recommend to auto-rename to match an event, a place or a theme. digiKam provides all date/calendar related grouping so that there’s hardly a need for coding the date into the file name. Unless you’d like to do just that to browse your albums with another application that is not calendar savvy. You will buy a new camera one day or you have a second one already, sooner than you believe. The numbering scheme of that new camera will start over at typically IMG_0001.JPG again, creating identical file names to the ones you have already if you do not rename them. By renaming you lessen the chance of inadvertently overwriting them at a later date. Keep the new names clean, use alphanumerics, dashes, underscores and a single period prior to the file extension.
I also recommend to switch-on the ‘save metadata’ options in the digiKam settings page for metadata. This will ensure that EXIF and IPTC data is written into the file. If you forgot to do that you can always catch up by copying the metadata in the database to the files in one go (from the Album menu).

Now we have a lot of stuff already in our database, but what if I need to change some of it? digiKam provides a metadata editor for a selected number of attributes, the most important ones of course.

The real work begins here as we will apply tags, captions and a rating to every photograph. Of course, all images requiring the same attribute can be treated as a selection in one action. Let's start with rating or ranking. It's best to start with ranking because for further work you can concentrate on the good shots.

### 2.6.2.4 Rating/Ranking

A ranking systematic is implemented in digiKam by the 5 star rating tool. In fact there are 6 levels, zero through five stars (*) can be attributed (when saving them into IPTC metadata a translation of levels ensures compatibility with other programs). Rating is rapidly applied with digiKam using keyboard shortcuts or the mouse on single photographs or whole selections. The rating can then be entered as a search criterion or directly from the status bar quick filters. However, before you start attributing stars everywhere take a moment to establish personal criteria for ranking. Best practice is to write down your personal match of stars to some qualitative expression, that will define what you actually mean when giving 5 stars. Generally there should be much less images rated with increasing star assignment. A ratio of 3-10 between each level has proven useful. That will get you quite far in distinguishing your rating pyramid. Say, you choose a ratio of 7 between levels. For every 5 star image you’ll then have 74 stars, 49 3 stars and so on, resulting in almost 20000 pictures. Amazing? Yes, and 16807 of them you didn’t have to rate at all! You even can define a different rating scheme depending on the kind of use, 2 stars for commercial use, may mean something else than 2 stars holiday photos. It is also a good practice to define a neutral rating, everything below is actually a negative rating. This will help you culling and thinning your collection very efficiently. Or you could define purposes to ratings, say 0 stars for ‘can throw away’, 1 star for images in quarantine (decide later), 2 stars for gallery export, 3 stars for printing, 4 stars for selling, 5 stars for ‘have to work on’, as you please. It must suit your needs. The following table illustrates a possible evolution for a professional photographer using a ranking ratio of roughly 7 over the next 12 years. It is evident that the good shots can be easily found, even within millions of photos.

<table>
<thead>
<tr>
<th>Rating</th>
<th>Year 2008</th>
<th>Year 2020</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total Images</td>
<td>132241</td>
<td>1503320</td>
</tr>
<tr>
<td>Neutral (0 stars)</td>
<td>55000</td>
<td>640000</td>
</tr>
<tr>
<td>*</td>
<td>72020</td>
<td>810000</td>
</tr>
<tr>
<td>**</td>
<td>4880</td>
<td>49000</td>
</tr>
<tr>
<td>***</td>
<td>301</td>
<td>3200</td>
</tr>
<tr>
<td>****</td>
<td>38</td>
<td>400</td>
</tr>
<tr>
<td>*****</td>
<td>2</td>
<td>720</td>
</tr>
</tbody>
</table>

Let's continue with tags (or keywords as called by other applications, or categories, they are all synonymous).
2.6.2.5 Tagging, Keyword assignment

Tags are a hierarchical labeling system that you create as you add to it. The important thing to do is to create a system that suits your needs and habits. Are you a (semi)professional who wants to sell photographs to agencies, do you want to publish on a web gallery, or are you just the occasional amateur managing the visual family memory? For all these different use cases you want to design a tag structure that is adapted to it. If you configure it so, digiKam will write the whole hierarchy into IPTC fields so that they can be used by your photographic agency using a different application of to automatically create title and caption for web exports. In any case it will serve you well to quickly find a specific picture again.

The hierarchy will provide you with automatic groupings. For example, if you start a typical private use hierarchy with 'Activities', 'People', 'Places', 'Themes' and 'Projects' on the top level, everything you tag with a sub-tag of these will be grouped together into a virtual album. digiKam has a dedicated view in the left sidebar for these virtual albums. But it comes even better! As you continue adding sub-tags into the hierarchies, not only will you be able to search and quick-filter for them, the right sidebar tag filter allows you to select combinations of tag groups. Lets say in the left sidebar tag panel you select the virtual album 'People' and you have 12 different tags for people in there, then you can combine it with the right sidebar and just choose 'Peter', 'Paul' and 'Mary' out of the 12.

In the long run you will not remember the details of your pictures and their subject (essentially the metadata in your brain will break down). It is therefore paramount that you choose general and generic categories. You will always remember that a particular shot was set at a river bank in a country or continent (-> river, continent), but you’ll have forgotten which river it was. Instead of only tagging it with 'Okavango' you tag it with river/Africa or river/South Africa. The details you can either put into a tag as well or into the captions. A trick may help you: How would you search for that river with an Internet search engine? That’s the way to go!

Another categorization might be task-oriented as in ‘print jobs’, ‘web export’, ‘personal’, ‘galleryXYZ’, ‘clients’, ‘slideshow’, etc. Create groups as you need them but not more, you should be able to remember by heart the top level tags at least, otherwise the differentiation will become useless. Don’t forget that you have all the other attributes to narrow down the search. The right sidebar tag filter combines with any view of left sidebar (albums, calendar, timeline, tag and search).

When you import cataloged images from other sources having embedded tags already, digiKam will automatically create the trees for you, respectively insert it into the right place. Rearranging the hierarchy within the tree is no problem, you can do that easily by dragging and dropping a sub-tree to another place in the hierarchy. The changed tags will be updated as digiKam ripples down the branches.

The graphics here shows how different metadata overlap. This is a very coarse representation, as each block of metadata will in itself be subdivided into many sections. File names and calendar data are properties of all images.
Enough of tags - let’s move on to captions or comments, the third major tool for metadata cataloging.

2.6.2.6 Captions/Comments

This is already the 4th kind of metadata we present here. What is the distinction of captions compared to tags (comments can be used synonymously, but the IPTC vocabulary stipulates the term ‘caption’), keywords? Where tags owe to a hierarchical and generalized description, captions are the opposite: prose description, details, anecdotal stuff. Tags foremostly serve the finding, retrieval and grouping of assets, whereas captions shall entertain, inform, touch the beholder. Naturally they can also be used to filter the catalog, but this is just a byproduct. Captions are to remember the story, the event, the emotions, it’s what makes photographs much more interesting to look at, captions put photographs into a context and meaning. If the pictures are an aesthetic statement, caption should be the emotional and informational complement.

You rarely want nobody to see your photographs. You rather want to share them with friends, your family, other photographers, agencies, put them onto the Internet. And don’t tell me you’re not interested as to how your photos are being received!

So you might have the most beautiful portrait, sunset or landscape and nobody seems to care. Why is that? Look at some good photographs yourself without reading the title, comment or background information. How many of you are interested in depth of field, exposure time, white balance etc.? Some, of course. But anybody will be interested in the story the pictures tell, you want to remember a photograph, meaningless images bombard us too much anyways. You have to give the viewer something that explains it all.

Let’s look at this panorama. From far it is not even a nice beach panorama. If you go closer you start to see some details, people, the space.
And now I tell you that this is the Allies landing site "Omaha Beach" in the French Normandie 60 years after the disembarkation. Wow! One starts to dream, have associations, memories, the historical time span is present, you may hear the silence. The caption has totally reframed to perception of this panorama.

For others to appreciate your photographs, the title is probably more important than the image itself for the interest it creates. When you show pictures, tell a story. Remember that the key is to convey the meaning to viewers, to help them understand what you understand about the subject and what moved you.

- let people know what you understand about the subject, why you love it
- create a red line between the photographs
- oppose or relate them to different epochs
- take notes shortly after shooting to remember
- contemplate, research, watch, and talk - but mostly listen.
- it’s okay if the image is less than perfect because it has the strength to stand on its own merit described in the caption.

With digiKam you can enter unlimited amounts of text using internationalized alphabet (UTF-8) as caption. You can enter it for a selection of photos at the same time. When you export images to web services, the captions will be exported at choice into either/or/and caption/title of the web gallery system, no need to re-write the story for publishing.

2.6.2.7 Geolocation (geo-tagging)

Do you still remember the times before GPS? When you would find your way to another city without navigation system? Wasn’t the earth a dull blue ball before GoogleEarth? Well then, with images, the train of spatial representation is running at cruising speed alright.

A few cameras have a GPS receiver built-in, the images come tagged with 3-dimensional coordinates. And with almost any GPS device you’re able to extract a trace (of course the receiver needs to be switched-on and carried with you whilst taking the photographs, and for good matching the camera time must be accurately set) and save it onto a computer. You have to store it in gpx format, that’s easily done with gpsbabel, gpsman and other tools. You then can automatically match a whole bunch of photos with that track using digiKam. The coordinates are written into the JFIF part of JPG files (settings choice) and into the database. digiKam will enable searches based on locations and coordinates, you can create virtual albums of geographical areas! In the right sidebar under the metadata tab you’ll find your image located on a local zoom of the world map. A further click brings on anyone of several mapping services on the web, zooming in on
details. Even if you don’t have a GPS trace you can geo-tag multiple images with a geo-editor. Just navigate on the map to the spot of shooting and click to fix it as a geo-tag.

e.g. conversion of a Garmin track with file name ‘xyz’:

```
$ gpsbabel -w -i mapsources -f xyz.mps -o gpx -F xyz.gpx
```

The possibilities of exploiting this geolocation are already innumerable and will become pervasive in the future. I’m sure one day not too far away we can revisit in a virtual reality our travels through geo-tagged pictures. The digiKam features include exporting to kml files that can be opened by GoogleEarth (which in turn will show the photos on their shooting site), exporting to gallery2, picasaweb, flickr etc. with GoogleMaps viewer and more.

### 2.6.3 Protect Your Authorship and Copyright

Themes: watermarking, IPTC and XMP authorship data, export size

This will be the last chapter and step to mark your digital library with authorship, ownership and copyright or -left information. More than in ‘the good(?) old days’ of paper copies, the ubiquitous Internet makes it just too easy to ‘steal’ a picture from a web site. At the very least, for all images that will be exported and/or published in any form, the authorship and copyright information should be part of their metadata. Nothing more simple to do with digiKam: you can setup the default identity, and any images ingested by digiKam will be automatically informed. I put copyleft in the title for a reason (citation from wikipedia):

> “Copyleft is a play on the word copyright and is the practice of using copyright law to remove restrictions on distributing copies and modified versions of a work for others and requiring that the same freedoms be preserved in modified versions.

Copyleft is a form of licensing and may be used to modify copyrights for works such as ... music, and art. In general, copyright law allows an author to prohibit others from reproducing, adapting, or distributing copies of the author’s work. In contrast, an author may, through a copyleft licensing scheme, give every person who receives a copy of a work permission to reproduce, adapt or distribute the work as long as any resulting copies or adaptations are also bound by the same copyleft licensing scheme. A widely used and originating copyleft license is the GNU General Public License. Similar licenses are available through Creative Commons - called Share-alike.”

And here follows a description of what should be supplied to digiKam’s setup page as information:

**Author** (synonymous with Creator and By-line): This field should contain your name, or the name of the person who created the photograph. If it is not appropriate to add the name of the photographer (for example, if the identity of the photographer needs to be protected) the name of a company or organization can also be used. Once saved, this field should not be changed by anyone. This field does not support the use of commas or semi-colons as separator.

**Author title** (synonymous with By-line title): Linked to Author. This field should contain the job title of the photographer. Examples might include titles such as: Staff Photographer, Freelance Photographer, or Independent Commercial Photographer. Since this is a qualifier for the Author field, the Author field must also be filled out.

**Credit** (synonymous to Provider): Use the Provider field to identify who is providing the photograph. This does not necessarily have to be the author. If a photographer is working for a news agency such as Reuters or the Associated Press, these organizations could be listed here as they are ‘providing’ the image for use by others. If the image is a stock photograph, then the group (agency) involved in supplying the image should be listed here.
Source: The Source field should be used to identify the original owner or copyright holder of the photograph. The value of this field should never be changed after the information is entered following the image’s creation. You should consider this to be a write-once field. The source could be an individual, an agency, or a member of an agency. To aid in later searches, I suggest to separate any slashes ‘/’ with a blank space. Use the form ‘photographer / agency’ rather than ‘photographer/agency.’ Source may also be different from Creator and from the names listed in the Copyright Notice.

Copyright Notice: The Copyright Notice should contain any necessary copyright notice for claiming the intellectual property, and should identify the current owner(s) of the copyright for the photograph. Usually, this would be the photographer, but if the image was done by an employee or as work-for-hire, then the agency or company should be listed. Use the form appropriate to your country. For the United States you would typically follow the form of © [date of first publication] name of copyright owner, as in ‘copr 2005 John Doe.’ The word ‘copyright’ or the abbreviation ‘copr’ shall be used in place of the (c) symbol as ASCII characters only are allowed. In some foreign countries only the copyright symbol is recognized and the abbreviation does not work. Using something like (c) where the parentheses form a partial circle is not sufficient. For additional protection worldwide, use of the phrase, ‘all rights reserved’ following the notice above is encouraged. In Europe you would use: Copyright [Year] [copyright owner], all rights reserved. In Japan, for maximum protection, the following three items should appear in the copyright field of the IPTC Core: (a) the word, Copyright, (b) year of the first publication; and (c) name of the author. You may also wish to include the phrase ‘all rights reserved.’

Whereas it is paramount to fill-in the author and copyright sections, they represent no protection against fraud. Anyone with a bit more than basic computer knowledge is able to delete or modify image embedded metadata. The solution to this problem is called ‘digital watermarking’. To private persons this might be of little interest for the majority of photographs, but for professionals ans semi-professionals this protection is really important.

2.6.3.1 Digital Watermarking (DW)

Digital Watermarking refers to an invisible digital watermark that is being impressed on photographs as an element of digital rights management (DRM). The watermark contains the same information of authorship and copyright as described above, but the metadata is encrypted and saved in the actual image data (as opposed to the metadata section which is a separate section within the image file). This invisible imprint has holographic properties so that modifications done to an image (size, color, crop, up to a certain limit) will not destroy the copyright information. Only when an image is resized to a very small fraction like a thumbnail will the embedded information be lost, but then the image is of no value anymore to the copyright infringing party.

The digital watermark will be unique per image. digiKam will provide a tool for DW in the near future that features batch processing.

2.6.4 Protect Your Images from Data Corruption and Loss

Themes: disk errors, disk failures, power surges, ECC, transmission errors, storage media deterioration, recovery, redundancy, disaster prevention, lifetime, temperature, data size, common myths

2.6.4.1 What are then the main factors of digital data loss?

Of course we’re not talking about losing CDs on the road or in a fire - that kind of loss is just the same as traditional paper copies or negatives. We are talking about problems with the so called “New Media”.

Problems with digital data can roughly be categorized into the following areas of concern:
1. the physical deterioration of the media (all media deteriorate at different time scales)
2. undetected transmission errors during data transfer
3. the lack of support for long-date, undoubtedly proprietary, digital formats
4. ancient hardware.

Kroll Ontrack, the worlds largest data recovery firm, have some interesting statistics on what actually causes data loss.

<table>
<thead>
<tr>
<th>Cause of data loss</th>
<th>Perception</th>
<th>Reality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hardware or system problem</td>
<td>78%</td>
<td>56%</td>
</tr>
<tr>
<td>Human error</td>
<td>11%</td>
<td>26%</td>
</tr>
<tr>
<td>Software corruption or problem</td>
<td>7%</td>
<td>9%</td>
</tr>
<tr>
<td>Computer viruses</td>
<td>2%</td>
<td>4%</td>
</tr>
<tr>
<td>Disaster</td>
<td>1-2%</td>
<td>1-2%</td>
</tr>
</tbody>
</table>

So let us analyze those cases step by step!

2.6.4.2 Physical deterioration

2.6.4.2.1 CD, DVD, Blue Ray, optical drives

Physical deterioration of the media happens more rapidly with paper and CD-Rs than the average of film. Yet while film lasts longer (sometimes decades longer) than other forms of media, the right kind of backup of digital media never loses anything. Film decays - digital 1’s and 0’s do not, and film starts to decay the moment it’s created and developed. It will never have the same color, contrast, etc. that it did have a moment before. Digital doesn’t do that. However, digital is susceptible to corruption! And yes, physical media such as floppies and magnetic hard drives are also susceptible to the decay of the medium, just like CDs are. They just last longer.

To combat the problem of CDs/DVDs, they need to be properly cared for and not trusted for more than a few years. Thankfully you can purchase archive-quality CDs and DVDs which last longer, though they are much more difficult to obtain and are much more expensive. There are offers out there for gold-plated DVDs, $2 a piece claiming 100 years storage life (if you care to believe it).

CD/DVD disks may become unreadable, but you can reduce the risk using good disks and a good recorder, and storing them in a correct way. The best DVD recorders are not much more expensive than the cheapest, but they write in a much more reliable way. It’s a matter of choosing the right one.

Essentially, CDs and DVDs are very prone to errors, even in a freshly written state. That’s why they are heavily protected with a checksum mechanism (75% of data are effective data, the rest is formatting and checksum overhead). But even with that massive amount of protection they will suffer deterioration from chemical aging, ultra-violet exposure, scratches, dust, etc.

For damaged CDs and DVDs, there is an inexpensive program called IsoBuster from which will do seeming miracles on CDs and DVDs. It runs on Windows and Linux®, but not (yet) on Macs. Similarly, there are applications designed to get data from damaged floppies, hard drives, flash media such as camera memory and USB drives, and so forth.
Optical media: Blu-ray disks seem to win the format war against ‘HD DVD’. A dual-layer Blu-ray disc can store 50 GB, almost six times the capacity of a dual layer DVD at 8.5 GB. Everything that has been said about CDs/DVDs applies to Blu-ray disks as well.

Best practice:
Burn them slowly with a good recorder on archive quality media in an open, non-proprietary format, read the data back to verify, label them with some descriptive text + date & author, lock them away where it is clean, dark, animal safe and dry. And do not forget to copy them over to the next generation of media before you throw away your last piece of hardware or software able to read them.

2.6.4.2.2 Hard disks (hard drives, HDD)

Disk manufacturers keep their statistics to themselves. A manufacturer guaranty buys you a new disk, but no data. Google for one has done a large scale study on HDD failure mechanisms: Disk Failures study

In a nutshell: Disks run longest when operating between 35C and 45C, at lower temperatures the error rates increases dramatically. Controller parts (electronics) are the foremost sources of failure, SMART does not diagnose any of this. Some SMART errors are indicative of imminent failure, in particular scan errors and relocation counts. Lifetime expectancy is 4-5 years.

But all depends much on the real use case and some luck. For example I have a Fujitsu notebook that is running 24/7 since 1998, almost ten years without the slightest hick up. Just luck? In general and contrary to intuition or ecological considerations, running a hard drive permanently results in a longer lifetime than switching it on and off all the time. It has even been reported that aggressive power management spinning down the drive can harm it quickly. Making it working hard shortens the lifetime somewhat. The worst factors for HDD probably are vibrations, shocks, and cold temperatures.

If your disk is making weird noises, normal file recovery software isn’t going to work. Do a quick backup if that is going to happen to you. (Use dd utility if possible, not a normal file backup since dd reads in a smooth, spiraling stream from beginning to end and doesn’t stress the mechanics). There are specialist companies that can recover data from otherwise destroyed drive, but they are costly, plan for 2000$ minimum charge.

2.6.4.2.3 Power surges

As much as 1% of all computers are affected by lightning and power surges every year. (This is about total data loss due to power surges. Of course you can have the occasional data loss due to power loss before saving files. But those losses can normally be restored without major difficulty.)

You don’t have to wait for the next thunderstorm to be concerned about how a sudden fluctuation in electric power may affect your computer system. Recent statistics have shown that as much as 63 percent of all electronics casualties are due to power problems, and most computers are subject to two or more power anomalies a day. Since power surges or blackouts can occur anywhere and at any time, it only makes sense to protect your computer by investing in some sort of surge protection device.

2.6.4.2.4 How surges happen

A power surge occurs when the power line voltage increases over nominal values for more than 10 milliseconds. Sixty percent of all power surges are caused from within the home or office, generally when a device with a motor (such as a hair dryer, refrigerator, or water pump) shuts off and the power it was using is diverted elsewhere as excess voltage. The remaining 40 percent of power surges are generated by factors such as lightning, utility grid switching, line slapping, poor wiring, and so on.
While most average electricity-using devices are not affected by power surges, devices relying on computer chips and high-speed microprocessors are susceptible to serious damage. For your computer, power anomalies can result in keyboard lockup, complete data loss, hardware degradation, damaged motherboards, and more. Failure to protect yourself from the inevitable can result in a loss of both time and money.

### Surge protectors

The most common defense against power surges is a surge protector or suppressor, a device that works by absorbing some of the excess energy and diverting the rest of it to the ground. These are usually found in the form of a power strip (one of those long devices that have six or so outlets and a single, grounded plug). Bear in mind, however, that not every power strip serves as a surge protector.

When selecting your surge protector, you want to be sure it is listed as meeting the UL 1449 standard, which guarantees a certain minimum of protection. You should also look for one that offers protection against lightning (not every one does) and provides insurance for equipment that is properly attached.

Because a power surge can follow any path to your computer, be sure that each peripheral connected to your system is protected. This includes your phone line or cable modem, as power can surge through these routes as well. A number of manufacturers are now producing surge suppressors that feature a phone jack for your modem along with the electrical outlets, while others have coaxial cable jacks for those who use a cable modem or TV tuner card.

If you have a notebook computer, you will want to carry a surge suppressor as well. A variety of suppressors designed specifically for notebooks are available, small in size and possessing both electric and phone outlets that make them ideal for use on the road.

### Uninterruptible power supply (UPS)

While a surge suppressor will protect your system from minor fluctuations in the power lines, it won’t help you if the power should black out completely. Even an outage of just a few seconds can result in the loss of valuable data, so you might find it worthwhile to invest in an uninterruptible power supply.

Besides serving as surge suppressors, these devices automatically switch to battery power when a power outage occurs, giving you the opportunity to save data and shut down your system. Some models will even allow you to keep working until power is restored. When purchasing a UPS, be sure that it has the same qualities that you would seek in a surge suppressor, but also check out the battery life and included software.

Considering the potential risk to your computing system, ensuring its safety from power disturbances is a worthwhile investment. A quality surge suppressor will cost you upward of €20, a 500W UPS can be had for less than €40. It’s a small cost to pay for the peace of mind you’ll gain knowing your computer is well protected. In the very least pull all lines to your computer when you go on holidays.

### Solid state drives: USB sticks, memory cards, flash disks

SSDs are mechanically more robust than HDDs and suffer much less on that front when they are plugged into the computer. But since they are mostly mobile devices, their exposure to drops, accidents and electrostatic discharges is much higher. So, for different reasons, SDDs are as likely to fail if not more than hard drives. Add the danger of theft and longevity and limited capacity, and SDDs will become prohibitive as permanent data storage devices.

One major cause for data loss (often recoverable) is the unsafe removal of SDDs from a computer. Before data is saved from a computer memory to any attached device, it remains for some time in
buffers. In hard drives this means seconds at most, whereas with SDDs it can be tens of minutes. Therefore, before you disconnect a flash device, always activate data flushing through software (often called “safely remove device”).

There is a new technology trend coming up, to replace hard drives with SSD flash drives. By 2010 they may be competitive in price to HDDs. Data retention is an issue with SDDs, it cannot be overwritten an infinite amount of times. SDDs wear in use. Wear then depends much on the location data is written, and how often it is written. Linux® has developed a special driver avoiding writing to the same spot too often. But this is all premature information. Keep your eyes and ears open.

2.6.4.2.8 Magnetic media

Magnetic tapes are used in backup systems, much more in professional environments than in home use. Tapes have issues with data retention and changing technology, but they are safer in one aspect than CDs and DVDs: they are less exposed to scratches and dirt and writing deficiencies. On the other hand they are susceptible to magnetic fields. Throw a magnet next to a tape and it’s gone! Tapes should be re-copied every 5-8 years, otherwise too many bits will fail and escape the checksum protection. The downside of magnetic tapes is often the recorder price and the restore time (20x longer than from HDD). Tape backup system have seen their best days.

2.6.4.3 Saveguarding against logical errors

2.6.4.3.1 Web storage services

Amazon Web Services includes S3 - Simple Storage Service. With appropriate configuration, you can mount S3 as a drive on Linux®, Mac, and Windows systems, allowing you to use it as a backup destination for your favorite software. Google Shared Storage is another popular offer where one can store infinite amount of data.

It is expensive compared to hard drives at home - 40 GB cost $75 a year, 400 GB cost $500. And you have to transfer the images over the (a comparatively slow) Internet.

I think as a safeguard against localized data loss of the most essential images it’s not a bad idea at all, but it is not a general backup solution, much too slow for that.

Google Photo, Flickr (Yahoo) and Foto-Community 23hq.com provide online storage services specialist on photographie. Their free space is limited to 1 GB and you don’t want to have full resolution images online. But the pro-accounts offer more, in the case of Flickr, dramatically more. For a mere 25$ a year you get unlimited (sic! reality check needed here) space.

In terms of data retention the web space solution is probably pretty safe. Transmission errors are corrected (thanks to the TCP protocol) and the big companies usually have backup included plus distributed storage so that they are disaster proof within themselves.

2.6.4.3.2 Transmission Errors

Data does not only get lost from storage devices, it also gets lost when traveling inside the computer or across networks (although the network traffic itself via TCP is error protected). Errors occur on buses and in memory spaces. Consumer hardware has no protection against those bit errors, whereas it is worthwhile to look into such. You can buy ECC (error code correction) protected memory (which is expensive, granted). With ECC RAM at least the memory will be scrubbed for single bit errors and corrected. Double bit errors would escape that scheme but they occur too infrequently.
This diagram depicts the transmission chain elements in a computer, all transitions are susceptible to transmission errors. The zfs and btrfs file system at least ensure the OS to disk path of data integrity.

The Byte Error Rate (BER) for memory and transmission channels is in the order of 1 in 10 Million (10E-7 bit). That just means that 1 in 3000 images has an error only due to transmission problems. Now how dramatic that is for an image is left to chance, it could mean that the image is destroyed or that a pixel somewhere changed its value, due to the compression used on almost all images one cannot predict the gravity of a single bit error impact. Often one sees some partial images instead of the full image.

The worst of all that is that nobody tells you when a transmission error occurs, not your hardware. All those glitches go down unheard until one day you open the photograph, and to your surprise it’s broken. It is quite worrisome that there should be no protection within a computer, nobody seems to have thought of it. The Internet (TCP protocol) is much saver as a data path than inside a computer.

Flaky power supplies are another source of transmission losses because they create interference with the data streams. With normal files systems those errors go unnoticed.

Even if you are not overly concerned today with transmission problems, have a look into the future at illustration. Already in 2010 we’ll see thousands of errors per year!

2.6.4.3.3 ‘Oracle’ or ‘Rising Sun’ at the file system horizon?

ZFS from Sun Microsystems seems to be one of two candidates to deal with disk errors on a low level, and it is highly scalable. It is Open Source, heavily patented, comes with an GPL incompatible license, and is available on Solaris and Leopard. Let us hope that it will soon be available for Linux® and Windows (article).

This is for the courageous ones. Fuse ZFS

Oracle has also started an initiative with its btrfs file system, which still is in an alpha stage. It employs the same protection technique as zfs does, and it’s available on Linux®, although it is not yet part of the stock kernel.
2.6.4.4 Human errors

2.6.4.4.1 Theft and accidents

Do not underestimate it! Those two factor account for 86% of notebook and 46% for desktop system data losses. For notebooks, theft counts for 50% alone.

2.6.4.4.2 Malware

Data loss due to viruses is less grave than common wisdom make you believe. It accounts for less damage than theft or re-installations, for example. And it is limited to Microsoft OS users. Apple users experience very few viruses and under Linux® they haven’t been around for quite some time now.

2.6.4.4.3 Panic is a factor in data loss

Human error, as in everything, is a major problem in data loss. Take a deep breath and stop! Panic is a common reaction, and people do really stupid things. Experienced users will pull the wrong drive from a RAID array or reformat a drive, destroying all their information. Acting without thinking is dangerous to your data. Stop stressing about the loss and don’t do anything to the disk. Better yet, stop using the computer until you have a plan. Sit down and explain you plan to a laymen or better, laywoman. You will be amazed how many stupid ideas you’ll discover yourself in such an exercise.

If your disk is making weird noises, normal file recovery software isn’t going to work. Do a quick backup if that is going to happen to you. If the drive is still spinning and you can’t find your data, look for a data recovery utility and backup to another computer or drive. (Non-Linux® users: Google for “free data recovery software” for some options, including one from Ontrack). The important thing is to download them onto another drive, either on another computer, or onto a USB thumb drive or hard disk. It is good practice to save the recovered data to another disk. dd is your friend on *nix systems.

2.6.4.5 Common myths dispelled

I’d like to dispel some common myths:

• Open Source file systems are less prone to data loss than proprietary systems: Wrong. NTFS is rather a tiny notch better than ext3, ReiserFs, JFS, XFS, to name just the most popular file systems that often come as default FS with distributions. A brilliant article about it is here: link

• Journaling files systems prevent data corruption/loss: Wrong, they only speed up the scan process in case of a sudden interrupt during operation and prevent ambiguous states. But if a file was not entirely saved before the mishap, it’ll be lost.

• RAID systems prevent data corruption/loss: Mostly wrong, RAID0 and 1 prevent you from nothing, RAID5 can prevent data loss due to disk-failures (but not from disk or file system errors). Many low-end RAID controllers (most mother board controllers are) don’t report problems, figuring you’ll never notice. If you do notice, months later, what is the chance that you’ll know it was the controller’s fault? One insidious problem is corruption of RAID 5 parity data. It is pretty simple to check a file by reading it and matching the metadata. Checking parity data is much more difficult, so you typically won’t see parity errors until a rebuild. Then, of course, it is too late.

• Viruses are the biggest thread to digital data: Wrong. Theft, and human errors are the primary cause of data loss.
2.6.4.6 Make your budget: Data size, required storage volume estimation

Digital camera sensors are 1-2 aperture stops away from fundamental physical limitations. What I mean is this: as technology evolves, there is a natural limit to its progress. Sensitivity and noise characteristics for any kind of light sensor are not far from that limit.

Today’s cameras tend towards 10 mega pixels sensors, although this resolution is already too high for compact cameras and deteriorates the end result. Given the sensor size and quality of optics, 6 mega pixels are optimum for compact cameras. Even DSLR cameras run into their limits at 10-12 mega pixels, for higher resolutions one has to go for full frame sensors (24x36mm) or even bigger formats.

So, taking into account the manufacturer mega pixel propaganda it seems save to say that the bulk of future cameras will see less than 20 mega pixels. This gives us an estimation for the necessary storage space per photograph in the long run: <15 MB per image. Even if file versioning will be introduced (grouping of variations of a photograph under one file reference), the trend is to implement scripting of changes so that a small overhead will be recorded only and not a whole different image per version. With faster hardware this concept will see it’s maturity quite soon.

In order to estimate the amount of storage space you have to plan for, simply determine the number of photographs you take per year (easy with digiKam’s timeline sidebar) and multiply it by 15 MB. Most users will keep less than 2000 pictures per year which requires less than 30 GB/year. Assuming that you will change your hard disk (or whatever media in the future) every 4-5 years, the natural increase in storage capacity will suffice to keep you afloat.

The more ambitious ones out there will need more space, much more maybe. Think of buying a file server, Giga-Ethernet comes integrated into motherboards today and it’s a flck to fetch the files over the local network. Speaking about modern mobos: they now have external SATA connectors. This makes it really a trifle to buy an external SATA drive and hook it up to your machine. 1000 GB drives will hit the market this year (2008). These are terrific compact storage containers for backup swapping: keep one drive at home and one somewhere else.

2.6.4.7 Back it up, backup, backup, recover!

A 750GB HD costs €100 today. Do not blame anybody else for data loss! 6% of all PCs will suffer an episode of data loss in any given year. Backup your data often according to a plan, and back it up and test the backup before you do anything dramatic like re-installing your OS, changing disks, resizing partitions and so on.

2.6.4.7.1 Disaster prevention

Say, you religiously do your backups every day on a external SATA drive. Then comes the day where lightning strikes. Happy you if the external drive was not connected at that moment!

Disasters strike locally and destroy a lot. Forget about airplane crashes: fire, water, electricity, kids and theft are dangerous enough to our data. They usually cover a whole room or house.

Therefore disaster control means de-localized storage. Move your backups upstairs, next house, to your bureau (and vise versa), whatever.

There is another good aspect to the physical separation: as said above, panic is often the cause of destroying data, even the backup data. Having a backup not at hand right away may safe your ass one day.

2.6.4.7.2 Some backup technicalities explained for laymen.

- Full Backup: A complete backup of all the files being backed up. It is a snapshot without history, it represents a full copy at one point in time.
• Differential Backup: A backup of only the files that have changed since the last full backup. Constitutes a full snapshot of two points in time: the full backup and the last differential one.

• Incremental Backup: A backup of only the files that have changed since last whatever backup. Constitutes multiple snapshots. You can recreate the original state at any point in time such a backup was made. This comes closest to a versioning system except that it is only sampled and not continuous.

2.6.4.7.3 Best practice: The IT-layman’s backup cookbook

1. do a full backup in a external storage device.
2. verify its data integrity and put it away (disaster control)
3. have another storage device for frequent backups
4. swap the devices every other month after having verified data integrity

2.6.4.7.4 A useful rsync recipe to backups

Rsync is a wonderful little utility that’s amazingly easy to set up on your machines. Rather than have a scripted FTP session, or some other form of file transfer script - rsync copies only the differences of files that have actually changed, compressed and through ssh if you want to for security. That’s a mouthful.

A reasonable backup approach for images could be this one:

1. backup important images right away (after dumping them to a computer) to DVD/optical media
2. do daily incremental backup of the work space
3. do a weekly differential backup and delete integral backups of week-2 (two weeks ago)
4. do a monthly differential backup and delete backup of month-2
5. if not physically separated already, separate it now (swapping-in another backup drive)

This protocol tries to leave you enough time to spot losses and to recover fully at the same time keeping the backup volume at <130% of the working space. You end up with a daily version of the last 7-14 days, a weekly snapshot for at least one month, and a snapshot of every month. Any more thinning should be done by hand after a full verification.

2.6.4.8 Preserve your images through the changes of technology and owners

Themes: metadata, IPTC stored in image files, XMP files associated, keep the originals, storage, scalability, media, retrieval of images and metadata, copying image data over to the next generation of media, applications, operating systems, virtualization, viewing device... use of the www.

In order for your valuable images to survive the next 40 years or so (because that’s about the time that you will become really interested to revisit those nice old photographs of you as a child, adolescent etc.) there are two strategies to be observed:

1. Keep up with technology, don’t lag behind more than a couple of years.
2. Save your photos in an open, non-proprietary standard.
2.6.4.8.1 How to keep up with technology?

As the future is unforeseeable by nature, everything said today is to be taken with caution, and to be reviewed as we advance. Unfortunately there is no shortcut possible to some basic vigilance. Every 5-8 years at least one should ask oneself the question of backwards compatibility of current systems. The less variants we used in the past the less questions are to be answered in the future.

Of course every time you change your computer system (machine, operating system, applications, DRM) you have to ask yourself the same questions. Today, if you want to switch to Windows Vista, you have to ask yourself three times if you still can import your pictures, and, more important so, if you are ever able to move them onto some other system or machine. Chances are good that you cannot. I see many people struggling around me, because Vista enforces a strict DRM regime. How can you prove to Vista that you are actually the owner of your pictures copyright?

Basically the questions should be answered along the line explained in this document: use and change to open standards supported by a manifold of applications.

Virtualization becomes available now for everybody. So if you have an old system that is important for reading your images, keep it, install it as a virtual machine for later.

Otherwise the advice is quite simple: every time you change your computer architecture, your storage and backup technology, your file format, check it out, go through your library and convert to a newer standard if necessary. And keep to open standards.

2.6.4.8.2 Scalability

Scalability is the tech-geek expression of the (easy) capability of a system to be resized, which always means up-sized.

Lets assume you planned for scalability and dedicated the container you want to increase to a separate disk or partition. On *nix systems like Linux® you then can copy and resize the container to the new disk:

Check with dmesg if your new disk is recognized by the system, but don’t mount it.

```
$ dd if=/dev/sdb[#] of=/dev/sdc # source is /dev/ ←
sdb, new disk is /dev/sdc
$ parted resize /dev/sdc1 0 <disk size in MB> # ←
works on ext2,3, fat16, 32 and reiserfs
$ resize2fs /dev/sdc1 # resize_reiserfs in case
```

2.6.4.8.3 Use open, non-proprietary standards as file formats

The short history of the digital era in the past 20 years has proven over and over again that proprietary formats are not the way to go when you want your data to be intelligible 10 years into the future. Microsoft is certainly the well known culprit of that sort because of its domineering market share. But other companies are actually (if inadvertently) worse since they may not stay long enough in the market at all or have a small user/contributor base only. In the case of Microsoft one has at least the advantage of many people sharing the same problems. Finding a solution has therefore much more success. Still, in some cases Microsoft is using Open Source documentation to understand their own systems, so badly maintained have been their own documentation. Usually with any given MSoffice suite one cannot properly read a document created with the same application two major versions earlier.

Image formats have had a longer live time than office documents and are a bit less affected by obsolescence.
Open Source standards have the huge advantage of having an open specification. Even if one day in the future there’ll be no software to read it anymore, one can recreate such software, a task becoming simpler every year.

JPEG has been around for a while now, and whilst it’s a lossy format losing a bit every time you make a modification and save it, it is ubiquitous, supports JFIF, EXIF, IPTC and XMP metadata, has good compression ratios and can be read by all imaging software. Because of its metadata limitation, lossy nature, absence of transparency and 8 bit color channel depth, we do not recommend it. JPEG2000 is better, can be employed lossless, but lacks in user base.

GIF is a proprietary, patented format and slowly disappearing from the market. Don’t use it.

PNG has been invented as a Open Source standard to replace GIF, but it does much more. It is lossless, supports XMP, EXIF and IPTC metadata, 16 bit color encoding and full transparency. PNG can store gamma and chromaticity data for improved color matching on heterogeneous platforms. Its drawback are a relatively big footprints (but smaller than TIFF) and slow compression. We recommend it.

TIFF has been widely accepted as an image format. TIFF can exist in uncompressed form or in a container using a lossless compression algorithm (Deflate). It maintains high image quality but at the expense of much larger file sizes. Some cameras let you save your images in this format. The problem is that the format has been altered by so many people that there are now 50 or more flavors and not all are recognizable by all applications.

PGF “Progressive Graphics File” is another not so known but open file image format. Wavelet-based, it allows lossless and lossy data compression. PGF compares well with JPEG 2000 but it was developed for speed (compression/decompression) rather than to be the best at compression ratio. At the same file size a PGF file looks significantly better than a JPEG one, while remaining very good at progressive display too. Thus it should be well-suited to the web but at the moment few browsers can display it. For more information about the PGF format see the libPGF homepage.

RAW format. Some, typically more expensive, cameras support RAW format shooting. The RAW format is not really an image standard at all, it is a container format which is different for every brand and camera model. RAW format images contain minimally processed data from the image sensor of a digital camera or image scanner. Raw image files are sometimes called digital negatives, as they fulfill the same role as film negatives in traditional chemical photography: that is, the negative is not directly usable as an image, but has all of the information needed to create an image. Storing photographs in a camera’s RAW format provides for higher dynamic range and allows you to alter settings, such as white balance, after the photograph has been taken. Most professional photographers use RAW format, because it offers them maximum flexibility. The downside is that RAW image files can be very large indeed.

My recommendation is clearly to abstain from archiving in RAW format (as opposed to shooting in RAW format, which I recommend). It has all bad ingredients: many varieties and proprietary nature. It is clear that in a few years time you cannot use your old RAW files anymore. I have already seen people changing camera, losing their color profiles and having great difficulty to treat their old RAW files correctly. Better change to DNG format!

DNG Digital Negative file format is a royalty free and open RAW image format designed by Adobe Systems. DNG was a response to demand for a unifying camera raw file format. It is based on the TIFF/EP format, and mandates use of metadata. A handful of camera manufacturers have adopted DNG already, let’s hope that the main contenders Canon and Nikon will use it one day.

I strongly recommend converting RAW files to DNG for archiving. Despite the fact that DNG was created by Adobe, it is an open standard and widely embraced by the Open Source community (which is usually a good indicator of perennial properties). Some manufacturers have already adopted DNG as RAW format. And last not least, Adobe is the most important source of graphical software today, and they of course support their own invention. It is an ideal archival format, the raw sensor data will be preserved as such in TIFF format inside DNG, so that the risk associated with proprietary RAW formats is alleviated. All of this makes migration to another operating system a no-brainer. In the near future we’ll see ‘non-destructive editing’, where files are not changed anymore but rather all editing steps will be recorded (into the DNG as it were).
When you open such a file again, the editing script will be replayed. This takes computation power, but it is promising as it leaves the original intact and computing power increases all the time.

**XML** (Extensible Mark-up Language) or **RDF** (Resource Description Framework). XML is like HTML, but where HTML is mostly concerned with the presentation of data, XML is concerned with the “representation” of data. On top of that, XML is non-proprietary, operating-system-independent, fairly simple to interpret, text-based and cheap. RDF is the WC3’s solution to integrate a variety of different applications such as library catalogs, world-wide directories, news feeds, software, as well as collections of music, images, and events using XML as an interchange syntax. Together the specifications provide a method that uses a lightweight ontology based on the Dublin Core which also supports the “Semantic Web” (easy exchange of knowledge on the Web).

**IPTC goes XMP**

That’s probably one of the reasons why, around 2001, that Adobe introduced its XML based XMP technology to replace the “Image resource block” technology of the nineties. XMP stands for “Extensible Metadata Platform”, a mixture of XML and RDF. It is a labeling technology that lets users embed data about a file in the file itself, the file info is saved using the extension “.xmp” (signifying the use of XML/RDF).

**XMP**. As much as ODF will be readable forever (since its containing text is written in clear text), XMP will preserve your metadata in a clearly understandable format XML. No danger here of not being able to read it later. It can be embedded into the image files or as a separate accompanying file (sidecar concept). XMP can be used in PDF, JPEG, JPEG2000, GIF, PNG, HTML, TIFF, Adobe Illustrator, PSD, PostScript, and Encapsulated PostScript. In a typical edited JPEG file, XMP information is typically included alongside Exif and IPTC data.

Embedding metadata in files allows easy sharing and transfer of files across products, vendors, platforms, customers, without metadata getting lost. The most common metadata tags recorded in XMP data are those from the Dublin Core Metadata Initiative, which include things like title, description, creator, and so on. The standard is designed to be extensible, allowing users to add their own custom types of metadata into the XMP data. XMP generally does not allow binary data types to be embedded. This means that any binary data one wants to carry in XMP, such as thumbnail images, must be encoded in some XML-friendly format, such as Base64.

Many photographers prefer keeping an original of their shots (mostly RAW) for the archive. XMP suits that approach as it keeps metadata separate from the image file. I do not share this point of view. There could be problems linking metadata file and image file, and as said above, RAW formats will become obsolete. I recommend using DNG as a container and putting everything inside.

The **Dublin Core Metadata Initiative** is an open organization engaged in the development of interoperable online metadata standards that support a broad range of purposes and business models. DCMI’s activities include work on architecture and modeling, discussions and collaborative work in DCMI Communities and DCMI Task Groups, annual conferences and workshops, standards liaison, and educational efforts to promote widespread acceptance of metadata standards and practices.

### 2.6.4.9 Best practice: Data protection

- Use surge protectors (UL 1449 standard), possibly combined with a UPS
- Use ECC memory to verify correct data transmission (even just saving files)
- Watch your hard drives (temperature, noise...), make backups
- Keep backups at another location, locked up, use web storage space
- Use archival media and burners
- Don’t panic in case of data loss, explain your recovery plan to a layperson
• choose you file system, partitions, folders to cater for easy scalability
• Use open, non-proprietary standards to manage and save photographs
• Do a technology/migration review at least every 5 years

### 2.6.5 A Typical DAM Workflow

1. Import images from camera, card reader or scanner. As long as the images are stored on the camera media, you can use that as temporary backup.

2. RAW are converted to DNG and stored away into a RAW archive.

3. Rate and cull, write-back metadata to the DNG archive.

4. Make a backup e.g. on external drive, and optical medium, or a tape.

5. Tag, comment, and geo-locate.

6. Edit and improve photographs.

7. For layered editing use external applications. Back in digiKam, re-apply the metadata, which was probably lost or curtailed by the other applications.

8. Run the routine backup with following data-integrity checks

9. Protect processed images for copyrights with Digital Watermarking. Export to web galleries, slide shows, MPEG encode, contact sheets, printing etc.
2.7 Face tagging with digiKam

digiKam allows for either manual or automatic face tagging.

For more information about face tagging using digiKam’s face recognition engine see The Face Management Tool and People View.

For tagging people manually, you can preview an image, click on Add a Face Tag icon highlighted on the screenshot below.

And then draw a rectangle around the face while holding left mouse button followed by entering the person’s name and pressing Enter.
Instead of clicking on *Add a Face Tag* icon you can draw a face region while holding *Ctrl* key.

### 2.8 Using a Digital Camera With digiKam

To be able to use your digital camera with digiKam, connect the camera to your computer, switch the camera to the image display mode and turn it on. See your camera’s user manual if you need more information.

#### 2.8.1 Introduction to the Import Interface

The Import Interface helps you to get photographs into a digiKam Album, whether it is directly from your camera, from a USB mass storage device, via a card reader or from a local or remote folder. You can access the Import Interface by

- **Import → Cameras**
  - Select one of the cameras from the submenu or choose *Add Camera Manually*.
  - The latter will open the dialog described in the *Camera Settings* section of this handbook.
  - If you want to have more information about how digiKam supports digital cameras, please take a look at this section.

- **Import → USB Storage Devices**
  - Select one of the USB devices from the submenu.

- **Import → Card Readers**
  - Select one of the card readers from the submenu.

- **Import → Add Images... (Ctrl+Alt+I)**
  - Select a source folder from the dialog that opens.

#### 2.8.2 Basic Import Interface Operations

![Import Interface Screenshot](image)
2.8.2.1 Getting information about the photographs

Before downloading photographs to your computer, you may wish to see the camera item information. Using the Properties and Metadata tabs on the Right Sidebar will launch camera and photograph properties and metadata information.

The Item Properties Sidebar Tab

The Properties tab displays file information recorded by the camera and a selection of photograph information to describe how the image has been taken. A flag indicates if the image has not yet been downloaded to the computer. Note that all this information may be unavailable with some digital cameras.

The Metadata tab displays internal picture’s metadata like EXIF, Makernotes, GPS, etc. This information is the same as Metadata from the digiKam Right Sidebar. Note that all these metadata can be unavailable with some digital cameras.

2.8.2.2 Geolocation Tab

The Geolocation tab will open a map that allows you to see and edit the GPS location of the selected photographs. For a detailed description see the Geolocation section of the Right Sidebar chapter of this handbook.

2.8.2.3 Downloading photographs to your computer

To download photographs from your camera to your computer click the Download button on the main toolbar and then click Download All (or use Item → Download All from the main menu). This will download all of the photographs on the camera with the settings you used with your last download (Settings tab). The download process will not remove the photographs from the camera. It is always advisable to check that the photographs have downloaded safely into the Album you were expecting before deleting them from the camera.

If you do not want to download all of the photographs you can select just those that you need using the standard selection methods. Once you have the photographs selected, click Download
and then **Download Selected**. The **Download Selected** button will be grayed out until you have selected some photographs.

Another option is **Download new**. New images are marked with a star in the upper right corner of the image icon. Once images are downloaded a “downloaded already” entry will be made in the digiKam database and they are marked with a checker. Obviously, if you choose this handy option, it will download the new images only.

### 2.8.2.4 Uploading Photographs to your camera

To upload photographs from your computer to your camera click **Item → Upload...** (Ctrl+U) in the Import Interface menu. A standard file selection dialog will appear to select the files from your computer for copying to your camera. You can select more than one file using the standard selection methods.

When images selection is done, digiKam will ask you to where you want to upload the files on your camera. A camera folder selection dialog will appear. Just select one folder and press OK to start uploading. No images will be removed from your computer.

---

**Example 2.13** The Camera Folder Selection Dialog

![Camera Folder Selection Dialog]

---

**NOTE**

Uploading feature is not supported by all camera drivers.

### 2.8.2.5 Deleting photographs from the camera

Once you are happy with the downloaded photographs that you wanted, you are ready to delete photographs from the Camera. You can delete all of the photographs at once by clicking the **Item → Delete All** button. If you just want to delete a selection of the photographs, you have to select those that you want to delete and click **Item → Delete Selected**. You may also select
Item \textit{→} Delete New, for example if you feel that the images marked with the star are not worth downloading.

\begin{center}
\textbf{CAUTION}
\end{center}

Please note that there is no way to restore a photo that you have deleted from the camera. The photographs are not moved to the internal Trash Can, they are removed completely. It is best to double check that you have successfully downloaded a photograph into a digiKam album before you delete it from the camera. Anyway, if you plan to empty the camera card, you better do that from the camera menu because it is much quicker.

\section*{2.8.3 Advanced Import Interface Operations}

The \textit{Settings} tab of the Right Sidebar in the Import Interface opens five sections with advanced options for the import processing.

\subsection*{2.8.3.1 File Renaming Options}

Cameras often do not use very meaningful filenames for photographs. The filenames are usually reused once the photographs have been deleted from the camera. This can lead to filename clashes if you download photographs from many shootings into the same Album. It can also be useful to include the date and time that an image was taken into the filename.

If you select \textbf{Camera filenames} the image filenames will not be altered. But you have the option to change their case to upper or lower case with the ‘Change case to:’ drop down field. If you select \textbf{Customize} you will be able to put together a renaming pattern from the Options drop down menu which contains original file name, file extension, owner and group, directory, a dialog for defining a sequence number and a dialog for adding date and time information, either fixed or based on the time information written by the camera into the image file.

In the sequence number dialog you will find two options: \textbf{Extension aware numbering} and \textbf{Folder aware numbering}. If they are checked digiKam will start a new sequence for every file extension and / or folder.
The Date & Time dialog looks like this:

![Date & Time dialog](image)

The calendar is active only if ‘Fixed Date’ is selected from the Source: drop down field. This way you can add the same date and time information to the filenames of all imported images or videos. If ‘Image’ is selected instead digiKam will use the time information from the metadata of the image files. With the Format: drop down field you can choose from several standard date/time formats and a custom format. For the latter choose Custom in Format: drop-down list and fill in for example “dd.MM.yyyy hh:mm:ss”. For more information, read QDateTime class reference.

In addition these options can be customized further with the help of a number of modifiers. A list of all options and modifiers together with a short explanations will open when clicking the info button.

**Tip**
The sequence number may be needed if you have a camera with a very fast multi-shoot mode where it is possible to get two photographs with exactly the same data and time.

The new filename that digiKam will use for the photographs when they are downloaded is shown underneath the thumbnail in the image icon. The renaming settings will be remembered the next time you use the camera interface.

**Caution**
At the moment digiKam cannot read metadata of RAW files during the import. You might want to import the files while preserving camera filenames first and then rename them after the import using the rename function (F2).
2.8.3.2 Auto-Creation of Albums

Check **Extension-based sub-albums** and digiKam will create subalbums based on the file extensions of the imported images in the target album. digiKam will open a dialog where you can choose the target album once you click one of the download options either from the toolbar or from the Item menu. If you want to create a new Album, into which you could download the photographs, click the **New Album** button. The new Album will be created as a sub-folder of the Album that is currently selected in the existing Album list. This means that if you do not want your new Album to be a sub-folder of an existing folder you must first select the collection where you want to create the new album. Collections are indicated by the 📷 icon.

If your camera provides information about the date of the photograph’s taking or, if you import from a USB device or a folder, the images contain EXIF metadata with date/time information, digiKam can use this to automatically create subalbums in the target album during import. Subalbums names will be based on the image dates. All images which have the same date will be downloaded into the same subalbum if you check **Date-based sub-albums**. Not all cameras include this information. See the sidebar Metadata section for more detail about information your camera may have embedded in your photographs.
2.8.3.3 On the Fly Operations

This section of the Settings tab offers several options for JPEG images. The Template: drop-down field lets you choose one of your metadata templates you customized in Templates Settings. You can access the Template Manager also with the edit button to the right of the drop-down field.

Write the document name to EXIF and Fix internal date & time writes this information into the respective EXIF tags and XMP fields.

If you check the next box digiKam will perform the auto-rotate/flip action described in Lossless Image Rotation.

Convert to lossless file format allows you to convert the images to PNG, TIFF, PGF or JPEG2000 during import.
2.8.3.4 DNG Convert Options

This section allows to enable the DNG conversion of RAW images by checking Convert RAW images to DNG container and to select options for that conversion. To learn more about Digital Negative (DNG) use the link ‘DNG container’.

Embed original file

Embeds the original RAW file into the DNG container.

Lossless Compression

Enables lossless compression. The difference between lossy and lossless compression is said to be practically indistinguishable with DNG.

JPEG preview

Choose whether you want a medium or full size JPEG preview to be embedded into the DNG container or none at all.

2.8.3.5 Scripting

This last section of the Settings tab offers to run scripts to manipulate the images during import. You can type the filename of the script into the input field or search for it using the Browse... button. Check out the info button for additional expressions to customize the command line!

2.9 digiKam Configuration

2.9.1 Introduction

digiKam tries to give you as much control over how it works as possible. There are many options that change the behavior of the application. To access these settings select Settings → Configure digiKam... from the menubar. The configuration dialog is separated by categories displayed in separated pages. You can change between these pages by clicking on the icons on the left-hand side of the dialog.
2.9.2 Database Settings

NOTE
For an introduction of internal data storage, please refer to Introduction of digiKam Databases section.

2.9.2.1 The Sqlite Database

SQLite is a relational database management system, contained in C programming library. SQLite is not directly comparable to client/server SQL database engines such as MySQL, Oracle or PostgreSQL. Rather, it is an embedded SQL database engine, i.e. it is embedded in an end program. SQLite reads and writes directly to ordinary disk files. For device-local storage with low writer concurrency and less than a terabyte of content, SQLite is almost always a better solution. SQLite is fast and reliable and it requires no configuration or maintenance. It keeps things simple. SQLite "just works".

By default, digiKam uses SQLite as its back-end for storing important metadata and thumbnails. Three SQLite files used for storing them are named respectively:

1. Core: digikam4.db.
2. Thumbs: thumbnails-digikam.db.

To make your application run fast and smoothly, it is recommended to check and optimize your databases once in awhile. This could be achieved using sqlite3 packages or sqlite browser (high quality, easy to use visual tool for managing database objects). For Ubuntu and its derivatives, it could be retrieved using `sudo apt-get install sqlite3` or `sudo apt-get install sqlitebrowser`. Now all remains is to open the terminal, switch to the directory where databases are stored.

NOTE
Take care to use a place hosted by fast hardware (such as SSD) with enough free space especially for thumbnails database. A remote file system such as NFS cannot be used here. For performance and technical reasons, you cannot use removable media.

SQLite database files could be found in your “collection” folder, which you have added to digiKam. (By default, if you add your “Pictures” collection, the database files will be present in `/Pictures` folder).
2.9.2.2 The MySQL Database

2.9.2.2.1 MySQL Versus SQLite

MySQL is an open-source, relational database management system, written in C and C++. Original development of MySQL by Michael Widenius and David Axmark beginning in 1994. Sun Microsystems acquired MySQL in 2008, which was later acquired by Oracle in 2010. MySQL currently works on almost all system platforms (Linux, Microsoft Windows, OS X, SunOS …).

MariaDB server is a community developed fork of MySQL server. Started by core members of the original MySQL team, MariaDB actively works with outside developers to deliver the most featureful, stable, and sanely licensed open SQL server in the industry.

MariaDB has actually overtaken MySQL, ’cause of few basic reasons:

1. MariaDB development is more open and vibrant.
2. More cutting edge features.
5. Compatible and easy to migrate.

digiKam also provides support for popular MySQL database engine. Of course, you might wonder why you’d want to switch to MySQL when SQLite already does a good job of managing the data? MySQL offers many advantages for storing digikam data, especially when collections include more than 100,000 items. With such large collections, SQLite introduces latency which slows down the application.

Using MySQL as digiKam’s database back-end allows you to store the data on local as well as remote server. Local, to replace the local SQLite storage and latter, to use a shared computer through network. Using MySQL as digiKam’s database back-end allows you to store the data on a remote server. This way, you can use multiple digiKam installations (For instance, on your
notebook and PC) to access and manage your photo collections. You can also use MySQL tools to backup and analyze digiKam’s data.

To switch from SQLite to MySQL database, go to Settings / Configure digiKam... and then under Settings section, select a database from the drop down list.

1. MySQL Internal: This allows to run an internal database server on your system. digiKam uses Unix socket for the connection.
2. MySQL Remote: Use this if you’ve your data on remote server and you’re on a different machine trying to access the collection.

2.9.2.2.2 The MySQL Internal Server

While using a large collection, of size greater than 100,000 items, the application tends to slow down. To avoid the delay and maintain efficiency, digiKam provides option of using MySQL Internal Server. To be clear, this isn’t an actual server, or a public network. Instead, it is a server that runs only while application is running.

Internal server creates a separate database that can be accessed (only while application is running) using the command: mysql --socket=/home/[user_name]/.local/share/digikam/db_misc/mysql.socket digikam

Internal server uses two MySQL Binary Tools - mysql_install_db and mysqld. You can configure their locations in the configuration dialog. digiKam will try to find these binaries automatically if they’re installed on your system.

2.9.2.2.3 The MySQL Remote Server

Obviously, to use digiKam with a remote MySQL, you would require a MySQL server. Or, you could also install MariaDB, which serves the purpose well. (Could be installed easily using this link.)

Follow the instructions below, if you don’t have a dedicated user account and a digiKam database already set up. Run the commands in MySQL server (after replacing password with correct one):
NOTE
You can select any database name. (Here it is, “digikam”). Just remember to fill in the database name correctly in Core, Thumbs, Face database names from the dialog box shown below.

```
CREATE USER ''@'%' IDENTIFIED BY 'password';
GRANT ALL ON *.* TO ''@'%' IDENTIFIED BY 'password' ;
CREATE DATABASE digikam;
GRANT ALL PRIVILEGES ON digikam.* TO ''@'%;
FLUSH PRIVILEGES;
```

NOTE
If you have an enormous collection, you should start the MySQL server with `mysql --max_allowed_packet = 128M`

Now, in digiKam, go to Settings → Configure digiKam... and then under Settings section, select MySQL Server from the drop down list.

Enter the IP address of your MySQL server in the Host Name field and specify the correct port in the Port field (the default port is 3306).

In the Core Db Name field, enter the name of the first database for storing photo metadata.

Specify the name of the second database for storing wavelets compressed thumbnails in the Thumbs Db Name field.

The third database is dedicated to store face histograms for recognition purpose. Use the Face Db Name field for that.

To be connected safety to the remote server, enter your MySQL identification using username and password fields.
To check whether the database connection works properly, press the **Check Connection** button. If everything works as it’s supposed to, switch to the **Collections** sections, and add the directories containing your photos. Hit **OK**, and wait till digiKam populates the databases with data from photos. This can take a while if you have a lot of items to register in database.

There are some tips and recommendation to obtain the best results with a remote MySQL database server.

With slow network, digiKam hangs a lot of time especially when album contains many items (>1000). This solution relies on network performance. Problem has been reproducible using Wifi connection, for instance. Switching to Ethernet must solves the problem.

Also, if you have an enormous collection, you should start the MySQL server with `mysql --max_allowed_packet = 128M`. (If you’re well acquainted with using MySQL, you could also change your settings in my.ini or ~/.my.cnf files).

### 2.9.2.3 Database Migration

The photo management application comes up with an exclusive tool “Database Migration”, that allows users to migrate their data. Suppose, you’re using SQLite and you wish to move all data to MySQL database, migration tool will help you do so. It can help you migrate data from SQLite to MySQL and vice versa.

To migrate to another database, go to **Settings → Database Migration**. A dialog box appears:

Now choose appropriate database types you want to convert to. Finally, click on **Migrate** button to convert the database from SQLite to MySQL (or vice versa).

### 2.9.2.4 Database Backup Recommendation

For security reasons, planning a database backup using crontab over the network can help against device dysfunctions. A NAS or an external drive can also be used for that.

Each database can be named with a different name, not only “digikam”. This permits user to backup only what is needed. For instance, naming “core” database as digikamCore, permits to isolate only this table (the most important file). Thumbnails and recognition databases can always be regenerated for scratch.
The digiKam Handbook

The chapter about digiKam Maintenance tool will explain how to maintain in time the database contents and how to synchronize the collections with databases information (and vice versa).

2.9.2.5 Database Statistics

digiKam provides a unique tool of maintaining the statistics of your collection. It includes count of images, videos (including individual count by image format), tags etc. Also, includes the Database backend (QSQLITE or QMYSQL) and the Database Path (where your collection is located).

You can view your statistics by going to Help → Database Statistics. A dialog box like this will appear:

<table>
<thead>
<tr>
<th>Format</th>
<th>Count</th>
</tr>
</thead>
<tbody>
<tr>
<td>JPG</td>
<td>40</td>
</tr>
<tr>
<td>PNG</td>
<td>10</td>
</tr>
<tr>
<td>total</td>
<td>56</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Videos</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>MP4</td>
<td>1</td>
</tr>
<tr>
<td>total</td>
<td>1</td>
</tr>
</tbody>
</table>

| Total Items | 57 |
| Albums      | 16  |
| Tags        | 50  |

Database backend: QMYSQL
Database internal server: Yes
Database internal server Path: /home/swati/Pictures/

2.9.3 Collections Settings

This dialog manages your Album Collections. Each Collection represents a root folder containing your photographs or videos. Usually the root folder will contain sub folders. All these folders we call Albums. How to work with them, create, delete, rename them etc. is described in detail in the Albums View section.
2.9.4 Views Settings

In a number of tabs you can access the following groups of settings for the Views of digiKam (Albums, Tags, Labels, ...):

2.9.4.1 Icon Settings

- Show filename
- Show file size
- Show camera creation date
- Show file modification date
- Show image dimensions
- Show image aspect ratio
- Show image Format

The first series of settings on the left side of this view permit to customize the technical information shown below the icon thumbnail, as the filename, the file size, the creation date, the image dimensions, and the aspect ratio.

Note that the Show file modification date option shows the file modification date only if it’s different from the creation date. This function is useful to identify quickly which items have been modified.
On the right side, the options permit to customize other properties to show over and below the icon thumbnail, as the file mime-type, the title, the caption, and the labels.

The **Show rotation overlay buttons** option shows overlay buttons over the image thumbnail to be able to process left or right image rotation.

The **Show fullscreen overlay button** option shows an overlay button over the image thumbnail to open it in fullscreen mode.

The **Show Geolocation Indicator** option shows an icon over the image thumbnail if the item has geolocation information.

An example of an icon is given below:

```
+  
|   
|   
|   
```

On the bottom side of this settings panel, you can tune the behavior of the icon with user actions.

The **Thumbnail click action** option permits to choose what should happen when you click on a thumbnail. Two settings are available: **Show preview** to display the image in preview mode (F3) or **Start image editor** to open the image in a separate editor window (F4).

The **Icon View font** option permits to select the font used to display text in icons.

The **Use large thumbnail size for high screen resolution** option renders the icon-view with large thumbnail size, for example in case of 4K monitor is used. By default this option is turned off and the maximum thumbnail size is limited to 256 x 256 pixels. When this option is enabled, the thumbnail size can be extended to 512 x 512 pixels. This option will store more data in the thumbnail database and will use more system memory. digiKam needs to be restarted for the option to take effect and the **Rebuild Thumbnails** option from the Maintenance tool needs to be processed over all collections.

### 2.9.4.2 Tree View Settings

These settings permit to customize the tree views of the Left and Right Sidebar. The **Tree View icon size** option configures the size in pixels of the Tree View icons in digiKam’s sidebars. Use large value for HiDPI screen. The **Tree View font** option sets the font used to display text in Tree Views. The option **Show a count of items in Tree Views** will display the number of items inside a folder or assigned to a tag behind the album/tag name. The count shown depends on whether
the subfolders/-tags are folded out or not and on the View → Include Album Sub-Tree and the View → Include Tag Sub-Tree settings in the main menu.

```
Tree View thumbnail size: 22
Tree View font: Custom Font
☐ Show a count of items in Tree Views
```

### 2.9.4.3 Preview Settings

Instead of opening the image in the editor, the digiKam preview mode (F3) will show the image within the main window in the Image Area. The advantage of the preview is that it is faster than opening the image editor and that the icons of the other images remain visible so that you are able to review the list of current images quickly. Depending on your computer features, you can customize the best way to load images into the preview. Raw files can be processed differently, as this kind of container can require long computation.

The first option will try to open a small version of the photograph embedded in the file. It will be found in all RAW files and can be found in all files that support IPTC or XMP like PNG, JPEG, TIFF, JPEG2000, PGF. If an embedded preview cannot be found some image decoders (JPEG, JPEG2000, and PGF, WebP) are able to create a reduced version of the photograph by themselves which is still faster than using the whole image. Depending on the size of the image, the size of the embedded preview and the size available for the preview on your screen the effect of this option can be visible or not.

The second option will always use the full image data for the preview regardless of whether there is a reduced version embedded in the file or not. This can result in a better quality of the preview but is usually slower.

Only if the second option is checked the drop down field to the right of “Raw images:” is accessible. It offers three options: With Automatic selected the Libraw decoder will decode the RAW data automatically without any adjustments from the user. This may lead to weird results sometimes. The algorithm also takes screen resolution and CPU speed into account to achieve an optimum regarding speed and rendering quality. Embedded preview will try to use the (JPEG) preview embedded in RAW files. Raw data in half size will show unprocessed RAW data in half size.

The option Preview is zoomed to the original image size is related to the first option. It will zoom the embedded view to the original image size which can lead to a reduced quality of the preview depending on the parameters mentioned above in the description of the first option.

The option Show icons and text over preview will show icons for rotation, face tags, full screen mode, etc. in the top left corner of the image preview and a text indicating which data the preview is showing in the top right corner.
2.9.4.4 Full-Screen Settings

The options in this tab apply only to the Full Screen Mode you can access via the Full Screen button on the Toolbar or via View → Full Screen Mode (Ctrl-Shift-F) in the main menu or the context menu. It does not apply to the Full Screen Mode you access by clicking the ‘Show Fullscreen’ icon either on a thumbnail or on the preview.

- Hide toolbars
- Hide thumbbar
- Hide sidebars

If all three options are activated the only way to leave the Full Screen Mode is the context menu or Ctrl-Shift-F. You can work on the images also by choosing functions from the context menu of an icon or the preview.

2.9.4.5 Mime Types Settings

digiKam can understand lots of different image file types as well as some video and audio formats. To control which types of files digiKam will try to display you can add or remove file extensions from these lists. Any files that are in the digiKam Album folders that do not match these extensions will be ignored by digiKam.

**NOTE**
The default settings can be easily restored by clicking on the update buttons to the right of each category.

Add new file types to show as album items.
digiKam attempts to support all of the image formats that digital cameras produce, while being able to handle a few other important video and audio formats. You can add to the already-appreciable list of formats that digiKam handles by adding the extension of the type you want to add. Multiple extensions need to be separated by a space.

- **Image Files**
  - Additional image file extensions: *(Currently-supported types):* 

- **Movie Files**
  - Additional movie file extensions: *(Currently-supported types):* 

- **Audio Files**
  - Additional audio file extensions: *(Currently-supported types):* 

For more information, for example how to remove file types from the list, use the context help with the question mark from the window header.
2.9.4.6 Album Categories Settings

In the Album View you can choose from View → Sort Albums → By Category to have the Albums in the Album Tree of the Left Sidebar sorted by category. Here you can manage these categories, which is add or remove categories or rename them by using the Replace button. To assign categories to an Album you got to use the Album Properties dialog.

![Manage categories to sort and re-arrange album tree-view.]

2.9.5 Tooltip Settings

This setup page covers all options of information appearing when the mouse hovers over a file icon in the Image Area. According to the checked options they will be shown or not.

See below an example of the information displayed in a tooltip over an icon with the relevant settings done in the configuration page.
2.9.6 Metadata Settings

2.9.6.1 Introduction

Image files can have some metadata embedded into the image file format. These metadata can be stored in a number of standard formats such as JPEG, TIFF, PNG, JPEG2000, PGF, and RAW files. Metadata can be read and written in the EXIF, IPTC, and XMP formats if they are present in the file.

2.9.6.2 Behavior Settings

The Behavior tab allows you to select what information digiKam will write to the metadata and control how digiKam will deal with this embedded information.
If the lazy synchronization is turned on digiKam will only write metadata when user clicks on the **Apply pending changes to metadata** icon in the status bar or on exit.

### 2.9.6.3 Sidecars Settings

The **Sidecars** tab allows user to control whether digiKam will read/write from/to XMP sidecars or not. Filename for the sidecars set to `filename.ext.xmp`. For example, `image1.dng` will have a sidecar file named `image1.dng.xmp`.

Please Note: If the box "Read from sidecar files" is checked digiKam will only read the sidecar while ignoring the embedded metadata.
2.9.6.4 Rotation Settings

2.9.6.4.1 Rotate Actions

Show images/thumbnails rotated according to orientation tag: this will use any orientation information that your camera has included in the EXIF information to automatically rotate your images.
photographs so that they are the correct way up when displayed. It will not actually rotate the image file, only the display of the image on the screen. If you want to permanently rotate the image on file, you can click with the right mouse button on the thumbnail and select Auto-rotate/flip according to EXIF orientation. The image will then be rotated on disk and the tag will be reset to “normal”. If your camera routinely gets this orientation information wrong you might like to switch this feature off.

Set orientation tag to normal after rotate/flip: the Auto Rotate option automatically corrects the orientation of images taken with digital cameras that have an orientation sensor. The camera adds an orientation tag to the image’s EXIF metadata. digiKam can read this tag to adjust the image accordingly. If you manually rotate an image, these metadata will be incorrect. This option will set the orientation tag to “Normal” after an adjustment, assuming that you rotated it to the correct orientation. Switch this off if you don’t want digiKam to make changes to the orientation tag, when you rotate or flip the image.

2.9.6.5 Views Settings

TODO

2.9.6.6 Advanced Settings

The Advanced tab allows you to manage namespaces used by digiKam to store and retrieve tags, ratings and comments. This functionality is often used by advanced users to synchronize metadata between different software. Please leave the default settings if you are not sure what to do here.

2.9.7 Templates Settings

The Metadata Templates Manager is meant to create and manage metadata templates which can be used in

- the Information tab of the Captions view of the Right Sidebar
• the On the Fly Operations (JPEG only) section of the Settings view of the Right Sidebar in the Import → Cameras → OneOfMyCameras Window.

The top part shows a list of the already existing templates. The first row shows the title of the template, the second row shows the name of the author(s) in the ‘Author Names’ field of that very template. To the right you have three editing buttons, below an input field for the template title. To create a new template you type a title in the input field and click the Add... button. The new template will appear in the list. To edit an existing template you select it in the list, then you edit its fields (see next paragraph) and finally you click the Replace... button. You can as well type in a new title for the edited template and save the new version with the Add... button. To delete a template, very obviously, you select it in the list and click the Remove button.

**WARNING**

Note that all the changes you made to the templates will only be stored in the template file if you exit the settings dialog with OK! The Add... and Replace... buttons only change the template list in the RAM.

**TIP**

The template file can be found in `./local/share/digikam/` for manual backup or for managing different template sets by means of the file system.

The rest of the window is divided into four tabs, grouping the metadata fields into Rights, Location, Contact and Subjects.

The Rights tab (see above) contains the default identity and copyright data. This is an extract of the IPTC specifications for these fields:

• **Author** (is synonymous to Creator and By-line): This field should contain your name, or the name of the person who created the photograph. If it is not appropriate to add the name of the photographer (for example, if the identity of the photographer needs to be protected) the name of a company or organization can also be used. Once saved, this field should not be changed by anyone. This field does not support the use of commas or semi-colons as separator.
• Author title (synonymous with By-line title): This field should contain the job title of the photographer. Examples might include titles such as: Staff Photographer, Freelance Photographer, or Independent Commercial Photographer. Since this is a qualifier for the Author field, the Author field must also be filled out.

• Credit (synonymous with Provider): Use the credit field to identify who is providing the photograph. This does not necessarily have to be the author. If a photographer is working for a news agency such as Reuters or the Associated Press, these organizations could be listed here as they are “providing” the image for use by others. If the image is a stock photograph, then the group (agency) involved in supplying the image should be listed here.

• Source: The Source field should be used to identify the original owner or copyright holder of the photograph. The value of this field should never be changed after the information is entered following the image’s creation. While not yet enforced by the custom panels, you should consider this to be a “write-once” field. The source could be an individual, an agency, or a member of an agency. To aid in later searches, it is suggested to separate any slashes / with a blank space. Use the form “photographer / agency” rather than “photographer/agency.” Source may also be different from Creator and from the names listed in the Copyright Notice.

• Copyright Notice: The Copyright Notice should contain any necessary copyright notice for claiming the intellectual property, and should identify the current owner(s) of the copyright for the photograph. Usually, this would be the photographer, but if the image was done by an employee or as work-for-hire, then the agency or company should be listed. Use the form appropriate to your country. For the United States you would typically follow the form of (c) [date of first publication] name of copyright owner, as in “(c)2005 John Doe.” Note, the word “copyright” or the abbreviation “copr” may be used in place of the (c) symbol. In some foreign countries only the copyright symbol is recognized and the abbreviation does not work. Furthermore the copyright symbol must be a full circle with a “c” inside; using something like (c) where the parentheses form a partial circle is not sufficient. For additional protection worldwide, use of the phrase, “all rights reserved” following the notice above is encouraged. In Europe you would use: Copyright [Year] [Copyright owner], all rights reserved. In Japan, for maximum protection, the following three items should appear in the copyright field of the IPTC Core: (a) the word, Copyright; (b) year of the first publication; and (c) name of the author. You may also wish to include the phrase “all rights reserved.”
The fields in the **Location** tab are self-explaining by their title and the gray hints in the empty fields. A little bit more elaborate description can be found under **Settings → Configure digiKam... → Metadata → Views → IPTC viewer**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Address</td>
<td>Enter the address of the lead author here.</td>
</tr>
<tr>
<td>Postal Code</td>
<td>Enter the postal code of the lead author here.</td>
</tr>
<tr>
<td>City</td>
<td>Enter the city name of the lead author here.</td>
</tr>
<tr>
<td>Province</td>
<td>Enter the province of the lead author here.</td>
</tr>
<tr>
<td>Country</td>
<td>Enter the country name of the lead author here.</td>
</tr>
<tr>
<td>Phone</td>
<td>Enter the phone number of the lead author here.</td>
</tr>
<tr>
<td>Email</td>
<td>Enter the email of the lead author here.</td>
</tr>
<tr>
<td>URL</td>
<td>Enter the web site URL of the lead author here.</td>
</tr>
</tbody>
</table>

Note: These information are used to set XMP and IPTC tag contents. There is no limitation with XMP, but note that IPTC text tags only support the printable ASCII character set, and tag sizes are limited. Use contextual help for details.

The data in the **Contact** tab refer to the (lead) photographer under ‘Author Names’ in the **Rights** tab.

<table>
<thead>
<tr>
<th>Reference code</th>
<th>Use standard reference code</th>
<th>Use custom definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>01000000</td>
<td>XMP</td>
<td>arts, culture and entertainment</td>
</tr>
</tbody>
</table>

Note: These information are used to set XMP and IPTC tag contents. There is no limitation with XMP, but note that IPTC text tags only support the printable ASCII character set, and tag sizes are limited. Use contextual help for details.

In the **Subjects** tab you can assign one or more Subject Codes according to the IPTC Photo Metadata Standard to the template. If the first option ‘Use standard reference code’ is selected you can choose a code from the drop down field and the meaning of it will then appear in the fields of the ‘Use custom definition’ section. If you don’t know the code for the subject you want to assign this way is a bit tedious since there are 1400 subjects in the standard. A better way is to
look for your subject in this URL. There you select ‘Subject Codes’ and your language (English recommended) and click ‘Show’. In the diagram you scroll and make additional levels of an item visible by clicking on one of the fields. In the field right of the diagram you can find the code of the selected subject.

In general the IPTC Subject Codes are quite comprehensive but on the other hand a bit incomplete in some fields, e.g. under Lifestyle and Leisure/Games you find just Go, chess, bridge and shogi. So you may want to add own subjects, even though they always remain private (or company) subjects. A way to do that in digiKam is to first check ‘Use standard reference code’ and select 10001004 which brings you to Lifestyle and Leisure/Games/shogi - just to stay in our example. Then you check ‘Use custom definition’ and change the last digit of ‘Reference:’ to 5 and the text in the ‘Detail:’ field to - say ‘domino’. You save this custom definition to the template by clicking Add... at the right side of the subjects list. Then you type in a template title (if it’s a new template) and save the template by clicking Add... at the right side of the templates list. Don’t mix up these two!

2.9.8 Image Editor Settings

2.9.8.1 Editor Window Settings

By default the Image Editor will use a black background behind photographs when they are displayed. If you prefer a different background color you can choose one here. You can also turn off the ToolBar when the Image Editor is in full screen mode. Over and underexposed areas of an image can be indicated by dark and light marker colors that can be defined here. In the editor this viewing mode can be switched on and off with F10 and F11 respectively. The thresholds for over- and under-exposure can be set by the adjustment bars “... percents”. Check Indicate exposure as pure color if you want only pure black (RGB 0,0,0) indicated as under-exposure and only pure white (RGB 8 bit 255,255,255 respectively RGB 16 bit 65535, 65535, 65535) indicated as over-exposure.

![Interface Options](image_url)

- Use theme background color
- Background color: 

- Full-screen Options
  - Hide toolbars
  - Hide thumbbar
  - Hide sidebars

- Exposure Indicators
  - Under-exposure color: 
  - Under-exposure percents: 1.0
  - Over-exposure color: 
  - Over-exposure percents: 1.0
  - Indicate exposure as pure color

Example:
2.9.8.2 Save Image Options

When changes are made to JPEG files and they are saved back to the hard disk the JPEG file must be re-encoded. Each time a JPEG file is encoded a decision must be made on the level of quality that is to be applied. Unfortunately the level of quality applied is not recorded in the image file. This means that the Image Editor cannot use the same quality ratio when saving an altered image as was used for the original image. You can change the default level of quality that the Image Editor will apply when it saves altered images by moving the JPEG quality slider (1: low quality / 100: high quality and no compression). At the time of writing, metadata is supported.

Chroma subsampling is the practice of encoding images by implementing more resolution for luminance information than for color information. Please read this Wikipedia article for a full explanation.

With PNG compression option, you can reduce PNG image files size. This operation does not reduce image quality because PNG uses a lossless algorithm. The only effect is that image data needs more time to compress/decompress. If you have a fast computer you can change this value to use a high compression factor (1: low compression / 9: high compression). At the time of writing, metadata is supported.

With Compress TIFF option, you can toggle to use Deflate compression algorithm with TIFF image files. This will reduce TIFF image files sizes. It has no image quality effect because Deflate is a lossless algorithm. At the time of writing, metadata is supported.

With the LossLess JPEG 2000 files option allows for lossless storage, or, if the lossy options is selected, even then the quality for comparative files size is much better than normal JPEG. At the time of writing, metadata is supported.

With the LossLess PGF files option allows for lossless storage, or, if the lossy options is selected, even then the quality for comparative files size is much better than normal JPEG-2000. At the time of writing, metadata is supported.

2.9.8.3 Image Versioning Settings

Non-Destructive Editing and Versioning gives you the freedom of editing your images, trying out whatever you want without worrying that you might regret later what you did. digiKam takes care of the original and every important intermediate step if you want.
In the checkbox at the top you can enable or disable Non-Destructive Editing and Versioning. In the first field you can choose the file format used for saving the intermediate steps and the final result. Remember that JPEG - like in the screenshot above - is a lossy format. So if you need to start over from an intermediate step it wouldn’t be really non-destructive. If you can afford it in terms of space on the harddisk and loading/saving speed you better choose a lossless format like PNG or PCF for instance. Please click the information button on the right side for more detailed information.

In the next field you can decide whether the editor will save changes automatically on exit or should ask first.

In the third field you decide on which occasions you want the editor to save intermediate steps. Please click the information button on the right side for more detailed information.

In the last field you can adjust whether you want only the last version to be shown in the Image View (default, none of the boxes checked) or if you also want to see icons of the original version and/or intermediate steps.

### 2.9.8.4 RAW Decoding Settings

In the early versions of digiKam the Image Editor was just a viewer for photographs, but it is rapidly developing into a very useful photo manipulation tool. This dialog allows you to control how the Image Editor will behave when opening RAW files.

- Fast and simple, as 8 bit image
RAW files will be decoded to 8-bit color depth with a BT.709 gamma curve and a 99th-percentile white point. This mode is faster than 16-bit decoding. In 8-bit mode only the Auto Brightness setting will be taken into account (dcraw limitation).

**Use the default settings, in 16 bit**

If enabled, all RAW files will be decoded to 16-bit color depth using a linear gamma curve and according to the settings in the RAW Default Settings tab. To prevent dark image rendering in the editor, it is recommended to use Color Management in this mode.

**Always open the Raw Import Tool to customize settings**

With this option checked the Raw Import Tool will open at the Right Side Bar in the Image Editor so that you can set individual parameters for every image you open.

### 2.9.8.5 RAW Default Settings

#### Demosaicing

A demosaicing algorithm is a digital image process used to interpolate a complete image from the partial raw data received from the color-filtered image sensor internal to many digital cameras in form of a matrix of colored pixels. Also known as CFA interpolation or color reconstruction.

**Interpolate RGB as four colors**

The default is to assume that all green pixels are the same. If even-row green pixels of the CCD sensor are more sensitive to ultraviolet light than odd-row this difference causes a mesh pattern in the output; using this option solves this problem with minimal loss of detail. To resume, this option blurs the image a little, but it eliminates false 2x2 mesh patterns with VNG quality method or mazes with AHD quality method.

**Do not stretch or rotate pixels**

TODO

**Quality:**

TODO digiKam and Dcraw offer us three alternatives: bi-linear, VNG interpolation, AHD interpolation. It seems that AHD interpolation (for Adaptive Homogeneity-Directed) is the best choice.
for quality according to some test that I have performed and the paper of the person that implemented it. **VNG interpolation** (Variable Number of Gradients) was the first algorithm used by Dcraw but suffers from color artifacts on the edge. **Bilinear** is interesting if you are looking for speed with an acceptable result.

**Pass:**
TODO

**Refine interpolation**
This option is available only for DCB and VCD/AHD. TODO

**White Balance**

**Method**
Four options are available here: Default D65, Camera, Automatic and Manual. ‘Default D65’ reflects normal daylight conditions. ‘Camera’ uses the camera’s custom white-balance settings if set. ?? ‘Automatic’ The default is to use a fixed color balance based on a white card photographed in sunlight. ?? ‘Manual’ will adjust colors according to the T(K) (color temperature in degrees Kelvin) and Green settings. TODO

**Highlights**

This is the story of the three highlight options, courtesy of Nicolas Vilars:

Default is here to consider highlights (read: part of your images that are burned due to the inability of your camera to capture the highlights) as plain / solid white (solid white option). You can get some fancy results with the unclip option which will paint the highlights in various pinks. At last you can try to consider recovering some parts of the missing information from the highlights (reconstruct option).

This is possible because the blue pixels tends to saturate less quickly than the greens and the reds. digiKam/dcraw will try to reconstruct the missing green and red colors from the remaining none saturated blue pixels. Of course here everything is a question of tradeoff between how much color or white you want.

If you select **Reconstruct** as the option, you will be given the choice to set a level. A value of 3 is a compromise and can/should be adapted on a per image basis.

**NOTE**
A small warning here, for the few curious that have read the man pages of Dcraw, the author says that 5 is the compromise, 0 is solid white and 1 unclip. This is because in digiKam 0 and 1 are the “solid white” and “unclip” options in the drop down menu (if you select these, the level slider will be grayed out). Therefore, the slider in digiKam with the “reconstruct” option will let you choose between 0 to 7 (instead of 0 to 9 in Dcraw command line) where 3 is the compromise instead of 5 in “native” Dcraw command line tool.

**Exposure Correction (E.V)**
TODO

**Correct false colors in highlights**
TODO

**Auto Brightness**
TODO

**Corrections**

**Noise Reduction**
TODO While demosaicing your image you can additionally ask for noise reduction (at a slight speed penalty). This option applies a noise reduction algorithm while the image still is in CIE Lab color space. Because the noise is only applied to the Luminosity layer (the “L” of the Lab), it
should not blur your image as traditional noise reduction algorithms do in RGB mode. So, if you converted an image from RAW and it appears noisy, rather than applying a denoiser, go back and re-convert with this option enabled. The defaults are: \textit{Threshold} = 100. Higher values will increase the smoothing, lower will decrease smoothing.

**Enable chromatic aberration (CA) correction**

If you know the CA of your lenses you can set the red and blue correction values here. This is certainly the optimal method for CA correction as it is done during RAW conversion.

### 2.9.9 Color Management Settings

digiKam is color-management enabled. RAW files - as they come - are not color managed at all. Your camera provides the data it has captured in a raw format and will let you manage all the processing. Every camera has its specifics as to how it captures color information, therefore you will need to apply a specific profile to the images you want to process. Please refer to the section \textit{ICC color profile management} for more details an explanations.

Basically, a profile “maps” the color information and gives information on how one should render them. It gives also information to LCMS and digiKam on how to translate the color information from one color space to an other in order to keep the colors as accurate as possible across all rendering media.

**Behavior** Ask when opening an image in image editor / Launch Color Management tool with RAW files

**Color Profiles Directory** : set this to the folder where you store all your profiles e.g. \\
"/usr/share/color/icc" or \\
"/home/user/.color/icc". digiKam will scan this folder when starting up.

**ICC Profiles Settings** : here you are given the ability to provide “default” choices for your profiles. Everything is adaptable later-on at the opening of a RAW file.

- The \textit{Use color managed view} is an alternative to using Xcalib or Argyll. Only your image will be color managed, not your entire screen!
• You have to provide a workspace profile (linear profiles such as sRGB, ECI-RGB, LStar-RGB, Adobe-RGB or CIE-RGB). If you want to print your images, you may want to opt for Adobe RGB, if it is only for web publishing, sRGB is better (Adobe RGB will be displayed slightly dull in non color managed enabled software such as browsers). However you may change this later of course (by attributing another profile), therefore Adobe RGB can be a good choice for storing and image handling as you can always change it to sRGB before releasing an image for your blog. Note: Do not use non-linear profiles as they will change the color-balance.

• The input profile should match the camera maker and model you are using. ‘Not all profiles are created equal’, there are some that have no tone mapping/gamma correction included (Canon). As of now, dcraw does not correct gamma for 16 bit depth conversion, which means that you have to do the tone mapping yourself.

• There are some other options such as the soft proof profile which enables you to emulate, granted that you have a profile for it, how your image will render for a particular device. It is useful before printing for instance because your printer has a smaller gamut than your camera and some colors might look saturated. You may want to fix this manually instead of relying on the “blind” algorithm of your printer.

For most cameras it is pretty obvious what color profile they propose for the type at hand, not so for the Canon’s. Here is a table of camera/profiles matches, it is non-authoritative of course:

<table>
<thead>
<tr>
<th>Camera</th>
<th>Profile series</th>
</tr>
</thead>
<tbody>
<tr>
<td>Canon 1D mark II</td>
<td>6051</td>
</tr>
<tr>
<td>Canon 1D mark II</td>
<td>6111</td>
</tr>
<tr>
<td>Canon 1Ds</td>
<td>6021</td>
</tr>
<tr>
<td>Canon 1Ds mark II</td>
<td>6081</td>
</tr>
<tr>
<td>Canon 5D</td>
<td>6091</td>
</tr>
<tr>
<td>Canon 10D</td>
<td>6031</td>
</tr>
<tr>
<td>Canon 20D</td>
<td>6061</td>
</tr>
<tr>
<td>Canon 30D</td>
<td>6112</td>
</tr>
<tr>
<td>Canon 40D</td>
<td>6101</td>
</tr>
<tr>
<td>Canon 300D</td>
<td>6031</td>
</tr>
<tr>
<td>Canon 350D</td>
<td>6111 or 6071</td>
</tr>
<tr>
<td>Canon 400D</td>
<td>6131</td>
</tr>
</tbody>
</table>

The Canon profile extension betray the target style: F for Faithful Style, L for Landscape Style, N for Neutral Style, P for Portrait Style, S for Standard Style.

Here you find a typical RAW workflow scenario.
2.9.10 Light Table Settings

The setting of the digiKam Light Table can be set to default values on this page so that every time you open the Light Table, these settings are activated (if possible, because for images having different sizes the synchronous mode does not work).

Synchronize panels automatically refers to the Synchronize button on the Light Table toolbar which is to say that you can still switch off this option there. If the next option is not checked you...
have to load the images from the thumbbar to the two panels of the Light Table by drag+drop or with the On left or On right buttons.

### 2.9.11 Slide-Show Settings

The slide show setup should be easy to understand. The upper slider adjusts the time between image transitions; usually a time of 4-5 seconds is good. The other check boxes enable/disable the metadata to be shown on the bottom of the slide show images during display.

![Slide-Show Settings](image)

**Delay between images:** 5
- [ ] Start with current image
- [ ] Slideshow runs in a loop
- [x] Show progress indicator
- [x] Show image file name
- [ ] Show image creation date
- [ ] Show camera aperture and focal length
- [ ] Show camera exposure and sensitivity
- [ ] Show camera make and model
- [ ] Show image caption
- [ ] Show image title
- [ ] Show image caption if it hasn't title
- [ ] Show image tags
- [ ] Show image labels

**Screen placement:** Current Screen

### 2.9.12 Image Quality Settings

These settings refer to the Image Quality Sorter tool which you can access via Tools → Maintenance.
Through the first checkbox you can enable or disable the whole function. With the four ‘Detect ...
' options you can choose which kind of fault should be factored in by the Image Quality Sorter. Talking about factoring in: the factors for blur, noise and compression can set with the help of the three ‘... Weight' adjustment bars at the bottom.

With the three ‘Assign ... Label ...' options you can decide to which image quality level a label
should be assigned. Un-checking all three of them renders the Image Quality Sorter useless, of course. The thresholds for these levels can be set through the three ‘... threshold' adjustment bars. It will normally take some testing and trying out to find the settings that suits your needs. Note that the input, i.e. the images the process has to investigate, will have quite some influence. It’s a difference whether you choose an album containing images which are all more or less o.k. and have only minor differences or if you present a collection of pictures where some of the pictures really have some bad blur, noise, ... You also have to consider at which point of your workflow you want to perform this operation. Right after importing the files from your camera is probably a good idea.

With the topmost of the adjustment bars you can adjust the speed of the process in three steps. Slow speed (1) should lead to better results.

2.9.13 Camera Settings

The camera settings shows on the left of the list of the currently supported cameras. On the right at the top there is an auto-detect button, which tries to identify the camera connected to your computer (make sure that the camera is connected properly to the computer and turned on in the image display mode). Below this are the port settings; the currently supported are Serial, USB, and USB/FireWire Mass Storage.
Clicking on a camera in the list on the left will display the supported ports which you can then select. If there is only one supported port it will be automatically selected. At the bottom on the right there is a box for setting the exact path in case of a serial port. Please note that USB interface does not need any paths to be set. If you cannot find your camera on the list, you can try to use a generic Mass Storage device selecting Mounted Camera item in the list.

At the very bottom is where you set the path for a USB or FireWire (IEEE-1394 or i-link) Mass Storage camera. This box becomes active once you select USB or FireWire Mass Storage camera in the camera list. You need to enter here the path where you mount the camera, usually "/mnt/camera" or "/mnt/removable".

To be able to use your digital camera with digiKam, connect the camera to your computer, switch
the camera to the image display mode and turn it on.
Try and see if digiKam can auto-detect the camera; if not, you can set the camera model and port manually. Once you have the camera setup, go to the “Cameras” menu in the main interface and you will see the camera listed in the menu.

**NOTE**
You can choose any title you like for the camera in the setup and this title will be used in the main window Cameras menu. If you have more than one camera, you can add them through this setup interface.
The digiKam Handbook

### Devices
- All Files
- Only New Files
- Raw Files
- JPG/TIFF Files
- Video Files

### Import Filters
- + Add...
- Remove
- Edit...

### Always ignore
- Ignored file names:
  - mgr_data pgr_mgr
- Ignored file extensions:
  - dsp dps

### Devices
- Icon-View Options
  - Show filename
  - Show file size
  - Show camera creation date
  - Show image Format
  - Thumbnails click action:
    - Show embedded preview
  - Icon font:
    - System Font
    - Choose...

### Preview Options
- Embedded preview loads full-sized images
- Preview each item while downloading it
- Show icons and text over preview

### Full-screen Options
- Hide toolbars
- Hide thumbbar
- Hide sidebars
2.9.14 Miscellaneous Settings

2.9.14.1 General Settings

With the **String comparison type** setting, you can set the way in which strings are compared inside digiKam. This influences the sorting of the tree views. **Natural** tries to compare strings in a way that regards some normal conventions. The result will be sort naturally even if they have a different number of digits inside. **Normal** uses a more technical approach. Use this style if you want to entitle albums with ISO dates (201006 or 20090523) and the albums should be sorted according to these dates.

With the **Confirm when moving items to trash** and **Confirm when permanently deleting items** settings you can set the verbosity of digiKam when you delete a photograph or an Album. See Deleting a Photograph and Deleting an Album sections for more details.

The editorial changes done through the right sidebar can be quietly applied by digiKam when setting the **Apply changes in the right sidebar without confirmation** option. Otherwise the changes must be applied by pressing the **Apply changes** button.

**Scan for new items at startup** option will force digiKam to scan the album library tree for new items added or removed between digiKam sessions. This may slow down the start time of digiKam. If any items have been removed from album library, digiKam will ask you confirmation before to remove definitely item references in database.

2.9.14.2 Application Behavior Settings

With the **Scroll current item to center of thumbbar** setting, you can force thumbbar to center current selected item with mouse pointer on the center of visible area.

With the **Show splash screen at startup** setting, you can switch off the display of the splash screen when application loads. This may speed up the start time slightly.
With the Sidebar tab title setting, you can set how sidebars on the sides will show the tab titles. Use Only For Active Tab option only if you use a small screen resolution as with a laptop computer. Else For All Tabs will be a best choice to discover quickly all internal features of digiKam.

With the Widget style setting, you can choose the default application window decoration and looks. Fusion style is the best choice under all desktop.

With the Icon theme setting, you can choose the default application icon theme. Theme availability depends of desktop used to run digiKam.

### 2.9.15 The Theme Setup

Color schemes are supplied like themes to personalize digiKam main interface for you pleasure. To access these settings select Settings → Themes from the menubar and select your preferred theme to use.

### 2.9.16 Configure Shortcuts

digiKam has the common KDE shortcut configuration tool accessed via the Settings → Configure Shortcuts main menu item. For more information read the section about the shortcut configuration in KDE applications of the KDE Fundamentals.

digiKam keyboard shortcuts by default:

#### 2.9.16.1 Rating assignment

<table>
<thead>
<tr>
<th>Rating</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>no rating</td>
<td>Ctrl+0</td>
</tr>
<tr>
<td>1 star</td>
<td>Ctrl+1</td>
</tr>
<tr>
<td>2 stars</td>
<td>Ctrl+2</td>
</tr>
<tr>
<td>3 stars</td>
<td>Ctrl+3</td>
</tr>
<tr>
<td>4 stars</td>
<td>Ctrl+4</td>
</tr>
<tr>
<td>5 stars</td>
<td>Ctrl+5</td>
</tr>
</tbody>
</table>

#### 2.9.16.2 Pick label assignment

<table>
<thead>
<tr>
<th>Pick Label</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>none</td>
<td>Alt+0</td>
</tr>
<tr>
<td>rejected</td>
<td>Alt+1</td>
</tr>
<tr>
<td>pending</td>
<td>Alt+2</td>
</tr>
<tr>
<td>accepted</td>
<td>Alt+3</td>
</tr>
</tbody>
</table>

#### 2.9.16.3 Color label assignment

<table>
<thead>
<tr>
<th>Color Label</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>none</td>
<td>Ctrl+Alt+0</td>
</tr>
</tbody>
</table>
### 2.9.16.4 Zooming

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom in</td>
<td>Ctrl++</td>
</tr>
<tr>
<td>Zoom out</td>
<td>Ctrl+-</td>
</tr>
<tr>
<td>Zoom 100%</td>
<td>Ctrl+.</td>
</tr>
<tr>
<td>Fit to window</td>
<td>Ctrl+Alt+E</td>
</tr>
<tr>
<td>Fit to selection</td>
<td>Ctrl+Alt+S</td>
</tr>
</tbody>
</table>

### 2.9.16.5 General shortcuts

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete items permanently</td>
<td>Shift+Del</td>
</tr>
</tbody>
</table>
Chapter 3

The Image Editor

3.1 Introduction to Image Editor

3.1.1 The Image Editor Window

digiKam incorporates a fast Image Editor with a few basic yet powerful image editing tools. You can use the Image Editor to view your photographs and to make corrections and alterations. The Image Editor can be accessed either by clicking on a thumbnail in the Image Window or by clicking with the right mouse button over a thumbnail and selecting Edit from the context menu. The Image Editor provides a number of powerful tools that use you to adjust a photograph.

Example 3.1 The Image Editor Window

The image editor has just one main window with:
• A status at the bottom which shows the filename, the current file number, the current zoom level, and the current image size.

• A menu bar across the top and below that a tool bar that provides quick access to some commonly used functions.

(1) (2) (3) (4) (5) (6) (7) (8) (9) (10) (11) (12) (13)

1. First Current Album Image.
2. Previous Image.
4. Last Current Album Image.
5. Save the modified image.
6. Undoing last action.
7. Redoing previous action.
8. Restore the Current Image From Disk.
11. Toggle Auto Zooming (if selected image will fit in the window).
12. Rotate the Current Image.
13. Crop Image to the Selected Region.

3.1.2 Restoring Your Original Photograph

The editing functions of the Image Editor will make changes to your photograph. None of the editing functions will change the original photograph unless you select File → Save or click the Save button in the tool bar. Note that once you have saved the changed version you will not be able to recover the original photograph.

You might prefer to take a copy of your photograph before you make any changes. You can use File → Save As... to save a working copy.

At any time before you save your photograph you can restore the view to the original image by selecting File → Revert or clicking the Revert button on the tool bar. You will lose any changes that you have made to the photograph since it was last saved.

3.1.3 Undoing/Redoing Actions

Almost anything you do to an image in Image Editor can be undone/redone. You can undo the most recent action by choosing Edit → Undo, and redo by Edit → Redo.

If these are done frequently, you really should memorize the keyboard shortcuts, Ctrl+Z to undo an action, and Ctrl+Shift+Z to redo an action.

You have to press the left mouse button over the undo or redo icon in the tool bar and hold it down for a moment to produce a context menu. If you choose one of the menu items, all undo/redo actions until the chosen ones are undone/redone.
3.1.4 Moving Between Photographs

Once you have started the Image Editor you can move between photographs in the same view you started from by using the navigator buttons on the toolbar, PgUp, PgDn or the entries in the File menu. If you have made any changes to the current photograph you will be asked if you want to save them.

3.1.5 Changing the View

You can zoom in and out of a photograph using the Ctrl-scroll wheel, the toolbar icons or the entries in the View menu.

To make a photograph fit the window use this button on the tool bar: Zoom Autofit

View → Full Screen Mode will display the photograph using the full screen mode. You can move back to the normal view by pressing the Esc key. By default the toolbar is still displayed even in Full Screen Mode. If you would prefer that the toolbar is not displayed you can turn it off in the Configure digiKam dialog accessed from the main digiKam window; see the Setup Image Editor Window Section.

3.1.6 Printing Images

When you want to print the current image from the Image Editor, select File → Print image... (Ctrl-P) and you get the standard Print dialog, where you can adjust the settings before printing your photograph.

From the main window view you can print single images or whole sets of them. Entire thumbnail pages can be printed with your selection. All you need to do is selecting images the standard way and call Item → Print Assistant.... Then follow the instructions and choices to make.

3.2 Photographic Editing - Workflow

3.2.1 Image Editing/Workflow Tools

3.2.1.1 A Standard Workflow Proposal

When performing a basic workflow, the primary areas for consideration are:

1. Exposure: White Balance
2. Color: White Balance
3. Black and white points: White Balance or Adjust Levels
4. Contrast: Adjust Curves
5. Saturation: White Balance or Vivid or Hue/Saturation/Lightness
6. Resizing (interpolation): Change Size
7. Sharpening
8. Digital Asset Management (applying tags, captions, rating, geolocation, save under new name)
We recommend this sequence of image editing steps to ensure optimum photographic quality for the end product. In particular, never do sharpening before the last step. And we recommend using a lossless format like PNG or TIFF for storing photographs. Otherwise you’ll lose a bit every time you save the results. If you can afford it, use 16 bit/channel for your best shots. If you want to change color space, in particular if you want to work in CIEL*a*b, 16 bit per channel are required to avoid truncation effects.

If you swap step 4 and 5, which is well possible if the initial contrast is already very good, you can do the first 4 adjustment in the same tool, the white balance.

Many of the tools you may need for photographic editing are included with digiKam. Their description follows here.

3.2.1.2 Introduction to common editing tools features

All Image Editor tools like Sharpen, Blur, Noise Reduction, Refocus, Unsharp Mask, etc. use a common dialog style that previews the effect before applying the filter to the current image. Below you see the ‘Apply Texture’ tool in action using this common dialog layout:

---

**Example 3.2 The Apply Texture Tool in Action**

---

- *(1)*: The seven buttons to the top left select the comparison style of the preview area. The modes are:
  - Original image.
  - Split vertically without duplication. The left area shows the original whereas the right side shows the filter applied to the continuation of the selected zoom.
  - Split horizontally without duplication. The top area shows the original whereas the lower area shows the filter applied to the continuation of the selected zoom.
  - Split vertically. The left area shows the original and the right one the filter effect for comparison.
  - Split horizontally. The top area shows the original and the lower one the filter effect for comparison.
  - Effect preview. This is a live effect preview without comparison.
– 'Mouse over' style: preview when mouse is off the preview (in the settings area), otherwise shows original.

• (2): There are two buttons that can be toggled to show over or underexposure. The colors can be customized in the general setup page.

• (3): The preview selector frame. Click and drag with the mouse on the floating frame to move it on the image. The preview area on the left of dialog is updated accordingly.

• (4): The filter or tool settings area.

• (5): At the lower left corner: there is help and a reset to defaults button (all settings are remembered from the last use of the tool).

• (6): There is a progress indicator for tool with involved calculations.

3.2.1.3 The digiKam tool set

• Image Color
  – Encoding Depth
  – Color-Space Converter
  – Auto Correction
  – Brightness/Contrast/Gamma
  – Hue/Saturation/Lightness
  – Color Balance
  – Levels Adjust
  – White Balance/Exposure/Saturation
  – Curves Adjust
  – Channel Mixer
  – Black and White
  – Simulate Infrared Film
  – Color Negative

• Image Enhancement
  – Sharpening (sharpen, unsharp mask, refocus)
  – Blur Tool
  – Red Eyes Removal
  – Photograph Inpainting
  – Local Contrast
  – Noise Reduction
  – Hot Pixel Correction
  – Lens Distortion Correction
  – Photograph Restoration
  – Vignetting Correction Tool
  – Lens Auto-Correction Tool

• Image Transformation Tools
  – Crop Tool
  – Change Size
  – Liquid Resizement
  – Change Size
3.2.2 Processing RAW image files, RAW workflow

A typical RAW workflow with digiKam may follow these steps:

• Setting up the RAW conversion and color management preferences:
  – get the ICC color profiles for the camera, display and printer
  – setup digiKam correctly defining a color work space
• Camera whitepoint setting
• Demosaicing (includes interpolation, noise filtering and chromatic aberration correction)
• Conversion to a color space
• Gamma correction, tone mapping
• Color profile assignment
• Dynamic range expansion (optional)
• Continue with standard workflow

From there everything is simple, select a RAW image and open it in the editor. The color management widget will be displayed after the image has been processed in order to adjust color rendering. Without color management all images are very dark, this is normal. You can experiment the various profiles you have in order to select the best input profile according to your image (some tends to be very neutral, even a bit dull, some gives more saturated results, etc.).

3.2.3 Color editing tools

3.2.3.1 Encoding Depth

Here you can change the encoding depth per color channel of the edited image. 8 bit encoding is the common JPEG format, 16 bit encoding is better suited for high quality images, but this format needs more storage space, calculation time and is currently available with PNG, PGF, TIFF, and JPEG-2000 formats only.
3.2.3.2 Color Management

This tool permit to convert image from one color space to another one. Its use is the change and assignment of color profiles to an image. For detailed instructions on the use of color profiles, please refer to Color Management Settings chapter.

3.2.3.3 Introduction

The Auto Levels, Normalize, Equalize, Stretch Contrast, and Auto Exposure available from Correct → Auto-Correction... menu entry menu will attempt to work out the best color levels automatically. You will need to experiment with the effects of these functions to see what works best with your photograph.

• Auto Levels: TODO.
• Normalize: this method scales brightness values across the selected image so that the darkest point becomes black, and the brightest point becomes as bright as possible without altering its hue. This is often a ‘magic fix’ for images that are dim or washed out.

Example 3.3 Normalize Colors Correction Preview

• Equalize: this method adjusts the brightness of colors across the selected image so that the histogram for the Value channel is as flat as possible, that is, so that each possible brightness value appears at about the same number of pixels as each other value. Sometimes Equalize works wonderfully at enhancing the contrasts of an image. Other times it gives garbage. It is a very powerful operation, which can either work miracles on an image or destroy it.
Example 3.4 Equalize Colors Correction Preview

• **Auto-levels**: this method maximizes the tonal range in the Red, Green, and Blue channels. It determines the image shadow and highlight limit values and adjust the Red, Green, and Blue channels to a full histogram range.

Example 3.5 Auto Levels Correction Preview

• **Stretch Contrast**: this method enhances the contrast and brightness of the RGB values of an image by stretching the lowest and highest values to their fullest range, adjusting everything
in between. This is noticeable only with washed-out images and can be a good fix-it tool for bad photographs.

### Example 3.6 Stretch Contrast Correction

The results of any adjustments you make will not be remembered until you save your photograph.

3.2.3.4 Black and White Conversion Filters

Black & White photography has always been fascinating in its abstraction capability. With the advent of digital photography, B&W has almost become a desktop activity, as color images can be easily converted on the computer into black and white, even providing a set of vintage film roll profiles. This filter is also able to simulate traditional infrared film material.

3.2.3.4.1 The Legacy Black and White Films Emulation

digiKam comes with a couple of black & white filters that you can use on your photographs. Under the Color → Black & White... menu you will find classic black & white chemical toning used in analog photography. The controls come on four drop-down items: Film, Lens Filters, Tone and Lightness as shown on the screenshot below. Film, filters and color toning can be applied independently of each other (on top of each other). The filters actually influence the RGB channel mixing, whereas the toning purely adds a uniform monochromatic tint to the black & white photograph. In the lightness tab you will find a tonal adjustment tool (like curve adjust), a contrast tool and an over-exposure indicator to improve the b&w rendering.
Example 3.7 The Black & White Filter tool in Action

The table below shows in more detail the effect of all filters and tints.

<table>
<thead>
<tr>
<th>Preview</th>
<th>Photographic Film Emulation</th>
</tr>
</thead>
</table>
| ![Image](image1.png) | Specific settings to emulate a number of famous black & white photographic films are available:  
Generic  
Agfa 200X, Agfa Pan 25, Agfa Pan 100, Agfa Pan 400  
Ilford Delta 100, Ilford Delta 400, Ilford Delta 400 Pro 3200, Ilford FP4 Plus, Ilford HP5 Plus, Ilford PanF Plus, Ilford XP2  
Super, Ilford SPX 200 (Infrared), Ilford SPX 400 (Infrared), Ilford SPX 800 (Infrared)  
Kodak Tmax 100, Kodak Tmax 400, Kodak TriX, Kodak HIE (Infrared) |

<table>
<thead>
<tr>
<th>Preview</th>
<th>Lens Filter Type</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image2.png" alt="Image" /></td>
<td></td>
</tr>
<tr>
<td>Filter Type</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Original color image</td>
<td>Original color image taken in New Zealand landscapes.</td>
</tr>
<tr>
<td>No Lens Filter</td>
<td>No Lens Filter: simulate black &amp; white neutral film exposure.</td>
</tr>
<tr>
<td>Green Filter</td>
<td>Green Filter: simulates black &amp; white film exposure with green lens filter. This comes good with all scenic images, especially suited for portraits taken against the sky (similar to 004 Cokin(tm) Green filter).</td>
</tr>
<tr>
<td>Orange Filter</td>
<td>Orange Filter: simulates black &amp; white film exposure with an orange lens filter. This will enhance landscapes, marine scenes and aerial photography (similar to 002 Cokin(tm) Orange filter).</td>
</tr>
</tbody>
</table>
Red Filter: simulates black & white film exposure with red lens filter. Creates dramatic sky effects and can simulate moonlight scenes in daytime (similar to 003 Cokin(tm) Red filter).

Yellow Filter: simulates black & white film exposure with yellow lens filter. Most natural tonal correction, improves contrast. Ideal for landscapes (similar to 001 Cokin(tm) Yellow filter).

Sepia Filter: gives a warm highlight and mid-tone while adding a bit of coolness to the shadows - very similar to the process of bleaching a print and re-developing in a sepia toner (typical for your grandmothers photographs). Similar to 005 Cokin(tm) Sepia filter.

Brown Filter: similar to Sepia Tone filter, but less pronounced.
Cold Filter: start subtle and replicate printing on a cold tone black & white paper such as a bromide enlarging paper.

Selenium Filter: effect that replicates traditional selenium chemical toning done in the darkroom.

Platinum Filter: effect that replicates traditional platinum chemical toning done in the darkroom.

3.2.3.4.2 Simulate Infrared Film

Simulating classical infrared film material (the effect is rendered in black and white) is an interesting alienation effect that is even stronger and more dramatic than pure black and white conversion. Contrast and an abstract touch are improved, which can underpin the expression of the photographer as an artist. It is like taking an image in black and white with a red filter on the camera lens. Areas which reflect little red light, e.g. the sky, will show as low density, dark areas. Areas which are excellent reflectors of red light, e.g. most green foliage, will be high density areas. And snow landscapes are really dramatic.

The algorithm is based on the method of the ‘Simulate Infrared Film’ tutorial of the GimpGuru.org web site available at this url. The filter tries to reproduce the famous Ilford(tm) SFX infrared film series. This film has a sensitivity range of 200-800 ISO.

The left part of the dialog window lets you select the region to be shown in the preview section. Move the red rectangle with the mouse around to show the effect on different parts of the image.
The lower part provides the two controls, Film Grain and ISO sensitivity. Check the **Add Film Grain** box if you want to simulate the grainy texture of a high sensitivity film. The ISO-level slider modifies the amount of film grain added and the predominance of green color (chlorophyll in nature) in the conversion mixer. Green pastures will become white as snow! Try it out.

**NOTE**
Because the filter mixes color channels to reproduce infrared film (with emphasis on green channel), one can not simulate infrared effect from black and white original photograph, since the color information is missing.

This is an example of the infrared film effect applied to a color image taken in New Zealand’s landscapes. The original image is (1) and the converted image is (2). The film sensitivity used to simulate the infrared film is ISO-400. Higher ISO values will create a kind of aura in the highlights.

3.2.3.5 **Correcting Colors**

Digital cameras often have problems with lighting conditions and it is not unusual to want to correct the color contrast and brightness of a photograph. You can experiment with altering the levels of different aspects of your photographs using the tools under the **Color** menu. You can see any adjustments you make reflected in the preview. When you are happy with the results, press **Ok** and they will take effect.
Example 3.8 The Color Balance Tool in Action

If your image is washed out (which can easily happen when you take images in bright light) try the Hue/Saturation/Lightness tool, which gives you four sliders to manipulate, for Hue, Saturation, Vibrance, and Lightness. Raising the saturation will probably make the image look better. In some cases, it is useful to adjust the lightness at the same time. ("Lightness" here is similar to "Brightness" in the Brightness/Contrast/Gamma tool, except that they are formed from different combinations of the red, green, and blue channels).

When you take images in low light conditions, you could get the opposite problem: too much saturation. In this case the Hue/Saturation tool is again a good one to use, only by reducing the saturation instead of increasing it. You can see any adjustments you make reflected in the preview image. When you are happy with the results, press Ok and they will take effect.
Example 3.9 The Hue Saturation Lightness Tool in Action

3.2.3.6 Introduction

The Adjust Curves tool is the most sophisticated tool available to adjust the images’ tonality. Start it from the Color → Curves Adjust... Image Editor menu. It allows you to click and drag control points on a curve to create a free function mapping input brightness levels to output brightness levels. The Adjust Curves tool can replicate any effect you can achieve with Brightness/Contrast/Gamma or the Adjust Levels tool, though it is more powerful than either one of them. But this tool can do more for you, it helps you to improve the tonal quality of your photographs to very finely stepped gray scales. And do not forget that the better the photographs are (good exposure, lossless format, 24 or 32 bit deep) the more you can improve them. Navigate to the “Achieving ultimate tonal quality” section of this instructive page: Tonal quality and dynamic range in digital cameras by Norman Koren. Use Adjust Curves tool to do just the same!

This tool provides visual curves to modify the intensity values of the active layer displayed as a histogram non-linearly. In Curve smooth mode, you change the curves shape by adding new points to the curve or by moving end point positions. Another way, is to draw all the curve manually in Curve free mode. In both cases the effect is immediately displayed in the image preview area to the left, where the preview can be configured by clicking on the top left icons.
3.2.3.6.1 Using Adjust Curves

To the left, half of the original and the target preview image is shown. The target preview is updated dynamically according to the widget settings. On the right side the following options are available:

- **Modify Channel**: with this combo box you can select the specific channel to be modified by the tool:
  - **Luminosity**: changes the intensity of all pixels.
  - **Red**: changes the Red saturation of all pixels.
  - **Green**: changes the Green saturation of all pixels.
  - **Blue**: changes the Blue saturation of all pixels.
  - **Alpha**: changes the transparency of all pixels.

- Next to this box are two icons to select linear or logarithmic histogram display. For images taken with a digital camera the linear mode is usually the most useful. However, for images containing substantial areas of constant color, a linear histogram will often be dominated by a single bar. In this case a logarithmic histogram will be more appropriate.

- **Main Curves Editing Area**: the horizontal bar (x-axis) represents input values (they are value levels from 0 to 255). The vertical bar (y-axis) is only a scale for output colors of the selected channel. The control curve is drawn on a grid and crosses the histogram diagonally. The pointer x/y position is permanently displayed above the grid. If you click on the curve, a control point is created. You can move it to bend the curve. If you click outside the curve, a control point is also created, and the curve includes it automatically. So each point of the curve represents an ‘x’ translated into a ‘y’ output level.

- **Curve Type for channel**: below the editing area are several icons that determine whether the curve can be edited using a **Curve smooth mode** curve or a **Curve free mode**. Smooth mode constrains the curve type to a smooth line with tension and provides a realistic rendering. Free mode lets you draw your curve free-hand with the mouse. With curve segments scattered all over the grid, result will be surprising but hardly repeatable. A reset-to-defaults button is also available.
The digiKam Handbook

- If, for example, you move a curve segment to the right, i.e. to highlights, you can see that these highlights are corresponding to darker output tones and that image pixels corresponding to this curve segment will go darker.
- With color channels, moving right will decrease saturation up to reaching complementary color. To delete all control points (apart from both end points), click on the Reset button. To delete only one point, move it onto another point. Just ply with the curves and watch the results. You even can solarize the image on part of its tonal range. This happens when the curve is inverted in some part.
- The original photo preview has a red marker on it. If you place this marker to a zone you want to modify, a corresponding line will be drawn on the curve grid indicating the original value. Create a point on that line and move it up or down to adjust it to your pleasing.
- Save As... and Load...: these buttons are used to do just that. Any curves that you have set can be saved to the filesystem and loaded later. The used file format is The Gimp Curves format.
- Reset: this button resets all curve values for all channels.

The curves tool has several features that facilitate the positioning of points on the control curves. Clicking the mouse button in the original image preview area produces a vertical dotted bar in the graph area of the curves tool. The bar position corresponds to the pixel value the mouse cursor is over in the image window. Clicking and dragging the mouse button interactively updates the position of the vertical bar. In this way, it is possible to see where different pixel values in the image are located on the control curve and helps to discover the locations of shadow, midtone, and highlight pixels.

Using this way and the three Tone Color Picker buttons will automatically create control points on the curve in all channels for shadow, middle, and highlight tones. Enable the color picker button that you want to use, and click on the original image preview area to produce control points on each of the Red, Green, Blue, and Luminosity control curves.

3.2.3.6.2 The Adjust Curves in action

Below you can see a black and white photograph corrected in Luminosity channel. Shadow and highlight tone picker tool have been use to determined the curves to apply from original. The original image is (1), the corrected image (2).
3.2.3.7 Introduction

Situated between the more sophisticated Adjust Curves tool and the simpler Brightness/Contrast/Gamma Image Editor tool is this Adjust Levels tool for improving exposure. Although the dialog for this tool looks very complicated, for the basic usage we have in mind here, the only part you need to deal with is the Input Levels area, concretely the 3 sliders that appear below the histogram.

This widget contains a visual graph of the intensity values of the active layer or selection (histogram). Below the graph are five sliders that can be clicked into and dragged to constrain and change the intensity level for the image. The left sliders position represents the dark areas and similarly, the right position represents the light areas.
3.2.3.7.1 Using the Adjust Levels tool

Actually the easiest way to learn how to use it is to experiment by moving the three sliders around, and watching how the image is affected.

On the right, both an original and a target preview image is available. The target preview is updated dynamically according to the slider positions. On the left, the following options are available:

- Modify levels for **Channel** : this combo box allows the selection of the specific channel that will be modified by the tool:
  - **Luminosity**: this option makes intensity changes against all pixels in the image.
  - **Red**: this option makes Red saturation changes against all pixels in the image.
  - **Green**: this option makes Green saturation changes against all pixels in the image.
  - **Blue**: this option makes Blue saturation changes against all pixels in the image.
  - **Alpha**: this option makes transparency changes against all pixels in the image.

- Set **Scale** for channel: this combo controls whether the histogram will be displayed using a linear or logarithmic amplitude. For images taken with a digital camera, the linear mode is usually the most useful. However, for images that contain substantial areas of constant color a linear histogram will often be dominated by a single bar. In this case a logarithmic histogram will often be more useful.

- **Input Levels**: the input levels allow manual adjustments to be selected for each of the ranges. The main area is a graphic representation of image dark, mid and light tones content. They are on abscissa from level 0 (black) to level 255 (white). Pixel number for a level is on ordinate axis. The curve surface represents all the pixels of the image for the selected channel (histogram). A well balanced image is an image with levels (tones) distributed all over the whole range. An image with a predominant blue color, for example, will produce a histogram shifted to the left in Green and Red channels, manifested by green and red color lacking on highlights. The level ranges can be modified in three ways:
  - Three sliders: the first on the top for dark tones, the second one for light tones, and the last one on the bottom for midtones (often called Gamma value).
Three input boxes to enter values directly.

Three Color Picker buttons using the original photo preview to automatically adjust inputs levels settings for shadow, midtone and highlights. There is also a fully automated adjustment button available next to the reset button.

- **Output Levels**: the output levels allow manual selection of a narrowed-down output level range. There are also two sliders located here that can be used to interactively change the output levels like **Input Levels**. This output level compression may, for example, be used to create a bleached image as a background for some other subject to put into the foreground.

- **Auto**: this button performs an automatic setting of the levels based on the pixel intensities of the image.

- **Save As...** and **Load...**: these buttons are used to do just that. Any Levels that you have set can be saved to the filesystem and loaded later. The used file format is The Gimp Levels format.

- **Reset All**: this button reset all **Input Levels** and **Output Levels** values for all channels.

The Adjust Levels tool has several features to facilitate the positioning input levels sliders. Clicking the mouse button in the original image preview area produces a vertical dotted bar in the graph area of the histogram. The bar position corresponds to the pixel value under the mouse cursor in the image window. Clicking and dragging the mouse button interactively updates the position of the vertical bar. In this way it is possible to see where different pixel values in the image are located on the input levels sliders and helps to discover the locations of shadow, midtone, and highlight pixels.

Using in this mode and the three **Color Picker** buttons will automatically adjust input levels settings in all channels for shadow, middle, and highlight tones. Enable the color picker button that you want use, and click on the original image preview area to set input levels on each of the Red, Green, Blue, and Luminosity histogram channels.

**Over Exposure Indicator** option checks all color channel to see if more than one channel in a pixel is over-exposed, and you will see the combined color resulting of channel level settings. This feature is available as an indicator in the target preview area and has no effect on final rendering.

### 3.2.3.7.2 The Adjust Levels tool in action

Below, you can see an **Input levels** adjustment example applied to a color image for the Red/Green/Blue channels. **Intensity/Alpha channels** and **Output Levels** are unchanged. The original image is (1), the corrected image (2).
3.2.3.8 Correcting Exposure

The simplest tool to use is the Brightness/Contrast/Gamma tool. It is also the least powerful, but in many cases it does everything you need. This tool is often useful for images that are overexposed or underexposed; it is not useful for correcting color casts. The tool gives you three sliders to adjust, for “Brightness”, “Contrast” and “Gamma”. You can see any adjustments you make reflected in the preview image. When you are happy with the results, press Ok and they will take effect.

Example 3.10 The Brightness Contrast Gamma Tool in Action
Another important tool is called Color → Levels Adjust. This tool provides an integrated way of seeing the results of adjusting multiple levels and also enables you to save level settings for application to multiple photographs. This can be useful if your camera or scanner often makes the same mistakes and you want to apply the same corrections. See the dedicated Adjust Levels manual for more information.

A very powerful way of correcting exposure problems is to use the Adjust Curves tool available by Color → Curves Adjust menu entry.

3.2.3.9 Introduction

The Channel Mixer is another sophisticated tool to refine the images’ tonality. Start it from the Color → Channel Mixer Image Editor menu.

3.2.3.9.1 Using the Channel Mixer

With the channel combo box you select and display the histogram per color. It gives a first hint of how to correct the channels by their relative distribution and amplitude. The left half of the dialog window always shows a preview of what you are doing. The original for comparison can be seen when selecting its own window tab.

The target photo preview has a red marker available. If you place this marker somewhere in the image, a corresponding vertical bar will be drawn in the histogram indicating the color level value in the current channel selected.

Now the controls are to the lower right: Red, Green and Blue slider controls enable you to mix the channels. If you check Preserve Luminosity the image will retain its overall luminosity despite you changing its color components. This feature is particularly useful when you also ticked the Monochrome box. Because the channel mixer is THE tool to make great black and white conversions of your photographs. Try to reduce the green channel for black and white portraits.
NOTE
Sometimes, especially when doing monochrome mixing, reducing one color channel may increase visible noise, which actually originates in the chroma noise. Chroma noise means that the little noise specs do not appear at the same location in all the color channels, but the noise patterns looks different in every channel. If that is the case you can improve the monochrome conversion by reducing the chroma noise first.

Save As... and Load... buttons are used to do just that. Any mixer settings that you have set can be saved to the filesystem and loaded later. The used file format is The Gimp channel mixer format.

Over Exposure Indicator option adds up the colors if more than one channel in a pixel is overexposed, and you will see the combined color resulting of channel gain settings. This rule is applying to target preview area and haven’t effect to final rendering.

Reset All button resets all channel mixer settings to default values.

3.2.3.9.2 The channel mixer in action

Below, you can see a photograph color tone adjustments for the Blue channel. Preserve luminosity option is on. The original image is (1), the corrected image (2).

3.2.3.10 Introduction

White Balance setting is a common hurdle for digital still cameras. In the ‘good old time’ of film rolls, the white balance was done by the photolab. Nowadays the poor little camera has to guess what is white and what is black. Most of the time, what the camera chooses as the white point, is not of the correct shade or hue. Using this tool it is easy to correct this problem. It provides a variety of parameters that can be trimmed to obtain a better result.
The digiKam Handbook

**NOTE**
The whitebalance correction is somewhat limited by the fact that we operate in 8bit per channel color space. So if you depart too much from the original, over exposure zones may appear. If you can adjust the whitebalance in raw conversion mode (which is done in 16 bit space), the margin for correction will be greater.

This tool is based on a white color balance algorithm copyrighted by Pawel T. Jochym. Launch it from the **Color → White Balance** Image Editor menu.

### 3.2.3.10.1 Using the Whitebalance Tool

The preview window can be resized. To the left, both an original and a target preview tab is shown. The target preview is updated dynamically according to the tool’s settings. If you want to see the original whitebalance, just click on that tab.

The target photo preview has a red marker available. The luminosity value of the pixel under the marker is shown as a vertical line in the histogram.

To the top right, the widget displays a histogram that is dynamically updated when changing the parameters. This histogram is very instructive as it shows that even in well exposed photos, most of the pixels have very small luminosity. With a button you can select to show either one of the 3 colors (or the sum of it which is called luminosity).

With **Exposure** you can digitally change the original photo exposure. Increasing the exposure is has the risk of making the pixel noise more visible and to blow out the highlights. Check the **Over exposure indicator** at the lower right to see if you run into saturation problems. The **Black Point** adjustment can be used to cut the histogram from the left. If your photograph looks foggy (histogram has empty space on the left, black side), you probably need to use this option. The Exposure and Black Point adjustments can be automatically estimated by pressing the **Auto Exposure Adjustments** button. This sets the black point quite accurately.

The contrast of your output depends on **Shadows**, **Saturation**, and **Gamma** parameters. The **Shadows** adjustment lets you enhance or diminish the shadow details in your photo.

Increasing the contrast of your photograph can have the side effect of reducing the apparent **Saturation** of the photo. Use a value larger than 1 to increase the saturation and a value of less than 1 to desaturate the photo. A value of 0 will give you a black and white photo. Don’t be
shy to bump up the saturation of your photos a little. The general rule is that for higher Contrast (lower Gamma) you need to apply more Saturation.

The next set of options is the mainstay of White Balance settings, which controls the ratio between the three color channels. Here you can set the color Temperature, making your image warmer or colder. Higher temperature will result in a warmer tint. Setting the ratio between the three color channels requires two adjustments. Since the temperature adjustment mostly controls the ratio between the red and the blue channels, it is natural that the second adjustment will control the intensity of the Green channel.

Instead of fiddling around with the above controls, you can simply use the Temperature Tone Color Picker button. Press on this button and click anywhere on the original preview image to get the output color of that area to calculate the white color balance temperature settings. This way, Temperature and Green values are automatically computed.

In addition you can set the White Balance using the preset list. These are the white color balance temperature presets available:

<table>
<thead>
<tr>
<th>Color Temperature</th>
<th>Description</th>
<th>Kelvin</th>
</tr>
</thead>
<tbody>
<tr>
<td>40W</td>
<td>40 Watt incandescent lamp.</td>
<td>2680</td>
</tr>
<tr>
<td>200W</td>
<td>200 Watt incandescent lamp, studio lights, photo floods.</td>
<td>3000</td>
</tr>
<tr>
<td>Sunrise</td>
<td>Sunrise or sunset light.</td>
<td>3200</td>
</tr>
<tr>
<td>Tungsten</td>
<td>Tungsten lamp or light at 1 hour from dusk or dawn.</td>
<td>3400</td>
</tr>
<tr>
<td>Neutral</td>
<td>Neutral color temperature.</td>
<td>4750</td>
</tr>
<tr>
<td>Xenon</td>
<td>Xenon lamp or light arc.</td>
<td>5000</td>
</tr>
<tr>
<td>Sun</td>
<td>Sunny daylight around noon.</td>
<td>5500</td>
</tr>
<tr>
<td>Flash</td>
<td>Electronic photo flash.</td>
<td>5600</td>
</tr>
<tr>
<td>Sky</td>
<td>Overcast sky light.</td>
<td>6500</td>
</tr>
</tbody>
</table>

Color Temperature is a simplified way to characterize the spectral properties of a light source. While in reality the color of light is determined by how much each point on the spectral curve contributes to its output, the result can still be summarized on a linear scale. This value is useful e.g. for determining the correct white balance in digital photography, and for specifying the right light source types in architectural lighting design. Note, however, that light sources of the same color (metamers) can vary widely in the quality of light emitted.

Low Color Temperature implies more yellow-red light while high color temperature implies more blue light. Daylight has a rather low color temperature near dawn, and a higher one during the day. Therefore it can be useful to install an electrical lighting system that can supply cooler light to supplement daylight when needed, and fill in with warmer light at night. This also correlates with human feelings towards the warm colors of light coming from candles or an open fireplace at night. Standard unit for color temperature is Kelvin (K).

Over Exposure Indicator option adds up the colors if more than one channel in a pixel is over-exposed, and you will see the combined color resulting of White Color Balance controls settings. This rule is applied to target preview area as an indication only and has no effect on the final rendering.

Save As... and Load... buttons are used to do just that. Any White Color Balance settings that you have set can be saved to the filesystem in a text file and loaded later.

Reset All button resets all filter settings to default values corresponding to Neutral White Balance color. (Attention, even the neutral setting might be different from your original photograph. If you save it, the white balance will be changed.)
3.2.3.11  Color Negative Tool

TODO

3.2.4  Image Enhancement

3.2.4.1  Introduction

Barrel distortion is associated with wide angle (or minimal zoom) lenses. It causes the images to appear slightly spherical (curved outward) like a barrel. You can notice this when you have straight features close to the image's peripheral sides. Pincushion distortion is the opposite defect and is associated with Telephoto lenses (maximum zoom) or underwater images. The images appear pinched (bent inward) toward the center. The Pincushion is often less noticeable than barrel but are equally visible near the edges. These distortions can easily be eliminated without visible loss in quality with this tool.

\[\text{NOTE}\]
This tool treats the geometrical distortions. Chromatic aberrations will not be corrected by this tool.

The following figures explain the main types of geometrical distortions:

- (1): pincushion distortion.
- (2): no distortion.
- (3): barrel distortion.

3.2.4.1.1  Using the lens distortion tool

\[\text{NOTE}\]
A bit of explanation first. The geometrical corrections use 4th-order polynomial coefficients.

- The 1st-order coefficient changes the size of the image. The tool calls this **Zoom**.
- The 2nd-order coefficient treats the main geometrical distortion of lenses and can correct the convex or concave shape of the image.
- The 3rd-order coefficient has a similar rounding effect but levels off towards the edges. This correction is not employed in the tool.
- The 4th-order coefficient corrects the far edges inversely to the 2nd-order rounding. Combining it with the 2nd-order correction the geometrical distortions can be almost completely eliminated.
Four sliders let you set the distortion correction filter:

**Main**: this value controls the amount of 2nd-order distortion. Negative values correct barrel distortions, while positive values correct pincushion distortion.

**Edge**: this value controls the amount of 4th-order distortion. The Edge control has more effect at the edges of the image than at the center. For most lenses, the **Edge** parameter has the opposite sign of the **Main** parameter.

**Zoom**: this value rescales the overall image size (1st-order correction). Negative values zoom out of the image, while positive values zoom in.

**Brighten**: this control adjusts the brightness in image corners. Negative values decrease the brightness image corners, while positive values increase it.

To help you to choose the best filter settings, the widget dialog illustrates with a thumbnail preview the distortion correction applied to a crossed mesh pattern. The values you apply to your image will be saved and come up with the same values as default the next time you call the tool.

**NOTE**
The barrel-pincushion correction should be done before any crop or size changes (including perspective correction). In fact the Barrel-Pincushion corrections should be the very first step on the original image. If you crop the image and then use barrel correction the effect would be obviously wrong.

To help you finding the best correction the tool provides a vertical and horizontal guide. Move the mouse cursor in the image preview to display the dashed lines guide. Move the cursor to an important place in the image like the sea level or a building border and press the left mouse button for freeze the dashed lines position. Now, adjust the barrel/pincushion correction to align with the guide.

When using pincushion correction the resulting image will have a black border in the corner. You will need to cut this out with a crop tool available in **Transform → Crop** Image Editor menu or via the zoom slider of this dialog.

On most images using the barrel correction is enough, however with some shots such as front images, frames, paintings, the next logical step is to use perspective correction to make all the angles 90 degrees. Note that when you hold your camera by hand you almost always introduce some kind of slight perspective distortion.
3.2.4.2 The lens distortion tool in action

This is an example of a barrel correction applied to church in north Norway. The original image is (1), the corrected image (2).

The values used for this example are:

- Main = -40.
- Edge = 0.
- Zoom = -20.
- Brighten = 0.

3.2.4.2 Introduction

Most current digital cameras produce images with several brightly colored “bad pixels” when using slow shutter speeds. Night images can be ruined by these “bad pixels”. There are three different types of “bad pixels”:

- Stuck pixels: it’s a pixel that always reads high or is always on to maximum power on all exposures. This produces a bright pixel usually of red, blue or green color in the final image. A stuck pixel will occur regardless of shutter speed, aperture size or any other user settings. It will occur on a normal exposure and tends to be more obvious under bright condition.
- Dead pixels: it’s a pixel that reads zero or is always off on all exposures. This state produces a black pixel in the final image. Similar to stuck pixel, a dead pixel will occur regardless of shutter speed, aperture size or any other user settings.
- Hot pixels: it’s a pixel that reads high (bright) on longer exposures as white, red, or green color. The longer the exposure time, the more visible hot pixels will become. These pixels will not be visible in bright conditions.

Note that stuck or dead pixels will occur at the same location for all images. If the location of the stuck or dead pixel occurs at different locations, it may be a Hot Pixel.

Stuck, dead or hot pixels are a problem in particular when shooting in high quality raw mode since many cameras have built-in hot pixel suppression applied automatically when JPEG compression is used (which is mostly the case).

This tool can be used to fix the “Hot pixels” and “Stuck Pixels” on a photograph using a black frame subtraction method. There is no yet a manual editor to select bad pixels.
The digiKam Handbook

3.2.4.2.1 Create the Black Frames

The Black Frame subtraction method is the most accurate “Hot Pixels” and “Stuck Pixels” removal. First you have to create a “Black Frame” as a reference. This is easy to do. When you finish taking your long exposure shots, put a lens cap on the camera and take one “dark” image with the same exposure time as the images before. This image will be all dark, but with close examination you will see that it has the Hot and Stuck Pixels (colored dots). These are positioned at the same places as on your previous shots.

Load this file to the widget using the Black Frame button. The tool will process an automatic detection of Hot and Stuck Pixels. They will be highlighted in the control panel preview areas.

**WARNING**

If you use an old digital camera, it is important to re-shoot the Black Frame next time you are taking a long exposure images to detect new Hot and Stuck Pixels on CCD defects.

3.2.4.2.2 Using the hotpixel tool

![Hotpixel Tool Image]

At first, as explained in the previous section, you need to load a Black Frame corresponding to the image to correct. An automatic parsing will be processed on the Black Frame to find bad pixels. Note that the widget will remember the previous Black Frame used on the last session and it will be re-opened automatically with the next session.

The image panel and the original preview help you to pan within the image. The preview window shows the filter output using the current settings. Bad Pixels are highlighted on all preview areas.

Select an area to see bad pixels on preview and the filter result using ‘Separate View’ options of image panel. Choose the best Filter method to interpolate pixels or pixel blocks. These are the available filters:

- **Average**: the pixels adjacent to the pixel block are averaged. The resulting color is assigned to all pixels in the block. For 1-dimensional interpolation, this is done separately for one pixel-wide, horizontal or vertical stripes.
• Linear: the pixels which have a distance of 1 from the pixel block are used to calculate a bi-linear surface (2-dim), or a group of linear curves (1-dim), which is then used to assign interpolated colors to the pixels in the block.

• Quadratic: this is the default filtering method. The pixels which have a distance of 2 or less from the pixel block are used to calculate a bi-quadratic surface (2-dim), or a group of quadratic curves (1-dim), which is then used to assign interpolated colors to the pixels in the block.

• Cubic: the pixels which have a distance of 3 or less from the pixel block are used to calculate a bi-cubic surface (2-dim), or a group of cubic curves (1-dim), which is then used to assign interpolated colors to the pixels in the block.

3.2.4.2.3 The hotpixels tool in action

Below, you can see the Hot Pixels Correction tool applied to a color photograph taken with a deficient digital camera at 200 ISO sensitivity with a long exposure shot. The original image magnified to 300% is (1), the corrected image (2).

3.2.4.3 Improve Photos exposure with Local Contrast Tool

There are multiple ways to render HDR image to improve photos containing under or overexposed areas. With camera devices, usual tools let you merge multiple shots with different exposures into one perfectly exposed photo. This work nicely but require some limitation, as for example the necessity to shot static subjects. But what if you have just in case of single image, or with dynamic subjects? You might want to give a try to the Local Contrast feature. It’s based on the LDR Tonemapping utility which is designed to improve the dynamic range of the photo by reducing its global contrast and increasing the local contrast. It does so by generating a desaturated and blurred version of the photo. It then combines the RGB channels of the original photo with the desaturated blurred image using either the Linear or Power function. Sounds complicated? Don’t worry, the Local Contrast tool is rather straightforward to use, so you don’t have to understand all its intricacies in order to achieve pleasing results.
Example 3.11 The Local Contrast in Action

Open the photo you want in the editor and choose Enhance → Local Contrast. The tool lets you apply up to four tonemapping operations called stages. Each stage offers two parameters for you to tweak: Power and Blur. The former allows you to specify the desaturation level, while the latter lets you adjust the affected areas on the photo. To preview the result, hit the Try button. Once you are satisfied with the result, press OK to apply the process to the photo.

While the Local Contrast tool may sound like an easy way to fix photos, you should use it with care: sometimes it can do more damage than good, producing unnaturally looking photos.

3.2.4.4 Introduction

This tool provides selectable image filters to remove specks or other artifacts caused by junk such as dust or hair on the lens. It also can be used to remove Sensor Noise from the camera that maybe caused by high ISO settings, as well as the so-called Moiré Patterns on scanned images from books or magazines.

If you want more information about what’s digital camera sensor noise, please take a look in this tutorial.
3.2.4.4.1 Using the Noisereduction Tool

The above screenshot shows a typical scene taken with a digital camera using a high sensitivity ISO setting. It shows grainy noise which can be reduced successfully with this tool.

The re-sizeable image panel with the original preview helps you to pan within the image. Move the red rectangle around to select the area that lets you judge on the optimal filter settings. The preview window shows the filter output using the current settings. It can be rearranged in four different combinations as depicted in the icons below the original preview. This screenshot shows the first arrangement where the same cutout is shown for comparison. On the bottom of preview area, you can see Zoom Factor settings to magnify an area of the image.

You can see below a full description of all parameters. In most cases only Details tab is needed and the other parameters available into Advanced tab can be left at their default setting.

- **Radius:** this control selects the gliding window size used for the filter. Larger values do not increase the amount of time needed to filter each pixel in the image but can cause blurring. This window moves across the image, and the color in it is smoothed to remove imperfections. In any case it must be about the same size as noise granularity or somewhat more. If it is set higher than necessary, then it can cause unwanted blur.

- **Threshold:** use the slider for coarse adjustment, and the spin control for fine adjustment. This controls edge detection sensitivity. This value should be set so that edges and details are clearly visible and noise is smoothed out. This value is not bound to any intensity value, it is bound to the second derivative of intensity values. Simply adjust it and watch the preview. Adjustment must be made carefully, because the gap between noisy, smooth, and blur is very small. Adjust it as carefully as you would adjust the focus of a camera.

- **Texture:** this control set the texture accuracy. This value can be used, to get more or less texture accuracy. When decreased, then noise and texture are blurred out, when increased then texture is amplified, but also noise will increase. It has almost no effect to image edges, opposed to filter Edge, which would blur edges, when increased. If Edge is adjusted in away so that edges are sharp, and there is still too much area noise, then Texture detail could be used to reduce noise without blurring edges. Another way would be to decrease Radius and to increase Edge.

- **Sharpness:** this control set the sharpness level. This value defines the pixel distance in which the filter looks ahead for luminance variations. When this value is increased, then spikenoise
is erased. You can eventually readjust filter Edge, when you changed this setting. When this value is too high, then the adaptive filter cannot longer accurately track image details, and noise can reappear or blur can occur.

- **Edge**: this control set the edge accuracy for sharpness. This value improves the frequency response for the filter. When it is too strong then not all noise can be removed, or spike noise may appear. Set it near to maximum, if you want to remove weak noise or JPEG-artifacts, without loosing detail.

- **Erosion**: this control set the phase shift for edges. This value can be used to erodes singular spikes and it has a smooth effect to edges, and sharpens edges by erosion, so noise at edges is eroded. The effect is dependent from Sharpness, Damping, and Edges. Set it to minimum, if you want to remove weak noise or JPEG-artifacts. When this value is increased, then also increasing Damping is often useful. This setting can provides sharpening and antialiasing effect to edges when spike noise is corrected.

- **Luminance**: this control set the luminance tolerance of image. It’s recommended to use only Color or Luminance tolerance settings to make an image correction, not the both at the same time. These settings don’t influence the main smoothing process controlled by Details settings.

- **Color**: this control set the color tolerance of image. It’s recommended to use only Color or Luminance tolerance settings to make an image correction, not the both at the same time. These settings don’t influence the main smoothing process controlled by Details settings.

- **Gamma**: this control set the gamma tolerance of image. This value can be used to increase the tolerance values for darker areas (which commonly are more noisy). This results in more blur for shadow areas.

- **Damping**: this control set the phase jitter damping adjustment. This value defines how fast the adaptive filter-radius reacts to luminance variations. If increased, then edges appear smoother, if too high, then blur may occur. If at minimum then noise and phase jitter at edges can occur. It can suppress spike noise when increased and this is the preferred method to remove it.

- **Save As... and Load...**: these buttons are used to do just that. Any Noise Reduction parameters that you have set can be saved to the filesystem and loaded later.

- **Defaults**: this button resets all settings to default values.

### 3.2.4.4.2 Noisereduction in action

This is an example of how the noise reduction can change your life. The original image is (1) and the corrected image is (2). The noise reduction was applied using default settings.
3.2.4.5 Softening a Photograph

Sometimes an image is too crisp for your purposes. The solution is to blur it a bit: fortunately blurring an image is much easier than sharpening it. Select the Blur Tool with the **Enhance** → **Blur** menu entry and experiment with the level. The preview window on the right of the dialog shows the effect of the operation on your photograph.

**Example 3.12 The Blur Tool in Action**
3.2.4.6 Introduction

This fantastic restoration filter is a new development providing unprecedented possibilities in the public domain to remove lots of unwanted stuff from your images. It is well adapted to deal with degraded images suffering from Gaussian noise, film grain, scratches or compression artifacts and local degradations usually encountered in digital (original or digitized) images. The smoothing happens along the image curvatures, thus preserving the meaningful content much alike our human eye would want it.

The same algorithm can be used for colorization and texture replacement which is covered by another tool (inpainting). The restoration algorithm has been developed by the IMAGE team of GREC CNRS lab in Caen/France and is a part of the CImg project.

3.2.4.6.1 Using the Restoration tool

The tool comes with several presets as starting points and to simplify the restoration. The preset settings available are listed below:

- **None**: Using most common default filter settings not optimized for any particular purpose.
- **Reduce Uniform Noise**: Optimum settings for image noise due to sensors.
- **Reduce JPEG Artifacts**: JPEG’s compression is not perfect, in fact for some types of images it is far from it. As a lossy compression algorithm, there are some compression “artifacts” - slight defaults showing in the decompressed image. This setting aims at correcting this problem.
- **Reduce Texturing**: Optimized to remove artifacts from scanning, digitizing or Moire patterns.

If you want to set filter parameters for finer adjustments, use **Smoothing Settings** and **Advanced Settings** tabs:
• **Detail Preservation** $p$ [0, 100]: this controls the preservation of the curvatures (features). A low value forces an equal smoothing across the image, whereas bigger values preferably smooth the homogeneous regions and leaves the details sharper. A value of 0.9 should well preserve details so that no sharpening is required afterwards. Note that **Detail Preservation** must be always inferior to **Anisotropy**.

• **Anisotropy** $\alpha$ [0, 100]: a low value smooths equally in all directions, whereas a value close to 1 smooths in one direction only. If you have film grain or CCD kind of noise a high value will result in wave-like pattern, whereas JPEG artifacts are suited for values close to 1.

• **Smoothing** [0, 500]: this sets the maximum overall smoothing factor (when $p$ defines the relative smoothing). Set it according to the noise level.

• **Regularity** [0, 100]: this parameter is concerned with the uniformity of the smoothing. Imagine the smoothing process as a combing of the image. Then the Regularity would correspond to the size of the comb. The bigger this value, the more even the overall smoothing will be. This is necessary when much noise is present since it is then difficult to estimate the local geometry. Also if you want to achieve a ‘van Gogh’ turbulence effect, setting it higher than 3 is recommended.

• **Filter Iterations**: number of times the blurring algorithm is applied. Usually 1 or 2 is sufficient.
Angular Step $da$ [5, 90]: angular integration of the anisotropy alpha. If alpha is chosen small, $da$ should also be chosen small. But beware, small angles result in long runs! Choose it as large as you can accept.

Integral Step [0.1, 10]: spatial integration step width in terms of pixels. Should remain less than 1 (sub-pixel smoothing) and never be higher than 2.

Use Linear Interpolation: The gain in quality if you select this option is only marginal and you lose a factor of 2 in speed. Our recommendation is to leave it off.

Save As... and Load... buttons are used to do just that. Any Photograph Restoration filter settings that you have set can be saved to the filesystem in a text file and loaded later.

**WARNING**
Photograph restoration is (comparatively) very fast in what it is doing, but it can take a long time to run and cause high CPU load. You may always abort computation by pressing Abort button during preview rendering.

3.2.4.6.2 The Restoration tool in action

Below, you can see a Reduce Uniform Noise Restoration type applied to a Black and White photograph taken with a Minolta(tm) 700Si camera using Ilford(tm) HP-5 film set at 3200 ISO sensitivity. You see the very prominent film grain on the faces. The original image is (1), the corrected image (2).
Below, you can see another Photograph Restoration example using **Reduce Texturing** Restoration type applied to an old color photograph acquired with a digital flat scanner. You see the very prominent artifacts resulting from scanner light on plastic photograph paper. The original image is (1), the corrected image (2).

3.2.4.7 Introduction

Wide angle lenses, especially those used in medium and large format photography, frequently do not uniformly illuminate the entire sensor plane. Instead, they “vignette” (shade) the edges and
corners of the image, substantially reducing the light reaching the sensor there. But telelenses may show vignetting too.

The traditional solution for this is to attach a "center filter" to the lens. This is a neutral density filter with maximum density at the optical axis of the lens, clear at the periphery, with density varying inversely to the vignetting of the lens. A center filter has many advantages: not only does it automatically correct for full-frame images but, since it’s fixed to the front of the lens, it also compensates for the off-center vignetting which occurs when camera movements are employed for perspective or plane of focus adjustment.

But there are disadvantages as well. Many center filters require a 1.5 or 2 f-stop filter factor adjustment, which may in turn necessitate a shutter speed so slow (since wide angle lenses, even with center filters, are best used at apertures of f/16 or smaller) that hand-holding the camera is impossible and motion blur becomes a problem when photographing moving objects.

With the wide exposure range of present-day film and the color (or grey-scale) depth of digital camera or film scanners, it is possible to simulate the effect of a center filter by applying an equivalent transform to a raw image taken without the filter. This antivignetting tool applies a center filter transformation to an image employing an algorithm copyrighted by John Walker.

3.2.4.7.1 Using the vignetting correction tool

Five sliders give you control over the vignetting correction filter, and three more over the target image exposure:

**Amount:** this option controls the degree of luminosity attenuation by the filter at its point of maximum amount. The default amount is 2.0, which corresponds to an optical filter with a 1 f-stop filter factor (or, by no coincidence, a factor of 2 in luminosity). Increase the amount to compensate for a greater degree of vignetting; reduce it for less.

**Feather:** this option determines the rate at which the filter intensity falls off from the point of maximum amount toward the edges, expressed as a power factor. The default of 1 yields a linear reduction in filter amount with distance from the center. Power factors greater than 1.0 cause a faster fall-off (for example, a power of 2 causes the amount to decrease as the square of the distance from the center) and causes the effect of the filter to be concentrated near the center.
Powers less than 1 spread out the amount of the filter toward the edges; a power of 0.5 causes the amount to fall as the square root of the distance from the center.

**Radius**: this option specifies the radius, as a multiple of the half diagonal measure of the image, at which the amount of the filter falls off to zero (or, in other words, becomes transparent). The default value of 1.0 specifies a filter which is transparent at its corners. A radius specification greater than 1 extends the effect of the center filter beyond the edges of the image, while a radius less than one limits the filter’s action to a region smaller than the image. When compensating for vignetting by lenses used with large format and some medium format cameras, the default radius factor of 1 is rarely correct! These lenses often “cover” an image circle substantially larger than the film to permit camera movements to control perspective and focus, and consequently have a vignetting pattern which extends well beyond the edges of the film, requiring a radius setting greater than 1 to simulate a center filter covering the entire image circle.

The only way to be sure which settings of **Amount**, **Feather**, and **Radius** best compensate for the actual optical characteristics of a given lens is to expose a uniformly illuminated scene (for example, a grey card lit by diffuse light) and perform densitometry on the resulting image (for example with Adjust Level tool histogram position bar). Failing that, or specifications by the lens manufacturer giving the precise degree of vignetting at one or more working apertures, you may have to experiment with different settings to find those which work best for each of your lenses. For help you in this task, the widget dialog provide a thumbnail mask rendering applied on the image. Fortunately, the response of the human eye is logarithmic, not linear like most digital imaging sensors, so you needn’t precisely compensate for the actual vignetting to create images which viewers will perceive as uniformly illuminated.

**X offset** and **Y offset** settings: these options moves respectively the center of the filter horizontally or vertically up to the border of the image by the specified percentage. A negative value for the X offset will shift the filter to the left while a positive value will shift it to the right. A negative value for the Y offset will move the filter up, and finally a positive value will move it down.

**Brightness**, **Contrast**, and **Gamma** settings: processing an image with this antivignetting tool reduces the luminosity of pixels. You need to re-adjust the target image exposure with these options. These sliders give only positive values because you need only to increase this setting.

**Add Vignetting**: many photographs looks flat because of a distracting background or another composition matter. While most of time you will want to remove vignetting it is a fact that a selective vignetting could improve the readability of a photograph and draw the eyes to the intended subject. As an artist you may choose this option, ticking it will invert the filter thus darkening the corners of a photograph.

### NOTE
digiKam If you want a finer exposure re-adjustment of the target image, leave the Brightness/Contrast/Gamma values at zero and use the Adjust Curve tool from Image Editor available under **Color** → **Adjust Curve** menu entry.

#### 3.2.4.7.2 The vignetting correction tool in action

This is an example of an anti vignetting correction applied to an image. The original image (1) shows vignetting in the corners, the corrected image (2) much less. A brightness and contrast correction is also applied to the target image by this tool.

The values used for this example are:

- Density = 2.6.
- Power = 0.9.
- Radius = 1.1.
- Brightness = 20.
The inpainting algorithm has been developed by the IMAGE team of GREC CNRS lab in Caen/France and is a part of the CImg project.
3.2.4.8.1 Using the Inpainting tool

The tool comes with several presets as starting points and to simplify the restoration. The preset settings available are listed below:

- **None**: Using most common default filter settings not optimized for any particular purpose.
- **Remove Small Area**: .
- **Remove Medium Area**: .
- **Remove Large Area**: .

If you want to set filter parameters for finer adjustments, use **Smoothing Settings** and **Advanced Settings** tabs:

- **Detail Preservation** $p \in [0, 100]$: this controls the preservation of the curvatures (features). A low value forces an equal smoothing across the image, whereas bigger values preferably smooth the homogeneous regions and leaves the details sharper. A value of 0.9 should well preserve details so that no sharpening is required afterwards. Note that **Detail Preservation** must be always inferior to **Anisotropy**.

...
• **Anisotropy** alpha $[0, 100]$: a low value smooths equally in all directions, whereas a value close to 1 smooths in one direction only. If you have film grain or CCD kind of noise a high value will result in wave-like pattern, whereas JPEG artifacts are suited for values close to 1.

• **Smoothing** $[0, 500]$: this sets the maximum overall smoothing factor (when $p$ defines the relative smoothing). Set it according to the noise level.

• **Regularity** $[0, 100]$: this parameter is concerned with the bigger structures. The bigger this value, the more even the overall smoothing will be. This is necessary when much noise is present since it is then difficult to estimate the geometry. Also if you want to achieve a ‘van Gogh’ turbulence effect, setting it higher than 3 is recommended.

• **Filter Iterations**: number of times the blurring algorithm is applied. Usually 1 or 2 is sufficient.

• **Angular Step** $da [5, 90]$: angular integration of the anisotropy alpha. If alpha is chosen small, da should also be chosen small. But beware, small angles result in long runs! Choose it as large as you can accept.

• **Integral Step** $[0.1, 10]$: spatial integration step width in terms of pixels. Should remain less than 1 (sub-pixel smoothing) and never be higher than 2.

• **Use Linear Interpolation**: The gain in quality if you select this option is only marginal and you lose a factor of 2 in speed. Our recommendation is to leave it off.

---

**Save As...** and **Load...** buttons are used to do just that. Any Photograph Inpainting filter settings that you have set can be saved to the filesystem in a text file and loaded later.

---

**WARNING**

Photograph Inpainting is (comparatively) very fast in what it is doing, but it can take a long time to run and cause high CPU load. You may always abort computation by pressing **Cancel** button during rendering.

---

**3.2.4.8.2 The Inpainting tool in action**

Below, you can see a **Remove Small Area** Inpainting type applied to a color photograph taken at Guatemala city with an analog camera. Look like there is a strange black artifacts on the face front, resulting of a bad film stockage during the travel. The original image is (1), the corrected image (2).
3.2.4.9 Remove Red Eyes in a Photograph

Red eyes are caused when the camera flashlight is used to take photographs of people. The red is the reflection from the back of the eye which can be seen because the pupil cannot react quickly enough to the flash. By the way, with a separate flash light the red eye effect is less likely because of the different viewing angle of flash and lens. You can correct some of the worst effect of Red Eye by selecting the area of the eye on the photograph, in the same way as described for cropping above. Then select Enhance → Red Eye Reduction.

How it works

- Set the preview mode to your liking
- The Sensitivity setting adjusts the amount of red eyes removal (aggressive or not)
- The Smooth slider sets the blurring of the area that has been darkened to render the pupil more natural
- The Color Tint sets a custom colorization for the pupil. If you want blue eyes instead of dark ones, here you can do it
- The Tint Level adjusts the luminosity of set pupil color
### Example 3.13 The Red Eyes Correction Tool in Action

![Example Image]

#### 3.2.4.10 Introduction

Out-of-focus photographs, as well as most digitized images, need correction of sharpness. This is due to the digitizing process that must chop up a color continuum in points with slightly different colors: elements thinner than sampling frequency will be averaged into an uniform color. Thus, sharp borders are rendered a little blurred. The same phenomenon appears when printing color dots on paper. SLR cameras need even more sharpening on a regular basis than consumer cameras.

Whereas JPEG images have some camera-internal sharpening applied, RAW format images always need sharpening in their workflow.

Some scanners apply a sharpen filter while scanning. It’s worth to disable it so that you keep control over your image.

#### 3.2.4.10.1 Adjusting Sharpness

#### 3.2.4.10.2 Unblurring a Photograph

If the camera focus is not set perfectly or if the camera is moving when the image is taken the result is a blurred photograph. If there is a lot of blurring, you probably will not be able to do much about it with any technique. If there is only a moderate amount, you should be able to improve the image. Many good SLR cameras apply less image processing to the images than simpler cameras (which tend to artificially increase the contrast to make the images look crisp). This kind of slight blur can be easily improved with tools.

In some situations, you may be able to get useful results by sharpening an photograph using the Sharpen tool by the **Enhance → Sharpen** menu entry.
You should be careful with this though, or the results will not look very natural: sharpening increases the apparent sharpness of edges in the photograph, but also amplifies noise. Generally, the most useful technique for sharpening a fuzzy photograph is the Refocus tool. You can access it with the Enhance → Refocus menu entry. Look at Refocus for more information and a comparison of all the sharpening techniques.

3.2.4.10.3 Reducing Graininess In a Photograph

When you take a photograph in low-light conditions or with a very fast exposure time, the camera does not get enough data to make good estimates of the true color at each pixel, and consequently the resulting photograph looks grainy. You can "smooth out" the graininess by blurring the image, but then you will also lose sharpness. Probably the best approach - if the graininess is not too bad - is to use the filter Noise Reduction tool, and you can access it by the Enhance → Noise Reduction menu entry.

3.2.4.10.4 Softening a Photograph

Sometimes you have the opposite problem: an image is too crisp. The solution is to blur it a bit: fortunately blurring an image is much easier than sharpening it. Select the Blur Tool with the Enhance → Blur menu entry and experiment with the level. The preview window on the right of the dialog shows the effect of the operation on your photograph.

3.2.4.10.5 The Unsharp Masking Filter

NOTE
The Unsharp Mask filter is an excellent tool to remove haze from your photographs, see this url for a demonstration.
The image panel and the original preview help you to pan within the image. The preview window shows the filter output using the current settings.

There are two important parameters, **Radius** and **Amount**. The default values often work pretty well, so you should try them first. Increasing either the **Radius** or the **Amount** increases the strength of the effect. Don’t get carried away, though: if you make the unsharp mask too strong, it will amplify noise in the image and create the impressions of ridges next to sharp edges.

The **Radius** allows you to set how many pixels on either side of an edge that will be affected by sharpening. High resolution images allow higher radius. You’d better always sharpen an image at its final resolution.

The **Amount** control is the percentage of the difference between the original and the blur image that is added back into the original. It allows you to set strength of sharpening.

The **Threshold** control is a fraction of the maximum RGB value, needed to apply the difference amount. It allows you to set the minimum difference in pixel values that indicates an edge where sharpening should be applied. That way, you can protect areas of smooth tonal transition from sharpening, and avoid creation of blemishes in face, sky or water surface.

### 3.2.4.10.6 The Unsharp Mask in action

This is an example of how the Unsharp Mask can change your life. The original image is (1) and the corrected image is (2). The unsharp mask was applied with **Radius** = 6.0, **Amount** = 0.5, **Threshold** = 0.0.
3.2.4.10.7 Refocus a Photograph

digiKam The *Refocus* is a tool to refocus an image by enhancing the sharpness. It uses the *Deconvolution Filter* algorithm copyrighted by Ernst Lippe.

This tool attempts to “refocus” an image by undoing the defocussing. This is better than just trying to sharpen a photograph. It is employing a technique called *FIR Wiener Filtering*. The traditional technique for sharpening images is to use unsharp masking. Refocus generally produces better results than Unsharp masking. Start it from the **Enhance → Sharpen → Refocus** Image Editor menu.

The Refocus technique works differently from Unsharp Mask and is also unlike the Sharpen Filter which both increase the contrast of the edges of an image. Refocus rather reverses the process by which the image got blurred by the circular aperture of the camera. This method gives you as much of the original “in focus” image as possible. Refocus uses a very powerful deconvolution algorithm that will reclaim the data that has been mixed up. In mathematical terms, blurring is usually the result of a convolution, a deconvolution will reverse the process, this is exactly what Refocus is doing. Furthermore, the FIR filter technique allows to remove much of the noise and granularity that often gets accentuated in the sharpening process of all sharpening filters.
3.2.4.10.8 Using the Refocus Tool

The image panel and the original preview help you to pan within the image. The preview window shows the filter output using the current settings.

In most cases (blurring by camera) a circular convolution caused the image degradation, but there are two convolutions available:

- The circular convolution: this one spreads each source point uniformly across a small disk with a fixed radius. Technically this describes the effects of using a (ideal) lens that is not correctly focused.

- The Gaussian convolution: this one is mathematically similar to the normal distribution, with its bell-shaped curve. Originates rather from unnatural blurring (software blurring). From a theoretical point of view the mathematical justification for using the Gaussian convolution is that when you apply a large number of independent random convolutions the results will always approach a Gaussian convolution.

The refocus tool supports both the Circular and the Gaussian convolution plus mixtures of both. In practice, in most cases the Circular convolution works much better than the Gaussian convolution. The Gaussian convolution has a very long tail, so mathematically the result of the convolution also depends on source pixels at a large distance from the original source pixel. The FIR Wiener inverse of a Gaussian convolution in most cases is heavily influenced by source pixels at a large distances, and in most cases this produces undesirable results.

To set correctly the deconvolution filter, the plug-in has the following parameters:

- **Circular Sharpness**: This is the radius of the Circular convolution filter. It is the most important parameter for using the plug-in. With most images the default value of 1 should give good results. Select a higher value when your image is very blurred, but beware of producing halos.

- **Correlation**: Increasing the **Correlation** may help reducing artifacts. The correlation can range from 0-1. Useful values are 0.5 and values close to 1, e.g., 0.95 and 0.99. Using a high value for the correlation will reduce the sharpening effect of the plug-in.
• **Noise filter**: Increasing the **Noise filter** parameter helps reducing artifacts. The Noise can range from 0-1 but values higher than 0.1 are rarely helpful. When the Noise value is too low, e.g. 0 the image quality will be horrible. A useful value is 0.03. Using a high value for the Noise will even blur the image further.

• **Gaussian Sharpness**: This is the radius for the Gaussian convolution filter. Use this parameter when your blurring is Gaussian (mostly due to previous blur filtering). In most cases you should leave this parameter to 0, because it causes nasty artifacts. When you use non-zero values you will probably have to increase the **Correlation** and/or **Noise filter** parameters, too.

• **Matrix size**: This parameter determines the size of the transformation matrix. Increasing the **Matrix Size** may give better results, especially when you have chosen large values for **Circular Sharpness** or **Gaussian Sharpness**. Note that the plug-in will become very slow when you select large values for this parameter. In most cases you should select a value in the range 3-10.

• **Save As...** and **Load...**: these buttons are used to do just that. Any Refocus parameters that you have set can be saved to the filesystem and loaded later.

• **Defaults**: this button resets all settings to default values.

Below, you can see few hints to help you work with the refocus plug-in:

• Preferably perform all cropping, color and intensity curve corrections on the image before using this plug-in.

• Otherwise use this plug-in before performing any other operations on the image. The reason is that many operations on the image will leave boundaries that are not immediately visible but that will leave nasty artifacts.

• When you are scanning images and compress them, e.g. to JPEG, you should use the plug-in on the uncompressed image.

### 3.2.4.10.9 Refocus comparison with other techniques

Comparison to two other techniques frequently used to enhance images are:

• **Sharpen Filter**

• **Unsharp Mask**

Sharpening applies a small convolution matrix that increases the difference between a source pixel and its immediate neighbors. FIR Wiener filtering is a more general technique because it allows a much larger neighborhood and better parameterizations. Sharpening only works when your images are very slightly blurred. Furthermore, for high values of the sharpening parameter the results frequently looks “noisy”. With FIR Wiener filtering this noise can be greatly reduced by selecting higher values for the **Correlation** and **Noise filter** parameters.

Unsharp masking is another very popular image enhancement technique. From a mathematical point of view its justification is a bit obscure but many people are very fond of it. The first step is to create a blurred copy of the source image. Then the difference between the source image and the blurred image is subtracted from the source image, hence the name unsharp masking. If fact, unsharp masking is more of a contrast enhancement on the important image feature than a sharpening. It does not undo the aperture pattern interference of the camera diaphragm as refocus does.

In general, unsharp masking produces better results than sharpening. This is probably caused by the fact that unsharp masking uses a larger neighborhood than sharpening.

From a theoretical point of view unsharp masking must always introduce artifacts. Even under optimal circumstances it can never completely undo the effect of blurring. For Wiener filtering
it is possible to prove that it is the optimal linear filter. In practice, in all cases the results of the FIR Wiener filter were at least as good as those of unsharp masking. The FIR Wiener filter is frequently better in restoring small details.

Below, you can see a comparison of different filters applied on a small unfocused image:

<table>
<thead>
<tr>
<th>Preview</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Original blurred color image to fix. This image has been taken with an analog still camera. The unfocusing result of an insufficient light for the auto-focus lens." /></td>
</tr>
<tr>
<td><img src="image" alt="Fixed image using simple sharpening filter. Sharpness setting is 80." /></td>
</tr>
<tr>
<td><img src="image" alt="Fixed image using unsharp mask filter. Settings are Radius=50, Amount = 5, and Threshold=0." /></td>
</tr>
</tbody>
</table>
3.2.4.11  Lens Auto Correction Tool

TODO

3.2.5  Image transformation tools

3.2.5.1  Cropping a Photograph

3.2.5.1.1  Manual Crop

Cropping a photograph is not only a common operation, but an often underestimated photographer’s tool to compose an image. The Image Editor makes it very easy. To crop a photograph simply drag a rectangle over the image by holding down the left mouse button and moving the mouse. You will see a wire frame rectangle appear as you move the mouse.

NOTE
For more information about correction of sharpness methods used in digital imagery, you can find a technical comparison at this url.
Example 3.15 The Current Image Selection in Image Editor

When you release the button the area of the photograph that will be removed by a crop operation is greyed out. This allows you to get a good view of how your photograph will look once you have cropped it. You can change the size of the cropped area by dragging the corners of the rectangle, and you can create a new crop area simply by dragging out another rectangle.

Once you are happy with the crop, click on the button on the toolbar and the photograph will be cropped (Ctrl-X). Use the File → Save or File → Save As... entries in the File menu to save the newly cropped photograph.

3.2.5.1.2 Auto Crop

The Auto Crop tool removes the borders from an image. It searches the largest possible border area that is all the same color, and then crops this area from the image, as if you had used the Crop tool.

This tool can be used for example to crop a stitched panorama, assembly with many images, which generate black borders around.

Example 3.16 Stitched Panorama Processed With Auto Crop

3.2.5.1.3 Proportional Crop

The Aspect Ratio Crop tool goes further. While you are editing digital images, it is often necessary to create a compatible format with, for example, your photo album or paper formats. If you print an image from your digital camera and then try to put it in your photo album, you may notice that the camera has a different width or height ratio than a normal photographic film format so you need to crop your digital images in a predefined ratio (for example 5:7 or 2:3 which is a standard photo ratio).
Example 3.17 The Aspect Ratio Crop Tool Dialog

In the preview area you can resize the cropping rectangle by moving the corners with the mouse. It will keep the ratio value set in the bottom of dialog.

In the Aspect Ratio Crop tool settings, you specify the Orientation as Portrait or Landscape. Portrait will always have the larger size assigned to the Height and Landscape to the Width.

Aspect Ratio Crop tool uses a relative ratio. That means it is the same if you use centimeters or inches and it doesn’t specify the physical size. For example, you can see below a correspondence list of traditional photographic paper sizes and aspect ratio crop.

<table>
<thead>
<tr>
<th>Standard Photograph Paper Size</th>
<th>Aspect Ratio Crop</th>
</tr>
</thead>
<tbody>
<tr>
<td>10x15cm 20x30cm 30x45cm</td>
<td>2:3</td>
</tr>
<tr>
<td>3.5x5” 4x6” 8x12” 12x18” 16x24” 20x30”</td>
<td>2:3</td>
</tr>
<tr>
<td>6x8cm 15x20cm 18x24cm 30x40cm</td>
<td>3:4</td>
</tr>
<tr>
<td>3.75x5” 4.5x6” 6x8” 7.5x10” 9x12”</td>
<td>3:4</td>
</tr>
<tr>
<td>20x25cm 40x50cm 8x10” 16x20” 15x21cm 30x42cm 5x7”</td>
<td>4:5</td>
</tr>
<tr>
<td>21x30cm 42x60cm</td>
<td>7:10</td>
</tr>
</tbody>
</table>

At the far right of the dialog two buttons are available to move the crop selection automatically to the horizontal or vertical center of the image.

At the very bottom line of the dialog, the Max. Ratio button lets you set the crop area size to the maximum size according to the current aspect ratio settings and orientation.

**NOTE**
The Aspect Ratio Crop tool remembers the settings depending on image orientation (horizontal or vertical). When you use the crop tool next time, these settings will be used as default values depending on the image orientation. The changed image dimensions are stored into the EXIF tables so that the EXIF data reflects the cropped image and not the original one.
3.2.5.1.4 Composition Guide

When first looking at an image, the eye of the viewer rarely settles at the center of the image, but moves instead from the top left to the right, and then from the lower left to the right again. This pattern is unconscious but has been well documented. It is probably associated with the western reading pattern. From the photographer’s point of view, the goal then becomes to guide the gaze of the viewer to the subject, being aware of the way many people perceive an image.

The Composition Guide settings provides guiding elements to better compose your images. These guides are:

- **Rule of Thirds**: a grid that divides the image into thirds in every direction (that makes for 9 parts). These proportions are close to the golden rule and are derived from the field of view of the human eye. They are often used with slight variations throughout a large number of commonly used objects. Within that frame there are precise areas where the important parts of the image should be placed. The same principle is used to determine the position of the horizon and the proportion of ground to sky.

Many photographers and artists are aware of the Rule of Thirds, where an image is divided into three sections vertically and horizontally and the points of intersection represent places to position important visual elements. Moving a horizon in a landscape to the position of one third is often more effective than placing it in the middle, but it could also be placed near the bottom one quarter or sixth. There is nothing obligatory about applying the Rule of Thirds. In placing visual elements for effective composition, one must assess many factors including color, dominance, size and balance together with proportion. Often a certain amount of image balance or tension can make a composition more effective.

**Example 3.18 Image Composition Example Using Rules of Third**

- **Harmonious Triangles**: Harmonious divisions rely on the principle of similarity. Like the Rule of Thirds guide, Harmonious Triangles are another division of the image using a rectangle into equiangular harmonious triangles aligned with the diagonal.
Example 3.19 Photograph Composition Example Using Harmonious Triangles

• **Golden Mean**: The Golden Mean is a ratio underlying numerous growth patterns throughout nature (from the spiral of a Nautilus shell to the petals of a sunflower), it has an uncanny way of showing up in all kinds of things we deem beautiful.

The Golden Ratio is the irrational number 1.618033988..., and it is usage dates back to the ancient Egyptians and Greeks who used it in the construction of their temples and pyramids. Artists and architects throughout time have used the Golden Ratio when composing their paintings, buildings, and even photographs, in order to give their creations a sense of natural order and beauty.

The ratio is inherent in the Fibonacci series: 1, 1, 2, 3, 5, 8, 13, 21, 34 etc., where each succeeding number after 1 is equal to the sum of the two preceding numbers. The ratio formed 1:1.618 is the Golden Mean. A composition following this rule is considered visually harmonious.

The Golden Mean provides more fluid guidelines when used to compose an image. These guides are listed below:

– The **Golden Spiral** guide will increase your odds of getting captivating results in your photographs. As opposed to Rule of Thirds, the Golden Spiral forms a fluid line for the eye to trace through the image. This style of composition will invite the viewer’s gaze into the image along the line of the spiral, creating a more symmetrical visual flow, and an overall compelling viewing experience.
Example 3.20 Image Composition example using Golden Spiral

One more rule is a **Golden Spiral Sections** (or Golden Rectangles). These rectangles are used to build the Golden Spiral. There should be something leading the eye to the center of the composition. It could be a line or several subjects. This "something" could just be there without leading the eyes, but it would make its job.

Example 3.21 Image Composition example using Golden Spiral Sections

The **Golden Triangles** is a derivative of the Golden Spiral discussed above. Its vertices are
the midpoints of the sides of the Golden Rectangle. Note that unlike Harmonious Triangles, Golden Triangles aren’t equiangular triangles. Placing diagonals along these lines can make an otherwise static subject appear more dynamic.

When you use Golden Triangles to break up your frame, you’re creating an effect professional photographic experts call Dynamic Symmetry. Try to keep your focal subject on one of the intersecting points, and place other visual information into the triangles you’ve already divided out. The result will be a very attractive composition you may not have otherwise attained.

Example 3.22 Photograph Composition Example Using Golden Triangle

Like the Rule of Thirds the Golden Sections affects the ratio of an image size as well as the placement of the main subjects on the photo. This ratio is close to the 35mm ratio, so you don’t need to change the size of the photo in most cases. But you need to consider the composition: the main subject should lie on one of the four lines or four intersections (subject’s eye for example). Truthfully speaking, these rules are not the same. Rule of Thirds is a simplified version of the Golden Mean.
**Example 3.23** Image Composition example using Golden Sections

The *Flip Horizontal* and *Flip Vertical* options can be used to apply flip transformation to the harmonious divisions.

The *Color* button lets you set the guidelines color. If you have an high color contrast image, the guidelines may become invisible. By the way, you can adapt the color guide to the current image.

### 3.2.5.2 Introduction

When taking an image it is all too easy to hold the camera not quite perfectly vertical or horizontal, resulting in an image where things are tilted at an angle. The way to fix this with the digiKam Image Editor is to use the Free Rotation tool. Select **Transform → Free Rotation** and adjust to the target angle.

#### 3.2.5.2.1 Free Rotation Tool

Rotate your image by using the *Angle* slider (value in degrees). Press to **Reset Values** for reset the slider to zero. A rotating effect preview is available on the right side of the dialog. The new target image dimensions in pixels are shown.

For better orientation, the Free Rotation tool provides a vertical and horizontal guide. Move the mouse cursor under image preview to display the dashed line guide. Move the cursor to an supposedly vertical or horizontal feature in the image like the sea or a building border and press the left mouse button for freeze the dashed lines position. Now, adjust the angle accordingly with the guide.
WARNING
After rotating the image, you often find that things are better but not quite perfect. One solution is to rotate a bit more, but there is a disadvantage to that approach. Each time you rotate an image, because the rotated pixels don’t line up precisely with the original pixels, the image inevitably gets blurred a little bit. For a single rotation, the amount of blurring is quite small, but two rotations cause twice as much blurring as one, and there is no reason to blur things more than you have to. Sure, the guide tool available in the Free Rotation preview can help you to apply correctly at the first time an angle adjustment to an image.

3.2.5.2.2 Free Rotation action
The Free Rotation dialog tool in action is available below.

After you have rotated an image, there will be unpleasant triangular "holes" at the corners. One way to fix them is to crop the image with Transform → Crop Image Editor menu.

A more elegant way to crop the rotated image is to use the Auto-crop function. Choose anyone of the following options from the combo-box to your preference:

- **Widest area** This option crops the rotated image to the widest possible (width) rectangular section.
- **Largest area** This options crops the rotated image to the biggest surface.

Hold the mouse over the combo-box and scroll with the wheel between the two possibilities.

The **Anti-aliasing** checkbox will smooth the image a bit after rotation. Please read the warning above.

3.2.5.3 Introduction
With this tool you can work on the perspective in a photograph. This is very useful when working with photographs that contain keystone distortion. Keystone distortion occurs when an object
is photographed from an angle rather than from a straight-on view. For example, if you take an image of a tall building from ground level, the edges of the building appear to meet each other at the far end. On the other hand you can use this tool to introduce a new perspective that is not a face-on view but to give the image a creative spin.

3.2.5.3.1 Using the Perspective Adjustment

All perspective transformations are performed around a fixed point called the reference point. This point is at the center of the item you are transforming and is displayed by a red circle.

To change the perspective, use the square areas at the image corners for dragging. The perspective preview is rendered automatically. On the right of the dialog you’ll find a set of information which help you to control the perspective change:

- **New Width**: show the new image width in pixels including the empty area around the image resulting from the geometrical transformation.
- **New Height**: show the new image height in pixels including the empty area around the image resulting from the geometrical transformation.
- **Top Left Angle**: show the current angle in degrees at the top left corner of the perspective area.
- **Top Right Angle**: show the current angle in degrees at the top right corner of the perspective area.
- **Bottom Left Angle**: show the current angle in degrees at the bottom left corner of the perspective area.
- **Bottom Right Angle**: show the current angle in degrees at the bottom right corner of the perspective area.

**Warning**

After applying the perspective adjustment, the image inevitably gets blurred a little bit. For a single adjustment, the amount of blurring is quite small, but two adjustments cause twice as much blurring as one, and there is no reason to blur things more than you have to.

After you have adjusted the perspective of an image there will be unpleasant triangular “holes” at the corners. One way to fix them is to crop the image with **Transform → Crop** Image Editor menu.

3.2.5.3.2 The Perspective Adjustment in action

The Perspective Adjustment dialog in action is shown below.
3.2.5.4 Introduction

Rescaling an image to make it smaller is easy. The big question is: how can you blow up an image and keep the details sharp? How can one zoom in when the resolution boundary has been reached? How can one reinvent or guess the missing information to fill in the necessarily coarse image after upsizing? Well, the CImg algorithm we use here does an excellent job, try it out and see for yourself!

3.2.5.4.1 Resizing a Photograph

If the photograph has the wrong size, you can scale it to the size you would like by using Transform Resize tool. Select Transform → Resize and adjust the target values. The Resize tool dialog is available below.

Example 3.24 The Resize Tool Dialog

This image resizing tool uses a standard linear interpolation method to approximate pixels. If you want to up-size a small image with a better quality, try the Blowup tool.
3.2.5.4.2 Increasing image size (Restoration)

Many image editing programs use some kind of interpolation e.g. spline interpolation to scale-up an image. digiKam uses a more sophisticated approach. The algorithm underlying Restoration has been developed by the IMAGE team of GREC CNRS lab in Caen/France and is a part of the CImg project.

You have to tell the tool about the resizing you want to do. These settings are available in New Size tab and are listed below:

- **Maintain Aspect Ratio**: if this option is enabled, setting the new image size will preserve the aspect ratio of the original image.
- **Width**: the new image width to use for blowing up.
- **Height**: the new image height to use for blowing up.

If you want to set filter parameters for finer adjustments, use Smoothing Settings and Advanced Settings tabs:

Photograph Blowup Smoothing Settings

- **Detail Preservation** \( p \, [0, 100] \): this controls the preservation of the curvatures (features). A low value forces an equal smoothing across the image, whereas bigger values preferably smooth the homogeneous regions and leaves the details sharper. A value of 0.9 should well preserve details so that no sharpening is required afterwards. Note that Detail Preservation must be always inferior to Anisotropy.
- **Anisotropy** \( \alpha \, [0, 100] \): a low value smooths equally in all directions, whereas a value close to 1 smooths in one direction only. If you have film grain or CCD kind of noise a high value will result in wave-like pattern, whereas JPEG artifacts are suited for values close to 1.
- **Smoothing** \([0, 500]\): this sets the maximum overall smoothing factor (when \( p \) defines the relative smoothing). Set it according to the noise level.
- **Regularity** \([0, 100]\): this parameter is concerned with the bigger structures. The bigger this value, the more even the overall smoothing will be. This is necessary when much noise is present since it is then difficult to estimate the geometry. Also if you want to achieve a 'van Gogh' turbulence effect, setting it higher than 3 is recommended.
- **Filter Iterations**: number of times the blurring algorithm is applied. Usually 1 or 2 is sufficient.

Photograph Blowup Advanced Settings

- **Angular Step** \( \delta a \, [5, 90] \): angular integration of the anisotropy alpha. If alpha is chosen small, \( \delta a \) should also be chosen small. But beware, small angles result in long runs! Choose it as large as you can accept.
The digiKam Handbook

- **Integral Step** \([0.1, 10]\): spatial integration step width in terms of pixels. Should remain less than 1 (sub-pixel smoothing) and never be higher than 2.

- **Use Linear Interpolation**: The gain in quality if you select this option is only marginal and you lose a factor of 2 in speed. Our recommendation is to leave it off.

**Save As...** and **Load...** buttons are used to do just that. Any Blowup Photograph filter settings that you have set can be saved to the filesystem in a text file and loaded later.

**WARNING**
Blowup Photograph is very fast in what it is doing, but it can take a long time to run and cause high CPU load. You may always abort computation by pressing **Cancel** button during rendering.

3.2.5.4.3 The blow-up tool in action

You can see below an Blowup Photograph example applied to a small color image area resized to \(x2\). The original is (1), the Blowup result (3). The (2) preview is the result given to standard linear resizing method to compare.

![Image](image_url)

3.2.5.5 The Liquid Rescale Tool

TODO

3.2.5.6 Rotating or Flipping a Photograph

If the photograph shows a wrong orientation you can **Flip** or **Rotate** it to the orientation you would like by using Transform Flip/Rotate tools available in **Transform → Rotate** and **Transform → Flip** menus.
With flipping options, you can flip or turn over the image horizontally or vertically like a card deck. With the rotating options, you can rotate the image in 90 degrees steps clockwise. It can be used to change the display mode to Portrait or Landscape. Be aware that this rotation is not lossless when using JPEG format. You also can rotate more accurately to a finer degree by using the Free Rotation tool. You can access it by the Transform → Free Rotation menu entry. See the dedicated Free Rotation manual for more information.

3.2.5.7 Introduction

The Shear tool is used to shift one part of an image to one direction and the other part to the opposite direction. For instance, a horizontal shearing will shift the upper part to the right and the lower part to the left. This is not a rotation: the image is distorted. In other words, it will turn a rectangle into a parallelogram. This tool is available from Transform → Shear menu.

3.2.5.7.1 Using the Sheartool

Shear your image by using the Horizontal Angle and Vertical Angle sliders (values in degrees). You can shear along either Horizontally and vertically at the same time. Click on the Reset Values reset. A shearing effect preview is shown on the center of dialog window. The new target image dimensions in pixels are displayed at the right side of dialog.

To assist you in aligning, the tool provides a vertical and horizontal guide. Move the mouse cursor under image preview for display the dashed lines guide. Move the cursor to an important place in the image like the sea or a building border and press the left mouse button for freeze the dashed lines position. Now, adjust the shear correction according with the guide.

**Warning**

After applying a shearing adjustment, the image inevitably gets blurred a little bit. For a single shearing, the amount of blurring is quite small, but two shears cause twice as much blurring as one, and there is no reason to blur things more than you have to.

After you have sheared an image, there will be unpleasant triangular “holes” at the corners. One way to fix them is to crop the image with Transform → Crop Image Editor menu.

3.2.5.7.2 The Sheartool in action

The Shear Tool dialog in action is available below.
3.2.6 Adding decorative elements

3.2.6.1 Introduction

By adding texture to your image, whether color or black and white, you can make it look like an oil painting on canvas, an Old Masters etching, a Pop Art portrait composed of enlarged half-tone dots, or even a mural on a brick wall. The Decorate → Apply Texture Image Editor menu can be used for that.
3.2.6.1.1 Using the Texture Tool

Two options give you control over the texture applying on image:

**Type**: this option specifies the decorative texture style to apply under the image.

**Relief**: dragging this option to the right increases the appearance of depth or three-dimensionality of the texture on image.

3.2.6.1.2 The Texture tool in action

A **Paper** texture effect apply to a photograph is available below. The original image is (1), the target image is (2). **Relief** factor used is 200.
3.2.6.2 Introduction

Keeping the viewer’s interest within the confines of the edges of a photograph is not a simple task. One of the simplest ways to hold the attention on an image is to incorporate a decorative frame around an image. It acts as a kind of psychological barrier to the straying eye. The Image \(\rightarrow\) Add Border Image Editor menu can be used for that.

3.2.6.2.1 Using the Add-border tool

Four options give you control over the decorative frame rendering:

Type: this option specifies the decorative frame style to apply around the image. Solid style just surrounds the image with a colored line, Niepce style surrounds the image with a fine line and a large border (ideal for black and white images), Beveled style adds a neat dimension to your image (ideal to create a button effect), and Decorative style adds an ornamental border using patterns.

Width: this option specifies the border width in percents of image size. The border is added around the image. The width range is limited between 1\% and 50\%.

First: this option specifies the first color to use with the current border type.

Second: this option specifies the second color to use with the current border type.

Click on the OK button to apply the border around the current image.

**NOTE**
The border decorated target image will be bigger than the original, but it will retain the same aspect ratio. This is important for printing images, especially if you have used the Aspect Ratio Crop tool before.
3.2.6.2.2 The Add-border tool in action

The Add Border dialog tool in action is available below.

3.2.6.3 Introduction

This is a handy tool as it lets you add formatted text easily to an image wherever you want, at several places when needed.

3.2.6.3.1 Using the Insert Text tool

This tool seems very intuitive to use. Type in your text and place it with the mouse. Use the block settings as you please. Choose the orientation, color from a color space, and fonts with all their properties. You will have to scale the font size to the image size, the larger the image, the larger the font has to be! Finally choose to add a border around the text and/or a semitransparent background. Voilà, it’s finished!

Any text setting you have chosen can always be changed as long as you don’t click the OK button. In saved and reloaded images the text has become part of the image, it cannot be changed anymore.

3.2.6.3.2 The Insert Text tool in action

The Insert Text dialog tool in action is shown below.
3.2.7 Special Effects (Filters)

3.2.7.1 Introduction

With this filter set, you can transform an ordinary photograph into a work of art suitable for framing using blurring operations. It uses algorithms copyrighted by Pieter Voloshyn.

3.2.7.1.1 Using the Blurfx

These are the blurring effects available:

<table>
<thead>
<tr>
<th>Type</th>
<th>Preview</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Zoom Blur</strong></td>
<td>blurs the image along radial lines starting from a specified center point. This simulates the blur of a zooming camera, thereby giving the photograph a dynamic expression as often seen in sport photography.</td>
</tr>
</tbody>
</table>
**Radial Blur**: blurs the image by rotating the pixels around the specified center point. This simulates the blur of a rotating camera.

**Far Blur**: blurs the image to simulate the effect of an unfocused camera lens. The subject seems to recede into the background.

**Motion Blur**: blurs the image by swishing the pixels horizontally. This simulates the blur of a linearly moving camera, i.e. like a shot taken from a car or train.
### Focus Blur
Focus Blur: blurs the image corners to reproduce the astigmatism distortion of a lens.

### Softener Blur
Softener Blur: blurs the image softly in the darker tones and strongly in the high lights. This gives photographs a dreamy and glossy soft focus effect (Hamilton effect). It’s ideal for creating romantic portraits, glamour photography, or adding a warm and subtle glow.

### Shake Blur
Shake Blur: blurs the image by randomly moving the pixels simulating the blur of an arbitrarily moving camera.
**Smart Blur**: finds the edges of color in photograph and blurs them without muddying the rest of the image.

**Frost Glass**: blurs the image by simulating randomly dispersing light filtering through hoarse frosted glass.

**Mosaic**: blurs the image by dividing the photograph into rectangular cells and then recreates it by filling those cells with average pixel value.

---

**WARNING**

Some effects can take a long time to run and cause high CPU load. You can always abort an effect by pressing the **Abort** button during preview rendering.

---

### 3.2.7.1.2 The Blurfx in action

An example of the Blur FX dialog in action is shown below.
3.2.7.2 Introduction

The digiKam Charcoal filter uses the gradients of color and luminosity to produce a grey scale charcoal sketch. The lines defining the outline of the image are pronounced. Images with slowly changing gradients are not ideal for this effect. It is helpful to imagine what scene you would pick to do as a hand sketch yourself, in order to choose the image to start with.

3.2.7.2.1 Using the Charcoal filter

There are two sliders to control the effect on a scale of 1-100. The upper slider selects the pencil size, whereas the second slider adjusts the contrast (smoothness).

3.2.7.2.2 The Charcoal filter in action

This is an example of the charcoal filter. The original image is (1) and the transformed image is (2). Default values of 30 and 10 where applied. The result can be improved by adjusting the luminosity levels.
3.2.7.3 Introduction

In the age of chemical image processing, solarizing (also known as Sabatier) was an effect created by exposing a partially developed print to a brief flash of light, then completing the development. The colored, darker areas shield the additional light from the sensitive photo layers, which has the net effect of making the lighter areas darker and colors being inverted during the second exposure. The result resembles a partially negative image. The tool allows to adjust the interesting effect smoothly.

3.2.7.3.1 The Solarization Effect

The **Intensity** control helps to preview the solarization by simply increasing it. At about 50% intensity the image shows what was once chemically possible. If you further increase the effect it will finally become a negative image, a stage of inversion not achievable on photographic paper. This is an example of solarization effect. The original image is (1) and the corrected image is (2). The **Intensity** level applied is 30%.
3.2.7.3.2 The Vivid Effect (Velvia filter)

The vivid filter simulates what is known as “Velvia” effect. It is different from saturation in that it has a more pronounced contrast effect that bring colors brilliantly alive and glowing. Try it, it renders beautiful for many subjects!

Velvia is a brand of daylight-balanced color reversal film produced by the Japanese company Fujifilm. The name is a contraction of “Velvet Media”, a reference to its smooth image structure. Velvia has very saturated colors under daylight, high contrast. These characteristics make it the slide film of choice for most nature photographers. Velvia’s highly saturated colors are, however, considered overdone by some photographers, especially those who don’t primarily shoot landscapes.

Example 3.25 Original versus Vivid filter
3.2.7.3.3 The Neon Effect

The neon filter simulates neon light along the contrast edges. The level parameter controls the lightness of the result, whereas the interaction slider determines the thickness of the neon light. With big images, the filter might eat the CPU time for a moment.

Example 3.26 The neon filter

3.2.7.3.4 The Edge Effect

TODO

3.2.7.3.5 The Lut3D Effect

TODO

3.2.7.4 Introduction

With this filter set, you can transform an ordinary photograph into a work of art suitable for framing using distorting operations. It uses algorithms copyrighted by Pieter Voloshyn.

3.2.7.4.1 Using the filter

These are the distorting effects available:

<table>
<thead>
<tr>
<th>Type</th>
<th>Preview</th>
</tr>
</thead>
</table>
**Fish Eyes**: warps the photograph around a 3D spherical shape to reproduce the common photograph ‘Fish Eyes’ effect.

**Twirl**: spins the photograph to produce a Twirl pattern.

**Cylinder Horizontal**: warps the photograph around a horizontal cylinder.

**Cylinder Vertical**: warps the photograph around a vertical cylinder.
<table>
<thead>
<tr>
<th>Effect</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Cylinder H/V</strong></td>
<td>warps the photograph around a 2 cylinders, vertical and horizontal.</td>
</tr>
<tr>
<td><strong>Caricature</strong></td>
<td>distorts photograph with ‘Fish Eyes’ effect inverted.</td>
</tr>
<tr>
<td><strong>Multiple Corners</strong></td>
<td>splits the photograph like a multiple corners pattern.</td>
</tr>
<tr>
<td><strong>Waves Horizontal</strong></td>
<td>distorts the photograph with horizontal waves.</td>
</tr>
<tr>
<td><strong>Waves Vertical:</strong></td>
<td>distorts the photograph with vertical waves.</td>
</tr>
<tr>
<td>--------------------</td>
<td>---------------------------------------------</td>
</tr>
<tr>
<td><strong>Block Waves 1:</strong></td>
<td>divides the image into cells and makes it look as if it is being viewed through glass blocks.</td>
</tr>
<tr>
<td><strong>Block Waves 2:</strong></td>
<td>like Block Waves 1 but with another version of glass blocks distortion.</td>
</tr>
<tr>
<td><strong>Circular Waves 1:</strong></td>
<td>distorts the photograph with circular waves.</td>
</tr>
</tbody>
</table>
Circular Waves 2: other variation of Circular Waves effect.

Polar Coordinates: converts the photograph from rectangular to polar coordinates.

Unpolar Coordinates: Polar Coordinate effect inverted.

Tiles: splits the photograph into square blocks and move them randomly inside the image.
WARNING
Some effects can take a long time to run and cause high CPU load. You can always abort an effect by pressing Abort button during preview rendering.

3.2.7.4.2 The Distortion filter in action

The Distortion FX dialog tool in action is available below.

3.2.7.5 Introduction

The digiKam Emboss filter is a quick tool to render your images in a 3-D effect. It works particularly well on images with simple structure where color is not the most important content. The filter uses the difference between colors and luminosity to convert it into a grey, moon-like landscape lit from 10 o’clock.

3.2.7.5.1 Using the Emboss filter

The Depth control allows to define the contrast of the filtering. A value of 30 (10%) is the standard.

3.2.7.5.2 The Emboss filter in action

This is an example of the emboss filter. The original image is (1) and the transformed image is (2). The Depth applied is 10%.
The digiKam Handbook

3.2.7.6  Introduction

The digiKam Filmgrain filter is an easy tool to produce film grain on your images as known from classical high speed film material as, for example, the famous B/W KodaK Tri-X. In order to increase film sensitivity, manufacturers employed larger silver grains in the photo emulsion.

The film grain effect gives your shot a particular mood or seems to transport it in time. The treated image acquires a timeless atmosphere, detached from everyday life. If you want that gritty, art-house, street-photography grainy film look, especially in monochromatic photos, use this filter.

3.2.7.6.1  Using the Filmgrain filter

There is a slider calibrated in ISO-sensitivity to control the grain intensity and granularity. The default is set to ISO-2400, although higher values are often required. If you still want more grain, apply the filter several times.

3.2.7.6.2  The filter in action

This is an example of the film grain effect applied on a black and white image. The original image is (1) and the corrected image is (2). The film sensitivity used for simulate the film graininess is ISO-1600.
3.2.7.7 Introduction

The digiKam Oil Paint filter gives your digital images a nice oilpainting-like look. Images of nature and still lifes are well suited for this effect.

3.2.7.7.1 Using the Oil Paint filter

There are two sliders to control the effect. The upper slider selects the Brush Size between 1 and 5. Bigger brushes are better suited for large images. Smooth controls the smoothness or, seen from the other end, the jaggedness.

3.2.7.7.2 The Oil Paint filter in action

This is an example of the oil paint filter effect. The original image is (1) and the transformed image is (2). Brush Size for this 640 pixel size image is 1, Smooth is 17.
3.2.7.8 Introduction

The Raindrops is nice little tool to put raindrops onto your images. Naturally, it renders your image in a kind of wet look. It uses an algorithm copyrighted by Pieter Voloshyn.

3.2.7.8.1 Using the Raindrops filter

Three sliders give you control over the effect filter:

- **Drop size** obviously allows to change the size of the drops. As the drop size doesn’t automatically scale with the image size it is often necessary to reduce the size for small images. **Number** changes the number and density of drops. **Fish eye** changes the optical effect of the drops across the image.
NOTE
You can keep a zone clear of raindrops with the digiKam Image Editor Select tool. Selecting the area to avoid (for example a face) before launching the Raindrops filter will keep it free from rain drops.

3.2.7.8.2 The Raindrops filter in action

This is an example of the raindrops filter. The original image (1) shows a quiet sunset, the transformed image (2) indicates a sunset after a thunderstorm. Default values have been used for this example.

3.3 RAW File Treatment and Color Management

3.3.1 Introduction

The point of a color-managed workflow is to ensure that the colors coming from your camera or scanner have a predictable relationship with the colors you actually photographed or scanned, that the colors displayed on your monitor match the colors coming from your camera or scanner, and that the colors you print or display on the web match the colors you produced in your digital darkroom.
3.3.1.1 Which buttons do I push?

When it comes to color management, everyone wants to know, "which buttons do I push to get the results I want". Unfortunately, color management of necessity involves making informed choices at every step along the image-processing workflow. The purpose of this tutorial is to provide sufficient background information on color management, along with links to more in-depth information, to enable you to begin to make your own informed decisions, based on your own desired results.

3.3.1.2 Is there anyone who doesn’t need to worry about color management?

If your imaging workflow meets all six criteria listed below, then you don’t need to worry about color management.

1. You are working at a monitor properly calibrated to the sRGB color space (more about that below).
2. Your imaging workflow starts with an in-camera-produced jpeg already in the sRGB color space.
3. You work exclusively in the sRGB color space for editing.
4. Your printer wants images in the sRGB color space.
5. Your scanner produces images in the sRGB color space.
6. Your only other image output is via email or the web, where sRGB is the de facto standard.

3.3.2 More definitions about Color Management

You’ve reached the end of this tutorial on color management. We’ve "color-managed" our way all the way from the camera and the monitor, to the working space, to the printer. I’ve learned a lot and I hope you have, too. What follow is some additional comments and definitions:
Assign a profile means change the meaning of the RGB numbers in an image by embedding a new profile without changing the actual RGB numbers associated with each pixel in the image. “Convert” to a profile means embed a new profile, but also change the RGB numbers at the same time so that the meaning of the RGB values - that is, the real-world visible color represented by the trio of RGB numbers associated with each pixel in an image - remains the same before and after the conversion from one space to another.

On the other hand, every time you assign a new working space profile rather than convert to a new working space (except when initially assigning a camera profile to the image file you get from your raw processing software), the appearance of the image should more or less drastically change (usually for the worse, unless the wrong profile had previously been inadvertently embedded in the image).

In theory, you should be able to do multiple conversions of an image from one working space to another, and if you are using a color-managed image editor, even though all the RGB numbers in the image will change with each conversion, the image displayed on your screen should look the same. In actual fact, because of rounding errors upon each conversion, not to mention gamut-clipping when going from a larger to a smaller working space, every time you convert from one space to another the image degrades a bit.

Device-dependent and device-independent profiles: The camera profile, a scanner profile, your monitor’s profile, and your printer’s color profile are all device-dependent profiles - these profiles only work with the specific device for which they were produced by means of profiling. Working space profiles and the PCS’s are “device-independent”. Once an image file has been translated by LCMS via a PCS to a device-independent working space, in a sense it no longer matters what device originally produced the image. But as soon as you want to display or print the image, then the device (monitor, printer) used matters a great deal and requires a device-dependent profile.

An interpolated raw file isn’t a raw file. For some reason this simple point causes a lot of confusion. But after a raw file has been interpolated by raw processing software and then output as a tiff or jpeg, the original raw file is still a raw file, of course, but the interpolated file is just an image file. It isn’t a raw file.

Linear has two related and easily confused definitions. “Linear” can mean that the image tonality reflects the tonality in the original scene as photographed instead of being altered by the application of an S-curve or other means of changing local and global tonality. It can also mean that the gamma transfer curve of the color space is linear. An image can be “linear” in either, both, or neither of these two senses. A raw image as developed by dcraw is linear in both senses. The same image as developed by Canon’s DPP won’t be linear in either sense.

HDR and LDR do not refer to the bit-depth of the image. “High dynamic range” and “low dynamic range” refer to the total dynamic range encompassed by an image. A regular low dynamic range image, say encompassing a mere 5 “stops” (the average digital camera these days can easily accommodate 8 or 9 stops), can be saved as an 8-, 16-, 32-, or even 64-bit image, depending on your software, but the dynamic range of the image isn’t thereby increased. Only the number of discrete steps from the brightest to the darkest tone in the image has changed. Conversely, a 22-stop scene (way beyond the capacity of a consumer-oriented digital camera without using multiple exposures) can be saved as an 8- or 16-bit image, but the resulting image will exhibit extreme banding (that is, it will display extreme banding in any given tonal range that can actually be displayed on a typical monitor at one time) because of the relatively few available discrete tonal steps from the lightest to the darkest tone in the image.

In-camera produced jpegs don’t need a camera profile. All jpegs (or tiffs, if you have an older Minolta Dimage camera) coming straight out of a camera (even if produced by point-and-shoots cameras that don’t allow you to save a raw file) start life inside the camera as a raw file produced by the camera’s A to D converter. If you save your images as jpegs, then the processor inside the camera interpolates the raw file, assigns a camera profile, translates the resulting RGB numbers to a working space (usually sRGB but sometimes you can choose AdobeRGB, depending on the camera), does the jpeg compression, and stores the jpeg file on your camera card. So jpegs (or tiffs) from your camera don’t need to be assigned a camera profile which is then translated to a working space via a PCS. Jpegs from a camera are already in a working space.
Useful mathematical information if you are dealing with dcraw’s linear gamma output: Mathematically speaking, when doing a gamma transform you normalize (that is, divide by 256 if you are working with 8-bit values) the RGB numbers and raise the resulting numbers to an appropriate power depending on the respective gammas of the starting and ending color space, then renormalize the results to a new set of RGB numbers. It’s not hard, and very instructive, to do this with a calculator for a few sets of RGB numbers spaced from (0,0,0) to (255,255,255) to see how RGB numbers change from one gamma encoding to another. LCMS does this for you when you ask LCMS to convert from one color space to another. However, if ALL you are doing is converting from one color space to the same color space except for a different gamma, use imagemagick instead of LCMS and just manipulate the RGB numbers directly, then assign the new working space to the image - the results will be more accurate than going through a color space transform.

Copyrighted and copyleft working spaces: I will take it as given that all the ordinarily encountered working spaces, such as:

1. The several variants of sRGB (see color.org).
2. BruceRGB or BestRGB.
3. The various ECI (European color initiative) working space profiles.
4. AdobeRGB, Adobe WideGamutRGB, and Kodak/Adobe ProPhotoRGB (Kodak and Adobe ProPhoto are the same, just branded differently) and their non-branded, non-copyrighted counterparts (Oyranos includes a non-branded version of AdobeRGB).

And quite a few other working spaces that could be added to this list, are all more or less suitable as working spaces. Which working space you should use depends only and solely on you, on your requirements as the editor of your digital images with your eventual output intentions (web, fine art print, etc.). However, as a critical aside, if you are using Adobe or other copyrighted working space profiles, these profiles contain copyright information that shows up in your image exif information. Lately I’ve been perusing the openicc mailing lists. Apparently LCMS can be used to produce nonbranded, copyleft working space profiles that are just the same as - actually indistinguishable from - the branded, copyrighted working space profiles. It would be a wonderful addition to digiKam if a set of “copyleft” working space profiles, including nonbranded, relabelled versions of ProPhotoRGB, AdobeRGB, and Adobe WidegamutRGB (perhaps in two flavors each: linear gamma and the usual gamma), could be bundled as part of the digiKam package.

3.3.3 The Color Space Connections

So the question for each RGB trio of values in the (let us assume) 16-bit tiff produced by dcraw becomes, “What does a particular trio of RGB values for the pixels making up images produced by this particular (make and model) camera really mean in terms of some absolute standard referencing some ideal observer”. This absolute standard referencing an ideal observer is more commonly called a Profile Connection Space. A camera profile is needed to accurately characterize or describe the response of a given camera’s pixels to light entering that camera, so that the RGB values in the output file produced by the raw converter can be translated first into an absolute Profile Connection Space (PCS) and then from the PCS to your chosen working space. As a very important aside, for most of the open source world (including digikam), the software used to translate from the camera profile to the PCS and from the PCS to your chosen working space and eventually to your chosen output space (for printing or perhaps monitor display) is based on lcms (the little color management engine). For what it’s worth, my own testing has shown that lcms does more accurate conversions than Adobe’s proprietary color conversion engine. Further, for almost all raw conversion programs, including commercial closed source software such as Adobe Photoshop, the raw conversion is typically based on decoding of the proprietary raw file done by dcraw. David Coffin, author of dcraw, is the hero of raw conversion - without him we’d all be stuck using the usually windows/mac only proprietary software that comes with our digital cameras. The dcraw’s interpolation algorithms (not to be confused with the aforementioned
decoding of the proprietary raw file), which are part of digiKam if properly used, produce results equal or superior to commercial, closed source software. We in the world of Linux® and open source software are not second-class citizens when it comes to digital imaging. Far from.

There are two commonly used Profile Connection Spaces - CIELAB and CIEXYZ (see Color management, section on color translation, then look up CIELAB and CIEXYZ on wikipedia). Lcms uses the camera profile to translate the RGB values from the interpolated raw file, that is, the tiff produced by dcrw, into the appropriate Profile Connection Space (usually CIEXYZ - why CIEXYZ? I haven’t taken the time to learn). A profile connection space is not itself a working space. Rather a PCS is an absolute reference space used only for translating from one color space to another - think of a PCS as a Universal Translator for all the color profiles that an image might encounter in the course of its journey from camera raw file to final output:

1. Lcms uses the camera profile, also called an input profile, to translate the interpolated dcrw-produced RGB numbers, which only have meaning relative to your (make and model of) camera, to a second set of RGB numbers that only have meaning in the Profile Connection Space.

2. Lcms translates the Profile Connection Space RGB numbers to the corresponding numbers in your chosen working space so you can edit your image. And again, these working space numbers ONLY have meaning relative to a given working space. The same red, visually speaking, is represented by different trios of RGB numbers in different working spaces; and if you assign the wrong profile the image will look wrong, slightly wrong or very wrong depending on the differences between the two profiles.

3. While you are editing your image in your chosen working space, then lcms should translate all the working space RGB numbers back to the PCS, and then over to the correct RGB numbers that enable your monitor (your display device) to give you the most accurate possible display representation of your image as it is being edited. This translation for display is done on the fly and you should never even notice it happening, unless it doesn’t happen correctly - then the displayed image will look wrong, perhaps a little wrong, perhaps really, really, really wrong.

4. When you are satisfied that your edited image is ready to share with the world, lcms translates the working space RGB numbers back into the PCS space and out again to a printer color space using a printer profile characterizing your printer/paper combination (if you plan on printing the image) or to sRGB (if you plan on displaying the image on the web or emailing it to friends or perhaps creating a slide-show to play on monitors other than your own).

To back up a little bit and look at the first color profile an image encounters, that is, the camera profile (see (1) immediately above) - dcrw can in fact apply your camera profile for you (dcrw uses lcms internally). But (i)the generating of the tiff composed of the interpolated RGB values derived from the camera raw file, and (ii)the application of the camera profile to the interpolated file, are two very distinct and totally separable (separable in theory and practice for dcrw; in theory only for most raw converters) steps. The dcrw command line output options “-o 0 [Raw color (unique to each camera)] -4 [16-bit linear] -T [tiff]” tell dcrw to output the RGB numbers from the raw interpolation into a tiff without applying a camera input profile (the words in brackets explain the options but should not be entered at the command line). Then, if you truly enjoy working from the command line, you can use the lcms utility tifficc to apply your camera profile yourself. The advantage of doing so is that you can tell lcms to use high quality conversion (dcrw seems to use the lcms default medium). The disadvantage, of course, is that applying your camera profile from the command line adds one extra step to your raw workflow.

3.3.3.1 Where to find camera profiles

So where do we get these elusive and oh-so-necessary camera-specific profiles that we need to translate our interpolated raw files to a working color space? The UFRAW website section on
color management has a bit of information on where to find ready-made camera profiles. It’s an unfortunate fact of digital imaging that the camera profiles supplied by Canon, Nikon, and the like don’t work as well with raw converters other than each camera manufacturer’s own proprietary raw converter. Which is why Bibble and Phase One (and Adobe, but ACR hides the Adobe-made profiles inside the program code), for example, have to make their own profiles for all the cameras that they support - keep this proprietary propensity of your camera manufacturer in mind next time you buy a digital camera.

But back to finding a camera profile for your camera - the real answer (assuming you don’t find a ready-made profile that makes you happy) is to make your own camera profile or have one made for you. There are quite a few commercial services who provide profiling services (for a fee, of course). Or you can use LPRof or Argyll to profile your camera yourself. I haven’t yet walked down that road so I cannot speak about how easy or difficult the process of profiling a camera might be. But I would imagine, knowing how very meticulous the people behind Argyll, LPRof, and lcms are about color management, that making your own camera profile is very do-able and very likely the results will be better than any proprietary profile. After all, Canon (and also Bibble and Phase One for that matter) didn’t profile MY camera - they just profiled a camera like mine.

Working Spaces:

So now your raw file has been interpolated by dcraw and you’ve obtained a camera profile and used lcms tifficc to apply your camera profile to the tiff produced by dcraw (or you’ve asked dcraw to apply it for you). What does all this mean? The real answer involves a lot of math and color science that goes way over my head and likely yours. The short, practical answer is that neither the camera profile space nor the Profile Connection Space is an appropriate space for image editing. Your next step is to choose a working space for image editing. And then you (or rather the lcms color management engine that your open source digital imaging software uses) actually perform a double translation. First lcms uses the camera profile to translate the RGB values of each pixel in the dcraw-output-image-without-camera-profile-applied into the aforementioned Profile Connection Space. Then it translates the RGB values of each pixel from the PCS to your chosen working space.

Confusions and confusing terminology:

Before talking more about working spaces, some confusions and confusing terminology needs to be cleared up:

First, sRGB is both a working color space and an output color space for images intended for the web and for monitor display (if you have a spiffy new monitor with a gamut larger than the gamut covered by sRGB, obviously you might want to reconsider what output profile to use to best take advantage of your wonderful and hopefully calibrated and profiled monitor, but please convert your image to sRGB before sending it on to your friends!). sRGB is also the color space that a lot of home and mass-production commercial printers expect image files to be in when sent to the printer. It is also the color space that most programs assume if an image does not have an embedded color profile telling the program what color space should be used to interpret (translate) the RGB numbers. So if you choose to not use color-management, your color-management choices are simple - set everything to sRGB.

Second, all jpegs (or tiffs, if you have an older Minolta Dimage camera) coming straight out of a camera (even if produced by point-and-shoots cameras that don’t allow you to save a raw file) start life inside the camera as a raw file produced by the camera’s A to D converter. The processor inside the camera interpolates the raw file, assigns a camera profile, translates the resulting RGB numbers to a working space (usually sRGB but sometimes you can choose AdobeRGB, depending on the camera), does the jpeg compression, and stores the jpeg file on your camera card. So jpegs (or tiffs) from your camera NEVER need to be assigned a camera or input profile which is then translated to a working space via a PCS. Jpegs from a camera are already in a working space.

Third, in case anyone is unsure on this point, note that an interpolated raw file is no longer a raw file - it has been interpolated and then output as a tiff whose RGB values need to be translated to a working space, using the camera profile, the PCS, and lcms. Fourth (strictly for future reference), to introduce a bit of commonly heard color-management terminology here - the camera profile and your printer’s color profile are both device dependent, whereas the working space will be
Fifth, above I have used the words translate and translation as a descriptive metaphor for what lcms does when it translates RGB values from one color space to another via the PCS. The usual and correct terminology is convert and conversion, which I will use below. The four methods of conversion from one color space to another are: perceptual, relative colorimetric, absolute colorimetric, and saturation. Which method of conversion you should use for any given image processing step from raw file to final output image is beyond the scope of this tutorial. The standard advice is: when in doubt, use perceptual.

Sixth (and again, strictly for future reference), assign a profile means change the meaning of the RGB numbers in an image by embedding a new profile without changing the actual RGB numbers associated with each pixel in the image; convert means embed a new profile, but also change the RGB numbers at the same time so that the meaning of the RGB values - that is, the real-world visible color represented by the trio of RGB numbers associated with each pixel in an image - remains the same before and after the conversion from one space to another. You should be able to do multiple conversions of an image from one working space to another, and with a properly color-managed image editor, even though all the RGB numbers in the image will change with each conversion, the image on your screen should look the same (leaving aside the usually unnoticeable small but inevitable changes from accumulated gamut mismatches and mathematical rounding errors). However, every time you assign a new working space profile rather than convert to a new working space, the appearance of the image should more or less drastically change (usually for the worse).

Finally, (and this is a crucially important point), color management is NOT only relevant if you shoot raw. Color management affects every stage of the image processing pipeline, whether you start with a raw file that you, yourself interpolate and translate into a tiff, or if you start with a jpeg or tiff produced by your camera.

Copyrighted and copyleft working spaces:
I will take it as given that ALL the ordinarily encountered working spaces, such as:

1. The several variants of sRGB (see color.org).
2. BruceRGB.
3. The various ECI (European color initiative) working space profiles.
4. AdobeRGB, Adobe WideGamutRGB, and Kodak/Adobe ProPhotoRGB (Kodak and Adobe ProPhoto are the same, just branded differently) and their non-branded, non-copyrighted counterparts (Oyranos includes a non-branded version of AdobeRGB).
5. And quite a few others that could be added to this list are all more or less suitable as working spaces. Which working space you should use depends only and solely on YOU, on YOUR requirements as the editor of YOUR digital images with YOUR eventual output intentions (web, fine art print, etc.).

However, as a critical aside, if you are using Adobe (or other copyrighted) working space profiles, these profiles contain copyright information that shows up in your image exif information. Lately I’ve been perusing the openicc mailing lists. Apparently lcms can be used to produce non-branded, copyleft working space profiles that are just the same as - actually indistinguishable from - the branded, copyrighted working space profiles. It would be a wonderful addition to digikam if a set of "copyleft" working space profiles, including nonbranded, relabelled versions of ProPhotoRGB, AdobeRGB, and Adobe WidegamutRGB (perhaps in two flavors each: linear gamma and the usual gamma), could be bundled as part of the digiKam package.

Which working space: gamma

Now, the next question is: which working space should I use? Wikipedia says:
Working spaces, such as sRGB or Adobe RGB, are color spaces that facilitate good results while editing. For instance, pixels with equal values of RGB should appear neutral. Using a large (gamut) working space will lead to posterization, while using a small working space will lead to clipping. This trade-off is a consideration for the critical image editor.

Well, that quote from wikipedia is about as clear as mud and I don’t know if I will be able to explain it more clearly, but I will try. “[P]ixels with equal values of RGB should appear neutral” just means that for any given pixel in an image that has been converted to a suitable working space, if R=G=B you should see grey or black or white on your screen.

I am not aware of a list of other technical requirements for a suitable working space, though undoubtedly someone has produced such a list. But most working space profiles are characterized by:

1. RGB primaries which dictate the range of colors, that is, the gamut covered by a given profile.
2. White point, usually D50 or D65, which dictates the total dynamic range of the working space, from 0,0,0 (total black) to the brightest possible white.
3. Gamma.

The practical consequences that result from using different RGB primaries, leading to larger or smaller working spaces, are discussed below. The practical consequences for different choices for the working space white point are beyond the scope of this tutorial. Here I will talk a little bit about the practical consequences of the working space gamma (for an excellent article and references, look up gamma on wikipedia).

The gamma of a color profile dictates what power transform needs to take place to properly convert from an image’s embedded color profile (perhaps your working color space) to another color profile with a different gamma, such as (i)the display profile used to display the image on the screen or (ii)perhaps to a new working space, or (iii)perhaps from your working space to your printer’s color space.

**Tip**

Mathematically speaking, for a power transform you normalize the RGB numbers and raise the resulting numbers to an appropriate power depending on the respective gammas of the starting and ending color space, then renormalize the results to a new set of RGB numbers. Lcms does this for you when you ask lcms to convert from one color space to another; however, if ALL you are doing is a power transform, use imagemagick instead of lcms and just manipulate the RGB numbers directly - the results will be more accurate.

One practical consequence of the gamma of a working space is that the higher the gamma, the more tones are available for editing in the shadows, with consequently fewer tones available in the highlights. So theoretically, if you are working on a very dark-toned (low key) image you might want a working space with a higher gamma. And if you are working on a high key image, say a picture taken in full noon sunlight of a wedding dress with snow as a backdrop, you might want to choose a working space with a lower gamma, so you have more available tonal gradations in the highlights. But in the real world of real image editing, almost everyone uses working spaces with either gamma 1.8 or 2.2.

Some people are trying to standardize on gamma 2.0. sRGB and LStar-RGB are not gamma-based working spaces. Rather, sRGB uses a hybrid gamma, and LStar-RGB uses a luminosity-based tonal response curve instead of a gamma value - see here for more information, and then google around for more in-depth information.

In addition to gamma 1.8 and gamma 2.2 the only other gamma for a working space that gets much mention or use is gamma 1.0, also called linear gamma. Linear gamma is used in HDR (high
dynamic range) imaging and also if one wants to avoid introducing gamma-induced errors into one’s regular low dynamic range editing. Gamma-induced errors is a topic outside the scope of this tutorial, but see Gamma errors in picture scaling, for gamma-induced color shifts.

Unfortunately and despite their undeniable mathematical advantages, linear gamma working spaces have so few tones in the shadows that (in my opinion) they are impossible to use for editing if one is working in 8-bits, and still problematic at 16-bits. When the day comes when we are all doing our editing on 32-bit files produced by our HDR cameras on our personal supercomputers, I predict that we will all be using working spaces with gamma 1; Adobe Lightroom is already using a linear gamma working space “under the hood” and Lightzone has always used a linear gamma working space.

Which working space: large gamut or small gamut

One major consideration in choosing a working space is that some working spaces are bigger than others, meaning they cover more of the visible spectrum (and perhaps even include some imaginary colors - mathematical constructs that don’t really exist). These bigger spaces offer the advantage of allowing you to keep all the colors captured by your camera and preserved by the lcms conversion from your camera profile to the really big profile connection space.

But keeping all the possible colors comes at a price. It seems that any given digital image (pictures of daffodils with saturated yellows being one common exception) likely only contains a small subset of all the possible visible colors that your camera is capable of capturing. This small subset is easily contained in one of the smaller working spaces. Using a very large working space mean that editing your image (applying curves, saturation, etc.) can easily produce colors that your eventual output device (printer, monitor) simply cannot display. So the conversion from your working space to your output device space (say your printer) will have to remap the out of gamut colors in your edited image, some of which might even be totally imaginary, to your printer color space with its much smaller gamut, leading to inaccurate colors at best and at worst to banding (posterization - gaps in what should be a smooth color transition, say, across an expanse of blue sky) and clipping (your carefully crafted muted transitions across delicate shades of red, for example, might get remapped to a solid block of dull red after conversion to your printer’s color space).

In other words, large gamut working spaces, improperly handled, can lead to lost information on output. Small gamut working spaces can clip information on input. Like Wikipedia says, it’s a trade-off. Here is some oft-repeated advice:

1. For images intended for the web, use (one of the) sRGB (variants - there are several).
2. For the most accuracy in your image editing (that is, making the most of your “bits” with the least risk of banding or clipping when you convert your image from your working space to an output space), use the smallest working space that includes all the colors in the scene that you photographed, plus a little extra room for those new colors you intentionally produce as you edit.
3. If you are working in 8-bits rather than 16-bits, choose a smaller space rather than a larger space.
4. For archival purposes, convert your raw file to a 16-bit tiff with a large gamut working space to avoid loosing color information. Then convert this archival tiff to your working space of choice (saving the converted working tiff under a new name, of course). See here for more details.

The whys of these bits of advice regarding which working space are beyond the scope of this tutorial. See Bruce Lindbloom’s excellent website (Info, Information about RGB Working Spaces) for a visual comparison of the gamut (array of included colors) of the various working color spaces. See here and here for a pro and con presentation, respectively, of the merits of using large gamut working spaces. And while you are on the cambridgeincolour.com website, check out the tutorial on color management.
3.3.3.2 Soft Proofing

Soft Proofing is a way of previewing on the screen (monitor) the result to be expected from an output on another device, typically a printer. Soft proofing will show you the difference to be expected before you actually do it (and waste your costly ink). So you can improve your settings without wasting time and money.

3.3.3.3 Rendering intention

Rendering intent refers to the way gamuts are handled when the intended target color space cannot handle the full gamut.

- **Perceptual**, also called Image or Maintain Full Gamut. This is generally recommended for photographic images. The color gamut is expanded or compressed when moving between color spaces to maintain consistent overall appearance. Low saturation colors are changed very little. More saturated colors within the gamuts of both spaces may be altered to differentiate them from saturated colors outside the smaller gamut space. Perceptual rendering applies the same gamut compression to all images, even when the image contains no significant out-of-gamut colors.

- **Relative Colorimetric**, also called Proof or Preserve Identical Color and White Point. Reproduces in-gamut colors exactly and clips out-of-gamut colors to the nearest reproducible hue.

- **Absolute Colorimetric**, also called Match or Preserve Identical Colors. Reproduces in-gamut colors exactly and clips out-of-gamut colors to the nearest reproducible hue, sacrificing saturation and possibly lightness. On tinted papers, whites may be darkened to keep the hue identical to the original. For example, cyan may be added to the white of a cream-colored paper, effectively darkening the image. Rarely of interest to photographers.

- **Saturation**, also called Graphic or Preserve Saturation. Maps the saturated primary colors in the source to saturated primary colors in the destination, neglecting differences in hue, saturation, or lightness. For block graphics; rarely of interest to photographers.

3.3.3.4 Links

- Color wiki
- CIELab
- Gamut explained

3.3.4 The Working Space

3.3.4.1 So I told digiKam where to find my monitor profile and I have a camera profile that I applied to the image file produced by my raw processing software. What’s the next step in color management?

You need to choose a working color space so you can edit your image. LCMS will transform your image from your camera color space to your chosen working space, via the PCS specified by your camera color profile.
3.3.4.2 Why cannot I just edit my images in the color space described by the camera profile?

After all, the camera profile should provide the best “fit” to the colors recorded by my camera, as processed by my raw processing procedure, right? Wikipedia says, “Working spaces, such as sRGB or Adobe RGB, are color spaces that facilitate good results while editing. For instance, pixels with equal values of RGB should appear neutral.” “[P]ixels with equal values of RGB should appear neutral” just means that for any given pixel in an image that has been converted to a suitable working space, if R=G=B you should see grey or black or white on your screen. Many camera profiles violate this “neutral” condition. I am not aware of a list of other technical requirements for a suitable working space. However, I can think of another good reason why you wouldn’t want to edit your image in your camera profile color space. If you look at the size of a typical camera profile, it is on the order of a quarter to a half a megabyte or more. It’s got a lot of information about all the changes that need to be made at different regions of color and tonality in the original scene, to get accurate color rendition from the RGB values that come out of the raw processor. The camera profile is accurate (at least for colors in the original target) but not particularly mathematically smooth. Working space color profiles, on the other hand, are very small in size (half a kilobyte instead of half a megabyte) because they describe a color gamut in terms of smooth, continuous mathematical functions. Working space profiles don’t need to make allowances for the “messiness” of real world sensors, so the mathematical manipulations performed during image editing will go much more smoothly and accurately than if you try to edit your image while it is still in the camera color space.

3.3.4.3 Which working space should I choose?

Everyone has an opinion. I’m just going to lay out some of the bits of information needed to make an informed choice. Working space profiles are characterized by:

1. Gamma (or other transfer function), which dictates how much the original linear intensity values captured by the camera sensor (and subjected to the in-camera A-to-D conversion, then interpolated by the raw processing program to produce the image file) are altered to make editing easier or more precise.

2. RGB primaries which dictate the range of colors, that is, the color gamut, covered by a given profile.

3. White point (usually D50 or D65 though other values may be used), which specifies the color temperature of the white point of the working space.

3.3.4.4 What gamma should my working space have?

The gamma of a color profile dictates what power transform needs to take place to properly convert from an image’s embedded color profile (perhaps your working color space or your camera color profile) to another color profile with a different gamma, such as your chosen working space, or the display profile used to display the image on the screen or perhaps from one working space to another, or perhaps from your working space to your printer’s color space. Dcraw outputs a 16-bit image with a linear gamma, which means that a histogram of the resulting image file shows the actual amount of light that each pixel on the camera sensor captured during the exposure (paraphrasing this page). (Which is why at present applying a camera profile to the dcraw output also requires applying an appropriate gamma transform to get to the desired working space, unless the camera profile also uses gamma=1.) One practical consequence of the gamma of a working space is that the higher the gamma, the more discrete tones are available for editing in the shadows, with consequently fewer tones available in the highlights. Changing the gamma of an image redistributes the number of tones available in the lighter and darker areas of an image. Theoretically, if you are working on a very dark-toned (low key) image you might want a working space with a higher gamma. And if you are working on a high key image, say a picture taken in full noon sunlight of a wedding dress...
with snow as a backdrop, you might want to choose a working space with a lower gamma, so you have more available tonal gradations in the highlights.

Theory aside, in the real world of real image editing, almost everyone uses working spaces with either a gamma of either 1.8 or 2.2. sRGB and L*-RGB are two notable exceptions.

sRGB uses a transfer function close to that of a CRT (and thus not necessarily relevant to image editing or to display on an LCD). As Wikipedia notes, “Unlike most other RGB color spaces the sRGB gamma can not be expressed as a single numerical value. The overall gamma is approximately 2.2, consisting of a linear (gamma 1.0) section near black, and a non-linear section elsewhere involving a 2.4 exponent and a gamma (slope of log output versus log input) changing from 1.0 through about 2.3” (cited from this page), which makes for some complicated math during image processing.

L*-RGB uses as its transfer function the same perceptually uniform transfer function as the CIELab color space. “When storing colors in limited precision values” using a perceptually uniform transfer function “can improve the reproduction of tones” (cited from this page).

In addition to gamma=1.8 and gamma=2.2, the only other gamma for a working space that gets much mention or use is linear gamma, or gamma=1.0. As noted above, dcrw outputs linear gamma files if you ask for 16-bit output. Linear gamma is used in HDR (high dynamic range) imaging and also if one wants to avoid introducing gamma-induced errors into one’s regular low dynamic range editing.

“Gamma-induced errors” is a topic outside the scope of this tutorial. But see “Gamma errors in picture scaling” (cited from this page) for gamma-induced tonality shifts; and of course see Timo Autioaki’s informative (albeit somewhat infamous) website for a whole-hearted endorsement of using linear gamma working spaces (Timo’s website seems to be down at present, though archived copies of his articles are still available through google). Bruce Lindbloom mentions a commonly-encountered gamma-induced error that is caused by incorrectly calculating luminance in a nonlinear RGB working space (see this page, sidenote 1). And in a similar vein, the calculations involved in mixing colors together to produce new colors (such as using a digital filter to add warmth to an image) result in gamma errors unless the new colors are calculated by first transforming all the relevant values back to their linear values.

Unfortunately and despite their undeniable mathematical advantages, linear gamma working spaces have so few tones in the shadows that (in my opinion) they are impossible to use for editing if one is working in 8-bits, and still problematic at 16-bits. When the day comes when we are all doing our editing on 32-bit files produced by our HDR cameras on our personal supercomputers, I predict that we will all be using working spaces with gamma=1. Adobe Lightroom is already using a linear gamma working space “under the hood”, CS2 allows the option of using linear gamma for mixing colors, and Lightzone has always used a linear gamma working space.

### 3.3.4.5 How many discrete tonal steps are there in a digital image?

In an 8-bit image, you have 256 tonal steps from solid black to solid white. In a 16-bit image theoretically you have 65536 steps. But remember, those 16-bits started out as either 10 bits (=1024 steps), 12 bits (=4096 steps), or 14 bits (=16384 steps) as produced by the camera’s A-to-D converter - the extra bits to reach 16-bits start out as just padding. The available tones are not distributed evenly from light to dark. In linear gamma mode (as the camera sensor sees things), there’s a whole lot more tones in the highlights than in the shadows. Hence the advice, if you shoot raw, to “expose to the right but don’t blow the highlights”. See Ron Bigelow’s articles on “why raw”, for a full discussion of the distribution of available tones in a raw image.

### 3.3.4.6 Should I use a large-gamut or a small-gamut working space?

One major consideration in choosing a working space is that some working spaces are bigger than others, meaning they cover more of the visible spectrum (and as a consequence include some imaginary colors - mathematical constructs that don’t really exist). These bigger spaces
offer the advantage of allowing you to keep all the colors captured by your camera and preserved by the LCMS conversion from your camera profile to the super-wide-gamut profile connection space and out again to your chosen working space.

But keeping all the possible colors comes at a price, as explained below. And it seems that any given digital image likely only contains a small subset of all the possible visible colors that your camera is capable of capturing. This small subset is easily contained in one of the smaller working spaces (an exception requiring a larger color gamut would be a picture of a highly saturated object such as yellow daffodil).

Using a very large working space means that editing your image (applying curves, increasing saturation, etc.) can easily produce colors that your eventual output device (printer, monitor) simply cannot reproduce (you cannot see these colors while you’re editing, either). So the conversion from your working space to your output device space (say your printer) will have to remap the out-of-gamut colors in your edited image, some of which might even be totally imaginary, to your printer color space with its much smaller color gamut. This remapping process will lead to inaccurate colors and loss of saturation at best. Even worse, the remapping can easily lead to banding (posterization - gaps in what should be a smooth color transition, say, across an expanse of blue sky) and clipping (e.g. your carefully crafted muted transitions across delicate shades of red, for example, might get remapped to a solid block of dull red after conversion to your printer’s color space). Also, the experts say that 8-bit images just don’t have enough tones to stretch across a wide gamut working space without banding and loss of saturation, even before conversion to an output space. So if you choose a large gamut working space, make sure you start with a 16-bit image.

To summarize, large gamut working spaces, improperly handled, can lead to lost information on output. Small gamut working spaces can clip information on input. Medium-sized gamut working spaces try to strike a happy medium. Like Wikipedia says, it’s a trade-off.

Here are some oft-repeated bits of advice on choosing a working space:

1. For images intended for the web, use (or at least convert the final image to) sRGB.

2. For the most accuracy in your image editing (that is, making the most of your limited “bits” with the least risk of banding or clipping when you convert your image from your working space to an output space), use the smallest working space that includes all the colors in the scene that you photographed, plus a little extra room for those new colors you intentionally produce as you edit.

3. If you are working in 8-bits rather than 16-bits, choose a smaller rather than a larger working space to avoid clipping and banding.

4. For archival purposes, convert your raw file to a 16-bit tiff with a large gamut working space to avoid loosing color information. Then convert this archival tiff to your medium-gamut or large-gamut working space of choice (saving the converted working tiff under a new name, of course).

For more information on choosing a working space, see this page, Information about RGB Working Spaces for a visual comparison of the gamut (array of included colors) of the various working color spaces. See here and here for a pro- and con- presentation, respectively, of the merits of using large gamut working spaces. And while you are on the cambridgeincolour.com website, check out the tutorial on color management.

### 3.3.5 The sRGB color space

#### 3.3.5.1 What is so special about the sRGB color space?

sRGB is widely accepted as a standard color profile by virtually everyone involved with consumer-oriented imaging. sRGB was proposed in 1996 by Hewlett Packard and Microsoft as a standardized color space for consumer-oriented applications. As stated in the initial HP/MS proposal:
Hewlett-Packard and Microsoft propose the addition of support for a standard color space, sRGB, within the Microsoft operating systems, HP products, the Internet, and all other interested vendors. The aim of this color space is to complement the current color management strategies by enabling a third method of handling color in the operating systems, device drivers and the Internet that utilizes a simple and robust device independent color definition. This will provide good quality and backward compatibility with minimum transmission and system overhead. Based on a calibrated colorimetric RGB color space well suited to Cathode Ray Tube (CRT) monitors, television, scanners, digital cameras, and printing systems, such a space can be supported with minimum cost to software and hardware vendors...

Currently, the ICC [International Color Consortium]... tracks and ensures that a color is correctly mapped from the input to the output color space... by attaching a profile for the input color space to the image in question. This is appropriate for high end users. However, there are a broad range of users that do not require this level of flexibility and control. Additionally, most existing file formats do not, and may never support color profile embedding, and finally, there are a broad range of uses [that] actually discourage people from appending any extra data to their files. A common standard RGB color space addresses these issues ... by merging the many standard and non-standard RGB monitor spaces into a single standard RGB color space. Such a standard could dramatically improve the color fidelity in the desktop environment. For example, if operating system vendors provide support for a standard RGB color space, the input and output device vendors that support this standard color space could easily and confidently communicate color without further color management overhead in the most common situations. (archived copy)

To summarize, the point of the by-now almost universally adopted sRGB color space was and is to make life easier for consumers (no need to worry about color management), less expensive for manufacturers (no need to worry about compatibility between consumer-level digital cameras or scanners, monitors, printers, and so forth), and more convenient for displaying images on the Internet (don’t worry about embedding and reading icc profiles - just assume sRGB).

So if sRGB works so well and makes life so easy for everyone, why use any other color space and thus be forced to worry about color management issues?

sRGB was designed to contain colors easily displayed on consumer-oriented monitors and printed by consumer-oriented printers manufactured in 1996. This least-common-denominator set of viewable and printable colors - the technical term is “color gamut” - is much smaller than the set of colors we can see in the real world, much smaller than the set of colors today’s digital cameras can capture, much smaller than the set of colors today’s printers can print, and much smaller than the color gamut of the new wide gamut monitors that are beginning to enter the consumer market. For anyone who wants to make use of the wider color gamut available today even at the consumer level, the gamut of sRGB is too small. Conversely, if you don’t intend to make use of an expanded gamut of colors at any point in your digital imaging workflow, then you don’t need to worry about non-sRGB color spaces and all the attending intricacies of color management.

3.3.5.2 How small is sRGB?

A visual representation of the limitations of sRGB compared to the colors we actually see in the real world is presented here after. It shows a two-dimensional representation of all the colors we can see (the horseshoe-shaped region) and the colors contained in the sRGB space (the smaller triangular region).
If you would like to see a two-dimensional representation of sRGB compared to some of the larger working color spaces, see Bruce Lindbloom’s excellent site, click on “Info” then on “Information About RGB Working Spaces”.

3.3.6 Calibrating and Profiling Your Monitor RGB

3.3.6.1 If I choose to work exclusively in the sRGB color space, do I need to calibrate my monitor?

Yes! Whether you stay within the color gamut provided by sRGB or not, you need a properly calibrated monitor because sRGB assumes that your monitor is calibrated to sRGB. Your monitor calibration closes the loop. If you work within the color gamut provided by sRGB then you need to calibrate your monitor to the sRGB standard (or produce and use an accurate monitor profile, or both).

3.3.6.2 What are the consequences of working with an uncalibrated monitor?

There are several possible consequences, none of them good. Every monitor, calibrated or otherwise, has a native (uncalibrated) white point, expressed as a temperature in degrees Kelvin. The white point of a monitor (calibrated or not) is the color you see when you are looking at a patch of pure white on your screen. Pure white is when the RGB values in your image all equal 255 (as expressed in 8-bits), such as the plain white background of a web page or an office document. You are thinking, “white is white” but if you were able to line up several monitors calibrated to different white points, you would see that the higher the temperature of the monitor’s white point, the bluer the screen looks in comparison with monitors with lower white points. If you can find the controls of your own monitor, change the temperature up and down (remembering to put it back to its initial setting when you are done, unless you decide you want a different white point). Your eyes, which adapt quickly to a constant white point, will easily discern the screen getting bluer and yellower as you move the white point higher and lower. If your uncalibrated monitor is too blue (native CRT color temperature is typically 9300K and sRGB assumes 6500K), as you edit your image you will overcompensate and produce images that will look yellowish and too warm on a properly calibrated monitor. Conversely, if your monitor is too yellow because the
The digiKam Handbook

color temperature is set too low (I believe LCD native color temperature is around 5500K), your images will look blueish/too cool on a properly calibrated monitor.

Setting a proper white point is only part of monitor calibration. You also need a proper black point, brightness (luminance), and gamma (transfer) function. If your monitor is too dark because the black point is set too low, you will overcompensate and produce images that look washed out on a properly calibrated monitor. Conversely, if your monitor black point is set too high, your images will look too dark and overly saturated on a properly calibrated monitor.

If the brightness/contrast is set too high, you will assume your images have a lot more "pop" than they really have when viewed on a properly calibrated monitor, plus your eyes will hurt and your LCD screen will burn out faster.

If your monitor gamma is improperly set, your tonal variations from dark to light will be off. That is, the shadows or highlights might be overly compressed or expanded, leading you to compensate in the opposite direction. So when viewed on a properly calibrated monitor, the shadows might be too bright or dark (or the highlights too dark or bright), with the rest of the image suffering from tonal over-compression. And heaven help you if the internal R, G, and B guns (or LCD equivalent) of your monitor are improperly set (each gun has its own black point and gain), because the resulting color casts - too green, too magenta, too orange, etc. - that you will inevitably create by "correcting" your image during editing - are very obvious when viewed on a properly calibrated monitor.

Whether or not your monitor is properly calibrated, you might be surprised by the results of comparing an image you've edited on your home monitor to the same image as displayed by other monitors in your house or on your friend's and neighbor's monitors. We certainly were - we have two Sony Trinitron monitors in our home, one with a failing (too high) green gun and one with a failing (too high) blue gun. Every image edited on either monitor looked very wrong on the other monitor, until we purchased a spectrophotometer to calibrate and profile both monitors. Unfortunately, at this point neither of these two monitors can be calibrated to display a proper black point, so they are no longer used for image editing - the point being that an additional benefit of using a spectrophotometer is you know when it's time replace your monitor.

3.3.6.3 The meaning of "black point" and "brightness" seems pretty clear, but what does "gamma" mean?

See this Wikipedia article for an overview of the role of gamma in monitors and photography; the links at the bottom of the article are all excellent sources of additional information. Wikipedia says "Gamma compression, also known as gamma encoding, is used to encode linear luminance or RGB values into video signals or digital video file values; gamma expansion is the inverse, or decoding, process ... Gamma encoding helps to map data (both analog and digital) into a more perceptually uniform domain." Yeah, I know, clear as mud. Read the Wikipedia article and study the pictures. Eventually it will sink in. If you wade very deeply into image editing and color management, eventually you will need to make decisions about what gamma (or other encoding/decoding function) you want to use when you calibrate your monitor, profile your digital camera, and choose a working color space. When in doubt (for those of you who just want to know which button to push!), gamma=2.2 is a widely-used value, both for monitor calibration and working color spaces.

3.3.6.4 What's the difference between calibrating a monitor and profiling a monitor?

When first learning about color management, many people are confused about the difference between calibrating and profiling a monitor (I know I was). Quoting from Hal Engel's excellent discussion in the digiKam users forum:

Calibration is a process where a device is brought into some defined state by making adjustments to its controls or some other physical means. For example, the act of calibrating a monitor involves adjusting its white point, black level, luminosity
and gamma to predetermined or standard values using the monitor’s controls and by altering the video card gamma ramp... In contrast to calibration, the process of creating a profile is a characterization of the device that does not involve making any changes or adjustments to the device. Rather it is a measurement process that results in a file that contains a precise mathematical description of the device’s color and tonality characteristics. This file is an ICC profile. These characteristics include the transfer function from the device’s color space to a standardized absolute color space (this is called a Profile Color Space, PCS, in an ICC profile), the device’s white point, black point, primaries and other information. Displays are normally characterized (profiled) in their calibrated state. To summarize, calibration makes changes to the device to alter it’s color reproduction characteristics to conform to some predetermined state. Profiling or characterization is a measurement process that results in a detailed description of the device’s (normally calibrated) color reproduction characteristics. (cited from here)

Calibrating your monitor technically is not really part of color management. But obviously a properly calibrated and/or profiled monitor is a prerequisite for a color-managed workflow. This tutorial does not cover the important topics of how to calibrate and profile a monitor. The Argyll-CMS and LProf documentations are very good and highly recommended reading. To use either of this software to calibrate and/or profile your monitor, you will need a spectrophotometer. A spectrophotometer (sometimes called a “spider”) is a device for measuring the RGB values of color patches projected onto the monitor screen by calibration/profiling software such as Argyll and LProf. The Argyll website maintains an up-to-date list of supported spectrophotometers. I believe LProf can use all the spectrophotometers that Argyll can use, as the two programs share the relevant sections of code.

3.3.6.5 Can I calibrate my monitor without a spectrophotometer?

There are various methods given on the Internet for calibrating a monitor without using a spectrophotometer. These “eye-ball” methods are better than not calibrating your monitor at all, and depending your eyeball and your monitor, can produce quite usable results. But the eye-ball methods are not a substitute for a properly calibrated and profiled monitor. For the record, calibrating and profiling a monitor with a spectrophotometer, though intimidating at first, is not difficult. Spectrophotometers can be obtained for well under $100 US (if you opt for a more expensive model, make sure you are paying for a better piece of hardware, rather than just a more fully-featured accompanying bit of manufacturer’s software that won’t run under Linux). Argyll and/or LProf documentation will guide you through the process of calibrating and profiling your monitor, without your having to learn very much color management theory. And if/when you learn enough about color management to realize that you want or need a more detailed monitor profile of a particular type, for a particular purpose, these two softwares have all the advanced capabilities you could possibly hope for.

3.3.6.6 Assuming I’ve decided to work exclusively in the sRGB color space, what “digiKam buttons” should I push after I calibrate my monitor?

If your monitor has been calibrated to the sRGB standard and you work exclusively in the sRGB color space, then you can disable color management in digikam. You don’t need to tell digiKam what monitor profile to use because digiKam defaults to using the sRGB color space as the monitor color space profile. And you don’t need to tell digiKam to use a color-managed workflow because digiKam defaults to using sRGB for your camera, printer, and working space, just as laid out by HP and MS back in 1996.

But if you want to take the first steps toward a color-managed workflow, then refer to corresponding page of Settings, enable color management, and select sRGB as your monitor profile, your camera profile, your working space profile, and your printer profile. If you’ve also used Argyll or LProf to produce a monitor profile after you calibrated your monitor - perhaps named
"mymonitorprofile.icc" - then tell digiKam to use "mymonitorprofile.icc" instead of sRGB as your monitor profile.

3.3.6.7 Where are all the icc profiles are located on my computer?

Well, this is Linux® and it depends on where you put them. I put all my icc profiles in the /usr/share/color/icc folder, which is the closest there is at this moment to a standard Linux location for icc profiles. If you use this folder for your icc profiles, likely you will need to change permissions on the folder to allow your user read/write access. Then you just tell digiKam where your profiles are located.

3.3.6.8 Does the lighting and wall/ceiling/drape/furniture colors near my monitor matter?

Yes! Good lighting is a prerequisite for proper image editing and for comparing prints to the image on your screen. If the lighting near your workstation is too bright, colors on your monitor look too dark, and conversely. If the light from the fixtures in your workroom have a low CRI (color rendering index, meaning you don’t have full spectrum bulbs), or if the light in your workroom comes from a window and so varies as the weather and time of day varies (or worse, is filtered through colored drapery), or if the walls and ceiling are creating color casts on your monitor, then your editing process will “correct” color casts that don’t really exist. Best advice, as far as is consistent with maintaining harmony in the family: neutral grey walls and ceiling, cover the windows, wear neutral clothing, set appropriate light levels using appropriate bulbs and fixtures. For more information on what are the appropriate light levels, bulbs and fixtures for editing images and viewing prints, see the following articles:

- http://www.creativepro.com/article/the-darkroom-makes-a-comeback

3.3.7 The Camera Profile and Raw File Development

3.3.7.1 What’s the next step in color management?

First and for the record, many excellent professional and amateur photographers save all their images as in-camera jpegs and work exclusively in the sRGB color space. But if you want to work in a larger color space, or if you want to work with raw files (even if you output sRGB image files from your raw files), read on.

Judging from questions asked in the digiKam user’s forum, if you are reading this tutorial you probably are shooting raw images with a digital dSLR and you are hoping that somewhere in the arcane waters of color management lies the answer to how to get a nice picture from your raw image file. And you’re right! The next thing you need is the right camera profile for developing your raw image. But first let’s answer the question you really might have been asking.

3.3.7.2 Why doesn’t the image produced by raw converters like dcraw or ufraw look like the embedded preview displayed by digikam?

Glad you asked. All digital camera images start out as raw files, whether or not the camera allows the user the option to save the image as a raw file. When you ask the camera to save jpegs instead of raw files, the camera uses its on-board processor to convert the raw file to a jpeg. That embedded preview is what your final image would have looked like if you had set your camera to save jpegs instead of raw files.
From here I will speak from my experience as a Canon user, but I will guess that most or all entry-level and mid-range dSLRs behave in a similar manner. Canon offers the user several picture styles - neutral, standard, portrait, landscape, and so forth - that determine what kind of processing will be done to the raw image file to produce the final image, whether or not the processing is done “in-camera” or later, using the proprietary Canon DPP software. The Canon DPP raw processing software does give the user additional control, but still manipulates the raw image file in accordance with the chosen picture style. Most of the Canon picture styles add a heavy S-curve and extra color saturation to give the picture more “pop”. Even if you choose the “neutral” picture style (the Canon picture style that gives you the least modified tonality), and select “less contrast”, “less saturation”, “no noise reduction”, and “no sharpening” in the DPP raw development dialog, you will find, if you know what to look for, that an S-curve and also shadow denoising has been applied to your image.

Libraw (which digiKam uses to convert raw files to image files) doesn’t add an S-curve to your image tonality. Libraw gives you the lights and darks that are actually recorded by the camera sensor. According to Tindeman, an excellent read and source of good advice, with links to equally good sources of additional information, dcraw is one of only a handful of raw developers that actually gives you the “scene-referred” tonality. Ufraw also produces a scene-referred image by default (although ufraw gives the user the option to modify the scene-referred image by changing the tonal distribution and saturation). And the dcraw/ufraw scene-referred image IS flat-looking, because the camera sensor records light linearly, whereas our eyes are constantly interacting with our brain to accommodate dim and bright areas in a scene, meaning our brain to some extent “applies an S-curve” to the scene to enable us to better focus in on the areas of particular interest as we look around.

3.3.7.3 The embedded jpeg preview looks so much nicer than dcraw’s output. What is the value in scene-referred tonality?

When you take a picture, presumably you have an idea of what you want the final image to look like. It is much easier to achieve that final image if you don’t have to “undo” stuff that has already been done to your image. Once Canon (or Nikon, or Bibble, etc.) has applied their proprietary S-curves and shadow-denoising, sharpening, etc. to your image, then your shadows, highlights, edge detail, etc. are already squashed, clipped, chopped, and otherwise altered and mangled. You’ve thrown information away and you cannot get it back. Especially in the shadows, even with 16-bit images (actually, 12- or 14-bits, depending on the camera, but it’s encoded as 16-bits for the computer’s convenience), there just isn’t that much information to begin with.

It seems to me that the heart and soul of image processing is the deliberate manipulation of image tonality, color, selective sharpening, and so forth, such that the viewer focuses in on what you, the photographer, found of particular interest when you took the picture. Why give the art of image processing over to some proprietary raw processing software? In other words, “flat is good” if you’d rather give your images your own artistic interpretation. The alternative is to let the canned, proprietary algorithms produced by Canon, Nikon, Bibble, etc. interpret your images for you. (On the other hand, there is no denying that for many images, those canned algorithms are really pretty good!)

3.3.7.4 I can see the value in starting my image-editing with a scene-referred rendition instead of the eye-popping rendition that I see in the embedded jpeg. But I’m telling you, the images produced by digiKam/libraw look really really bad! Why?

Well, that depends. If the image looks very dark, then you asked dcraw to output a 16-bit file and you have run into a problem with dcraw not applying a gamma transform before outputting the image file. You can use imagemagick to apply the appropriate gamma transform to the image file produced by Libraw. Or you can find or make a camera profile with a gamma of 1. Or you can use ufraw, which applies the gamma transform for you.

If your image has pink highlights, there’s a solution. For an explanation of the problem, along with the command line cure for this problem, see this “Luminous Landscape” forum post.
If the image isn’t dark but it looks really weird, probably you made some injudicious choices in the Libraw user-interface. The Libraw interface conveniently allows you to “dial in” options that you would otherwise have to specify at the command line. However, convenience always comes at a price. First, the interface might not provide access to all the options that are available at the command line. And second, to get the most from the Libraw interface, you have to know what the buttons, sliders, etc. in the interface actually do. Which means you need to know what happens at the command line if you want to get the best results from using the interface. (This tutorial will not attempt to document how to use the Libraw user interface. Digikam is developing at a rapid pace and anything I might write about the Libraw interface will surely be outdated in the near future.)

For example, if your embedded jpeg has very nice deep rich shadows but the Libraw-produced jpeg or tiff has blotchy red line patterns in the shadow areas, then you probably put an “x” in the “Advanced, Black point” option, with the slider set to 0. Uncheck the Black point box and try again. This box in the Libraw interface corresponds to the “-k” option when using dcraw at the command line. The “-k” option allows you to override dcraw’s best estimate of where, in the shadow tones of your image, does digital signal start to override background noise. If you don’t use the “-k” option at the command line, then dcraw calculates an appropriate value for you, based on its estimate of background noise. For my Canon 400di, the dcraw-calculated background noise value is usually around 256 (the command line option “-v” will tell dcraw to tell you what it’s doing as it processes your raw file). If, however, I use the “-K /path to blackframe.pgm” option to tell dcraw to subtract out a black frame, then dcraw will report the black point as “0”, as there is now no need to set it higher to avoid the deepest shadows in the image, where noise typically drowns out signal. (A “black frame” is an exposure taken with the lens cap on, with the same exposure settings as, and ideally right after, taking the image being processed. The “-K” option allows dcraw to subtract background noise from the image.)

3.3.7.5 Where do I find good information on digital noise?

See the following excellent articles:

- [http://www.cambridgeincolour.com/tutorials/noise.htm](http://www.cambridgeincolour.com/tutorials/noise.htm)

3.3.7.6 Why are the Canon and Nikon colors better than the colors produced by Libraw?

Color rendition is one place where the Canon (and presumably Nikon) proprietary raw developing software does a really, really good job. Why? Because the proprietary raw processing software is coupled with camera profiles that are specific to raw images coming from your make and model of camera, when processed using your make and model camera’s proprietary raw processing software. I’ve checked extensively, using an “eyedropper” to compare the output of various raw developers using various camera profiles from various sources - a very tedious though instructive process. With ufraw and dcrw (from the command line if not from digikam’s dcrw user interface), you can apply Canon’s camera-model-picture-style-specific color profile(s) to the dcrw output during the raw development process, and the colors will still NOT be exactly the same as what Canon produces. Likewise, Bibble profiles work pretty well with the Bibble software, but they don’t work quite as well, in my opinion, with Libraw as they do with Bibble’s own software. And so on. And so forth.

3.3.7.7 Why is a camera profile specific to a given make and model of camera?

Digital cameras have an array of millions of little light sensors inside, making up either a CCD or a CMOS chip. These light-sensing pixels are color-blind - they only record the amount, not
the color, of light falling on them. So to allow pixels to record color information, each pixel is capped by a transparent red, green, or blue lens, usually alternating in what is called a Bayer array (except for Faveon sensors, which work differently). A raw image is nothing more than an array of values indicating "how much light" passed through the red, blue, or green lens cap to reach the sensor.

Clearly, pixel response to light is the result of lots of camera-specific factors including: the nature of the sensor array itself, the precise coloring/transmissive qualities of the lens caps, and the particular analog-to-digital conversion and post-conversion processing that happens inside the camera to produce the raw image that gets stored on the card.

3.3.7.8 What does "analog-to-digital conversion" mean?

"Analog" means continuously varying, like how much water you can put in a glass. "Digitizing" an analog signal means that the continuously changing levels from the analog signal source are "rounded" to discrete quantities convenient to the binary numbers used by computers. The analog-to-digital conversion that takes place inside the camera is necessary because the light-sensing pixels are analog in nature - they collect a charge proportionate to the amount of light that reaches them. The accumulated charge on each pixel is then turned into a discrete, digital quantity by the camera's analog-to-digital converter. Which by the way explains why a 14-bit converter is better than a 12-bit converter - more precision in the conversion output means less information is thrown away in the conversion process.

3.3.7.9 Why is a camera profile specific to the raw processing program used to develop the raw file?

The whole point of interpolation using demosaicing algorithms such as dcraw’s default AHD is to guess what color and intensity of light actually fell on any given pixel by interpolating information gathered from that single pixel plus its neighboring pixels (see Wikipedia article). Every raw processing program makes additional assumptions such as “when is it signal and when is it background noise?”, “at what point has the sensor well reached full saturation?”, and so forth. The resulting output of all these algorithms and assumptions that raw processing software makes is a trio of RGB values for each pixel in the image. Given the same raw file, different raw processors will output different RGB values.

3.3.7.10 Where do I find a generic profile for my camera?

The ufraw website section on color management has information on where to find ready-made camera profiles. If you poke around the digiKam users forum archives, you’ll find additional advice. If you keep hunting and experimenting, likely you will find a generic profile that works “well enough”. However, as stated above, it’s an unfortunate fact of digital imaging that the camera profiles supplied by Canon, Nikon, and the like don’t work as well with raw converters other than each camera manufacturer’s own proprietary raw converter. Which is why Bibble and Phase One, for example, have to make their own profiles for all the cameras that they support. So eventually you may decide that you want a camera profile that is specific to your camera, your lighting conditions, and your raw processing workflow.
3.3.7.11 How do I get a camera profile specific to my camera, lighting conditions, and raw workflow?

Many commercial services provide profiling services, for a fee, of course. Or you can use LProf to profile your camera yourself. If you want to profile your own camera, you will need an “IT8 target”, that is, an image containing squares of known colors. Along with the IT8 target, you will receive the appropriate set of known values for each square of color on the target.

If you plan to use LProf to profile your camera, check the documentation for a list of recommended targets. To profile your camera, you photograph the IT8 target under specified lighting conditions (for example, in daylight, usually taken to mean noon on a sunny day in the summer, with nothing nearby that might cast shadows or reflect color casts) and save the image as a raw file. Then you process the raw file using your particular raw processing software+settings and run the resulting image file through the profiling software. The profiling software compares the RGB values in the image produced by your camera+lighting conditions+raw processing routine with the RGB values in the original target and then produces your camera (icc) profile.

Profiling a camera is exactly analogous to profiling a monitor. When profiling a monitor, the profiling software tells the graphics card to send squares of color with particular RGB values to the screen. The spectrophotometer measures the actual color that is produced on the screen. When profiling a camera, the known colors are the RGB colors in the original patches on the IT8 target, which the profiling software compares to the colors produced by the digital image of the target, which was photographed in selected lighting conditions, saved as raw, then processed with specific raw processing software plus settings.

Here is a link to a “how to” for using LProf v1.11 and ufraw (and by analogy, any other raw processor) to produce a camera profile. Debian Lenny has LProf 1.11.4 in the APT repositories. More recent versions can be built from CVS. And here is a link to an affordable, well-regarded IT8 target.

3.3.7.12 How do I apply a camera profile to the 16-bit image file produced by my open source raw processing software?

If you are using the Libraw interface, here is how to tell digiKam which camera profile to use. If you are using dcraw from the command line, you have the choice of outputting your 16-bit
image file with or without the camera profile already applied. If you ask dcraw to output the file without applying the camera profile, you can use LCMS’s tifficc utility (also at the command line) to apply the camera profile. The advantage of using tifficc is that you can tell LCMS to use high quality conversion (dcraw seems to use the LCMS default medium). The disadvantage, of course, is that applying your camera profile from the command line adds one extra step to your raw workflow. If you are using ufraw, consult the ufraw user’s guide.

3.3.8 The Profiles Point to Real Colors in the Real World

3.3.8.1 Camera, scanner, working space, monitor, printer - what do all these color profiles really do?

A color profile describes the color gamut of the device or space to which it belongs by specifying what real color in the real world corresponds to each trio of RGB values in the color space of the device (camera, monitor, printer) or working space.

The camera profile essentially says, “for every RGB trio of values associated with every pixel in the image file produced from the raw file by the raw processing software, “this RGB image file trio” corresponds to “that real color as seen by a real observer in the real world” (or rather, as displayed on the IT8 target if you produced your own camera profile, but it amounts to the same thing - the goal of profiling your camera is to make the picture of the target look like the target).

You cannot see an image by looking at its RGB values. Rather you see an image by displaying it on a monitor or by printing it. When you profile your monitor, you produce a monitor profile that says “this RGB trio of values that the graphics card sends to the screen” will produce on the screen “that real color as seen by a real observer in the real world”. What the monitor profile and the camera profile have in common is the part (in italics above) about “that real color as seen by a real observer in the real world.” Different trios of RGB numbers in, respectively, the monitor and camera color spaces point to the same real, visible color in the real world. Real colors in the real world provide the reference point for translating between all the color profiles your image will ever encounter on its way from camera to screen to editing program to print or the web.

3.3.8.2 How can a color profile point to a real color in the real world?

Real people don’t even see the same colors when they look at the world, do they?

A long time ago (1931, although refinements continue to be made), the International Color Consortium decided to map out and mathematically describe all the colors visible to real people in the real world. So they showed a whole bunch of people a whole bunch of colors and asked them to say when “this” color matched “that” color, where the two visually matching colors were in fact produced by differing combinations of wavelengths. What was the value of such a strange procedure? Human color perception depends on the fact that we have three types of cone receptors with peak sensitivity to light at wavelengths of approximately 430, 540, and 570 nm, but with considerable overlap in sensitivity between the different cone types. One consequence of how we see color is that many different combinations of differing wavelengths of light will look like “the same color”.

After extensive testing, the ICC produced the CIE-XYZ color space which mathematically describes and models all the colors visible to an ideal human observer (“ideal” in the sense of modeling the tested responses of lots of individual humans). This color space is NOT a color profile in the normal sense of the word. Rather it provides an absolute “Profile Connecting Space” (PCS) for translating color RGB values from one color space to another. (See here and here.)

CIE-XYZ is not the only PCS. Another commonly used PCS is CIE-Lab, which is mathematically derived from the CIE-XYZ space. CIE-Lab is intended to be “perceptually uniform”, meaning “a change of the same amount in a color value should produce a change of about the same visual importance” (cited from Wikipedia article). Wikipedia says “The three coordinates of CIELAB
represent the lightness of the color (L* = 0 yields black and L* = 100 indicates diffuse white; specular white may be higher), its position between red/magenta and green (a*, negative values indicate green while positive values indicate magenta) and its position between yellow and blue (b*, negative values indicate blue and positive values indicate yellow)" (cited from Wikipedia article).

To be useful, color profiles need to be coupled with software that performs the translation from one color space to another via the PCS. In the world of Linux® open source software (and also many closed source, commercial softwares), translation from one color space to another usually is done by LCMS, the "little color management software". For what it's worth, my own testing has shown that LCMS does more accurate color space conversions than Adobe’s proprietary color conversion engine.

### 3.3.9 Printer Profiles with Rendering Intents and Soft-Proofing

#### 3.3.9.1 Where do I get a printer profile?

Whew! We’ve come a long way - almost ready to print that image! Where do I get a printer profile? Well, you already know the answer. You can use the generic profile that comes with your printer. You can purchase a professionally produced profile. If you ask, some commercial printing establishments will send you their printer profiles (which won’t work with your printer!). You can make your own printer profile using Argyll, in which case your profile can be tailored to your particular paper, inks, and even image characteristics (if you are printing a series of images with a color palette limited to subdued browns, you don’t need a printer profile that tries to make room for saturated cyans and blues). I cannot offer any more advice or links to more information on this subject because I’ve just started to learn about printing images (previously I’ve only viewed and shared my images via monitor display). But do see this page for an excellent presentation of the benefits of producing your own printer profile, plus a resoundingly positive endorsement of using Argyll for making your printer profile.

#### 3.3.9.2 What about rendering intents?

“Rendering intent” refers to the way color gamuts are handled when the intended target color space (for example, the monitor or the printer) cannot handle the full gamut of the source color space (for example the working space).

There are four commonly-used rendering intents: perceptual, relative colorimetric, absolute colorimetric, and saturation. I have searched the Internet looking for the best write-up on rendering intents and the trade-offs involved in choosing one rendering intent over another. I believe I found that article. See this page. Briefly quoting from the Cambridge in Color article on color space conversion:

Perceptual and relative colorimetric rendering are probably the most useful conversion types for digital photography. Each places a different priority on how they render colors within the gamut mismatch region.

Relative colorimetric maintains a near exact relationship between in gamut colors, even if this clips out of gamut colors.

In contrast, perceptual rendering tries to also preserve some relationship between out of gamut colors, even if this results in inaccuracies for in gamut colors...

Absolute is similar to relative colorimetric in that it preserves in gamut colors and clips those out of gamut, but they differ in how each handles the white point... Relative colorimetric skews the colors within gamut so that the white point of one space aligns with that of the other, while absolute colorimetric preserves colors exactly (without regard to changing white point)...

Saturation rendering intent tries to preserve saturated colors.
I would quote the entire article (it’s that good), but that would involve “unfair usage” I am sure. So go check out the article for yourself. The illustrations in the article really help to clarify what the different rendering intents actually do and the compromises involved in choosing one rendering intent over another.

For another excellent source of information on rendering intents with accompanying illustrations, see this page.

3.3.9.3 What rendering intent should I use for displaying images on my monitor?

The usual choice is relative colorimetric. I would suggest that you not use absolute colorimetric (e.g. with ufraw) unless you want very strange results.

3.3.9.4 What is soft-proofing?

Soft-proofing will show you the differences to be expected between what you see on your screen and what you will see when you make a print. To soft-proof, you need a profile for your printer (actually, for your printer-paper combination, as the paper used affects the ink colors and the white point). If you don’t like the soft-proofed image, you can make changes (in your working space, not after converting the image to your printer space!) to bring the soft-proofed image more in line with how you want the final print to look.

3.3.9.5 What rendering intent should I use when I soft-proof?

I’ve always heard that you ought to use “perceptual intent” when transforming an image from a larger working space to a smaller printer space. But especially in light of reading the afore-mentioned Cambridge in Color article, it seems that perceptual intent may or may not give the best results, depending on the respective gamuts of the image and printer/paper combination in question. I’ve been experimenting quite a bit lately with output intents for printing. I find that for my images, the colorimetric intents give clearer, brighter colors, albeit at the cost of having to carefully re-edit the image to avoid clipping highlights and shadows. Perusal of the various photography forums and articles available on the Internet indicates that “perceptual intent” is just an option, not by any means always “the best” option.

3.3.9.6 And what about black point compensation?

The clearest definition I could find about black point compensation is as follows: “BPC is a way to make adjustments between the maximum black levels of digital files and the black capabilities of various digital devices [such as a printer]” (cited from this page).

The article from which this definition comes offers a very clear explanation (albeit Adobe-centric) of how black point compensation works and the practical consequences of using or not using it. The bottom line advice is, it depends. Try soft-proofing with black point compensation on. If you like it, use it. Otherwise, don’t use it.

3.3.9.7 Can all of the rendering intents be used when converting from one color space to another?

In a word, no. Which rendering intents are available when converting from one profile to another depends on the destination profile. Not every profile supports every rendering intent. What happens when you select an unsupported rendering intent is that LCMS quietly uses the profile’s default rendering intent.

For an informative and humorous discussion of myths surrounding the use of various rendering intents, see here and here.
3.3.9.8 Why does the perceptual rendering intent get recommended so often as the "photographic" rendering intent?

It’s a safe choice because it prevents clipping of shadows and highlights, although possibly at the expense of desaturating all your colors. So if you don’t want to bother doing any soft-proofing, choose the perceptual rendering intent (if you don’t want to soft-proof, probably you should also stick with sRGB).
Chapter 4

Acquire Images Tool

The Acquire Images tool is dedicated to scan images using a flat scanner.

This tool can be used to scan images using a flat scanner. The tool uses libksane, an interface for SANE library to control flat scanners.

It can save images in all main image containers, as for example the following formats:

- png (8 and 16 bits per color)
- jpeg, jpg, jpeg 2000
- tiff

NOTE
You can check the status of your scanner support from the SANE project website by entering the information on this search page: http://www.sane-project.org/cgi-bin/driver.pl.

4.1 Scanner Selection

If the selected scanner cannot be opened or if no default scanner is provided, a scanner selection dialog is opened.

The user can choose the scanner to be used and press OK to open the scanner. Pressing Cancel will cause the tool to exit.
In case no devices were found, maybe because the scanner is not plugged in or switched off, correct that. Then the **Reload device list** can be used to reload the list of scanners.

**NOTE**
Not all drivers/backends support this feature. In that case quit the tool, connect your scanner and restart the application.

### 4.2 Main Dialog

**Main dialog**

In the main window, the user has two sets of scan options: **Basic Options** and **Scanner Specific Options**. The **Basic Options** tab contains the most common parameters that the SANE scanner backends provide, while the **Scanner Specific Options** tab contains all the options of the backend. The options listed here depend on SANE support for your driver: libksane (which the tool uses) should be able to display most of the types of parameters that SANE provides (analog gamma tables are not supported at this time).
The scanner specific options contains more detailed options of the backends. The tool does not have any special handling for these options.

If you are satisfied with your settings, you can use the little arrow on the top of the options splitter. When clicked it collapses or expands the options. The collapser can overlap the preview area, but fades away when the mouse cursor moves out of the collapser.

4.3 Scanning

To scan an image, the user can start with a preview scan and then select the part of the scan area to do the final scan on. The preview scan is started by pressing the preview button.

When the preview is scanned the area for the final image can be selected.
To better select the image the user can zoom in, out, to the current selection or zoom to fit the whole preview to the window.

When the image is selected the final image can be acquired by pressing the final scan button.

You will see the progress of the scan.
4.4 Scanning Multiple Selections

Sometimes you need only certain parts of an image. Instead of scanning the whole picture and then using a graphics application (e.g. KolourPaint) to save the different image parts into separate files, use the tool multiple selection feature.

Scan a preview and then use the left mouse button to select the first part of the image in the preview. Hover the selected area with mouse cursor and click on the green + icon to select the area. Selected areas are indicated by a red border. Now select the next parts of the image in the same way.

To remove a single selection hover the area with the mouse cursor and click on the red - icon. With Clear Selections from the context menu launched with the right mouse button all selections in a preview can be removed.

If you placed two separate images or photos on you scanner and started a preview the tool automatically preselect the different areas.

If you are satisfied with your choice starting the final batch scan of all selections. The selected parts of the image are scanned and saved separately into different files.

4.5 Help and Close

At the bottom of the main window you find the Help and Close buttons.

The Help button brings up the menu described in the section Help Menu. The Close button is used to exit the tool.
Chapter 5

Geolocation

Geolocation means assigning, editing and using metadata which describe the geographic place where images or videos were taken. The source of these metadata can be your camera, a separate GPS receiver or other means of geographical information, in particular maps.

Not only for professional photographers can it be interesting to link an image to a precise geographical location. Not everybody uses an airplane to overfly and scan a certain area with automatic GPS data recording. Environmental planners, military, police, construction bureaus, real estate agencies, all will have an immediate application.

But if, after some time, one has forgotten where the image was taken, if one loves the nice feature to open with a simple click a browser displaying a zoom of the area, if you like to send your image as a postcard to another digiKam user (who is then able to locate your shot), or if you simply need the documentation aspect of it - having position data stored in a photo is great.

GPS (global positioning system) is used as a generic term throughout this document. It just means a location in the common spherical coordinate system that can be displayed on a map. The actual technical implementation that provides the data can be the American GPS, the Russian GLONAS, the European GALILEO or any other system.

There are four tools regarding geolocation in digiKam and two in Showfoto:

1. The Map mode of the Image Area which displays images with GPS data on a map depending on the selection on the Left Sidebar, e.g. the images in the album you selected in the Album View, the images with a certain tag assigned (selected in the Tag View), with a certain label and so on. This is only available in digiKam.

2. The Map View on the Left Sidebar of digiKam which is the search tool for finding images by their GPS data. This is also only available in digiKam.

3. The Geolocation Editor we describe a little bit further below and which is accessible via Item → Edit Geolocation... (Ctrl+Shift+G) (File → Edit Geolocation... in Showfoto).

4. The Map tab on the Right Sidebar which shows the location of the image on a map and is purely informative.

All four are based on the Marble widget.

NOTE
These tools only work for image formats that have EXIF or XMP metadata supported by Exiv2 library.
5.1 Geolocation Editor

The Geolocation Editor allows for adding and editing GPS coordinates of picture metadata. The geo-data is stored into the image (EXIF tags) and the location can be displayed in an internal or external browser map. The Geolocation Editor also offers a Reverse Geocoding tool.

Geolocation Editor can be opened via menu entry Item → Edit Geolocation or via pressing Ctrl+Shift+G. It requires at least one image to be selected otherwise it will not open.

The Geolocation Editor provides the tools to localize pictures geographically in the common spherical coordinate system (used by GPS/Galileo). Altitude, latitude and longitude, speed, number of satellites, fix type and DOP are editable.

The editor has two methods to mark the pictures with coordinates:

• Semi-automatic coordinate attribution to single pictures, accessible via the Details tab on the Right Sidebar.

• Batch correlation of GPS tracking data with a series of images you will find in the GPS Correlator tab.

Furthermore the Right Sidebar offers three more tools:

• The Undo/Redo tab.

• The Reverse Geocoding tab which allows to find geographic names (cities, street names, ...) by using a public reverse geocoding service and the GPS data of an image.

• The Search tab which allows to find positions on the map from geographic names (cities, monuments, ...) by using a public geoname service (GeoNames and OpenStreetMap at the time of writing).
5.1.1 The map

For navigating on the map refer to Marble handbook, Chapter 2. Also for the sky context menu see Marble documentation.

Right under the map you find a row of buttons. I shall use the tooltip texts as designations in the following description. From left to right we have

- The Map-settings button opens a small menu which allows you to choose between Google Maps and Marble and depending on that choice to choose the kind of map you want to use. Furthermore you can select the projection for Marble (spherical, Mercator, equirectangular) and you can display a few additional tools like compass and scale on the map.
- The Zoom-in button.
- The Zoom-out button.
- The Switch-between-markers-and-thumbnails button lets you choose whether you want the positions of your images indicated by a marker symbol or by a thumbnail on the map. If you choose thumbnails the next two buttons are of particular interest.
- The Increase-the-thumbnail-size-on-the-map button is doing just that and ...
- ... the Decrease-the-thumbnail-size-on-the-map button as well.
- The Pan-mode button lets you move the map by click with the left mouse button and holding on it and then drag it with the mouse to where you need it. The cursor symbol will change to a hand.
- The Zoom-into-a-group button is useful if you have images so close to each other on the map that all but the topmost are obscured. Once you click on the visible image the zoom factor will be adjusted so that all the other images behind it become visible. If you click on a group of images and nothing really happens they either have exactly the same geographic position and/or the zoom factor is already at its maximum.

Note that ‘group’ in this context here has nothing to do with grouped images as described in chapter 2 of the digiKam Handbook. Here the term refers to images which are very close to each other on the map (depending on the zoom factor) or have exactly the same geographic position.

- The Select-images button toggles the selection of an image or a group of images in the list of images right below the buttons once you click on it on the map. The selection status of all other images in the list remain unchanged. Be aware of the fact that there is a kind of two-stage selection! If you click on a thumbnail or marker on the map the selected image(s) in the list of images will become a light blue background. If you click on it in the list the background will become a darker blue and if there where more than one image with light blue background before the others will become un-selected. Only clicking on an image in the list will let its preview appear to the right of the list.
- The Display-bookmarked-positions-on-the-map button is not working at the time of writing because the whole bookmark issue needs to be reorganized. This also affects the Bookmarks → Edit Bookmarks... item in the context menu on the list of images below the map and the Add Bookmark item in the context menu on the map.

**WARNING**
The use of Add Bookmark in the context menu on the map can lead to loss of your bookmarks in Marble!

From the context menu on the map only Copy Coordinates is of interest for geotagging. It copies the geographic coordinates at the cursor position to the clipboard. For all other menu items see Marble handbook.

Note that you can change the layout from one map to two maps, beside or above each other via the little drop-down menu at the bottom of the Geolocation Editor.
5.1.2 Edit Coordinates

The coordinates can be set manually in the Details tab (see screenshot above). The location can be found and fixed iteratively with the displayed map. Move the mouse cursor to the region of interest, zoom in, adjust location, zoom in again, and so on until sufficient accuracy is achieved. Note that the zoom center will always be at the cursor position. Eventually you click with the right mouse button at the desired position and choose Copy Coordinates. Now you can go to the list of images below the map, select one or more images, click with the right mouse button on them and choose Paste Coordinates. The coordinates will then be displayed in the Latitude and Longitude fields to the right of the map. To save your changes you click the Apply button right under the DOP field.

If you have one or more images that already have GPS data you can copy the coordinates from one of those and paste them to one or more other images by using the respective items from the context menu on the list of images. This comes in handy if there is a series of photos taken at the same location.

To the right of the map there are, beside latitude and longitude, fields for altitude, speed, number of satellites, fix type and uncertainty (DOP). You may see these fields already filled in if you select a photograph where your camera wrote these information into the EXIF data. Otherwise you can fill them in manually if you have these data from somewhere else, e.g. a separate GPS receiver.

Note that you have to check the relevant checkbox before you can edit a field (under Windows® you may have to double-click it). Only for Altitude the context menu on the list of images offers Look up missing altitude values which causes the editor to look up these data in the map data provided the position (latitude and longitude) is already assigned to the photograph.

To delete geolocation data you got to un-check the relevant checkbox and click the Apply button right under the DOP field. Other than that the context menu on the list of images offer items to remove some of the data from the image. Regarding the last item Bookmarks see here.

5.1.3 The Correlator

In order to correlate your images with geographic data you need to have a GPS tracking information available as a XML file in gpx format (gpsbabel and gpsman can download and convert tracking data from a GPS device for you). The idea is: while taking your pictures just keep a GPS device running and carry it around with the camera. Once you are done, download the pictures and the GPS tracks, and run the correlator.
Select the images you want to correlate in the application main view, then call the geolocation editor with (Ctrl+Shift+G) and switch to the GPS Correlator tab on the Right Sidebar. The above dialog will show up with the selected images in the list below the map. To indicate possible time/location correlation you have to load a track file with Load GPX File that contains GPS data taken at the same time and location as the pictures.

When the file is loaded and Show tracks on map is checked the track is displayed on the map. You can load more than one file and digiKam will assign different colors to them and display the tracks on the map accordingly.

GPS track data is invariably recorded in UTC (Universal Time Coordinated), so you need to match the camera time with UTC, which can be done with Camera time zone. Select Same as system if you took the photographs in your home time zone and digiKam will figure out the difference to UTC from your system time. If you took the photographs somewhere else you got to check Manual: and choose the appropriate difference from the drop-down field to the right. You can use the same mechanism as well to correct a simple mis-adjustment of your camera time for whatever reasons or an offset of a gpix-file due to quirks of a software used to convert other track file formats into gpix. Here comes Fine offset (m:ss) into play where you can add or subtract up to 59 minutes and 59 seconds to your time difference chosen in the field above.

The Max. time gap (sec.): setting specifies the limit within which GPS time and camera time shall be deemed coincident. The maximum value is 2000 seconds. This means that if no entry in the gpix-file matches the time stamp of the photograph exactly, the position of the entry with the smallest time gap to the photograph will become assigned to it as long as this time gap is smaller than the Max. time gap (sec.): setting. If you wonder which value you should specify here a look into the settings of your track recording device/software or into the gpix-file (which is easily possible with a text editor) might help. The faster you were moving while taking the photograph(s) the more important this decision will be.

Interpolate offers another option in case there is no exact match between the time stamp of your photograph(s) and an entry in the gpix-file and as long as you were moving more or less straight between two recorded GPS positions it will be the more precise option. Here the position of the photograph is calculated (linear interpolated) from the positions of the two closest entries in the gpix-file and the respective differences in time. If, for instance, the time gaps between the two closest entries and the photograph are equal the position assigned will be on a straight line between the positions of the two entries right in the middle.
Max. interpol. time gap (min): has nothing to do with policeman Max from Interpol ;-) Instead it determines whether a GPS point is eligible for interpolation. If its time is farther away from the picture time than this limit, it cannot be used. 240 minutes is the maximum time difference that can be introduced here.

Once your settings are done you click on the Correlate button. If there is no match at all you will get the message “Could not correlate any image - please make sure the timezone and gap settings are correct.” Otherwise you will get something like “2 out of 4 images have been correlated. Please check the timezone and gap settings if you think that more images should have been correlated.” Best case you get “All images have been correlated. You can now check their position on the map.”

If you want to follow this recommendation it is a good idea to change to the Details tab since there you have a preview of the images which can help a lot to identify them on the map. Once you are satisfied with the results click the Apply button at the bottom of the Geolocation Editor to save the changes to the image file and the database.

5.1.4 Undo/Redo

In the Undo/Redo tab a history is being recorded about all the changes you apply to the images loaded into the Geolocation Editor. The history shows changes made in only one tab or in several tabs and will be deleted only once you leave the editor. After a few actions in the different tabs the record might look like this:

The last step is highlighted when you enter the tab. The first step is always labeled ‘empty’ and represents the status the images had when they were loaded. You can click on every step and, depending on what kind of changes you did, you might see the images appearing, disappearing or moving on the map or see the differences in the list of images under the map. Note that the list is configurable by clicking with the right mouse button on the header.

Now let’s assume that you realize that the move in the last step was wrong. You just click on the step before (Details changed), you go to the Search tab (described further below) and you do another move. After returning to the Undo/Redo tab it might look like this:
5.1.5 Reverse Geocoding

In this tab you can use a public geoname service to look up address details of the geographic position of one or more images and convert them into tags. In order to do that you need a few preparations. You should be already familiar with the idea of tags and how to create, edit and use them. The best entry into this issue you find in the Tags View section of Chapter 2 of the digiKam handbook.

First you should create a root tag in the Tag Manager or in the tag tree of the Left or Right Sidebar. You might name it Location or Places or ...

Then you select the image(s) you want to tag (they need to have GPS data assigned), open the Geolocation Editor and click the **Reverse Geocoding** tab. You will see your tag tree and if you click with the right mouse button over a tag, preferable the one you created for the geo tags, you will see this context menu:
In the main section the tags you can add are sorted from the largest region (country) down to the smallest (house number). If you choose *Add all address elements* and then fold out the Location tag and all the sub-tags you will have this:

These red tags in curly brackets are called control tags. They determine which address elements you want the reverse geolocation service you have chosen at the top under **Select service** to look for. You can still delete some of them with the help of the context menu if you feel that you don’t need them or modify the structure by deleting some control tags and add them in other places of the tree or even build a new tree parallel to the first by adding a control tag to the root tag (here: Location). Arranging the control tags on the same level instead of a tree structure can save a lot of redundant tags since the same city or town name exists in more than one state or country let
alone street names. But it can make the whole location branch of your tag tree quite long and therefore incalculable. This is to say that you have to find your own solution to this problem depending on your needs, maybe a mix, and the sooner you find it the less work you have to invest in editing your tag tree and the control tags.

Let us assume you use the control tags as shown in the above screenshot, select the images you want to tag from the list of images to the left and click **Apply reverse geocoding**. Then the tag tree might look similar to this:

![Tag tree with location tags](image)

The green tags represent the search result of the selected public reverse geocoding service and are already assigned to the image(s). To save these tags to the image file and the digiKam database click **Apply**. The tags will appear as regular tags in your tag tree which you can see already here or in the tag tree of the Left or Right Sidebar. Of course you can still edit them like any other tag in the Tag Manager or in the Left or Right Sidebar, but not here in the Geolocation Editor.

### 5.1.6 Search

In the **Search** tab you can look up places by their geographic names using public geoname services (GeoNames and OpenStreetMap at the time of writing). You just type in a name of a place (city, monument, hotel, ...) into the input field at the top and click **Search**. In the result list below you will get something like this:
Obviously Paris does not only exist in France. So if you were looking for the capital of France you can either scroll down the list until you find an entry that undoubtedly belongs to there like "Arc de Triomphe" and click on it or specify your search a little bit more precise like "Paris, Arc de Triomphe" or "Paris, France". Once you click on an entry in the list the map will become centered to that place and you can now zoom in with the zoom-in button (second from the left below the map). Using this example with GeoNames you will notice that you still get a lot of results and even two labeled only "Arc de Triomphe", the second one a street a few hundred meters away from the arch. With OSM you get only one result. You got to play a bit with the different services in different regions, with more or less precise search terms and then you will get an idea about how to best conduct your searches.

For the buttons right above the result list refer to their tooltips! The context menu on search result entries offers

- **Copy coordinates** which you can paste later to one or more images in the image list under the map

- **Move selected images to this position** which is basically the same but more straightforward provided you have the images already loaded into the geolocation editor

- **Remove from results list** which is particular useful in conjunction with the Keep-the-results-of-old-searches-... button above the results list.
Chapter 6

Presentation Tool

The ‘Presentation’ tool creates a configurable full screen slide-show of your images using advanced visual effects.

With this tool you can create a perfect slide show with just three mouse clicks.

6.1 The Settings Dialog

When opening the tool, the Presentation window will appear asking questions as to how you want to stage your slide show. You can choose between the selected images or all images in the same album.

The Use OpenGL Slideshow Transitions checkbox enables very smooth image transitions using the OpenGL display mode. Be sure you have OpenGL enabled on your graphics card, since otherwise the slideshow will be very slow.

The Print Filename checkbox enables displaying the image filename in the lower left corner.

The Loop checkbox will enable running the whole show in an endless loop (until manually stopped with Esc).

The Shuffle Image checkbox will enable displaying the images randomly (not using the current images collection order).

The Delay Between Images may be set in millisecond steps. 1500 milliseconds correspond to 1.5 seconds and is a good default value. The best timing depends also a bit on your computer power and the transition effect. Try it out before you show it to your friends!

There are more than a dozen Transition Effects available to choose from. The Random selection will change the transition effect with every image.
6.2 Presentation Tool in Action

During the slide show, you can access a toolbar on the upper left screen corner. Move the mouse cursor to the top left of the screen to access it.

With this toolbar, you can drive the progress of the slide show. You can pause or play the slide show, go back to the preview image, go to the next image, and stop the slide show.

In the lower left screen corner you can see the current image file name, the current image ID, and the total number of images included in the slide show.
Figure 6.2: The Presentation Tool in Action
Chapter 7

Metadata Editor

The Metadata Editor is a tool for adding and editing EXIF, IPTC, or XMP metadata attached to an image.

Image metadata is textual information that can be attached to digital images in order to annotate, describe and categorise them. This information is useful for searching and indexing images and for accessibility services. There are three standard formats in which image metadata can be stored: EXIF, IPTC and XMP. They concentrate on different properties of the image and are used for different purposes. digiKam provides tools for viewing and editing image metadata in all these formats.

The application offers metadata editing tools available through the Edit Metadata menu entry. The metadata editor conveniently arranges all metadata into sections for each kind of metadata chunk, making it easier to find and edit specific entries. For example, to edit hardware-related information, switch to the Device section. Here you can modify device manufacturer, device model, exposure-related settings, and other information.
In addition to EXIF, IPTC and XMP formats are supported, so you can perform the described actions on metadata stored in these metadata chunks as for EXIF. Remember that EXIF is dedicated to store camera information, where IPTC and XMP are more used to store post-process text information such as rights management. So, it is not recommended to edit the metadata injected by the camera that took the photograph; on the other hand, you can add information about the author, copyright, etc. Detailed description of supported entries is available online.

Note that you can synchronise some specific metadata entries from one chunk to another one, as for example the comments which is available in EXIF, IPTC, and XMP as separate entries. Mark the check boxes corresponding to the entries you wish to copy from one format to another.

**CAUTION**

Note that synchronising metadata may produce undesired results because EXIF is limited to pure ASCII character set.
Chapter 8

Panorama Tool

Panorama is a tool for stitching images together.

TODO
Chapter 9

HTML Gallery

The HTML Gallery is a tool for exporting a set of Albums or images to a HTML page.

This powerful tool can export your Albums into a HTML compliant web image gallery. You can easily select the Albums to export in an HTML page and set many designs and parameters for the HTML rendering. UTF-8 encoding is used for the best internationalization.

9.1 Album Selection Dialog

Launching the tool from within digiKam displays three tabs to change the settings. The My Albums tab allows you to select all Albums you want to export to HTML. Just check the respective Albums (they are displayed without hierarchical nesting). On the next two tabs My Tags and My Searches you can refine your selection using tags or previous search results in digiKam.
The digiKam Handbook

Figure 9.1: The Album Selection Dialog in digiKam

Next step is to select a theme for the gallery from this dialog:

Figure 9.2: The Theme Selection Dialog

Depending on the chosen theme you may have additional options to fine-tune the appearance of
The digiKam Handbook

the gallery.
The next screenshot shows the theme parameter setting for the **Classic** theme:

![Theme Parameters](image)

**Figure 9.3: Parameters for Classic Theme**

For all selected themes you can adjust the settings for the images and thumbnails in the gallery:
In the **Full Image** section you can either save modified images or **Use original image**.

For modified images you can select as output format JPEG (smallest filesize, but lossy) and PNG (lossless and free license) and set specific image compression features. If disk space is of concern check the target image compression and lower the compression level from the host application default value.

Checking the **Max. size** box you can fix the maximum target image size (in pixels) with the spinbox at the right. Images bigger than this value will be scaled down to it, but smaller images will not be modified.

**NOTE**

If JPEG file format is selected for target resizing images, all EXIF information will be preserved from the original JPEG files.

The **Thumbnails** section allows to set the **Format**, **Quality** and **Size** for the thumbnails in the gallery.
This page defines the settings of where and how to store the gallery with all its associated images. Select a folder or add a new folder with write access where you want the gallery to be written to. Two sub-folders with the name of your album folder and the theme name will be created containing everything.

A progress dialog giving a feedback indicate to user. Press Cancel button during this stage if you want abort the process.
Chapter 10

Expoblending Tool

Expoblending is a tool for assemble bracketed or focus stack images.

TODO
Chapter 11

Calendar Tool

Calendar is a tool for printing calendar.

TODO
Chapter 12

Maintenance Tool

Maintenance is a tool running processes in the background to maintain image collections and database contents.

12.1 Introduction

Depending on your workflow, your digiKam settings and whether you work on your images collection also with other programs it might be necessary to run maintenance operations from time to time to update the digiKam databases and also your images regarding duplicates, face tags, quality labels, etc. The maintenance tool can do that for you, even more than one operation in one go depending on your requirements.

12.2 The Maintenance Features

12.2.1 The Common Options

In the Common Options section you can restrict the scope of the maintenance process(es) to certain albums or tags. You got to un-check Whole albums collection or Whole tags collection to get access to the drop down fields where you can select albums or tags. Note that in this drop down field you have a context menu to select or deselect children and/or parents and also to invert the selection. If you switch from Albums to Tags or vice versa your selection in the now grayed out item will remain untouched which might be useful if you need a certain selection more often.

Since many of the processes the maintenance tool can perform are time consuming (depending also on the scope, of course) you have the choice to check Work on all processor cores if your machine has more than one and they are not occupied otherwise.

12.2.2 The Scan for New Items Tool

This process will scan the collections you defined in Settings → Configure digiKam... → Collections for new items, i.e. image files you added to your collections while digiKam was not running. You can run this process also automatically on digiKam startup by checking Scan for new items at startup in Settings → Configure digiKam... → Miscellaneous.
12.2.3 The Rebuild Thumbnails Tool

Rebuilding the thumbnails might be necessary if you worked on your images with other applications or if you changed the thumbnail size in Settings → Configure digiKam... → Views → Tree-Views. The ‘Scan for changed or non-cataloged items’ option can speed up the process in the first case or if you just added pictures to your collection.

12.2.4 The Rebuild Fingerprints Tool

Fingerprints are necessary for finding duplicates and similar items and for finding images by sketches. For detailed description see Fuzzy View.

12.2.5 The Find Duplicates Tool

The Find Duplicates Tool is doing the same as the Find duplicates button in the Fuzzy View, but here you can combine it with other maintenance operations and you have the chance to check ‘Work on all processor cores’ under Common Options (see above) to speed up the process.

12.2.6 The Face Management Tool

Detect and Recognize Faces

This is the same process you can access in the People View with the Scan collection for faces button. Here you just cannot set the Fast - Accurate parameter and the option ‘Clear and rebuild all training data’. For more information about the Faces Data Management options see People View.

12.2.7 The Image Quality Sorter Tool

The Image Quality Sorter assigns quality labels to images according to the settings in Settings → Configure digiKam... → Image Quality Sorter. There you also have to enable this tool if you want to use it. Since it is a time consuming process it’s a good idea to check Work on all processor cores and restrict the job to certain albums or tags. The tool will set the red flag for ‘rejected’, the yellow one for ‘pending’ and the green one for ‘accepted’.

12.2.8 The Metadata Synchronizer Tool

TODO
Chapter 13

DLNA Mediaserver Tool

DLNA Mediaserver is used to automatically export digiKam photos through the local network to other DLNA-compliant devices like smart phones and tablets.

13.1 Starting The Server

To start the mediaserver, head to the right bar and click the Tools menu. You will find the dlna server icon as shown in the next screenshot. You can also start it from the Tools menu in the main toolbar.

When you click the icon, the mediaserver window will open as follows:
Now you have a couple of buttons. Use **Add Items** if you want to add single image files to be shared through the server. Use **Add New Root Directory** if you want a complete folder to be added to your server. You can choose to add the files inside this folder only or also the files inside the internal folders by checking the **Scan Recursively** checkbox. Use **Delete Selected** to remove the selected files/folders from the shared items. And finally you can hide this mediaserver window (without closing the actual server) using the **Hide Window** button. If you want to close the window AND the server, press the ordinary cross to the top-right of the window. Note that the files and folders you specify will be saved for you to use in later sessions.

### 13.2 The Configuration Panel

Starting the digiKam configuration panel (**Settings → Configure digiKam...**), you will find a new option for the digiKam mediaserver. You actually have two simple options: if you want to start the mediaserver automatically once you start digiKam and if so, if you want to start the server in background or show the actual mediaserver window. That’s all what the two checkboxes here do.
13.3 Important Notes

1. After you start the server, you might have to wait for about 30 seconds to one minute before other devices in the network can see your server, so please be patient :)

2. This server was tested with some client applications. This list includes:
   - VLC media player 3.0.0-git (PC - archlinux) - Note: Older versions of VLC do not work properly.
   - GUPnP AV (PC - archlinux)
   - VLC media player (Android)
   - BubbleUPnP (Android)
   - MediaHouse (Android)
   - AnDLNA (Android)
Chapter 14

Print Wizard

The print wizard is a tool for to print images at the same time.

The print wizard allows multiple images to be combined into single sheets of paper in standard photo sizes for printing. The combined images can also be automatically opened with the image editor Gimp for enhancement or for direct printing using the Gimp-Print tool. The combined images can also be output directly to jpeg files.
Chapter 15

Send Images Tool

‘Send Images’ is a tool for sending images directly by e-mail.

15.1 Using the Module

With this tool you can e-mail the selected images with your favorite e-mail agent. Resizing images is possible. You can use drag and drop to add more images to the list of images to send.

15.1.1 Image Selection

When opening the tool from the host application, the Email Images Options dialog will appear with your pre-selected images already in the list at the left part of the dialog.

Below the image list there are five buttons. The two left buttons are used to move a selected image in the list up or down. The middle button opens a file browser to add more files as needed in the usual file selection manner.

When clicking on the other buttons the selected images will be removed from the list or the list will be cleared.

**Tip**

You can drag and drop images between the host application window and the image file list to add new items to e-mail.

**Warning**

Be sure not to overload your own or your addressees e-mail transmission limit; most providers limit the e-mail size to some megabytes of data. Use several e-mails if you want to send a lot of data.
15.1.2 Mail Settings

The right part of the dialog is used to change the settings of the images to be sent. These settings will be remembered when you close the tool until you change them.

Select your favorite e-mail client from the drop-down menu. Default is the current email program set in KDE System Settings.

If you select Attach a file with image properties from Application the comments, rating or tags included with the images will be merged to a text file and attached in the mail.

The next three items allow you to set-up the image properties to be sent. To enable these options check Adjust image properties. First select an Image size suitable for your Internet connection speed and the target mailbox size.

The PNG format in the Image file format drop-down menu is not well adapted to reduce photographic images file size, but is best suited for compressing lossless items like the TIFF file format. PNG must be used if you use dialup speed Internet and you want to preserve the photo quality. Otherwise, JPEG is the recommended format.

The Image quality can be chosen with the input box. 75% is the standard compression ratio for JPEG files. Setting compression to 100% will result in lossless compression at the cost of the largest file size. The difference in file size between 90% and 100% can be quite dramatic, whereas the gain in quality is minor. Very good quality is already obtained with 85% compression.

**NOTE**

If you choose JPEG as the Image file format and the original files were in JPEG format, the original Exif data included is preserved in e-mailed images.

![Email Images Options - Gwview](image)

Figure 15.1: The Email Images Dialog

15.1.3 Email Images in Action

When you have finished selecting your files, click OK to open the composer window of your favorite e-mail client. You just need to add the addressee and the subject. The selected images will be already be listed as attachments.
A progress dialog gives you feedback on the progress of your operation. Press the **Cancel** button during this stage if you want to abort the process.

When all jobs are completed, this dialog will not close automatically and you can consult the progress messages if any errors occurred during this stage. The mail agent will be started automatically at the end. Press the **Close** button to close this dialog.

![Image of email images tool in action](image)

*Figure 15.2: The E-mail Images Tool in Action*
Chapter 16

Flickr Export Tool

FlickrExport tool allows the user to upload photos to the Flickr web service.

Flickr is an online photo management application. Flickr is a way to get your photos to the people who matter to you. With Flickr you can show off your favorite photos to the world, blog the photos you take with a cameraphone, and securely and privately show photos to your friends and family around the world.

The FlickrExport tool can be used to upload an image collection from your computer to the remote flickr server using the Internet.

16.1 Tool initialization on first access

When accessing the tool for the first time you are taken through the process of obtaining a token which is used for authentication purposes. The following dialog will popup and a browser window will be launched you will log in to Flickr:

![Figure 16.1: The First Sign Up Dialog Preview](image)

After successful signup FlickrUploadr will be allowed to send photos to the flickr website. You will be presented with the following page on successful signup:
Then, simply close the browser windows and return to the host application dialog. After clicking Yes, you will see the interface used to upload photos to Flickr, described in the next section.

### 16.2 Regular Tool Usage

When the flickrexpport tool is invoked for second time or later you are greeted with the following dialog, which shows the current access permissions the Flickr Export tool has. The uploading process requires ‘write’ permissions. The tool doesn’t allow any other permissions as of now. You are then asked if they want to proceed with their current permissions.

After clicking Yes, you will see the interface to upload photos to Flickr.
After clicking No, the authentication process is repeated.

The Main upload dialog is shown below:

![Flickr Export](Image)

Figure 16.4: The Main Uploading Dialog Preview

The Add Photos button should be clicked once user has set the other options in the dialog. After clicking this button an image selector dialog opens up where you can select the photos you want to upload and click OK, whereupon the image uploading starts.

The Tags field can be filled with a series of words (comma separated) which will be assigned as tags to the images uploaded.

The Public, Friends, and Family checkboxes can be checked to assign appropriate access permissions to the images you upload. By default the images uploaded are private.

If the Resize photos before uploading option is selected, the photos will be resized before uploading. The values will be read from the Maximum dimension combobox.

The Maximum Dimension combobox can be used to adjust the maximum height to which the photos will be resized before uploading. The width calculation will be done so as to have the aspect ratio conserved.
Figure 16.5: The Uploading Progress Dialog Preview

You can click **Cancel** button to abort the uploading of photos.
Finally, you can view the uploaded photos by visiting the [Flickr](https://flickr.com) website.
Chapter 17

Piwigo Export Tool

This tool is dedicated to export image to a Piwigo remote gallery.

TODO
Chapter 18

KML Export Tool

This tool is dedicated to export image properties to a KML file.

TODO
Chapter 19

Google Services Export Tool

This tool is dedicated to export image to a Google web services.

TODO
Chapter 20

Flash Export tool

This tool is dedicated to export image to a Flash.

TODO
Chapter 21

DropBox Tool

DropBox is a tool to export images on DropBox web service.

TODO
Chapter 22

FaceBook Tool

FaceBook is a tool to export images on Facebook social network.

TODO
Chapter 23

ImageShack Tool

ImageShack is a tool to export images on Imageshack web service.

TODO
Chapter 24

ImgUr Tool

ImgUr is a tool to export images on Imgur web service.

TODO
Chapter 25

Mediawiki Tool

MediaWiki is a tool to export images on Mediawiki web service.

TODO
Chapter 26

Rajce Tool

Rajce is a tool to export images on Rajce web service.

TODO
Chapter 27

RemoteStorage Tool

RemoteStorage is a tool to import and export images on a remote computer.

TODO
Chapter 28

Smug Tool

Smug is a tool to export images on Smug web service.

TODO
Chapter 29

VKontakte Tool

VKontakte is a tool to export images on Vkontakte web service.

TODO
Chapter 30

YandexFotki Tool

YandexFotki is a tool to export images on Yandexfotki web service.

TODO
Chapter 31

Menu Descriptions

31.1 The main digiKam window

31.1.1 The Browse Menu
The Browse menu provides access to the same views you can see on the Left Sidebar. Descriptions see under The Main digiKam Window. In addition there are “Back” and “Forward” menu items that will lead you through the history of your digiKam use in the same way you are used to from an internet browser for example. And finally there is the “Quit” item to leave digiKam.

31.1.2 The Album Menu
The first five items of this menu (above the separator) are only active if you are in the Albums View.

Album → New... (Ctrl+N)
Opens a dialog to create a new album folder similar to the album properties dialog described here. It just has an additional drop down field where you can choose whether the new album is created as a child of the current one or at the root of the current collection.

Album → Properties
Edit the currently selected album title, caption and collection as described here.

Album → Rename (F5)
Rename the current album.

Album → Open in File Manager
Open the default file manager with the current Album path.

Album → Delete Album
Delete/Move to trash selected Album and all items in it.

Album → Write Metadata to Images
Write the metadata in the database to the file’s metadata of all items in the current album. The images will inherit the database metadata, not the other way round as in the next menu item.

Album → Reread Metadata From Images
Write the metadata of all items in the current album to the database. The database will inherit the images metadata, not the other way round as in the previous menu item.
The digiKam Handbook

31.1.3 The Tag Menu

The items below the separator are only active if you are in the Tags View.

Tag → Tag Manager
Opens the digiKam Tag Manager.

Tag → New...
A dialog will open where you can type in the tag name (or even a whole hierarchy branch), assign an icon and/or a shortcut to the tag. The new tag will be created as a sub-tag of the selected tag.

Tag → Properties
The Tag Properties allow you to change the name of the tag, the icon used in the Tags tree and the shortcut.

Tag → Delete
Remove the currently selected Tag from the Album’s Database. This doesn’t delete the images the tag was assigned to.

31.1.4 The Item Menu

Item → Open... (F4)
Opens the selected image in the digiKam image editor.

Item → Open With Default Application (Meta-F4)
Opens the selected item in the default application according to the mimetype, e.g. Gwenview.

Item → Rename (F2)
Renames the currently selected item(s). See description here.

Item → Move to trash (Del)
Moves selected item(s) to trash (recoverable delete).

Item → Place onto Light Table (Ctrl-L)
Inserts selection into the Light Table thumbbar and puts the Light Table into the foreground.

Item → Add to Light Table (Ctrl-Shift-L)
Adds selection to the Light Table thumbbar and puts the Light Table into the foreground.

Item → Add to Current Queue (Ctrl-B)
Opens the digiKam Batch Queue Manager and adds selection to the current queue or, if there is no queue yet, to a new queue.

Item → Add to New Queue (Ctrl-Shift-B)
Opens the digiKam Batch Queue Manager and puts selection into a new queue.

Item → Find Similar...
Puts the selected item into the Image tab in the Fuzzy View. See the dedicated Image (Similar items) for more information.

Item → Write Metadata to Image
TODO
Item → Reread Metadata from Image
When editing metadata using the Metadata Editor the data will be written to the image only. If you want them to appear in the Metadata Tab of the Right Sidebar you got to use this function first.

Item → Rotate
Menu entry for rotating the currently selected images lossless Left (Ctrl-Shift-Left) or Right (Ctrl-Shift-Right) in 90 degree steps (see submenu).

Item → Flip
Menu entry for flipping the currently selected images lossless Horizontally (Ctrl-*) or Vertically (Ctrl-/) (see submenu).

Item → Auto Rotate/Flip using EXIF information
Menu entry to manually activate the auto rotate/flip feature for the currently selected images using the EXIF orientation tag. For a more detailed description see Lossless Image Rotation.

Item → Adjust EXIF Orientation Tag
The EXIF Orientation Tag of the current selection will be changed depending on the option you choose from the submenu. The thumbnail(s) and preview(s) will be rotated accordingly if Show images/thumbnails rotated according to orientation tag is checked in Settings → Configure digiKam... → Metadata → Rotation → Rotate actions, but not the actual image file. If you want to rotate that as well you got to use the function Item → Auto Rotate/Flip using EXIF information described above additionally. If you open the file in the digiKam Image Editor it will also come up in the rotated version and will be stored that way on disc if you save it. But be aware of the fact that this would be a lossy operation as long as it is not a lossless file format.

Item → Edit Metadata...
Opens the digiKam Metadata Editor to handle meta data of the image (EXIF, IPTC, XMP). See the dedicated Metadata Editor chapter for more information.

Item → Edit Geolocation...
Opens the digiKam Geolocation Editor to handle GPS meta data of the image. See the dedicated Geolocation Tool for more information.

Item → Print
Calls standard print dialog.

Item → Print Assistant...
Tool to print Album images. See the dedicated Print Wizard for more information.

NOTE
Another very useful function on items is grouping which is at the time of writing only available through the context menu on a selection of items. For details see Grouping Photographs in the chapter about the Main digiKam Window.
31.1.5 The Edit Menu

Beside the usual “Cut”, “Copy” and “Paste” the Edit Menu contains the following items:

Edit → Select All (Ctrl+A)
Select all images currently shown

Edit → Select None (Ctrl+Shift+A)
Un-select all items in the current view

Edit → Invert Selection (Ctrl+I)
Invert the current selection

31.1.6 The View Menu

View → Thumbnails
Shows thumbnails in the Image Area

View → Preview Image (F3)
Shows additionally a preview in the Image Area.
The preview has “Back” and “Forward” buttons at the top left corner to navigate through all the images currently shown.

View → Map
Shows images on a map.

View → Table
Shows images in a table where you can choose by right clicking on the title bar which information you want to be displayed.
By default you have these four items also on the main toolbar.

View → Slideshow
Slide Show including RAW files.

View → Slideshow → All (F9)
Start slide show of all images in current window.

View → Slideshow → Selection (Alt+F9)
Start slide show on selected images.

View → Slideshow → With All Sub-Albums (Shift+F9)
Slide show that recurses through the current album tree.

View → Slideshow → Presentation... (Alt+Shift+F9)
Tool to display an advanced slide show with Album items.
See the dedicated Presentation Tool for more information.

View → Full Screen Mode (Ctrl+Shift+F)
Switch to full screen (Return with the same keyboard shortcut).

View → Zoom in (Ctrl++,+)
Increase preview or the thumbnail size of the currently selected Album.

View → Zoom out (Ctrl+-,-)
Decrease preview or the thumbnail size of the currently selected Album.
View → Zoom to 100% (Ctrl+,)
Will show the image 1:1 (meaning 1 image pixel is mapped exactly to 1 screen pixel) in preview mode.

View → Fit to Window (Ctrl+Alt+E)
Will size the image as to fit snug into the window.

View → Sort Albums
Sort all digiKam Albums by Folder, by Category or by Date.

View → Sort Images
Sort all images in current Album by Name, Path, Date, File Size, Rating, Image Size, Aspect Ratio or by Similarity, the latter only in the Fuzzy View.

View → Image Sorting Order
Select whether images should be sorted in ascending or descending order.

View → Group Images
Select whether images should be shown un-grouped (Flat List) or grouped by album or by format.

View → Group Sorting Order
Select whether groups should be sorted in ascending or descending order.

View → Include Album Sub-Tree
If a hierarchical album structure exists, the currently selected branch will be displayed in full depth.

View → Include Tag Sub-Tree
If a hierarchical tag structure exists, the currently selected branch will be displayed in full depth.

View → Color-Managed View (F12)
Toggles between showing thumbnails and preview in color-managed mode or not.
For more information about color management see this lengthy chapter.

31.1.7 The Tools Menu

Tools → Image Editor
Opens the digiKam Image Editor.

Tools → Light Table (L)
Switches to the Light Table window.

Tools → Batch Queue Manager (B)
Opens the Batch Queue Manager window.

Tools → Search... (Ctrl+F)
Switches to the Search View with focus on the simple search field.

Tools → Advanced Search... (Ctrl+Alt+F)
Switches to the Search View and launches the advanced search dialog.
Tools → Find Duplicates (Ctrl+D)
Leads to the “Duplicates” tab in the Fuzzy View.
See Fuzzy View for more information.

Tools → Maintenance...
Opens the maintenance tool.
For a detailed description see this Chapter

Tools → Blend Bracketed or Focus Stack Images...
TODO

Tools → Create Panorama...
TODO

Tools → Create Calendar...
Tool to create a calendar with Album items.
See the dedicated Calendar Tool for more information.

Tools → Email Images...
Tool to send images with your favorite email client.
See the dedicated Send Images Tool for more information.

31.1.8 The Import Menu

Import → Cameras
Any configured digital camera will be listed here. You can use the “Add Camera Manually...” menu entry to add a new camera to the list. Please, read the Camera Settings for more information.
Once you choose a camera from the list the Camera Interface will open. For a detailed description see Using a Digital Camera With digiKam.

Import → USB Storage Devices
All currently mounted USB storage devices will be listed here. The function will open the same interface as the Import/Cameras menu item.

Import → Card Readers
All currently mounted card readers will be listed here. The function will open the same interface as the Import/Cameras menu item.

Import → Add Images... (Ctrl+Alt+I)
After asking for the source folder with the standard Open dialog of your OS the function will display the images in that folder in the same interface as the Import/Cameras menu item.
This item is only active in the Albums View.

Import → Add Folders...
Navigate to a folder and import it entirely
This item is only active in the Albums View.

Import → Import from Scanner...
Opens a scanner dialog
See the dedicated Acquire Images Tool for more information.

Import → Import from ...
Here are following the import menu items for the webservices you have chosen in
Settings → Configure digiKam... → Tools and which are labeled ‘Export’ in the ‘Categories’ column.
31.1.9 The Export Menu

Export → KML Export...
 Tool to export the images series into a KML structure. KML files can then be opened and displayed with GoogleEarth.
 See the dedicated KML Export Tool for more information.

Tools → Export to Piwigo
 Tool to upload or update images to Piwigo galleries
 See the dedicated Piwigo Export Tool for more information.

Export → Export to Flickr...
 Tool to upload or update images to Flickr server.
 See the dedicated Flickr Export Tool for more information.

Export → Export to Google Photos...
 Tool upload or update images to Google Photos galleries.
 See the dedicated Google Services Tool for more information.

Export → Export to Google Drive...
 Tool upload images to Google Drive.
 See the dedicated Google Services Tool for more information.

Export → Flash Export
 Tool to create a Flash gallery with Albums.
 See the dedicated Flash Export Tool for more information.

31.1.10 The Settings Menu

Settings → Show Toolbar
 Enable or disable the main digiKam toolbar.

Settings → Show Menubar (Ctrl+M)
 Enable or disable the main digiKam menu bar.
 Remind the keyboard shortcut in order to be able to get it back! Another way is the context menu within the Image Area.

Settings → Show Statusbar
 Enable or disable the main digiKam status bar.

Settings → Show Thumbbar (Ctrl+T)
 Enable or disable the thumbbar in the digiKam Image Area.
 This item is only active while a preview is displayed because it is meant to make more space for the preview in the Image Area.

Settings → Themes
 Choose from a list (submenu) of predefined color themes for the appearance of digiKam.

Settings → Configure Shortcuts...
 Configure the digiKam shortcuts and manage different schemes of shortcuts.
Settings → Configure Toolbars...
Configure the digiKam toolbars.

Settings → Configure Notifications...
Configure the digiKam notifications including actions like “Play a sound”, “Log to a file” or “Run command”.

Settings → Database Migration...
Launch tool to migrate the digiKam databases from SQLite to MySQL or vice versa.
Find more information about the databases and database migration in the setup section about digiKam databases.

Settings → Configure digiKam...
Launch digiKam configure dialog.
For a detailed description see digiKam Configuration.

31.1.11 The Help Menu

Help → Supported RAW Cameras
Displays a live filter of all supported RAW format cameras.

Help → Components Information
Displays an information panel with shared libraries and components.
Help → Database Statistics
Displays an information panel with a database summary.

31.2 The Image Editor

31.2.1 The File Menu
The digiKam Handbook

File → Back (PgUp)
   Display the previous image of the current Album.

File → Forward (PgDn)
   Display the next image of the current Album.

File → First (Ctrl+Home)
   Display the first image of current Album.

File → Last (Ctrl+End)
   Display the last image of current Album.

File → Save (Ctrl+S)
   Save the current image if it has been modified.

File → Save As...
   Save the current image in a new file.

File → Revert
   Restore the current image from the original file if it has been modified.

File → Delete File/Move to trash (Shift-Del)
   Delete/Move to trash the current image from the current Album.

File → Print Image... (Ctrl+P)
   Print the current image.

File → Quit (Ctrl-Q)
   Quit digiKam Image Editor.

31.2.2 The Edit Menu

Edit → Copy (Ctrl+C)
   Copy the current image selection in the clipboard.

Edit → Undo (Ctrl+Z)
   Cancel the last action applied to the current image using history.

Edit → Redo (Ctrl+Shift+Z)
   Redo the last action applied to the current image using history.

31.2.3 The Color Menu

Color → Auto-Correction (Ctrl+Shift+B)
   Automatic color/exposure correction of the current image by an histogram manipulation (help).

Color → White Balance
   Image Editor tool to adjust white color balance on the current image (help).

Color → Brightness/Contrast/Gamma
   Exposure correction of the current image by Brightness, Contrast, or Gamma adjustments (help).
The digiKam Handbook

**Color → Hue/Saturation/Lightness (Ctrl+U)**
Color correction of the current image by Hue, Saturation, or Lightness adjustments (help).

**Color → Color Balance (Ctrl+B)**
Color correction of the current image by Red, Green, or Blue adjustments (help).

**Enhance → Curves Adjust**
Image Editor tool to adjust curves manually on the current image (help).

**Color → Levels Adjust**
Image Editor tool to adjust levels manually on the current image (help).

**Color → Channel Mixer**
Image Editor tool to mix color channels on the current image.

**Color → Invert (Ctrl+I)**
Invert image colors.

**Filter → Black & White**
Open the Black & White filter dialog for the current image.

**Color → Color Management**
Invokes the interactive Color Management editor.

**Color → Depth**
Toggle between 8 bit and 16 bit format on color channels.

### 31.2.4 The Enhance Menu

**Enhance → Sharpen**
Classical image sharpening operation (help).

**Enhance → Blur**
Image softening operation by blurring (help).

**Enhance → Red Eye Reduction**
Red Eye correction tool using the current selection (help).

**Enhance → Inpainting**
Image Editor tool to remove unwanted areas and specs (help).

**Enhance → Noise Reduction**
Image Editor tool to reduce the noise with a Despeckle filter (help).

**Enhance → Restoration**
Image Editor tool to reduce artifacts on the current image (help).

**Enhance → Hot Pixels Correction**
Image Editor tool to remove hot pixels on the current image (help).

**Enhance → Anti Vignetting**
Image Editor tool to correct vignetting of the current image (help).

**Enhance → Lens Distortion Correction**
Image Editor tool to correct lens distortion of the current image (help).
31.2.5  The Transform Menu

Transform → Rotate → -90 degrees (Ctrl+Shift+Left)
   Left rotation of the current image.

Transform → Rotate → 90 degrees (Ctrl+Shift+Right)
   90 degrees rotation of the current image.

Transform → Free Rotation
   Image Editor tool to rotate the current image by any angle in degrees (help).

Transform → Flip → Horizontally (Ctrl+*)
   Horizontal flip of the current image.

Transform → Flip → Vertically (Ctrl+/)
   Vertical flip of the current image.

Transform → Crop (Ctrl+X)
   Crop image to the current selection.

Transform → Resize
   Resize (reduce or blow-up) the current image to the appropriate factor or dimensions (help).

Transform → Aspect Ratio Crop
   Crop the current image using an constrained aspect ratio (help).

Transform → Shear
   Image Editor tool to shear the current image horizontally or vertically (help).

Transform → Perspective Adjustment
   Image Editor tool to adjust perspective of the current image (help).

31.2.6  The Decorate Menu

Decorate → Apply Texture
   Image Editor tool to apply decorative texture to the current image.
   See the dedicated Apply Texture manual for more information.

Decorate → Add Border
   Image Editor tool to add a decorative border around the current image (help).

Decorate → Insert Text
   Image Editor tool to insert text in the current image (help).
31.2.7 The Effects Menu

Effects → Color Effects
Set of four Image Editor tools: Solarize, Vivid (Velvia), Neon and Edge (help).

Effects → Add Film Grain
Image Editor filter for adding Film Grain (help).

Effects → Oil paint
Image Editor filter to simulate Oil Painting (help).

Effects → Charcoal Drawing
Image Editor filter to simulate Charcoal Drawing (help).

Effects → Emboss
Image Editor Emboss filter (help).

Effects → Distortion Effects
Image Editor filter set with distortion special effects (help).

Effects → Blur Effects
Image Editor filter set with blurring special effects on (help).

Effects → Raindrops
Image Editor filter to add Rain Drops (help).

31.2.8 The View Menu

View → Zoom In (Ctrl++)
Increase the zoom factor on the current image.

View → Zoom Out (Ctrl+-)
Decrease the zoom factor on the current image.

View → Fit to Window (Ctrl+Shift+A)
Toggle between fit-to-window zoom or 100% image zoom size.

View → Fit to Selection (Ctrl+Shift+S)
Make the selection fit the window.

View → Histogram
Display superposed histogram on current image (Luminosity, Red, Green, Blue, Alpha).

View → Slideshow
Start a slideshow of the current album.

31.2.9 The Settings Menu

Settings → Full Screen Mode (Ctrl+Shift+F)
Toggles the graphic interface to full screen mode.

Settings → Configure Shortcuts
Configure the digiKam image editor shortcuts.

Settings → Configure Toolbars
Configure the digiKam image editor toolbars.
31.2.10 The Help Menu

Help → digiKam Handbook (F1)
  Invokes the KDE Help system starting at the digiKam help pages. (this document).

Help → What's This? (Shift+F1)
  Changes the mouse cursor to a combination arrow and question mark. Clicking on items within digiKam will open a help window (if one exists for the particular item) explaining the item’s function.

Help → Report Bug...
  Opens the Bug report dialog where you can report a bug or request a ‘wishlist’ feature.

Help → Switch Application Language...
  Opens a dialog where you can edit the Primary language and Fallback language for this application.

Help → About digiKam
  This will display version and author information.

Help → About KDE
  This displays the KDE version and other basic information.

31.3 The Light Table

TODO

31.4 The Batch Queue Manager

TODO

31.5 The Camera Interface

TODO
Chapter 32

Credits and License

Program copyright 2001-2020, digiKam developers team
Documentation copyrighted by:

- 2001-2022
  - Gilles Caulier caulier_dot_gilles_at_gmail_dot_com

- 2001-2005
  - Renchi Raju renchi_dot_raju_at_gmail_dot_com

- 2003-2005
  - Richard Taylor r_dot_taylor_at_bcs_dot_org_dot_uk
  - Ralf Hoelzer kde_at_ralfhoelzer_dot_com
  - Joern Ahrens kde_at_jokele_dot_de
  - Oliver Doerr oliver_at_doerr-privat.de
The digiKam Handbook

- 2006
  - Elle Stone jrle1_at_twcnry_dot_rr_dot_com
- 2007
  - Kåre Särs kare_dot_sars_at_iki_dot_fi
  - Anne-Marie Mahfouf annma_at_kde_dot_org
- 2003-2010
  - Gerhard Kulzer gerhard_at_kulzer_dot_net
- 2017-2018
  - Antoni Bella Pérez antonibella5_at_yahoo_dot_com>

This documentation is licensed under the terms of the GNU Free Documentation License. This program is licensed under the terms of the GNU General Public License.
Chapter 33

Index

A
Assembly, 269

B
Blend, 275
Bracketing, 275

C
Calendar, 276
Comments, 267
Computer, 300

D
DropBox, 294

E
EXIF, 267

F
Facebook, 295
Flash, 293
Flat scanner, 249

G
Google, 292
GPS, 254

I
Imageshack, 296
Imgur, 297
IPTC, 267

K
KDE, 270
KML, 291

M
Maintenance, 277
Makernote, 267
Map, 254
Mediawiki, 298
Metadata, 267

P
Panorama, 269
Piwigo, 290
Presentation, 264

R
Rajce, 299
Remote, 300

S
Smug, 301
Stack, 275

V
Vkontakte, 302

X
XMP, 267

Y
Yandexfotki, 303