The Cantor Handbook

Alexander Rieder
# Contents

1 Introduction ........................................................................................................ 5

2 Using Cantor ....................................................................................................... 6
   2.1 Cantor features ................................................................................................. 6
   2.2 The Cantor backends ....................................................................................... 7
   2.3 The Cantor Workspace .................................................................................... 8
      2.3.1 The Worksheet ......................................................................................... 9
      2.3.1.1 Settings ............................................................................................... 9
   2.4 The assistant dialogs ....................................................................................... 10
      2.4.1 The Create Matrix dialog ....................................................................... 10
      2.4.2 Matrix operation dialog .......................................................................... 10
      2.4.3 Differentiation dialog ............................................................................. 11
      2.4.4 Integration dialog .................................................................................. 11
      2.4.5 Solve equations dialog .......................................................................... 12
      2.4.6 Package import dialog ........................................................................... 12
      2.4.7 Plot dialog ............................................................................................. 13
      2.4.8 Plot 2D dialog ......................................................................................... 14
      2.4.9 Plot 3D dialog ......................................................................................... 14

3 Command Reference ........................................................................................... 15
   3.1 The main Cantor window .............................................................................. 15
      3.1.1 The File Menu ......................................................................................... 15
      3.1.2 The View Menu ....................................................................................... 16
      3.1.3 The Worksheet Menu ............................................................................. 16
      3.1.4 The Linear Algebra Menu ..................................................................... 17
      3.1.5 The Calculate Menu .............................................................................. 17
      3.1.6 The Package Menu ................................................................................. 17
      3.1.7 The Plot Menu ........................................................................................ 17
      3.1.8 The Settings and Help Menu ................................................................. 18

4 Questions and Answers ....................................................................................... 19

5 Credits and License ............................................................................................ 20
Abstract

Cantor is an application, aimed at providing a nice worksheet view to other Free Software Math packages.
Chapter 1

Introduction

Cantor is an application to allow you to use your favorite mathematical applications from within an elegant KDE-integrated Worksheet Interface. It provides dialogs to assist with common tasks and allows you to share your worksheets with others.
Chapter 2

Using Cantor

Screenshot:

2.1 Cantor features

- Intuitive worksheet view for evaluating expressions.
- Results of graph plotting shown inside the worksheet.
- Easy plugin-based structure to allow different backends to be added.
- GetHotNewStuff integration to allow example worksheets to be downloaded (or uploaded.)
- Mathematical formula typesetting using \[\text{LATEX}\].
- Backend-aware syntax highlighting.
- Plugin-based assistant dialogs to help with common tasks, such as integrating a function, or entering a matrix.
2.2 The Cantor backends

Cantor offers you several choices for the backends you wish to use with it. The choice to make depends on what you want to achieve.

Currently the following backends are available:

Sage:
Sage is a free open-source mathematics software system licensed under the GPL. It combines the power of many existing open-source packages, within a common Python-based interface. See https://sagemath.org for more information.

Maxima:
Maxima is a system for the manipulation of symbolic and numeric expressions, including differentiation, integration, Taylor series, Laplace transforms, ordinary differential equations, systems of linear equations, polynomials, sets, lists, vectors, matrices, and tensors. Maxima yields high-precision numeric results by using exact fractions, arbitrary precision integers, and variable precision floating point numbers. Maxima can plot functions and data in two and three dimensions. See http://maxima.sourceforge.net for more information.

R:
R is a language and environment for statistical computing and graphics, similar to the S language and environment. It provides a wide variety of statistical (linear and nonlinear modelling, classical statistical tests, time-series analysis, classification, clustering, ...) and graphical techniques, and is highly extensible. The S language is often the vehicle of choice for research in statistical methodology, and R provides an open-source route to this. See https://www.r-project.org for more information.

Julia:
Julia is a high-level, high-performance dynamic programming language for technical computing, with syntax that is familiar to users of other technical computing environments. It provides a sophisticated compiler, distributed parallel execution, numerical accuracy, and an extensive mathematical function library. See Julia documentation for more information.

KAlgebra:
KAlgebra is a MathML-based graph calculator, that ships with KDE Education project. See https://edu.kde.org/kalgebra/ for more information.

Qalculate!:
Qalculate! is not your regular software replication of the cheapest available calculator. Qalculate! aims to make full use of the superior interface, power and flexibility of modern computers. The center of attention in Qalculate! is the expression entry. Instead of entering each number in a mathematical expression separately, you can directly write the whole expression and later modify it. The interpretation of expressions is flexible and fault tolerant, and if you nevertheless do something wrong, Qalculate! will tell you so. Not fully solvable expressions are however not errors. Qalculate! will simplify as far as it can and answer with an expression. In addition to numbers and arithmetic operators, an expression may contain any combination of variables, units, and functions. See https://qalculate.github.io/ for more information.

Python2 and Python3:
Python is a remarkably powerful dynamic programming language that is used in a wide variety of application domains. There are several Python packages to scientific programming.

Python is distributed under Python Software Foundation license (GPL compatible). See the official website for more information.
NOTE
This backend adds an additional item to the Cantor's main menu, **Package**. The only item of this menu is **Package → Import Package**. This item can be used to import Python packages to the worksheet.

Scilab:
Scilab is a free software, cross-platform numerical computational package and a high-level, numerically oriented programming language. Scilab is distributed under CeCILL license (GPL compatible). See [https://www.scilab.org/](https://www.scilab.org/) for more information.

**WARNING**
You need Scilab version 5.5 or higher to be installed in your system to make this backend usable.

Octave:
GNU Octave is a high-level language, primarily intended for numerical computations. It provides a convenient command line interface for solving linear and nonlinear problems numerically, and for performing other numerical experiments using a language that is mostly compatible with MATLAB. See [https://www.gnu.org/software/octave/](https://www.gnu.org/software/octave/) for more information.

Lua:
Lua is a fast and lightweight scripting language, with a simple procedural syntax. There are several libraries in Lua aimed at math and science. See [https://www.lua.org/](https://www.lua.org/) for more information.

This backend supports **luajit 2**.

### 2.3 The Cantor Workspace

The Worksheet interface of Cantor consists of three parts:
1. The tab bar, where you can switch through the open worksheets.

2. A help panel, where help for a specific command is displayed if you enter `?? command`, `describe(command)` or `example(command)` (Maxima backend).

3. A Variable Manager panel where you can see the list of all available variables on the current worksheet. The Help and Variable Manager panels are shown as tabs on a sidebar of a Cantor window. Variable manager can be used for Maxima (if enabled on Settings → Configure Cantor... Maxima page), KAlgebra, Octave, Python2, Python3, Qalculate, and Scilab backends only.

4. The worksheet itself.

### 2.3.1 The Worksheet

The worksheet is the basic area for working with Cantor. Using it, you can enter expressions, allow the backend to perform calculations, and look at the results. The commands the worksheets accept depend on the chosen backend, so you should learn the appropriate backend syntax (the Show Help button takes you there directly). If you know the command, but you need additional information, you can type `/hungarumlaut.ts1 ? command /hungarumlaut.ts1`, and contextual help will appear on the right of the worksheet. If you want to see some example worksheets, you can go to File → Download Example Worksheets menu item, and download worksheets other users have published.

To control each command entry of the worksheet you can use control buttons shown at the right part of the worksheet when hovering the entry field with a mouse cursor. There are three basic actions for each entry: Evaluate Entry to update the result of calculations for the entry, Drag Entry to move the entry at the other place of the current worksheet and Remove Entry to remove the entry from the current worksheet.

Font settings and alignment of worksheet entries can be changed using a toolbar above the worksheet.

### 2.3.1.1 Settings

The Settings menu allows you to change some settings of the appearance of your current worksheet.

**Typeset using LaTeX**

This setting changes the way results are presented to you. If enabled, it passes the result through the \LaTeX system, to produce visually appealing formulas. For example, `3*x^2*sqrt(2)*x+2/3` becomes $3x^2 + \sqrt{2}x + \frac{2}{3}$.

**Syntax Highlighting**

Syntax Highlighting increases the readability of code, by highlighting keywords, or matching brackets in different colors.

**Completion**

When this is enabled, Cantor will show you possible completions for the command you are currently typing when you press the Tab-key. If there is only one choice remaining, it will insert the rest of the command for you.

**Line Numbers**

This setting controls whether the different expressions should have a number in front. This allows you to recall older results - in Maxima, for instance, this is done with the `%O1` command.
Animate Worksheet
This setting controls whether the different animations will be used to highlight changes on a worksheet.

Embedded Math
This setting controls whether rendering math expressions inside $$..$$ in Text and Markdown entries is enabled by default (needs pdflatex installed).

2.4 The assistant dialogs

There are several assistant dialogs implemented in Cantor to alleviate some basic operations. These dialogs can be accessed using the main menu items. Each backend has its own assistant dialogs.

2.4.1 The Create Matrix dialog

This dialog can be used to input matrices. You can define matrix dimensions and its elements. It is possible to navigate between cells quickly during input using the Tab key.

2.4.2 Matrix operation dialog
This dialog allows entering name of the matrix to compute its eigenvectors, eigenvalues or invert matrix. The default value (%) is used to refer to the previous result of calculation or input.

### 2.4.3 Differentiation dialog

![Differentiation Dialog]

This dialog allows entering expression of the function to differentiate, the name of the variable and the order of derivative.

### 2.4.4 Integration dialog

![Integration Dialog]

This dialog allows entering expression of the function to integrate, the name of the variable and the limits of integration (for the definite integral).
2.4.5 Solve equations dialog

This dialog allows entering equations to solve (each equation in a separate line) and the variables to determine (separated by the comma).

2.4.6 Package import dialog

This dialog allows entering name of the package to import (e.g. `numpy` for Python).
2.4.7 Plot dialog

The options of this dialog are separated into two groups using tabs. The **Functions** tab allows entering functions to plot.

To enter new function click on the **Add**. Double-click on the **Title** cell and enter the title, then double-click on the **Expression** cell and enter the function expression.

The **Options** tab is used to define plot and legend options. You can fine-tune almost every plot option to obtain the pleasant look of your figure.
2.4.8 Plot 2D dialog

This dialog allows entering expression of the function, its variable and the limits for this variable.

2.4.9 Plot 3D dialog

This dialog allows entering expression of the function, its variables and the limits for each variable.
Chapter 3

Command Reference

3.1 The main Cantor window

Cantor has the common KDE menu items, for more information read the Menu chapter of the KDE Fundamentals. Below is the list of the additional or special menu items in Cantor. Please note that some menus are only shown for backends that have corresponding implementation.

3.1.1 The File Menu

File → New (Ctrl+N)
Creates a new worksheet with the default backend.

File → New → Backend
Creates a new worksheet with the chosen backend.

File → Open... (Ctrl+O)
Open a supported new worksheet with the file dialog.

File → Open Recent
Choose a worksheet from a list of recently used files.

File → Download Example Worksheets
Opens the dialog to download examples uploaded by other Cantor users with GetHotNewStuff.

File → Open Example
Opens the dialog to choose an example to load. The examples should be downloaded with File → Download Example Worksheets beforehand.

File → Save Plain Text
Allows saving the current worksheet as a plain text document.

File → Export to LaTeX
Allows saving the current worksheet as a LaTeX document.

File → Publish Worksheet
Opens the dialog to publish your current worksheet and make it available to other Cantor users through GetHotNewStuff.

File → Run Script
Allows to load and run the batch scripts for the current backend.
3.1.2 The View Menu

View → Panels
Allows you to toggle the visibility of some tabs in the sidebar. Choices are:

- File Browser
  Toggles the visibility of the File Browser tab in the sidebar.
- Help
  Toggles the visibility of the Help tab in the sidebar.
- Variable Manager
  Toggles the visibility of the Variable Manager tab in the sidebar.

View → Zoom In (Ctrl++)
Zoom in the current worksheet by 10%.

View → Zoom Out (Ctrl+-)
Zoom out the current worksheet by 10%.

View → Show Script Editor
Opens the batch script editor window for the current backend.

3.1.3 The Worksheet Menu

Worksheet → Evaluate Worksheet (Ctrl+E)
Triggers the evaluation of the whole worksheet.

Worksheet → Evaluate Entry (Shift+Enter)
Triggers the current entry evaluation.

Worksheet → Insert Command Entry (Ctrl+Enter)
Inserts a new command entry below the current cursor position.

Worksheet → Insert Text Entry
Inserts a new text entry below the current cursor position.

Worksheet → Insert Markdown Entry
Inserts a Markdown entry below the current cursor position.

Worksheet → Insert LaTeX Entry
Inserts a LaTeX entry below the current cursor position.

Worksheet → Insert Image
Inserts an image below the current cursor position.

Worksheet → Insert Page Break
Inserts the page break below the current cursor position.

Worksheet → Collapse All Results
Collapse all results of the command entry.

Worksheet → Expand All Results
Expand all results of the command entry.
Worksheet → Remove All Results
Remove all results of the command entry.

Worksheet → Remove current Entry (Shift+Del)
Removes current entry from the worksheet.

3.1.4 The Linear Algebra Menu

Linear Algebra → Create Matrix
Opens the matrix creation assistant dialog.

Linear Algebra → Compute Eigenvalues
Opens the matrix name input assistant dialog to compute its eigenvalues and dimensions of the multiplicities of the eigenvalues in the corresponding order.

Linear Algebra → Compute Eigenvectors
Opens the matrix name input assistant dialog to compute its eigenvalues, dimensions of the multiplicities of the eigenvalues and eigenvectors in the corresponding order.

Linear Algebra → Invert Matrix
Opens the matrix name input assistant dialog to find the inverse of the matrix.

3.1.5 The Calculate Menu

Calculate → Differentiate
Opens the differentiation parameters dialog.

Calculate → Integrate
Opens the integration parameters dialog.

Calculate → Solve equations
Opens the parameters input dialog to solve linear and non-linear equations.

3.1.6 The Package Menu

Package → Import Package
Opens the package import dialog.

3.1.7 The Plot Menu

Plot → Plot
Opens the plot parameters dialog.

Plot → Plot 2D
Opens the plot parameters dialog.

Plot → Plot 3D
Opens the plot parameters dialog.
3.1.8 The Settings and Help Menu

Cantor has the common KDE Settings and Help menu items, for more information read the sections about the Settings Menu and Help Menu of the KDE Fundamentals.
Chapter 4

Questions and Answers

1. The Menu Item Typeset using LaTeX is not available
   Not every backend supports every option. Current version supports \LaTeX output for Maxima, Qalculate! and Sage backends.

2. I have installed Sage/Maxima or other supported CAS, but the appropriate backend does not appear.
   One possible explanation is that Cantor did not correctly detect the location. Go to the Settings → Configure Cantor... dialog and change the Path to the appropriate application on the backend’s page.

3. What a peculiar name - what does it have to do with mathematics?
   Cantor is named after the German mathematician Georg Cantor, the creator of set theory.
Chapter 5

Credits and License

Cantor
Program copyright 2009-2011 Alexander Rieder alexanderrieder@gmail.com
Documentation Copyright (c) 2009-2011 Alexander Rieder alexanderrieder@gmail.com
This documentation is licensed under the terms of the GNU Free Documentation License.
This program is licensed under the terms of the GNU General Public License.