The Calligra Stage Handbook

Neil Lucock
Krishna Tateneni
Anne-Marie Mahfouf
Gary Cramblitt
## Contents

1  Introduction ................................................................. 5

2  A Step-By-Step Tutorial ................................................ 6
   2.1  Start a new document ................................................ 6
   2.2  Add a new page ..................................................... 7
   2.3  Insert a picture ...................................................... 9
   2.4  Insert a Calligra object .......................................... 10
   2.5  Change the color of the title text .............................. 12

3  Detailed Guides ............................................................ 15
   3.1  Create a HTML Slideshow ........................................ 15
   3.2  Creating Calligra Stage Templates .............................. 16

4  General Hints and Tips for Great Presentations .................. 18

5  The Menu and Toolbar Items .......................................... 20
   5.1  The Toolbars ........................................................ 20
       5.1.1  Manipulating the Toolbars ............................... 20
   5.2  File Menu .......................................................... 21
   5.3  Edit Menu .......................................................... 22
   5.4  View Menu .......................................................... 23
   5.5  Insert Menu .......................................................... 24
   5.6  Format Menu .......................................................... 24
   5.7  Slide Menu .......................................................... 24
   5.8  Slide Show Menu .................................................. 25
   5.9  Settings Menu ........................................................ 25
   5.10 Help Menu ........................................................... 26

6  Configuring Calligra Stage ............................................. 28
   6.1  The Configure - Stage Dialog .................................. 28
       6.1.1  Misc ............................................................ 28
       6.1.2  Grid ............................................................. 29
       6.1.3  Document ....................................................... 30
       6.1.4  Author .......................................................... 31

7  Credits and License ...................................................... 32

A  Installation ............................................................... 33
Abstract

Calligra Stage is the presentations program in the Calligra suite of productivity applications.
Chapter 1

Introduction

Calligra Stage is the presentations program in the Calligra productivity suite. Using Calligra Stage, you can prepare a set of slides for use in an on-screen slideshow or for printing. Your slides can include text and graphics in a variety of formats, and of course, you can embed all sorts of objects using KParts.

The Calligra productivity suite consists of a number of applications which are designed to work together. Overview documentation for Calligra is available, as well as manuals for each component of the suite. Other components of Calligra are:

- Calligra Words - a frames based wordprocessor.
- Calligra Tables - a spreadsheet application.

Calligra is a free (or open-source) software project which is released under the terms of the GNU General Public License.
Chapter 2

A Step-By-Step Tutorial

Neil Lucock
Krishna Tateneni
Anne-Marie Mahfouf

In this chapter, Calligra Stage is introduced using a simple tutorial. We shall walk through the most basic steps that are involved in creating a presentation, and adding some basic effects.

2.1 Start a new document

When you start Calligra Stage, the usual Calligra startup dialog appears.

Select Screen on the left then select the template labeled Empty (highlighted in blue in the screenshot above) by clicking on it. You can check Always use this template to make it the default template.

Now click Use This Template. This brings up the slide editor window, where you can view and edit the slides (and objects contained in them) in your document.

At the moment, we just have one empty slide, so select the upper left slide with the single text box from the Slide Layouts docker.

Double-click the text box. The cursor changes to a vertical bar to show that you can now type some text.
Go ahead, type some text!

Click away from the text to de-select the text box when you are done typing.

2.2 Add a new page

Let’s now add a new slide to our document. To do so, click the Slide menu, and then click on Insert Slide.
Now we can decide what the new slide should look like. This time, select one column layout (highlighted in blue.)

The new slide layout now appears in the editing window. To change between pages of your presentation, you can select slides in the pane to the left (highlighted in blue for this screenshot).

The newly inserted slide has two text boxes. There is one for a title, and another to contain a bulleted list of items.

Double-click and type a title. Then double-click on the second text box with the bullet. Type some text and end the paragraph by pressing the Enter or Return key. As you type new paragraphs, bullets automatically appear in front of them.
2.3 Insert a picture

Let’s go back to the first slide now. Use the list of slides on the left of your screen. In this section, we’ll liven our presentation up a bit by adding a nice logo to the title page. To do so, the first step is to enable the Add Shape docker using Settings → Dockers from the menu.

Now select Image in the Add Shape docker and click with the left mouse button where you want to place the logo in its original size or draw a rectangle with the left mouse (click the left mouse button and keep the button pressed) to specify the position and size for the logo.

A file selection dialog appears. To learn about this or other standard KDE dialog boxes in detail, please consult the KDE documentation. You can browse by clicking on folder icons or by using the browser style buttons on the toolbar. Clicking the up arrow takes you up one folder level.

Select a file and click OK.
Now the image is inserted in the slide and there are selection handles (little squares) visible around the border of the graphic.
Place the mouse cursor anywhere in the middle of the logo, and drag it to the middle of the title page. Then use the selection handles to resize it correctly.
That’s it. Now you have a picture on the title page!

2.4 Insert a Calligra object

Let’s insert another Calligra object under the picture, for example a chart.
Every Calligra supported object can be embedded in a Calligra Stage slide. Let’s choose a chart from the Add Shape docker.
Select Chart and then outline with your mouse the area you want to put your chart in on the Calligra Stage slide.
Once you release the mouse button, a template chart is added on the slide. Whenever you work in the chart, its Tool Options appear in the docker.

To move, resize or even delete the embedded chart switch to the Basic shape manipulation tool and click anywhere within the chart area. It should now appear with a green border and with a small yellow square at each corner and in the middle of each edge.

If you move the cursor over any of the squares it should change to a double headed arrow. You can resize the chart by dragging one of these squares with the left mouse button pressed. To delete the chart right click on one of the squares and select Delete.

To move the chart move the cursor into the chart. The cursor should then change to a cross, press the left mouse button and you will be able to drag the chart to where you want it to be.
To restore the chart to its normal appearance simply click anywhere outside of the chart area.

To change the format of the chart itself left click twice within the chart area. The chart **Tools Options** should appear in the docker. You can then use these tools to edit the chart properties like chart type, labels, axis and data.

Click anywhere with the left mouse button outside the chart to go back to Calligra Stage slide.

A single click on the chart will allow you to drag it to change its location and also to drag the borders to make it bigger as with any other Calligra Stage object. Double click on the chart to get into KChart mode and modify any of the chart property.

### 2.5 Change the color of the title text

Let’s finish by changing the color of the title text from black to blue. To do so, select the title text by double-clicking the text box and select the text.

Open the color selector by clicking on the icon in the Text editing Tools Options (this icon has a Text Color... tooltip).

![Color Selector](image)
The Calligra Stage Handbook

Change the color to blue.

Changing the color of the selected text to blue changes its appearance. The exact color that highlighted text turns depends on your system color scheme.

**NOTE**
Text color selection is also available on the Decorations tab of the Select Font dialog. Open this dialog with Font in the Format menu or context menu.

Now click away from the text to de-select it.

Now that there are two slides, why not try a slide show! To start the slide show, press the Start Presentation button in the toolbar. The first slide should appear on your screen.
The Calligra Stage Handbook

To advance from the first slide to the next, just click anywhere on the screen, or use the Page Down key.

To exit the slide show, press the Esc key.
Chapter 3

Detailed Guides

Neil Lucock
Krishna Tateneni
Brad Hards
Danny Allen
Anne-Marie Mahfouf

This chapter describes how to perform some common tasks in Calligra Stage.

3.1 Create a HTML Slideshow

Turn an existing presentation into standard HTML pages with accompanying navigation aids. First, either make a new presentation, or open an existing one. Then, click on File → Export as HTML...

You will then get a dialog box asking for a few details:

![Image of export dialog box]

Fill in Title and Author fields. Select the slides which should be exported. If you want to change a name used on the HTML page for each slide double click on the name and edit it inline.
In the **Output preview** area the downsized slides are displayed and you can check the correct slide order and browse the presentation with the `<` and `>` buttons.

Now you can select a stylesheet with the configuration of the HTML options.

To actually produce your HTML presentation, press the **Export** button and select a folder.

What we now have are the newly-produced `html/` and `pics/` folders, created where we earlier set the path:

```
<table>
<thead>
<tr>
<th>js</th>
<th>img</th>
<th>style.css</th>
<th>slide1.png</th>
</tr>
</thead>
<tbody>
<tr>
<td>slide1.html</td>
<td>slide0.png</td>
<td>slide0.html</td>
<td>index.html</td>
</tr>
</tbody>
</table>
```

There is also an `index.html` file to launch your web slideshow.

You can see how it works by using your file manager or web browser to open the `index.html` file. Click where prompted, and the first slide of your presentation is displayed. It will now behave as a Calligra Stage slideshow.

Each click on the arrow icons take you to the next or previous slide. To get back to the start of the slideshow click on the slide icon.

**Tip**

To share your presentation with the world, transfer the newly-produced files to a network-accessible location (i.e. webspace), remembering to keep the folder structure intact.

### 3.2 Creating Calligra Stage Templates

It is very easy to create a new template for Calligra Stage.

If you have made a presentation in a style that you would like to use again, you can save it as a template.

This tutorial will show how we can make a new template and save it.

Open Calligra Stage and create a new document.

To add a little sparkle to the blank slide, we can change the slide background - do this by selecting the **Document background** tool in the Tools docker.

We want the background to look attractive, so you may choose to use an image as a background by clicking the **Set image** button: feel free to experiment, but keep it beautiful!
The page should now have the background you desire. Create a text box, and type a heading for your slide:

```
Double click to add a title

Double click to add an outline
```

When you are happy with your template, go to File → **Save As** and select **Opendocument Presentation Template** filetype in the file dialog.
Chapter 4

General Hints and Tips for Great Presentations

Neil Lucock
Krishna Tateneni

Okay, you’ve decided to use Calligra Stage for your presentation. Before you start making transparencies or animated slide shows, go and find a piece of paper and sit down at a desk away from the computer. It doesn’t matter whether you are doing a teaching session or trying to convince the boss that your plan, policy or idea should be adopted, you need to figure out what you are trying to say. Write down all the subjects you need to cover, try to get them in the order you think will make sense. Don’t put any details in yet, just decide on headings and the structure of your talk.

Under each heading make a note of what facts you need to cover. You are trying to build a convincing argument. Consider grouping your facts into things must be included, things that should be included and things that it would be nice to cover if you had plenty of time.

Once you have written down all the things you need to say, consider the time available to do it in. Ten minutes seems ages when you start, but it is very difficult to actually get much across in so short a time. Get your sheet of paper and a clock with a second hand. Practise your presentation over and over again. This has many benefits. Firstly, you get the timing right. If someone says you have ten minutes, never go over the allowed time. Secondly, when you actually do it in front of a live audience, it will not be the first time you have done that presentation. Third, you get the words right in your own head. You will find ways of saying things about the subject. If you’ve heard yourself do this presentation several times, you will know what you are going to say next and how you are going to say it.

Calligra Stage does not produce Speaker’s Notes at the time of writing, but I am happy to just use ordinary slides. Produce some slides for yourself, printed on plain paper, and some for use with the Overhead Projector. Make the text on your slides nice and big, you need to be able to read it at a distance. I use 14 or 16 point text, experiment to find a size that you can read easily. I never write out a script.

If you are using an Overhead projector, learn how to use it beforehand. Make sure that the bulb works, that the spare bulb is still okay. Clean the lens and display plates. If you are not used to working with projectors, practice. Ensure that the projection screen itself is clean. It’s probably best, when timing yourself, to allow for five seconds (count ‘one thousand and one, one thousand and two....’) to change each slide. That way you know you don’t have to rush. If you need to point at something on a slide, you can use a pointer and point at the display screen, find a laser pointer or put a pencil on the transparency itself. Be warned, these tend to roll out of place when you nudge the table.

Consider where you are going to stand. You cannot stand in front of your display, so off to one side is probably your best option if you want your audience to be able to see. I often project a
picture onto a wipeboard and draw over the top of it. If you are using a PC with a digital projector you can draw over the top of your slides with Calligra Stage’s pen tool. Remember, drawing freehand with a mouse is a skill that needs practice. If you are using an Overhead projector, you can use transparent overlay slides and a pen over the top of your computer generated ones.

When you are doing the presentation do not accidently look into the light, it’s easy to do. If you are not going to use the machine for a few minutes, turn it off. Practise to get where you are going to stand sorted out. Check the room you intend to use for electrical sockets and learn how the blinds work and where the light switches are. Good preparation not only makes you less likely to make mistakes (inanimate things can be a nightmare in front of an audience) but also gives you confidence. Always have a ‘Plan B’ ready if something refuses to work. Have a paper copy of your slides with you. You can photocopy and distribute these to your audience if the equipment fails.

I have not said much about the content yet. At present all you have is a piece of paper with everything you want to say on it. Before you make anything, ask yourself if their understanding of what you are saying is going to improved by showing them a picture. Bad presentations consist of a series of slides full of text. The presenter then reads the slide to the audience (who have already read it as they can read faster than someone can say it aloud). Try to avoid writing anything on the slide, except a title and a number. Draw a picture of what you need to say, then explain the picture to them. That way they do not get ahead of you (they can read faster than you can speak, remember?) and you look like you know it. You do not know it, you are using the picture as a series of prompts. A slide should support what you are saying, not duplicate it. A slide should be the focus of the audience’s attention, not a distraction.

An example. I teach Railway staff how to respond to accidents. I wanted to use a slide to discuss how you can move dangerous loads from a derailed or damaged rail vehicle to a road vehicle after an accident. The slide I made had a simple drawing of tank wagon, the kind used for carrying gases or oils. On the side I wrote ‘Lethal Chemical Company’ so that I do not have to explain it. I wanted to make several important points. First, you must get any overhead electric wires turned off before you do anything if they are within a certain distance. I drew one of the supporting structures and drew an arrow with the safety distance on it. Then I wanted to say that you must not transfer the wagon’s contents in darkness or thunderstorms. I drew a moon and a lightning bolt above the vehicle. You must get specialist advice, so I drew a sheet of paper and wrote the word ‘Plan’ near the vehicle. You also have to ensure that the vehicle does not move when the weight inside is removed. I drew little red wedges by the wheels. Everything I need to talk about is on this drawing. All I have to do is look at the drawing and it tells me what I need to cover. When I have covered all the things in the drawing, I have finished on that subject.

In general, only use a slide or picture if it shows something that adds to what you are saying. Finally, relax and try not to rush through it all. Talk to them, not at them and remember that a presentation is about whatever message you are trying to get across. Calligra Stage is a useful tool. It can help you to get that message over, but it cannot do the job for you.
Chapter 5

The Menu and Toolbar Items

Neil Lucock
Krishna Tateneni
Anne-Marie Mahfouf

Calligra Stage presents different types of interfaces for you to interact with the program. Perhaps the most familiar type of interface is the menu which appears on the top of the Calligra Stage window.

Clicking on the menu items gives you a list of commands from which you can choose the one you want. Many of the commands can also be accessed directly by holding down Ctrl or Alt and pressing another key on your keyboard. In the next section, each of the menu commands is described in brief.

5.1 The Toolbars

5.1.1 Manipulating the Toolbars

In addition to the menus, Calligra Stage also has a toolbar. The toolbar consists of a collection of icons. A toolbar icon often presents a convenient shortcut to a command that is found in one of the menus.

You can move the unlocked toolbar around by dragging the handle at the left. The unlocked toolbar can be ‘docked’ or attached to any side of the Calligra Stage window. If you like, you can also have the toolbar ‘float’ in its own window, separated from the main Calligra Stage window.

If you don’t like dragging toolbars around, right click on the handle and a menu pops up.

Choosing the item Text Position leads to an additional menu which lets you control the appearance of the items in toolbar. This additional cascading menu is shown in the screenshot below:
You can choose to display the toolbar items as text instead of icons, or even to combine both icons and text. If you want both text and icons, the cascading menu allows you to select whether the text appears beside the icons or below them.

In icons only view, if you don’t know what a particular icon means, you can hold the mouse over the icon, and after a second or so, a little hint pops up in a highlighted text box.

The **Orientation** item in the popup menu has to do with the placement of the toolbar. You can choose any of the four sides of the Calligra Stage window.

The Calligra Stage menus are discussed in the following sections.

### 5.2 File Menu

File → New (Ctrl+N)

Begins a new presentation. The startup dialog will open, allowing you to choose a template for your presentation.

File → Open... (Ctrl+O)

Opens an existing presentation. A standard KDE file open dialog will appear, allowing you to choose a file to open.

File → Open Recent

Displays a list of recently opened files for you to choose from.

File → Save (Ctrl+S)

Saves the currently open presentation. If you have not previously saved it, you will be asked to name the file. If you have previously saved the presentation, it will be resaved with the same name.

File → Save As...

Saves the currently open presentation with a new name.

File → Reload

Reload the currently active file.

File → Import...

Import a presentation that was previously created in one of several common formats.
File → Export...
Export the currently open presentation to one of several common formats for use in another application, or for exchange with someone who does not have access to Calligra Stage.

File → Mail...
Open a new email message in your selected email client with the current Calligra Stage document attached.

File → Export as HTML...
Starts the HTML wizard, which is described in the section Section 3.1.

File → Print... (Ctrl+P)
Prints the presentation. More precisely, it opens the print settings dialog, where you can adjust the settings before printing your presentation.

File → Print Preview...
Displays the presentation with a viewer, exactly as it would look if printed.

File → Document Information
Allows you to enter information about the document. This includes information about the author, and an abstract on the documents contents.

File → Close (Ctrl+W)
Close the current presentation. You will be given an opportunity to save any changes first.

File → Quit (Ctrl+Q)
Close Calligra Stage. You will be given an opportunity to save all changes in all open presentations first.

5.3 Edit Menu

Edit → Undo: Last task (Ctrl+Z)
Undo the last action you performed.

Edit → Redo: Last undone task (Ctrl+Shift+Z)
Redo the last action you undid. If you have not undone any actions, or the last undo action is not reversible, this menu item is disabled.

Edit → Cut (Ctrl+X)
Copy the selected item to the clipboard, and remove it from the document.

Edit → Copy (Ctrl+C)
Copy the selected item to the clipboard, while leaving it intact in your presentation.

Edit → Paste (Ctrl+V)
Insert the contents of the clipboard into your presentation.

Edit → Delete (Ctrl+Del)
Remove the currently selected item from your presentation.

Edit → Select All (Ctrl+A)
Select all the objects and text on the current slide.

Edit → Deselect (Ctrl+Shift+A)
Deselect any currently selected objects.
Edit → Find... (Ctrl+F)
  Search for text within the presentation.

Edit → Find Next (F3)
  Find the next occurrence of a piece of text within a presentation.

Edit → Find Previous (Shift+F3)
  Find the previous occurrence of a piece of text within a presentation.

Edit → Replace... (Ctrl+R)
  Replace one or more occurrences of a piece of text in your presentation with a different piece of text.

5.4 View Menu

View → New View
  Opens another window with the same presentation loaded so you can work on more than one slide at a time.

View → Normal (Ctrl+F5) View → Notes (Ctrl+F6) View → Slides Sorter (Ctrl+F7)
  Switch with these actions between the view modes Normal, where you edit slides, Notes, which shows a slide preview with a textbox for your annotations for the actual slide and the Slides Sorter view, where you can rename, cut, copy and paste slides and arrange them for your presentation.

View → Show Master Slides (Ctrl+F8)
  Toggle the display of the slide master where you can put objects that you want to appear on each slide in your presentation.

View → Show Grid
  If enabled, Calligra Stage will display a grid of dots representing the intersections of imaginary horizontal and vertical lines. You can use these dots to precisely position objects on the slide.

View → Snap to Grid
  If this is enabled, when dropping or moving objects on the slide the top left corner of the object will ‘snap’ or move, to the nearest grid point.
  This does reduce your freedom to freely position objects on the slide, however it also helps to line up objects precisely. It is easily disabled or enabled with this menu entry, allowing you the best of both worlds.

View → Show Guides
  When working in Calligra Stage you can drag a ‘guide line’ from either the horizontal or vertical ruler onto your document. This guide-line will not print or display in the finished presentation, it is simply to help you align objects on screen. If this item is enabled, these guide lines will be visible. If this is disabled, they will not be visible.
  Guide lines work across slides, allowing you to align objects the same way across multiple slides.
  Disabling (hiding) guide lines does not delete them. If you have created guide lines, and then disabled this item, enabling it again will retain the guide lines you created.

View → Zoom
  This submenu allows you to zoom in or out of the slide. Several predefined zoom levels are available, including Fit Page to scale the entire slide so as to be visible in the size window you have open, and Fit Page Width to scale the slide so it fills the entire width of the window, although you may now have to scroll vertically. There are also several other scaling choices, from 33% up to 500%.
5.5 Insert Menu

**Insert → Variable**
Here you can insert a variable that is filled in with a value that may be updated as you update the document.

**Insert → Import Slideshow...**
Insert an already existing presentation. A standard KDE file open dialog will appear, allowing you to choose a OpenDocument Presentation (.odp), which will be inserted after the last slide in your current presentation.

**Insert → Insert Pictures as Slides...**
Use this menu item to insert one or more pictures, each is inserted on a new slide. This is useful for the people who want to use Calligra Stage to make a slide show.

**Insert → Scan Image...**
Scan an image with a scanner. This requires you have a scanner installed. It opens a scan dialog to allow the use of the scanner.

5.6 Format Menu

**Format → Font...**
The Select Font dialog contains options for selected segments of text.
With this dialog, you can change the font, style and size of selected text. The preview box at the bottom allows you to approximate changes before you make them.

**Format → Paragraph... (Ctrl+Alt+P)**
The Paragraph Format dialog contains settings for larger blocks of text, such as paragraphs. Using this dialog, you can set indenting, line spacing, bullet/numbered list and border settings.

**Format → Style Manager (Ctrl+Alt+S)**
The Style Manager allows you to create an entire set of attributes that will be applied to selected text all at once.

**Format → Page Layout...**
Allows you to set the page details. You can specify the margins, the orientation, either portrait (higher than wide) or Landscape (wider than high) formats. There are many templates, such as screen, A4, US legal.

5.7 Slide Menu

**Slide → Insert Slide**
Insert a new slide after the current one.

**Slide → Copy Slide**
Copy the current slide to the clipboard.

**Slide → Delete Slide**
Delete the current page from the presentation. You will be asked to confirm this action.
The Calligra Stage Handbook

**Slide → Previous Slide (PageUp)**
Go back to the previous slide in the slide show.

**Slide → Next Slide (PageDown)**
Go to the next slide in the slide show.

**Slide → First Slide (Ctrl+Home)**
Go directly to the first slide in the slide show.

**Slide → Last Slide (Ctrl+End)**
Go immediately to the final slide in the slide show.

### 5.8 Slide Show Menu

**Slide Show → Start Presentation → From Current Slide (Shift+F5)**
Begin the slideshow from the current slide.

**Slide Show → Start Presentation → From First Slide (F5)**
Begin the slideshow from the first slide.

**Slide Show → Configure Slide Show...**
You can set up the properties for the entire slide show here, including whether to show the duration on screen, which of the slides in a presentation to include, and several other global settings.

### 5.9 Settings Menu

The **Settings** menu allows you to customize Calligra Stage.

**Settings → Show Toolbar**
In this menu you can both enable and disable the display of toolbar.

**Settings → Configure Shortcuts...**

**Configure Shortcuts** allows you to assign a keyboard shortcut to actions that Calligra Stage menus or icons contain.
The Calligra Stage Handbook

If you try to assign a shortcut that is already used, it will give you a warning message. Highlight what you want to do (in the picture, I have chosen to make a keyboard shortcut to About KDE).

Click the radio button to the Custom key setting and type the key you want to use. I assigned Control key and Y to bring up the ‘About KDE’ dialog box.

The button shows what has been assigned. Click OK to make the changes, click Default to restore whatever was assigned as default, click Cancel to do nothing and leave the dialog.

Settings → Configure Toolbars...

Configure Toolbars allows you to add or delete icons on each of the toolbars.

At the top is a drop down box to enable you to choose which toolbar you want to modify. In the picture the File toolbar is selected. If I want to add the Dockers icon to that toolbar, I click the entry in the left window. The arrow pointing right becomes available, if I click the arrow the Dockers entry is added to the selected toolbar. The left arrow is available when you click in the right side window. It allows you to remove an icon from a toolbar. The up and down arrows become active when an item on the right side is selected. You can also move the highlight in the right side window up and down with the keyboard arrow keys. By clicking on the arrows with the mouse you can change the order of the entries in the menu.

Settings → Themes

Choose the color theme for Calligra Stage window. You can choose one of the predefined color schemes or select Configuration... to open System Settings color selection module.

Settings → Configure Stage...

See the Configure Calligra Stage section for a complete explanation of all Calligra Stage settings.

5.10 Help Menu
Help → Calligra Stage Handbook (F1)
   Invokes the KDE Help system starting at the Calligra Stage help pages. (this document).

Help → What’s This? (Shift+F1)
   Changes the mouse cursor to a combination arrow and question mark. Clicking on items within Calligra Stage will open a help window (if one exists for the particular item) explaining the item’s function.

Help → Report Bug...
   Opens the Bug report dialog where you can report a bug or request a ‘wishlist’ feature.

Help → Switch Application Language...
   Opens a dialog where you can edit the Primary language and Fallback language for this application.

Help → About Calligra Stage
   This will display version and author information.

Help → About KDE
   This displays the KDE version and other basic information.
Chapter 6

Configuring Calligra Stage

Neil Lucock
Krishna Tateneni
Anne-Marie Mahfouf

6.1 The Configure - Stage Dialog

6.1.1 Misc

Units
Choose the default unit that will be used in your slides.

Handle radius
If you select a shape with the default tool (arrow) you see the yellow and red rectangles. These are called handles (used for resizing, rotation, ...). The handle radius changes the size of the handles. If you make them bigger it is easier to hit them.
The Calligra Stage Handbook

**Grab sensitivity**

This option defines how exactly you need to hit a handle to select it.

**Paste offset**

This is only active if Paste at Cursor is disabled. If you copy a shape with the shortcut Ctrl+C and paste it with Ctrl+V, and do that at a place where already a shape is this offset is used to paste the new shape to the bottom/right.

**Paste at Cursor**

Disables the paste offset and insert a pasted shape at the mouse cursor position.

### 6.1.2 Grid

**Show grid**

If enabled, Calligra Stage will display a grid of dots representing the intersections of imaginary horizontal and vertical lines. You can use these dots to precisely position objects on the slide.

**Snap to grid**

If this is enabled, when dropping or moving objects on the slide the top left corner of the object will ‘snap’ or move, to the nearest grid point.

This does reduce your freedom to freely position objects on the slide, however it also helps to line up objects precisely. It is easily disabled or enabled with this option, allowing you the best of both worlds.

**Grid color:**

You can change here the grid color which is black as default.

**Spacing**
Horizontal:
Set the space in centimeters between two points on an horizontal line on the grid. Default is 0.5 centimeter.

Vertical:
Set the space in centimeters between two points on a vertical line on the grid. Default is 0.5 centimeter.

6.1.3 Document

![Document Settings](image)

**Document Settings**

**Autosave interval:**
You can use this to adjust how often Calligra Stage saves a temporary file. If you set this value to **No autosave**, Calligra Stage will not autosave. You can adjust the autosave from 1 minute to 60 minutes.

**Create backup file:**
If checked, this will create a `<name>.odp.autosave.odp` in the folder where your file is. This backup file can then be used in case of a problem. The backup file is updated everytime you save your document or everytime there is an autosave.
6.1.4 Author

Choose an author profile for your document.
You can add a new profile or delete the current profile using the buttons to the right of the profiles drop-down list.
Chapter 7

Credits and License

Calligra Stage
Program copyright 1998-2000 by Reginald Stadlbauer reggie@kde.org
Current maintainer is Laurent Montel montel@kde.org.
CONTRIBUTORS
• Werner Trobin trobin@kde.org.
• David Faure faure@kde.org
• Toshitaka Fujioka fjioka@kde.org
• Lukáš Tinkl lukas@kde.org
• Thorsten Zachmann T.Zachmann@zagge.de
• Ariya Hidayat ariya@kde.org
• Percy Leonhardt percy@eris23.de

Documentation based on the work copyright 1999-2000 by Krishna Tateneni. Portions are copyright 2000-2002 Neil Lucock neil@nlucoki.freeserve.co.uk and 2005 Anne-Marie Mahfouf annma@kde.org

This documentation is licensed under the terms of the GNU Free Documentation License.
This program is licensed under the terms of the GNU General Public License.
Appendix A

Installation

Calligra Stage is part of the KDE project http://www.kde.org/. Calligra Stage can be found on the download site of the KDE project. For information on how to compile and install KDE applications visit the KDE Community wiki. Since KDE uses cmake you should have no trouble compiling it. Should you run into problems please report them to the KDE mailing lists.