The Konqueror Handbook

Pamela Roberts
Developers: The KDE Team
Contents

1 Overview 6

2 Konqueror Basics 7
   2.1 Starting Konqueror ............................. 7
   2.2 The Parts of Konqueror ........................ 8
   2.3 Tooltips and What’s This? ...................... 9
   2.4 Left and Middle Mouse Button Actions ........... 9
   2.5 Right Mouse Button Menus ...................... 10
   2.6 Viewing Help, Man and Info Pages ............. 11

3 Konqueror the File Manager 12
   3.1 Folders and Paths ............................. 12
   3.2 View Modes ................................... 12
      3.2.1 File Tip Info .................................. 13
      3.2.2 File Previews ................................ 13
      3.2.3 Information in the View ...................... 14
   3.3 Folder View Properties ......................... 14
      3.3.1 The View Properties Dialog ................. 15
   3.4 Navigation ..................................... 15
      3.4.1 Finding Files and Folders ................... 16
      3.4.2 Removable Devices ......................... 16
   3.5 Deleting Files and Folders ...................... 17
   3.6 Moving and Copying ............................. 17
      3.6.1 Using Drag ’n Drop .......................... 18
      3.6.2 Duplicate File or Folder Names ............. 18
   3.7 Selecting Items in the View ..................... 19
      3.7.1 Selecting Items Using the Mouse ............ 19
      3.7.2 Selecting Items Using the Keyboard .......... 19
      3.7.3 Selecting Items Using the Menu ............. 20
   3.8 Create New ..................................... 20
   3.9 Changing Names and Permissions ................ 21
      3.9.1 Copy and Rename ............................ 21
   3.10 Configuring File Associations .................. 22
   3.11 At the Command Line ........................... 22
The Konqueror Handbook

4 Konqueror the Web Browser 23
  4.1 Connecting to the Internet .................................... 23
  4.2 Surfing and Searching ........................................ 24
  4.3 Tabbed Browsing ................................................ 25
  4.4 Web Shortcuts .................................................. 25
  4.5 Access Keys .................................................... 26
  4.6 Browser Identification ........................................ 26
  4.7 Saving and Printing Web Items ............................... 26
  4.8 FTP ............................................................. 27
  4.9 URLs with Port Numbers ..................................... 28

5 Automatic Text Completion 29

6 Using Bookmarks ................................................... 30

7 Saving Settings ....................................................... 31

8 Plugins 32
  8.1 Konqueror Plugins .............................................. 32

9 View Mode Extensions 37
  9.1 FSView - the File System View ............................... 37
    9.1.1 Introduction .............................................. 37
    9.1.2 Visualization Features .................................. 37
      9.1.2.1 Item Drawing Options ................................ 37
      9.1.2.2 TreeMap Drawing Algorithms ....................... 38
    9.1.3 User Interface ............................................ 38
    9.1.4 Credits and License ..................................... 38

10 Configuring Konqueror 39
  10.1 Other Settings ................................................ 39

11 Command Reference 41
  11.1 Special Shortcuts ............................................ 41
  11.2 The Menubar .................................................. 41
    11.2.1 The File Menu .......................................... 42
    11.2.2 The Edit Menu ......................................... 43
    11.2.3 The View Menu ......................................... 44
    11.2.4 The Go Menu ............................................ 45
    11.2.5 The Bookmarks Menu .................................. 46
    11.2.6 The Tools Menu ........................................ 47
    11.2.7 The Settings Menu ..................................... 47
    11.2.8 The Window Menu ...................................... 47
    11.2.9 The Help Menu .......................................... 48

12 Questions and Answers 49

13 Credits and License 51
Abstract

Konqueror is KDE’s advanced File Manager, Web Browser and Universal Viewing Application.
Chapter 1

Overview

Pamela Roberts

Konqueror is an advanced file manager, providing file management functions ranging from simple cut/copy and paste operations to advanced local and remote network file browsing. Folder contents can be displayed in a variety of text and icon view modes, which can include thumbnail preview images of file contents. File and folder properties can easily be examined and changed, and applications launched with a simple click of the left mouse button.

In KDE Applications Dolphin is the default file manager. To change the default component for browsing folders, open Default Applications in the System Settings and select Konqueror as file manager.

Konqueror is an HTML 4.01 compliant web browser with built in support for JavaScript (ECMA-262), CSS (Cascading Style Sheets) and bidirectional scripts (such as Arabic and Hebrew). It provides support for the secure running of Java™ applets, Netscape® plugins for viewing Flash™, RealAudio® and RealVideo® and SSL for secure communications. Advanced features include automatic URL and form completion, the ability to import bookmarks from other browsers and tabbed browsing.

Konqueror is also an excellent full featured FTP client.

Konqueror is a universal viewing application, capable of displaying images and documents without having to launch another application. It does this by embedding components (KDE Parts) provided by other applications; from Gwenview; for image viewing, Okular for PDF, PostScript® and other documents.

Konqueror is a fully customizable application which anyone can configure to suit their own needs, from changing the overall style and the sizes of text and icons to selecting which items appear in the Menubar, changing the number and positions of the toolbars and even defining new shortcut key combinations.
Chapter 2

Konqueror Basics

Pamela Roberts

IMPORTANT
Like all KDE applications, Konqueror is highly configurable. This document describes how Konqueror behaves with the normal, default settings.
A three button mouse can be useful when you are running Konqueror or any other KDE application. If your mouse only has two buttons then you should be able to set your system up so that you can simulate a middle mouse button by pressing both buttons at the same time.
You can read more about mouse usage in Section 2.4
If you are used to having to double-click to perform an action, then take care, because in common with the rest of KDE, Konqueror defaults to single-clicking.

2.1 Starting Konqueror

Being a combined File Manager and Browser, Konqueror will automatically switch between the two modes as needed when it is running, but it is convenient to be able to choose which mode is to be used when you start it up.

• From the application launcher menu, select Internet → Konqueror (Web Browser) to start it as a browser.
• Alt+F2 will open KRunner, enter a path to a folder and press Enter to start in file manager mode, or just enter a URL such as http://www.konqueror.org to start Konqueror as a browser.

NOTE
Click on the black arrow to the right of the Home Page icon to switch to your Home Folder in the file manager mode and vice versa.

If Konqueror is the default file manager it also starts automatically when you left click on a desktop icon that represents a folder, such as a hard disk drive or the Trash icon.
2.2 The Parts of Konqueror

A brief look at the main parts of Konqueror’s window:

The Titlebar is the strip across the top of Konqueror’s window, and operates in the same way as for other KDE applications. Right click on the central portion to bring up the neat Titlebar menu.

The Menubar is the strip containing the names of the drop-down menus. Left click on a name to alternately show and hide that menu, or use Alt+the underlined letter in the name as a hot key, for example Alt+E to show the Edit menu. The various menus are described in the Menubar section of this document.

The Toolbar contains icons for commonly used operations. Left clicking on an icon will activate it. A brief description of what that icon does will appear when you hover the pointer over it.

Some icons, for example the Up and Back icons in the previous screenshot, have a small black arrow at the right. If you click with the left mouse button at this arrow a small dropdown menu will appear.

Right clicking on the Toolbar will bring up the Toolbar Settings menu which you can use to change the Toolbar’s appearance and position.

The Location Toolbar shows the path to the directory, URL or file being viewed. You can type a path or URL here and press Enter or left click on the Go icon at the right hand end of the Location Toolbar to go to it. The black icon at the right hand end of the Location Toolbar clears the text entry box.

The Bookmark Toolbar is the area under the Location Toolbar in the previous screenshot. You can add frequently used bookmarks here; see the Organizing Your Bookmarks section of this document.

The Window is the main area of Konqueror and can show you the contents of a directory, web page, document or image. Using the Window menu you can split Konqueror’s main window into one or more separate views, useful for drag and drop operations, or set it to contain two or more tabbed views.

The Status Bar runs across the bottom of the Konqueror’s window and often shows general information about whatever the mouse pointer is hovering over. If you have split the main window into a number of views you will get a Status Bar for each view, and it will include a small green light at the left hand end to show which is the ‘active’ view. Right clicking on the Status Bar brings up the Status Bar Right Mouse Button Menu.
NOTE
Don’t worry if your Konqueror doesn’t look exactly like this screenshot; it is highly configurable. In particular:

• You can use the Settings menu to choose whether to show or hide the Menubar, Main Toolbar, Location Toolbar and Bookmark Toolbar, or even to add an Extra Toolbar.

• If the toolbars are unlocked, you can also drag them to a new position by left clicking on the handle at the left hand end of a bar and move it around by holding the left mouse button down while you drag it.

For more details of how to change Konqueror’s appearance, see the Configuring Konqueror section

2.3 Tooltips and What’s This?

You can find out a lot about how Konqueror works without needing to read this entire document if you take advantage of Tooltips and the What’s This? feature.

When you hover the mouse pointer over a Toolbar tab button it should bring up a terse description of what that button does.

What’s This? is invoked by the Menubar Help → What’s This? item or by Shift+F1. It changes the cursor to show a question mark alongside the arrow.

When this question mark is visible, a left mouse button click won’t actually do anything until you have clicked on a control (or the text alongside it) that supports What’s This?, in which case it will display a reasonably comprehensive description of what the control does. Most of the dialog boxes that Konqueror brings up support the What’s This? feature.

2.4 Left and Middle Mouse Button Actions

If you click the left mouse button on an item in Konqueror’s window, it will be ‘activated’. Thus

• Left click on an icon in the Toolbar to perform the action that icon represents.

• Left click on an item in the Menubar to make that menu drop down.

• Left click on a menu item to do that thing.

• Left click on an icon in the Bookmark Toolbar to open that URL.

• Left click on a link in a web page to make Konqueror follow that link.

• Left click on a folder icon or name and Konqueror will descend into (show the contents of) that folder.

• Left click on a file name or icon and Konqueror will do whatever it thinks appropriate, based on the file type. In general this means opening HTML pages, or previewing text, image or Okular documents, showing them within Konqueror’s window (‘Preview’ means that you can see the file but not change it).

Konqueror decides what the file type is by matching the filename extension against a list of known types. If that fails it tries to guess the type from the file contents. You can change the list of known file types and associated actions with the File Associations page of the Settings → Configure Konqueror... dialog.
Clicking the middle mouse button on a file or folder name or icon does essentially the same as left clicking except that it usually does it in a new Konqueror window, unless the **Open links in new tab instead of in new window** box has been checked in the **General** page of the **Settings → Configure Konqueror...** dialog. Konqueror can open links on pages and **Bookmarks**, as well as the **Home, Up, Back and Forward** entries in a new tab or window.

Holding the **Shift** key down while pressing the middle mouse button will open the link in the background.

## 2.5 Right Mouse Button Menus

Clicking the right mouse button on almost any part of Konqueror’s window will bring up an appropriate context menu.

**NOTE**

If you have enabled the **Right click goes back in history** option in Konqueror’s **configuration** settings a simple right click is equivalent to clicking on the **Back** button. In this case you can access the context menu by moving the mouse with the right button held down.

**On the Titlebar**

Right clicking on any free area of the Titlebar brings up the Titlebar Menu, allowing you to control the position of Konqueror’s window as well as the decoration applied to all KDE program windows.

**On the Main Toolbar**

Right click on any free area of the Toolbar to bring up the Toolbar Menu. You can also use the Toolbar Menu to set the size of the buttons on the Toolbar, and whether they are shown as icons, text or both.

Unlock the toolbar and you can move it to the top, bottom, left or right of Konqueror’s window.

**On the Location Toolbar**

Right click in the URL entry box area to perform Cut, Copy, Paste or Clear operations in this area, or to change the automatic **Text Completion** features.

**Within a View**

If you right click on any free area of a view then you will get a menu that contains, among other options, the **Up, Back, Forward and Reload** navigation commands.

**On a File or Folder**

This is a most useful feature. Right clicking on the name or icon of any file or folder not only ‘selects’ that item but also brings up a menu allowing you to **Cut, Move, Copy or Remove** the item in various ways, open it with the program of your choice or preview it, rename it, or edit the file type or properties.

**On the Status Bar**

Right click on the Status Bar at the bottom of a window or view to add or remove a view and lock or link views within Konqueror’s window.
2.6 Viewing Help, Man and Info Pages

You can view KDE Help and UNIX® Man and Info pages directly in Konqueror, without having to start up KHelpCenter.

To view a KDE Help page, enter `help:/ application name` (for example `help:/ kmail` to view the KMail documentation.) into Konqueror’s Location Toolbar window.

If you want to read UNIX® Man pages Konqueror makes it easy. For example type `man:/touch` or `#touch` into the Location Toolbar to see the page for the `touch` command.

To browse through UNIX® Info pages, entering `info:/dir` takes you to Info’s top level directory, then it’s just a matter of clicking on the right links to find the page you want. Alternatively, use `info:/ command name` to go straight to the Info page you want.

**NOTE**
Unfortunately, KDE Help pages are stored in such a way that they cannot be viewed in other browsers. If you really need to do this your only recourse is to go online and visit [http://docs.kde.org](http://docs.kde.org).
Chapter 3

Konqueror the File Manager

Pamela Roberts

3.1 Folders and Paths

In UNIX® and Linux® all folders are arranged in a simple hierarchy. Starting from a top level folder (also called the root directory), the structure descends and branches containing various files and subfolders. This means that you can get from any folder to any other by going ‘up’ until you reach a common point then ‘down’ through the appropriate subfolders until you reach your target.

The position of any file or folder in the structure (also called a directory tree) can be described by its ‘path’, which is a simple list of the folders you would have to descend through to get to the target folder or file. For example /home/pam is the subfolder pam of the subfolder home of the top level folder, and /home/pam/words.txt is the file words.txt in that subfolder. The leading ‘/’ in these paths represents the top level folder.

Every folder accessible by your system — including those on other hard disk partitions, a USB device or CD-ROM — will appear in the tree descending from /, their exact paths will depend on how your system was set up (see also the section on Removable Devices).

Every user on a UNIX® / Linux® system has their own ‘home’ folder to hold their personal files and settings; for example /home/john and /home/mary. The symbol ~ is often used to represent the user’s home folder, so that ~/letter.txt refers to the file letter.txt in my home folder.

Note that the term ‘directory’ is often used instead of ‘folder’.

3.2 View Modes

In File Manager mode, Konqueror lists which files and subfolders are contained within a given folder and can provide you with some information about them. The ‘path’ of the current folder is shown in the Location Toolbar. The way that Konqueror displays the files and folders depends mainly on your choice of view mode which can be selected from the View → View Mode sub menu. The view modes Konqueror provides are outlined below.

Note

In File Manager mode, Konqueror uses an embedded Dolphin component.
In the Icons view, which is the default, files will be represented by an icon that visualizes the file type, and a folder icon will be shown for subfolders. The names of folders and files, and the items enabled in View → Additional Information, are displayed below the icons.

The Compact view shows the folder contents as icons with the name beside it and the items enabled in View → Additional Information below the name. The items are grouped in columns similar to the Short View in the KDE file dialog.

In the Details view, the folder contents are displayed as a detailed list which contains the name, size and last modification time of each item. Additional columns can be added by clicking a column header with the right mouse button.

In the context menu of the header line you can choose between custom or automatic column width. Automatic width adjusts the width of all columns once to display the longest item in the column completely, except for the Name column where the extension is replaced by ‘...’

The order of columns can be changed by drag and drop of column headers, except for the Name header, which is always the first column in this view.

The details view allows you to view the current directory in a tree-like fashion if Expandable folders are enabled: Each subfolder of the current folder can be ‘expanded’ or ‘collapsed’ by clicking on the > or v icon next to it.

All view modes support grouping by the sort type selected in View → Sort by

3.2.1 File Tip Info

Checking the Show tooltips box in the File Management → General page of the Konqueror Configuration dialog causes a small pop up information window to appear when the mouse pointer is hovered over a file or folder name or icon.

3.2.2 File Previews

The Previews tab of the File Management → General settings page lets you enable file previews for certain types of file.
Generally this means that the file’s icon will be replaced by a small image showing the file contents.
Because Konqueror has to read much more data than just the file name to generate a preview, file previews may not be appropriate when viewing files from a remote system. To disable previews for remote files where reading the extra data would take too long set a file size limit at the bottom of the Previews tab.

3.2.3 Information in the View

In all view modes Konqueror shows at least an icon and a name for each item. Using Additional Information in the View menu or the context menu of the header in Details mode, you can select more information for each item to be shown: Size, Date, Type, Rating, Tags or Comment.
Depending on the file type, additionally, the following criteria can be selected:

- **Document**: Number of words and lines
- **Image**: Size and orientation
- **Audio**: Artist, album, duration and track

The Other submenu allows to select Path, Link Destination, Copied From, Permissions, Owner or User Group.

3.3 Folder View Properties

The following settings control how the contents of a folder are displayed in the Konqueror view, and are stored on a per-folder basis by default:

- The view mode (Icons, Compact, Details)
- The sorting of items, which is determined by the sort order (ascending, descending) and the attribute (such as name, size,...) that the items are sorted by
- Sorting of folders and files – are folders shown first or not?
- Previews – are they shown instead of icons (based on the settings made in Previews tab of Konqueror’s General settings) or not?
- Are items shown in groups in the views?
- Are hidden files shown?
- What additional information (besides the name) is shown in the Icons or Details view?

The view properties can be configured in the View menu, some (such as the view mode) can also be changed using toolbar buttons.
3.3.1 The View Properties Dialog

The View Properties dialog can be used to quickly modify several view properties at once. This is done for the current folder, for the current folder including all subfolders, or even for all folders, depending on the choice made in the Apply View Properties To section.

If Use these view properties as default is enabled, the chosen view properties will also be used for all folders which do not have customized view properties yet.

3.4 Navigation

To get to a file with Konqueror you first need to navigate through the folder tree to find the folder containing that file.

To move between folders you can simply step up and down the tree:

- To descend into a subfolder left click on its name or icon -- or if you have already ‘selected’ it (see below) -- then just press Enter.
- To go up the folder tree you can click on the Up button in the Toolbar, use Alt+Up, or use the Menubar Go → Up option.

To ‘select’ a file or folder in the displayed folder without opening it in any way use the up and down arrow keys to move through the items. The selected item will be highlighted and some information about it will be displayed in the Status Bar.

Setting the View Mode to Details can help you locate folders in the tree below the current folder; in this mode each folder is shown with a small box at the left. If the box contains a > sign, left clicking on the box (not on the folder name or icon) will display a sub tree showing files and subfolders contained in that folder. The small box will then change to show a v sign. Left click on that to collapse the sub tree. Once you have found the folder you are looking for, left click on the folder name or icon to open it.
You can go directly to any folder by switching with File → Open Location or Alt+O to the Location Bar and typing its path. Konqueror’s Text Completion feature may be useful when you do this. Don’t forget that in Linux®/UNIX® file and folder names are case sensitive.

When you have moved to a new folder you can go back to your previous choice by using the Toolbar Back button, the Menubar Go → Back item, or Alt+Left. Once you have gone back you can go forward. Use the Toolbar Forward button, the Menubar Go → Forward item or Alt+Right. Alternatively, you can also choose to enter the parent folder by clicking on the Toolbar Up, the Go → Up item, or with Alt+Up.

**Tip**
Click the checkmark at the right of the toolbar Up, Back or Forward buttons or selecting these items in the Go menu brings up a submenu of recently visited locations.

### 3.4.1 Finding Files and Folders

If you don’t know or can’t remember where a file or folder is within your system, then use the shortcut Ctrl+F or the Menubar Tools → Find File... option. This starts the file finder application KFind. See the KFind Handbook for help in using KFind.

**Note**
If the name of a file or folder begins with a period (dot), then it is a 'hidden' file or folder, and will not normally be shown by Konqueror. To see hidden files or folders use the Menubar View → Hidden Files option.

Another reason Konqueror may not show the file or folder you are looking for is that you may have the Directory Filter plugin set to display only certain types of file.

### 3.4.2 Removable Devices

Any removable device (USB stick, floppy disk, CD drive or other hard disk partition that you have on your system) will usually appear in the /media, /mnt or /auto folder, having a path something like /mnt/floppy or /cdrom. The details will depend on how your system was set up.

UNIX®/Linux® requires that you mount a removable device when you have inserted it into the drive, and mount other hard disk partitions when you want to access them. You also need to unmount a removable device before removing it to register that it is no longer available.

How you do this will depend on your system setup:

- **Using the Device Notifier**
  In a KDE session the Device Notifier window will popup, when you insert a removable device and allows you to select an appropriate application for this media or only mount the device.

- **If you use the Folder View layout for your desktop you may have icons for removable devices on your desktop, in which case left mouse button click on the icon to mount it. Doing this should also bring up a Konqueror window showing the contents of the device. To unmount, right click on the icon and choose the Unmount item. Visit the section Create New... in this Handbook to see how to create such an icon.**

- **Or you can do it the traditional way by typing into a text console window:**
  ```
  mount /mnt/floppy
  ```
  to mount, for example, the floppy drive, and
  ```
  umount /mnt/floppy
  ```
  to unmount it (umount not unmount).
3.5 Deleting Files and Folders

Konqueror gives you two ways to dispose of an unwanted file or folder:

- You can move it to the Trash folder, which is the safest method as you can get it back if you realize that you have made a mistake.
- You can just plain Delete it, which removes the entry from the folder and adds the disk area occupied by the file(s) to the system’s list of free disk areas, in the same way as the rm command.

If you want to use this feature check the option Show ‘Delete’ menu entries which bypass the trashcan on the File Management settings page.

The simplest way to remove a file or folder is to position the mouse pointer over its name or icon and press the right mouse button, which will bring up a menu containing the options Move to Trash and Delete.

Or, if you have ‘selected’ the item, the Menubar Edit menu will give you the choice of ‘Move to Trash’ and ‘Delete’ options.

Del will move the selected item or items to Trash.

Shift+Del will really, truly and irrevocably delete the selected item or items.

3.6 Moving and Copying

To copy a file or subfolder between folders you can:

- Position the mouse pointer over its name or icon and hold down the right mouse button, which will bring up a menu containing the Copy option. Choose that.

Or if the item is ‘selected’ you can use the Copy button on the Toolbar or the Menubar Edit → Copy item, or the Ctrl+C shortcut key combination. You can also select multiple files or folders to copy/move as well.

- Navigate to the folder you want to copy the item into then Paste the item into the new folder by using the Toolbar Paste button or the Menubar Edit → Paste option or the Ctrl+V shortcut, or by moving the mouse pointer to a clear area of the window and holding the right mouse button down to bring up a menu containing the Paste option.

Moving a file or subfolder between folders can be done in the same way as copying, except that you choose the Cut option or Ctrl+X instead of Copy. The item that you have Cut will be removed from the original folder when you do the Paste into the new folder.

You can also copy or move selected item(s) to another folder by selecting Copy To or Move To from the context menu you get when you right click on a file or folder name in the File Manager window.

To enable this feature select Show ‘Copy To’ and ‘Move To’ commands on the File Management → Services page of the settings.

You may not be able to copy or move a file or folder if you don’t have the necessary permissions.
3.6.1 Using Drag ‘n Drop

Konqueror also supports Drag and Drop copying and moving of files and folders. You can do this by having two instances of Konqueror, one showing the folder you want to copy from, the other showing the target folder. Position the mouse pointer over the item you wish to copy or move, then, holding the left mouse button pressed, ‘drag’ it to a clear space in the target folder. Release the button and you will be presented with a menu choice of Copy Here, Move Here or Link Here. Take care to ‘drop’ the item into an empty area of the target folder view - dropping it on top of a subfolder will copy or move the item into that folder.

You can also set up Konqueror to show more than one folder within its window and drag & drop between them.

This screenshot illustrates the use of the Menubar Window → Split View Left/Right option, also available with the shortcut Ctrl+Shift+L, to split the main Konqueror window into two views, each showing the contents of a different folder.

To be able to show different folders in each view they should not be linked; the little boxes at the bottom right of each view should be empty.

The ‘active’ view, that is the one whose path is shown in the Location Toolbar and which responds to navigation and Menubar commands, is shown by the little green light in the bottom left corner. To make a view active, left click on an empty area of the view or on its Status Bar.

To remove an active view from Konqueror’s window use the Ctrl+Shift+W shortcut, or the Menubar Window → Close Active View option, or right mouse button click on the Status Bar and choose the Close View option from the resulting menu.

If you use Konqueror tabs, you can drag and drop between tabs by dragging the file to the tab label, without letting go yet. The destination tab will pop to the front, allowing you to continue dragging and then to drop the file.

3.6.2 Duplicate File or Folder Names

If you try to paste a file or folder into a folder that already contains an item with the same name, Konqueror will pop up a dialog box warning you that the item already exists. You can then choose to:
The Konqueror Handbook

- Cancel the paste operation by pressing the Cancel button.
- Give the item that is being copied a different name. You can do this by typing a new name into the text entry box or get Konqueror to Suggest New Name. When you have done this press the Continue button.
- If you have copied multiple items, Skip the current item.

The Apply to All button can be used if you have copied multiple items.

3.7 Selecting Items in the View

There are several ways to select items in the view. Once a group of items is selected, all actions, such as Cut, Copy, Move to Trash, and drag and drop operations, affect all selected items.

3.7.1 Selecting Items Using the Mouse

- You can press the left mouse button somewhere in the view and draw a rectangle around a group of items before releasing the button. This will select all items in the rectangle and clear the previous selection. If the Shift key is pressed during the selection process, the previous selection is kept.
- If the Ctrl key is pressed while an item is clicked with the left mouse button, the selection state of this item is toggled. If the Ctrl key is pressed while a rectangle is drawn around a group of items as described above, the selection state of all items in the rectangle will be toggled.
- If the Shift key is pressed while an item is clicked with the left mouse button, all items between the previous current item and the clicked item will be selected.
- If Show selection marker is enabled in the Behavior tab of the File Management → General section of the settings, a small + or - button appears in the top left corner of the item which is currently hovered over with the mouse. Clicking this sign selects or deselects the item, respectively.

3.7.2 Selecting Items Using the Keyboard

- If an arrow key, PgUp, PgDn, Home, or End is pressed, the new current item is selected, and the previous selection is cleared.
- If the Ctrl key is held while one of the above keys is pressed, the selection remains unchanged.
- If the Shift key is held while one of the above keys is pressed, all items between the previous current item and the new current item will be selected.
- If Ctrl+Space is pressed, the selection state of the current item is toggled.
- Ctrl+A selects all items in the view.
- Ctrl+Shift+A toggles the selection state of all items in the view.
- Select a file or folder by typing the first few letters of its name and the first matching item is selected. To clear the selection and cancel the keyboard search press Esc or wait longer than the timeout of 1 second.
3.7.3 Selecting Items Using the Menu

You sometimes want to delete, copy or move a number of files that are similar in some way. For example you may wish to move all of the .png graphics files from one folder to another. Konqueror makes this easy by letting you select multiple files based on similarities in their file names.

Use the Menubar Edit → Selection → Select Matching Items... option or the shortcut Ctrl+S. This brings up a little dialog box in which you enter a filename containing the wildcard characters *, which matches any number of characters, and ? which matches a single character. Press OK and Konqueror will highlight all files with matching names. For example:

- **flag*.png** will select all filenames starting with the letters ‘flag’ and ending with ‘.png’.
- **memo?.txt** will select memo1.txt and memo9.txt but not memo99.txt.

When you have selected a range of files, you can narrow down the selection by using the Menubar Edit → Selection → Unselect Matching Items... option to specify which of the selected files should be removed from the selection.

Use the Menubar Edit → Selection → Unselect All option or just left mouse button click on a clear area of the view to cancel the selection.

You can even invert the selection: that is, deselect all selected files and select those that were previously unselected. Use the Menubar Edit → Selection → Invert Selection option or Ctrl+Shift+A to do this.

3.8 Create New

When Konqueror is in File Manager mode, picking Create New from the Edit menu or from the context menu you get by right mouse button clicking on a free area in a folder view gives you a submenu letting you create any of the following in the current folder:

**Folder...**
- An easy way of creating a new (sub)folder.

**Text File...**
- Use this to create an ordinary, empty, text file. A dialog box will be opened for you to enter the name of your new file.

**HTML File...**
- Creates a skeleton HTML source file. When you type the new file’s name into the dialog box it is probably best to give it a .html extension to avoid confusion.

**Type of Document Document...**
- Depending on the installed applications and file associations several menuitems for different types of documents are displayed and enable you to create skeleton documents of the selected type.

**Link to Location (URL)...**
- This lets you create an icon to open Konqueror at a particular folder or web page. As with Link To Application... you can make the application icon appear on your desktop by creating the link in your ~/Desktop folder or going to the Create New... sub menu by right clicking on a free area of the desktop.

**Basic link to file or directory...**
- Create a symbolic link for local files or folder.
Link to Application...

This option is most useful if you want to create an icon that will open a particular application. It opens a dialog box with several tabbed pages. The first, General, is where you choose an icon and the text that will appear with it. The second page, Permissions, lets you select who can use or modify the icon. In the Application page you must enter the Command that will run the application, for example, kwrite to start up the KWrite text editor. 

\texttt{kwrite /home/pam/todo.txt} would open the file /home/pam/todo.txt in KWrite. Advanced options such as the file types which the application can open are also available from this page.

To make the application icon appear on your desktop, create the link in your ~/Desktop folder (this may be called something slightly different depending on how KDE was installed on your system) or get to the Create New... sub menu by right clicking on a free area of the desktop instead of within Konqueror’s window.

If you have a lot of specialized application links and don’t want to clutter up the desktop, then why not create them in your Applications folder. You can get there in Konqueror by choosing Go → Applications. Then create a single icon on your desktop to open your Applications folder, which is usually in ~/\.local/share/applications.

To put an application link icon into the panel, first create it in the Applications folder then drag the icon onto a clear area of the panel.

Link to Device

Use the options in this submenu to create an icon that will mount a device and open an instance of Konqueror showing it’s contents. To unmount the device when you have finished with it right click on the icon and select Unmount. However, in most cases you will want to create the icon on your desktop.

3.9 Changing Names and Permissions

The two easiest ways to change the name of a file or folder is to either right click on it and select Rename, or select the file or folder and then press the F2 key.

To change the name or permissions of a file or folder right click on its name or icon and select the Properties item, or if you have ‘selected’ the file or folder, then you can use the Menubar Edit → Properties (Alt+Return) option.

This will bring up the Properties dialog box with several tabbed pages:

- General, which gives you some information about the item and lets you change its name and, for a folder, the associated icon.
- Permissions, which shows you the item’s ownership and access permissions and lets you change the permissions.

3.9.1 Copy and Rename

If you want to make a copy of an existing file with a different name -- perhaps as a backup -- in the same folder as the original file, do a normal Copy then when you Paste it a dialog box will pop up complaining that the file already exists. Just type the new name into the dialog’s text box and press the Continue button (or if you are feeling lazy pressing the Suggest New Name button will generate a new name for you).
3.10 Configuring File Associations

KDE provides many applications which can open many different types of file. Most of the time, the defaults will work with no problems, but Konqueror provides a powerful system to allow you to change the applications used to open each file type. For more details, choose the Settings → Configure Konqueror... menu item, select File Associations in the configuration dialog, and click on Help.

3.11 At the Command Line

Although Konqueror is a very powerful and flexible GUI file manager, there are occasions when the experienced Linux® / UNIX® user wants to get down to the basics and work at the text command line level.

You can, of course, open an instance of Konsole, perhaps with Konqueror’s Menubar Tools → Open Terminal option or with F4.

If you only want to launch a program or view a URL, the Tools → Execute Shell Command... (Ctrl+E) option may be easier.

Tools → Execute Shell Command... (Ctrl+E) opens a small command line dialog window where you can enter a shell command such as `ps -ax | grep kdeinit`. Note that it does not support full featured terminal control characters, so applications such as `top` and `less` will not work properly, but it is available immediately without the delay involved in starting Konsole.

For more complex operations, Konqueror has another nice feature: the Menubar Settings → Show Terminal Emulator option, which opens up a terminal window as a new view within Konqueror.
Chapter 4

Konqueror the Web Browser

Pamela Roberts

4.1 Connecting to the Internet

Once you are connected to the Internet you can use Konqueror to browse the Web just as easily as you can use it to handle your local files. Just type a URL into the Location Toolbar window, press Enter, and you are away!

- If you use a dial-up modem connection, then you will be using KPPP or a similar dialer program to make the connection.

- If your machine is connected to a local area network (LAN) that gives you a proxy connection to the Internet then you will have to set Konqueror up for the proxy connection. This can be done with the Web Browsing → Proxy page of the Settings → Configure Konqueror... dialog.
If you are lucky enough to have a high speed cable connection, then the service provider will probably give you an external cable modem which needs an ethernet connection to your machine. Unfortunately the details of how to establish the connection depend on the service provider and to some extent on which Linux/UNIX® distribution you are using. Some ISPs connect their customers to the Internet through a proxy server, in which case you will have to set up Konqueror to use it. You may find it useful to search the archives of your distribution’s user group mailing list for help.

**NOTE**

An error message such as Unknown Host usually means that Konqueror cannot find a connection to the Internet or that you have entered an incorrect URL.

### 4.2 Surfing and Searching

Once you have a connection to the Internet, you can surf with Konqueror just as you can with any other browser.

Type a URL into the Location Toolbar window, press **Enter** or left click on the **Go** button at the right hand end of the Location Toolbar, and Konqueror will download and display that page. If you have visited the page before, Konqueror’s Automatic Text Completion feature can help you type the URL a second time. If you want to use one of the web’s search engines, Konqueror’s Web Shortcuts feature can make this easier.

Left click on a link in a page to open that link.

To open a link in a new instance of Konqueror, leaving the old page still visible, right mouse button click on the link and select the **Open in New Window** option. Alternatively, you might want to **Open in New Tab**. **Tabbed Browsing** will let you hold a number of pages in one Konqueror window and quickly switch between them with a single mouse click.

You could also select multiple view modes with **Window → Split View Left/Right (Ctrl+Shift+L)** / **Window → Split View Top/Bottom (Ctrl+Shift+T)** option which will let you see different pages at the same time. This can be useful if you are looking through a complicated set of HTML pages, but make sure the little link box at the bottom right hand corner is empty when you are doing this.

To go back to the previous page use the **Alt+Left** shortcut, the **Back** button on the Toolbar, or the menu bar **Go → Back** option.

Similarly, once you have gone back you can go forward by using **Alt+Right**, the **Forward** button, or the menu bar **Go → Forward** option.

There are multiple ways of scrolling the viewing area. One is to use the **Up** and **Down** keys. You may also use the scrollbar, your mousewheel or the **PgUp** and **PgDn** keys.

If you want to read a long webpage use the automatic scrolling feature of Konqueror. Start automatic scrolling with **Shift-Down** or **Shift-Up**. Then use these keys to increase and decrease the scrolling speed. You can start or stop automatic scrolling temporarily by pressing the **Shift** key; pressing any other key deactivates this feature.

Automatic scrolling works only in the view mode KHTML.

If you want to stop a download for any reason then use the **Esc** key, the Toolbar **Stop** button or the Menu bar **View → Stop** item.

When you are viewing a web page with the **HTML Toolbar** enabled you should see two new icons in the toolbar and . Use these to adjust the size of the text in the page if you find it difficult to read. How well this works will depend on how the web page has been constructed.
4.3 Tabbed Browsing

By using this feature you can make Konqueror load multiple web pages in the same window, and switch between them using tabbed pages. This way, you can preload a page ‘in the background’ while you carry on reading another.

To use tabbed browsing, right click on a link and choose Open in New Tab from the drop down menu or middle mouse button click. The page will be downloaded and displayed as normal, but with tabs across the top of the view, one tab for each page. Left mouse button click on a tab to view that page, or you can use the shortcuts Ctrl+, and Ctrl+. to cycle through the tab pages. Alternatively, you can scroll through the tabs using the mouse wheel while the mouse pointer is over the tab bar (assuming that your mouse has one). Also, double-clicking over the empty tab bar space will open a new tab.

Using the Open new tabs in the background option in the General page of the Settings dialog, clicking on a link downloads the page and shows a new tab for it, but the new page will not be displayed until you left click on the tab.

If you check the Open links in new tab instead of in new window box in the General page of the Settings → Configure Konqueror... dialog, middle mouse button clicking on a link will open it in a new tab page and if you hold the Shift key down while clicking the middle mouse button the link will be opened in a background tab page.

Right clicking on a tab will bring up a menu with the following options:

New Tab (Ctrl+T)
This opens a new, blank, tabbed page view. You can then download a web page into it by typing the URL into the Location Bar or by making a selection from the Bookmark Toolbar.

Duplicate Tab (Ctrl+D)
To create a duplicate tabbed page.

Reload Tab (F5)
Reloads the content of the current tab.

Other Tabs
Displays a submenu showing all other tabs. Choosing a tab from this list makes it the active tab.

Other Tabs → Reload All Tabs (Shift+F5)
Reloads the content of every tab.

Other Tabs → Close Other Tabs
To close all but the selected tab page.

Detach Tab (Ctrl+Shift+B)
This option removes the selected tabbed page from the current Konqueror window and opens it in a new instance of Konqueror.

Close Tab (Ctrl+W)
To close the selected tab page.

4.4 Web Shortcuts

If enabled, Konqueror’s Web Shortcuts feature lets you submit a query directly to a search engine or similar web site without having to visit the site first.

For example, entering gg:konqueror into the Location Bar and pressing Enter will ask Google™ to search for items related to Konqueror.

To see what Web Shortcuts are available, and perhaps add your own, open the Web Shortcuts module in the System Settings category Workspace.
4.5 Access Keys

Konqueror has full support for the accesskey HTML attribute in forms and links. Access keys allow you to use the keyboard keys for functions which would perhaps normally be done with the mouse, such as following links. The benefit of this is, quite simply, that users can interact with a page with devices other than a pointing device.

This feature has to be enabled by checking the Enable Access Key activation with Ctrl key option on the Web Browsing settings page.

To activate the access keys in Konqueror, press and release Ctrl. Once this is pressed, if a particular link on the website has the accesskey attribute in the given link, then the character(s) should appear over the link, identifying what needs to be pressed. Then, you can enter the character(s) associated with the link as an alternative to following the link with the mouse. To disable the access keys once activated you can press Ctrl again.

NOTE
The proper use of this feature requires that the web designer of the page has specifically assigned, using the accesskey attribute, an access key for the link. Many web designers might not include the accesskey in their links and forms, and consequently this feature will be unusable on the given webpage.

4.6 Browser Identification

When Konqueror connects to a web site it sends some brief browser identification information, known as the 'User Agent' string. Many web sites use this information to customize the pages that they send back, based on the strengths and weaknesses of different browsers.

Unfortunately, some badly designed sites refuse to work properly unless you are using a browser that the site recognizes as a 'valid' one, even though if given a chance, Konqueror will work satisfactorily with the vast majority of web pages.

To overcome this problem you can change the browser identification information that Konqueror sends for specific sites or domains by selecting the Browser Identification module in the System Settings category Network.

NOTE
Problems with getting a web page to work properly may also be due to its use of Java™ or JavaScript. If you suspect that this may be the case check that they have been enabled in the Java & JavaScript section of the settings dialog.

4.7 Saving and Printing Web Items

When you are viewing a web page you can save it (or at least the basic HTML or similar source text) to your local disk with File → Save As... If the page you are viewing uses frames, then you will also be given the File → Save Frame As... option. Left click in the frame you want to save first. If the page uses a background image, you can get and save that with the File → Save Background Image As... option.

But if what you really want is that glorious picture of the latest Ferrari, then right clicking on the image will give you a drop-down menu with a Save Image As... option. Be sure to respect the owner’s copyright, and ask for permission before using any pictures saved this way for anything other than your own viewing pleasure.
If you right click on a link (which may be a picture) and select **Save Link As...** from the pop up menu the basic HTML or similar source text will be downloaded and saved on your local disk.

Right clicking on a link (which may be a picture) and choosing **Copy Link Address** will copy the URL of the link to the clipboard so you can then paste it into, say, an e-mail to a friend telling her about this wonderful new site.

Right clicking on a picture and choosing **Copy Image** copies the URL of the picture to the clipboard.

Printing a copy of the page you are viewing is easily done with the Menubar **File → Print...** or **Print Frame** option or with the Toolbar **Print** button.

### 4.8 FTP

FTP, or File Transfer Protocol, is one of the earliest, and still perhaps the best, way of transferring files between computers over the Internet.

With FTP you can see files and folders on the distant computer just as if they were on your own system, download them onto your computer using Konqueror’s normal **Copy** and **Paste** or **Drag n’ Drop** methods and, if allowed, upload files from your machine to the other computer’s filesystem. To try it, type the URL

```
ftp://ftp.l10n.kde.org
```

into the Location Toolbar and press **Enter**. As long as you are connected to the Internet, you should end up seeing the `ftp` folder of the l10n server.

**NOTE**

Although, strictly speaking, FTP URLs should be entered starting with **ftp://** and WWW URLs starting with **http://** Konqueror is usually smart enough to figure out what is meant, and insert these characters for you if you leave them out.

When you access an FTP site it will usually need some form of username and password from you. To simplify things, most FTP sites that offer files for free downloading will accept the word **anonymous** as a username and your email address as a password, and to make your life even easier Konqueror will automatically supply these without troubling you.

**NOTE**

If you try to access an FTP site that does not need a proper username or password but which is too busy to accept any more connections, Konqueror often interprets the ‘busy’ message as a request for a name and password and will therefore pop up a dialog box asking you to supply them.

Sites that are more concerned with security will need a proper username and password, in which case Konqueror will ask you for them or you can include the username in the URL you type into the Location Toolbar, as for example

```
ftp://username@ftp.l10n.kde.org
```

Konqueror will then prompt you for the password.

Konqueror can also support automatic logins as specified in a `.netrc` file. Details of how to enable this feature are given at [https://konqueror.org/faq/#DoesKonquerorsupportautomaticftploginsvianetrcfiles](https://konqueror.org/faq/#DoesKonquerorsupportautomaticftploginsvianetrcfiles)
4.9 URLs with Port Numbers

If you specify a port number in your URL, as in for example http://intranet.corp.com:1080, you might get the error message ‘Access to restricted port in POST denied’. This is done for security reasons. If you nevertheless need to access a server on this port, just add a key line

```
OverridenPorts=CommaSeparatedListOfAllowedPorts
```

to kio_httprc in the folder $(qtpaths --paths GenericConfigLocation).

For example

```
OverridenPorts=23,15
```

(it should not include any embedded spaces).

Konqueror will reject the following ports:

Chapter 5

Automatic Text Completion

Pamela Roberts

You can get Konqueror to help you enter a path or URL into the Location Toolbar by enabling one of the Text Completion features. To do this right click on a clear part of the Location Toolbar text entry box and select Text Completion from the pop up menu. This will let you choose between the following options:

None
What you get is what you type.

Manual
When you have typed part of a path or URL, pressing Ctrl+E or Tab will complete the entry if it is possible to do so unambiguously.

Automatic
As you type into the Location Toolbar window Konqueror will automatically extend what you type to complete one possible path or URL, highlighting the characters it has added. Continue typing if that’s not what you wanted or press Enter to accept it.

Dropdown List
A drop-down window will appear as you type, showing the possible matches to what you have typed so far. When the path or URL that you want appears in the window click on it with the left mouse button. You can also use the Down or Tab and Up or Shift+Tab keys to select it then press Enter.

Short Automatic
This is like Automatic mode except that it only extends what you have typed as far as the next / symbol in the path or URL. Press Ctrl+E or Tab to accept the suggestion, Enter when the complete path or URL is shown.

Dropdown List & Automatic
This is a combination of both options described above.

Default
This item appears at the bottom of the submenu and enables you to switch to the default behaviour Dropdown List.

You should try out these different modes and pick the one that suits you best.
Chapter 6

Using Bookmarks

Pamela Roberts

Although you can use Konqueror’s bookmarks to record the locations of your own files and folders, they are most useful when you are surfing the Web, letting you build up a list of useful sites.

To open the Bookmarks menu left click on the Bookmarks menu. Once the list is visible, you can navigate through it with the arrow keys or with your mouse, then press Enter or left click to visit the selected location.

To add a new item to the list use Bookmarks → Add Bookmark or Ctrl+B or right click on a clear space in the web page or folder view and select Bookmark this Page from the pop up menu.

The Bookmarks list can contain subfolders containing other bookmarks, you can create these with Bookmarks → New Bookmark Folder... To add a bookmark into a subfolder rather than into the main Bookmark list, select the folder from within the Bookmarks list and use the Add Bookmark item in that folder.

If you enter bookmarks: in the location bar the bookmarks home page with an overview of all bookmarks and folders is shown.

If you want to edit your bookmarks use the Bookmark Editor
Chapter 7

Saving Settings

Pamela Roberts

You can specify different View menu settings for an individual folder. To do this select View → Adjust View Properties..., change the View settings in the dialog to whatever you want. Then apply the view properties to the Current folder. Doing this creates a .directory file in that folder to hold the folder View settings. Use this dialog again to remove the folder specific settings (or just delete the .directory file).

**NOTE**

One nice use of this feature is if you have a folder full of pictures, you can set that particular folder to display thumbnails of the pictures (by choosing the View Mode → Icons and Preview from the View menu) when you open it, while not displaying images as thumbnails in other folders.
Chapter 8

Plugins

Pamela Roberts

8.1 Konqueror Plugins

KDE releases several useful plugins that interact with Konqueror in various ways. These are explained briefly below.

Use Settings → Configure Extensions... to open a dialog with all installed plugins and select the ones you need. All plugins are accessible in the Tools menu.

Only plugins appropriate for the current mode (file manager or browser in KHTML/WebEngine view) are listed in the dialog.

**BROWSER MODE**

Web Page Translation

This uses the machine translation service provided by Google Translate to translate the current HTML page to whatever language you want (within reason). It can be launched with Tools → Translate Web Page.

If you have a portion of the text on the page selected, that will be translated instead of the entire URL.

**IMPORTANT**

Machine translation is not a perfect science! Google will at best give you a rough translation, and at worst will give you a very funny read. Don’t base important decisions on things you have read from a Google translated page, without confirming that the translation is indeed accurate.

**NOTE**

You may only translate web pages that are accessible on the world wide web. To translate any other text, you should go directly to the Google site itself, where you are able to paste in text for translation.

HTML Settings (KHTML view)

Select Tools → HTML Settings to enable or disable a number of HTML settings without going through the Settings dialog.
JavaScript
   Allows you to turn the use of JavaScript in Konqueror on or off.

Java
   Allows you to turn the use of Java™ in Konqueror on or off.

Cookies
   Allows you to turn the use of Cookies in Konqueror on or off.

Plugins
   Allows you to turn the use of the Konqueror plugins you have installed on or off.

Autoload Images
   Allows you to turn on or off the loading of images in web pages.

Enable Proxy
   Allows you to enable or disable the use of a proxy in the Konqueror browser.

Enable Cache
   Allows you to enable or disable the use of a cache in the Konqueror browser.

Cache Policy
   The Cache Policy submenu provides you with a way to configure how Konqueror uses a cache. The possible uses include:
   • Keep Cache in Sync
   • Use Cache if Possible
   • Offline Browsing Mode

Auto Refresh (KHTML view only)
   This works on any readonly part (though currently it only plugs into khtmlpart). It lets you tell Konqueror to refresh a page automatically after a specific period. This is useful for things like news pages, and should be very nice for people using Kiosk mode

FILE MANAGER MODE

Directory Filter
   This is controlled by Tools → Show Filter Bar (Ctrl+Shift+I) and allows you to choose which types of item are displayed in a folder.

Image Gallery
   In File Manager mode, you can select Tools → Create Image Gallery or use Ctrl-I to create an HTML page with thumbnails of all the images in the current folder. By default the HTML page is called images.html and the thumbnails are put into a new images folder.
   When you start the Image Gallery plugin a dialog opens allowing you to adjust the way the gallery is created.

PAGE LOOK

The Look dialog is for adjusting the appearance of the gallery page.
Page title
The Page title option has a text input box for changing the title of the image gallery page.

Images per row
The Images per row option has a slider and a spin box for adjusting the number of thumbnails that are in a single row in the gallery.

Show image file name
The Show image file name check box allows you to choose whether to display filenames below the gallery thumbnails.

Show image file size
The Show image filesize check box allows you to choose whether to display file sizes below the gallery thumbnails.

Show image dimensions
The Show image dimensions check box allows you to choose whether to display image dimensions in pixels below the gallery thumbnails.

Font name
The Font name combo box provides you with a choice of which font to use in creating the gallery.

Font size
The Font size spin box is for changing the size of the font you selected.

Foreground color
The Foreground color option has a selector for choosing the foreground color of the gallery, this includes the text areas.

Background color
The Background color option has a selector for choosing the background color of the gallery.

FOLDERS
The Folders dialog is used for choosing where to save the gallery. This dialog is also used to configure which folders are used.
Save to HTML file
The Save to file selector allows you to decide where you want to save your image gallery html page.

Recurse subfolders
The Recurse subfolders check box enables recursing of subdirectories. If the check box is enabled, a slider and spin box are enabled to select the recursion depth.

Copy original files
The Copy original files check box creates an image folder storing copies of the original images used in the gallery.

Use comment file
The use comment file check box enables a file selector to choose a comments file to use with your gallery. The comment file contains the subtitles for the images.

The format of this file is:

```
# this is a comment, lines starting with '#' are ignored
FILENAME1:
Description
FILENAME2:
Description
```

Thumbnails
The thumbnails dialog is used for adjusting the properties of the thumbnails in the gallery.
The Konqueror Handbook

Image format for the thumbnails
The image format combo box allows you to choose which format is used for the thumbnail images.

Thumbnail size
The thumbnail size option provides a slider and spin box for adjusting the size of the thumbnails used in the gallery.

Set different color depth
The set different color depth check box enables a combo box for changing the color depth of the thumbnails if you wish to use a different color depth to that used in the original image.

Search Bar
Provides a text box for easy access to search engines such as Google. Clicking on the icon on the left side of the search box opens a menu to select and enable different search engines and configure their Web Shortcuts.

Shell Command Plugin
This plugin enables you to execute a shell command in the current folder and view the output in a separate window.
Chapter 9

View Mode Extensions

Konqueror provides additional views in View → View Mode in file manager and browser mode, if the corresponding applications and plugins are installed.

The file manager mode has the additional views Radial Map from the application Filelight and the Konqueror plugin File Size View.

9.1 FSView - the File System View

9.1.1 Introduction

The FSView Plugin for Konqueror is another view mode for objects of mimetype inode/directory for local files. It can be viewed as an alternative to the various iconviews and listviews for browsing the content of your local file system.

The unique property of FSView is its ability to show whole nested folder hierarchies using a so-called tree map for graphical visualization. Tree maps allow for displaying metrics of objects in nested structures: each object is represented by a rectangle whose area is proportional to its metric. The sum of the children’s metrics must be equal to or smaller than the parent object’s metric.

For FSView, sizes of files and folders are chosen as the metric, where the size of a folder is defined to be the sum of the sizes of its subitems. This way, big files even deep down in the folder hierarchy can be spotted easily by looking for large rectangles. So FSView can be looked at as a graphical and interactive version of the UNIX\textsuperscript{®} du command.

The integration of FSView as part of Konqueror allows it to use the standard features such as context file menus, and mime type sensitive actions. But it was chosen not to implement automatic update by watching file system changes: if you delete a file shown in FSView outside of Konqueror, you have to update manually by e.g. pressing F5 to see the change. The reason for this decision is the potentially huge number of files which would have to be watched for changes, and thus, could put an unreasonable pressure on system resources for a small feature.

9.1.2 Visualization Features

This section explains the graphical visualization of FSView in detail.

9.1.2.1 Item Drawing Options

In FSView, an item of the tree map visualization is a rectangle representing a file or folder of your file system. For easier navigation, rectangles have meaningful coloring and labeling options.
The color of a rectangle, switchable via menu item View → Color Mode can be either representative of Depth, for easy detection of nesting, or a color mapping of different file attributes such as name, owner, group, or mime type.

A rectangle can be labeled with the various attributes of the corresponding file or folder. For each attribute, you can choose whether it should be shown at all, only if space is available, or if space should be taken from children (thus introducing errors to pure tree map drawing constraints). Additionally, you can choose the relative location of the label in the rectangle.

9.1.2.2 TreeMap Drawing Algorithms

For drawing algorithms in tree maps, the rule that the area is proportional to the metric of an item should hold true. With the tree map in FSView, this goal isn’t always met: we draw borders to show the nesting of items, and this border takes space for an item which is possibly lost for the areas of child items. Note that less space is lost for the border if the rectangle is quadratic.

Similarly, it is better for a good overview to let each rectangle at least have its name as a label. It is an option to always force space for labels, or only to draw labels when empty space is available. In the latter case, the tool tips appearing when the mouse is held over an item can help a lot. They show information for the item the mouse is currently over, together with its parent folders up to the root item of the tree map.

How the space of an item is split into subareas for children is left to the implementation. It is always better to try to split areas in such a way that rectangles are as quadratic as possible, both for labeling and less space lost by borders. The best methods in this regard are Rows, Columns, or Recursive Bisection.

You can choose the minimal area of items to be drawn via the menu item View → Stop at Area. Instead, a hash pattern will be drawn over the parents area to signal that this space is in fact occupied by a child or children.

9.1.3 User Interface

FSView supports multiple selection of items, similar to the iconview and listview. This allows for actions to be done simultaneously to a set of files. A simple mouse click always selects a single item below the mouse pointer. Use a mouse click in combination with pressing the Shift key for range selection or the Ctrl key for selection toggle. Note that by selecting an item, subitems can no longer be selected. Selecting an item will also clear the selection of all its parent items before.

Keyboard navigation is available in tree maps: use Left Arrow and Right Arrow keys to move the current item between siblings, and the Up Arrow and Down Arrow keys to go up and down the nesting hierarchy. Space selects the item; in conjunction with Shift does range selection; and with the Ctrl key held down simultaneously, toggles selection of the current item. Press Return to run the open action on the current item.

9.1.4 Credits and License

Originally, FSView was meant as a small test application and usage tutorial for the TreeMap widget developed within KCachegrind.

Copyright by Josef Weidendorfer, licensed using GPL V2.

The Konqueror Handbook

The color of a rectangle, switchable via menu item View → Color Mode can be either representative of Depth, for easy detection of nesting, or a color mapping of different file attributes such as name, owner, group, or mime type.

A rectangle can be labeled with the various attributes of the corresponding file or folder. For each attribute, you can choose whether it should be shown at all, only if space is available, or if space should be taken from children (thus introducing errors to pure tree map drawing constraints). Additionally, you can choose the relative location of the label in the rectangle.

9.1.2.2 TreeMap Drawing Algorithms

For drawing algorithms in tree maps, the rule that the area is proportional to the metric of an item should hold true. With the tree map in FSView, this goal isn’t always met: we draw borders to show the nesting of items, and this border takes space for an item which is possibly lost for the areas of child items. Note that less space is lost for the border if the rectangle is quadratic.

Similarly, it is better for a good overview to let each rectangle at least have its name as a label. It is an option to always force space for labels, or only to draw labels when empty space is available. In the latter case, the tool tips appearing when the mouse is held over an item can help a lot. They show information for the item the mouse is currently over, together with its parent folders up to the root item of the tree map.

How the space of an item is split into subareas for children is left to the implementation. It is always better to try to split areas in such a way that rectangles are as quadratic as possible, both for labeling and less space lost by borders. The best methods in this regard are Rows, Columns, or Recursive Bisection.

You can choose the minimal area of items to be drawn via the menu item View → Stop at Area. Instead, a hash pattern will be drawn over the parents area to signal that this space is in fact occupied by a child or children.

9.1.3 User Interface

FSView supports multiple selection of items, similar to the iconview and listview. This allows for actions to be done simultaneously to a set of files. A simple mouse click always selects a single item below the mouse pointer. Use a mouse click in combination with pressing the Shift key for range selection or the Ctrl key for selection toggle. Note that by selecting an item, subitems can no longer be selected. Selecting an item will also clear the selection of all its parent items before.

Keyboard navigation is available in tree maps: use Left Arrow and Right Arrow keys to move the current item between siblings, and the Up Arrow and Down Arrow keys to go up and down the nesting hierarchy. Space selects the item; in conjunction with Shift does range selection; and with the Ctrl key held down simultaneously, toggles selection of the current item. Press Return to run the open action on the current item.

9.1.4 Credits and License

Originally, FSView was meant as a small test application and usage tutorial for the TreeMap widget developed within KCachegrind.

Copyright by Josef Weidendorfer, licensed using GPL V2.
Chapter 10

Configuring Konqueror

Pamela Roberts

In common with the rest of KDE, Konqueror is highly configurable, so you can really get the look and feel that best fits your needs and wishes.

When KDE is newly installed, Konqueror’s window contains a Menubar, Main and Location Toolbars and possibly a Bookmark Toolbar.

For detailed information how to modify toolbars and shortcuts please read the sections about Toolbars and Shortcuts in the Fundamentals.

10.1 Other Settings

Selecting Settings → Configure Konqueror... brings up a dialog box which you can use to control most aspects of Konqueror’s behavior.

It contains these sections which are selected by left clicking on one of the icons at the left of the dialog box:

- **General**: Configure general Konqueror behavior
- **Performance**: Configure settings that can improve Konqueror’s performance
- **Bookmarks**: Configure the bookmarks home page
- **File Management**: You can configure how Konqueror behaves as a file manager here
- **View Modes**: Configure file manager view modes
- **Navigation**: Configure file manager navigation
- **Services**: Configure file manager services
- **General**: Configure general file manager settings
- **File Associations**: Configure file associations
- **Trash**: Configure trash settings
- **Web Browsing**: Configure the browser behavior
- **Proxy**: Configure the proxy servers used
- **Appearance**: Configure how to display web pages
The Konqueror Handbook

- **AdBlocK Filters**: Configure Konqueror AdBlocK filters
- **Cache**: Configure web cache settings
- **History**: Configure the history sidebar
- **Cookies**: Configure the way cookies work
- **Browser Identification**: Configure the way Konqueror reports itself
- **Java & JavaScript**: Configure the behavior of Java and JavaScript

Pressing the **Help** button will give you detailed instructions about how to use each of these sections, or you can use the **What’s This?** feature.
11.1 Special Shortcuts

There are some useful shortcuts that are not shown in any of the menus:

F6
Sets the focus to the text entry box in the Location Toolbar.

Ctrl+.  
Activate the next tab page.

Ctrl+,  
Activate the previous tab page.

11.2 The Menubar

Note that some menu entries only appear when they are applicable to the file you currently have open in Konqueror. For example, the **Edit → Find...** item will not appear when you are viewing the contents of a directory.

Konqueror has different menu items in file manager and browser mode. Only the items for these two modes are described in this chapter.

If **Konqueror** is using embedded components (KDE Parts) such as Gwenview for image viewing, Okular for PDF and PostScript® documents etc. the menu items from these applications are merged into Konqueror’s menu. Help for these additional menu items you find in the handbook of the embedded application.
11.2.1 The File Menu

File → New Window (Ctrl+N)
Open another Konqueror window.

File → New Tab (Ctrl+T)
Open another Konqueror tab, containing a blank page.

File → Open Location... (Alt+O)
Sets the focus to the text entry box in the Location Toolbar.

File → Open File... (Ctrl+O)
Open a file using the KDE file dialog.

File → Sessions
Open a submenu to save the current session (open tabs and windows) for easy retrieval, manage sessions and switch to previously saved sessions.

File → Send Link Address...
Send an email containing a link to the current location.

File → Send File...
Send an email containing the selected file as an attachment.

File → Save Background Image As... (Browser mode - KHTML view)
Only applies if you are viewing a web page with a background image. Opens the Save As dialog box to let you save the background image file to your own computer.

File → Save As... (Browser mode)
Only applies if you are viewing a document or web page, uses the Save As... dialog box to let you save a copy to your own computer.

File → Save Frame As... (Browser mode)
Similar to Save As... but for use with a web site that uses frames.

File → Print... (Ctrl+P)
Print.

File → Print Frame (Browser mode)
Print selected frame of a Web page.

File → Open With
Displays a list of applications installed on the system associated with the mimetype of the current URL.

File → Quit (Ctrl+Q)
Close down this instance of Konqueror.
11.2.2 The Edit Menu

**NOTE**
Some items in the Menubar Edit menu can also be found by right mouse button clicking on a free area of a view.

Edit → Undo: Action (Ctrl+Z)
Sometimes lets you reverse a mistaken action.

Edit → Cut (Ctrl+X)
Puts selected item(s) into the clipboard. If you then paste the items they will be moved from the original location to the new one.

Edit → Copy (Ctrl+C)
Copy selected item(s) to the clipboard.

Edit → Paste (Ctrl+V) (Browser mode)
Paste the clipboard content into the Location Bar, if the Location Bar has the focus.

Edit → Paste Clipboard Contents... (Ctrl+V) or Edit → Paste one File or Edit → Paste one Folder or Edit → Paste x Items (File Manager mode)
Paste the currently copied/cut item(s) to the current folder. If the clipboard does not contain files or folders, the clipboard contents (such as text or image data) will be pasted into a new file.

Edit → Select All (Ctrl+A) (Browser mode)
Selects all text in an HTML page or in a text page being previewed, you can then Copy it and Paste it into a text editor.

Edit → Create New (File Manager mode)
Creates a new object (such as a folder or a text file) in the current folder. See the Create New... section for more details.

Edit → Rename (F2) (File Manager mode)
Lets you rename a file or folder without having to open the Properties... dialog box.

Edit → Move to Trash (Del) (File Manager mode)
Move selected item(s) to the Trash folder.

Edit → Delete (Shift+Del) (File Manager mode)
Delete the selected item(s).

Edit → Edit File Type... (File Manager mode)
Open the Edit File Type dialog box

Edit → Properties... (Alt+Return) (File Manager mode)
Shows the properties dialog for the currently selected item(s).

Edit → Selection → Select Items Matching... (Ctrl+S) (File Manager mode)
Together with the Unselect Items Matching..., Unselect All and Invert Selection commands, this provides an easy and powerful way of selecting multiple files.

It brings up a simple dialog box where you can enter a file name using the wild card characters * and ?, for example entering *.html will select all files ending with .html while ?a* will select all files which have the letter a as the second character in their filename.
The Konqueror Handbook

Edit → Selection → Unselect Items Matching... (File Manager mode)
Unselect files or folders via a dialog similar to the one used by Select....

Edit → Selection → Select All (Ctrl+A) (File Manager mode)
Selects all items in a folder; you can then Copy or Cut them and Paste them into a different folder.

Edit → Selection → Unselect All (File Manager mode)
Unselect all selected files or folders.

Edit → Selection → Invert Selection (Ctrl+Shift+A) (File Manager mode)
Invert current selection.

Edit → Find... (Ctrl+F) (Browser mode)
Displays the search bar at the bottom of the current window. Start typing to find a text string in a text page you are previewing or in an HTML page.

Edit → Find Next (F3) (Browser mode - KHTML view)
Find the next occurrence of the text string in the text or HTML page.

Edit → Find Previous (Shift+F3) (Browser mode - KHTML view)
Find the previous occurrence of the text string in the text or HTML page.

11.2.3 The View Menu

View → View Mode
In browser mode this submenu holds items to select embedded views like KHTML, WebEngine, Embedded Advanced Text Editor and more embedded views.
In file manager mode this submenu holds items to select Icon, Details, Compact, Terminal Emulator and more view modes.

View → Lock to Current Location
A locked view cannot change folders. Use in combination with Link View to explore many files from one folder.

View → Link View
Link current view to others in a multiple view window. A linked view follows folder changes made in other linked views. This is especially useful with different types of views, such as a folder tree with an icon view or detailed view, and possibly a terminal emulator window.

View → Reload (F5)
Reload.

View → Stop (Esc)
Stop load (particularly useful when web browsing).

View → Enlarge Font (Ctrl++) / View → Shrink Font (Ctrl+-) (Browser mode - KHTML view)
Use these to adjust the size of the text in the page if you find it difficult to read. How well this works will depend on how the web page has been constructed.

View → View Document Source (Ctrl+U) (Browser mode - KHTML view)
View document source text.
Only available if you are viewing a document or HTML page.
The Konqueror Handbook

**View → View Frame Source (Browser mode)**
View frame source text
Only applies if you are viewing a web site that uses frames. Similar to View Document Source.

**View → Zoom In → Zoom Out → Actual Size → Zoom Text Only → Zoom To DPI (Browser mode - WebEngine view)**
These menu items offer different actions to modify the size of the items in the page.

**View → View Document Information (Ctrl+I) (Browser mode - KHTML view)**
View document information, such as title, URL, and HTTP headers used in retrieving the document.
Only available if you are viewing an HTML page.

**View → Set Encoding (Browser mode)**
Allows you to choose the character encoding used to display HTML pages. Default is usually the best choice.

**View → Sort By (File Manager mode)**
Changes whether items are sorted by Name or other criteria described in Information in the View.
Descending reverses the sort order. Folders First sorts folders before files.

**View → Additional Information (File Manager mode)**
Displays additional information described in Information in the View.

**View → Preview (File Manager mode)**
Displays a symbolic preview of the file contents in the different view modes.

**View → Show in Groups (File Manager mode)**
Displays the content of the current folder grouped by the option selected in Sort By (only available in the Icons view mode).

**View → Show Hidden Files (Alt+. ) (File Manager mode)**
Shows all the hidden files and sub-folders within the current folder.

**View → Adjust View Properties... (File Manager mode)**
Opens the View Properties Dialog.

### 11.2.4 The Go Menu

**Go → Up (Alt+Up)**
Go up a level in the folder hierarchy or select a folder in the hierarchy from the submenu.

**Go → Back (Alt+Left)**
Go back to the previous view or select a previously visited item from the submenu.

**Go → Forward (Alt+Right)**
You can only go forward if you’ve previously gone back.

**Go → Home Page (Alt+Home) (Browser mode)**
Go to your home page as defined on the General page of the settings dialog.

**Go → Home Folder (Alt+Home) (File Manager mode)**
Changes to the users home folder, e.g., /home/Peter/.
Go → Applications (File Manager mode)
Open the folder holding your applications.

Go → Network Folders (File Manager mode)
Network folders show up in a special location of Konqueror and Dolphin called a virtual folder. You can find more information on how to use this folder in the KNetAttach Handbook.

Go → Settings (File Manager mode)
Open a virtual folder with all System Settings modules in Icons, Details or Columns view. Select an item to display the settings module in a separate dialog window.

Go → Trash (File Manager mode)
Open your Trash folder.

Go → Autostart (File Manager mode)
Open your Autostart folder.

Go → Show History (Ctrl+Shift+H)
Shows a tree view of your browsing history in a separate window.

Go → Most Often Visited
Displays a submenu showing the URLs you visit most often. Selecting one of these will make Konqueror open that URL.

Go → Recently Visited
Displays a submenu showing the URLs you recently visited. Selecting one of these will make Konqueror open that URL.

Go → Closed Items
Displays a submenu showing the closed URLs you visit. Selecting one of these will make Konqueror open that URL. Use Empty Closed Items History to clear the submenu.

11.2.5 The Bookmarks Menu

**NOTE**
See the section Using Bookmarks in this manual for a fuller description of these menu items.

Bookmarks → Add Bookmark (Ctrl+B)
Add current selection to your bookmarks.

Bookmarks → Bookmark Tabs as Folder...
Create a bookmark folder containing links to all of the URLs currently open in Konqueror tabs.

Bookmarks → New Bookmark Folder...
Create a new folder in your Bookmarks folder.

Bookmarks → Edit Bookmarks...
Open the Bookmark Editor.
11.2.6 The Tools Menu

Tools → Open Terminal (F4) (File Manager mode)
Open a Konsole terminal window.

Tools → Find File... (Ctrl+F) (File Manager mode)
Open the KFind application.

Tools → Select Remote Charset (File Manager mode)
Offers to choose the charset used by a remote connection manually.

If you have Konqueror plugins installed there will be additional entries in the Tools menu. See the Konqueror Plugins chapter for further details.

11.2.7 The Settings Menu

Apart from the common KDE Settings menu items described in the Settings Menu chapter of the KDE Fundamentals Konqueror has these application specific menu entries:

Settings → Show Terminal Emulator
Open a small text terminal view at the bottom of the main window.

Settings → Full Screen Mode (Ctrl+Shift+F)
Changes Konqueror to full screen mode, in which the Konqueror window takes up the whole screen, and does not have the usual window decorations. To exit full screen mode, click on the Exit Full Screen Mode icon on the toolbar, or press Ctrl+Shift+F.

Settings → Configure Extensions...
Opens a dialog with all installed plugins (e.g. from the KDE module extragear) and allows you to select the ones you need. All plugins are accessible in the Tools menu.

Settings → Configure Spell Checking...
Displays the spell checking configuration dialog box, in which you can change settings associated with spell checking in Konqueror.

11.2.8 The Window Menu

Window → Split View Left/Right (Ctrl+Shift+L)
Split View Left/Right.

Window → Split View Top/Bottom (Ctrl+Shift+T)
Split View Top/Bottom.

Window → Close Active View (Ctrl+Shift+W)
Remove Active View.

Window → New Window (Ctrl+N)
Open another Konqueror window.

Window → Duplicate Window (Ctrl+Shift+D)
Open another Konqueror window, duplicating the current one.
Window → New Tab (Ctrl+T)
Open a new, empty, tab page.

Window → Duplicate Current Tab (Ctrl+D)
Open a duplicate tab page.

Window → Detach Current Tab (Ctrl+Shift+B)
Show the current tab page in a new instance of Konqueror.

Window → Close Current Tab (Ctrl+W)
Close the current tab page.

Window → Move Tab Left (Ctrl+Shift+Left)
Move the current tab one place left in the list of tabs.

Window → Move Tab Right (Ctrl+Shift+Right)
Move the current tab one place right in the list of tabs.

11.2.9 The Help Menu

Apart from standard KDE Help menu items described in the section Help Menu of the KDE Fundamentals you will have the menu entry Konqueror Introduction to revisit the introductory pages that you got when Konqueror was first started.
Chapter 12

Questions and Answers

Pamela Roberts

1. Can I run Konqueror from another window manager?
   Just install Qt™, KF5 and Konqueror, and from your favorite window manager, launch
   Konqueror. It should work just fine, but if it doesn’t (KDE developers don’t test that case
   often), report it to http://bugs.kde.org and try running kdeinit before running Konqueror;
   it usually helps.

2. Where does Konqueror keep all its configuration data?
   Generally in the qtpaths --paths GenericDataLocation folder (this may be ~/.local/share
   on your system, depending on how Konqueror was installed). Don’t alter these files
   unless you really know what you are doing.
   
   • Your bookmarks are held in konqueror/bookmarks.xml
   • Cookies are held in kcookiejar/cookies
   • Your history, as used for the auto-completion feature, is in kong_history in the folder
     qtpaths --paths GenericConfigLocation.
   • In the folder qtpaths --paths GenericConfigLocation the file konquerorrc holds a
     whole lot of general configuration settings.
   • The folder kio_http/ in qtpaths --paths GenericCacheLocation contains the browser
     cache.
   
   Any folder specific view settings are put into .directory files in the individual folders.

3. How do I clear out the history file?
   There are two ‘histories’:
   
   • One is used for text completion in the Location Toolbar text entry box. To clear this right
     click on the text entry box and select Clear History .
   • The other is the log of visited locations. Select Show History in the menu Go and right
     click on an entry and choose Remove Entry (Del) to remove just that entry or Clear
     History to delete all entries.

   NOTE
   You can also use the application Sweeper from the kdeutils module which allows you to clean up
   cookies, favicons, web history and cache, form completion entries and cache policies of visited
   websites.

49
4. **How do I enable, disable or clear the browser cache?**

If you select **Web Browsing → Cache** in the dialog launched by selecting **Settings → Configure Konqueror...**, you will be presented with a dialog box that lets you disable the cache, clear it or set its size, and change the caching policy.

5. **How can I change the timeout values used by Konqueror when web browsing?**

In the System Settings category **Network** on the **Settings → Connection Preferences** page.

6. **How do I set my ‘home’ page - the page loaded on startup?**

Konqueror has a **Home Folder** used in file manager mode and a **Home Page** used in browser mode.

To change these settings launch **Settings → Configure Konqueror+General**.

To set the Konqueror startup page in filemanager mode select **Show Introduction Page, Show My Home Page, Show Blank Page** or **Show My Bookmarks** from the drop down box labeled **When Konqueror starts**.

In browser mode Konqueror starts with the **Home page** entry.

7. **I can’t find the answer to my question here.**

Take a look at [https://konqueror.org/faq/](https://konqueror.org/faq/) or [https://konqueror.org/contact/](https://konqueror.org/contact/).

You may find further information in the **KDE Community Forums** or on Konqueror’s **KDE Userbase page**.
Chapter 13

Credits and License

Pamela Roberts
Konqueror. Program copyright 1999-2003, the Konqueror developers:

David Faure faure@kde.org
developer (parts, JavaScript, I/O lib) and maintainer

Simon Hausmann hausmann@kde.org
developer (framework, parts)

Michael Reiher michael.reiher@gmx.de
developer (framework)

Mattias Welk welk@fokus.gmd.de
developer

Alexander Neundorf neundorf@kde.org
developer (list views)

Michael Brade brade@kde.org
developer (list views, I/O lib)

Lars Knoll knoll@kde.org
developer (HTML rendering engine)

Antti Koivisto koivisto@iki.fi
developer (HTML rendering engine)

Dirk Müller mueller@kde.org
developer (HTML rendering engine)

Peter Kelly pmk@post.com
developer (HTML rendering engine, JavaScript)

Waldo Bastian bastian@kde.org
developer (HTML rendering engine, I/O lib)

Matt Koss koss@napri.sk
developer (I/O lib)
The Konqueror Handbook

Alex Zepeda zipzippy@sonic.net
developer (I/O lib)

Stephan Kulow coolo@kde.org
developer (HTML rendering engine, I/O lib, regression test framework)

Richard J. Moore rich@kde.org
developer (Java™ applet support)

Dima Rogozin dima@mercury.co.il
developer (Java™ applet support)

Wynn Wilkes wynnw@calderasystems.com
developer (Java™2 manager support and other major improvements to applet support)

Harri Porten porten@kde.org
developer (JavaScript)

Stefan Schimanski schimmi@kde.org
developer (Netscape® plugin support)

Carsten Pfeiffer pfeiffer@kde.org
developer (framework)

George Staikos staikos@kde.org
developer (SSL support, Netscape plugins)

Dawit Alemayehu adawit@kde.org
developer (I/O lib, Authentication support)

Torsten Rahn rahn@kde.org
Graphics / icons

Torben Weis weis@kde.org
kf m author

Joseph Wenninger kde@jowenn.at
developer (navigation panel framework)

Stephan Binner binner@kde.org
developer (misc stuff)

Leo Savernik l.savernik@aon.at
JavaScript access controls, per-domain policies extensions, HTML rendering engine

Germain Garand germain@ebooksfrance.org
Developer (HTML rendering engine)

Zack Rusin zack@kde.org
Developer (HTML rendering engine)

Tobias Anton anton@stud.fbi.fh-darmstadt.de
Developer (HTML rendering engine)

Lubos Lunak l.lunak@kde.org
Developer (HTML rendering engine)
The Konqueror Handbook

Maks Orlovich maksim@kde.org
Developer (HTML rendering engine, JavaScript)

Allan Sandfeld Jensen kde@carewolf.com
Developer (HTML rendering engine)

Apple Safari Developers
Developer (HTML rendering engine, JavaScript)

Koos Vriezen koos.vriezen@xs4all.nl
Developer (Java applets and other embedded objects)

Ivor Hewitt ivor@ivor.org
Developer (AdBlock filter)

Eduardo Robles Elvira edulix@gmail.com
Developer (framework)

Documentation copyright 2000-2003

• Erwan Loisant erwan@loisant.org
• Pamela Roberts pamroberts@blueyonder.co.uk

Documentation updated for KDE 3.2 by Philip Rodrigues phil@kde.org.
Documentation proofreading for KDE 4.11 by David Palser davidpalser179@btinternet.com.
This documentation is licensed under the terms of the GNU Free Documentation License.
This program is licensed under the terms of the GNU General Public License.