La barra dei menu

Nella barra dei menu trovi tutte le azioni di KTurtle. Sono nei seguenti gruppi: File, Modifica, Area di disegno, Esegui, Strumenti, Impostazioni e Aiuto. Questa sezione li descrive tutti.

Il menu File

FileNuovo (Ctrl+N)

Crea un nuovo file di TurtleScript vuoto.

FileApri... (Ctrl+O)

Apre un file di TurtleScript.

FileApri recenti

Apre un file di TurtleScript che è stato aperto recentemente.

FileEsempi

Apre i programmi di esempio di TurtleScript. Gli esempi sono nella tua lingua preferita, che puoi scegliere nel sotto-menu ImpostazioniLingua degli script.

FileScarica altri esempi...

Apre la finestra Scarica le novità per scaricare da Internet dei file TurtleScript.

FileSalva (Ctrl+S)

Salva il file di TurtleScript attualmente aperto.

FileSalva come... (Ctrl+Shift+S)

Salva in un percorso specificato il file di TurtleScript attualmente aperto.

FileEsporta come HTML...

Esporta il contenuto corrente dell'editor come file HTML, che include i colori di evidenziazione.

FileStampa... (Ctrl+P)

Stampa il codice nell'editor.

FileEsci (Ctrl+Q)

Esce da KTurtle.

Il menu Modifica

ModificaAnnulla (Ctrl+Z)

Annulla l'ultima modifica al codice. KTurtle può annullare un numero infinito di modifiche.

ModificaRifai (Ctrl+Shift+Z)

Rifa una modifica annullata al codice.

ModificaTaglia (Ctrl+X)

Taglia il testo selezionato nell'editor negli appunti.

ModificaCopia (Ctrl+C)

Copia negli appunti il testo selezionato nell'editor.

ModificaIncolla (Ctrl+V)

Incolla nell'editor il testo degli appunti.

ModificaSeleziona tutto (Ctrl+A)

Seleziona tutto il testo nell'editor.

ModificaTrova... (Ctrl+F)

Con questa azione puoi cercare delle frasi nel codice.

ModificaTrova successivo (F3)

Usalo per trovare l'occorrenza successiva della frase che stavi cercando.

ModificaTrova precedente (Shift+F3)

Usalo per trovare l'occorrenza precedente della frase che stavi cercando.

ModificaModalità di sovrascrittura (Ins)

Passa dalla modalità d'inserimento a quella di sovrascrittura, e viceversa

Il menu Area di disegno

Area di disegnoEsporta come immagine (PNG)...

Esporta il contenuto corrente dell'area di disegno come immagine raster in formato PNG (Portable Network Graphics).

Area di disegnoEsporta come disegno (SVG)...

Esporta il contenuto corrente dell'area di disegno come immagine vettoriale in formato SVG (Scalable Vector Graphics).

Area di disegnoStampa area di disegno...

Stampa il contenuto corrente dell'area di disegno.

Il menu Esegui

EseguiEsegui (F5)

Avvia l'esecuzione dei comandi nell'editor.

EseguiMetti in pausa (F6)

Mette in pausa l'esecuzione. Questa azione è abilitata solo quando KTurtle sta eseguendo dei comandi.

EseguiTermina (F7)

Ferma l'esecuzione. Questa azione è abilitata solo quando KTurtle sta eseguendo dei comandi.

EseguiVelocità di esecuzione

Presenta una lista delle velocità di esecuzione possibili, formata da: Velocità massima (nessuna evidenziazione e nessun ispettore), Velocità massima, Lenta, Più lenta,Lentissima e Passo passo. Quando la velocità di esecuzione è impostata a Velocità massima (predefinito), possiamo a mala pena renderci conto di ciò che sta accadendo. Qualche volta questo comportamento è voluto, ma altre vogliamo tener traccia dell'esecuzione. Nel secondo caso, imposta la velocità di esecuzione a Lenta, Più lenta o Lentissima. Quando una delle modalità lente è selezionata, verrà mostrata la posizione corrente del cursore nell'editor. Passo passo eseguirà un comando per volta.

Il menu Strumenti

StrumentiScelta della direzione...

Questa azione apre la finestra per la scelta della direzione.

FileSelettore di colore...

Questa azione apre la finestra per la scelta colore.

Il menu Impostazioni

ImpostazioniLingua degli script

>Sceglie la lingua per il codice.

ImpostazioniMostra l'editor (Ctrl+E)

Mostra o nasconde l'editor.

ImpostazioniMostra ispettore (Ctrl+I)

Mostra o nasconde l'ispettore.

ImpostazioniMostra gli errori

Mostra o nasconde la scheda Errori con la lista degli errori che si sono verificati durante l'esecuzione del codice. Se questa opzione è attivata, per vedere nuovamente la tartaruga fai clic sull'area di disegno.

ImpostazioniMostra i numeri di riga (F11)

Con questa azione puoi mostrare i numeri di riga nell'editor. Ciò può essere utile per trovare gli errori.

ImpostazioniMostra la barra degli strumenti

Mostra o nasconde la barra degli strumenti principale.

ImpostazioniMostra la barra di stato

Mostra o nasconde la barra di stato.

ImpostazioniConfigura le scorciatoie...

La finestra standard di KDE per configurare le scorciatoie.

ImpostazioniConfigura le barre degli strumenti...

La finestra standard di KDE per configurare le barre degli strumenti.

Il menu Aiuto

KTurtle ha il menu Aiuto predefinito di KDE, come descritto nei Fondamentali di KDE, ma con una voce aggiuntiva:

AiutoAiuto su: ... (F2)

Questa funzione è molto utile: fornisce un aiuto sul codice sul quale si trova il cursore nell'editor del codice. Così, ad es., hai usato il comando scrivi nel codice, e vuoi sapere cosa dice il manuale su questo comando. Muovi il cursore sul comando scrivi, e premi F2. Il manuale mostrerà le informazioni sul comando scrivi.

Questa funzione può rivelarsi molto utile quando si impara ad usare TurtleScript.