Chapter 4. Command Reference

By default the menubar is not shown. All actions described here either can be accessed with toolbar buttons or with items in the menu of the Control toolbar button.

The Menubar in Dolphin's Main Window

The File Menu

File → Create New

Creates a new object (such as a folder or a text file) in the current folder.

You will find an explanation of all available objects in Konqueror's handbook in the chapter Create New.

Note

It is possible to create your own Create New... submenu items. Use files from KIO source repository as a reference and put the resulting .desktop file into the .local/share/templates in your home directory (the address can be determined using the kf5-config --path templates command in Konsole), then restart Dolphin.

File → New Window (Ctrl+N)

Opens a new Dolphin window.

File → New Tab (Ctrl+T)

Opens a new tab.

File → Close Tab (Ctrl+W)

Closes the current tab.

File → Undo close tab (Ctrl+Shift+T)

Reopens the last closed tab.

File → Rename (F2)

Renames one currently selected item inline. Opens the batch rename dialog if several items are selected.

File → Move to Trash (Del)

Moves the currently selected item(s) to the trash.

File → Delete (Shift+Del)

Permanently deletes the currently selected item(s). The items are not moved to the trash and cannot be restored.

File → Show Target

This action highlights a link target in a new Dolphin window.

File → Duplicate Here (Ctrl+D)

Creates duplicates of selected items appending copy to the end of their names.

File → Properties (Alt+Return)

Shows the properties dialog for the currently selected item(s).

File → Quit (Ctrl+Q)

Exits Dolphin.

The Edit Menu

Edit → Undo (Ctrl+Z)

Undoes the last action performed by Dolphin.

Edit → Cut (Ctrl+X)

Cuts the currently selected item(s).

Edit → Copy (Ctrl+C)

Copies the currently selected item(s).

Edit → Paste Clipboard Contents... (Ctrl+V) or Edit → Paste one File or Edit → Paste one Folder or Edit → Paste x Items

Pastes the currently copied/cut items to the current folder. If the clipboard does not contain files or folders, the clipboard contents (such as text or image data) will be pasted into a new file. The name of this file has to be entered in a dialog.

Edit → Copy to inactive split view (Ctrl+F5)

Copies the currently selected item(s) from the active split view to the inactive split view.

Edit → Move to inactive split view (Ctrl+F6)

Moves the currently selected item(s) from the active split view to the inactive split view. Is disabled if the current user does not have write permission on the selected item(s).

Edit → Filter... (Ctrl+I)

Enables and disables the filter bar. You can also use the alternate shortcut Shift+/ for this action.

Edit → Search... (Ctrl+F)

Opens the find bar. Enter a search term into the edit box and select to search for filename or in contents of files starting from the current folder or everywhere.

Edit → Select All (Ctrl+A)

Selects all files and folders in the current folder.

Edit → Invert Selection (Ctrl+Shift+A)

Selects all unselected items and deselects all selected items in the current folder.

The View Menu

View → Zoom In (Ctrl++)

Increases the size of icons in the view.

View → Zoom Out (Ctrl+-)

Decreases the size of icons in the view.

View → Zoom Reset (Ctrl+0)

Resets the size of icons in the view to default.

View → View Mode

Changes the view mode to Icons (Ctrl+1), Compact (Ctrl+2) or Details (Ctrl+3).

View → Sort By

Changes whether items are sorted by Name or other criteria described in Information in the View.

Descending reverses the sort order. Folders First sorts folders before files.

View → Show Additional Information

Displays additional information described in Information in the View.

View → Show Previews

Displays a symbolic preview of the file contents in the different view modes.

View → Show in Groups

Displays the content of the current folder grouped by the option selected in Sort By.

View → Show Hidden Files (Alt+.)

Shows all the hidden files and sub-folders within the current folder.There is an alternate shortcut Ctrl+H for this action.

View → Split (F3)

Enables and disables the split view mode.

View → Reload (F5)

Reloads the current folder.

View → Stop

Stops loading/reading the contents of the current folder.

View → Show Panels

Enables and disables the different panels: Places (F9), Information (F11), Folders (F7), Terminal (F4). With Lock Panels the panel header with caption and two buttons is hidden to save space and the panels are immutable, with Unlock Panels the header is visible and the panel can be moved to the right or left or even outside the main window.

View → Location Bar → Editable Location (F6)

Changes the location bar between the two modes; the bread crumb mode and the editable mode.

View → Location Bar → Replace Location (Ctrl+L)

Switches the location bar to editable mode, if necessary, and selects the location such that it can be replaced quickly.

View → Adjust View Display Style...

Opens the View Display Style Dialog.

The Go Menu

Go → Up (Alt+Up)

Changes to the folder above the current folder.

Go → Back (Alt+Left)

Changes to the previously viewed folder.

Go → Forward (Alt+Right)

Undoes a “Go Back” action.

Go → Home (Alt+Home)

Changes to the users home folder, e.g. /home/Peter/.

Go → Recently Closed Tabs

Shows a list of recently closed tabs which can be reopened.

The Tools Menu

Tools → Open Terminal (Shift+F4)

Opens Konsole within the current folder.

Tools → Open Preferred Search Tool (Ctrl+Shift+F)

Opens preferred search tool in the current folder.

Tools → Compare Files

Compare the currently selected files or folders with Kompare. This action is only enabled if two files or folders are selected.

Tools → Select Remote Charset

Allows you to choose the charset used by a remote connection manually.

The Settings and Help Menu

Dolphin has the common KDE Settings and Help menu items, for more information read the sections about the Settings Menu and Help Menu of the KDE Fundamentals.