Меню

В главном меню вы найдёте все команды KTurtle. Они находятся в следующих группах: Файл, Правка, Холст, Выполнить, Сервис, Настройка и Справка. Данный раздел посвящён их описанию.

Меню Файл

ФайлСоздать (Ctrl+N)

Создаёт новый, пустой файл TurtleScript.

ФайлОткрыть... (Ctrl+O)

Открывает файл TurtleScript.

ФайлПоследние файлы

Открывает файлы TurtleScript, которые открывались недавно.

ФайлПримеры

Показывает примеры программ на TurtleScript. Примеры открываются на языке, выбранном в НастройкаЯзык команд.

ФайлЗагрузить новые примеры...

Открывает диалоговое окно Загрузить новые примеры для загрузки дополнительных файлов TurtleScript из интернета.

ФайлСохранить (Ctrl+S)

Сохраняет текущий открытый файл TurtleScript.

ФайлСохранить как...

Сохраняет текущий открытый файл TurtleScript в выбранном месте.

ФайлЭкспорт кода в HTML...

Экспортирует текущее содержимое редактора в файл HTML с подсветкой цветами.

ФайлПечать... (Ctrl+P)

Печатает текущий код, введённый в редакторе.

ФайлЗакрыть (Ctrl+Q)

Выход из KTurtle.

Меню Правка

ПравкаОтменить действие (Ctrl+Z)

Отменяет последние изменения в коде. KTurtle имеет неограниченное число отмен!

ПравкаПовторить (Ctrl+Shift+Z)

Возвращает отменённые изменения в коде.

ПравкаВырезать (Ctrl+X)

Вырезает выделенный текст из редактора в буфер обмена.

ПравкаКопировать (Ctrl+C)

Копирует выделенный текст из редактора в буфер обмена.

ПравкаВставить (Ctrl+V)

Вставляет текст из буфера обмена в редактор.

ПравкаВыделить всё (Ctrl+A)

Копирует весь текст из редактора в буфер обмена.

ПравкаНайти... (Ctrl+F)

Ищет выражения в тексте.

ПравкаПродолжить поиск (F3)

Ищет следующее вхождение фразы в тексте.

ПравкаНайти предыдущее (Shift+F3)

Ищет предыдущее вхождение фразы в тексте.

ПравкаРежим замены (Ins)

Переключает между режимами «вставки» и «замены».

Меню Холст

ХолстЭкспорт в изображение (PNG)...

Экспортирует текущее состояние холста в растровое изображение PNG (Portable Network Graphics).

ХолстЭкспорт в рисунок (SVG)...

Экспортирует текущее состояние холста в векторный рисунок SVG (Scalable Vector Graphics).

ХолстПечать холста...

Печатает текущее содержимое холста.

Меню Выполнить

ВыполнитьВыполнить (F5)

Запускает на выполнение команды, введённые в редакторе.

ВыполнитьПриостановить (F6)

Приостанавливает выполнение.

ВыполнитьПрервать (F7)

Прекращает выполнение команд. Этот пункт доступен только тогда, когда выполняются команды.

ВыполнитьСкорость выполнения

Выводит список возможных скоростей выполнения, состоящий из: С максимальной скоростью (без подсветки и инспектора), С обычной скоростью, Замедленно, Медленно, Очень медленно и Шаг за шагом. Если скорость установлена как С обычной скоростью (по умолчанию), то бывает трудно уследить за тем, что происходит. Иногда это то, что нужно, но порой хочется отследить выполнение программы. В этом случае вы можете установить скорость в Замедленно, Медленно или Очень медленно. Когда выбрана одна из медленных скоростей выполнения в редакторе показывается текущее положение выполнения. Шаг за шагом выполняет по одной команде за раз.

Меню Сервис

СервисВыбор направления...

Открывает диалоговое окно выбора направления.

СервисВыбор цвета...

Открывает диалоговое окно выбора цвета.

Меню Настройка

НастройкаЯзык команд

Выбирает язык команд для кода.

НастройкаРедактор кода (Ctrl+E)

Показывает или скрывает редактор.

НастройкаИнспектор (Ctrl+I)

Показывает или скрывает инспектор.

НастройкаСообщения об ошибках

Показывает или скрывает вкладку Ошибки со списком всех ошибок, возникших при выполнении кода. Если этот параметр включён, щёлкните холст, чтобы снова увидеть Черепашку.

НастройкаНомера строк (F11)

Включает показ нумерации строк в редакторе. Это может быть полезно при поиске ошибок.

НастройкаПоказать панель инструментов

Управляет отображением панели инструментов.

НастройкаПоказать строку состояния

Управляет отображением статусной строки.

НастройкаКомбинации клавиш...

Стандартное диалоговое окно KDE для настройки клавиатурных комбинаций.

НастройкаПанели инструментов...

Стандартное диалоговое окно KDE для настройки панелей инструментов.

Меню Справка

СправкаРуководство пользователя KTurtle (F1)

Запускает Центр помощи KDE и открывает справочное руководство по KTurtle. (Этот документ вы и читаете).

СправкаЧто это? (Shift+F1)

Вид курсора меняется на стрелочку со знаком вопроса. Нажимая на различные элементы внутри KTurtle, вы увидите подсказку с объяснениями назначения и действия данного элемента (если она для него существует).

СправкаСообщить об ошибке...

Открывается диалог отправки сообщения об ошибке. Он служит для того, чтобы вы могли отправить сведения об обнаруженной вами ошибке в программе или свое «пожелание», чтобы какая-либо пока что отсутствующая возможность была реализована в будущих версиях программы.

СправкаСменить язык интерфейса приложения...

Открывает диалоговое окно, с помощью которого вы сможете изменить Основной язык и Резервный язык интерфейса программы.

СправкаО программе KTurtle

Будут выведены сведения о версии и авторах программы.

СправкаО KDE

Будут выведены сведения о версии KDE.

СправкаСправка по ... (F2)

Очень полезная функция — вызывает помощь по тому элементу кода, рядом с которым находится курсор в редакторе. Например, вы используете команду напиши в своей программе и хотите узнать побольше о ней из руководства. Вам достаточно переместить курсор, чтобы он оказался на команде напиши и нажать F2. Руководство откроется на странице с описанием команды напиши.

Эта функция может оказаться полезной при изучении TurtleScript.