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Sommario

KMenuEdit permette la modifica dei lanciatori delle applicazioni di KDE.



Manuale dell’editor del menu di KDE

Capitolo 1

Introduzione

KMenuEdit consente la modifica dei lanciatori delle applicazioni di KDE.

KMenuEdit può essere avviato sia facendo clic con il tasto destro del mouse sul pulsante del
lanciatore nel pannello scegliendo Modifica applicazioni..., sia digitando kmenuedit nella barra
di KRunner.
KMenuEdit permette di:

• Visualizzare e modificare il menu del lanciatore di applicazioni utilizzato.

• Sottomenu e voci Taglia, Copia e Incolla

• Creare ed eliminare sottomenu e voci

• Cambiare l’ordine dei sottomenu e delle voci

• Nascondere le voci e aggiungere nuovi sottomenu e voci

In modo predefinito, tutte le applicazioni installate sul computer appaiono nel menu del lancia-
tore di tutti gli utenti. Le applicazioni potrebbero apparire più di una volta in diversi menu. Le
categorie di sottomenu vuote definite nelle specifiche del menu del desktop saranno mostrate al-
lo stesso modo, ma non saranno visibili nei lanciatori a meno che non si installi un’applicazione
appartenente a tali categorie.

La vista ad albero ha due tipi diversi di voci:

• Sottomenu: sono abilitati solo i campi Nome, Commento e Descrizione e il pulsante per sele-
zionare un’icona, la scheda Avanzate è disabilitata. Ogni sottomenu può contenere sottomenu
e/o voci aggiuntivi.

• Voci; utilizzare questo oggetto per digitare i dati dell’applicazione che si desidera aggiungere.
Per informazioni dettagliate, vedere Utilizzare KMenuEdit.

KMenuEdit ha due modalità di visualizzazione ad albero - normale e con voci nascoste. Per
visualizzare l’ultima, marcare l’opzione Mostra le voci nascoste nella finestra di configurazione
della pagina Opzioni generali.

Molte voci aggiuntive appaiono nell’albero in modalità di visualizzazione nascosta. Diverse voci
nascoste sembrano essere semplici duplicati, ma hanno differenti opzioni del comando. Normal-
mente si dovrebbe evitare di modificare queste voci nascoste per non rischiare di compromettere
alcune funzionalità del sistema.
Nella modalità nascosta, sarà disponibile un sottomenu speciale .hidden [Hidden] come ele-
mento di primo livello nell’albero. Questo sottomenu speciale non è modificabile. In questo
sottomenu tutte le voci eliminate saranno mostrate al successivo avvio di KMenuEdit.
Non è possibile eliminare voci utilizzando la GUI in questo menu speciale. Esse appariranno
nuovamente al successivo avvio di KMenuEdit.
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1.1 Casi d’uso

1.1.1 Adattare il menu a un utente

1.1.1.1 Riordinare le voci

Questa operazione dovrebbe essere compiuta nella modalità nascosta, in cui solo i sottomenu e
le voci visibili nel menu del lanciatore sono visualizzati.
In modo predefinito, il menu è ordinato alfabeticamente utilizzando i nomi inglesi o le descri-
zioni. Utilizzando una lingua diversa dall’inglese, alcuni sottomenu e voci appariranno non
ordinati.
Utilizzare le opzioni in Modifica → Ordina per ordinare per nome o descrizione. Se si utilizza
l’avviatore classico delle applicazioni, sarà necessario selezionare l’opzione Formato corrispon-
dente nella finestra delle impostazioni. Nell’avviatore Kickoff marcare Mostra le applicazioni
per nome se le si ordina per nome qui.

Il raggruppamento dei sottomenu o delle voci più utilizzati ad es. nella parte superiore del menu
rende più semplice la loro selezione. Per cambiare l’ordine nell’albero di voci o sottomenu parti-
colari, utilizzare il pulsante Sposta in alto o Sposta in basso nella barra degli strumenti o queste
azioni nel menu.
Tutti i lanciatori delle applicazioni utilizzeranno l’ordine di sottomenu specificato in KMenuEdit.

1.1.1.2 Rimuovere le voci dalla vista Menu

La visualizzazione di tutte le applicazioni installate su un computer potrebbe generare confusio-
ne per alcuni utenti, che potrebbero voler nascondere alcune delle voci o dei sottomenu usate
meno frequentemente. Ci sono due diversi modi per farlo:

Passare alla modalità normale senza le voci nascoste. Le voci eliminate sono spostate nel sottome-
nu .hidden [Hidden]. Sarà sufficiente riportarle nell’albero per renderle nuovamente disponibili
nel menu.
Se si elimina un sottomenu, esso sarà effettivamente eliminato con tutti i sottomenu e le voci.
Per ricrearlo, è possibile utilizzare Modifica → Ripristina il menu di sistema, ma ciò rimuoverà
tutti i sottomenu e le voci personalizzati e i file .desktop corrispondenti. Questa azione non può
essere annullata.
Il modo migliore per rimuovere sottomenu e voci dal menu di un lanciatore di applicazioni è
marcare Voce nascosta nella scheda Generale e passare in modalità nascosta. In questa modalità
è facile annullare le modifiche senza compromettere la struttura del menu. L’unico svantaggio
consiste nel dover nascondere tutte le voci in un sottomenu manualmente per nascondere l’intero
sottomenu alla vista.

1.1.2 Aggiungere voci personalizzate

Per aggiungere voci personalizzate (sottomenu o voce), utilizzare le azioni nel menu o nella barra
degli strumenti. Le voci richiedono un Nome e un Comando, senza un comando una voce non
sarà salvata e le modifiche saranno ignorate.

Se si aggiunge una voce, tale voce è inserita come sottoelemento della posizione evidenziata
nell’albero. Spostare una voce trascinandola con il mouse o utilizzando il pulsantre Sposta in
basso nella parte inferiore dell’albero per trasformarla in una voce di primo livello.
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1.1.3 Trasferire le impostazioni del lanciatore

Non è possibile trasferire le impostazioni del menu utilizzando la GUI, sarà necessario farlo
manualmente e copiare i seguenti file nell’utente di destinazione:

KMenuEdit memorizza la gerarchia dei menu in menus/applications-kmenuedit.menu nella car-
tella $(qtpaths --paths GenericConfigLocation) e desktop-directories nella cartella $(qtpa
ths --paths GenericDataLocation) contiene i file desktop per i sottomenu creati. In applicat
ions/ nella cartella $(qtpaths --paths GenericDataLocation) si troveranno i file desktop per
gli elementi personalizzati creati.

Le scorciatoie per ogni applicazione sono memorizzate in kglobalshortcutsrc nella cartella $
(qtpaths --paths GenericConfigLocation), ma le funzioni di esportazione/importazione non
funzionano poiché gli UUID delle scorciatoie non corrispondono tra i due sistemi, nonostante i
file .desktop siano gli stessi. Sarà necessario riassegnare tutte le scorciatoie manualmente.
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Capitolo 2

Aggiungere una voce di menu

Virgil J. Nisly

In questo esempio, aggiungeremo Firefox al sottomenu Internet.

Per cominciare dobbiamo eseguire KMenuEdit. Fare clic con il tasto destro del mouse nel me-
nu del lanciatore, fare clic su Modifica applicazioni... per avviare KMenuEdit. Dopo che il
KMenuEdit è stato avviato, selezionare Internet come illustrato nell’immagine seguente.

Dopo aver selezionato la voce Internet, fare clic su File → Nuova voce..., per aprire la fine-
stra Nuova voce come nell’immagine seguente. Digitare quindi il nome del programma che
si desidera aggiungere, in questo caso digitare firefox.
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Premi il tasto invio, la finestra principale dovrebbe assomigliare alla figura sottostante.

Ora compiliamo il campo Descrizione:, in questo caso digita Browser web.

NOTA
La descrizione ed il nome saranno visualizzati nel lanciatore in questo modo, ‘Browser web (Firefox)’
o ‘Firefox (Browser web)’.

Ora abbiamo bisogno di specificare il nome del file eseguibile nel campo Comando:, in questo
caso scriveremo firefox.
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Il comando deve essere nella variabile PATH o devi specificare il percorso completo dell’eseguibile.
Se non si conosce il nome dell’eseguibile di un’applicazione, utilizzare il comando locate per
cercare il file desktop e digitare qui la stringa presente nella riga Exec come comando.

NOTA
Di seguito al comando, puoi usare numerosi segnaposto che possono essere rimpiazzati con i valori
attuali quando il programma viene eseguito:

%f - un nome di file
%F - una lista di file, da usare per applicazione che possono aprire più file alla volta
%u - un unico URL
%U - un elenco di URL
%d - la cartella di un file da aprire
%D - un elenco di cartelle
%i - l’icona
%m - mini-icona
%c - l’etichetta

Per esempio, se vuoi che firefox cominci la navigazione da www.kde.org - invece di firefox dovresti
scrivere firefox %u www.kde.org.

La maggior parte delle applicazioni accettano opzioni aggiuntive, ad es. il nome di un profilo
definito come Konqueror o Konsole. Per vedere tutte le opzioni di una applicazione lancia nome
applicazione--help in Konsole.

Ci piacerebbe avere un’icona più significativa, così possiamo fare clic sull’icona generica accanto
alla voce Nome: (nota, l’icona predefinita può essere vuota, in questo caso fare clic nell’area
a destra della casella di testo per l’inserimento del nome). Verrà aperta la finestra di dialogo
Seleziona icona che ci permetterà di scegliere la nuova icona, come mostrato nell’immagine qui
sotto.

Abbiamo scelto l’icona di firefox dall’elenco e premuto il tasto Invio. La tua schermata finale
dovrebbe assomigliare all’immagine sottostante.
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La posizione della nuova voce di menu ora può essere modificata utilizzando Sposta in alto e
Sposta in basso nella barra degli strumenti di KMenuEdit o trascinandola con il mouse.

Gli elementi del sottomenu possono essere ordinati utilizzando il pulsante Ordina nella barra
degli strumenti di KMenuEdit o gli elementi del sottomenu Modifica → Ordina.

Fare clic su File → Salva, attendere l’esecuzione della finestra di dialogo Aggiornamento della
configurazione di sistema, ora dovrebbe essere possibile trovare Firefox nel sottomenu Internet
del lanciatore.
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Capitolo 3

Usare KMenuEdit

Il pannello alla sinistra mostra la struttura del lanciatore. Quando sfogli gli elementi nel pan-
nello di sinistra, il pannello di destra mostra informazioni dettagliate sull’elemento del menu
evidenziato.

3.1 Scheda generale

Nome:
Questo è il nome del programma come appare nel menu del lanciatore. Può essere di-
verso dal vero nome dell’eseguibile. Per esempio, il nome dell’eseguibile mc è «Midnight
Commander».

Descrizione:
La descrizione viene mostrata assieme al nome dell’applicazione nel lanciatore. È
opzionale.

Commento:
Questo campo descrive il programma in maggior dettaglio. È opzionale.

Comando:
Questo è il nome del programma eseguibile. Assicurati di avere il permesso di eseguire il
programma.

Abilita la notifica dell’avvio
Se questa opzione è selezionata, verrà visualizzata una notifica durante l’avvio
dell’applicazione.

Mostra solo in KDE
Quando selezionato, la voce dell’applicazione sarà visibile in tutti i lanciatori di KDE ma
non negli altri ambienti desktop.

Voce nascosta
Rimuovere una voce dalla vista del menu nel lanciatore.
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3.2 Scheda avanzate

Cartella di lavoro:
Specifica la cartella di lavoro del programma. Diventerà la cartella corrente quando avvii il
programma. Non è necessario che sia uguale alla cartella in cui è collocato l’eseguibile.

Esegui in un terminale

Devi marcare questa opzione se il programma ha bisogno di un emulatore di terminale per
funzionare. Ciò serve soprattutto per le applicazioni della console.

Opzioni del terminale:

Metti in questo campo tutte le opzioni del terminale.

Esegui come un altro utente

Se desideri eseguire questo programma come un altro utente (diverso da te), marca questa
casella ed inserisci il nome dell’utente nel campo Nome utente.

Scorciatoia corrente:
Puoi assegnare una speciale scorciatoia della tastiera per avviare il programma.
Fai clic sul pulsante Nessuno alla destra della casella Tasto scorciatoia corrente:.
Il testo del pulsante cambierà in Inserisci.... Ora puoi premere nella tastiera la
combinazione di tasti che desideri assegnare al programma.

Puoi azzerare la scorciatoia in Nessuna utilizzando questo pulsante: .
Non dimenticare di salvare le impostazioni facendo clic su Salva oppure attraverso la voce
di menu File → Salva.

13



Manuale dell’editor del menu di KDE

Capitolo 4

Guida di riferimento per il menu

La maggior parte delle azioni della barra dei menu sono disponibili anche nel menu contestuale,
che si apre con un clic del tasto destro del mouse su una voce nella vista ad albero.

File → Nuova voce... (Ctrl+N)
Aggiunge una nuova voce al menu.

File → Nuovo sottomenu...
Aggiunge un nuovo sottomenu.

File → Salva (Ctrl+S)
Salva il menu

File → Esci (Ctrl+Q)
Esce da KMenuEdit.

Modifica → Sposta in alto
Sposta l’elemento selezionato in alto nel suo sottomenu.

Modifica → Sposta in basso
Sposta l’elemento selezionato in basso nel suo sottomenu.

Modifica → Taglia (Ctrl+X)
Taglia la voce corrente del menu negli appunti. Se vuoi spostare una voce del menu, de-
vi prima tagliarla negli appunti, spostarla nel posto di destinazione usando il pannello a
sinistra ed usare la funzione Incolla per incollare la voce del menu dagli appunti.

Modifica → Copia (Ctrl+C)
Copia la voce corrente del menu negli appunti. In seguito puoi usare la funzione Incolla
per incollare la voce del menu copiata dagli appunti alla sua destinazione. Puoi incollare la
stessa voce più volte.

Modifica → Incolla (Ctrl+V)
Incolla la voce di menu dagli appunti nella posizione attualmente selezionata nel menu
principale. Devi usare Taglia o Copia prima di poter usareIncolla.

Modifica → Elimina (Canc)
Elimina la voce selezionata del menu.

Edit → Ordina
Apre il sottomenu per ordinare la sezione selezionata o l’intero albero dei menu. Sono stati
implementati due metodi di ordinamento, vale a dire, per nome e per descrizione.
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Modifica → Ripristina a menu di sistema

Questo ripristina il lanciatore predefinito e rimuove tutte le impostazioni personalizzate.
Una finestra ti chiederà se veramente vuoi farlo.

KMenuEdit ha gli elementi tipici dei menu di KDE Impostazioni e Aiuto, per altre informazioni,
leggere le sezioni relative al Menu Impostazioni e Menu Aiuto dei fondamentali di KDE.
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Capitolo 5

Riconoscimenti e licenza

KMenuEdit
Programma copyright (c) 2002, Raffaele Sandrini

Hanno contribuito:

• Matthias Elter elter@kde.org - Autore originale

• Matthias Ettrich ettrich@kde.org

• Daniel M. Duley dan.duley@verizon.net

• Preston Brown pbrown@kde.org

Documentazione copyright (c) 2000 Milos Prudek

Documentazione copyright (c) 2008 Anne-Marie Mahfouf

Aggiornata per KDE 3.0 da Lauri Watts lauri@kde.org 2002

Traduzione della documentazione: Vincenzo Reale smart2128vr@gmail.com

Traduzione e revisione completa: Nicola Ruggero nicola@nxnt.org

Traduzione della documentazione: Giovanni Bacci s206756@studenti.ing.unipi.it

Revisione della documentazione: Federico Cozzi federicocozzi@federicocozzi.it
Aggiornamento della traduzione: Leonardo Finetti finex@finex.org

Questa documentazione è concessa in licenza sotto i termini della GNU Free Documentation
License.
Questo programma è concesso in licenza sotto i termini della GNU General Public License.
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Capitolo 6

Glossario

Applicazione della console

Applicazioni originariamente scritte per un ambiente non grafico. Queste applicazioni fun-
zionano bene in KDE. Devono essere avviate dentro un emulatore di terminale, come Kon-
sole. Tuttavia non sono automaticamente avvisate quando chiudi la tua sessione di KDE.
Pertanto non ti devi dimenticare di salvare i documenti aperti in queste applicazioni prima
di uscire da KDE.
Le applicazioni della console supportano il copia ed incolla dalle applicazioni KDE com-
patibili. Basta evidenziare il testo nella console con il mouse, spostarsi nell’applicazione
KDE compatibile e premere Ctrl+V per incollare il testo. Se vuoi copiare da un’applica-
zione KDE in una applicazione della console, prima evidenzia il testo con il mouse, premi
Ctrl+C, spostati nell’applicazione della console e premi il tasto centrale del mouse1.

1 Se il tuo mouse non ha un tasto centrale, devi premere i tasti sinistro e destro assieme. Questa è l’‘emulazione del
tasto centrale’ e deve essere supportata dal tuo sistema operativo perché funzioni
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