# Contents

1 Introduction ........................................... 7

2 Five-minute Fly-over Course of KOrganizer ............................... 9
   2.1 Entering Events ........................................ 9
   2.2 Entering To-dos ......................................... 9
   2.3 Adding Journal Entries .................................. 10
   2.4 Rescheduling Events ................................... 10
   2.5 Rescheduling or Editing To-dos .......................... 10
   2.6 Conclusion .............................................. 10

3 Importing, Exporting, and Managing Calendars ......................... 11
   3.1 Calendar Resources ...................................... 11
   3.2 Importing, Exporting and Maintaining Calendars .............. 13
      3.2.1 Importing Calendars ................................. 13
      3.2.2 Exporting Calendars ................................ 13
      3.2.3 Maintaining Your Calendars ......................... 13
   3.3 Downloading Using Get Hot New Stuff ....................... 14

4 Views and Filters ........................................... 15
   4.1 KOrganizer Views ........................................ 15
      4.1.1 What’s Next View .................................... 16
      4.1.2 Event List View ...................................... 16
      4.1.3 Agenda View ......................................... 16
         4.1.3.1 Day View .................................... 17
         4.1.3.2 Next X Days View ................................. 17
         4.1.3.3 Week View ...................................... 17
         4.1.3.4 Work Week View ................................ 17
      4.1.4 Month View ........................................... 18
      4.1.5 Timeline View ....................................... 18
      4.1.6 To-do List ............................................ 18
      4.1.7 Journal View ......................................... 19
   4.2 Categories ............................................... 19
   4.3 Filters .................................................. 19
   4.4 Searching ............................................... 19
5 Entering Data

5.1 Events ................................................................. 21
  5.1.1 General Tab .................................................. 22
  5.1.2 Attendees Tab .............................................. 23
  5.1.3 Reminder Tab ............................................... 24
  5.1.4 Recurrence tab ............................................ 24
    5.1.4.1 Recurrence Rule ................................... 25
    5.1.4.2 Recurrence Range .................................. 25
    5.1.4.3 Exceptions ........................................... 26
  5.1.5 Attachments .................................................. 26
  5.1.6 Free/Busy ..................................................... 27
  5.1.7 Manage Templates ......................................... 27

5.2 To-dos ............................................................. 27
  5.2.1 General Tab .................................................. 28

5.3 Required Fields ................................................. 28

6 Group Scheduling .................................................. 30

6.1 Publishing an Event, To-do or Journal Entry .................. 30

6.2 Acting as Organizer in Group Scheduling ..................... 31
  6.2.1 Sending Invitations and Processing Responses ............ 31
  6.2.2 Cancelling an Event or To-do ............................. 31

6.3 Acting as the Attendee .......................................... 31
  6.3.1 Answering an Invitation ................................ 31
  6.3.2 Sending an Alternative Proposal ......................... 32
  6.3.3 Requesting the Latest Version of an Event or To-do .... 32

6.4 Free Busy information ........................................ 32

6.5 Examples .......................................................... 32
  6.5.1 Entering a New Group Event ............................. 32

7 KOrganizer Configuration ........................................... 34

7.1 KOrganizer Main Configuration ................................. 34
  7.1.1 General page ............................................... 34
    7.1.1.1 Personal tab ........................................ 34
    7.1.1.2 Save tab .............................................. 35
  7.1.2 Time and Date .............................................. 35
    7.1.2.1 Regional tab ........................................ 35
    7.1.2.2 Default Values tab ................................ 35
  7.1.3 Views .......................................................... 36
    7.1.3.1 General tab .......................................... 36
    7.1.3.2 Agenda View tab .................................... 37
    7.1.3.3 Month View tab ..................................... 38
    7.1.3.4 Todo View tab ....................................... 38
The KOrganizer Handbook

7.1.4  Colors and Fonts ................................................. 38
  7.1.4.1  Colors .................................................. 38
  7.1.4.2  Fonts tab ............................................... 39

7.1.5  Group Scheduling .................................................. 39

7.1.6  Free/Busy .......................................................... 40
  7.1.6.1  Publish ................................................... 40
  7.1.6.2  Retrieve .................................................. 41

7.1.7  Plugins ............................................................ 41

7.1.8  Custom Pages ..................................................... 41

8  Plugins ................................................................. 42
  8.1  Available Plugins .................................................. 42
    8.1.1  Date Numbers Plugin for Calendars ......................... 42
    8.1.2  Wikipedia ‘This Day in History’ Plugin ...................... 42
    8.1.3  Wikipedia Picture of the Day Plugin for Calendars .......... 42
    8.1.4  Jewish Calendar Plugin .................................... 42

9  Reference ............................................................... 43
  9.1  Menus ............................................................. 43
    9.1.1  File ......................................................... 43
    9.1.2  Edit ......................................................... 44
    9.1.3  View ......................................................... 45
    9.1.4  Go .......................................................... 46
    9.1.5  Actions ..................................................... 47
    9.1.6  Schedule ................................................... 48
    9.1.7  Settings and Help .......................................... 48

10 Other Features ........................................................... 50
  10.1  Command Line ..................................................... 50
  10.2  Drag and Drop Operations ...................................... 50

11 Questions and Answers .................................................. 51

12 Credits and License ..................................................... 52

13 Glossary ............................................................... 53
Abstract

KOrganizer is an easy to use personal information manager (PIM). You can write journal entries, schedule appointments, events, and to-dos. KOrganizer will remind you about pending tasks, and help you keep your schedule.
Chapter 1

Introduction

KOrganizer is an intuitive and easy to use personal information manager (PIM). You can schedule
appointments, events, create to-dos and write journal entries. KOrganizer will remind you about
pending tasks, record your occurrences, experiences, and reflections and help you keep your
schedule.

But KOrganizer is not only about your personal calendar, it can help you to interact with your
colleagues and friends too. With KOrganizer, you can invite anyone with an email address to an
event and process responses, share a calendar (using a groupware server or simply a file over
the network), and share events (e.g. the schedule of a championship or a conference), using
the get hot new stuff framework. KOrganizer is based on open standards, and works with many
different group scheduling servers, giving you the control over your information and the freedom
to choose the best solutions.

KOrganizer is also the calendar, journal and to-do component of Kontact, offering you an inte-
grated solution for your communication and information management needs: email, notes, con-
tacts management, news reader and news feeds reader. Even if you do not use it inside Kontact,
KOrganizer is integrated with the other KDE PIM applications. For instance, you can configure
it to show birthdays from KAddressBook in your agenda, use KMail to send and receive invita-
tions, etc.

Main features of KOrganizer:

• Create To-dos, schedule events, and write journal entries.
• Organize your events and to-dos by grouping the related items in categories.
• Highlight categories with colors.
• Open multiple calendars, and seamlessly view and edit them.
• Reschedule your events by drag-and-drop.
• Generate recurring events easily.
• Organize or attend events using the group scheduling features.
• Choose among the multiple supported groupware servers.
• vCalendar and iCalendar (open standards) native support.
• Calendar merging and import.
• Drag-and-drop between open calendars.
• Embedding collaboration with Konqueror.
The KOrganizer Handbook

- Customizable icon sets.
- Drag-and-drop tool panels.
- Much more...

Now take a Five-minute fly-over course of KOrganizer, or delve into the documentation!
Chapter 2

Five-minute Fly-over Course of KOrganizer

Pressed for time? Let’s get you kick-started with a fast, hands-on overview of KOrganizer!

If you ever worked with a personal information program before, you’ll be right at home with KOrganizer. You can enter new events, reschedule existing events, assign categories to your events, devise new categories, enter and modify lists of attendees and their roles, email event invitations automatically and exchange data with other KOrganizer calendars, create to-dos and write journal entries.

This course assumes that you know how to work with the KDE, and that you prefer to explore on your own. Only the basic functions of KOrganizer are covered here.

2.1 Entering Events

1. Click the Agenda toolbar button or choose the View → Agenda menu item. This will bring up the Agenda View.

2. Click on the desired date in the Date Navigator.

3. Select the text area beside the desired hour in the main panel that reflects the time of the event. Double click this area, or just start typing the title of the event to open the New Event dialog.

4. Enter event details. Use the six tabs at the bottom of the window to move around the dialog and access all the event’s characteristics.

5. Press OK to save the event.

2.2 Entering To-dos

1. Select the Actions → New To-do... menu item to open the New To-do dialog.

2. Enter the to-do details. Use the five tabs at the bottom of the window to move around the dialog and access all the event’s characteristics.

3. Press OK to save the to-do.
2.3 Adding Journal Entries

1. Select the View → Journal menu item to open the Journal main view.
2. Select the Actions → New Journal menu item.
3. Enter journal entry title and text.

2.4 Rescheduling Events

Rescheduling events is a simple drag-and-drop operation:

1. Using the Date Navigator go to the date of the event that you want to reschedule.
2. You should choose an appropriate view before beginning this operation. Only the Agenda view (Day, Work Week and Week views) shows individual hours and are suitable for rescheduling exactly-timed events (appointments), while the Month view only shows days. Therefore the Month view is most suitable for long-term events like holidays.
3. To display the Week view select the Agenda view, press the Week view toolbar button, or choose the Go → Week menu item.
4. Drag and drop the event to the new date and time location.

If you wish to reschedule more precisely, double-click the event and change the start and end time using the drop down menus that divide the day into quarter hours. If that is not precision enough, you can enter the desired time directly.

2.5 Rescheduling or Editing To-dos

You should choose an appropriate view before beginning this operation. Only the To-do List view and the To-do View sidebar component show to-dos which do not have a due date.

To display the To-do List view, press the To-do List view toolbar button, or choose the View → To-do List menu item.
To reschedule a to-do, right click it. This will bring up a context menu. Choose the Copy to or Move to menu items and select the new date from the calendar now appearing. The to-do is now copied or moved to the selected date. Alternatively, if the main panel holds a To-do List view, just right click the column Due Date/Time. A calendar will appear instantly, allowing you to set the new due date.
To edit a to-do, right click it and choose the Edit... menu item.

2.6 Conclusion

This five-minute course covered only the basic operation of KOrganizer. Now you should go on and read the rest of this manual to unleash the full power of KOrganizer’s capabilities. But if you do not feel like it, you should at least skip through the FAQ.
Chapter 3

Importing, Exporting, and Managing Calendars

KOrganizer can store (and retrieve) events, journal entries and to-dos using various methods, and to different locations. Each of these locations is called a calendar resource.

KOrganizer supports calendar files based on standards such as iCalendar and vCalendar natively (adding them as new resources), but you can import the data (merge) into an existing resource and open the file in a new window too. Importing files in the format used by the old ical application is also supported.

You can export your data as an iCalendar or vCalendar file. These files are supported by most scheduling applications.

In this chapter, we will explain how to manage your calendar, using the resources, import and export actions and the get hot new stuff scheme.

3.1 Calendar Resources

KOrganizer uses a local file as its default resource. But this is not your only option: there are several other resources you can add: groupware servers, journal entries as blogs, network files, etc. If you use more than one resource, KOrganizer can be configured to use the default resource or ask which resource to use when saving new events, to-dos or journal entries. KOrganizer will seamlessly merge the items from two or more resources in the views.

The default resource is a good choice for many use cases, but you may want to use another resource, especially if you use a supported groupware server. Please ask the server administrator for the information required to configure the groupware resource, including free/busy information publishing and retrieving. Access to free/busy information allows an event organizer to take the attendee’s calendar into consideration when adding him to the event’s attendee list.

NOTE
Besides calendar storage, groupware servers typically offer contacts, mail and free/busy information storage. Therefore, some of the resources discussed here may be related to other resources from KMail and KAddressBook (the mail and contacts components of Kontact), or to the free/busy settings in the main configuration.

Please note that KOrganizer group scheduling communication is based on a peer to peer email standard. This means that you do not need a groupware server to use it!
The KOrganizer Handbook

A screenshot of KOrganizer’s Add Calendars dialog

1. Open KOrganizer’s settings dialog with **Settings → Configure KOrganizer...** and select the **Calendars** tab from the **General** page. Alternatively open the context menu in the **Calendar Manager** sidebar with a right mouse button click and select **Add Calendar...**

2. If the **Calendar Manager** is not displayed on the sidebar, choose the **Settings → Sidebar → Show Calendar Manager** menu item to display it.

3. Press the **Add...** button to add new resources to the list of available resources.

4. Select the resource to enable it.

5. Later, if you want to edit or delete a resource, select it on the **Calendar Manager** sidebar and press **Delete Calendar** to delete it or **Calendar Properties...** to modify it.

Among the existing resources, you can find in KOrganizer:

**Birthdays & Anniversaries**

Provides access to birthday and anniversary dates of contacts in your address book as calendar events.

**DAV groupware resource**

Resource to manage DAV calendars and address books (CalDAV, GroupDAV).

**Google Calendars and Tasks**

Access your Google Calendars and Tasks.

**iCal Calendar File**

Loads data from an iCal file.

**iCal Calendar Folder**

Provides access to calendar items, each stored in a single file, in a given directory.
The KOrganizer Handbook

KAAlarm Calendar File
Loads data from a KAAlarm calendar file.

KAAlarm Calendar Directory
Loads data from a local KAAlarm folder.

Kolab Groupware Server
Provides access to Kolab groupware folders and e-mail on a Kolab IMAP Server.

Open-Xchange Groupware Server
Provides access to the appointments, tasks, and contacts of an Open-Xchange groupware server.

3.2 Importing, Exporting and Maintaining Calendars

While local files are just one among many other resources that can be used by KOrganizer, they are the most convenient way to share calendars, save copies, or import items from your old calendar program.

3.2.1 Importing Calendars

If you have an iCalendar or vCalendar file, and you would like to import it, choose the File → Import → Import Calendar... menu item. KOrganizer will ask you if you want to Add as new calendar, which adds the calendar file as a new local file resource or Merge into existing calendar, which merges the calendar items into an existing resource.

A good time to do this would be if you received a vCalendar with a few entries via email, for instance, or if you are planning to import your calendar from another application. In the latter case, the first thing to do is to use that application to export the calendar data in one of the formats above, or use a tool to convert from the application’s native format.

3.2.2 Exporting Calendars

You can export your data as an iCalendar file, which is supported by most scheduling applications. KOrganizer will export all calendar items from the enabled (checked) resources which are not filtered out (let’s call these items ‘active’ items). In other words, if you cannot see a calendar item, it won’t be in the exported file. To filter out the undesired items before exporting them, you can create filters. Filters are even more effective if you classify your events and to-dos in categories. To enable and disable resources, check or uncheck the resource box in the Calendar Manager sidebar.

To export all your ‘active’ events, to-dos and journal entries (independent of to what resource they belong) as a new iCalendar file, choose the File → Export → Export as iCalendar... menu item. The Save As dialog will pop up. Enter the file name and location for the new file to complete the export action.

3.2.3 Maintaining Your Calendars

Contemporary computers have ample storage space. However, if you synchronize your KOrganizer calendar with a limited-memory machine like the Palm device, you will find archiving useful. The performance of KOrganizer can also become worse when there are many events. To archive old items, follow the procedure below:
1. Choose the **File → Archive Old Entries...** menu item.

2. Fill in the date in **Archive now items older than** field or use the Calendar Widget to choose the date. Alternatively, you can automatically archive all items older than a certain period of time.

3. If you have chosen archiving, you must also provide a filename for the archive in the **Archive File** field. If you want to re-use an older archive file, press the **Open file dialog** button and find an existing archive. The entries will be added to the file, so any item already in the file will not be modified.

Archiving will keep all old items in a file, including completed to-dos. But if you do not want to keep completed to-dos at all, choose the **File → Purge Completed To-dos** menu item to remove all the completed to-dos from your active resources. If you want to keep your completed to-dos, but do not wish to view them in the to-do lists, consider filtering them out instead of purging them.

### 3.3 Downloading Using Get Hot New Stuff

To open the **Get Hot New Stuff** dialog, which offers a list of calendars to download, choose the **File → Import → Get Hot New Stuff...** menu item. If you select one of the calendars, a dialog with the list of events from the calendars will appear. To merge the displayed events with your default resource, press **Merge**.
Chapter 4

Views and Filters

While calendars (resources) can hold events, to-dos and/or journal entries, these items are very different in nature. To-dos may have no date associated with them, so a schedule view is not suitable to them. Journal entries are a collection your reflections, occurrences or experiences. They require their own view mode, as they are not related with the list of upcoming events or the list of to-dos, etc.

To solve the challenge of displaying your information in a useful and intuitive fashion, KOrganizer offers different views, filters and search capabilities. You can also assign related events and to-dos to categories, which will help you to view them later, using filters or colors.

4.1 KOrganizer Views

In this section, we describe the different view modes, and present an overview of how to browse your personal data using KOrganizer.

The KOrganizer window can be divided into two main areas: the main window and the sidebar. The main window displays the main views and the sidebar displays the Date Navigator, the To-do View, the Item Viewer and the Calendar Manager View. To show or hide the sidebar components, check or uncheck the menu items under the Settings → Sidebar submenu.

The Date Navigator is provided to browse and select dates. Today’s date will be outlined with a small box, dates which have events scheduled on them will be bold (daily or weekly recurring events may not be marked as bold, depending on the view configuration), and holidays will be colored red. If you want to jump to a date, simply click on it. Hold down the mouse to select multiple contiguous dates at once. The What’s Next, List, Agenda and Journal views will only show events, to-dos or journals items from the dates selected in the Date Navigator. The Month view will show events or to-dos from the first month shown in the Date Navigator (the selected days in the month won’t change the Month view, only month changes).

The To-do View sidebar component lists your to-dos, just like the To-do view. It is useful if you want to see your to-dos while using the other views.

The Item Viewer sidebar component shows details of the currently selected events, to-dos or journal entries.

Finally, Calendar Manager Viewer sidebar component allow you to enable or disable the resources on the list, by checking or unchecking the resource box, and to manage your resources. For more information, please check Section 3.1.

You can also browse your calendar view by choosing the Go → Backward menu item (or pressing the toolbar button), which goes to the previous day, week, month or year, choosing the
Go → Forward menu item (or pressing the toolbar button), which goes to the next day, week, month or year (depending on the view), or choosing the Go → To Today menu item (or pressing the toolbar button), which will include the current day in the current view.

4.1.1 What’s Next View

This view displays events and to-dos in a simple format you can quickly read. All open to-dos will be displayed, but only the events from the days selected in the Date Navigator sidebar will be shown. Events and to-dos are displayed one per line.

Switch to the What’s Next view by choosing the View → What’s Next menu item.

4.1.2 Event List View

This view displays all your to-dos, events and journal entries for the dates selected in the Date Navigator as a list. Open to-dos that are not due on the selected dates are not shown. This view is good for displaying many different items in a compact fashion. It is also useful if your events are spread out over a long time period that would not be displayed completely on the screen when using one of the other views.

The items are displayed one per line. Columns show if a reminder is set (a bell icon displayed in it means the reminder is set), if it repeats multiple times (a chasing-arrows icon means a repeating event), the start and end time information. Hovering the mouse over an item will bring up a tooltip with detailed information about the item.

Switch the display to the list view by choosing the View → Event List menu item.

4.1.3 Agenda View

The Agenda view presents your events or due to-dos for one or more days, sorted chronologically. You can also see the length of each event in the day timetable. To enable the Agenda view choose the View → Agenda menu item or press the toolbar button.

The Day, Work Week and Week views are variations of the Agenda view. In fact, you can set the days shown in the Agenda view at any time by selecting them in the Date Navigator.

Time is indicated by a time bar on the left side of the view. A scrollbar on the right is provided when the whole day cannot be displayed on a single screen (which is the usual case). Each rectangle in the view represents an individual event or to-do due for that time, and displays the start and end time and summary. A bell icon is displayed if a reminder is set, and a chasing-arrows icon is displayed if it repeats multiple times. Hovering the mouse over an calendar item will bring up a tooltip with the item detailed information. To make KOrganizer show a red line marking the current-time on the current day (the Marcus Bains line), check the Show current-time (Marcus Bains) line box in the KOrganizer view configuration.

Any event can be re-sized with your mouse. Simply move the mouse pointer near the top or bottom edge of the event, and drag the edge up or down. This way you can visually modify the starting and ending time of your event. This also works in the Week and Work Week views. In other words, it is possible to change start and end times with the mouse by just moving the upper or lower border of the event to the new time.

Any event can be rescheduled with your mouse. Move the mouse pointer over the event, and drag it to a new time location. This also works in the Week and Work Week views. Events can be moved to other, presently non-visible dates. Move the mouse pointer over the event, and drag it to the Date Navigator.
Since the Agenda view cannot contain the whole day on most screens, you will have to scroll up and down to see the whole day. There is a useful hint that tells you if there are any currently invisible events above or below your current view; it is a small down-pointing arrow at the bottom of each day view or up-pointing arrow at the top.

**Tip**

There are two useful shortcuts for adding events:

- Double-click any open region of time, and KOrganizer will automatically create an event with default duration (which is customizable in the preferences dialog). You can immediately add the title. The events ‘snap’ to half-hour increments, rounding off to the closest half hour from where you clicked.

- Select any open region of time, and double click it or start writing the title of the event. KOrganizer will automatically set the duration and start time as defined by the selection area in the Agenda view.

To help you organize your agenda, the color of the events reflect their category, and depending on the KOrganizer view configuration, it may also reflect its resource. Therefore, if you assign categories to events and different colors to categories, you will be able to quickly identify the type of event by its color.

The Agenda view can display events from all your calendars merged into one view or show a view per calendar. Having both views available via tabs is also possible and can be customized in the preferences dialog.

### 4.1.3.1 Day View

This view presents the Agenda view for a single day.

Switch the display to the Day view by choosing the Go → Day menu item or pressing the Day button in the toolbar.

### 4.1.3.2 Next X Days View

This view presents the Agenda view for the next days, starting from today. You can change the number of days to be displayed in the KOrganizer view configuration. The default value is 3.

Switch the display to the next days view by choosing the Go → Next X Days menu item, (X represents the number of days, usually 3).

### 4.1.3.3 Week View

The Week view provides a view similar to the Day view. Events for seven days are shown next to each other.

Switch the display to the Week view by choosing the Go → Week menu item or pressing the Week button in the toolbar.

### 4.1.3.4 Work Week View

This is the same as the Week view, except that it shows only the working days of the week.

Switch the display to the Work Week view by choosing the Go → Work Week menu item.
4.1.4 Month View

The Month view shows all the events and due to-dos for the current month in a familiar month calendar layout. Each cell in the view represents a day, and each day contains all of the events that can fit in the area provided (maximizing the window will enable you to see more appointments). Information on repeating and reminder status is indicated through bell and chasing arrows icons, just as in other views.

Navigate the Month view using the Date Navigator arrows, or the items and toolbar buttons from the Go menu. Since the visible area of a day cell may not contain all events and to-dos, you can use the keyboard to browse the items, or you can use the scrollbars to see all the events and to-dos from that day.

Hover your mouse over any calendar item to display a tooltip with the item details. Double click an empty area to create an event, double click any calendar item to edit it.

To help you organize your data, the color of the events may reflect their category, and its resource, depending on the KOrganizer view configuration. Therefore, if you assign categories to events and different colors to categories, you can identify the type of event (or resource) by its color.

Switch the display to the Month view by choosing the View → Month View menu item or pressing the Month button in the toolbar.

4.1.5 Timeline View

The Timeline view shows all events for the selected timespan in a gantt view. Every calendar is displayed in a separate line.

Hover your mouse over any calendar item to display a tooltip with the item details. Double click an empty area to create an event, double click any calendar item to edit it.

4.1.6 To-do List

The To-do List provides a place for you to jot down quick (or long-term) notes about things that need to be done. The To-do View sidebar component appears right below the Date Navigator.

You can also display it in the main panel if you click the To-do List view toolbar button or if you choose the View → To-do List menu item.

You can give your to-do a ‘date due’, in other words a date when the to-do should be finished.

You can also assign priorities to to-dos, and they will appear sorted in order of priority. The lower the number, the higher the priority, except that zero (0) is defined as ‘no priority.’

To make a new to-do entry, right click the To-do View sidebar component, or the To-do List view, and choose the New To-do menu item. If you right click an already existing to-do, you will get more choices: you can Show the summary, Edit... the to-do details, Delete the to-do altogether, or you can create a New Sub-To-do... You could for example make a large to-do like building a house, and make sub-to-dos like choosing the right building site, hiring an architect, hiring workers and finally arranging a party for your friends.

When you choose New To-do..., a dialog will pop up, allowing you to enter all necessary information.

Click any to-do in the list to highlight it. If you click the thick-line box on the left of the to-do description, you will change the ‘completed’ status of the to-do. If you double-click the to-do description, you will be able to edit all its details.

You may also pick Purge Completed from the right mouse button menu to delete all to-do entries that you have marked completed.

To-dos can also be dragged around with the mouse to rearrange the hierarchy or to exchange to-dos with other calendar windows. You can also read an overview of all available drag-and-drop operations.
4.1.7 Journal View

The Journal view provides a place for you to record your reflections, occurrences or experiences.

You can display the Journal view in the main panel if you press the Journal View toolbar button or if you choose the View → Journal menu item.

When you click the add journal entry link, a new journal entry will be created. If you want to edit a journal entry, just click the text box and edit it! To remove a journal entry, press the delete button next to the Title of the journal entry.

4.2 Categories

To help you organize your entries in related groups, you can assign categories to events, to-dos and journal entries. If you assign categories, you can use them later when searching, filtering, and displaying events and to-dos.

To assign categories when editing or creating new events or to-dos, select a category from the drop down box labelled Categories in the General tab. You can assign more than one category for each item.

To create, delete and edit categories, choose the Settings → Manage Categories... menu item to open the Edit Categories dialog. If you assign different colors to categories, you will be able to quickly identify the type of event by its color, either in the Agenda view or in the Month view (depending on the KOrganizer view configuration).

4.3 Filters

To help you view, find and export your data, you can create and use filters for your calendars. For instance, if you do not want to view completed to-dos, you can filter them out, instead of purging them. If you assign categories, you can use them to create filters.

To create, delete and edit filters, choose the Settings → Manage View Filters... menu item to open the Edit Calendar Filters dialog. Using this dialog, you can create, delete and edit filters that will affect which items will be displayed by KOrganizer.

The View → Filter submenu and the filter toolbar drop down offer access to all available filters created using the Edit Calendar Filters dialog. To toggle the display of the filters toolbar on and off, choose the Settings → Toolbars Shown → Filters Toolbar. If you do not want to use any filter, choose No filter.

Filters are useful when exporting your calendar. If you use a filter, only the filtered (visible) items will be exported. Also, filters are more effective when the items are already classified and organized in categories, as you can easily create filters based on categories.

4.4 Searching

Choose the Edit → Find menu item or press the Ctrl+F shortcut to find items (events, to-dos or journal entries) according to title, description, and/or categories. The find action will only search the specified fields.
You can use wildcards if you do not remember the exact summary. If you do not know a single character of the summary, put ? instead of the missing character. If you do not know more characters, use *. For instance if you know that the event or to-do has *meeting in the beginning and product after, you would write meeting*product in the Find dialog. KOrganizer will locate entries like 'To-do: arrange meeting about the new product', 'Meeting to discuss the old product line' and similar. Letter case is ignored.

The result of the Find operation is a list of events, journal entries and/or to-dos with the specified keyword. The search list characteristics are the same as the List View.

This resulting list is active. You can double-click a line to display or edit the event or to-do details. Get more information about these details in Section 5.1 and Section 5.2.
Chapter 5

Entering Data

5.1 Events

Events are future or past appointments, like business meetings, personal anniversaries and cinema visits. An event can also take several days, like holidays.

Entering a new event is very easy. Just choose the Actions → New Event... menu item. A window with five tabs at the bottom will appear.

If you wish you can use a different way to create a new event:

1. Use the Date Navigator to go to the event date.

2. Switch to Agenda view and click the desired view’s icon on the View Toolbar or select the desired view from the Go menu. Since your event starts at a particular time, you should choose a view that displays hours of the day. You may choose Day, Work Week view or Week view. The Month view is more suitable for to-dos, described below.

3. In the main panel, double click the time and date when your event starts.

4. A dialog with six tabs at the bottom of the window appears. Enter your data as described below.
A screenshot of KOrganizer’s Edit Event dialog

This is a thorough description of the individual event window fields and widgets. Not all fields have to be filled in; some can be left empty. Read the Required fields section for detailed information. And if you prefer to learn by example, there’s one in the Entering event section.

Title:

Enter short description of the event into the Title field. This description is the text shown on the KOrganizer main panel.

Location:

Enter short description of the location where the event will take place.

Start and End

The KOrganizer suggested Start and End dates of your event. Events are expected to start and end on the same date. Change these dates as desired. Enter the dates directly or use the Calendar Widget. Select the time from quarter hour intervals, or enter the desired time directly into the time fields. These fields are only available when the All Day box is not checked.

5.1.1 General Tab

Details:

Enter a long description of the event in the large, untitled rectangle. You can write as many details as you wish here. For example, If the event is, say, planned general repair of your car, you can list all items that need repairing. Later on you can print this list and hand it over to the serviceman. If the event is shopping, you should list the goods that you need to buy. Print the event and take it to the shop with you.

Categories
You can assign several categories to a calendar item. Click the drop down box to display all available categories. Check the category boxes to assign suitable categories to the event.

You can also add a new category, modify a category or delete a category in the Edit Categories dialog. Open this dialog with Settings → Manage Categories.

**Tip**

Your language lesson at work may belong to both Business and Education categories, while the anniversary of your marriage belongs to either Personal or Special Occasion - it is your choice.

**Access:**

Choose Public, Private or Confidential to keep the event private or confidential. Currently, this choice correctly sets the ‘CLASS’ attribute of the events to ‘PUBLIC’, ‘PRIVATE’ or ‘CONFIDENTIAL’. However, whether these settings are really used to restrict the access of the information depends on the client and/or groupware server implementation.

**Warning**

Currently, KOrganizer will display items owned by other people and marked as confidential. Other clients may treat them differently, but be careful when publishing private or confidential events: iCalendar is a text file format, and can be read with any text editor (if someone has read access to them). So if you want to keep items really confidential, make sure you use a resource that only you can access.

### 5.1.2 Attendees Tab

Choose in this tab the people you want to invite to your event.

![A screenshot of KOrganizer’s Edit Event dialog - Attendees tab](image)

**Meeting Organizer:**

Sets the identity corresponding to the organizer of this to-do or event. If KOrganizer is configured to send invitation emails, the identity selected on this combo box will be used when sending these emails. The default identity can be set in the Personal section of the KOrganizer configuration. In addition, identities are gathered from your KMail settings and from your address book.
Attendee list

The list in the center of the tab displays the attendees selected for this event, and lets you add attendees by entering the name and mail address, edit or remove them.

If the attendee(s) are in your Address Book, you do not have to remember or type his email address to add it to the attendee list. Just click the Select Addressee... button and choose the attendee(s) from the list. Please note that this is the standard KDE address book, which is also used by KMail and can also be called as a separate application (KAddressBook).

Participants

Choose the role of the attendee (Participant, Optional Participant, Observer, Chair) from the drop down menu at the left side of an entry. The role is a simple reminder of what part the attendee plays in this event.

Status

Choose the status of the attendee (Needs Action, Accepted, Declined, Tentative, Delegated) from the drop down menu at the right side of an entry. If you use groupware schedule and request responses from your attendees, as you receive the responses the status of the attendee will be updated. If you do not request responses, you will have to update the status manually.

Request Response

Select Request Response from the drop down box if this attendee should respond to your schedule plan. Consequently the attendee will be emailed with the event schedule information. A small envelope will appear in the details list to indicate this. This feature is specially useful when groupware scheduling is enabled, as the attendee’s status is updated automatically.

5.1.3 Reminder Tab

Reminder

Select a default reminder in the drop down box and press Add if KOrganizer should remind you about an event.

Use the Configure button to open the Edit existing reminder dialog. Using this dialog, you can choose how many minutes, hours or days before or after the events start or end you want to be reminded, you can set repeating intervals for your reminders, and create special reminders that display text, send emails, play sounds or run programs and scripts.

TIP

If you select to run a specific program or script at the reminder time, make sure, however, that you have sufficient rights to run that program; if you do not, the program will not run.

5.1.4 Recurrence tab

Some events take place regularly. You can specify their exact scheduling here.
5.1.4.1 Recurrence Rule

Choose if you want to repeat this event daily, weekly, monthly or yearly. More detailed options are as follows:

**Daily**
Specify whether the event occurs every day (1), every other day (2) and so on.

**Weekly**
Specify whether the event occurs every week (1), every other week (2) and so on. Also specify the days (Sunday ... Monday) on which the event occurs.

**Monthly**
You can either have the event occur on the same day of the month, or in a specific week on a specific day of the week. You need to choose between these two possibilities. By default, KOrganizer assumes you want to repeat on the same calendar day of the month (for instance the 15th). You can also adjust the period, so you can repeat monthly, tri-monthly and so on.

**Yearly**
This is similar to Monthly. You need to choose whether or not you are indicating a calendar day of the year (e.g., the 250th day of the year), in a specific week on a specific day of the week of a month (e.g., the 2nd Tuesday of March), or the day of the month in a particular month of the year. By default, KOrganizer assumes you mean the day of the month. You can adjust the period to reflect events that occur bi-annually, every four years, and so on.

5.1.4.2 Recurrence Range

By default, events which repeat will do so forever; there is no ‘end’ to the repetition. This may or may not be desirable, so you are able to terminate the repetition by selecting an end date or a number of occurrences.
5.1.4.3 Exceptions

You may have a very nice recurrence rule set up, but realize that there are a few exceptions. If you set up your college class schedule for instance, you may want to make exceptions for holidays and the like. In this area, you can add, change, and delete dates from the list of exceptions (i.e. times when even if the recurrence rule matches, the event will not be scheduled). Pick a date with the date selector, and press Add to include it. For removing dates, highlight them in the box on the right side, and then click Delete.

5.1.5 Attachments

Events and to-dos can contain attachments. Attachments can either be stored as links or inline. To add an attachment press the Add button.

A screenshot of KOrganizer’s Edit Event dialog - Attachments tab
Checking Store attachment inline will cause the attachment to be stored inside your calendar, which can take a lot of space depending on the size of the attachment. If this option is not checked, then only a link pointing to the attachment will be stored. Do not use a link for attachments that change often or may be moved (or removed) from their current location.

The following actions in the context menu are provided to work with attachments:

Open
Display the selected attachment with the associated application.

Save As...
Allows to save an existing attachment with a different name.

Copy, Cut and Paste
Allows to copy, cut and paste to and from the clipboard.

Remove
Deletes the selected attachment.
Properties...

 Allows to change an existing attachment.

5.1.6 Free/Busy

When adding attendees to your event, you need to know if they are busy or free in that particular time. If the attendees make their free / busy information available, you can view here their schedule before sending the invitations.

This shows the free/busy schedule chart on the right, where each line represents one of the attendees, listed on the left. The marked areas on the chart represent the time already taken by other events, unmarked areas represent time free from other events. You can move the event to a different point in time by dragging it with the mouse, or resize it by moving the edges of the highlighted area with the mouse.

The free/busy information is only available if the attendee publishes his free/busy schedule, and if KOrganizer is correctly configured to retrieve it. For more information about configuring KOrganizer to publish and retrieve free/busy information, please check the chapter 7. Double-clicking on an attendee entry in the list will allow you to enter the location of their free/busy information.

Scale

Sets the zoom level on the schedule chart. Hour shows a range of several hours, Day shows a range of a few days, Week shows a range of a few months, and Month shows a range of a few months, while Automatic selects the range most appropriate for the current event or to-do.

Center on Start

Press this button to center the free/busy schedule chart on the start time and day of this event.

Pick Date

Press this button to automatically move the event to a date and time when all the attendees are free.

Reload

Press this button to reload Free/Busy data for all attendees from the corresponding servers.

When you want to confirm, call off or revert the entered data, choose among the Action Buttons OK, Apply and Cancel.

5.1.7 Manage Templates

The Manage Templates button opens a dialog which enables you to save the current event as a template, so that you can reuse the data entered for future events. As an example you can save a template for a meeting that takes place at the same location and with the same people.

With the Apply button you can use an existing template for your event. Continuing the example in the preceding paragraph you can specify the agenda of the meeting.

5.2 To-dos

The To-do List is a place for you to write down notes to yourself about things that you need to do. To-dos are tasks, that may or may not be scheduled. There are short-term and long-term to-dos. For instance you should go to a hairdresser within a week, and you should sell your old
car within a year. You likely do not want a reminder go off at a particular time, you just want to have a list of things that you must do, and dates when they must be finished at the latest (date due).

To enter a new to-do, choose Actions → New To-do.... A window with five tabs at the bottom will appear.

### 5.2.1 General Tab

![A screenshot of KOrganizer’s Edit To-do dialog](image)

This tab shares a lot of options with the Edit Events dialog, but has some additional items for to-dos:

**Completion**

This is a percent completed pull down menu initially set at 0% complete. Later on, you can indicate your progress by adjusting the percent completed in steps of 10%.

**Priority**

Assign a priority to your to-do. This drop down menu offers priorities from one to nine, one being the highest. Initially to-dos are set to priority five (medium).

### 5.3 Required Fields

This is an overview of what fields are required and what fields can be empty when entering events and to-dos:

- In the General Tab, you should at least fill the Title field and the description (the large rectangle), even though neither is mandatory. If you set a Reminder, you should also specify the time, and either the sound to be played or the program to be run.
The KOrganizer Handbook

• The Attendees tab may be left completely empty.
• The Recurrence tab must only be filled if you select a daily, weekly, monthly or yearly repeat.
• The Attachments dialog may be left completely empty.
Chapter 6

Group Scheduling

The group schedule functionality of KOrganizer allows you to organize appointments, meetings and shared to-do items, request responses from attendees and publish items. If you are being invited to an event or to-do, you can reply to it, stating if you will be able to attend, or send a counter proposal, with different arrangements, like a different time or location. You can also publish your free/busy schedule, to let people know when you are available, and request the same information from others.

Currently, KOrganizer schedules events and to-dos using email to transport the data, in a standards based scheme, the IMIP-protocol for group scheduling. Being a standard, IMIP is used by many other clients too. For example Microsoft® Outlook, Lotus Notes and Novell Evolution. This means that you can share events with other users using one of these clients. KOrganizer is integrated with KMail for receiving, processing, and sending events, event responses, updates, cancellations, etc. For instance, when you get an invitation in KMail, and decide to accept it, by clicking the accept link in the mail body, the event is added to your calendar, and a response to the event’s organizer is sent automatically.

If you check the Use Groupware Communication box in the KOrganizer group scheduling configuration, KOrganizer will handle the group scheduling communication for you. In other words, you will seldom need to use the Schedule menu directly to perform the scheduling actions. For instance, if you create an event or to-do with attendees, KOrganizer will ask you if you want to send the invitations to the attendees, so you will not need to use the Schedule → Send Invitation to Attendees menu item later. Also, if you change your status as an attendee for an event you were invited to, it will ask you if you want to send your updated status to the event’s organizer, so you will not need to use the Schedule → Send Status Update menu item later.

6.1 Publishing an Event, To-do or Journal Entry

If you simply want to send an event, to-do or journal entry, choose the Schedule → Publish Item Information... menu item, when the item is selected. Then a dialog appears, asking you the email addresses which will receive the event or to-do. The item will be sent by email, in the iCalendar format.

Please note that you can use this action to email any item to anyone, not just to the item’s attendees. In fact, you can publish an item with no attendees at all, as publishing does not request an answer from the attendees.

An example: you are playing in a band and, from time to time, you give live concerts. To notify your fans about the concerts, you maintain a mailing list. If you use KOrganizer to organize your concert dates, you can just choose the Schedule → Publish Item Information... menu item, put in the address of the mailing list and the event gets sent. Mailing list subscribers who use KOrganizer get the concert date automatically inserted in their calendar.
Publishing an event as described above will only inform the receiver about the event, but not give her the option to ask for attendance. Use Schedule → Send as iCalendar... if you want to provide that option instead.

### 6.2 Acting as Organizer in Group Scheduling

When you create an event or a to-do, and add attendees to it, you are acting as the event organizer. To add attendees, use the attendee tab, in the Edit Event, or Edit To-do dialog. In the Agenda view, a little icon is placed in the event, if you are the organizer of a group scheduling event.

The organizer is responsible for sending the invitations, collecting the attendees responses, and for keeping the data of the event or to-do up to date for all people involved.

#### 6.2.1 Sending Invitations and Processing Responses

To organize an event or to-do, create it in KOrganizer and add all the people that should attend using the attendees tab. KOrganizer can send invitations to the attendees, either automatically depending on KOrganizer group scheduling configuration, or by selecting the event or to-do and choosing the Schedule → Send Invitation to Attendees menu item. The attendees get an email containing all the relevant information for the event or to-do. They can respond to the meeting proposal by accepting or rejecting it or by making a counter proposal. They can also delegate or forward the invitation. All this information is sent to you by email again and, if you have configured KMail appropriately, the attendees responses are automatically inserted in your calendar. If there are additional attendees willing to participate (e.g. by accepting a forwarded invitation) you will be asked to accept the new attendees.

#### 6.2.2 Cancelling an Event or To-do

To cancel an event or to-do you have to be the organizer. If you checked the Use Groupware Communication box in the KOrganizer group scheduling configuration, just delete the item, and KOrganizer will ask you to send the cancellation. If not, simply select the item, and choose the Schedule → Send Cancellation to Attendees menu item.

This action will send a cancel-message to all attendees, so they can remove the item from their calendars too.

### 6.3 Acting as the Attendee

When you get an email with an invitation and accept it, the event or to-do is added to your calendar. If it is an event, a little icon is placed in the event in the Agenda view.

#### 6.3.1 Answering an Invitation

If you have an invitation in your KMail inbox you can either press Reject to ignore the request, or press Accept or Accept Cond. The last two actions will insert the item into your calendar. In any case, KMail will send your response to the organizer automatically.

You can also Delegate or Forward the invitation. When delegating, you can suggest another person as your proxy. Using Forward you can forward the invitation to one or more people not
yet invited. When the receiver of the delegation or forward accepts the invitation, the organizer will be asked to approve the new attendee.

If for any reason you changed your mind, edit your status in the item’s attendee tab. If you checked the Use Groupware Communication box in the KOrganizer group scheduling configuration, KOrganizer will ask you to send an email updating your attendee status. If not, choose the Schedule → Send Status Update menu item to send your status update.

### 6.3.2 Sending an Alternative Proposal

If you are not satisfied with some of the characteristics of the event or to-do you got invited to, and want to send a counter proposal to the organizer (for instance an alternative location or time), just edit the item and send it back as your proposal, by selecting the item and choosing the Schedule → Request Change menu item.

The organizer of the event will get your proposal by email, and will be able to accept it or decline.

### 6.3.3 Requesting the Latest Version of an Event or To-do

To request the latest version of an event or to-do, select the item, and choose the Schedule → Request Update menu item. The organizer should then send you back the latest version of the item.

### 6.4 Free Busy information

The free/busy information represents an availability schedule. By presenting the intervals when one already has previous commitments, others can avoid arranging appointments for these periods. Note that only the times are published, not the events, reasons or attendees.

KOrganizer supports publishing and retrieving free/busy information, either manually or automatically.

To email your free/busy information, choose the Schedule → Mail Free Busy Information... menu item. Enter the email addresses you want to send the information to in the dialog and press OK.

Groupware servers usually have a standard location for uploading your free busy information, so that other users can access your data, and you can access other user’s free busy schedule. You can configure KOrganizer to upload and download free busy information automatically, using the Free Busy preferences, in the KOrganizer Configure dialog.

To upload your free/busy information to the server set in KOrganizer preferences, choose the Schedule → Upload Free Busy Information menu item.

### 6.5 Examples

#### 6.5.1 Entering a New Group Event

In this example, you’ll enter an event. You need to arrange a meeting on the next Monday regarding launch of your new Product. Your boss Joan Holden will be the event chairwoman owner, and you, Jack Smith, will be the event organizer. There will be two more attendees (participants): Peter Krzinski and Kirsten Friese. Joan gave you the program of the meeting. The appointment will start at 12 noon and end at 1 pm. The same appointment should be scheduled (recurred) each Monday.
1. Using the Date Navigator, go to the next Monday.

2. Choose the Actions → New Event..., or select the area between 12 noon and end at 1 pm, and start typing the event title.

3. Enter a suitable title. It’s important to choose the right brief description, because this is the only field that can be searched. We suggest that you enter Product launch event.

4. Enter the detailed event program into the largest rectangle area. For the sake of this simple example, enter Introduction, The Plan, Conclusion on three separate lines.

5. Go to the Reminder tab. Set the reminder time to 15 minutes, just long enough to brew a cup of tea prior to the meeting start.

6. Select Appointment from the Categories drop down box.

7. Go to the Recurrence tab and select the Weekly repeats.

**NOTE**
Most work has been done for you automatically. KOrganizer defaults to recurring weekly. Also note that Ends: never is chosen. This means that this event will be repeated each Monday (starting, of course, on Monday August 30, 2010) until the end of time (that is, until you delete it).

8. Since everything is all right here, click the Attendees tab.

9. In the Attendees tab you should do the following:
   
   (a) You will see that you are the organizer of the event.
   
   (b) In the first input field enter the email in the Name <email> format. In our example, enter Joan Holden <jholden@thiscompany.com>.

   **Tip**
   If the attendees are already in your KDE address book, instead of typing the names and emails, you can press the Select Attendees... button to add them.

   (c) Choose Chair as the role.
   
   (d) In the next input field enter Peter Krzinski <pkrzinski@thiscompany.com>.
   
   (e) In the next input field enter Kirsten Friese <kfriese@thiscompany.com>.

10. If you have configured KOrganizer to use groupware communication, you will be asked if you want to send an email to the attendees, with details of the event and asking for a response if the Request response box from the Attendees tab is checked. Else, you can send the invitations choosing the Schedule → Send Invitation to Attendees menu item.

11. Review the event setup by clicking on the tabs. If you are satisfied, click OK.

Congratulations, you’ve scheduled your first event!
Chapter 7

KOOrganizer Configuration

To change KOOrganizer’s look and behavior, choose the Settings → Configure KOOrganizer... menu item. You can get more information about all the configure options and possibilities in Section 7.1.

To customize the set of tools available on the bar, choose the Settings → Configure Toolbars... menu item and read the Section Customizing Toolbars in the KDE Fundamentals.

Localization information like date and time formats can be configured from System Settings within the modules Language, and Formats. These control modules can be accessed from within KOOrganizer: just choose the Settings → Configure Date & Time... menu item. KOOrganizer has to be restarted for changes done in System Settings to take effect.

To configure where KOOrganizer stores and retrieves calendar events, journal entries and to-dos, (in local files, groupware servers etc.), please check Section 3.1.

7.1 KOOrganizer Main Configuration

The options dialog lets you configure a number of different areas of KOOrganizer.

7.1.1 General page

7.1.1.1 Personal tab

The personal options relate to your personal identity, and other miscellaneous things that do not fall under any of the other general categories.

Full name

Full name is initially set to ‘Anonymous’ with an email address of ‘nobody@nowhere’. You can change your name by directly entering it here. This name will be displayed by default as Organizer in to-dos and Events.

Email address

Email address will be used to identify the owner of the calendar. When another person opens your calendar or events, he/she will not be able to modify it because it will be read-only.

Default Email Attachment Method

This option allows you to select the way an email is attached to an event. You can attach an email as the complete email including attachments, the email excluding attachments or only a link to the email.

Note that attaching an email without attachments might invalidate its signature.
7.1.1.2 Save tab

Confirm deletes
When you check Confirm deletes box, KOrganizer will ask you to confirm each deletion. If this is not checked, KOrganizer will not ask before deleting events.

New Events, To-dos and Journal Entries Should
This option lets you choose between adding new items to the standard calendar or making KOrganizer ask you which calendar should be used to save each new item.
Kolab2 server specificity: It is recommended to choose Be asked which calendar to use, if you intend to use the shared folder functionality of the Kolab server. This will allow you to keep control of which information is available only to you, and which information is published in the shared folders.

7.1.2 Time and Date

7.1.2.1 Regional tab

Day begins at
Select the time you start your day from the drop down list. It could be the time when you usually get up, or the time when you start working. This setting does not prevent you from adding or viewing items before this time, it just sets the time that will be displayed by default on the top of the calendar view. Use the scrollbar to display earlier or later events in the Agenda view.

Holidays
Select your country from the drop down list, or if it is not listed, select (None). If your country is selected, KOrganizer will recognize and display its important dates and holidays in the calendar view.

Working Period
The options Daily starting hour and Daily ending hour let you specify when your working day starts and when it ends. KOrganizer sets the working hours apart by marking them with a different color from the non working hours, holidays and non working days.
Additionally, you have check boxes beside each day of the week. Check the week days that are working days for you, in order to mark the working hours in these days. Checking Exclude holidays prevents KOrganizer from marking the working hours for the holiday days in the region defined in the Use holiday region drop down above.

Weekly Start Day
Select the first day of each week. Normally, you can ignore this since it is set in your locale.

7.1.2.2 Default Values tab

Default appointment time
Select the default start time for events from the drop down list. When you choose New Event from the Actions Menu, or create an event in some other manner such that KOrganizer cannot guess when you would like your event to start, KOrganizer will put this hour in the start time editor as the default value.
Default duration of new appointment (HH:MM):

Select the default duration for events using the spin box. When you choose New Event from the Actions Menu, or create an event in some other manner such that KOrganizer cannot guess its duration, KOrganizer will use this as the default value.

Reminders

Select a Default reminder time to determine how long before the actual event’s scheduled time the reminder will activate.

Set a file to be used as the default sound file for new reminders. You can always specify another file in the Advanced Reminder accessible from the event or to-do editors.

Check the next two boxes if you want to enable reminders for all newly created events or to-dos. You can always turn-off the reminders in the editor dialogs.

7.1.3 Views

These options let you configure KOrganizer views:

7.1.3.1 General tab

Next x days:

This option allows you to change the number of days shown by the Next x Days menu item in the Go menu.

Enable tooltips for displaying summaries

If your summary for an event is longer than would fit in the current View, the remaining characters are not displayed. Check Enable tooltips for displaying summaries if you want the full summary displayed when hovering the mouse pointer over the appointment for a few seconds.

To-dos use category colors

Check this box so that to-dos will use category colors and not colors specific to their due, due today or overdue state.

Date Navigator options:

Show items that recur daily

If the Show items that recur daily box is checked, the days containing daily recurring events are shown in bold typeface in the Date Navigator.

Show items that recur weekly

If the Show items that recur weekly box is checked, the days containing weekly recurring events are shown in bold typeface in the Date Navigator.

Show to-dos instead of events when in Todo View

Check this box to show the days containing to-dos in bold typeface in the Date Navigator when in To-do view.

Show journals instead of events when in Journal View

Check this box to show the days containing journals in bold typeface in the Date Navigator when in Journal view.

Week numbers select a work week when in work week mode

If the Week numbers select a work week when in work week mode box is checked, clicking on the week numbers along the side of the Date Navigator will navigate through work weeks rather than through normal 7-day weeks.
The KOrganizer Handbook

7.1.3.2 Agenda View tab

Agenda View options:

Hour size:
By using this you can control the height of the rows in the Agenda view.

Show icons in agenda view items
Check this box to display icons (reminder, recursion etc.) in Agenda view items

Show to-dos
This check box toggles the display of to-dos in the Day, Week and Month views in the Agenda view. If you have too many to-dos which have a due date associated, you may want to turn them off to avoid clutter.

Show current-time (Marcus Bains) line
This check box toggles on or off a red line in the Day or Week view indicating the current time (Marcus Bains line). This line gives you an indication of how much time is left e.g. until a meeting takes place.

Show seconds on current-time (Marcus Bains) line
This check box toggles on or off the seconds on the current-time line (Marcus Bains line).

Time range selection in agenda view starts event editor
Check this box to start the event editor automatically when you select a time range in the daily and weekly view. To select a time range, drag the mouse from the start time to the end time of the event you are about to plan.

Color Usage
Select the Category inside, calendar outside option if you would like to draw calendar items in their associated category color, with the item’s border drawn in the color of its calendar.
Select the Calendar inside, category outside option if you would like to draw calendar items in their associated calendar color, with the item’s border drawn in the color of its category.
Select the Only category option if you would like to draw calendar items (both inside and border) in the color of their associated category.
Select the Only calendar option if you would like to draw calendar items (both inside and border) in the color of their calendar.
Please use the Colors and Fonts configuration page for setting these colors.

Color busy days with a different background color
Check this box if you want Agenda view’s background to be filled with a different color on days which have at least one all day event marked as busy.
Please look in the Colors configuration area to select the Agenda view background busy color of your choosing.

Multiple Calendar Display
Select if all calendars should be merged into one Agenda view, each calendar should be displayed in its own Agenda view or if each view should be available via tabs. The side by side view can be customized with Configure View from the context menu.
7.1.3.3 Month View tab

Month view options:

Display Options
Use the first four check boxes to display the time, icons (reminder, recursion etc.), to-dos or journals in Month view.

Color busy days with a different background color
Check this box if you want Month view’s background to be filled with a different color on days which have at least one all day event marked as busy.
Please look in the Colors configuration area to select the Agenda/Month view background busy color of your choosing.

Color Usage
Configure the colors for the Month view as in Agenda view.

7.1.3.4 Todo View tab

Todo view options:

Always display completed to-dos at the bottom of the list
If you enable this option, all completed to-dos will be always grouped at the bottom of the To-do List.

Record completed to-dos in journal entries
If you check this box, KOrganizer will automatically add a journal entry for every completed to-do.

7.1.4 Colors and Fonts

7.1.4.1 Colors

Choose the color used for holidays, for highlighting, and for specific event categories. You can choose a different color for each category. Of course too many colors may be confusing, so use common sense. The use of color depends also on the view preferences.

Holiday color
This button opens the Select Color dialog, allowing you to select the holiday color. The holiday color will be used for the holiday name in the Month view and the holiday date in the Date Navigator.

Agenda view background color
This button opens the Select Color dialog, allowing you to select the Agenda view background color.

Busy days background color
This button opens the Select Color dialog, allowing you to select the Agenda or Month view background busy color. This color is only used when the option for drawing busy days with a different color is set in either of these views.
Agenda view current-time line color
This button opens the Select Color dialog, allowing you to select a color for the current-time (Marcus Bains) line.

Working hours color
This button opens the Select Color dialog, allowing you to select the color of the working hours background in the Agenda view.

To-do due today color
This button opens the Select Color dialog, allowing you to select the to-do due today color.

To-do overdue color
This button opens the Select Color dialog, allowing you to select the to-do overdue color.

Categories
This group allows you to assign a color to each category. Select a category in the drop down list, and press the button to open the Select Color dialog, allowing you to select the color for that category. Depending on the view preferences, this color will be used to mark events and to-dos which belong to this category in the Agenda and Month views.

Resources
This group allows you to assign a color to each resource. Select a resource in the drop down list, and press the button to open the Select Color dialog, allowing you to select the color for that resource. Depending on the view preferences, this color will be used to mark events and to-dos which are stored using this resource in the Agenda and Month views.

7.1.4.2 Fonts tab

Time bar
Press this button to pick the font, font style and size for the time bar.

Month view
Press this button to pick the font, font style and size for the Month view.

Agenda view
Press this button to pick the font, font style and size for the Agenda view (Day, Week and Work Week views).

Current-time line
Press this button to pick the font, font style and size for the Marcus Bains line (a colored line in the Agenda view indicating the current time).

7.1.5 Group Scheduling

Use Groupware Communication
Check this box to automatically send emails when creating, updating or deleting events or to-dos which involve others. This email can be an invitation to attendees of an event you created, a cancellation of an event you created, an answer or an update on your invitation status, an event change request, etc. Check this option if you want to use the groupware functionality (e.g. Configuring Kontact as a KDE Kolab client).

Send copy to owner when mailing events
When you check the Send copy to owner when mailing events box, you will get a copy of all email messages that KOrganizer sends at your request to the event attendees.
Mail transport
Here you can choose which type of mail transport you would like to use. You can either use KMail or the sendmail® command (which must be installed on your system in order to work).

7.1.6 Free/Busy

The free/busy information represents an availability schedule. By presenting the intervals when one already has previous commitments, others can avoid arranging appointments for these periods. Note that only the times are published, not the events, reasons or attendees.

KOrganizer supports publishing and retrieving free/busy information, either manually or automatically.

7.1.6.1 Publish

By publishing your free/busy information, you allow others to take your busy time schedule into account when inviting you to an event.

Publish free/busy information automatically
Enable this option if you wish your Free/Busy information to be uploaded automatically. Note that you may skip this option and choose to mail or upload your Free/Busy information via the Schedule menu of KOrganizer.

If your application is setup to work as a KDE Kolab client, this is not required. The Kolab2 server can take care of publishing your Free/Busy information and manage the access to it from other users.

Minimum time between uploads (in minutes)
If you choose to publish your information automatically, you can configure the interval of time in minutes between each upload.

Publish (default 60) days of free/busy information
Configure the number of calendar days you wish to be published and available to others

Server URL
Enter the URL for the server on which your Free/Busy information will be published. Ask the server administrator for this information.

Kolab2 server example: webdavs://kolab2.com/freebusy/joe@kolab2.com.ifb

Username
Enter the login information relative to your account on the server
Kolab2 server specificity: your registered UID (Unique IDentity), by default, would be similar to your email address on the Kolab2 server but it may be different. In this case enter your UID. Ask the server administrator about your UID if you do not know it.

Password
Enter your password (server login password) here.

Remember password
Check this option if you want KOrganizer to remember your password and skip asking you each time it uploads your Free/Busy information.

WARNING
It is not recommended to store your password in the configuration file for security reasons.
7.1.6.2 Retrieve

By retrieving other people’s free/busy information, you can take their busy time schedule into account when inviting them to an event.

**Retrieve other people’s free/busy information automatically**

Automate the process for retrieving other users free/busy time. Fill in the server information section below to enable this option.

**Use full email address for retrieval**

This setting lets you change the name of the file which will be fetched from the server. If you check this option, it will download a free/busy file called `user@domain.ifb`, else it will fetch `user.ifb`. Ask the server administrator if you are not sure about how to configure this option.

**Kolab2 server specificity:** If you are configuring KOrganizer as a component to a KDE Kolab client (Kontact/Kolab) you have to check this option.

**Server URL**

Enter the URL for the server from which your Free/Busy information will be fetched. Ask the server administrator for this information.

**Kolab2 server example:** `webdavs://kolab2.com/freebusy/`

**Username**

Enter the login information relative to your account on the server.

**Password**

Enter your password (server login password) here.

**Remember password**

Check this option if you want KOrganizer to remember your password and skip asking you each time it fetches the free/busy files.

**WARNING**

It is not recommended to store your password in the configuration file for security reasons.

7.1.7 Plugins

For more information about configuring plugins, please refer to chapter 8

7.1.8 Custom Pages

This page allows you to add your own GUI Elements to store your own values into KOrganizer.
Create your elements as described in *How does this work?*
Chapter 8

Plugins

KOrganizer provides you with the possibility of extending the application with plugins. The plugins can be configured under the KOrganizer main configuration dialog. Choose Settings → Configure KOrganizer and click the Plugins icon on the icon list sidebar of the dialog.

8.1 Available Plugins

8.1.1 Date Numbers Plugin for Calendars

This plugin adds the number of the day in the year to the Agenda view. For instance, February 1 is day number 32.

8.1.2 Wikipedia ‘This Day in History’ Plugin

This plugin provides links to Wikipedia’s ‘This Day in History’ pages.

8.1.3 Wikipedia Picture of the Day Plugin for Calendars

This plugin provides the Wikipedia ‘Picture of the Day’.

8.1.4 Jewish Calendar Plugin

This plugin provides Jewish calendar dates in addition to the Gregorian calendar dates. In the configuration dialog of the plugin, you can choose if you want to display Israeli holidays, weekly prasha, day of Omer and/or Chol HaMoed.
Chapter 9

Reference

9.1 Menus

When KOrganizer starts, the main KOrganizer window appears. The window has several components: a menubar, a toolbar, a month calendar, a main panel with the current ‘view’ of events, and a to-do list.

The menus provide access to all the common operations that can be performed with the calendar, including saving, loading, adding and deleting events, to-dos and journal entries, printing and more.

Please note that when using KOrganizer as the calendar component of Kontact, the menus differ from the stand alone application.

9.1.1 File

The File menu provides access to functions involving the entire calendar.

File → Open (Ctrl+O)

Opens a file dialog allowing you to select a new vCalendar or iCalendar file to load. If you have made changes to the current calendar, you will be given the option of saving them before loading a new one.

For more information about this, please refer to Section 3.2.

File → Print (Ctrl+P)

Choose Print or click the Print icon to print the current calendar. You can specify the range of dates to be printed (either manually or with the Calendar Widget) and the Print Style (Day, Week, Month or To-dos and Journal).

File → Print Preview

If you choose Print Preview or click the Print Preview icon, the current calendar will be printed on your screen, instead of on your printer. Use this feature to check if the printout will be correct before you start printing.

You can specify the range of dates to be printed (either manually or with the Calendar Widget) and the View Type (Day, Week, Month or To-do).
The KOrganizer Handbook

File → Import → Import Calendar

If you have a different iCalendar or vCalendar file somewhere, and you would like to merge its contents into your own calendar, add as a new resource or open it as a new window, choose this menu item. A good time to do this would be if you received a vCalendar with a few entries via email, for instance.

For more information about this action, please refer to Section 3.2.1.

File → Import → Get Hot New Stuff...

This action will open the Get Hot New Stuff dialog, which offers a list of calendars to download. These events can be added to your calendar.

For more information about this action, please refer to Section 3.3.

File → Export → Export as iCalendar

This action will export all your active events, to-dos and journal entries (independent of to which resource they belong) as a new iCalendar file.

For more information about this action, please refer to Section 3.2.2.

File → Archive Old Entries...

From time to time you should delete your old events.

For more information about this action, please refer to Section 3.2.3.

File → Purge Completed To-dos

This action will remove all the completed to-dos from your active calendar.

For more information about this action, please refer to Section 3.2.3.

File → Quit (Ctrl+Q)

When you choose Quit or click the Quit icon, the current calendar window will quit, prompting you to save if the current calendar has been modified but not yet saved.

This has no effect on other calendar windows which may be opened. You have to quit each calendar window individually.

9.1.2 Edit

With the Edit menu you can edit and search events and to-dos.

Cut, Copy, and Paste menu items behave in the same fashion as in other KDE applications. With the Find menu item you can find events and to-dos across the current calendar.

Edit → Undo (Ctrl+Z)

Undo the latest action, or in other words, return the calendar to the state it was immediately before the latest action.

Edit → Redo (Ctrl+Shift+Z)

Redo the latest action, or in other words, return the calendar to the state it was immediately before the latest undo.

Edit → Cut (Ctrl+X)

Cuts the currently selected event(s) to the clipboard, removing them from your calendar.

Edit → Copy (Ctrl+C)

Copies the currently selected item(s) to the clipboard, but leaving them untouched.
Edit → Paste (Ctrl+V)

Paste inserts the contents of the clipboard into your calendar. The clipboard must contain a valid vCalendar or iCalendar item, provided either by a previous Cut/Copy operation or from a selection made outside of KOrganizer. You will be warned if the contents of the clipboard cannot be understood.

Tip
However, you can safely use Ctrl+C and Ctrl+V hotkeys to copy text data from any outside application to a KOrganizer Edit Event window and vice versa.

Edit → Delete

Delete the currently selected item(s), removing them from your calendar.

Edit → Find (Ctrl+F)

Choose Find from the Edit or click the Find icon to find events, to-dos and journal entries according to their title, description, and/or categories.

For more information about this action, please refer to Section 4.4.

9.1.3 View

There are several different ‘views’ available for displaying your events, to-dos and journal entries. KOrganizer is smart enough to remember in between sessions what the last active view was, and the next time it is started, it will display that view.

In general, each view will provide a way of displaying your journal entries, to-dos and events, constrained to a particular time period or style of display. Click any item to select it for further action. Right click an item to bring up a menu with options such as Edit, Delete, and so on. You can also use the Action menu to perform similar operations.

View → Agenda

Switch the display to the Agenda view.

For more information about this action, please refer to Section 4.1.3.

View → Month View

Switch the display to the Month view.

For more information about this action, please refer to Section 4.1.4.

View → Timeline

Switch the display to the Timeline view.

For more information about this action, please refer to Section 4.1.5.

View → To-do List

Switch the display to the To-do List view.

For more information about this action, please refer to Section 4.1.6.

View → Event List

Switch the display to the list view.

For more information about this action, please refer to Section 4.1.2.
View → What's Next
Switch the display to the what’s next view.
This view displays your next events and to-dos. Events and to-dos are displayed one per line.
For more information about this action, please refer to Section 4.1.1.

View → Journal
Switch the display to the Journal view.
For more information about this action, please refer to Section 4.1.7.

View → Refresh
Updates or refreshes the currently displayed view.

View → Zoom
Use this submenu to adjust the current view to show more or less data.
In the Agenda view (Day(s) or Week view), you can use the zoom actions to show more or less days (Zoom → In Horizontally and Zoom → Out Horizontally), or more or less hours in the day (Zoom → In Vertically and Zoom → Out Vertically).

View → Filter
This submenu offers access to the filters already created using the Edit Calendar Filters dialog. Select on this submenu the filter that will be used in KOrganizer view. If you do not want to use a filter, choose No filter.

9.1.4 Go
For more information about browsing KOrganizer views, please refer to Section 4.1.

← Go → Backward
Go to the previous day, week or month, depending on the view.

→ Go → Forward
Go to the next day, week, or month, depending on the view.

Go → To Today
Go to the period of time that includes the current day.

Go → Day
Switch the display to the Day view.
For more information about this action, please refer to Section 4.1.3.

Go → Next x Days
Switch the display to the Next x Day view, where x is defined in KOrganizer main configuration.
For more information about this action, please refer to Section 4.1.3.
Go → Work Week
Switch the display to the Work Week view.
This is the same as the Week view, except only the working days of the week are shown.
For more information about this action, please refer to Section 4.1.3.

Go → Week
Switch the display to the Week view.
The Week view provides a view similar to the Day view. Events for seven days are shown next to each other. All of the functions available for the Day view are available in the Week view, too.
For more information about this action, please refer to Section 4.1.3.

9.1.5 Actions

Actions → New Event...
Choose New Event... to create a new event.
You can get a detailed description of the event window in the Entering Events section.

Actions → New To-do...
Choose New To-do... to create a new to-do. Initially the to-do has no due date, but you can specify one.
You can get a detailed description of the to-do window in the Entering To-dos section.

Actions → New Sub-to-do...
Choose New Sub-to-do... to start writing a new sub-to-do. The currently selected to-do will be the sub-to-do parent. Initially the to-do has no due date, but you can specify one.
You can get a detailed description of the to-do window in the Entering To-dos section.

Actions → New Journal...
Choose New Journal... to start writing a new journal entry.

Actions → Show
Choose Show to open a dialog showing the details of the currently selected journal entry, event or to-do.

Actions → Edit...
Choose Edit... to edit the currently selected journal entry, event or to-do.

Actions → Delete (Del)
Choose Delete to remove the currently selected journal entry, event or to-do.

Actions → Make Sub-to-do Independent
Choose Make Sub-to-do Independent to detach the currently selected sub-to-do item from its parent and make it an independent to-do item.
9.1.6 Schedule

Schedule → Publish Item Information...
Email the selected event, to-do or journal entry in the iCalendar format.
For more information about this action, please refer to Section 6.1.

Schedule → Send Invitation to Attendees
Send the selected to-do or event to the attendees, and, if necessary, request a response from them.
For more information about this action, please refer to Section 6.2.1.

Schedule → Send Status Update
If you changed your status as an attendee, choose this menu item to send your updated status (accepted, tentative, etc.) to the item’s organizer.
For more information about this action, please refer to Section 6.3.1.

Schedule → Send Cancellation to Attendees
If you plan to cancel an event or to-do, select it, and choose this menu item to notify the attendees about the cancellation.
For more information about this action, please refer to Section 6.2.2.

Schedule → Request Update
Request the latest version of the selected event or to-do from the organizer.
For more information about this action, please refer to Section 6.3.3.

Schedule → Request Change
Send an alternative proposal to the organizer of the selected event or to-do.
For more information about this action, please refer to Section 6.3.2.

Schedule → Mail Free Busy Information...
Email your Free Busy information to one or more email addresses.
For more information about this action, please refer to Section 6.4.

Schedule → Upload Free Busy Information
Upload your Free Busy information to the groupware server. Other users will then be able to retrieve the information.
For more information about this action, please refer to Section 6.4.

9.1.7 Settings and Help

Apart from the common KDE menus described in the Menu chapter of the KDE Fundamentals documentation KOrganizer has these application specific Settings and Help menu entries:

Settings → Sidebar
Click the menu items of this submenu to show or hide KOrganizer sidebar components. Note that the sidebar is visible only when the current view does not use the full window.

Settings → Configure Date & Time...
Click this menu item to set the desktop date and time formats. Note that this setting is shared between other desktop applications.
Settings → Manage View Filters...

Choose this menu item to open the Edit Filters dialog. Using this dialog, you can create, delete and edit filters that will affect which items will be displayed by KOrganizer.

Settings → Manage Categories...

Choose this menu item to open the Edit Categories dialog. Using this dialog, you can create, delete and edit calendar item categories. Categories are used to organize your events and to-dos in related groups.
Chapter 10

Other Features

In this chapter, you’ll learn of other useful features of KOrganizer: what tricks you can do with a click of your mouse.

10.1 Command Line

A nice program to access a KDE calendar from the command line is konsolekalendar.

10.2 Drag and Drop Operations

KOrganizer can be easily controlled with your mouse. The supported drag-and-drop operations are detailed below.

- Any event can be re-sized with your mouse. Simply move the mouse pointer near the top or bottom edge of the event, and drag the edge up or down. This way you can visually modify the starting and ending time of your appointment. This works in the Day, Week and Work Week views.

- Any event can be rescheduled with your mouse. Move the mouse pointer over the event, and drag it to a new time location. This works in the Day, Week and Work Week views.

- Events can be copied to other, presently non-visible dates. Move the mouse pointer over the event, and drag it to the Date Navigator on the left side of the current calendar, or to the Date Navigator of a different calendar.

  **Tip**
  However, you cannot drag from Agenda view in one calendar to Agenda view in another calendar.

- Toolbars can be dragged on the screen. Move the mouse pointer over the toolbar’s handle, and drag it to a new location on your screen.
Chapter 11

Questions and Answers

1. *Can I use freebusy-time with KOrganizer?*
   Yes, follow the instructions in *Free/Busy.*
Chapter 12

Credits and License

KOrganizer
Program copyright 2000-2010, The KDE Developers
Contributors:

• Allen Winter winter@kde.org
• Reinhold Kainhofer reinhold@kainhofer.com
• Cornelius Schumacher schumacher@kde.org
• Preston Brown pbrown@kde.org

Documentation copyright 2000 Milos Prudek
Documentation copyright 2001 Paul E. Ahlquist, Jr pea@ahlquist.org
Documentation copyright 2004 Jürgen Nagel juergen.nagel@student.fh-reutlingen.de
Documentation copyright 2005 Carlos Leonhard Woelz carloswoelz@imap-mail.com

This documentation is licensed under the terms of the GNU Free Documentation License.
This program is licensed under the terms of the GNU General Public License.
Chapter 13

Glossary

Calendar Widget
A tool for choosing the date inside certain entry windows, such as the event editing window. It is displayed as a small button to the right of the date field. When you click the button, you will see a month calendar. Use the arrows to go to a desired date, or click the month name or year number to go directly to the desired month or year.

Date Navigator
The calendar that is in the upper-left corner of the KOrganizer window. It is the main way provided to navigate among dates, and to select from them. The single-arrow icons move forwards and backwards in time by increments of a month, while the double-arrows allow moving by a year at a time. Today’s date will be outlined with a small box. Dates which have events scheduled on them will be bold. If you want to select a date, simply click it. Hold down the Ctrl key and click the dates if you wish to select multiple neighboring dates at once. The dates will be displayed in the main panel.

Dates which have events scheduled on them will be bold. If you want to select a date, simply click it. Hold down the Ctrl key and click the dates if you wish to select multiple neighboring dates at once. The dates will be displayed in the main panel.

Recurring events are not always displayed. You can prevent the display of recurring appointments in the Date Navigator. Get more information in the Views chapter.

Due Date
A due date is simply the date when your to-do must be finished. For instance, if your to-do is that you must return your books to the library by 16th November, that date is called ‘the to-do due date’

Main panel
Normally the largest part of the screen, to the right of the Date Navigator. It displays the View of the Day, Workdays, Week or Month, the List View or the To-do List view.

The right mouse button can be used in the List view and To-do List view only. It displays a local menu. The left mouse button can be used in any view.

Free/busy
The free/busy information is a set of busy time intervals. By presenting the intervals when one already has previous commitments, others can avoid arranging appointments for these periods. Note that only the times are published, not the event titles, descriptions or attendees. In other words, the free/busy information is the availability schedule.

When adding attendees to your event, you need to know if they are busy or free at that particular time before sending the invitations. If the attendees make their free/busy information available, KOrganizer can retrieve this information and display it in the Free/Busy tab of the Edit Event dialog.