# Contents

1 Introduction ......................................................... 6

2 Basic Usage ....................................................... 7
   2.1 Opening Files .................................................. 7
   2.2 Navigating ..................................................... 7
   2.3 Presentation Mode ............................................. 9
   2.4 Inverse Search between LATEX Editors and Okular ....... 10

3 Okular Advanced Features ......................................... 11
   3.1 Embedded Files ................................................. 11
   3.2 Forms .......................................................... 11
   3.3 Signatures ..................................................... 11
       3.3.1 Adding Digital Signatures .............................. 12
   3.4 Annotations .................................................... 13
       3.4.1 Adding annotations ..................................... 14
       3.4.2 Removing annotations ................................. 22
       3.4.3 Editing annotations ................................. 22
   3.5 Bookmark Management ........................................ 23
       3.5.1 Bookmarks view ....................................... 23
   3.6 Command Line Options ........................................ 24
       3.6.1 Specify a File ........................................... 24
       3.6.2 Other Command Line Options ......................... 25
   3.7 Fit window to page ............................................ 25

4 The Menubar .......................................................... 26
   4.1 The File Menu .................................................. 26
   4.2 The Edit Menu .................................................. 27
   4.3 The View Menu ................................................. 28
   4.4 The Go Menu ................................................... 29
   4.5 The Bookmarks Menu ......................................... 30
   4.6 The Tools Menu ............................................... 30
   4.7 The Settings and Help Menu ................................. 31
5 Configuring Okular Backends
  5.1 Markdown backend configuration ........................................... 32
  5.2 PostScript® backend configuration .......................................... 33
  5.3 PDF backend configuration .................................................... 33
    5.3.1 PDF Digital Signature Certificates .................................... 35

6 Configuring Okular
  6.1 General configuration .......................................................... 36
  6.2 General ............................................................................. 37
  6.3 Accessibility ................................................................. 38
  6.4 Performance ................................................................. 39
  6.5 Presentation ................................................................. 39
  6.6 Annotations ................................................................. 41
  6.7 Editor ................................................................. 42

7 Credits and License ................................................................. 43
Abstract

Okular is a KDE universal document viewer based on KPDF code.
Chapter 1

Introduction

Okular is a KDE universal document viewer based on the code of the KPDF application. Although being based on KPDF code, Okular has some unique features such as overview mode, improved presentation support and annotation support.

Okular supports a lot of different formats like PDF, PostScript®, Tiff, CHM, DjVu, Images (png, jpg, etc.) XPS, Open Document (ODT), Fiction Books, Comic Book, Plucker, EPub, Fax and Markdown. For all supported formats and their features see Okular Document Format Handlers.
Chapter 2

Basic Usage

2.1 Opening Files

To view any supported file in Okular, select File → Open..., choose a supported file in the dialog and click Open. Your file should now be displayed in the main window.

**IMPORTANT**
The new document will be opened in a new tab if the Open new files in tabs option on the General configuration page is checked.
You can close the tab by clicking with middle mouse button on it.
The previously closed document in a tab can be reopened using the File → Undo close tab (Ctrl+Shift+T) menu item.

If you have already opened files in Okular before, you can quickly access them by selecting them in the File → Open Recent menu.

Okular is the default KDE application for PDF and PostScript® files, launched when you click with the left mouse button on such a file type in the filemanager. If you want to open any file whose format is supported by Okular use Open with... → Okular from context menu in the filemanager.

After having a file opened you probably want to read it and therefore navigate through it. Go to the next section to learn more about this.

2.2 Navigating

This section describes how you can navigate through a document in Okular.

There are multiple ways of scrolling the viewing area. One is to use the Up and Down arrow keys. You may also use the scrollbar, your mousewheel or the PgUp and PgDn keys.

You can also use vim-like navigation keys, namely H to move to the top of the previous page, L to move to the top of the next page, J to move one line down, and K to move one line up.

Another way is to hold the left mouse button down at any place on the document while dragging the mouse in the opposite direction of where you want to move. This procedure only works if the Browse tool is enabled, which you can select by choosing Tools → Browse.
When viewing a document in the Presentation mode use Up and Down arrow keys to switch between pages or slides. The number and the position of the current slide will be shown in the overlay at the right upper corner of screen.

If you want to read a document with several pages use the automatic scrolling feature of Okular. Start automatic scrolling with Shift+Down or Shift+Up. Then use these keys to increase and decrease the scrolling speed. You can start or stop automatic scrolling temporarily by pressing the Shift key; pressing any other key deactivates this feature.

Another way to navigate through a document with several pages is to use the mouse pointer. Drag the page up or down, continue to drag even while reaching the bottom or top of the screen and behold. Once you cross the border of a page, the mouse cursor appears on top or bottom of the screen again and you can just continue to drag.

The sidebar on the left side of the screen enables two more ways of navigating through a document:

- If you click on a page thumbnail the viewing area will be brought to that page.
- If the document has a table of contents, clicking on a table of contents item will bring the document to the page linked to that item.
- If the document has layers, you can control the layers shown by checking or unchecking the items in the Layers list.
- If the document has bookmarks, enable the Bookmarks view and click them to go to the associated page. If bookmarks are not only shown for the current document, you can quickly switch to bookmarks in all recently opened files.
- If the document has annotations, enable the Annotations view and click the annotations or select them with the Up and Down arrow keys and press Enter to go to the associated page.

Some documents have links. In this case you can click on them and the view will change to the page it links to. If the link is to a web page or some other document the default KDE handler for that format will be invoked. For example, clicking on a link pointing to ‘https://www.kde.org’ will open the web page in the default KDE’s web browser.

The document internal links work only when Browse Tool is used.

Additionally, you may use the following functionality to quickly move to specific places in the document:

- You can go to the beginning of the document using Ctrl+Home or using Go → Beginning of the document.
- You can go to the end of the document using Ctrl+End or using Go → End of the document.
- You can go forward in the document using Space or PgDn. To go to the next page of the document use the Next Page Toolbar button or Go → Next Page in the menubar.
- You can go back in the document using Backspace or PgUp. To go to the previous page of the document use Previous Page Toolbar button or Go → Previous Page in the menubar.
- You can go back to the positions in the document where you came from in a chronological order. Consider e.g. reading the phrase ‘As shown in [15], &amp;#8230;’, and you want to know quickly lookup reference [15]. So you click on it, and Okular will jump to the list of references. Using Alt-Shift-Left or Go → Back in the menubar will bring you back to exactly the position where you came from.
• You can go forward in the document after the jumping back as described above using **Alt-Shift-Right** or **Go → Forward** in the menubar.

• You can go to the next match when searching using **F3** or **Enter** (when the focus is on **Find** text field) keys or **Edit → Find Next** menu item or move back to the previous match using **Shift-F3** or **Shift-Enter** (when the focus is on **Find** text field) keys or **Edit → Find Previous** menu item.

### 2.3 Presentation Mode

The Presentation mode represents another way to view documents in Okular. It can be enabled in **View → Presentation**. It shows the document on a page per page basis. The pages are shown with zoom to page, that means all the page is visible.

**Note**

PDF documents can even specify that they are always opened in presentation mode.

When in presentation mode, you have an helper bar located on the top of the screen. Just move the mouse cursor to the top of the screen to make it appear.

To navigate between pages you may use the left mouse button (next page) and the right mouse button (previous page), the mouse wheel, the arrow icons or the line edit in the top bar, or the keys specified in the **Navigating** section.

Use **Play/Pause** button in the top bar to start playing presentation or pause it, correspondingly.

You can exit presentation mode at any time by pressing the **Esc** key or clicking the **Quit** icon in the top bar.

You can also draw on the current page with a pencil. Click on the **Toggle Drawing Mode** icon in the top bar to enable or disable the possibility to draw in the presentation mode. The drawings are cleared automatically when leaving the presentation mode. You can also click on the **Erase Drawings** icon to remove the drawings in the current page.
The Okular Handbook

The presentation mode has support for more than one screen in a multi-monitor configuration. With more than one screen a new button will appear in the top bar, with the icon of a screen: this is a drop down box that allows you to move the presentation to any of the other available screens. Presentation mode has some configuration options, you can find their description in the chapter Configuring Okular.

2.4 Inverse Search between LaTeX Editors and Okular

Inverse search is a very useful feature when you are writing a LaTeX document yourself. If everything is set up properly, you can click into Okular’s window with the left mouse button while pressing **Shift**. After that editor loads the LaTeX source file and jumps to the proper paragraph.

Inverse search cannot work unless:

- The source file has been compiled successfully.
- Okular knows which editor you would like to use.
- The Browse tool has to be enabled, which you can select by choosing **Tools → Browse**.

With this feature of Okular, a left mouse click while pressing **Shift** in the DVI or PDF document will result in editor opening the corresponding LaTeX document and attempt to go to the corresponding line. Remember to tell Okular to use proper editor, in Okular’s menu item **Settings → Configure Okular...** (on the page **Editor**).

For more details on editor configuration please refer to the corresponding section of this manual.

![Configuring editor in Okular](image-url)
Chapter 3

Okular Advanced Features

3.1 Embedded Files

If the current document has some files embedded in it, when you open it a bar will appear above the page view to notify you about the embedded files.

In this case, you can either click on the link in the text of the bar or choose File → Embedded Files to open the embedded files dialog. The dialog allows you to view the embedded files and to extract them.

3.2 Forms

If the current document has forms, when you open it a bar will appear above the page view where you can enable the forms.

In this case, you can either click on Show Forms in the bar or choose View → Show Forms to enter data into the form fields.

3.3 Signatures

If the current document has signatures a bar will appear above the page view after the document opening. It allows you to open the Signatures panel.

Using the Signatures panel you can inspect the document signature and its certificate.
3.3.1 Adding Digital Signatures

You can add digital signatures to documents using the corresponding action in the Tools menu. To be able to sign a document you need to have a proper PKCS signing certificate available on your system. Okular does not have the ability to create such certificates since they need to be issued by certificate authorities to be useful for validation, etc.

We use the Poppler library to handle signing of PDF documents and Poppler is using the NSS library to handle certificates. At the point of writing, Poppler will try to use one of the following NSS certificate stores in order (the first that exists):

- The current Firefox user certificate store.
- The system-wide /etc/pki/nssdb certificate store.
- The current user $HOME/.pki/nssdb

If you want to use a custom certificate store you can do so by setting it in the PDF Backend Configuration section of the Configure Backends... dialog.

NOTE
This feature is available for PDF documents only. You need to install at least version 21.01 of Poppler to be able to add digital signatures to a document.
3.4 Annotations

Okular allows you to review and annotate your documents.

Okular has two different kinds of annotations:

Text annotations like **Yellow Highlighter** and **Black Underlining** for files with text like e.g. PDF.

Graphic annotations like **Pop-up Note**, **Inline Note**, **Freehand Line**, **Highlighter**, **Straight Line**, **Polygon**, **Stamp**, **Underline**, **Ellipse**, and **Typewriter** for all formats supported by Okular.

Using the context menu either in the **Annotations** view of the sidebar or in the main window you can open a **Pop up Note** for any kind of annotation and add or edit comments.

Annotations are not only limited to PDF files, they can be used for any format Okular supports.

Okular has the “document archiving” feature. This is an Okular-specific format for carrying the document plus various metadata related to it (currently only annotations). You can save a “document archive” from the open document by choosing **File → Save As** and selecting **Okular document archive** in the Filter selector. Documents saved this way will get .okular as their filename extension. To open an Okular document archive, just open it with Okular as it would be e.g. a PDF document.

You can also save annotations directly into PDF files. You can use **File → Save** to save it over the current file or **File → Save As**... to save it to a new file.

**NOTE**
Due to DRM limitations (typically with PDF documents), adding, editing some properties or removing annotations could not be possible.

**NOTE**
Any action on annotations (creation and removal of annotations, editing arbitrary annotation properties, relocating annotations with Ctrl+drag, and editing the text contents of an annotation) can be undone or redone using the corresponding item from the Edit menu. It is also possible to undo the action by pressing Ctrl-Z and redo the undone action by pressing Ctrl-Shift-Z.
You can configure the default properties and appearance of each annotating tool. Please refer to the corresponding section in this documentation.

3.4.1 Adding annotations

To add some annotations to the document, you have to use Quick Annotations button on the main Okular toolbar or activate the annotating toolbar. This is done by either selecting Tools → Annotations or pressing F6. Once the annotating toolbar is shown, just press one of its buttons or use keyboard shortcuts (keys from 1 to 9) to start constructing that annotation.

The annotating toolbar helps you to make annotations with drawings, shapes, and text messages. You can use the annotating toolbar to mark up a document (e.g. add lines, ellipses, polygons, stamps, highlights, underlines etc.). The table below describes exactly what the default set of annotating toolbar buttons does.

<table>
<thead>
<tr>
<th>Button</th>
<th>Tool Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Highlighter" /></td>
<td>Highlighter</td>
<td>To highlight text in the document with some given background color. Click on the tool button, then click with the left mouse button and hold to place the beginning of the highlighted text snippet, then drag to highlight it. It is possible to define the Type (Highlight, Squiggle, Underline or Strike out), Color, and Opacity for the highlighter. Just right-click on the highlighted text and select the Properties menu item.</td>
</tr>
<tr>
<td><img src="image" alt="Underline" /></td>
<td>Underline</td>
<td>To underline some text. Click on the tool button, then click with the left mouse button and hold to place the beginning of the underlined text snippet, then drag to underline it. It is possible to define the Type (Highlight, Squiggle, Underline or Strike out), Color, and Opacity for the underline. Just right-click on the underlined text and select the Properties menu item.</td>
</tr>
<tr>
<td>Squiggle</td>
<td>To underline some text by a squiggle line. Click on the tool button, then click with the left mouse button and hold to place the beginning of the underlined text snippet, then drag to underline it. It is possible to define the Type (Highlight, Squiggle, Underline or Strike out), Color, and Opacity for the underline. Just right-click on the underlined text and select the Properties menu item.</td>
<td></td>
</tr>
<tr>
<td>---</td>
<td>---</td>
<td></td>
</tr>
<tr>
<td>Strike Out</td>
<td>To strike out some text. Click on the tool button, then click with the left mouse button and hold to place the beginning of the underlined text snippet, then drag to underline it. It is possible to define the Type (Highlight, Squiggle, Underline or Strike out), Color, and Opacity for the underline. Just right-click on the underlined text and select the Properties menu item.</td>
<td></td>
</tr>
</tbody>
</table>
Typewriter features opaque letters on transparent background, so that it is useful to fill noninteractive forms. Click on the tool button, then click with the left mouse button and hold to place the top-left corner of the note, then drag to place the bottom-right one. Enter the text of the note then click on the OK to save the note, Cancel to cancel note entering or Clear to clear the note.

It is possible to define the **Font** and **Text color** for the text. Just right-click on the typewriter text created and select the **Properties** menu item.

To draw inline note. The note will be shown inline as is. Click on the tool button, then click with the left mouse button and hold to place the top-left corner of the note, then drag to place the bottom-right one. Enter the text of the note then click on the OK to save the note, Cancel to cancel note entering or Clear to clear the note.

It is possible to define the **Color**, **Opacity**, **Font**, **Align**, and **Border width** for the note. Just right-click on the note icon created and select the **Properties** menu item.
<table>
<thead>
<tr>
<th></th>
<th>Pop-up Note</th>
<th>To draw multiline note. The note will can be viewed by double clicking on an icon in the document. Click on the tool button, then click on the place in the document where the pop-up note should be added. Enter the text of pop-up note then click on the <strong>Close this note</strong> button in the top right corner of the pop-up window. It is possible to define the <strong>Color, Opacity, and Icon</strong> for the note. Just right-click on the note icon created and select the <strong>Properties</strong> menu item.</th>
</tr>
</thead>
<tbody>
<tr>
<td>📒</td>
<td>Freehand Line</td>
<td>To draw free-form lines. Click on the tool button, then click with the left mouse button and hold to place the start of the line, then drag to draw the line. It is possible to define the <strong>Color, Opacity, and Width</strong> for the line. Just right-click on the line created and select the <strong>Properties</strong> menu item.</td>
</tr>
<tr>
<td>🔶</td>
<td>Arrow (drop-down list)</td>
<td>To mark with an arrow. Click on the tool button, then click with the left mouse button to place the starting point of the line, then drag to place of the ending point of the line should be and click once more. It is possible to define the <strong>Color, Opacity, Width, Line start, Line end, Leader line length,</strong> and <strong>Leader line extension length</strong> for the line. Just right-click on the line created and select the <strong>Properties</strong> menu item.</td>
</tr>
<tr>
<td>Tool</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>-------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td><strong>Straight line</strong></td>
<td>To mark with a line. Click on the tool button, then click with the left mouse button to place the starting point of the line, then drag to place of the ending point of the line should be and click once more. It is possible to define the <strong>Color</strong>, <strong>Opacity</strong>, <strong>Width</strong>, <strong>Line start</strong>, <strong>Line end</strong>, <strong>Leader line length</strong>, and <strong>Leader line extension length</strong> for the line. Just right-click on the line created and select the <strong>Properties</strong> menu item.</td>
<td></td>
</tr>
<tr>
<td><strong>Rectangle</strong></td>
<td>To draw a rectangle around some chosen area. Click on the tool button, then click with the left mouse button and hold to place the top-left corner of the rectangle, then drag to place the bottom-right one. It is possible to define the <strong>Type</strong> (<strong>Rectangle</strong> or <strong>Ellipse</strong>), <strong>Color</strong>, <strong>Opacity</strong>, <strong>Shape fill</strong> (and its color), and <strong>Width</strong> for the border. Just right-click on the border created and select the <strong>Properties</strong> menu item.</td>
<td></td>
</tr>
</tbody>
</table>
To draw an ellipse or rectangle around some chosen area. Click on the tool button, then click with the left mouse button and hold to place the top-left corner of the circumscribed rectangular for the ellipse, then drag to place the bottom-right one. It is possible to define the Type (Rectangle or Ellipse), Color, Opacity, Shape fill (and its color), and Width for the border. Just right-click on the border created and select the Properties menu item.

To draw a closed plane figure from three or more segments. The corresponding note can be viewed by double clicking inside the polygon. Click on the tool button, then click with the left mouse button to place the first vertex of the polygon, then drag to place of the second vertex. Proceed until you draw the whole polygon up to the first vertex. Click twice if you want to add some note to the polygon. Enter the text of the note then click on the OK to save the note, Cancel to cancel note entering or Clear to clear the note. It is possible to define the Color, Opacity, Shape fill (and its color), and Width for the polygon. Just right-click on the polygon created and select the Properties menu item.
To mark the text or image with some predefined shape. Click on the tool button to choose the stamp from the drop-down list then click with the left mouse button to place the stamp. A single click just places a square stamp (useful for icons). To add a rectangular stamp you can click with the left mouse button and hold to place the top-left point, then drag to place the bottom-right one. It is possible to define the Opacity and Stamp symbol for the stamp. Just right-click on the stamp icon created and select the Properties menu item.

**WARNING**
This feature is experimental. Custom stamps inserted in PDF documents are not visible in PDF readers other than Okular.

These are the default annotations provided by Okular. Using the Annotations page of the configuration dialog you can add your own annotations like custom stamps, text markup or a geometrical shape with inner color to highlight regions etc.

**NOTE**
It is possible to add \( \text{L}^{\text{A}}\text{T}_{\text{E}}\text{X} \) code into the text of annotations. Please add \( $$\text{code}$$ \) to the text of annotation, where \text{code} is any valid \( \text{L}^{\text{A}}\text{T}_{\text{E}}\text{X} \) equation, and follow instructions on the screen to make it render by a \( \text{L}^{\text{A}}\text{T}_{\text{E}}\text{X} \) distribution installed in your system.

It is possible to configure the current tool options using the annotating toolbar itself. The table below describes exactly what the default set of annotating toolbar configuring buttons does.

<table>
<thead>
<tr>
<th>Button</th>
<th>Option Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>☑️</td>
<td>Line width</td>
<td>Click on the tool button to choose the width from the drop-down list.</td>
</tr>
</tbody>
</table>
The Okular Handbook

<table>
<thead>
<tr>
<th></th>
<th>Annotation color</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="okular/01.png" alt="Image" /></td>
<td>Click on the tool button to choose color of text or border of your annotation. You can chose one of the predefined colors or click on the <strong>Custom Color...</strong> item to open the color selection dialog.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th>Annotation fill color</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="okular/02.png" alt="Image" /></td>
<td>Click on the tool button to choose a fill color of your annotation. You can chose one of the predefined colors or click on the <strong>Custom Color...</strong> item to open the color selection dialog.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th>Annotation opacity</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="okular/03.png" alt="Image" /></td>
<td>Click on the tool button to choose annotation level of opacity from the drop-down list (100% is for the opaque annotations).</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th>Annotation font</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="okular/04.png" alt="Image" /></td>
<td>Click on the tool button to open the font selection dialog.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th>Advanced settings for the current annotation tool</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="okular/05.png" alt="Image" /></td>
<td>Click on the tool button to open the general configuration dialog for your annotation.</td>
</tr>
</tbody>
</table>

There are three additional utility buttons on the default annotating toolbar.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="okular/06.png" alt="Image" /></td>
<td>Add the current annotation to the <strong>Quick Annotations</strong> menu on the main toolbar.</td>
</tr>
</tbody>
</table>

**NOTE**
You can use the default shortcuts from **Alt+9** to **Alt+0** to select the quick annotation actions any time you like even with the annotating toolbar hidden.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="okular/07.png" alt="Image" /></td>
<td>When checked keep the current annotation tool active after use.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="okular/08.png" alt="Image" /></td>
<td>Hide the annotating toolbar.</td>
</tr>
</tbody>
</table>
By pressing Shift you can constrain the angle of line and polygon annotations to 15 steps, and the ratio of shape annotations (e.g. Rectangle, Ellipse) to 1:1. You can also get a toolbar button from Configure Toolbars....

The contents of the Quick Annotations menu can be configured using the Annotations page of Okular configuration dialog. This page can be opened by clicking Quick Annotations button, then choosing Configure Annotations... from the pop-up menu.

**NOTE**
Activating the annotating toolbar will make you switch to the Browse Mode.

You can stop the construction any time by pressing again on the button of the annotation you are constructing, or by pressing the Esc key.

The newly constructed annotation will have as author the author you set in the Annotations page in Okulars configuration dialog. The Annotations page can also be used to configure the content of the annotating toolbar.

### 3.4.2 Removing annotations

To remove an annotation, just click on it with the right mouse button, and select Delete or select an annotation using the left mouse button and press the Del key.

When removing the annotation, its window will be closed if open.

**NOTE**
This option could not be enabled because the document does not allow removing annotations.

### 3.4.3 Editing annotations

To edit an annotation, click on it with the right mouse button and select Properties. A dialog will appear with the general annotation settings (like color and opacity, author, etc.) and the settings specific to that annotation type.
To move an annotation, hold down the Ctrl key, move the mouse pointer on it and then start dragging with the left mouse button.

If you click with the left mouse button on an annotation, it gets selected. Resize handles appear on the selection rectangle. When the cursor is moved over one of the 8 resize handles on the corners or edges, the cursor shape changes to indicate the resize mode. Click anywhere else on the annotation to move it. Pressing Esc or clicking an area outside the annotation cancels a selection.

Resizing is only applicable for annotation types Inline Note, Typewriter, Stamp and Ellipse.

NOTE
Depending on the document permissions (typically with PDF documents), some options can be disabled.

3.5 Bookmark Management

Okular has a very flexible bookmark system. Okular saves the position on the page in bookmark and allows you to define more than one bookmark per page.

To manage bookmarks in Okular you can use Bookmarks view from Sidebar, Bookmarks menu or context menu of document view (click with right mouse button to open it).

3.5.1 Bookmarks view

To open Bookmarks view, click on the Bookmarks tab at the top of the Sidebar. If the Sidebar is not shown, click the Show Sidebar button on the toolbar or the menu item, or the Settings → Show Sidebar (F7) menu item to make it visible.
The Okular Handbook

2.1 Opening Files

To view any supported file in Okular, select File → Open..., choose a supported file in the dialog and click Open. Your file should now be displayed in the main window.

### IMPORTANT

The new document will be opened in a new tab should the Open new files in tabs option on the General configuration page is checked.

You can close the tab by clicking with middle mouse button on it.

The previously closed document in a tab can be reopened using the File → Undo close tab (Ctrl+Shift+T) menu item.

If you have already opened files in Okular before, you can quickly access them by selecting them in the File → Open Recent menu.

Okular is the default KDE application for PDF and PostScript® files. Launched when you click with the left mouse button on such a file type in the file manager. If you want to open any file whose format is supported by Okular use Open with... → Okular from context menu in the file manager.

After having a file opened you probably want to read it and therefore navigate through it. Go to...

The filter bar at the top of Bookmarks view can be used to filter the content of bookmark list pane according to the text in the box.

The list pane permits to view the bookmark list in a tree-like fashion: each document in the list can be ‘expanded’ or ‘collapsed’ by clicking on the < or > icon next to it.

Click on icon below the list to show only the bookmarks from the current document.

Right-click menu of document item can be used to open document, rename its item or remove it from the list. Remember that the removal of a document item leads to the removal of all bookmarks in the corresponding document.

Right-click menus of individual bookmark items allow you to go to the bookmark, rename or remove it.

The Right-click menu of items in the table of contents can be used to create bookmarks or go to the next or previous bookmark.

3.6 Command Line Options

Though Okular may most often be started from the KDE program menu, or a desktop icon, it can also be opened at the command line prompt of a terminal window. There are a few useful options that are available when doing this.

3.6.1 Specify a File

By specifying the path and name of a particular file the user can have Okular open that file immediately upon startup. This option might look something like the following:

```bash
% okular /home/myhome/docs/mydoc.pdf
```

**NOTE**

For PDF documents, the name can be given as `document_name#named_destination` where `named_destination` is a particular named destination embedded in the document.
3.6.2 Other Command Line Options

The following command line help options are available

```
okular -p --page number
  Open a page with a given number in the document. Also available through okular -p number

okular --presentation
  Start the document in presentation mode.

okular --print
  Start with print dialog.

okular --print-and-exit
  Start with print dialog and exit after printing.

okular --unique
  Unique instance control.

okular --noraise
  Allows to prevent Okular window raising after the start.

okular --find string
  Tries to find and highlight a given string in the document. Only works if just one document
  is given as an argument of the okular command.
```

3.7 Fit window to page

The Fit window to page feature resizes the window so that it is exactly the same size as the page at the current zoom factor. If the page doesn’t completely fit on the screen, the window is enlarged so that the largest possible part of the page is shown.

This feature can be accessed by using the keyboard shortcut Ctrl+J.
Chapter 4

The Menubar

4.1 The File Menu

File → Open... (Ctrl+O)
Open a supported file or Okular document archive. If there is already an opened file it will be closed. For more information, see the section about Opening Files.

File → Open Recent
Open a file which was used previously from a submenu. If a file is currently being displayed it will be closed. For more information, see the section about Opening Files.

File → Import PostScript as PDF...
Open a PostScript® file and convert it to PDF.

File → Undo close tab (Ctrl+Shift+T)
Reopen the last closed document. This action is active only if you have closed some document in tab during the current session.

File → Open Containing Folder
Open folder that contains the current document in your favorite file manager. This action is especially useful for the case when you have downloaded a PDF file from the internet that opens itself in Okular. The location of this file may not be clear or easy to find without this feature.

File → Save (Ctrl+S)
Saves the document including all the changes (annotations, form contents, etc.), provided the document backend supports saving those changes. If the backend does not support saving the changes, the user will be given the option to either discard or to save them together with the document in an Okular document archive.

File → Save As... (Ctrl+Shift+S)
Saves the document under a new name including all the changes (annotations, form contents, etc.), provided the document backend supports saving changes. If the backend does not support saving the changes, the user will be given the option to either discard or to save them together with the document in an Okular document archive.

Note
Note that, due to the way this is implemented, even if there are no changes to the file, the new file need not to be an exact bit-for-bit copy of the original file (e.g. can have a different SHA-1 hash, etc.).
File → Reload (F5)
Reload the currently open file.

File → Print... (Ctrl+P)
Print the currently displayed document. Please take into account that Okular has some specific options for printing PDF which are available via pressing the Options » button then choosing the PDF Options. Use these options to print your annotations or configure rasterization mode if you have problems with printing some symbols or need to change the scale mode.

**NOTE**
The scale mode options are only available when you check the Force rasterization option.

File → Print Preview...
Show a preview of how the currently displayed document would be printed with the default options.

File → Properties (Alt+Return)
Display some basic information about the document, such as title, author, creation date, and details about the fonts used. The available information depends on the type of document.

**NOTE**
Please pay attention on the information about substituting font in the Fonts tab of the Properties dialog. Many problems with font rendering can be solved by installing of the substituted fonts.

File → Embedded Files...
Show the files embedded in the document, if the document has any. For more information, see the section about the Embedded Files.

File → Export As
This item contains the export formats the current document can be exported to. The first entry for all kind of documents is always Plain Text....
The second entry is Document Archive, which allows you to save the document with your annotations into an Okular-specific archive format. Thus it is easily possible to share the original document and your annotations with other Okular users or work with them collaboratively.

File → Share
This item contains the services which can be used to share the current document with other people or send it to your devices. The entries in this sub-menu are controlled by the system. They depend on the current document format and the installed KPurpose plugins.

File → Quit (Ctrl+Q)
Close Okular.

### 4.2 The Edit Menu

Edit → Undo (Ctrl+Z)
Undo the last annotation editing command (creation and removal of annotations, editing arbitrary annotation properties, relocating annotations with Ctrl+drag, and editing the text contents of an annotation).
Edit → Redo (Ctrl+Shift+Z)
Redo the last undo step when editing annotations.

Edit → Copy (Ctrl+C)
Copy the currently selected text in Text Selection mode to the clipboard.

Edit → Select All (Ctrl+A)
Selects all the text (if the document provides it). This works only in Text Selection mode.

Edit → Select All Text on Current Page
Selects all the text (if the document provides it) of the current page.

Edit → Find... (Ctrl+F)
Show the find bar on the bottom of the viewing area that allows you to search for a string in the document.

Edit → Find Next (F3)
Try to find the previous searched string again in the document.

Edit → Find Previous (Shift+F3)
Goes to the previous occurrence of the search string in the document.

4.3 The View Menu

View → Presentation (Ctrl+Shift+P)
Activates the Presentation Mode. For more information, see the section about Presentation Mode.

View → Full Screen Mode (Ctrl+Shift+F)
Enables the full screen mode. Note that full screen mode is different from presentation mode insofar as the only peculiarity of full screen mode is that it hides the window decorations, the menubar and the toolbar.

View → Zoom In (Ctrl++)
Increase the magnification of the document view.

View → Zoom Out (Ctrl+-)
Decrease the magnification of the document view.

View → Zoom to 100%
Zoom the document image to the actual size as prescribed by the document parameters.

View → Fit Width
Change the magnification of the document view to a value that makes the pages’ width equal to the document view’s width.

View → Fit Page
Change the magnification of the document view to a value that makes at least one whole page visible.
The Okular Handbook

View → Auto Fit
Change the magnification of the document view to a value that, depending on the size relation between the page and the view area, automatically either makes the pages’ width equal to the document view’s width (like fit-width), the pages’ height equal to the document view’s height (like fit-height), or the whole page visible (like fit-page).

View → View Mode
This submenu makes you choose the view mode for the pages. The possible options are: Single Page (only one page per row), Facing Pages (two pages per row, in a book style), Facing Pages (Center First Page) and Overview (the number of columns is the one specified in the Okular settings).
Additionally, you can enable the Continuous mode. In continuous mode, all pages of the document are shown, and you can smoothly scroll through them. Otherwise, only one page (or one row of pages) is shown at a time.

View → Orientation
This submenu allows you to changes the orientation of the pages of the document.

NOTE
The rotation is applied to the orientation of every page.

You can select Original Orientation to restore the orientation of the document, discarding all the rotations applied manually.

View → Trim View
This submenu allows you to remove the white border of pages when viewing pages (Trim Margins item) or trim viewport to selection (Trim To Selection item).
The ‘trim to selection’ mode allows you to draw a selection over the rendered page in order to define a visible bounding box to be applied to all pages in the document. Selecting a small trim bounding box enforces minimum dimensions size (20% as a percentage of total page size).
The ‘trim margins’ mode is persistent across Okular restarts. The ‘trim to selection’ mode is forgotten across Okular restarts.
When you switch Okular from ‘trim margins’ mode to ‘trim to selection’ mode, the view jumps out of ‘trim margins’ mode for the bounding box selection interaction.
The trim mode can be deactivated by selecting the same menu item that activates it once again.

View → Show/Hide Forms
Show or hides the display of the form fields of the document.

NOTE
This menu item is active only if the current document has form fields.

4.4 The Go Menu

Go → Previous Page
View the previous page of the document.

Go → Next Page
View the next page of the document.
The Okular Handbook

Go → Beginning of the document (Ctrl+Home)
Go to the beginning of the document.

Go → End of the document (Ctrl+End)
Go to the end of the document.

Go → Back (Alt+Shift+Left)
Go back to the previous view of the document.

Go → Forward (Alt+Shift+Right)
Move forward to the next view of the document. This only works if you have already moved back before.

Go → Go to Page... (Ctrl+G)
Open a dialog which allows you to go to any page of the document.

4.5 The Bookmarks Menu

Bookmarks → Add/Remove Bookmark (Ctrl+B)
Add or remove a bookmark for the current position.

Bookmarks → Rename Bookmark
Rename a bookmark for the current position.

Bookmarks → Previous Bookmark
Go to the previous bookmark, or do nothing if there are no bookmarks prior to the current one.

Bookmarks → Next Bookmark
Go to the next bookmark, or do nothing if there are no bookmarks after the current one.

Bookmarks → No Bookmarks
This is an always disabled action that appears in this menu only if the current document has no bookmarks. Otherwise a list of all bookmarks is displayed here. Clicking on these bookmarks allows you to go directly to the associated position.

4.6 The Tools Menu

Tools → Browse (Ctrl+1)
The mouse will have its normal behavior, left mouse button for dragging the document and following links and right mouse button for adding bookmarks and fit to width.

Tools → Zoom (Ctrl+2)
The mouse will work as a zoom tool. Clicking left mouse button and dragging will zoom the view to the selected area, clicking right mouse button will bring the document back to the previous zoom.

Tools → Area Selection (Ctrl+3)
The mouse will work as a rectangular region selection tool. In that mode clicking left mouse button and dragging will draw a selection box and provide the option of copying the selected content to the clipboard, speaking the selected text, or transforming the selection region into an image and saving it to a file.
Tools → Text Selection (Ctrl+4)

The mouse will work as a text selection tool. In that mode clicking left mouse button and dragging will give the option of selecting the text of the document. Then, just click with the right mouse button to copy to the clipboard or speak the current selection.

Tools → Table Selection (Ctrl+5)

Draw a rectangle around the text for the table, then click with the left mouse button to divide the text block into rows and columns. A left mouse button click on an existing line removes it and merges the adjacent rows or columns. Finally, just click with the right mouse button to copy the table to the clipboard.

Tools → Magnifier (Ctrl+6)

Activates the magnifier mode for the mouse pointer. Press and hold the left mouse button to activate magnifier widget, move the pointer for panning through the document. The magnifier scales each pixel in the document into 10 pixels in the magnifier widget.

Tools → Annotations (F6)

Open the annotating toolbar. The annotating toolbar allows you to add annotations on the document you are reading. For more information, please see the section about Annotations.

Tools → Digitally Sign...

Starts the digital signature creation workflow. Addition of digital signatures is only supported for PDF files at this point. For more information, please see the section about Adding Digital Signatures.


These items allow you to speak the whole document or just the current page and stop speaking using the system speech service. This service is provided by a Qt™ library which wraps speech-dispatcher on Linux®, and native speech systems on other platforms. It is possible to choose the current voice via Okular Accessibility configuration page.

The Speak ... actions are enabled only if a speech service is available in the system.

4.7 The Settings and Help Menu

Apart from the common KDE Settings and Help menus described in the Menu chapter of the KDE Fundamentals documentation Okular has these application specific menu entries:

Settings → Show Sidebar (F7)

Shows or hides the Sidebar.

Settings → Show Page Bar

Toggle the page bar at the bottom of document area on and off to save vertical place in Okular window. Note that the page numbers will be shown on the default toolbar anyway.

Settings → Configure Backends...

Opens the Backend Configuration window.
Chapter 5

Configuring Okular Backends

You can configure Okular backends by choosing Settings → Configure Backends.... Currently, configuration options are provided for EPub, PostScript®, FictionBook, Txt, OpenDocument Text, and PDF backends only.

Using backend configuration pages for EPub, FictionBook, Mobipocket, Markdown, TXT, and OpenDocument Text you can define the font to render documents in the corresponding formats. The Choose... button in these pages opens standard KDE font configuration window. Please refer to the KDE Fundamentals documentation for the details.

The description of Markdown, PostScript® and PDF backends configuration pages can be found below.

5.1 Markdown backend configuration

You can configure Okular Markdown rendering backend based on Discount by choosing Markdown from the list on the left part of the configuration dialog. An additional configurable option
Enable SmartyPants formatting

When checked this option allows Okular to process SmartyPants formatting. Such formatting can be troublesome in the technical texts because of unwanted substitutions (e.g., it replaces (C) with a copyright symbol). This option is checked by default.

5.2 PostScript® backend configuration

You can configure Okular PostScript® rendering backend based on Ghostscript by choosing Ghostscript from the list on the left part of the configuration dialog. The only configurable option is as follows.

Use platform fonts

This option determines whether Ghostscript should be allowed to use platform fonts, if unchecked only usage of fonts embedded in the document will be allowed. This option is checked by default.

5.3 PDF backend configuration

You can configure Okular PDF rendering backend based on Poppler by choosing PDF from the list on the left part of the configuration dialog. The only configurable option is as follows.

Enhance thin lines

Drawing lines in Okular is implemented in two steps: generation of the clipping path and filling this clipping path. When the line in the original document is less than one pixel this two step implementation could cause problems. For those lines, the clipping path is filled with the filling color that depends on the thickness of the line part inside the clipping area. If the part of the line inside the clipping area gets very small the contrast between the shape and the background color can become too low for the line to be recognizable. The grids of such lines then looks very unpretty.
The Okular Handbook

To enhance the look of the thin lines Okular implements two options. The first option is **Solid**. With this option Okular adjusts clipping path and line position so that clipping path and line are on the same pixel boundary, i.e. Okular enlarges the thin lines to one pixel on the output device. This mode is similar to the *Enhance thin lines* in Adobe® Reader®. If this option is chosen, the thin lines are always enlarged.

![Thin line with Solid enhancement](image)

The second option is **Shape**. With this option the clipping path and line are adjusted to pixel boundary as well, but the line intensity is corrected according to its width.
Thin line with **Shape enhancement**

The thin lines are not enhanced by default (option No).

### 5.3.1 PDF Digital Signature Certificates

This section allows you to set a custom Certificate Database to use when adding Digital Signatures to PDF files.

It also lists the certificates available in the current Certificate Database (if any).
Chapter 6

Configuring Okular

6.1 General configuration

You can configure Okular by choosing Settings → Configure Okular.... The configuration dialog is split into six sections. This chapter describes the available options in detail.

- General
- Accessibility
- Performance
- Presentation
- Annotations
- Editor

Depending on the currently installed backends, the Settings → Configure Backends... menu item could be enabled. This particular configuration dialog holds the configurations of the backends that can actually be configured.
The Okular Handbook

6.2 General

Use smooth scrolling
Whether to display animated transitions when scrolling using the mouse wheel and keyboard.

Show scrollbars
Whether to show scrollbars for the document view.

Link the thumbnails with the page
Whether the thumbnails view should always display the current page or not.

Show hints and info messages
Whether to show some informative messages on startup, file load, etc.

Notify about embedded files, forms, or signatures
Whether to show informative panels about embedded files, forms or signatures etc.

Display document title in titlebar if available
Whether to show the current document title in the titlebar of Okular window. If no metadata for title found in the document or this item is unchecked Okular shows filename of the document.

When not displaying document title
You can choose any of two options, Display file name only or Display full file path.

Use custom background color
Enables choosing the document background color (the color around the displayed page). By default, the Qt™ toolkit color is used when this option is unchecked.

Open new files in tabs
Whether to open new documents in tabs. The tabs are disabled by default.
The default shortcuts to switch between tabs are Ctrl- (Next tab) and Ctrl- (Previous tab).

Switch to existing tab if file is already open
Whether Okular should switch to a tab if the file is already open instead of opening a new tab. This option is enabled by default. Can be toggled only if Open new files in tabs is enabled.

Obey DRM limitations
Whether Okular should obey DRM (Digital Rights Management) restrictions. DRM limitations are used to make it impossible to perform certain actions with PDF documents, such as copying content to the clipboard. Note that in some configurations of Okular, this option is not available.

Reload document on file change
Whether opened files should be automatically checked for changes and updated, if necessary.

Show backend selection dialog
Whether Okular should ask the user which backend to use in case of more than one backend able to open the current file. If unchecked, Okular will use the backend with the highest priority.

Right to left reading direction
Whether to use right to left reading direction by default for the opened files. Can be useful for some writing systems.
Open in continuous mode by default
Whether to use the continuous mode by default. In continuous mode, all pages of the document are shown, and you can smoothly scroll through them. Otherwise, only one page (or one row of pages) is shown at a time.

Overview columns
This option represents the number of columns to use in the overview mode.

Page Up/Down overlap
Here you can define the percentage of the current viewing area that should be visible after pressing PgUp/PgDn keys.

Default Zoom
This options specifies the default zoom mode for file which were never opened before. For those files which were opened before the previous zoom mode is applied.

6.3 Accessibility

Draw border around links
Whether to draw a border around links.

Change colors
Enables the color changing options.

Color mode
Defines the color changing mode.

Invert Colors
Inverts colors on the view, i.e. black objects will be shown white.

Change Paper Color
Changes the paper’s color, i.e. the document’s background. The color can be selected using the Paper color swatch below.

Change Dark & Light Colors
Changes the dark and light color to your preference, that means black will not be rendered as black but as the selected dark color and white will not be rendered as white but as the selected light color.

Convert to Black & White
Converts the document to black and white. You can set the threshold and the contrast. Setting the threshold to a higher value by moving it to the right will result in lighter grays used.

Invert Lightness
Inverts lightness of all colors. Light and dark colors will be swapped, but hue and saturation will not be affected. The Contrast in images will usually be worse than in Invert Luma (sRGB Linear).

Invert Luma (sRGB Linear)
Inverts luma of all colors. Light and dark will be swapped, but hue and saturation will not be affected. The Contrast in images is preserved better than in Invert Lightness, but graphics and colorful text markup usually look worse. Uses sRGB luma coefficients, but no gamma correction.

Invert Luma (Symmetric)
Inverts luma of all colors, using symmetric luma coefficients. Light and dark will be swapped, but hue and saturation will not be affected. Very similar to Invert Lightness, but the contrast is in some cases better.
Shift Hue Positive
Shifts hue of all colors by 120 degrees. Can mitigate some contrast problems in colorful graphics.

Shift Hue Negative
Shifts hue of all colors by 240 degrees. Can mitigate some contrast problems in colorful graphics.

**NOTE**
You can configure keyboard shortcuts and toolbar actions for the color modes using the corresponding menu items in the **Settings** menu of the Okular main window.

Text-to-speech engine

Allows you to choose the text-to-speech (TTS) engine to be used by Okular. The default is speechd TTS, but you can use all languages and voices depending on the available synthesizers on your platform. On Linux®, speech-dispatcher is used by default to determine available voices.

### 6.4 Performance

**Enable transparency effects**

Draw selections and other special graphics using transparency effects. Disable the option to draw them using outline or opaque fill styles and increase speed on selections.

**Memory usage**

Okular can achieve best performance by tuning the memory usage, based on your system and your tastes. The more memory you let it to use, the faster the program will behave. The Default profile is good for every system, but you can prevent Okular from using more memory than necessary by selecting the Low profile, or let it get the most out of your system using Aggressive. Use Greedy profile to preload all pages without risk of system memory overfull (only 50% of total memory or free memory will be used).

**Rendering options**

Using this group of options you can improve text and image rendering in Okular. The result depends on the device to display the document. **Enable Text Antialias** and **Enable Graphics Antialias** items can be used to switch on and off spatial anti-aliasing of text and images in document, correspondingly. **Enable Text Hinting** item is meant to be a switcher for font hinting. Antialiasing and hinting change how the documents are displayed, you may want to tweak them to your preference.

### 6.5 Presentation

**Advance every**

Enables automatic advancing of pages given a time period.

**Loop after last page**

When navigating on presentation mode and going past the last page the first page will appear.
Touch navigation

Allows you to fine-tune touchscreen navigation with tapping in the presentation using the following three possible values:

- **Tap left/right side to go back/forward**: Tapping on the left (right) half of the screen makes the presentation go to the previous (next) slide.
- **Tap anywhere to go forward** (default): Tapping on the screen makes the presentation go to the next slide, no matter where the screen is being tapped.
- **Disabled**: Screen tapping does not do anything.

Background color

The color that will fill the part of the screen not covered by the page when on presentation mode.

Mouse cursor

Whether the mouse should be always hidden, always shown or hidden after a small time of inactivity.

Show progress indicator

Whether to show a progress circle that shows the current page and the total number of pages on the upper right corner of the presentation screen every time you change the page.

Show summary page

Whether to show a summary page at the beginning of the presentation with the title, author and number of pages of the document.

Enable transitions

Use this check box to enable or disable transition effects between pages.

Default transition

The transition effect between page and page if the document does not specify one. Set this to **Random Transition** to make Okular randomly choose one of the available effects.

Placement

In this section you can select the **Screen** used to display the presentation.

- **Current Screen** is same screen of the Okular window that starts the presentation mode.
- **Default Screen** is the screen marked as default in the xinerama configuration.
- **Screen 0, Screen 1** etc. are the available screens.

Drawing Tool Configuration

Manage the colors of the pencil used when drawing on the pages during the presentation mode.
6.6 Annotations

Author
The author of the contents added on a document. Default is the name from the Password & User Account page of the System Settings module Account Details.

Annotation tools
This pane is used to configure your annotating toolbar.
There are five buttons (Add, Edit, Remove, Move Up, Move Down) and a list box (which lists the contents of the current annotating toolbar) which are used to configure the toolbar.
If you need to add some tool button on the toolbar click on the Add button. You can choose the Name, the Type and the Appearance of the created tool.

NOTE
Please remember that annotation tools in Okular are highly configurable. For example, you can have two buttons of the same tool but with different color. Do not hesitate to experiment in choosing the button set that is exactly tailored to your workflow.

Click on some item in the list box then click on the corresponding button at the right part of the page to edit, remove, move up or move down the item. The keyboard shortcut of the tool (keys from 1 to 9) depends on its position in the list of annotating toolbar.

Using Custom Stamps
1. Create the icon you want to use for your own stamp and save it in any graphics format supported by Okular
2. Click the Add button, select type Stamp and enter a name for your stamp.
3. Enter the full path to your custom icon into the dropdown box in the Stamp Symbol group
6.7 Editor

Editor

Choose the editor you want to launch when Okular wants to open a source file. This is the case when the document has references to the various points (usually row and column number) of sources it was generated from. The DVI format supports natively the addition of the information about the sources the \LaTeX{} document was generated from. A similar system exists for PDF documents, called pdfsync, which stores these extra information in an external file named after the PDF file itself (for example mydocument.pdfsync for mydocument.pdf).

Okular ships with preconfigured settings for the following editors: Kate, Kile, SciTE, Emacs client, LyX client, TeXstudio, and TeXiFY IDEA.

NOTE
To use inverse search in Kile, you have to compile your \LaTeX{} file with the Modern configuration.

Command

This is the command and its parameters to invoke the selected editor with the source file of the actual document. This field will be filled automatically if you use one of the preconfigured editors. Otherwise, please choose Custom Text Editor in Editor drop down box and refer to the documentation on your favorite editor to find the proper command.

You can use the following placeholders:

- \%f - the file name
- \%l - the line of the file to be reached
- \%c - the column of the file to be reached

If \%f is not specified, then the document name is appended to the specified command.
Chapter 7

Credits and License

Program Copyright:

- Albert Astals aacid@kde.org Current maintainer
- Pino Toscano pino@kde.org
- Enrico Ros eros.kde@email.it KPDF developer

Documentation Copyright:

- Albert Astals aacid@kde.org Author
- Titus Laska titus.laska@gmx.de Some updates and additions
- Pino Toscano pino@kde.org

This documentation is licensed under the terms of the GNU Free Documentation License.
This program is licensed under the terms of the GNU General Public License.