The Marble Handbook
Contents

1 Introduction ................................................................. 6
2 Marble quick start guide: Navigation .................................... 7
3 Choosing different map views for Marble ................................ 9
4 Searching places using Marble ........................................... 11
5 Find your way with Marble .................................................. 13
   5.1 Creating a new Route ..................................................... 13
   5.2 Route Profiles ........................................................... 14
   5.3 Adjusting Routes ........................................................ 16
   5.4 Loading, Saving and Exporting Routes ............................... 17
6 Measuring distances with Marble ........................................ 19
7 Download Map Regions ..................................................... 20
8 Recording a movie with Marble ............................................ 23
   8.1 Recording a movie with Marble ........................................ 23
       8.1.1 Troubleshooting .................................................... 24
9 Command Reference ......................................................... 25
   9.1 Menus and shortcut keys ................................................. 25
       9.1.1 The File Menu ..................................................... 25
       9.1.2 The Edit Menu ..................................................... 26
       9.1.3 The View Menu .................................................... 26
       9.1.4 The Bookmarks Menu ............................................ 27
       9.1.5 The Settings Menu ................................................. 27
       9.1.6 The Help Menu .................................................... 28
10 Configuring Marble

10.1 View Configuration .................................................. 29
10.2 Navigation Configuration ............................................. 30
10.3 Cache & Proxy Configuration ......................................... 31
10.4 Date & Time Configuration ........................................... 32
10.5 Synchronization Configuration ...................................... 32
10.6 Routing Configuration ................................................ 34
10.7 Plugins Configuration ................................................ 34

11 Questions and Answers .................................................. 38

12 Credits and License ....................................................... 39
Abstract

Marble is a geographical atlas and a virtual globe which lets you quickly explore places on our home planet. You can use Marble to look up addresses, to easily create maps, measure distances and to retrieve detail information about locations that you have just heard about in the news or on the Internet. The user interface is clean, simple and easy to use.
Chapter 1

Introduction

Welcome to Marble, a small interactive globe and geographical atlas that puts the world at your fingertips. Just like a real atlas or a conventional globe Marble allows you to freely move across its map and lookup places. Furthermore Marble allows you to zoom in and have many different views on the surface for the Earth or the Moon (with his view). In its default configuration Marble offers 15 different views: Atlas, OpenStreetMap, Satellite View, Earth at Night, Behaim Globe 1492, Sentinel2 Satellite Map, Historical Map 1689, Political Map, Plain Map, Precipitation (December), Precipitation (July), Temperature (December), Temperature (July), Vector OSM and Moon.

Marble comes with a small database of more than 12,000 locations (cities, mountains, volcanoes) which can be searched for and which are integrated with Wikipedia. Additionally you can measure distances using Marble between multiple measure points which can be set freely.

Marble is free software and licensed under the GNU Lesser General Public License.
Chapter 2

Marble quick start guide: Navigation

Here is Marble the first time you run it, either with Applications → Education → KDE Marble (Virtual Globe) from the global menu or with Alt+F2 and entering marble into the input field.

On the right you can see a topographical map of our beautiful home planet. To allow for better orientation the map offers a scale bar in the lower left corner as well as a windrose on the top right. To navigate and to control the view you can use the tools on the Navigation info box at the right: Press the arrow buttons to rotate the globe. The Up and Down arrow buttons will tilt the earth axis back and forth. The Left and Right arrow buttons will make the earth spin around its physical axis.

You can accomplish the same behavior by pressing the left mouse button somewhere on the globe and by moving the mouse while keeping the left mouse button pressed. Using this drag and drop style navigation will allow you to adjust the viewing angle much easier and more precisely. The cursor keys on your keyboard offer another alternative way to quickly change directions.

Zoom in and out by moving the vertical slider up and down. If your mouse has got a mouse wheel you can use that one instead - or you just hold the left mouse button and the right mouse button down both at once while moving the mouse up and down. Changing the zoom level step
by step can be done via the **Zoom In** and **Zoom Out** buttons which are placed above and below the zoom slider (or using the + and - keys on your keyboard).

Depending on the map’s resolution zooming in will provide you with more detail. Smaller cities will appear and using the topographic map you might notice that coastlines are provided as vector graphics.

In case you should get lost you can always reset the viewing angle and zoom level back to the point where we started off: Just press the **Home** button (or the **Home** button on your keyboard). To set the home location to the current position (center of the map) select the **Bookmarks → Set Home Location** menu item.

A click onto the status bar using the right mouse button offers a menu which lets you customize the appearance of the status bar. You can show the position, altitude, the current tile level and a progress indicator that displays the status of the map data download.
Chapter 3

Choosing different map views for Marble

Marble comes with 15 different views: Atlas, OpenStreetMap, Satellite View, Earth at Night, Behaim Globe 1492, Sentinel2 Satellite Map, Historical Map 1689, Political Map, Plain Map, Precipitation (December), Precipitation (July), Temperature (December), Temperature (July) Vector OSM and Moon. You can choose among these by pressing the Map View tab on the top of Marble’s toolbox:

- **Atlas**: A classic topographic map. It uses vector lines ("MicroWorldDataBase II") to mark coastlines, country borders etc. and bitmap graphics ("SRTM30") to create the height relief.

- **OpenStreetMap**: A global roadmap created by the OpenStreetMap (OSM) project. OSM is an open community which creates free editable maps. The OSM data was rendered using Mapnik.

- **Satellite View**: Earth as seen from Space. The map is based on NASA’s beautiful Blue Marble Next Generation pictures. Credits: NASA’s Earth Observatory
- **Earth at Night**: This image of Earth’s city lights was created with data from the Defense Meteorological Satellite Program (DMSP) Operational Linescan System (OLS).

- **Behaim Globe 1492**: Produced by Martin Behaim from 1490–1492, it is the oldest surviving terrestrial globe.

- **Sentinel2 Satellite Map**: Based on the Sentinel data, see more information here.

- **Historical Map 1689**: A historical world map from the year 1689 created by G. van Schagen in Amsterdam.

- **Political Map**: A simple map with the current frontiers of countries.

- **Plain Map**: A plain map. It uses vector lines to mark coastlines and country borders etc.

- **Precipitation (December)**: A map which shows the average precipitation in December.

- **Precipitation (July)**: A map which shows the average precipitation (rain, snow, hail, etc.) in July.

- **Temperature (December)**: A map which shows the average temperature in December.

- **Temperature (July)**: A map which shows the average temperature in July.

- **Vector OSM**: Vector map from the OpenStreetMap project.

- **Moon**: A map of the moon. The map is based on data from the Clementine Moon mission (UVVIS Basemap Mosaic). Credits: NASA/SDIO, Courtesy USGS Astrogeology Research Program.
Chapter 4

Searching places using Marble

Marble comes with a small database of more than 12,000 cities (from https://www.populationdata.net/monde/) and a few mountains and volcanoes. You can find a location by entering its name into the search line on the top of the toolbox (Marble always uses the native name in Latin letters). As you start typing, suggestions below the search line will appear like this:

As you hit Enter, Marble runners will also query both online and offline searches to return you even more useful data.

The following online search runners are available:

- Nominatim: An online search and reverse geocoding service, using data from https://www.openstreetmap.org
- HostIP: A reverse geocoding based on IP address, using data from https://www.hostip.info

The following offline search runners are also available, depending on extra software and data you have installed:
• Local Database: All placemarks in all open documents will be searched for. This includes your Bookmarks of course.

• Monav: An offline search service using the data from Monav offline routing information, based on OSM data

• Gosmore: An offline reverse geocoding service using data from gosmore setup

Once you have found your search on the map you can click on its label or its symbol using the left mouse button. After clicking the name of the location on the map a data sheet will appear, like this:

On the first tab of the dialog some very basic data is provided, like the name, coordinates and flag of the country the place belongs to. In addition, population numbers for cities get shown, as well as the elevation for mountains. If your computer is connected to the Internet and if you're online, Marble will try to connect to the popular Internet encyclopedia ‘Wikipedia’. If a matching Wikipedia article is available Marble will display it on the data sheet.

NOTE
The additional data sources can be enabled using View → Online services submenu. For example, you should mark Wikipedia menu item to see Wikipedia articles.
Chapter 5

Find your way with Marble

Besides searching for places, Marble can display possible routes between two or more of them. Do you want to plan a bicycle tour in the nearby wood? Need driving instructions to get to an address in a foreign city? Select the Routing tab on the top of Marble’s toolbox to start planning your trip.

5.1 Creating a new Route

In the Routing tab you’ll see two green icons A and B. Enter the start address in the input field next to the A button, the route start input field. Press Enter or press the Search button to find matching placemarks. A small progress animation will shorten your waiting time while the search is running. Using the search term ‘Weavers Lane, London’, the result will look similar to the screenshot below:

Matching placemarks line up in the list below the input fields. They are also shown in the map. The first result is automatically selected as the route start. In the map, this position is indicated
using the same A icon as the button next to the route start input field. If the first result is not your desired route start, click on any other result to make that the new start position. You can either click on it in the result list or on its icon in the map to achieve that. The currently chosen route start is always indicated using the A icon.

With the route start at hand, let’s move on to enter the destination of our trip. The procedure is the same: Enter the destination address in the input field next to the B button, press Enter and select the desired item among the result list.

Did you notice that the Search button is now gone and replaced by a Get Directions button? Marble is signaling that all information needed to calculate a route has been entered correctly. Press the Get Directions button to retrieve a suitable route now. If your destination search term is ‘Sun Walk, London’, the result will resemble this screenshot:

If the start (or destination) position is already visible on the screen, you may find it more convenient to select it directly in the map. To do that, press the A (or B) button next to the input field. Select From Map in the upcoming menu. Once pressed, the map input mode is activated: The next click on a position in the map will become the start (or end) of your trip. The mouse cursor turns into a cross to ease an accurate selection. The selected position will be included in the route and marked in the map. To abort the selection, either press the button again or press Esc.

An alternative selection of the route start and destination is provided via the context menu of the map: Click with the right mouse button on the desired location and select Directions from here or Directions to here, respectively.

5.2 Route Profiles

Which route to choose depends on the type of vehicle you plan to use (if any). You can tell Marble about this and other preferences using route profiles. Each profile contains the settings for a certain routing scenario. On the first start, Marble creates four common profiles for you: Car (fastest), Car (shortest), Bike, and Pedestrian.

The examples in the previous sections used the Car (fastest) profile. Let’s revisit the last route with a different profile: Select the Pedestrian option in the Profile combo box. The route now looks like this:
The proposed route has become shorter because footways are now also included when calculating the best route.

If you want to tweak one of the default profiles further, select it in the Profile combo box and click on the Configure link. A new window opens.

The left side lets you configure which routing backends are queried for routes. Eight or more backends are supported by Marble, some working online and the other ones working offline. Online routing requires an Internet connection to query a route. Offline routing works without an Internet connection, but requires you to download and install offline routing maps in advance. The supported routing backends are
The Marble Handbook

- CycleStreets: Bicycle routing for the United Kingdom using cyclestreets.net
- Gosmore: An offline router that also serves as the backend for the Yours online router
- MapQuest: An online router which provides advanced turn-by-turn instructions

**NOTE**
An AppKey is required for MapQuest routing to work. You can register the AppKey [here](#).

- Monav: An offline router that is very fast even when calculating very large routes
- OSRM: An online router that is very fast even when calculating very large routes
- OpenRouteService: An online router that also generates driving instructions, limited to Europe
- Routino: An offline router with a very flexible configuration
- Yours: An online router that operates world-wide, but lacks driving instructions

Once you select and enable a routing backend on the left to include it in routing queries, you can modify its settings on the right side. The settings are specific to each backend.

Besides configuring the four default profiles, you can add new profiles and remove existing ones in the Marble settings in the **Routing** page.

### 5.3 Adjusting Routes

Marble let’s you modify several aspects of the route for fine-tuning: Change route options, insert via points, move or remove existing points. The modification of route options has been discussed in the previous section already; we’ll concentrate on point management now.

Inserting via points is done by drag-and-drop in the map. Every time you move the mouse pointer above any part of the route (except above existing trip points), a green flag icon appears to indicate that it is possible to insert a via point. To start the insert operation, click with the left mouse button. Move the mouse pointer to the desired new position while keeping the left mouse button pressed. Blue lines from the neighboring via points to the new position will appear.
The new via point will be inserted between the existing neighbor via points once you release the left mouse button. At the same time the existing route is painted dotted to indicate that it contains outdated information. In the background, a new route is prepared which will replace the outdated one automatically.

It is also possible to add via points before the start or after the end of the route. To do that, follow the instructions above for inserting a new via point, but press Ctrl while moving the mouse. One blue line from the start or the end of the route appears. Its origin indicates where the new via point will be appended.

Existing via points can be moved freely across the map. Move the mouse pointer above a via point and drag it to its new location. Once released, the route will be updated automatically.

To exclude via points from the route, remove them. This can be done using either the Remove button next to the via point input field or by clicking with the right mouse button on the via point in the map. In the context menu, choose Remove this Destination. To start an entirely new route, remove all via points.

5.4 Loading, Saving and Exporting Routes

You can save routes in kml (Keyhole Markup Language) format and load them again at a later point - on the same computer or a different device running Marble, or share them with your friends or other applications which are able to read kml files (like Google Earth). To save a route to a .kml file, press the Save button on the bottom of the routing tab. The upcoming save dialog allows you to choose a file name to save the route to. Similarly loading a route is initiated with the Open button on the bottom of the routing tab. Select the .kml route file to open in the upcoming open dialog and Marble loads the route from it.

Routes planned in Marble can be used in other applications or navigation devices which support gpx (GPS eXchange Format) or equivalent formats. If your navigation device does not support gpx directly, you can use a conversion utility like gpsbabel to convert a gpx file exported by Marble to a suitable format. The export of a route in Marble is initiated from the routing context menu in the map. Click with the right mouse button on any point of the route in the map. In the context menu that appears, choose Export Route...
Enter the desired filename in the upcoming save dialog. The filename extension should be \texttt{gpx} to store in \texttt{gpx} format or \texttt{kml} to store in \texttt{kml} (Keyhole Markup Language) format. Note that the internal format of Marble is \texttt{kml}; in doubt save routes as \texttt{kml} and only use \texttt{gpx} to share routes with other applications that are not capable of reading \texttt{kml} files.
Chapter 6

Measuring distances with Marble

As mentioned already Marble always displays a dynamic scale bar on the lower left to estimate distances on the map. Together with the windrose in the top right corner these overlays are provided for better orientation. But there’s more: Marble allows you to measure distances between two or more points on earth. To do so click the respective points in correct order on the globe using the right mouse button. On each click a popup menu will appear which allows you to add a measure point (Add Measure Point) or to remove all measure points altogether (Remove Measure Points):

Once you have added at least two measure points, the total distance will be displayed in the top left corner of the map. Marble will assume a spherical earth for all measurements which should be accurate enough for most cases.

**Tip**
Displaying of distances and bearings for the measured segments can be configured using Measure Tool configuration dialog.
Chapter 7

Download Map Regions

Pre-installed with a set of maps, Marble is ready to use. When you zoom in at places, more detailed parts of the current map theme are downloaded in the background. This works excellent whenever an Internet connection is available. What to do, however, when traveling to a foreign city where no constant Internet connection is available to download maps? Plan ahead and download those map regions you are going to use.

To understand what needs to be downloaded to display certain parts of the map offline, let’s briefly look into the concept of tiles which Marble uses internally. A tile is an image which corresponds to a certain part of the map. Tiles are arranged by Marble next to each other to form the map image that is displayed to you. Depending on the selected projection mode, tiles are arranged to form a rectangle (Flat Map Projection, left) or a sphere (Globe Projection, right):

Zooming in at this view, more details need to be displayed. The tiles shown in the two screenshots above are too coarse then; Marble automatically recognizes this and changes to the next tile level where images provide more details. This keeps going: The more you zoom in, the higher the tile level. The following sketch illustrates the different number of tiles (colored) corresponding to the same map region at different tile levels:
When downloading a map region for offline usage, you need to download all tiles in the desired region for all tile levels you plan to use. Because of the connection between tile levels and zoom levels, you can think of it as downloading all tiles in the zoom levels you plan to use.

To accomplish this for a certain region, make that region visible in the screen by zooming and moving the Globe. Now select the File+Download Region... menu item to open the Download Region dialog. Keep the Visible region option selected to download those tiles that correspond to the map region visible in the screen. Next, select the Tile level range: (zoom range) you wish to download. The first field corresponds to the smallest, the second field corresponds to the largest tile level that will be downloaded. Tile levels in between will be downloaded as well. Marble shows how many tiles (images) need to be downloaded and updates this number whenever you change the region or tile level range.
The tile level corresponding to the current zoom level is shown in the status bar on the bottom. Please note that you may have to configure Marble to show that information: Click with the right mouse button on the status bar and select **Show Tile Zoom Level**.

Select **OK** to trigger the map region download. The progress bar of Marble will show the download progress (if activated).

In case you do know the coordinates of the map region to download, you can enter them by clicking on the **Specify region** option. The map region visible in the screen will be ignored in that case.

You can keep using Marble while the **Download Region** dialog is open. This is useful to queue several downloads for different regions or different tile ranges. Just select **Apply** instead of **OK** to trigger the map region download.
Chapter 8

Recording a movie with Marble

8.1 Recording a movie with Marble

To record a movie with Marble, use this function for recording.

Begin recording from the Edit → Record Movie (Ctrl+Shift+R) menu item to open the Record Movie dialog. You will see a dialog like this:

![Record Movie dialog]

Press the Open... button to choose the name and destination folder of the movie. Also you can change the frames per second (FPS) of the movie between 1 and 60.

When all is set, you can start recording. To start, press the Start button. Once this is done you can zoom and pan around and Marble will capture a video of your journey across the globe.

To stop recording of the movie and save it, select the Edit → Stop Recording menu item.
8.1.1 Troubleshooting

There may appear an error message because avconv or ffmpeg are not installed. Download from ffmpeg’s downloads page and avconv’s downloads page or use packages from your distribution.
Chapter 9

Command Reference

9.1 Menus and shortcut keys

9.1.1 The File Menu

File → Open... (Ctrl+O)
Opens a map file.

File → Open Recent
This is a shortcut to open recently opened maps. Clicking on this item opens a list to the side of the menu with several of the most recently opened files. Clicking on a specific file will open it in Marble - if the file still resides at the same location.

File → Download Maps... (Ctrl+N)
Displays the Get Hot New Stuff! dialog to download additional maps for Marble, among others maps for Mars and Venus.

File → Create a New Map...
Displays the Marble Map Theme Creation Wizard dialog to create a new map using Web Map Service data, your own image file or Open Street Map indexed tiles.

File → Download Region...
Displays the Download Region dialog to download map data in different zoom levels for offline usage. See Download Map Regions for details.

File → Export Map... (Ctrl+S)
Exports a screenshot of Marble’s map to an image file.

File → Print... (Ctrl+P)
Prints a screenshot of Marble’s map.

File → Print Preview
Opens a window that shows a preview of the printed map.

File → Work Offline
If this option is selected Marble will no longer download map data from the Internet. The search feature gets restricted to the local database. New routes cannot be retrieved.

File → Quit (Ctrl+Q)
Quits Marble.
9.1.2 The Edit Menu

Edit → Copy Map (Ctrl+C)  
Copies a screenshot of Marble’s map to the global clipboard.

Edit → Copy Coordinates  
Copies the current coordinates to the global clipboard.

Edit → Edit Map... (Ctrl+E)  
Allows you to open the current map in the external map editor. The current version supports Potlatch (in a web browser), Merkaartor and JOSM map editors.

Edit → Record Movie (Ctrl+Shift+R)  
Records a movie with Marble.

Edit → Stop Recording  
Stops the current recording of movie.

9.1.3 The View Menu

View → Current Location  
Toggle the display of the location page in the left panel. If a GPS device is connected with your computer, Marble displays longitude and latitude of your current location.

View → Crosshairs  
Toggle the display of a simple crosshair in the center of the map.

View → Refresh (F5)  
The currently visible part of the map is downloaded again and refreshed on the screen.

View → Info Boxes  
In this submenu you can lock the position of the infoboxes and show or hide the plugins you have enabled in the Plugins page of Marbles configuration dialog.

View → Online Services  
The Wikipedia plugin displays georeferenced Wikipedia articles as an icon on the map. A click onto the icon launches a browser window that displays the referenced site. The data is provided through a webservice via GeoNames.org. Likewise a Photos plugin currently provides photos via the FlickR photo sharing site.

View → Clouds  
Show real-time cloud cover. A real-time cloud map that gets updated every 3 hours. It uses GOES, METEOSAT, and GMS satellite imagery downloaded from the Geostationary Satellite Imagery page at Dundee University. Credits: Hari Nair, Xplanet Project.

View → Atmosphere  
Show the diffuse reflection of the atmosphere around the Earth.

View → Stars  
Show the star map as seen from the Solar System.

View → Sun Control...  
Displays the Sun Control where you can set the Sun Shading and center the map on subsolar point position.
The Marble Handbook

View → Time Control...
Displays the Time Control dialog where you can set date and time and the simulation time speed.

View → Eclipses in year
Displays the list of the eclipses for the year chosen using View → Browse Eclipses... menu item.
This menu item will be shown only when Eclipses plugin is enabled.

View → Browse Eclipses...
Displays the Eclipse Browser dialog where you can set the year to show eclipses for, open plugin settings dialog, view data on eclipse start, end, type and magnitude. Choose some eclipse item from the list and press the Go To Selected Eclipse to view the location of the eclipse on the globe.
This menu item will be shown only when Eclipses plugin is enabled.

9.1.4 The Bookmarks Menu

Bookmarks → Add Bookmark... (Ctrl+B)
Open the Edit Bookmark dialog to manage a bookmark.

Bookmarks → Show Bookmarks
A check box for enable the bookmarks visualization on the map.

Bookmarks → Set Home Location
Set the current position as your house.

Bookmarks → Manage Bookmarks...
Open the Manage Bookmarks dialog to manage all bookmarks.

Bookmarks → Default
This submenu shows your default locations.

9.1.5 The Settings Menu

Settings → Show Toolbar
Toggle the display of the toolbar.

Settings → Show Statusbar
Toggle the display of the status bar.

Settings → Panels
Toggle the display of the Marble panels.

Tip
You can make Marble hide all panels or show them by selecting the Settings → Panels → Hide All Panels/Show All Panels menu item or pressing F9 key on your keyboard.

Settings → View Size
Switches between various sizes of Marble map area. You can choose one of the sizes that are suitable for capturing frames for screencast or keep Marble map area resizable (Default (resizable) item).
Settings → Full Screen Mode (Ctrl+Shift+F)
Switches between normal view and full screen view. In full screen view, the titlebar is hidden and the actual application window is resized to the entire screen.

Settings → Configure Marble Virtual Globe...
Display the Marble configuration dialog.

9.1.6 The Help Menu
Marble has the common KDE Help menu item, for more information read the section about the Help Menu of the KDE Fundamentals.
Chapter 10

Configuring Marble

10.1 View Configuration

Distance:
The unit that gets used to measure altitude, lengths and distances (e.g. km, mi, ft).

Angle:
Specifies the notation of angles in coordinates: By default the Degree-Minute-Second notation (e.g. 5430’00") gets used. As an alternative you can choose decimal degrees (e.g. 54.5).

Still image:
Specifies the map quality that gets displayed while there is no user input. Usually this allows for high map quality as speed is no concern.
During animations:
Specifies the map quality that gets displayed during map animations (e.g. while dragging the globe). Especially on slow machines it is advisable to set this option to Low Quality as this will give better speed.

Default map font:
The default font that gets used on the map.

10.2 Navigation Configuration

Inertial globe rotation
By default Marble will use kinetic spinning while dragging the map. You can turn this behavior off using this check box.

Animate voyage to the target
When searching for a location Marble can either move instantly to the new location or it can show a travel animation from the previous place to the new place.

Mouse view rotation
The map and mouse movement is aligned while panning.

On Startup:
By default Marble will display the home location immediately after the application has started. As an alternative it can also show the last position that was active when the user left the application.

External editor:
Here, you can define the default editor for the maps or choose Always ask if Marble should ask you to choose before starting the external editor.
10.3 Cache & Proxy Configuration

**Cache**
There are two caches being used for Marble: The **Physical memory**: which is needed to keep map data in the computer’s memory. Increasing the value will make the application more responsive. The **Hard disc**: memory cache is used by download contents from the Internet (e.g. Wikipedia data or map data). Decrease this value if you want to save space on the hard disc and if high usage of the Internet is not an issue.

**Proxy**
Proxy settings for your local intranet. Please leave empty if there is no proxy.
10.4 Date & Time Configuration

Time Zone
Here, you can choose a time zone for Marble: UTC, system time zone or choose custom time zone. The chosen option changes the map view only if the map can show the light conditions on the surface.

When Marble starts
Here, you can choose the date and time which will be used on Marble start: system time or the last session time.

10.5 Synchronization Configuration

Marble can upload route and bookmark data to ownCloud server and synchronize them between Marble instances installed on different devices.
Enable synchronization

The synchronization can be enabled or disabled using this item. When the synchronization is enabled you can choose whether to synchronize route and bookmark data using the corresponding check boxes or press the **Sync now** button to initiate synchronization immediately.

Credentials

Here, you can enter your ownClowd credentials. More information on ownClowd configuration can be found on the [ownClowd official website](https://example.com).
10.6 Routing Configuration

Add...
Opens a window where you can add a new routing profile.

Configure...
Opens a window where the currently selected routing profile can be configured.

Remove
Deletes the selected routing profile.

Move Up
The selected routing profile is moved up one step. It will appear before the one that was previously on top of it.

Move Down
The selected routing profile is moved down one step. It will appear after the one that was previously below of it.

10.7 Plugins Configuration

The Plugin Configuration widget is the place to activate (or deactivate) Info Boxes, Online Services and other plugins that affect the look of Marble. Active plugins appear in the View menu where you can toggle their visibility.
Each plugin can be activated and deactivated using the check box on the left. Some plugins provide further configuration options which are accessible by clicking on the tool icon on the right.

**Amateur Radio Aprs Plugin**
Retrieves data from the Automatic Packet Reporting System via the Internet, a file or a serial device. The position and status of data senders is displayed in the map and updated in real-time.

**Annotation**
- Allows you to add annotations on the maps.

**Atmosphere**
- Displays atmosphere effects.

**Compass**
- Shows a compass in the map.

**Coordinate Grid**
- Displays a coordinate grid (you can choose the colors of the grid lines).

**Crosshairs**
- Enable this to display a small crosshair in the center of the map.

**Download Progress Indicator**
- A pie chart on top of the map that shows the progress of ongoing downloads.

**Earthquakes**
- Displays the earthquake markers on the map.

**Eclipses**
- Displays the data about Solar and Moon eclipses.
The Marble Handbook

Elevation Profile
Displays the elevation profile overlay for the routes on the map.

Elevation Profile Marker
Marks the current elevation of the elevation profile on the map.

GpsInfo
Displays a float item that provides GPS information.

License
Displays a float item that provides copyright information.

Measure Tool
The plugin to measure distances between two or more points.
Displaying of the distance and the bearing between the points can be configured after pressing the tool icon. It is enough to check the corresponding item to make Marble show the labels or uncheck the item to hide the labels.

Navigation
Displays the mouse control to zoom and move as float item on the map.

OSM Mapper Notes
Implementation of geocoding notes.

OpenDesktop Items
Shows OpenDesktop users’ avatars and some extra information about them on the map.

Overview Map
This is a float item that provides an overview map.

Photos
Automatically downloads images from around the world in preference to their popularity.

Places
Displays trending Foursquare places.

Position Marker
Draws a marker at the current GPS position.

Postal Codes
Shows postal codes of the area on the map.

Routing
Displays the routing information and navigation controls.

Satellites
Displays the Earth and other planets natural and artificial satellites and their orbits.

Scale Bar
This is a float item that provides a map scale.

Speedometer
Displays the current cruising speed. Needs some GPS data.

Stars
A plugin that shows the Starry Sky.

Sun
A plugin that shows the Sun.
Weather
Downloads current weather information of cities and displays them in the map.

Wikipedia Articles
Automatically downloads Wikipedia articles and shows them on the right position on the map.
Chapter 11

Questions and Answers

1. *I cannot see my house on the map / Why should I use Marble if there is Google Earth already?*

   Marble aims to be a lightweight fast educational geographical browser that easily runs on any platform that is supported by Qt™. While higher resolution maps would be nice to have they aren’t necessary for every user and every use case (just like you don’t use a full blown text processor each time you just need a simple editor). Also notice Marble is free software and is based on data that can be freely redistributed in the same way that applies to Free Software.

2. *Why is Marble so fast although I don’t have hardware acceleration enabled? / Why doesn’t Marble run smoothly on my expensive 3D graphics card?*

   Despite depicting the earth as a globe Marble doesn’t make use of any 3D hardware acceleration. This has the advantage of running at a decent speed on any platform and hardware supported by Qt™. However it has the disadvantage that it doesn’t run as smoothly as it could if it used hardware accelerated OpenGL. Marble just uses plain 2D graphics and therefore requires a graphics adapter that is fast at drawing 2D graphics. We plan to add an optional OpenGL backend in the future.

3. *Will I ever have to pay for Marble?*

   No, never. But the authors always welcome feedback. Marble is licensed under the LGPL, so you will never have to pay for this program.

4. *How can I contribute?*

   Marble is not only an application but also a Free Software project. As such it’s easy to join: just contact us via the marble-devel mailing list (marble-devel@kde.org).
Chapter 12

Credits and License

Marble
Program Copyright, 2005-2007 Torsten Rahn rahn@kde.org
Contributors:

• Torsten Rahn rahn@kde.org
• Inge Wallin inge@lysator.liu.se

This documentation is licensed under the terms of the GNU Free Documentation License.
This program is licensed under the terms of the GNU Lesser General Public License.