The Krusader Handbook
Contents

1 Introduction
  1.1 Package description ............................................. 14
  1.2 Welcome to Krusader! ............................................ 14

2 Features ................................................................. 17

3 User Interface ......................................................... 21
  3.1 OFM User Interface .............................................. 21
  3.2 Krusader Main Window ........................................... 21
  3.3 Toolbars .......................................................... 21
    3.3.1 Main Toolbar ................................................ 21
    3.3.2 Job Toolbar .................................................. 23
    3.3.3 Actions Toolbar ............................................. 23
    3.3.4 Location Toolbar .......................................... 23
    3.3.5 Panel Toolbar .............................................. 23
  3.4 Panels ............................................................ 24
    3.4.1 List Panel ................................................... 24
    3.4.2 Sidebar ..................................................... 25
    3.4.3 Folder History ............................................. 26
  3.5 Command Line / Terminal Emulator . .......................... 26
    3.5.1 Command Line ................................................ 26
    3.5.2 Terminal Emulator ......................................... 27
  3.6 Function (FN) Keys Bar ............................................ 27
  3.7 Folder Tabs ...................................................... 28
  3.8 Buttons .......................................................... 28

4 Basic Functions .......................................................... 29
  4.1 Controls .......................................................... 29
    4.1.1 General ....................................................... 29
    4.1.2 Moving Around ............................................. 29
    4.1.3 Selecting .................................................... 30
    4.1.4 Executing Commands ....................................... 30
    4.1.5 Quick search ............................................... 31
    4.1.6 Quick filter ................................................ 31
# The Krusader Handbook

## 4.1 File Management

<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>4.1.7</td>
<td>Quick select</td>
<td>31</td>
</tr>
<tr>
<td>4.1.8</td>
<td>Context Menu</td>
<td>31</td>
</tr>
</tbody>
</table>

## 4.2 Basic File Management

<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>4.2.1</td>
<td>Executing Files</td>
<td>32</td>
</tr>
<tr>
<td>4.2.2</td>
<td>Copying and Moving</td>
<td>32</td>
</tr>
<tr>
<td>4.2.3</td>
<td>Queue manager</td>
<td>32</td>
</tr>
<tr>
<td>4.2.4</td>
<td>Deleting - move to Plasma Trash</td>
<td>33</td>
</tr>
<tr>
<td>4.2.5</td>
<td>Shred Files</td>
<td>33</td>
</tr>
<tr>
<td>4.2.6</td>
<td>Renaming Files, Creating Directories and Link Handling</td>
<td>33</td>
</tr>
<tr>
<td>4.2.7</td>
<td>Viewing and Editing files</td>
<td>33</td>
</tr>
</tbody>
</table>

## 4.3 Archive Handling

<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>4.3.1</td>
<td>Browsing Archives</td>
<td>34</td>
</tr>
<tr>
<td>4.3.2</td>
<td>Unpack Files</td>
<td>34</td>
</tr>
<tr>
<td>4.3.3</td>
<td>Packing Files</td>
<td>34</td>
</tr>
<tr>
<td>4.3.4</td>
<td>Testing Archives</td>
<td>35</td>
</tr>
</tbody>
</table>

## 5 Advanced functions

<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>5.1</td>
<td>Virtual file systems (VFS)</td>
<td>36</td>
</tr>
<tr>
<td>5.2</td>
<td>Compare</td>
<td>37</td>
</tr>
<tr>
<td>5.2.1</td>
<td>Compare by Content</td>
<td>37</td>
</tr>
<tr>
<td>5.2.2</td>
<td>Compare Directories</td>
<td>37</td>
</tr>
<tr>
<td>5.3</td>
<td>Calculate Occupied Space</td>
<td>38</td>
</tr>
<tr>
<td>5.4</td>
<td>File Splitter</td>
<td>38</td>
</tr>
<tr>
<td>5.5</td>
<td>Checksum Creation and Verification</td>
<td>38</td>
</tr>
<tr>
<td>5.6</td>
<td>Send Files by Email</td>
<td>39</td>
</tr>
<tr>
<td>5.7</td>
<td>Profiles</td>
<td>39</td>
</tr>
<tr>
<td>5.7.1</td>
<td>Panel Profiles</td>
<td>39</td>
</tr>
<tr>
<td>5.7.2</td>
<td>Color Profiles</td>
<td>39</td>
</tr>
<tr>
<td>5.7.3</td>
<td>Key-binding Profiles</td>
<td>39</td>
</tr>
<tr>
<td>5.7.4</td>
<td>Search Profiles</td>
<td>39</td>
</tr>
<tr>
<td>5.7.5</td>
<td>Synchronizer Profiles</td>
<td>39</td>
</tr>
</tbody>
</table>

## 5.8 ACL permissions

## 6 Menu Commands

<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.1</td>
<td>File Menu</td>
<td>40</td>
</tr>
<tr>
<td>6.2</td>
<td>Edit Menu</td>
<td>41</td>
</tr>
<tr>
<td>6.3</td>
<td>Go Menu</td>
<td>42</td>
</tr>
<tr>
<td>6.4</td>
<td>View Menu</td>
<td>43</td>
</tr>
<tr>
<td>6.5</td>
<td>Useractions Menu</td>
<td>44</td>
</tr>
<tr>
<td>6.6</td>
<td>Tools Menu</td>
<td>45</td>
</tr>
<tr>
<td>6.7</td>
<td>Window Menu</td>
<td>45</td>
</tr>
<tr>
<td>6.8</td>
<td>Settings Menu</td>
<td>46</td>
</tr>
<tr>
<td>6.9</td>
<td>Help Menu</td>
<td>48</td>
</tr>
</tbody>
</table>
The Krusader Handbook

7 Keyboard Commands ........................................ 49
  7.1 Keyboard Usage ........................................ 49
  7.2 Key-Bindings ........................................ 49

8 Mouse Commands ........................................... 55
  8.1 Mouse Usage ........................................... 55

9 Krusader Tools .............................................. 56
  9.1 BookMan: Organize your Bookmarks ...................... 56
    9.1.1 Using Bookmarks .................................... 56
    9.1.2 Password handling .................................... 57
    9.1.3 Popular URLs ....................................... 58
    9.1.4 Permanent bookmarks ................................ 58
    9.1.5 Manage bookmarks .................................... 58
    9.1.6 Bookmarks as action buttons on the Toolbar ........ 59
  9.2 Disk Usage ............................................ 59
  9.3 KruSearcher: find what you are looking for ............... 60
  9.4 KrViewer: Krusader's internal viewer-editor ............ 64
    9.4.1 Viewer ............................................. 64
    9.4.2 Editor ............................................. 65
    9.4.3 Menu overview ....................................... 65
      9.4.3.1 The File Menu .................................... 65
      9.4.3.2 The Edit Menu .................................... 65
      9.4.3.3 The View Menu .................................... 67
      9.4.3.4 The Bookmarks Menu ............................... 69
      9.4.3.5 The Tools Menu .................................... 69
      9.4.3.6 The Settings Menu ................................ 72
      9.4.3.7 The KrViewer Menu ................................ 72
    9.4.4 The Editor Component Configuration .................. 72
      9.4.4.1 Appearance ....................................... 73
        9.4.4.1.1 General ..................................... 73
        9.4.4.1.2 Borders ..................................... 73
      9.4.4.2 Fonts & Colors ..................................... 74
        9.4.4.2.1 Colors ..................................... 74
        9.4.4.2.2 Fonts ..................................... 74
        9.4.4.2.3 Normal Text Styles ......................... 75
        9.4.4.2.4 Highlighting Text Styles .................... 75
      9.4.4.3 Editing ........................................ 75
        9.4.4.3.1 General ..................................... 75
        9.4.4.3.2 Cursor & Selection ......................... 76
        9.4.4.3.3 Indentation ................................ 76
        9.4.4.3.4 Auto Completion ............................ 78
        9.4.4.3.5 Vi Input Mode ............................... 78
The Krusader Handbook

9.4.4.3.6 Spellcheck ............................................. 78
9.4.4.4 Open/Save .............................................. 78
  9.4.4.4.1 General .............................................. 78
  9.4.4.4.2 Advanced ......................................... 79
  9.4.4.4.3 Modes & Filetypes ................................. 80
  9.4.4.5 Extensions ........................................... 81
9.5 Locate GUI Frontend ........................................ 82
9.6 MountMan: work with your mounted file systems .......... 82
9.7 Remote Connections ......................................... 83
  9.7.1 LAN connections via fish:/ protocol (zeroconf) .... 85
9.8 Synchronizer ................................................ 86
  9.8.1 Introduction ........................................... 86
  9.8.2 Comparator ............................................. 87
  9.8.3 Synchronization ....................................... 90
9.9 UserActions ................................................ 91

10 Konfigurator: Krusader’s Configuration Center 96
10.1 Startup ..................................................... 96
10.2 Panel ....................................................... 97
  10.2.1 General ............................................... 98
  10.2.2 View .................................................. 99
  10.2.3 Buttons ............................................... 100
  10.2.4 Selection Mode ...................................... 100
  10.2.5 Media Menu ......................................... 101
  10.2.6 Layout ............................................... 101
10.3 Colors ..................................................... 102
10.4 General ................................................... 103
  10.4.1 General ............................................... 103
  10.4.2 Viewer/Editor ....................................... 104
  10.4.3 Atomic extensions ................................. 104
10.5 Advanced ................................................. 104
10.6 Archives .................................................. 105
10.7 Dependencies page ....................................... 105
10.8 UserActions .............................................. 107
10.9 Protocols .................................................. 107

11 Frequently Asked Questions (FAQ) 109
11.1 Installation FAQ ........................................... 109
11.2 Usage FAQ ................................................ 113
11.3 General FAQ .............................................. 115

12 Credits and License 119
13 Installation of Krusader

13.1 Requirements ........................................ 121

13.2 Obtaining Krusader ................................... 121

13.2.1 Krusader Downloads ............................... 122
13.2.2 Version Scheme ................................... 123
13.2.3 Stable Version ..................................... 123
13.2.4 Development Version (beta release) ............... 123
13.2.5 Git ................................................ 123
13.2.6 Older Releases .................................... 124

13.3 Krusader installation instructions ...................... 124

13.3.1 Krusader dependencies ............................ 124
13.3.2 Suggested packages ............................... 124
13.3.3 Compilation requirements ......................... 125

13.4 Installing on Linux® and BSD™ platforms ............. 126

13.5 Installing on the Mac® OS-X platform .................. 126

13.6 Starting Krusader .................................... 126

13.7 Configuring Krusader ................................ 127

13.8 Making Krusader the default file manager .......... 128

A Configuration Files ..................................... 129

B useractions.xml ....................................... 131

C Release overview ...................................... 135

D Glossary ............................................. 137

E Index ................................................... 140
## List of Figures

<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.1</td>
<td>Krusader screenshot</td>
<td>15</td>
</tr>
<tr>
<td>3.1</td>
<td>Krusader Main Window</td>
<td>22</td>
</tr>
<tr>
<td>3.2</td>
<td>Main Toolbar</td>
<td>22</td>
</tr>
<tr>
<td>3.3</td>
<td>List Panel</td>
<td>24</td>
</tr>
<tr>
<td>3.4</td>
<td>Command Line</td>
<td>26</td>
</tr>
<tr>
<td>3.5</td>
<td>Terminal Emulator</td>
<td>27</td>
</tr>
<tr>
<td>3.6</td>
<td>Function (FN) Keys Bar</td>
<td>27</td>
</tr>
<tr>
<td>3.7</td>
<td>Folder Tabs</td>
<td>28</td>
</tr>
<tr>
<td>4.1</td>
<td>Copy dialog</td>
<td>33</td>
</tr>
<tr>
<td>9.1</td>
<td>Bookmark menu</td>
<td>57</td>
</tr>
<tr>
<td>9.2</td>
<td>KeditBookmarks Bookmark Manager</td>
<td>59</td>
</tr>
<tr>
<td>9.3</td>
<td>General Search</td>
<td>60</td>
</tr>
<tr>
<td>9.4</td>
<td>Advanced Search</td>
<td>62</td>
</tr>
<tr>
<td>9.5</td>
<td>MountMan</td>
<td>83</td>
</tr>
<tr>
<td>9.6</td>
<td>Synchronizer</td>
<td>87</td>
</tr>
<tr>
<td>9.7</td>
<td>ActionMan</td>
<td>92</td>
</tr>
<tr>
<td>10.1</td>
<td>Startup configuration</td>
<td>97</td>
</tr>
</tbody>
</table>
List of Tables

C.1 Release overview .................................................... 136
Abstract

Krusader is an advanced, twin-panel (commander-style) file-manager for Plasma and other desktops in the *nix world
Help Krusader

Here is your opportunity to contribute to the Krusader project. There are things that need to be done, but cannot be done by us. If you feel you can help, do not hesitate to contact us; every OpenSource can use some help. Please also check the contribute donate URL page on our website for more recent information. Thanks!

To get contributor account and commit changes to Krusader by yourselves you should follow this tutorial. Some useful advices on using KDE Git can be found here. It is a good practice to use review board for the non-trivial patches.

Documentation
Help is needed (we are looking for documentation writers) for keeping the Krusader documentation up to date. The draft explanation of new features is done by the developers on the krusader-devel mailing list, but we need editors to add this information in the handbook. By playing with the new features these editors can give valuable information to the developers for making the new features even better!

Krusader Extensions
Please upload your favourite extensions at store.kde.org, so that they become available for the Krusader community. Maybe they will be shipped by default with Krusader at the next release :-)).

Spread the Word Krusader
If you like Krusader, let people know! Write articles and reviews for internet or print publications. Encourage your friends to give Krusader a try. Participate in forums to help others in the community.

GUI Translations
Krusader is available in many languages, but sometimes translations do need an update or translations to new languages are always welcome. If you are interested in translating the Krusader GUI, please contact the KDE translation team of your language.

Documentation Translations
If you are interested in translating this Krusader documentation, please contact the KDE translation team of your language.

Donations
Actually, we had not considered donations, until users asked us for a way to Donate to the project. Krusader is, and always will be free, in all the terms of the GNU Public License.

Packagers
We are always in need of packagers for different distro rpm’s, deb’s, etc. All help is welcome.

Users’ feedback for the Krusader Mac® OS X port
There is a Mac® OS-X port with the help of macports.org, the port was maintained by Jonas Bähr, all feedback is welcome.

FAQ
If you have a question that is missing in the FAQ, we would like to hear it.

**Rate Krusader**

On some websites like freshmeat.net or linux-apps.com you can give a rate, if you like Krusader go to one of these sites and rate Krusader, thanks.

**Others**

Feedback, Bug reports, patches, etc. are always welcome! An open source project’s greatest strength is derived from getting user feedback.
Note from the Editors

As you may notice, this handbook is written by various authors. The draft explanation of new features is done by the developers on the krusader-devel mailinglist, the editors add this information in this handbook. We have taken much care in ensuring technical and vocabulary consistency. The authors write in English even though it is not their native language; therefore, you may notice strange sentence constructions. Do not hesitate to let us know, if something is not clear to you.

An open source project’s greatest strength is derived from getting user feedback. That is why we would love to hear what you have to say. Documentation contributors are always welcome!, since this is a time consuming task. If you have ideas on how to improve the content, if you would like to write about an undocumented Krusader feature, or if you have comments or suggestions about the Krusader Handbook, please let us know. You can contact us even if you find typos!

For information about the Krusader documentation project, please contact the Krusader documentation coordinator, Yuri Chornoivan yurchor@ukr.net.

This handbook is available in several formats.

- via the Help Menu when using Krusader
- the Online Handbook

The most recent version of this handbook is available when using Krusader from Git.

NOTE
If you are using a development or Git version, it is possible that the latest new features are not yet in the “The Krusader Handbook”. Please read the Changelog file online or in the Krusader sources to find out more about the new features. For a brief description, please read the NEWS file online or in the Krusader sources. User feedback and Bug reports are always welcome!

All mentioned Trademarks and Copyrights in this handbook belong to their respective owners.
Chapter 1

Introduction

1.1 Package description

Krusader is a simple, easy, powerful, twin-panel file manager (commander-style) for Plasma and other *nix desktops, similar to Midnight Commander or Total Commander®. It provides all the file management features you could possibly want.

Krusader also includes extensive archive handling, mounted file system support, FTP, advanced search module, viewer/editor, directory synchronization, file content comparisons, powerful batch renaming and much, much more. Krusader supports archive formats: ace, arj, bzip2, deb, gzip, iso, lha, rar, rpm, tar, zip and 7-zip and handles other KIO Slaves such as smb:// or fish://. Krusader is almost completely customizable and therefore very user-friendly.

Try Krusader.

More Krusader Screenshots can be viewed on our website.

1.2 Welcome to Krusader!

Our aim is to give you a simple, intuitive tool that easily handles the most important tasks you perform on your computer each and every day: manage and process your files the way you want. Whether you are a Linux® expert or a novice, Krusader makes routine file management tasks quick and accurate, allowing you to focus on the big picture, not command line syntax. This is especially helpful if you are new to xNIX operating systems. To do just that, Krusader uses a good-looking GUI and supports drag and drop as well as MIME types, making it easy to use.

Krusader has many useful features. It is fast, and handles archives transparently. In addition, Krusader streamlines many complex file management tasks, reducing fatigue, errors, and distraction. Basically, Krusader provides all the helpful features you have come to expect from other quality file management tools like Midnight Commander and Total Commander®. Krusader is designed to integrate seamlessly with the Plasma, the desktop of choice for many programmers, network engineers, and other power users of Linux®. With Krusader even novice users can quickly access the power, convenience, and feature rich capabilities of the Plasma. Krusader is a free open-source project, and it is released under the GNU General Public License (GPL), although the developers still retain the copyright for the project and its name, and manage the project’s continuing evolution.

The Krusader Project mission is to create an “all-in-one” file manager, which will do all the ordinary things you would expect of it, and more. Since the principle behind Krusader is based on the Orthodox File Manager (OFM), dual-pane filemanagers (Midnight Commander, Norton
Commander®, etc.), it is certain that Krusader is able to handle all the standard Copy, Move, Delete, etc. file operations.

From the start, virtual file systems became the main focus. Virtual file systems (VFS) are an abstracted layer over all kinds of archived information (ZIP files, FTP servers, TAR archives, NFS filesystems, SAMBA shares, ISO CD/DVD images, RPM catalogs, etc.), which allow the user to access all the information in these divergent types of file systems transparently - just like entering an ordinary sub-directory. Files can then be copied or moved around (except ISO, rpm, tar.gz) between these data sources/containers effortlessly. Krusader currently supports VFSs for all popular and some specialized types of archives (ace, arj, bzip2, gzip, iso, lha, rar, tar, zip and 7-zip), configuration packages (rpm, deb), and traditional remote file system types (FTP, NFS, Samba, FISH, SFTP).

Krusader also includes a built-in Mount-Manager MountMan, which enables you to mount or unmount file systems of all types with a click of a mouse. The user is able to obtain usage and other property information easily, in a consistent and understandable format in seconds. Ease and consistency is the goal.

A Bookmark-Manager for local files/remote URLs and an Advanced Search module is also included to speed the locating of needed files. Krusader also allows the user to configure Toolbars in order to provide a wide variety of additional functionality, such as File Comparison (several user selectable methods available), Multiple File Rename, and standard Terminal windows.

Advanced users benefit greatly from being able to carry out clerical tasks effortlessly, without distraction from the real task at hand. Convenient shortcut keys enable the user to navigate directory trees with ease, create multiple tabbed directory views simultaneously, and access fully functional history lists. Due to efficient programming and low system overhead, Krusader is perhaps the most responsive all around system management tool used to access the full potential of a computer using Plasma, or any other standards compliant X Window System® window manager. Although designed specifically for - and tightly integrated with - Plasma, Krusader works equally well with GNOME, MATE, Enlightenment, Window Maker, IceWM, XFCE, etc.
as long as the KF5 libraries are installed.

New extensibility is provided by the flexible UserActions, a Krusader innovation that allows unlimited additional custom functionality to be added to suit the specific needs of users. We are planning to develop more modules in the near future, thereby enhancing Krusader. Information on what is proposed, approved, or remains to be completed can be found in the Krusader Phabricator page.

No other program we know of, offers so many useful, easily accessible features in such an intuitive and simple format. Best of all, we listen, and implement good suggestions that are consonant with the Krusader Project’s goal: making Krusader the very best File Manager available.

We hope you will enjoy it - we do!
Chapter 2

Features

NOTE
The most important features and improvements are highlighted here, it would make this list too long if we were to include all the features and improvements. You will discover even more features in this documentation and in the ChangeLog and NEWS files.

- **ORTHODOX FILE MANAGER (OFM) FEATURES**
  - Two powerful and easy to use OFM panels.
  - Command Line and optional Terminal emulator below.
  - Strong keyboard orientation and the ability to perform all functions without the mouse.
  - Context-dependent invocation of scripts and programs e.g. mouse click/Enter (execute or open with the associated application), F3 (view) and F4 (edit).
  - User Menu, create your own customized menu.
  - History e.g. Folder History, Popular URLs, etc.
  - Virtual file systems (VFS) e.g. for Remote Connections, archives, search results, synchronizer.
  - Powerful internal viewer and editor via kparts supporting almost every file format.
  - Advanced Search module: searching in archives and search content on remote file systems.
  - Several Panel view modes via the Sidebar.

- **KRUSADER TOOLS**
  - Remote Connections: FTP/SAMBA with SFTP/SCP support via KIO Slaves
  - Locate GUI frontend
  - Synchronize Directories
  - Mount-Manager
  - Disk Usage
  - Root mode

- **KRUSADER FEATURES**
  - Archive Handling: browsing, unpack, pack, testing. Supported archives: ace, arj, bzip2, deb, gzip, iso, lha, rar, rpm, tar, zip and 7-zip.
  - Checksum Creation and Verification mechanism that supports md5, sha1, sha256, sha224, sha256, sha384, sha512, tiger, whirlpool, cfv, and crc.
  - Calculate occupied space of files and folders, archives and remote filesystems.
The Krusader Handbook

- Directory comparison and filtering.
- Compare files by content via external diff programs like Kompate, KDiff3 or xxdiff.
- Rename files and folders via KRename
- Completely supports drag’n’drop: drag from Konqueror straight into a .tar.gz file, from Krusader’s panel into the trash bin, the desktop or into Konqueror
- Preserve date for local targets at copy/move operations.
- F9 opens a Terminal Window in the current directory.
- Easy editing of file permissions and ownership and Numeric Permissions.
- Selection filters used in e.g. Synchronizer and KruSearcher.
- Jump-Back
- MIME type-aware.
- Tabbed panels and Tabbed Editor/Viewer.
- Quick search, select and filter
- File splitter
- Mouse Gestures
- Quick Navigation in the Location Toolbar.
- WhatsThis Help function in favour of tooltips where reasonable.
- Sync-browsing

• CUSTOMIZE KRUSADER TO YOUR OWN NEEDS
  - Konfigurator Krusader’s configuration center.
  - Main Toolbar, Actions Toolbar for user actions and bookmarks.
  - Key-bindings
  - Colors
  - Panel profiles
  - Bookmark-Manager
  - Selection Modes
  - Many more features can be configured the way you like.

• KRUSADER EXTENSIONS
  - UserActions
  - Color Profiles
  - Key-binding Profiles

Download and upload your favourite Krusader extensions at store.kde.org.

NEW FEATURES IN THE KRUSADER-1.80.0 "FINAL 3RD STONE" RELEASE

• Archive improvements
  - Password support for: arj, ace, rar and zip. Passwords can be stored in Kwallet
  - 7-zip support, by external applications 7z and 7za.
  - Auto-detection support, allowing you to open "hidden archives" (e.g. OpenOffice® documents).
  - Packing/unpacking is now in the background.

• Brief View

• Many improvements of the UserAction system.

• Countless usability enhancements, especially in Konfigurator and the heavily reordered menubar.
• **Media button**
• Copy/Move: **preserve all attributes** (time, owner, group).
• **Dim the colors of the inactive panel.**
• Renaming a filename without extension, single instance mode, start to system tray, check this out in **Konfigurator**
• Configurable **Atomic extensions**, so that extensions like `.tar.gz` are shown as one part in the **Ext Column**.
• Context menu for bookmarks and enable/disable special bookmarks.
• Restyled **MenuBar**
• **Terminal emulator** enhancements bringing new functions, new usages and new look.
• **Synchronizer** enhancements and parallel threads for slow FTP servers.
• **Single instance mode, start to system tray**
• Context menu for permanent bookmarks.
• Full support for **ACL permissions**, like properties, preserve attributes, synchronizer and other.
• Searcher-results, Locate-results, Synchronizer-results: support for dragging items and copy to clipboard (Ctrl+C).
• Many bug fixes.

**NEW FEATURES IN THE KRUSADER-1.90.0 ”POWER STONE” RELEASE**
• Last release for KDE 3.x with a big collection of Useractions.

**NEW FEATURES IN THE KRUSADER-2.0.0 ”MARS PATHFINDER” RELEASE**
• The first release for the KDE 4.x series
• Krusader works on Windows®! (But not so useful and powerful yet as under Linux®)
• **Queue manager!**
• **Five methods in the panel!**

**NEW FEATURES IN THE KRUSADER-2.1.0-beta1 ”RUSTY CLUTCH” RELEASE**
• Fast text/hex viewer for huge file sizes.
• Locked tabs.
• Queued packing / unpacking.
• Better trash integration.
• The quick search, select and filter bar supports regular expressions for matching files.

**NEW FEATURES IN THE KRUSADER-2.5.0 ”CLEAR SKIES” RELEASE**
• Ported to KDE Frameworks 5.
• The new **Quickfilter** bar with three different modes to operate: select, search and filter.
• Reworked Queue Manager (JobMan) and the new **Job Toolbar**.
The Krusader Handbook

New features in the Krusader-2.7.0 “Peace of Mind” release

- Quick Search in Bookmark menu.
- Pinned tabs.
- Tooltip with file information when you hover a file name.
- Extended options for Tree Panel at the Side Bar.

Note
If you are using a development or Git version, it is possible that the latest new features are not yet in the “The Krusader Handbook”. Please read the Changelog file online or in the Krusader sources to find out more about the new features. For a brief description, please read the NEWS file online or in the Krusader sources. User feedback and Bug reports are always welcome!
Chapter 3

User Interface

3.1 OFM User Interface

The OFM file manager concept contains many features that make them powerful enough to belong among the best file managers today. The interface is simple: left panel, right panel and a command line below. Because of interaction between these three items the file managing will become more efficient.

If you would like to know how Krusader works you can try it yourself, just install it on your computer. To accept an Orthodox File Manager (OFM) like Krusader, the user needs to get used to new ideas that are actually already 20 years old. If you prefer to waste time and lose a lot of productivity, you can always continue to use one panel file managers that are based on Windows® Explorer.

3.2 Krusader Main Window

The User Interface is based on Orthodox File Manager (OFM) paradigm, a 20- year old principle that has proven its bones. It is known as simple, easy and powerful. In the following sections we will cover the basic functions of each part with the exception of:

• The Menu Bar which has a chapter of its own.
• The Bookmarks which has a chapter of its own.
• The Status Bar shows the properties of the current file (that is being) in focus.

3.3 Toolbars

Krusader comes with several Toolbars.

3.3.1 Main Toolbar

The Krusader Main Toolbar is a standard KDE toolbar that can be dragged around the application (please unlock it first by unchecking the Lock Toolbar Positions item in the right-click menu) or configured via a Right-Click menu. You can decide whether or not you want to display it each time you start Krusader in the Konfigurator Startup page, and you can toggle its use in the current session in the Settings menu. The Main Toolbar contents can be configured from the Configure
The Krusader Handbook

Figure 3.1: Krusader Main Window

Figure 3.2: Main Toolbar
Toolbars in the Settings menu. Since various commands and options in Krusader are context-dependent, some commands are not always available. The icon of an inappropriate or inactive action will be deactivated (grayed-out) disabling its use. Bookmarks can be placed into the Main Toolbar and the Actions Toolbar with the mouse using “drag and drop”.

3.3.2 Job Toolbar

By default, the Krusader Job Toolbar (Queue Manager or simply the JobMan) is located at the right part of the Main Toolbar. This toolbar allows you to view the job progress, to pause and resume the job list execution and to undo the last executed job.

3.3.3 Actions Toolbar

UserActions and Bookmarks can be “plugged” into the Actions Toolbar. To show it, use Settings → Show Actions Toolbar. To add user actions, use Settings → Configure Toolbars and select Actions Toolbar. You can, for example, drag the Actions Toolbar to the right side using the mouse.

3.3.4 Location Toolbar

Below the Main Toolbar there is a Location Toolbar for each panel. It shows the path the panel is currently pointing to. When entering archives the path will be displayed in the following format: “archive type:/directory/archive_filename/the directory inside the archive”. This format makes the paths uniform and easy to read. The Location Toolbar supports also KIO Slaves but not all of them, some can only be used with the viewer and some can not be used. The user can enter a desired path by clicking on it.

- /mnt/cdrom/
- settings:/ will browse and open entries of the System Settings.
- trash:/ opens trash folder.
- mtp:/ uses the kio_mtp to access, upload and organize the multimedia stored on Android™-based devices.
- And last but not least Remote Connections.

You can copy-paste a URL in the Location Toolbar or use a middle click. With the Right-Click menu you can configure the auto-complete function. An optional Clear Location Toolbar button is also available.

Quick Navigation: Ctrl point with mouse in the middle of URL of the Location Toolbar. A pop-up window shows the next URL location. Pressing Ctrl + Left Mouse Button shows the location where the mouse was pointing to. This feature allows faster navigation in a big directory tree.

3.3.5 Panel Toolbar

Each panel has a configurable Panel Toolbar. The complete Panel Toolbar or specific buttons can be made visible or be hidden.

- OpenDir Button: opens the directory browser.
- Equals Button (=): changes the panel directory to the other panel directory.
- Up Button (...): changes the panel directory to the parent directory.
- Home Button (..): changes the panel directory to the home directory.
- Root Button (/): changes the panel directory to the root directory.
- Sync-browsing Button: when active, each directory change in the specific panel is performed in the other panel as well.
3.4 Panels

The Krusader panels are where most of the action takes place. Currently, there are two types of panels:

- **List Panel**: shows the files and directories.
- **Sidebar**: has several display modes: Preview, Tree, Quickselect, View and Disk Usage for the file or directory that has the focus. The Sidebar may be left open or closed, as desired.

Krusader is a "twin-panel" file manager so there are two panels: the "Left" panel and the "Right" panel, or a more important logical distinction, the "Active" panel and the "Inactive" panel. The active panel is the one that will accept your mouse and keyboard input. If you choose a command from the **Menu-Bar** or **Toolbar** the command will act upon the selected files/directories in the active panel. You can switch between panels using the **Tab** key or by clicking on the **Information** or **Totals labels**, or by selecting any file in a panel with the mouse. As always, default startup settings can be modified with the **Konfigurator Startup page**, and you control the current session with the **Settings menu**.

![Figure 3.3: List Panel](image)

### 3.4.1 List Panel

This is the default panel and the one you will probably use most of the time. This panel shows the contents of one directory which can be local (part of your mounted file systems, either a native file or the files inside an archive) or remote files (accessed via FTP, NFS or Samba). There are two modes: **Detailed View** that shows the file names, file size, creation date and time and their attributes. And **Brief View** that shows only the file names, the number of brief columns can be changed, by right clicking on the **Name** header. File copy/paste/cut via clipboard between Konqueror and Krusader **Ctrl+C**, **Ctrl+V**, **Ctrl+X** is supported. **Alt+Ctrl+R** toggles the **List Panel** between horizontal and vertical mode.

The following items are available:
The Krusader Handbook

- **Information Label**: shows how much free space is physically available on the file system, the file system capacity and where the filesystem is mounted. If the information is not available (most often in the case of remote file system) a message will be displayed with the reason for unavailability instead of the information.

The Media button on the left of the Information Label displays a list of all available media, where you can select the desired media (HDD partition, DVD, USB stick, etc.). Pressing Ctrl-Return when the Media menu is opened mounts the highlighted media when it is unmounted, and unmounts it when it is mounted. The context menu of a medium gives several options like Mount, Open in a new tab, etc. The Media menu is configurable.

- **Column Headers**: here you can change the sort order of the files and directories as desired. The default sort order is by Name. The sort order can be instantly changed by clicking on one of the Column Headers. To reverse the sort order, click a second time on the Column Header. An arrow will appear on the right of the Column Header text, showing the sort direction (Up arrow = A to Z sorting, Down arrow = Z to A sorting). Default UserActions set a keybinding for the Column Headers. The default Column Headers are: Name, Ext, Size, Modified, rwx. Predefined Atomic extensions like .tar.gz are shown as one part in the Ext Column. More optional Column Headers are available with the right mouse button. The width Column Headers can be changed with the mouse by single clicking and moving the divider line to the desired width (keep the mouse button pressed). Both List Panels remember the sort order and column width. The Column Headers can be changed and saved individually to each panel.

- **File List**: displays the files and directories in the browsed directory. The search bar allows you to search for files by typing their names, or the first few characters of a file name. Pressing Enter or double clicking on a file will open/execute that file. You can select/unselect files using the mouse, with the Insert key or the Edit menu.

- **Totals Label**: selecting or deselecting files will change the Totals Label at the bottom of the panel, which displays how many files you have selected (and how much total disk space they use) as well as the total file and disk usage of the current directory (as opposed to the information label that displays information for the whole file system). If a directory contains a lot of subdirectories, it may not be possible to drop the URL onto the panel (on which only directories are visible), but the URL can be dropped onto the Information Label or Totals Label instead. When a custom filter is set, it will show the setting, example: [*.cpp].

When using the "KDE default colors", then the selected files are shown in blue and the current file is surrounded by a fine-lined rectangle. By default an icon is shown according to the file type. Use Konfigurator Panel page to change the default configuration to meet your individual needs.

Some useful List panel Key-Bindings:

- **Ctrl+R** will refresh the panel.

Focus a file or directory on the left panel, press **Ctrl+Right arrow** and the right panel changes:

- On a file: the right panel gets the same path as the left panel.
- On a directory: right panel opens the directory focused on the left panel.

For the right panel: press **Ctrl+Left arrow** and the left panel will change.

### 3.4.2 Sidebar

This is "Krusader is 3rd Hand" or the 3rd Panel, click on the arrow-up button on the right of the Totals Label or Alt+Down-Arrow to open the Sidebar. This panel has several display modes which can be activated by clicking on the appropriate button.

- **Preview Panel**: gives a preview of the file that has the focus (currently selected file).
• *Tree Panel*: is used to quickly browse the local directory tree. This panel behaves like the list panel but only one directory may be selected at a time and double clicking or pressing *Enter* on a directory will open that directory in the active panel. The panels fully support drag and drop (copy, move, link) mouse actions.

• *Quick Panel*: is used to quickly select files, e.g. enter *.*.png and click on the *Go* button. The “floppy” button stores the current selection. The “select group dialog” is also available.

• *Viewer Panel*: views a text file, views an image, etc. A thumbnail view is generated whenever you open the *Viewer Panel*.

• *Disk Usage Panel*: views the Disk Usage of a directory.

It is possible to change the sidebar placement using the rotation button which is located to the left of the arrow down button at the bottom part of the Krusader tab. Each click on this button moves the sidebar on one position in the loop “bottom-left-top-right”.

If needed you can resize the window e.g. to better display a picture or view a file contents. Click on the arrow down button to close the 3rd Hand Panel.

### 3.4.3 Folder History

Both panels remember recently visited folders. Click on the *Folder history* button (“watch” symbol) to open the folder history list. Here you can quickly change to previously visited folders. The currently focused folder is checked. On every new start of Krusader, the history list is populated by the items from previous run (history is saved).

### 3.5 Command Line / Terminal Emulator

This part of the GUI can have four modes: Command Line, Terminal Emulator, show both and show none. You can choose your mode of operation either on start-up with the *Konfigurator Startup page*, or for the current session with the Settings menu.

#### 3.5.1 Command Line

```
/home/kubuntu/krusader/build> make
```

Figure 3.4: Command Line

The traditional command line mode offers a single line of input to enter commands, it also features three buttons:

• *command history* (down arrow) to quick open previous used commands

• *Useraction expander* (green plus button) to add easy Useraction placeholders

• *run in terminal mode* (console icon) button with the next options:
  – Start and Forget
  – Display Separated Standard and Error Output
  – Display Mixed Standard and Error Output
The Krusader Handbook

- Start in New Terminal
- Send to Embedded Terminal Emulator

When you start typing your commands, the command line auto-completion feature will make its offers according to what you choose in the System Settings. If you want to change the way auto-complete behaves in the current Krusader session, right click on the command line and change it. To the left of the input line you can find the local path that the active panel is currently pointing to. This path is where your command will be executed. Typing `cd <directory>` in the command line will also cause the active panel to point to this directory. Click here to view the command line keybindings.

### 3.5.2 Terminal Emulator

![Terminal Emulator](image)

Figure 3.5: Terminal Emulator

The terminal emulator mode is in fact a small console and acts like one. You can change the active directory in the terminal by using the `cd` command. The terminal emulator will follow the active panel directory. You can drag a file from the List Panel and name of file will pasted into Terminal Emulator. If you drag multiple files, the names will pasted into Terminal Emulator. A full-screen terminal emulator can be used when configured or `Ctrl+Shift+F` toggles between normal and full screen mode. If the command line is hidden, press `Ctrl+Arrow down` to focus the terminal emulator. `Ctrl+Arrow up` brings you back down. `Ctrl+Enter` and `Ctrl+Shift+Enter` paste the filename. You can close the emulator by typing `exit`.

Click here to view the Terminal emulator keybindings.

### 3.6 Function (FN) Keys Bar

![Function (FN) Keys Bar](image)

Figure 3.6: Function (FN) Keys Bar

This bar gets its name from the function (FN) keys it represents. For each button on this bar there is a corresponding function key that performs the same action. This bar is derived from the design of the first twin-panel file managers and the FN keys usually act the same way with two changes: the F2 key is used to rename files and the F9 key will open a terminal at the last local path that the active panel pointed to. `Mkdir F7` can create whole directory trees on the fly e.g. `foo/bar/test`. You can choose to display or not the FN keys bar when starting up Krusader via the Konfigurator Startup page, and you can toggle its use in the current session with the Settings menu. The actions and Key-Bindings performed by the function keys are configurable since version 1.51, they will remain active with or without the FN keys bar displayed.
3.7 Folder Tabs

With **Folder Tabs** you can quickly change to multiple folders; each panel has its own **Folder Tabs**. The **Folder Tabs** positions are saved when closing Krusader. To switch between **Folder Tabs**, click them with the mouse. Squeezed **Folder Tabs** have tooltips to display the full path. The following **Folder Tabs** operations are available:

- To open a new tab and keep the current tab opened: **Right-click** on a directory and select **Open in New Tab**.
- To lock a tab, **Right-click** and select **Lock Tab**.
- To pin a tab, **Right-click** and select **Pin Tab**. The pinned tab is a locked tab but with temporarily changeable address. It resets to pinned address on tab reactivation. To unpin the pinned tab right-click on it and choose the **Unpin Tab** item.
- To duplicate a tab: **Right-click** on the folder tab and select **Duplicate Current Tab**, or use **Ctrl+Alt+Shift+N**.
- To close a tab (except for the last tab): **Right-click** on the tab and select **Close Current Tab**, or use the middle mouse button, or use the Folder tab **red cross** button, or use **Ctrl+W**.
- To create a “home” tab: click on the **Home** button.
- To change tabs: **Ctrl+,,** or **Ctrl+..**.
- To open the current folder in a new tab: use **Ctrl+Alt+Enter**.
- To close all other tabs, **Right-click** and select **Close Inactive Tabs**.
- To close duplicated tabs, **Right-click** and select **Close Duplicated Tabs**.
- To move tab on the other panel, drag it to the area of the other panel with the left mouse button (the mouse cursor will become an arrow pointing left or right) and drop it. You can also press **Ctrl+Shift+O**.

3.8 Buttons

Several buttons for fast operations are available: **Main Toolbar**, **Actions Toolbar**, **Panel Toolbar**, **Location Toolbar**, **Media**, **Folder history**, **Bookmarks**, **Tab**, **Commandline**, **Function keys**.
Chapter 4

Basic Functions

4.1 Controls

4.1.1 General

This is a rather short but important section that will go into the details of controlling Krusader. This section does not try to cover all the various key combinations for two reasons:

1. there are just too many of them
2. most of Krusader actions are configurable in the Konfigurator Panel page

We will only mention the most important keyboard shortcuts with the default configuration, but keep in mind that most of the Key-Bindings are configurable. If you find that you use a certain command a lot and want to know the shortcut for this command, or you want to change this command shortcut, then check out the Configure Shortcuts window (Settings → Configure Shortcuts...).

4.1.2 Moving Around

By Moving Around we mean the transfer of the keyboard and mouse focus between the different parts of the Krusader main window. The focus can be in one of five places: the Left or Right Panel, the Menu Bar, the Command Line or the Terminal Emulator. The panel that has the focus is called the Active Panel. An Active Panel will remain active until the other panel receives the focus (i.e.: if the Left Panel was active and you clicked on the Command Line - then the Left Panel remains the Active Panel). You must deliberately change which panel is active.

The most common way to transfer the focus to a specific panel is to use the mouse to click on that panel. But you should be aware of the following:

- Clicking on the Toolbar, the FN keys bar or the Status Bar does not change the focus.
- Pushing the Run in Terminal Mode button in the Command Line will not transfer the focus, so you have to click inside the Input Line.
- When you choose a menu, the Menu Bar will become focused. It remains focused until you choose a command - the focus returns to the previous owner.

There are, of course, ways to use the keyboard to change the focus:
The Tab Key will switch panels, if one of the panels has the focus or rotate between all the commands in a menu, if the Menu Bar is active.

The Ctrl+Down Arrow will take you from the Active Panel to the Command Line or Terminal Emulator, and the Ctrl+Up Arrow will take you back from the Command Line to the Active Panel.

The Esc Key will make the Menu Bar return the focus, if it has it, to the previous Active Panel.

If you happen to be inside the Terminal Emulator, you can use the Tab Key, or the mouse, to navigate to an Active Panel.

Pressing Alt+Underlined Letter from the Menu Bar will open that menu (unless this key combination is a ”Reserved Key”, used by one of Krusader’s actions).

4.1.3 Selecting

<table>
<thead>
<tr>
<th>NOTE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Krusader offers 4 Selection Modes, to say nothing about the Quickselect bar, only Krusader’s Selection Mode is explained here.</td>
</tr>
</tbody>
</table>

Selecting is a skill you need to master in order to get the most out of Krusader. Since the Tree Panel allows select only one directory at a time, this paragraph mainly explains how to select files in the List Panel.

Moving the cursor is easy. Left-clicking on a file or directory (referred to herein as “elements” meaning files and directories) will select it. Here are some useful pointers that will make Krusader even easier to use (assuming you are using Krusader’s Mouse Selection Mode):

- The Space and Insert keys will toggle the selection of the file under the cursor without affecting the selection of other files/directories, the cursor will go one position down.
- Left Clicking on a file will select, or unselect, all previously selected files.
- Ctrl+Left Clicking will toggle the selection of the file under the cursor without affecting the selection of other files/directories.
- Shift+Left Clicking will select all the elements between the previous cursor location and the new one.
- Shift+Home selects everything above the cursor (and deselects everything below the cursor, if selected).
- Shift+End selects everything below the cursor (and unselects everything above the cursor, if selected).
- The “..” entry is not selectable.
- The Edit menu can offer more ways to select your files.

4.1.4 Executing Commands

There is not a lot to say here, all you need to do is select some files (if you do not, Krusader will operate on the file(s) or directory(s) that have the focus), choose a Command from the Menu Bar or use a Keyboard Shortcut (or the Right Click Menu) and the selected Command executes. See also Executing Files.
4.1.5 Quick search

This feature will do a quick search for the file name in the Active List Panel.

Type foo (one character) to do a quick search in the Active List Panel for a file beginning with “foo”. A small quick search dialog box will open below the Active List Panel. Type the first few characters of the desired file name (more than one character allowed), the cursor will jump to that filename (if it exists), e.g. type “ab” to search for a file which begins with “ab”. The Up/Down Arrow will jump to the next or previous match. Esc will close the quick search line. The cursor will stay on the last file found. The Quicksearch supports regular expressions for searching files.

**NOTE**

If you press Alt-foo, the key binding shortcut will be executed. If there is no configured key binding, the remaining letter foo will be used for the quick search.

Use Configure Shortcuts window (Settings → Configure Shortcuts...).

4.1.6 Quick filter

This feature will do a quick filter for the file list in the Active Panel.

Press Ctrl-I to open Quickfilter bar. Type foo (one character) to filter out from the Active Panel all the files that do not have “foo” in names. You can use wildcards for the filtering, e.g. use "a*b" to filter files which have "a" and "b" in their names. The Quickfilter follows the case-sensitivity setting of Quicksearch.

Pressing Enter in Quickfilter mode sets focus to panel, when panel or Quickfilter is focused, Esc closes Quickfilter.

To change the default shortcut of Quickfilter use Configure Shortcuts window (Settings → Configure Shortcuts...).

4.1.7 Quick select

This feature will do a quick select for the file list in the Active Panel.

Press Ctrl-Shift-S to open Quickselect bar. Type foo (one character) to filter out from the Active Panel all the files that do not have “foo” in names. You can use wildcards for the filtering, e.g. use "a*b" to filter files which have "a" and "b" in their names. The Quickselect follows the case-sensitivity setting of Quicksearch.

Pressing Enter in Quickselect mode sets focus to panel, when panel or Quickselect is focused, Esc closes Quickselect.

To change the default shortcut of Quickselect use Configure Shortcuts window (Settings → Configure Shortcuts...).

4.1.8 Context Menu

Krusader has many Context menus that allow you to do fast operations with the mouse, usually a right-click will open the Context menu (depending on your Selection Modes settings). This list gives an overview of the most important context menus. Use them to discover the available commands.

- **Main Toolbar** (orientation, text position, icon size)
4.2 Basic File Management

4.2.1 Executing Files

You can only execute files in the Active List Panel. To execute a file just (double-)click on it or press Enter when it is under the list cursor. Krusader will open it in the default application for this file type (picture, text file...) or the file will be executed (script, binary...). If you want to use another application to open the file, click with the right mouse button on the file and go to the Open with sub-menu which will offer more options. Krusader is compatible with the Plasma default file manager for all file types except archives that are opened inside the Krusader panel and not in an external application. See the archives page in Konfigurator for details.

4.2.2 Copying and Moving

To copy or move files/directories just select them and press F5 to copy or F6 to move them. Krusader tries to preserve the time of modification. When copying a directory owner is changed to the user which copies the directory, group is changed to the default group of the user. When copying a file owner is changed to the user which copies the file, group is changed to default group of the user, and permissions are preserved. The owner, the group and the permissions are preserved when moving file or directory. When copying or moving files/directories a dialog appears and allows you to choose the operation destination. The default destination is the other-panel browsed directory. If you enter a partial URL, Krusader will use the current panel directory as the URL base.

4.2.3 Queue manager

The copy, move, pack and unpack operations can be queued. After selecting copy or move, hit F2 to use it. After selecting pack or unpack, hit F2 to use it. Or the direct shortcuts: copy by queue Shift+F5, move by queue Shift+F6. Queue manager performs actions one-by-one. For example, if you have a pen drive (which is slow), and you want to copy 40 files onto it, it is much better copying them one-by-one instead of starting to copy 40 files in parallel. That is why enqueuing is important. If you pack/unpack 40 files in parallel, you overload your computer, but adding them to a queue, is much more useful.

It is possible to switch the Queue Manager mode by the Settings → Job Queue Mode menu item.
4.2.4 Deleting - move to Plasma Trash

Deleting files/directories is done by selecting them and pressing F8 or Delete. By default it will be moved to Plasma Trash. You can open the Plasma Trash with the Trash icon in the Main Toolbar or with the trash:/ KIO slave. Physically Plasma Trash is located in ~/.local/share/Trash/ or Trash in the subdirectory in user home directory which can be determined using the `qtpaths --paths GenericDataLocation` command. Shift+Delete will delete the file permanently. A dialog will ask for your confirmation and will warn you when deleting non-empty directories. Of course only operations that are permitted to do by the Operating System will be performed - you will be notified otherwise. If you do not wish to see the confirmation dialogs, you can disable them in the Konfigurator advanced page.

4.2.5 Shred Files

Shred was removed from KDE 4 (and as consequence Krusader-2 for KDE 4). The main reason is probably that shredding is filesystem dependent and even if you overwrite the file 100 times, it is not sure, that it will be deleted from the disk finally. Quote from the kkgpg posts: ‘The shred feature has been removed from the KDE library. Kgpg will not support this feature anymore. Moderns file systems use journalisation. So the shred feature should be implemented in the file system. Not in kkgpg.’ But you might use a proper shred UserAction for your filesystem. But keep in mind that if you want to be 100% sure that it is impossible that someone can read a deleted file, you need to destroy your harddrive hardware...

4.2.6 Renaming Files, Creating Directories and Link Handling

Rename the file under the cursor with the F2 key or with two single mouse clicks. If only the file name needs to be renamed and not the extension, you can configure this in the Konfigurator General page. Create a new directory with the F7 key. Right-clicking on a regular file will give you the option Link Handling → New Symlink. A dialog will prompt you to enter a symlink name. That symlink will point to the file/directory you right-clicked on. If the file you right-clicked on is a symlink, you will also be presented with the Link Handling → Redirect Link option that will allow you to change the link target.

4.2.7 Viewing and Editing files

KrViewer has a chapter of its own.
4.3 Archive Handling

4.3.1 Browsing Archives

The Virtual file systems (VFS) allows you to browse archives as if it was a directory. Currently Krusader supports the following archives types: ace, arj, bzip2, deb, gzip, iso, lha, rar, rpm, tar, xz, zip, and 7-zip and supports the following passworded archives: arj, ace, rar and zip. Passwords can be stored in Kwallet. Please note that the archive support first needs to be properly configured in Konfigurator. To open the archive, use Enter, (double-)click or the Right Arrow. Krusader supports also hidden archives, these are renamed archives with a "wrong" extension, e.g. OpenOffice® uses zip archives with the following extensions: .odt, .sxw and .odw. Enter will open the OpenOffice® document and the Right Arrow will open the archive. Another example is J2EE, where the .jar extension means a zip archive. Since Krusader auto-detects the supported archive types, it will open with Right Arrow even if it has another MIME type. Please note that browsing archives has a few limitations:

- Not all functions are supported by all archive types. (i.e.: you cannot delete files in ace or rar archives)
- The permissions you have inside the archive are the same as the permissions you have for the archive.
- The command line (if visible) will not follow you inside the archive but will point to the archive directory.
- Before any action is performed on files/directories inside the archive, they must be extracted. The archive will be repacked when you leave it or when Krusader detects that extracted files have changed.
- Packing and un-packing are "blocking operations" that display a progress dialog. However, this might change in the future since we are planning to create more background operations.

4.3.2 Unpack Files

There are 2 ways to extract files from archives:

If you want to unpack a whole archive(s), browse to the archive location, select the archive(s) and select File → Unpack or Alt+Shift+U. Krusader will ask you where to put the extracted files. The default location is the inactive panel directory. If you do not cancel the operation, Krusader will try to unpack all the selected files in the inactive panel.

If you only want to extract a part of the archive, then browse the archive and copy the files you want to extract to their new location just as you would copy "normal" files. Note that unpacking from a browsed archive takes more time (file by file unpack) compared to unpacking a whole archive with the first method. The unpack operation can be put in a queue.

4.3.3 Packing Files

If you want to create a new archive, begin by selecting the elements you want to pack in the active panel and select File → Pack or Alt+Shift+P. A dialog will pop-up prompting you to select the archive name and location. Select the packer from one of the supported file name extensions.

To add files to an existing archive(s), open the archive in one panel and the files to be copied in the other panel, then simply copy the files into the archive in exactly the same way you copy files into a "normal" directory. The pack operation can be put in a queue.
4.3.4 Testing Archives

Krusader will not handle corrupted archives since it may result in data loss. If you receive an error message when opening an archive, or if you suspect that there is something wrong with the archive, you should test it before use. To test an archive, browse (navigate) to the archive location and select the archive. Next select File → Test Archive or Alt+E. Krusader will test the archive file and inform you whether the archive passed or failed the file integrity test.
Chapter 5

Advanced functions

5.1 Virtual file systems (VFS)

A basic OFM feature is VFS, this an abstracted layer over all kinds of archived information (ZIP files, FTP servers, TAR archives, NFS filesystems, SAMBA shares, ISO CD/DVD images, RPM catalogs, etc.), which allows the user to access all the information in these divergent types of filesystems transparently - just like entering an ordinary sub-directory. Krusader supports several virtual file systems:

- **Remote connections VFS**: provides the capability of working with a remote connection session (FTP, NFS, Samba, FISH, SFTP) like with local filesystems. It is perfect for complex remote operations and almost as powerful as most standalone GUI remote clients.

- **Archive VFS**: allows to browse archives in VFS as it was a directory (ace, arj, bzip2, deb, gzip, iso, lha, rar, rpm, tar, zip and 7-zip).

- **Search VFS**: Feed to listbox places the search results in VFS.

- **Synchronizer VFS**: places the synchronizer results in VFS.

Actions you perform on the files in VFS are performed on the ‘real’ files. You do not just delete files from the VFS - you delete them from your hard drive. Limitations: you cannot create directories inside a VFS.

It is possible to keep the directory structure when doing a copy from a virtual folder to a non virtual folder, by selecting the “Keep virtual directory structure” check box of the copy dialog. Imagine the following virtual folder:

```
$ file:/home/myhome/mydir1/myfile1

$ file:/home/myhome/mydir1/myfile2

$ file:/home/myhome/mydir2/myfile3
```

Then do the following steps:

- go to the virtual folder and select the files
- select a destination folder (non virtual!)
- press F5-> copy dialog appears
The Krusader Handbook

- Check Keep virtual directory structure
- Select /home/myhome/ for base URL
- Start copy by pressing OK

The result will be:

```bash
$ destinationdir/mydir1/myfile1
$ destinationdir/mydir1/myfile2
$ destinationdir/mydir2/myfile3
```

5.2 Compare

Krusader contains several compare functions: Compare by Content, Compare Directories and the Synchronizer compare function.

5.2.1 Compare by Content

Select one file in each panel and use File → Compare by content. Krusader will open an external graphical difference tool that is configured. Kompare, KDiff3 and xxdiff are supported.

5.2.2 Compare Directories

Compare the files of each panel by using Edit → Compare Directories. By default newer and single files will be selected in each panel, this behaviour can be changed in the Compare Setup menu.

**NOTE**
The files are not compared by content but by their names and dates only.

**Edit → Compare Setup**

Configures the Compare Directories function.

- Select Newer and Single (default)
- Select Single
- Select Newer
- Select Different and Single
- Select Different
5.3 Calculate Occupied Space

There are two ways to calculate the occupied space of files/directories.

- Pressing the configurable shortcut for the Calculate occupied space on a directory under the cursor instantly calculates the occupied size.

- To calculate how much disk space is occupied by the selected files and directories in the active panel select Edit → Calculate Occupied Space. After a small delay, a dialog box will be displayed with total occupied space and the number of files and directories you selected. The space occupied by every selected directory will be shown as if the user just pressed configurable shortcut on those directories. If the active panel is browsing an archive, the numbers will apply to the unpacked size of the selected files and directories, not their compressed size. After the calculation the selection state will be toggled and the cursor will move one step downwards.

Calculating the occupied space on remote file systems is supported.

**NOTE**
Performing this operation on a very large file system (thousands of files) may be time-consuming. You can cancel the calculation process at any time by clicking the Cancel button.

5.4 File Splitter

This function splits one (large) file up into multiple smaller files so that they can be placed on smaller media (e.g. ZIP drives, ...) or sent by email. The multiple files can be combined again to recreate the original file. Krusader and Total Commander© split/combine functions are compatible. To split a file choose File → Split or Ctrl+P: a Split dialog will open to confirm the operation.

If the name of the original file is `foo`, then the name of the smaller files will be `foo.000`, `foo.001`, `foo.002` etc. There is no theoretical limit in the number of smaller files, but it is recommended to limit the number to a maximum of 1023 files. Krusader creates a `foo.crc` file. This file contains the name, size and the crc checksum of the original file. It is possible to combine the file without the `foo.crc` file but in this case Krusader cannot check if the original file was recreated correctly.

An example of a `foo.crc` file:

```
filename=foo size=432998467868 crc32=21EB719A
```

To combine the multiple files choose, select a partial file `foo.xxx` and choose File → Combine files or Ctrl+B. The target directory is the inactive panel and can be changed. The file names must be numbered in ascending order: `foo.001`, `foo.002`, `foo.003` etc. or have letters in ascending order: ("split -b letter method") `fileaa`, `fileab`, `fileac` etc. If the file `foo.crc` is found in the same directory as the partial files, Krusader will use this file to check the combined file for errors.

5.5 Checksum Creation and Verification

**File → Create Checksum:** Krusader checks which tools you have and if those tools allow recursive operation (in case you selected folders), you can generate a checksum by choosing a checksum type from the list (md5, sha, etc.). You can then save the checksum to a file, usually called `checksum.md5` or `checksum.sha1`.

**File → Verify Checksum:** Krusader checks if you have a tool that supports the type of checksum you need (from your specified checksum file) and displays the files that failed the checksum (if any).
The system abstracts over different checksum mechanisms and Checksum Utilities. At the moment, the following checksums are supported: md5, sha1, sha256, sha224, sha256, sha384, sha512, tiger, whirlpool, cfv and crc. Please check your Checksum Utilities settings before using this function.

5.6 Send Files by Email

Select a file and use Right-Click menu → Send by Email. Selecting this option will open a new KMail window with the file already attached. Just fill in the subject and recipient(s) and send it. Of course, KMail must be properly configured.

5.7 Profiles

With profiles you can save and restore your favorite settings. Several features support profiles, you can have e.g. different panel profiles (work, home, remote connections, etc.), search profiles, synchroniser profiles, etc.

5.7.1 Panel Profiles

A panel profile contains the following: all the tab paths (left or right), the current tab (left or right) and the active panel (left or right). All this information is stored in the krusaderrc file. You can have several panel profiles, e.g. file management, FTP management, home, work, etc. The panel profile can be saved and restored in the Window menu. The default startup profile will be used when starting Krusader, but you can override it with a command-line option.

5.7.2 Color Profiles

Colormaps can be saved and restored with Color Profiles.

5.7.3 Key-binding Profiles

Keymaps can be saved and restored with Key-binding Profiles.

5.7.4 Search Profiles

If you regularly perform the same search operation, you can save the search settings (e.g. include files, exclude files, etc.) in a Search Profile.

5.7.5 Synchronizer Profiles

If you regularly perform the same synchronize operation, you can save the synchronize settings in a Synchronizer Profile.

5.8 ACL permissions

ACL permissions are fully supported when using properties, preserve attributes and the synchronizer. To view/modify the ACL permissions, select a file and use the Context Menu: Properties → Permissions → Advanced permissions. At Copy/Move, the ACL permissions are also copied. The synchronizer keeps the ACL permissions as well.
Chapter 6

Menu Commands

6.1 File Menu

File \rightarrow New Text File (Shift+F4)
   Creates a new text file in the current directory, unless another directory is specified. The new file is opened for editing after it is created.

File \rightarrow New Directory (F7)
   Creates a new directory in the current directory.

File \rightarrow New Symlink (Alt+Ctrl+S)
   Creates a symbolic link to the currently selected file.

File \rightarrow View File (F3)
   Opens the currently selected file for viewing.

File \rightarrow Edit File (F4)
   Opens the currently selected file for editing.

File \rightarrow Copy to other panel (F5)
   Copy the currently selected files or directories to the other panel.

File \rightarrow Move (F6)
   Opens a dialog to move the currently selected files or directories to a specified location.

File \rightarrow Pack (Alt+Shift+P)
   Creates a new archive of all the selected files and directories in the active panel.

File \rightarrow Unpack (Alt+Shift+U)
   Unpacks all the selected files in the active panel.

File \rightarrow Test Archive (Alt+Shift+E)
   Tests archive for corruption.

File \rightarrow Compare by Content
   Compares two current files by content - one from each panel via an external graphical diff utility. By default Kompare is used, but you can also use e.g. xdiff or KDiff3, change it in the Konfigurator Dependencies page.
File → Multi Rename (Shift+F2)

This menu option starts Krename, a very powerful external batch renamer.

KRENAME FEATURES

• Renaming a list of files based on a set of expressions
• Copying/moving a list of files to another directory
• Convert filenames to upper/lower case
• Adding numbers to filenames
• Finding and replacing parts of the filename
• Renaming MP3/OGG Vorbis files based on their ID3 tags
• Setting access and modification dates
• Changing permissions and file ownership
• A plugin API which allows you to extend KRename’s features
• Renaming directories recursively
• Support for KFilePlugins
• Undo renaming
• And many more....

File → Create Checksum

Checksum creation on file(s) and/or folder(s).

File → Verify Checksum

Verify Checksum

File → Split File (Ctrl+P)

The Split file function splits a file up into multiple smaller files so that it can be stored on several smaller media (like diskettes, zip-drives, ...) or sent by e-mail.

File → Combine Files (Ctrl+B)

The Combine files function combines multiple files into one file after the Split file function was used.

File → Quit (Ctrl+Q)

Closes Krusader and cleans up the temporary directory, the same as pressing F10 key.

6.2 Edit Menu

Edit → Cut (Ctrl+X)

Cuts the selected file(s) to the clipboard to be moved to another location.

Edit → Copy (Ctrl+C)

Copies the selected file(s) to the clipboard to be moved to another location.

Edit → Paste (Ctrl+V)

Pastes previously cut or copied items from the clipboard to the current directory.

Edit → Delete (F8)

Deletes the currently selected file(s).
The Krusader Handbook

**Edit → Select Group (Ctrl++)**
Opens a dialog which allows you to select files in the active panel. In the Search for dialog place the main search criteria. Enter a filename, a wildcard (*.*., *.c etc.) or both - separated by a space. When using 'text', the results are the same as '*'text*'. You can exclude files from the search with '|' (e.g. '*.cpp *.h | *.moc.cpp'). With the profile handler you can manage your selections for future usage. A double-click on a profile is the same as entering the selection and pressing the OK button. More options for Select Group dialog are explained in the Search dialog, which are basically almost the same dialogs.

**Edit → Unselect Group (Ctrl+-)**
The opposite of Select Group. The files that match the pattern in the active panel will be deselected.

**Edit → Select All (Alt++)**
Selects all files in the active panel. You can also select all directories by activating the Autoselect directories option in the Konfigurator Panel page.

**Edit → Unselect All (Alt+-)**
Unselects all the files in the active panel.

**Edit → Invert Selection (Alt+*)**
Inverts the selection status of all the files in the active panel (i.e. selected files will become unselected and deselected files will become selected).

**Edit → Restore Selection**
Restore the selection status of previously unselected items.

**Edit → Find in folder (Ctrl+F)**
Toggles Krusader quick search function.

**Edit → Compare Directories (Alt+Shift+C)**
Toggles Krusader Compare Directories function.

**Edit → Compare Setup**
Configures the Compare Directories function.
- Select Newer and Single (default)
- Select Single
- Select Newer
- Select Different and Single
- Select Different

**Edit → Calculate Occupied Space**
Calculates occupied space of files and folders, archives and remote filesystems.

**Edit → Properties (Alt+Return)**
Opens the properties dialog for the currently selected file. (KP refers to Key Pad.)

### 6.3 Go Menu

**Go → Up (Alt+Up)**
Navigates to the parent directory of the active panel.
The Krusader Handbook

Go → Back (Alt+Left)
Navigates to the previously viewed directory in the active panel.

Go → Forward (Alt+Right)
Navigates to the next viewed directory in the active panel. Becomes available only if Go → Back was used beforehand.

Go → Home (Alt+Home)
Navigates to the home directory of the current user.

Go → Root (Ctrl+Backspace)
Navigates to the root directory of the system.

Go → Popular URLs (Ctrl+Z)
Displays a listing of frequently viewed directories from which you may navigate to one by double-clicking on it.

Go → Set Jump Back Point (Ctrl+Shift+J)
Sets the current directory as a “jump back” point. To navigate to this directory quickly, select the Jump Back command from the Go menu.

Go → Jump Back (Ctrl+J)
Returns to a previous “jump back” point.

6.4 View Menu

The action in this submenu usually affects the current Krusader session. If you want to make permanent changes use Konfigurator Startup page.

View → Zoom In
Increase the view scale.

View → Zoom Out
Decrease the view scale.

View → Default Zoom
Reset the view scale.

View → Detailed View (Alt+Shift+D)
Shows the file names, file size, creation date and time and their attributes.

View → Brief View (Alt+Shift+B)
Shows only the file names.

View → Show Hidden Files (Alt+.)
Toggles the option to display the hidden files in the Krusader panels.

View → All Files (Shift+F10)
Turns off all filters and display all files.

View → Custom (Shift+F12)
Allows you to install a custom filter on the Krusader panel. Only files that match the filter pattern(s) and directories will be displayed. Do not forget to deactivate the custom filter after use, or some files may not be visible.

View → Show Previews
If checked, show the previews for all files and folders on the active panel.
View → Select Remote Charset
Selects the remote charset for Remote Connections.

View → Reload (Ctrl+R)
Refreshes the contents of the active panel.

View → Save settings as default
Allows you to save the view settings of the current tab for new instances of this view type.

View → Apply settings to other tabs
Allows you to apply the view settings of the current tab to the other tabs.

6.5 Useractions Menu

You can add your own menu entries here by defining your own UserActions.

Useractions → Manage User Actions...
Opens the UserActions manager.

Useractions → Multimedia → Enqueue in Amarok (Meta+A)
Appends selected item(s) to Amarok playlist.

Useractions → Samples → Equal panel-size (Ctrl+Alt)
Sets the ratio between the two panels to 50/50.

Useractions → Samples → Edit as root (Ctrl+E)
Allows you to edit a file with kwrite using root permissions.

Useractions → Samples → Mount (Ctrl+Alt+M)
Mounts a new filesystem.

Useractions → Samples → Copy current item to clipboard (Ctrl+Alt+C)
Copies current item name to the clipboard.

Useractions → System → Backup current (Meta+F5)
Backups current file in current directory and asks the user for a new filename. By default .old is appended to the original filename.

Useractions → User Interface → Sort By Name (Meta+1)
When this action is turned on, the main sorting key in the Krusader panel becomes the file name.

Useractions → User Interface → Sort By Extension (Meta+2)
When this action is turned on, the main sorting key in the Krusader panel becomes the file extension (the part of the filename after the last ‘.’). This is useful for grouping files of the same type closer together.

Useractions → User Interface → Sort By Size (Meta+3)
When this action is turned on, the main sorting key in the Krusader panel becomes the file size. This is useful for determining the largest files in a particular directory.

Useractions → User Interface → Sort By Modified (Meta+4)
When this action is turned on, the main sorting key in the Krusader panel becomes the last modified date for each file. This is useful for finding files you recently worked on.
6.6 Tools Menu

Tools → Search (Ctrl+S)
Opens KruSearcher - the Krusader search module.

Tools → Locate (Ctrl+Shift+L)
Opens the Locate GUI frontend for fast file searching.

Tools → Synchronize Directories (Ctrl+Y)
The Synchronize Directories function compares the left and right panels and shows the differences between them. After the compare function, you can move files/directories so that they can be synchronized.

Tools → MountMan (Alt+/)
Opens submenu with items to open MountMan or mount/unmount various mounting points.

Tools → Disk Usage (Alt+Shift+S)
Opens Disk Usage.

Tools → New Net Connection (Ctrl+N)
Opens the New Network Connection dialog to start a FTP, SMB, FISH or SFTP connection to a remote host. If you leave the user name and password fields empty, you will login as anonymous. You can Bookmark these remote sessions.

Tools → Disconnect From Net (Ctrl+Shift+D)
Ends the remote connection in the active panel and returns to the start-up path.

Tools → Start Terminal
Opens a terminal window in the default directory (usually your home directory). You can choose your favorite terminal application in the Konfigurator General page.

Tools → Start Root Mode Krusader (Alt+Shift+K)
Starts Krusader in Root mode at the same location. Root mode Krusader requires kdesu by default, if kdesu is not available or if you prefer e.g. gksu when using GNOME you can change this behaviour in the Konfigurator Dependencies page.

**CAUTION**
Be careful when using Krusader with ROOT PRIVILEGES.

Tools → Empty Trash
Empties the trash bin.

6.7 Window Menu

Window → New Tab (Ctrl+Shift+N)
Opens a new tab in the active panel.

Window → Lock Tab/Unlock Tab
Locks then unlocks current tab in the active panel.
The Krusader Handbook

**Window → Duplicate Current Tab (Ctrl+Alt+Shift+N)**
Opens a new tab that is a duplicate of the active tab in the active panel.

**Window → Move Current Tab to Other Side (Ctrl+Shift+O)**
Moves current tab to the other side of Krusader window.

**Window → Close Current Tab (Ctrl+W)**
Closes the current tab in the active panel. This command is only available if there is more than one tab in the active panel.

**Window → Close Inactive Tabs**
Closes all the tabs in the active panel except for the active.

**Window → Close Duplicated Tabs**
Closes the duplicated tabs in the active panel.

**Window → Next Tab (Ctrl+.)**
Navigates to the next tab in the active panel. This command is only available if there is more than one tab in the active panel.

**Window → Previous Tab (Ctrl+,)**
Navigates to the previous tab in the active panel. This command is only available if there is more than one tab in the active panel.

**Window → Profiles (Alt+Shift+L)**
Opens a menu where Panel profiles can be saved and restored.

**Window → Swap Panels (Ctrl+U)**
The left panel will become the right panel and vice versa, only the current tabs will be swapped.

**Window → Swap Sides (Ctrl+Shift+U)**
The complete left panel will become the right panel and vice versa, and all tabs will be swapped.

**Window → Vertical Mode (Ctrl+Alt+R)**
Toggles the List Panel between horizontal and vertical mode.

**Window → Toggle Fullscreen Terminal Emulator (Ctrl+Alt+F)**
Toggles full screen mode of the terminal emulator. This option is only available when Show Terminal Emulator is activated.

**Window → Save Position**
Saves the current size and position of the Krusader main window. This action can be automated with Save last position, size and panel settings in Konfigurator Startup page

### 6.8 Settings Menu

**Settings → Toolbars → Show Main Toolbar**
Shows the Main Toolbar if checked.

**Settings → Toolbars → Show Job Toolbar**
Shows the Job Toolbar if checked.
Settings → Toolbars → Show Actions Toolbar
   Shows the Actions Toolbar if checked.

Settings → Show Statusbar
   Shows the Statusbar if chosen.

Settings → Show FN Keys Bar
   Shows the FN Keys Bar if checked.

Settings → Show Terminal Emulator (Ctrl+Alt+T)
   Show the Terminal Emulator if checked.

Settings → Show Command Line
   Shows the Command Line if checked.

Settings → Command Execution Mode Setup
   Allows you to choose command execution mode. You can choose one of the following options.
   • Start and Forget: start execution and do not wait for the results.
   • Display Separated Standard and Error Output: show the output to stdout and stderr on the separate panels.
   • Display Mixed Standard and Error Output: show the output to stdout and stderr on the single panel (default).
   • Start in New Terminal: execute the command in the new terminal window.
   • Send to Embedded Terminal Emulator: send the command to the embedded terminal emulator.

Settings → Job Queue Mode
   Toggles the Queue Manager mode. If checked then pressing F2 or the corresponding button in the copy/move dialog immediately starts the job even if there are running jobs in queue. If unchecked then the job will be put into the queue if the queue is not empty. Otherwise the job will be started immediately.

Settings → Configure Shortcuts
   Opens a dialog which allows you to configure the Krusader key bindings.
   With the Import shortcuts and Export shortcuts buttons you can load and save a Key-binding profile. This allows Krusader to have the Total Commander©, Midnight Commander, foo-commander, or your custom Key-bindings. The only limitation is that global Plasma key-bindings and some Krusader key-bindings cannot be changed yet, as well as some features in foo-commander that we either do not have or need. The Key-bindings are stored in /usr/share/krusader, foo.keymap.info contains a description, foo.keymap is an ini file that holds the Key-bindings. Until Krusader-1.70.1 this was a binary file, Krusader is backwards compatible for importing this legacy binary format. If a *.keymap.info text file exists, Krusader will display it, showing additional information regarding the loaded Key-bindings file. Here you have a chance to exit without importing the proposed Key-bindings file.

   TIP
   A Total Commander© Key-bindings file is provided. Please upload your favorite Key-bindings schemes so that they become available for the Krusader community. Thanks!

Settings → Configure Toolbars
   Opens a dialog which allows you to configure the Main Toolbar or the Actions Toolbar. You can add action buttons of your favourite UserActions to the desired toolbar.

Settings → Configure Krusader
   Opens Konfigurator - the Krusader configuration center.
6.9 Help Menu

Additionally, Krusader has the common KDE Help menu items, for more information read the sections about the Help Menu of the KDE Fundamentals.
Chapter 7

Keyboard Commands

7.1 Keyboard Usage

In this chapter you will learn how to use the keyboard effectively, because most operations can be done more quickly by keyboard than with the mouse. It will take some time to learn the Key-Bindings, but mastering them saves you a lot of time. Please note that Krusader can use Key-binding Profiles to swap easily to other Key-binding setups, e.g. of other commanders, or you can create your own key-bindings.

After starting Krusader, the keyboard action can begin. Use \texttt{Ctrl}+\texttt{L} to jump to the Location Toolbar where you can type the desired directory. After \texttt{Ctrl}+\texttt{Down arrow} you are in the Terminal emulator and you can type any command you desire. Use \texttt{Ctrl}+\texttt{Up arrow} to jump back to the active panel. If you want to jump to a file or directory that starts with \texttt{f}, then simply press \texttt{f} on the keyboard to use the search bar. Use the \texttt{Enter} key to execute the file or to open a directory that has the focus. Be sure to remember the Function Keys - \texttt{F3} to View, \texttt{F4} to Edit, \texttt{F5} to Copy, \texttt{Alt+Shift+U} to Unpack, etc.

You can also perform several operations with the Folder tabs, including several selection operations. And at the end you can close Krusader with \texttt{F10}.

7.2 Key-Bindings

Most of the key-bindings (shortcuts) are configurable in the Settings $\rightarrow$ Configure Shortcuts menu, if you like to use other key-bindings then the default ones. You can even configure more actions to a Key-Binding (for the actions that do not have a key-binding set by default). Please note that some key-bindings are not Krusader key-bindings (e.g. Plasma key-bindings). The key-bindings that Krusader uses by default are listed below.

Function (FN) Keys

These are the Key-Bindings of the FN Keys Bar. These Key-Bindings are configurable since version 1.51.

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Help</td>
</tr>
<tr>
<td>F2</td>
<td>Rename files.</td>
</tr>
<tr>
<td>F3</td>
<td>View files.</td>
</tr>
<tr>
<td>F4</td>
<td>Edit files.</td>
</tr>
<tr>
<td>F5</td>
<td>Copy files.</td>
</tr>
<tr>
<td>F6</td>
<td>Move files.</td>
</tr>
</tbody>
</table>
## The Krusader Handbook

<table>
<thead>
<tr>
<th>F7</th>
<th>Create a new directory.</th>
</tr>
</thead>
<tbody>
<tr>
<td>F8</td>
<td>Delete (or move to Trash) files.</td>
</tr>
<tr>
<td>F9</td>
<td>Terminal.</td>
</tr>
<tr>
<td>F10</td>
<td>Quit Krusader</td>
</tr>
</tbody>
</table>

### Shift keys

<table>
<thead>
<tr>
<th>Shift+F1</th>
<th>What’s this?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift+F2</td>
<td>Multi-rename (Krename).</td>
</tr>
<tr>
<td>Shift+F3</td>
<td>Enter an URL to view.</td>
</tr>
<tr>
<td>Shift+F4</td>
<td>Edit new file.</td>
</tr>
<tr>
<td>Shift+F5</td>
<td>Copy by queue.</td>
</tr>
<tr>
<td>Shift+F6</td>
<td>Move by queue.</td>
</tr>
<tr>
<td>Shift+F10</td>
<td>View all files.</td>
</tr>
<tr>
<td>Shift+F12</td>
<td>Custom view files.</td>
</tr>
<tr>
<td>Shift+Left Arrow</td>
<td>Change to left folder tab.</td>
</tr>
<tr>
<td>Shift+Right Arrow</td>
<td>Change to right folder tab.</td>
</tr>
</tbody>
</table>

### Alt keys

| Alt++ | Select All. |
| Alt-- | Unselect All. |
| Alt* | Invert Selection. |
| Alt.- | Show/Hide hidden (dot) files. |
| Alt+/ | MountMan. |
| Alt-' | User Menu |
| Alt+Home | Home |
| Alt+Enter | Properties. |
| Alt+Left Arrow | Left bookmarks. |
| Alt+Right Arrow | Right bookmarks. |
| Alt+Down Arrow | Sidebar. |
| Alt+F1..F12 | Standard (Plasma) key-bindings. |

### Alt+Shift keys

| Alt+Shift+B | Brief View |
| Alt+Shift+C | Compare Directories |
| Alt+Shift+D | Detailed View |
| Alt+Shift+E | Test Archive. |
| Alt+Shift+K | Start Root mode Krusader. |
| Alt+Shift+L | Panel profiles. |
| Alt+Shift+O | Sync panels aka 'Equals Button (=)'. |
| Alt+Shift+P | Pack files. |
| Alt+Shift+Q | Queue Manager |
| Alt+Shift+S | Disk Usage. |
| Alt+Shift+U | Unpack files. |
## Ctrl keys

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+B</td>
<td>Add bookmark for the current item.</td>
</tr>
<tr>
<td>Ctrl+D</td>
<td>Open Bookmarks in the active panel.</td>
</tr>
<tr>
<td>Ctrl+E</td>
<td>Edit file as root (Default Useraction).</td>
</tr>
<tr>
<td>Ctrl+F</td>
<td>Open Quicksearch bar.</td>
</tr>
<tr>
<td>Ctrl+H</td>
<td>Open History list in the active panel.</td>
</tr>
<tr>
<td>Ctrl+I</td>
<td>Open QuickFilter bar.</td>
</tr>
<tr>
<td>Ctrl+J</td>
<td>A Safari®-like Jump-Back.</td>
</tr>
<tr>
<td>Ctrl+L</td>
<td>Go to the Location Toolbar (origin) as in Firefox® and Konqueror.</td>
</tr>
<tr>
<td>Ctrl+M</td>
<td>Open media list.</td>
</tr>
<tr>
<td>Ctrl+N</td>
<td>New Network Connection dialog.</td>
</tr>
<tr>
<td>Ctrl+O</td>
<td>Select directory dialog to open this directory in the panel.</td>
</tr>
<tr>
<td>Ctrl+P</td>
<td>Split file.</td>
</tr>
<tr>
<td>Ctrl+Q</td>
<td>Quit Krusader.</td>
</tr>
<tr>
<td>Ctrl+R</td>
<td>Reload (Refresh) panel.</td>
</tr>
<tr>
<td>Ctrl+S</td>
<td>Search.</td>
</tr>
<tr>
<td>Ctrl+U</td>
<td>Swap panels (do not swap all folder tabs).</td>
</tr>
<tr>
<td>Ctrl+W</td>
<td>Close Current tab.</td>
</tr>
<tr>
<td>Ctrl+Y</td>
<td>Synchronize Directories.</td>
</tr>
<tr>
<td>Ctrl+Z</td>
<td>Popular URLs.</td>
</tr>
<tr>
<td>Ctrl+</td>
<td>Select group.</td>
</tr>
<tr>
<td>Ctrl++</td>
<td>Unselect group.</td>
</tr>
<tr>
<td>Ctrl+/</td>
<td>Open command line history list.</td>
</tr>
<tr>
<td>Ctrl+Down arrow</td>
<td>Go from the active panel to the command line/terminal emulator.</td>
</tr>
<tr>
<td>Ctrl+Up arrow</td>
<td>Go from the command line/terminal emulator to the active panel.</td>
</tr>
<tr>
<td>Ctrl+Up arrow</td>
<td>Go from the active panel to the Location Toolbar.</td>
</tr>
<tr>
<td>Ctrl+Home</td>
<td>Jump to the Home directory.</td>
</tr>
</tbody>
</table>

### Ctrl+Left or Right arrow

Focus a file or directory on the left panel, press Ctrl+Left arrow and the right panel changes:
- on a file: the right panel gets the same path as the left panel.
- on a directory: refreshes the right panel with the contents of the directory. For the right panel: press Ctrl+Right arrow and the left panel will change.

### Ctrl+Backspace

Jump to the Root directory.

### Ctrl+PageUp

Up one directory.

### Ctrl+=

Go to the directory from other panel.

### Ctrl+Return

When media menu is open (un)mounts the highlighted device.
# The Krusader Handbook

## Ctrl+Shift keys

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Shift+D</td>
<td>Disconnect remote connection.</td>
</tr>
<tr>
<td>Ctrl+Shift+F</td>
<td>Activate search bar to find entries in the active tab.</td>
</tr>
<tr>
<td>Ctrl+Shift+J</td>
<td>Set jump back point.</td>
</tr>
<tr>
<td>Ctrl+Shift+L</td>
<td>Locate GUI frontend.</td>
</tr>
<tr>
<td>Ctrl+Shift+O</td>
<td>Move current tab to other side of the window.</td>
</tr>
<tr>
<td>Ctrl+Shift+S</td>
<td>Open Quickselect bar.</td>
</tr>
<tr>
<td>Ctrl+Shift+U</td>
<td>Swap Sides (also swap all folder tabs).</td>
</tr>
<tr>
<td>Ctrl+Shift+Left arrow</td>
<td>Open left media list.</td>
</tr>
<tr>
<td>Ctrl+Shift+Right arrow</td>
<td>Open right media list.</td>
</tr>
<tr>
<td>Ctrl+Shift+Up arrow</td>
<td>Open terminal emulator, independently, whether the command line is shown or not.</td>
</tr>
<tr>
<td>Ctrl+Shift+Down arrow</td>
<td>Close terminal emulator, independently, whether the command line is shown or not.</td>
</tr>
</tbody>
</table>

## Ctrl+Alt keys

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Alt+M</td>
<td>Mount (Default Useraction).</td>
</tr>
<tr>
<td>Ctrl+Alt+N</td>
<td>New tab.</td>
</tr>
<tr>
<td>Ctrl+Alt+R</td>
<td>Toggle the List Panel between horizontal and vertical mode.</td>
</tr>
<tr>
<td>Ctrl+Alt+S</td>
<td>Create a new symlink.</td>
</tr>
<tr>
<td>Ctrl+Alt+T</td>
<td>Show/hide the embedded terminal.</td>
</tr>
<tr>
<td>Ctrl+Alt+Left Arrow</td>
<td>Left History list.</td>
</tr>
<tr>
<td>Ctrl+Alt+Right Arrow</td>
<td>Right History list.</td>
</tr>
<tr>
<td>Ctrl+Alt+=</td>
<td>Equal Panel Size (Default Useraction).</td>
</tr>
<tr>
<td>Ctrl+Alt+Shift+N</td>
<td>Duplicate a tab.</td>
</tr>
<tr>
<td>Ctrl+Alt+Enter</td>
<td>Open current folder in a new tab.</td>
</tr>
</tbody>
</table>

## General Ctrl keys

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+A</td>
<td>Select all.</td>
</tr>
<tr>
<td>Ctrl+PageDown</td>
<td>Move to the lower part in the current directory.</td>
</tr>
<tr>
<td>Ctrl+Fl..Fl2</td>
<td>Standard (Plasma) key-bindings.</td>
</tr>
<tr>
<td>Ctrl+Shift+Fl..Fl2</td>
<td>Standard (Plasma) key-bindings.</td>
</tr>
</tbody>
</table>

## Other keys

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>foo</td>
<td>Quick search, quick select or quick filter. See this configuration page on how to configure the default mode.</td>
</tr>
</tbody>
</table>
### The Krusader Handbook

<table>
<thead>
<tr>
<th>Tab</th>
<th>Switch between the panels</th>
</tr>
</thead>
</table>
| Enter        | On a file: open/execute that file  
On an archive file: browse the archive as if it was a directory. |
| Esc          | Will make the menu bar lose the focus if it has it. |
| Delete       | Delete (or move to Trash). |
| Shift+Delete | Delete permanently. |
| Space        | On a file: toggle the selection of the file down one position without affecting the selection of other files/directories. |
| Backspace    | One directory up. |
| Insert       | Does the same as the Space key and goes down one position to toggle the next file. |
| Menu         | Right-click menu. |
| Home         | Cursor jumps to the top of the list. |
| End          | Cursor jumps to the last file in the list. |

#### Command Line

**Command Line** keybindings.

<table>
<thead>
<tr>
<th>Up arrow and Down arrow</th>
<th>Scroll through previously typed commands.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+/</td>
<td>Open the command line history list.</td>
</tr>
<tr>
<td>Ctrl+Up arrow</td>
<td>Jump from the command line to the active panel.</td>
</tr>
<tr>
<td>Ctrl+Down arrow</td>
<td>Jump from the active panel to the command line.</td>
</tr>
<tr>
<td>Ctrl+Enter</td>
<td>Insert current file / directory name without path to current command line position.</td>
</tr>
<tr>
<td>Ctrl+Shift+Enter</td>
<td>Insert current file / directory with full path name to current command line position.</td>
</tr>
</tbody>
</table>

#### Terminal emulator

**Terminal emulator** keybindings.

<table>
<thead>
<tr>
<th>Ctrl+F</th>
<th>Toggle between normal and full screen Terminal emulator.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+V</td>
<td>Insert from clipboard.</td>
</tr>
<tr>
<td>Ctrl+Up arrow</td>
<td>Jump from the Terminal Emulator to the active panel if the Command line is hidden.</td>
</tr>
<tr>
<td>Ctrl+Down arrow</td>
<td>Jump from the active panel to the Terminal Emulator if the Command line is hidden.</td>
</tr>
<tr>
<td>Ctrl+Shift+Up/Down arrow</td>
<td>Always focus/unfocus the Terminal Emulator independently whether the Command Line is shown or not.</td>
</tr>
<tr>
<td>Shift+Insert</td>
<td>Insert from clipboard.</td>
</tr>
</tbody>
</table>
The Krusader Handbook

Synchronizer

Synchronizer keybindings.

<table>
<thead>
<tr>
<th>Ctrl+W</th>
<th>Reverse direction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt+Down arrow</td>
<td>Exclude</td>
</tr>
<tr>
<td>Alt+Up arrow</td>
<td>Restore original task</td>
</tr>
<tr>
<td>Alt+Left arrow</td>
<td>Copy to left</td>
</tr>
<tr>
<td>Alt+Right arrow</td>
<td>Copy to right</td>
</tr>
<tr>
<td>Alt+Delete</td>
<td>Mark for delete</td>
</tr>
</tbody>
</table>

Default Useractions

Default UserActions keybindings provided by Krusader.

<table>
<thead>
<tr>
<th>Ctrl+E</th>
<th>Edit a file as root.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Alt+C</td>
<td>Copy current item to clipboard.</td>
</tr>
<tr>
<td>Ctrl+Alt+M</td>
<td>Mount a new file system.</td>
</tr>
<tr>
<td>Ctrl+Alt+=</td>
<td>Equal panel-size.</td>
</tr>
<tr>
<td>Meta+A</td>
<td>Enqueue in Amarok.</td>
</tr>
<tr>
<td>Meta+1</td>
<td>Sort by Name.</td>
</tr>
<tr>
<td>Meta+2</td>
<td>Sort by extension.</td>
</tr>
<tr>
<td>Meta+3</td>
<td>Sort the active panel by size.</td>
</tr>
<tr>
<td>Meta+4</td>
<td>Sort by modified.</td>
</tr>
<tr>
<td>Meta+F5</td>
<td>Backup current file (Default Useraction).</td>
</tr>
</tbody>
</table>

OTHER KEY-BINDINGS

- Selecting files
- KrViewer
- Disk Usage
- Locate GUI frontend
- System Settings -> Common Appearance and Behavior -> Shortcuts and Gestures
- UserActions configurable key-bindings
Chapter 8

Mouse Commands

8.1 Mouse Usage

In this chapter you will be guided in using Krusader effectively with a mouse and to configure mouse gestures through KHotKeys. By simply clicking the mouse you can select different sections of Krusader. Another chapter describes the selection modes, and how you can configure them: Selection Mode
Chapter 9

Krusader Tools

9.1 BookMan: Organize your Bookmarks

BookMan is Krusader’s Bookmark tool for bookmarking folders, local and remote URLs, and later returning to them in a click of a button. The Bookman menu is divided into four sections:

- Your personal bookmarks
- Popular URLs
- Permanent bookmarks
- Manage bookmarks

**NOTE**
You can bookmark inside a remote file system (FTP or SAMBA) and later use the bookmark to quickly connect to the remote machine, but you cannot bookmark inside an archive.

9.1.1 Using Bookmarks

Usually, you click on the BookMan II button (the rightmost button to the right of the address bar at the top of the active panel) when you are in the target folder. For example, to bookmark /usr/tmp, navigate Krusader there and click the BookMan II button and select Bookmark Current. When the Add Bookmark dialog box appears, the URL line will say /usr/tmp. Name is for the name you would like to give to the bookmark (e.g.: temporary folder). Hotkeys are supported by adding & to the bookmark name e.g. &sourceforge, &home, download etc., so you can quickly call the bookmark name with Alt+foo. If you add the bookmark without entering a name, the bookmarks name will be the same as its target. URL is where the bookmark points to. Create in creates bookmark folders for organizing your bookmarks.

To use your bookmarks, click the BookMan II button and choose a bookmark. You may also use the Key- Bindings: Ctrl+B to bookmark the current item, Alt+right/left arrow to open right/left panel bookmarks list and Ctrl+D to open the bookmarks of the active panel. From the context menu of the bookmark (right mouse button click) you can open it in a new Folder tab.

There is a quick search bar at the top of the BookMan II menu.
Below are the rules to handle bookmarks:

- Just type letters to search: bookmarks are matched by name prefix
- If multiple bookmarks are matched by the prefix, they are highlighted and the first one is selected - hit Enter to activate the bookmark
- Once a single bookmark is matched, it is immediately triggered. That is when you type ‘h’ and only one bookmark starts with ‘h’, it is executed immediately - no Enter needed
- Accelerators work only if the keystroke is the first one
- Backspace is supported
- Search is case insensitive unless you type a capital letter. That is typing Hamburglar will only match Hamburglar but not hamburglar or Hamburglar.
- Search bar is intentionally a read-only field

### 9.1.2 Password handling

One of the benefits of the bookmark manager is that the passwords are saved using Plasma’s services - where e.g. your Konqueror/KMail password are saved. If you have a wallet, Plasma will save the passwords there. By clicking the bookmarks, a dialog will open and ask for your username and password. Supply them and click Save password. The passwords and usernames will be saved securely by Plasma’s wallet (make sure it is enabled by your distro). The downside here is that if the system was reinstalled and you do not backup your passwords from the wallet as well as Krusader’s bookmark file, something will be lost.
9.1.3 Popular URLs

The submenu **Popular URLs** holds persistent the most popular visited URLs (local or remote). This submenu displays the top 15 popular URLs, sorted by ranking, so that the top URL is the most popular. This is easy for when you need to visit URLs often, but do not want to create Bookmarks, it serves as a temporary bookmark list for the most visited links. Quicksearch in Popular URLs is a fast way to browse/select the popular URLs:

- Open the Popular URLs or use Ctrl+Z
- Type a few letters to narrow the search
- Press Enter (you will go to the URL from list)

9.1.4 Permanent bookmarks

These are hardcoded bookmarks to the top bookmark menu; there is no need for them to be saved to the file. With the Context Menu you can enable/disable these permanent bookmarks. The following permanent bookmarks are available:

- **Trash bin** uses Plasma’s trash:/ protocol.
- **Local Network** uses Plasma’s remote:/ protocol.
- **Virtual Filesystem** Virtual file systems (VFS) virt:/ is not a virtual folder, but a container for URLs from different file systems. It is used for e.g. the Feed to Listbox feature of the search module and the synchronizer. The location toolbar will display e.g. virt:/Search results 1 or virt:/Synchronise results 1.
- **Jump back** or Ctrl+J brings you back to your starting position when you did create a new tab in the panel window. This feature is very handy if you go deep into a directory tree, then you can return with one action to the starting point. With Set jump back point here or Ctrl+Shift+J sets the current directory as a jump back point.

9.1.5 Manage bookmarks

To edit and organize your bookmarks, by clicking the BookMan II button and selecting the Manage Bookmarks, KeditBookmarks will be displayed. This is where you can edit/remove and rearrange the bookmarks. KeditBookmarks is a bookmark editor for Konqueror, Krusader and other applications, which use the XBEL standard for the bookmark format. The bookmarks are stored in ~/local/share/krusader/krbookmarks.xml.

**NOTE**

The default folder for the bookmarks file krusader/krbookmarks.xml is ~/local/share. You can determine the needed folder in your system using the qtpaths --paths GenericDataLocation command in terminal.

This local file exists only if you have edited Krusader bookmarks. It will be created after the first run of KeditBookmarks from Krusader.

The default system bookmarks are stored in the kfileplaces/bookmarks.xml file in the directory which can be determined using the qtpaths --paths GenericDataLocation command.

KeditBookmarks is easy to use, however, if you need more information, please read the Kedit-Bookmarks handbook.
9.1.6 Bookmarks as action buttons on the Toolbar

Bookmarks can be placed as buttons on the Main Toolbar or the Actions Toolbar. You can even make a key-binding for them:

- Create your Bookmarks.
- If you want, create keybindings for the bookmarks in the Configure Shortcuts window (Settings → Configure Shortcuts…).
- Add your bookmarks as action buttons on the Main Toolbar or the Actions Toolbar with the Configure Toolbars window (Settings → Configure Toolbars…).

9.2 Disk Usage

The Disk Usage is based on the code of Filelight. The Disk Usage shows you how your disk space is being used by a graphical representation of your file system. The following presentations are possible:

- Line view
- Detailed view
- Filelight view: as a set of concentric segmented-rings

Choose Tools → Disk Usage or Alt+Shift+S to start this feature in a separate window, or open it inside the Sidebar.

Disk Usage Keybindings, right click menu.
9.3  KruSearcher: find what you are looking for

Welcome to Krusader’s powerful search module - nicknamed KruSearcher. It is the most able tool (that we know of) for Linux®, since it allows so many different ways to quickly find the file you are looking for. The search function is also available on remote file systems. It is divided into two levels, the general and the advanced. Let’s take a look at the general page.

![General Search](image)

The page is divided into four parts: top (search for) part, bottom part - titled Containing text, left part - titled Search in and right part which is called Do not search in. Obviously, each part handles different aspects of the search. Let’s look at them closely.
TOP PART:

- **Search for:** here you enter the main search criteria. You can enter a file name, a wildcard (*.*o.*, *.c etc.) or both - separated by a space. If you type ‘text’ the results is the same as ‘*text*’. You can exclude files from the search with ‘!’ (e.g. ‘*.cpp *.h | *.moc.cpp’). You can use quotation marks for names that contain spaces. Filter “Program Files” searches out those files/directories the name of which is Program Files.

- **Case sensitive:** unchecking it will allow lower and upper case search (i.e.: *.c interprets as *.c AND *.C).

- **Of type:** this box lets you search for a file not only by its name, but also by its MIME type. For example, you can search for all the audio files whose name begins with B. Usually this option defaults to ‘all files’, but you can choose to search for archives, directories, images, text files, videos and audio files.

LEFT AND RIGHT PART:

- **Search in** and **Do not search in:** Using those two parts, you can specify a search exactly the way you want it. For example, you might want to search for a file in the whole file system (beginning with /), but do not want to search inside /mnt. All you need to do is write / in the **Search in** box, and write /mnt in the **Do not search in** box. If you want to enter more than one directory in one of the list boxes, just type the first name and press Enter. The directory name will be copied to the bigger list box and you will be able to enter another name.

    **NOTE**
    The input line has an auto-completion feature, corresponding to Plasma global settings. If you wish, you can click on the folder icon, and browse to the directory you wish to add.

    **NOTE**
    It is possible to define files and directories which will be filtered out from the search results using the **Exclude Folder Names** input field at the bottom of the **Do not search in** box.
    Items in the filtering list should be space-separated.
    Spaces in the filtering list items can be escaped or quoted. Example: `.git "target build" build\ krusader`

BOTTOM PART:

- **Text:** entering text here makes Krusader search for it inside the files (grep). This way you can search for all header files (*.h) which include the word ‘testing 123’.

- **RegExp switch:** toggle the regular expressions mode. A drop-down list that is shown after clicking down arrow on the right allows you to enter special symbols of regular expressions.

- **Encoding:** allows you to choose the text encoding.

- **Match whole word only:** allows you to specify that a complete match (letters and length) must be found.

- **Case sensitive:** refers to your text being searched for in upper and lower case or the exact phrase you entered.

- **Search in sub folders:** perform a recursive search and dive into every directory on the way.

- **Search in archives:** Krusader will search for your files inside every supported archive. This, however, takes longer to perform.
The Krusader Handbook

**NOTE**
If you check this checkbox, you will notice you cannot **grep** inside files anymore. This is done, since looking inside archived files forces Krusader to extract them, which results in an extremely time-consuming search.

- **Follow links**: if checked, Krusader will follow soft-links during the search.
- **Profiles**: if you have to regularly perform the same search operation, you can save the search settings e.g. include files, exclude files, etc.... Press the 'profile' button, and you can add/load/save/remove search profiles.
- **Query to clipboard**: if checked, Krusader will place search text to clipboard when a found file is opened.

The above screen shot shows a search for all the files which end with `.c`, `.cpp` or `.h` and include the string ‘testing 123’. Krusader will search in `/root`, `/opt`, `/bin` and `/usr`, but not in `/usr/lib` and `/usr/share`.

Clicking the **Search** button starts the search and displays the results page. During the search, you may press the **Stop** button to stop the search. The **Close** button is not operational during a search, so you must first stop the search and then **Close** the window. When a result is found, double-clicking on it will take Krusader's active panel point to the found files - but will not close the search window, so you will be able to click on a different result.

Sometimes, you need to narrow your search even more. Krusearcher allows a much finer search, and for that, let’s look at the **Advanced Page**...

![Advanced Search](https://example.com/advanced_search.png)

**Figure 9.4: Advanced Search**

This screen shot shows a search for files whose size is between 10KiB and 150KiB, which were modified between October 10th and November 1st, which belong to any user in the ‘nobody’ group, and are readable and writable by anyone in the ‘nobody’ group, but only readable to the rest of the world.
The advanced page is divided into three parts: size, date and ownership.

Size
Allows you to choose the size range of the file you are looking for. By checking the check boxes, you can search for a file which is bigger than XXX bytes (or KB, MB), smaller than XXX bytes or, by checking both search for a file which size is bigger than XXX but smaller than YYY.

Date
This part offers three different ways of defining a date criteria:

• **Modified between:** allows you to enter two dates. Krusader will search for files with a modification date between the first date and the second one, inclusive.

  **NOTE**
  You can click on the date icon (near the input boxes) to open a standard date window - which allows you to easily browse through the calendar and search for the desired date. Clicking on a date will close the window and the date will appear in the input box.

• **Not modified after:** choosing this option makes Krusader search for files that were NOT modified after a given date, which is the same as searching for files older than that date.

• **Modified in the last/not modified in the last:** in these input boxes, you do not enter a date but a number. This number represents days/weeks/months (as chosen in the near drop box). Entering the number 5 in the upper input box, makes Krusader search for files that were modified in the last 5 days. Entering the number 2 in the lower input box makes Krusader search for files that did NOT change in the last 2 days. The combination of both results in a search for files that were changed in the last 5 days, but NOT in the last 2 days.

Ownership

• **Belongs to user/group:** by checking each of the corresponding check boxes, you can search for files which belong to a certain user and/or group. The drop box lists all the user names and group names in the system, just choose one and go ahead.

• **Permissions:** divided into owner, group and all - it allows you to choose certain permissions for the file. You can choose to specify permissions for the owner, group, all or any combination. The question mark (?) is a wildcard - which means that any permission is valid.

  **NOTE**
  To clarify, the screen shot above (the ownership part) describes a search for files that belong to any user in group ‘users’, are readable, writable but not executable to any user in the group, are readable but not writable or executable to the rest of the world and have unknown permissions to its owner.

Results
Clicking on the **Search** button to start the search and open the Results window. Here you can see the progress and the results of the search action. If you want you can stop the current search action with the **Stop** button. In the result list select the file and use **F3/F4** to view/edit or use the right-click menu. When you click on a found item, the directory of the active panel will change if the selected item is not in the current panel directory. The results window supports dragging items to other windows and copy to clipboard (**Ctrl+C**). When you close the Krusearcher window, the selected item is selected in the active panel.

Feed to listbox
When you click the **Feed to listbox** button after the results are displayed, then Krusader ask for a Query Name, this name will be used in the Results-Tab in the List Panel that holds the search results. You can do whatever you want on the files in the new tab. The location toolbar will display e.g. **virt:/Search results 1**.
WARNING
The files in the Results-Tab are actually the original files. If you delete a file - it is removed!

9.4 KrViewer: Krusader’s internal viewer-editor

Pressing Enter on a selected file opens the file with the associated application. The editor-viewer is tabbed, configure it on the Konfigurator General page.

9.4.1 Viewer

To view a file as fast as possible according to its type, just put it under the cursor and press F3. Krusader’s internal viewer is actually a part of Konqueror, which can basically view every file type viewable by Konqueror (e.g. display pictures, play music, show the content of an archive). This is called the ‘Generic viewer’, for which you need to configure the MIME types.

The viewer works as follows:

- It tries to view the file with the ‘Generic viewer’.
- When the file type (MIME type) cannot be determined or when a file (e.g. a binary) does not have an associated action, it disables the ‘generic viewer’. The file is treated as a text file, which is the ‘Text viewer’.
- The user can change in the KrViewer menu between: ‘Generic viewer’ (if available), ‘Text viewer’ and ‘Hex viewer’.

You can configure the default viewer mode on the Konfigurator General page.

Shift+F3 views a URL on demand, e.g.:

- man:/ views the manpages.
- man:/ krusader views manpage of Krusader.
- info:/ views the infopages.
- https:// krusader.org views a webpage.
- sftp:// sftp.foo/ views a secure FTP server.
- file:/ home/frank views the home directory of Frank.
- tar:// home/frank/archive.tar.gz/ opens content browser window for the tar.gz archive.

KrViewer can have the following menus: File, Edit, View, Settings and Krviewer, depending on which file type is viewed. They will be discussed in the Editor section. The internal viewer can follow links on HTML pages. With Ctrl+Shift+E the viewer can start Krusader’s internal editor (which is basically the same application).

NOTE
The embedded viewer is not written by us, it is supplied via KF5 and KIO Slaves. We cannot and do not want to change it, using these libraries reduces the amount of written code. So we do not have to reinvent the wheel ;-)
9.4.2 Editor

Krusader’s internal editor has almost everything that you can expect of an editor. Editing is similar to viewing but with the F4 key. The default editor is Krusader’s internal editor. You can change the default editor in the Konfigurator General page, if you prefer to use an external editor.

**Tip**
When you use Krusader’s internal editor for the first time, it is recommended to look at each section of the Settings menu, and configure it the way you want it.

9.4.3 Menu overview

There are different menus and menu items in simple and advanced mode. The advanced mode is enabled by checking the option Enable power user mode (KDE 3 mode) on the Appearance page in Krusader’s settings.

9.4.3.1 The File Menu

**File → Save (Ctrl+S)**
This saves the current document. If there has already been a save of the document then this will overwrite the previously saved file without asking for the user’s consent. If it is the first save of a new document the save as dialog (described below) will be invoked.

**File → Save As...**
This allows a document to be saved with a new file name.

**File → Reload (F5)**
Reloads the active file from disk. This command is useful if another program or process has changed the file while you have it open in Krusader.

**File → Print... (Ctrl+P)**
Opens a simple print dialog allowing the user to specify what, where, and how to print.

**File → Export as HTML**
Export your file in HTML format so your document can be viewed as a web page. This item is only displayed when the plugin Exporter is loaded.

9.4.3.2 The Edit Menu

**Edit → Undo (Ctrl+Z)**
This is used to eliminate or reverse the most recent user action or operation.

**Edit → Redo (Ctrl+Shift+Z)**
This will reverse the most recent change (if any) made using Undo

**Edit → Cut (Ctrl+X)**
This command deletes the current selection and places it on the clipboard. The clipboard is a feature that works invisibly to provide a way to transfer data between applications.
Edit → Copy (Ctrl+C)
This copies the currently selected text to the clipboard so that it may be pasted elsewhere. The clipboard is a feature that works invisibly to provide a way to transfer data between applications.

Edit → Paste (Ctrl+V)
This will insert the contents of the clipboard at the cursor position. The clipboard is a feature that works invisibly to provide a way to transfer data between applications.

Edit → Copy as HTML
This copies the currently selected text to the clipboard as HTML. This item is only displayed when the plugin Exporter is loaded.

Edit → Select All (Ctrl+A)
This will select the entire document. This could be very useful for copying the entire file to another application.

Edit → Deselect (Ctrl+Shift+A)
Deselects the selected text in the editor if any.

Edit → Block Selection Mode (Ctrl+Shift+B)
Toggles Selection Mode. When the Selection Mode is BLOCK, you can make vertical selections, e.g. select column 5 to 10 in lines 9 to 15. The status bar shows the current state of the Selection Mode, either BLOCK or LINE.

Edit → VI input Mode (Meta+Ctrl+V)
Switch to a vi-like, modal editing mode. This mode supports the most used commands and motions from vim’s normal and visual mode and has an optional vi mode statusbar. This status bar shows commands while they are being entered, output from commands and the current mode. The behavior of this mode can be configured in the Vi Input Mode section of the Editing page in Krusader’s settings dialog.

Edit → Overwrite Mode (Ins)
Toggles the Insert/Overwrite modes. When the mode is INS, you insert characters where the cursor is. When the mode is OVR, writing characters will replace the current characters if your cursor is positioned before any character. The status bar shows the current state of the Overwrite Mode, either INS or OVR.

Edit → Find... (Ctrl+F)
This opens the incremental search bar at the bottom of the editor window. On the left side of the bar is a button with an icon to close the bar, followed by a small text box for entering the search pattern.

When you start entering characters of your search pattern, the search starts immediately. If there is a match in the text this is highlighted and the background color of the entry field changes to light green. If the search pattern does not match any string in the text, this is indicated by a light red background color of the entry field and Not found is displayed at the right side of the bar.

Use the Next or Previous button to jump to the next or previous match in the document. You can choose whether the search should be case sensitive. Selecting Match Case will limit finds to entries that match the case (upper or lower) of each of the characters in the search pattern.

Click on the button with a green arrow icon at the right side of the incremental search bar to switch to the power search and replace bar.

Edit → Find Next (F3)
This repeats the last find operation, if any, without calling the incremental search bar.
The Krusader Handbook

**Edit → Find Previous (Shift+F3)**
This repeats the last find operation, if any, without calling the incremental search bar, and searching backwards instead of forwards through the document.

**Edit → Replace... (Ctrl+R)**
This command opens the power search and replace bar. On the upper left side of the bar is a button with an icon to close the bar, followed by a small text box for entering the search pattern.

You can control the search mode by selecting **Plain text**, **Whole words**, **Escape sequences** or **Regular expression** from the drop down box.

If **Escape sequences** or **Regular expression** are selected, the **Add...** menu item at the bottom of the context menu of the text boxes will be enabled and allows you to add escape sequences or regular expression items to the search or replace pattern from predefined lists.

Use the **Next** or **Previous** button to jump to the next or previous match in the document.

Enter the text to replace with in the text box labeled **Replace** and click the **Replace** button to replace only the highlighted text or the **Replace All** button to replace the search text in the whole document.

You can modify the search and replace behavior by selecting different options at the bottom of the bar. Selecting **Match Case** will limit finds to entries that match the case (upper or lower) of each of the characters in the search pattern. **Selection Only** will search and replace within the current selection only. The **Find All** button highlights all matches in the document and shows the number of found matches in a small popup.

Click on the button with a green arrow icon at the right side of the power search and replace bar to switch to the incremental search bar.

**Edit → Find Selected (Ctrl+H)**
Finds next occurrence of selected text.

**Edit → Find Selected Backwards (Ctrl+Shift+H)**
Finds previous occurrence of selected text.

**Edit → Go to Line... (Ctrl+G)**
This opens the goto line bar at the bottom of the window which is used to have the cursor jump to a particular line (specified by number) in the document. The line number may be entered directly into the text box or graphically by clicking on the up or down arrow spin controls at the side of the text box. The little up arrow will increase the line number and the down arrow decrease it. Close the bar with a click on the button with an icon on the left side of the bar.

### 9.4.3.3 The View Menu

The **View** menu allows you to manage settings specific to the active editor, and to manage frames.

**View → New Window**
Create another window containing the current document. All changes to the document in one window are reflected in the other window and vice versa.

**View → Switch to Command Line (F7)**
Displays the Katepart command line at the bottom of the window. In the command line, type **help** to get help and **help list** to get a list of commands.

**View → Show the Javascript Console**
This opens a tool view that allows you to run Javascript code interactively. For more information, see Extending Kate with Scripts
The Krusader Handbook

View → Schema
Select a font schema.

View → Dynamic Word Wrap (F10)
The text lines will be wrapped at the view border on the screen.

View → Dynamic Word Wrap Indicators
Choose when and how the dynamic word wrap indicators should be displayed. This is only available if the Dynamic Word Wrap option is checked.

View → Show Static Word Wrap Marker
If this option is checked, a vertical line will be drawn at the word wrap column as defined in the Settings → Configure Editor... in the Editing tab. Please note that the word wrap marker is only drawn if you use a fixed pitch font.

View → Show Icon Border (F6)
This is a toggle item. Setting it on checked will make the Icon Border visible in the left side of the active editor, and vice versa. The Icon Border indicates the positions of the marked lines in the editor.

View → Show Line Numbers (F11)
This is a toggle item. Setting it on checked will make a pane displaying the line numbers of the document visible in the left border of the active editor, and vice versa.

View → Show Scrollbar Marks
If this option is checked, the view will show marks on the vertical scrollbar. The marks are equivalent to the marks on the Icon Border.

View → Show Folding Markers (F9)
If this option is checked, the marks for code folding will be shown.

View → Code Folding
These options pertain to code folding:

Show Folding Markers (F9)
Toggles the display of the folding marker pane in the left side of the view.

Fold Current Node
Collapse the region that contains the cursor.

Unfold Current Node
Expand the region that contains the cursor.

Fold Toplevel Nodes (Ctrl+Shift+-)
Collapse all toplevel regions in the document. Click on the right pointing triangle to expand all toplevel regions.

Enlarge Font
This increases the display font size.

Shrink Font
This decreases the display font size.
9.4.3.4 The Bookmarks Menu

**Bookmarks → Set Bookmark (Ctrl+B)**
Sets or removes a bookmark in the current line of the active document. (If it is there, it is removed, otherwise one is set).

**Bookmarks → Clear All Bookmarks**
This command will remove all the markers from the document as well as the list of markers which is appended at the bottom of this menu item.

**Bookmarks → Previous (Alt+PgUp)**
This will move the cursor to beginning of the first above line with a bookmark. The menuitem text will include the line number and the first piece of text on the line. This item is only available when there is a bookmark in a line above the cursor.

**Bookmarks → Next (Alt+PgDown)**
This will move the cursor to beginning of the next line with a bookmark. The menuitem text will include the line number and the first piece of text on the line. This item is only available when there is a bookmark in a line below the cursor.

At the bottom of this menu, a list of bookmarks appears if any bookmarks are available for this window.

9.4.3.5 The Tools Menu

**Tools → Read Only Mode**
Set the current document to Read Only mode. This prevents any text addition and any changes in the document formatting.

**Tools → Mode**
Choose the filetype scheme you prefer for the active document. This overwrites the global filetype mode set in **Settings → Configure Editor...** in the Filetypes tab for your current document only.

**Tools → Highlighting**
Choose the Highlighting scheme you prefer for the active document. This overwrites the global highlighting mode set in **Settings → Configure Editor...** for your current document only.

**Tools → Indentation**
Choose the style of indentation you want for your active document. This overwrites the global indentation mode set in **Settings → Configure Editor...** for your current document only.

**Tools → Encoding**
You can overwrite the default encoding set in **Settings → Configure Editor...** in the **Open/Save** page to set a different encoding for your current document. The encoding you set here will be only valid for your current document.

**Tools → End of Line**
Choose your preferred end of line mode for your active document. This overwrites the global end of line mode set in **Settings → Configure Editor...** for your current document only.
Tools → Add Byte Mark Order (BOM)
Checking this action you can explicitly add a byte order mark for unicode encoded documents. The byte order mark (BOM) is a Unicode character used to signal the endianness (byte order) of a text file or stream, for more information see Byte Order Mark.

Tools → Invoke Code Completion (Ctrl+Space)
Manually invoke command completion, usually by using a shortcut bound to this action.

Tools → Word Completion
Reuse Word Below (Ctrl+9) and Reuse Word Above (Ctrl+8) complete the currently typed text by searching for similar words backward or forward from the current cursor position. Shell Completion pops up a completion box with matching entries.

Tools → Automatic Spell Checking (Ctrl+Shift+O)
When Automatic Spell Checking is enabled, wrong text is underlined in the document on-the-fly.

Tools → Spelling...
This initiates the spellchecking program - a program designed to help the user catch and correct any spelling errors. Clicking on this entry will start the checker and bring up the speller dialog box through which the user can control the process. There are four settings lined up vertically in the center of the dialog with their corresponding labels just to the left. Starting at the top they are:

Unknown word:
Here, the spellchecker indicates the word currently under consideration. This happens when the checker encounters a word not in its dictionary - a file containing a list of correctly spelled words against which it compares each word in the editor.

Replace with:
If the checker has any similar words in its dictionary the first one will be listed here. The user can accept the suggestion, type in his or her own correction, or choose a different suggestion from the next box.

Language:
If you have installed multiple dictionaries, here you can select which dictionary/language should be used.

On the right side of the dialog box are 6 buttons that allow the user to control the spellcheck process. They are:

Add to Dictionary
Pressing this button adds the Unknown word to the checker’s dictionary. This means that in the future the checker will always consider this word to be correctly spelled.

Suggest
The checker may list here a number of possible replacements for the word under consideration. Clicking on any one of the suggestions will cause that word to be entered in the Replace with box, above.

Replace
This button has the checker replace the word under consideration in the document with the word in the Replace with box.

Replace All
This button causes the checker to replace not only the current Unknown word: but to automatically make the same substitution for any other occurrences of this Unknown word in the document.

Ignore
Activating this button will have the checker move on without making any changes.
The Krusader Handbook

Ignore All
This button tells the checker to do nothing with the current Unknown word: and to pass over any other instances of the same word.

NOTE
This only applies to the current spellcheck run. If the checker is run again later it will stop on this same word.

Three more buttons are located horizontally along the bottom of the spellcheck dialog. They are:

Help
This invokes the KDE help system with the help page for this dialog.

Finished
This button ends the spellcheck process, and returns to the document.

Cancel
This button cancels the spellcheck process, all modifications are reverted, and you will return to your document.

Tools → Spelling (from cursor)...
This initiates the spellchecking program but it starts where your cursor is instead of at the beginning of the document.

Tools → Spellcheck Selection...
Spellchecks the current selection.

Tools → Change Dictionary
Displays a drop down box with all available dictionaries for spellchecking at the bottom of the editor window. This allows easy switching of the spellcheck dictionary e.g. for automatic spellcheck of text in different languages.

Tools → Clean Indentation
This cleans the indentation for the current selection or for the line the cursor is currently in. Cleaning the indentation ensures that all your selected text follows the indentation mode you choose.

Tools → Align
Causes a realign of the current line or selected lines using the indentation mode and indentation settings in the document.

Tools → Comment (Ctrl+D)
This adds one space to the beginning of the line where the text cursor is located or to the beginning of any selected lines.

Tools → Uncomment (Ctrl+Shift+D)
This removes one space (if any exist) from the beginning of the line where the text cursor is located or from the beginning of any selected lines.

Tools → Uppercase (Ctrl+U)
Put the selected text or the letter after the cursor in uppercase.

Tools → Lowercase (Ctrl+Shift+U)
Put the selected text or the letter after the cursor in lowercase.

Tools → Capitalize (Ctrl+Alt+U)
Capitalize the selected text or the current word.
The Krusader Handbook

Tools → Join Lines (Ctrl+J)

Joins the selected lines, or the current line and the line below with one white space character as a separator. Leading/trailing white space on joined lines is removed in the affected ends.

Tools → Apply Word Wrap

Apply static word wrapping on all the document. That means that a new line of text will automatically start when the current line exceeds the length specified by the Wrap words at option in the Editing tab in Settings → Configure Editor...

If the plugin Insert File is enabled, you will find here an additional menu item Insert File....

9.4.3.6 The Settings Menu

Settings → Configure Editor...

This menu item opens a dialog whereby several different settings may be adjusted.

9.4.3.7 The KrViewer Menu

KrViewer → Generic viewer (Ctrl+Shift+G)

Krusader’s internal viewer is actually part of Konqueror, which can basically view every file type viewable by Konqueror (e.g. display pictures, play music, show the content of an archive).

KrViewer → Text viewer (Ctrl+Shift+T)

View the file in text mode.

KrViewer → Hex viewer (Ctrl+Shift+H)

View the file in hex mode.

KrViewer → Lister (Ctrl+Shift+L)

Fast text/hex viewer for huge file sizes, done by Krusader lister.

KrViewer → Text editor (Ctrl+Shift+E)

Edit the file in text mode.

KrViewer → Detach Tab (Ctrl+Shift+D)

Detach browsing Tab and open in a new window.

KrViewer → Quit (Ctrl+Q)

Closes Krusader’s viewer/editor window.

9.4.4 The Editor Component Configuration

This group contains all pages related to the editor component of Krusader. Most of the settings here are defaults, they can be overridden by defining a filetype, by Document Variables or by changing them per document during an editing session.
9.4.4.1 Appearance

9.4.4.1.1 General

Dynamic Word Wrap
If this option is checked, the text lines will be wrapped at the view border on the screen.

**Dynamic word wrap indicators (if applicable)**
Choose when the Dynamic word wrap indicators should be displayed, either *Off*, *Follow Line Numbers* or *Always on*.

**Align dynamically wrapped lines to indentation depth:**
Enables the start of dynamically wrapped lines to be aligned vertically to the indentation level of the first line. This can help to make code and markup more readable. Additionally, this allows you to set a maximum width of the screen, as a percentage, after which dynamically wrapped lines will no longer be vertically aligned. For example, at 50%, lines whose indentation levels are deeper than 50% of the width of the screen will not have vertical alignment applied to subsequent wrapped lines.

Whitespace Highlighting

**Highlight tabulators**
The editor will display a » symbol to indicate the presence of a tab in the text.

**Highlight trailing spaces**
The editor will display dots to indicate the presence of extra whitespace at the end of lines.

Advanced

**Show indentation lines**
If this is checked, the editor will display vertical lines to help identifying indent lines.

**Highlight range between selected brackets**
If this is enabled, the range between the selected matching brackets will be highlighted.

9.4.4.1.2 Borders

Borders

**Show folding markers (if available)**
If this option is checked, the current view will display marks for code folding, if code folding is available.

**Show icon border**
If this is checked, you will see an icon border on the left hand side. The icon border shows bookmark signs for instance.

**Show line numbers**
If this is checked, you will see line numbers on the left hand side.

**Show scrollbar marks**
If this option is checked the current view will show marks on the vertical scrollbar. These marks will for instance show bookmarks.

Sort Bookmarks Menu

**By creation**
Each new bookmark will be added to the bottom, independently from where it is placed in the document.

**By position**
The bookmarks will be ordered by the line numbers they are placed at.
9.4.4.2 Fonts & Colors

This section of the dialog lets you configure all fonts and colors in any color scheme you have, as well creating new schemes or deleting existing ones. Each scheme has settings for colors, fonts and normal and highlight text styles.

Krusader will preselect the currently active scheme for you, if you want to work on a different scheme start by selecting that from the **Schema** combobox. With the **New** and **Delete** button you can create a new scheme or delete existing ones.

At the bottom of the page you can select the **Default schema for Krusader**.

9.4.4.2.1 Colors

**Text Area Background**

- **Normal text**
  This is the default background for the editor area, it will be the dominant color on the editor area.

- **Selected text**
  This is the background for selected text. The default is the global selection color, as set in your Plasma color preferences.

- **Current line**
  Set the color for the current line. Setting this a bit different from the Normal text background helps to keep focus on the current line.

- **Bookmark**
  This combobox lets you set overlay colors for various mark types. The color is mixed into the background color of a marked line, so that a line with more marks or a marked line that is current has a background that is a mix of more colors. The mark colors are also used if you enable display of scrollbar marks.

**Additional Elements**

- **Left border background**
  This color is used for the marks, line numbers and folding marker borders in the left side of the editor view when they are displayed.

- **Line numbers**
  This color is used to draw the line numbers on the left side of the view when displayed.

- **Bracket highlight**
  This color is used to draw the background of matching brackets.

- **Word wrap markers**
  This color is used to draw a pattern to the left of dynamically wrapped lines when those are aligned vertically, as well as for the static word wrap marker.

- **Tab and space markers**
  This color is used to draw white space indicators when enabled.

- **Spelling mistake line**
  sets the color of the line that is used to indicate spelling mistakes.

9.4.4.2.2 Fonts

Here you can choose the font for the schema. You can choose from any font available on your system, and set a default size. A sample text displays at the bottom of the dialog, so you can see the effect of your choices.
9.4.4.2.3 Normal Text Styles

The normal text styles are inherited by the highlight text styles, allowing the editor to present text in a very consistent way, for example comment text is using the same style in almost all of the text formats that Krusader can highlight.

The name in the list of styles is using the style configured for the item, providing you with an immediate preview when configuring a style.

Each style lets you select common attributes as well as foreground and background colors. To unset a background color, rightclick to use the context menu.

9.4.4.2.4 Highlighting Text Styles

Here you can edit the text styles used by a specific highlight definition. The editor preselects the highlight used by your current document. To work on a different highlight, select one in the Highlight combobox above the style list.

The name in the list of styles is using the style configured for the item, providing you with an immediate preview when configuring a style.

Each style lets you select common attributes as well as foreground and background colors. To unset a background color, rightclick to use the context menu. In addition you can see if a style is equal to the default style used for the item, and set it to that if not.

You will notice that many highlights contain other highlights represented by groups in the style list. For example most highlights import the Alert highlight, and many source code formats imports the Doxygen highlight. Editing colors in those groups only affects the styles when used in the edited highlight format.

9.4.4.3 Editing

9.4.4.3.1 General

Static Word Wrap

Word wrap is a feature that causes the editor to automatically start a new line of text and move (wrap) the cursor to the beginning of that new line. Krusader will automatically start a new line of text when the current line reaches the length specified by the Wrap Words At option.

Enable static word wrap

Turns static word wrap on or off.

Show static word wrap markers (if applicable)

If this option is checked, a vertical line will be drawn at the word wrap column as defined in the Settings → Configure Editor... in the Editing tab. Please note that the word wrap marker is only drawn if you use a fixed pitch font.

Wrap words at:

If the Enable static word wrap option is selected this entry determines the length (in characters) at which the editor will automatically start a new line.

Misc

Remove trailing spaces while editing

Krusader will automatically eliminate extra spaces at the ends of lines of text.
Auto brackets
When the user types a left bracket ([, (, or {) Krusader automatically enters the right bracket (], ), or ]}) to the right of the cursor.

Copy/Cut the current line if no selection
If this option is enabled and the text selection is empty, copy and cut action are performed for the line of text at the actual cursor position.

Allow scrolling past the end of the document
This option lets you scroll past the end of the document. This can be used to vertically centre the bottom of the document, or put it on top of the current view.

9.4.4.3.2 Cursor & Selection

Text Cursor Movement

Smart home and smart end
When selected, pressing the home key will cause the cursor to skip white space and go to the start of a line’s text.

Wrap cursor
When on, moving the insertion cursor using the Left and Right keys will go on to previous/next line at beginning/end of the line, similar to most editors.
When off, the insertion cursor cannot be moved left of the line start, but it can be moved off the line end, which can be very handy for programmers. When this option is chosen, moving the cursor with the arrow keys off the end of a line (to the right) causes it to jump down to the beginning of the next line. Likewise when the cursor is moved past the beginning of a line (to the left) it jumps up to the end of the preceding line. When this option is not selected, moving the cursor right past the end of a line merely causes it to continue horizontally in the same line and trying to move it left past the beginning does nothing.

PageUp/PageDown moves cursor
This option changes the behavior of the cursor when the user presses the Page Up or Page Down key. If unselected the text cursor will maintain its relative position within the visible text in Krusader as new text becomes visible as a result of the operation. So if the cursor is in the middle of the visible text when the operation occurs it will remain there (except when one reaches the beginning or end.) With this option selected, the first key press will cause the cursor to move to either the top or bottom of the visible text as a new page of text is displayed.

Autocenter cursor (lines):
Sets the number of lines to maintain visible above and below the cursor when possible.

Text Selection Mode

Normal
Selections will be overwritten by typed text and will be lost on cursor movement.

Persistent
Selections will stay even after cursor movement and typing.

9.4.4.3.3 Indentation

Default Indentation mode:
Select the automatic indentation mode you want to use as default. It is strongly recommended to use None or Normal here, and use filetype configurations to set other indentation modes for text formats like C/C++ code or XML.
Indent using

Tabulators
When this is enabled the editor will insert tabulator characters when you press the Tab key or use automatic indentation.

Spaces
When this is enabled the editor will insert a calculated number of spaces according to the position in the text and the tab-width setting when you press the Tab key or use automatic indentation.

Tabulators and Spaces
When this is enabled, the editor will insert spaces as describe above when indenting or pressing Tab at the beginning of a line, but insert tabulators when the Tab key is pressed in the middle or end of a line.

Tab width:
This configures the number of spaces that are displayed in place of a tabulator character.

Indentation width:
The indentation width is the number of spaces which is used to indent a line. If configured to indent using tabulators, a tabulator character is inserted if the indentation is divisible by the tab width.

Indentation Properties

Keep Extra Spaces
If this option is disabled, changing the indentation level aligns a line to a multiple of the width specified in Indentation width.

Adjust indentation of code pasted from the clipboard
If this option is selected, pasted code from the clipboard is indented. Triggering the Undo action removes the indentation.

Indentation Actions

Backspace key in leading blank space unindents
If this option is selected, the Backspace key decreases the indentation level if the cursor is located in the leading blank space of a line.

Tab key action (if no selection exists)
If you want Tab to align the current line in the current code block like in emacs, make Tab a shortcut to the action Align.

Always advance to the next tab position
If this option is selected, the Tab key always inserts white space so that the next tab position is reached. If the option Insert spaces instead of tabulators on the General tab in the Editing page is enabled, spaces are inserted; otherwise, a single tabulator is inserted.

Always increase indentation level
If this option is selected, the Tab key always indents the current line by the number of character positions specified in Indentation width.

Increase indentation level if in leading blank space
If this option is selected, the Tab key either indents the current line or advances to the next tab position. If the insertion point is at or before the first non-space character in the line, or if there is a selection, the current line is indented by the number of character positions specified in Indentation width. If the insertion point is located after the first non-space character in the line and there is no selection, white space is inserted so that the next tab position is reached: if the option Insert spaces instead of tabulators on the General tab in the Editing page is enabled, spaces are inserted; otherwise, a single tabulator is inserted.
9.4.4.3.4 Auto Completion

General

Enable auto completion
If enabled, a word completion box automatically pops up during typing showing a
list of text entries to complete the current text under the cursor.

Minimal word length to complete
While typing text, the word completion searches for words in the document starting with
the already typed text. This option configures the minimal amount of characters that are
needed to make the word completion active and pop up a completion box.

9.4.4.3.5 Vi Input Mode

General

Use VI input mode
When selected, the vi input mode will be enabled when opening a new view. You can
still toggle the vi input mode on/off for a particular view in the Edit menu.

Let Vi commands override Kate shortcuts
When selected, Vi commands will override Krusader’s built-in commands. For ex-
example: Ctrl+R will redo, and override the standard action (showing the search and
replace dialog).

Hide the Vi mode status bar
By default, an extra status bar will be used when the Vi input mode is enabled. This
status bar shows commands while they are being typed and messages/errors pro-
duced by Vi commands.
Checking this option will hide this extra status line.

Key Mapping
Key mapping is used to change the meaning of typed keys. This allows you to move com-
mands to other keys or make special keypresses for doing a series of commands.
Example:
F2 -> I-- Esc
This will prepend I-- to a line when pressing F2.

9.4.4.3.6 Spellcheck

These configuration options are described in the documentation for the System Settings module
Spell Checker.

9.4.4.4 Open/Save

9.4.4.4.1 General

File Format
Encoding:
This defines the standard encoding to use to open/save files, if not changed in the open/save dialog or by using a command line option.

Encoding Detection
Select an item from the drop down box, either to disable autodetection or use Universal to enable autodetection for all encodings. But as this may probably only detect utf-8=utf-16, selecting a region will use custom heuristics for better results. If neither the encoding chosen as standard above, nor the encoding specified in the open/save dialog, nor the encoding specified on command line match the content of the file, this detection will be run.

Fallback Encoding
This defines the fallback encoding to try for opening files if neither the encoding chosen as standard above, nor the encoding specified in the open/save dialog, nor the encoding specified on command line match the content of the file. Before this is used, an attempt will be made to determine the encoding to use by looking for a byte order marker at start of file: if one is found, the right unicode encoding will be chosen; otherwise encoding detection will run, if both fail fallback encoding will be tried.

End of line:
Choose your preferred end of line mode for your active document. You have the choice between UNIX®, DOS/Windows® or Macintosh.

Automatic end of line detection
Check this if you want the editor to autodetect the end of line type. The first found end of line type will be used for the whole file.

Enable byte order marker
The byte order mark is a special sequence at the beginning of unicode encoded documents. It helps editors to open text documents with the correct unicode encoding. For more information see Byte Order Mark.

Automatic Cleanups on Load/Save

Remove trailing spaces
The editor will automatically eliminate extra spaces at the ends of lines of text while loading/saving the file.

9.4.4.2 Advanced

Folder Config File

Search depth for config file:
The editor will search the given number of folder levels upwards for Krusader config file and load the settings line from it. Further information about these hidden folder config files you find in the document variables section.

Backup on Save
Backing up on save will cause Krusader to copy the disk file to <prefix><filename><suffix> before saving changes. The suffix defaults to _ and prefix is empty by default.

Local files
Check this if you want backups of local files when saving.

Remote files
Check this if you want backups of remote files when saving.

Prefix
Enter the prefix to prepend to the backup file names.
Suffix
Enter the suffix to add to the backup file names.

Disable swap file syncing
Krusader is able to recover (most of) what was written after last save in case of a crash or power failure. A swap file (.swp.<filename>) is created after the first editing action on a document. If the user doesn’t save the changes and Krusader crashes, the swap file remains on the disk. When opening a file, Krusader checks if there is a swap file for the document and if it is, it asks the user whether he wants to recover the lost data or not. The user has the possibility to view the differences between the original file and the recovered one, too. The swap file is deleted after every save and on normal exit.
Krusader syncs the swap files on the disk every 15 seconds, but only if they have changed since the last sync. The user can disable the swap files syncing if he wants, by checking the Disable swap file syncing box, but this can lead to more data loss.

9.4.4.3 Modes & Filetypes
This page allows you to override the default configuration for documents of specified MIME types. When the editor loads a document, it will try if it matches the file masks or MIME types for one of the defined filetypes, and if so apply the variables defined. If more filetypes match, the one with the highest priority will be used.

Filetype:
The filetype with the highest priority is the one displayed in the first drop down box. If more filetypes were found, they are also listed.

New
This is used to create a new filetype. After you click on this button, the fields below get empty and you can fill the properties you want for the new filetype.

Delete
To remove an existing filetype, select it from the drop down box and press the Delete button.

Properties of current filetype
The filetype with the highest priority is the one displayed in the first drop down box. If more filetypes were found, they are also listed.

Name:
The name of the filetype will be the text of the corresponding menu item. This name is displayed in the Tools → Filetypes

Section:
The section name is used to organize the file types in menus. This is also used in the Tools → Filetypes menu.

Variables:
This string allows you to configure Krusader’s settings for the files selected by this MIME type using Krusader variables. You can set almost any configuration option, such as highlight, indent-mode, etc.
Press Edit to see a list of all available variables and their descriptions. Select the checkbox on the left to enable a particular variable and then set the value of the variable on the right. Some variables provide a drop-down box to select possible values from while others require you to enter a valid value manually.
For complete information on these variables, see Configuring with Document Variables.
The Krusader Handbook

Highlighting:
If you create a new file type, this drop down box allows you to select a filetype for highlighting.

Indentation Mode:
The drop down box specifies the indentation mode for new documents.

File extensions:
The wildcards mask allows you to select files by filename. A typical mask uses an asterisk and the file extension, for example *.txt; *.text. The string is a semicolon-separated list of masks.

MIME types:
Displays a wizard that helps you easily select MIME types.

Priority:
Sets a priority for this file type. If more than one file type selects the same file, the one with the highest priority will be used.

Download Highlighting Files...
Click this button to download new or updated syntax highlight descriptions from the Krusader website.

9.4.4.5 Extensions

The Plugins tab lists all available plugins and you can check those you want to use. Click on the Information button to open the About dialog of this plugin.

Once a configurable plugin is checked, the Configure button is enabled and you can click it in order to configure the highlighted plugin.

EDITOR COMPONENT PLUGINS

AutoBrace
The autobrace plugin supersedes the Krusader internal ‘Auto Brackets’ feature. It automatically inserts a closing brace } at the beginning of the next line after ending a line with an opening one { and pressing the Enter key.

Data Tools
Enables data tools like thesaurus and spell check (if installed). Data tools are only available when text is selected, or when the right mouse button is clicked over a word. If no data tools are offered even when text is selected, you need to install them. If this plugin is enabled and data tools are installed, additional items appear at the end of the context menu.

Exporter
This command allows you to export the current document with all highlighting information into a HTML document using File → Export as HTML. Additionally you can use Edit → Copy as HTML to copy the currently selected text as HTML to the system clipboard.

IconInserter
The icon inserter plugin is only of use for KDE developers: It adds an item Insert KIcon-Code into the context menu of the editor. If activated, the Plasma’s icon chooser opens (showing application icons, action icons etc...). If you click on it, the file name without file extension will be inserted as text. Useful only for setting icons via KF5 through the KIcon() class.

Insane (not ZEN) HTML coding (light edition)
A plugin, which does zen-coding like selector completion. For more information see Zen Coding.

Insert File
This plugin allows you to insert any readable file at the cursor position. If enabled, the Tools menu has an additional menu item Insert File.
9.5 Locate GUI Frontend

Krusader has a GUI front end for the `locate` command (findutils). Locate is used for fast file searching not from a directory but a database. The package contains among other files, `locate` and `updatedb`. `updatedb` goes through the local file system and stores the file entries in the database. `cron` often calls `updatedb` every night (set with KCron). Choose Tools → Locate or Ctrl+Shift+L to start this feature. Konfigurator can set additional arguments for `updatedb`.

Checkbox Options

- **Show only the existing files**: if the database contains entries which no longer exist any more (deleted, moved since the last `updatedb`), `locate` does not list them. It checks the existence of each file before the listing in the results window (slow).
- **Case Sensitive**: unchecking it allows lower and upper case search.

Action buttons

- **Locate**: executes `locate foo foo` and places its output into the results window.
- **Stop**: stops the locating process.
- **UpdateDB**: starts `updatedb` for updating the locate database after entering the root password.
- **Close**: closes the locate window.

Results window

- Double-click on an item: steps to its directory, makes the item visible and closes the locate dialog.
- Right click: edits/views/finds the menu.
  - F3: views the current item.
  - F4: edits the current item.
  - Ctrl+F: finds files in the results window.
  - Ctrl+N: shows the next search result.
  - Ctrl+P: shows the previous search result.

- The results window supports dragging items to other windows and copy to clipboard (Ctrl+C).

9.6 MountMan: work with your mounted file systems

MountMan is a tool which helps you manage your mounted file systems. Once invoked, it displays a list of every mounted file system. For each file system, MountMan displays its name (which is the actual device name - i.e. `/dev/sda1` for a first partition on first HDD), its type (ext4, ext3, ntfs, vfat, ReiserFS...) and its mount point on your system (the directory on which the file system is mounted).

If you want filter out non-removable devices from the list, just check the item **Show only removable devices** at the left of the device list.

MountMan also displays usage information using total size, free size, and percentage of available space free. If those numbers say N/A, that usually means that the file system is not mounted. Left clicking on a file system displays a pie chart on the left of the window, graphically displaying the usage information for the file system. Clicking on a non-mounted file system will display **not mounted** instead of the graph.
Double-clicking on a file system will close MountMan and open that file system inside Krusader’s active panel.

Right-clicking on a file system will open a small menu which displays what actions can be performed on that file system. At the moment, you can only mount, unmount and eject (if clicking on a removable file system, e.g., a CD-ROM).

NOTE
We plan to expand MountMan in the next evolution of Krusader. It will be able to format partitions, edit /etc/fstab, create new file systems and more.... By the way, we have started working on it, see “Quickmode for MountMan”.

Quickmode for MountMan
To activate Quickmode for MountMan, click lateral button with arrow on the MountMan button on the Main Toolbar.

General idea: display a list of all possible mount points. Each time the menu is displayed, it determines if a mount point is mounted or not and associates the correct action (mount or umount). This offers a quick interface to MountMan. It is working, and currently uses KMOUNTMAN::mount and umount. It uses the new KDE Frameworks 5 services for fstab-reading and this will enable us to remove a lot of code from the ‘old’ MountMan.

9.7 Remote Connections

Remote connections are easily made by typing the URL in the Location Toolbar; these are actually KIO Slaves. Please note that the Krusader panel does not support all KIO Slave e.g. http:// will not work in the panel, but will work in the viewer. Some examples:
The Krusader Handbook

- ftp:// public.ftpserver.org/directory/
- fish:// username@hostname/
- sftp:// username:password@sftp.foo.org/
- ftp:// username@my.server.org:21/directory/
- smb:// username:password@server/share
- ftp:// username@proxyusername:password@proxipassword@hostname/directory
- nfs:// <host>:<port><url-path>
- webdav:// www.server.com/path/

You can bookmark these URLs, however, please read the Bookman section regarding securely save passwords. For connecting to multiple locations, bookmark these URLs and open them one by one, or open them all together by using Panel profiles. To switch from one to another location, just open a Folder tabs for each.

There are three ways to start a remote connection:

- Type the URL in the Location Toolbar
- Select Tools → New Net Connection which will pop-up a dialog that will ask for the remote site details. This dialog is handy if you are not used to type remote URLs in the Location Toolbar. Leaving the password and user name fields empty will log you in as anonymous. Note: we are planning to rewrite this dialog window.
- You can bookmark a directory on a remote host and return to this directory from the bookmark button on the top corner of your panel just like in a web browser.

After you log on to a remote server you can browse it just like your local hard drive with the following exceptions:

- You cannot execute files on remote servers.
- Permissions cannot always be calculated on remote servers (depends on server and access method) so you might get a ? on the permissions columns for some files.
- Disk usage information is not available for most remote filesystems.

To change the charset of the remote host use View → Select Remote Charset .

You can close the current Active Remote Connection by two separate methods:

- Manually: Add the disconnect button to the Main Toolbar and click on it.
- Automatically: Change the URL in the Location Toolbar .

**NOTE**
Krusader is a file manager that supports remote connections via KIO Slaves, but if you are looking for even more advanced remote connections features, e.g. an advanced FTP client we recommend you to use e.g. LFTP or FileZilla.
9.7.1 LAN connections via fish:/ protocol (zeroconf)

This section is contributed by Andrew Svet (z-vet), feedback about this chapter is appreciated. Thanks!

**NOTE**
This works on a Debian® system, so it will work on Debian® and derivatives (Kubuntu® etc.), though it should work on other Linuxes as well. We assume that you have SSH installed, configured and working on every machine on LAN you want to connect to/from. There are plenty of very good tutorials about SSH on the net, e.g. at linuxhomenetworking.com or just google for it. We use the default SSH port (22) for this chapter. Remember to change it if you use different one. All modifications, editing etc. must be done as root.

Let’s start with installing all the packages we need:

```bash
# apt-get install avahi-daemon libnss-mdns kdnssd
```

Everything is installed, now let’s do some configuration. First, we need our services to be announced on LAN. That is why we installed avahi-daemon: it represents your machine on local network and allows other applications to publish services they provide. Avahi-daemon comes with example ssh.service configuration file found in /usr/share/doc/avahi-daemon/examples.

In order to get the service to be announced on LAN we need to copy this file to /etc/avahi/services directory:

```bash
# cp /usr/share/doc/avahi-daemon/examples/ssh.service /etc/avahi/services
```

Now we need fish:/ protocol to be announced too, so we use an ssh.service file as a template for fish.service:

```bash
# cp /etc/avahi/services/ssh.service /etc/avahi/services/fish.service
```

This file is just a copy of ssh.service. Edit the fish.service file and replace "Remote Terminal on %h" with "Fish to %h" and "_ssh._tcp" with "_fish._tcp". Here is how it looks after edit:

```xml
<?xml version="1.0" standalone="no"?>
<!DOCTYPE service-group SYSTEM "avahi-service.dtd">
<service-group>

-- See avahi.service(5) for more information about this configuration
</service-group>
```

85
The Krusader Handbook

Save the modified file. Now we need to create a new file _fish._tcp, open a text editor and add the next lines:

```plaintext
Name=FISH Protocol (ssh)
Type=_fish._tcp
UserEntry=u
PathEntry=path
PasswordEntry=p
```

And save the file `/usr/share/apps/zeroconf/_fish._tcp` Do the same on each machine on your LAN, then restart avahi-daemon:

```
# /etc/init.d/avahi-daemon restart
```

Then open Krusader and type in location-toolbar-lnk: `zeroconf:` to open the `zeroconf` connection. Enter the `Fish Protocol` directory. Inside you will find the links to each machine that announced `fish:` on your LAN, the location-toolbar-lnk: will point to `zeroconf:/_fish._tcp` Double clicking on any of these machines, them will bring up the password prompt, asking you for your ssh key passphrase (if password was set). Enter your passphrase. Congratulations: you connected to remote machine using Krusader!

### 9.8 Synchronizer

#### 9.8.1 Introduction

This function compares two directories with all subdirectories and shows the differences between them. After selecting some options and the Compare function you can synchronize the files and directories. One panel could be an FTP server. Do not forget the Compare by content option if the file size stays equal. Choose Tools → Synchronize Directories or Ctrl+Y to start this feature. The colors are configurable. The synchronizer has its own keybindings.

**Note**

For local files: The synchronizer changes the date information to the original dates.

**Procedure:**

1. Set the Left directory and the Right directory that you want to compare.
2. Configure the optional File Filter, General Filters and Advanced filters. The General Filters includes a Do not search in option which lets you exclude directories from comparison.
3. Set the Checkbox options: Recurse subdirectories, Follow symlinks, Compare by content, Ignore Date, Asymmetric and Ignore Case.
4. Click on the Compare button to compare the directories.
5. By using Show options, you can include/exclude particular file types. The files that are not on the list will be untouched by synchronization.

6. If needed, you can change the Task operations determined by the Comparator with the right click menu.

7. When you agree with the Compare results, click on the Synchronize button to show the synchronize dialog.

8. After selecting the options of the Synchronizer, click on the Start button to start the synchronization process.

A detailed explanation of all the functions and buttons is described in the following text.

9.8.2 Comparator

Panel elements

- **Left Directory**: The left side base directory.
- **Right Directory**: The right side base directory.
- **File Filter**: Filters the filenames at synchronizing. e.g., `.png` selects only files the names of which end with `.png`. Directories are listed if the directory name ends with `.png` or if the directory contains files which end with `.png`. Multiple include/exclude example: `'*'.cpp *.h | *.moc.cpp' includes *.cpp *.h and exclude *.moc.cpp.`
- **General filters**: Search for, containing text
- **Advanced filters**: Size, date, ownership
Filename filtering criteria

- You can make use of wild cards. Multiple patterns are separated by space (means logical OR) and patterns are excluded from the search using the pipe symbol. If the pattern is ended with a slash ("pattern*/), it means that pattern relates to recursive search of directories.
- pattern - means to search those files/directories whose name is a pattern, recursive search goes through all subdirectories independently of the value of the pattern.
- pattern/ - means to search all files/directories, but recursive search goes through/excludes the directories whose name is a pattern.
- You can use quotation marks for names that contain spaces. Filter "Program Files" searches out those files/directories the name of which is Program Files.
- Examples:
  - *.o
  - *.h *.c??
  - *.cpp *.h | *.moc.cpp
  - * | CVS/ .svn/
- Note: the search term 'text' is equivalent to "text*.

Checkbox options

- **Recurse subdirectories**: The Synchronizer walks through subdirectories when comparing.
- **Follow symlinks**: The Synchronizer follows the symbolic links to directories (not the files!).
- **Compare by content**: The files the sizes of which are equal will be compared by content as well.
- **Ignore Date**: Ignores the date information (useful for FTP, smb, archive, ... ) the date information is relevant *only* in the local file system.
- **Asymmetric**: The **Left Directory** is the target directory, the **Right Directory** is the source directory. This function synchronizes the content of the left directory to the right directory.
  - The files that exist only on the left side will be deleted.
  - The files that exist only on the right side will be copied to left.
  - The files considered to be equal will be untouched.
  - Those files considered to be different will be copied to left. Use this feature with care! This function is useful if the date information is unusable, or to synchronize the left directory to the content of a file server (like a download). Alternatively, it is useful to make a backup from the right directory to the left directory. NOTE: Do NOT use this option to synchronize a desktop and a notebook (e.g. files that exist only on the left side will be deleted!).
- **Scroll Results**: This is for slow FTP servers, ... When the Synchronizer has finished comparing a file, it puts the file into the end of the list at once and scrolls the window, if necessary. It is important, if you want to know what the Synchronizer is doing. If the FTP server is slow, the comparison of a directory may take a lot of time. By turning this option on, you can see that the comparator is “alive”, but slow. For fast file systems, it can reduce the speed of comparing slightly.
- **Ignore Case**: Case insensitive filename compare, this is useful when synchronizing Windows® filesystems.
- **Ignore hidden files**: Ignores files that start with a dot.
The Krusader Handbook

When everything mentioned above is done, click on the **Compare** button to compare the directories, the results are displayed in the **File List**.

**File List**
The **File List** has the following columns: "Left name | Left size | Left time | Task | Right time | Right size | Right name". Here you can check the compare results and modify the synchronization actions if desired. The text color defines the default copy direction determined by the comparator.

- Green: Copy from left to right.
- Blue: Copy from right to left or delete on the right side in asymmetric mode.
- Red: Files which are different by the given criteria (no copy direction).
- Black: Files which are identical (no copy direction).

A double click on a file calls the Krusaders **Compare by content** function. The Tasks (<> ) column defines the default copy direction, which can be modified by the user if needed. The results window supports dragging items to other windows ( drag [left], **Shift**+drag [right] ) and copy left/right selected items to clipboard (**Ctrl**+C).

**File List: Tasks (<> ) column**
This column displays the task that is planned for the Synchronizer, this task can be modified with the **right click menu**.

- =>: Copy from the left side to the right side. For directories: `mkdir` in the right side.
- =: The files are the same, do not do anything.
- !=: The file is excluded, or the Synchronizer does not know what to do.
- <=: copy from the right side to the left side. For directories: `mkdir` in the left side
- DEL: delete files from the right side.

**Show options**
Here you can include/exclude particular file types. Those files, that are not in the list, will be untouched at synchronization.

- =>: Enable/Disable the copy task from left to right.
- =: Enable/Disable listing the equal files.
- !=: Enable/Disable listing the excluded / "do not know what to do" files.
- <=: Enable/Disable the copy task from right to left.
- **Trash**: Enable/Disable the file deleting from the left side task.
- **Duplicates**: Enable/Disable those files that exist on both sides.
- **Singles**: Enable/Disable those files that exist only on one side.

**Action buttons**

- **Compare**: Compares the directories, the results are displayed on the **File List**.
- **Stop**: Stops comparing.
- **Synchronize**: Shows the synchronize dialog.
- **Close**: Closes the Synchronizer window.

**The Status line may contain**

- The number of scanned directories while comparing.
- The filename when comparing by content (for big files).
- The number of files on the list.
The right click menu is split up in three sections:

1. change the Task operations determined by the Comparator. Select one or multiple files. The change will be applied on the selection and not only on the right clicked item. If the selected item is a directory, the change will be applied on its files/subdirectories as well.
   - **Synchronize Directories**: Starts synchronization.
   - **Exclude**: Excludes a file/dir from synchronization (task change to != ).
   - **Restore original operation**: Task change to the original result of comparison.
   - **Reverse direction**: Task change ( -> to <-, and <- to -> ).
   - **Copy from right to left**: Task change to <-.
   - **Copy from left to right**: Task change to ->.
   - **Delete (left single)**: Task change to DEL.

2. change the selections
   - **Select items**: Opens a dialog which allows you to select items. This is the Select Group dialog from the Edit menu.
   - **Unselect items**: Opens a dialog which allows you to deselect items. This is the Unselect Group dialog from the Edit menu.
   - **Invert selection**: Invert the selection status of all items.

3. others (note that the following operations work on the right-clicked file and not on the selection).
   - **View left file**: Starts viewer on the left file.
   - **View right file**: Starts viewer on the right file.
   - **Compare Files**: Starts the diff utility (e.g. Kompare) on the files.

Other buttons

- **Profiles**: If you have to synchronize the same directories often, you can save the settings e.g. include files, exclude files, ... Press the Profile button, and you will be able to add / load / save / remove synchronizer profiles.
- **Swap sides**: Swaps the File List.

Synchronize with kget

If you want to synchronize a local directory with an unstable FTP server, kget is a much better solution than simple file copying. After comparing you may right click on the result list and select Synchronize with KGet to execute the synchronization, after that the listed files will be downloaded with kget instead of Krusader. Of course kget needs to be installed on your computer; otherwise, it will not be available.

### 9.8.3 Synchronization

After pressing the Synchronize button the synchronization dialog appears.

**Check boxes**

Here you confirm the copy and delete operations of the Synchronizer

- **Right to left**: copy X1 files (Y1 bytes) enable / disable the copy from right to left.
- **Left to right**: copy X2 files (Y2 bytes) enable / disable the copy from left to right.
- **Left**: delete X3 files (Y3 bytes) enable / disable the left side deleting.
The Krusader Handbook

- **Confirm overwrites**: By switching this option on, Krusader will show the *rename, skip, overwrite, skip all, overwrite all* dialog box, before overwriting the file.

### Status labels

- **Ready**: A1/A2 files, B1/B2. This line is changed at synchronizing, showing that synchronizer finished with A1 files from A2 (B1 bytes from B2).
- **Progress bar**: Shows the progress on the synchronization (based on bytes).

### Action buttons

- **Start**: Starts synchronization.
- **Pause / Resume**: Pauses/resumes the synchronization process.
- **Close**: Closes the synchronization dialog (and stops synchronization).

### Parallel synchronization

- One can give the number of the ‘quasi’ threads.
- Can drastically increase the speed when synchronized with slow FTP servers.
- Does not affect the speed of local synchronization.
- Remote “compare by content” and “directory compare” is done in parallel.
- Remote synchronization is also done in parallel, except the mkdir tasks (mkdir must be before copy).

### 9.9 UserActions

With ActionMan you can set up, configure and manage UserActions. Some general settings are configured with Konfigurator. With UserActions you can perform actions on files in the panel or to access Krusader internal functions with parameters directly using placeholders. The actions integrate seamlessly into Plasma action system, which means that the standard Edit Toolbar and Edit Shortcut dialogs will show UserActions, too. The UserActions are stored in `/share/krusader/useractions.xml` or `krusader/useraction.xml` in the directory which can be determined using the `qtpaths --paths GenericDataLocation` command. Several examples are included in the documentation. UserActions can be edited / added / imported / exported by using ActionMan. The default UserActions are stored in `/usr/share/krusader/useraction-examples.xml`. UserActions can appear nearly everywhere where “normal” KActions can be placed. The actions can even be placed in the menu bar, but for that the `krusaderui.rc` file must be edited. A few examples:

- **Useractions Menu**
- **User Menu**
- **Actions Toolbar**
- right click menus
- etc.

Krusader’s UserActions tool is very powerful and customizable if you are familiar with writing UserActions in general.

**Tip**

Several UserActions are provided by default. Please upload your favorite UserActions so that they become available for the Krusader community. Thanks!
Basically, UserActions are a method to call external programs with variable parameters. For example, you could have a UserAction with the following `xmms --enqueue %aList("Selected")` to enqueue all selected items of the active panel to the current instance of xmms. Additionally, there is limited access to Krusader internal functions requiring parameters. For example, `%aPanelSize("80")%` will set the width of the active panel to 80% of the Krusader mainwindow. Since the parameter of placeholders can contain other placeholders, few scripts are possible.

Managing UserActions

Open Konfigurator and choose User Actions → Start ActionMan, in which you can add, edit, remove, import and export UserActions.

- **Add Action**: If you add an new action, you get an empty input mask where you can enter all the properties you desire. The action will be added as soon as you press Apply. Afterwards, the name is shown in the list on the left.

- To edit a UserAction: Select the UserAction on the left. Then choose it if you want to edit its properties. The changes will only take effect when you press Apply.

- **To remove a UserAction**: Select the UserAction on the left and click the button.

- **To import a UserAction**: If you import some actions, they will be automatically added to your list. If there are name conflicts (the names have to be unique because these are the ID for Plasma action system), you are asked to resolve them. For this, the list on the left will only show the actions where conflicts exist. You can now give them new names or remove them.

- **Export Action**: If you export a UserAction you have to give a filename in which to store it. If it does not exist, it will be created. If the file already contains UserActions, the action you are exporting will be added to that file.
The Krusader Handbook

All actions you have defined are now shown in the user menu and in Plasma dialogs for changing shortcuts and managing the toolbar. In addition, all actions available for the current item will also show up in the right click menu.

### Basic Properties

**Identifier, Title** and **Command line** are always required, all the other properties are optional.

- **Identifier**: A unique name of the UserAction, used to identify it for Plasma action system.
- **Icon button**: The icon for your UserAction.
- **Category**: Categories are used for a better overview. They appear as submenu items in the **Useractions** menu.
- **Title**: The title displayed in the menus or dialogs.
- **Tooltip**: A tooltip for your UserAction, e.g. displayed in the toolbar on mouseover.
- **Description**: A description of what the UserAction does. This is also displayed as **What's This** if you **Shift+F1** click on your UserAction.
- **Command**: The command which will be executed. You can add placeholder using a GUI with the **add** button.
- **Workdir**: The working directory for the command which will be executed.
- **Execution mode**:  
  - **Normal**: Normal execution mode.
  - **Run in terminal**: Runs the command in the terminal.
  - **Run in embedded terminal emulator**: Runs the command in the embedded terminal.
  - **Collect output**: Collects the output of the executed program in a GUI window.
  - **Separate standard error**: When **Collect output** is used the stdout and stderr are separately collected.
- **Command accepts**:  
  - **Local files (no URLs)**: Tells the placeholder it should return local addresses.
  - **URLs (remote and local)**: Tells the placeholder it should return URLs.
- **Default shortcut**: Configures a default shortcut for the UserAction.
- **Enabled**: if checked, the useraction is shown in the **User Menu**, otherwise the useraction will be hidden.

### Command-line syntax

Basically, everything you type in the command line will get executed (if you type “ls -l”, “ls -l” gets executed). You have the possibility to get a character string from Krusader which represents the current state of the panel. This is done using placeholders. A placeholder begins with a percent-sign (%) and is followed by a panel indicator (’a’ for the active, ’o’ for the other, ’l’ for the left and ’r’ for the right panel. If the placeholder does not need a panel to operate on, you have to indicate this by an underscore (_)). Then comes the name of the placeholder (see the list below), which may get some parameters enclosed in quotes. Finally, again the percent sign.

This sounds very complicated, so let’s make an example: ‘%aList(“Selected”)’% is replaced by a list of all selected items in the active panel. So a command like ‘xmms --enqueue %aList(“All”, “”, “”, “*.mp3”)’% will execute xmms with a list of all .mp3s in the current panel, separated by a single blank.

Currently, these placeholders are implemented:

- **Path** - replaced by the panels path

- **Count** - replaced by the number of <first parameter>
  1. Parameter: Which items; either "All", "Selected", "Files" or "Dirs"

- **Filter** - replaced by the panel’s filter mask

- **Current** - replaced by the current item
  1. Parameter (optional): Omit the current path. Default: no

- **List** - replaced by a list of all <first parameter>
  1. Parameter: Which items; either "All", "Selected", "Files" or "Dirs"
  3. Parameter (optional): Omit the current path. Default: no
  4. Parameter (optional): Filtermask (for all but "Selected"). Default: *

- **Select** - manipulates the selection in a panel
  1. Parameter: Filtermask
  2. Parameter (optional): manipulate in which way; either “Set”, “Add” or “Remove”. Default: “Set”

- **Goto** - changes the panels’ path to <first parameter>
  1. Parameter: A relative or absolute path, or an URL
  2. Parameter (optional): Open the location in a new tab. Default: no

- **Ask** - asks the user for some text and is replaced by the answer
  1. Parameter: The Question
  2. Parameter (optional): A default answer
  3. Parameter (optional): A caption for the question box

- **Clipboard** - manipulates the clipboard
  1. Parameter: The text that should go to the clipboard (you may want to use ”%aCurrent%” here)
  2. Parameter (optional): Append the text to the current content of the clipboard with this separator

- **Copy** - copies a file, useful for quick, local backups
  1. Parameter: What should be copied
  2. Parameter: Where it should be copied

- **Sync** - opens the Synchronizer with a given profile
  1. Parameter: A profile for the Synchronizer

- **NewSearch** - opens the search windows with a given profile
  1. Parameter: A profile for the search module

- **Profile** - loads a given panel profile
  1. Parameter: A panel profile

- **Each** - splits the commandline into a list. These commands are executed one after another.
1. Parameter: A list item (all, all files, all dirs, all selected).

- **Move** - move from source to destination.
  1. Parameter: A source
  2. Parameter: A destination

- **PanelSize** - change the ratio between the two panels.
  1. Parameter (optional): A integer value, e.g., 80 makes the active panel use 80% of Krusader’s width (height in vertical mode), omitting the parameter means 50%.

- **Ask** - cancel the execution.
  1. Parameter (optional): A string for the cancel question.

- **ListFile** - is replaced by path/file name of a temporary file containing a list of items
  1. Parameter: path/filename

- **ColSort** - set the sorting on a column of a specific panel.
  1. Parameter: Column: Either “Name”, “Ext”, “Type”, “Size”, “Modified”, “Perms”, “rwx”, “Owner” and “Group”

- **View** - set the view mode.
  2. Parameter: Window Mode: Either “tab”, “window”

A GUI-based helper for placeholder adding is provided. Spaces in Path, Current and List are by default, automatically escaped. There is one more important thing to know: All placeholders that interact with Krusader internal functions are called at expand time (meaning directly when the placeholders are replaced). External programs are called at execution time (meaning after all placeholders are replaced).

**Advanced Properties**

Here you can configure where your command should be visible (for the right click menu). In addition, it is possible to change the command executed and confirm it separately. You can also set a user under which the command should be executed.

- Configures if the action is valid for a Protocol, Path, MIME type or File name.
- Tweaking the command line before being executed.
- Set a different user for the execution (this has no effect in Krusader internal functions)
Chapter 10

Konfigurator: Krusader’s Configuration Center

Konfigurator is Krusader’s configuration center. When running Krusader, use **Settings → Configure Krusader**, and it will start Konfigurator. There you can modify the way Krusader works and customize it to your own needs. At any time, pressing the **Apply** button applies the changes, pressing **Close** closes Konfigurator, and pressing **Defaults** re-applies Krusader’s “factory” settings. Konfigurator is divided into pages, each containing items related to that page. For some changes to the GUI, you have to close and restart Krusader.

**NOTE**
Since Krusader-1.80.0 the **Key-Bindings** and **Main Toolbar-Actions Toolbar** have received their own configuration windows and so they are not a part anymore of Konfigurator, you can configure them now via the **Settings** menu.

10.1 Startup

The startup page determines the way that Krusader looks (and works) when it is launched. It is divided into two main parts:

**General**

- **Startup Profile**: Starts the selected Panel profile at startup. `<Last session>` is a special Panel Profile, it is saved automatically when closing Krusader.
- **Show splashscreen**: Displays a splash screen when starting Krusader.
- **Single Instance Mode**: Allows only one Krusader instance to run.
- **Fallback Icon Theme**: Allows you to configure a fallback icon theme for Krusader. Whenever icon is not found in system icon theme, this theme will be used as a fallback. If the fallback theme does not contain the icon, Breeze or Oxygen will be used if any of these are present.

**User Interface**

Determines which parts of the user interface are visible after start-up.
The Krusader Handbook

Figure 10.1: Startup configuration

- **Save last position, size and panel settings**: When launched, Krusader resizes itself to the size it was when last shut-down. Krusader also appears in the same location on the screen, having panels sorted and aligned as they were. If this option is unchecked, you can use the menu **Window → Save Position** option to manually set Krusader size and position at start-up.

- **Update default panel settings**: If checked, the default panel settings will be updated after start-up.

- **Start to tray**: If checked, Krusader starts to tray (if minimize to tray is set), without showing the main window.

- **Save component settings on exit**: If checked, restores the user interface components to their condition when last shut-down.

- **Show function keys**: If checked, the **FN Keys Bar** is visible after start-up.

- **Show statusbar**: If checked, the **Statusbar** is visible after start-up. Available only if the **Save component settings on exit** item is unchecked.

- **Show command line**: If checked, the **Command Line** is visible after start-up. Available only if the **Save component settings on exit** item is unchecked.

- **Show embedded terminal**: If checked, the **Terminal emulator** is visible after start-up. Available only if the **Save component settings on exit** item is unchecked.

### 10.2 Panel

Here you can determine the look and feel of panel - which means finetuning the application to your needs. The page is divided into six tabs: **General**, **View**, **Buttons**, **Selection Mode**, **Media Menu**, and **Layout**.
10.2.1 General

Navigator bar

- **Edit Mode by default**: If checked, show editable path in Navigator bar by default.
- **Show full path by default**: If checked, always show full path in Navigator bar by default.

Operation

- **Autoselect Directories**: When you select a group of files (either by using Select Group or by using Select All), Krusader checks this option. If checked, the directories matching the select criteria are also selected. Otherwise, only files are selected.
- **Rename selects extension**: When you rename a file, the whole text is selected. If you want total commanderlike renaming of just the name, without extension, deselect this item.
- **Unselect files before copy/move**: If checked, Krusader remove the selection marks from files or folders before copying or moving them to the new location.
- **Filter dialog remembers settings**: If checked, the filter dialog will be opened with the last filter settings that were applied to the panel.

Tabs

- **Use fullpath tab names**: If checked, display the full path in the Folder tabs; otherwise only the last part of the path is displayed.
- **Show new/close tab buttons**: If checked, Krusader displays new and close buttons on tabs.
- **Tab Bar position**: Lets you choose Tab bar position (Bottom or Top).
- **Show Tab Bar on single tab**: If checked, Krusader displays the Tab Bar even if there is only one tab on the panel.

Search bar

- **Start by typing**: allows to select if quick search feature is used. When checked, you can open search bar and start searching by typing something while viewing folder contents in the active panel.
- **Case sensitive**: When you use the search or filter feature: If checked (the UNIX® default), all files beginning with capital letters appear before files beginning with lower case letters; otherwise, all files beginning with a specified letter (capital or otherwise) will be displayed together.
- **Up/Down cancels search**: Pressing Arrow Up or Arrow Down cancels search bar.
- **Directory navigation with Right Arrow**: If checked, pressing the Right arrow key enters directory if no search text editing intention is captured.
- **Position**: Lets you choose search and filter bar position (Bottom or Top).
- **Default mode**: Lets you choose the search bar default mode between Search, Select and Filter. You can change the mode later using the search bar itself.

Bookmark Search

- **Always show search bar**: If checked, make bookmark search bar always visible.
- **Search in special items**: If checked, bookmark search is also applied to special items in bookmark menu like Trash, Popular URLs, Jump Back, etc.

Status/Totalsbar

- **Show size in bytes too**: If checked, Krusader displays size in bytes on statusbar or totalsbar.
- **Show space information**: If checked, Krusader displays free/total disk space in the Statusbar/Totalsbar.
10.2.2 View

General

- **View font**: Allows you to change the font used inside the file lists.
- **Tooltip delay (msec)**: Allows you to configure the delay in milliseconds between the moment you have stopped mouse pointer above an item in a file list and the moment when the tooltip will be shown.
- **Use human readable file size**: If checked, the file size appears in kB, Mb etc., and not in bytes (default).
- **Numeric permissions**: Permission column (Panel View tab) shows octal numbers ‘0755’ instead of ‘rwxr-xr-x’.
- **Show hidden files**: If checked, Krusader displays the “dot-files” which are otherwise hidden.
- **Load the user defined folder icons**: If checked, Krusader loads the user defined folder icons.
- **Always show current item**: If checked, Krusader shows current item border decoration in inactive panel.
- **Sort method**
  - **Krusader (default)**: the comparison used so far. Uses comparison using locale rules (even context rules).
  - **Alphabetical**: strings are compared character by character (no context rules from locale applied). Alphabet characters are compared using locale rules, special characters are compared by the character code.
  - **Alphabetical and numbers**: the same as above, but if the names contains numbers, the numbers are compared numerically instead of alphabetically.
  - **Character code**: comparison by character code (quick).
  - **Character code and numbers**: the same as above, but with numerical comparison of numbers.
- **Case sensitive sorting**: If checked (the UNIX® default), all files beginning with capital letters appear before files beginning with non-capital letters; otherwise, all files beginning with a specified letter (capital or otherwise) appear together.
- **Always sort dirs by name**: Sorts directories by name, regardless of the sort column.
- **Show directories first**: If checked directories have precedence in folder lists.
- **Locale aware sorting**: Sorts files and directories according to the current locale settings.

View modes

- **Default view mode**: Allows you to change the default view mode. You can choose Detailed View or Brief View. On tabs of both view modes you can define the following options.
- **Default icon size**: Allows you to change the size of the icons in the file lists. The available sizes are 16x16, 22x22, 32x32 and 48x48 pixels.
- **Use icons in the filenames**: If checked, show the icons in file names and folders.
- **Show previews by default**: If checked, show the previews of file contents.

To configure the columns use the right click menu in the panel when viewing files. The left and right panel use their own columns independently. The following columns are available:

- **Name**: Shows the filename without the part after the last dot, this latter part is displayed in the Ext column. When the Ext column is made hidden, the complete filename is shown in the Name column like e.g. Konqueror does.
– **Ext:** Shows the last part of the filename (the part after the last dot) in the Ext column, and not as a complete filename in the Name column like e.g. Konqueror does.

– **Type:** Shows the MIME type field.

– **Size:** Shows the size field.

– **Modified:** Shows the modified date and time field.

– **Perms:** Shows the full permissions e.g. "rwxr-xr-x" or as octal numbers '0755' instead with enable/disable **Numeric Permissions** in **Panel View** Tab.

– **rwx:** Shows only the rights of the current user e.g. "-rw-".

– **Owner:** Shows the owner field.

– **Group:** Shows the group field.

---

**Tip**

Uncheck the columns not in use. This allows more space for columns in use.

---

### 10.2.3 Buttons

**Toolbar buttons have icons:** If checked, Krusader displays icons on toolbar buttons.

**Show Media Button:** If checked, Krusader displays media button.

**Show Back Button:** If checked, Krusader displays back button.

**Show Forward Button:** If checked, Krusader displays forward button.

**Show History Button:** If checked, Krusader displays history button.

**Show Bookmarks Button:** If checked, Krusader displays bookmarks button.

**Show Panel Toolbar:** If checked, Krusader displays the Panel Toolbar.

You can make the buttons on the **Panel Toolbar** visible or hidden:

**Visible Panel Toolbar Buttons**

- Equal button (=)
- Up button (..)
- Home button (..)
- Root button (/)
- **Toggle-button for sync-browsing:** If checked, shows the **Sync-browsing** button.

---

### 10.2.4 Selection Mode

Here you can configure the selection modes.

**General**

- **Krusader Mode:** The way Krusader has worked from day one. Both mouse keys allow selecting files. To select more than one file, hold the **Ctrl** key and click the left mouse button. Right-click menu appears with a short click on the right mouse button.

- **Konqueror Mode:** pressing the left mouse button selects files -- you can click and select multiple files. Right-click menu appears with a short click on the right mouse button.

- **Total commander Mode:** Pressing the right mouse button selects multiple files and the right-click menu appears with **pressing and holding** the right mouse button. The **Left Mouse Button** does not select, but sets the current file without affecting the current selection.
• **Ergonomic Mode**: The left mouse button does not select, but sets the current file without affecting the current selection. The right mouse button invokes the context-menu. You can select with Ctrl key and the left button.

• **Custom Selection Mode**: Create your own selection style!

**DETAILS**

• **Double-click selects (classic)**: A single click on a file will select and focus, a double click opens the file or steps into the directory.

• **Obey global selection policy**: Pressing the left mouse button selects files -- Use global setting: Plasma System Settings -> Input Devices -> Mouse.

• Custom Selection Mode items:
  – Based on Plasma’s selection mode
  – Left mouse button selects
  – Left mouse button preserves selection
  – Shift/Ctrl-Left mouse button selects
  – Right mouse button selects
  – Right mouse button preserves selection
  – Shift/Ctrl-Right mouse button selects
  – Spacebar moves down
  – Insert moves down
  – Right-clicking pops context menu immediately

**10.2.5 Media Menu**

Using this tab you can select the Media button menu contents:

• **Show Mount Path**: show the mount path of partition if checked.

• **Show File System Type**: show the file system type of partition if checked.

• **Show Size**: allows selection of the size representation in media menu. Can be Always (default, always show the size of partition), When Device has no Label (show the size for partitions with no label only) or Never (never show the size in media menu).

**10.2.6 Layout**

You can choose the layout and frame settings:

• **Layout**: allows to define layout. The default options are Default, Compact, and Classic.

• **Frame Color**: defines frame color. Can be Defined by Layout, None, or Statusbar.

• **Frame Shape**: defines frame color. Can be Defined by Layout, None, or Statusbar.

• **Frame Shadow**: defines frame color. Can be Defined by Layout, None, or Statusbar.
10.3 Colors

This page configures the colors of the List Panel and the Synchronizer. The KDE default colors is the default color configuration.

General

- **Use the default KDE colors**: this is the default, it uses Plasma color defined in the System Settings.
- **Use Alternate Background color**: If checked, the Background color and the Alternate background color alternates line by line. When you do not use the Plasma default colors, you can configure the alternate colors in the Colors box.
- **Show current item even if not focused**: If checked, shows the last cursor position in the non active list panel. This option is only available when you do not use the Plasma default colors.
- **Dim the colors of the inactive panel**: If checked, the colors of the inactive panel are dimmed. These settings can be configured in the Inactive tab of the Colors box. This option is only available when you do not use the Plasma default colors.

Colors

Configure the colors the way you like, you can see the result in the Preview section. The following items of the active and inactive panel can be configured:

- Foreground
- Directory foreground
- Executable foreground
- Symbolic link foreground
- Invalid symlink foreground
- Background
- Alternate background
- Selected foreground
- Selected background
- Alternate selected background
- Current foreground
- Selected current foreground
- Current background

The following items of the Synchronizer can be configured:

- Equals foreground
- Equals background
- Differing foreground
- Differing background
- Copy to left foreground
- Copy to left background
- Copy to right foreground
- Copy to left background
- Delete foreground
- Delete background

Preview

Here you see a preview of the configured colors.
Color schemes

With the **Import Color Scheme** and **Export Color Scheme** buttons you can load and save a Color Scheme profile. This allows Krusader to use Total Commander©, Midnight Commander, foo-commander or your own custom color profile. The Color Schemes are stored in `/usr/share/krusader`, the `foo.color` is a binary file that holds the color scheme.

**Tip**
Midnight Commander and Total Commander© Color scheme files are provided. Please upload your favorite Color schemes so that they become available for the Krusader community. Thanks!

### 10.4 General

Here you configure the basic operations. The page is divided into three tabs: **General**, **Viewer/Editor**, and **Atomic extensions**.

#### 10.4.1 General

The following options determine basic aspects of operation:

- **Warn on exit**: if checked, Krusader warns you every time when exit action is triggered.

- **Minimize to tray**: If checked, the Krusader icon will appear in the system tray. When you minimize Krusader, it will not appear in the taskbar. It also will not exit if you close the main window. Instead you can quit Krusader by selecting **Quit** from the **File** menu or the context menu of the tray icon.

- **Use MIME type magic**: MIME type magic is a mechanism which allows Krusader to inspect the files in the panels and determine their type even if the file has no identifying extension. For example, if you take an image file - `image1.jpg` - and rename it to `image1`, Krusader will still know it is an image file and work with it accordingly. However, this mode of operation is slower (while refreshing the panel, or changing directories), so try Krusader with and without MIME type magic and decide what is best for you.

- **Temp Directory**: this option selects the base directory for Krusader’s temporary files. The actual files will be created in separate directories under the ‘Temp directory’, so that each user running Krusader will have their own temporary subdirectories under the chosen directory.

**Note**
You must choose a temporary directory to which all users running Krusader have full permissions!

**Delete mode** (**Delete files/Move to trash**): when Krusader deletes files it can either really delete them or move them to the trash folder, thereby making them available via Plasma’s trash.

**External Terminal**: choose which terminal emulator will be used when Krusader opens a console window (via F9, or **Tools** → **Start Terminal** menu option).

**Embedded Terminal sends Chdir on panel change**: if unchecked, there will be no `cd` command sent to the Terminal Emulator if the panel folder changes.

**Toggle Fullscreen Embedded Terminal**: if checked, Krusader shows fullscreen terminal in Midnight Commander style (Terminal is shown instead of Krusader window).
10.4.2 Viewer/Editor

Here you can change the viewer and editor settings:

- **Internal editor and viewer opens each file in separate window:** check this item if you want each file to be opened in separate window.

- **Default viewer mode:**
  - **Generic mode:** use the systems default viewer.
  - **Text mode:** view the file in text-only mode.
  - **Hex mode:** view the file in hex-only mode.
  - **Lister mode:** Fast text/hexadecimal viewer for huge file sizes. Krusader lister never loads the whole file into memory, just a little part of it, and uses caching for faster scrolling. Remote files are downloaded, but during the download, viewing the downloaded part is possible. If a file constantly changes, then it can also be viewed, lister will always see its current state.
  - **Use lister if the text file is bigger than: 10 MB (default value):** checks whether a text file is bigger than 10 MB (configurable), and if yes, then Krusader Lister is used instead of Plasma’s default viewer.
  - **Use Okteta as Hex viewer:** if checked (default option), use Plasma hex editor Okteta to view raw data. To use this option you should install Okteta package first.

- **Editor:** choose what editor will be used when editing a file (via F4). Default the internal viewer is used, this is Plasma’s default viewer.

10.4.3 Atomic extensions

**Atomic extensions:** predefined atomic extensions like *.tar.gz* are shown as one part in the Ext Column of the List Panel.

10.5 Advanced

This page handles more advanced issues, so you should double-check your actions here: modifying settings here makes Krusader a more powerful and dangerous tool.

The page is divided into three parts:

**General**

- **Automount filesystems:** this makes Krusader try to mount a file system before entering it. For example, if you click on /mnt/cdrom (and /mnt/cdrom appears in /etc/fstab as a mount point), Krusader will check if it is mounted. If not, it will try and mount it for you and then enter, so that you would see the contents of your cdrom. Note, however, that Krusader will NOT unmount when exiting /mnt/cdrom.

- **MountMan will not (un)mount the following mount points:** If you have file systems that you do not want to accidentally unmount (or mount) then enter a list of mount points separated by commas (e.g. /, /boot, /tmp) and MountMan will not try to (un)mount them.

**Confirmations**

By checking the options in this section, Krusader will ask for confirmation before doing a specific action; otherwise, the following actions will be done without warning:

- deleting non empty directories
The Krusader Handbook

- deleting file(s)
- copying file(s)
- moving file(s)

Fine-Tuning

- **Icon Cache Size**: Krusader uses an icon cache, so it will not have to reload icons that have been used before. Of course, as the cache grows bigger, it can store more icons and further speed operations, but the memory footprint of Krusader will become bigger.

- **Arguments of updatedb**: sets additional arguments for `updatedb`, please read the man-pages for more information.

10.6 Archives

This page configures some aspects of archive handling in Krusader.

**krarc ioslave**

**Enable Write Support**: this option allows you to enable writing files into an archive.

**WARNING**
The down side is that if a power failure occurs during the process, the files that were moved might already be deleted, but not yet packed into the archive. Moving archives into themselves will delete them.

Archive handling

**Browse Archives As Directories**: if checked, Krusader will handle the archives transparently and let you open them as folders; otherwise, Krusader will attempt to invoke an application which opens archives of that type.

Fine-Tuning

- **Test archives after packing**: this option automatically runs a test on a newly packed archive. It is safer, but takes longer.

- **Test archives before unpacking**: this option automatically runs a test before unpacking. Some corrupted archives might cause a crash; therefore, it is better to test archives before unpacking.

10.7 Dependencies page

This page configures the full path of the external applications. It is even possible to configure the full path of Krusader!

**General tab**

Here you can configure the full path of the following external applications:
The Krusader Handbook

<table>
<thead>
<tr>
<th>application</th>
<th>configurable full path</th>
</tr>
</thead>
<tbody>
<tr>
<td>kdesu</td>
<td>/usr/bin/kdesu</td>
</tr>
<tr>
<td>kget</td>
<td>/usr/bin/kget</td>
</tr>
<tr>
<td>mailer</td>
<td>/usr/bin/kmail</td>
</tr>
<tr>
<td>diff utility</td>
<td>/usr/bin/kompare</td>
</tr>
<tr>
<td>krename</td>
<td>/usr/bin/krename</td>
</tr>
<tr>
<td>krusader</td>
<td>/usr/bin/krusader</td>
</tr>
<tr>
<td>locate</td>
<td>/usr/bin/locate</td>
</tr>
<tr>
<td>mount</td>
<td>/bin/mount</td>
</tr>
<tr>
<td>umount</td>
<td>/bin/umount</td>
</tr>
<tr>
<td>updatedb</td>
<td>/usr/bin/updatedb</td>
</tr>
</tbody>
</table>

**Tip**

By default Kompare is used as external diff utility but you can also use your favorite diff utility e.g. `xxdiff` or `KDiff3`, just fill in the full path and enjoy.

Packers tab

In the Packers tab you will see a list of archive formats. Some are filled and some are empty. The ones that are available (filled) are supported by Krusader. For them, Krusader will handle the archives transparently and let you open them as folders (provided you have checked the **Browse Archives As Directories** item in the Archives section); otherwise, Krusader will attempt to invoke an application which opens archives of that type. If a certain archive item is empty, it means that Krusader could not find the appropriate executables in the configured path. The next archives are supported: ace, arj, bzip2, deb, gzip, iso, lha, lzma, rar, rpm, tar, xz, zip and 7z.

<table>
<thead>
<tr>
<th>packer</th>
<th>configurable full path</th>
</tr>
</thead>
<tbody>
<tr>
<td>7z</td>
<td>/usr/bin/7z</td>
</tr>
<tr>
<td>arj</td>
<td>/usr/bin/arj</td>
</tr>
<tr>
<td>bzip2</td>
<td>/usr/bin/bzip2</td>
</tr>
<tr>
<td>cpio</td>
<td>/bin/cpio</td>
</tr>
<tr>
<td>dpkg</td>
<td>/bin/dpkg</td>
</tr>
<tr>
<td>gzip</td>
<td>/usr/bin/gzip</td>
</tr>
<tr>
<td>lha</td>
<td>/usr/bin/lha</td>
</tr>
<tr>
<td>lzma</td>
<td>/usr/bin/lzma</td>
</tr>
<tr>
<td>rar</td>
<td>/usr/bin/rar</td>
</tr>
<tr>
<td>tar</td>
<td>/bin/tar</td>
</tr>
<tr>
<td>unace</td>
<td>/usr/bin/unace</td>
</tr>
<tr>
<td>unarj</td>
<td>/usr/bin/unarj</td>
</tr>
<tr>
<td>unrar</td>
<td>/usr/bin/unrar</td>
</tr>
<tr>
<td>unzip</td>
<td>/usr/bin/unzip</td>
</tr>
<tr>
<td>zip</td>
<td>/usr/bin/zip</td>
</tr>
<tr>
<td>xz</td>
<td>/usr/bin/xz</td>
</tr>
</tbody>
</table>
NOTE
Krusader may not be compatible with ACE despite our best efforts. Unace uses closed source and contains additional lines that make Unace get into infinite loop if the stdin is redirected to somewhere else. It works in the same manner as ‘su’, where you cannot enter the password only from the stdin. Krusader >= 1-51 emulates the command line environment to enable co-operation with Unace, but we have noticed that Unace always changes its output format from release to release, making co-operation almost impossible.

Checksum Utilities tab
Here you can configure the full path of the following external Checksum Utilities:

<table>
<thead>
<tr>
<th>Checksum Utilities</th>
<th>configurable full path</th>
<th>supported checksums</th>
</tr>
</thead>
<tbody>
<tr>
<td>md5sum</td>
<td>/usr/bin/md5sum</td>
<td>md5</td>
</tr>
<tr>
<td>sha1sum</td>
<td>/usr/bin/sha1sum</td>
<td>sha1</td>
</tr>
<tr>
<td>md5deep</td>
<td>/usr/bin/md5deep</td>
<td>md5</td>
</tr>
<tr>
<td>sha1deep</td>
<td>/usr/bin/sha1deep</td>
<td>sha1</td>
</tr>
<tr>
<td>sha224sum</td>
<td>/usr/bin/sha224sum</td>
<td>sha224</td>
</tr>
<tr>
<td>sha256sum</td>
<td>/usr/bin/sha256sum</td>
<td>sha256</td>
</tr>
<tr>
<td>sha256deep</td>
<td>/usr/bin/sha256deep</td>
<td>sha256</td>
</tr>
<tr>
<td>sha384sum</td>
<td>/usr/bin/sha384sum</td>
<td>sha384</td>
</tr>
<tr>
<td>sha512sum</td>
<td>/usr/bin/sha512sum</td>
<td>sha512</td>
</tr>
<tr>
<td>tigerdeep</td>
<td>/usr/bin/tigerdeep</td>
<td>tiger</td>
</tr>
<tr>
<td>whirlpooldeep</td>
<td>/usr/bin/whirlpooldeep</td>
<td>whirlpool</td>
</tr>
<tr>
<td>cfv</td>
<td>/usr/bin/cfv</td>
<td>md5, sha1, sfv, crc</td>
</tr>
</tbody>
</table>

10.8 UserActions
Here you can configure the terminal for UserActions and the font for the output-collection. The default terminal is konsole --noclose -e. To set up, configure and manage your UserActions use ActionMan (UserActions URL).

10.9 Protocols
This page links the MIMEs to protocols. e.g. protocol “tar” is linked to MIME “application/x-tar”.

In the Links you will see e.g.

- Iso
  - application/x-iso

- krarc
  - application/x-ace
  - application/x-arj
  - application/x-bzip2
  - application/x-cpio
  - application/x-deb
The Krusader Handbook

- application/x-debian-package
- application/x-gzip
- application/x-jar
- application/x-lha
- application/x-rar
- application/x-rpm
- application/x-zip
- tar
  - application/x-tar
  - application/x-tarz
  - application/x-tbz
  - application/x-tgz
Chapter 11

Frequently Asked Questions (FAQ)

If you have problems with Krusader please check the Installation procedure, as your problem may be caused by a bad installation.

The FAQ is divided into three sections:

• Installation FAQ (this page)
• Usage FAQ (issues with running/using Krusader)
• General FAQ (bug reports, forum, mailing list, ...)

If you feel that a FAQ is missing or if something is not clear to you, please let us know.

11.1 Installation FAQ

1. Does Krusader need Plasma to run?
   No, Krusader does not need the Plasma window manager to run on your computer but Krusader’s natural environment is Plasma, because it relies on services provided by the KDE Frameworks 5 base libraries. Only some shared libraries are needed e.g. KF5 libraries, Qt™ libraries, etc. This means that Krusader runs on GNOME, AfterStep, XFce and other window managers provided the appropriate libraries are installed on your computer. All this is not a problem since the apt-get world can resolve these dependencies instantly.

   You do not need to switch to the Plasma window manager to use Krusader; you can still use GNOME, AfterStep, XFce or another window manager. However, the configuration of the Krusader fonts and some behavior is done by running systemsettings.

   A lot depends on what you want to do with Krusader. You should know that Krusader uses the KF5 KIO Slaves to access remote file systems, and support for only a limited number of file system types are shipped with KF5 libraries, most of the KIO Slave are bundled with KDE Frameworks 5 (including fish, sftp and tar).

   To summarize, if you want a working Krusader - install KDE Frameworks 5. If you want a functional Krusader then you need KDE Frameworks 5 and some additional Plasma packages. For maximum functionality, Krusader needs some KDE Applications (Ark, KDiff3, KRename), but the Plasma window manager is optional.

2. Which libraries does Krusader need to run?
   For running Krusader (e.g. when you have installed Krusader with a binary RPM) you need less libraries than if you compile Krusader from source. e.g. you only need the C-compiler gcc when you compile Krusader from source (see the next question).
Take a look at the Krusader dependencies paragraph of our install chapter.
If you need more details please take a look at the Krusader requirements on Ubuntu. The 
"depends" are required, the "suggests" make Krusader more powerful.

3. I have followed all the steps but make complains about missing libs or headers. What do I need to do?
Install the missing packages.
Take a look at the Compilation requirements paragraph of our install chapter.
Most RPM-based distributions separate the headers from the libs. The headers are needed
to compile Krusader. Look for packages in the form foo-devel-*.rpm (e.g. kdelibs-devel-f
oo.i586.rpm) or foo-dev-*.deb for Debian® based distributions. These are usually included
with your distribution.

Tip
If you cannot find the needed package, use rpmfind and click 'missing lib or header' in the
search line. Or use apt-cache search foo to find the corresponding package for Debian® based distributions.

4. How do I compile Krusader when I am using a 64 bit processor?
As far as we know, there are no issues. Krusader is also available on many other architectures.

5. I have downloaded the Source RPM krusader-x.xx.dist.src.rpm, what to do now?
(a) Check the ownership and the permissions on /usr/src/RPM/ and all recursive direc-
tories that your normal user can read-write-execute in these directories.
(b) To produce the binary RPM for your computer, do this:

$ rpm --rebuild </path/to/rpmfile/> krusader-x.xx.dist.src.rpm

(c) If all dependencies are OK, a binary RPM krusader-x.xx.dist.rpm will be created at
/usr/src/RPM/RPMS/i586 (replace i586 with your architecture).
(d) Test the binary RPM for errors before installing:

$ rpm -i --test </path/to/rpmfile> krusader-x.xx.dist.rpm

If the prompt returns without any message, then everything is OK.
(e) Install the binary RPM as usual, for example:

$ su -c 'rpm -Uvh </path/to/rpmfile> krusader-x.xx.dist.rpm'

You will be asked to enter your root password.
(f) Now you can start Krusader.

Tip
For more information about RPM, visit rpm.org and read the RPM Guide by Eric Foster-Johnson.

6. I am trying to install binary foo (RPM or DEB package), but it fails. What is wrong?
Since we only prepare (and use) the source, we have no way of knowing this. Did you test
the binary RPM before installing?

$ rpm -i --test </path/to/rpmfile> krusader-x.xx.dist.rpm
If the prompt returns without any message, then everything is OK. RPM’s downloaded from our website are usually provided by Krusader users. Visit your distro website and search for an updated RPM.

If the RPM is not OK, try to find another package at Linux® software archives such as freshmeat.net or linux-apps.com. If you still cannot find the appropriate package for your Linux® distribution, we recommend searching for it with rpmfind or rpmpbone.

In general, a package for an older version of your distribution or even for another distribution might work on your computer (e.g. FC RPM’s often work on Mdk and RH, and vice versa), but it is always the best that you install only RPM’s that exactly match your distribution. If you cannot find a package that matches your distribution version, architecture or distribution, then use a source RPM. When you use a source RPM, the Krusader sources will be built, on your computer, guaranteeing a suitable binary RPM for your specific distribution and architecture. In addition, this method results in maximum system speed, since the resulting binary is customized for your computer. Please read the previous question, it explains how to install a source RPM. The best solution is explained in the next question.

7. **I cannot find an RPM or DEB package for Krusader, what to do?**

   Check if your distribution provides Krusader, if it does not then contact your distribution creator and ask them to include Krusader!

   Did you take a look at the URLs on the **Installation procedure** page? If you have and found nothing, you can always compile Krusader from source. Even if you feel you have not got the necessary skills, you will probably succeed in compiling Krusader: we provide a very detailed installation procedure. This HowTo enables newcomers to compile Krusader from source, even if they have never done a compilation from source before, just follow the instructions carefully. Feel free to post a help request if you encounter problems.

8. **Some new menu items are missing after updating Krusader, what is wrong?**

   The **krusaderui.rc** file is stored in /usr/share/kxmlgui5/krusader/krusaderui.rc. When you change the Toolbar, Plasma makes a copy of that file in the home folder at ~/.local/share/kxmlgui5/krusader/krusaderui.rc. If Krusader was previously installed on your computer, and you install a newer Krusader version the ~/.local/share/kxmlgui5/krusader/krusaderui.rc file must be replaced with the newer version. Note: this will also reset all your changes on toolbars and shortcuts!

   The first line of krusaderui.rc contains the version number. After installing a newer Krusader version, Plasma will automatically replace the old ~/.local/share/kxmlgui5/krusader/krusaderui.rc with the newer version when starting the new Krusader for the first time (Plasma will detect the newer version number in the first line).

   If you install a development or beta version and Krusader was already installed on your computer then you should delete the krusaderui.rc file from your home directory to activate the new menu entries $ rm ~/.local/share/kxmlgui5/krusader/krusaderui.rc

   If the ~/.local/share/kxmlgui5/krusader/krusaderui.rc file is older, then the new menu elements will not be shown. Read the previous question for information on how to update the krusaderui.rc file. If krusaderui.rc is missing or in a wrong directory, only the Help menu appears, please read the previous question.

   **NOTE**

   The default folder for the local configuration file kxmlgui5/krusaderui.rc is ~/.local/share. You can determine the needed folder in your system using the qtpaths --paths GenericDataLocation command in terminal.

9. **I am having trouble compiling and installing Krusader, how do I send a help request?**

   Please read our detailed **installation procedure** and the **FAQ**. If you cannot find a solution to your problem then feel free to post a help request at our Krusader forum or use the Krusader-users mailing list. But before posting a help request, please try the following:
(a) Use the search function on the KDE Forum, your problem might be solved or discussed already.

(b) If you cannot find a solution, please make a note of the following issues:
   • the Krusader version used
   • the Linux® distribution + version used
   • a good description of the problem

   Without this information, it is very difficult for us to help you.

   **NOTE**
   If you give us the error messages (e.g. make error messages) please start with the FIRST error message, all the error messages which follow the first error message are consequences and not the cause of your problem.

(c) Send out your help request.

   Thank you for your co-operation!

10. **How can I build an RPM package for Krusader?**

    If you have experience with compiling from source, you will probably be able to build a Krusader RPM too. Information about RPM can be found at rpm.org and in the RPM Guide by Eric Foster-Johnson. The following is the short procedure howto on building an RPM.

    **WARNING**
    NEVER build RPMs when logged in as root. Mistakes in building packages (e.g. a bad krusader.spec file) can do serious damage to your system when logged in as root.

    (a) Compile Krusader from source to check that the compilation works fine.
    (b) Check the ownership and the permissions on /usr/src/RPM/ and all recursive directories that your normal user can read-write-execute in these directories.
    (c) Copy krusader-1.xx.tar.gz to /usr/scr/RPM/SOURCE
    (d) Copy krusader.spec to /usr/scr/RPM/SPECS
    (e) Edit krusader.spec and add your name, your email address, the rpm name, ... Other changes may be needed if rpmbuild fails.
    (f) Build the binary and the source RPM with:

       ```bash
       $ rpmbuild -ba /usr/scr/RPM/SPECS/krusader.spec
       ```

       If everything went OK you will have a binary RPM in /usr/src/RPM/RPMS/i586 (depending on your architecture) and a source RPM in /usr/src/RPM/SRPMs/ e.g. krusader-1.70-beta1.suse10.i586.rpm and krusader-1.70-beta1.suse10.src.rpm
    (g) If the build is not OK you will receive an error message during the rpmbuild process, try to fix it and run rpmbuild again.
    (h) And finally: test the RPM before sending it in.

11. **Why does Krusader-git show an old version number in the about box?**

    Because we only change the version number just before we do a new release. Krusader-git will show an older version number, so ignore the version number and check the download date. We simply have not yet decided what the next version number will be.

12. **Why does Krusader not start on Mac® OS?**

    Please read carefully the macports.org installation instructions. Do not forget to start dbus.
11.2 Usage FAQ

1. Why does Krusader freeze or hang on a dead mountpoint?
   When Krusader is e.g. browsing an NFS share and the NFS server goes down, Krusader will freeze. This Krusader (and all other open internal viewers/editors) freeze is fatal, and can only be corrected with the `kill -9`. We have no solution for this. This is an issue not confined to file managers, or even the Linux® OS! The problem is that you “hang” on the first access to the dead share - so there is no way around it, no check to avoid it, even `ls` will freeze. Just trying to read something - anything - is enough to get you stuck. The one and only way around this architectural problem is using a multi-threaded design - this way if we get stuck, we do not hang the entire application event loop, but we do not think that the time is right for adding threads, we are not sure that *all* the KF5 systems out there are using Qt™-mt (the multi threaded version of the Qt™ library), and the Krusader Krew may not be the right people to address this major issue in any case; so currently this is just a bug we have to learn to live with.

2. When I try to resize Krusader to make it smaller, I discover that I cannot resize it below a certain size. Why?
   See the F1, F2 (etc.) buttons? They are not allowing Krusader to downsize as they have a minimum size. Just disable them Settings → Show FN Keys Bar and you will be able to resize Krusader to your liking. Since version 1.51 we have improved this greatly: when downsizing the buttons will look like ‘F5 ..py’. When the button faces are too small to read a tooltip will give the complete text. The minimum width is 45 pixels for each button.

3. Samba ISO 8859-x codepage / What to do if Krusader does not read shared directories containing special international characters?
   Krusader does not handle (yet) Samba ISO 8859-x codepages, if you use a codepage different than 8859-1 you will have to do a manual configuration. Create or modify the file: 
   ```
   ~/.smb/smb.conf
   
   [global]
   workgroup = MyWorkGroup (ex. WORKGROUP)
   client code page = MyCodePage (ex. 852)
   character set = MyCharSet (ex. ISO8859-2)
   ```
   You can try to configure smb.conf with appropriate System Settings module.

4. Krusader reports “krarc:... protocol not supported “ error at opening an archive file, what to do?
   Install the krarc slave properly:
   Copy the kio_krarc.so,kio_krarc.la files into /usr/{lib or lib64}/qt5/plugins
Copy the `krarc.protocol` file into `/usr/share/services` or the directory where the KIO slaves are placed in your Linux® distribution.

5. **I get the error message “Protocol not supported by Krusader: “krarc:/path/to/foo-archive”, when I try to open foo-Archive, what to do?**

   The icons, kio_slaves and documentation must be installed in the correct places in the KF5 directory tree. The `kio_krarc.*` files must be in the same directory with the other KIO slaves. Try this: locate `kio_tar.*` and copy/link the `kio_krarc.*` files to the same location. Do not forget to run # `ldconfig` on this directory when you are done.

6. **What to do if an external tool does not seem to work?**

   Krusader uses several programs as external tools, and sometimes they appear not to work. Open a terminal and check if tool `foo` is installed.

   ```
   $ foo
   ```

   Check if tool `foo` is properly configured in the Konfigurator Dependencies page. For Archiving tools: autodetect the archives again with the Auto Configure button in the Konfigurator archive page. Check the Konfigurator Protocol page. If it does not work, backup your `XDG_CONFIG_HOME /krusaderrc` (default is `$HOME /.config/krusaderc`) configuration file and remove it from this location. Restart Krusader. Krusader will now start the first start configuration wizard, follow these guidelines.

7. **How to executing jar files (and not enter the jar archive)?**

   Go to the Konfigurator Protocol page and remove `application/x-jar` from the krarc node, Krusader should no longer enter the archive. Global file associations are handled by Plasma and not by Krusader. To associate the jar extension:

   - Open Plasma System Settings: systemsettings
   - Applications → File Associations
   - Enter `jar` as filename pattern
   - Add `java` as application

8. **Why do I have trouble with my FTP connection?**

   This problem often occurs when you are behind a firewall or proxy. Open System Settings → Network → Settings → Connection Preferences, Enable Passive Mode (PASV) has to be turned on or off, depending on its current setting. Now try your FTP session again to see if it works. Also, make sure you have no other FTP sessions open (using web browsers, etc.), they can cause complications. More information can be found in Active FTP vs. Passive FTP, a Definitive Explanation.

9. **I get FTP protocol not supported by Krusader error when trying to open a remote FTP directory, what to do?**

   The reason for this error is that ‘FTP via HTTP proxy’ feature is not yet supported by Krusader. This error may be caused by a misconfiguration of the proxy settings in System Settings. Modify the proxy settings to not use HTTP proxy and FTP will work.

10. **How do not add .part suffix when copying files via FTP?**

    When uploading files a .part suffix is added to the filename, once the upload is complete the filename is renamed automatically to remove the .part suffix. This works great but sometimes some FTP servers do not allow a rename operation. You can solve this by unchecking the checkbox Mark partially uploaded files in Plasma System Settings. The check box is located at Network → Settings → Connection Preferences.

11. **How can I close a remote connection (e.g. a FTP connection)?**

    It is explained in the remote connections chapter.
12. *I am experiencing problems with the media:/ protocol, why?*

The media:/ protocol was removed since KDE 4. Please use mtp:/ protocol instead.

13. **How can I disable the default sounds, e.g., when I do a delete action?**

Those are the default Plasma System sounds, and not related to Krusader. If you want to
disable them globally open your Plasma System Settings ( systemsettings): **Personalization → Notifications → Manage Notifications**, **Event Source**: “Plasma Workspace” and
uncheck sound items you do not like.

14. **Where the remote connection manager?**

Use our Bookmark Manager. Use a remote URL and bookmark it.

15. **Why does not MIME type magic sometimes work inside archives?**

When you enter an archive and press F3 to view a file that has no known extension, e.g.,
README, INSTALL etc. And if the viewer opens in hex-mode instead of the usual mode, than
you need to configure: **KDE System Settings → File Associations → Application → octet-
stream**, **binary viewer** needs to be removed.

16. **Where is Konfigurator, do i need to install the Plasma to use it?**

Konfigurator is Krusaders configuration module, if you have installed Krusader then you
have also Konfigurator. For some reason some people think it is an other Plasma applica-
tion, but it is not, so you do not need to install the full fledged Plasma to use Konfigurator.
When running Krusader, use **Settings → Configure Krusader**, and it will start Konfigura-
tor. Please read the manual, Krusader has many many configuration options, a lot of things
can be customized to your needs with Konfigurator.

17. **How can I set the look & feel of 2 different users to be the same?**

Presuming that the current setup is the good configuration, you can copy the configuration
to the other user.

```
$ cp ~/.config/krusaderrc /home/foo_user/.config
```

And when the other user is Root use:

```
$ cp ~/.config/krusaderrc /root/.config
```

### 11.3 General FAQ

1. **How can I report a wish, a suggestion, or a comment?**

An open source project’s greatest strength is derived from getting user feedback. That is
why we love to hear what you have to say. Your “grips” are our instructions. After about
6 months, programmers can no longer see their own mistakes. It is natural. We want the
ideas, critiques, and feedback because we all want to make Krusader the best and most
useful file manager available anywhere.

The most convenient way to contact us is to use the krusader-users mailing list. For infor-
mation on what remains to be done look at the Krusader-devel mailing list. We review and
discuss every submission.

2. **How can I send a patch?**

It is not easy to write patch guidelines, but here are some.

(a) Patches, new code or new features are always welcome!

(b) Focus only on one problem at a time, so the developers can easily understand you,
and commit your patch it works.
The Krusader Handbook

(c) Preferably, you can start a discussion with the developers on the krusader-devel mailing lists or on the Krusader Phabricator page. Unfortunately, we cannot apply a patch if the patch is in conflict with the "general design" of the Krusader code (read for more instructions in this FAQ). Please send only one change request per mail, so that the discussion is easier to follow. The modifications should be committed step by step, checking each line.

(d) Submit your patch files into the Krusader group on the Phabricator, so that all patch proposals stay organised and do not get lost, tar.gz archives or diffs are usually ok. Do not copy changes into a mail. Most mailers will change the white spaces, so that the diff will not apply or the code snipped does not diff. In the past, patch mails went lost or disorganized in many many mails, so please use the Phabricator, thanks!

(e) Use portable solutions, Krusader should run on:

- All POSIX (Linux®, BSD/UNIX®-like OSes), Solaris™.
- All BSD Platforms (FreeBSD®/NetBSD®/OpenBSD®/Mac® OS).
- KDE 3.3- KDE 3.5 and even on GNOME with KDElibs (for Krusader-2.x).
- GCC 2.95 - GCC 5.4

Architecture changes are made by the team only.

(f) A final note: always keep in mind a patch might be rejected. Either it has side effects, which we could not fix or it contradicts with the idea behind the patched module. In this sense, a software project differs from, let’s say a wiki: a software project has to have someone to make all the final decisions. Otherwise the software will not work. Furthermore: keep in mind that the examination of patches might take time, as we all have private lives.

3. How can I report a bug?

Bugs?!?!? Well, ok.... We have an online Bug Tracking System.

Using the online bug-tracker helps us have a clear and orderly way to know how many bugs are open, bug priority and follow-ups. It saves us from browsing through the entire Krusader forum, searching for yesterdays bug. Please use this system.

Before reporting a bug, please read the following:

(a) Check if the bug is already posted in the online bug list of the Bug Tracking System.

(b) If you cannot find this bug mentioned, please submit it into the bug tracker by clicking the Submit New button in the bug-tracker window. Please submit the following issues: the Krusader version used, the Linux® distribution + version used, processor type, and as good a description of the problem as you can manage.

Thank you for your co-operation!

NOTE

If possible, try to do the same operation with Konqueror or another KDE application. If you encounter the same problem then it is possibly a KIO Slaves or KDE Frameworks 5 bug, and not a Krusader bug. Krusader uses the KF5 libraries and the KIO Slave for many operations. In some cases you can encounter problems if your distribution is incorrectly configured, please test it first as explained above.

4. How can I send good debug or crash reports?

Usually binary packages that are been used by your distribution do not contain debug information. Since we usually only develop and fix Krusader-git, compile Krusader-git in debugmode and install it, than check if the bug still exist.

$ cmake -DCMAKE_BUILD_TYPE=debugfull

Install valgrind, a suite of tools for debugging and profiling Linux® programs. Run Valgrind/Krusader
The valgrind tool will write to stdout, what really happens. If you could send these information before the crash, it is almost sure, that we may fix or tell you what to do.

5. **What to do if the KDEcrashhandler sends no useful backtrace information?**
   
   Usually binary packages that are been used by your distribution do not contain debug information. Since we usually only develop and fix Krusader-git, compile Krusader-git in debugmode and install it, than check if the bug still exist.

   ```bash
   $ cmake -DCMAKE_BUILD_TYPE=debugfull
   ```
   
   If the KDEKrashhandler still does not provide useful backtrace information, than sometimes a coredump will give better information. Run Krusader, with disabled crashhandler.

   ```bash
   $ krusader --nocrashhandler
   ```
   
   On a crash you will get a `.core` file, usually in your home directory. Run `gdb`, the GNU Project Debugger

   ```bash
   $ gdb -c corefile krusader
   ```
   
   Now type `bt` to get the backtrace and type `q` to quit gdb. Often the best debug results will be given when using the valgrind tool.

6. **Does Krusader have a mailing list?**

   Yes, currently we have 5 mailing lists. No spam, no bother, just Krusader. Feel free to subscribe and unsubscribe.
   
   Tip. our mailing lists can be browsed online or read with a newsreader, so that you do not even need to subscribe to follow the action on the mailing lists.

   - **Krusader-devel** is the developer mailing list (read-only). If you want to follow the development of Krusader on the cutting edge, this is the list to follow.
   - **Krusader-users** is the Krusader users mailing list. Here you can ask for help and talk with the Krusader users and developers.

7. **Does Krusader provide news feeds?**

   Yes, we do. Several news feeds in various formats are available. `krusader-devel` feed, `krusader-users` feed.

8. **Does Krusader have an IRC channel?**

   Yes, we do. Feel free to talk to the Krusader Krew and fellow-users via `freenode.org` servers. The server is `irc.freenode.org`, the channel is `#krusader`. Everyone is welcome.

9. **How does the Krusader forum work?**

   In the spirit of freedom of speech, everything that is Krusader related can be discussed in our forum. It does not matter if you are a newcomer or an advanced user, everyone is welcome. An open source project’s greatest strength is derived from getting user feedback. That is why we love to hear what you have to say. With your feedback we can make Krusader better and better; otherwise, we are not aware of issues and ideas you may have. But please remember the following, so that we can maintain some order in the chaos.

   If the Documentation, FAQ and Krusader-devel (please use the search function ) cannot help you, do not hesitate to post on our forum. The Krusader Krew or the Krusader community is always available to help you.

   Please use the search function of the KDE Forum, your issue may have been previously discussed (this allows us to minimize the double/triple/... postings). If your issue has already been discussed in the past there is a great chance that you will have an instant
solution to your problem. If the issue is currently being discussed, you can join in the
discussion. Some questions are asked over and over again, that is why we have created this
FAQ. This allows us to spend more time developing Krusader.
Thank you for your co-operation!

10. How can I translate Krusader into my native language?
If you are interested in translating the Krusader GUI or documentation, please contact the
KDE translation team of your language.

11. How can I support Krusader?
You can support Krusader in many different ways. Please send us feedback, bug reports,
patches, donations, translations, ...

12. Is there a Mac® OS X port?
Yes, there is a Mac® OS-X port with the help of macports.org, the port is maintained by
Jonas Bähr, all feedback is welcome. A recommended native file manager for Mac® OS is
Disk Order (shareware).

13. Is there a Windows® port?
No, there was a port but it is unmaintained and unavailable now. A recommended native
file manager for Windows® is Total Commander (shareware).

If you want to help with porting please join The KDE on Windows Initiative. Some useful
tips on porting can be found in the INSTALL file of the Krusader sources, it contains all
latest compilation instructions.

14. Why is Konqueror in “midnight commander style” not an OFM?
The two panels and a commandline are available, all the other stuff like OFM features and
the OFM interaction with the user is missing from this profile.

15. Why should I use an OFM?
An Orthodox File Manager (OFM) is much faster than a one panel filemanager and faster
than the command line. If you would like to know how Krusader feels, there is only one
way to discover: install it on your computer and use it for a while. If you prefer to waste
time and lose productivity, continue to use one panel filemanagers which are based on
Windows® Explorer. Matej Urbančič has written a blog on why OFM is better than a one
panel filemanager.
Chapter 12

Credits and License

Krusader
Krusader is developed by a dedicated team of individuals, known as the Krusader Krew.

- Shie Erlich, author (retired) erlich * users.sourceforge.net
- Rafi Yanai, author (retired) yanai * users.sourceforge.net
- Dirk Schler, webmaster (retired) deschler * users.sourceforge.net
- Csaba Karai, developer (retired) ckarai * users.sourceforge.net
- Heiner Eichmann, developer (retired) h.eichmann * gmx.de
- Jonas Bähr, developer (retired) jonas.baehr * web.de
- Václav Žůza, developer (retired) vaclavzuza * seznam.cz
- Jan Lepper, developer (retired) jan_lepper * gmx.de
- Andrey Matveyakin, developer (retired) a.matveyakin * gmail.com
- Davide Gianforte, developer davide * gengisdave.org
- Toni Asensi Esteve, developer toni.asensi * kdemail.net
- Alexander Bikadorov, developer alex.bikadorov * kdemail.net
- Martin Kostolný, developer clearmartin * gmail.com
- Nikita Melnichenko, developer nikita+kde * melnichenko.name
- Frank Schoolmeesters, Documentation & Marketing coordinator (retired)
  frank_schoolmeesters * yahoo.com
- Richard Holt, Documentation & Proofing (retired) richard.holt * gmail.com
- Yuri Chornoivan, Documentation yurchor * ukr.net
- Matej Urbančič, Marketing & Product Research (retired) matej.urban * gmail.com
We would especially like to thank Dirk Eschler the Krusader web master. If you visit the Krusader website you will appreciate the hard work and effort that Dirk has put into the site as much as we do.

We would like to thank everyone who has contributed to Krusader. Sorry we can not mention all of you in this handbook.

**NOTE**
For a more complete list of Krusader contributors please take a look at the CREDITS and Changelog file online or in the Krusader sources.

Special thanks to:

- kde.org
- KDE translation teams
- Sourceforge.net
- Jonas Bähr (webspace)
- store.kde.org
- Google.com

Documentation Copyright 2000-2003 Shie Erlich and Rafi Yanai.
Documentation Copyright 2004-2011 Frank Schoolmeesters.

This documentation is licensed under the terms of the GNU Free Documentation License.
This program is licensed under the terms of the GNU General Public License.
Chapter 13

Installation of Krusader

13.1 Requirements

In order to successfully use the most recent Krusader, you need KF5 >= 5.18

Required KDE version:

• Krusader v1.01: KDE 2
• Krusader v1.02 - 1.140: KDE 3.0 - KDE 3.2
• Krusader 1.40: prefers KDE 3.2 (otherwise all features will not be available)
• Krusader v1.50 - v1.51: KDE 3.2 - KDE 3.3 (Konfigurator crash on KDE 3.4)
• Krusader v1.60.0 - v1.70.0: KDE 3.3 - KDE 3.5
• Krusader 1.70.x: prefers KDE >= 3.4 (otherwise all features will not be available)
• Krusader 1.80.0: KDE 3.4 - KDE 3.5
• Krusader 1.90.0: KDE 3.2 - KDE 3.5
• Krusader v2.4.x: KDE 4.x
• Krusader v2.5.x: KDE Frameworks 5

Platforms:

• All POSIX (Linux® / BSD/UNIX®-like OSes), Solaris™
• All BSD Platforms (FreeBSD®/NetBSD®/OpenBSD®/Mac® OS)

In order to handle archives, checksums and other utilities they must be configured in our configuration tool. When running Krusader for the first time the available utilities will be autodetected, and a report will be shown in the first launch wizard. Afterwards additional utilities can be added/removed/changed.

A package of popular (un)packers, Krusader itself and add-ons can be found on the Krusader download page.

For more requirements, see below. Have a look at the FAQ section as well.

13.2 Obtaining Krusader

The latest information about Krusader can be found on the Krusader website.
13.2.1 Krusader Downloads

It is recommended to use the Krusader package that is provided by your distribution. Distrowatch.com is a great resource to check the availability. If your distribution does not offer Krusader, please contact the creators of your distribution and ask them to provide a Krusader package.

The latest version, as well as the older versions, can be found on the Krusader download page (current version) and on the Sourceforge mirrors (outdated versions). It contains the source tarballs, RPM and DEB packages to whatever distro the Krusader-Krew is using and packages build by Krusader users and third parties.

Distributions who provide Krusader:

- SuSE
- Fedora via `%dnf install krusader` will do the job.
- Debian, on our Krusader download page you might find more recent DEB packages. Note: usually Debian® packages work also on distributions that are “based on Debian®”, and some of these provide their own (incompatible) packages. Ubuntu / Kubuntu, Knoppix® 4.x DVD, Kanotix®, etc.
- Mageia via the contrib repository `%urpmi krusader` will do the job.
- Gentoo.
- Arch Linux, Frugalware Linux, PCLinuxOS®, ALT Linux.
- FreeBSD, the port was maintained by Heiner Eichmann.
- NetBSD, Lunar Linux, ,Ark Linux®, OpenLX™.
- More distributions can be found with Distrowatch.com.

Use the installation tools included in your distro to install the Krusader package. You might need an internet connection if Krusader is not included on the CD or DVD. There are probably other distributions which include Krusader. If you know of one, please send feedback so that we can include it on the distrolist.

Others

- Slackware® txz binaries can usually be found in the Slackware package repositories.
- There is a Mac® OS-X port.

Search engines

- You can also find packages on Linux® software archives such as freshmeat.net.
- If you can not find a package for your distribution, we recommend searching for it with `rpmfind`, `rpmdbone` or `rpmseek`.

If you enjoy using Krusader, we would appreciate it if you went to one of these sites and rated it.
If you still can not find a package, follow the installation procedure on how to compile Krusader from source. This very thorough HowTo describes the process in such detail that even newcomers should not have any problems.
13.2.2 Version Scheme

A new version scheme has been used since Krusader-1.60.0

- First digit - the major version
- Second digit(s) - percentage of features completed for this major version
- Third digit(s) - bugfixes.

In essence, releasing Krusader-1.60.0 means that we believe that Krusader is about 60% done with all the features we had scheduled for the 1.x.x series. Series up to 2.4.x are KDE 4.x releases. 2.5.x series are the releases for KDE Frameworks 5. Hopefully, it is easy to understand.

13.2.3 Stable Version

krusader-x.xx.tar.gz

NOTE
Krusader is released under the GNU General Public License (GPL). This means that THE PROGRAM IS PROVIDED "AS IS" WITH NO WARRANTY OF ANY KIND, even when it is marked as a stable release.

13.2.4 Development Version (beta release)

krusader-x.xx-betax.tar.gz

Before every stable release we release at least one development version in order to hunt down the bugs.

WARNING
These releases are beta releases and will probably contain some bugs.

NOTE
If you are using a development or Git version, it is possible that the latest new features are not yet in the "The Krusader Handbook". Please read the Changelog file online or in the Krusader sources to find out more about the new features. For a brief description, please read the NEWS file online or in the Krusader sources. User feedback and Bug reports are always welcome!

The beta release has 3 goals:

- Apply a feature-freeze until the stable is released, only bugs will be fixed. New features have to wait until the stable is released.
- Obtain feedback from Krusader users so that we can fix the bugs.
- Give translators time to update the translations for the coming stable release.

13.2.5 Git

Git is used for our sourcecode repository. It is also possible to Browse the Git Repository.

To check out the latest development Krusader 2.x for KDE Frameworks 5 from Git:

`$ git clone git://anongit.kde.org/krusader`
13.2.6 Older Releases

If you are looking for older releases we recommend the Sourceforge mirrors, available from our project page.

13.3 Krusader installation instructions

**NOTE**
Please read the INSTALL file of the Krusader sources, it contains all latest installation instructions.

**NOTE**
From version Krusader-2.5.0 and higher is KDE Frameworks 5 only.

`krusader_version.tar.gz` is the supposed name of the krusader tarball (it will be probably a different one ;)

You can download the latest available Krusader-2.x from Git.

13.3.1 Krusader dependencies

The next packages are needed to run the Krusader binary.

- c libraries
- plasma-framework libraries (KDE Frameworks core libraries and binaries for KDE Frameworks 5 applications)
- libqt5dbus5 (Qt™ 5 D-Bus module)
- libqt5xml5 (Qt™ 5 XML module)
- libqt5core5 (Qt™ 5 core module)
- libqt5gui5 (Qt™ 5 GUI module)
- libqt5printsupport5 (Qt™ 5 print support module)

13.3.2 Suggested packages

These packages are optional but they will make Krusader much more powerful and useful. The next packages are the names that Debian/Ubuntu uses, other Linux distros will probably use similar names.

- arj: archiver for .arj files
- ark: graphical archiving tool by KDE
- bzip2: high-quality block-sorting file compressor - utilities
- cpio: GNU cpio -- a program to manage archives of files
- kdiff3: compares and merges 2 or 3 files or directories
• OR kompare: a KDE GUI for viewing differences between files
• OR xxdiff: a graphical file and directories comparison and merge tool
• kmail: KDE Email client
• okteta: KDE hex editor
• konsole: X terminal emulator by KDE
• krename: Powerful batch renamer by KDE
• lha: lz archiver
• md5deep: versatile file checksum creator and verifier
• cfv: versatile file checksum creator and verifier
• p7zip: 7zr file archiver with high compression ratio
• rpm: Red Hat package manager
• unace: extract, test and view .ace archives
• unrar: Unarchiver for .rar files (non-free version)
• OR unrar-free: Unarchiver for .rar files
• OR rar: Archiver for .rar files
• unzip: De-archiver for .zip files
• zip: Archiver for .zip files

13.3.3 Compilation requirements

The next packages are needed for compiling Krusader, if you only run a Krusader binary you do not need these packages.

• gcc (The GNU C compiler)
• g++ (The GNU C++ compiler)
• cmake (A cross-platform, open-source make system)
• zlib1g-dev: (library for implementing the deflate compression method found in gzip and PKZIP)
• gettext (contains msgfmt)
• plasma-framework-dev (installs many development libraries for KF5)
• kio-dev
• libkf5archive-dev
• libkf5parts-dev
• libkf5wallet-dev
• libkf5xmgui-dev
• kdoctools-dev
13.4 Installing on Linux® and BSD™ platforms

NOTE
Please read the INSTALL file of the Krusader sources, it contains all latest installation instructions.

-DQT_INCLUDES=/usr/share/qt5/include is the location of the Qt™ 5 includes
-DCMAKE_INSTALL_PREFIX=/usr/ is the location where Krusader will be installed with the make command.
Another example is: -DCMAKE_INSTALL_PREFIX=/opt/krusader to install the compiled Krusader in an other directory to not overwrite the Krusader version installed by your package manager.

NOTE
Please use sudo instead of su -c if you are using Ubuntu-based systems.

$ tar -xzvf krusader-2.5.0.tar.gz
$ cd krusader
$ mkdir build
$ cd build
$ cmake -DCMAKE_INSTALL_PREFIX=/usr/ -DQT_INCLUDES=/usr/share/qt5/ include ..
$ make
$ su -c "make install"

Uninstall

$ su -c "make uninstall"

13.5 Installing on the Mac® OS-X platform

NOTE
Please read the INSTALL file of the Krusader sources, it contains all latest installation instructions.

With KDE-4 Krusader runs natively on Mac® OS-X, using its Aqua user interface (No more X11 needed!).
With the help of macports.org, Krusader is ported to Mac® OS-X, the port was maintained by Jonas Bähr. A portfile is provided.

$ sudo port install krusader

13.6 Starting Krusader

Type krusader (lower case) at a command prompt. You can create shortcut on your desktop or create an entry in the menu. Read the previous page and the FAQ if Krusader does not start.
When Krusader is started from the command line, various options can be specified to modify its behavior.
You can also use `Alt+F2` to open the Run Command dialog box, type `krusader` (lower case) and press `Enter` or click on the `Run` button.

If Krusader is installed by an RPM or DEB package then usually Krusader can be started from the K menu. Click on the application launcher button and choose `Applications → Utilities → Krusader`.

**COMMAND-LINE OPTIONS:**

- `--left <path>`
  start left panel at `<path>`

- `--right <path>`
  start right panel at `<path>`

- `--left <path1>,<path2>,<path3>`
  start left panel at `<path1>,<path2>,<path3>`, with tabs.

- `--profile <panel-profile>`
  load a panel-profile on startup (this overrides the default startup profile).

**Examples:**

```
$ krusader --left=<path> --right=<path>

$ krusader --left=/mnt/cdrom --right=ftp://downloads@myserver.net

$ krusader --left=<path1>,<path2> --right=<path1>,<path2>,<path3>

$ krusader --profile <panel-profile>

$ krusader --profile ftp-management
```

The standard Qt™ and KF5 command-line options are available.

**OTHER COMMAND-LINE OPTIONS:**

- `--author`
  Show the authors names

- `--license`
  Show license information

## 13.7 Configuring Krusader

When you run Krusader for the first time, the Krusader configuration module Konfigurator will show up and allow you to configure Krusader as well as detect installed packers and tools. You can always run Konfigurator again from the Settings menu.
13.8 Making Krusader the default file manager

To make Krusader the default file manager in Gnome, click here for more information.
To make Krusader the default file manager in Plasma, click here for more information.
Appendix A

Configuration Files

This appendix gives an overview of the configuration files used by Krusader.

**krusaderui.rc**
This file stores the users toolbar settings and the menu structure. Tip: read also the `krusaderui.rc FAQ`.

Location: `/usr/share/kxmlgui5/krusader/krusaderui.rc`, or `~/.local/share/kxmlgui5/krusader/krusaderui.rc`, or `kxmlgui5/krusader/krusaderui.rc` in the directory which can be determined using the `qtpaths --paths GenericDataLocation` command

**krusaderrc**
This file stores the Krusader configuration.

Location: `~/.config/krusaderrc`

The following settings are e.g. stored:

- Actions Toolbar
- Archives
- Colors
- Dependencies
- DiskUsage
- DiskUsageViewer
- General
- HTML Settings
- KFileDialog
- KFileDialog Speedbar
- KrDetailedViewLeft
- KrDetailedViewRight
- KrViewerWindow
- KrViewerWindow Toolbar extraToolBar
- Look & Feel
- Notification Messages
The Krusader Handbook

- Panel Profiles
- Private
- Protocols
- Search
- Startup
- Synchronize
- Locate
- SynchronizerProfile - 1

krbookmarks.xml
This file stores the Krusader bookmarks and uses the XBEL standard.
Location: ~/.local/share/krusader/krbookmarks.xml or krusader/krbookmarks.xml in the directory which can be determined using the qtpaths --paths GenericDataLocation command

useractions.xml
This file stores the UserActions configuration.
Location: ~/.local/share/krusader/useractions.xml or krusader/useractions.xml in the directory which can be determined using the qtpaths --paths GenericDataLocation command

useraction-examples.xml
This is the default UserActions provided by developers.
Location: $KDEDIR/share/krusader/useraction-examples.xml

foo.keymap
This is a .ini file that holds a Key binding profile. Until Krusader-1.70.0 this was a binary file. Krusader is backwards compatible for importing this legacy binary format.
Location: /usr/share/krusader/foo.keymap

foo.color
This is a binary file that holds the Color Scheme.
Location: /usr/share/krusader/foo.color
Appendix B

useractions.xml

This appendix gives several examples of useractions.xml files. With this you can begin to discover the power of the UserActions and start learning how to use them. Once you understand how to write UserActions you will find that Krusader is an even more powerful, customizable tool.

Please consider uploading your UserActions at store.kde.org as we are collecting them. If your UserAction is selected by us it will be shipped with Krusader at the next release.

• Runs uptime

```xml
<!DOCTYPE KrusaderUserActions>
<KrusaderUserActions>
  <action name="uptime">
    <title>Uptime</title>
    <tooltip>Tells how long since the computer has been booted</tooltip>
    <icon>clock</icon>
    <category>Information</category>
    <description same_as="tooltip"/>
    <command executionmode="collect_output">uptime</command>
    <defaultshortcut>Alt+Ctrl+U</defaultshortcut>
  </action>
</KrusaderUserActions>
```

• Runs ls -l

```xml
<!DOCTYPE KrusaderUserActions>
<KrusaderUserActions>
  <action name="ls -l">
    <title>ls -l in current dir</title>
    <description same_as="tooltip"/>
    <command executionmode="collect_output">ls -l %aPath% %oPath%</command>
    <defaultshortcut>Alt+Shift+L</defaultshortcut>
  </action>
</KrusaderUserActions>
```

• Echo Placeholder

```xml
<!DOCTYPE KrusaderUserActions>
<KrusaderUserActions>
  <action name="test_placeholder">
    <title>Echo Placeholder</title>
    <tooltip>Echo’s the placeholder values</tooltip>
  </action>
</KrusaderUserActions>
```
The Krusader Handbook

• This useraction copies current path and filename to clipboard:

```xml
<DOCTYPE KrusaderUserActions>
<KrusaderUserActions>
  <action name="clipboard current" >
    <title>Copy to Clipboard</title>
    <tooltip>Copy to clipboard</tooltip>
    <icon>klipper</icon>
    <category>System</category>
    <description>Copy current path and filename to clipboard</description>
    <command>%_Clipboard("%aCurrent%")%</command>
  </action>
</KrusaderUserActions>
```

• Selects .diff and *.h in the active panel:

```xml
<DOCTYPE KrusaderUserActions>
<KrusaderUserActions>
  <action name="test select" >
    <title>Add selection *.diff and *.h</title>
    <category>Selection</category>
    <command>%aSelect("*. diff", "add")% %aSelect("*.h", "add")%</command>
  </action>
</KrusaderUserActions>
```

• Active panel changes to mnt/floppy (bookmark):

```xml
<DOCTYPE KrusaderUserActions>
<KrusaderUserActions>
  <action name="mnt/ floppy bookmark" >
    <title>Jump to /mnt/floppy</title>
    <category>Bookmarks</category>
    <command>%aGoto("/mnt/floppy", "yes")%</command>
  </action>
</KrusaderUserActions>
```

• Select in the non-active panel, all filenames that are highlighted in the active panel:

```xml
<DOCTYPE KrusaderUserActions>
<KrusaderUserActions>
  <action name="asdfasdf" >
    <title>Select in Other Panel</title>
    <category>Selection</category>
    <description>Select all filenames that are selected in the active panel also in the non-active panel</description>
    <command>%oSelect("%aList("selected", " ", "Yes")%")%</command>
  </action>
</KrusaderUserActions>
```
The Krusader Handbook

• Make a backup of the current file/folder to foo.bak into the current directory:

```xml
<!DOCTYPE KrusaderUserActions>
<KrusaderUserActions>
  <action name="backup current">
    <title>Backup in Current Directory</title>
    <tooltip>Backup in current directory</tooltip>
    <icon>document-save-as</icon>
    <category>System</category>
    <description same_as="tooltip"/>
    <command>%_Copy("%aCurrent%", "%_Ask("new name", "%aCurrent%. bak")%")</command>
    <defaultshortcut>Shift+F5</defaultshortcut>
  </action>
</KrusaderUserActions>
```

• Opens KruSearcher:

```xml
<!DOCTYPE KrusaderUserActions>
<KrusaderUserActions>
  <action name="search">
    <title>Search Test</title>
    <command>%_NewSearch("Search 2")%</command>
  </action>
</KrusaderUserActions>
```

• Sets the selected picture as wallpaper:

```xml
<!DOCTYPE KrusaderUserActions>
<KrusaderUserActions>
  <action name="set wallpaper">
    <title>Set as Wallpaper</title>
    <tooltip>Set as wallpaper</tooltip>
    <icon>image</icon>
    <category>Service Menu</category>
    <description>Set as wallpaper (scaled)</description>
    <command>dcop kdesktop KBackgroundIface setWallpaper "%aCurrent%" 6</command>
    <defaultshortcut>Win+W</defaultshortcut>
  </action>
</KrusaderUserActions>
```

• This useraction edits a file with root permissions using kdesu:

```xml
<!DOCTYPE KrusaderUserActions>
<KrusaderUserActions>
  <action name="edit as root">
    <title>Edit as Root</title>
    <tooltip>Edit as root</tooltip>
    <icon>kwrite</icon>
    <category>System</category>
    <description>Edit a file with root permissions using kdesu</description>
    <command>kdesu kwrite %aCurrent%</command>
    <defaultshortcut>Win+F4</defaultshortcut>
  </action>
</KrusaderUserActions>
```
The Krusader Handbook

• This useraction Add item(s) to Amarok playlist:

```xml
<DOCTYPE KrusaderUserActions>
<KrusaderUserActions>
  <action name="amarok enqueue">
    <title>Enqueue in Amarok</title>
    <tooltip>Append selected item(s) to Amarok playlist</tooltip>
    <icon>amarok</icon>
    <category>Multimedia</category>
    <command>amarok --append %aList("Selected")%</command>
    <defaultshortcut>Win+A</defaultshortcut>
  </action>
</KrusaderUserActions>
```

• Opens Synchronizer:

```xml
<DOCTYPE KrusaderUserActions>
<KrusaderUserActions>
  <action name="synchronizer">
    <title>Synchronizer</title>
    <command>\_Sync("Sync 2")%</command>
  </action>
</KrusaderUserActions>
```
Appendix C

Release overview

This appendix gives an overview of the Krusader releases.

<table>
<thead>
<tr>
<th>Krusader version</th>
<th>release date</th>
<th>KDE version</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.7.2 “Peace of Mind”</td>
<td>2019-08-25</td>
<td>KDE Frameworks 5</td>
</tr>
<tr>
<td>2.7.1 “Peace of Mind”</td>
<td>2018-08-12</td>
<td>KDE Frameworks 5</td>
</tr>
<tr>
<td>2.7.0 “Peace of Mind”</td>
<td>2018-05-13</td>
<td>KDE Frameworks 5</td>
</tr>
<tr>
<td>2.6.0 “Stiff Challenges”</td>
<td>2017-04-12</td>
<td>KDE Frameworks 5</td>
</tr>
<tr>
<td>2.5.0 “Clear Skies”</td>
<td>2016-10-22</td>
<td>KDE Frameworks 5</td>
</tr>
<tr>
<td>2.4.0-beta1 “Migration”</td>
<td>2011-06-26</td>
<td>KDE 4.0 - 4.6</td>
</tr>
<tr>
<td>2.3.0-beta1 “New Horizons”</td>
<td>2010-12-25</td>
<td>KDE 4.0 - 4.5</td>
</tr>
<tr>
<td>2.2.0-beta1 “DeKade”</td>
<td>2010-04-30</td>
<td>KDE 4.0 - 4.4</td>
</tr>
<tr>
<td>2.1.0-beta1 “Rusty Clutch”</td>
<td>2009-10-31</td>
<td>KDE 4.0 - 4.3</td>
</tr>
<tr>
<td>2.0.0 “Mars Pathfinder”</td>
<td>2009-04-11</td>
<td>KDE 4.0 - 4.2</td>
</tr>
<tr>
<td>2.0.0-beta2 “Space Odyssey”</td>
<td>2008-12-27</td>
<td>KDE 4.0 - 4.2</td>
</tr>
<tr>
<td>2.0.0-beta1 “Phoenix Egg”</td>
<td>2008-06-07</td>
<td>KDE 4.0 - 4.1</td>
</tr>
<tr>
<td>1.90.0 “Power Stone”</td>
<td>2008-03-15</td>
<td>KDE 3.2 - 3.5</td>
</tr>
<tr>
<td>1.80.0 “Final 3rd Stone”</td>
<td>2007-07-21</td>
<td>KDE 3.4 - 3.5</td>
</tr>
<tr>
<td>1.80.0-beta2 “Last Unstable Stone”</td>
<td>2007-03-31</td>
<td>KDE 3.4 - 3.5</td>
</tr>
<tr>
<td>1.80.0-beta1 “The Last Crusade”</td>
<td>2007-01-07</td>
<td>KDE 3.4 - 3.5</td>
</tr>
<tr>
<td>1.70.1 “Round Robin”</td>
<td>2006-07-17</td>
<td>KDE 3.3 - 3.5</td>
</tr>
<tr>
<td>1.70.0 “Round Robin”</td>
<td>2006-02-12</td>
<td>KDE 3.3 - 3.5</td>
</tr>
<tr>
<td>1.70.0-beta2 “Afterburner”</td>
<td>2005-11-05</td>
<td>KDE 3.3 - 3.5</td>
</tr>
<tr>
<td>1.70.0-beta1 “Hellfire”</td>
<td>2005-10-02</td>
<td>KDE 3.3 - 3.5</td>
</tr>
<tr>
<td>1.60.1</td>
<td>2005-10-30</td>
<td>KDE 3.3 - 3.4</td>
</tr>
<tr>
<td>1.60.0</td>
<td>2005-04-10</td>
<td>KDE 3.3 - 3.4</td>
</tr>
<tr>
<td>1.60.0-beta2</td>
<td>2005-03-21</td>
<td>KDE 3.3 - 3.4</td>
</tr>
<tr>
<td>1.60.0-beta1</td>
<td>2005-03-03</td>
<td>KDE 3.3 - 3.4</td>
</tr>
<tr>
<td>1.51</td>
<td>2004-12-14</td>
<td>KDE 3.2 - 3.3</td>
</tr>
<tr>
<td>1.50</td>
<td>2004-10-31</td>
<td>KDE 3.2 - 3.3</td>
</tr>
<tr>
<td>1.50-beta1</td>
<td>2004-10-17</td>
<td>KDE 3.2 - 3.3</td>
</tr>
<tr>
<td>1.40</td>
<td>2004-07-20</td>
<td>KDE 3.2</td>
</tr>
<tr>
<td>Version</td>
<td>Date</td>
<td>Environment</td>
</tr>
<tr>
<td>--------------</td>
<td>--------------</td>
<td>-----------------</td>
</tr>
<tr>
<td>1.40-beta2</td>
<td>2004-06-22</td>
<td>KDE 3.2</td>
</tr>
<tr>
<td>1.40-beta1</td>
<td>2004-04-11</td>
<td>KDE 3.2</td>
</tr>
<tr>
<td>1.30</td>
<td>2003-11-14</td>
<td>KDE 3.0 - 3.2</td>
</tr>
<tr>
<td>1.29-beta1</td>
<td>2003-10-02</td>
<td>KDE 3.0 - 3.2</td>
</tr>
<tr>
<td>1.25-beta1</td>
<td>2003-08-15</td>
<td>KDE 3.0 - 3.2</td>
</tr>
<tr>
<td>1.21-beta1</td>
<td>2003-07-18</td>
<td>KDE 3.0 - 3.2</td>
</tr>
<tr>
<td>1.20</td>
<td>2003-05-31</td>
<td>KDE 3.0 - 3.2</td>
</tr>
<tr>
<td>1.12-beta2</td>
<td>2003-05-09</td>
<td>KDE 3.0 - 3.2</td>
</tr>
<tr>
<td>1.12-beta1</td>
<td>2002-12-23</td>
<td>KDE 3.0 - 3.2</td>
</tr>
<tr>
<td>1.11</td>
<td>2002-10-17</td>
<td>KDE 3.0 - 3.2</td>
</tr>
<tr>
<td>1.10</td>
<td>2002-08-15</td>
<td>KDE 2</td>
</tr>
<tr>
<td>1.02</td>
<td>2002-04-16</td>
<td>KDE 3</td>
</tr>
<tr>
<td>1.01</td>
<td>2002-04-01</td>
<td>KDE 2</td>
</tr>
<tr>
<td>1.00</td>
<td>2002-01-01</td>
<td>KDE 2</td>
</tr>
<tr>
<td>0.99</td>
<td>2001-12-01</td>
<td>KDE 2</td>
</tr>
<tr>
<td>0.98</td>
<td>2001-10-27</td>
<td>KDE 2</td>
</tr>
<tr>
<td>0.97</td>
<td>2001-10-08</td>
<td>KDE 2</td>
</tr>
<tr>
<td>0.95</td>
<td>2001-07-22</td>
<td>KDE 2</td>
</tr>
<tr>
<td>0.93</td>
<td>2001-05-31</td>
<td>KDE 2</td>
</tr>
<tr>
<td>0.92</td>
<td>2001-05-17</td>
<td>KDE 2</td>
</tr>
<tr>
<td>0.91</td>
<td>2001-05-10</td>
<td>KDE 2</td>
</tr>
<tr>
<td>0.90</td>
<td>2001-04-30</td>
<td>KDE 2</td>
</tr>
<tr>
<td>0.79</td>
<td>2001-02-25</td>
<td>KDE 2</td>
</tr>
<tr>
<td>0.75</td>
<td>2000-01-12</td>
<td>KDE 2</td>
</tr>
<tr>
<td>0.70</td>
<td>2000-11-07</td>
<td>KDE 2</td>
</tr>
<tr>
<td>0.69</td>
<td>2000-10-28</td>
<td>KDE 2</td>
</tr>
<tr>
<td>0.65</td>
<td>2000-08-19</td>
<td>KDE 2</td>
</tr>
<tr>
<td>0.60</td>
<td>2000-07-19</td>
<td>KDE 2</td>
</tr>
<tr>
<td>M2</td>
<td>2000-07-11</td>
<td>KDE 2</td>
</tr>
<tr>
<td>MI</td>
<td>2000-05-??</td>
<td>KDE 2 (Kleopatra 1.91)</td>
</tr>
<tr>
<td>Project began</td>
<td>2000-04-30</td>
<td>Kleopatra 1.91</td>
</tr>
</tbody>
</table>

Table C.1: Release overview

Note: older 0.x beta releases are not included in this table.
Appendix D

Glossary

This chapter is intended to explain the various words which have been used throughout the Krusader documentation. If you believe some acronyms or terms are missing, please do not hesitate to contact the Krusader documentation team.

Thanks to wikipedia.org the free encyclopedia that anyone can edit.

ACL
Access Control List; a concept in computer security used to enforce privilege separation. It is a means of determining the appropriate access rights to a given object depending on certain aspects of the process that is making the request.

BSD
Berkeley Software Distribution; refers to any of several free UNIX®-compatible operating systems, derived from BSD™ UNIX®.

CVS
Concurrent Versions System; an important component of Source Configuration Management (SCM). By using it, developers can record the history of source files and documents.

DEB
This is a binary file format that is used by Debian and Debian®-based distributions. It is a suffix of a installation file specifically built for these distributions; e.g. krusader_1.70.1-1_amd64.deb. Simply described it is a special archive containing all the program files and their proposed location on the system.

D-Bus
D-Bus is an inter-service messaging system. Developed by Red Hat®, it was heavily influenced by KDE 3 DCOP, which it supersedes. Krusader can use D-Bus to communicate with other applications. On the other hand, you can use D-Bus to control Krusader from other applications. Just use qdbusviewer to examine the possibilities.

DCOP
Desktop Communication Protocol; the interprocess communication protocol used by KDE 3 desktop environment. It enables various KDE 3 applications to communicate with each other. Replaced with D-Bus in KDE 4.

FAQ
Frequently Asked Questions; a document where questions that arise many times are answered. If you have a question to the developers of Krusader, you should always have a look at the FAQ first.
FTP
File Transfer Protocol; it is an Internet protocol that allows you to retrieve files from so-called FTP servers.

Git
Git; a distributed version control system that replaces Subversion. It is used by many software projects including KDE and Krusader.

GPL
GNU General Public License; a software license created by the Free Software Foundation defining the terms for releasing free software.

GUI
Graphical User Interface.

ISO
An ISO image (.iso) is an informal term for a disk image of an ISO 9660 file system. More loosely, it refers to any optical disk image, even a UDF image.

KDE
K Desktop Environment; a project to develop a free graphical desktop environment for UNIX® compatible systems.

Key Binding
All features of Krusader are available through the menubar, but you can also bind (link) a certain key combination to that function. You will find, however, that using the keyboard is remarkably faster than using the menubar or GUI. Keyboard usage is an important tool for Orthodox File Managers. Krusader comes with several predefined Key Bindings.

KPart
KPart; KParts is the name of the component framework for the KDE desktop environment. KParts are analogous to Bonobo components in GNOME, both of which are based on the same concepts as Microsoft®’s Object Linking and Embedding, e.g. if you use Krusader’s viewer to view a PDF file, Okular will be launched inside Krusader’s viewer.

KIO or kioslave
KDE Input/Output; also known as KIO Slaves is part of the KDE architecture. It provides access to files, web sites and other resources through a single consistent API.

mount
Mounting; in computer science, is the process of making a file system ready for use by the operating system, typically by reading certain index data structures from storage into memory ahead of time. The term recalls a period in the history of computing when an operator had to mount a magnetic tape or hard disk on a spindle before using it.

OFM
Orthodox File Manager; also known as “Commanders”. Members of this family of file managers use simple yet very powerful interface that is a direct derivative of the Norton Commander (NC) interface.

RPM
This is the binary file format for distributions based on the RPM Package Manager, a widely used packaging tool for the Linux® operating system. If you still have to get Krusader and your system supports RPM packages, you should get Krusader packages ending in .rpm.

SSH, Secure Shell
SSH; is a set of standards and an associated network protocol that allows establishing a secure channel between a local and a remote computer.
SVN, Subversion
Subversion; a version control system that is a compelling replacement for CVS. It is used by many software projects including KDE.

Terminal emulator
Terminal emulator; simply a windowed shell; this is known as command line window in some other environments. If you want to use the shell and type the commands, you should know at least a few of the system-level commands for your operating system.

POSIX
Portable Operating System Interface for uniX; a collective name of a family of related standards specified by the IEEE to define the application programming interface (API) for software compatible with variants of the UNIX® operating system.

URL
Universal Resource Locator; a universal resource locator is the technical term for what is commonly referred to as a website address. Examples of URLs include https://krusader.org and Remote Connections.

VFS
Virtual file systems (VFS) is a basic OFM feature, this an abstracted layer over all kinds of archived information (ZIP files, FTP servers, TAR archives, NFS filesystems, SAMBA shares, ISO CD/DVD images, RPM catalogs, etc.), which allows the user to access all the information in these divergent types of file systems transparently - just like entering an ordinary sub-directory! Krusader supports several Virtual file systems (VFS).

XML
Extensible Markup Language; a very flexible text format derived from SGML (ISO 8879). Originally designed to meet the challenges of large-scale electronic publishing, XML is also playing an increasingly important role in the exchange of a wide variety of data on the Web and elsewhere.

Zeroconf
Zeroconf; or Zero Configuration Networking is a set of techniques that automatically create a usable IP network without configuration or special servers. This allows inexpert users to connect computers, networked printers, and other items together and expect them to work automatically.
Appendix E

Index

A
Archives, 34

B
Bookmarks, 56

C
Checksum, 38
Commands
Keyboard, 49
Menu, 40
Mouse, 55
Compare
Content, 37
Directories, 37
Configuration files, 129
Configure
Krusader, 96
Shortcuts, 47
Credits, 119

D
Disk Usage, 59

E
Editor, 65

F
FAQ, 109
Features, 17
File Splitter, 38

G
Glossary, 137

H
Help, 11

I
Installation, 121
Introduction, 14

K
Key-Bindings, 49

L
License, 119
Locate, 82

M
Mount, 82

O
Occupied Space, 38

P
Panel
List Panel, 24
Popular URLs, 58
Profiles, 39

R
Release overview, 135
Remote Connections, 83
Remote LAN Connections (zeroconf), 85

S
Search, 60
Sidebar
Sidebar (3rd Panel), 25
Synchronizer, 86

T
Toolbar
Actions Toolbar, 23
Job Toolbar, 23
Location Toolbar, 23
Main Toolbar, 21
Panel Toolbar, 23

U
User Interface, 21
UserActions, 91

V
VFS, 36
Viewer, see Editor