# Contents

1 Introduction .............................................. 6

2 Using Konversation ....................................... 7
   2.1 If you haven’t used IRC before....................... 7
   2.2 Setting your identity ................................ 9
   2.3 Defining new networks, servers and auto join channels 11
   2.4 Listing available channels ......................... 14
   2.5 A tour of the main screen ......................... 15
   2.6 Quick Connect ....................................... 18
   2.7 Frequently-used IRC commands ................... 18
   2.8 Private conversations (queries) ................. 19
   2.9 Setting notifications ............................... 20
   2.10 Monitoring who is online ......................... 20
   2.11 Message highlighting ............................. 22
   2.12 Configuring On Screen Display (OSD) ......... 23
   2.13 Sending colorful messages ...................... 24
   2.14 Configuring nickname themes .................... 25
   2.15 Configuring Quick Buttons ...................... 26
   2.16 Sending and receiving files ..................... 26
   2.17 Capturing URLs from messages ................. 28
   2.18 Setting your preferred web browser ............ 29
   2.19 Marking Channel and Query Logs ............... 30
   2.20 Logging ............................................ 30
   2.21 Konversation commands ......................... 31
   2.22 Scripting ......................................... 34
   2.23 Script Reference Guide ........................... 35

3 Command Reference ..................................... 37
   3.1 The main Konversation window ................. 37
      3.1.1 The File Menu ................................ 37
      3.1.2 The Edit Menu ................................ 37
      3.1.3 The Insert Menu .............................. 38
      3.1.4 The Bookmarks Menu ....................... 38
      3.1.5 The Settings Menu ......................... 38
      3.1.6 The Window Menu ........................... 38
      3.1.7 The Help Menu ................................ 39
Abstract

Konversation is a user-friendly IRC client built on Qt™ and KDE Frameworks 5.
Chapter 1

Introduction

Konversation is an IRC client built on Qt™ and KDE Frameworks 5. It offers the following features:

- SSL support.
- User-friendly tabbed interface.
- Customizable Quick Buttons for often-used commands.
- Automatic reconnect and rejoin.
- DCC send and receive.
- Nickname watch list.
- Visual and auditory notifications for a wide variety of events, such as messages containing your nickname, or nicknames on your watch list going online or offline.
- Customizable highlighting of messages by nickname or regular expression pattern.
- Nickname completion.
- Capture and save all URLs appearing in messages.
- On-screen display of messages, even when minimized.
- Nickname ignore list.
- Automatic logging and log management.
- Marking of lines in logs.
- Scripting.

The Konversation website is https://konversation.kde.org. Further information like a FAQ and tips and tricks you find in the Konversation UserBase page.

Developers for Konversation can often be contacted via IRC at irc.libera.chat channel #konversation.
Chapter 2

Using Konversation

2.1 If you haven’t used IRC before...

Simply put, IRC is a chat protocol, defined by official Internet standards, and capable of stealing many hours of your life. To use IRC, you must connect to a server, and then join a channel (equivalent to a chat room) or just engage in private conversations.

To connect to a server and channel, open Konversation. The Server List screen appears.

1. The list of configured IRC Networks are listed here. An IRC network is a collection of cooperating servers. You need only connect to one of the servers in the network to be connected to the entire IRC network. Once connected, Konversation will automatically join the Channels shown. When Konversation is started for the first time, the Libera network and #kde channel are already entered for you. Click on a network to select it.

2. Click here to define a new Network, including the server to connect to, and the Channels to automatically join once connected. See Defining new networks, servers, and auto join channels for more information.

3. Click here to connect to the selected IRC network and channel.
NOTE
When you click the Connect button the first time you open Konversation, you may see the following message, telling you that your default identity is not set up correctly.

The first time you open Konversation it obtains information about the current user from the operating system and fills in defaults for the Identity. If the operating system user information is not complete, for example, no Full Name is defined, you may see the message above. To correct this problem, click Edit Identity... and see Setting your identity for more information.

The Main screen will be displayed showing the messages sent by the server to the client. (If Konversation will not connect to the server, see Questions and Answers.) When the server messages have finished scrolling past, Konversation will join the channel or channels chosen.

This is called the Input Line. To send a message to everyone in the channel, type the message here and press Enter. Your message, as well as everyone else's messages appear in the channel scroll above. Each message is preceded by the time and user's nickname.

You may join additional servers and channels. Each server, channel, channel list, and other screen gets a separate tab here. To display a list of available channels, see Listing available
channels. To join a channel, type: /join #channelname in the Input Line. (The # is required.) You may also type /j as a shorthand to /join. To leave a channel, just type /part. To switch the display to a different server or channel, click the corresponding tab.

This is called the Nick Panel. It lists the nicknames of all the users who have joined the channel, including yourself.

That’s the basics, for more detailed information, read on...

### 2.2 Setting your identity

Before you start using Konversation regularly, you should set how you will be identified on the network.

Click Settings → Identities on the main menu. The Identities screen will appear. You can also display the Identities screen by clicking the Edit button on the Edit Network or New Network screen.

1. Click here to select an Identity to edit.
2. Use these buttons to Add, Duplicate, Rename, or Remove an Identity.
3. Enter your real name here. IRC is not intended to keep you hidden from your friends or enemies. Keep this in mind if you are tempted to behave maliciously. A fake “real name” can be a good way to mask your gender from all the nerds out there, but the PC you use can always be traced so you will never be truly anonymous.
4. Use these buttons to Add or Remove a nickname.
5. This is your list of nicknames. A nickname is the name that other users will know you by. You may use any name you desire. The first character must be a letter. Other characters may be letters, numbers, or the special characters -[]"_{}|

Since nicknames must be unique across an entire IRC network, your desired name may be rejected by the server because someone else is already using that nickname. Enter alternate
nicknames for yourself. If your first choice is rejected by the server, Konversation will try
the alternate nicknames.
According to RFC 2812, the maximum nickname length is 9, but this is actually determined
by the server. To determine the maximum for a server, connect to the server. In the Server
Messages tab, look for a [Support] message. For example:

[18:51] *Eisfuchs* [21:45] [Support] Eisfuchs MODES=4 MAXCHANNELS=20 NICKLEN=16 USERLEN=10 HOSTLEN=63 TOPICLEN=450 KICKLEN=450 CHANNELLEN=30 KEYLEN=23 CHANTYPES=# PREFIX=8+ CASEMAPPING=ascii CAPAB IRCD=dancer

The NICKLEN parameter specifies the maximum nickname length.

1. Use these buttons to change the order of the nicknames. The top nickname is tried first,
then the next nickname, and so on.
2. If you have registered your nickname with the IRC network, enter the service and password
to authenticate your nickname. When Konversation connects, it will automatically send /msg service IDENTIFY password to the server. If you don’t know what this is, leave
these boxes blank.

Click the Away tab.

3. Enter a nickname that indicates you are away. Whenever you perform an /away msg
command in any channel joined with this Identity, Konversation will automatically change
your nickname to the Away nickname. Other users will be able to tell you are away from
your computer. Whenever you perform an /away command in any channel in which you
are away, Konversation will automatically change your nickname back to the original. If
you do not wish to automatically change your nickname when going away, leave blank.
4. If you check this box, whenever you perform an /away command, a horizontal line will
appear in the channel, marking the point where you went away. Other IRC users do not
see this horizontal line.
5. If you check this box, Konversation will automatically send the Away command to all chan-
nels joined with this Identity. %s is replaced with msg. Whenever you perform an /away
command, the Return command will be displayed in all channels joined with this Identity.
NOTE
Away messages are often considered annoying by other users. Use this option carefully, with consideration for your fellow IRC users.

Click the Advanced tab.

- You can enter a command here that will be executed before connecting to the server. If this identity is used for more than one server, the command will be executed for each server.
- This setting affects how characters you type are encoded for sending to the server. It also affects how messages are displayed. When you first open Konversation, it automatically retrieves this setting from the operating system. If you seem to be having trouble seeing other user’s messages correctly, try changing this setting.
- When you connect, many servers query your computer for an IDENT response. If your computer is not running an IDENT server, this response is sent by Konversation. No spaces are allowed. Your first name is suggested.
- Whenever you leave a channel, this message is sent to the channel.
- Whenever you are kicked from a channel (usually by an IRC operator), this message is sent to the channel.
- Click to apply your changes. In order for all the changes to take effect, you must disconnect from the server and re-connect. The easiest way to do that is to quit Konversation and restart.

2.3 Defining new networks, servers and auto join channels

The Server List screen appears when you open the Konversation program. It also appears when you choose File → Server List on the main menu. The Server List screen lists your existing defined IRC Networks, listed by group. An IRC network is a collection of cooperating servers.
When you connect to any server in a network, you have access to all the channels of the network. Examples of IRC networks are Libera and Undernet.

Your existing defined Networks are listed here along with the Identity used to connect to the network, and the Channels automatically joined when connected. If you have specified a group for your networks, networks are listed indented under the group. Click on a network to select it.

Use these buttons to Add a new network, Edit a highlighted network, or Delete a highlighted network.

Click this button to connect to the highlighted Network and close the Server List screen. You may highlight more than one network if you wish, which will connect to all the highlighted networks.

Clicking this button does not discard the changes you have made. It merely means you do not wish to connect to any networks at this time.

When you click the New button, the New Network screen appears.
Enter the **Network name** here. You may create as many entries in the **Server List** screen with the same **Network** as you like.

Choose an existing **Identity** or click the **Edit** button to add a new Identity or edit an existing one. The **Identity** will identify you and determine your nickname when you connect to the network.

Optional. This command will be sent to the server after connecting. Example: `/msg Nic kServ IDENTIFY konvirocks`. This example is for the Libera network, which requires users to register their nickname with a password and login when connecting. **konvirocks** is the password for the nickname given in **Identity**. You may enter more than one command by separating them with semicolons.

Check here if you want Konversation to automatically connect to this network whenever you open Konversation.

This is a list of IRC **Servers** in the network. When connecting to the network, Konversation will attempt to connect to the top server first. If this fails, it will attempt the second server. If this fails, it will attempt the third, and so on. At least one server must be specified. Click a server to highlight it.

Use these buttons to **Add** a server, **Edit** a highlighted server, or **Delete** a highlighted server. You can also adjust the order of the server list and therefore the order of connection attempts.

Optional. This is a list of the channels that will be automatically joined once Konversation has connected to a server. You may leave this blank if you wish to not automatically join any channels.

Use these buttons to **Add** a channel, **Edit** a highlighted channel, or **Delete** a highlighted channel. You may also change the order the channels are joined.

**NOTE**
Avoid mixing servers on different IRC networks under the same **Network**. Avoid entering the same server under two different **Networks**. Otherwise, monitoring of online nicknames will not function correctly.
When you click the **Add** button in the **Servers** frame, the **Add Server** screen appears.

![Add Server Screen]

1. The name or IP number of the server. irchelp.org maintains a list of servers.
2. Enter the port number required to connect to the server. For most servers, this should be **6667**.
3. If the server requires a password in order to connect, enter it here, otherwise leave blank.
4. Check if you want to use Secure Socket Layer (SSL) protocol to communicate with the server. This protects the privacy of your communications between your computer and the IRC server. The server must support SSL protocol for this to work. In most cases, if the server does not support SSL, the connection will fail.

When you click the **Add** button in the **Auto Join Channels** frame, the **Add Channel** screen appears.

![Add Channel Screen]

Enter a channel name. Do not forget leading #. If the channel requires a password in order to join, enter it, otherwise leave blank.

### 2.4 Listing available channels

To display a list of available channels, choose **Window → Channel List** on the main menu. After a warning screen, a new tab is created called the **Channel List**.
Enter a filter string here.

You can limit the channel list to those channels with a minimum or maximum number of users here. Choosing No Limit disables the respective criteria.

Click here to retrieve the list of channels from the server and apply the filter.

The filtered list of channels is displayed here. Notice that if you don’t use regular expressions, Konversation lists any channel whose name contains the filter string you entered. The channel name does not have to start with the string you entered.

Select a channel you want to join by clicking on it. Right click on the channel to get a list of all web addresses mentioned in the channel’s topic.

Click here to join the channel. A new tab is created for the channel.

Sometimes there are “secret” channels on servers. Such channels are not listed in the Channel List. You can still join these channels if you know their name. In any Input Line, type: /join #channelname. (The # is required.) A new tab is created for the channel. If you join a channel and the Nick Panel lists only your nickname, it means that the channel did not exist before. The server created the channel and you are the operator. In this case, you probably want to close the channel by typing: /part.

2.5 A tour of the main screen

Let’s learn more about the Main screen. The screen is shown below with a channel tab selected.
This is called the Input Line. It appears only when the current tab is a channel. To send a message to everyone in the channel, type the message here and press Enter. Your message, as well as everyone else’s messages appear in the channel scroll above. Each message is preceded by the time and user’s nickname.

You can also paste text from the clipboard. If the pasted text has more than one line (newlines), a dialog box appears. Edit the text as desired and click OK.

If the pasted text is longer than 256 characters, or it contains more than one line, a warning message appears advising you that large postings can cause connection resets and flooding. You can still proceed with the input, but doing so is a bad idea, as flooding will annoy other users in the channel, or you may be disconnected from the server. It is better to send the message in shorter chunks.

A convention used in many channels is to precede messages directed at one user with their nickname. Konversation provides a convenient nickname completion feature. Start typing the user’s nickname, then press Tab. Konversation will complete the rest of the user’s nickname followed by a colon. To customize the completion feature, choose Settings → Configure Konversation from the main menu, expand Behavior, click on General, and select a Completion mode.

You can also enter an IRC command here by first typing / followed by a valid IRC command. See Frequently-used IRC commands. On some servers, you can type /help for a list of available commands, or type /help command for help on a specific command.

You may join additional servers and channels. Each server and each channel gets a separate tab here. To display a list of available channels, see Listing available channels. To join a channel, type: /join #channelname in the Input Line. (The # is required.) To leave a channel, just type /part. Tabs also appear here if you open a Channel List, participate in a private conversation (query), open the URL Catcher, or open one or more Konsoles. To switch the display to a different screen, click the corresponding tab, or use the mouse wheel to cycle through the tabs.

To set other options for tabs, choose Settings → Configure Konversation from the main menu, expand Interface, click on Tabs or expand Notifications and click on Tabs.

These LEDs will blink when there is something you haven’t seen in that tab. The LED will blink slower when the only unseen messages are join, part, quit, or nickname changes. They blink faster if there are unseen regular messages. The colors are as follows:
The Konversation Handbook

- Channel
- Server Messages, Channel List, or URL catcher.
- Konsole or DCC Status.
- Private Message (Query).

1. Click here to close the current tab. Closing a Channel tab will leave the channel. Closing a Server Messages tab will leave all channels you’ve joined, close all open queries at that server and disconnect from the server.

2. Click this button to change your own nickname. It appears only when the current tab is a channel. To hide this button, choose Settings → Configure Konversation from the main menu, expand Interface, click on Chat Window, and uncheck Show box to change own nickname box.

3. The channel topic is displayed here. Hover the mouse over the topic to see long topics. You can change the topic by clicking the button to the left of the topic. To hide channel topics, choose Settings → Configure Konversation from the main menu, expand Interface, click on Chat Window, and uncheck the Show channel topic box.

4. These buttons display the current state of channel modes. A button is down if that mode is on. If you have the correct privileges, you can also change channel modes by clicking on these buttons, or click the button to the left of the topic. To hide channel mode buttons, choose Settings → Configure Konversation from the main menu, expand Interface, click on Chat Window, and uncheck the Show channel mode buttons box.

5. This is called the Nick Panel. It is displayed whenever the current tab is a channel. It lists the nicknames of all the users who have joined the channel, including yourself. Hover the mouse pointer over a nickname to display additional information about the user. You may change how the icons are displayed next to each nickname by changing the nickname icon theme. See Configuring nickname themes for more information. The Default Theme, as shown in the screen above, uses the following icons:

   - normal user
   - voiced user. User may talk in a moderated channel.
   - channel halfop
   - channel operator
   - channel owner
   - channel admin

   In addition, if a user is away, a small clock will be drawn in the corner of the icon.

   Click with the right mouse button on any nickname to display a context menu of operations you can perform with that nickname. For example, you can send a file to the nickname.

   To hide the Nick Panel, choose Settings → Show Nicklist from the main menu.

6. These are called the Quick Buttons. By default, they are not shown. To display them, see Configuring Quick Buttons. You can customize their definitions to whatever commands you wish.

**NOTE**
You can control how messages are displayed in the message scroll of channel and query tabs. For example, you can change the color of messages, play a sound when a message containing a string is received, or automatically reply to messages. See Message highlighting for more information.
NOTE
Channel names sometimes begin with &, +, or !. The first character of a channel name determines the type of channel (RFC 2811) as follows:

- # - Regular channels.
- ! - Regular channels.
- & - Local. Channels that can only be joined from the server hosting the channel. All other channels can be joined from any server in the network.
- + - Channels that do not support channel modes. This means that all the modes are unset, with the exception of the 't' channel flag which is set.

Channel names are up to 50 characters long and may contain any characters except for space, comma, and Ctrl-G (’G or ASCII 7).

2.6 Quick Connect

Sometimes you want to connect to a server without going through the trouble of creating a new server in the Server List.

Choose File → Quick Connect on the main menu. The Quick Connect screen will appear.

Enter the server address in the Server host box, your desired nickname in the Nick box, and click the Connect button. When Konversation has connected to the server, enter command /join #channellename to join a channel.

2.7 Frequently-used IRC commands

The following is a short list of frequently-used IRC commands. See RFC 2812 for a complete list of all commands, or visit irchelp.org. For a list of commands treated specially by Konversation, see Konversation commands.

/help
Lists commands available on the current server. Not supported by all servers.
The Konversation Handbook

/help cmd
Provides help for cmd. Not supported by all servers.

/join #channel
Joins #channel. If the channel does not already exist, it is created and you are the channel operator.

/part
Leaves the current channel and closes the channel tab.

/part #channel
Leaves #channel and closes the corresponding channel tab. Synonym for /leave

/me msg
Sends msg to the channel preceded by your nickname. For example, if your nickname were Tux, typing /me brews a cup of tea. displays the message Tux brews a cup of tea. Unless they’ve filtered against these types of messages, all users see it. This kind of message is typically used to convey non-verbal information, such as your current emotional state, or what you are physically doing. If you are leaving your workstation for a short time, use the /away command instead.

/away msg
If anyone tries to send you a private message or invite you to a channel, they will be told that you are away from your workstation with msg.

/away
Cancels an /away msg command.

/query nick
Creates a new tab with the user’s nick for private conversation, commonly known on IRC as a Query. Everything written here is only visible to you and your query partner.

/msg nick msg
Sends msg to the user with nickname nick. Only nick sees the message. Use /query for longer conversations.

/invite nick
Invites the user with nickname nick to join a channel. This command is especially useful if the channel is invite-only.

2.8 Private conversations (queries)

A private conversation is one that only you and one other person can see. Private conversations are called “queries” in Konversation. To initiate a private conversation, type /query nick in any input line, where nick is the nickname of the person you want to talk with. You can also click with the right mouse button on the person’s nickname in the Nick Panel and choose Open Query. A new tab will be created. Announce yourself by sending a message.

Queries are just like channels, except that only you and the other person can participate in the channel.

To leave the query, just close the tab. Note however, that if the other person sends you another message in the query, the tab will open again.

To leave all queries, choose Window → Close All Open Queries on the main menu, or press F11 key.

When someone else initiates a query with you, Konversation creates a new tab with their nickname. If you don’t wish to talk with the person, close the tab.
2.9 Setting notifications

Notifications are actions that Konversation will perform whenever an event occurs. Suppose you have Konversation running, but minimized or hidden behind other application windows on your desktop. If someone wants to communicate with you, or your buddy joins a channel, you’d like to be alerted. Notifications will accomplish this.

To configure notifications, choose Settings → Configure Notifications on the main menu. The Notification Settings screen will appear.

1. Click here to select an event.
2. Check the types of notifications you’d like to happen when the event occurs. (Mark taskbar entry causes the entry in the taskbar to flash when the event occurs.)

Repeat by selecting another event and checking the notifications desired. When you’ve configured all the desired notifications, click the OK button.

Once you’ve set up your notifications, you can enable or disable all notifications using Window → Enable Notifications on the main menu.

Tip
You can also alert yourself when someone mentions your nickname in a message using Konversation’s highlighting feature.

2.10 Monitoring who is online

Konversation will keep you informed when your buddies are connected to the IRC network or not.

The IRC network is recorded because nicknames are unique across a single IRC network. The nickname in two different IRC networks is not necessarily the same person, but the same nickname on two different servers within the same IRC network generally is the same person.
NOTE
This is why it is important to use the same Network for all servers in the same IRC network, when defining networks, servers, and auto join channels.

To activate the nickname watching feature, choose Window → Watched Nicks on the main menu. The Watched Nicks screen will appear.

The nicknames in your watch list are listed here. They are listed under their associated IRC network. If no nicknames are listed, either you haven’t specified any nicknames to watch, or you need to activate the nickname watching feature (see below). Expand each online nickname to see a list of channels the nickname has joined. The icons next to each channel are the same as the icons that appear in the Nick Panel in the channel screens.

The information known about the nickname is displayed here. When the Watched Nicks screen is first displayed, this information is sparse. Every 20 seconds, one WHOIS command is automatically sent to the server to request information for nicknames that do not have any information. This continues until all nicknames have information.

To add a single nickname to watch, open the context menu in the Nick List by clicking with the right mouse button on a nickname and select Add to Watched Nicks. If you want to add several nicknames choose Settings → Configure Konversation from the main menu, expand Notifications and click on Watched Nicknames. The Watched Nicknames screen appears.
1. Check this box to activate the nickname watcher feature.

2. If you want the Watched Nicks screen to automatically display when you open Konversation, check this box.

3. In the Watched Nicks screen, you may double click on any nickname and this command will be sent to the server. %u will be replaced with the nickname. The %n is required at the end of the command.

4. The Watched Nicks feature works by periodically polling the server. This box sets how often that occurs. Avoid numbers less than 20 seconds because it places excessive load on the server.

Click the OK button when you have finished adding or removing nicknames.

**Note:** Whenever you display the Watched Nicks screen, it may take a while before any nicknames are displayed until Konversation has polled the server. Normally, you leave the Watched Nicks screen running.

Konversation also displays a message in all the channels whenever a user in your Watched Nicknames list connects or disconnects from the server. The message looks like this:

```
[17:52] [Notify] psn is online (irc.kde.org).
```

2.11 Message highlighting

You can control how messages are displayed in channel and query screens.

To activate the highlighting feature, choose Settings → Configure Konversation on the main menu. The Configure screen will appear.
2.12 Configuring On Screen Display (OSD)

On Screen Display (OSD) is a unique feature of Konversation. With OSD turned on, channel messages will appear on your desktop screen, even if Konversation is minimized. Here’s an example.
of OSD in action. The message in the upper lefthand part of the screen is from Konversation, which is running minimized in the system tray.

To activate OSD, choose Settings → Configure Konversation on the main menu. The Configure screen will appear.

1. Click here to expand the Notification item.
2. Click here to select the On Screen Display screen.
3. Check this box to activate OSD.
4. Click this button to choose a font for OSD. (Note: Not all fonts work. Luxi Sans 22 and Impact 22 are known to work.)
5. Check the boxes here to select the types of messages you’d like to appear on screen.
6. Drag the OSD Preview to your desired position, then click the Apply button.

### 2.13 Sending colorful messages

You can add color to the messages you send in any channel. In the Input Line of any channel, start typing your message. Click the IRC Color button or choose Insert → IRC Color on the main menu. The IRC Color Chooser screen will appear.
Choose a color and click OK. Continue typing your message in the Input Line. To change the color again, click the IRC Color button. Choose a different color and click OK.

2.14 Configuring nickname themes

You can change the icons displayed next to nicknames in the Nick Panel of channel tabs. To change the nickname theme, choose Settings → Configure Konversation on the main menu. The Configure screen will appear. Click Interface to expand it, then click Nicklist Themes to display the Nicklist Themes screen.

Click here to select the Nicklist Themes screen.
Select a theme.
Sample icons are displayed here in the chosen theme.
If you have downloaded a nick theme from elsewhere, click to install it.
### 2.15 Configuring Quick Buttons

You can enable a feature to display Quick Buttons on the Main screen, eight Quick Buttons appear. To display the Quick Buttons, choose Settings → Configure Konversation on the main menu. The Configure screen will appear. Click Interface to expand it, then click Chat Window. Check the Show quick buttons box and click OK.

The buttons may be customized to your liking for performing often-used IRC commands. To customize the Quick Buttons, choose Settings → Configure Konversation on the main menu. The Configure screen will appear. Click Interface to expand it, then click Quick Buttons to display the Quick Buttons screen.

![Configuring Quick Buttons](image)

There are 8 default Quick Buttons. Click on an entry to change it or use the buttons at the right side of the list to add or remove Quick Buttons. The Button Name column is the name that will appear on the button in the Main screen. Keep the names short. The Button Action column is the action that will be performed when you click the Quick Button. Tips for creating actions are given on the screen.

Click OK to complete the changes.

Example:

**Button Name:** Msg  
**Button Action:** Msg %u (there is a space after %u)

To use this button in the Main screen, click on a nickname in the Nick Panel, then click the button. /MSG will appear in the Input Line followed by the chosen nickname. Type a message you want to send to that person and press Enter. The message will be sent to the user. Only that user will see the message.

### 2.16 Sending and receiving files

You may send files via IRC to other users online, or they may send you files.
**The Konversation Handbook**

**WARNING:** Never open a file someone sends you unless they are a trusted source. It could be a virus.

To send a file to someone in a channel, click with the right mouse button on the nickname of the person in the Nick Panel of the Main screen. Choose Send File. A dialog appears for you to choose a file to send. Next, a new **DCC Status** tab appears.

<table>
<thead>
<tr>
<th>Type</th>
<th>Started At</th>
<th>Status</th>
<th>File</th>
<th>Partner</th>
<th>Progress</th>
<th>Position</th>
<th>Remaining</th>
<th>Speed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outgoing</td>
<td>19:12:45</td>
<td>Pending</td>
<td>index.docbook</td>
<td>Black</td>
<td>0%</td>
<td>0/140,7 KiB</td>
<td>0 B/sec</td>
<td></td>
</tr>
</tbody>
</table>

1. The nickname of the recipient and file name appear here.
2. The **Status** column indicates the status of the file send or receive as follows:

- **Preparing**
  A receiving transfer is checking for resumable files or a sending transfer is acquiring the data to send.

- **Connecting**
  Konversation is trying to establish a connection with the other end.

- **Sending**
  Konversation is sending the file to the other end.

- **Receiving**
  Konversation is receiving the file from the other end.

- **Done**
  The file has been successfully transferred.

- **Pending**
  The transfer is waiting for the partner to accept or reject it.

- **Aborted**
  Either you clicked the **Abort** button, or the other person aborted the transfer.

- **Failed**
  An error occurred and the transfer was not successful.

- **Queued**
  Transfer is waiting for you to accept or reject it.

- **Resuming**
  When a transfer begins but the file already exists on the user’s system, the user will be prompted File already exists. Resume transfer? This status indicates the user resumed the transfer.
When someone wants to send you a file, the **DCC Status** tab will be created (if not already created). Click the **DCC Status** tab to display it. Click the file to select it, then click this button to accept the file and the transfer will begin. **Note**: You may configure Konversation to automatically accept sends from other people by choosing **Settings → Configure Konversation** on the main menu. Click **Behavior** to expand it, then click **DCC** to display the DCC screen.

If you have trouble sending or receiving files, your firewall or router may be blocking DCC ports. See **Questions and Answers**.

### 2.17 Capturing URLs from messages

In any **channel**, users sometimes post the URLs of interesting websites or other resources on the web. You can double-click any such URL and Konversation will launch the application associated with the URL. The application launched depends upon the MIME type of the URL. For example, a URL beginning with http: will activate your default web browser and display the web page. (You can also specify the **web browser** to use.) If the URL scrolls off the screen, you might have trouble finding it again. Konversation can keep a convenient list of all URLs for you. To activate this feature, choose **Window → URL Catcher** on the main menu. A new tab called **URL Catcher** is created.

<table>
<thead>
<tr>
<th>From</th>
<th>URL</th>
<th>Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>#konversation</td>
<td><a href="http://konversation.kde.org/">http://konversation.kde.org/</a></td>
<td>29.11.16 16:17</td>
</tr>
<tr>
<td>#kde</td>
<td><a href="http://userbase.kde.org">http://userbase.kde.org</a></td>
<td>29.11.16 16:17</td>
</tr>
<tr>
<td>#kde</td>
<td><a href="http://forum.kde.org">http://forum.kde.org</a></td>
<td>29.11.16 16:17</td>
</tr>
<tr>
<td>#kde</td>
<td><a href="http://paste.kde.org">http://paste.kde.org</a></td>
<td>29.11.16 16:17</td>
</tr>
<tr>
<td>#konversation</td>
<td><a href="http://userbase.kde.org/Konversation/Sources">http://userbase.kde.org/Konversation/Sources</a></td>
<td>29.11.16 16:17</td>
</tr>
<tr>
<td>#konversation</td>
<td><a href="http://userbase.kde.org/Konversation">http://userbase.kde.org/Konversation</a></td>
<td>29.11.16 16:17</td>
</tr>
<tr>
<td>freenode</td>
<td><a href="https://bugs.kde.org/inter_bug.cgi?product=konversation">https://bugs.kde.org/inter_bug.cgi?product=konversation</a></td>
<td>29.11.16 16:17</td>
</tr>
<tr>
<td>freenode</td>
<td><a href="https://www.privateinternetaccess.com/">https://www.privateinternetaccess.com/</a></td>
<td>29.11.16 16:17</td>
</tr>
<tr>
<td>freenode</td>
<td><a href="http://www.fosscon.org">http://www.fosscon.org</a></td>
<td>29.11.16 16:17</td>
</tr>
<tr>
<td>freenode</td>
<td><a href="http://www.freenode.net">http://www.freenode.net</a></td>
<td>29.11.16 16:17</td>
</tr>
<tr>
<td>freenode</td>
<td><a href="http://www.neterra.net">http://www.neterra.net</a></td>
<td>29.11.16 16:17</td>
</tr>
</tbody>
</table>

1. This is the list of URLs seen since you started Konversation. The **From** column is the nickname of the person who posted the URL or the name of the channel or server, where the URL was posted. (URLs appearing in join and leave messages are not listed.) Click on a URL to select it.
2. Click here to activate the application associated with the selected URL. The application launched depends upon the MIME type of the URL. For example, a URL beginning with http: will activate your default web browser and display the web page. For web pages, you can also specify the **web browser** to use.
3. Click here to copy the selected URL to the clipboard.
Click here to delete the selected URL from the list.
Click here to save the list of URLs to a file.
Click here to clear the list.

2.18 Setting your preferred web browser

When you click on a highlighted URL anywhere in Konversation, it will launch the default application associated with the MIME type of the URL. For example, when clicking on a URL beginning with http, Konqueror is launched to display the web page. You can specify an application different from the Default Applications module of the System Settings. For example, you can use Firefox instead.

To choose a different web browser from Konversation app, choose Settings → Configure Konversation on the main menu. The Configure screen will appear.

Click here to display the General screen.
Click here to specify that you want to use a custom web browser.
Enter the command to launch your desired web browser. When you click on a URL %u will be replaced with the URL.

Note: The web browser setting does not apply to mailto: URLs. mailto: URLs always launch the default mailer.

Click Apply to save your changes. You must reconnect to each server and channel for the changes to take effect. The easiest way to do this is to quit and restart Konversation.
2.19 Marking Channel and Query Logs

You can insert a marker into channel and query screens to help you quickly locate information. To do this, choose Insert → Marker Line on the main menu, or press Ctrl+R. A line will appear at the bottom of the text on the screen. The line will scroll with the rest of the text in the screen.

To make the Marker Line be inserted in all channels and queries at once, choose Settings → Configure Konversation from the main menu, expand Behavior, click on Chat Window, and check the Show manually inserted lines in all chat windows box.

To make Konversation automatically insert a Marker Line whenever you do an /away msg command, see Setting your identity.

2.20 Logging

If logging is enabled, Konversation keeps a log of each Server, Channel, and Private conversation (query) session. Each session is stored in a log file on disk. When you open the same session again, Konversation appends to the log.

Whenever you open a session again, approximately the last 1024 characters of the previous session are read from the tail of the log and shown on the screen.

As your session continues, messages scroll off the top of the display. You can scroll backwards to view these messages. Eventually, in order to conserve memory, the oldest messages are discarded from the scroll. This is called the Scrollback limit. Messages that disappear from the display because of the Scrollback limit are still available in the log file, if logging is enabled.

To view the logfile for a session, click the tab for the session to make it the current session and choose Window → Open Logfile from the main menu. A new tab appears displaying the log file.

Logfile of #konversation — Konversation

File Edit Insert Bookmarks Settings Window Help

[Dienstag, 29. November 2016] [16:17:06 CET] Join You (~kde@kde.org parted) has joined the channel #konversation.


[Dienstag, 29. November 2016] [16:17:06 CET] Topic The topic was set by sho@kde.org on 03.08.16 21:26.


[Dienstag, 29. November 2016] [16:17:12 CET] Mode Channel modes: no messages from outside, topic protection

[Dienstag, 29. November 2016] [16:17:25 CET] Created This channel was created on 25.11.06 07:42.

[Dienstag, 29. November 2016] [16:20:41 CET] Nick paul_ is now known as crazystick.

[Dienstag, 29. November 2016] [16:23:38 CET] Quit: jreznik (jreznik@nat/redhat/x-pnyrzczruegzdub) has left this server (Quit: Konversation terminated).

[Dienstag, 29. November 2016] [16:27:56 CET] Join vencour (~vencour@37-48-5-100.tmcc.cz) has joined this channel.

Ready.

1 The messages in the log file are displayed here. The oldest messages are at the top and the most recent are at the bottom.

2 Click this button to save the log file to another file.
The Konversation Handbook

1. Click to refresh the log file display. While you are viewing a log file, newer messages in the corresponding session are not automatically added to the log file display. Use this button to view the most recent messages.

2. Click to erase the log file display and the log file on disk.

3. Use this box to set the maximum size of the scroll. This setting does take effect only for newly opened log tabs. The last changed value of the scroll size will be used on Konversation's next start. Each log file may have a separate setting.

The Scrollback limit can be changed by choosing Settings → Configure Konversation on the main menu, then expand Behavior and click on Chat Window. The Scrollback limit box appears on this screen. If you set it to Unlimited (i.e. zero), messages are not discarded from the scroll.

You can enable or disable logging and set other logging options, by choosing Settings → Configure Konversation on the main menu, then expand Behavior and click on Logging.

2.21 Konversation commands

The following commands are interpreted by Konversation and may differ from standard IRC commands. Items inside square brackets are optional. Items separated by bar (|) are alternate forms of the command. Commands not listed here are sent to the server as entered.

/me msg
Sends msg to the channel preceded by your nickname. For example, if your nickname were Tux, typing /me brews a cup of tea. displays the message Tux brews a cup of tea. Unless they’ve filtered against these types of messages, all users see it. This kind of message is typically used to convey non-verbal information, such as your current emotional state, or what you are physically doing. If you are leaving your workstation for a short time, use the /away command instead.

/ame msg
Like the /me command above except that the message is sent to all the channels and queries you have open on all the servers you have connected in Konversation.

/join channel [pwd]
Joins channel. If the server permits it, and if the channel does not already exist, it is created and you are the channel operator. If the channel requires a password in order to join, specify as pwd. Most channel names begin with #.

/j channel [pwd]
Same as /join above.

/part [channel] [reason]
Leaves channel with reason and closes the corresponding channel tab. Within a Konversation channel or query tab, you can just enter /part which closes that channel or query with your default reason as given in the Settings.

/leave [channel] [reason]
Same as /part above.

/quit
When entered in any channel, query, or DCC tab, disconnects from the corresponding server and closes all channel, query, or DCC tabs open on that server.
The Konversation Handbook

/notice nick|channel msg
Sends msg to the user with nickname nick or to everyone in channel. The following is an example of what appears to you in the channel tab

[17:14] [Notice] Sending notice “I think I understand” to #konversation
And this is what the recipients see

[17:15] [Notice] -Eisfuchs- I think I understand

/query nick
Creates a new tab with the user’s nick for private conversation, commonly known on IRC as a Query. Everything written here is only visible to you and your query partner. You may enter more than one nickname separated by spaces and a query tab will be opened for each nickname. Each such query tab will be private between you and the query partner.

/msg nick|channel message
Sends a private message to the user with nickname nick or to all users in channel. Unlike /query, does not open a new tab. If message begins with /me, the message is formatted in the same manner as a /me command.

Examples
/msg Eisfuchs I need some help with the msg command
/msg #konversation New version of Konvi is online!
/msg Eisfuchs /me is compiling the Handbook right now.

/smsg nick|channel message
Same as /msg except the message is not displayed on your screen. This is useful for preventing passwords and other sensitive information from remaining exposed on your screen or being logged.

/amsg nick|channel message
Like the /msg command above except that the message is sent to all the channels and queries you have open on all the servers you have connected in Konversation.

/op nick
When entered into a channel tab, attempts to give nick operator privilege for the channel. May not work if you lack sufficient privilege in the channel (you must be a channel operator yourself). You may enter more than one nickname separated by spaces.

/deop nick
When entered into a channel tab, takes away channel operator privilege from nick. You may enter more than one nickname separated by spaces.

/oper [nick]
Grants the user with nickname nick IRC-Op (Administrator) privilege. This only works if the nickname is listed in the server’s O: line. IRC-Ops have the privilege to /kill nicknames, /connect servers to the IRC network, and more. If nick is not entered, attempts to grant yourself IRC-Op privilege. You will be prompted for your IRC-Op user name and password in either case.

/voice nick
In certain channels (with +m flag), users cannot send messages unless they have voice privilege. This command attempts to give nick voice privilege. You must have channel operator privilege to execute this command. This command is mostly used when you are an operator for a moderated channel.

/unvoice nick
Takes away voice privilege from nick in the channel.
The Konversation Handbook

/topic [channel] [message]
Attempts to set the topic of channel to message. When entered in a channel tab, channel may be omitted and defaults to the channel active in the tab. If message is omitted, displays the current topic of the channel. Changing a channel topic may fail if you lack sufficient privilege.

/away reason
If anyone tries to send you a private message or invite you to a channel, they will be told that you are away from your workstation for reason. To change your state back to normal, enter /away without a reason.

/aaway reason
Like the /away command above except that the command is sent to all the servers you have connected in Konversation.

/invite nick [channel]
Invites the user with nickname nick to join channel. This command is especially useful if the channel is invite-only. When entered in a channel tab, channel may be omitted.

/exec script [parameters]
Executes the Konversation-compatible shell script named script, passing it parameters. See Scripting for more information on using and writing scripts.
Examples:
/sayversion
Sends your system’s Konversation, Qt™, KF5 and Plasma version numbers to the channel.
/exec cmd uname -a
Sends your Linux® version string (the output of ‘uname -a’) to the channel.

/notify [nick]
Adds or removes nick from your Watched Nicks list. If the nickname is already in the list, it is removed. If it is not in the list, it is added. If nick is omitted, displays the current list of watched nicknames.

/kick nick reason
When entered in a channel tab, attempts to kick the user with nickname nick from the channel with reason. If reason is not entered, defaults to the reason in the Settings. This command may only be used in a channel tab.

/ban [-host|-domain| -userhost| -userdomain] [channel] user|mask
Attempts to ban the user or mask from channel. When entered in a channel tab, channel may be omitted. For more information on hosts, domains, and masks, see the documents at irchelp.org. To get the current ban list for a channel, enter /mode channel b.

/unban [channel] pattern
Reverts a previous banning from a channel. When entered in a channel tab, channel may be omitted.

/ignore [-all] nick
Adds nick to your Ignore list. You may specify more than one nickname separated by spaces. Channel messages from users on your Ignore list are not displayed. In addition, if you enter -all, all message types (queries, notices, CTCP, DCC, and Exceptions) from the user are ignored as well as channel messages.

/quote cmd
Sends cmd to the server.
The Konversation Handbook

/say msg
When entered in a channel tab, sends msg to the channel. This is the same as entering msg in the channel Input Line. Useful for sending IRC commands when you don’t want to execute the command. Two command characters (//) in a row does the same thing as /say. Also used by scripts to send messages.

/raw [open|close]
Places the server log in raw mode (open) or stops raw mode (close). If neither open or close is entered, defaults to open. In raw mode, the log displays every message received from the server in native IRC format.

/konsole
Opens a new tab running a Konsole.

/server [url] [pwd]
Connects to the server at address url. If url is omitted, connects to the server associated with the tab where you enter the command. This is useful for re-connecting to a server when disconnected. If the server requires a password in order to connect to it, enter it for pwd. If the server requires a port number other than the default (6667), enter the url like this: irc.kde.org:6665.

/dcc SEND nick [filename]
Sends filename to the user with nickname nick. If filename is omitted, a dialog appears for you to select a file.

/dcc
Opens the DCC Status tab.

/ctcp nick|channel ping
Sends a PING message to nick or channel. This is useful for determining if someone you are talking with has a high network lag, or (when sent to a channel) if your system has a high lag.

/ctcp nick|channel msg
Sends a message to nick or all users in channel. This is similar to the /msg command above, except that the message is sent using the CTCP protocol. The response on the other end depends on the IRC client program the user is running. For example, when conversing with another Konversation user, /ctcp Eisfuchs TIME will return the system time on Eisfuch’s computer. /ctcp Eisfuchs VERSION will return the Konversation version number from Eisfuch’s computer.

2.22 Scripting
Konversation comes with some handy scripts you can run from the program. To run a script, in a channel, query, DCC, or server tab, type a command of the form

/exec script [parameters]
which executes the script named script passing it (optional) parameters.
For example, type the following command in a channel tab

/sayversion
To send your Konversation, Qt™, KF5 and Plasma version numbers to the channel.

/exec cmd uname -a
executes the cmd script, passing it uname -a. This sends your Linux® version string to the channel.
To learn more about the scripts installed with Konversation please see the Script Reference Guide.

To get a list of all available scripts, type the following command in a Konversation screen.

```bash
/exec --showpath media
```

Then browse to folder from the output to see the list.

You can write your own scripts. Scripts are shell scripts and can be written in any shell language, such as bash, perl, or python. When Konversation runs a script, the first two parameters sent to the script are:

- The address of the server.
- The channel name.

Here is a sample shell script (cmd).

```bash
#!/bin/sh

# Executes a command and prints the output into Konversation.

SERVER=$1;
TARGET=$2;
shift;shift;

$@ | while read line; do qdbus org.kde.konversation /irc say $SERVER "$TARGET" "$@: $line"; done
```

Notice that the script uses qdbus to communicate with Konversation. The `say` command causes the output to be sent to the channel as a normal message. To display something in the tab without sending it to other users, use `info` instead. Look at the existing script files for more examples of writing scripts.

To be able to run a script you have written, you must install it by copying it to `$(qtpaths --path s GenericDataLocation)/konversation/scripts`. You must also give the file execute privilege, for example `chmod a+x myscript`.

### 2.23 Script Reference Guide

Konversation comes with several scripts installed by default, please refer to this guide to learn how to use them.

**/exec bug [Bug Number|Search String]**

This script is used to open your browser to search for the given string or bug number on KDE’s Bugzilla.

Example: To open your browser to search for bug 123456

```bash
/exec bug 123456
```

Sample action: The default browser in your System Settings should open to `https://bugs.kde.org/show_bug.cgi?id=123456`.

**/exec cmd [command line arguments]**

This script is used to have the output of the command line arguments to be written to your current channel.

Example: To show everyone in your current channel what version of Konversation you have installed.

```bash
/exec cmd konversation --version
```

Sample output: `Konversation: 1.6`

WARNING! The output of the entire command is posted to everyone in the current channel tab! Please use with care.
The Konversation Handbook

/exec fortune
This script when run will output a Random Fortune.
Example: To output a random fortune to your current channel tab.
/exec fortune
Sample output: Random Fortune: Never make any mistaeks. -- Anonymous, in a mail discussion about to a kernel bug report

/exec gauge [percentage]
This script shows a simple text based progress bar for the given percentage.
Example: To output a progress bar with 50% completion to the current channel tab.
/exec gauge 50
Sample output: Beer load [ | ] 50%

/exec media [audio|video|{player}]
This is a Now Playing script for various media players. It also features a method to show Now Playing information for only audio players, or only video players via the optional command arguments audio and video. Additionally, it’s possible to specify the media player you wish to query.
The following media players are supported: Amarok (audio), JuK (audio), Kaffeine (video, audio), KMPlayer (video, audio), KPlayer (video, audio), kdetv (video), Yammi (audio), Audacious (audio), MPD (audio).
Example: To output your currently playing song in Amarok.
/exec media amarok
Sample output: * user is listening to You Give Love A Bad Name by Bon Jovi on Slippery When Wet [Amarok]

/exec sysinfo
This script outputs some detailed information about your system by combining the outputs of several commands and formatting them appropriately.
Example: To output some information about your system to the current channel tab.
/exec sysinfo
Sample output: Sysinfo for ‘user-desktop’: Running inside KDE Plasma 5.6.5 on Ubuntu 16.04.1 LTS (Xenial Xerus) powered by Linux 4.4.0-47-generic, CPU: Intel(R) Core(TM) i7-4910MQ CPU @ 2.90GHz at 2996-3338/3900 MHz, RAM: 15795/15967 MB, Storage: 1591/2281 GB, 406 procs, 47.59h up

/exec tinyurl [Link Address]
This script uses Tinyurl’s api to turn the given link into a tinyurl that is then sent to the current channel tab.
Example: To give someone a short link to https://konversation.kde.org
/exec tinyurl https://konversation.kde.org
Sample output: https://tinyurl.com/y4rk8wa3

/exec uptime
This script outputs the result of the command “uptime” and formats it appropriately.
Example: To show off your rock solid 98 day uptime.
/exec uptime
Sample output: Uptime: 98 days, 15 hours and 2 minutes

All these scripts have predefined command aliases. In Konversation’s settings dialog select Behavior → Command Aliases to view, add, remove or edit command aliases.

For more information about scripting please read the Userbase Scripting guide
Chapter 3

Command Reference

3.1 The main Konversation window

3.1.1 The File Menu

File → Server List (F2)
   Displays the list of servers and channels.

File → Quick Connect (F7)
   Displays the Quick Connect screen for connecting to a server.

File → Disconnect
   Disconnects from all servers.

File → Reconnect
   Reconnects to all servers that were disconnected by a network error or other problem.

File → Join Channel (Ctrl+J)
   Displays a dialog for you to enter the name of a channel to join. Does the same thing as entering /join #channelname in a channel or server tab.

File → Global Away (Ctrl+Shift+A)
   Changes your nickname status to away in all channels.

File → Quit (Ctrl+Q)
   Quits Konversation.

3.1.2 The Edit Menu

Edit → Find Text... (Ctrl+F)
   Searches for text strings in the current screen.

Edit → Find Next (F3)
   Searches again for text strings in the current screen using the previous search string.

Edit → Clear Window (Ctrl+L)
   Clears the current screen.

Edit → Clear All Windows (Ctrl+Shift+L)
   Clears all screens.
3.1.3 The Insert Menu

Insert → IRC Color... (Ctrl+K)
See Sending colorful messages.

Insert → Marker Line (Ctrl+R)
See Marking Channel and Query Logs.

Insert → Special Character... (Alt+Shift+C)
Used to enter special characters, such as foreign characters.

3.1.4 The Bookmarks Menu

Bookmarks → Add Bookmark (Ctrl+B)
Bookmarks current network & channel.

Bookmarks → Bookmark Tabs as Folder...
Adds all channels to a new menu item at the end of the bookmarks menu.

Bookmarks → New Bookmark Folder...
Creates a new bookmark folder.

Bookmarks → Edit Bookmarks...
Opens bookmark editor.

3.1.5 The Settings Menu

Settings → Show Nicklist (Ctrl+H)
Hides (or displays) the panel of nicknames in channel tabs.

Settings → Identities... (F8)
Displays the Identities screen for setting your identification information.

3.1.6 The Window Menu

Window → Previous Tab (Ctrl+,)
Displays the screen corresponding to the previous tab.

Window → Next Tab (Ctrl+)
Displays the screen corresponding to the next tab.

Window → Close Tab (Ctrl+W)
Closes the current screen. If closing a channel, leaves the channel. If closing a Server Messages tab, closes all open channels on that server and disconnects from the server.

Window → Close All Open Queries (F11)
Closes all Private conversations (queries).
Window → Watched Nicks (F4)
Displays the Watched Nicks screen. See Monitoring who is online.

Window → URL Catcher (F6)
Displays the URL Catcher screen.

Window → DCC Status (F9)
Displays the DCC Status tab with information about file transfers.

Window → New Konsole
Displays a terminal screen. You may open as many Konsole tabs as you like.

Window → Channel List for (F5)
Displays a list of channels available on the server.

Window → Open Logfile for (Ctrl+O)
Displays a screen with the log of messages from the current tab. Only works for Channel, Server Messages, and Query tabs. Logging must be enabled in Settings → Configure Konversation → Behavior → Logging on the main menu.

3.1.7 The Help Menu

Konversation has the common KDE Help menu item, for more information read the section about the Help Menu of the KDE Fundamentals.
Chapter 4

Questions and Answers

1. When I start Konversation, I’d like to connect to a server without joining any channels. How do I do that?
   In the Edit Server screen, leave the Channels frame empty.

2. Konversation won’t connect to any servers. What is wrong?
   There are several things that could be wrong.
   (a) Make sure that you have entered the correct Server name and the correct Port in the Add Server screen.
   (b) Check the output in the Server Messages screen for any error messages. Did the server reject the connection because of a bad password? Did the server reject the connection because it requires IDENTD and your computer did not respond to the IDENT request? Did you check the SSL protocol box but the server does not support SSL?
   (c) If you are behind a firewall, make sure the correct ports are enabled. Konversation needs the following ports enabled:
      - Outgoing TCP 6667 (or the port of the server you connect to)
      - Incoming TCP 113 (if the server requires IDENTD)
   For more information on IRC connection problems, see irchelp.org.

3. When I go to Window → Channel List, I cannot select it. Why is that?
   The Window → Channel List menu entry will be grayed-out if a non-channel tab, e.g. Watched Nicks, is currently being viewed. To make it selectable again go back to a channel tab or the server tab.

4. How do I have Konversation automatically mark me as away after a period of inactivity?
   Auto-away messages are configured on a per-identity basis. To enable auto-away select Settings → Identities. Choose the identity for which you want to enable auto-away from the drop down list at the top of the dialog and go to the Away tab. Check the Automatic Away option.

5. How to avoid the Auto Replace feature of the Input Line?
   Use Ctrl+Enter instead of just Enter to avoid parsing and automatically replacing the text in the Input Line according to the options in the settings dialog page Behavior → Auto Replace.

6. Where can I find the scripts included with Konversation?
   Run this command in Konversation’s input line (using the media script as an example, since it comes with any Konversation installation):
   /exec --showpath media
   Sample output: The script file ‘media’ was found at: /usr/share/konversation/scripts/media
7. How do I make my text bold/italicized/underlined?

Example: This is my %Bbold%B text.
Output: This is my **bold** text.

Example: This is my %Iitalicized%I text.
Output: This is my *italicized* text.

Example: This is my %Uunderlined%U text.
Output: This is my _underlined_ text.

Example: This is my %Sstruck-out%S text.
Output: This is my **struck-out** text.

Example: This is my %Mmonospace%M text.
Output: This is my monospace text.
Chapter 5

Credits and License

Konversation
Program copyright 2002-2005 by the Konversation team.
https://konversation.kde.org

Contributors:

• Dario Abatianni eisfuchs@tigress.com
• Peter Simonsson psn@linux.se
• Christian Muehlhaeuser chris@chris.de
• John Tapsel john@geola.geo.uk
• Ismail Donmez ismail.donmez@boun.edu.tr
• Shintaro Matsuoka shin@shoegazed.org
• Gary Cramblitt garycramblitt@comcast.net
• Matthias Gierlings gismore@users.sourceforge.net
• Alex Zepeda garbanzo@hooked.net
• Stanislav Karchebny berkus@users.sourceforge.net
• Mickael Marchand marchand@kde.org

Thanks to:

• Michael Goettsche michael.goettsche@kdemail.net
• Benjamin Meyer ben+konversation@kdemail.net
• Jacub Stachowski qbast@go2.pl
• Sebastiano Sariego segfault@kde.cl
• Olivier Bedard www.konversation.org hosting
• Frauke Oster frauke@frsv.de
• Lucijan Busch lucijan@kde.org
• Sascha Cunz mail@sacu.de
• Steve Wollkind steve@njord.org
The Konversation Handbook

- Thomas Nagy thomas.nagy@eleve.emn.fr
- Tobias Olry tobias.olry@web.de
- Ruud Nabben r.nabben@gawab.com

Documentation Copyright (c) 2003-2005 Gary R. Cramblitt garycramblitt@comcast.net
This documentation is licensed under the terms of the GNU Free Documentation License.
This program is licensed under the terms of the GNU General Public License.