The Parley Handbook

Frederik Gladhorn
Sabine Eller
Daniel Laidig
Amarvir Singh
Contents

1 Introduction 7
2 Dashboard 8
3 Open an existing collection 10
4 Vocabulary Practice 12
  4.1 Practice Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
  4.2 Practice Configuration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
    4.2.1 General Practice Settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
    4.2.2 Blocking . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14
    4.2.3 Thresholds . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14
    4.2.4 Specific Practice Settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
  4.3 Practice . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
    4.3.1 Flash Cards . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
    4.3.2 Mixed Letters . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
    4.3.3 Multiple Choice . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
      4.3.3.1 Automatic selection of the possible answers . . . . . . . . . . . . . 19
      4.3.3.2 With yes/no answers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21
    4.3.4 Written . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22
    4.3.5 Counting an Answer as Right . . . . . . . . . . . . . . . . . . . . . . . . . . . 23
    4.3.6 Reset Practice to Initial State . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
  4.4 Summary After Practice . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
  4.5 Grammar Practice Modes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25
    4.5.1 Articles and Gender of Nouns . . . . . . . . . . . . . . . . . . . . . . . . . . . 25
    4.5.2 Comparison Forms of Adjectives and Adverbs . . . . . . . . . . . . . . . . . 26
    4.5.3 Conjugations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
5 Vocabulary Editing 29
  5.1 Setup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29
    5.1.1 About the Collection . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29
    5.1.2 Vocabulary Columns . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30
    5.1.3 Languages and Grammar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31
<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>5.1.3.1</td>
<td>Let’s Have a Closer Look at Spanish</td>
<td>31</td>
</tr>
<tr>
<td>5.2</td>
<td>Units</td>
<td>33</td>
</tr>
<tr>
<td>5.2.1</td>
<td>New Unit</td>
<td>34</td>
</tr>
<tr>
<td>5.2.2</td>
<td>Moving, Renaming and Deleting Units</td>
<td>34</td>
</tr>
<tr>
<td>5.2.3</td>
<td>Splitting a Unit</td>
<td>35</td>
</tr>
<tr>
<td>5.2.4</td>
<td>What is Shown in the Table</td>
<td>35</td>
</tr>
<tr>
<td>5.3</td>
<td>Word Types</td>
<td>35</td>
</tr>
<tr>
<td>5.3.1</td>
<td>Adding New Vocabulary</td>
<td>35</td>
</tr>
<tr>
<td>5.3.2</td>
<td>Editing Words</td>
<td>35</td>
</tr>
<tr>
<td>5.4</td>
<td>Synonyms</td>
<td>35</td>
</tr>
<tr>
<td>5.5</td>
<td>Adding Images</td>
<td>36</td>
</tr>
<tr>
<td>5.6</td>
<td>Adding Sound</td>
<td>36</td>
</tr>
<tr>
<td>5.7</td>
<td>Entering Comparison Forms</td>
<td>37</td>
</tr>
<tr>
<td>5.8</td>
<td>Entering Inflection Forms</td>
<td>38</td>
</tr>
<tr>
<td>5.9</td>
<td>Creating New Files</td>
<td>39</td>
</tr>
<tr>
<td>5.9.1</td>
<td>New Collection: Vocabulary English-German</td>
<td>39</td>
</tr>
<tr>
<td>5.9.2</td>
<td>New Collection: Single Names and Collective Names</td>
<td>48</td>
</tr>
<tr>
<td>5.10</td>
<td>Getting Additional Collections</td>
<td>52</td>
</tr>
<tr>
<td>5.11</td>
<td>Configure Parley</td>
<td>53</td>
</tr>
<tr>
<td>5.11.1</td>
<td>Theme Tab</td>
<td>54</td>
</tr>
<tr>
<td>5.11.2</td>
<td>General Tab</td>
<td>55</td>
</tr>
<tr>
<td>5.11.2.1</td>
<td>Open/Save options</td>
<td>55</td>
</tr>
<tr>
<td>5.11.2.2</td>
<td>Editing option</td>
<td>55</td>
</tr>
<tr>
<td>5.11.3</td>
<td>View Tab</td>
<td>56</td>
</tr>
<tr>
<td>6</td>
<td>Notes For Advanced Users</td>
<td>57</td>
</tr>
<tr>
<td>6.1</td>
<td>Upload and Share Collections</td>
<td>57</td>
</tr>
<tr>
<td>6.2</td>
<td>File format</td>
<td>57</td>
</tr>
<tr>
<td>7</td>
<td>Credits and License</td>
<td>58</td>
</tr>
<tr>
<td>7.1</td>
<td>Thanks</td>
<td>58</td>
</tr>
<tr>
<td>7.2</td>
<td>Copyright</td>
<td>58</td>
</tr>
</tbody>
</table>
List of Tables

5.1 Personal Pronouns in English ................................. 31
Abstract

Parley is a vocabulary trainer. It helps you to memorize your vocabulary, for example when you are trying to learn a foreign language. Parley is not limited to language learning but supports a multitude of subjects.
Chapter 1

Introduction

Parley is a vocabulary trainer. It helps you to memorize your vocabulary, for example when you are trying to learn a foreign language. You can create your own vocabulary collections with the words you need or select from a great variety of available Vocabulary Collections. There you can find collections containing language vocabulary and also anatomy, music, geography, chemistry or exam preparation.

Parley is very flexible and uses the flash card learning approach. It automatically keeps track of your learning progress. With Parley you can arrange your vocabulary as you wish, you create your own lessons as needed. But unlike real flash cards you can use different learning methods with Parley.

Flashcards contain expressions on the front side and their translation on the back. You start with a pile of cards. If you know the translation on a card, you can put it into a second pile of cards. If you did not remember it, you keep it in the first one to try again later.

Parley’s main focus is not to teach you grammar. However, there are some exercise forms which may help you in this matter.

Parley consists of two big parts: Vocabulary Practice and an Editor for Vocabulary Collections.

In this manual the term Vocabulary Collection refers to a file that contains Units. Each unit can be a lesson or a collection of lessons nested to any depth. In the rest of this manual we will refer to units rather than lessons since they can be used for other purposes too.

Both, the Editor and the Practice can be reached from the Practice Overview.

The Practice consists of three parts: first the Practice Overview where you choose what to practice. From there you start the actual Practice and when you are done, you get a Summary.

Tip
Like in all applications try to use the right-click if you explore features and functionality in Parley. The right-click displays a ‘context menu’ that shows what you can do with your present situation. Try right-clicking units and words to find some options.
Chapter 2

Dashboard

When you first launch Parley the Dashboard welcomes you.

At first the Dashboard is empty, once you opened some vocabulary collections, it shows you the ones you worked with most recently.

A vocabulary collection is a file that contains words and their translations into other languages or other pairs of words and sentences that you want to memorize. The words are organized in units.

To start practicing, click the Practice on one of the vocabulary collection names in the list. You are taken to the practice overview.

Note that a small Delete Icon appears to the left of the document name. The Delete Icon lets you remove the collection from the list.

If you’d like to start your own collection of vocabulary, click on Create a New Collection.

You can also open a collection if you have it on your computer already but it’s not in the list.

The last button on the Dashboard offers you to download vocabulary collections made by others. When you’ve created a file that you’d like to share with others, you can easily upload it from the editor.
Parley comes with different themes, you can switch to a different graphical style in the settings. For further information, see Configure Parley.
Chapter 3

Open an existing collection

Let's suppose your collection is already on your hard disk.
This is what the screen will look like the first time you start Parley:

Click on **Open an Existing Collection**.
In the file selection dialog, navigate to the folder containing the data file, and select it by clicking on it. Depending on your system the file either opens immediately, or you have to click **OK**
Now, the file is loaded, and you move on to the **Practice Overview** screen: see the following section for further details.
Chapter 4

Vocabulary Practice

To start practicing you select a document after starting Parley. If you have it opened in the editor already, just click Practice in the toolbar.

4.1 Practice Overview

Before the actual practice starts, you always get to the Practice Overview page. There are three areas which allow you to choose what to practice:

- The selection of languages
- The selection of the practice mode
- The selection of the units that also shows your current progress
On the left you can select the combination of languages you will practice. If you select for example English to French, you will be shown English words and Parley will ask you to enter the French translations.

Below the language selection you choose the practice mode. **Practice Mode** determines how the practice will ask you questions.

The **Practice Direction** drop down list can be used to select the query that will be shown during the practice. The possible choices are the known phrase (**Known to Learning**), the learning phrase (**Learning to Known**), or the mix of the phrases (**Mixed Directions**).

In the big part on the right, you see the units of the vocabulary collection. You can select which units you want to practice with the check box in front of the unit name. The number of words that each unit contains is shown next to its name. On the right of the name you see your current progress for the unit.

The progress for each unit is displayed as the percentage of the unit completed and the multi-shaded progress bars. The percentage is calculated based on the total number of words in that unit and the confidence level of each word. The progress bars depict the number of words in each confidence level, with a darker shade depicting a higher confidence. A legend can also be seen at the top of the unit selections, in the header. The colors in this legend depict the corresponding colors of the progress bars, from the fully learned words to the words not yet practiced.

### 4.2 Practice Configuration

The **Practice Configuration** allows you to specify more advanced settings that will affect the practice.

In the **Practice Overview** page you reach the **Practice Configuration** with the **Configure Practice** button in the toolbar.

#### 4.2.1 General Practice Settings

You can find several general configuration options for the practice in the **general settings page**.
The most important options are:

- Ignore Accents: with this option if you enter a word with $e$ instead of $é$ it will still count as right.
- Ignore Capitalization: this option allows you to ignore capitalization when you enter words.
- Images and Sound: if you enable images they will be displayed during the practice, if they are available. Same applies to Sound.
- Allow images instead of words: if you enable this option, it will allow an image to be used as the question during practice, provided a translation is not set for that target language’s word.

4.2.2 Blocking

If you plan to practice your vocabulary regularly, you should make sure that the Blocking feature is enabled. Go to the blocking page and tick the check box that says Blocking. Now you can even configure the interval in which words that you answered correctly will be repeated. Blocking means that words will not be asked for some period of time after the last practice. This period of time depends on how well you know the word, so that words you don’t know yet will be asked more frequently.

4.2.3 Thresholds

Thresholds are another way of limiting what you want to practice.
You can decide to practice only words that you know better or less well than some confidence level. Or you can select only words that you have practiced a certain number of times.

### 4.2.4 Specific Practice Settings

Configuration options for the practice with multiple choices can be changed using the specific settings page.

Here you can select if the choices should be of the same type as well as the number of choices.
4.3 Practice

4.3.1 Flash Cards

After having activated the Flash Card Practice Mode and having clicked on Start Practice the following screen shows up. The Flash Card training mode works just as if you would do it with ‘real’ flash cards. You imagine the result and should you wish some help, you can click on Hint which will start to give you the result one letter at a time.

You can also decide to skip a word for now. When you click Answer Later the word will show up again at a later time.

Clicking on Continue reveals the solution. At this stage you then have to tell if you knew the answer.

If you did not know it, click I did not know it. If you did remember the answer, click I knew it. This will take you to the next question.

On the left hand side bottom of the screen you have 7 boxes that show how good you know the vocabulary. These 7 boxes correspond to the blocking levels set under Blocking in the Practice Configuration.

**Tip**

Instead of clicking Continue you can also use the Spacebar of your keyboard.
4.3.2 Mixed Letters

Mixed Letters is a training method that provides you with an immediate help: all letters that are part of the solution are shown mixed up:

Should you wish some help, you can click on Hint which will give you the solution one letter at a time. Of course you can also decide to Answer Later by clicking on that button.
To give the answer type it in the blank field below the mixed letters and press the Enter key or Continue button.

If your answer was correct Parley will tell you so and you can press Enter again or click on Continue to go ahead with the next question.

Should you enter a wrong answer, you will be told to try again:

If you don’t know the answer, just click on Continue a second time. Then the following comes up and you are shown the solution. Go ahead with Continue.
You can overrule how your answer is counted. See Counting an Answer as Right.

4.3.3 Multiple Choice

4.3.3.1 Automatic selection of the possible answers

In Multiple Choice mode you are shown a number of potential answers, of which only one is correct. By clicking on Hint Parley excludes one of the wrong answers so that your choice gets more and more restricted with each further click on Hint. The answer is revealed when only one option is left and the question is counted as wrong. Of course you may also choose Answer Later.
Once you made your choice by clicking on what you believe to be correct or type the number in front of the choice, Parley shows up with the screen below if the answer was right. Go ahead with the next question by clicking on Continue.

If your answer instead was wrong, the correct answer will be shown in green and the wrong one in red. Also here you go ahead by clicking on Continue.
The Parley Handbook

4.3.3.2 With yes/no answers

Normally Parley automatically proposes one correct and several wrong answers in Multiple Choice mode. For some exercises instead you will have preset answers like yes/no or similar. And for these you have to configure the practice by clicking on Configure Practice. Select the tab Specific and you will get something very similar to the following screenshot:

You can overrule how your answer is counted. See Counting an Answer as Right. If you wish to stop practice, just click on the Stop Practice button.
If you have just two choices like yes/no in the section Multiple Choice set the Number of choices to 2.

### 4.3.4 Written

When you select the option Written to do your practice you are supposed to type in the solution. You can use the button Hint which will start to give you the result one letter at a time. Of course you can also decide to Answer Later by clicking on that button.

Once you have entered the solution, click on Continue and Parley will show whether your answer was correct. Go ahead by clicking on Continue again.
Should you give a wrong answer, you may try again several times to find the right answer. If you don’t try again, and just click on Continue, the solution will be shown.

Go ahead practicing by clicking on Continue or stop by clicking on the button Stop Practice.

When the solution is revealed, you see a big icon on the right that indicates if your answer will count as right or wrong.

You can overrule how your answer is counted. See Counting an Answer as Right.

4.3.5 Counting an Answer as Right

After the solution is revealed, you see a big icon on the right that indicates if your answer will count as right or wrong.

If you see the big checkmark, Parley thinks you were right.

If you needed more than one attempt to answer correctly, your answer will be counted as wrong.
You can click the small icon next to the indicator to change how your answer is counted. The big symbol always indicates how the answer is counted.

### 4.3.6 Reset Practice to Initial State

You can reset all your practice scores (remove the confidence levels) to the initial state. You can reset your confidence levels for individual units from within the Practice Overview by right clicking on the unit to reset and choosing Remove Confidence Levels from this Unit or by choosing Remove Confidence Levels from this Unit and all Sub-Units.

### 4.4 Summary After Practice

The summary shows up when you finish a learning session. In the big bar on the top it shows you how well you did.

Below is a table with all the words you practiced, together with the mistakes you made.

The words with the most mistakes are on top so you can easily see what you do not know yet.

Press the Export results button or use Practice → Export results... menu item to export practice results as HTML or OpenDocument text file (.odt).
4.5 Grammar Practice Modes

With Parley you can also learn specific grammar structures, such as the gender of nouns, the comparison forms of adjectives and the conjugation of verbs. Let’s look at some examples.

4.5.1 Articles and Gender of Nouns

Once the practice mode Gender of Nouns is activated, click on Start Practice.

In the case below we use German as language to learn and so you have three genders to choose from: masculine, feminine and neuter. By clicking on Hint one of the wrong answers gets excluded. Of course you can also decide to Answer Later by clicking on that button.

You should enter the articles for the language in the Editor to see the articles instead of the grammatical gender terms. Also note that this only works, if the gender of the words has been set up properly. See Word Types for more information how to change the word type to the right gender.

When you give the correct answer the following is shown and you go ahead practicing by clicking on Continue.
4.5.2 Comparison Forms of Adjectives and Adverbs

On the Practice screen select Comparison Forms and then click on Start Practice to go ahead. This only works when the conjugation forms of the word have been entered in the vocabulary collection. See Entering Comparison Forms.
The exercise requires you to enter the comparison forms for the term shown. In this case the translation of the English word *old* to German. The German language has three forms: *absolute, comparative* and *superlative*. To go on with the exercise just click on **Continue**.

4.5.3 Conjugations

To practice conjugations choose the **Conjugations** mode and the tenses you wish to exercise.

In the document the conjugation forms of the words have to be entered in order to allow this practice mode to work. See **Entering Inflection Forms**.
Then click on **Start Practice**. You are required to enter the correct conjugation forms according to the tense shown. To go ahead click on **Continue**
Chapter 5

Vocabulary Editing

5.1 Setup

Before you start using a vocabulary collection or create your own it is helpful to understand the different elements in Parley and configure them accordingly. The next sections will guide you step by step through this process. There are several locations in Parley for settings:

- **File → Properties** This is the place for the ‘General Document Properties’, meaning some information about your vocabulary collection and yourself.
- **Edit → Languages** Find here settings around the languages you use
- **Practice → Configure Practice** Here are settings how you practice your vocabulary. Depending on what you want to do during the specific learning session you change them on the fly.
- **Settings → Configure Parley** For more general and display settings

5.1.1 About the Collection

Entering meta data like a title and your contact info is relevant if you plan to make your collection available for other people. Use **File → Properties** to edit the data.
5.1.2 Vocabulary Columns

Depending on what your learning sessions are going to be about it can be relevant to have further Vocabulary Columns show up in your edit section. To choose these columns select View from the menubar and then Vocabulary Columns. There you can determine if the columns for Pronunciation, Word Type, Synonym, Antonym, Example, Comment and/or Paraphrase are to be shown.
5.1.3 Languages and Grammar

Set up some grammar details to let Parley help you. Use Edit → Languages to pull up the grammar dialog.

Articles in English are simply the which is the definite article and a as indefinite article. Most other languages have more articles which can be filled in at the articles tab.

For conjugations the personal pronouns should be filled out. Most languages do not have different conjugation forms for he/she/it, in that case, you should not check Male/Female have different conjugations! Simply enter the pronouns for all three forms.

<table>
<thead>
<tr>
<th></th>
<th>Singular</th>
<th>Plural</th>
</tr>
</thead>
<tbody>
<tr>
<td>1st Person</td>
<td>I</td>
<td>we</td>
</tr>
<tr>
<td>2nd Person</td>
<td>you</td>
<td>you</td>
</tr>
<tr>
<td>3rd Person</td>
<td>he/she/it</td>
<td>they</td>
</tr>
</tbody>
</table>

Table 5.1: Personal Pronouns in English

Tenses: Depending on the language, you can enter the right tenses which you later want to learn how to conjugate. Examples are: Simple Present, Simple Past, Future I etc.

Btw. by clicking on the Add Language button you can add an additional language to your collection.

5.1.3.1 Let’s Have a Closer Look at Spanish

On the General tab the basic language settings, like here

- **Language** = Spanish
- **Name** = Spanish
- **Keyboard layout** = us (for English)

You can leave Keyboard layout empty if you are not sure about what you are using. Parley will then simply take the standard layout of your computer.
Let’s have a look at the Articles tab: Spanish knows only male and female nouns, therefore the field Neutral remains empty.

Spanish Personal Pronouns have multiple forms for 3rd person singular and 1st, 2nd and 3rd person plural. To remain consistent, the possibilities should be entered with a / between the two forms.
Under **Tenses** you will find the various tenses that are available for a verb form. You can add to the tenses that are already there by clicking on **New**, modify with **Modify** or in case something does not actually exist simply **Delete** the tense after having it selected.

### 5.2 Units

On the left you have a list of units. If you started a new collection, this list might be empty except for one unit that was created by default for you.

If you cannot see the list of units, you might have to enable it in the View menu - **View → Units**.
The Parley Handbook

The check boxes in front of the unit name show which units are currently included in your practice. The number next to it is the number of words in the unit.

5.2.1 New Unit

Add a new unit: Select where this unit belongs to, for example the collection My Spanish Lessons.

In the Unit menu, select New Unit.

Please make sure to select the right point in the tree structure of units before selecting New Unit. In our case, wanting a Sub-Unit of Collection: My Spanish Lessons it is exactly that one that needs to be selected before going ahead with New Unit.

5.2.2 Moving, Renaming and Deleting Units

To change the name of a unit, double click it, or right click on the unit and choose Rename Unit. You can also delete it this way (but you’ll lose its contents also then).

If you don’t like the arrangement of units, you can move a unit with the mouse. You can drag it onto another unit, then it will become a child of that unit.
5.2.3 Splitting a Unit

If your units grow too big, you can choose to split them up to make learning easier in small units. 20 words for a unit is probably a good size. Right click a unit, or use Unit → Split Unit into Smaller Units and the unit will be separated into child units. You can choose to randomize the words that are put into the new units before assigning them, or to keep them in order.

5.2.4 What is Shown in the Table

Parley shows always the words of the unit that you have currently selected. You can enable to see the words in sub-units contained in this unit also. Use Unit → Show Entries from Child Units to enable this. That way, you can browse all words by selecting the document unit at the very top.

5.3 Word Types

Parley lets you associate word types with the words. Word types are for example: Nouns, Verbs, Adjectives and Adverbs.

In order to work with word types, enable the word type tool: View → Word Types.

You can categorize the word types just like units.

If you want to see all words of a certain type - e.g. all nouns, simply select the noun category, and you will see only nouns in the table.

The easiest way to set the word type, is to drag and drop a word onto its type. You can even do this with multiple words at the same time.

5.3.1 Adding New Vocabulary

Use Add New Entry in the toolbar to add new words. You can start typing the word in the first language right away. After entering the first word, press Tab to go to the next language.

5.3.2 Editing Words

If you want to replace a word, select its entry and start typing. To change the word instead, double click the entry and you can change the contents of the cell without losing the old word.

Press Tab to go to the next word while staying in editing mode. Enter leaves this mode. You can use the arrow keys to move around.

5.4 Synonyms

Synonyms are hard to set up and do not always work really well. Here is how you set them up in any case:

- Use View → Synonyms to see the synonyms tool.
- Select first word (A) you want to make synonyms, then click on the second word (B)
- The button in the synonym tool changes it’s text to A and B are synonyms

The words will now be shown as connected in the synonym tool and can be recognized as synonyms in the practice.
5.5 Adding Images

First show the image tool by selecting **View** in the menubar and then clicking on **Image**. The check box in front of **Image** will then be activated. This will show up the picture section on the right hand side of the Parley screen.

To add an image to a word make sure the word is highlighted. In the image section on the right hand side click on the **Folder icon** and choose the picture you wish to associate. On selecting an image for a pair of translations, the bottom right corners of the cells of both the words would be marked with a blue flag. Hovering over this flag with the mouse cursor shows the name and path of the image file.

![Image section in Parley](image.png)

5.6 Adding Sound

First show the sound tool by selecting **View** in the menubar and then clicking on **Sound**. This will show up the sound section on the right hand side of the Parley screen.

To add a sound to a word make sure the word is highlighted. In the sound section on the right hand side click on the **Folder icon** and choose the sound you wish to associate. On selecting a sound file for a word, the top right corner of the cell of that word would be marked with a red flag. Hovering over this flag with the mouse cursor shows the name and path of the sound file.
The Parley Handbook

The needed sound files can be obtained from Wiktionary using Parley inbuilt scripts.

To obtain the sound file highlight a word in the list then choose Scripts → Fetch Sound from the Parley menu.

The sound file will be saved next to the current vocabulary file in the name_of_vocabulary_files subfolder.

5.7 Entering Comparison Forms

In order to enter comparison forms, make sure the comparison forms tool is enabled. You open it with the menu: View → Comparison Forms.

First select a word that is an adjective or adverb.

Click the Adjective or Adverb button in the comparison forms tool.

Enter the comparison forms.
Now you can use the Comparison Forms Practice mode.

### 5.8 Entering Inflection Forms

In order to enter inflection forms, make sure the inflection forms tool is enabled. You open it with the menu: **View → Inflection (verbs, adjectives, nouns)**.

First select a word that is a verb.

Click the **Verb** button in the inflections tool.
After selecting the right tense in the tense selection box, enter the conjugation forms. The tenses can be configured for each language: Languages and Grammar. Now you can use the Conjugations Practice mode.

Use the Noun or Adjective button to add declension forms to your vocabulary.

5.9 Creating New Files

In this section we will describe how to create new files and this not only with the usual vocabulary learning part, but also for grammar exercises, mathematics etc.

5.9.1 New Collection: Vocabulary English-German

In this section we describe how you can create a vocabulary training file including pictures and sound. In a second stage we will also add adjectives and verbs. This is a very complete example and therefore quite long. Eventually you will not need all points for your project.

Since we wish to add sound-files and pictures, we should make sure that these will all be in one folder which for convenience is being called eng-deu. Our data file we create with Parley will be saved in the same folder. This will help a lot when you decide to share your work with others.

So this is what we have in terms of sound files and pictures:
Let’s start from the Dashboard which is shown once you launch Parley:

Click on the button **Create a New Collection**.

The **General Document Properties** page shows up which is being filled as follows (just adapt to what your file is about):
Next click on **OK**. The following screen asks you to set up the language details. Here we don’t want to change anything and therefore we just click on **OK**.

As a first step, let’s create the vocabulary part. We will think about the addition of the sound files and pictures in a second stage. This is what the unit looks like:

Before we do anything else, let’s save the file to the folder with the pictures and sound-files. Use **File → Save** and select the folder using the navigation. In this example we will call the file **Trainer eng-deu** - once you entered the name just click on save.
If you now check your folder where the sound-files and pictures are, you will also find the file `Trainer eng-deu.kvtml`.

Let’s have a short look at the words we want to add: apple, bird, cat, cherry, cow, orange, pear, snake, strawberry. We have animals and fruit and therefore we decide to create two units that are called: **Animals** and **Fruits**.

We now rename **Lesson 1** to **Animals** and then we add a unit called **Fruits**. Right-click on **Lesson 1** and choose **Rename Unit** from the options shown. Now **Lesson 1** is highlighted and you can simply overwrite it by typing in **Animals**. When done, hit the **Enter** key. Now right-click on **Collection: Vocabulary trainer E...** which is the root of the unit tree and choose **New Unit** from the options shown. In the new field write **Fruits** and hit the **Enter** key again.

First, let’s insert the animals. Please click on the unit **Animals** and you will get an empty table you can fill in. Click with your mouse in the first field, and insert the source terms. Then, insert the target terms in the second column. Once you’ve inserted all 4 English animal names with their German translation the screen looks like this:

<table>
<thead>
<tr>
<th>Places</th>
<th>Home</th>
<th>Documents</th>
<th>Parley</th>
</tr>
</thead>
</table>

Name: Trainer eng-deu
Filter: KDE Vocabulary Document

If you now check your folder where the sound-files and pictures are, you will also find the file `Trainer eng-deu.kvtml`.

Let’s have a short look at the words we want to add: apple, bird, cat, cherry, cow, orange, pear, snake, strawberry. We have animals and fruit and therefore we decide to create two units that are called: Animals and Fruits.

We now rename **Lesson 1** to **Animals** and then we add a unit called **Fruits**. Right-click on **Lesson 1** and choose **Rename Unit** from the options shown. Now **Lesson 1** is highlighted and you can simply overwrite it by typing in **Animals**. When done, hit the **Enter** key. Now right-click on **Collection: Vocabulary trainer E...** which is the root of the unit tree and choose **New Unit** from the options shown. In the new field write **Fruits** and hit the **Enter** key again.

First, let’s insert the animals. Please click on the unit **Animals** and you will get an empty table you can fill in. Click with your mouse in the first field, and insert the source terms. Then, insert the target terms in the second column. Once you’ve inserted all 4 English animal names with their German translation the screen looks like this:
In our case we want only 4 entries in the animals unit. There are many empty lines that should be deleted. To do this click on the first empty field, and keep the Shift key pressed while clicking on the last empty field. All lines to be deleted will be highlighted. Then, press the Del key.

Let’s add the fruit terminology. Just click on the unit named Fruits. This second unit is completely empty. Since we have five fruit terms we need to add five lines. Therefore, press the Ins key five times, and then, just like before, we add our terminology.

Don’t forget to save every now and then ...

A click on the root of our unit tree Collection: Vocabulary trainer E... and Parley will show us all entries that are present in the two units:

Time to add sound and images. First of all we need to activate the Image and Sound views. From the menubar select View and there click on Image and then Sound. Once these options are activated, two new sections are shown on the right hand side of the Parley editing screen: Image and Sound.
Select the English word *apple* by clicking on it. It is highlighted, so let’s add the picture. In the image section on the right hand side click on the *Folder* icon and choose the picture you wish to associate.

To add the pronunciation for the English *apple*, do the same in the Sound section, selecting the relevant sound file.

By clicking on the *Play* button in the sound tool you can listen to the pronunciation.

The screen will then look like this:

![Screen showing the Parley Handbook interface with a table of English and German words, an image of an apple, and a play button for pronunciation.](image)

Then click on the German translation *Apfel*. The field is now highlighted to indicate the selection. You will note the picture with the apple is associated also to the German term. In the sound section select the pronunciation, just like before.
The Parley Handbook

Just go ahead like this for all terms.

Time to add adjectives and verbs as units to our project. So just do as before with the unit Fruits and create two new units: Adjectives and Verbs. Let’s assume we will add big, small, old, young, narrow in the adjective unit and to go, to come, to buy, to drink, to eat in the verb unit.

The following shows a screenshot with all inserted terminology. Now, words are mixed and it would be nice to see what is a noun, adjective or verb.

As the next step we are going to show the Word Type. Select View in the menubar and then select Vocabulary Columns. We activate Word Type for English and German by clicking on the check box in front of Word Type. Then click on OK to accept the changes.
By clicking on the fields in the column **Word Type** you can select the word type and for those languages where nouns have a gender you can also select the **Noun/Gender** combination. Alternatively start to type the first characters of a word type to select it. Below the **Word Type** column with part of the selections already done.

Once we have specified all the word types, we will first consider **Adjectives**, adding **Comparison Forms** to them. So let’s move to the **Adjectives** unit only.
To show the **Comparison Forms** on the right hand side of the screen, select the **View** in the menu bar and activate the **Comparison Forms** check box.

Edit the **Comparison Forms** by adding **Comparative** and **Superlative** to the single adjectives. First, click on the adjective for which you wish to add the comparison forms, in our case *big*, and add *bigger* and *biggest*. Then, continue with the next adjective to complete, until all comparison forms have been entered.
Finally, let’s consider the **Conjugation** form of the **Verbs**. Select the **Verbs** unit and then activate the conjugation section on the right hand side by selecting **View** from the menubar and activating **Conjugation**. As an example we edit the present tense (**Präsens**) form of **gehen**. Please first select **Präsens** from the drop down menu and then add the verb forms.

This needs to be done for all verbs, and in all possible tenses.

Once you are done you can start to practice by clicking on the **Practice** button.

### 5.9.2 New Collection: Single Names and Collective Names

This exercise was created for the 3rd class of an Italian primary school. Pupils are supposed to connect single names with collective names, such as **tree → woods**
When you start Parley you get the start page, eventually also listing some previously used files (that you cannot see here).

Click on Create a New Collection and the following screen with empty or partly filled fields will show up:

Fill in the title, here nomi singoli e collettivi, your name, email address, in the Comment section you can write down a more detailed description, select your category and license. Then there we have something special: instead of indicating the first and second language, like it normally would happen, we added nome singolo (single name) and nome collettivo (collective name). Setup Grammar Details and Download Grammar are not needed here. In the screenshot they are still
activated - please deactivate them by just clicking on the check boxes. When you are done, please click on OK.

Select View → Languages and the Properties for nome singolo page comes up and here you see it already with the necessary changes made:

![Properties for nome singolo](image)

On the left hand side you can see where the data you are adding belongs to. *nome singolo*. Choose the language, here *Italian* and insert *nome singolo* in the following editable field. Then click on OK.

Now the Properties for nome collettivo page is shown:

![Properties for nome collettivo](image)

Like before: choose *Italian* as language and insert *nome collettivo* and click on OK.
And now you can start to edit:

Just insert the *nome singolo* (single name) in the first column and the corresponding *nome collettivo* (collective name) in the second column.

If the number of available fields is not enough, just right-click anywhere on the edit section and choose **Add New Entry**. Don’t forget to save your file every now and then. When you have finished adding all entries you will want to see if Practice mode works fine. Well just click on the **Practice** button right above the edit section and the page with the practice settings comes up:
The Parley Handbook

In this case Multiple Choice is a good option, but also Written will do fine. After choosing the Practice Mode just click on Start Practice and have fun.

5.10 Getting Additional Collections

When you are on the Dashboard you have the possibility to install collections directly from the server, provided you are online. Just click on Download New Collections.

A window with many interesting collections opens. Just select what you find most interesting and click on Install. Then open the file to practice or edit.
5.11 Configure Parley

You can configure the appearance of Parley from the Dashboard or from within the Edit section. Select Settings from the menubar and then Configure Parley.
5.11.1 Theme Tab

The configuration opens with the Theme section. This is the place where you can choose how Parley should greet you when launching it: an elegant Gray version or the all time busy Bees. Note that it could well be that Fluffy Bunny is not in your version: if you want it, read the following section.

Once you selected your preferred theme, click on OK.

Screenshots of the Bees theme:

And if these are not enough: you can click on Get New Themes to find more themes. Over time we hope that more and more themes come along. If you know how to create SVG graphics (for example with Inkscape), you can create your own theme and share it with the world.
5.11.2 General Tab

The General tab gives you some options regarding the behavior of Parley.

5.11.2.1 Open/Save options

Always load the last opened collection on start will immediately take you back to the vocabulary you were learning. Often you will use this together with the second option Save vocabularies automatically on close and quit because it’s just handy not to have always answer the same question if changes (including learning results) should be changed or not. The option Create a backup every … minutes can be very handy to help you save your work frequently. One less thing to think about.

Sometimes the import and/or export of text (CSV) files can be very handy and there you need the proper separator to elaborate data afterwards or to be able to read the data you got from somewhere else. Parley allows you to choose among various separators to make sure you can re-use your data.

5.11.2.2 Editing option

Here you can determine whether Parley automatically appends new rows while you are editing your vocabulary collection. This can be useful if you want to add many entries, before then splitting them up into various units. On the other hand, it can be good to have this option off if you want to work by creating units with a set maximum number of entries.

Additional themes can be found on kde-look.org
5.11.3 View Tab

The View Settings allows you to change font and size for the pronunciation symbols, and you can choose the Base color for displaying confidence levels you like best.
Chapter 6

Notes For Advanced Users

6.1 Upload and Share Collections

You can upload your files and share them with others.
Use Upload Vocabulary Document from the file menu in the Editor within Parley.
If that does not work, you can also visit store.kde.org.
In either case the files will show up in the Download New Collections dialog on the Dashboard.

6.2 File format

If you are interested in the file formats that Parley can read and stores the vocabulary collections in, visit:
Parley File Formats on userbase.kde.org
Chapter 7

Credits and License

7.1 Thanks

I’d like to thank the following people personally for their contribution to Parley:

- Peter Hedlund who kept KVocTrain alive and started the KDE 4 port which eventually would become Parley
- David Capel
- Avgoustinos Kadis
- Daniel Laidig
- Johannes Simon

I also want to thank all the other unnamed persons, especially the whole KDE team, for their help, constructive criticism, suggestions or bug-reports.

7.2 Copyright

Parley copyright 2007-2010 Frederik Gladhorn frederik.gladhorn@kdemail.net

Documentation copyright 2010 Frederik Gladhorn frederik.gladhorn@kdemail.net, Sabine Eller s.eller@voxhumanitatis.org, Daniel Laidig d.laidig@gmx.de; 2014 Amarvir Singh amar-vir.ammu.93@gmail.com

This documentation is licensed under the terms of the GNU Free Documentation License.
This program is licensed under the terms of the GNU General Public License.