The KAddressBook Handbook
## Contents

1 Introduction  
2 Getting Started  
3 Integration With Other KDE Programs  
4 Adding or Editing Contact Data  
5 Command Reference  

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Introduction</td>
<td>6</td>
</tr>
<tr>
<td>2 Getting Started</td>
<td>7</td>
</tr>
<tr>
<td>2.1 How to Add a New Address Book</td>
<td>7</td>
</tr>
<tr>
<td>2.2 How to Add a New Contact</td>
<td>12</td>
</tr>
<tr>
<td>3 Integration With Other KDE Programs</td>
<td>14</td>
</tr>
<tr>
<td>3.1 Integration Overview -- KMail</td>
<td>14</td>
</tr>
<tr>
<td>3.1.1 Starting KAddressBook from KMail’s Tools Menu</td>
<td>14</td>
</tr>
<tr>
<td>3.1.2 Querying KAddressBook from KMail’s Message Composition Window</td>
<td>15</td>
</tr>
<tr>
<td>3.1.3 KMail’s Recipient Selection Dialog</td>
<td>16</td>
</tr>
<tr>
<td>3.1.4 KMail’s New Contact Creation Interface</td>
<td>17</td>
</tr>
<tr>
<td>3.2 KAddressBook’s Interface with KOrganizer</td>
<td>18</td>
</tr>
<tr>
<td>4 Adding or Editing Contact Data</td>
<td>21</td>
</tr>
<tr>
<td>4.1 The Basics</td>
<td>21</td>
</tr>
<tr>
<td>4.1.1 The Contact Tab</td>
<td>21</td>
</tr>
<tr>
<td>4.1.2 The Location Tab</td>
<td>23</td>
</tr>
<tr>
<td>4.1.3 The Business, Personal, and Notes Tabs</td>
<td>24</td>
</tr>
<tr>
<td>4.2 The Tricky Stuff</td>
<td>26</td>
</tr>
<tr>
<td>4.2.1 The Custom Fields Tab</td>
<td>26</td>
</tr>
<tr>
<td>4.2.2 The Crypto Settings Tab</td>
<td>27</td>
</tr>
<tr>
<td>5 Command Reference</td>
<td>29</td>
</tr>
<tr>
<td>5.1 The Menu Bar</td>
<td>29</td>
</tr>
<tr>
<td>5.1.1 The File Menu</td>
<td>29</td>
</tr>
<tr>
<td>5.1.2 The Edit Menu</td>
<td>31</td>
</tr>
<tr>
<td>5.1.3 The View Menu</td>
<td>32</td>
</tr>
<tr>
<td>5.1.4 The Action Menu</td>
<td>33</td>
</tr>
<tr>
<td>5.1.5 The Tools Menu</td>
<td>34</td>
</tr>
<tr>
<td>5.1.6 The Settings Menu</td>
<td>35</td>
</tr>
<tr>
<td>5.1.7 The Help Menu</td>
<td>36</td>
</tr>
<tr>
<td>5.2 The Tool Bar</td>
<td>37</td>
</tr>
<tr>
<td>5.3 The Context Menus</td>
<td>39</td>
</tr>
<tr>
<td>5.3.1 The Address Book Context Menu</td>
<td>39</td>
</tr>
<tr>
<td>5.3.2 The List of Contacts Context Menu</td>
<td>40</td>
</tr>
<tr>
<td>5.3.3 The Individual Contact Context Menu</td>
<td>41</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>6 Glossary</td>
<td>42</td>
</tr>
<tr>
<td>A KAddressBook Advanced Features Reference Section</td>
<td>46</td>
</tr>
<tr>
<td>A.1  . . . . . . . . . . . . . . . . . . . . . .</td>
<td>46</td>
</tr>
<tr>
<td>A.2 The New Group Dialog . . . . . . . . . . .</td>
<td>46</td>
</tr>
<tr>
<td>A.3 The Print-Preview Dialog . . . . . . . . .</td>
<td>47</td>
</tr>
<tr>
<td>A.4 The Configure LDAP Dialog . . . . . . . .</td>
<td>50</td>
</tr>
<tr>
<td>A.5 The Import CSV File Function . . . . . . .</td>
<td>52</td>
</tr>
<tr>
<td>A.6 The Export CSV File Function . . . . . . .</td>
<td>54</td>
</tr>
<tr>
<td>A.7 The Change Number of Columns Function . .</td>
<td>55</td>
</tr>
<tr>
<td>A.8 The Configure Shortcuts Option . . . . . .</td>
<td>57</td>
</tr>
<tr>
<td>A.9 The Configure Toolbars Option . . . . . .</td>
<td>60</td>
</tr>
<tr>
<td>A.10 The Configure KAddressBook Option . . . .</td>
<td>61</td>
</tr>
<tr>
<td>A.11 Credits and Licenses . . . . . . . . . . .</td>
<td>64</td>
</tr>
</tbody>
</table>
Abstract

KAddressBook is part of the KDE suite of personal information management (PIM) programs. KAddressBook is primarily an email address manager, but it can also help you keep track of your friends’ and associates’ telephone numbers, web sites, social media connections, snail-mail addresses, and more, besides. It’s your one-stop shop for keeping track of all the people you know.
Chapter 1

Introduction

KAddressBook is part of the KDE suite of personal information management (PIM) programs. KAddressBook is primarily an email address manager, but it can also help you keep track of your friends’ and associates’ telephone numbers, web sites, social media connections, snail-mail addresses, and more, besides. It’s your one-stop shop for keeping track of all the people you know!

KAddressBook’s primary display. The Menubar is at the top, the Toolbar is next, and there are three Panels for data in the Text Area at the bottom.

KAddressBook has been integrated into the structure of KMail, the KDE email client. So once you add a contact’s name to KAddressBook, you can address an email message to that person by just typing in a portion of his name. Or if you receive an email message from somebody new, you can add him to your address book with just a few clicks of your mouse.

KAddressBook also permits you to maintain multiple separate contact lists in a wide variety of popular address list formats, either on your local hard disk, or via a resource residing in the cloud. It also supports importing and exporting contact data in .csv (Comma Separated Values), .ldif (LDAP Data Interchange Format), and .vcf (Virtual business Card Format) record formats.
Chapter 2

Getting Started

Here is a picture of the primary KAddressBook user interface before any address data have been entered. The first thing you may want to do is create an address book. Note that the ‘Personal Contacts’ address book is present by default.

![KAddressBook’s ‘empty’ GUI interface, before any extra address books have been created. The ‘Personal Contacts’ address book is present when KAddressBook is first installed.](image)

2.1 How to Add a New Address Book

1. Open KAddressBook’s Add Address Book dialog with the File → New → Add Address Book... option. A dialog box will appear.
The KAddressBook Handbook

KAddressBook’s Add Address Book dialog. Five cloud services are supported, plus three local storage options.

2. Choose one of the options that appear in the dialog. Several of these options link to data collections residing in the cloud: DAV groupware (Distributed Authoring and Versioning, RFC4918), Google Contacts (your gmail.com account), Kolab groupware server (collaboration via IMAP), Microsoft® Exchange Server EWS (Exchange Web Services, on servers running MS software), and Open-Xchange Groupware Server (an open-source alternative to MS EWS). If you already have access to one or more of these cloud-based resources, you can integrate those data into KAddressBook by simply selecting the option and then entering your login credentials.

The remaining options in the dialog (Personal Contacts, vCard Directory, and vCard File) all create data sets that are saved on a local storage device. Each one of these options uses the same data format (.vcf, or Virtual Card Format), the only difference being in which particular directory the data are saved. The ‘Personal Contacts’ and ‘vCard Directory’ options create a separate file for each named contact you save; the ‘vCard File’ option puts all the data into one file. It’s probably easiest to start with the pre-defined ‘Personal Contacts’ address book. You will not need more address books unless you have extensive contact lists you would like to keep separate.

3. Once you have made your selection, click on OK. If you have selected a cloud-based service a brief dialog will ensue, to establish communications between Akonadi (the PIM cross-desktop storage service) and the selected cloud server. Here’s what the dialog looks like for a Google (gmail.com) account. The other cloud-based services are slightly different, but similar.
KAddressBook’s link-to-gmail dialog. Begin by clicking ‘Add’. A new dialog will appear. Once your credentials have been accepted, this screen will reappear, and you will click ✓ OK. If you would like KAddressBook to refresh the locally cached copy of your contact list automatically, do it here, before you click ✓ OK.

Another picture of KAddressBook’s link-to-gmail dialog. Enter your gmail.com address and click Next. You will be asked to enter your gmail password.
Yet another picture of KAddressBook’s link-to-gmail dialog. Your account name and password have been accepted by Google’s server. Read the privacy notice and press **Allow**, then ✓ **OK** in the ‘Add’ dialog with which you started.

Enter your login credentials as illustrated above and say OK. Voila! Your cloud-based contact list is now integrated into KAddressBook.

Another picture of the KAddressBook window, after a gmail.com account has been added. You can now manipulate your gmail contacts via KAddressBook, if you like.

As the preceding screenshot indicates, once you have registered KAddressBook as a trusted resource, you can view and edit your gmail contacts using KAddressBook. Of course, you
may also continue to maintain your contacts by using a web browser, if you wish.

4. If you selected one of the local address book options in step 2 above, a different dialog will ensue.

\[\text{KAddressBook’s ‘Personal Contacts’ dialog. You may specify which directory will contain your data, and whether you have write access to this resource, or not. For most people, the default selections (as shown above) work well.}\]

Make any modifications you deem necessary in the ‘Personal Contacts’ dialog, then click ✓ OK . A new address book will appear in the main KAddressBook interface window, as shown below.
2.2 How to Add a New Contact

1. Open KAddressBook’s New Contact dialog by clicking the + New Contact button on the Toolbar. A dialog box will appear.

2. As you can see from the preceding screenshot, the ‘New Contact’ dialog allows one to enter several different data items. Additional data may be entered via the ‘Location’, ‘Business’,
‘Personal’, ‘Notes’, ‘Custom Fields’, and ‘Crypto Settings’ sub-dialogs, as explained more fully in chapter 4, below. For now, let’s concentrate on adding the ‘Contact’ data items appearing in the preceding illustration.

3. If you have created more than one address book, use the drop-down list labeled ‘Add to:’ to select the data set to which the new contact will be added. Then enter the new contact’s name in the input field marked ‘Name’, and key in his or her email address in the input field labeled ‘Email’. If you want to specify special formatting options for this contact’s name data, click the ... button to the right of the ‘Name’ input field and follow the prompts. If you wish to add more email addresses for this person, click the + button to the right of the ‘Email’ input field and another Email input field will be generated. To delete an Email address, click the associated − button.

4. You may also associate a nickname, one or more telephone numbers, multiple instant messaging services, and several web sites with each contact in an address book, as explained in chapter 4. You may also use the ‘Show messages ...’ and ‘Allow remote content ...’ options to fine-tune the way KMail handles email you receive from each contact. See chapter 3 for a more complete explanation.
Chapter 3

Integration With Other KDE Programs

3.1 Integration Overview -- KMail

Because KAddressBook -- an essential piece of PIM, KDE’s suite of Personal Information Management programs -- is the central repository for information about all your contacts, it has been integrated into KMail and also into KOrganizer. Here is a quick look at the interface between KAddressBook and those two programs.

3.1.1 Starting KAddressBook from KMail’s Tools Menu

<table>
<thead>
<tr>
<th>Tools</th>
<th>Settings</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>🔎 Find Messages...</td>
<td>S</td>
<td></td>
</tr>
<tr>
<td>📝 Address Book</td>
<td></td>
<td></td>
</tr>
<tr>
<td>⌨ Certificate Manager</td>
<td></td>
<td></td>
</tr>
<tr>
<td>✅ Edit &quot;Out of Office&quot; Replies...</td>
<td></td>
<td></td>
</tr>
<tr>
<td>⚡ Filter Log Viewer...</td>
<td></td>
<td></td>
</tr>
<tr>
<td>✉️ Import from another Email Client...</td>
<td></td>
<td></td>
</tr>
<tr>
<td>📦 Import/Export KMail Data...</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Launching KAddressBook from KMail’s Tools → Address Book menu choice.

This interface is the epitome of simplicity. Need to consult or update the entry for one of your contacts while reading or composing an email message with KMail? Left click Tools → Address Book, and the KAddressBook application will be launched automatically, allowing quick access to the contact data you want to view or modify.
3.1.2 Querying KAddressBook from KMail’s Message Composition Window

Using KAddressBook’s auto completion feature from inside KMail’s message composition window.

When you are composing a new email message, KMail helps you find the recipient’s complete email address by presenting a list of probable matches drawn from the contents of KAddressBook and from your email archives, as illustrated above. Just left click an item in the list to use that email address.
3.1.3 KMail’s Recipient Selection Dialog

When you are addressing a new email message to multiple recipients, KMail provides a convenient method of choosing multiple addressees from the contacts you have saved with KAddressBook. Simply left click the Select ... button to open a Drop Down Box that lists all the contacts in the selected address books. Then scroll through the list (or use the handy ‘Search:’ box), select the recipient you want, and left click Add as To, Add as CC, or Add as BCC to add this person to the list of email recipients for your new message. Choose Add as Reply-To to insert this address into your message as a ‘Reply To’ tag.
3.1.4 KMail’s New Contact Creation Interface

Invoking the new contact creation dialog from KMail’s message viewing window.

When you receive an email message from someone who is not yet in your address book, KMail makes it very easy to create a new contact. Simply point your cursor at the email address you want to save, then click the right mouse button and a context menu will appear (see above). Select **Add to Address Book** to add the selected email address to one of your address books. If you recognize this person as somebody who’s already in your address book, and he is using a new email address, you may click on **Add to Existing Contact** instead -- this enters a dialog that will direct KAddressBook to the spot where you want to insert the new email address.
Choosing the address book in which the new contact will be created.

KMail will ask you to choose the address book to which the new contact should be added.

Deciding if you would like to edit the newly created contact now, or later.

KMail will also ask you if you wish to edit the new contact that has just been added. Say ✓ Yes if you want to add more data to the new entry right away.

3.2 KAddressBook’s Interface with KOrganizer

KOrganizer, the KDE scheduling and calendar management program, allows you to send e-mail messages to people you want to invite to a meeting, and provides two interfaces with KAddressBook in this connection.
The KAddressBook Handbook

Adding a single attendee to a scheduled meeting in KOrganizer.

The first interface is just like the auto completion feature provided by KMail: just start typing the name of the person you want to invite, and you will be presented with a list of probable matches, as illustrated above.

Adding multiple attendees to a scheduled meeting in KOrganizer.

The second interface is just like the recipient selection dialog provided by KMail: when you left
click the **Select Attendees ...** button, a searchable list of the contacts in all your address books will appear, as the preceding screenshot shows.
Chapter 4

Adding or Editing Contact Data

4.1 The Basics

When you first click on the + Add Contact button on KAddressBook’s Toolbar, this screen will appear. (If you click on Edit Contact, a similar screen appears, the only difference being that the drop-down box labeled ‘Add to:’ will not appear as part of the ‘Edit’ dialog. That is why both functions are covered in this chapter: they’re practically identical.)

![KAddressBook's 'Add Contact' dialog after clicking the + Add Contact button on the Toolbar.](image)

4.1.1 The Contact Tab

We have already seen (in How to Add a New Contact) how basic data like Name and Email are entered when a new contact record is created. Here’s a description of the many ways to use the rest of the data fields accessible from the ‘Contact’ tab in the + Add Contact dialog.
Phone
You may associate one or more telephone numbers with this person. Use the + and − buttons to add or delete phone number fields. The Home Drop Down Box allows you to identify fifteen categories of phone numbers (Home, Work, Mobile, Car, ISDN, PCS, etc.)

Messaging
You may associate one or more Instant Messaging service identities with this person. Use the + and − buttons to add or delete messaging service fields. The Select Drop Down Box permits you to identify thirteen categories of IM services: AIM, Facebook, Gadu-Gadu, Google Talk, GroupWise, ICQ, IRC, Jabber, Meanwhile, SMS, Skype, Twitter, and Yahoo. (MSN Messenger is still on the list of IM services in version 5.10.3; it has been defunct since 2014.)

Web
You may associate one or more web site URLs with this person. Use the + and − buttons to add or delete Web address fields. The Select Drop Down Box allows you to identify three different kinds of Web addresses: Home, Work, and Other.

Tags
You may associate one or more Tags of your own devising with this person. Use the button to enter the Tag creation and configuration dialog illustrated below.

![KAddressBook's 'Manage Tags' dialog after clicking the button next to 'Tags'.](image)

Tags (continued)
Use the Create new tag button and the data entry field to the left to build your customized list of tags. Select the tags associated with this person from the list appearing in the configuration window. Press the OK button to add the selected tags to this contact.
Blog Feed
Use this field to record the URL associated with this contact’s web log, or blog.

Show messages ...
Use this Drop Down Box to override the corresponding message display option in KMail’s Privacy & Security configuration menu. Choose ‘Default’ to leave it up to KMail. Choose ‘Plain Text’ or ‘HTML’ if you want to override KMail’s default behavior when you receive a message from this person.

Allow remote content ...
Select this option if you want to override the corresponding message display option in KMail’s Privacy & Security configuration menu when you receive a message from this person.

✓ OK
Select this option to save the changes you have made. This button performs the same function in all seven tabs appearing in the Add Contact dialog.

⊘ Cancel
Select this option to leave the Add Contact dialog without saving your changes. This button performs the same function in all seven tabs appearing in the ‘Add Contact’ dialog.

4.1.2 The Location Tab
Use the data input fields in the ‘Location’ tab shown below to associate one or more snail-mail addresses with this person.

KAddressBook’s ‘Location’ tab, part of the ‘Add Contact’ dialog.
(unlabeled) Drop Down Box
Use this list of categories to describe each mailing address for this contact. Available options include ‘Home’, ‘Work’, ‘Postal’, etc.

Street / Post Office Box / Postal Code / Locality / Region
Use these free-form data fields to enter mailing address data: Street Address, PO Box, ZIP Code, City, and State, respectively, for addresses in the U.S.A.

Country
Use this Drop Down Box to select a country, from Afghanistan to Zimbabwe.

This is the preferred address
Check this box to designate the preferred, or default, mailing address.

Add Address
When you have finished entering address data, left click this button to add a new address to the set of saved addresses appearing in the large display window to the right.

Icon in the large display window
Left click this icon to edit the associated address data.

Icon in the large display window
Left click this icon to delete the associated address data.

4.1.3 The Business, Personal, and Notes Tabs
The next three tabs in the ‘Add Contact’ dialog are even simpler than the ‘Location’ tab. They allow you to save some information about this person’s business and professional affiliations, a few personal details, and miscellaneous free-form notes, respectively.

KAddressBook’s ‘Business’ tab, part of the ‘Add Contact’ dialog.
The ‘Business’ tab, shown above, lets you save some additional details about this person’s professional and business associations. All the input fields are free-form; you may enter any kind of text data in each field. The small button will open a file search dialog, making it easy to associate a filename with this person’s ‘Free/Busy’ schedule, if you wish.

Notice that you should enter your business associate’s phone as a telephone number under the ‘Contact’ tab. Similarly, his office address is entered via the ‘Location’ tab, as described in the preceding section.

KAddressBook’s ‘Personal’ tab, part of the ‘Add Contact’ dialog.

Use this tab to store a few personal details: this person’s birthday, his wedding anniversary, and the name of his partner, or significant other. Click one of the buttons (e.g., ) to enter his date of birth, or his wedding anniversary.
The KAddressBook Handbook

4.2 The Tricky Stuff

KAddressBook provides a couple of more complex data storage features, in addition to the simple functions described in the preceding section.

4.2.1 The Custom Fields Tab

Not happy with the wide array of data items that KAddressBook has already pre-programmed for you? Well, you’re in luck. Someday -- maybe soon --you may utilize the ‘Custom Fields’ dialog shown below to define and populate as many additional data fields as you can possibly use.
KAddressBook’s ‘Custom Fields’ tab, part of the ‘Add Contact’ dialog.

This is an experimental feature which doesn’t yet do anything worth talking about. So I’m not going to say anything else about it.

4.2.2 The Crypto Settings Tab

Need to send a confidential email message that ought not be read by prying eyes? KAddressBook provides a simple way for you to associate cryptographic keys with each person on your mailing list.
The KAddressBook Handbook

KAddressBook’s ‘Crypto Settings’ tab, part of the ‘Add Contact’ dialog.

Allowed Protocols
Choose which mode of encryption you wish to use when sending a message to this person: Inline OpenPGP, OpenPGP/MIME, S/MIME, or S/MIME Opaque.

Preferred OpenPGP Encryption Key:
Use the Change... button to select from a list of available OpenPGP keys, if you have chosen OpenPGP encryption. Use the button to clear a previously selected key.

Preferred S/MIME Encryption Certificate:
Use the Change... button to select from a list of available certificates, if you are using a verified key. Use the button to clear a previously selected key.

Message Preference / Sign:
Use this drop-down box to specify when messages addressed to this person should bear your cryptographic signature: Never / Always / If Possible / Ask.

Message Preference / Encrypt:
Use this drop-down box to specify when messages addressed to this person should be encrypted by using the selected protocol and key: Never / Always / If Possible / Ask.
Chapter 5

Command Reference

5.1 The Menu Bar

Here is a rundown of the seven menus appearing on KAddressBook’s Menubar.

5.1.1 The File Menu

KAddressBook’s ‘File’ menu after clicking the File button on the Menubar.

The File menu lets you access six main functions, three of which have several options.

File → New → + New Contact (Ctrl+N)

This has exactly the same effect as clicking the + New Contact button on the Toolbar. See chapter 2 above for complete details.
File → New → 🗒️ New Group (Ctrl+G)

Opens a dialog in which you may define a new group, or mailing list. See the appendix for a detailed explanation of this function.

File → New → 📜 Add Address Book

This opens the ‘Add Address Book’ dialog, which is fully documented in chapter 2 above.

File → Import → Import from LDAP server ...

This function allows you to import data from an LDAP server. The server must be configured before you can use this function. See the appendix for full details.

File → Import → Import CSV file ...

This function allows you to import contact data from a comma separated values (csv) file. A dialog ensues, in which you may associate each field in the input file with a named field in KAddressBook’s internal storage record. See the appendix for a more detailed explanation.

File → Import → Import vCard ...

This function facilitates the importation of vcf, or vCard, data. All three versions of vCard are supported. You can learn more about the vCard formats at this web site.

File → Export → Export CSV file ...

This function allows you to export selected contact data as a Comma Separated Values (csv) file. There are 47 fields in the output record. Please refer to the appendix for a list of those data fields.

File → Export → Export vCard 4.0 ...

This function allows you to export selected contact data as a file in vCard 4.0 format. See this Wikipedia article for more information.

File → Export → Export vCard 3.0 ...

This function allows you to export selected contact data as a file in vCard 3.0 format. This format is similar to vCard 4.0 format.

File → Export → Export vCard 2.1 ...

This function allows you to export selected contact data as a file in vCard 2.1 format. This format is similar to vCard 3.0 format.

File → 🗼️ Print (Ctrl+P)

Opens a printer selection dialog. Use the Print Preview dialog below to set up the range of names and the print format before you select this function.

File → 📷 Print Preview

Opens a print preview dialog, which also permits you to format the report, select which items to include, and specify a sort order, etc. See the appendix for further details.

File → ❎ Quit (Ctrl+Q)

Closes the KAddressBook application.
5.1.2 The Edit Menu

The Edit menu lets you access eight main functions, two of which have multiple options.

Edit → Edit Contact ...
This has nearly the same effect as clicking the + New Contact button on the Toolbar. The difference is that this menu item allows you to edit a contact record that already exists, instead of creating a brand new one. See chapter 2 above for complete details.

Edit → Cut Contact ... (Ctrl+X)
Performs a ‘Cut’ operation on the selected contact. A copy of this contact, in vCard 3.0 format, is placed on the clipboard. The ‘Cut’ will be completed when you ‘Paste’ this contact somewhere.

Edit → Copy Contact ...
Places a copy of this contact on the clipboard, so you can paste it somewhere else.

Edit → Paste (Ctrl+V)
‘Pastes’ the cut or copied contact at the current location. This may be in the same address book you did the ‘Cut’ or ‘Copy’ from, or in another address book. Since the preceding operations placed the contact information on the system’s clipboard, you may also paste it somewhere else besides KAddressBook (e.g. into a text editor, or as a vCard 3.0 file in your home folder).

Edit → Copy Contact To > → (a variable list)
Combines the ‘Copy’ and ‘Paste’ operations into a single click of the left mouse button. The list of destinations displayed depends on how many address books you have created.
The KAddressBook Handbook

**Edit → Move Contact To** > (a variable list)

Works just like the ‘Copy Contact To’ operation described above, except that it combines ‘Cut’ and ‘Paste’ into a single click of the left mouse button.

**Edit → Delete Contact (Del)**

Delete the selected contact from the current address book.

**Edit → Delete Address Book**

Delete the current address book. Be careful with this command – you could lose some data! In theory, this function simply removes the symbolic link between KAddressBook and the associated vCard file or directory (or the hyperlink to a cloud-based service), and the real data will not be altered. Still, it’s probably wisest to make a backup copy of this address book somewhere before you delete it.

### 5.1.3 The View Menu

The View menu lets you access four main functions, and one experimental feature which doesn’t really do anything yet.

**View → Themes**

This menu item doesn’t really do anything. It will open a ‘Themes’ dialog, but that dialog is broken in release 5.10.3.

**View → Simple (one column) (Ctrl+Shift+1)**

Changes the default three panel layout into a single column. For more details, see the appendix.
The KAddressBook Handbook

**View → Two columns (Ctrl+Shift+2)**
Changes the default three panel layout into two panels. For more details, see the appendix.

**View → Three columns (Ctrl+Shift+3)**
Switches back to the default three panel layout.

**View → Show QR Codes**
Check this box to display contact information as a QR code. Uncheck it to suppress QR codes.

### 5.1.4 The Action Menu

![KAddressBook’s ‘Action’ menu after clicking the Action button on the Menubar.](image)

The **Action** menu lets you access two data transmission functions.

**Action → Send vCards...**
This option is similar to ‘Send an email...’, below, except that after you select some contacts with **Ctrl** and your mouse, the message composition window will open with a blank list of addressees, and with files attached (the selected contacts, in vCard 3.0 format). This makes it easy to share selected KAddressBook information with your friends and business associates.

**Action → Send an email...**
This option provides an alternate method for setting a new email message’s recipient list. Press **Ctrl** (or **Shift**) and select the people to whom you wish to send the new message, by using your left mouse button. Then click on ‘Send an Email...’; this will open a KMaisl composition window. All the selected contacts will be listed as ‘To’ addressees.
The KAddressBook Handbook

5.1.5 The Tools Menu

The KAddressBook’s ‘Tools’ menu after clicking the Tools button on the Menu bar.

The Tools menu lets you access two data management functions.

Tools → Merge Contacts...

This tool allows you to merge the contents of two or more KAddressBook records. To activate it, you must first select two or more contacts (hold Ctrl or Shift and left-click contacts to make your selection). A dialog box will appear, asking you to verify which contacts you wish to combine, and where the merged record should be saved. Click ‘merge’ to complete the operation.

Tools → Search Duplicate Contacts...

This tool will search one or more address books for duplicate entries, and offer you the option of merging any duplicate records it finds.
5.1.6 The Settings Menu

KAddressBook's 'Settings' menu after clicking the Settings button on the Menubar.

The Settings menu offers you five options for fine-tuning the way KAddressBook operates.

**Settings → Show Menubar Ctrl+M**

This option allows you to show or hide the Menubar.

**Settings → Show Toolbar**

This option allows you to show or hide the Toolbar.

**Settings → Configure Shortcuts...**

This option allows you to customize the keyboard shortcuts available within KAddressBook. See the appendix for more details.

**Settings → Configure Toolbars...**

This option allows you to customize the contents of KAddressBook’s Toolbar. See the appendix for more details.

**Settings → Configure KAddressBook... Ctrl+Shift+,**

This option allows you to configure several advanced KAddressBook options. See the appendix for more details.
5.1.7 The Help Menu

KAddressBook’s ‘Help’ menu after clicking the Help button on the Menubar.

The Help menu offers seven options.

Help → Handbook F1
This option displays a copy of ‘The KAddressBook Handbook’ via the KHelpCenter utility program.

Help → What’s This? Shift+F1
This is KAddressBook’s built-in help tool. Left-click this option, then move your cursor and click on any one of the first four items on the Toolbar. A brief description of that tool’s function will be displayed.

Help → Report Bug
This option opens a dialog that helps you file a bug report at bugs.kde.org, KDE’s main bug tracking page.

Help → Donate
This opens a web page in your browser, where you may donate money to support KDE. We accept euros, dollars, rubles, sterling, yen, yuan, pesos, etc.

Help → Switch Application Language
This option lets you change the language that is used to label the various menu items and built-in help screens. You must quit KAddressBook and restart it before the new language takes effect.
5.2 The Tool Bar

There are five separate tools available on KAddressBook’s Toolbar: ‘New Contact’, ‘New Group’, ‘Edit Contact’, ‘Search…’, and a category filter. Here’s a picture. (Note that I have only documented the default version of KAddressBook’s Toolbar. You may alter the Toolbar layout by using the ‘Settings’ menu, if you so desire.)

![KAddressBook’s standard Toolbar, up close and personal.](image)

+ **New Contact**
  This Toolbar button opens the ‘Add New Contact’ dialog documented in chapter 4, above.

+ **New Group**
  This Toolbar button opens the ‘Add New Group’ dialog documented in the appendix.

🔗 **Edit Contact**
This Toolbar button opens the ‘Edit Contact’ dialog documented in chapter 4, above.

[ Search... Alt+Q ]
This tool searches through all the contacts in selected address books as you type. Pressing Alt-Q simply positions the cursor inside the ‘Search...’ box. Be aware that this function searches the entirety of each contact record; a search for ‘and’ may return not only Andy Brown and Andrew Jones, but also Bill Smith (who happens to work for Brown and Root Construction Company).
The KAddressBook Handbook

KAddressBook’s ‘Search’ function in action.

[ (All)  
Clicking either button will set the selected categories to ‘None’; the button will reset the selection criteria to ‘All’.

KAddressBook’s ‘Filter’ function in action.

This tool performs a filtering function, based on categories. The two default categories are ‘Untagged’ and ‘Groups’. You can create new categories by associating ‘Tags’ of your own devising with particular contact records (see Add New Contact in chapter 4, above).
5.3 The Context Menus

When you click the right mouse button anywhere inside the main Text Area, a context menu will appear, as illustrated below. The particular menu that appears depends on both the panel within which the right-click occurred and the particular data item that was selected, if any.

5.3.1 The Address Book Context Menu

KAddressBook’s ‘Address Book’ context menu.

- **Add Address Book Folder**
  This context menu option does not perform a useful function in release 5.10.3.

- **Delete Address Book Folder**
  This context menu option does not perform a useful function in release 5.10.3.

- **Add Address Book**
  This context menu option launches the ‘Add Address Book’ dialog that is documented in chapter 2, above.

- **Delete Address Book**
  Choosing this context menu option will delete the selected address book. Be careful!

- **Update Address Book Folder (F5)**
  This context menu option forces KAddressBook to reload the contact data associated with the selected address book.

- **Folder Properties...**
  This context menu option displays summary information about the selected address book.
Address Book Properties...
This context menu option displays summary information about the selected address book.

Serverside Subscription...
This context menu option may or may not perform a useful function in release 5.10.3; so far as I can tell, it is permanently grayed out. If you understand what it does, please let me know (davidbryant AT gvtc.com).

5.3.2 The List of Contacts Context Menu

KAddressBook’s ‘Contact List’ context menu.

+ New Contact (Ctrl+N)
Choosing this context menu option has exactly the same effect as clicking the + New Contact button on the Toolbar. See chapter 2 above for complete details.

👩‍💼 New Group (Ctrl+G)
Choosing this context menu option opens a dialog in which you may define a new group, or mailing list. See the appendix for a detailed explanation.

🔗 Edit Contact ...
Choosing this context menu option has exactly the same effect as clicking the Edit Contact… button on the Toolbar. See chapter 2 above for complete details.

Export >
This context menu function allows you to export selected contact data in either vCard or csv format.
Copy Contact To >
This context menu choice lets you copy the selected contact(s) to a variable destination. The list of destinations displayed when this option is chosen depends on how many address books you have created.

Move Contact To >
Works just like the ‘Copy Contact To’ operation described above, except that it deletes the source data, instead of creating an extra copy of it.

Print (Ctrl+P)
Choosing this context menu item opens a printer selection dialog. Use the Print Preview dialog below to set up the range of names and the print format before you select this function.

Print Preview
This context menu option opens a print preview dialog, which also permits you to format the report, select which items to include, and specify a sort order, etc. See the appendix for further details.

Delete Contact (Del)
Delete the selected contact(s) from the current address book.

5.3.3 The Individual Contact Context Menu

Depending on which data item you select, the caption in this context menu may vary. But in every case, the function is the same: the selected data item is copied to the clipboard.
Chapter 6

Glossary

AIM
AIM stands for America Online Instant Messaging. AIM was an early leader in the competitive IM marketplace, but fell into disfavor as AOL itself became less popular. The original service was discontinued in 2017, but fans have kept it running at this web site.

Akonadi
An extensible cross-desktop storage service for PIM data and meta data providing concurrent read, write, and query access. Akonadi can be manipulated with the akonadictl command: enter ‘akonadictl --help’ in a console window to learn more.

Cloud-based service
Any provider of data storage and data processing resources residing in some ‘cloud’ of servers one may access via the internet.

.csv
A Comma Separated Values (or .csv) file is a plain text document in which each line, or record, is divided into fields by a specific separator character, usually a comma. The .csv format dates back to the early days of computing. It is still widely used, mainly because it is conceptually so simple.

DAV
DAV stands for Distributed Authoring and Versioning, which exists in several ‘flavors’, such as WebDAV (for creating pages on the internet), GroupDAV (for groupware, open source software authored by a group of collaborators), and CalDAV (calendar management for groups), each one of which helps connect open source clients with open source servers.

DIGEST-MD5
DIGEST-MD5 is an authentication technique used to set up secure communications between a client and an internet service. It gets its name from the MD5 hashing function used to encode the client’s credentials. See this Wikipedia article to learn more about it.

EWS
EWS stands for Exchange Web Services, Microsoft®’s set of proprietary protocols for exchanging personal data between internet servers and end users, or clients. Kolab provides similar functionality.

Gadu-Gadu
Gadu-Gadu (aka GG) is the most popular instant-messaging app in Poland.
GMX
GMX stands for Global Mail eXchange (or, in Germany, Global Message eXchange), a free advertising-supported email service. Visit either this web site or this one to learn more about it.

Gravatar
Gravatar, or Globally Recognized Avatar, is a graphic image associated with a WordPress user’s email address. It is usually displayed as an 80px X 80px graphic image. Since many bloggers use WordPress software, the Gravatar is widely available.

GroupWise
GroupWise Messenger is an instant messaging service sponsored by Micro Focus International plc, a software company located in Newbury, Berkshire, England. You can get a copy of the Messenger software from this web site.

GSSAPI
GSSAPI stands for Generic Security Service Application Program Interface, a sort of ‘dictionary’ for the many security protocols in use on the internet. It consists of a program library and a set of standard subroutine calls that allow an internet client to determine which particular security protocol an internet service is using, and then to encode/decode the user’s credentials appropriately.

ICQ
ICQ is not precisely an acronym: it’s a pun meant to sound like ‘I Seek You’. It is one of the original IM platforms, first coming online in 1996. The software is available for download here.

IMAP
IMAP stands for Internet Message Access Protocol, a widely available method for managing email messages. IMAP maintains and synchronizes local and remote copies of a set of messages -- in other words, the locally stored data for an IMAP account are a mirror image of the messages on the server.

Inline OpenPGP
Inline OpenPGP is an encryption protocol in which PGP signatures are directly embedded in the body of the email message. This protocol is deprecated because of technical difficulties caused by the indiscriminate use of non-ASCII characters in plain-text email messages.

IRC
IRC stands for Internet Relay Chat, an IM service that has its roots in a Finnish predecessor of the World Wide Web called OuluBox (1988). IRC has been losing users steadily for many years as social media platforms like Facebook have become more popular. One larger remaining network is Libera Chat; it can be accessed via this web site.

ISDN
ISDN stands for Integrated Services Data Network, the very first set of telecommunication standards that permitted the simultaneous transmission of analog voice signals and digital data signals over a switched network of copper wires (i.e. the old-style telephone system). ISDN was unavoidable in the early days of the Internet, but has lately been supplanted by more robust technologies that permit unswitched connections over networks that utilize fiber optic cables, satellites, and very high frequency microwave transmitters / receivers. It is still widely used in a few industrial applications where a direct point-to-point connection is necessary, but is on the way out in the broader consumer market.

Jabber
Jabber is an instant-messaging service that relies on the XMPP protocol. The original ‘Jabber’ web site is no longer accepting new registrations, but the XMPP protocol is in widespread use. See this web site for more information.
KMail
KDE’s email management program. Provides a fully integrated environment for sending and receiving email messages from one (or more) email account(s), maintaining as many email identities as you want to have, organizing and archiving your old email messages, and managing your personal email encryption keys.

Kolab
Kolab Systems AG is a corporation headquartered in Zurich, Switzerland that provides both proprietary and open source software tools to facilitate collaboration among groups of people who share data, messages, and calendaring / scheduling resources via the internet. EWS provides similar, though wholly proprietary, software packages.

LDAP
The Lightweight Directory Access Protocol (or ldap) is a standard protocol, or method, for sharing some particular classes of information among the many server computers that comprise the internet.

.ldif
An LDAP Data Interchange Format (or .ldif) file is a type of plain text file designed for exchanging directory information among the various servers in a distributed network.

Meanwhile
'Meanwhile' is open source software designed to communicate with IBM's Sametime instant messaging software. See this web site if you want to learn more about it.

MIME
MIME stands for Multipurpose Internet Mail Extensions, a set of coding conventions designed to make email messages more flexible by enabling features like extended character sets, embedded images, ‘rich text’ coding, etc. The original email coding conventions supported nothing besides plain text (or encrypted) messages written with 7-bit ASCII code. Almost all contemporary email messages are MIME encoded.

OpenPGP/ MIME
OpenPGP/MIME refers to an encryption convention for MIME encoded email messages. A special set of MIME headers are wrapped around the PGP signature, allowing an email client program to conceal the signature when the message is displayed.

Open-Xchange Groupware Server
Open-Xchange AG is a corporation headquartered in Cologne, Germany that provides both proprietary and open source software tools to facilitate collaboration among groups of people who share data, messages, and calendaring / scheduling resources via the internet. EWS and Kolab provide similar software packages.

PCS
PCS stands for Personal Communication Service, which is basically a cell phone with some extra functionality built in. PCS phones operate on a higher frequency band than traditional cell phones, which implies that they can provide more bandwidth than older cell phones.

PGP
PGP stands for Pretty Good Privacy, a data-encryption program that was released by Philip Zimmerman in 1991. Most email encryption software in use today employs some variant of PGP to encrypt, decrypt, and cryptographically sign messages.

PIM
KDE’s Personal Information Management system, a suite of programs to help you manage your contacts and your schedule. PIM includes Kontact, KMail, KAddressBook, KOrganizer, Akregator, and Akonadi. Also used more generally to describe any system for managing personal information such as names, addresses, telephone numbers, etc.
QR Code
QR Code stands for Quick Response Code, a two-dimensional barcode used to represent digital data. It was invented in Japan in 1994 for use by automobile manufacturers, but has spread far and wide, so that it is ubiquitous today.

SASL
SASL stands for Simple Authentication and Security Layer, a framework for client authentication (passwords and usernames) and data security (encrypted connections). It supports more than a dozen different protocols.

S/MIME
S/MIME stands for Secure / Multipurpose Internet Mail Extensions, a standard cryptographic method for signing, encrypting, and decrypting email messages. Unlike PGP, which uses private keys, S/MIME uses publicly published encryption keys certified by a Certificate Authority, such as Verisign.

S/MIME Opaque
S/MIME Opaque stands for the ‘opaque’ version of Secure / Multipurpose Internet Mail Extensions. It is similar to the ‘S/MIME’ format defined above, but the entire contents of the message are rolled up into a single MIME object. (Most MIME encoded email messages consist of two or more separate MIME objects.)

SMS
SMS stands for Short Message Service, a text-messaging service built into most telephone, internet, and mobile device communication networks. It facilitates the exchange of text messages that are less than 161 bytes long.

SSL
SSL stands for Secure Socket Layer, a deprecated cryptographic protocol that has been largely supplanted by TLS.

TLS
TLS stands for Transport Layer Security, a cryptographic protocol that is widely used to secure internet communications. Its primary function is to allow a client and a server to exchange enough information securely that they can set up a pair of encryption / decryption keys for use during the rest of the internet session. TLS is the weakest link in the chain connecting a client program to a secure (encrypted) internet service. It has been the target of several hacking exploits, and it has been revised several times in response to those attacks.

.vcf
The Virtual (business) Card Format (or .vcf) is a keyword-oriented data interchange format that has gone through several iterations (2.0, 2.1, 3.0, etc.) since its introduction *ca. 1990*. The most recent version is vCard 4.0.

XMPP
XMPP stands for Extensible Messaging and Presence Protocol, the basic technological underpinning for the ‘Jabber’ instant messaging service.
Appendix A

KAddressBook Advanced Features Reference Section

A.1

A.2 The New Group Dialog

When you invoke the ⚫ New Group function, a dialog will begin, as shown below.

![KAddressBook’s ‘New Group’ dialog after choosing the File → New → ⚫ New Group function.](image)

Use the ‘Add To’ drop-down box to choose the address book to which the new group should be added. Use the ‘Name’ field to give the new group a name. Enter e-mail addresses, or portions of email addresses, in the blue ‘+’ area. A list of potential matches will appear. Select an item in the list that pops up, and a new name will be added to the list. Continue adding individual
contacts to the list until it is complete, then click the ✓ OK button to add this group to your address book. If you want to delete a name from the list, click the icon to the right of that particular name. If you need to make changes to the group later, simply select the group and use the ‘Edit’ menu, or the ‘Edit Contact’ button on the toolbar, to open a substantially similar dialog that will let you make the desired changes.

The KMail program provides an alternative method of creating a new group in KAddressBook. After you have addressed an e-mail message to several people, you are given the option of adding a new group to your address book, as shown below.

![KMail's 'New Group' dialog after choosing the Save List... function.](image)

After addressing a message to a group of people, clicking the Save List... button to the right of the address input area will cause the illustrated dialog box to appear. Give the list a name and left click the Save List button. Another dialog box will pop up, asking you to select an address book. Make your selection, and a new group will be created for you.

Click here to return to the Table of Contents for this Appendix.

### A.3 The Print-Preview Dialog

KAddressBook’s ‘Print Preview’ function lets you tailor a hard-copy of your address book data just about any way you want.
KAddressBook’s ‘Print Preview’ dialog. You may select one or more entire address books, or just a smattering of individual contacts.

The first step is to select the contacts to be included in the printout. If you wish to print just a smattering of individual contacts, you must choose the contacts to be printed before invoking the Print Preview dialog. If you wish to select all your contacts, or all the contacts in a particular address book, you can do it here. Click Next when you have made your selection. A new screen will appear.
The second screen in KAddressBook’s ‘Print Preview’ dialog. You may choose a sort field and a sort direction (up or down). You may also choose among seven different print layouts.

Here you can choose a sort field (any one of the 47 named fields in the contact record), the direction of the sort, and any one of seven different report formats. When you click Next, you will be given a chance to tailor the color scheme to be used.

The third screen in KAddressBook’s ‘Print Preview’ dialog. You may select a color scheme here.
Here is a picture of the completed report. It is now ready for printing.

KAddressBook’s ‘Print Preview’ after the report has been generated and is ready to print. You may select alternative print orientations (landscape or portrait) and launch the print task from this window.

Click here to return to the Table of Contents for this Appendix.

A.4 The Configure LDAP Dialog

Here is a picture of the first configuration screen that appears when you choose either the Configure LDAP Servers... button in the File → Import → Import from LDAP Server... dialog or the Settings → Configure KAddressBook... menu item.
KAddressBook’s ‘Configure LDAP Server’ dialog after choosing the File ➔ Import ➔ Import from LDAP Server... function and left clicking the Configure LDAP Servers... button.

If you have already configured one or more LDAP servers, use this screen to select the servers that should be queried when you search for a name or email address. Use the Add host... button to add a new server to the list of available LDAP hosts. Use the Edit host... button to reconfigure a server that’s already on the list, and the Remove host button to delete an entry you don’t need any more. The Reset button can be used to undo the last ‘Add’ or ‘Remove’ action performed. The ‘Defaults’ button is inoperative in release 5.10.3. The rest of the buttons (OK, Apply, Cancel) have their ordinary functions: apply changes and exit, apply changes and stay here, and exit the dialog without making any changes, respectively.

When you choose either the Add host... button or the Edit host... button, the following dialog will appear.
KAddressBook’s ‘Configure LDAP Server’ dialog after left clicking either the Add Host... or the Edit Host... button.

The first four fields (‘User’, ‘Bind DN’, ‘Realm’, and ‘Password’) will all be grayed out unless authentication is required. Obtain these credentials from the LDAP server’s administrator. Enter the appropriate URI in the ‘Host’ field. The default values for ‘Port’, ‘Size limit’, etc. will work OK for most users. You can use the Query Server button to set up the ‘DN’ field. I have no idea what the ‘Filter’ field is for. If you figure it out, please let me know (davidbryant AT gvtc.com).

Use the ‘Security’ section to specify the encryption method to use: ‘No’ for an unencrypted connection, TLS for Transport Layer Security, or SSL for Secure Socket Layer. Use the ‘Authentication’ options to specify what level of authentication the server requires: ‘Anonymous’ for no name or password at all, ‘Simple’ if ‘Bind DN’ and ‘Password’ must be given, and SASL (Simple Authentication and Security Layer) for the whole smear (four data items). If ‘SASL’ is chosen, use the Query Server button to set the advanced options for this host.

Click here to return to the Table of Contents for this Appendix.

### A.5 The Import CSV File Function

When you choose the File → Import ➔ Import CSV file... function, you will be presented with a dialog. After you click the button and choose the file to be imported, the screen will look like this.
The KAddressBook Handbook

KAddressBook’s ‘Import CSV File’ dialog after choosing the File → Import → Import CSV file... function and selecting the file to be imported.

Use the ‘Delimiter’ section of this dialog to specify which separator character defines the end of a field in the chosen input file. If quote marks are used to delimit fields with embedded separator characters, you may specify the style (single or double quote) used via the ‘Text quote:’ drop-down box. If the input file contains dates, use the ‘Date format:’ field to define the way dates have been encoded. The default is yyyy-mm-dd. If that’s the wrong format, hover your cursor over the ‘Date format:’ field box and a handy set of formatting instructions will be displayed. If the input file is not UTF-8 encoded, use the ‘Text codec:’ drop-down box to specify the binary encoding scheme to use. If the first row of the file contains column headers, check the ‘Skip first row of file’ box to avoid importing the column headers as data. Use the ‘Undefined’ boxes at the top of each column to specify which data fields are to be imported, and where they should be stored, as shown below.
KAddressBook’s ‘Import CSV File’ dialog after choosing the File → Import → Import CSV file... function, selecting the file to be imported, and beginning to define the fields to be imported.

If you wish the contents of the current column to be imported, choose a destination from the list of field names appearing beneath the blue ‘Undefined’ box. See the next section for a list of the pre-defined fields. Use the horizontal scrollbar near the bottom of the dialog to view all the columns in the input file. When your selections are complete, click the ✓ OK button. If you have defined multiple address books, you will be asked to specify which address book is to be used. KAddressBook will then import the selected data as new contacts.

If you intend to import additional datasets in the same format sometime in the future, you may click the Save template... button (cf. the first illustration in this section) to save the selections you have made. You will be prompted to give the template a name. Later, when you import another file with the same layout, you can save time by clicking the Apply template... button.

Click here to return to the Table of Contents for this Appendix.

A.6 The Export CSV File Function

When you invoke the File → Export → Export CSV file... function, a dialog box appears.
KAddressBook’s ‘Export CSV File’ dialog after choosing the File → Export → Export CSV file ... function.

You may select all your contact data, or just a portion of it. When you press the ✓ OK button, you will be allowed to choose the name of the generated file, and the directory in which it will be written. The output file will contain the following forty-seven (47) output fields, in this order, left to right. This list of field names is included as the first record in the file.

Formatted Name | Honorific Prefixes | Given Name | Additional Names | Family Name | Honorific Suffixes | Nick Name | Birthday | Anniversary | EMail (preferred) | EMail (2) | EMail (3) | EMail (4) | Home Address Street | Home Address Post Office Box | Home Address City | Home Address State | Home Address Zip Code | Home Address Country | Home Address Label | Business Address Street | Business Address Post Office Box | Business Address City | Business Address State | Business Address Zip Code | Business Address Country | Business Address Label | Home Phone | Business Phone | Mobile Phone | Home Fax | Business Fax | Car Phone | ISDN | Pager | Mail Client | Title | Role | Organization | Note | Homepage | Blog Feed | Profession | Office | Manager | Assistant | Spouse

All fields are formatted as character class data. Dates (Birthday and Anniversary, if present) are coded as yyyy-mm-dd (Year, Month, Day).

Click here to return to the Table of Contents for this Appendix.

### A.7 The Change Number of Columns Function

When you open the View menu, the following screen appears.
KAddressBook’s ‘View’ menu after choosing the View menu on the main Menubar.

Not happy with the hum-drum three column layout appearing above? Jazz things up a little with this minimalist approach.

KAddressBook’s ‘Simple (one column)’ layout. Only the basic contact data are visible.

Notice that the information about which address books exist and are in use is not visible when this ‘Simple’ layout is in effect. Only the contacts from the address books that were selected before choosing this view are displayed.
If the ‘Simple’ layout does not appeal to you, you may want to try the ‘Two columns’ style.

![KAddressBook's 'Two columns' layout. The list of address books is stacked on top of the alphabetized contact list.](image)

At KDE, our motto is “Be Free!” We aim to give you maximum flexibility when it comes to tailoring and configuring our software to suit your tastes. We toyed with the idea of adding even more views to KAddressBook (Four columns! Five!), but eventually concluded that enough is enough.

Click here to return to the Table of Contents for this Appendix.

### A.8 The Configure Shortcuts Option

When you first select the **Settings → Configure Shortcuts...** option, this is what you will see.
The KAddressBook Handbook

KAddressBook's 'Configure Shortcuts' dialog. Use the 'Search' field, or the vertical scrollbar, to locate the action for which a new keyboard shortcut is to be defined.

The KAddressBook actions for which keyboard shortcuts have already been defined are clearly marked in the 'Shortcut' column. You may either assign additional shortcuts via the 'Alternate', 'Global', and 'Global Alternate' columns in this table, or assign a new shortcut to an action for which no keyboard shortcut has as yet been defined. Select the action to be configured by clicking its name, as illustrated above.

When you left-click the None button, its name will change to 'Input...'; you can then record the combination of keystrokes you wish to assign to the selected action. (Hover the cursor over the None button to view a handy hint about this procedure.) The program will note which keys you have pressed, and record the new keyboard shortcut, as illustrated below. If you choose a combination that conflicts with an existing shortcut assignment, you will see an error message, and you will be prompted to make a different selection. You may use the button to erase your selection.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
<th>Alternate</th>
<th>Global</th>
<th>Global Alternate</th>
</tr>
</thead>
<tbody>
<tr>
<td>Category filter</td>
<td>Finder</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Configure KAddressBook...</td>
<td>Ctrl+Shift+</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Configure Shortcuts...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Configure Toolbars...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Copy Contact</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cut Contact</td>
<td>Ctrl+X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Delete Address Book</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Delete Address Book Folder</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Delete Contact</td>
<td>Del</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

![Configure Shortcuts dialog](image_url)
KAddressBook’s ‘Configure Shortcuts’ dialog after a new keyboard shortcut has been entered, but before the new configuration has been saved.

Click the ✓ OK button to save your changes. Click on ☢ Cancel to exit without saving your changes. Click Defaults to restore KAddressBook’s default set of keyboard shortcuts. Choose Manage Schemes » to integrate your custom assignments into a larger scheme of shortcut assignments; see the Customizing KDE Software chapter of the KDE Fundamentals handbook.

You may select the Print button to produce a hard-copy version of the keyboard shortcut assignments. Here is a sample from the printed table.
Shortcuts for KAddressBook

<table>
<thead>
<tr>
<th>Action Name</th>
<th>Shortcuts</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>About KAddressBook</td>
<td></td>
<td></td>
</tr>
<tr>
<td>About KDE</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add Address Book Folder</td>
<td></td>
<td>Add a new address book folder to the currently selected address book folder.</td>
</tr>
<tr>
<td>Add Address Book</td>
<td></td>
<td>Add a new address book</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You will be presented with a dialog where you can select the type of the</td>
</tr>
<tr>
<td></td>
<td></td>
<td>address book that shall be added.</td>
</tr>
<tr>
<td>Address Book Properties</td>
<td></td>
<td>Open a dialog to edit properties of the selected address book.</td>
</tr>
<tr>
<td>Category filter</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Configure KAddressBook</td>
<td>Main: Ctrl+Shift+,</td>
<td></td>
</tr>
<tr>
<td>Configure Shortcuts</td>
<td></td>
<td>You will be presented with a dialog where you can configure the application-</td>
</tr>
<tr>
<td></td>
<td></td>
<td>wide shortcuts.</td>
</tr>
</tbody>
</table>

An excerpt from KAddressBook’s printed list of keyboard shortcuts.

Click here to return to the Table of Contents for this Appendix.

A.9 The Configure Toolbars Option

Here is a picture of the screen that appears when you click on the Settings → Configure Toolbars... menu item.
KAddressBook’s ‘Configure Toolbars’ dialog. Actions that are already displayed on the Toolbar appear in the large window on the right. Actions in the left-hand window may be added to the Toolbar, as explained below.

Use either one of the ‘Filter’ fields to restrict the range of choices displayed in the corresponding window. Select an action in the left-hand window (as shown above) if you wish to add it to the Toolbar. Left click the button to add the item to the list in the right-hand window (and thence to KAddressBook’s Toolbar). If you want to delete an item from the Toolbar simply reverse the procedure: highlight the item to be deleted from the right-hand window and click the button. The selected item will be removed from the Toolbar.

You may tailor the order in which selected items appear on the Toolbar by using drag and drop within the right-hand window. The order of items on the Toolbar, left to right, corresponds with the order in the window, top to bottom. You may make additional changes to the appearance of the Toolbar by using the Change Icon... button to alter the icon associated with a particular action. Similarly, you may change the description of each item on the Toolbar by clicking the Change Text... button.

Use the Defaults button to restore the default Toolbar settings. Choose ‘OK’ to save your changes and exit the dialog, ‘Apply’ to apply your changes while keeping the dialog open, or ‘Cancel’ to exit the dialog without saving your changes. (See the Customizing KDE Software chapter of the KDE Fundamentals handbook for a more detailed explanation of this procedure.)

Click here to return to the Table of Contents for this Appendix.

A.10 The Configure KAddressBook Option

When the Settings → Configure KAddressBook... option is selected, this screen will appear.
KAddressBook’s ‘Configure Contact Actions’ dialog. These features are still experimental, and not yet entirely operational.

The first dialog that appears supports experimental features that have not yet been completely implemented. You may select from several different options under the headings ‘Show Address’, ‘Dial Phone Number’, or ‘Send SMS’, but there isn’t yet any software to do anything with the options you choose.

The next option, ‘LDAP Server Settings’, is the same dialog that is documented in the preceding section entitled ‘The Configure LDAP Dialog’.
KAddressBook’s ‘LDAP Server Settings’ dialog. This dialog, and its child, are documented in a preceding section of this appendix.

The final set of options for configuring KAddressBook appears when you select ‘Plugins’.

KAddressBook’s ‘Plugins’ dialog. There are ten plugins all together. Seven of them have been activated by default, as shown above.

The actions supported by the seven default ‘Plugins’ are documented in preceding sections of this manual. The ‘Import Export GMX’ and ‘Import/Export LDIF’ actions will appear as part of
the **File** menu when activated. The ‘Check Gravatar’ item will appear in the **Tools** menu when it is activated. Notice that KAddressBook must be stopped and restarted before any changes to the ‘Plugins’ will take effect.

Click here to return to the Table of Contents for this Appendix.

### A.11 Credits and Licenses

KAddressBook

Copyright (c) 2007–2019 KAddressBook authors montel@kde.org

Documentation Copyright (c) 2019 David C. Bryant davidbryant@gvtc.com

This documentation is licensed under the terms of the Creative Commons Attribution-ShareAlike 4.0 International.

Click here to return to the Table of Contents for this Appendix.