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Abstract

Konsole is KDE’s terminal emulator.



The Konsole Handbook

Chapter 1

Introduction

1.1 What is a terminal?

Konsole is an X terminal emulator, often referred to as a terminal or a shell. It emulates a com-
mand line interface in a text only window.

Konsole typically runs a command shell, an application that executes commands that you type.
The shell the Konsole runs depends on your account settings. Consult your operating system
documentation to know what the shell is, how to configure it and how to use it.

1.2 Scrollback

Konsole uses the notion of scrollback to allow users to view previously displayed output. By
default, scrollback is on and set to save 1000 lines of output in addition to what is currently
displayed on the screen.

As lines of text scroll off the top of the screen, they can be reviewed by moving the scroll bar
upwards, scrolling with a mouse wheel or through the use of the Shift+Page Up (to move back),
Shift+Page Down (to move forward), Shift+Up Arrow (to move up a line) and Shift+Down
Arrow (to move down a line) keys.

The amount of scrolling using Shift+Page Up/Down can be switched between half and full page
in the Scrolling tab of the profile configuration window (use Settings → Edit Current Profile...
to open this window).

1.3 Profiles

Profiles allow the user to quickly and easily automate the running of common commands. Ex-
amples could include:

• ssh into another machine

• starting an irc session

• use tail to watch a file

All new and changed profiles are saved in the user’s local home folder in $XDG_DATA_HOME /kon
sole.
Procedure to create a new profile:
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1. Click on the menu entry Settings → Manage Profiles...

2. Click on the button New Profile....

3. Fill in the first entry with a name. This is the name that will show in the menu, and will be
the default label instead of Shell when you start a session of this type.

4. Enter a command just as you normally would if you opened a new shell and were going to
issue that command. For our first example above, you might type ssh administration.

5. On the other tabs of the dialog, configure this session’s appearance. You can configure a
different font, color scheme, $TERM type and many other settings for each session.

6. Press the OK button. The new session is now available in the Manage Profiles... dialog.

Any profiles which have Show in Menu checked will be listed by their name in the File → New
Tab menu. There will be no submenu if only the default profile is to be shown.

1.4 Mouse Buttons

This section details the use of the mouse buttons for the common right handed mouse button
order. For the left handed mouse button order, swap left and right in the text below.

Left
All left mouse button clicks will be sent to a mouse-aware application running in Konsole.
If an application will react on mouse clicks, Konsole indicates this by showing an arrow
cursor. If not, an I-beam (bar) cursor is shown.
Holding the left mouse button down and dragging the mouse over the screen with a mouse-
unaware application running will mark a region of the text. While dragging the mouse, the
marked text is displayed in reversed color for visual feedback. Select Copy from the Edit
menu to copy the marked text to the clipboard for further use within Konsole or another ap-
plication. The selected text can also be dragged and dropped into compatible applications.
Hold the Ctrl key and drag the selected text to the desired location.
Normally, new-line characters are inserted at the end of each line selected. This is best for
cut and paste of source code, or the output of a particular command. For ordinary text, the
line breaks are often not important. One might prefer, however, for the text to be a stream
of characters that will be automatically re-formatted when pasted into another application.
To select in text-stream mode, hold down the Ctrl key while selecting normally.
Pressing the Ctrl and Alt keys along with the left mouse button will select text in columns.
Double-click with the left mouse button to select a word; triple-click to select an entire line.
If the upper or lower edge of the text area is touched while marking, Konsole scrolls up
or down, eventually exposing text within the history buffer. The scrolling stops when the
mouse stops moving.
After the mouse is released, Konsole attempts to keep the text in the clipboard visible by
holding the marked area reversed. The marked area reverts back to normal as soon as the
contents of the clipboard change, the text within the marked area is altered or the left mouse
button is clicked.
To mark text in a mouse-aware application (Midnight Commander, for example) the Shift
key has to be pressed when clicking.

Middle
Pressing the middle mouse button pastes text currently in the clipboard. Holding down
the Ctrl key as you press the middle mouse button pastes the text and appends a new-line.
That is convenient for executing pasted command quickly, but it can be dangerous so use it
with caution.
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NOTE
If you have a mouse with only two buttons, pressing both the left mouse button and right mouse
button together emulates the middle mouse button of a three button mouse.

If you have a wheel as the middle button, rolling it in a mouse-unaware program will move
Konsole’s scrollbar.

Right

These items appear in the menu when the right mouse button is pressed:

• Copy
• Paste
• With a text selection a submenu Search for with a list of the preferred Web Shortcuts and

an option to configure web shortcuts.
• Open File Manager
• Set Encoding
• Clear Scrollback
• Adjust Scrollback...
• Show Menu Bar, only when the menubar is hidden
• Switch Profile
• Edit Current Profile...
• Close Tab

In a mouse aware application, press the Shift key along with the right mouse button to get
the popup menu.

1.5 Drag and Drop

If you drop a file, folder or URL on a Konsole window, a context menu appears with these actions:

Move Here (Shift)
Move the dropped item into the current folder. This item only appears in the context menu,
if you have the rights to delete the dropped file or folder.

Copy Here (Ctrl)

Copy the dropped item into the current folder.

Link Here (Ctrl-Shift)
Insert a symbolic link to the dropped item.

Paste Location
Insert the full file path of the dropped item at the cursor.
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Change Directory To

If a folder is dropped, this action appears in the context menu and allows you to change the
working folder of the Konsole session.

Cancel (Esc)
Break the drag and drop action.

If you press the shortcuts before releasing the left mouse button during drag and drop, no context
menu appears and the actions will be executed immediately.

If you want to use the Ctrl key for drag and drop or disable the context menu to insert URLs as
text by default, enable the corresponding options on the Mouse tab in the profile settings dialog.
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Chapter 2

Command Reference

2.1 The Menubar

The menubar is at the top of the Konsole window. If the menubar is hidden, Show Menu Bar
can be reached by right clicking in the window (as long as no full screen application is running
in that window such as vi, minicom, etc.). The default shortcut is listed after each menu item.

Alternatively you can use the shortcut Ctrl+Shift+M to show or hide the menubar.

2.1.1 File Menu

File → New Window (Ctrl+Shift+N)
Opens a new separate Konsole window with the default profile

File → New Tab (Ctrl+Shift+T)
Opens a new tab with the default profile

NOTE
Konsole ships with a default profile. Any new profiles added by the user will be listed in the
submenu. There will be no submenu if only the default profile is to be shown.

File → Clone Tab
Attempts to clone the current tab in a new tab

File → Save Output As... (Ctrl+Shift+S)

Saves the current scrollback as a text or html file

File → Print Screen ... (Ctrl+Shift+P)
Print the current screen. By default the output is scaled to fit the size of the paper being
printed on with black text color and no background. In the print dialog these options can
be changed on the Output Options tab.

File → Open File Manager

Opens KDE’s file manager at the current directory. By default, that is Dolphin.

File → Close Tab (Ctrl+Shift+W)
Closes the current tab

9
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File → Close Window (Ctrl+Shift+Q)
Quits Konsole

NOTE
Konsole will display a confirmation dialog if there is more than one tab open. This dialog can be
disabled by clicking on the Do not ask again checkbox.
If you want to get the confirmation dialog get back, delete the entry

[Notification Messages]
CloseAllTabs=true

in $XDG_CONFIG_HOME /konsolerc.

2.1.2 Edit Menu

Edit → Copy (Ctrl+Shift+C)

Copies the selected text to the clipboard

Edit → Paste (Ctrl+Shift+V)
Pastes text from the clipboard at the cursor location

Edit → Select All
Selects all the text in current window

Edit → Copy Input To → All Tabs in Current Window

Allows input from the current session to be sent simultaneously to all sessions in current
window

Edit → Copy Input To → Select Tabs... (Ctrl+Shift+.)

Allows input from the current session to be sent simultaneously to sessions picked by user

Edit → Copy Input To → None (Ctrl+Shift+/)

Stop sending input from current session into other sessions

Edit → Send Signal

Send the specified signal to the shell process, or other process, that was launched when the
new session was started.
Currently available signals are:

STOP to stop process
CONT continue if stopped

HUP hangup detected on controlling terminal,
or death of controlling process

INT interrupt from keyboard
TERM termination signal
KILL kill signal
USR1 user signal 1
USR2 user signal 2

Refer to your system manual pages for further details by giving the command man 7 sig
nal.
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Edit → Rename Tab... (Ctrl+Alt+S)
Opens a dialog box allowing you to change the name of the current tab (more info)

Edit → ZModem Upload... (Ctrl+Alt+U)

Opens up a dialog to select a file to be uploaded if the required software is installed

Edit → Find... (Ctrl+Shift+F)
Opens a search bar at the bottom of Konsole’s window
This allows for case sensitive, forward or backwards, and regular expressions searches.

Edit → Find Next (F3)
Moves to the next search instance . If the search bar has the focus, you can use the shortcut
Enter as well.

Edit → Find Previous (Shift+F3)
Moves to the previous search instance . If the search bar has the focus, you can use the
shortcut Shift+Enter as well.

2.1.3 View Menu

View → Split View → Split View Left/Right (Ctrl+()

Splits all the tabs into left and right views
Any output on one view is duplicated in the other view.

View → Split View → Split View Top/Bottom (Ctrl+))

Splits all the tabs into top and bottom views
Any output on one view is duplicated in the other view.

View → Split View → Close Active (Ctrl+Shift+S)

Closes the current view

View → Split View → Close Others (Ctrl+Shift+O)

Closes all non-current views

View → Split View → Expand View (Ctrl+Shift+])

Makes the current view larger

View → Split View → Shrink View (Ctrl+Shift+[)

Makes the current view smaller

View → Detach Current Tab (Ctrl+Shift+H)
Opens the current tab in a separate window
Quiting the previous Konsole window will not affect the newly created window.

View → Monitor for Silence (Ctrl+Shift+I)
Toggles the monitoring of the current tab for lack of activity
By default, after 10 seconds of inactivity, an info icon will appear on the session’s tab. The
type of alerts can be changed through Settings → Configure Notifications → Silence in
monitored session.

View → Monitor for Activity (Ctrl+Shift+A)

Toggles the monitoring of the current tab for activity
Upon any activity, an info icon will appear on the session’s tab. The type of alerts can be
changed through Settings → Configure Notifications → Activity in monitored session.
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View → Enlarge Font (Ctrl++)

Increases the text font size

View → Shrink Font (Ctrl+-)
Decreases the text font size

View → Set Encoding

Sets the character encoding

View → Clear Scrollback
Clears the text in the scrollback

View → Clear Scrollback and Reset (Ctrl+Shift+K)
Clears the text in the current tab and scrollback and resets the terminal

2.1.4 Bookmarks Menu

Bookmarks → Add Bookmark (Ctrl+Shift+B)
Adds the current location

Bookmarks → Bookmark Tabs as Folder...
Adds all tabs to a bookmark folder
A dialog will open for the bookmark folder name.

Bookmarks → New Bookmark Folder...
Adds a new folder to the bookmark list
A dialog will open for the bookmark folder name.

Bookmarks → Edit Bookmarks
Opens the bookmark editor

NOTE
You can use the bookmark editor to manually add URLs. Currently, Konsole accepts the follow-
ing:

• ssh://user@host:port

• telnet://user@host:port

2.1.5 Settings Menu

Settings → Edit Current Profile...

Opens a dialog to configure current profile

Settings → Switch Profile

Switch current profile to a listed profile

Settings → Manage Profiles...

Opens a editor for managing profiles

Settings → Show Menu Bar (Ctrl+Shift+M)

Toggles the menubar being visible
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Settings → Full Screen Mode (F11)

Toggles Konsole filling the entire screen

Settings → Configure Shortcuts...

Opens the keyboard shortcut editor. More on shortcuts configuration can be found in the
KDE Fundamentals.
Additionally Konsole has a few special shortcuts with no corresponding menu item:

Shortcut Description
Shift+Right Next Tab
Shift+Left Previous Tab
Ctrl+Shift+Left Move Tab Left
Ctrl+Shift+Right Move Tab Right
Ctrl+Shift+Ins Paste Selection
Shift+Tab Next View Container

Settings → Configure Notifications...

Opens the notifications editor

Settings → Configure Konsole...

Opens the Konsole settings editor
This dialog has options influencing the appearance and behaviour of the TabBar and gen-
eral options for the Konsole window.

2.1.6 Help Menu

Konsole has the some of the common KDE Help menu items, for more information read the
section about the Help Menu of the KDE Fundamentals.

2.2 Konsole Dialogs

2.2.1 Rename Tab Dialog

The name of the current tab can be changed from this dialog. The dialog can be displayed via the
menu, the shortcut Ctrl+Alt+S or by double-clicking on the tab in the tab bar. These changes can
be made permanent by editing the current profile.

Konsole will substitute these tokens for local tabs:

• %n : program name

• %d : current directory (short)

• %D : current directory (long)

• %h : local host (short)

• %u : user name

• %w : window title set by shell

• %# : session number
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Konsole will substitute these tokens for remote tabs:

• %c : current program

• %h : remote host (short)

• %H : remote host (long)

• %u : user name

• %U : user name@ (if given)

• %w : window title set by shell

• %# : session number

Examples:

• %d : %n with /usr/src as current directory and running bash will display src : bash

• %D : %n with /usr/src as current directory and running top will display /usr/src : top

• %w (%#) with ~ as current directory and running vim in the first tab will display [No Name]
(~) - VIM(1)

2.2.2 Copy Input Dialog

The text entered in one tab can simultaneously be sent to other tabs. This dialog allows you to
select which tabs will get that input. The current tab will be greyed out.

2.2.3 Adjust Scrollback Dialog

The scrollback options for the history size can be changed in this dialog. Any changes are for the
current tab only and will not be saved to the profile.
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Chapter 3

Command-line Options

When Konsole is started from the command line, various options can be specified to modify its
behavior.

--help

List various options.

--profile file

Start Konsole using the specified profile instead of the default profile.

--fallback-profile

Use the internal FALLBACK profile. This option is a shortcut for --profile FALLBACK/.

--workdir dir

Open with dir as the initial working directory.

--hold, --noclose

Do not close the initial session automatically when it ends.

--new-tab
Create a new tab in an existing window rather than creating a new window.

--tabs-from-file file

Create tabs as specified in the given tabs configuration file.

NOTE
The file has one tab per line in the following format:
Each line specifies a tab to open using up to 4 fields specifying how it is to open. Fields are
delimited with ;; and a field name must have a : appended. Empty lines or lines with # at the
beginning are ignored, so you can use line beginning with # to add comments.
title: a name for this tab, tab default if blank or not specified
workdir: working directory, ~ if blank or not specified
profile: a Konsole profile to use, the default if blank or not specified
command: a command to run

Each line should contain at least one of command or profile field.
Example: title: %n;; command: /usr/bin/top ;; profile: Shell

--background-mode

Start Konsole in the background and bring to the front when Ctrl+Shift+F12 (by default) is
pressed.
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--separate, --nofork
Run the new instance of Konsole in a separate process.

--show-menubar
Show the menubar, overriding the default behavior.

--hide-menubar
Hide the menubar, overriding the default behavior.

--show-tabbar
Show the tabbar, overriding the default behavior.

--hide-tabbar
Hide the tabbar, overriding the default behavior.

--fullscreen
Start Konsole in fullscreen mode.

--notransparency

Disable transparent backgrounds, even if the system supports them.

--list-profiles

List all available profiles.

--list-profile-properties

List all possible properties with name and type. See option -p.
For more information, please visit Konsole API Reference.

-p property=value

Change the value of a profile property.

-e command

Execute command instead of the normal shell.

NOTE
This option will catch all following arguments passed to Konsole, and execute it as command. So
this option should always be used as the last option.

Konsole also accepts generic Qt™ and KDE Frameworks 5 options, see man pages qt5options
and kf5options.
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Chapter 4

Scripting Konsole

Konsole does support numerous methods that can be used with D-Bus.

There are two ways to use the D-Bus interface: Qt™’s GUI qdbusviewer and the command line
qdbus.

Examples:

• % qdbus will display all services available.

• % qdbus org.kde.konsole will display the D-Bus interface for Konsole.

• % qdbus org.kde.konsole /Windows/1 will display methods for controlling window 1.

• % qdbus org.kde.konsole $KONSOLE_DBUS_WINDOW will display methods for controlling the
current window.

• % qdbus org.kde.konsole /Sessions/1 will display methods for controlling session 1.

• % qdbus org.kde.konsole $KONSOLE_DBUS_SESSION will display methods for controlling the
current session.

• % qdbus $KONSOLE_DBUS_SERVICE $KONSOLE_DBUS_SESSION will display methods for control-
ling the current Konsole’s session.

If any of the above commands outputs: Service ’org.kde.konsole’ does not exist, change org.kde
.konsole to one of the following:

• org.kde.konsole-‘pidof -s konsole‘ (will select first pid)

• $KONSOLE_DBUS_SERVICE (this can be used from the current Konsole)

• select one from the output of ’qdbus | grep konsole’

For more information, please visit D-Bus tutorial.
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Chapter 5

Using Style Sheet for the Tab Bar

The default style sheet for the tab bar sets the minimum and maximum tab widths. The user can
create a .css file and have Konsole use that as the style sheet for the tab bar. In the .css file, the
widget to use is QTabBar::tab.

For more information, consider reading Qt Style Sheets

Examples:

• Change the selected tab’s background to a light gray

QTabBar::tab:selected {
background: #999999

}

• Change the selected tab’s text to red

QTabBar::tab:selected {
color: red

}

• All tabs will be at least 200 pixels in width

QTabBar::tab {
min-width: 200px

}

• Only the selected tab will be at least 200 pixels in width

QTabBar::tab::selected {
min-width: 200px

}

• Any of these can be combined in one file

QTabBar::tab::selected {
background: #999999;
color: red;
min-width: 200px;

}
QTabBar::tab {

min-width: 100px
}
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Chapter 6

Did You Know?, Common Issues and
More

6.1 Did You Know?

• Pressing Ctrl while selecting text will cause lines breaks to be converted to spaces when pasted.

• Pressing the Ctrl+Alt keys while selecting text will select columns.

• The Ctrl+Wheel combination will zoom text size, like in konqueror and firefox.

• When a program evaluates either mouse button, pressing the Shift key will allow the popup
menu to appear.

• The Ctrl+Shift+F10 shortcut will activate the menu.

• The Shift+Insert keys will insert the clipboard.

• Double-clicking will select a whole word. Continuing to hold the mouse button and moving
the mouse will extend the selection.

• Triple-clicking will select a whole line. Continuing to hold the mouse button and moving the
mouse will extend the selection.

• There is a hidden feature for the ´́ %d´́ formatter in tab title. You can tell Konsole to abbreviate
a directory name into its first character. For example, ´́ /path/to/konsole/src´́ can be abbrevi-
ated into ´́ konsole/s´́ . If you want to enable and control this hidden feature, open konsolerc
in qtpaths --paths GenericConfigLocation and add following lines:

[ProcessInfo]
CommonDirNames=name1 ,name2 ,name3...

NOTE
If you are using Yakuake, you need to edit yakuakerc in qtpaths --paths GenericConfi
gLocation instead.

6.2 Common Issues

• Some fonts might be unavailable for usage in Konsole, although they are available in other
applications. That doesn’t mean there is a bug in Konsole. Konsole requires monospaced fonts
to provide the best visual result, so it asks Qt™ to only list monospaced fonts.
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Starting with version 16.08 (August 2016), Konsole can be configured to allow selecting any
font with the caveat that the display may not be correct.

• Since KDE4 all the tabs use the same process ID. This has the side-effect that if one tab’s process
has issues, all the other tabs may experience issues as well.
This is most noticeable when a command that connects to an external device or system (ssh,
nfs) has issues.

• Konsole treats arguments after the -e option as one command and runs it directly, instead of
parsing it and possibly dividing it into sub-commands for execution. This is different from
xterm.

– konsole -e ´́ command1 ; command2´́ does not work
– konsole -e $SHELL -c ´́ command1 ; command2´́ works

• Konsole doesn’t provide convenience for running login shell, because developers don’t like
the idea of running login shell in a terminal emulator.
Of course, users still can run login shell in Konsole if they really need to. Edit the profile in use
and modify its command to the form of starting a login shell explicitly, such as ´́ bash -l´́ and
´́ zsh -l´́ .

• The --new-tab option sometimes behaves strangely. It may create new window, or it may
create new tab in another existing Konsole window instead of the current Konsole window.
Those behaviors feel strange, but they are not necessarily bugs. The --new-tab option tries
to reuse existing Konsole windows, but not all Konsole windows are reusable. All Konsole
windows opened through KRunner are reusable, while most Konsole windows opened from
command line are not.
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Chapter 7

Credits and Copyright

Konsole is currently maintained by Kurt Hindenburg kurt.hindenburg@gmail.com

Previous Konsole maintainers include: Robert Knight robertknight@gmail.com and Waldo Bas-
tian bastian@kde.org

The application Konsole Copyright (c) 1997-2008 Lars Doelle lars.doelle@on-line.de

This document was originally written by Jonathan Singer jsinger@leeta.net

This document was updated for KDE 4.x by Kurt Hindenburg kurt.hindenburg@gmail.com

This document was updated for KDE 3.4 by Kurt Hindenburg kurt.hindenburg@gmail.com

Originally converted to DocBook SGML by Mike McBride and Lauri Watts

This documentation is licensed under the terms of the GNU Free Documentation License.
This program is licensed under the terms of the GNU General Public License.
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Appendix A

Links

For more information please visit these websites:

• Konsole’s homepage on KDE’s UserBase

• Konsole’s homepage

• Konsole’s mailing list

• KDE on FreeBSD

• KDE on Solaris
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