# Contents

1 Introduction ................................................................. 5
   1.1 What is Akregator? .................................................. 5
   1.2 RSS and Atom feeds ................................................... 5

2 Quick Start to Akregator .................................................. 6
   2.1 The Main Window ................................................................. 6
   2.2 Adding a feed ................................................................. 7
   2.3 Creating a Folder ............................................................ 9
   2.4 Browsing inside of Akregator .......................................... 10

3 Configuring Akregator ....................................................... 11
   3.1 General ................................................................. 11
   3.2 URL Interceptor ............................................................. 12
   3.3 Archive ................................................................. 13
   3.4 Appearance .............................................................. 14
   3.5 Browser ................................................................. 15
   3.6 Advanced ............................................................... 16

4 Command Reference ............................................................. 18
   4.1 Menus and Shortcut Keys ............................................... 18
      4.1.1 The File Menu ................................................... 18
      4.1.2 The Edit Menu ................................................... 18
      4.1.3 The View Menu ................................................... 18
      4.1.4 The Go Menu ................................................ 19
      4.1.5 The Feed Menu ................................................ 19
      4.1.6 The Article Menu ........................................... 20
      4.1.7 The Settings and Help Menu .............................. 20

5 Credits and License .......................................................... 21
Abstract

Akregator is a program to read RSS and other online news feeds.
Chapter 1

Introduction

1.1 What is Akregator?

Akregator is a KDE application for reading online news feeds. It has a powerful, user-friendly interface for reading feeds and the management of them.

Akregator is a lightweight and fast program for displaying news items provided by feeds, supporting all commonly-used versions of RSS and Atom feeds. Its interface is similar to those of e-mail programs, thus hopefully being very familiar to the user. Useful features include searching within article titles, management of feeds in folders and setting archiving preferences. Feeds can be displayed in a similar manner to e-mails. Websites related to a feed can be shown in Akregator’s embedded browser or, at the users’ choice, opened in an external browser.

1.2 RSS and Atom feeds

RSS (Really Simple Syndication) is an XML-based format used for publishing news or articles in a machine-readable form. An RSS or Atom file is also called a feed. A program that can be used to read such feeds is called a feed reader or aggregator, hence the title of the application, Akregator.

Akregator automatically extracts new items from the feed and displays them in a human-friendly form to the user. The user can therefore save time with regularly-visited websites, as they need no longer manually check whether there are new pieces of information available.

RSS is available in different versions which are not compatible with each other (this situation caused by competing companies): RSS 0.9, RSS 1.0 and RSS 2.0. Atom is also an XML-based feed language which has been redesigned to fit the needs of webloggers and news sites. Atom attempts to replace RSS feeds and remove the uncertainty with incompatibilities in the different RSS versions.
Chapter 2

Quick Start to Akregator

This section describes how to start using Akregator. It explains the user interface and shows you how to add your own feed to the list. This section is particularly interesting if you are not yet familiar with the general RSS/Atom and feed aggregator concept.

2.1 The Main Window

When you first start Akregator, you see its main window:

![Main Window](image)

The main window consists of the feed list, the article list and the article viewer. The feed list is on the left. In the tree, you have news feeds you can select. A news feed is a collection of articles: for example, the recent news of a news site or the new entries of a blog. The default list contains feeds related to the KDE project, but of course you can add your own feeds and remove the ones you are not interested in.

In the upper right is the article list. It contains all the articles of the feed selected in the feed list (if it is empty, you must first fetch the feed). The list shows the headlines of the articles and the date when they were published. By default, the newest articles are at the top.
If you select an article, it will be displayed in the article viewer in the lower right of the window. Depending on the feed, it contains either only a headline, a short summary, or the complete article content.

2.2 Adding a feed

Akregator provides you with some default feeds related to KDE - of course, you probably want to add your own feeds. Good candidates are the news sites you visit regularly.

- Go to the menu Feed and choose Add Feed... or use the default keyboard shortcut (Ins). The following dialog appears, with an input line labeled Feed URL:
• Enter `planet.ubuntu.com` or `http://planet.ubuntu.com` in the line edit next to `Feed URL` and click OK.

• The feed settings dialog appears and you can modify the default options. When you are happy with the feed settings, click OK again.

• Now Planet Ubuntu has been added to your feed list.

There are multiple other ways to find and add interesting feeds. Within KDE, websites browsed with Konqueror will display the recognizable ‘RSS’ icon in the bottom-right if a compatible news feed is detected at the website. Just left-click on the icon and choose **Add Feed to Akregator**.
On pages with this ‘RSS’ or this icon, right-click on the icon and choose in the context menu Copy Link Address:

Switch to Akregator, select Add Feed... and the Feed URL is filled out with the link address. All feeds added using this procedures appear under Imported Feeds folder in the feed list, and from there you can use your mouse to drag it to a different folder.

2.3 Creating a Folder

After adding your own feeds, you may want to group them in some way, rather than just leave them unsorted. So let us create a folder for the Planet Ubuntu feed we just added:

- Select the parent folder of the new folder. In this example, we select All Feeds.
- Open Feed → New Folder... Enter News (or a more appropriate name for the feed category) in the line edit and choose OK.
• Now you can drag the Planet Ubuntu feed to the new folder.

2.4 Browsing inside of Akregator

When reading feed articles, often you may want to read the web page that belongs to the article: some articles only contain the headline, and not the actual content. In this case, you need to visit the web page to read the complete article. Or perhaps an article links to some website, or you are reading a blog and want to comment on an entry. For these situations, Akregator contains a simple web browser. Whenever you follow a link in the article viewer, by default Akregator opens the link in new tab.

**Note**

Note that the browser in Akregator is not intended to replace your favorite Web Browser. It is meant for reading articles, commenting on them, or following up a link quickly. It is not meant for browsing the web in general. It lacks many features fully-fledged web browsers offer.
Chapter 3

Configuring Akregator

Most of Akregator’s options are listed in the Akregator configuration dialog. The configuration dialog can be found in the menu under Settings → Configure Akregator...

3.1 General

The General tab contains the basic and otherwise-uncategorizable options of Akregator.

Global

- **Show tray icon**
  - Display the Akregator icon in the systray.
- **Show unread articles in Taskbar**
  - Defines if the number of unread articles should be shown on the system taskbar item.
The Akregator Handbook

**Hide feeds with no unread articles**
If checked, hides feeds with no unread articles.

**Lock feeds in place**
If checked, prevents feeds from being moved in the list, all feeds will be locked where they are.

**Auto-expand folders containing unread articles**
If checked, auto-expands folders with unread articles.

**Use notifications for all feeds**
Set global notifications for all feeds. This setting will override the individual notification value of each feed. When enabled, Akregator will notify you of all new articles fetched in any feed. If you only want to enable notifications for some (but not all) feeds, leave this option disabled and enable notifications for each specific feed using the individual feed properties dialog.

**Use interval fetching**
If this is unchecked, interval checking is disabled. However, if this is checked, you can set in **Fetch feeds every**: the interval that Akregator will automatically check for new feed entries. Note that fetching articles generates traffic and therefore may be costly to the provider hosting the feed you’re reading. Some sites may even block connections from your computer if you attempt to fetch the feed too often. In general, 30 minutes is a good choice.

**Fetch feeds every:**
This is enabled when **Use interval fetching** is checked. You can specify a time interval, after which feeds are checked for new articles. Default is 30 minutes.

**Startup**

**Mark all feeds as read on startup**
When enabled, Akregator marks all articles as read when started.

**Fetch all feeds on startup**
When enabled, Akregator fetches all feeds right after start.

**Network**

**Use the browser cache (less network traffic)**
When enabled, the KDE-wide browser cache settings are used when updating feeds. You can configure the KDE-wide browser cache in Konqueror’s configuration dialog.

**Note**
You should leave this option enabled whenever possible. Disabling this option leads to increased network traffic. The traffic caused by aggregators not using caching increases the costs for providers and may decrease the number of feeds that are offered in future.

3.2 **URL Interceptor**

Akregator can be configured to replace or remove images or frames from web pages that match a series of filters.
For a detailed description of this feature see AdBlock Filters.

### 3.3 Archive

Archiving articles means storing the links of articles. Here you can limit the number of articles stored and the method used for archiving. These settings are global settings, used by all feeds within Akregator. If you want to use a custom setting for a feed, you can set it in each feed properties dialog in the archive tab.
Default Archive Settings

**Keep all articles**
All articles are kept forever.

**Limit feed archive size to:**
If the number of articles exceeds the chosen limit, the oldest articles are deleted. Note that flagged articles are ignored when counting the number of articles: if your limit is 500, and you have 510 unflagged and 50 flagged articles, Akregator will ignore the 50 flagged ones and only delete the 10 oldest unflagged articles. So in this example, 550 articles would be kept.

**Delete articles older than:**
Articles older than the specified number of days are deleted from the archive, unless they have the keep flag set. Akregator checks for expired articles at startup and then once per hour, so expiry may be delayed.

**Disable archiving**
No articles are stored - all articles are discarded when quitting Akregator.

**Do not expire important articles**
Right clicking on an article opens a context menu where you can mark this article as Important. Articles marked as Important will not expire, they will be kept.

### 3.4 Appearance

On this page you can configure the appearance of the article viewer and the browser tabs. You can specify the colors, font sizes and families to be used.

**Article List Colors**
Selecting **Use custom colors** allows you to select own colors for Unread articles and New articles.
Font Size

Minimum font size
Set the minimum size for the article viewer

Medium font size
Set the default font size for the article viewer

Fonts

Standard font:
In the article viewer, the content is rendered using the Standard font in Medium font size. If you change the Standard font, the change will be applied in the article viewer.

Fixed font:
If the article uses a fixed-width font in the article viewer, the content will be rendered using this font family in Medium font size.

Serif font:
If the article uses Serif fonts, they will be rendered using the family you choose here in Medium font size.

Sans serif font:
If the article uses Sans-serif fonts, they will be rendered using the family you choose here in Medium font size.

Underline links
Check this if you want links to be underlined by default.

3.5 Browser

This tab allows you to customize the behavior of the internal browser tabs.

Left mouse click
You can choose three actions for the Left mouse click action: Open in Tab (open the link in a tab and put this tab in focus), Open in Background Tab (open the link in a tab but keep the current tab in focus) and Open in External Browser to open an article in a new window with your default browser.
Middle mouse click

As above, you can set one of the three actions for the middle mouse click.

External Browsing

Use default web browser

If this is checked, Akregator will use the web browser you set in System Settings. It may be the KDE default, Konqueror, or another browser depending on what you set here.

Use this command:

You can use another web browser for Akregator other than your KDE default. If you wish to do so, check this option and enter the command for the browser, provided it is in your $PATH.

Tabs

Always show the tab bar

If this option is checked, the tab will be always shown, even when only one tab is open. This allows you to create tabs directly from the tab bar. Otherwise, the tab bar will be shown only when several tabs are open.

Show close button on each tab

If this option is checked, the close button will appear when you move your mouse on the left side of the tab title so you can more easily close tabs.

Open links in new tab instead of in new window

If checked, Akregator will open a link which would normally open in a new window (external browser) in a new tab instead.

Security

Verify URLs using Google’s Safe Browsing API

If this option is checked, Google Safe Browsing API will be used to check URLs against Google’s constantly updated lists of unsafe web resources. Examples of unsafe web resources are social engineering sites (phishing and deceptive sites) and sites that host malware or unwanted software.

Enable Javascript

If checked, Akregator will use JavaScript when processing web resources. JavaScript usage has several security implications.

Misc

Access Key Enabled

This is an accessibility option. When checked, Akregator will process the web page accessKey property, which defines the keyboard shortcut used to jump to a given element.

3.6 Advanced

The Advanced tab allows you to set more advanced options. If you are not sure about their effect, you can just leave the default ones.
The Akregator Handbook

Archive

Archive backend:
Akregator currently only uses the Metakit database.

Article List

Mark selected article read after
Default is 0 seconds, which means that as soon as you click on an article it is marked as read. You can choose to mark any article as read after a specified number of seconds.

Reset search bar when changing feeds
This will clear the search bar when you change feed.
Chapter 4

Command Reference

4.1 Menus and Shortcut Keys

4.1.1 The File Menu

File → Import Feeds
Open the import feeds dialog to load ‘OPML Outlines’ with feed subscriptions.

File → Export Feeds
Open the save as dialog and export your feeds and folder structure as .opml file.

File → Quit (Ctrl+Q)
Quit Akregator

4.1.2 The Edit Menu

Edit → Edit Feed... (F2)
Edit current feed to change its properties in the Properties dialog

Edit → Delete feed (Alt+Del)
Delete current feed

4.1.3 The View Menu

View → Normal View (Ctrl+Shift+1), View → Widescreen View (Ctrl+Shift+2) and View → Combined View (Ctrl+Shift+3)
Choose the View Mode for Akregator

View → Enlarge Font (Ctrl++)
Increase the font size in the article viewer

View → Shrink Font (Ctrl++)
Decrease the font size in the article viewer
4.1.4 The Go Menu

Go → Previous Article (Left)
   Go to the previous article in the article list

Go → Previous Unread Article (-)
   Go to the previous unread article in the article list

Go → Next Article (Right)
   Go to the next article in the article list

Go → Next Unread Article (+)
   Go to the next unread article in the article list

Go → Previous Feed (P)
   Go to the previous feed in the feed list

Go → Previous Unread Feed (Alt+-)
   Go to the previous unread feed in the feed list

Go → Next Feed (N)
   Go to the next feed in the feed list

Go → Next Unread Feed (Alt++)
   Go to the next unread feed in the feed list

4.1.5 The Feed Menu

Feed → Add Feed... (Ins)
   Open the Add Feed dialog

Feed → New Folder... (Shift+Ins)
   Open the Add Folder dialog

Feed → Mark Feed as Read (Ctrl+R)
   Mark the current feed as read

Feed → Mark All Feeds as Read (Ctrl+Shift+R)
   Mark all feeds as already read

Feed → Fetch Feed (F5)
   Fetch the current feed

Feed → Fetch All Feeds (Ctrl+L)
   Fetch all feeds

Feed → Abort Fetches (Esc)
   Stop Akregator fetching feeds
4.1.6 The Article Menu

**Article → Open in Tab (Shift+Return)**
Open the current article in a tab within Akregator

**Article → Open in Background Tab (Return)**
Load the current article into a new tab, but not automatically activate that tab. That is useful to browse a feed, open all interesting articles into background tabs and later read them all.

**Article → Open in External Browser. (Ctrl+Shift+Return)**
Open the current article in an external browser

**Article → Mark as Important (Ctrl+I)**
Mark the current article as important

**Article → Mark as Read Ctrl+E, New Ctrl+N or Unread Ctrl+U**
Mark the current article as Read

**Article → Delete (Del)**
Delete the current article

**Article → Send Link Address...**
Open your mail client and attach the link in the mail.

**Article → Send File...**
Open your mail client and attach the file in the mail.

4.1.7 The Settings and Help Menu

**Settings → Show Quick Filter**
Toggle the Quick Filter (Show/Hide it)

<table>
<thead>
<tr>
<th></th>
<th>Feed</th>
<th>Author</th>
<th>Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>akregator: a guide to (and how to fix it)</td>
<td>Planet KDE</td>
<td>Tomaz Canab...</td>
</tr>
<tr>
<td>Read</td>
<td>developer documentation : writing with KIO</td>
<td>Planet KDE</td>
<td>Arnav Dhari...</td>
</tr>
<tr>
<td>Unread</td>
<td>sma / Apps</td>
<td>Planet KDE</td>
<td>Tomaz Canab...</td>
</tr>
</tbody>
</table>

Additionally Akregator has the common KDE Settings and Help menu items, for more information read the sections about the Settings Menu and Help Menu of the KDE Fundamentals.

Many actions provided in the menu are also available in the context menus of the feed list, the article list and the article viewer.
Chapter 5

Credits and License

Akregator

Program copyright 2004-2010 Akregator authors
Documentaion copyright 2006 Frank Osterfeld frank.osterfeld@kdemail.net
Documentaion copyright 2006 Anne-Marie Mahfouf annma@kde.org

This documentation is licensed under the terms of the GNU Free Documentation License.
This program is licensed under the terms of the GNU General Public License.