Chapter 7. Menu Entries

Each menu item is discussed below. When there is a keyboard shortcut that performs a menu item function, the default shortcut is listed with the menu item.

The Contact List Window's Menus

File Menu

FileSet StatusOnline

Go online with all accounts

FileSet StatusAway

Set all connected accounts away

FileSet StatusOffline

Set all accounts offline

FileAdd Contact...

This displays the Add Contact Wizard, which allows you to add a new contact to your list

FileCreate New Group...

Prompts you for the new group's name and adds it to the contact list.

FileQuit (Ctrl+Q)

Disconnects you from all IM systems, closes all the windows and exits the application.

Edit Menu

EditSend Single Message...

Opens an email-style message window with the selected contact, to send a single message.

EditStart Chat...

Opens a chat window with the selected contact, to have a conversation.

EditSend File...

If supported by the IM system, this opens a file selector to choose a file to send to the selected contact.

EditMove To

(Enabled when a contact is selected) Choose another group from the sub-menu, and the contact will move to that group.

EditCopy To

(Enabled when a contact is selected) Choose a group from the sub-menu, and the contact will be copied to group. IM systems that allow contacts to be in more than one group on the server contact list will be updated accordingly.

EditAdd Contact...

(Enabled when a contact is selected) Choose another account from the submenu, and you can add another way to message that person using that account.

EditAdd to Your Contact List...

(Enabled when a contact is selected) Sometimes people will message you who aren't on your contact list already. In this case, Kopete creates a temporary entry for them, but to keep them on your contact list, use this function.

EditDelete Contact (Del)

(Enabled when a contact is selected) Removes a contact from the contact list entirely.

EditRename (F2)

(Enabled when a contact is selected) Renames the contact on the contact list. If you do this, the contact list entry will no longer change if the contact changes their display name remotely. You can re-enable this using the contact's Properties dialog.

EditProperties

The Properties dialog lets you choose custom icons for the selected item, and change its name.

For contacts, you can change the KDE Address Book entry that they are associated with.

EditRemove Group

(Enabled when a group is selected) Removes a group from the contact list entirely. Any contacts that are only in this group are moved to the top level.

EditRename Group

(Enabled when a group is selected) Renames the group.

Settings Menu

Kopete has a default KDE Settings menu as described in the KDE Fundamentals with additional entries:

SettingsShow Offline Users

This shows/hides contacts who are currently offline. They will become visible when they go online again.

SettingsShow Empty Groups (Ctrl+G)

This shows/hides groups which do not have any members, or where all the members are offline and hidden (see above).

SettingsConfigure Global Shortcuts...

Displays the KDE standard Configure Global Shortcuts dialog, where you can change keyboard shortcuts that work all the time under KDE.

Help Menu

The contact list window has the common KDE Help menu items, for more information read the section about the Help Menu of the KDE Fundamentals.