The Menubar

Note that some menu entries only appear when they are applicable to the file you currently have open in Konqueror. For example, the EditFind... item will not appear when you are viewing the contents of a directory.

Konqueror has different menu items in file manager and browser mode. Only the items for these two modes are described in this chapter.

If Konqueror is using embedded components (KDE Parts) such as Gwenview for image viewing, Okular for PDF and PostScript® documents etc. the menu items from these applications are merged into Konqueror's menu. Help for these additional menu items you find in the handbook of the embedded application.

The File Menu

FileNew Window (Ctrl+N)

Open another Konqueror window.

FileNew Tab (Ctrl+T)

Open another Konqueror tab, containing a blank page.

FileOpen Location... (Alt+O)

Sets the focus to the text entry box in the Location Toolbar.

FileOpen File... (Ctrl+O)

Open a file using the KDE file dialog.

FileSessions

Open a submenu to save the current session (open tabs and windows) for easy retrieval, manage sessions and switch to previously saved sessions.

FileSend Link Address...

Send an email containing a link to the current location.

FileSend File...

Send an email containing the selected file as an attachment.

FileSave Background Image As... (Browser mode)

Only applies if you are viewing a web page with a background image. Opens the Save As dialog box to let you save the background image file to your own computer.

FileSave As... (Browser mode)

Only applies if you are viewing a document or web page, uses the Save As... dialog box to let you save a copy to your own computer.

FileSave Frame As... (Browser mode)

Similar to Save As... but for use with a web site that uses frames.

FilePrint... (Ctrl+P)

Print.

FilePrint Frame (Browser mode)

Print selected frame of a Web page.

FileQuit (Ctrl+Q)

Close down this instance of Konqueror.

The Edit Menu

EditUndo: Action (Ctrl+Z)

Sometimes lets you reverse a mistaken action.

EditCut (Ctrl+X)

Puts selected item(s) into the clipboard. If you then paste the items they will be moved from the original location to the new one.

EditCopy (Ctrl+C)

Copy selected item(s) to the clipboard.

EditPaste (Ctrl+V) (Browser mode)

Paste the clipboard content into the Location Bar.

EditPaste Clipboard Contents... (Ctrl+V) (File Manager mode)

Paste the currently copied/cut item(s) to the current folder. If the clipboard does not contain files or folders, the clipboard contents (such as text or image data) will be pasted into a new file.

EditSelect All (Ctrl+A) (Browser mode)

Selects all text in an HTML page or in a text page being previewed, you can then Copy it and Paste it into a text editor.

EditCreate New (File Manager mode)

Creates a new object (such as a folder or a text file) in the current folder. See the Create New... section for more details.

EditRename (F2) (File Manager mode)

Lets you rename a file or folder without having to open the Properties... dialog box.

EditMove to Trash (Del) (File Manager mode)

Move selected item(s) to the Trash folder.

EditDelete (Shift+Del) (File Manager mode)

Delete the selected item(s).

EditEdit File Type... (File Manager mode)

Open the Edit File Type dialog box

EditProperties... (Alt+Return) (File Manager mode)

Shows the properties dialog for the currently selected item(s).

EditSelectionSelect Items Matching... (Ctrl+S) (File Manager mode)

Together with the Unselect Items Matching..., Unselect All and Invert Selection commands, this provides an easy and powerful way of selecting multiple files.

It brings up a simple dialog box where you can enter a file name using the wild card characters * and ?, for example entering *.html will select all files ending with .html while ?a* will select all files which have the letter a as the second character in their filename.

EditSelectionUnselect Items Matching... (File Manager mode)

Unselect files or folders via a dialog similar to the one used by Select....

EditSelectionSelect All (Ctrl+A) (File Manager mode)

Selects all items in a folder; you can then Copy or Cut them and Paste them into a different folder.

EditSelectionUnselect All (File Manager mode)

Unselect all selected files or folders.

EditSelectionInvert Selection (Ctrl+Shift+A) (File Manager mode)

Invert current selection.

EditFind... (Ctrl+F) (Browser mode)

Displays the search bar at the bottom of the current window. Start typing to find a text string in a text page you are previewing or in an HTML page.

EditFind Next (F3) (Browser mode)

Find the next occurrence of the text string in the text or HTML page.

EditFind Previous (Shift+F3) (Browser mode)

Find the previous occurrence of the text string in the text or HTML page.

The View Menu

ViewView Mode

In browser mode this submenu holds items to select embedded views like KHTML, Embedded Advanced Text Editor and more embedded views.

In file manager mode this submenu holds items to select Icon, Details, Compact, Terminal Emulator and more view modes.

ViewUse index.html (File Manager mode)

If a selected folder contains a file index.html, it will be opened as a web page rather than showing the folder as a list of files.

ViewLock to Current Location

A locked view cannot change folders. Use in combination with Link View to explore many files from one folder.

ViewLink View

Link current view to others in a multiple view window. A linked view follows folder changes made in other linked views. This is especially useful with different types of views, such as a folder tree with an icon view or detailed view, and possibly a terminal emulator window.

ViewReload (F5)

Reload.

ViewStop (Esc)

Stop load (particularly useful when web browsing).

ViewEnlarge Font (Ctrl++) / ViewShrink Font (Ctrl+-) (Browser mode)

Use these to adjust the size of the text in the page if you find it difficult to read. How well this works will depend on how the web page has been constructed.

ViewView Document Source (Ctrl+U) (Browser mode - KHTML view)

View document source text.

Only available if you are viewing a document or HTML page.

ViewView Frame Source (Browser mode)

View frame source text

Only applies if you are viewing a web site that uses frames. Similar to View Document Source.

ViewView Document Information (Ctrl+I) (Browser mode - KHTML view)

View document information, such as title, URL, and HTTP headers used in retrieving the document.

Only available if you are viewing an HTML page.

ViewSet Encoding (Browser mode)

Allows you to choose the character encoding used to display HTML pages. Default is usually the best choice.

ViewSort By (File Manager mode)

Changes whether items are sorted by Name or other criteria described in Information in the View.

Descending reverses the sort order. Folders First sorts folders before files.

ViewAdditional Information (File Manager mode)

Displays additional information described in Information in the View.

ViewPreview (File Manager mode)

Displays a symbolic preview of the file contents in the different view modes.

ViewShow in Groups (File Manager mode)

Displays the content of the current folder grouped by the option selected in Sort By (only available in the Icons view mode).

ViewShow Hidden Files (Alt+.) (File Manager mode)

Shows all the hidden files and sub-folders within the current folder.

ViewAdjust View Properties... (File Manager mode)

Opens the View Properties Dialog.

The Go Menu

GoUp (Alt+Up)

Go up a level in the folder hierarchy.

GoBack (Alt+Left)

Go back to the previous view.

GoForward (Alt+Right)

You can only go forward if you've previously gone back.

GoHome Page (Alt+Home) (Browser mode)

Go to your home page as defined on the General page of the settings dialog.

GoHome Folder (Alt+Home) (File Manager mode)

Changes to the users home folder, e.g., /home/Peter/.

GoApplications (File Manager mode)

Open the folder holding your applications.

GoNetwork Folder (File Manager mode)

Network folders show up in a special location of Konqueror and Dolphin called a virtual folder. You can find more information on how to use this folder in the KNetAttach Handbook.

GoSettings (File Manager mode)

Open a virtual folder with all System Settings modules in Icons, Details or Columns view. Select an item to display the settings module in a separate dialog window.

GoTrash (File Manager mode)

Open your Trash folder.

GoAutostart (File Manager mode)

Open your Autostart folder.

GoShow History (Ctrl+Shift+H)

shows a tree view of your browsing history in a separate window. See Sidebar.

GoMost Often Visited

Displays a submenu showing the URLs you visit most often. Selecting one of these will make Konqueror open that URL.

GoRecently Visited

Displays a submenu showing the URLs you recently visited. Selecting one of these will make Konqueror open that URL.

GoClosed Items

Displays a submenu showing the closed URLs you visit. Selecting one of these will make Konqueror open that URL. Use Empty Closed Items History to clear the submenu.

The Bookmarks Menu

Note

See the section Using Bookmarks in this manual for a fuller description of these menu items.

BookmarksAdd Bookmark (Ctrl+B)

Add current selection to your bookmarks.

BookmarksBookmark Tabs as Folder...

Create a bookmark folder containing links to all of the URLs currently open in Konqueror tabs.

BookmarksNew Bookmark Folder...

Create a new folder in your Bookmarks folder.

BookmarksEdit Bookmarks...

Open the Bookmark Editor.

The Tools Menu

ToolsOpen Terminal (F4) (File Manager mode)

Open a Konsole terminal window.

ToolsFind File... (Ctrl+F) (File Manager mode)

Open the KFind application.

ToolsSelect Remote Charset (File Manager mode)

Offers to choose the charset used by a remote connection manually.

If you have Konqueror plugins installed there will be additional entries in the Tools menu. See the Konqueror Plugins chapter for further details.

The Settings Menu

Note

See also the section Saving Settings and Profiles.

SettingsToolbars Shown

Opens a submenu where you can choose to show or hide the various Toolbars.

SettingsShow Menubar (Ctrl+M)

Show/Hide the menubar.

SettingsShow Terminal Emulator

Open a small text terminal view at the bottom of the main window.

SettingsShow Sidebar (F9)

Toggles the display of the Konqueror sidebar. See Chapter 7, The Sidebar.

SettingsFull Screen Mode (Ctrl+Shift+F)

Changes Konqueror to full screen mode, in which the Konqueror window takes up the whole screen, and does not have the usual window decorations. To exit full screen mode, click on the Exit Full Screen Mode icon on the toolbar, or press Ctrl+Shift+F.

SettingsLoad View Profile

Load the settings associated with a particular view profile.

SettingsSave View Profile As...

Save the current settings to the current view profile.

SettingsConfigure View Profiles...

Lets you change an existing view profile or create a new one.

SettingsConfigure Extensions...

Opens a dialog with all installed plugins (e.g. from the KDE module extragear) and allows you to select the ones you need. All plugins are accessible in the Tools menu.

SettingsConfigure Spell Checking...

Displays the spell checking configuration dialog box, in which you can change settings associated with spell checking in Konqueror.

SettingsConfigure Shortcuts...

Lets you see and change Konqueror's shortcut key bindings, i.e. the associations between actions such as Copy and keys or combinations of keys such as Ctrl+V. If you do this take care not to duplicate an existing shortcut.

SettingsConfigure Toolbars...

Lets you configure the Main, Extra and Location Toolbars. See the section Changing Bars.

SettingsConfigure Konqueror...

Lets you configure Konqueror's behavior in file manager and browser mode.

The Window Menu

WindowSplit View Left/Right (Ctrl+Shift+L)

Split View Left/Right.

WindowSplit View Top/Bottom (Ctrl+Shift+T)

Split View Top/Bottom.

WindowClose Active View (Ctrl+Shift+W)

Remove Active View.

WindowNew Window (Ctrl+N)

Open another Konqueror window.

WindowDuplicate Window (Ctrl+Shift+D)

Open another Konqueror window, duplicating the current one.

WindowNew Tab (Ctrl+T)

Open a new, empty, tab page.

WindowDuplicate Current Tab (Ctrl+D)

Open a duplicate tab page.

WindowDetach Current Tab (Ctrl+Shift+B)

Show the current tab page in a new instance of Konqueror.

WindowClose Current Tab (Ctrl+W)

Close the current tab page.

WindowMove Tab Left (Ctrl+Shift+Left)

Move the current tab one place left in the list of tabs.

WindowMove Tab Right (Ctrl+Shift+Right)

Move the current tab one place right in the list of tabs.

The Help Menu

Apart from standard KDE Help menu items described in the section Help Menu of the KDE Fundamentals you will have the menu entry Konqueror Introduction to revisit the introductory pages that you got when Konqueror was first started.