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Abstract

Manage your disks, partitions and file systems.
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Chapter 1

Introduction

KDE Partition Manager is a utility program to help you manage the disk devices, partitions and
file systems on your computer.

It allows you to easily create new partitions, create file systems on new or existing partitions,
copy, move or delete partitions and also to modify a partition’s size without losing the data on it.

To get its job done efficiently KDE Partition Manager makes use of external tools to support a
long list of file systems. You will probably have the required tools for the file systems on your
computer installed already.

ALWAYS BACK UP YOUR DATA!
KDE Partition Manager has been designed and written with high diligence and an emphasis on data
integrity. There is however always some danger involved when modifying a device’s partition table or
its partitions: There might still be a bug in KDE Partition Manager, an unexpected power failure or a
problem with the computer’s hardware.
For those reasons you should always have a back up of your important data before making any modi-
fications with a tool like KDE Partition Manager.
The program’s authors take no responsibility whatsoever if you lose any data while using KDE Partition
Manager.

KDE Partition Manager uses operations, jobs and commands to logically divide up the work it
does. See the glossary for details on this.
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Chapter 2

Using KDE Partition Manager

2.1 The Main Window

Besides the main view showing the currently selected device in a graphical and a tree view,
KDE Partition Manager uses Qt™’s ‘dock widgets’ or panels to display some information and
allow selections. See the following screen shot for an overview of KDE Partition Manager’s main
window.

• Menubar: The menu bar presents some custom and some non-standard menus to choose ac-
tions to perform. All commands are described in detail in chapter 3.

• Toolbar: KDE Partition Manager’s tool bar is a standard tool bar. It can be fully customized;
for details see Section 3.1.6.

• Devices Panel: This panel lists all devices found on your computer that KDE Partition Manager
can handle. Select a device in this panel to view or modify it in the graphical device view or in
the tree device view.
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• Graphical Device View: In this view KDE Partition Manager shows a graphical representation
of the currently selected device. Each of the device’s partitions has its own box with device
node name (‘sda1’ for the first partition in the screenshot above) and usage information (the
dark violet area in the screenshot).
Extended partitions are visually distinct by their extra border (light green in the screenshot
above) around them.
You can select a partition by clicking on it in the graphical device view. A double click opens
the partition’s properties dialog. A right click shows the partition context menu.

• Tree Device View: The tree device view shows extended information about each partition on
the selected device. The currently selected partition is highlighted. Double-clicking a partition
opens the partition’s properties dialog. A right click shows the partition context menu.

• Information Panel: The information panel shows some details about the currently selected
device or partition. It is not enabled by default.

• Pending Operations Panel: This panel lists all operations that will be executed once you choose
Edit → Apply .
In the screenshot above, one operation is pending: If the user applies the operations now, the
file system on /dev/sdb3 will be checked for errors and, if required, repaired.

• Statusbar: The status bar shows how many operations are currently pending.

• Log Output Panel: This panel shows log information. It is only of secondary importance for
non-advanced users and is not enabled by default.

2.2 How-To: Resizing a Partition

This how-to explains the resizing of a partition that is becoming too full. See the following screen-
shot for the initial situation before resizing:

On device ‘/dev/sdb’, partition ‘sdb2’ has only little free space left while the other partition,
‘sdb1’, is far from being full. For that reason it seems advisable to make the first partition a little
smaller and grow ‘sdb2’ so it has more free space available.
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NOTE: YOU CANNOT MODIFY MOUNTED PARTITIONS.
In the screenshot above both partitions are not currently mounted. If one or both of them were mounted
you would have to unmount them first using Partition → Mount/Unmount .

The first step is to make more room for the partition to grow, so start by shrinking ‘sdb1’. Click
on the partition and choose Partition → Resize/Move (Ctrl+R) . The following dialog comes up:

The dialog allows you to resize the partition in multiple ways. You can either drag the right
handle to the left until the partition has the desired size or simply enter the size in the Size text
field. Another possibility would be to adjust the size by clicking on the little arrows next to the
text field, but that is a little tedious for larger changes.

Whichever way you prefer for setting the new size, the dialog should now look like this:
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After you click on OK, a new operation is added to the pending operations list and the graphical
view and tree view of the device are updated to reflect the new situation:

NOTE: OPERATIONS ARE PREVIEWED FIRST BEFORE APPLYING THEM.
Although the main window reflects the device’s state how it will be after applying the new operation,
the operation has in fact not been applied yet: While operations are pending you can still undo them
(one by one using Edit → Undo (Ctrl+Z) or Edit → Clear to undo all of them) or quit KDE Partition
Manager, and nothing will have been modified at all.

Now that there is some free space between the two partitions you can move and grow partition
‘sdb2’. First, click on ‘sdb2’ and choose Partition → Resize/Move (Ctrl+R) again. The resize
dialog comes up once more, this time for the second partition. Drag its left handle to the leftmost
end so that the dialog looks like this:

9



The KDE Partition Manager Handbook

Be careful to make sure that the Free space before text field really does show ‘0 MiB’ because
otherwise there will be a little free space left between the partitions that will then be wasted.

Now click OK again. In the main window things now look like this:

This already looks like what you wanted, so choose Edit → Apply . A dialog box will come up
and ask you if you are sure to apply the pending operations. Confirm this dialog box and KDE
Partition Manager will begin executing operations:
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While operations are being executed you can click on the plus-sign next to each operation in the
list to find out the jobs it is made up of and see which job is currently being run.

Resizing a partition in the way you resized ‘/dev/sdb2’ above always means it has to be moved
to the left first before it can be grown because partitions can never be grown to the left directly.
Unfortunately, moving such a large partition will take quite some time. It is not unusual for an
operation like this to take several minutes or even more.

Finally, all operations will have been successfully completed:

By clicking on OK you can now close the progress dialog and return to the main window. KDE
Partition Manager will rescan your devices at this point so that might take a few seconds.
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If you are interested in some more details about the operations that were just run click on Details.
You will see the detailed report that is always generated (and updated on the fly) while KDE
Partition Manager executes operations:

This report is particularly of interest if an error occurs while executing operations. A report
shows each operation, each job and each external command that is being run and is thus very
helpful when trying to track down problems.

You can save the report as HTML or view it in an external web browser.

TIP
Always save the detailed report as HTML when executing the operations fails with errors or warnings
for later reference. You might also want to include it in a bug report you submit to the KDE bug tracking
system at bugs.kde.org.

To hide the details again click on Details and to finally close the progress dialog click on OK.

2.3 How-To: Copying a Partition

This how-to describes copying a partition. We will assume the intention is to copy a partition
from one device to another and overwriting an existing target partition, but the general procedure
would not be much different when copying to the same device or to some unallocated area.

The following screenshot shows how the source device looks like:
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The source partition in our example will be ‘sdb1’ which is currently mounted, indicated by the
lock-icon next to the mount point name in the screen shot. A mounted partition can not be copied,
thus you first need to unmount it: Click on it then select Partition → Mount/Unmount .
After unmounting the partition the lock icon has gone and it is now possible to select Partition
→ Copy (Ctrl+C) . This puts ‘sdb1’ in KDE Partition Manager’s clipboard; in other words: ‘sdb1’
is now the partition that will be inserted when you select Partition → Paste (Ctrl+V) .
The destination device for copying in this how-to is ‘/dev/sdc’. Click on it in the Devices panel.
This is how the device looks like before copying:

The partition to overwrite is ‘sdc5’. To paste the copied partition into it, click on it and select
Partition → Paste (Ctrl+V) . You will see the operation to copy the partition has been added to
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the list of pending operations. Note that there is no dialog box required to insert the partition
as would be the case if you pasted into an unallocated area: Beginning and end of the pasted
partition are determined by the overwritten partition.

Now select Edit → Apply and the partition will be copied. See the how-to on resizing partitions
for details about applying operations.

2.4 How-To: Installing a New Operating System

This how-to describes the preparation of a new hard disk device for an OS installation: Suppose
you bought a new hard disk and now intend to use it as a replacement for the old one that
currently holds your OS and data partitions. You would also like to take this opportunity to
install a new operation system. Several steps will have to be taken to make the transition from
the old to the new system and drive.

In the following, ‘/dev/sdb’ is the old hard disk and ‘/dev/sdc’ is the new one. This screenshot
shows the situation on the source device:

The new device will look like this. Note that it doesn’t yet have valid partition table, thus the first
step to take is to create one by selecting Device → New Partition Table (Ctrl+Shift+N) :
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After confirming the warning dialog you can begin creating partitions on the new device by
clicking the extended partition and selecting Partition → New (Ctrl+N) . Begin with an extended
partition at the end of the device to later hold the home and swap partitions:

Click OK and the operation to create this extended partition is added to the list.

Now create a primary partition on the rest of the device where the new OS will be installed. Make
it as large as the unallocated area in front of the extended partition:
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Click OK in the dialog to accept your choice. The operation to create the new primary partition
is then added to the operation list.

Now it is time to copy the home partition from the old device to the extended partition on the
new device. Select the old device in the Device List panel, click on partition ‘sdb5’ and pick
Partition → Copy (Ctrl+C) .

Then go back to the new device and click the extended partition. Select Partition → Paste
(Ctrl+V) . The following dialog will come up:

This already looks mostly okay but you already know that you will not need that much free space
after the home partition because you will later create a swap partition there.
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So grab the right resize handle in the dialog’s resizer widget and move it to the right until the
free space after the pasted partition has a size more suitable for a swap partition:

This looks fine. Click OK to accept and close the dialog. A new operation to paste the copied
partition to the extended partition on ‘sdc’ is added to the operation list. Note that this operation
will also set the new size.
Finally you will want to create a new swap partition at the end of the extended partition on ‘sdc’.
There is no need to copy the existing swap partition from ‘sdb’ because swap does not hold any
permanent information worth keeping. Simply create a new partition with type linuxswap that
fills the whole of the unallocated area after the new home partition.

The main window with all operations and the preview of how ‘sdc’ will look like once they are
applied now looks like this:
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This looks great so select Edit →Apply , confirm the warning dialog and wait until the operations
have all been executed. For details on executing operations see the how-to on resizing partitions.

Your new hard disk device is now ready for the installation of your new operation system.
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Chapter 3

Command Reference

3.1 Overview

This chapter gives detailed explanations of all commands available in KDE Partition Manager. It
is intended as a reference to accompany the information given in chapter 2.

3.1.1 The File Menu

File → Quit (Ctrl+Q)
Quits KDE Partition Manager without applying any pending operations. The application
will however ask you to confirm your choice to quit if there are pending operations.

3.1.2 The Edit Menu

Edit → Undo (Ctrl+Z)
Undoes the last operation that has been added to the operation stack.
This command is only enabled if the list of operations is not empty.

Edit → Clear
Clears the list of operations without applying any of them.
This command is only enabled if the list of operations is not empty.

Edit → Apply

Applies the list of operations. This command will apply all operations in the list so that all
changes are permanently written to your disks. After the operations have been applied, the
list is cleared and there will be no way to undo any operation.
This command is only enabled if the list of operations is not empty.

3.1.3 The Device Menu

Device → Select Current Device
Allows you to select a device from a submenu with all available devices of the system.

19



The KDE Partition Manager Handbook

Device → New Partition Table (Ctrl+Shift+N)
Creates a new partition table: This command creates a new and empty GPT or MSDOS
partition table on the currently selected device. This will delete all partitions on the device
and all data on them, so you will want to be careful with this command.
This command is only enabled if a device is selected and no partition on this device is
currently mounted.

Device → Export Partition Table

Allows you to export a list of all partitions on the selected device into a file.

Device → Import Partition Table

Allows you to import partition table from a previously exported file.
This will delete all partitions on the device and all data on them, so you will want to be
careful with this command.
This command is only enabled if a device is selected and no partition on this device is
currently mounted. Importing into logical devices such as LVM Volume Groups is currently
not supported.

Device → SMART Status
Shows a SMART report. SMART is a monitoring system included in hard disk and solid-
state drives that detects and reports on various indicators of drive reliability, with the intent
of enabling the anticipation of hardware failures.

Device → Properties

Shows information about currently selected devices. In this dialog you can find capacity,
sector sizes, partition table type as well as used and maximum number of primary parti-
tions.

3.1.4 The Tools Menu

Tools → New Volume Group (Ctrl+Shift+L)

Create a new logical device such as LVM Volume Group.

Tools → File System Support

Shows the file system support dialog. This dialog shows in detail which operations can be
performed for which of the supported file systems.
Here is an example how the dialog might look like with most external tools installed:
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The blue check marks mean ‘supported’, the red crosses mean ‘not supported’. Some com-
binations are never supported, for example checking a linuxswap file system, because they
are inherently impossible. Others cannot be supported because the external tools lack the
functionality.
If you have installed new tools while KDE Partition Manager is running click on Rescan
Support to force a recheck of installed file system support tools.

Tools → Refresh Devices (F5)
Refreshes the devices: This command forces KDE Partition Manager to scan and read the
devices on your computer again. This may for example be useful if you plugged in an
external USB hard disk after you started KDE Partition Manager.

3.1.5 The Partition Menu

Partition → New (Ctrl+N)
Creates a new partition: Opens the dialog to create a new partition where you will be able
to set type, size, position and file system of the partition to create.
Please note that the partition table on a device may impose restrictions on how many par-
titions can be created. MS-DOS partition tables, for example, allow only four primary par-
titions.
This command is only enabled if an unallocated area on a device is selected.

Partition → Resize/Move (Ctrl+R)
Resizes or moves a partition: Opens the dialog to resize or move an existing partition.
Depending on the partition’s file system and the external tools installed on your computer,
not all three possible resize-related actions -- that is, moving the partition, making it smaller
(‘shrinking’ it) or making it larger (‘growing’ it) -- may be available in this dialog. See Tools
→ File System Support .
This command is only enabled if a partition is selected that is not currently mounted and
whose file system can be shrunk, grown or moved. For an extended partition, it is only
enabled if none of the logicals in the extended partition are mounted.
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Partition → Delete (Del)
Deletes a partition: This command deletes the currently selected partition.
This command is only enabled if a partition is selected that is not currently mounted. For
an extended partition, it is only enabled if it does not contain any logical partitions.

WARNING: POSSIBLE LOSS OF DATA
Deleting a partition means that all data on the partition is destroyed.

Partition → Shred (Ctrl+Del)
Shreds a partition: This command shreds the currently selected partition.
This command is only enabled if a partition is selected that is not currently mounted. For
an extended partition, it is only enabled if it does not contain any logical partitions.

WARNING: LOSS OF DATA
Shreding a partition means that all data on the partition is destroyed.

Partition → Copy (Ctrl+C)
Copies a partition: This command copies the currently selected partition to KDE Partition
Manager’s clipboard.
This command is only enabled if a partition is selected that is not currently mounted and
whose file system can be copied. Extended partitions can not be copied.

Partition → Paste (Ctrl+V)
Paste a partition: This command pastes the partition from KDE Partition Manager’s clip-
board to the currently selected partition or unallocated area.
When pasting to an unallocated area, a dialog will open allowing you to move or grow the
inserted copy. When overwriting an existing partition this dialog will not be shown.
This command is only enabled if a partition is currently in the clipboard and a valid target
(either a partition or an unallocated area) is selected. The target must also be large enough
to hold the source and can not be mounted. You can not copy a partition onto itself.

WARNING: POSSIBLE LOSS OF DATA
Pasting a partition on an existing one means that all data on the existing partition is destroyed
and replaced with the data from the pasted partition.

Partition → Mount/Unmount
Mounts or umounts a partition: This command mounts or unmounts the selected partition,
depending on its current state.
This command is only enabled if a partition is selected that can be mounted or unmounted.
If the operating system does not know a mount point for the partition you can not mount
it from KDE Partition Manager.

Partition → Edit Mount Point
Opens a dialog to edit the mount point and the mount options.
This command is only enabled if a partition unmounted.

Partition → Check
Checks a partition: This command checks the selected partition and its file system for errors
and tries to correct any problems it finds. During this process the file system on the partition
will also be resized to fill the partition completely.
This command is only enabled if a partition is selected that can be checked and is not cur-
rently mounted.
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Partition → Backup

Backs up a partition: This command backs up the file system on the selected partition to a
file. You will be asked where to store the image file after activating this command.
The created image file is a sector-for-sector copy of the file system on the partition. It is
not compressed and does not have any additional meta information or header added to it,
thus it can be directly mounted using a loop device outside of KDE Partition Manager if the
operation system supports that.
This command is only enabled if a partition is selected and the file system on it can be
backed up. The partition must also not be mounted.

Partition → Restore
Restores a partition: This command restores a file system from an image file to a partition.
You will be asked for the name of the image file to restore after activating this command.
The target to restore to must be large enough for the image file.
The command is only enabled if either an unallocated area is selected or a partition that is
not currently mounted.

WARNING: POSSIBLE LOSS OF DATA
Restoring a partition on an existing one means that all data on the existing partition is destroyed
and replaced with the data from the restored image file.

Partition → Properties

Shows a partition’s properties: This command shows a dialog with information about the
currently selected partition or unallocated space.
What is displayed and what can be modified in this dialog depends on the type of partition,
the type of the file system on the partition and on the partition being currently mounted or
not.
Not all file systems, for example, support setting a label. It is also generally not possible to
modify any properties if the partition is mounted.
This is a list of all partition and file system properties that can in general be modified in this
dialog:

• Set or modify a file system’s label
• Change the partition’s file system.

WARNING: POSSIBLE LOSS OF DATA
Changing the file system for a partition always means that all data on the partition is de-
stroyed.

• Recreate the file system on the partition

WARNING: POSSIBLE LOSS OF DATA
Recreating a file system on a partition always means that all data on the partition is destroyed.
Recreating a file system should only be used as a last resort if the file system on a partition
cannot be repaired anymore.

• Change a partition’s flags
Depending on the type of partition table used, there will be several flags available for
each partition on the partition table. In most cases, modifying the flags is not necessary
and should be considered an advanced feature.

The command is only enabled if either an unallocated area or a partition is selected.
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3.1.6 The Settings and Help Menu

KDE Partition Manager has the common KDE Settings and Help menu described in the KDE
Fundamentals with an additional submenu Panels Shown, where you can toggle the display of
the Devices, Pending Operations, Information and panels Log Output on and off.
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Chapter 4

Questions and Answers

1. How dangerous is KDE Partition Manager for my data?
First of all, you should never perform any destructive operations (delete, move, resize)
without first making a complete backup of everything affected.
Having said that, KDE Partition Manager is safe to use. It performs extensive checks before
and after every operation. It calls external tools written and supported by the file system
authors. And it has been tested extensively.
There is always the risk of data loss due to an unknown bug. KDE Partition Manager’s
authors try to minimize this risk, but there are of course no guarantees.

2. I have installed all recommended external file system support packages and still do not get support
for all operations on all file systems.
Not everything KDE Partition Manager can do in principle can be done with all file systems.
One example is performing a file system check on linuxswap: It is just not possible. There
are other limitations like that inherent in some file systems. You cannot shrink JFS or XFS
file systems because neither of the two supports shrinking at all, with or without KDE
Partition Manager.

3. Why can’t I see any meaningful progress information when resizing a partition?
KDE Partition Manager can only show progress information when it knows how long the
jobs in an operation will take. Unfortunately this is usually not the case when resizing parti-
tions because the by far longest job when doing so is resizing the file system on the partition.
Resizing file systems is in most cases something an external tool will do on behalf of KDE
Partition Manager and these external tools do not provide useful progress information to
KDE Partition Manager, so there’s nothing to report while they are running.

4. Why can’t I resize the root partition? How can I resize the partition /home is on?
To modify a partition it must not be mounted. You can however not unmount the root
partition. Neither will you be able to unmount the home partition if the home directory of
the currently logged in user is on it.
The solution for this problem is to boot from a Linux Live CD that comes with KDE Partition
Manager and modify these partitions from there.

5. I’m getting a warning message in the log output about something that a partition cannot be created
with the size I requested and that it will instead be smaller. What happened?
On MS-DOS partition tables, partitions have to begin and end on cylinder boundaries. This
is mainly for historical reasons. KDE Partition Manager will deal with this internally and
try not to bother the user with that limitation.
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Under rare circumstances, KDE Partition Manager will however not be able to set up an
operation in the way the user requested it due to this limitation. For example, if one cylinder
on a device is 8 MiB large and you try to resize a partition by 6 MiB, this will not work.
You might also encounter this message if you have a device and partition table where the
partitions are, for whatever reason, not correctly snapped to cylinder boundaries and you
try to move or copy these partitions for the first time.
The message itself is harmless and only exists to inform the user that something can not be
done quite exactly the way the user expects. Your partitions and data will not be negatively
affected in any way if you see this message.

6. How many operations can I add to the list of pending operations?
There is no limit.
It is however not recommended to add too many operations to the list. There is always a
small chance an operation might fail with an error, in which case KDE Partition Manager
will stop executing operations. In that case it is a lot easier to find out what happened (and
to re-add all the operations that could not be executed) if the list of pending operations was
not exceedingly long.

7. Resizing an ext2 or ext3 file system failed with something in the report about ‘no space left on device’.
What happened? Is my data corrupted now?
This is a problem of the e2resize command and the underlying ext2/3/4 file system. If a
file system is nearly full, e2resize cannot make it any smaller even though that should be
possible from the number of free sectors left. KDE Partition Manager can unfortunately not
know beforehand if e2resize will abort with this error for a given file system or not. If it
happens nothing will be done at all and your data will not be negatively affected.
There is no real workaround for this problem right now.

8. Why can’t I format my floppy disk with KDE Partition Manager? Why is there no support for CD
writing or DVD burning?
None of this is what KDE Partition Manager has been designed to do: It is an application
that deals with partitions and the file systems on these partitions. Floppy disks, CDs or
DVDs do not need or use partitions.

9. Why can’t I modify partitions on a device with an amiga or bsd partition table?
KDE Partition Manager currently only allows read-only access to any other partition table
type than MS-DOS. This is for safety reasons: Support in KDE Partition Manager for this
partition table types is not really there and what is there (or just incidentally works) has not
been tested enough to use it with confidence.
Of course you can still create a new MS-DOS partition table on the device in question, but
that is probably not what you want.

10. On startup, KDE Partition Manager hangs for a couple of minutes while it apparently tries to scan
the floppy drive on my computer.
This happens if you have a floppy drive configured in your computer’s BIOS settings but
have not actually connected one. If you do not have a floppy drive check your BIOS settings
and disable any floppy drives configured there to see if this makes the problem go away.

11. During startup, KDE Partition Manager prints some message about probing devices and that it
might even crash or at least take a long time.
LibParted, a backend library KDE Partition Manager uses, has problems with systems
where the Linux Device Mapper is used in a way it doesn’t understand. Unfortunately
it reacts to some of these situations with segmentation faults, i.e. crashes. KDE Partition
Manager therefore tries to avoid these situations by using an alternative way to scan your
computer for disks. If it cannot do that, however, and therefore has to rely on LibParted, it
will print a message like the one mentioned. If the scanning for disks works, you can safely
disregard the message.
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Chapter 5

Credits and License

KDE Partition Manager

Program copyright 2008, 2009, 2010 Volker Lanz vl@fidra.de

Documentation Copyright (c) 2008, 2009, 2010 Volker Lanz. vl@fidra.de

This documentation is licensed under the terms of the GNU Free Documentation License.
This program is licensed under the terms of the GNU General Public License.
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Chapter 6

Glossary

Command
In KDE Partition Manager commands are what jobs are made up of. These are very low
level steps being taken, often executed by an external tool, and only visible in the detailed
progress report.
The user normally does not have to bother with commands at all.
See Also "Operation". See Also "Job".

Cylinder

A unit used to divide up a device. Some operating systems and many disk tools require
partitions to begin and end on a cylinder. KDE Partition Manager therefore automatically
snaps partitions to cylinder boundaries when changing their start or end.
See Also "Head". See Also "Sector".

Cylinder Size

The number of sectors per cylinder on a device. Calculated as the number of heads multi-
plied by the number of sectors per track.

Device
A physical disk device. Physical disk devices are divided into logical sections called parti-
tions with the use of partition tables.

Disk Label
Another name for a partition table stemming from the SUN/BSD world.

NOTE
They are easy to mix up, but a disk label has nothing to do with a file system label.
See this Wikipedia entry for details on the name.

See Also "Partition Table".

Extended Partition
A partition that contains other partitions. Extended partitions can only be primary parti-
tions themselves. Whether extended partitions are available or not depends on the partition
table type used. MS-DOS partition tables allow one extended partition per device.
See Also "Primary Partition". See Also "Logical Partition".

28

http://en.wikipedia.org/wiki/BSD_disklabel


The KDE Partition Manager Handbook

File System

A file system defines how the storage of data (files with their metadata, folders and their
metadata, free space) is organized within a partition. There are various different types of
file systems, some coming originally from the Unix/Linux world, some not. Examples for
commonly used file systems on Unix/Linux are Btrfs, ext4 and XFS.

File System Label

A title of a file system. Some file systems (among them Btrfs, ext2/3/4, FAT16/32 and
NTFS) support setting a label for the file system so it can be identified in tools like KDE
Partition Manager or other applications.

NOTE
They are easy to mix up, but a file system label has nothing to do with a disk label.

Flag

See "Partition Flag".

GPT
A modern partition table format supported by most modern computers and operating sys-
tems. It supports more than 4 primary partitions unlike older MS-DOS partition table.

Head
A unit used to divide up a device.
See Also "Cylinder". See Also "Sector".

Job
In KDE Partition Manager a number of jobs is what operations are made up of. You nor-
mally do not have to bother with jobs at all; it only becomes apparent when applying the
list of pending operations: KDE Partition Manager will then show a progress dialog that
is made up of all operations and their jobs and show which operation and which job is
currently being executed.
See Also "Operation". See Also "Command".

Label
Either a disk label or a file system label.
See Also "Disk Label". See Also "File System Label".

Logical Partition

A partition inside an extended partition.
See Also "Primary Partition". See Also "Extended Partition".

LUKS
Linux Unified Key Setup is the standard encryption format for Linux.

LVM
LVM is a system for managing logical partitions that is more flexible than normal partitions.
It consists of three main components:

LVM physical volumes are partitions on the disk whose space is managed by LVM.
LVM volume group is a collection of LVM physical volumes that can be partitioned into logical
partitions. It might be used to create file systems spanning over multiple devices or to split
encrypted LUKS volume into smaller partitions.
LVM logical volumes are similar to normal partitions except that they reside on LVM volume
group. Also, the location of LVM logical partitions does not matter and they do not have to be
physically contiguous. Therefore, KDE Partition Manager does not allow to move LVM logical
volumes and displays the remaining free space at the end of the device.
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Operation

KDE Partition Manager divides the work it does up in operations, jobs and commands.
Operations are the most visible of the three. If you pick an action in the graphical user inter-
face, this will likely result in a new operation being added to the list of pending operations.
The idea behind that is: You will most probably want to set up quite a number of steps to
transform the current state of your disk devices to the state you have in mind. Some of these
steps may take quite a long time to execute (like copying a large file system or resizing a file
system that is nearly full). To save you from having to sit in front of your computer for a
long time waiting for one step to finish and then starting the next one, operations allow you
to exactly specify how the computer’s devices should look like once everything is finished,
then let KDE Partition Manager apply the operations and come back when it has executed
all of them.
Operations are kept in a list of pending operations. As long as an operation has not been
applied it can still be taken back easily and nothing will have been modified.
See Also "Job". See Also "Command".

Partition
A section of a hard disk device that can hold a file system or other partitions. Without at
least one valid partition, a disk can not be used.
See Also "Device". See Also "Partition Table". See Also "Primary Partition". See Also "Ex-
tended Partition". See Also "Logical Partition".

Partition Flag

A marker for a partition. The availability of these flags depends on the type of partition
table used.

Partition Table
A small section at the beginning of a device used to store information about the layout of
the device’s partitions. There are different types of partition tables, each with their own
limitations.
Sometimes also referred to as ‘disk label’.

Primary Partition

A partition directly inside a partition table, as opposed to logical partitions, which are in
extended partitions.
Partition tables usually impose restrictions on the maximum number of primary partitions
that can be created on a device. For MS-DOS type partition tables, for example, this maxi-
mum number is four.
See Also "Extended Partition". See Also "Logical Partition".

Sector
A unit used to divide up a device. Partitions must always begin and end on a sector.
See Also "Head". See Also "Cylinder".

Sector Size
The number of bytes per sector on a device. The sector size of most devices in use today is
512 bytes.
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