A barra de menus

No menu, você irá encontrar todas as ações do KTurtle. Elas estão nos seguintes grupos: Arquivo, Editar, Área de Desenho, Executar, Ferramentas, Configurações e Ajuda. Esta seção descreve todas elas.

O menu Arquivo

ArquivoNovo (Ctrl+N)

Cria um arquivo de TurtleScript novo e vazio.

ArquivoAbrir... (Ctrl+O)

Abre um arquivo do TurtleScript.

ArquivoAbrir recente

Abre um arquivo de TurtleScript que foi aberto recentemente.

ArquivoExemplos

Um exemplo dos programas do TurtleScript. Os exemplos estão em seu idioma favorito, que poderá ser escolhido em ConfiguraçõesLinguagem dos scripts.

ArquivoObter mais exemplos...

Abra o diálogo Obter novidades para baixar arquivos do TurtleScript adicionais da Internet.

ArquivoSalvar (Ctrl+S)

Salva o arquivo de TurtleScript atualmente aberto.

ArquivoSalvar como...

Salva o arquivo do TurtleScript aberto atualmente num local especificado.

ArquivoExportar para HTML...

Exporta o conteúdo atual do Editor como um arquivo em HTML que inclui as cores do realce.

ArquivoImprimir... (Ctrl+P)

Imprime o código atual no editor.

ArquivoSair (Ctrl+Q)

Sai do KTurtle.

O menu Editar

EditarDesfazer (Ctrl+Z)

Desfaz a última alteração no código. O KTurtle pode fazer desfazer de forma ilimitada.

EditarRefazer (Ctrl+Shift+Z)

Refaz uma alteração desfeita no código.

EditarRecortar (Ctrl+X)

Corta o texto selecionado do editor para a área de transferência.

EditarCopiar (Ctrl+C)

Copia o texto selecionado do editor para a área de transferência.

EditarColar (Ctrl+V)

Cola o texto na área de transferência no editor.

EditarSelecionar tudo (Ctrl+A)

Seleciona todo o texto do editor.

EditarProcurar... (Ctrl+F)

Com esta ação, você poderá procurar frases no código.

EditarProcurar próximo (F3)

Use isto para procurar a próxima ocorrência da frase que estava pesquisando.

EditarLocalizar anterior (Shift+F3)

Use isto para procurar a ocorrência anterior da frase que estava pesquisando.

EditarModo de edição (Ins)

Alterne entre o modo de 'inserir' e 'sobrescrever'.

O menu Área de Desenho

Área de DesenhoExportar para Imagem (PNG)...

Exporta o conteúdo atual da Área de Desenho como uma imagem rasterizada no formato PNG (Portable Network Graphics).

Área de DesenhoExportar para Desenho (SVG)...

Exporta o conteúdo atual da Área de Desenho como um desenho vetorial no formato SVG (Scalable Vector Graphics).

Área de DesenhoImprimir a Área de Desenho...

Imprime o conteúdo atual da Área de Desenho.

O menu Executar

ArquivoExecutar (F5)

Inicia a execução dos comandos no editor.

ExecutarPausa (F6)

Coloca a execução em pausa. Esta ação só fica ativa quando os comandos estiverem de fato sendo executados.

ExecutarInterromper (F7)

Interrompe a execução; esta ação só fica ativa quando os comandos estiverem de fato sendo executados.

ExecutarVelocidade da Execução

Apresenta uma lista com as velocidades de execução possíveis, consistindo em: velocidade máxima (sem realce e inspetor), velocidade máxima, velocidade baixa, velocidade mais baixa, velocidade mínima e passo-a-passo. Quando a velocidade de execução é igual velocidade máxima (padrão), você poderá não conseguir ver o que está acontecendo. Em alguns dos casos este comportamento poderá ser o desejado, mas em outros casos você poderá querer ter uma ideia da execução. No último caso, você poderá desejar configurar a velocidade da execução como velocidade baixa, velocidade mais baixa ou velocidade mínima. Quando um dos modos lentos for selecionado, a posição atual de execução será exibida no editor. O passo-a-passo irá executar um comando por vez.

O menu Ferramentas

FerramentasSeletor de direção...

Esta ação abre o diálogo do seletor de direção.

FerramentasSeletor de cores...

Esta ação abre o diálogo do seletor de cores.

O menu Configurações

ConfiguraçõesLinguagem de Programação

Escolhe a linguagem para o código.

ConfiguraçõesMostrar o Editor (Ctrl+E)

Mostra ou oculta o Editor.

ConfiguraçõesMostrar o Inspetor (Ctrl+I)

Mostra ou oculta o Inspetor.

ConfiguraçõesMostrar os Erros

Exiba ou esconda a aba Erro com a lista de erros resultantes do código em execução. Se esta opção estiver habilitada, clique na área de desenho para ver a tartaruga novamente.

ConfiguraçõesMostrar números de linha (F11)

Com esta ação, você poderá mostrar os números de linha no editor. Isto poderá ser útil para procurar um erro.

ConfiguraçõesMostrar a Barra de Ferramentas

Ativa ou desativa a barra de ferramentas principal

ConfiguraçõesMostrar a Barra de Estado

Alterna a barra de status

ConfiguraçõesConfigurar atalhos...

O diálogo padrão do KDE para configurar os atalhos.

ConfiguraçõesConfigurar barra de ferramentas...

A janela padrão do KDE para configurar as barras de ferramentas.

O menu Ajuda

AjudaManual do KTurtle (F1)

Invoca o sistema de ajuda do KDE, iniciando nas páginas de ajuda do KTurtle. (este documento)

AjudaO que é isto? (Shift+F1)

Muda o cursor do mouse para uma combinação de seta com um ponto de interrogação. Ao clicar nos itens do KTurtle uma janela de ajuda será aberta (se existir alguma para o item) explicando a função do item.

AjudaRelatar erro...

Abre o diálogo para relatar erros onde você pode comunicar um erro ou sugerir uma funcionalidade.

AjudaMudar o idioma do aplicativo...

Abre uma caixa de diálogo onde você pode escolher o Idioma primário e o Idioma secundário para este aplicativo.

AjudaSobre o KTurtle

Mostra a versão e as informações do autor.

AjudaSobre o KDE

Mostra a versão do KDE e outras informações básicas.

AjudaAjuda sobre: ... (F2)

Esta é uma função muito útil: ela oferece ajuda sobre o código sob o cursor na janela do editor. Por isso, por exemplo, você poderá ter usado o comando mostre no seu código e deseja ler e aprender o que o manual diz sobre este comando. Basta mover o seu cursor para cima do mostre e pressionar então F2. O manual irá então mostrar toda a informação sobre o comando mostre.

Esta função poderá ser útil enquanto aprende o TurtleScript.