La barre de menus

Dans la barre de menus, vous trouverez toutes les actions de KTurtle. Elles se trouvent dans les menus suivants : Fichier, Édition, Canevas, Exécuter, Outils, Configuration et Aide. Ce chapitre les décrit tous.

Le menu Fichier

FichierNouveau (Ctrl+N)

Crée un nouveau fichier TurtleScript vide.

FichierOuvrir... (Ctrl+O)

Ouvre un fichier TurtleScript.

FichierRécemment ouvert(s)

Ouvre un fichier TurtleScript qui a récemment été ouvert.

FichierExemples

Ouvre les programmes d'exemple de TurtleScript. Les exemples sont dans votre langue natale que vous pouvez choisir dans ConfigurationLangue du code.

FichierObtenir d'autres exemples...

Ouvre l'Installateur d'extensions pour télécharger d'autres fichiers TurtleScript depuis Internet.

FichierEnregistrer (Ctrl+S)

Enregistre le fichier TurtleScript actuellement ouvert.

FichierEnregistrer sous...

Enregistre le fichier TurtleScript actuellement ouvert vers un emplacement spécifique.

FichierExporter en HTML...

Exporte le contenu actuel de l'éditeur dans un fichier HTML, en y incluant la coloration syntaxique.

FichierImprimer... (Ctrl+P)

Imprime le code courant dans l'éditeur

FichierQuitter (Ctrl+Q)

Quitte KTurtle.

Le menu Édition

ÉditionAnnuler (Ctrl+Z)

Annule la dernière modification dans le code. KTurtle a un nombre de possibilités d'annulation infini !

ÉditionRefaire (Ctrl+Maj+Z)

Refait une modification annulée dans le code.

ÉditionCouper (Ctrl+X)

Coupe le texte sélectionné de l'éditeur dans le presse-papiers.

ÉditionCopier (Ctrl+C)

Copie le texte sélectionné depuis l'éditeur dans le presse-papiers.

ÉditionColler (Ctrl+V)

Colle le texte du presse-papiers dans l'éditeur.

ÉditionTout sélectionner (Ctrl+A)

Sélectionne tout le texte depuis l'éditeur.

ÉditionChercher... (Ctrl+F)

Grâce à cette action, vous pouvez trouver des mots dans le code.

ÉditionPoursuivre la recherche (F3)

Utiliser ceci pour trouver la prochaine occurrence du mot que vous cherchez.

ÉditionPoursuivre la recherche (Maj+F3)

Utiliser ceci pour trouver la prochaine occurrence de la phrase que vous cherchez.

ÉditionÉcraser / Insérer (Inser)

Bascule entre les modes « Insérer » et « Écraser ».

Le menu Canevas

CanevasExporter sous forme d'image (PNG)...

Exporte le contenu actuel du canevas comme image matricielle au format PNG (Portable Network Graphics).

CanevasExporter en dessin (SVG)...

Exporte le contenu actuel du canevas comme dessin vectoriel au format SVG (Scalable Vector Graphics).

CanevasImprimer le canevas

Imprime le contenu actuel du canevas.

Le menu Exécuter

ExécuterExécuter (F5)

Démarre l'exécution des commandes dans l'éditeur.

ExécuterPause (F6)

Suspend l'exécution. Cette action n'est disponible que lorsque les commandes s'exécutent.

ExécuterInterrompre (F7)

Arrête l'exécution. Cette action n'est disponible que lorsque les commandes s'exécutent.

ExécuterPleine vitesse

Présente une liste des vitesses d'exécution possibles : Pleine vitesse (pas de mise en évidence ni d'inspecteur), Pleine vitesse, Lente, Plus lente, La plus lente et Pas à pas. Lorsque la vitesse d'exécution est réglée sur Pleine vitesse (valeur par défaut), vous pouvez difficilement vous rendre compte de ce qu'il se passe. Ce comportement est parfois voulu, mais il arrive que vous souhaitiez suivre l'exécution du programme. Dans ce cas, utilisez une vitesse d'exécution Lente, Plus lente, La plus lente. Lorsqu'un des modes lents est choisi, la position actuelle dans le programme est affichée dans l'éditeur. Pas à pas exécutera une commande à la fois.

Le menu Outils

OutilsChoisir la direction...

Cette action ouvre une boîte de dialogue de choix de direction.

OutilsSélecteur de couleur...

Cette action ouvre une boîte de dialogue de choix de couleur.

Le menu Configuration

ConfigurationLangue du code

Choisit la langue pour le code.

ConfigurationAfficher l'éditeur (Ctrl+E)

Affiche ou masque l'éditeur.

ConfigurationAfficher l'inspecteur (Ctrl+I)

Affiche ou masque l'inspecteur.

ConfigurationAfficher les erreurs...

Affiche ou cache l'onglet Erreur avec la liste des erreurs qui provient du code en cours. Si cette option est activée, appuyez sur le Canevas pour afficher à nouveau la tortue.

ConfigurationAfficher les numéros de ligne (F11)

Cette action vous permet d'afficher les numéros de lignes dans l'éditeur. Ceci peut être très pratique pour trouver des erreurs.

ConfigurationAfficher la barre d'outils...

Affiche ou cache la barre d'outils

ConfigurationAfficher la barre d'état

Affiche ou cache la barre d'état

ConfigurationConfigurer les raccourcis clavier...

Affiche une boîte de dialogue standard de KDE pour configurer les raccourcis clavier.

ConfigurationConfigurer les barre d'outils...

La boîte de dialogue standard de KDE pour configurer les barre d'outils.

Le menu Aide

AideManuel utilisateur de KTurtle (F1)

Exécute le système d'aide de KDE en commençant par les pages d'aide de KTurtle (ce document).

AideQu'est-ce que c'est ? (Maj+F1)

Change le curseur de la souris en une combinaison flèche et point d'interrogation (?). Cliquer sur des éléments dans KTurtle ouvrira une fenêtre d'aide (s'il en existe une pour cet élément particulier), expliquant la fonction de l'élément en question.

AideRapport de bogue...

Ouvre une boîte de dialogue de rapport de bogue où vous pouvez signaler un bogue ou effectuer une requête de fonctionnalité sous la forme d'une liste de souhaits (« wishlist »).

AideÀ propos de KTurtle

Affiche des informations sur la version et sur l'auteur.

AideÀ propos de KDE

Affiche la version de KDE et d'autres informations de base.

AideAide sur : (F2)

C'est une fonctionnalité particulièrement utile. Elle vous fournit de l'aide sur le code qui se trouve sous le curseur dans l'éditeur. Ainsi, par exemple, vous avez utilisé la commande écris dans votre code, et vous voulez savoir ce que dit le manuel sur cette commande. Déplacez simplement le curseur sur la commande écris et appuyez sur F2. Le manuel affichera toutes les informations sur la commande écris.

Cette fonction peut être très utile lors de l'apprentissage de TurtleScript.