La barra de menús

En la barra de menús encontrará todas las funciones de KTurtle. Estas están agrupadas de la siguiente forma: Archivo, Editar, Lienzo, Ejecutar, Herramientas, Preferencias y Ayuda. Todas las funciones están descritas a continuación:

El menú Archivo

ArchivoNuevo (Ctrl+N)

Crea un nuevo archivo TurtleScript.

ArchivoAbrir... (Ctrl+O)

Abre un archivo TurtleScript.

ArchivoAbrir reciente

Abre un archivo TurtleScript utilizado recientemente.

ArchivoEjemplos

Abre ejemplos de programas TurtleScript. El idioma de estos ejemplos es el que haya seleccionado en PreferenciasIdioma del código.

ArchivoObtener más ejemplos...

Abre el diálogo para obtener novedades para descargar de Internet archivos de TurtleScript adicionales.

ArchivoGuardar (Ctrl+S)

Guarda el archivo TurtleScript que está abierto en ese momento.

ArchivoGuardar como...

Guarda el archivo TurtleScript que está abierto en ese momento en una ubicación específica.

ArchivoExportar a HTML...

Exporta el contenido del editor a un archivo HTML manteniendo los colores de resaltado.

ArchivoImprimir... (Ctrl+P)

Imprime el código que aparece en el editor.

ArchivoSalir (Ctrl+Q)

Sale de KTurtle.

El menú Editar

EditarDeshacer (Ctrl+Z)

Deshace el último cambio en el código. No hay límite en KTurtle para el número de veces que puede usarse esta función.

EditarRehacer (Ctrl+Mayúsculas+Z)

Rehace un cambio en el código que anteriormente ha sido deshecho.

EditarCortar (Ctrl+X)

Corta el texto seleccionado del editor al portapapeles.

EditarCopiar (Ctrl+C)

Copia el texto seleccionado del editor al portapapeles.

EditarPegar (Ctrl+V)

Pega el texto del portapapeles al editor.

EditarSeleccionar todo (Ctrl+A)

Selecciona todo el texto del editor.

EditarBuscar... (Ctrl+F)

Con esta función, puede buscar frases en el código.

EditarBuscar siguiente (F3)

Use esto para encontrar la próxima aparición de la frase que está buscando.

EditarBuscar anterior (Mayúsculas+F3)

Use esto para encontrar la aparición anterior de la frase que está buscando.

EditarModo de sobrescritura (Ins)

Cambia entre los modos «insertar» y «sobrescribir».

El menú Lienzo

LienzoExportar a imagen (PNG)...

Exporta el contenido actual del lienzo a una imagen rasterizada de tipo PNG (Portable Network Graphics).

LienzoExportar a dibujo (SVG)...

Exporta el contenido actual del lienzo a una imagen vectorial de tipo SVG (Scalable Vector Graphics).

LienzoImprimir lienzo...

Imprime el contenido actual del lienzo.

El menú Ejecutar

EjecutarEjecutar (F5)

Inicia la ejecución de las órdenes introducidas en el editor.

EjecutarPausar (F6)

Detiene momentáneamente la ejecución. Esta acción solo está disponible mientras se ejecutan las órdenes.

EjecutarInterrumpir (F7)

Detiene la ejecución. Esta acción solo está disponible mientras se ejecutan las órdenes.

EjecutarVelocidad de ejecución

Muestra una lista con las posibles velocidades de ejecución:Velocidad máxima (sin resaltado y sin inspector), Velocidad máxima, Moderada , Lenta, Muy lenta y Paso a paso. Cuando la velocidad de ejecución es Velocidad máxima (que es el valor predeterminado) apenas podremos ver lo que está ocurriendo. En ocasiones, esto es lo que se quiere, pero es posible que en otras se prefiera seguir con atención la ejecución. Es entonces cuando conviene cambiar la velocidad de ejecución a Moderada, Lenta o Muy lenta. Cuando se selecciona uno de estos modos, el punto actual de la ejecución se muestra en el editor. Con el modo Paso a paso las órdenes se ejecutan de una en una.

El menú Herramientas

HerramientasSelector de dirección...

Esta acción abre el diálogo de selección de dirección.

HerramientasSelector de color...

Esta acción abre el diálogo de selección de color.

El menú Preferencias

PreferenciasIdioma del código

Permite elegir el idioma del código.

PreferenciasMostrar editor (Ctrl+E)

Muestra u oculta el editor.

PreferenciasMostrar inspector (Ctrl+I)

Muestra u oculta el inspector.

PreferenciasMostrar errores

Muestra u oculta la pestaña Errores con una lista de los errores que se han producido al ejecutar el código. Si esta opción está activada, pulse sobre la pestaña Lienzo para volver a ver la tortuga.

PreferenciasMostrar números de línea (F11)

Con esta acción se muestran los números de línea en el editor. Esta función es muy útil para encontrar errores.

PreferenciasMostrar la barra de herramientas

Conmuta la barra de herramientas principal

PreferenciasMostrar barra de estado

Conmuta la barra de estado

PreferenciasConfigurar los accesos rápidos...

Diálogo estándar de KDE para configurar los accesos rápidos.

PreferenciasConfigurar las barras de herramientas...

Diálogo estándar de KDE para configurar las barras de herramientas.

El menú Ayuda

AyudaManual de KTurtle (F1)

Inicia el sistema de ayuda de KDE mostrando las páginas de ayuda sobre KTurtle (este documento).

Ayuda¿Qué es esto? (Mayúsculas+F1)

Modifica la forma del puntero transformándola en una combinación de flecha e interrogación. Al pulsar sobre los elementos que hay dentro de KTurtle se abrirá una ventana de ayuda (si existe para cada caso particular) con una descripción de la función de dichos elementos.

AyudaInformar de fallo...

Abre un cuadro de diálogo para informar de fallos donde puede notificar un fallo o solicitar una mejora o nueva propiedad deseable.

AyudaCambiar el idioma de la aplicación...

Abre un diálogo donde puede modificar el Idioma principal de esta aplicación y el Idioma al que recurrir en caso de que el principal no esté disponible.

AyudaAcerca de KTurtle

Muestra información sobre la versión de la aplicación y su autor.

AyudaAcerca de KDE

Muestra la versión de KDE y otra información básica.

AyudaAyuda sobre: ... (F2)

Esta es una función muy útil: proporciona ayuda acerca de la porción de código en el editor sobre el que se encuentra el cursor. Por ejemplo, ha usado la orden escribir en su código y quiere saber lo que el manual dice acerca de ella. Solo tiene que colocar el cursor sobre la orden escribir y pulsar F2. El manual mostrará toda la información acerca de la orden escribir.

Esta función le puede ser de gran ayuda a la hora de aprender el lenguaje de programación TurtleScript.