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Abstract

Kompare is a GUI front-end program that enables differences between source
files to be viewed and merged. Kompare can be used to compare differences
on files or the contents of folders. Kompare supports a variety of diff formats
and provide many options to customize the information level displayed.

This document describes Kompare version 3.5.1.
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Chapter 1

Introduction

When two or more people are working on a file and passing it back and forth
between one another, it becomes difficult to see what changes have been made
to a new version or copy of the file. Opening the new copy and the original,
side-by-side in the application used to create it is one solution but, laborious,
time consuming, and prone to error. This is where a program to show differ-
ences, diffs for short, is useful.
As would be expected, an appropriate name for such a program would be
"diff". As it happens, the program diff is installed on most Linux R©-based
systems and is used for exactly this purpose. Developers often use diff, as a
command line tool, to show differences between versions of a source code file.
However, the use of diff is not limited to showing differences in code source
files, it can be used on many text-based file types.

Using diff from the command line can be confusing, learning the diff command
syntax and deciphering the output can bewilder most people. This is where
Kompare comes into play. Providing a graphical front-end to the diff program,
the interface displays source and destination files side-by-side with all differ-
ences automatically highlighted. From this starting point, changes in one file
can be sequentially applied to the other file on a selective and controlled ba-
sis. Not all changes need to be applied and if you do apply a change it can
always be ’unapplied’. When all required changes have been applied they can
be saved and will display as normal in the original application used to create
the file.
In addition to displaying differences between a source and destination file,
Kompare can be used to create and view a special file called a ’diff’. This file
captures the differences between the two sources into a single file that can be
used to view and apply changes to any other copy of the file. For example, if
two people are editing a document. The first person wants to make changes
and send just the changes made to the second person. Normally, the first per-
son would send a complete copy of the modified document to the second per-
son, who would then have to compare the modified document side-by-side
with unmodified version. The process for this is much like what we have de-
scribed in the previous paragraphs. With Kompare the first person would first
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make a local copy of the file to be modified, then make changes and compare
the original and modified copy. Now using Kompare a diff file can be created
that captures only the changes made. This can be sent to the second person in
place of a whole file containing the changes.

Using Kompare the second person can view the diff file, compare it to the local
copy of the document and apply the changes made by the first person. So the
process can go on for many versions of the document, each person making
changes, creating diffs, distributing them and applying them. This process is
commonly called "patching", a term taken from the program named "patch"
which is another command line tool specifically designed for the purpose of
applying diff files.

It sometimes happens that people edit a file at the same time. In this situa-
tion it is likely that people will make changes in the document at exactly the
same line. This creates a problem because, without applied caution, people
could be overwriting each others work as they apply the diff files they receive.
Fortunately the developers of the diff and patch programs took this into con-
sideration and so these tools will not allow such changes to be applied without
manual intervention. When this state is reached, it is known as a "conflict".
Kompare will display conflicts so that you can manually resolve them, decid-
ing which changes should be applied to which file.

Kompare is also a great program for comparison of file changes on a folder
level. When used to compare folders Kompare recursively examines subfold-
ers and their file contents for differences. In this use case, each file where differ-
ences are found are automatically opened and listed by Kompare where easy
navigation between the various files is possible.
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Chapter 2

Using Kompare

2.1 Getting Started

This section provides instructions for starting Kompare and provides a quick
tour to the Kompare main interface.

2.1.1 Starting Kompare

A shortcut for starting Kompare can be found in the K menu in the Develop-
ment group Development→ Kompare.

When Kompare starts the first thing it does is display a dialog from which to
select the files you wish to compare. Special settings for the properties of the
diff and the appearance thereof can also be selected. In the file form select a
source and destination source to compare. This can be any two files, folders
or a URL and a file. Once the source and destination are selected click the
Compare button.

Once Kompare has discovered the differences it will display the main inter-
face. When comparing two files or a url and a file the process takes just a few
seconds. However, when comparing folders with many subfolders and files,
this process can take awhile.

For explanation of the options available from diff and appearance forms see
chapter 3.

2.1.2 The Main Interface

This section provides a quick tour of the main interface which is comprised of
the following areas:
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• Menus

• Toolbar

• Source and Destination Folders

• Source and Destination Files

• Source and Destination Line Changes

• Source and Destination Text View

• Statusbar

2.1.2.1 Menus

Kompare provides a menu driven interface. Explanation to the menu items
and their options is provided in chapter 4.

2.1.2.2 Toolbar

The Kompare toolbar provides shortcuts to the most frequently used diff and
merge operations. The toolbar orientation, text positioning, icon size proper-
ties and which shortcut icons are displayed can be customized from the toolbar
context menu accessed when right-clicking the toolbar with the mouse. The
toolbar context menu also enables the toolbar to be hidden. If the toolbar is
hidden and you wish to unhide it, select Settings→ Show Toolbar.

2.1.2.3 Source and Destination Folders

The source folder and destination folder panes display the folders in which
compared files reside. When many subfolders are included in the comparison,
then selecting a folder will display the first document in that folder where a
difference was found between the source and destination.

2.1.2.4 Source and Destination Files

The source and destination file pane displays files where a difference was found
for the currently selected source or destination folder. When a folder has mul-
tiple documents containing differences, all documents with a difference are
listed. The selected document is displayed.

2.1.2.5 Source and Destination Line Changes

The source and destination line changes pane summarizes the differences found
between the current source and destination documents. Selecting a record
within the pane highlights and selects the difference. This is a useful way to
navigate and inspect long documents with many differences.
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2.1.2.6 Source and Destination View

The source and destination view is the main workspace of Kompare. The con-
tents and highlighted differences of the currently selected source and destina-
tion file are displayed here with line numbers.

2.1.2.7 Text View

The Text View is not displayed by default. It can be opened by selecting Set-
tings→ Show Text View.

2.1.2.8 Statusbar

The status bar provides a summary of the current source and destination file
or folder under comparison. The status bar also reports the number of changes
found in the current document and counts the differences that have been ap-
plied. Furthermore, the status bar shows the overall number of documents
containing differences and the current document number selected from this
set. For example, a comparison run over two folders may return 1890 files
with differences. The currently selected document is number 18 of 1890.

2.2 Viewing Differences

2.2.1 Managing Screen Real-Estate

Kompare displays the source and destination file under using equal percentage
of the main interface view work area. This view area provides some features
that help optimize use of screen real-estate while viewing differences, includ-
ing:

Dual Scrollbars The most obvious feature is that scrollbars are provided both
on the right and bottom edges of the view area. Using the scrollbars it is
possible to move rapidly through the comparison.

Share Grip Handle The vertical space between the source and destination view
not only makes it possible to clearly see the start and end of lines in each
of the panes, but is also a grip handle that allows adjustment of percent-
age occupied between the source and destinate views that comprise the
view pane. To change pane size for one of the views, hover the mouse
pointer over the grip handle then hold down the mouse button and drag
left or right. Naturally, increasing the area of one pane will decrease the
area available to the opposite pane within the view panel area.
A second horizontal handle is available between the navigation panel
and the source and destination view.
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Docking The navigation panel can be undocked from the main interface by
clicking the undock button located top right of the panel. This opens it in
a window of its own, allowing you to move it across the screen. You can
even hide the navigation panel by clicking the hide button. To display a
hidden navigation bar again, click with the right mouse button into the
menubar and select Navigation from the context menu.

Statusbar Toggle The status bar of the view panel can be toggled on and off
by selecting Settings→ Show Statusbar.

2.2.2 Switching Source and Destination Views

Sometimes it can be useful to consider what the file to which differences where
to be applied as the source. For example, when comparing two modified ver-
sions of a file and discovering that the one file has many more modifications
that the other. The file with more changed would be better as the source, since
then fewer differences would need to be applied.

In this case select File→ Swap Source with Destination. This will switch the
files displayed in all Kompare panels.

2.2.3 Displaying Difference Statistics

For a quick overview of the differences, select File→ Show Statistics. This will
display the Diff Statistics dialog. The following information is provided:

Old file: The file name of what is usually the source file or file that is unmodi-
fied.

New file: The file name of what is usually the destination file or file that is
modified and to which differences will be applied.

Format: The diff format used to display the difference (see Section 3.2.2).

Number of hunks: The number of hunks found in the difference.
A hunk is a ‘chunk’ of lines that have been marked as different between
source and destination and may include context lines depending on the
diff format Lines of Context value (see Section 3.2.2).

Number of differences The actual number of differences found, not hunks. A
hunk can contain one or more differences when the line change range
and the context lines of any two or more changes overlap.

2.2.4 Navigating the Difference View

Kompare enables rapid navigation of differences on a file level and of multiple
difference files when comparing folder trees.
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2.2.4.1 Selecting a Difference

A difference can be selected using by:

• clicking a line in the Source and Destination Line Changes pane (top right of
the main window).

• clicking the highlighted difference in the View pane.

• traversing the listed differences in a comparison (see Section 2.2.4.2).

When a difference is selected it is considered to be ‘in focus’ and is displayed
in a brighter color that non-selected differences.

2.2.4.2 Traversing Differences

When a comparison finds many differences one of the best ways to approach
reviewing them is to traverse the differences in a logical order, usually from
top to bottom.

By default Kompare selects the first difference found in a comparison. By se-
lecting Difference→Next Difference (Ctrl+Down) the difference following the
current selection is brought into focus. To select the difference before the cur-
rent difference select Difference→ Previous Difference (Ctrl+Up).

In this way it is possible to traverse differences in an orderly manner, applying
and unapply differences upon review.

2.2.4.3 Switching Between Files

When a comparison is performed on folder level, many files may be found
with differences. A complete list of the files compared with difference found
is provided in the ‘Source and Destination Folders’, and ‘Source and Destina-
tion Files’ panes. However, Kompare displays differences between source and
destination one comparison at time.

To switch between documents in this scenario the following options are avail-
able:

• Select the ‘Source and Destination Folders’ pane to display file differences
found in the ‘Source and Destination Files’ pane, then select a file.

• Select Difference→ Previous File (Ctrl+PageUp) or Difference→ Next File
(Ctrl+PageDown) to display the previous or next difference file found in the
‘Source and Destination Files’ pane.
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2.3 Merging Differences

Kompare makes the task of applying and unapplying differences as simple as
point and click. Multiple apply and unapply operations can be performed on
a difference as all operations are performed in memory and not written to the
files on disk until the save operation is performed.

2.3.1 Applying a Difference

To apply a difference, click the highlighted difference region, then select Dif-
ference→Apply Difference (Space).

2.3.2 Unapplying a Difference

To unapply a difference, click the highlighted difference region previously ap-
plied, then select Difference→Unapply Difference (Backspace).

2.3.3 Applying All Differences

After reviewing differences between files and finding all acceptable it is possi-
ble apply them all with a single operation by selecting Difference→Apply All
(Ctrl+A).

2.3.4 Unapplying All Differences

To revert all differences that have been applied previously select Difference
→Unapply All (Ctrl+U).

2.3.5 Saving Changes

Once differences have been applied they can be saved by selecting File→ Save
or File→ Save All....
Applied differences are saved to both the source and destination file.

2.4 Working with Diff Files

Diff files contain only the changes made between files, or a set of files within
a folder system, and may or may not contain a number of context lines before
and after line changes. The sum of a line change and its context lines is known a
hunk. A diff file therefore may contain multiple hunks from one or more files.
When the context lines of two or more hunks overlap, they are considered a
single hunk. Diff files can be used to:
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• Apply the changes contained in the hunks to an original file.

• Apply the changes contained in the hunks to a file or set of original files
within a folder system.

• Modified before being applied to an original file or set of original files within
a folder system.

2.4.1 Creating a Diff

To create a diff file a comparison must be displayed in Kompare. Assuming
this is the case, then select File→ Save .diff. This will display the Diff Options
dialog (see Section 3.2 for more information on diff formats and options). After
configuring these options, click the Save button and save the diff to a file with
the extension .diff.

2.4.2 Displaying a Diff

It is possible to display the contents of a diff file within Kompare by opening
the diff file from File→Open Diff....

When viewing a diff file the hunks between the source and destination file are
shown, remember that only the hunks are shown, no unmodified lines will be
shown. In some cases a diff file is created with 0 lines of context. In this case
only the changed lines will be displayed.

When a diff file contains hunks from multiple files Kompare displays the hunks
from each file one at a time and you can switch between files as though they
were real files even though this information is only provided by the diff file
contents.

2.4.3 Applying Differences in a Diff File

When viewing differences in a diff file it is possible to apply difference as you
would when comparing source and destination files (see Section 2.3).

2.4.4 Blending a URL with a Diff

In cases where a diff file is provided it is possible to compare the hunks in the
diff against a file or folder. To do this select File→ Blend URL with Diff.... Then
input the File/Folder and Diff Output paths.

When viewing differences between a source file and a diff file it is possible to
apply difference as you would when comparing source and destination files
(see Section 2.3).
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Chapter 3

Configuring Preferences

Kompare enables users to set appearance preferences for difference format-
ting in the main interface and set behavioural properties of the diff program.
The Preferences dialog can be accessed by selecting Settings→Configure Kom-
pare....

To configure preferences for appearance select the View menu item (see Section
3.1).

To configure preferences for diff program properties select the Diff menu item
(see Section 3.2).

3.1 View Settings

The View menu found on the Preferences dialog displays the Appearance and
Fonts tabbed forms.

3.1.1 Appearance

The Appearance form provides controls to manage the Colors used to denote
difference in the main interface, behaviour of the Mouse Wheel when jogging
up and down and how Tabs to Spaces conversion is managed.
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COLOR GROUP

Removed color Lines that have been removed, do not exist, between source
and destination.

Changed color Lines that have been changed, modified, between source and
destination.

Added color Lines that have been added between source and destination.

Applied color Any of the above states where the difference has been applied
between source and destination.

MOUSE WHEEL

Number of lines The number of lines to jog the differences when turning the
mouse wheel forward or backward.

11
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TABS TO SPACES

Number of spaces to convert a tab character to Convert each tab character to
n space characters.

3.1.2 Fonts

Select the font family and size to display when displaying differences.

3.2 Diff Settings

The Diff menu found on the Preferences dialog displays the Diff, Format, Op-
tions and Exclude tabbed forms. These forms can be used to configure the
behavioural properties of the Diff program.

12
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3.2.1 Diff

The command used to run the diff program (default diff).

13
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3.2.2 Format

Adjust options for the Output Format and number of Lines of Context.

OUTPUT FORMAT

Context The context output format adds several lines of context around the
lines that differ.

Ed diff can produce commands that direct the ed text editor to change the
first file into the second file. Historically, this was the only output mode
suitable for automatically editing one file into another. With the advent
of patch this option is hardly ever used.

Normal The normal output format displays differing lines without any sur-
rounding lines of context.
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RCS The RCS output format is designed specifically for use by the Revision
Control System (RCS). Like Ed format, this format is rarely used since
the patch program was introduced.

Unified The unified output format is a variation on the context format. It is
considered better than context because the output is more compact than
that of context as it omits redundant context lines.

LINES OF CONTEXT

Number of context lines When performing a diff with context or unified out-
put format use this parameter to control the number of context lines in-
cluded.

3.2.3 Options

15
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The Options tab form allows configuration of the options supported by the diff
program.

GENERAL

Look for smaller changes Forces diff to display changes in case, punctuation,
space, etc. when checked.

Optimise for large files Switches diff to process files with high-speed when
checked.

Ignore changes in case Lower and Uppercase character changes are omitted
when this option is checked.

Ignore regexp Ignore lines matching a regular expression.

WHITESPACE

Expand tabs to spaces in output When checked diff outputs will converts tab
characters to the number of spaces defined in the Preferences dialog View
menu Tabs to Spaces option.

Ignore added or removed empty lines lines of zero length that differ between
source and destination are ignored when this option is checked.

Ignore changes in the amount of whitespace White space before, after and be-
tween lines may change depending on different editors. When this op-
tion is checked such changes are ignored.

Ignore all whitespace when checked white space differences are completely
ignored.

Ignore changes due to tab expansion when checked white space resulting from
tab characters is ignored.

3.2.4 Exclude

The Exclude form enables use of the filter options provided by the diff pro-
gram.
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FILE PATTERN TO EXCLUDE

File Pattern to Exclude Exclude files based on wild card filtering

FILE WITH FILENAMES TO EXCLUDE

File with Filenames to Exclude Define the filter based on the content of an ex-
ternally managed file.
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Chapter 4

Command Reference

4.1 The File Menu

File→Open Diff... (Ctrl+O) Displays the Open dialog.

File→ Compare Files... (Ctrl+C) Displays the Compare Files or Folders dia-
log.

File→ Blend URL with Diff... (Ctrl+B) Displays the Blend File/Folder with
diff Output dialog.

File→ Save (Ctrl+S) Writes applied differences to current source and or des-
tination file.

File→ Save All Writes applied differences to all source and or destination files.

File→ Save .diff... Displays the Diff Options dialog to define diff format and
options.

File→ Swap Source with Destination Changes source and destination.

File→ Show Statistics Displays the Display Statistics dialog.

File→Quit (Ctrl+Q) Exits Kompare.

4.2 The Difference Menu

Difference→Unapply All (Ctrl+U) Unapply all differences previously applied
between source and destination.

Difference→Unapply Difference (Backspace) Revert a selected difference pre-
viously applied.
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Difference→Apply Difference (Space) Apply a selected difference.

Difference→Apply All (Ctrl+A) Apply all differences between source and
destination.

Difference→ Previous File (Ctrl+PageUp) Make the previous difference, in
the list of differences, the current file in the view pane.

Difference→Next File (Ctrl+PageDown) Make the next difference, in the list
of differences, the current file in the view pane.

Difference→ Previous Difference (Ctrl+Up) Select the difference above the
currently selected difference.

Difference→Next Difference (Ctrl+Down) Select the difference below the cur-
rently selected difference.

4.3 The Settings Menu

Settings→ Show Toolbar Toggle the toolbar display ON/OFF.

Settings→ Show Statusbar Toggle the status bar display ON/OFF.

Settings→ Show Text View Display the Text View pane.

Settings→ Configure Shortcuts... Display the Configure Shortcuts dialog.

Settings→ Configure Toolbars... Display the Configure Toolbar.

Settings→ Configure Kompare... Display the Kompare Preference dialog.

4.4 The Help Menu

Help→Kompare Handbook (F1) Invokes the KDE Help system starting at
the Kompare help pages. (this document).

Help→What’s This? (Shift+F1) Changes the mouse cursor to a combination
arrow and question mark. Clicking on items within Kompare will open
a help window (if one exists for the particular item) explaining the item’s
function.

Help→ Report Bug... Opens the Bug report dialog where you can report a
bug or request a ‘wishlist’ feature.

Help→ Switch Application Language... Opens a dialog where you can edit
the Primary language and Fallback language for this application.

Help→About Kompare This will display version and author information.

Help→About KDE This displays the KDE version and other basic informa-
tion.
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Chapter 5

Credits and License

Kompare

Program copyright 2001-2004, John Firebaugh jfirebaugh@kde.org and Otto
Bruggemanotto.bruggeman@home.nl

Documentation Copyright (c) 2007 Sean Wheller sean@inwords.co.za

This documentation is licensed under the terms of the GNU Free Documenta-
tion License.
This program is licensed under the terms of the GNU General Public License.
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Appendix A

Installation

A.1 How to obtain Kompare

Kompare is part of the KDE project http://www.kde.org/ .

Kompare can be found in the kdesdk package on ftp://ftp.kde.org/pub/kde/
, the main FTP site of the KDE project.

A.2 Compilation and Installation

For detailed information on how to compile and install KDE applications see
Building KDE4 From Source

Since KDE uses cmake you should have no trouble compiling it. Should you
run into problems please report them to the KDE mailing lists.
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