Command Reference

The File Menu

FileOpen Sandbox...

Opens a sandbox in the main window. See the section called “The Main Screen, Viewing File Status and Updating”.

FileRecent Sandboxes

Opens one of the sandboxes that were in use recently.

FileInsert ChangeLog Entry...

Opens the ChangeLog editor, prepared such that you can add a new entry with the current date. See the section called “Committing Files”.

FileUpdate (Ctrl+U)

Runs 'cvs update' on selected files and changes the status and revision numbers in the listing accordingly. See the section called “The Main Screen, Viewing File Status and Updating”.

FileStatus (F5)

Runs 'cvs -n update' on selected files and changes the status and revision numbers in the listing accordingly. See the section called “The Main Screen, Viewing File Status and Updating”.

FileEdit

Opens the selected file in KDE's default editor for the selected file's type.

FileResolve...

Opens a dialog for the selected file which allows you to resolve merge conflicts in it. See the section called “Resolving Conflicts”.

FileCommit... (#)

Allows you to commit the selected files. See the section called “Committing Files”.

FileAdd to Repository... (Ins)

Allows you to add the selected files to the repository. See the section called “Adding Files”.

FileAdd Binary...

Allows you to add the selected files to the repository as binaries (cvs add-kb). See the section called “Adding Files”.

FileRemove from Repository... (Del)

Allows you to remove the selected files from the repository. See the section called “Removing Files”.

FileRevert

Discards any local changes you have made to the selected files and reverts to the version in the repository (Option -C to cvs update).

FileQuit (Ctrl+Q)

Quits Cervisia.

The View Menu

ViewStop (Escape)

Aborts any running subprocesses.

ViewBrowse Log... (Ctrl+L)

Shows the log browser of the selected file versions. See the section called “Browsing CVS Logs”.

ViewAnnotate... (Ctrl+A)

Shows an annotated view of the selected file, i.e. a view where you can for each line see which author modified it last. See the section called “Watching an Annotated View of a File”.

ViewDifference to Repository (BASE)... (Ctrl+D)

Shows the differences between the selected file in the sandbox and the revision you last updated (BASE). See the section called “Watching Differences Between Revisions”.

ViewDifference to Repository (HEAD)... (Ctrl+H)

Shows the differences between the selected file in the sandbox and the revision you last updated (HEAD). See the section called “Watching Differences Between Revisions”.

ViewLast Change...

Shows the differences between the revision of the selected file you last updated (BASE) and the revision before. See the section called “Watching Differences Between Revisions”.

ViewHistory...

Shows the CVS history as reported by the server. See the section called “Browsing the History”.

ViewHide All Files

Determines whether only folders are shown in the main tree view. See the section called “The Main Screen, Viewing File Status and Updating”.

ViewHide Unmodified Files

Determines whether unknown and up to date files are hidden in the main tree view. See the section called “The Main Screen, Viewing File Status and Updating”.

ViewHide Removed Files

Determines whether removed files are hidden in the main tree view. See the section called “The Main Screen, Viewing File Status and Updating”.

ViewHide Non-CVS Files

Determines whether files not in CVS are hidden in the main tree view. See the section called “The Main Screen, Viewing File Status and Updating”.

ViewHide Empty Folders

Determines whether folders without visible entries are hidden in the main tree view. See the section called “The Main Screen, Viewing File Status and Updating”.

ViewUnfold File Tree

Opens all branches in the file tree so that you can see all files and folders. See the section called “The Main Screen, Viewing File Status and Updating”.

ViewFold File Tree

Closes all branches in the file tree. See the section called “The Main Screen, Viewing File Status and Updating”.

The Advanced Menu

AdvancedTag/Branch...

Tags or branches the selected files. See the section called “Tagging and Branching”.

AdvancedDelete Tag...

Removes a given tag from the selected files. See the section called “Tagging and Branching”.

AdvancedUpdate to Tag/Date...

Brings the selected files to a given tag or date, making it sticky. See the section called “Updating to Tag, Branch or Date”.

AdvancedUpdate to HEAD...

Brings the selected files to the respective HEAD revision. See the section called “Updating to Tag, Branch or Date”.

AdvancedMerge...

Merges either a given branch or the modifications between two tags into the selected files. See the section called “Tagging and Branching”.

AdvancedAdd Watch...

Adds a watch for a set of events on the selected files. See the section called “Using Watches”.

AdvancedRemove Watch...

Removes a watch for a set of events from the selected files. See the section called “Using Watches”.

AdvancedShow Watchers

Lists the watchers of the selected files. See the section called “Using Watches”.

AdvancedEdit Files

Runs cvs edit on the selected files. See the section called “Using Watches”.

AdvancedUnedit Files

Runs cvs unedit on the selected files. See the section called “Using Watches”.

AdvancedShow Editors

Runs cvs editors on the selected files. See the section called “Using Watches”.

AdvancedLock Files

Locks the selected files. See the section called “Locking”.

AdvancedUnlock Files

Unlocks the selected files. See the section called “Locking”.

AdvancedCreate Patch Against Repository...

Creates a patch from the modifications in your sandbox. See the section called “Creating Patches”.

The Repository Menu

RepositoryCreate...

Opens a dialog which allows you to create a new local repository. See the section called “Accessing The Repository”.

RepositoryCheckout...

Opens a dialog which allows you to checkout a module from a repository. See the section called “Checkout a Module From the Repository”.

RepositoryImport...

Opens a dialog which allows you to import a package into the repository. See the section called “Importing a Module Into the Repository”.

RepositoryRepositories...

Configures a list of repositories you often use and how to access them. See the section called “Accessing The Repository”.

The Settings Menu

SettingsShow Toolbar

Determines whether the toolbar is displayed.

SettingsCreate Folders on Update

Determines whether updates create folders in the sandbox which were not there before (Option -d to cvs update).

SettingsPrune Empty Folders on Update

Determines whether updates remove empty folders in the sandbox. (Option -P to cvs update).

SettingsUpdate Recursively

Determines whether updates are recursive (Option -r to cvs update).

SettingsCommit & Remove Recursively

Determines whether commits and removes are recursive (Option -r to cvs add, cvs remove resp.).

SettingsDo cvs edit Automatically When Necessary

Determines whether cvs edit is executed automatically whenever you edit a file.

SettingsConfigure Shortcuts...

Opens a dialog for configuring shortcuts.

SettingsConfigure Toolbars...

Opens a dialog for configuring Cervisia's toolbars.

SettingsConfigure Cervisia...

Opens a dialog for customizing Cervisia.

The Help Menu

HelpCervisia Handbook (F1)

Invokes the KDE Help system starting at the Cervisia help pages. (this document).

HelpWhat's This? (Shift+F1)

Changes the mouse cursor to a combination arrow and question mark. Clicking on items within Cervisia will open a help window (if one exists for the particular item) explaining the item's function.

HelpReport Bug...

Opens the Bug report dialog where you can report a bug or request a wishlist feature.

HelpSwitch Application Language...

Opens a dialog where you can edit the Primary language and Fallback language for this application.

HelpAbout Cervisia

This will display version and author information.

HelpAbout KDE

This displays the KDE version and other basic information.

Apart from the standard KDE Help menu items described above you will have this additional menu entry:

HelpCVS Manual

Opens the CVS info pages in the KDE help system.